Save a document

You can save a document using its current name and location, or save a copy of the document using a different name or location. You can save a document in several formats, including Hypertext Markup Language (HTML), Extensible Markup Language (XML), and Portable Document Format (PDF).

When a document or a book has unsaved changes, an asterisk (*) appears in the Page Status area of the status bar.

An asterisk indicates unsaved changes.

do_asterisk_page_status.png

Save a document

1)Do one of the following:

To save changes in the current file, choose File > Save.

To save the file in a different folder or with a different filename, choose File > Save As.

2)If you choose the Save As command, or if the file has never been saved, specify the new file­name and location. If you want to save the file in a different format, choose the format from the pop-up menu.

3)Click Save. If you choose Text Only format, specify how to treat the text and tables in the docu­ment.

Save a book

1)Do one of the following:

To overwrite the current version on the disk, choose File > Save Book.

To save the file in a different folder or using a different name, choose File > Save Book As.

2)If you choose the Save Book As command, or if the file has never been saved, specify the new filename and location.

Save all open documents

Hold down Shift and choose File > Save All Open Files.

Return to the saved version of your document

Choose File > Revert To Saved and click OK.

File formats you can save in

You can use the Save As command to save a file in the following formats:

Document 2015

Saves the FrameMaker document or book as a document or book that you can open and edit in FrameMaker.

XML

Creates an XML document that can be used for data exchange and viewed on the World Wide Web.

View Only 2015

Produces a book or document that you can open but cannot edit. If you accidentally save a file in View Only format, you can make it editable by pressing Esc Shift+f l (lowercase L) k. Then you can save the document or book in Document or Book format.

Document 12.0

Saves the FrameMaker document or book as a document or book that you can open and edit in FrameMaker version 12.

note:    To save a FrameMaker 12 document as a FrameMaker 9.0 or prior version’s document, save the document as a MIF 7.0 document, open the MIF 7.0 document in FrameMaker 9.0 or prior, and Save the document in the desired format.

MIF 2015

Creates a text file containing FrameMaker 2015 statements that describe all text and graphics. To avoid overwriting your original document, save the MIF file under a different name. (For example, add a .mif extension to the name.) For information on MIF, see the MIF Reference­guide.

MIF 7.0

Creates a text file containing FrameMaker 7.0 statements that describe all text and graphics. To avoid overwriting your original document, save the MIF file under a different name. (For example, add a .mif extension to the name.) For information on MIF, see the online manual MIF Reference.

Text Only

Creates a text file without graphics or formatting information. To avoid overwriting your orig­inal document, save the text file under a different name. (For example, add a .text extension to the name.)

PDF

Creates a Portable Document Format (PDF) file that can be viewed in Adobe Acrobat® and other applications that support PDF files.

SGML

Creates an SGML file with the content, elements, and attributes from your document.

HTML

Creates an HTML document that can be viewed on the World Wide Web. For information on adjusting the mapping of paragraph and character tags to predefined HTML elements, see Set up and adjust HTML mappings.

note:   When you save a structured FrameMaker document as HTML, all attributes with the same name are mapped to the same value, even if the attributes have different values for different elements. To use different values for these attributes after exporting, use a text editor to edit the resulting file.

Microsoft RTF

Create files in Rich Text Format 1.6 (RTF), which is supported by many word processors and can be read by other applications. Most formatting is preserved as formats are usually converted to word-processing styles.

note:   You can use the Print command to save a PostScript®file.

Filename extensions for saved files

When you save a file for the first time in Windows, FrameMaker automatically adds these exten­sions: .fm for documents, .book for book files, and .mif for MIF files. With these extensions, the files are recognized as FrameMaker files by the Windows operating system.

If you don’t want these special extensions added to the filenames you assign, enclose the filenames in double quotation marks. Windows doesn’t recognize a file without one of these extensions as a FrameMaker file, but you can still open the file in FrameMaker.

If you assign an extension that’s registered by another application, such as .doc, the extension is not replaced by the FrameMaker extension and you can still open the file in FrameMaker.

Save documents in text-only format

Saving a document in text-only format creates a text file with the text encoding of your choice: ANSI (Windows), or ASCII. (On Japanese-language systems, you can also use JIS, Shift-JIS, or EUC. On other Asian-language systems, you can use encoding for the supported languages.) Only ordinary text—those in text frames and tables—is saved; graphics, text in graphic callouts, footnotes, and formatting information are not saved. Reformat line lengths and hyphenation as needed before saving the file.

If some characters are not available in the text encoding that you choose, those characters are replaced in the text file. For example, when you save a document in Text Only format using ANSI (Windows) or ASCII encoding, spaces (including thin, en, em, and numeric spaces) are converted to regular spaces.

1)Choose File > Save As.

2)Specify the filename and location, and choose Text Only format.

3)Click Save.

4)Do one of the following:

To break each line into a separate paragraph, click At The End Of Each Line. This option maintains a file’s original line breaks and blank lines. Use this option for a line-oriented file such as computer code.

To merge adjacent lines into paragraphs and insert a carriage return only at blank lines, click Only Between Paragraphs. Use this option for paragraph-oriented files, such as files containing document text.

5)If you want to save table text, select Include Text From Table Cells. Then do the following:

Specify the order in which you want the table cells saved (row by row or column by column).

Choose whether to separate cells with tabs or with carriage returns by choosing items from the pop-up menus.

6)If the text file will be used on a platform that uses a different text encoding, choose an appro­priate encoding from the Text Encoding pop-up menu, and then click Save.

Use Save As to export XML from unstructured documents

You can export both structured and unstructured files to XML. The mapping used to specify what element to create for each paragraph tag in the source FrameMaker file is defined on a reference page. The export function creates an XML file and a corresponding cascading style sheet (CSS), which can be used with the document.

1)Do one of the following:

Select File > Save As XML.

Select File > Save As and choose XML from the pop-up menu. Give the filename an extension of .xml.

2)Specify the file location.

3)Click Save.

Back up and save automatically

FrameMaker can back up and save your work automatically.

1)Choose Edit > Preferences.

2)In General preferences, do the following:

To create a backup file every time you save, select Automatic Backup On Save. This option creates a copy of the file before your latest changes are saved. If a backup file exists, the new backup file overwrites it. (The filenames of backup files contain .backup.)

To create an autosave file at regular intervals, select Automatic Save and enter an interval (in minutes) in the box. This causes a copy of the file to be saved periodically without your having to choose File > Save. (The filenames of autosave files contain .auto.) When you save manually or revert to the last saved version with the Revert To Saved command, the autosave file is deleted.

3)Click OK.


September 30, 2016

Legal Notices | Online Privacy Policy