Vorschau von Formularen und Formulare testen

Auf der Registerkarte „PDF-Vorschau“ können Sie einen Formularentwurf oder eine Vorlage mit Acrobat oder Adobe Reader als PDF-Formular anzeigen und testen.

Die Registerkarte „PDF-Vorschau“ wird nur angezeigt, wenn Acrobat oder Adobe Reader installiert wurde. Wenn Sie sowohl Acrobat als auch Adobe Reader installiert haben, wird Designer standardmäßig automatisch Acrobat öffnen, um die Formular-Vorschau anzuzeigen. Wenn Sie in Adobe Reader eine Vorschau des Formulars anzeigen möchten, müssen Sie das Programm starten, bevor Sie auf die Registerkarte „PDF-Vorschau“ klicken.

Wenn Sie die Einstellung „Datei“ > „Formulareigenschaften“ > „Standard“ > „Zielversion“ in eine bestimmte Version von Acrobat und Adobe Reader ändern, müssen Sie darauf achten, dass Sie die der angegebenen Zielversion entsprechende Acrobat-Version installiert haben. Andernfalls wird möglicherweise ein Fehler oder eine Warnmeldung ausgegeben, wenn Sie auf die Registerkarte „PDF-Vorschau“ klicken.

Für die Vorschau wird das dem gespeicherten Formular entsprechende Format verwendet. Wenn Sie mit der rechten Maustaste auf die Registerkarte „PDF-Vorschau“ klicken, sehen Sie, welcher Standarddateityp aktuell ausgewählt ist. Das Format eines nicht gespeicherten Formulars wird unter „Extras“ > „Optionen“ > „Dokumentoptionen“ festgelegt.

Wenn Sie ein interaktives oder druckbares Formular entwerfen, können Sie die Einstellung „Datei“ > „Formulareigenschaften“ > „Vorschau“ > „Vorschautyp“ ändern, um die PDF-Vorschau korrekt einzurichten.

Wenn Sie Formulare für eine Verwendung mit Forms entwerfen, kann derselbe Formularentwurf zur Wiedergabe von PDF- oder HTML-Formularen verwendet werden. Obwohl Sie eine Vorschau des Formularentwurfs auf der Registerkarte „PDF-Vorschau“ anzeigen können, wird das HTML-Formular möglicherweise nicht wie bei der Wiedergabe mit Forms dargestellt. Wenn Sie ein HTML-Formular erstellen, geben Sie das Formular mit Forms wieder und zeigen Sie eine Vorschau in einem Webbrowser an.

Anzeigen einer Vorschau und Testen von Formularen auf der Registerkarte „HTML-Vorschau“.

Zusätzlich zur Vorschau der Formulare als PDF können Sie das Format jetzt auch in HTML wiedergeben und die Formulare in Designer entwerfen. Die neue Registerkarte für HTML-Vorschau kann dazu verwendet werden, eine Vorschau des Formulars anzuzeigen, wie es in einem Browser erscheint. Weitere Informationen finden Sie unter Anzeigen eines XDP-Formulars als HTML-Vorschau.

Um eine HTML-Vorschau der Formulare anzuzeigen, geben Sie die Konfigurationsdetails des Formularservers an:
  1. Wählen Sie „Extras > Optionen“.

  2. Wählen Sie im Fenster „Optionen“ die Seite mit Serveroptionen und geben Sie folgende Informationen ein:
    • Server-URL: URL des AEM Forms-Servers.

    • HTTP-Portnummer: Portnummer, die der AEM Forms-Server nutzt. Der Standardwert ist 8080.

    • HTML-Vorschaukontext: Pfad des Profils, der für die Wiedergabe der XFA-Formulare verwendet wird. Der Standardwert ist lc/content/xfaforms/profiles/default.html. Das Standardprofil wird für die Vorschau des Formulars in Designer verwendet. Wenn Sie ein anderes benutzerdefiniertes Profil verwenden möchten, geben Sie den entsprechenden Pfad dieses benutzerdefinierten Profils an.

    • Forms Manager Context: Kontextpfad, an dem die Forms Manager-Benutzeroberfläche bereitgestellt wird. Der Standardwert ist lc/fm.

Hinweis: Stellen Sie sicher, dass AEM Forms über die Server-URL verfügbar ist, die oben konfiguriert wurde. Die HTML-Vorschau stellt eine Verbindung zum CRX-Server zur Generierung einer Vorschau her.

So können Sie Formulare auf der Registerkarte „PDF-Vorschau“ in der Vorschau anzeigen und testen

Auf der Registerkarte „PDF-Vorschau“ können Sie eine Vorschau des Formularentwurfs so anzeigen, wie er in Acrobat oder Adobe Reader dargestellt wird. Stellen Sie vor der Vorschau des Formularentwurfs sicher, dass Sie die entsprechenden Optionen für die Vorschau des jeweiligen Formulartyps im Dialogfeld „Formulareigenschaften“ festgelegt haben.

Zum Anzeigen des derzeit ausgewählten Standardvorschautyps klicken Sie mit der rechten Maustaste auf die Registerkarte „PDF-Vorschau“.

Drücken Sie die Tastenkombination ALT+F8, um die Acrobat- oder Adobe Reader-Werkzeugleiste auf der Registerkarte „PDF-Vorschau“ anzuzeigen.

Hinweis: Um die Vorschau eines Formulars auf der Registerkarte „PDF-Vorschau“ anzuzeigen, muss in Acrobat die Option „PDF in Browser anzeigen“ ausgewählt sein. Die installierte Version von Acrobat oder Adobe Reader muss der Version entsprechen, in der das Formular gespeichert wurde. Andernfalls wird beim Aktivieren der Registerkarte „PDF-Vorschau“ ein Fehler oder ein Warnhinweis ausgegeben.
  1. Sie können die Registerkarte „PDF-Vorschau“ auf eine der folgenden Arten anzeigen:

    • Wählen Sie „Ansicht“ > „PDF-Vorschau“.

    • Klicken Sie im Layout-Editor auf die Registerkarte „PDF-Vorschau“.

  2. Falls es sich um ein interaktives Formular handelt, können Sie durch Testen der Objekte im Formular sicherstellen, dass sie wie erwartet funktionieren.

  3. (Optional) Falls es sich um ein nicht interaktives Formular handelt, das mit Daten zusammengeführt wird, können Sie das Formular anhand einer Musterdatendatei testen, um sicherzustellen, dass die Felder ordnungsgemäß mit der Datenquelle verbunden sind.

Hinweis: Sie müssen die Funktionen für die Webdienste und die Datenbankverbindung mit Acrobat testen. Diese Funktionen erfordern ein PDF-Formular mit aktivierten Berechtigungen. Verwendungsrechte für ein PDF-Formular können jedoch nicht für die Vorschau in Designer festgelegt werden.

So legen Sie Vorschauoptionen für ein interaktives Formular fest

Wenn Sie eine Vorschau für ein interaktives Formular anzeigen möchten, müssen Sie die entsprechenden Optionen im Dialogfeld „Formulareigenschaften“ festlegen.

  1. Wählen Sie Datei > Formulareigenschaften.

  2. Klicken Sie auf die Registerkarte „Vorschau“ und wählen Sie in der Liste „Vorschautyp“ die Option „Interaktives Formular“ aus.

  3. (Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer von Ihnen erstellten Datenquelle testen möchten, geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.

  4. (Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer automatisch generierten Datenquelle testen möchten, klicken Sie auf „Vorschaudaten erstellen“. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um zu dem Speicherort zu gelangen, an dem Sie die Datei speichern möchten. Wenn das Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, geben Sie an, wie oft das jeweilige Teilformular oder der Teilformularsatz in der Datendatei wiederholt wird.

  5. Wählen Sie unter „Vorschau des Adobe XML-Formulars anzeigen als“ den Eintrag „Statisches PDF-Formular“ oder „Dynamisches XML-Formular“ aus und klicken Sie auf „OK“.

So legen Sie Vorschauoptionen für ein nicht interaktives Formular fest

Wenn Sie eine Vorschau für ein nicht interaktives Formular anzeigen möchten, müssen Sie die entsprechenden Optionen im Dialogfeld „Formulareigenschaften“ festlegen.

  1. Wählen Sie Datei > Formulareigenschaften.

  2. (Optional) Um das in der Vorschau angezeigte Formular so zu testen, als wäre es auf einer Seite des Papiers gedruckt, klicken Sie auf die Registerkarte „Vorschau“ und wählen Sie unter „Vorschautyp“ die Option „Druckbares Formular (einseitig)“ aus.

  3. (Optional) Um das in der Vorschau angezeigte Formular so zu testen, als wäre es auf beiden Seiten des Papiers gedruckt, klicken Sie auf die Registerkarte „Vorschau“ und wählen Sie unter „Vorschautyp“ die Option „Druckbares Formular (zweiseitig)“ aus.

    Hinweis: Wenn Sie „Formular zum Drucken“ auswählen, sind alle Objekte nicht interaktiv.
  4. (Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer Datenquelle testen möchten, geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.

  5. (Optional) Wenn Sie das in der Vorschau angezeigte Formular mit einer automatisch generierten Datenquelle testen möchten, klicken Sie auf „Vorschaudaten erstellen“. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um zu dem Speicherort zu gelangen, an dem Sie die Datei speichern möchten. Wenn das Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, geben Sie an, wie oft das jeweilige Teilformular oder der Teilformularsatz in der Datendatei wiederholt wird.

  6. Wählen Sie unter „Vorschau des Adobe XML-Formulars anzeigen als“ den Eintrag „Statisches PDF-Formular“ oder „Dynamisches XML-Formular“ aus und klicken Sie auf „OK“.

So zeigen Sie die Vorschau eines Formulars mit Musterdaten an

Sie können Ihr Formular in Designer mit Hilfe von Muster-XML-Daten testen und in der Vorschau anzeigen. Es wird empfohlen, das Formular häufig mit Musterdaten zu testen, um sicherzustellen, dass es richtig wiedergegeben wird.

Falls Ihnen keine Musterdaten vorliegen, können Sie sie von Designer erstellen lassen oder auch selbst erstellen. (Siehe So generieren Sie automatisch Musterdaten für die Vorschau eines Formulars und So erstellen Sie Musterdaten für die Vorschau eines Formulars.)

Durch Testen Ihres Formulars mit Hilfe von Musterdaten können Sie sicherstellen, dass die Daten und Felder zugeordnet werden und dass sich wiederholende Teilformulare erwartungsgemäß wiederholt werden. Sie können ein ausgeglichenes Formularlayout erstellen, das den jeweiligen Objekten genügend Platz zur Anzeige der zusammengeführten Daten bietet.

  1. Wählen Sie Datei > Formulareigenschaften.

  2. Klicken Sie auf die Registerkarte Vorschau und geben Sie im Feld „Datendatei“ den vollständigen Pfad zu einer Testdatendatei ein. Sie können auch auf die Schaltfläche „Durchsuchen“ klicken, um zur gewünschten Datei zu gelangen.

  3. Klicken Sie auf OK. Wenn Sie das nächste Mal eine Vorschau des Formulars auf der Registerkarte „PDF-Vorschau“ anzeigen, werden die Datenwerte der XML-Musterdatei in den entsprechenden Objekten dargestellt.

Detaillierte Informationen zu jeder Option im Register „Vorschau“ finden Sie in Vorschau (Dialogfeld „Formulareigenschaften“).

So generieren Sie automatisch Musterdaten für die Vorschau eines Formulars

Statt eine Musterdatendatei zu erstellen, können Sie Musterdaten generieren, um Ihr Formular in der Vorschau anzuzeigen und zu testen. Wenn Ihr Formular sich wiederholende Teilformulare oder Teilformularsätze enthält, können Sie bei der Formularvorschau außerdem angeben, wie oft die Daten wiederholt werden.

Designer generiert Musterdaten, die für die entsprechenden Objekte im Formular gültig sind, mit folgenden Ausnahmen:

  • Die Musterdaten werden nicht gemäß einem Überprüfungsskript generiert, das unter Umständen für ein Objekt festgelegt wurde.

  • Durch den minimalen und maximalen Zählerwert für ein Teilformular wird die Anzahl der sich wiederholenden Teilformulare eingeschränkt, die Sie für die generierte Musterdatendatei angeben.

  • Der Standardwert, den Sie für einen 2D-Barcode auswählen, wird in der generierten Musterdatendatei beibehalten.

Nachdem Sie die Musterdatendatei generiert haben, können Sie die Datei gegebenenfalls bearbeiten.

Legen Sie fest, welche Datendatei bei der Vorschau des Formulars verwendet werden soll. Wenn Sie das nächste Mal eine Vorschau des Formulars in Designer anzeigen, werden die Musterdaten in den entsprechenden Objekten dargestellt.

  1. Wählen Sie in Designer die Registerkarte „Datei“ > „Dateieigenschaften“ > „Vorschau“.

  2. (Optional) Um das in der Vorschau angezeigte Formular als interaktives Formular zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Interaktives Formular“ aus.

  3. (Optional) Um das in der Vorschau angezeigte Formular für den einseitigen Druck zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Druckbares Formular (einseitig)“ aus.

  4. (Optional) Um das in der Vorschau angezeigte Formular für den zweiseitigen Druck zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Druckbares Formular (zweiseitig)“ aus.

  5. Klicken Sie auf „Vorschaudaten erstellen“.

  6. Geben Sie im Dialogfeld „Vorschaudaten erstellen“ den vollständigen Pfad zur Testdatendatei ein, einschließlich eines Dateinamens. Sie können auf die Schaltfläche „Durchsuchen“ klicken, um im Feld „Datendatei“ zum Speicherort zu navigieren.

  7. Wählen Sie in der Liste „Wiederholungselemente“ die Zahl links neben einem Teilformular aus und geben Sie an, wie oft es in der Datendatei wiederholt wird.

  8. Klicken Sie auf „Erstellen“.

So erstellen Sie Musterdaten für die Vorschau eines Formulars

Wenn Sie keine von Designer automatisch erstellte Musterdatendatei verwenden möchten, können Sie eine solche Datei manuell erstellen.

  1. Speichern Sie den Formularentwurf als PDF-Datei.

  2. Öffnen Sie die PDF-Datei und geben Sie Werte in die zu testenden Felder ein.

  3. Wählen Sie in Acrobat „Erweitert“ > „Formulare“ > „Formulardaten exportieren“.

  4. Benennen Sie die Datei im Dialogfeld „Formulardaten exportieren“ und speichern Sie sie als XML-Datenpaket (*.xdp).

  5. Wählen Sie in Designer die Registerkarte „Datei“ > „Dateieigenschaften“ > „Vorschau“.

  6. (Optional) Um das in der Vorschau angezeigte Formular als interaktives Formular zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Interaktives Formular“ aus.

  7. (Optional) Um das in der Vorschau angezeigte Formular für den einseitigen Druck zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Druckbares Formular (einseitig)“ aus.

  8. (Optional) Um das in der Vorschau angezeigte Formular für den zweiseitigen Druck zu testen, wählen Sie in der Liste „Vorschautyp“ die Option „Druckbares Formular (zweiseitig)“ aus.

  9. Klicken Sie neben dem Feld „Datendatei“ auf die Ordnerschaltfläche und suchen Sie die XML-Datei.

  10. Wählen Sie die XML-Datei aus und klicken Sie auf „OK“.

Überlegungen zum Testen von Formularentwürfen mit Daten

Bei der Einrichtung von Formularen zur Unterstützung von zusammengeführten Daten müssen Sie die Anforderungen des Formulars für das Zusammenführen von Daten hinsichtlich der Eingabedaten analysieren. Der Formularentwurf sollte auf der Basis der Struktur der Eingabedaten erstellt werden.

Bei der Datenbindung wird versucht, alle neuen Formular-Nodes einer entsprechenden Daten-Node zuzuordnen. Wenn Sie explizite Bindungen verwenden, haben die im Formularentwurf definierten Ziele Vorrang vor impliziten Bindungen. Im Zusammenhang mit impliziten (normalen) Bindungen gelten folgende Regeln:

  • Die relative Reihenfolge von Datenwerten oder -gruppen mit demselben Namen ist von Bedeutung.

  • Die relative Reihenfolge von eindeutig benannten Datenwerten oder -gruppen ist nicht von Bedeutung.

  • Die Hierarchie der von Datenwerten oder -gruppen beschriebenen Struktur ist von Bedeutung.

Überprüfen Sie die Eingabedaten und erwägen Sie die Vorbereitung einer Musterdatendatei für Testzwecke. Sie können diese Musterdatendatei auch automatisch von Designer erstellen lassen.

Beispieldaten können verwendet werden, um das Verhalten eines Formulars zu ermitteln, und sollten nicht als Ersatz für eine gründliche Überprüfung betrachtet werden. Um die besten Ergebnisse zu erzielen, sollte der Formularentwurf mit systemgenerierten Daten getestet werden. Sie können die Beispieldaten wie in der folgenden Liste generieren, um zu ermitteln, ob das Layout, die Formatierung, der Inhalt und das Verhalten eines Formulars den Erwartungen entspricht:

  • Um zu überprüfen, ob die Datenformatierung (z. B. Schriftart, Schriftgröße und Absatzausrichtung) korrekt ist, generieren Sie Daten für jedes Feld im Formular. Mit den Daten kann auch jeder berechnete Feldwert überprüft werden.

  • Um zu prüfen, ob Feldobjekte ausreichend groß sind, um alle Datenwerte aufzunehmen, generieren Sie Daten, die die maximal zulässige Zeichenanzahl pro Feld erreichen.

  • Um den Vorgang der Einstellung von „Mehrfache Zeilen zulassen“ und „Passend erweitern“ zu überprüfen, generieren Sie mehrere Zeilen mit Daten.

  • Wenn Ihr Formularentwurf Teilformulare enthält, die sich wiederholen, generieren Sie sich wiederholende Datengruppen, um die Wiedergabe dieser Teilformulare in der von Ihnen erstellten Musterdatendatei zu testen. Wenn Sie eine automatisch generierte Musterdatendatei verwenden, können Sie festlegen, wie oft sich eine Datengruppe wiederholen soll.

  • Wenn Ihr Formularentwurf Überlaufkopfbereiche oder Überlauffußbereiche enthält, generieren Sie die Daten, die nötig sind, um jeden Überlaufkopf- oder -fußbereich und die Einstellungen für deren Auftreten zu testen. Sie sollten genügend sich wiederholende Datengruppen generieren, die über drei Seiten fließen. Hierdurch wird auch die Überprüfung der Seitennummerierung ermöglicht. Verwenden Sie Beispieldaten (fügen Sie jeweils eine sich wiederholende Datengruppe hinzu), um zu überprüfen, wie ein sich wiederholendes Teilformular aussieht, wenn es auf die nächste Seite fließt.

  • Um die Datenmustereinstellung für gebundene Daten zu testen, stellen Sie sicher, dass alle Datenwerte vom System im gleichen Format generiert werden, insbesondere wenn die Syntax der Quelldaten nicht den Designer-Standardeinstellungen entspricht.

  • Generieren Sie genügend Daten, um das Layout jeder Masterseite im wiedergegebenen Formular einzusetzen.

Wichtig: Achten Sie darauf, dass die Daten keine hexadezimalen Werte zwischen 0x00 und 0x20 enthalten. Ausnahmen sind Wagenrücklauf und horizontaler Tabulator. Bei diesen Werten handelt es sich um ungültige XML-Zeichen, die Forms nicht erkennt.

Musterdatendateien erstellen

Die folgenden Richtlinien helfen Ihnen bei der Erstellung einer einfachen Testdatei, die repräsentative Eingabedaten enthält:

  • Die Eingabedatendatei muss eine gültige XML-Datei sein. Beispielsweise könnte eine einfache Datei Elemente in diesem Format besitzen:

            <root_node> 
                <first_node>value</first_node> 
                <second_node>value</second_node> 
                ...  
                <last_node>value</last_node> 
            </root_node>
  • Vergleichen Sie den Fluss der Eingabedaten mit dem physischen Layout des Formulars. Wenn Sie die implizite Bindung verwenden, müssen die Namen der Datennodes mit den entsprechenden Containern und Feldern im Formular übereinstimmen und in der gleichen Reihenfolge wie die Ausfüllreihenfolge im Formular wiedergegeben werden.

  • Wenn die Eingabedatendatei über mehr Verschachtelungsniveaus verfügt als die Elemente in der Palette „Hierarchie“, müssen Datenbindungen für alle verschachtelten Objekte explizit auf der Registerkarte „Bindung“ in der Palette „Objekt“ eingestellt werden.

  • Suchen Sie in der Eingabedatendatei nach Daten, die wiederholt werden, jedoch nicht Bestandteil jedes Datensatzes sind. Diese Informationen können möglicherweise auf Masterseiten als Textbausteinobjekte oder in Teilformularen, die nur Daten für einmalige Datensätze wiederholen, gehandhabt werden.

So testen Sie die Barrierefreiheit

Sie sollten Ihre Formulare mit verschiedenen Hilfstechnologien testen, um sicherzustellen, dass sie für Benutzer verfügbar sind.

Laden Sie Demoversionen von Bildschirmlesehilfen herunter. Da Sie als Formularverfasser mit dem Formular sehr vertraut sind, ist es für Sie eventuell schwierig zu beurteilen, ob die von der Bildschirmlesehilfe gelesenen Informationen ausreichend und verständlich sind. Lassen Sie wenn möglich jemand anders das Formular auf diese Weise testen. Zum Testen schalten Sie den Bildschirm aus und verwenden Sie nur die Bildschirmlesehilfe zum Navigieren und Ausfüllen des Formulars.

Schauen Sie im Internet nach Demo-Versionen von Bildschirmvergrößerungs-Software.

Stellen Sie sicher, dass das Formular ausschließlich mit der Tastatur ausgefüllt werden kann, und berücksichtigen Sie folgende Punkte:

  • Gibt es Vorgänge, die nicht ausgeführt werden können?

  • Sind einige Vorgänge umständlich oder schwierig auszuführen?

  • Sind die Tastaturfunktionen gut dokumentiert?

  • Haben alle Steuerelemente und Menüeinträge unterstrichene Zugriffstasten?

Beachten Sie beim Ausfüllen des Formulars folgende Punkte:

  • Teile des Formulars, die unsichtbar, nicht erkennbar oder schwer verwendbar sind

  • Bereiche, die fortwährend in Schwarz mit weißem Hintergrund angezeigt werden

  • Formularobjekte, die zu groß, zu klein oder abgeschnitten sind