Aperçu et tests de formulaires

Le panneau Aperçu PDF permet de vérifier et de tester une conception de formulaire ou un modèle comme s’il s’agissait d’un formulaire PDF à l’aide d’Acrobat ou d’Adobe Reader.

Le panneau Aperçu PDF s’affiche uniquement si Acrobat ou Adobe Reader est installé. Par défaut, si les deux logiciels sont installés sur votre poste, Designer affiche automatiquement l’aperçu dans Acrobat. Pour prévisualiser le formulaire à l’aide d’Adobe Reader, vous devez lancer l’application avant de cliquer sur l’onglet Aperçu PDF.

Si vous choisissez Fichier > Propriétés du formulaire > Valeurs par défaut > Choisir la version cible en sélectionnant une version spécifique d’Acrobat et d’Adobe Reader, assurez-vous que la version d’Acrobat installée sur votre ordinateur correspond bien à la version cible enregistrée ; sans quoi vous risquez d’obtenir un message d’erreur ou d’avertissement lorsque vous activez l’onglet Aperçu PDF.

L’aperçu applique au fichier le format dans lequel il a été enregistré. Vous pouvez cliquer avec le bouton droit de la souris sur Aperçu PDF pour voir quelle option de type de fichier par défaut est actuellement sélectionnée. Pour indiquer le format d’un formulaire non enregistré, modifiez le paramètre disponible en passant par Outils > Options > Gestion du document.

Si vous concevez un formulaire interactif ou imprimable, vous pouvez configurer correctement l’aperçu PDF en modifiant le paramètre disponible dans le menu déroulant Fichier > Propriétés du formulaire > Aperçu >Type d’aperçu.

Si vous concevez des formulaires destinés à Forms, vous pouvez utiliser la même conception de formulaire pour générer des formulaires PDF ou HTML. Bien que vous puissiez prévisualiser la conception de formulaire dans le panneau Aperçu PDF, un formulaire HTML risque de ne pas avoir le même aspect que lorsqu’il est généré avec Forms. Si vous créez un formulaire HTML, il est préférable de le générer à l’aide de Forms et de l’afficher dans un navigateur Web.

Pour prévisualiser et tester les formulaires dans le panneau Aperçu HTML

En plus de prévisualiser le rendu PDF des formulaires, vous pouvez également prévisualiser le rendu au format HTML lors de la conception du formulaire dans Designer. L’onglet Aperçu HTML peut être utilisé pour prévisualiser le formulaire tel qu’il devrait apparaître dans un navigateur. Pour plus d’informations, voir Aperçu des formulaires XDP au format HTML.

Pour prévisualiser vos formulaires au format HTML, vous devez fournir les détails de la configuration de votre serveur de formulaires :
  1. Accédez à Outils > Options.

  2. Dans la fenêtre Options, sélectionnez la page Options de serveur et fournissez les détails suivants :
    • URL du serveur : URL du serveur AEM forms.

    • Numéro de port HTTP : numéro de port sur lequel le serveur AEM forms est en cours d’exécution. La valeur par défaut est 8080.

    • Contexte de l’aperçu HTML : chemin d’accès au profil à utiliser pour le rendu des formulaires XFA. La valeur par défaut est lc/content/xfaforms/profiles/default.html. Le profil par défaut est utilisé pour afficher l’aperçu du formulaire dans Designer. Pour utiliser un autre profil personnalisé, indiquez son chemin.

    • Contexte du gestionnaire de formulaires : chemin de contexte du déploiement de l’interface utilisateur de Forms Manager. La valeur par défaut est lc/fm.

Remarque : Vérifiez qu'AEM forms est disponible à partir de l’URL du serveur configurée ci-dessus. L’aperçu HTML se connecte au serveur CRX pour générer un aperçu.

Pour prévisualiser et tester les formulaires dans le panneau Aperçu PDF

Utilisez l’onglet Aperçu PDF pour prévisualiser la conception de formulaire telle qu’elle apparaît dans Acrobat ou Adobe Reader. Avant de demander un aperçu de la conception de formulaire, assurez-vous que vous avez choisi les options d’affichage appropriées en fonction du type de formulaire dans la boîte de dialogue Propriétés du formulaire.

Vous pouvez cliquer sur l’onglet Aperçu PDF avec le bouton droit de la souris pour voir quelle option de type d’aperçu par défaut est activée.

Pour afficher la barre d’outils Acrobat ou Adobe Reader sur l’onglet Aperçu PDF, appuyez sur ALT+F8.

Remarque : Pour afficher l’aperçu d’un formulaire dans l’onglet Aperçu PDF, assurez-vous que l’option Afficher PDF dans le navigateur d’Acrobat est sélectionnée. vérifiez que la version d’Acrobat ou Adobe Reader installée sur votre ordinateur correspond à la version cible enregistrée, sans quoi vous risquez de recevoir un message d’erreur ou d’avertissement en cliquant sur l’onglet Aperçu PDF.
  1. Choisissez l’un des modes d’affichage suivants dans le panneau PDF :

    • Choisissez Affichage > Aperçu PDF.

    • Dans l’éditeur de mise en page, cliquez sur l’onglet Aperçu PDF.

  2. Si le formulaire est interactif, testez les objets qui s’y trouvent pour vérifier s’ils se comportent comme prévu.

  3. (Facultatif) S’il s’agit d’un formulaire non interactif destiné à être fusionné avec des données, il peut être utile de le tester avec un échantillon de fichier de données pour s’assurer que tous les champs correspondent bien aux données source.

Remarque : Vous devez utiliser Acrobat pour tester les fonctions de services Web et de connectivité de base de données. Pour ce faire, vous avez besoin d’un formulaire PDF dont les droits ont été activés pour ces fonctions ; en revanche, vous ne pouvez pas définir de droits d’utilisation pour un formulaire PDF et afficher son aperçu dans Designer.

Pour définir les options d’aperçu d’un formulaire interactif

Pour afficher un aperçu d’un formulaire interactif, vous devez définir les options correspondantes dans la boîte de dialogue Propriétés du formulaire.

  1. Sélectionnez Fichier > Propriétés du formulaire.

  2. Cliquez sur l’onglet Aperçu et, dans la liste Type d’aperçu, sélectionnez Formulaire interactif.

  3. (Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l’aide d’une source de données, indiquez le chemin d’accès complet au fichier des données de test dans la zone appropriée. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu’au fichier.

  4. (Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l’aide d’une source de données générée automatiquement, cliquez sur Générer les données d’aperçu. Vous pouvez vous servir du bouton Parcourir pour accéder à l’emplacement où vous souhaitez enregistrer le fichier. Si le formulaire contient des sous-formulaires ou des jeux de sous-formulaires qui se répètent, indiquez le nombre de répétitions pour chaque sous-formulaire ou jeu de sous-formulaires dans le fichier de données.

  5. Dans la liste Mode d’aperçu du formulaire XML Adobe, sélectionnez Formulaire PDF statique ou Formulaire PDF dynamique.

Pour définir les options d’aperçu d’un formulaire non interactif

Pour afficher un aperçu d’un formulaire non interactif, vous devez définir les options correspondantes dans la boîte de dialogue Propriétés du formulaire.

  1. Sélectionnez Fichier > Propriétés du formulaire.

  2. (Facultatif) Pour tester le formulaire que vous prévisualisez comme s’il était imprimé sur un côté de la feuille, cliquez sur l’onglet Aperçu, puis dans la liste Type d’aperçu, sélectionnez Imprimer le formulaire (recto).

  3. (Facultatif) Pour tester le formulaire que vous prévisualisez comme s’il était imprimé sur les deux côtés de la feuille, cliquez sur l’onglet Aperçu, puis dans la liste Type d’aperçu, sélectionnez Imprimer le formulaire (recto verso).

    Remarque : lorsque vous sélectionnez Formulaire pour impression, les objets ne sont pas interactifs.
  4. (Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l’aide d’une source de données, indiquez le chemin d’accès complet au fichier des données de test dans la zone appropriée. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu’au fichier.

  5. (Facultatif) Pour tester le formulaire que vous êtes en train de prévisualiser à l’aide d’une source de données générée automatiquement, cliquez sur Générer les données d’aperçu. Vous pouvez vous servir du bouton Parcourir pour accéder à l’emplacement où vous souhaitez enregistrer le fichier. Si le formulaire contient des sous-formulaires ou des jeux de sous-formulaires qui se répètent, indiquez le nombre de répétitions pour chaque sous-formulaire ou jeu de sous-formulaires dans le fichier de données.

  6. Dans la liste Mode d’aperçu du formulaire XML Adobe, sélectionnez Formulaire PDF statique ou Formulaire PDF dynamique.

Pour prévisualiser un formulaire contenant des données d’exemple

Designer vous permet de prévisualiser et de tester un formulaire avec des données XML d’exemple. Il est recommandé de tester fréquemment le formulaire avec des données d’exemple pour vous assurer qu’il est généré correctement.

Si vous ne disposez pas de données d’exemple, Designer peut en fournir ou vous pouvez en créer vous-même (Voir Pour générer automatiquement des données d’exemple à utiliser dans l’aperçu d’un formulaire et Pour créer des données d’exemple à utiliser dans l’aperçu du formulaire.)

L’utilisation d’une source de données d’exemple pour tester votre formulaire est un bon moyen de s’assurer que les données et les champs correspondent et que les sous-formulaires se répètent comme prévu. Vous pouvez créer un formulaire à la disposition équilibrée, où chaque objet a la place nécessaire pour afficher les données fusionnées.

  1. Sélectionnez Fichier > Propriétés du formulaire.

  2. Cliquez sur l’onglet Aperçu et, dans la zone Fichier de données, indiquez le chemin d’accès complet au fichier de données de test. Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu’au fichier.

  3. Cliquez sur OK. La prochaine fois que vous prévisualiserez le formulaire dans le panneau Aperçu PDF, les valeurs des données provenant de l’échantillon de fichier XML figureront dans les objets correspondants.

Pour obtenir des informations détaillées sur chaque option dans Aperçu, reportez-vous à la section Aperçu (boîte de dialogue Propriétés du formulaire).

Pour générer automatiquement des données d’exemple à utiliser dans l’aperçu d’un formulaire

Il est possible de générer des données d’exemple afin de prévisualiser et de tester un formulaire au lieu de créer un fichier de données d’exemple. Si le formulaire contient des sous-formulaires ou des jeux de sous-formulaires qui se répètent, indiquez le nombre de répétitions voulu au moment de prévisualiser le formulaire.

Designer génère des données d’exemple valides pour les objets correspondants dans le formulaire, à quelques exceptions près :

  • Les données d’exemple ne sont pas générées en fonction des scripts de validation éventuellement prévus pour un objet.

  • La valeur d’occurrence minimale et maximale d’un sous-formulaire limite le nombre de sous-formulaires répétitifs que vous spécifiez pour le fichier de données d’exemple généré.

  • La valeur par défaut sélectionnée pour un code à barres 2D est conservée dans le fichier de données d’exemple généré.

Après avoir généré le fichier de données d’exemple, vous avez la possibilité de le modifier si nécessaire.

Spécifiez le fichier de données à utiliser lors de l’aperçu du formulaire. La prochaine fois que afficherez l’aperçu du formulaire dans Designer, les données d’exemple figureront dans les objets correspondants.

  1. Dans Designer, choisissez Fichier > Propriétés du formulaire > Option Aperçu.

  2. (Facultatif) Pour tester le formulaire en cours de prévisualisation sous forme interactive, sélectionnez Formulaire interactif dans la liste Type d’aperçu.

  3. (Facultatif) Pour tester le formulaire en cours de prévisualisation en mode d’impression recto, sélectionnez Imprimer le formulaire (recto) dans la liste Type d’aperçu.

  4. (Facultatif) Pour tester le formulaire en cours de prévisualisation en mode d’impression recto verso, sélectionnez Imprimer le formulaire (recto verso) dans la liste Type d’aperçu.

  5. Cliquez sur Générer les données d’aperçu.

  6. Dans la boîte de dialogue Générer les données d’aperçu, indiquez le chemin d’accès complet au fichier de données de test (y compris le nom du fichier). Vous pouvez également vous servir du bouton Parcourir pour naviguer jusqu’à l’emplacement dans la zone Fichier de données.

  7. Dans la liste Répétition des éléments, sélectionnez le nombre à gauche d’un sous-formulaire et tapez le nombre de fois où il se répète dans le fichier de données.

  8. Cliquez sur Générer.

Pour créer des données d’exemple à utiliser dans l’aperçu du formulaire

Si vous préférez ne pas utiliser un fichier de données d’exemples généré automatiquement par Designer, vous pouvez créer manuellement ce type de fichier.

  1. Enregistrez la conception de formulaire au format PDF.

  2. Ouvrez le fichier PDF, puis entrez des valeurs dans les champs que vous voulez tester.

  3. Dans Acrobat, choisissez Options avancées > Formulaires > Exporter les données d’un formulaire.

  4. Dans la boîte de dialogue Exporter les données du formulaire, nommez et enregistrez le fichier sous forme de paquets de données XML (*.xdp).

  5. Dans Designer, choisissez Fichier > Propriétés du formulaire > Option Aperçu.

  6. (Facultatif) Pour tester le formulaire en cours de prévisualisation sous forme interactive, sélectionnez Formulaire interactif dans la liste Type d’aperçu.

  7. (Facultatif) Pour tester le formulaire en cours de prévisualisation en mode d’impression recto, sélectionnez Imprimer le formulaire (recto) dans la liste Type d’aperçu.

  8. (Facultatif) Pour tester le formulaire en cours de prévisualisation en mode d’impression recto verso, sélectionnez Imprimer le formulaire (recto verso) dans la liste Type d’aperçu.

  9. Cliquez sur le bouton de dossier situé en regard de la zone Fichier de données, puis naviguez jusqu’au fichier XML voulu.

  10. Sélectionnez le fichier XML et cliquez sur OK.

Points à prendre en compte lors du test de conceptions de formulaire avec des données

Lorsque vous configurez des formulaires pour prendre en charge des données fusionnées, analysez les exigences relatives à la fusion des données du formulaire par rapport aux données d’entrée. Vous devez concevoir le formulaire d’après la structure des données d’entrée.

La liaison de données tâche de faire correspondre chaque nouveau nœud de formulaire avec un nœud de données. Lorsque vous utilisez des liaisons explicites, les cibles définies dans la conception de formulaire ont la priorité sur les liaisons implicites. Lorsque vous utilisez des liaisons implicites (normales), les règles suivantes s’appliquent :

  • L’ordre relatif des valeurs ou groupes de données du même nom est important.

  • L’ordre relatif des valeurs ou groupes de données portant un nom unique n’est pas important.

  • La hiérarchie de structure décrite par les valeurs ou groupes de données est importante.

Examinez les données d’entrée et préparez un fichier de données d’exemple, ou demandez à Designer de générer automatiquement ce fichier à des fins de test.

Vous pouvez utiliser des données d’exemple pour vérifier le comportement d’un formulaire, mais il demeure important de faire des tests approfondis. Pour optimiser les résultats, testez la conception de formulaire avec les données générées par le système. Vous pouvez générer les données d’exemple comme suggéré dans la liste suivante afin de déterminer si la disposition, le formatage, le contenu et le comportement d’un formulaire répondent aux exigences :

  • Pour vérifier si le formatage des données (par exemple, le type de police, la taille de la police et l’alignement des paragraphes) est correct, générez des données pour chaque champ du formulaire. Les données vous permettront également de vérifier toutes les valeurs des champs calculés.

  • Pour vérifier si la taille des objets de champ est suffisante pour accueillir toutes les valeurs des données, générez des données permettant d’atteindre le nombre maximum de caractères autorisé par champ.

  • Pour vérifier le fonctionnement des options de lignes multiples et de zones agrandissables automatiquement, générez plusieurs lignes de données.

  • Si votre conception de formulaire comporte des sous-formulaires qui se répètent, générez des groupes de données répétitifs pour tester l’affichage de ces sous-formulaires dans le fichier de données d’exemple que vous créez. Si vous utilisez un fichier de données d’exemple généré automatiquement, vous pouvez spécifier le nombre de répétitions du groupe de données.

  • Si la conception de formulaire comporte des débuts/fins de débordement, générez les données requises pour tester chaque début ou fin de débordement et les paramètres d’occurrence associés. Vous devez générer suffisamment de groupes de données qui se répètent afin qu’ils débordent sur trois pages, ce qui vous permettra également de vérifier la numérotation des pages. Utilisez les données d’exemple (ajoutez les groupes de données qui se répètent un par un) pour vérifier l’aspect d’un sous-formulaire qui se répète lorsqu’il s’étend sur une nouvelle page.

  • Pour tester le paramètre de modèle de données s’appliquant aux données liées, assurez-vous que toutes les valeurs de données suivent le même format généré par le système, en particulier si la syntaxe des données source ne correspond pas aux valeurs par défaut de Designer.

  • Générez suffisamment de données pour utiliser la disposition de chaque gabarit du formulaire résultant.

Important : Assurez-vous que les données du formulaire ne contiennent pas de valeurs hexadécimales comprises entre 0x00 et 0x20, à l’exception du retour chariot et de la tabulation horizontale. Ces valeurs ne sont pas des caractères XML corrects reconnus par Forms

Création d’un fichier de données d’exemple

Les consignes suivantes visent à faciliter la création d’un fichier test simple qui comporte des données d’entrée représentatives :

  • Le fichier des données d’entrée doit être un fichier XML valide. Par exemple, un fichier plat comporte des éléments au format suivant :

            <root_node> 
                <first_node>value</first_node> 
                <second_node>value</second_node> 
                ...  
                <last_node>value</last_node> 
            </root_node>
  • Comparez le flux des données d’entrée à la disposition du formulaire. Si vous utilisez une liaison implicite, les noms des nœuds de données doivent correspondre aux champs et aux conteneurs correspondants du formulaire et suivre l’ordre de remplissage du formulaire.

  • Si le fichier des données d’entrée comprend davantage de niveaux d’imbrication que les éléments de la palette Hiérarchie, vous devez définir les liaisons de données de tous les objets imbriqués de manière explicite via le panneau Liaison de la palette Objet.

  • Dans le fichier des données d’entrée, recherchez les données qui sont répétées, mais qui ne figurent pas dans tous les enregistrements. Ces données pourraient peut-être être traitées en tant qu’objets standard dans les gabarits ou dans des sous-formulaires qui répètent les données pour des enregistrements spécifiques.

Test d’accessibilité

Il est recommandé de tester les formulaires avec divers dispositifs d’assistance afin d’en garantir l’accessibilité.

Téléchargez des versions de démonstration de logiciels de lecteur d’écran. En tant que concepteur du formulaire, votre grande connaissance de ce dernier peut faire en sorte qu’il vous soit difficile de déterminer si l’information lue par le lecteur d’écran est suffisante et compréhensible. Par conséquent, si cela est possible, demandez à quelqu’un d’autre de tester votre formulaire de cette façon. Pour tester les résultats des lecteurs d’écran, éteignez votre moniteur et remplissez un formulaire en ne vous servant que du lecteur d’écran.

Recherchez sur Internet des versions de démonstration de logiciels de grossissement d’écran.

Assurez-vous de pouvoir remplir le formulaire en vous servant seulement du clavier et gardez à l’esprit les points suivants :

  • Existe-t-il des opérations qui ne peuvent pas être effectuées ?

  • Existe-t-il des opérations qui semblent bizarres ou difficiles à effectuer ?

  • Est-ce que les séquences de touches sont bien documentées ?

  • Est-ce qu’un raccourci clavier a été défini pour chacune des commandes et des touches ?

Lorsque vous remplissez le formulaire, gardez à l’esprit les éléments suivants :

  • Toute partie du formulaire devenant invisible, impossible à reconnaître ou difficile à utiliser

  • Zones s’affichant en noir sur un fond blanc

  • Objets du formulaire mal dimensionnés ou tronqués