Test with BugHunter for HTML Help

note:   Microsoft HTML Help projects only.

BugHunter is a troubleshooting tool to test context-sensitive Help topics and diagnose problems. During testing, BugHunter captures and displays calls that the application makes.

note:    Before you start using BugHunter, you must launch Html Help Workshop once. To launch Html Help Workshop, double-click the hhw.exe file in the Html Help Workshop install folder.

Use BugHunter for the following tasks:

Test Help buttons, F1 Help, or What's This? Help.

Track the causes of errors.

Copy data to the clipboard or annotate it and save it in a text file.

Discover why the wrong topic appears.

Determine if a particular map number is used.

Determine if a window-level Help topic has a map ID assigned.

Start and close BugHunter

1)Select Project > Open > Pods > Tools.

2)Do one of the following:

To start capturing data, choose Tools > Enable BugHunter.

The output dialog box displays capture data while the program is enabled. When you activate Help in an application's dialog box, messages from BugHunter appear in the output window. Right-click in the pane to copy, annotate, or save the data.

To clear the pane, right-click inside it and select Clear All. Data remains in the pane until you clear it.

To stop capturing data, choose Tools > Enable BugHunter.

Interpret BugHunter data

BugHunter data resembles this example:

C:\APPLICATION FOLDER\HELP_FILE.CHM, Custom Folder\Help_Topic_Name.htm, HH_HELP_CONTEXT, 10253, Topic launched

Multiple lines of data resemble this example:

Project: C:\APP FOLDER\HELP_FILE.CHM
File: Custom Folder\Help _Topic_Name.htm
Command: HH_HELP_CONTEXT
Map Number: 10253
Result: Topic launched

Interpret the data as follows:

Project

Application location. Filename of the HTML Help that contains the called Help topic.

File

Folder and subfolders where the .htm topic exists.

Command

The command name sent to HTML Help.

10253

Map number.

Result

Activity summary. “Topic launched” indicates that the topic map ID matches the application code.

Customize the BugHunter pane

1)Right-click inside the BugHunter pane and click Options.

View map numbers in hex format

1)Select File > Options. Click the BugHunter tab.

2)In Display options, select Map Numbers In Hex.


September 30, 2016

Legal Notices | Online Privacy Policy