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About StreamOUT
The StreamServer can produce record-based output, and send this output to some
kind of destination. The contents and structure of the record based output are
configured using the StreamOUT tool.
Output configuration
When you create a StreamOUT configuration, you define a structure of records
with fields for recurring and non-recurring data. See Configuring record based
output on page 7.
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Configuring record based output
You use the StreamOUT tool to configure the contents and structure of record
based output from the StreamServer. With the StreamOUT tool, you can
configure the following:
•

Record type
By default, the fields in a record will be space separated, and each record will
end with a carriage return and line feed (CR+LF). To change the default
settings, you must select Tools > Options and edit the options. See
StreamOUT options dialog box on page 21.

•

Blocks
Recurring data is defined as fields within blocks in the Event configuration.
The block and field configuration defined in the Event tool is available in a
separate Event view in the StreamOUT tool. In the StreamOUT tool, you
drag the blocks from the Event view, and drop them in the Process view. See
Blocks on page 11.

•

Records
You can create global record and block records. Global records contain nonrecurring data, and block records contain recurring data as specified in the
Event configuration. See Records on page 11.

•

Fields
You must add fields to the records. A record contains a number of record
fields. A record field can be a field defined in the Event configuration, a
variable, or a static text created in the StreamIN tool. See Record fields on
page 12.

•

Free blocks
You can create free blocks with one or more records. A free block can be
added before the first instance of a main block, added after the last instance
of a main block, added after all other blocks have been processed, or be
invoked using the CallBlock scripting function. See Free blocks on page 13.

•

Sort criteria for blocks
For each block defined in the StreamOUT tool, you can specify one or more
sort keys. When the StreamServer processes the data, it will sort the blocks
according to the sort keys. See Sorting on page 17.

•

Output format for fields and variables
You can specify which format to use for the output from fields and variables.
See Output format for fields and variables on page 16.
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Example: creating a StreamOUT configuration
Configuring record based output

Example: creating a StreamOUT
configuration
In this example, you have the Event configuration in Example 1, and want the
StreamServer to generate output according to Example 2.
Example 1

Event configuration

Example 2

Sample output

C_begin
Vivaldi

Quattro stagioni

23

Wagner

Gotterdammung

25
C_end
J&B_begin

Armstrong

Wonderful world

26

Gillespie

Zabadiddelidoo

24
J&B_end
R&P_begin

Sting

Save the jungle

Procol Harum Procol’s ninth

23
25
R&P_end

Edit the record type
All fields in the output should be in fixed positions, and each record should end
with CR+LF.
1

Select Tools > Options. The StreamOUT options dialog box opens.

2

Select Fixed field positions, New line at end of record, and Carriage
return and line feed (CR + LF) and click OK.
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Add the blocks and records
1

Drag the Classic block from the Event view, and drop it on the Message
node in the Process view. The Classic block, including a block record, is
added below the Message node.

2

Do the same with the Jazz and blues and Rock and pop blocks.

Add and configure the fields
The steps below describe how to add fields to the Classic block record. The same
steps also apply to the two other blocks.
Add the fields
1

Drag the classic_artist field from the Classic block in the Event view, and
drop it on the Classic record in the Process view.

2

Drag the classic_artist_album field from the Classic block in the Event
view, and drop it on the classic_artist field in the Process view.

3

Drag the classic_artist_price field from the Classic block in the Event
view, and drop it on the classic_artist_album field in the Process view.

Configure the fields
1

Right-click the classic_artist field and select Edit Start Position. The
corresponding field in the Pos column in the Process view is write enabled.

2

Enter 1 as start position.

3

Right-click the classic_artist field and select Edit Width. The
corresponding field in the Width column in the Process view is write
enabled.

4

Enter 25 as width.

5

Repeat steps 1 - 4 for the fields classic_artist_album and
classic_artist_price, and set the start position to 31 and 61 respectively.
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Example: creating a StreamOUT configuration
Configuring record based output

Add and configure free blocks
Each block calls two free blocks – one before first instance block, and one after
last instance block. The steps below describe how to add the free blocks to the
Classic block. The same steps also apply to the two other blocks.
Add the free blocks
1

Right-click the Classic block and select Insert Before First Instance
Block. A Before_Classic block is added to the Classic block.

2

Right-click the Classic block and select Insert After Last Instance Block.
An After_Classic block is added to the Classic block.

Configure the free blocks
1

Right-click the Before_Classic block and select Insert Record. A new
record is added to the Before_Classic block.

2

Right-click the new record and select Insert Static Text. A new static text
object is added to the record.

3

Select the new static text object. The properties for the static text object are
displayed in the Properties view.

4

In the Value field, enter C_begin.

5

Right-click the text object and select Edit Start Position. The
corresponding field in the Pos column in the Process view is write enabled.

6

Enter 62 as start position.

7

Right-click the text object and select Edit Width. The corresponding field in
the Width column in the Process view is write enabled.

8

Enter 20 as width.

9

Repeat steps 1 - 8 for the After_Classic block and set the value of the
static text to C_end.
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Adding and configuring objects
Blocks
There is one block for each group of recurring data. All blocks available in the
StreamOUT tool have been created in the corresponding Event. In the
StreamOUT tool, you drop the blocks in the Process view.
To add a block
Drag the block from the Event view and drop it on the Message node or parent
block in the Process view. The block, including a block record, is added below the
Message node. You can use the left mouse button as usual, or you can use the right
mouse button to get more drag-and-drop options.
To configure a block
In the Process view, right-click the block and select the appropriate shortcut menu
command. See Block on page 28.
See also
•

Sorting on page 17

•

Unlinked blocks and fields on page 18

Records
You can add global records and block records to the StreamOUT configuration.
Global records contain fields with non-recurring data, whereas block records
contain fields with recurring data.
Overall record definition
The overall record definition, i.e. which type of separator to use etc. applies to all
records. To change the default settings, you must select Tools > Options and edit
the options. See StreamOUT options dialog box on page 21.
To add a global record
In the Process view, right-click the Global records folder and select Insert
Record. A new record is added below the Global records folder.
To add a block record
In the Process view, expand the block, right-click the Block records folder, and
select Insert Record. A new record is added below the Block records folder.
To configure a record
In the Process view, right-click the record and select the appropriate shortcut
menu command. See Record on page 28.
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Adding and configuring objects
Configuring record based output

Record fields
A record contains a number of record fields. A record field can be a field defined
in the Event configuration, a variable, or a static text.

Fields
All fields have been created in the corresponding Event. In the StreamOUT tool,
you drop the fields on the appropriate record.
To add a field
Drag the field from the Event view and drop it on the appropriate record in the
Process view. You can use the left mouse button as usual, or you can use the right
mouse button to get more drag-and-drop options.
To configure a field
In the Process view, select the field and edit the properties in the Properties view,
or right-click the field and select the appropriate shortcut menu command. See
Field on page 25.
See also
•

Output format for fields and variables on page 16

•

Unlinked blocks and fields on page 18

Variables
You can add data to the output using variable fields. If the variable is defined in
the Event configuration, you can drag the variable from the Event view to the
appropriate record. If the variable is created using scripts, you must add the
variable field manually. You must make sure that the variable is available when
it is used in the Process. For example, a variable defined within a block is only
available when the corresponding block is being processed.
To add a new variable field
In the Process view, right-click the record and select Insert Variable. A new
variable field is added to the record.
To drag a variable from the Event view
Drag the variable from the Event view and drop it on the appropriate record in the
Process view. You can use the left mouse button as usual, or you can use the right
mouse button to get more drag-and-drop options.
To configure a variable field
In the Process view, select the variable field and edit the properties in the
Properties view, or right-click the variable field and select the appropriate
shortcut menu command. See Variable on page 27.
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See also
Output format for fields and variables on page 16

Static text
You can add static text fields to any record
To add a new static text field
In the Process view, right-click the record and select Insert Static Text. A new
static text field is added to the record.
To configure a static text field
In the Process view, select the static text field and edit the properties in the
Properties view, or right-click the static text field and select the appropriate
shortcut menu command. See Static Text on page 26.

Free blocks
There are four types of free blocks:
•

Free Block. This block can be invoked using the CallBlock scripting

function. See the Scripting reference.
•

Before First Instance Block. This block will be added before the first

instance of a main block, i.e. a block specified in the corresponding Event.
•

After Last Instance Block. This block will be added after the last instance

of a main block.
•

After all blocks block. This block will be added after the last instance of

the last block, i.e. after all other blocks have been processed.

Free block – CallBlock invoked
If you want to add records if certain conditions are fulfilled, you can use a Free
block.
For example, you can include the accumulated sum on every tenth article line,
even if the sum is not included in the input data. To be able to do this, you must
add a Free block with a record that includes a variable for the sum. Then create a
script after the article block in which you calculate the accumulated sum and
assign it to the variable. In the script, you must also count the article lines to be
able to call the Free block from every tenth line.
This block can be invoked using the CallBlock scripting function. See the
Scripting reference.
To add the block
In the Process view, right-click the Free blocks folder and select Insert Free
Block. The new free block is added to the Free blocks folder.
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Adding and configuring objects
Configuring record based output

To configure the block
In the Process view, select the free block and edit the properties in the Properties
view, or right-click the free block and select the appropriate shortcut menu
command. Free Block on page 29.

Before first instance block
If you want to add records before a sequence of a certain block type, you can use
Before first instance blocks. This type of block will appear as a sub-block to the
selected block type. The sub-block will be processed before each sequence of
parent blocks.
To add the block
In the Process view, right-click the main block and select Insert Before First
Instance Block. The free block is added to the main block.
To configure the block
In the Process view, select the free block and edit the properties in the Properties
view, or right-click the free block and select the appropriate shortcut menu
command. Before First Instance Block on page 30.

After last instance block
If you want to add records after a sequence of a certain block type, you can use
After last instance blocks. This type of block will appear as a sub-block to the
selected block type. The sub-block will be processed before each sequence of
parent blocks.
To add the block
In the Process view, right-click the main block and select Insert After Last
Instance Block. The free block is added to the main block.
To configure the block
In the Process view, select the free block and edit the properties in the Properties
view, or right-click the free block and select the appropriate shortcut menu
command. After Last Instance Block on page 30.

After all blocks block
If you want to process records and perform actions after all other blocks have been
processed, you can use an After all blocks block. For example, you can create
statistics on the number of records an output file contains. An After all blocks
block is automatically included in the Process browser. The block will not be
processed, unless you add scripts or records with fields to it.

StreamServe Persuasion SP5 StreamOUT User Guide Rev A

Adding and configuring objects
Configuring record based output

To configure the block
In the Process view, select the free block and edit the properties in the Properties
view, or right-click the free block and select the appropriate shortcut menu
command. After All blocks on page 31.
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Output format for fields and variables
Configuring record based output

Output format for fields and variables
In the Event tool, you can configure fields and variables to handle numeric or date
formatted data. Which format to use is determined by the input data. In the
StreamOUT tool, you can specify which format to use for the output from the
corresponding field or variable. You can use the same format as specified in the
Event tool, or you can select a new format.
For example, if the input is 02/08/12, and you want to change this to 08.12.02
in the output, you must first specify the format yy/mm/dd in the Event tool. You
then specify the new output format, mm.dd.yy, in the StreamOUT tool.
Format tables
Numeric and date formats are made available through format tables. Before you
specify any formats, you must add a format table to a resource set connected to
the Message. You can import Formats.txt from
<StreamServe
installation>\Applications\StreamServer\<version>\Tools\Samples

to the resource set.
The first time you specify a format, a resource selection dialog box opens. In this
dialog box, you must browse to and select the format table you want to use. This
table will be selected by default the next time you specify a format for any of the
fields or variables in the StreamOUT configuration.
To select a new numeric | date format for a field or variable
1

In the Process view, select the field or variable. The properties are displayed
in the Properties view.

2

In the Output format field, click the browse button. The Formats dialog
box opens.

3

Select the Numeric | Date category.

4

Double-click the new Format.

Note: Do not use the Numeric formats k and d. They should be used in the Event

configuration only.
To add a new format
In the Formats dialog box, in the Format field, enter the new format and click
Add. You can also add new formats directly to the format table resource. See
Formats dialog box on page 22.

StreamServe Persuasion SP5 StreamOUT User Guide Rev A

Sorting
Configuring record based output

Sorting
You can use sort keys to specify the order in which block data will be added to
the output. If no sort keys are used, data will be added in the same order as
specified in the Event configuration, i.e. in the same order as in the Message.
To specify sort keys for a block
1

In the Process view, right-click the block and select Sort Criteria. The Edit
Sort Criteria dialog box opens.

2

Edit the sort criteria and click OK.

Syntax
"<field>":"<type><order>"

For example:
"customer_name":"SA"
<type> is

either S (alpha-numeric) or N (numeric)

<order> is

either A (ascending) or D (descending)

Multiple sort keys
Multiple sort keys are separated with spaces. Data will be sorted according to the
first key. Block instances that equally fulfill the first sort will be sorted according
to the next key, and so on.
Example 3

Sort keys for the fields name and age
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Configuring record based output

Unlinked blocks and fields
If a field or block is removed from the Event configuration, the corresponding
fields in the StreamOUT configuration are not removed. Instead the links are
broken.
Exporting data from unlinked fields
You can configure unlinked fields to be exported as variables, static text, or not
at all. You can select Tools > Default Unlinked Export and set export options
that apply to all unlinked fields. See Set Unlinked Field Properties dialog box on
page 21. You can also set the export settings separately for each field. See Field
on page 25.
Deleting unlinked objects
You can delete the unlinked objects separately. You can also select Tools >
Delete all Unlinked Objects to delete all unlinked objects at the same time.
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StreamOUT tool GUI reference
Main Window
The Main window contains five views:
•

Event view
This is the structure created in the corresponding Event tool. You can drag
fields and blocks from this view to the Process view.

•

Process view
This is where you create the StreamOUT configuration.

•

Preview view
This is where you preview the record based output.

•

Properties view
Select a node in the Process view, and configure the corresponding
properties in the Properties view.

Menus and menu commands
File menu
New

Clear the existing StreamOUT configuration and start with a new Process view.

Open

Open an existing StreamOUT configuration. The StreamOUT configuration
must have been saved as a *.dso file.

Save

Save the StreamOUT configuration as data embedded in the corresponding
Message file in the Design Center Project.

Save As

Save the StreamOUT configuration as a separate *.dso file.

Exit

Exit the StreamOUT tool.

Edit menu
Standard Windows options.
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View menu
Status Bar

Show/hide the status bar.

Event
Browser

Show/hide the Event view.

Process
Browser

Show/hide the Process view.

Toggle View
Mode

The View Mode determines the display names for the fields in the Event view
and Process view. You can toggle between the following modes:

Toggle
Operation
Nodes

•

Label

•

Description

•

Sample content

Show/hide operation nodes. Operation nodes can include scripts and sort key
definitions.

Insert menu
Contains all available item types, i.e. records, fields, etc., that you can add to the
StreamOUT configuration.

Tools menu
Import Event Import an Event configuration. Applicable only when using the StreamOUT tool

as a standalone application.
Link Objects Link all unlinked fields and blocks. Unlinked blocks and fields in the Process

view will be linked to blocks and fields with the same name in the Event view.
Unlink object Manually cut the link between a field or block in the Process view, and the

corresponding field or block in the Event view.
Default
unlinked
export

Set export options that apply to all unlinked fields. See Set Unlinked Field
Properties dialog box on page 21.

Delete all
Unlinked
Objects

Delete all unlinked objects at the same time.

Edit Script

Select an item in the Process view and edit a before or after script.

Edit Sort
Criteria

Select a block in the Process view and edit the sort keys for the block.
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Preview
Export

Preview the export from the StreamOUT tool.

Customize

Open the Customize dialog box.. See Customize dialog box on page 22.

Options

Edit the settings for indentation, empty elements, and escape sequences. See
StreamOUT options dialog box on page 21.

Dialog boxes
StreamOUT options dialog box
Record type settings
Fixed record length Select this option to create fixed length records, and

specify the length (characters).
Fixed field
positions

Select this option to create records with fields in fixed
positions.

New line at end of
record

Select this option to create records that end with a line
feed, and optionally a carriage return.

Separator

Specify which field separator to use.
Note: Hex values will be interpreted as pairs within

angle brackets. For example, 1E3 will be
interpreted as <1E><03>.

Set Unlinked Field Properties dialog box
Settings
Do not export

Do not export the field.

Export as variable

Export the field as a variable. Do not use white spaces in
the variable name. Do not enter the $-prefix.

Export as static
text

Select to export the Label, Description, Sample Data, or
a custom Text.
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StreamOUT tool GUI reference

Customize dialog box
Toolbars tab
Turn toolbars on and off, turn tooltips on and off, and modify the appearance of
the toolbars.
Commands tab
Display information about the toolbar buttons.

Formats dialog box
Settings
General – Data will be handled as a regular string of
characters.

Category

Numeric – Data will be handled as numeric data. This
category must have been specified for the field or
variable in the Event configuration.
Date – Data will be handled as date formatted data. This
category must have been specified for the field or
variable in the Event configuration.
Format

Select an existing format or add a new format. Do not use
the Numeric formats k and d. They should be used in the
Event configuration only.

Select Resource

Browse to and select an alternative format resource.

Numeric format description
Z

If the value of a leading or trailing digit is zero, the digit is replaced
by a space, " ".

B

If the value of a leading or trailing digit is zero, the digit is removed.

9

The digit is always displayed.

#

A digit on either side of a decimal separator, or the last sign if no
decimal separator exists. The digit is always displayed, except if the
field value is zero (0 or 0.0 or similar).

Example

Z ZZZ ZZZ ZZ#,##

Date format description
d

Day
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Date format description
m

Month

y

Year

Example

dd/mm/yyyy
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Event view
This is the structure created in the corresponding Event tool. You can drag fields
and blocks from this view to the Process view.
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Process view
This is where you create the StreamOUT configuration.

Process view nodes
Global records
Shortcut menu commands
Insert Record

Add a record with fields for non-recurring data.

Free blocks
Shortcut menu commands
Insert Free Block

Add a free block.

Field
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Edit start position

Applicable only to records with fixed field positions.
Select this command and enter the start position in the
Pos column.

Edit width

Applicable only to records with fixed field positions.
Select this command and enter the width in the Width
column.

Unlink

The field is normally linked to a field in the Event view.
You can unlink the field and use the Unlinked export
property to specify what to do with the field data.

Settings
Label

Label displayed in the Process view and preview.
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Settings
Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Sample content

Descriptive text entered in the Event configuration.

Item state

Linked – The field is linked to a field defined in the
corresponding Event.
Unlinked – The field is not linked to any field in the

Event configuration. Use the Unlinked export property to
specify what to do with the field data.
Unlinked export

Determines whether or not to export an unlinked field.
Do not export – Do not export the field.
Export as static text – Use Fixed Export Type below

to specify what to export as static text.
Export as variable – Use Variable Name below to

specify what to export.
Fixed Export Type

Below “Export as static text”.
Select to export the Label, Description, Sample Data, or
a fixed string. Use Fixed Export Value below to specify
what to export as Fixed String.

Fixed Export Value Below “Fixed Export Type > Export Fixed String”.

The text to export. Must not contain quotation marks.
Variable Name

Below “Export as variable”.
The variable name. You cannot type the $-prefix when
you enter the variable name. The prefix is automatically
included in the export.

Item type

Field.

Output format

Used to select numeric or date format. See Output format
for fields and variables on page 16.

Static Text
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.
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Shortcut menu commands
Edit start position

Applicable only to records with fixed field positions.
Select this command and enter the start position in the
Pos column.

Edit width

Applicable only to records with fixed field positions.
Select this command and enter the width in the Width
column.

Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Item type

Static text.

Value

The static text.

Output format

N/A

Fixed field width

Select this option to create a field with a fixed width
(characters) for the static text.

Field width

The field width. Same as Edit width shortcut menu
command.

Start position

Start position for the static text field. Same as Edit
start position shortcut menu command.

End position

End position for the static text field.

Align

Alignment of the text within the field.

Variable
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Edit start position

Applicable only to records with fixed field positions.
Select this command and enter the start position in the
Pos column.

Edit width

Applicable only to records with fixed field positions.
Select this command and enter the width in the Width
column.
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StreamOUT tool GUI reference

Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Sample content

Descriptive text.

Item type

Variable.

Output format

Used to select numeric or date format. See Output format
for fields and variables on page 16.

Fixed field width

Select this option to create a field with a fixed width
(characters) for the variable.

Field width

The field width. Same as Edit width shortcut menu
command.

Start position

Start position for the variable field. Same as Edit start
position shortcut menu command.

End position

End position for the variable field.

Align

Alignment of the text within the field.

Record
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Insert Field

Add a field to the record. See Field. You must first select
the field in the Event view.

Insert Variable

Add a variable field to the record. See Variable.

Insert Static Text

Add a static text field to the record. See Static Text.

Block
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.
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Shortcut menu commands
Sort Criteria

Edit sort keys for the block.
Syntax
"<field>":"<type><order>"

where:
<type>

is either S (alpha-numeric) or N (numeric)

<order>

is either A (ascending) or D (descending)

Multiple sort keys

Multiple sort keys are separated with space.
Example
"customer_name":"SA" "customer_number":"NA"

Insert Block

Add a new block to the StreamOUT configuration. You
must first select the block in the Event view.

Insert Before First
Instance Block

Add a before first instance block to the block. See Before
First Instance Block.

Insert After Last
Instance Block

Add an after last instance block to the block. See After
Last Instance Block.

Unlink

You can manually unlink a block and all its fields from
the corresponding block and fields in the Event
configuration.

Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Item type

Block.

Free Block
With this item, you specify a free block that can be invoked using the CallBlock
scripting function.
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.
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Shortcut menu commands
Insert Record

Add a new record to the block. See Record.

Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Item type

Free block.

Before First Instance Block
With this item ,you specify a free block that will be added before the first instance
of a main block, i.e. a block specified in the corresponding Event.
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Insert Record

Add a new record to the block. See Record.

Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Item type

Block before first instance.

After Last Instance Block
With this item, you specify a free block that will be added after the last instance
of a main block, i.e. a block specified in the corresponding Event
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Insert Record

Add a new record to the block. See Record.
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Settings
Label

Label displayed in the Process view and preview.

Description

Optional information about this item. This information is
not exported from the StreamOUT tool.

Item type

Block after last instance.

After All blocks
This block will be added after the last instance of the last block, i.e. after all other
blocks have been processed.
Shortcut menu commands
Script Before

Insert or edit a before script.

Script After

Insert or edit an after script.

Insert Record

Add a record.
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