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About PageOUT

The StreamServer can produce page oriented output, and send this output together 
with driver information to some kind of print device. The driver information and 
output destination is specified in the output connector configuration, and the 
contents, structure, and layout of the output is configured using the PageOUT 
tool.

Page setup

Before you configure the output, you must make sure that the page setup in the 
PageOUT tool conforms to the page setup in the receiving print device. See Page 
setup in the PageOUT tool on page 9.

Output configuration

The actual output configuration consists of a number of tasks: selecting which 
fields to pick from the input data, adding new text segments, formatting text, etc. 
See Configuring page formatted output on page 19.

Preview

You do not have to export and run the whole StreamServe Project each time you 
want to check how changes in the PageOUT configuration affects the output. 
Instead you can preview the output from the PageOUT tool. See Previewing 
output on page 64.
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Page setup in the PageOUT tool

Page types

You can create different types of pages, where each type has its own layout. See 
Page types on page 9.

Grid lines and margins

You can configure the grid lines and margins displayed on the PageOUT sheet. 
See Grid lines and margins on page 15.

Page format

You must adapt the size and orientation of the PageOUT sheet to the size and 
orientation of the actual print-out. See Page format on page 16.

Page offset

Some printers will automatically offset the output. You can adjust the page offset 
accordingly in the PageOUT tool. See Page offset on page 17.

Page types
You can create different types of pages, where each type has its own layout. Each 
page type (except the types Before and After) will contain the same frames, 
including blocks and fields. If you add a frame to one page type, it will 
automatically be added to all the others. The size, position, and shape of the 
frames can however be different on the different page types.

Body page

This is the default page type. The output can contain zero or more pages of this 
type. A Body page can be preceded by a First page and followed by a Last page, 
if required. You cannot delete this page type.

Single page

This type can be used in the output if there is room for all data on one single page. 
A Single page cannot be preceded by a First page or followed by a Body or Last 
page.

First page

This type can be used if you want to have a first page with a specific layout 
followed by one or more pages with different layouts. A First page can be 
followed by one or more Body pages, and one Last page, if required.
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Last page

This type can be used if you want to have a last page with a specific layout 
preceded by one or more pages with different layouts. A Last page can be 
preceded by one or more Body pages, and one First page, if required. There is an 
option to always add a Last page to the output. See Always adding a Last page to 
the output on page 13.

Before and After pages

There are two special types of pages that you can add to the beginning or end of 
the output document. These page types are called Before and After. If you define 
a Before or After page, it will always be added to the output – unless you use the 
scripting function Skip to explicitly remove it from the output. Before and After 
pages cannot contain frames.

You can create one or more Before pages, and one or more After pages in the 
PageOUT configuration, if required. These types of pages will be added to the 
output in the same order as they are specified in the PageOUT tool. See Before 
and After pages on page 11.

Examples

The following examples illustrate how the different page types will be used when 
generating an invoice with logo, address information, etc. at the top, one frame 
with recurring data, and a payment slip. The PageOUT configuration contains a 
Single, a First, a Body, and a Last page.

Example 1 Single page

The Single page is large enough for the data. Consequently, the Single page will 
be used in the output.
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Example 2 First page and Last page

Neither the Single, nor the First page is large enough for the data. But the First 
page together with the Last page is large enough. Consequently, one First and one 
Last page will be used in the output.

Example 3 First page, Body page, and Last page

One First and one Last page is not large enough for the data. But one First page, 
together with one Body and one Last page is large enough. Consequently, one 
First, one Body, and one Last page will be used in the output.

Adding page types
By default, there is one Body page in the PageOUT configuration. You cannot 
remove this page type. To this default configuration you can add a Single, a First, 
a Last and any number of Before and After page types. Each new page type will 
have its own tab in the Process view.

1 In the Process view, right-click the root node and select New Page. The 
Select Page Type dialog box opens.

2 Select the page type and click OK. A new page is added to the PageOUT 
configuration.

Before and After pages
You can use Before and After pages for different purposes. You can, for example, 
use a Before page as a cover sheet. You can create as many Before and After 
pages as you like. The pages will be added to the output in the same order as you 
create them in the PageOUT tool. Note that Before and After pages cannot contain 
frames.
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Renaming a page

All Before and After pages initially have the default name Other. To change the 
name you must:

1 Select the tab for the page you want to rename.

2 In the Process view, select the name in the root node and enter a new name.

Disabling a page

The page will by default be added to the output. To disable the page from the 
output you must:

1 Select the tab for the page you want to disable.

2 In the Process view, right-click the root node and select Edit Script. The 
Script editor opens.

3 Enter the following Before script: Skip();

Using variables

You can use variables below the root node in the Message view, and variables 
created by before Message or before Process scripts. For example, you can use 
these variables together with the Skip function to select different Before pages.

Dynamic number of Before and After pages

You can create a dynamic number of Before and After pages by using the 
scripting function NewPage in a Before script attached to an object on a page.

Example 4 Before script attached to a dummy field

OutputLXFJobResource(num($jobid),"statementattach",num($cnt));

$cnt++;

if (num($cnt)<=num($attpages))

    newpage();

How the StreamServer determines which page type to 
use

Which page types to include in the output depends on the amount of recurring 
data, and on the size of the frames on each page type. The StreamServer fills the 
frames on the different page types in a specific order until all data has been added 
to the output. To get the desired output, for example a First and a Body page, you 
must understand how the StreamServer determines when to use a specific page 
type. 

Testing order

The StreamServer normally uses the following order to test if the data fits in the 
frames of the different page types:
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Single => First => Last => Body

If a page type is not defined, no testing will be performed for that type.

The resulting output

1 If all data fits into a Single page, only this page type is generated and the 
StreamServer proceeds to the next Process. The output is a Single page. 

2 If the data does not fit in a Single page, the server tests if it fits into a First 
page. If it does, a First page is generated, then the StreamServer proceeds to 
the next Process. The output is a First page.

3 If the data does not fit in a First page, the StreamServer fills the First page 
and then tests if the remaining data fits in a Last page. If it does, a Last page 
is generated, then the StreamServer proceeds to the next Process. The 
output is a First page and a Last page.

4 If the data does not fit in a Last page, a Body page is generated. If all data 
fits in the Body page, the StreamServer proceeds to the next Process. The 
output is a First page and a Body page.

5 If the data does not fit in a Body page, the StreamServer fills the Body page, 
and tests if the remaining data fits in a Last page. If it does, a Last page is 
generated, then the StreamServer proceeds to the next Process. The output 
is a First page, a Body page, and a Last page.

6 If the data does not fit in a Last page, steps 4 and 5 are repeated until there is 
no remaining data. Depending on the amount of data, the output can be 
either a First page, one or more Body pages, and a Last page, or it can be a 
First page and one or more Body pages. 

Avoiding getting only a last page

To avoid getting only a Last page in the output, you should always include a 
Single page type in the PageOUT configuration. If you do not, the StreamServer 
will use a different order than when a Single page is included:

Last => First => Body

This means that if all data fits on the Last page, the output will only include a Last 
page. If you include a Single page with a reasonably large frame there will always 
be a Single page or a First page before the Last page in the output.

Always adding a Last page to the output
The Last page may contain information that must be included in the output. If the 
amount of recurring data in the output fits into a First page or a First page and one 
or more Body pages, a Last page will not be generated by default. You can change 
this default behavior to make sure that a Last page is always generated.

Note: If the data fits into a Single page, no Last page will be generated.

To enable “always Last page output”

1 Select File > Page Setup. The Page Setup dialog box opens.
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2 On the Other tab, select Always output and click OK.
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Grid lines and margins
Grid settings

You can configure the grid lines on the PageOUT sheet. These settings apply to 
all pages/page types you have defined.

1 Select Format > Guide Settings. The Guides Settings dialog box opens.

2 On the Grid tab, specify the grid settings and click OK. See Guides Settings 
dialog box on page 100.

Margins

You can have the top, right, bottom, and left margins displayed on the PageOUT 
sheet. These margins are for guidance only.

1 Select Format > Guide Settings. The Guide Settings dialog box opens.

2 Select the Borders tab and specify the margins (in millimeters).

3 Select Show borders and click OK.

Note: You cannot specify different margins for different page types in the same 
PageOUT configuration.
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Page format
You must adapt the size and orientation of the PageOUT sheet to the size and 
orientation of the actual print-out as specified with the device driver settings. 
Output devices that have no driver options for page size and orientation (e.g. the 
PDF driver) will inherit the size and layout of the PageOUT sheet. 

To configure the page size and orientation

1 Select File > Page Setup. The Page Setup dialog box opens.

2 On the Paper Size tab, specify the page format settings and click OK. See 
Page Setup dialog box on page 98.

Different settings for different page types

If the output device has no driver settings for size and orientation, you can use 
different settings for different page types in the same PageOUT configuration. For 
example, if the output format is PDF, you can have different page size and 
orientation for First and Body pages. If the output device has driver settings for 
size and orientation, you cannot do this – the driver settings will override the 
settings for the PageOUT sheet, and you can only have one device driver 
configuration per Process output.

PreformatIN scenario

PreformatIN generates a number of variables when processing an input 
document. The following auto generated variables reflect the page properties of 
the input document:

• $pageorientation – The page orientation of the current page (Portrait or 
Landscape).

• $pagemedia – The page media of the current page (A4, Letter, etc.).

• $pagewidth – The page width (mm) of the current page.

• $pageheight – The page height (mm) of the current page.

In this scenario, a PDF file is received via a PDFIN filter and PreformatIN, and 
the output is generated by a PageOUT Process and a File output connector with a 
PDF driver. The input document contains a mix of Portrait and Landscape pages.

By default, the PageOUT Process uses the static page properties configured on the 
Paper Size tab in the Page Setup dialog box (File > Page Setup). This means the 
PDF output would contain either Portrait or Landscape pages – not a mix of both.

To enable both Portrait and Landscape pages in the output, the Page Setup option 
Enable width variable in PageOUT is selected, and the variable value is set to 
pagewidth. The option Enable height variable is also selected, and the variable 
value is set to pageheight.

When a page is processed in PageOUT, the width and height is retrieved from the 
$pagewith and $pageheight variables of the corresponding input page. This 
means the output now contains the same mix of Landscape and Portrait pages as 
the input document.
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Page offset
Some printers will automatically offset the output. You can adjust the page offset 
accordingly in the PageOUT tool. The offset will be applied on the printed output 
page, and will not be visible on the PageOUT sheet.

Note: You must adjust the offset for every page type in the PageOUT 
configuration.

To adjust the offset of the output page

1 Select File > Page Setup. The Page Setup – Body dialog box opens.

2 Select the Other tab.

3 In the Margins area, specify the offset settings and click OK. See Page 
Setup dialog box on page 98.
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Configuring page formatted 
output

You use the PageOUT tool to configure the contents and structure of page 
formatted output from the StreamServer. With the PageOUT tool, you can 
configure the following:

• Overlays
You can add overlays with logotypes, labels, frames, etc. See Overlays on 
page 34 and Overlay management on page 49.

• Frames for recurring data
You must define areas for recurring data. You do this by drawing frames on 
the PageOUT sheet. When the StreamServer processes data, and a frame is 
filled with data, a new page will be generated in the output. See Frames on 
page 25.

• Blocks
Recurring data is defined as fields within blocks in the Event configuration. 
The block and field configuration defined in the Event tool are available in a 
separate Message view in the PageOUT tool. In the PageOUT tool, you drag 
the blocks from the Message view, and drop them in the appropriate frame 
on the PageOUT sheet. See Blocks on page 25.

• Fields
All fields are defined in the Event configuration. In the PageOUT tool, you 
drag the fields from the Message view, and drop them where they belong – 
at root level or in the appropriate block. When you have added the fields, you 
can change the font, convert text to barcodes, create hyperlinks, etc. See 
Fields on page 26.

• Additional text segments
You can add additional text segments. You can, for example, add page 
numbering functions, time and date stamps, and static text. When you have 
added the text segments, you can change the font etc. See Text objects on 
page 27 and Advanced text on page 29.

• Free blocks
You can add free blocks that you use to, for example, add text before and 
after a page break. See Free blocks on page 26.

• Graphics
You can add images, rectangles, lines, and charts. See Images on page 31, 
Lines and rectangles on page 33, and Charts on page 67.
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• RFID inlays
You can configure RFID inlays to use with label printers. See RFID inlays 
on page 36.

• Position and size of objects
You can move, stretch, resize, etc. all objects. See Positioning and resizing 
objects on page 39.

• Page breaks
When a frame is filled with data, a new page will be generated. For each 
block, you can define where you want to have the page break. See Defining 
page breaks on page 54.

• Sort criteria for blocks
For each block defined in the PageOUT tool, you can specify one or more 
sort keys. When the StreamServer processes the data, it will sort the blocks 
according to the sort keys. See Sorting on page 57.

• Output format for fields and variables
You can specify which format to use for the output from fields and variables. 
See Output format for fields and variables on page 53.

Automatic configuration (PageIN and PreformatIN only)

You can let the PageOUT tool automatically pick all frames, blocks, and fields 
defined in a PageIN or PreformatIN Event, and add them to the PageOUT 
configuration. See Applying a PageIN/PreformatIN page layout on page 38.

Previewing the output

You do not have to export and run the whole StreamServe Project each time you 
want to check how changes in the PageOUT configuration affects the output. 
Instead, you can preview the output from the PageOUT tool. See Previewing 
output on page 64.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Example: configuring page formatted output 21
Configuring page formatted output
Example: configuring page formatted output
In this example you have the Message configuration in Example 5 and want the 
StreamServer to generate output according to Example 6.

Example 5 Message configuration

Example 6 Sample output

Add an overlay

The logotype, header “Billy’s Music Ltd.”, background color, and table lines are 
all implemented as an LXF overlay. In this example, you have already created and 
added the overlay Music.lxf to the resource set.

1 Right-click the PageOUT sheet and select Add Overlay. The Add Overlays 
dialog box opens.

2 In the Overlays list, check Music.lxf and click OK. The overlay is added to 
the PageOUT sheet.
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Draw the area for recurring data

The table in the overlay is where you want to have the recurring data from the 
blocks Classic, Jazz and blues, and Rock and pop.

1 Select Insert > Frame and draw the frame around the table.

2 Rename the frame to Artists.

Add the blocks

1 In the Process view, select the frame Artists.

2 Drag the Classic block from the Message view to the frame on the 
PageOUT sheet.

3 Drag the Jazz and blues block from the Message view to the frame.

4 Drag the Rock and pop block from the Message view to the frame.

Add and configure the fields

The steps below describe how to add the fields classic_artist, 
classic_artist_album, and classic_artist_price to the Classic block. The 
same steps apply to the other blocks.

1 In the Process view, select the Classic block.

2 Drag the fields classic_artist, classic_artist_album, and 
classic_artist_price from the Message view to the frame on the PageOUT 
sheet.

3 In the Process view, right-click the field classic_artist and select Position. 
The Position dialog box opens.

4 Set X to 5.6 and Y to 6.0 and click OK.

5 Repeat steps 3 and 4 for the other fields and change X to 72.0 and 134.0 for 
the field classic_artist_album and classic_artist_price respectively.

6 On the PageOUT sheet, multi-select the fields in the Classic block, and use 
the toolbar to set the font to Arial-12pt-Red-Bold.

Add free blocks

This example includes the following free blocks:

• Label. This block is the table header. It contains the column labels Artist, 
Album and Price.

• Label_Classic. This block is the header for the Classic block. It contains 
the label Classic music.

• Label_Jazz. This block is the header for the Jazz and blues block. It 
contains the label Jazz and Blues.

• Label_Rock. This block is the header for the Rock and pop block. It 
contains the label Rock and Pop.
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Add the Label block

The steps below describe how to add the Label free block to the frame. The same 
steps apply to the other free blocks.

1 In the Process view, right-click the frame and select Add Free Block. The 
free block is added to the frame.

2 Rename the free block to Label.

Add text labels to the free blocks

The steps below describe how to add text labels to the Label_Classic free block. 
The same steps apply to the other free blocks.

1 In the Process view, select the Label_Classic free block.

2 Select Insert > Static Text.

3 On the sheet, click the position where you want to insert the text. The Edit 
Text dialog box opens.

4 Enter Classic music and click OK.

5 Right-click the text label and select Position. The Position dialog box 
opens.

6 Set X to 5.6 and Y to 6.0 and click OK.

7 Select the field, and use the toolbar to set the font to Arial-12pt-Bold.

Adjust the block height

The steps below describe how to adjust the block height for the Classic block. 
The same steps apply to the other blocks – including the free blocks.

1 In the Process view, right-click the Classic block and select Block 
Properties. The Output Block Properties dialog box opens.

2 In the After field, enter 0.9 and click OK.

Call the free blocks

Call the Label block

This free block should be inserted as the first line in the frame.

1 In the Process view, right-click the frame and select Frame Properties. The 
Frame Properties dialog box opens.

2 In the Before Frame and After (overflow) fields, enter Label and click OK.

Call the Label_Classic block

This free block should be inserted before the first instance of the Classic block. 
It should also be inserted as the first line after a page break.

The steps below describe how to call the Label_Classic free block from the 
Classic block. The same steps apply to the other blocks.
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1 In the Process view, right-click the Classic block and select Block 
Properties. The Output Block Properties dialog box opens.

2 In the Before first instance and After (overflow) fields, enter 
Label_Classic and click OK.

Specify sort keys for the blocks

Data is already sorted according to the sort keys specified in the Event 
configuration: Classic => Jazz and Blues => Rock and Pop. In the PageOUT 
configuration we specify two sort keys:

• The primary sort key instructs the StreamServer to sort data by Artist in 
ascending alphabetical order.

• The secondary sort key instructs the StreamServer to sort data by Album in 
ascending alphabetical order.

The steps below describe how to specify sort keys for the Classic block. The 
same steps apply to the other blocks.

1 In the Process view, right-click the Classic block and select Block 
Properties. The Output Block Properties dialog box opens.

2 In the Criteria field, enter "Artist":"SA" "Album":"SA" and click OK.
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Frames
Frames define areas for blocks with recurring data on the PageOUT sheet. You 
must first draw one or more frames, and then add the blocks to the frames.

To add a frame

1 Select Insert > Frame and draw the frame on the PageOUT sheet.

2 Rename the frame.

To configure a frame

In the Process view, right-click the frame and select the appropriate shortcut menu 
command. See Frame on page 95.

See also

• Positioning and resizing objects on page 39

• Invoking free blocks on page 51

Blocks
There is one block for each group of recurring data. All blocks available in the 
PageOUT tool have been created in the corresponding Event. In the PageOUT 
tool, you drop the blocks in one or more frames on the sheet.

To add a block

1 In the Process view, select the frame.

2 Drag the block from the Message view to the frame on the sheet.

To configure a block

In the Process view, right-click the block and select the appropriate shortcut menu 
command. See Block on page 96.

See also

• Invoking free blocks on page 51

• Defining page breaks on page 54

• Sorting on page 57

• Unlinked blocks and fields on page 65
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Fields
All fields have been created in the Event tool. In the PageOUT tool, you drop the 
fields on the sheet at either root level or in a block.

A field contains text where the whole text segment has the same size, font, color, 
etc.

To add a field

1 In the Process view, select the top node or the appropriate block.

2 Drag the field from the Message view to the sheet.

To configure a field

In the Process view, right-click the field and select the appropriate shortcut menu 
command. See Text objects on page 93.

See also

• Positioning and resizing objects on page 39

• Using barcodes on page 41

• Creating hyperlinks on page 43

• Output format for fields and variables on page 53

• Unlinked blocks and fields on page 65

Free blocks
Ordinary blocks are defined in the Event configuration. A free block is defined in 
the PageOUT tool, and can be edited the same way as ordinary blocks. You can 
use a free block to, for example, add text before and after a page break. A free 
block can be invoked using the CallBlock scripting function or by frame and 
block properties.

To add a free block at root level

1 In the Process view, select the top node.

2 Select Insert > Free Block and draw the block on the PageOUT sheet.

3 Give the block a unique name.

To add a free block to a frame

1 In the Process view, right-click the frame and select Add Free Block. The 
free block is added to the frame.

2 Give the block a unique name.

To configure a free block

In the Process view, right-click the free block and select the appropriate shortcut 
menu command. See Free Block on page 96.
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See also

Invoking free blocks on page 51

Text objects
Text objects contain text where the whole text segment has the same size, font, 
color, etc. You can add the following text object types to the PageOUT 
configuration:

• Field. Described separately in Fields on page 26.

• Static Text

• Variable

• Page Number

• Page of Pages

• Pages

• Date

• Time

Static Text
You can use this object to add text segments to the sheet. You can include 
variables, identified by a $-prefix, in the text.

To add a Static Text object

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Static Text.

3 On the sheet, click the position where you want to insert the text. The Edit 
Text dialog box opens.

4 Enter the text and click OK.

To configure a Static Text object

In the Process view, right-click the Static Text object and select the appropriate 
shortcut menu command. See Text objects on page 93.

See also

• Positioning and resizing objects on page 39

• Using barcodes on page 41

• Creating hyperlinks on page 43

• Output format for fields and variables on page 53

• Language handling on page 59
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Variable
You can add text to the output using variables. If the variable is created in the 
corresponding Event, you can drag the variable from the Message view to the 
PageOUT sheet. If the variable is created using scripts, you must enter the 
variable manually. When you add a variable, you must make sure that it is 
available when it is used in the Process. For example, a variable defined within a 
block is only available when the corresponding block is being processed.

To add a Variable object

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Variable.

3 On the sheet, click the position where you want to insert the text. The Edit 
Variable dialog box opens.

4 Enter the name of the variable, without the $-prefix, and click OK.

To drag a Variable object from the Message view

1 In the Process view, select the top node or the appropriate block.

2 Drag the variable from the Message view to the sheet.

To configure a Variable object

In the Process view, right-click the Variable object and select the appropriate 
shortcut menu command. See Text objects on page 93.

See also

• Positioning and resizing objects on page 39

• Using barcodes on page 41

• Creating hyperlinks on page 43

• Output format for fields and variables on page 53

Page numbering
You can add automatic page numbering functions to the PageOUT sheet. There 
are three page numbering functions:

• Page. Generates the number of the current page.

• Page of pages. Generates the number of the current page, and the total 
number of pages in the output document. For example, 7 (98).

• Pages. Generates the total number of pages in the output document. 

To add page numbering objects

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Page Number | Page of Pages | Pages.

3 On the sheet, click the position where you want to insert the page number.
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To configure a Page numbering object

In the Process view, right-click the page numbering object and select the 
appropriate shortcut menu command. See Text objects on page 93.

See also

• Positioning and resizing objects on page 39

• Output format for fields and variables on page 53

Date and time stamps
You can add automatic date and time functions to the PageOUT sheet. These 
functions generate the date and time when the output is created.

To add a date or time stamp

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Date | Time.

3 On the sheet, click the position where you want to insert the stamp.

To configure a date or time stamp

In the Process view, right-click the date or time stamp object and select the 
appropriate shortcut menu command. See Text objects on page 93.

See also

• Positioning and resizing objects on page 39

• Output format for fields and variables on page 53

Advanced text
Advanced Text enables you to enter text with different fonts, color and size for 
different words in the text segment. You can include variables ($-prefix) in the 
text.

To add Advanced Text areas

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Advanced Text.

3 On the sheet, draw the boundaries for the text area and enter the text.

To configure an Advanced Text area

Right-click the advanced text area, and select the appropriate shortcut menu 
command. See Advanced Text on page 94.

To configure a text segment in an Advanced Text area

1 Select a text segment.
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2 Right-click the advanced text area, and select the appropriate shortcut menu 
command. See Advanced Text on page 94.

See also

• Moving a text segment (vertical shift) on page 30

• Specifying font properties for text segments on page 30

• Specifying a fixed width for empty text variables on page 30

• Cropping, wrapping and vertical alignment of an Advanced Text on page 31

• Positioning and resizing objects on page 39

• Hyphenating text on page 31

Moving a text segment (vertical shift)
You can shift text segments up or down.

To specify vertical shift of a text segment

1 Select the text segment.

2 Right-click the advanced text area, and select Vertical shift. The Vertical 
Shift dialog box opens.

3 Specify the vertical shift. See Vertical Shift dialog box on page 112.

Specifying font properties for text segments
1 Select the text segment.

2 Right-click the advanced text area, and select Font. The Font dialog box 
opens.

3 Specify the font properties. See Font dialog box on page 105.

Specifying a fixed width for empty text variables
For each variable in the Advanced Text area, you can specify a fixed width 
(points) that will be applied if the variable is empty in runtime.

To specify a fixed width

1 Select the variable (text segment).

2 Right-click the advanced text area, and select Alias attributes. The Text 
Alias dialog box opens.

3 Specify the fixed width.
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Cropping, wrapping and vertical alignment of an Advanced Text
You can configure how to handle cropping, vertical alignment, and wrapping of 
text in an Advanced Text area.

1 Right-click the Advanced Text area and select Properties. The Advanced 
Text Properties dialog box opens.

2 Specify the settings. See Advanced Text Properties dialog box on page 109.

Hyphenating text
1 Double-click the Advanced Text area and select the text to hyphenate.

2 Right-click and select Language. The Language dialog box opens.

3 Specify the settings. See Language dialog box on page 106.

Note: The language selected for hyphenation is independent from the language 
selected from the PageOUT menu bar.

Hyphenation exceptions

You can define exceptions to the general hyphenation rules for the selected 
language. Foreign language words and proper names, for example, are not 
covered by these rules. You define exceptions in an exception file. 

You must create one exception file per language and save it in the export 
directory. The file must have the extension .udct and be named according to the 
list of languages stated in the document talo_h_lib.pdf. This document is 
included in the installation CD. 

Images
You can add images (image resources as well as external image files) to the 
PageOUT sheet.

In this section

• Using image resources on page 31

• Using image files on page 32

• Dynamic selection of images on page 33

Using image resources
This type of image is the best choice if you want to add a static image, but if you 
want to use variables to determine which image to include in the output, you must 
use image files instead.

To be able to use image resources, these resources must be available in a resource 
set connected to the Message that includes the PageOUT Process. An image 
resource is added in its original size to the PageOUT sheet.
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To add an image resource

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Picture. The Select Image dialog box opens.

3 Select Select Resource and click OK. The Select Resource dialog box 
opens.

4 Select the image resource and click OK. The Insert Message Field dialog 
box opens.

5 Keep the default settings and click OK. The image is added to the upper left 
corner of the PageOUT sheet.

6 Drag the image to the appropriate position on the sheet.

7 Resize the image if needed.

To configure an image

In the Process view, right-click the image object and select the appropriate 
shortcut menu command. See Picture on page 97.

See also

• Using image files on page 32

• Dynamic selection of images on page 33

• Positioning and resizing objects on page 39

Using image files
You can add any external image file to the PageOUT sheet. When you add this 
type of image, you must specify the path to the image. 

The image added to the PageOUT sheet in this case is only an empty container for 
the image file, which means the actual image is not displayed on the sheet. The 
width and height of the image container is not determined by the image you want 
to add. This means you must specify the width and height manually – either by 
using static values or variables.

To add an image file – static selection

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Picture. The Select Image dialog box opens.

3 Select File name, enter the path to the image, and click OK. The Insert 
Message Field dialog box opens.

4 Keep the default settings and click OK. An image container is added to the 
upper left corner of the PageOUT sheet.

5 Right-click the image container and select Position. The Position dialog 
box opens.

6 Specify a static Width and Height for the image, or click Variables and 
specify variables for the Width and Height.
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7 Drag the image to the appropriate position on the sheet.

To configure an image

In the Process view, right-click the image object and select the appropriate 
shortcut menu command. See Picture on page 97.

See also

• Using image resources on page 31

• Dynamic selection of images on page 33

• Positioning and resizing objects on page 39

Dynamic selection of images
You can use scripting to dynamically determine which image to include in the 
output. This can be used for image files only, but not for image resources.

To add an image file – variable selection

1 In the Process view, select the top node or the appropriate block.

2 Select Insert > Picture. The Select Image dialog box opens.

3 Select File name, enter the image selection variable, and click OK. The 
Insert Message Field dialog box opens.

4 Keep the default settings and click OK. An image container is added to the 
upper left corner of the PageOUT sheet.

5 Right-click the image container and select Position. The Position dialog 
box opens.

6 Specify a static Width and Height for the image, or click Variables and 
specify variables for the Width and Height.

7 Drag the image to the appropriate position on the sheet.

To configure an image

In the Process view, right-click the image object and select the appropriate 
shortcut menu command. See Picture on page 97.

See also

• Using image resources on page 31

• Using image files on page 32

• Positioning and resizing objects on page 39

Lines and rectangles
You can draw lines and rectangles on the PageOUT sheet.
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To add a line or rectangle

1 In the Process view, select the top node or the appropriate block

2 Select Insert > Line | Rectangle.

3 On the sheet, draw the line or rectangle.

To configure a a line | rectangle

In the Process view, right-click the line or rectangle object and select the 
appropriate shortcut menu command. See Rectangle and Line on page 97.

See also

Positioning and resizing objects on page 39

Overlays
An overlay is a preprinted form with static information that you can add to any 
PageOUT configuration. You can create overlays with logotypes, labels, frames, 
etc. 

Overlays in different file formats can be used, see:

• Overlays – LXF type on page 34.

• Overlays – Printer type on page 35.

• Overlays – TIFF type on page 35.

To configure an overlay

In the Process view, right-click the overlay and select the appropriate shortcut 
menu command. See Overlay on page 97.

See also

Overlay management on page 49.

Overlays – LXF type

To create an overlay

1 Right-click the PageOUT sheet and select New Overlay. The Overlay 
Editor opens.

2 Create the overlay (see the Overlay Editor documentation). The overlay is 
added to a resource set connected to the Message.

3 In the resource set, rename the overlay resource.

You can also create the overlay starting from the resource set. See the Design 
Center documentation for information on how to create resources.

To add an overlay

The overlay must be added to a resource set connected to the Message.
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1 Right-click the PageOUT sheet and select Add Overlay. The Add Overlays 
dialog box opens.

2 In the Overlays list, check the overlay you want to add and click OK. The 
overlay is added to the PageOUT sheet.

Overlays – Printer type
You can create printer overlays with corresponding preview files for the 
PageOUT tool. The printer overlay is a PRN, PCL, or PS file sent separately to 
the printer, and the preview file can be any type of image file (EMF, WMF, JPEG, 
etc.).

To create an overlay

Any application that can save output as *.prn, *.pcl or *.ps can be used as an 
editor for printer overlays. If you want to preview the overlay in the PageOUT 
tool, you must also save the printer overlay as *.emf, *.wmf, *.gif, etc.

You must import the overlay and preview files to a resource set connected to the 
Message. 

To add an overlay

The overlay must be added to a resource set connected to the Message.

1 Right-click the PageOUT sheet and select Add Overlay. The Add Overlays 
dialog box opens.

2 Click Browse. The Select Resource dialog box opens.

3 Browse to, and select, the printer overlay resource. The PageOUT tool 
prompts you to select a preview file.

4 Click Yes. The Select Resource dialog box opens.

5 Browse to, and select, the preview resource. The preview overlay is added 
to the PageOUT sheet.

Overlays – TIFF type
Use an application that can save output in TIFF format to create the overlay. You 
can not create and edit TIFF overlays with the StreamServe tools. 

You must add the overlay to a resource set connected to the Message.

To add an overlay

The overlay must be added to a resource set connected to the Message.

1 Right-click the PageOUT sheet and select Add Overlay. The Add Overlays 
dialog box opens.

2 In the Overlays list, check the overlay you want to add and click OK. The 
overlay is automatically added to the PageOUT sheet.
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Charts
You can add bar charts, pie charts, and line charts to the PageOUT sheet.

See Charts on page 67 for details.

RFID inlays
Radio Frequency Identification (RFID) tags are used for automatic identification 
of individual items. You can mark the positions of RFID inlay chips and configure 
the inlays in the PageOUT tool. 

Inserted RFID inlays are visualized in the PageOUT tool to assist during label 
design. They are not printed in the output document. The reason why inlays are 
visualized is that objects placed on the leading and trailing edges of the inlay, or 
at the sides of the inlay, can not be scanned and are not printed, see figure below.

Figure 1 Label with RFID inlay

To mark the position of an RFID inlay

1 In the Process view, select the top node or the appropriate block

2 Select Insert > RFID, alternatively click the Insert RFID icon.

3 On the sheet, draw a rectangle to mark the position of the RFID inlay.

To configure an RFID inlay

In the Process view, right-click the RFID object and select the appropriate 
shortcut menu command. 

See also

• RFID Properties dialog box on page 118.
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The figure below shows a sample print command file and how data is retrieved 
from the values entered as RFID properties in the PageOUT tool.

Figure 2 Sample print command file
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Applying a PageIN/PreformatIN page layout
You can let the PageOUT tool automatically pick all frames, blocks, and fields 
defined in a PageIN or PreformatIN Event, and add them to the PageOUT 
configuration. 

1 Select Tools > Apply Page Layout. The Apply Page Layout dialog box 
opens.

2 Keep the default settings and click OK. The PageOUT tool automatically 
creates the frames and adds all blocks – including fields – to the frames.
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Positioning and resizing objects

Moving objects
You can use standard methods (point-click-move) to move an object. You can 
also specify the coordinates for the upper left corner of the object.

To move an object using coordinates

1 Right-click the object and select Position. The Position dialog box opens.

2 Specify the horizontal (X) and vertical (Y) coordinates, or click Variables 
and specify the same using variables. See Position dialog box on page 102.

Resizing objects
You can use standard methods (point-click-stretch) to expand or shrink an object. 
You can also specify the coordinates for the width and height of the object. If you 
use coordinates to resize a text object, you must first disable the Autosize option.

To specify width and height using coordinates

1 Right-click the object and select Position. The Position dialog box opens.

2 Specify the Width and Height, or click Variables and specify the same 
using variables. See Position dialog box on page 102.

To revert to the original size

Right-click the object and select Size to Content.

Aligning objects
You can align two or more objects. This applies to all objects on the PageOUT 
sheet. Text objects are aligned with respect to the anchoring position, and all other 
objects (including advanced text) with respect to the object border.

To align objects

1 On the sheet, select the objects.

2 Select Format > Align Objects > Left | Right | Top | Bottom.
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Managing overlapping objects
If you have overlapping objects on the PageOUT sheet, you can decide which 
objects to bring to the front, and which to send to the back.

To move an object to the front or to the back

1 On the sheet, select the object.

2 Select Format > Bring To Front | Send To Back.

To move an object one level

1 On the sheet, select the object.

2 Click the Bring Forward or Send Backward toolbar button.
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Using barcodes
You can add barcodes to the PageOUT sheet. The barcode data is either retrieved 
from the input data via a Field object, or added as a Static Text object. The 
composition of the barcode data, and allowed characters, depends on the type of 
barcode you intend to use.

The barcode field (Field or Static Text object) contains the barcode data as a string 
of characters. To create the actual barcode symbology, you must enable barcodes 
for the field, and select the appropriate barcode type.

To barcode enable a field

1 Right-click the barcode field and select Barcode. The Barcode dialog box 
opens.

2 Select Enable barcodes.

3 From the Barcode types drop-down list, select the appropriate barcode 
type.

4 Edit the settings. See the corresponding barcode specification for 
information.

5 Click OK.

Specification of barcode symbology

The specification of a barcode symbology includes the encoding of the single 
characters of the barcode data, the start and stop markers, the size of the quiet zone 
required before and after the barcode, and the computation of a checksum.

When output is delivered using PCL, Postscript, PDF, and AFP drivers, 
StreamServer creates the barcode symbology.

When output is delivered using label printer drivers, the label printer creates the 
barcode symbology. In this case, StreamServer delivers the information to be 
included in the barcode, the coordinates where to add the barcode, and the type of 
barcode to use.

Resizing barcodes

The width and height of the barcode in the output document depends on the 
specified barcode properties. There are a number of one-dimensional barcodes, 
where you can resize the height directly on the PageOUT sheet. For information 
whether the height is fixed or can be resized, see the corresponding barcode 
specification.
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To display barcodes correctly in design-time for upgraded Projects

1 Select Tools > Options.

2 In the Barcode style drop-down list, select Alternative style.

If you have upgraded a Project from Persuasion SP2, SP3, or SP4, the 
height of these barcodes may not be correctly displayed in the 
PageOUT tool. To display them correctly, see To display barcodes 
correctly in design-time for upgraded Projects on page 42.

In the Design Center platform export configuration, the argument 
-alternativebarcode will be automatically set for Projects upgraded 
from SP2, SP3, or SP4. This means the output will by default be 
correct, independently of this PageOUT tool setting.
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Creating hyperlinks
If you are using the PDF, RTF, or HTTP driver to produce output, you can create 
hyperlinks for text strings from Field and Static Text objects.

To create hyperlinks

1 Right-click the text object and select Hyperlink. The Hyperlink dialog box 
opens.

2 Edit the settings and click OK. See Hyperlink dialog box on page 104.
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Importing external texts
You can import texts from external sources to your output documents. For 
example, personalized marketing messages. Either you create texts in the 
StreamStudio Composer, or use texts available in lookup tables or variables. If 
you use an array variable, all variable values are inserted one after another.

In the Advanced Text area, you define from where to retrieve the external texts.

To import texts created in StreamStudio Composer

See the Composer User Guide for information.

To import texts from lookup tables or variables

1 Right-click in the Advanced Text area and select Properties.

2 Select the Import Text tab.

3 Configure the settings.
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Defining bookmarks
You define bookmarks to simplify navigation in PDF and AFP documents. In the 
PDF viewer, the generated bookmarks are listed on the bookmarks tab. In the AFP 
viewer, they are displayed as Tag Logical Elements (TLE) on page level. 

You can define bookmarks for a page and any object on the page, except for 
Overlays. Bookmarks defined for pages and objects are displayed as nodes in the 
Process view.

In the Advanced Text object you can define bookmarks for specific text segments. 
These bookmarks are indicated by markers in the text, and are not displayed in the 
Process view.

You can use variables and scripting to retrieve input data for the Advanced Text 
object. If the input contains bookmark definitions, the corresponding bookmarks 
are generated in the output.

To define a bookmark

1 Right-click the object and select Bookmarks. The Bookmarks dialog box 
opens.

2 Click Add new bookmark (the plus sign) to add the new bookmark.

3 Edit the settings and click OK. See Bookmarks dialog box on page 107.

To edit a bookmark

1 In the Process view, right-click the bookmark and select Edit.

2 Edit the settings and click OK. See Bookmarks dialog box on page 107.

To define bookmarks within an Advanced Text object

1 In the Advanced Text area, select a text segment or place the cursor where 
the bookmark should be defined.

2 Right-click and select Bookmarks. The Bookmarks dialog box opens.

3 Click Add new bookmark (the plus sign) to add the new bookmark.

4 Edit the settings and click OK. See Bookmarks dialog box on page 107. 

Organizing bookmarks
To show the relationship between data in the PDF document, you can group 
related bookmarks under parent bookmarks. Use the bookmark Level property to 
build the bookmark hierarchy, see Example: Grouping bookmarks on page 46. 
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When you build the hierarchy, be aware that the bookmarks are generated in the 
same order as the data is processed. The bookmark Level property must be 
consistent with that order:

• A level 1 bookmark must be followed by a level 1 or level 2 bookmark.

• A level 2 bookmark must be followed by a level 1, 2 or level 3 bookmark. 
This pattern continues throughout all bookmark levels.

To display identical bookmarks in the output, enable the Repeat identical 
bookmark property, see Example: Displaying identical bookmarks on page 47.

Example: Grouping bookmarks
The following example shows how to use the Level property to group bookmarks 
in the bookmark hierarchy. The input contains the following data:

In this example, one bookmark is generated per row in the input data, except for 
the second row where the bookmark is identical to the first row’s bookmark. The 
bookmark hierarchy in the PDF viewer will look like this:

1 In the Event tool, define variables for the Manufacturer and Model items 
($manufacturer and $model).

2 In the PageOUT tool, select the Manufacturer item and define a bookmark 
with the following settings:

Manufacturer Model

Volvo S80

Volvo S80

Volvo XC90

Toyota Corolla

Toyota Prius

Volvo S80

Name Value Level Format Repeat identical 
bookmarks

Manufacturer $manufacturer 1 %1 - %2 Not selected
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3 Select the Model item and define a bookmark with the following settings:

Example: Displaying identical bookmarks
The following example shows the effect of selecting the Repeat identical 
bookmarks property. The input contains the following data (the same as in 
Example: Grouping bookmarks on page 46):

In this example, one bookmark is generated per row in the input data, including 
an identical bookmark for row two. The bookmark hierarchy in the PDF viewer 
will look like this:

1 In the Event tool, define variables for the Manufacturer and Model items 
($manufacturer and $model).

2 In the PageOUT tool, select the Manufacturer item and define a bookmark 
with the following settings:

Name Value Level Format Repeat identical 
bookmarks

Model $model 2 %1 - %2 Not selected

Manufacturer Model

Volvo S80

Volvo S80

Volvo XC90

Toyota Corolla

Toyota Prius

Volvo S80

Name Value Level Format Repeat identical 
bookmarks

Manufacturer $manufacturer 1 %1 - %2 Not selected
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3 Select the Model item and define a bookmark with the following settings:

Name Value Level Format Repeat identical 
bookmarks

Model $model 2 %1 - %2 Enabled
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Overlay management
An overlay is a preprinted form with static information that you can add to any 
PageOUT configuration. You can create overlays with logotypes, labels, frames, 
etc.

The following types of overlays can be used:

• LXF Overlays, see Overlays – LXF type on page 34.

• Printer overlays, see Overlays – Printer type on page 35.

• TIFF overlays, see Overlays – TIFF type on page 35.

Dynamic selection of overlays
If you add one or more overlays to a page type in a PageOUT configuration, these 
overlays will be the default overlays included in the output. For each overlay, you 
can use aliases to dynamically select alternative overlays.

Prerequisites

All overlays must be included in the same resource set as the default overlay.

To specify overlay aliases

1 In the Process view, right-click the overlay and select Properties. The 
Overlays dialog box opens.

2 Specify the Alias settings and click OK. See Overlays dialog box on page 
116.

Offsetting overlays
If you want to adjust the offset of an overlay, you must enable this in the 
PageOUT tool. Then you use the SetXoffs and SetYoffs scripting functions to 
define the offset, see the Scripting reference.

To enable offset adjustment

1 In the Process view, right-click the overlay and select Properties. The 
Overlays dialog box opens.

2 Select Offset adjustment.

Printing overlays on the reverse side of a sheet
If you want to print static information on the reverse side of a sheet, you can add 
a verso overlay. Note that the verso overlay is the only information that will be 
printed on the reverse side.
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Prerequisites

• The printer must be able to handle duplex printing.

• The driver option duplex must be set at either Job Begin or Document 
Begin.

To add a verso overlay

1 Add the overlay to the PageOUT configuration.

2 In the Process view, right-click the overlay and select Properties. The 
Overlays dialog box opens.

3 Select Verso.

Multi-page overlays
You can add multi-page overlays in LXF and TIFF formats to the PageOUT 
configuration. All overlay pages can be used in the output, or you can select 
specific overlay pages when you configure the PageOUT sheet. For example, if 
you have a PageOUT configuration with the page types First, Body and Last you 
can select which overlay page to use on each page.

You can use variables and scripting, for example the CallProc scripting function, 
to dynamically select or suppress overlay pages. See the Scripting reference. 

The total number of overlay pages is displayed in the title bar of the Overlays 
dialog. Use the OverlayGetNumPages scripting function to dynamically count the 
pages, see the Scripting reference. 

To select pages from a multi-page overlay

1 In the Process view, select the PageOUT sheet where you want to add the 
overlay and right-click Overlays.

2 Select Add overlay.

3 Select the multi-page overlay.

4 In the Process view, right-click the overlay and select Properties.

5 Select Page number for the overlay page that you want to use on the sheet.
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Invoking free blocks
Ordinary blocks are defined in the Event. A free block is defined in the PageOUT 
tool, and can be edited the same way as ordinary blocks. You can use a free block 
to, for example, add text before and after a page break. A free block can be 
invoked using the CallBlock scripting function or by frame and block properties.

See also Free blocks on page 26.

Invoking using block and frame properties
You can use block and frame properties to invoke a free block.

Frame properties – invoke a free block...

Before frame Before all blocks in the frame.

After frame After all blocks in the frame.

Before overflow At the bottom of the frame on the current page before a 
page break.

After overflow At the top of the frame on the following page after a page 
break.

Block properties – invoke a free block...

Before first 
instance

Before the first instance of a block.

After last instance After the last instance of a block.

After block 
children

After the last instance of any block children. If the block 
has no children, the free block will be invoked after each 
instance of the main block.
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To invoke a free block using block properties

1 In the Process view, right-click the block and select Block Properties. The 
Output Block Properties dialog box opens.

2 On the General Settings tab, in the appropriate Free blocks field, enter the 
name of the free block to invoke.

To invoke a free block using frame properties

1 In the Process view, right-click the frame and select Frame Properties. The 
Frame Properties dialog box opens.

2 In the appropriate Free blocks field, enter the name of the free block to 
invoke.

Invoking using the CallBlock scripting function
Free blocks can also be invoked using the scripting function CallBlock. For 
example, you can create a Before script on a block that dynamically selects which 
free block to insert. See the Scripting reference.

Before overflow At the bottom of the frame on the current page before a 
page break.

After overflow At the top of the frame on the following page after a page 
break.

Block properties – invoke a free block...
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Output format for fields and variables
In the Event tool, you can configure fields and variables to handle numeric or date 
formatted data. Which format to use is determined by the input data. In the 
PageOUT tool, you can specify which format to use for the output from the 
corresponding field or variable. You can use the same format as specified in the 
Event tool, or you can select a new format.

For example, if the input is 02/08/12, and you want to change this to 08.12.02 
in the output, you must first specify the format yy/mm/dd in the Event tool. Then 
specify the new output format, mm.dd.yy, in the PageOUT tool. 

Format tables

Numeric and date formats are made available through format tables. Before you 
specify any formats, you must add a format table to a resource set connected to 
the Message. You can import Formats.txt from 

<StreamServe 
installation>\Applications\StreamServer\<version>\Tools\Samples

to the resource set.

The first time you specify a format, a resource selection dialog box opens. In this 
dialog box you must browse to and select the format table you want to use. This 
table will be selected by default the next time you specify a format for any of the 
fields or variables in the PageOUT configuration.

To select a new numeric | date format for a field or variable

1 Right-click the object and select Format. The Formats dialog box opens.

2 Select the Numeric | Date category.

3 Double-click the new Format.

To add a new format

In the Formats dialog box, in the Format field, enter the new format and click 
Add. You can also add new formats directly to the format table resource. See 
Formats dialog box on page 108
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Defining page breaks
For each block, you can define where to generate a page break when an instance 
of a block causes a frame overflow.

Comments

• If the block has Use line enabled, the two last modes will behave as for the 
Break between blocks mode.

• The following types of free blocks can generate page breaks: before first 
instance, after last instance, and blocks invoked by the callblock scripting 
function.

• If you are using a PageIN Event, you must select Event Order Repeating 
when you configure the Event settings in the Message window.

• The StreamServer must run licensed if you use the modes Break between 
blocks, Break between fields, and Break between lines in fields. Only 
the Default mode works if you run the StreamServer in demo mode.

To define page breaks

1 In the Process view, right-click the block and select Block Properties. The 
Output Block Properties dialog opens.

2 On the Frame Overflow tab, select page break mode. See Frame Overflow 
tab on page 116.

Widow and orphan rows
When you select the page break mode Break between lines in a field, you also 
enable the property Overflow zone boundary.

The window between the Overflow zone boundary and the bottom of the frame 
determines how many lines to move to the next page, and prevents the 
StreamServer from generating widow and orphan lines in the output.

If you want to break between lines in a field between different page types, you 
must select the Suppress frame overflow zone synchronization option on the 
page type where the text overflows to, see Page Setup dialog box on page 98.
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To move the Overflow zone boundary

1 In the Process view, right-click the frame and select Frame Properties. The 
Frame Properties dialog opens.

2 In the Overflow zone boundary field, specify the distance (in grid units) 
from the top of the frame. You can also use a variable to determine the 
distance.

Examples

Example 7 Paragraph begins below the Overflow zone boundary

A paragraph begins below the Overflow zone boundary, and generates an 
overflow. 

The entire paragraph (red text) is moved to the next page.

Example 8 Less than four lines in a paragraph

A paragraph contains three lines and generates an overflow. The paragraph does 
not begin below the Overflow zone boundary.

The entire paragraph (red text) is moved to the next page.
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Example 9 Four lines or more in a paragraph

A paragraph contains four lines and generates an overflow. The paragraph does 
not begin below the Overflow zone boundary.

The two last lines (red text) are moved to the next page, i.e. there will be at least 
two lines on each page.
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Sorting
You can use sort keys to specify the order in which block data is added to the 
output. If no sort keys are used, data is added in the same order as specified in the 
Event configuration, i.e. in the same order as in the Message.

To specify sort keys for a block

1 In the Process view, right-click the block and select Block Properties. The 
Output Block Properties dialog box opens.

2 In the Criteria field, edit the sort criteria and click OK.

Syntax

"<field>":"<type><order>"

For example:

"customer_name":"SA"

<type> is either S (alpha-numeric) or N (numeric)

<order> is either A (ascending) or D (descending)

Multiple sort keys

Multiple sort keys are separated with spaces. Data is sorted according to the first 
key. Block instances that equally fulfill the first sort are sorted according to the 
next key, and so on.

Example 10 Sort keys for the fields name and age
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Mirroring page layouts
You can use variables in input data to mirror the positions of objects, and the 
alignment of text within text objects, according to the figure below.

Disabling mirroring of an object

All objects are by default mirror enabled. If you want to mirror enable the Process 
as a whole, and there are some objects you do not want to mirror, you can disable 
mirroring for those objects:

1 Right-click the object and select Position. The Position dialog box opens.

2 Uncheck the Mirror option and click OK.

Keeping the text alignment in a text object

You can select to keep the original text alignment (not applicable to Advanced 
Text) when mirroring the object layout. The wrapping option for the text object 
must be either Clip or Wrap.

1 Right-click the object and select Alignment. The Alignment dialog box 
opens.

2 Select Keep alignment.

To enable mirroring of the Process output

1 In the Runtime configuration, right-click the PageOUT Process and select 
Settings. The Runtime Process Settings dialog box opens.

2 On the General tab, specify the mirror settings and click OK.

Mirror settings

Mirror PageOUT Select to enable mirroring.

Mirror variable Enter the mirror variable. If the variable returns 1, the 
layout will be mirrored, and if it returns 0 the layout will 
not be mirrored. If no variable is specified, the layout will 
always be mirrored.
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Language handling
A StreamServer application can deliver documents in different languages. If, for 
example, the input consists of invoices in several languages, all these invoices can 
be managed by the same PageOUT Process.

Code page issues

To be able to handle several languages in the same Project, you must use a code 
page that applies to all languages in the input.

Input data

The input data is mapped to fields in the Event, and the fields are added to the 
PageOUT Process. The contents of each field is retrieved from the input, which 
means you can use the same fields irrespective of the language.

Text labels

In the PageOUT tool, you can add text labels to the output. When you create the 
labels, you enter the text in the “default language”. This means you must be able 
to change the text labels dynamically with respect to the language in the input 
data. For example, if the “default language” is english, and the language in the 
input data is german, you must dynamically change the text labels to german. To 
be able to do this, you must use a language file. See Language files on page 60.
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Language files
A language file is a table resource that must be available to the PageOUT Process 
via a resource set connected to the Message. The language file contains the 
following columns:

• Label ID – A unique ID for each label.

• Language code – The language code for the label. These language codes 
will be used in a before Process script to dynamically select language.

• Label text – The label text for the corresponding language code.

Figure 3 Language file with Label ID, language code, and label text columns.

The language file example above contains entries for five labels (five english 
entries and five swedish entries). Note that the label IDs are the same for both 
languages.

Creating language files
When you create a language file, you start by creating an empty table resource. 
You create this resource in a resource set connected to the PageOUT Process you 
want to configure. Then you export the label entries (label ID, language code, and 
label text of the default language) from the PageOUT tool to the language file. 
Finally you copy-paste all label entries in the language file, and change the 
language code and label text of the new entries.

Setting the default language code
Before you export the label entries from the PageOUT tool, you must set the 
default language code. You can use any code that is unique for the language. For 
example EN for english or SV for swedish.

//!CodePage UTF8!

7696c1fe-e8b2-4404-a4a1-130b0b802b6d    EN    Invoice

0982a31a-826d-4df5-b916-25ffb07c011e    EN    Invoice number

7a255d5d-74bb-4402-9b92-5e5507009fc9    EN    Invoice date

c6975a58-b975-426b-b2b0-71b597684eb9    EN    Payment due date

931eaaa9-8931-4467-b420-deb98da01670    EN    Amount to pay

7696c1fe-e8b2-4404-a4a1-130b0b802b6d    SV    Faktura

0982a31a-826d-4df5-b916-25ffb07c011e    SV    Fakturanummer

7a255d5d-74bb-4402-9b92-5e5507009fc9    SV    Fakturadatum

c6975a58-b975-426b-b2b0-71b597684eb9    SV    Förfallodag

931eaaa9-8931-4467-b420-deb98da01670    SV    Att betala
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To set the default language code

1 Open the PageOUT tool.

2 Select Tools > Options. The Options dialog box opens.

3 In the Language code field, enter the language code and click OK.

Setting the label IDs
Before you export the label entries from the PageOUT tool, you must set the label 
IDs for all labels.

To set the label ID for a label

1 In the PageOUT Process browser, right-click the label and select Set ID. 
The Edit Label ID dialog box opens.

2 Click Generate ID and OK.

Note: The Generate ID function ensures that all label IDs are unique. You can 
also manually enter your own IDs, but you must make sure all IDs are 
unique.

Exporting the label entries to the language file
When you have specified the default language code and all label IDs, you can 
export the label entries to the language file.

To export the label entries

1 Select Tools > Export Language File. The resource browser opens.

2 Browse to, and double-click, the language file resource.

Adding new language entries to the language file
The language file only contains the label entries of the default language after the 
export from PageOUT. You must add label entries for other languages manually 
to the language file.

To add new label entries to the language file

1 Open the table file in the resource editor.

2 Copy all default language entries, and paste them to the language file.

3 Edit the language code and label texts of the new entries.

Note: You must not change the label IDs.

Previewing the labels in the PageOUT tool
You can preview the labels in the PageOUT tool. To do this, you specify the 
language to preview, and load the language file in the PageOUT tool.
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To preview the labels

1 Select Tools > Options. The Options dialog box opens.

2 In the Language code field, enter the language code of the language to 
preview and click OK.

3 Select Tools > Load Language File. The resource browser opens.

4 Browse to, and double-click, the language file resource. The labels changes 
to the text entries that corresponds to the selected language code.

Using language files
To be able to use language files, you must set the startup argument -langfile. 
You must also create a before Process script that uses field reference or variable 
values in the input data, and the language codes in the language file, to 
dynamically select the appropriate label texts.

Setting the -langfile startup argument
The startup argument -langfile instructs the StreamServer application to use 
language files, and specifies the path to the language file.

The path to the language file is normally ..\data\tables\<languagefile>, 
where <languagefile> is the name of the language file resource you created in 
Design Center. This means the exported language file is deployed to 
..\data\tables relative to the StreamServer application’s working directory.

You can also extract the language file resource to any directory, and use the 
absolute path to this directory when you set the -langfile argument.

To set the -langfile startup argument

1 In the Design Center Project browser, double-click the appropriate physical 
Platform layer node. The selected layer is activated in the Platform view.

2 Right-click the Platform view and select Configure Export. The Configure 
Platform Export dialog box opens.

3 Check the -langfile argument and enter the path to the language file, for 
example:

..\data\tables\langfile

4 Click OK.
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Creating the before Process script
The language codes in the language file are used as keys to dynamically select the 
appropriate label texts. To be able to use these keys, you must create a before 
Process script. This script must include the following:

• A field reference or variable that contains a unique language identifier, for 
example a country code.

• The script function setLanguage.

Example 11 Before Process script

switch(&countryCode)

{

    case "USA":

        setLanguage("EN");

    break;

    case "Sverige":

        setLanguage("SV");

    break;

    default:

        setLanguage("EN");

}
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Previewing output
You do not have to export and run the whole StreamServe Project each time you 
want to check how changes in the PageOUT configuration affects the output. You 
can instead preview the output from the PageOUT tool.

Input samples

Before you run the preview, you must create an input data sample that you add to 
a resource set available to the PageOUT tool.

To configure preview options

1 Select Tools > Preview Options. The Preview Paths dialog box opens.

2 Enter the preview settings and click OK. In most cases it is sufficient to 
specify the input sample resource and enter -demo as additional startup 
argument. See Preview Paths dialog box on page 101 for a full description 
of the settings.

To preview the output

Select Tools > Preview. The output page is displayed in the Document preview 
pane.
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Unlinked blocks and fields
If a field or block is removed from the Event configuration, the corresponding 
fields in the PageOUT configuration are not removed. Instead the links are 
broken. 

Exporting data from unlinked fields

You can configure unlinked fields to be exported as variables, static text, or not 
at all. You can select Tools > Default Unlinked Export and set export options 
that apply to all unlinked fields. You can also set the export settings separately for 
each unlinked field by right-clicking the field and selecting Unlinked Export.

See Set Unlinked Field Properties dialog box on page 100.

Deleting unlinked objects

You can delete the unlinked objects separately. You can also select Tools > 
Delete all Unlinked Objects to delete all unlinked objects at the same time.
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You can add bar charts, pie charts, and line charts to the PageOUT sheet.

The items presented in a chart consist of value pairs – a Label (for example, an 
article) and a Value (for example, the number of articles sold). A chart can be 
based on a fixed or a variable number of value pairs. For example, if you create a 
chart based on fields defined in a block, you may not know how many value pairs 
the chart will include.

Variable number of value pairs

To create a chart based on a variable number of value pairs, you use a pair of 
arrays, one with Labels and the other with Values. You first define variables for 
the Labels and the Values, and then you create the arrays.

You define the variables in the Event tool. How to create the arrays depends on 
the type of Event used. If you use a PageIN or PreformatIN Event, you must create 
a script in the PageOUT Process that generates the arrays. If you use a StreamIN 
or XMLIN Event, you can select a block property in the Event tool to create arrays 
automatically.

Note: You can also create charts based on value pairs other than from an Event. 
For example, you can create a chart based on value pairs stored in a 
database. You first fetch the variables from the database, and then you 
create a script in the PageOUT Process to generate the arrays.
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Example: Fixed number of items from a 
PageIN Event

In this example, you create a chart for three types of articles showing the name of 
the article (Label), and the number of articles sold (Value) during a month.

Assigning variables in the Event

This example uses a PageIN Event containing fields with article names, and fields 
with the number of articles sold. 

Assign a variable to each name field and each amount field.

Adding variables to the Process

In the Chart Properties dialog box, add a new item for each article, and enter the 
Value and Label variables.
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Example: Variable number of items from a 
PageIN Event

In this example, you create a chart for different types of articles showing the name 
of the article (Label), and the number of articles sold (Value) during a month.

The article items are defined in a block in the PageIN tool, which means you 
cannot tell how many items to include in the chart. You must therefore create a 
script that generates an array for the values, and another array for the labels.

Assigning variables in the Event

This example uses a PageIN Event containing the block Articles. This block has 
one field for the article name, and one field for the number of articles sold.

Assign a variable to the name field ($label_article), and another variable to the 
amount field ($value_article).

Creating arrays in the Process

Add the following script to the Articles block in the PageOUT Process:

$arr_label_article[$i]=$label_article;
$arr_value_article[$i]=$value_article;
$i++;

The script generates one array for the values, and one array for the labels.

Making sure that the arrays contain all required values

Before the chart is generated, you must make sure that the arrays contain all 
required values. How you do this will depend on what data you want to include 
in the chart. In this example, you first insert the chart in a free block inserted 
directly on the PageOUT sheet. You then call the free block after the frame that 
includes the Articles block.

Adding variables to the Process

Add a new item in the Chart Properties dialog box. Select the Array option, and 
enter the Value ($arr_value_article) and Label ($arr_label_article) 
variables.
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Example: Variable number of items from a 
StreamIN Event

In this example, you create a chart for different types of articles showing the name 
of the article (Label), and the number of articles sold (Value) during a month.

The article items are defined in a block in the StreamIN tool, which means you 
cannot tell how many items to include in the chart. By enabling the array function 
for the block, the arrays are automatically created for the data.

Assigning variables in the Event

This example uses a StreamIN Event containing the block Articles. 

Select Array type = Yes when defining the properties for the Articles block. 

The Articles block has one field for the article name, and one field for the number 
of articles sold. Assign a variable to the name field ($label_article), and 
another variable to the amount field ($value_article).

Making sure that the arrays contain all required values

Before the chart is generated, you must make sure that the arrays contain all 
required values. How you do this will depend on what data you want to include 
in the chart. In this example, you first insert the chart in a free block inserted 
directly on the PageOUT sheet. You then call the free block after the frame that 
includes the Articles block.

Adding variables to the Process

Add a new item in the Chart Properties dialog box. Select the Array option, and 
enter the Value ($value_article) and Label ($label_article) variables.
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Adding and editing charts
You can add charts directly to the PageOUT sheet, to a frame, or to a free block.

To add a chart

1 In the Process view, select the object to which you want to add the chart.

2 Click the Chart toolbar button.

3 Outline the area on the PageOUT sheet where you want to insert the chart. 
The Chart Properties dialog box opens.

4 Configure the chart.

5 Click OK.

To edit a chart

1 Double-click the chart. The Chart Properties dialog box opens.

2 Edit the chart.

3 Click OK.

Selecting chart types
In the Chart Properties dialog box, from the Chart type list, select one of the 
following chart types:

• Bar chart

• Line chart

• Pie chart

Defining chart borders
You can create a border to surround the chart.

To set the border width

In the Chart Properties dialog box, in Lines area, in the Width text box, enter the 
border width (in millimeters).

To set the border color

In the Chart Properties dialog box, in Lines area, select a color from the Color list, 
or select a custom color by clicking Palette.

Labelling charts
You can add a label to the chart.
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To add a label

In the Chart Properties dialog box, in the Label box, enter a name for the label.

To select font for the label

In the Chart Properties dialog box, click Set font and select font, style, size, color 
etc.

To position the label

In the Chart Properties dialog box, in the Label position area, select Upper or 
Lower. The label is positioned above or below the chart.

Adding chart items
You must add all items you want to use in the chart to the table at the bottom of 
the Chart Properties dialog box. If the input is an array, you add the array as a 
single item. If the input is not an array, you add a new row for each item.

Prerequisites

Before you add items to a bar or a line chart, you must select Chart items from 
the View list.

To add an item

In the Chart Properties dialog box, click the New button. An item is added to the 
Chart items table. For information on how to configure the value and label, see:

• Defining bar chart values and labels on page 80.

• Defining line chart values and labels on page 82.

• Defining pie chart values and labels on page 85.

To enable array input to the chart

If you use arrays as input to the chart, you must select the Array option.

To combine two or more series of data in the same chart, you can add several table 
rows with arrays.
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Rotating labels
You can rotate the labels in bar and line charts.

To rotate a label

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Rotate cell.

2 Enter the rotation angle (0-360 degrees counter-clockwise).

Aligning labels
You can align the position of labels in bar and line charts. Use the following 
columns in the Chart items table in the Chart Properties dialog box:

• Horizontal pos sets the horizontal position for the label:

– Left

– Center

– Right

• Vertical pos sets the vertical position for the label:

– Top

– Center

– Bottom

To align labels

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Horizontal pos or Vertical pos cell.

2 Select an option from the list.

Specifying label fonts
You can specify which font to use for labels attached to chart items, support lines, 
and X/Y-axes.
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To specify label fonts

1 For bar charts and line charts, select the item in the table (Chart items, 
Support lines, or X/Y-axis) in the Chart Properties dialog box.

2 Click Set font right above the table.

3 Enter the font settings.

4 Click OK.

Specifying label formats
You can specify which format to use for labels attached to chart items, support 
lines and X/Y-axes. You can, for example, change the format for support line 
labels from 10 to 10.0, from 10.0 to 10,00 etc.

For information about the Formats dialog box and data formats, see Output format 
for fields and variables on page 53.

To specify label formats

1 For bar charts and line charts, select the item in the table (Chart items, 
Support lines, or X/Y-axis) in the Chart Properties dialog box.

2 Click Format. The Formats dialog box opens.

3 From the Category list, select the type of formatting. The available formats 
are displayed.

4 Select the new format.

5 Click OK.

Defining logical graph coordinates
The area that you outline when you insert a chart determines the physical 
dimensions of the chart.

You use logical graph coordinates to translate the absolute units of the physical 
area (in millimeters) to relative units. This enables you to adjust the chart to the 
input data.

For more information, see:

• Defining coordinates for bar charts on page 78.

• Defining coordinates for line charts on page 81.

• Defining coordinates for pie charts on page 84.

Creating support lines
You can create support lines in bar and line charts.
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To create support lines

1 In the Chart Properties dialog box, from the View list, select Support lines.

2 Click the New button.

3 In the Support lines table, configure the support lines by double-clicking the 
corresponding cell and entering a value. For support line properties, see 
Support line properties on page 128.

Creating X-axes
You can create one or more X-axes in bar and line charts. 

To create an X-axis

1 In the Chart Properties dialog box, from the View list, select X-axis.

2 Click the New button.

3 In the X-axis table, configure the X-axis by double-clicking the 
corresponding cell and entering a value. For X-axis properties, see X-axis 
properties on page 129.

Creating Y-axes
You can create one or more Y-axes in bar and line charts.

To create a Y-axis

1 In the Chart Properties dialog box, from the View list, select Y-axis.

2 Click the New button.

3 In the Y-axis table, configure the Y-axis by double-clicking the 
corresponding cell and entering a value. For Y-axis properties, see Y-axis 
properties on page 131.

Defining bar, pie slice, and line segment colors
You can select which color to use for bars, pie slices, and line segments in a chart.

For non-array elements, you can select a specific color for each chart item. For 
array elements, you can define a color interval that will be applied to the chart 
items.

Selecting colors for non-array elements
1 In the Chart Properties dialog box, in the Chart items table, double-click the 

Fill cell.

2 Select a color from the list.
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Selecting colors for array elements
You define the color settings for arrays on the Array Options tab in the Chart 
Properties dialog box. If you do not define any color settings, gray scale shading 
will be used.

To select a single color for all chart items

Figure 4 Output using a single color and no shading

1 Click the Array Options tab.

2 Clear Automatic color shading.

3 Click the New button. A new color item is added to the list.

4 Double-click the color item and edit the color.

To select multiple colors for the chart items

You can use multiple colors for chart items. The first color you define is used for 
the first item, the second color is used for the next item etc. When all colors have 
been applied, the first color is used for the next item etc.

Figure 5 Output using two colors and no shading

1 Click the Array Options tab.

2 Clear Automatic color shading.
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3 Click the New button. A new color item is added to the list.

4 Double-click the color item and edit the color.

5 Repeat steps 3 and 4 for each new color you want to add.

To enable automatic color shading

You can enable automatic shading of the colors you have added to the list. You 
use a shading offset value to define how much the shade will change between 
iterations – the lower the value, the smaller the change, and more shades are 
available.

If you use a single color, this color is used for the first item. The color is then 
gradually shaded, until no more shades are available. Then the original color is 
applied again.

Figure 6 Output using a single color and automatic color shading

If you use two or more colors, each of the original colors are applied in the order 
in which they appear in the list. Then shades of the original colors are applied in 
the same order.

Figure 7 Output using two colors and automatic color shading

1 Click the Array Options tab.

2 Select Automatic color shading.

3 Enter a Shading offset value.
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Bar chart specifics
This section covers the following topics:

• Defining coordinates for bar charts on page 78.

• Defining margins, bar width, and bar gap on page 79.

• Defining bar chart values and labels on page 80.

• Defining line widths of bar borders on page 80.

Defining coordinates for bar charts
The logical graph coordinates (Y-axis) are used to adjust the input data to the 
physical dimensions of the chart on the PageOUT sheet, so that the bars are kept 
within the chart.

Make sure that the interval you set for the Y-axis covers the interval between the 
lowest and highest values in the input data. Also make sure that the interval is not 
too large. The following examples illustrate how you can set the interval for the 
Y-axis:

• If the input data ranges from -50 to 50, set the interval for the Y-axis 
between -60 and 60.

• If the input data ranges from 0.2 to 0.5, set the interval for the Y-axis 
between 0.1 and 0.6.

You use the logical graph coordinates (X-axis) to define margins, bar width, and 
bar gap in relative units. See Defining margins, bar width, and bar gap on page 
79.

To define the logical graph coordinates - basic mode

In basic mode, you define the logical graph coordinates along the Y-axis. The 
logical graph coordinates along the X-axis span from 0 to 100 and cannot be 
changed.

1 In the Chart Properties dialog box, enter the largest y-value in Max value.

2 Enter the lowest y-value in Min value.

To define the logical graph coordinates - advanced mode

In advanced mode, you define the logical graph coordinates both along the Y- and 
X-axes.

1 In the Chart Properties dialog box, select Advanced options.

2 Enter the largest y-value in Y high.

3 Enter the lowest y-value in Y low.

4 Enter the largest x-value in X high.

5 Enter the lowest x-value in X low.
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To draw bars from the lowest y-value

By default, bars are drawn from Y-value 0. If you want to create a more 
differentiated chart, you can draw the bars from the lowest Y-value (Min value or 
Y low) instead.

Figure 8 Drawing bars from lowest y-value

1 In the Chart Properties dialog box, enter the lowest Y-value in Min value or 
Y low.

2 Select Draw from min value.

Defining margins, bar width, and bar gap
In the Chart Properties dialog box, use the following fields to define margins, bar 
width, and bar gap:

If the Absolute option is selected, the units are in millimeters. Otherwise the units 
are relative to the logical graph X-axis.

Example 12 Relative units

In this example, the bar width is set to 10 units. The table below shows the bar 
width (% of X-axis) for three different X-axis settings.

Left margin The distance between the first bar and the left side of 
the chart.

Right margin The distance between the last bar and the right side of 
the chart.

Bar width The width of each bar.

Bar gap The distance between two bars.

Span 
(X-axis)

Units total
(X-axis)

Bar width 
(% of X-axis)

0...100 100-0=100 10/100=10%

0...50 100-50=50 10/50=20%

-10...50 50+10=60 10/60=16.7%
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Defining bar chart values and labels
You must define a value and a label for each bar in the bar chart. Use the 
following columns in the Chart items table:

• Value is the height of the bar and is retrieved from the input data.

• Label is the label of the bar and is retrieved from the input data.

To define values and labels

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Value or Label cell.

2 Enter the value.

Defining line widths of bar borders
You can define the line width of the bar border.

To define the line width

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Outline cell.

2 Enter the value (in millimeters).
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Line chart specifics 81
Charts
Line chart specifics
This section covers the following topics:

• Defining coordinates for line charts on page 81.

• Defining line chart values and labels on page 82.

• Defining line widths of line graphs on page 82.

• Defining line styles for line graph on page 82.

• Connecting lines in line graphs on page 83.

Defining coordinates for line charts
The logical graph coordinates (X- and Y-axis) are used to adjust the input data to 
the physical dimensions of the chart on the PageOUT sheet, so that the line graph 
is kept within the chart.

Make sure that the intervals you set for the X- and Y-axis cover the interval 
between the lowest and highest values in the input data. Also make sure that the 
interval is not too large. The following examples illustrate how you can set the 
interval for the X- and Y-axes:

• If the input data ranges from 0 to 1000 in the X-dimension, and from -50 to 
50 in the Y-dimension, set the interval for the X-axis between 0 and 1100, 
and for the Y-axis between -60 and 60.

• If the input data ranges from 0 to 100 in the X-dimension, and from 0.2 to 
0.5 in the Y-dimension, set the interval for the X-axis between 0 and 110, 
and for the Y-axis between 0.1 and 0.6.

To define logical graph coordinates - basic mode

In basic mode, you define logical graph coordinates along the Y-axis. The logical 
graph coordinates along the X-axis span from 0 to 100 and cannot be changed.

1 In the Chart Properties dialog box, enter the largest y-value in Max value.

2 Enter the lowest y-value in Min value.

To define logical graph coordinates - advanced mode

In advanced mode, you define logical graph coordinates both along the Y- and X-
axes.

1 In the Chart Properties dialog box, select Advanced options.

2 Enter the largest Y-value in Y high.

3 Enter the lowest Y-value in Y low.

4 Enter the largest X-value in X high.

5 Enter the lowest X-value in X low.
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Defining line chart values and labels
You must define an X/Y-value and a label for each input data item in the line 
chart. Lines are drawn between the value pairs.

Use the following columns in the Chart items table:

• Value is the Y-coordinate and is retrieved from the input data.

• X is the X-coordinate and is retrieved from the input data.

• Label is the label of the item and is retrieved from the input data.

To define values and labels

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Value or X or Label cell.

2 Enter the value.

Defining line widths of line graphs
You can define the line width of line graph.

To define the line width

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Outline cell.

2 Enter a value (in millimeters).

Defining line styles for line graph
You can specify a line style for the line graph.

To select line style

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Line style cell.

2 Select a line style from the list.
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Connecting lines in line graphs
You can use a dot or a square to connect lines. 

The following applies when you specify the size:

• Dot – The Size value is multiplied by half of the line width (Outline value) 
to give the diameter of the dot.

• Square – The Size value is multiplied by half of the line width (Outline 
value) to give the side of the square.

To connect lines

1 In the Chart Properties dialog box, select Connect lines width.

2 Select Dot or Square.

3 In the Size box, enter the size of the dot or square.
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Pie chart specifics
This section covers the following topics:

• Defining coordinates for pie charts on page 84.

• Defining pie chart center on page 84.

• Changing pie chart angles, rotations, and heights on page 85.

• Defining pie chart values and labels on page 85.

• Emphasizing slices in pie charts on page 86.

• Defining line widths of pie contours on page 87.

• Arranging pie slice labels on page 87.

Defining coordinates for pie charts
You use the logical graph coordinates to position the pie chart center, and define 
pie chart radius. See Defining pie chart center on page 84 and Defining pie chart 
radius on page 85.

To define logical graph coordinates - basic mode

In basic mode, you define the logical graph coordinates along the Y-axis. The 
logical graph coordinates along the X-axis span from 0 to 100 and cannot be 
changed.

1 In the Chart Properties dialog box, enter the largest Y-value in Max value.

2 Enter the lowest Y-value in Min value.

To define logical graph coordinates - advanced mode

In advanced mode, you define the logical graph coordinates both along the Y- and 
X-axes.

1 In the Chart Properties dialog box, select Advanced options.

2 Enter the largest Y-value in Y high.

3 Enter the lowest Y-value in Y low.

4 Enter the largest X-value in X high.

5 Enter the lowest X-value in X low.

Defining pie chart center
You use the X and Y coordinates in the X and Y fields, in the Chart Properties 
dialog box, to define the position of the pie chart center. The center of the chart is 
positioned relative to the logical graph coordinates.
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Example

If you set the logical graph coordinates to span from 0 to 100 long for both the X- 
and Y-axes, and set the X and Y values to 50, the pie chart will be positioned in 
the center of the chart.

Defining pie chart radius
You set the radius in the Radius field in the Chart Properties dialog box. The 
radius is defined relative to the logical graph coordinates.

Defining pie chart values and labels
You must define a value and a label for each slice in the pie chart. Use the 
following columns in the Chart items table in the Chart Properties dialog box:

• Value is the size of the slice and is retrieved from the input data.

• Label is the label of the slice and is retrieved from the input data that.

To define values and labels

1 In the Chart items table, double-click the Value or Label cell.

2 Enter the value.

Changing pie chart angles, rotations, and heights
You define the settings below in the Chart Properties dialog box.

To define the view angle

You define the view angle in the View angle field. You can enter a value between 
0 and 1.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



86 Pie chart specifics
Charts
To rotate a pie chart

You can rotate the pie chart by entering a value (in degrees) in the Start angle 
field.

To define the pie chart height

You define the height of the pie chart in the Height field. The height is defined 
relative to the logical graph coordinates.

To draw the pie chart counter-clockwise

By default, the pie chart is drawn clockwise. You can draw the pie chart counter-
clockwise by selecting Draw counter-clockwise. 

Emphasizing slices in pie charts
You can emphasize a slice in the pie chart. 

To emphasize a pie slice

1 In the Chart Properties dialog box, in the Chart items table, double-click the 
Burst cell.

2 Select True from the list.
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Defining line widths of pie contours
You can set the width of the contours in the pie chart by entering a value (in 
millimeters) in the Line width field in the Chart Properties dialog box.

Arranging pie slice labels
By default, the slice labels are attached to the pie slices. You can organize the 
labels in columns to the left and right of the pie chart, with lines from a pie slice 
to the corresponding label. You do this by selecting Burst labels in the Chart 
Properties dialog box.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



88 Layers of charts
Charts
Layers of charts
You can create layers of charts by adding overlapping charts.

You define the border, labels, support lines etc. for the first chart. Then select the 
Transparent option for the overlapping charts. This option removes everything 
but the actual data (bars, pies, and lines).

You can use this feature for different purposes, for example, to combine two bar 
charts, with a left margin offset, to simulate 3-D effects.

Note: If you want to combine two or more series of data and display them in the 
same chart, you should use several arrays in the same chart. See Adding 
chart items on page 72.
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Main window
The main window contains three views:

• Message view
This is the Message structure created in the corresponding Event tool. You 
drag blocks and fields from this view to the PageOUT sheet.

• PageOUT sheet
This is where you position the objects – blocks, fields, static text, graphics, 
etc. – that you want to include in the PageOUT configuration. You can edit 
the objects on the PageOUT sheet, or you can edit the corresponding nodes 
in the Process view.

• Process view
This view displays the PageOUT configuration as nodes in a tree structure. 
You can edit the nodes in this view, or you can edit the corresponding objects 
on the PageOUT sheet.

File menu

New Clear the existing PageOUT configuration and start with a new Process view.

Open Open an existing PageOUT configuration. The PageOUT configuration must 
have been saved as a *.dur file.

Save Save the PageOUT configuration as data embedded in the corresponding 
Message file in the Design Center Project.

Save As Save the PageOUT configuration as a separate *.dur file.

Page Setup Open the Page Setup – Body dialog box and edit the page setup for the PageOUT 
sheet. See Page Setup dialog box on page 98.

Print Print the PageOUT sheets in the current PageOUT configuration.

Recent File Open recent *.dur files.

Exit Exit the PageOUT tool.
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Edit menu

View menu

Insert menu
Insert objects on the sheet. Note that you must select the appropriate node – root 
or specific block – in the Process view before you add the object to the sheet.

Find Find objects in the Message view, Process view, and PageOUT sheet.

Add Overlay Add an existing overlay to the PageOUT configuration. See Add Overlays dialog 
box on page 99.

New Overlay Create a new overlay and add it to the PageOUT configuration. See the Overlay 
Editor documentation.

Toolbars Show/hide different toolbars.

Browsers Show/hide the Message view and Process view.

Grid Show/hide the grid.

Rulers Show/hide the rulers.

All layers Show all data from all blocks in a frame.

Field Sample 
Data on 
Sheet

Display field sample data and not field names on the PageOUT sheet.

Zoom Zoom the PageOUT sheet.

Toggle View 
Mode

The View Mode determines the display names for the fields in the Message view 
and Process view. You can toggle between the following modes:

• Label

• Description

• Sample content

Toggle 
Operation 
Nodes

Show/hide operation nodes. Operation nodes can include scripts and sort key 
definitions.

Static Text Add a new plain text segment. See also Text objects on page 93.

Variable Add a new variable. See also Text objects on page 93.
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Format menu

Advanced 
Text

Add a new advanced text segment. See also Advanced Text on page 94.

Frame Draw a frame. See also Frame on page 95.

Free Block Add a free block to a frame or at root level. See also Free Block on page 96.

Overlay Add an overlay to the PageOUT configuration. See also Overlay on page 97.

Picture Add a picture. See also Picture on page 97.

Rectangle Draw a rectangle. See also Rectangle and Line on page 97.

Line Draw a line. See also Rectangle and Line on page 97.

Page 
Number

Add a Page Number function that generates the number of the current page. See 
also Text objects on page 93.

Page of 
Pages

Add a Page of Pages function that generates the number of the current page and 
the total number of pages in the output document. See also Text objects on page 
93.

Pages Add a Pages function that generates the total number of pages in the output 
document. See also Text objects on page 93.

Date Add a Date function that generates the date when the output was created. See also 
Text objects on page 93.

Time Add a Time function that generates the time when the output was created. See 
also Text objects on page 93.

Align 
Objects

Align two or more objects. Text objects are aligned with respect to the anchoring 
position, and all other objects (including advanced text) with respect to the object 
border.

Bring to 
Front

Bring the selected object to the front.

Send to Back Move the selected object to the back.

Guide 
Settings

See Guides Settings dialog box on page 100.
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Tools menu

Objects
The objects described below are the objects you can configure in the Process view 
or on the PageOUT sheet.

Selection 
Tool

Activate select mode and deactivate any of the insert modes (insert rectangle, 
static text, etc.). In select mode, you can move the objects on the sheet.

Import Event Applicable only when using the PageOUT tool as a standalone application. 
Imports an Event configuration.

Apply Page 
Layout

Pick all frames, blocks, and fields defined in a PageIN or PreformatIN Event and 
add them to the PageOUT configuration. The PageOUT tool will automatically 
create the frames and add all blocks – including fields – to the frames.

Apply Layout 
Template

Browse to and select a page layout template.

Load 
Language 
File

Browse to and select a language file. The original text is replaced by the 
translated text.

Set 
Language ID

Select a Static Text object and generate a unique identifier for the text. See Edit 
Label ID dialog box on page 104.

Export 
Language 
File

Exports all language IDs defined in the current configuration to a language file 
in an available resource set.

Link Objects Link all unlinked fields and blocks. Unlinked blocks and fields in the Process 
view are linked to blocks and fields with the same name in the Message view.

Unlink 
Object

Manually cut the link between a selected field in the Process view, and the 
corresponding field in the Message view.

Default 
Unlinked 
Export

Set export options that apply to all unlinked fields. See Set Unlinked Field 
Properties dialog box on page 100.

Delete all 
Unlinked 
Objects

Delete all unlinked objects at the same time.

Preview Preview the output. You must first set the preview options below.

Preview 
Options

Set the preview options. See Preview Paths dialog box on page 101.

Export Preview the export from the PageOUT tool.

Options See Options dialog box on page 101.
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Applicable to:

• Field

• Static Text

• Variable

• Page Number

• Page of Pages

• Pages

• Date

• Time

Shortcut menu commands

Position Position the object and specify whether or not to wrap 
text. See Position dialog box on page 102.

Rotate Rotate the object. See Rotation dialog box on page 103.

Barcode Convert the text to barcodes. See Barcode dialog box on 
page 103.

Edit Script Open the script editor where you can edit a before or after 
script.

Hyperlink Create a hyperlink for the text. See Hyperlink dialog box 
on page 104.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Set ID Only applicable to Static Text.

Generate a unique identifier for the text. See Edit Label 
ID dialog box on page 104.

Alignment Specify the anchoring position for the object. See 
Alignment dialog box on page 105.

Font Specify the font for the text. See Font dialog box on page 
105.

Format Used to select numeric or date format. See Output format 
for fields and variables on page 53.

Properties Specify line spacing for the text. See Properties dialog 
box on page 109.
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Advanced Text

Size to content Applicable only if the wrap option is set to Autosize.

If you have expanded or shrunken an object, use this 
option to revert to the original size.

Unlink Applicable only to Field objects.

Unlink the field from the corresponding field in the Event 
configuration.

Unlinked Export Applicable only to unlinked Field objects.

Open the Set Unlinked Field Properties dialog box and 
specify what to export from the unlinked field. See Set 
Unlinked Field Properties dialog box on page 100.

Shortcut menu commands

Shortcut menu commands

Paragraph Available if you first select one or more characters in the 
text area.

Specify the options for a paragraph selected in the text 
area. See Paragraph dialog box on page 111.

Vertical shift Available if you first select one or more characters in the 
text area.

Open the Vertical Shift dialog box where you can move 
text segments up/down relative to the text on the same 
line. See Vertical Shift dialog box on page 112.

Font Available if you first select one or more characters in the 
text area.

Open the Font dialog box, where you can specify the font 
properties for the selected text segment. See Font dialog 
box on page 105.

Language Open the Language dialog box, where you can specify 
whether to use hyphenation on selected language. See 
Language dialog box on page 106.

Alias attributes Available if you first select a variable in the text area.

Open the Text Alias dialog box where you can specify a 
fixed width (points) that will be applied if the variable is 
empty at runtime.

Position Position the object. See Position dialog box on page 102.
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Frame

Edit Script Open the script editor where you can edit a before or after 
script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Properties Open the Advanced Text Properties dialog box where 
you can configure how to handle cropping, vertical 
alignment, and wrapping of text. See Advanced Text 
Properties dialog box on page 109.

Shortcut menu commands

Shortcut menu commands

Position Position the object. See Position dialog box on page 102.

Edit Script Open the script editor, where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Add Free Block Add a free block to the frame. See Free Block on page 96.

Block Properties Edit the properties for the active block. The active block 
is the block displayed in the frame on the PageOUT 
sheet. See Output Block Properties dialog box on page 
115.

Unlink Unlink the active block and all its fields from the 
corresponding block and fields in the Event 
configuration.

Drawing Properties Specify drawing properties for the frame. For example, 
line color, fill color, and rounded corners. See Drawing 
Properties dialog box on page 118.

Frame Properties Edit frame specific properties. See Frame Properties 
dialog box on page 113.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



96 Main window
PageOUT tool GUI reference
Block

Free Block

Shortcut menu commands

Edit Script Open the script editor where you can edit a before or after 
script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Unlink Unlink the block and all its fields from the corresponding 
block and fields in the Event configuration.

Block Properties Edit the properties for the block. See Output Block 
Properties dialog box on page 115.

Shortcut menu commands

Position Only applicable to free blocks outside frames.

Position the object. See Position dialog box on page 102.

Edit Script Open the script editor where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Block Properties Only applicable to free blocks in frames.

Edit the properties for the free block. See Output Block 
Properties dialog box on page 115.

Properties Only applicable to free blocks outside frames.

Specify drawing properties for the free block. For 
example, line color, fill color, and rounded corners. See 
Drawing Properties dialog box on page 118.
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Overlay

Picture

Rectangle and Line
Add lines and rectangles to the PageOUT sheet.

Shortcut menu commands

Edit Only applicable to LXF overlays.

Edit the overlay in the Overlay Editor. See the Overlay 
Editor documentation.

Refresh Obsolete option. The overlay is reloaded when the 
resource is updated.

Properties Open the Overlays dialog box. See Overlays dialog box 
on page 116.

Shortcut menu commands

Position Position the object. See Position dialog box on page 102.

Edit Script Open the script editor where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Select Select an alternative image. See Select Image dialog box 
on page 117.

Size to Content Revert to the original size of the image.

Shortcut menu commands

Position Position the object. See Position dialog box on page 102.

Edit Script Open the script editor where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Properties Open the Drawing Properties dialog box. See Drawing 
Properties dialog box on page 118.
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Charts

RFID

Dialog boxes

Page Setup dialog box

Shortcut menu commands

Position Position the object. See Position dialog box on page 102.

Edit Script Open the script editor where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Properties Open the Chart Properties dialog box. See Charts on 
page 121.

Shortcut menu commands

Position Position the object. See Position dialog box on page 102.

Rotate Rotate the object. See Rotation dialog box on page 103.

Edit Script Open the script editor where you can edit a before or 
after script.

Bookmarks Define a bookmark for the object. See Bookmarks dialog 
box on page 107.

Properties Open the RFID Properties dialog box. See RFID 
Properties dialog box on page 118.

Paper Size tab settings

Format Select a standard format or specify a custom width and 
height.

Width Width of the PageOUT sheet. You can select Enable 
width variable and let a variable determine the width. 
Enter the variable without the $-prefix.
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Add Overlays dialog box

Height Height of the PageOUT sheet. You can select Enable 
height variable and let a variable determine the height. 
Enter the variable without the $-prefix.

Orientation Portrait or Landscape.

Printers If you want to print the PageOUT sheet layout, select 
which printer to use.

Other tab settings

X/Y offset Some printers will automatically offset the output. You 
can use these settings to adjust the page offset 
accordingly in the PageOUT tool. The offset will be 
applied on the printed output page and will not be visible 
on the PageOUT sheet.

X offset – The horizontal offset (in millimeters) from the 
upper-left corner of the PageOUT sheet.

Y offset – The vertical offset (in millimeters) from the 
upper-left corner of the PageOUT sheet.

Always output Applicable only to the page type Last. use this option to 
make sure that a Last page is always generated. 

Note: If the data fits into a Single page, no Last page 
will be generated.

Priority N/A

Suppress frame 
overflow zone 
synchronization

Disables the frame overflow zone synchronization 
between frames in different page types. For example, 
selecting this option on a Body page type, and a frame is 
edited in a First page type, the values set in Overflow 
zone boundary will not be changed in the body page 
frame. See Frame Properties dialog box on page 113.

Paper Size tab settings

Settings

Overlay list A list of all LXF overlays available to the PageOUT tool. 
When an overlay is added to the PageOUT tool, it is 
removed from this list.
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Guides Settings dialog box

Set Unlinked Field Properties dialog box

Add print file If you want to use a PRN, PCL, or PS file as an overlay, 
use this button to browse to the corresponding resource.

Settings

Grid tab settings

Origin Horizontal and vertical origin of the grid. The origin is 
defined relative to the upper-left corner of the PageOUT 
sheet.

Frequency Number of horizontal and vertical grid lines per unit.

Snap to grid Select to snap objects to the grid.

Show Grid Select whether or not to display the vertical and 
horizontal grid lines.

Minimum pixels The minimum grid line width. The actual width depends 
on the screen resolution and zooming. If the actual width 
is less than the minimum width, the grid lines will not be 
visible on screen.

Borders tab settings

Left, Top, Right, 
Bottom

The top, right, bottom, and left borders. These borders are 
for guidance only.

Note: You cannot specify different borders for different 
page types in the same PageOUT configuration.

Show borders Select whether or not to display the borders on the 
PageOUT sheet.

Settings

Do not export Do not export the field.

Export as variable Export the field as a variable. Do not use white spaces in 
the variable name. Do not enter the $-prefix.

Export as static 
text

Select to export the Label, Description, Sample Data, or 
a custom Text. 
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Preview Paths dialog box

Options dialog box

Settings

StreamServer Path to the executable (strsloader.exe) that creates the 
preview. This path is set up automatically when you 
install the Design Center software.

Platform The Platform you are using.

InConnector The input connector that receives the input data.

Grab (In) File A sample file to use as input for the preview.

Additional server 
arguments

All the startup arguments strsloader.exe needs to 
create the preview, for example -demo. All startup 
arguments specified for the Project, and that may 
influence the preview, must be specified here.

Settings

Init path Path to the init directory.

Language code The default language code, for example eng.

Default Default font and alignment (anchoring position) settings 
for classes of fields. The classes Label, Dynamic, and 
Header are assigned to fields in the Event tool. The 
settings are applied to all existing and new fields of the 
class.

By specifying the Other class, you can assign settings for 
new text, such as static text, advanced text, page 
numbering, etc. Already inserted text is not automatically 
updated. 

Resources Select whether or not you want the PageOUT tool to send 
out warnings when a resource is reloaded or deleted.

Barcode style For Projects upgraded from Persuasion SP2, SP3, or SP4, 
you may have to set this option to Alternative style to get 
a correct representation of the barcodes in the tool.

Note: Runtime rendering of the output is not affected by 
this setting.
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Position dialog box

Settings

Position Use coordinates to specify the position and size of the 
object. The units are determined by the Frequency 
settings for the grid. The origin for objects added to 
blocks is by default the top left corner of the frame. The 
origin for objects outside frames is determined by the 
Origin settings for the grid. See Guides Settings dialog 
box on page 100.

X/Y – X/Y-coordinate for the upper left corner of the 
object.

Width/Height – Width/Height of the object.

Export as absolute Only applicable to objects added to blocks. The origin for 
these objects are by default the top left corner of the 
frame. 

If you select Export as absolute, the origin will be a 
static value determined by the Origin settings for the 
grid.

Enable mirroring Enable/disable mirroring of the object.

Mirroring for the Project is enabled in the Runtime 
configuration. Mirroring applies to all mirroring enabled 
objects. See Mirroring page layouts on page 58.

Wrapping Options for how to conform the text to the width and 
height of text area.

Clip – The width and height of the text area is static. If the 
text does not fit into the text area, it will be cropped.

Wrap – The width and height of the text area is static. If 
the text is wider than the width, it will be wrapped. If 
there are more lines of text than there is room, the text 
will be cropped.

Autosize – Default option. Adjust the width and height 
of the text area to the size of the text. The text will never 
be cropped with this option.

Keep leading spaces inside text – Select to keep 
leading spaces. For example, if the text extends over two 
lines, the second line can start with a space.

Variables Use variables to determine the position and size of the 
text area.
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Rotation dialog box
Rotate the object using a fixed or custom angle.

Barcode dialog box

Comments

Settings

Enable barcodes Enable barcodes for the selected field.

Barcode types Only types where StreamServer creates the barcode 
symbology are displayed by default. The Show all 
option enables the use of specific label printer barcodes, 
where text and formatting information is sent separately 
to the label printer.

Property/Value list See the corresponding barcode specification for 
information.

Code 128 The StreamServer will automatically calculate and use the most advantageous 
subset, which will result in the shortest barcode. You can include the FNC4 
character in your barcode by inserting the hexadecimal value <F4> in the string 
to be encoded. The FNC4 character is normally used to facilitate Extended Code 
128.

EAN 128 The StreamServer can handle EAN128 barcodes containing data fields of 
variable length. The variable length must be indicated by the data field separator 
FNC1. To include FNC1 in the text, you must use the hexadecimal code <F1>.

Maxicode When using the Maxicode barcode with Printronix and Intermec DP driver, the 
barcode fields must be separated by hexadecimal code <D1>. For example:

856501234<1D>844<1D>002<1D>Test

where:

• 856501234 – Postal Code (9 digit numeric for US or 6 digit alphanumeric 
for Canada)

• 844 – Country Code (3 digit numeric)

• 002 – Class of Service (3 digit numeric)

• Test – secondary message.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



104 Main window
PageOUT tool GUI reference
Hyperlink dialog box

Address lookup table syntax

<key>    <address>

Example 13 Address lookup table

SWE    http://www.abs.se/

FIN    http://www.abs.fi/

Screen tip lookup table syntax

<key>    <tip>

Example 14 Screen tip lookup table

SWE    Välkommen

FIN    Tervetuloa

Edit Label ID dialog box
Used for specifying unique IDs for text strings used in language files.

Settings

Enable hyperlink Enable the use of hyperlinks in PDF, RTF, and HTML 
driver produced output.

Address The hyperlink URL.

Screen Tip Optional tip displayed on mouse over. Works only if the 
viewer application supports this functionality.

Alias Use aliases to dynamically select alternative addresses 
and screen tips. See Dynamic selection using aliases in 
the Design Center documentation for information about 
aliases.

Settings

Text Displays the text string.

ID Enter an ID manually, or click Generate ID and let the 
PageOUT tool generate an ID.
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Alignment dialog box
The anchoring position for text fields is, by default, the base position for the first 
character. If the text is not static, the length of the text will grow from left to right. 
You can change the anchoring position to either center or right.

Font dialog box
Edit the font according to standard Windows procedures.

Aliases

Use aliases to dynamically select font, font size, color, and background color. See 
Dynamic selection using aliases in the Design Center documentation for 
information about aliases. You can use scripting and lookup table alias for fonts, 
but only scripting alias for font size, color, and background color. The following 
scripting functions are used to define fonts and colors:

• Font – SetFontProperties

• Color and background color – RGBcolor

Font lookup table syntax

<key>    <font>

where <font> corresponds to the font name in the driver files.

Settings

Left Left positioned anchor – the text will grow from left to 
right.

Right Right positioned anchor – the text will grow from right to 
left.

Centered Center positioned anchor – the text will grow from the 
center and out.

Variable Let a variable determine the position. The variable must 
return either Left, Right or Center (case sensitive).

Keep alignment Keep the original alignment of the text when mirroring 
the object layout. 
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Example 15 Font lookup table

SWE    Arial_Black

ENG    Arial_Narrow

Language dialog box

Language lookup table syntax

<key>    <language_code>

where <language_code> is the text string after the semicolon in the Language 
drop-down list.

Example 16 Language lookup table

USA    en-US

UK     en-GB

Hyphenation lookup table syntax

<key>    <hyphenate>

where <hyphenate> is either YES or NO.

Example 17 Hyphenation lookup table

USA    YES

UK     NO

Settings

Language Select language.

Use hyphenation Enable hyphenation for selected language.

Alias Use aliases to dynamically select language and whether 
to use hyphenation. See Dynamic selection using aliases 
in the Design Center documentation for information 
about aliases.
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Bookmarks dialog box
Define a bookmark for the selected object. Note that bookmarks are only 
applicable for PDF and AFP output.

Settings PDF AFP

Bookmarks Displays all bookmarks defined for 
the selected object. 

Same as PDF.

Name Enter a bookmark name. Enter a bookmark name. When left 
empty, Bookmark is used by default in 
AFP output.

Value Enter a bookmark value. Same as PDF.

Level Specify the level of the bookmark in 
the output bookmark hierarchy. Level 
1 is parent level. See Organizing 
bookmarks on page 45.

N/A

Repeat identical 
bookmarks

Enable/disable consecutive identical 
bookmarks at the same level in the 
output bookmark list. See Organizing 
bookmarks on page 45.

Same as PDF.

Format Specify how to display the bookmark 
in the output. Use one of the 
predefined formats, or enter any 
separator character. For example, to 
use the & character, enter %1 & %2

%1 – Represents the Name.

%2 – Represents the Value.

The Format column in the 
Bookmarks list displays a preview.

N/A

Style Specify the style of the bookmark. N/A

Color Specify the color of the bookmark. N/A

Alias Use aliases to dynamically define the 
bookmark properties. See Dynamic 
selection using aliases in the Design 
Center documentation for 
information about aliases. 

Same as PDF.
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Formats dialog box

Settings

Category General – Data will be handled as a regular string of 
characters.

Numeric – Data will be handled as numeric data. This 
category must have been specified for the field or 
variable in the Event configuration.

Date – Data will be handled as date formatted data. This 
category must have been specified for the field or 
variable in the Event configuration.

Format Select an existing format or add a new format. Do not use 
the Numeric formats k and d. They should be used in the 
Event configuration only.

Select Resource Browse to and select an alternative format resource.

Numeric format description

Z If the value of a leading or trailing digit is zero, the digit is replaced 
by a space, " ".

B If the value of a leading or trailing digit is zero, the digit is removed.

9 The digit is always displayed.

# A digit on either side of a decimal separator, or the last sign if no 
decimal separator exists. The digit is always displayed, except if the 
field value is zero (0 or 0.0 or similar).

Example Z ZZZ ZZZ ZZ#,##

Date format description

d Day

m Month

y Year

Example dd/mm/yyyy
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Properties dialog box

Advanced Text Properties dialog box

Height Modes tab

The text area you draw on the PageOUT sheet, is not the same used in the output. 
When you add text to a block, you have four options for how to conform the 
height of text area to the actual output.

When the text is added on root level (not in frames), the Maximum height mode 
equals the Fixed height mode, and the Minimum height mode equals the Default 
height mode.

Settings

Auto Keep the default line spacing suggested by the PageOUT 
tool.

Custom Specify a custom line spacing. The custom line spacing 
will not be visible on the PageOUT sheet.

Line spacing Line spacing (in points).

Variable Use a variable to determine the line spacing. The variable 
must return a line spacing (in points).

Settings

Default height Adjusts the height of the text area to the size of the text. 
The text will never be cropped using this option.

Fixed height The height of the text area is exactly the same height as 
defined in the PageOUT tool. If the text does not fit, it 
will be cropped.

Maximum height Behaves like the Default height option until the height of 
the text area equals the height defined in the PageOUT 
tool. If more text is added to the output, it will be cropped.

Minimum height Behaves like the Fixed height option until the maximum 
height is reached. If more text is added to the output, the 
height of the text area will grow. The text will never be 
cropped using this option.
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Alignment tab

Specify the vertical alignment of the text in an Advanced Text area.

Wrapping tab

Specify how to wrap text lines in an Advanced Text area.

Example 18 Wrapping mode=Word Wrap and Scaling=None

Wrapping mode is set to Word Wrap and Scaling is set to None.

Example 19 Wrapping mode=None and Scaling=None

Wrapping mode is set to None and Scaling is set to None.

Settings

Top Start text at the top of the Advanced Text area.

Center Center text in the Advanced Text area. Text moves 
toward the top and bottom as you add new text.

Bottom Places text at the bottom of the Advanced Text area. Text 
moves toward the top of the Advanced Text area as you 
add new text.

Settings

Wrapping mode Word Wrap – Wrap text inside the Advanced Text area.

None – Disable wrapping of text.

Scaling None – Keep original font size.

Scale to Fit – The text will be scaled, up or down, so that 
the longest line of text will fit into the Advanced Text 
area.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Main window 111
PageOUT tool GUI reference
Example 20 Wrapping mode=None and Scaling=Scale to Fit

Wrapping mode is set to None and Scaling is set to Scale to Fit.

Import Text tab

Specify from where external texts are imported. The imported texts replace the 
text in the Advanced Text area.

Paragraph dialog box
Specify text indentation, paragraph spacing, line spacing and text alignment.

Settings

Get text from 
StreamStudio 
Composer

Select to make the Advanced Text area available for texts 
created in the StreamStudio Composer.

Area name Enter the name of the text area that should be available in 
the StreamStudio Composer.

Alias Not applicable if you use the Advanced Text area for 
texts created in the StreamStudio Composer.

Use aliases to dynamically replace the text in the area. If 
you use an array variable, all variable values are inserted 
one after another.

See Dynamic selection using aliases in the Design Center 
documentation for information about aliases.

Settings

Text indentation Left and Right indentation for the paragraph.

First line adjustment – An adjustment of the Left 
indentation for the first line in the paragraph. You can 
enter a positive or a negative value.

Paragraph spacing Spacing before and after the paragraph.
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Vertical Shift dialog box
Specify how to move a text segment up/down relative to the text on the same line.

Line spacing Auto – Use the default line spacing.

Fixed – Enter a fixed line spacing.

Relative – Enter a relative line spacing. The value will be 
multiplied by the current font height. If a text line 
includes multiple font sizes, the highest value will be 
used as font height. If a text line includes a vertical shift, 
the absolute value of vertical shift is added to current font 
height.

Text alignment Left, center, or right align the paragraph.

Justified – Distribute the text evenly between the right 
and left margins. Lines terminated with CR+LF and the 
last line of a paragraph are excluded from justification. 
The last line of a paragraph is aligned according to the 
selection Left, Center, and Right.

Collapse empty 
paragraph at 
runtime

A paragraph that only contains variable data can be 
empty at runtime. Select this option if you want to 
remove the empty space, caused by the empty paragraph, 
from the output.

Exclude paragraph 
from scaling

Disables the Scale to fit option (Wrapping tab in the 
Advanced Text properties dialog box) for the selected 
paragraph.

Settings

Settings

Vertical shift Number of points to move the selected text segment.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Main window 113
PageOUT tool GUI reference
Frame Properties dialog box

Relative to Baseline – The vertical shift is the distance between the 
base of the moved text segment and the base of the text.

Cap line – The vertical shift is the distance between the 
top of the moved text segment and the top of the highest 
character.

Settings

Settings

Free blocks Enter the names of the free blocks you want to add.

Before frame – Add a free block before all blocks in the 
frame.

After frame – Add a free block after all blocks in the 
frame.

Before overflow – Add a free block at the bottom of the 
frame, on the current page before a page break.

After overflow – Add a free block at the top of the frame, 
on the following page after a page break.

Priority level The StreamServer processes frames in the order in which 
they appear in the Process view, from top to bottom. You 
can change the processing order by using drag-and-drop, 
or by assigning priority levels (0, 1, etc.) to the frames. 
The frame with the lowest value will be processed first. 
Frames with the same priority will be processed 
according to the order in the Process browser.
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Overflow zone 
boundary

Enabled when any of the blocks have the page break 
mode set to Break between lines in a field.

The Overflow zone boundary and the bottom of the frame 
create a window that determines how many lines to move 
to the next page after a page break. See Widow and 
orphan rows on page 54.

Specify the distance (in grid units) from the top of the 
frame. You can also let a variable determine the distance.

Note: To let these values change depending on if a 
corresponding frame is modified in another page 
type, you must enable Suppress frame overflow 
zone synchronization, see Page Setup dialog 
box on page 98.

Retain frame data Retain frame data from the previous page.

When a frame is filled, a new page is triggered. New data 
will be added to the frame on the new page until the frame 
is filled, and so on. If the PageOUT configuration 
contains two or more frames, one frame will cause the 
page break, and the rest of the frames will most likely not 
be filled. By default, no data from the previous page will 
be retained in any of the frames after a page break. 

Ignore frame 
boundaries

Do not crop text that extends outside the vertical frame 
borders.

Settings
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Main window 115
PageOUT tool GUI reference
Output Block Properties dialog box

General tab

Settings

Spacing Before – Spacing (in millimeters) above the block.

After – Spacing (in millimeters) below the block.

Line – Fixed block height (in millimeters). To enable this 
option, you must select Use line.

Note: By selecting Use line you disable the page break 
modes Break between fields and Break 
between lines in fields.

Keep lines together – If the frame is not big enough for 
the block and its associated free blocks, the blocks are 
moved to the next page. This setting is ignored if the 
frame on the next page is too small.

Only applicable if Frame Overflow is set to Default, and 
when using a StreamIN or XMLIN event with parent 
blocks. The child blocks inherit this setting from the 
parent block. 

Indentation Top – Top indentation (in millimeters, counted 
downwards using a negative value) of the block.

Left – Left indentation (in millimeters) of the block.

Free blocks Enter the names of the free blocks you want to add.

Before first instance – Add a free block before the first 
instance of this block.

After last instance – Add a free block after the last 
instance of this block.

Before overflow – Add a free block at the bottom of the 
frame, on the current page, before a page break.

After overflow – Add a free block at the top of the frame, 
on the following page, after a page break.

After block children – Add a free block after the last 
instance of any block children. If the block has no 
children, the free block will be invoked after each 
instance of the main block.

Sort Use sort keys to specify the order in which block data is 
added to the output, see Sorting on page 57.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



116 Main window
PageOUT tool GUI reference
Frame Overflow tab

See Defining page breaks on page 54 for more information.

Overlays dialog box

Settings

Default Move the block, and all associated free blocks, to the next 
page after a page break.

Note: Not applicable if it is the first block in the frame.

Break between 
blocks

Similar to the Default option. The difference is that the 
page break can separate blocks and free blocks.

Break between 
fields

The page break can occur between fields in blocks and 
free blocks.

If the block has Use line enabled, this mode will behave 
like the Break between blocks mode.

Break between 
lines in fields

The page break can occur between lines within a field. 
This mode will not work if the field is rotated.

If the block has Use line enabled, this mode will behave 
like the Break between blocks mode.

Settings

Alias Use aliases to dynamically select alternative overlays. 
See Dynamic selection using aliases in the Design Center 
documentation for information about aliases.

Offset adjustment Enable offset adjustment of an overlay. Use the SetXoffs 
and SetYoffs scripting functions to define the offset, see 
the Scripting reference.

Verso Make this overlay a verso overlay.

If you want to print static information on the reverse side 
of a sheet, you can add a verso overlay. Note that the 
verso overlay is the only information that will be printed 
on the reverse side.

Page number Only applicable for LXF and TIFF overlays.

Select a page from the multi-page overlay. 

Suppress overlay Select to suppress the overlay.
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Overlay lookup table syntax

"<Event>.<Process>.<number>.<key>"    <Overlay>

where <number> refers to the sequential order of the overlays in the Process view.

Example 21 Overlay lookup table

"In.Out.1.SWE"    logoSWE.lxf

"In.Out.1.ENG"    logoENG.lxf

"In.Out.1.FIN"    logoFIN.prn

"In.Out.2.SWE"    footSWE.lxf

"In.Out.2.ENG"    footENG.lxf

"In.Out.2.FIN"    footFIN.prn

Select Image dialog box
In this dialog box you specify images to add to the PageOUT sheet. You can add 
image resources as well as external image files.

You can select a static image that always will be used. You can also create a script 
that selects the image dynamically (not applicable to image resources).

Variable Use a variable to dynamically:

• select pages from the multi-page overlay. Only 
applicable for LXF and TIFF overlays.

• suppress the overlay.

Preview Resource Not applicable to LXF and TIFF overlays.

Browse to and select a preview resource for the printer 
overlay. The preview resource will be displayed on the 
PageOUT sheet.

Settings

Settings

Select Resource Click OK and browse to the image resource.
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Drawing Properties dialog box

RFID Properties dialog box
The available memory size is dependent on chip memory and the number of 
partitions. When you enter static values in the fields, your are assisted with 
information regarding allowed values in the remaining fields. Red colored 
information indicates memory overflow.

Different fields are available in the dialog box depending on selected air protocol 
and EPC encoding format.

Using variables

Variables can be used in all fields. You can also enter a variable in the Encoding 
format drop-down list. 

File name The path to an image (static image selection) or a variable 
(dynamic image selection).

Settings

Lines tab settings

Colors Line or border color.

Variable Color variable defined using the scripting function 
RGBcolor. See the Scripting reference.

Width Width (millimeters) of the line or border.

Fill tab settings

Colors Color or pattern of the rectangle area.

Variable Color variable defined using the scripting function 
RGBcolor. See the Scripting reference.

Corners tab settings

Sharp corners Draw a rectangle with sharp corners.

Round corners Draw a rectangle with rounded corners. Use Radius to 
specify the radius of the corners.

Frame tab settings

Snap to content Select if you want to conform the size of the frame to the 
contents of the frame.
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Settings

Settings

Air protocol or tag type Protocol that determines how RFID tags and 
RFID printers communicates.

Available options are:

• EPC Class 1 version 1

• EPC Class 1 Generation 2

• ISO18000-6b

Tag data / Use EPC tag 
encoding

If selected, EPC identification scheme is 
used to identify objects via RFID tags. 

Encoding format Only available when Use EPC tag 
encoding is selected.

For a list of available EPC formats and 
arguments, see EPC encoding formats and 
arguments on page 120.

Data format This option is not available if EPC tag 
encoding is used.

Available options are:

• HEX 64 and 96 bit

• ASCII 64 and 96 bit.

• NUM 64 and 96 bit.

Intermec
• HEX – Hexadecimal string. Values 0-

9 and a-f are allowed. Hex characters 
must be entered in pairs.

• ASCII – 8-bit ASCII string.

• NUM – Integer. 0 to 2147483647 is 
allowed. Always uses 4 bytes to 
represent data, unless a field smaller 
has been defined, and the number fits 
in that field. Not allowed in Class1 tag

ID Only available when EPC Class 1 version 1 
is used without EPC tag encoding.

EPC data Only available if EPC Class 1 Generation 2 
or ISO18000-6b is used without EPC tag 
encoding.

User Only available if EPC Class 1 Generation 2 
is used without EPC tag encoding.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



120 Main window
PageOUT tool GUI reference
Security settings

EPC encoding formats and arguments

Only available when EPC tag encoding is selected. EPC encoding formats are 
predefined according to the EPC specification EPC Generation 1 Tag Data 
Standards Version 1.1 (EPC Global TDS). See: http://www.epcglobalna.org/
StandardsDevelopment/EPCglobalStandards/tabid/185/Default.aspx

• SGTIN-96 – Filter value, Partition, Company prefix (Index), Item 
reference, Serial number

• SGTIN-64 – Filter value, Company prefix (Index), Item reference, Serial 
number

• SSCC-96 – Filter value, Partition, Company prefix (Index), Serial reference

• SSCC-64 – Filter value, Company prefix (Index), Serial reference

• SGLN-96 – Filter value, Partition, Company prefix (Index), Location 
reference, Serial number

• SGLN-64 – Filter value, Company prefix (Index), Location reference, 
Serial number

• GRAI-96 – Filter value, Partition, Company prefix (Index), Asset type, 
Serial number

• GRAI-64 – Filter value, Company prefix (Index), Asset type, Serial number

• GIAI-96 – Filter value, Partition, Company prefix (Index), Individual asset 
ref

• GIAI-64 – Filter value, Company prefix (Index), Individual asset ref

• GID-96 – General manager number, Object class, Serial number

Security settings

Kill password This options is available if EPC Class 1 
version 1 or EPC Class 1 Generation 2 is 
used.

• For EPC Class 1 version 1 is one byte 
HEX passwords allowed.

• For EPC Class 1 Generation 2 is four 
bytes HEX passwords allowed.

Access/lock password This options is available if EPC Class 1 
Generation 2 is used.

Four bytes HEX passwords are allowed.

Tag protect/lock enabled This options is available if EPC Class 1 
version 1 or ISO19000-6b is used.

Permanent lock This options is available if EPC Class 1 
Generation 2 is used.
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• USDOD-96 – Filter value, Government managed ID, Serial number

• USDOD-64 – Filter value, Government managed ID, Serial number

Charts
This section describes buttons, fields, etc. in the dialog boxes used to manage 
charts. The following topics are covered:

• Chart features on page 121

• Color settings for arrays on page 122

• Bar chart reference on page 123

• Line chart reference on page 125

• Pie chart reference on page 126

• Support line properties on page 128

• X-axis properties on page 129

• Y-axis properties on page 131

Orientation

In the PageOUT tool, click the Chart toolbar button. Outline the area on the 
PageOUT sheet where you want to insert the chart.

Chart features

Settings

Advanced options Select to enable advanced chart options to be set.

Transparent Select to insert the chart without border, support lines, X-
axis, etc. Use this option, for example, to combine two 
charts, with a left margin offset, to simulate 3-D effects.

Label The label/caption of the chart.

Set font Click to set a font for the chart label.

Lines/Width The line width (in millimeters) of the border around the 
chart.

Lines/Color The color of the border around the chart. 

Palette Click to select colors other than those supplied by default.
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Color settings for arrays

Label position The position of the label, above (Upper) or below 
(Lower) the chart.

Chart type The chart type (Bar, Pie, or Line).

Interval
(Basic mode)

The interval for the chart height. The chart width is 
automatically set to span from 0 to 100.

Logical graph 
coordinates
(Advanced mode)

The coordinates for the chart area.

Set font Click to set a font for the label.

Format Click to specify a format for the label.

New Click to add a row to the table.

Delete Click to remove the selected row from the table.

Move Up Click to move the selected row one step up in the table.

Move Down Click to move the selected row one step down in the 
table.

Settings

Settings

Automatic color 
shading

Select to enable automatic color shading.

Shading offset A shading offset value. The lower the value, the smaller 
the change, and more shades are available

Color All colors to be used by the array elements. Double-click 
the color item to edit the color settings.

New Click to add a color item to the Color list.

Delete Click to remove the selected color item from the Color 
list.

Move Up Click to move the selected color item one step up in the 
Color list.

Move Down Click to move the selected color item one step down in 
the Color list.
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Bar chart reference

Chart items

When you select Chart items from the View list, you can edit properties for the 
appearance of the bars.

Settings

View Select which type of data to view and edit in the table at 
the bottom of the dialog box.

Left margin The distance between the first bar and the left side of the 
chart.

Right margin The distance between the last bar and the right side of the 
chart.

Bar width The width of each bar.

Bar gap The distance between two bars.

Draw from min 
value

Select to create a differentiated chart where the X-axis is 
moved to the lowest Y-value (Y low or Min value).

Absolute Select to set the units (millimeters). Otherwise the units 
are related to the logical graph X-axis.

Use item color
(Applicable to arrays 
only)

Used in previous versions of PageOUT. Applicable only 
if you do not define color settings for arrays.

If selected, all bars will have the color specified in the Fill 
column. If cleared, the bars will be printed in gray scale.

Settings

Array Select if the input data comes in the form of an array.

Value A fixed value or variable that corresponds to the input 
data value. This value determines the height of the 
corresponding bar.

Label A fixed value or variable that corresponds to the input 
data value. This value determines the label attached to the 
corresponding bar.

Rotate The rotation angle (in degrees) of the label.
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Support Lines

When you select Support Lines from the View list, you can edit properties for 
the appearance of the support lines. These properties are the same for bar charts 
and line charts, and are described in Support line properties on page 128.

X-axis

When you select X-axis from the View list, you can edit properties for the 
appearance of the X-axis. These properties are the same for bar charts and line 
charts, and are described in X-axis properties on page 129.

Y-axis

When you select Y-axis from the View list, you can edit properties for the 
appearance of the Y-axis. These properties are the same for bar charts and line 
charts, and are described in Y-axis properties on page 131.

Horizontal pos The horizontal position of the label. There are three fixed 
positions:

• Left

• Center

• Right

Vertical pos The vertical position of the label. There are three fixed 
positions:

• Top

• Center

• Bottom

Fill The color to fill the bar with.

If Array is selected, you define these color settings on the 
Array options tab.

Outline The line width (in millimeters) of the bar border.

Settings
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Line chart reference

Chart items

When you select Chart items from the View list, you can edit properties for the 
appearance of the bars.

Settings

Connect lines with Select to use a dot or a square to connect lines.

• Dot – The Size value is multiplied by half of the 
line width (Outline value) to give the diameter of 
the dot.

• Square – The Size value is multiplied by half of 
the line width (Outline value) to give the side of the 
square.

View Select which type of data to view and edit in the table at 
the bottom of the dialog box.

Settings

Array Select if the input data comes in the form of an array.

Value A fixed value or variable that corresponds to the input 
data Y-coordinate.

X A fixed value or variable that corresponds to the input 
data X-coordinate.

Label A fixed value or variable that corresponds to the input 
data that is to be displayed as a label.

Rotate The rotation angle (in degrees) of the label.

Horizontal pos The horizontal position of the label. There are three fixed 
positions:

• Left

• Center

• Right

Vertical pos The vertical position of the label. There are three fixed 
positions:

• Top

• Center

• Bottom
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Support Lines

When you select Support Lines from the View list, you can edit properties for 
the appearance of the support lines. These properties are the same for bar charts 
and line charts, and are described in Support line properties on page 128.

X-axis

When you select X-axis from the View list, you can edit properties for the 
appearance of the X-axis. These properties are the same for bar charts and line 
charts, and are described in X-axis properties on page 129.

Y-axis

When you select Y-axis from the View list, you can edit properties for the 
appearance of the Y-axis. These properties are the same for bar charts and line 
charts, and are described in Y-axis properties on page 131.

Pie chart reference

Fill The color of the line segment.

If Array is selected, you define these color settings on the 
Array options tab.

Outline The line width (in millimeters) of the line segment, 
starting at the coordinates for the current item, and ending 
at the coordinates for the next item.

Line style The line style of the line segment, starting at the 
coordinates for the current item, and ending at the 
coordinates for the next item.

Settings

Settings

Draw counter-
clockwise

Select to draw the pie chart counter-clockwise.

Line width The width (in millimeters) of the contours in the pie 
chart.

X and Y Positions the center of the pie chart relative to the logical 
graph coordinates. You define the position by setting the 
X and Y coordinates in the X and Y fields respectively.
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Charts 127
PageOUT tool GUI reference
Height The pie chart thickness. The thickness is set relative to 
the logical graph coordinates.

Radius The pie radius. The pie radius is set relative to the logical 
graph coordinates.

View angle The view angle. You can enter a value between 0 and 1.

Start angle The rotation of the pie chart (in degrees).

Use item color
(Applicable to arrays 
only)

Used in previous versions of PageOUT. Applicable only 
if you do not define color settings for arrays.

If selected, all bars will have the color specified in the Fill 
column. If cleared, the bars will be printed in gray scale.

Burst labels Select to organize the labels in columns to the left and 
right of the pie chart, with lines from each pie slice to the 
corresponding label.

Array Select if the input data comes in the form of an array.

Note: If you select this option, you cannot have more 
than one pie in the table.

Settings
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Support line properties

Value A fixed value or variable that corresponds to the input 
data value. This value determines the size of the 
corresponding slice.

Label A fixed value or variable that corresponds to the input 
data value. This value determines the label attached to the 
corresponding slice.

Fill The color to fill the slice with.

If Array is selected, you define these color settings on the 
Array options tab.

Burst Select True to separate the slice from the pie. 

Settings

Settings

First The Y-coordinate for the first support line to be drawn. 
This value relates to the logical graph coordinates.

Last The Y-coordinate for the last support line to be drawn. 
This value relates to the logical graph coordinates.

Length The length of the support lines. This value relates to the 
logical graph coordinates.

Distance The distance between the support lines and, 
consequently, the number of support lines to be drawn. 
This value relates to the logical graph coordinates.

Horizontal pos The Y-coordinate is displayed as a label at the end of each 
support line. Horizontal pos is the horizontal position 
(fine tuning) of the label. There are three fixed positions:

• Left

• Center

• Right
StreamServe Persuasion SP5 PageOUT User Guide Rev A



Charts 129
PageOUT tool GUI reference
X-axis properties

Vertical pos The Y-coordinate is displayed as a label at the end of each 
support line. Vertical pos is the vertical position (fine 
tuning) of the label. There are three fixed positions:

• Top

• Center

• Bottom

Placement The Y-coordinate is displayed as a label at the end of each 
support line. Set this value to Left or Right to have the 
label positioned to the left or right end of the support 
lines.

Outline The line width (in millimeters) of the support lines.

Line style The line type (solid, dashed, etc.) for the support lines.

Set font Click to set the font for labels attached to the support 
lines.

Format Click to select the format for labels attached to the 
support lines.

New Click to add a row to the table.

Delete Click to remove the selected row from the table.

Move Up Click to move the selected row one step up in the table.

Move Down Click to move the selected row one step down in the 
table.

Settings

Settings

Text Select to attach labels to the X-axis. If you have one 
single X-axis, this option is selected by default and 
cannot be deselected. If you have several X-axes, this 
option must be selected for one of the axes.

Start The X-coordinate where you want the X-axis to start. 
This value relates to the logical graph coordinates.

End The X-coordinate where you want the X-axis to end. This 
value relates to the logical graph coordinates.
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Y The Y-coordinate where the X-axis intersects the Y-axis. 
This value relates to the logical graph coordinates.

Only available in advanced mode. In basic mode, the X-
axis intersects the Y-axis at the 0 (zero) coordinate.

Label The label text you want to use for the X-axis.

Horizontal pos The horizontal position (fine tuning) of the X-axis label. 
There are three fixed positions:

• Left

• Center

• Right

Vertical pos The vertical position (fine tuning) of the X-axis label. 
There are three fixed positions:

• Top

• Center

• Bottom

Placement The alignment of the X-axis label relative to the end 
points of the X-axis. There are two fixed positions:

• Left

• Right

Outline The line width (in millimeters) of the axis.

Set font Click to set the font for the X-axis label.

Format Click to select the format for the X-axis label.

New Click to add a row to the table.

Delete Click to remove the selected row from the table.

Move Up Click to move the selected row one step up in the table.

Move Down Click to move the selected row one step down in the 
table.

Settings
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Y-axis properties

Settings

Start The Y-coordinate where you want the Y-axis to start. 
This value relates to the logical graph coordinates.

End The Y-coordinate where you want the Y-axis to end. This 
value relates to the logical graph coordinates.

X The X-coordinate where the Y-axis intersects the X-axis. 
This value relates to the logical graph coordinates.

Only available in advanced mode. In basic mode the Y-
axis intersects the X-axis at the 0 (zero) coordinate.

Label The label text you want to use for the Y-axis.

Horizontal pos The horizontal position (fine tuning) of the Y-axis label. 
There are three fixed positions:

• Left

• Center

• Right

Vertical pos The vertical position (fine tuning) of the Y-axis label. 
There are three fixed positions:

• Top

• Center

• Bottom

Placement The alignment of the Y-axis label relative to the end 
points of the Y-axis. There are two fixed positions:

• Left

• Right

Outline The line width (in millimeters) of the axis.

Set font Click to set the font for the Y-axis label.

Format Click to select the format for the Y-axis label.

New Click to add a row to the table.

Delete Click to remove the selected row from the table.

Move Up Click to move the selected row one step up in the table.

Move Down Click to move the selected row one step down in the 
table.
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