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AEM DAM Connector for Adobe® Drive CC
Overview
Adobe Drive CC enables you to connect Creative Suite® 6 and Creative Cloud™ desktop applications to
Digital Asset Management (DAM) servers. The connected servers appear in your computer as a mounted
hard drive or mapped network drive. Once connected, you can access server files through Windows
Explorer or Mac OS Finder, as well as the platform-specific file-access dialogs, and directly through the UI of
integrated applications.
Adobe Drive CC is the name of the version 5 release; the product is referred to in the documentation and in
the user interface as Adobe Drive 5.
Adobe Drive 5 is extensible; an SDK allows partners and third parties to create connectors for particular
asset management systems. Adobe provides some ready-made connectors. The Adobe Experience
Manager Digital Asset Management Connector (AEM DAM Connector) enables access to Adobe
Experience Manager Digital Asset Management (AEM DAM).

Supported features
The connector supports these features:


Connecting to and disconnecting from a server



Browsing documents and folders.



Creating and deleting documents and folders



Moving and copying documents and folders



Checking documents out and in



Managing document versions



Searching documents



Thumbnails and preview icons in Adobe Bridge



Thumbnails in the Show Versions dialog



Viewing, editing, and searching XMP metadata in Adobe Bridge
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Using the AEM DAM Connector
Before connecting, you must obtain the URL for the AEM DAM server from the server administrator, as well
as a valid user ID and password.
This document uses the localhost server in examples; this works if you have default server installation on
your local machine. You must replace localhost with the server URL when you connect to a remote
server. For example, to access an AEM DAM server in a default installation on your local machine:
SERVER URL: http://localhost:4502
USERNAME: myName
PASSWORD: xxxx

Connecting to a server
To connect to an AEM DAM server:
1.

2.

Start the Adobe Drive application.


In Windows, right-click your desktop, or a folder or file in Windows Explorer, and choose
Adobe Drive > Connect To from the context menu.



In Mac OS, CTRL-click your desktop or a folder or file in Finder, and choose
Adobe Drive > Connect To from the context menu.

Click Add Drive.
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If you have the name of a preset server, click it to display the Server URL. Otherwise enter the Server
URL manually.

4. Enter your connection details. For example:
Server URL: http://localhost:4502
Name: MyUsername
Password: xxxxxx
Display Name: AEM
Do not use spaces or special characters other than underscore and dash in the display name.
5.

Click Connect.

6. Check that the server has been mounted in the file browser:


In Windows Explorer, it should be under My Computer.



In Mac OS Finder, it should be under Devices.

Troubleshooting
If connection fails, open a web browser and test whether the server is available using the server URL. For
example, if you enter http://localhost:4502 and authenticate with your credentials, you should see
the AEM DAM login screen, and be able to navigate to and open DAM access to digital assets.


If you receive no response or an empty response, your server might not be available or your
credentials might be incorrect.



If you do not have DAM access, check that you have the Digital Asset Management capability installed;
the connector does not work with a DAM server that does not have this capability.

Disconnecting


In Windows Explorer: Right-click the AEM DAM drive and choose Disconnect from the context menu.



In Mac OS Finder: CTRL-click the AEM DAM drive device and choose Eject from the context menu.



In Adobe Bridge: Select Adobe Drive in the Favorites panel. Right-click (in Windows) or CTRL-click (in
Mac OS) the AEM DAM drive and choose Disconnect from the context menu.



In Adobe Drive 5: Select the server to be disconnected from Recent Connections and click
Disconnect.
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Browsing and manipulating documents and folders.
Once you are connected, Adobe Drive 5 presents documents and folders from your AEM DAM server in a
network drive on your computer. You can view the server’s files in Windows Explorer or Mac OS Finder. You
can also access these files in Open, Save As, and other file management dialog boxes.

You can also use the UI for your AEM DAM server to view and manipulate documents and folders.
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Creating and deleting documents and folders
CS6 and CC desktop applications Photoshop®, Illustrator®, InDesign®, and InCopy® allow you to check in
documents directly to the AEM DAM server. In other applications you must save your document to the
AEM DAM drive and use Windows Explorer, Mac OS Finder or Adobe Bridge to manually check in the file.
You can create new folders using Windows Explorer, Mac OS Finder or Adobe Bridge or using the Open,
Save As, and other file management dialog boxes in an application.
You cannot create documents or folders at the root of the drive; you must save any new content under a
folder in the root that already exists on the server. If you need to create new folders at the root location,
you must use the UI provided by your AEM DAM server.
For example, to create a new document in the AEM DAM server from Photoshop:
1.

Create a new document in Photoshop.

2. Choose File > Check In.
3.

In the Save As dialog, navigate to the folder on the AEM DAM drive where you want to save the
document.

4. Enter a check-in comment when prompted, and click OK.

Photoshop, Illustrator, InDesign, and InCopy display the file status in a status bar when you view or edit
documents. Once the document is saved to the server, the file status changes to Up-to-Date.
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Automatic check-in for new documents added from file system
The Settings dialog includes the option "Enable automatic check-in for files added from Finder or Explorer".
This option is selected by default; you can use the Settings dialog to add a default check-in comment.
If you do not disable the feature in the Settings dialog, new files that you create on a connected drive
using Mac OS Finder or Windows Explorer are automatically checked in with the default comment.
Automatic check-in is not available for files added through Adobe Bridge, Photoshop, InDesign or InCopy.

Moving, copying documents and folders
To move or copy documents or folders on the AEM DAM server:
In Adobe Bridge:


Invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder.



Choose Move To or Copy To from the context menu, then choose the destination folder.


Documents moved or copied in this way are automatically checked in.

In Windows Explorer or Mac OS Finder:


Drag a document or folder to move it to a different location.



CTRL-drag (in Windows) or OPTION-drag (in Mac OS) to copy to a new location.


If you move a document from the desktop to an AEM DAM drive this way, or copy any document
to a new location, you must check it in explicitly.



You cannot move or copy documents or folders to the root of an AEM DAM drive.

Renaming documents and folders
In Adobe Bridge, Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or
CTRL-click in Mac OS) for the document or folder, and choose Rename.


You cannot rename documents or folders in the root of an AEM DAM drive.
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Deleting documents and folders


In Adobe Bridge, Mac OS Finder, or Windows Explorer, invoke the context menu (right-click in
Windows or CTRL-click in Mac OS) for the document or folder, and choose Delete.



You cannot delete documents or folders in the root of an AEM DAM drive.



Deletion from an AEM DAM server is permanent; deleted files cannot be restored. The Tools > Adobe
Drive > Project Trash option in Adobe Bridge, Recycle Bin in Windows, and Trash in Mac OS are not
supported.

Working with XMP metadata
When you are connected to an AEM DAM server, you use Adobe Bridge to view, edit, and search XMP
metadata in managed assets.
You can view metadata directly through the Adobe Bridge menus and panels, or you can right-click the
asset and choose File Info.
The Adobe Bridge Label menu gives you access to the view and edit rating and label information:
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For other XMP properties, use the Adobe Bridge Metadata and Keywords panels:
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The File Info dialog provides access to all XMP metadata properties:

Searching documents and folders
To search for a document or a folder on an AEM DAM server from Adobe Bridge:
1.

Select Adobe Drive from the Favorites panel and open the folder in the AEM DAM drive you want to
search.

2. Choose Edit > Find.
3. Choose search criteria by selecting options and limiters from the Criteria menus.
4. Enter search text in the box on the right. To add search criteria, click the plus sign (+). To remove search
criteria, click the minus sign (-).
5. Choose an option from the Match menu to specify whether any or all criteria must be met.
6.

Click Find.

The "Search includes all versions of a file" and “Search includes deleted files” options in the Find dialog are
ignored.

AEM DAM Connector for Adobe® Drive CC

Check-out and version management

12

NOTE: You can search assets based on any metadata information except "File size", "Check in comment", or
"Lock owner" (although these are listed in the search criteria).

Check-out and version management
Photoshop, Illustrator, InDesign, and InCopy automatically check out a managed document when the first
edit is made.


Check the document in using the File > Check In menu.



To cancel checkout, close the document and click Don't Save when prompted for whether changes
should be saved.

In other applications, you must check out manually, modify and save the document and then check in
manually.


In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click
in Mac OS) and choose the desired action from the Adobe Drive menu (Check Out, Check In, or
Cancel Check Out).

Managing document versions
All documents created or modified via the Adobe Experience Manager Digital Asset Management
Connector are versioned. Versions track changes to a document. Each version is a snapshot of the
document at a particular point in time. When you check a document in, you create a new version of the
document on the AEM DAM server.
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In Photoshop, Illustrator, InDesign and InCopy, use the Show Versions popup menu on the status bar
to display the versions of a document in the Versions dialog.



In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click
in Mac OS) for the document or folder, and choose Adobe Drive > Show Versions.

You can use this dialog to delete, promote and open selected versions.

You can also use the UI for the AEM DAM server to display versions of a document, or show different
versions in Adobe Bridge. When multiple versions are shown in Adobe Bridge, the metadata associated
with the currently selected version appears in the Metadata panel.
If you check out an unversioned document, checking in the edited document creates version 1of that
document. If you cancel the checkout, the document remains unversioned.
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Release notes


Some special characters, such as /:[ ]*| , are not supported in file and folder names. Avoid using
them. [2918134].



If an asset is renamed by another user in Adobe Bridge on another machine, its thumbnail and preview
cannot be displayed or opened in Adobe Bridge on a local machine. To correct this, reconnect to the
DAM server. [2947444]



AEM DAM servers do not support event notifications for file and folder changes. If you are browsing in
Adobe Bridge when another user deletes or moves a folder, your window does not automatically
refresh to show the change. Display the parent folder to refresh manually, or clear the Adobe Bridge
cache. [2921270]



The Adobe Experience Manager Digital Asset Management Connector does not support setting the
last modification date of a file, which Adobe applications expect. [2920819]
You might see an alert is some cases; for example:


Open an InDesign file that links to other files, package the file to the server using File > Package,
then open the packaged InDesign file. An alert warns “This document contains links to sources
that have been modified. You can update the modified links now, or update them later using the
Links Panel. “
Choose Update Links to update the modification date.



Create a new file in Photoshop and check it in to the server, leaving it open in Photoshop. If you
double-click the newly created file In Adobe Bridge or a platform file browser, an alert warns: “The
disk copy of “xx” was changed since you last opened or saved it. Do you wish to update it?”
Choose Update to update the modification date. [2920819]



When you check in an edited document from Photoshop or Illustrator, you are prompted to save
it: “The disk copy of 'x' was changed since you last opened or saved it. Do you want to save
anyway?”
The confirmation should not appear, but you can go ahead and confirm. [2617667]



In Adobe Bridge, when you copy or move a file or check in a version after the first one, you cannot
cancel the operation. If you click Cancel in the progress dialog, the operation continues. [3115316]



Adobe Bridge does not correctly display the ColorMode and BitDepth XMP metadata values for a file
that has been checked in to an AEM DAM server. [#3176146]



When you edit the metadata for a file that was previously checked in with a comment, then display the
new version with the changed metadata in the AEM DAM server, it shows the comment from the
previous check-in, rather than a comment about the metadata change or an empty comment.
[3172349]



When you change some IPTC metadata values in the XMP metadata (such as City and Address), using
Adobe Bridge or the AEM DAM server, the changes are not written correctly on save. If the values were
edited in the server, the old value remains. If they were edited in Adobe Bridge, the fields are empty.
[3172354]

