CMIS CONNECTOR
FOR ADOBE DRIVE 4:
TECHNICAL NOTE
Technical Note: CMIS Connector for Adobe Drive 4

Adobe, the Adobe logo, Creative Suite, Illustrator, InDesign, and Photoshop are either registered trademarks or trademarks of Adobe Systems Inc. in the United States and/or other countries. Microsoft and Windows are registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Apple, Mac OS, and Macintosh are trademarks of Apple Computer, Inc., registered in the United States and other countries. Java and Sun are trademarks or registered trademarks of Oracle Corporation, in the United States and other countries. All other trademarks are the property of their respective owners.

The information in this document is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by Adobe Systems Inc. Adobe Systems Inc. assumes no responsibility or liability for any errors or inaccuracies that may appear in this document. The software described in this document is furnished under license and may only be used or copied in accordance with the terms of such license.

Adobe Systems Inc., 345 Park Avenue, San Jose, California 95110, USA.
## Contents

**Overview** .................................................................................................................. 4  
  Supported features ........................................................................................................ 4

**Using the CMIS Connector** .......................................................................................... 5  
  Connecting to a server ................................................................................................... 5  
  Troubleshooting ............................................................................................................ 6  
  Disconnecting ................................................................................................................ 7

**Browsing and manipulating documents and folders** .................................................. 7  
  Creating and deleting documents and folders .............................................................. 8  
  Moving, copying documents and folders ..................................................................... 10  
  Renaming documents and folders .............................................................................. 10  
  Deleting documents and folders .................................................................................. 10  
  Working with custom properties .................................................................................... 10  
  Searching documents and folders ................................................................................ 12

**Check-out and version management** ......................................................................... 12  
  Managing document versions ....................................................................................... 13

**Administering the CMIS Connector** ......................................................................... 16  
  Compatibility requirements ........................................................................................... 16  
  Release notes ................................................................................................................ 16
CMIS Connector for Adobe® Drive 4

Overview

Adobe Drive 4 enables you to connect Creative Suite® 6 to Digital Asset Management (DAM) servers. The connected servers appear in your computer as a mounted hard drive or mapped network drive. Once connected, you can access server files through Windows Explorer or Mac OS Finder, as well as the platform-specific file-access dialogs, and directly through the UI of integrated applications.

Adobe Drive 4 is extensible; an SDK allows partners and third parties to create connectors for particular asset management systems.

Adobe provides some ready-made connectors. The CMIS Connector enables basic access to servers that implement the Content Management Interoperability Services (CMIS) specification. CMIS is a standard for improving interoperability between Digital Asset Management servers. It specifies a domain model, plus a set of services and protocol bindings for web services (SOAP) and AtomPub. See http://en.wikipedia.org/wiki/Content_Management_Interoperability_Services.

Supported features

The CMIS Connector allows you to connect to any server that supports the OASIS CMIS 1.0 Specification, such as Alfresco Community Edition 3.4b and Alfresco Enterprise 3.3.

The connector supports these features:

- Connecting to and disconnecting from a server
- Browsing documents and folders.
- Creating and deleting documents and folders
- Moving and copying documents and folders
- Checking documents out and in
- Managing document versions
- Searching documents
- Viewing, editing, and searching XMP metadata in Adobe Bridge

At this time, CMIS Connector does not support:

- Thumbnails and preview icons in Adobe Bridge
- Thumbnails in the Show Versions dialog
Using the CMIS Connector

Before connecting, you must obtain the server URL for the CMIS AtomPub Service from the administrator of your CMIS server, as well as a valid user ID and password. This document uses the Alfresco CMIS server as an example. CMIS is an open standard; you can use other CMIS server implementations. For information on how to set up and configure the server, refer to your server’s documentation.

Use these URLs for access to Alfresco CMIS servers:

**WEB USER INTERFACE URL:** http://hostname:port/alfresco

Use in a web browser to access the user interface of the CMIS server.

**CMIS ATOMPUB SERVICE URL:** http://hostname:port/alfresco/service/cmis

Use in a web browser to test whether the server is responding.

**SERVER URL:** scheme://hostname:port/alfresco/service/cmis

Use to connect from Adobe Drive 4. It is the same as the CMIS AtomPub Service URL, except that the HTTP protocol is replaced by the optional scheme element, which can be cmis, http, or https.

If you specify http or https, the CMIS connector connects using only the specified scheme. If you use cmis or omit the scheme specification, the CMIS connector tries HTTPS first, then HTTP. When connecting to CMIS servers with different security settings, you must specify the correct scheme in order to establish the connection.

These are the URLs shown in the examples here; if you are using a different vendor or installation, your URLs will be different. You must also replace the user ID and password shown in the samples with ones that are valid for your server.

Connecting to a server

To connect to a CMIS server:

1. Start the Adobe Drive application.
   - In Windows Explorer, right-click a folder, a file, or your desktop, and choose **Adobe Drive 4 > Connect To** from the context menu.
   - In Mac OS, CTRL-click a folder or file in Finder or your desktop, and choose **More > Adobe Drive 4 > Connect To** from the context menu.
2. Click **Add Drive**.

3. If you have the name of a preset server, click it to display the Server URL. Otherwise enter the Server URL manually.

4. Enter your connection details. For example:
   
   ```
   Server URL: cmis://localhost:8080/alfresco/service/cmis
   Name: admin
   Password: admin
   Display Name: Alfresco
   ```

5. Click **Connect**.

6. Check that the server has been mounted in the file browser:
   
   ▶ In Windows Explorer, it should be under My Computer.
   
   ▶ In Mac OS Finder, it should be under Devices.

**Troubleshooting**

If connection fails, open a web browser and test whether the server is available using the CMIS AtomPub Service URL. For example, if you enter `http://localhost:8080/alfresco/service/cmis` and authenticate with your credentials, you should receive an AtomPub service XML document such as this in response:
If you receive no response or an empty response, it is likely that your server is not available or your credentials are incorrect.

Disconnecting

- **In Windows Explorer:** Right-click the CMIS drive and choose Disconnect from the context menu.
- **In Mac OS Finder:** CTRL-click the CMIS drive device and choose Eject from the context menu.
- **In Adobe Bridge:** Select Adobe Drive in the Favorites panel. Right-click (in Windows) or CTRL-click (in Mac OS) the CMIS drive and choose Disconnect from the context menu.
- **In Adobe Drive 4:** Select the server to be disconnected from Recent Connections and click Disconnect.

Browsing and manipulating documents and folders.

Once you are connected, Adobe Drive 4 presents documents and folders from your CMIS server in a network drive on your computer. You can view the server’s files in Windows Explorer or Mac OS Finder. You can also access these files in Open, Save As, and other file management dialog boxes.
You can also use the UI for your CMIS server to view and manipulate documents and folder. For example, an Alfresco server presents content contained in the Company Home space:

Creating and deleting documents and folders

CS6 applications Adobe Photoshop®, Adobe Illustrator®, Adobe InDesign®, and Adobe InCopy® allow you to check in documents directly to the CMIS server. In other applications you must save your document to the CMIS drive and use Windows Explorer, Mac OS Finder or Adobe Bridge CS6 to manually check in the file.

You can create new folders using Windows Explorer, Mac OS Finder or Adobe Bridge CS6, or using the Open, Save As, and other file management dialog boxes in an application.

You cannot create documents or folders at the root of the drive; you must save any new content under a folder in the root that already exists on the server. If you need to create new folders at the root location, you must use the UI provided by your CMIS server.

For example, to create a new document in the CMIS server from Photoshop:

1. Create a new document in Photoshop.

2. Choose File > Check In.
3. In the Save As dialog, navigate to the folder on the CMIS drive where you want to save the document.

4. Enter a check-in comment when prompted, and click **OK**.

Photoshop, Illustrator, and InDesign display the file status in a status bar when you view or edit documents. Once the document is saved to the server, the file status changes to Up-to-Date.

**Automatic check-in for new documents added from file system**

The Settings dialog includes the option "Enable automatic check-in for files added from Finder or Explorer". This option is selected by default; you can use the Settings dialog to add a default check-in comment.

If you do not disable the feature in the Settings dialog, new files that you create on a connected drive using Mac OS Finder or Windows Explorer are automatically checked in with the default comment.

Automatic check-in is not available for files added through Adobe Bridge, Adobe Photoshop, or Adobe InDesign or InCopy.
Moving, copying documents and folders

To move or copy documents or folders on the CMIS server:

In Adobe Bridge:

- Invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder.
- Choose Move To or Copy To from the context menu, then choose the destination folder.
  - Documents moved or copied in this way are automatically checked in.

In Windows Explorer or Mac OS Finder:

- Drag a document or folder to move it to a different location.
- CTRL-drag (in Windows) or OPTION-drag (in Mac OS) to copy to a new location.
  - If you move a document from the desktop to a CMIS drive this way, or copy any document to a new location, you must check it in explicitly.
  - You cannot move or copy documents or folders to the root of a CMIS drive.

Renaming documents and folders

In Adobe Bridge, Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder, and choose Rename.

- You cannot rename documents or folders in the root of a CMIS drive.

Deleting documents and folders

- In Adobe Bridge, Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder, and choose Delete.
- You cannot rename documents or folders in the root of a CMIS drive.
- Deletion from a CMIS server is permanent; deleted files cannot be restored. The Tools > Adobe Drive > Project Trash option in Adobe Bridge, Recycle Bin in Windows, and Trash in Mac OS are not supported.

Working with custom properties

In Adobe Drive 4, the properties of a document object other than those inherited from the cmis:document type are called custom properties.

You can view and edit the custom properties in Adobe Bridge through the CMIS Connector. Right-click the document and choose Custom Properties from the context menu to show the Custom Properties dialog.
Use this dialog to view and edit all available custom properties, both single-valued and multi-valued. Double click a property to view the definition. Valid property value types are String, Integer, and Boolean.

You cannot use this dialog to add or delete properties.

You can also view custom properties in the Adobe Bridge Inspector panel, if you enable this preference:

The Inspector panel displays custom properties for selected assets. If more than one asset is selected, custom properties are displayed only for the first one.
Searching documents and folders

To search for a document or a folder on a CMIS server from Adobe Bridge:

1. Select Adobe Drive from the Favorites panel and open the folder in the CMIS drive you want to search.
2. Choose Edit > Find.
3. Choose search criteria by selecting options and limiters from the Criteria menus.
4. Enter search text in the box on the right. To add search criteria, click the plus sign (+). To remove search criteria, click the minus sign (-).

You can search using any custom properties that are searchable.

5. Choose an option from the Match menu to specify whether any or all criteria must be met.
6. Click Find.

The "Search includes all versions of a file" and "Search includes deleted files" options in the Find dialog are ignored.

Check-out and version management

Adobe Photoshop, Adobe Illustrator, and Adobe InDesign automatically check out a CMIS document when the first edit is made.

- Check the document in using the File > Check In menu.
- To cancel checkout, close the document and click Don't Save when prompted for whether changes should be saved.

In other applications, you must check out manually, modify and save the document and then check in manually.
In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click in Mac OS) and choose the desired action from the Adobe Drive 4 menu (Check Out, Check In, or Cancel Check Out).

Managing document versions

All documents created or modified via the CMIS Connector are versioned. Versions track changes to a document. Each version is a snapshot of the document at a particular point in time. When you check a document in, you create a new version of the document on the CMIS server.

In Adobe Photoshop, Adobe Illustrator, and Adobe InDesign use the Show Versions popup menu on the status bar to display the versions of a document in the Versions dialog.

In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder, and choose Adobe Drive 4 > Show Versions.

You can use this dialog to delete, promote and open selected versions. The CMIS Connector does not provide preview thumbnails.

You can show different versions in Adobe Bridge. When multiple versions are shown in Adobe Bridge, the metadata associated with the currently selected version appears in the Metadata panel.

You can also use the UI for the CMIS Server to display versions of a document. For example, in the Alfresco UI, the Details view presents the version history.
In order for the CMIS Connector to access version information, the CMIS server must support a version label of the form `major.minor` (such as “1.0”).

- The CMIS Connector always checks in a document as a major version.
- When checking out a file, the CMIS Connector always uses the latest version, even if it is a minor version.

The first version of a document has a version label of 1.0, the second 2.0 and so on. The Versions dialog does not show minor version numbers. For this reason, you may want to avoid using minor versions in your workflows; that is, avoid checking in minor versions of a document using the user interface of your CMIS server.

If you check out an unversioned document, the CMIS Connector converts it into a versioned document with version label 1.0 on checkout. Checking in the edited document creates version 2.0 of that document. If you cancel the checkout, the document remains at version 1.0. It is not converted back to an unversioned document.

### Administering the CMIS Connector

#### Compatibility requirements

To be compatible with the CMIS Connector the server must:

- Implement the OASIS CMIS 1.0 Specification.
- Make CMIS services available via the Restful AtomPub Binding.
- Support versioning of documents (that is, the `cmis:versionable` attribute for the document object type must be `true`; see Document Object-Type Definition).
- Implement a `cmis:versionLabel` property of the form “`major.minor`” such as “1.0”.

#### Release notes

These issues are known to occur in this release:

- Thumbnails and preview icons are not available in Adobe Bridge.
- Thumbnails are not available in the Versions dialog.
- Browsing or refreshing a folder containing many documents or sub-folders is slow. The recommended maximum number of documents / sub-folders in a folder is 200.
- The maximum number of items in a search result may be constrained by the CMIS server to a fixed number such as 1000. Paging of search results is not supported by Adobe Drive so the CMIS Connector does not specify a maximum number of items to return in a search result set. [#2657944]
- Document and folder names containing two or more space characters get reduced to one space character on creation in the CMIS Server. On Alfresco this is a server side issue. For example say you have a document named “A. B.png” with two spaces in it. On upload the name is changed to “A B.png” with only one space. See Alfresco has issues with folder name containing two space characters via CMIS. [#2651332]
On checking in an edit to a document from Adobe Photoshop and Adobe Illustrator an alert reading “The disk copy of 'x' was changed since you last opened or saved it. Do you want to save anyway?” is shown unexpectedly. On Alfresco this is caused by a server side issue which causes the modification date for a document to be updated on check out. Workaround is to click the OK button. [#2617667]

On closing a document that has been edited but never saved and choosing “Don’t Save” button in the alert dialog, the document remains checked out. On Alfresco this is caused by a server side issue with causes the modification date for a document to be updated on check out. Workaround is to cancel check out the document manually. [#2617667]

On opening a document in Adobe Photoshop, modifying it and then using Edit > Undo or Edit > Step Backward the document remains checked out and displays the file status Checked out by me. Workaround is to close the document and click the Don’t Save button and then cancel check out the document manually to revert the edits. [#2634585]

Workflows where several people logon to the CMIS server using the same login credentials should be avoided. For example, say two people login to the server using the same username on different computers. Adobe InDesign may crash if both of these people edit the same INDD file and then check it in at the same time. The CMIS Connector can only enforce locking for a specific user rather than a specific user on a specific computer. [#2640390]

Adobe InDesign may hang if a user checks in a document which another user moved or renamed on the server while the document was being edited. The CMIS Connector polls the server when a document is open to find out if it has changed on the server. The issue only occurs when a user opens a file, the file is moved or renamed on the server by another user, and the user checks out the file before polling detects the change. To mitigate this issue the polling interval has been set to 10 seconds. [#2651219]

Adobe Bridge becomes unresponsive on Mac OS when browsing a folder and the Please wait, Browsing message is displayed in the Content panel. Workaround is to wait, since both Adobe Drive and Bridge have a cache the next time the folder is entered the response will be faster. Alternatively limit the number of files in your folders to less than 200. [#2653773]

Adobe Bridge does not display the promoted version in the Content panel after using Promote to Current Version. Workaround is to manually refresh the view. [#2641021]

Windows Explorer displays a Location is not available alert on renaming a newly created folder if the user hits the enter key twice in quick succession after entering the folder name. Workaround is to click OK on the alert and continue working. The folder can be used. [#2643736]

CMIS does not support event notifications on file and folder changes; the CMIS Connector uses a polling mechanism with a 10-second interval to detect file and folder changes. To improve performance, the CMIS connector only observes files opened by Adobe point products. This leads to some refresh issues in Adobe Bridge when one user is browsing in Bridge while another user deletes or moves a folder. To refresh the view, you can display the parent folder, then refresh manually, or clear the Adobe Bridge cache.

CMIS does not support setting the last modification date of a file, which Adobe point products expect [#2667384]. In some cases users may see an alert; for example:

- Open an InDesign file that links to other files, package the file to the server using File > Package, then open the packaged InDesign file. An alert warns “This document contains links to sources that have been modified. You can update the modified links now, or update them later using the Links Panel.” Choose Update Links to update the modification date.
Create a new file in Photoshop and check it in to the server, leaving it open in Photoshop. If you double-click the newly created file in Adobe Bridge or a platform file browser, an alert warns: “The disk copy of “xx” was changed since you last opened or saved it. Do you wish to update it?”. Choose Update to update the modification date.

In order to use secure HTTP (HTTPS) to connect to a CMIS server, you must configure the server to enable HTTPS. There are two ways to set up the CMIS Connector to connect to a server using HTTPS:

1. Connect directly to the HTTPS port. For example, when the server is configured to accept HTTPS requests on port 443, you can simply specify that port. Enter `cmis://yourserver:443/alfresco/service/cmis` as the server URL in the Adobe Drive Connect UI.

2. Connect to an HTTP port that is configured to redirect requests to HTTPS. The port you connect to must redirect to port 443.

If you are connecting to an IBM FileNet P8 server, renaming a file causes the subsequent check-in or move operation to fail. Avoid renaming files on this server. [2927054]

When you check out a file from an Alfresco 4 server, the string “working copy” is appended to the file name, with a warning about file renaming. The string is removed on check-in, with another warning. [3181833]