Contents

Chapter 1: Resources
Help and support ................................................................. 1
Services, downloads, and extras ........................................... 1

Chapter 2: Using the Extension Manager
Downloading and installing extensions ................................... 3
Managing extensions ............................................................ 4
Packaging and submitting extensions .................................... 5
Working from the command line ........................................... 6

Index ...................................................................................... 10
Chapter 1: Resources

Before you begin working with your software, take a few moments to read an overview of the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more.

Help and support

Community Help

Community Help is an integrated environment on adobe.com that gives you access to community-generated content moderated by Adobe and industry experts. Comments from users help guide you to an answer. Search Community Help to find the best content on the web about Adobe products and technologies, including these resources:

- Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.
- Complete online Help, which is updated regularly and is more complete than the Help delivered with your product. If you are connected to the Internet when you access Help, you automatically see the complete online Help rather than the subset delivered with your product.
- All other content on Adobe.com, including knowledgebase articles, downloads and updates, Developer Connection, and more.

Use the help search field in your product’s user interface to access Community Help. For a video of Community Help, see www.adobe.com/go/lrvid4117_xp.

Other resources

Printed versions of the complete online Help are available for the cost of shipping and handling at www.adobe.com/go/store. Online Help also includes a link to the complete, updated PDF version of Help.

Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.

Services, downloads, and extras

You can enhance your product by integrating a variety of services, plug-ins, and extensions in your product. You can also download samples and other assets to help you get your work done.

Adobe creative online services

Adobe Creative Suite 4 includes new online features that bring the power of the web to your desktop. Use these features to connect with the community, collaborate, and get more from your Adobe tools. Powerful creative online services let you complete tasks ranging from color matching to data conferencing. The services seamlessly integrate with desktop applications so you can quickly enhance existing workflows. Some services offer full or partial functionality when you’re offline too.
Visit Adobe.com to learn more about available services. Some Creative Suite 4 applications include these initial offerings:

**Kuler™ panel** Quickly create, share, and explore color themes online.

**Adobe® ConnectNow** Collaborate with dispersed working teams over the web, sharing voice, data, and multimedia.

**Resource Central** Instantly access tutorials, sample files, and extensions for Adobe digital video applications.

For information on managing your services, see the Adobe website at http://www.adobe.com/go/learn_creativeservices_en.

**Adobe Exchange**
Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as thousands of plug-ins and extensions from Adobe and third-party developers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

**Adobe downloads**
Visit www.adobe.com/go/downloads to find free updates, tryouts, and other useful software.

**Adobe Labs**
Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

- Prerelease software and technologies
- Code samples and best practices to accelerate your learning
- Early versions of product and technical documentation
- Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users.

Adobe Labs fosters a collaborative software development process. In this environment, customers quickly become productive with new products and technologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.

**Adobe TV**

**Extras**
The installation disc contains a variety of extras to help you make the most of your Adobe software. Some extras are installed on your computer during the setup process; others are located on the disc.

To view the extras installed during the setup process, navigate to the application folder on your computer.

- **Windows®**: [startup drive]\Program Files\Adobe\[Adobe application]
- **Mac OS®**: [startup drive]/Applications/[Adobe application]

To view the extras on the disc, navigate to the Goodies folder in your language folder on the disc. Example:

- /English/Goodies/
Chapter 2: Using the Extension Manager

The Adobe® Extension Manager lets you install and manage extensions in a number of Adobe® Creative Suite® applications. You can also use it to submit your own extensions on the Adobe Exchange website.

Downloading and installing extensions

An extension is a piece of software that can be added to an Adobe application to enhance its capabilities. You can add extensions to Dreamweaver®, Flash®, Fireworks®, Photoshop®, InDesign®, Illustrator®, Contribute®, and Adobe Bridge.

About the Extension Manager

The Extension Manager provides an easy and convenient way to install and delete extensions in Adobe applications, and to find information about extensions you installed. It also provides a convenient way to navigate to the Adobe Exchange site. You can find more extensions, get information about extensions, and rate extensions that you used.

The Extension Manager is automatically installed when you install your Adobe application.

Note: The Extension Manager only displays extensions that were installed with the Extension Manager application or with Extension Manager commands from the command line. Extensions that are installed using a third-party installer or local changes made to your configuration files do not appear in the Extension Manager.

The Adobe Exchange website at [www.adobe.com/go/exchange](http://www.adobe.com/go/exchange) is a repository for many types of extensions. Some extensions on the website are created by Adobe and some are created by other developers. If you find a non-commercial extension you’re interested in, you can download and install it in an application using the Extension Manager. Some extensions on the Exchange are commercial and cannot be downloaded immediately. The download link redirects you to the author’s website so you can obtain purchasing information.

Download extensions


   The Adobe Exchange is one of the most comprehensive sites for extensions. You can view the highest rated, most downloaded, and featured extensions.

2. Select an extension to start the download.

3. Save the extension on your hard disk and take a note of its location.

Install extensions

You can use Extension Manager CS4 to install extensions in the CS4 applications that support it. However, you cannot use it to install extensions in earlier versions of the applications. To install extensions in earlier versions of Dreamweaver, Flash, or Fireworks, use the Extension Manager installed with those products.

1. Double-click the extension file in Windows® Explorer (Windows) or in the Finder (Macintosh®).

2. Read the Adobe extensions disclaimer and any third-party extension license.

Select Accept to continue with the installation, or select Decline to cancel the installation.
3 If you have installed another version of the extension or have another extension with the same name, the Extension Manager asks if you want to disable or overwrite it. Select Yes to replace the previously installed extension with the new extension, or No to cancel the installation and leave the existing extension in place.

4 When asked if you want to replace one or more existing files, select Yes or Yes To All to accept the versions included in the extension. Select No to keep the current version of the file. If you click Cancel, the installation stops and no files are installed or replaced.

If the Extension Manager doesn’t encounter any problems, it informs you that the extension has been successfully installed.

**Note:** For some types of extensions, the changes only take effect after you close and restart the application.

If an extension modifies a configuration file, such as menus.xml, the Extension Manager creates a backup of the affected configuration file (for example, menus.xbk) before installing the extension. In the unlikely event that the extension damages the configuration file, you can restore it with the backup file.

**Important:** Adobe recommends that you not modify configuration files by hand. Incorrectly modifying them can cause significant portions of the product to fail and prevent the installation of other extensions. Modify configuration files only by using the Extension Manager.

See also
“Working from the command line” on page 6

## Managing extensions

The first time you launch the Extension Manager, you are given the choice of migrating previously installed extensions. If you select Yes, the Extension Manager migrates all compatible extensions and prompts you to restart the application. Once restarted, you can enable any previously installed extension by clicking the Enabled checkbox next to it in the Extension Manager.

You can use Extension Manager CS4 to manage extensions developed for Dreamweaver CS4, Flash CS4, Fireworks CS4, Photoshop CS4, InDesign CS4, Illustrator CS4, Contribute CS4, and Bridge CS4. However, you can’t use it to manage extensions in earlier versions of these products. To manage extensions in earlier versions of Dreamweaver, Flash, or Fireworks, use the Extension Manager installed with those products.

### Launch the Extension Manager

- Launch the Extension Manager from the Start menu in Windows or the Applications folder on the Macintosh.

You can also launch the Extension Manager from Dreamweaver, Flash, or Fireworks by selecting Help > Manage Extensions.

### Sort installed extensions

- In the Extension Manager, click a column heading such as Enabled, Version, or Author.

For example, to sort alphabetically by author name, click the Author column. To reverse the order of the sort, click the column heading again.
Enable or disable installed extensions
❖ In the Extension Manager, select the Enabled checkbox next to the extension you want to enable or disable.
If you installed large numbers of extensions, you can selectively enable and disable them to help manage the performance of the application.

Remove an extension
Removing an extension uninstalls it from the application.

1 In the Extension Manager, select an Adobe application from the list of installed programs in the left sidebar.
A list displaying currently installed extensions appears.
2 Select an extension from the list of installed extensions.
If an extension doesn’t appear in the list, you can’t remove it.
3 Click the Remove icon. Confirm that you want to remove the extension by choosing Yes in the confirmation dialog box.

Note: Do not manually remove disabled extensions from the Disabled folder. If you do, necessary changes to your configuration files are not completed.

Obtain information about an extension
❖ Select an installed extension listed in the Extension Manager and review the information in the bottom half of the window.

Go to Adobe Exchange
You can get more information about an extension, rate an extension you’ve used, or find more extensions on the Adobe Exchange.
❖ In the Extension Manager, select File > Go to Adobe Exchange.
The Exchange Manager starts your browser and loads the Adobe Exchange website. You can find information about any posted extension, rate extensions you’ve used, and search for and download a wide variety of extensions.

Packaging and submitting extensions
You can use the Adobe Extension Manager to package your own extensions before submitting them to Adobe for distribution on the Adobe Exchange website. After packaging an extension, test it by using the Extension Manager to install it locally. Guidelines for writing and testing your extensions can be found on the Adobe Exchange website (www.adobe.com/go/exchange). For information on how to configure and test extensions, review the “How do I ensure that my extension will pass Adobe testing?” section of the Adobe Exchange site help. After you have written and tested your extension, you can package and submit it.

You can find more resources for creating extensions in Extending Dreamweaver Help, Extending Flash Help, and Extending Fireworks Help.

Package an extension
1 Test your extension thoroughly.
For information on how to configure and test extensions, review the “How do I ensure that my extension will pass testing?” section of the Adobe Exchange site help.

2. If you want, create an icon to display next to your extension in the Extension Manager. Make the icon a PNG or GIF measuring 24 pixels by 24 pixels.

If you don’t provide your own icon, the default icon is used.

3. Copy all of the files for your extension to a staging folder for ease of packaging.

All the files don’t have to be at the same level of the folder hierarchy. Specify a path to each file relative to the installation file using the `<file>` tag in the extension installation file (MXI file—see the next step). However, it’s easier to keep track of all the files if you don’t try to package them directly from their installed locations in the Configuration folder.

4. Create an extension installation file (a filename ending in .mxi) for your extension.

The MXI file is an XML file that specifies attributes of the extension, including the extension name, a description of the extension, version number, and type. The file also specifies each file included in the extension, including any custom icon you want to use. To specify a description of your extension, you can use HTML in your text or link to a local HTML file. You can also link to a remote HTML page when the user has an Internet connection. For more information, see the Extension Installation File Format document, which you can download from the Adobe website at www.adobe.com/go/em_file_format.

You’ll find several sample MXI files for Dreamweaver, Flash, and Fireworks in the following folders in the Extension Manager application folder: Samples/Dreamweaver, Samples/Flash, and Samples/Fireworks.

5. In the Extension Manager, select File > Package Extension.

6. In the file-selection dialog box that appears, browse to your MXI file to select it, and then click Open.

7. Select a location for the package file, give it a name (ending in .mxp), and click Save.

   **Note:** The extension package filename must not contain spaces. It must also be valid on both Windows and Macintosh platforms.

The Extension Manager creates a package file containing compressed versions of all the files used by the extension, including the MXI file.

8. Install and test the extension to make sure everything works as intended.

### Submit an extension

1. In the Extension Manager, select File > Submit Extension.

The Adobe Exchange submission page opens in your browser.

2. Follow the instructions on the page and proceed until you receive a confirmation message.

### Working from the command line

You can use the command line to perform various operations you would normally perform in the Extension Manager workspace.
Extension Manager command-line basics

You can manage extensions from the command line, using certain syntax, commands, and attributes.

1. In Windows, open the command prompt by selecting Start > All Programs > Accessories > Command Prompt. On the Macintosh, open Terminal by double-clicking its icon in the Applications/Utilities folder.

2. In Windows, navigate to the following folder:
   - C:\Program Files\Adobe\Adobe Extension Manager CS4\

3. On the command line, enter the executable as follows (including the double quotes):
   - Windows: "Adobe Extension Manager CS4.exe"
   - Mac: "~/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4"

4. After the executable, enter the desired command. The available commands are as follows:
   - **-package** Package an extension. Required attributes: mxi, mxp.
   - **-install** Install an extension. Required attribute: mxp.
   - **-remove** Remove an extension. Required attributes: product, extension.
   - **-enable** Enable an extension. Required attributes: product, extension.
   - **-disable** Disable an extension. Required attributes: product, extension.
   - **-locate** Locate the point product in the Extension Manager workspace. Required attribute: product.
   - **-suppress** Suppress the license dialog box and success confirmation message when installing. Must precede the install command. Attributes: none.
   - **-locale** Specify a locale when installing. Must precede the install command. Required attribute: lang.
   - **-EMBT** Implement a command through BridgeTalk. Can be used with any of the other commands. Must precede the command. Attributes: none.

The available attributes are as follows:

- **mxi** Specifies the name and location of the extension installation file.
- **mxp** Specifies the name and location of the package file.
- **product** Specifies the product that uses the extension.
- **extension** Specifies the name of the extension (as specified in the MXI file).
- **lang** Specifies the locale language code, such as en_US.

Package an extension from the command line

1. Navigate to the Extension Manager application folder. For more information, see the previous command-line basics topic.

2. Enter the following command, specifying your own attribute values:
   - Windows: "Adobe Extension Manager CS4.exe" -package mxi="c:\myfile.mxi" mxp="c:\myfile.mxp"
   - Mac: "~/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -package mxi="~/myfolder/mysubfolder/myfile.mxi" mxp="~/myfolder/mysubfolder/myfile.mxp"
If you want to package an extension through BridgeTalk, add the EMBT command before the package command, as follows:
- Windows: "Adobe Extension Manager CS4.exe" -EMBT -package mxi="c:\myfile.mxi" mxp="c:\myfile.mxp"
- Mac: '/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -EMBT -package mxi="/myfolder/mysubfolder/myfile.mxi" mxp="/myfolder/mysubfolder/myfile.mxp"

Install and test the extension to make sure everything works as intended.

Install an extension from the command line
1 Navigate to the Extension Manager application folder. For more information, see the command-line basics topic.
2 Enter the following command, specifying your own attribute value:
- Windows: "Adobe Extension Manager CS4.exe" -install mxp="c:\myfile.mxp"
- Mac: '/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -install mxp="/myfolder/mysubfolder/myfile.mxp"
3 To install the extension through BridgeTalk, add the EMBT command before the install command, as follows:
   ... -EMBT -install mxp="c:\myfile.mxp"
4 To suppress the license dialog box and success confirmation message, add the suppress command before the install command, as follows:
   ... -suppress -install mxp="c:\myfile.mxp"
5 To suppress the installation dialog boxes through BridgeTalk, add the EMBT command before the suppress command, as follows:
   ... -EMBT -suppress -install mxp="c:\myfile.mxp"
6 To specify a locale, add the locale command and specify the lang attribute before the install command, as follows:
   ... -locale lang="en_US" -install mxp="c:\myfile.mxp"
7 To specify a locale through BridgeTalk, add the EMBT command before the locale command, as follows:
   ... -EMBT -locale lang="en_US" -install mxp="c:\myfile.mxp"
8 Test the extension to make sure everything works as intended.

Remove an extension from the command line
1 Navigate to the Extension Manager application folder. For more information, see the command-line basics topic.
2 Enter the following command, specifying your own attribute values:
- Windows: "Adobe Extension Manager CS4.exe" -remove product="Dreamweaver CS4" extension="Sample"
- Mac: '/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -remove product="Dreamweaver CS4" extension="Sample"

Use the product attribute to specify the product that uses the extension. Use the extension attribute to specify the name of the extension.
3 To remove an extension through BridgeTalk, add the EMBT command before the remove command, as follows:
   ... -EMBT -remove product="Dreamweaver CS4" extension="Sample"
Enable an extension from the command line

1. Navigate to the Extension Manager application folder. For more information, see the command-line basics topic.
2. Enter the following command, specifying your own attribute values:
   - Windows: "Adobe Extension Manager CS4.exe" -enable product="Dreamweaver CS4" extension="Sample"
   - Mac: "/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -enable product="Dreamweaver CS4" extension="Sample"

Use the product attribute to specify the product that uses the extension. Use the extension attribute to specify the name of the extension.
3. To enable an extension through BridgeTalk, add the EMBT command before the enable command, as follows:
   ... -EMBT -enable product="Dreamweaver CS4" extension="Sample"

Disable an extension from the command line

1. Navigate to the Extension Manager application folder. For more information, see the command-line basics topic.
2. Enter the following command, specifying your own attribute values:
   - Windows: "Adobe Extension Manager CS4.exe" -disable product="Dreamweaver CS4" extension="Sample"
   - Mac: "/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -disable product="Dreamweaver CS4" extension="Sample"

Use the product attribute to specify the product that uses the extension to be disabled. Use the extension attribute to specify the name of the extension.
3. To disable an extension through BridgeTalk, add the EMBT command before the disable command, as follows:
   ... -EMBT -disable product="Dreamweaver CS4" extension="Sample"

Locate the point product in the Extension Manager workspace

1. Navigate to the Extension Manager application folder. For more information, see the command-line basics topic.
2. Enter the following command, specifying your own attribute value:
   - Windows: "Adobe Extension Manager CS4.exe" -locate product="Dreamweaver CS4"
   - Mac: "/Applications/Adobe Extension Manager CS4/Adobe Extension Manager CS4.app/Contents/MacOS/Adobe Extension Manager CS4" -locate product="Dreamweaver CS4"

Use the product attribute to specify the product to locate.
3. To locate the point product through BridgeTalk, add the EMBT command before the locate command, as follows:
   ... -EMBT -locate product="Dreamweaver CS4"
Index

A
Adobe Exchange 2
Adobe Exchange website 3

B
backup files 4

C
command line 6
Community help 1
Community search engine 1
configuration files
  backups 4
  modifying 4

D
disabling extensions 5
downloads
  updates, plug-ins, and tryouts 2

E
Exchange 2
Extension Manager 3
extensions
  about 3
  enabling and disabling 5
  finding more 5
  getting information 5
  installation files 6
  installing 3
  managing 4
  package files 6
  packaging 5
  rating 5
  removing 5
  saving 3
  sorting 4
  submitting 5
  viewing 3
Extras 2

I
installation files 6
installing extensions 3

M
managing extensions 4
modifying configuration files 4
MXI files 6
MXP files 6

O
online resources 2

P
package files 6
packaging extensions 5
plug-ins
  in Adobe Store 2

R
rating extensions 5
removing extensions 5

S
saving downloaded extensions 3
software
  downloads 2
  sorting extensions 4
  submitting extensions 5

T
tryouts 2

U
updates 2

V
viewing extensions 3