Create and manage projects

Create a project

  1. Do one of the following:
    • Select File > New > Project.

    • In the Starter pod, click More under Create New.

  2. On the New pane in the New Project dialog box, double-click a project type. You can change the project type after your project is created.

    Blank Project
    Customize and publish a project in any output. You can modify the window settings for WebHelp, FlashHelp, and HTML Help outputs.

    Application Help
    Create a Help system that you can install locally. The Application Help project has sample topics with notes on how you can customize and modify the information. For example, you can create a Help system to document information about a company product.
    Note: By default, the Application Help does not use master pages or snippets but you can always add them.

    e-Handbook
    Create a project for an electronic handbook, such as an employee handbook for a company. The e-Handbook project template provides the relevant folders and topics for you to place company-specific information.

    e-Learning
    Integrate and organize Captivate demos into a project. Using the layout and recommendations provided, you can create computer-based and web-based training.

    Knowledge Base
    Create a knowledgebase that has an interface similar to a wiki page. The knowledgebase project template contains master pages that you can customize. You can also create self-updating pages.

    Web Application Help
    Create a Help system that you can publish on a server. The Web Application Help project has sample topics with notes on creating online Help for a software application.

    Department Guidelines
    Create a Help system to outline guidelines for a department in a company. For example, you can create Help for a human resources department, outlining guidelines on recruitment and selection, flexible working hours, and so on.

    Disaster Recovery Plan
    Create a Help system with samples on how to write a disaster recovery plan.

    Online Manual
    Create an online manual for a company product or software application.

    Policies And Procedures
    Create a handbook or a document listing policies and procedures specific to an organization.

    Custom
    Customize a Help project template.

  3. Specify options in the New Project Wizard dialog box:

    • RoboHelp stores the project title in a field called Project Title. You can insert the field in topic contents, snippets, master pages, and screen layouts.

    • Leave Language as English or select another language to localize the project. Spell checking, indexing with the Smart Index Wizard, and parts of the user interface are localized.

    • If you select Save As Default, the selected language is used for all new projects.

  4. Click Finish.

The first topic opens in the Design Editor on the right. On the left, the Project Manager opens. The first topic is selected in the HTML Files (Topics) folder.

Create a project by importing documents

  1. Do one of the following:
    • From the Starter pod, select a new project type from the Import list.

    • Select File > New > Project. Click the Import tab and select a new project type.

  2. Follow the prompts. The new project opens in RoboHelp.

Create a project using FrameMaker or Word documents

You can create new projects by importing FrameMaker or Word documents. While importing, you can map the styles of these documents to styles in RoboHelp.
  1. Select File > New > Project and click Import.

  2. Select FrameMaker or Word documents and click OK.

  3. Select from .book, .mif, .fm, .bk, and .frm files for FrameMaker and .doc, .docx, .rtf, and .docm files for Word. You can import multiple FrameMaker or Word documents at the same time. You can import .book and .bk files one at a time.

    Note: For any FrameMaker format other than MIF, FrameMaker 8 or later is required. If the correct version is not installed, you cannot import the file.
  4. Enter the project title, filename, and location of the project.

  5. Click Finish.

    A new project wizard prompts you to select options to map the TOC, index, or glossary.

  6. Select the required options, and click Next.

  7. Click Edit.

  8. Select styles to map to the RoboHelp styles.

    For information about different conversion options for FrameMaker documents, see Conversion basics.

    For information about different conversion options for Word documents, see Converting Word styles to RoboHelp styles.

  9. Click OK.

    Note: If you click Cancel in the wizard, no files are imported and the empty project remains open.
  10. Click Finish.

Create a project using a DITA map file

Important: For expert users only.

Before you import a DITA map file, Java JDK and the DITA Open Toolkit must be installed and running properly. Experience with DITA and the DITA Open Toolkit is also required.

  1. Select File > New > Project.

  2. Click the Import tab.

  3. Select DITA Map File.

  4. Click OK.

  5. Enter the following information in the New Project wizard:
    DITA Map File To Import
    Specify path to a valid DITA map file that you want to import and create a project. Click the Browse button   to select the file.

    Location Of The Project
    Specify path to the location of the new project.

  6. Click Next.

  7. Specify the input required on the Open DITA Toolkit Processing Options dialog box.

  8. Click Finish.

Save projects

Save frequently while you work.

  • To save individual files, select File > Save [item].

  • To save all files, click the Save All button .

Disable auto-save

By default, RoboHelp saves changes when you close the project. If you prefer, you can disable the auto-save feature.

  1. From the Tools menu, select Options.

  2. Click the General tab.

  3. Under Options, deselect Save Without Prompt.

Opening a project

Open a project when starting RoboHelp

 From the Starter pod listing recently opened projects, click the project name. If you don’t see the project you want, click Open.

You can use the following controls to locate the project you want to open:

My Places bar
Find documents by using the shortcuts to the left of the Folder and Files list.

Desktop
The Desktop folder lists all folders on your desktop.

My Computer
The My Computer folder lists the hard drives configured on your computer.

My RoboHelp Projects
The My RoboHelp Projects folder is the default working folder where RoboHelp stores all projects. This folder is placed in the My Documents folder when Adobe RoboHelp is installed. When you start Adobe RoboHelp, projects stored in the My RoboHelp Projects folder are automatically listed in the Starter pod under the Recent Projects list. All RoboHelp projects use the .xpj filename extension.

Look in list
By default, this list displays the My RoboHelp Projects folder. Alternatively, if you have accessed other folders, the last folder you accessed, is selected in this list. This list includes the My Computer, My Network Places, and My Documents folders under the Desktop folder.

Go To Last Folder Visited icon
Displays the last folder you accessed. Click the arrowhead to view a list of the most recent folders you visited. This icon is disabled if you do not access a folder in the dialog box.

Up one level icon
Enables you to move to the parent folder of the current folder displayed in the Look in list.

Delete icon
Enables you to delete a selected folder or file. The deleted folder or file is sent to the Recycle Bin.

Create New Folder icon
Enables you to create a folder under the parent folder selected in the Look in list.

View Menu icon
The arrowhead enables you to choose the view in which the folder and file list must be displayed. You can view the folders and files as thumbnails, tiles, icons, a simple list, or a list with details of the folders or files.

Tools icon
Enables you to delete or rename a folder or file, add a folder or file to the My Places bar, or map a hard drive to a computer or folder on your network. You can also view properties of a folder or file.

File Namebox Enables you to specify the name of the file to access (to open, to import, and so on.)

Files Of Type menu
Enables you to select the type of files to list in the folder and file list.

Open a project after starting RoboHelp

  1. Select File > Open. The Open Project dialog box appears.

    Note: You can also select the last ten projects opened from the bottom of the File menu.
  2. Select RoboHelp HTML Help Project (.xpj) from the Files Of Type menu.

  3. Locate the project file, and double-click it.

Adobe recommends

Creating and opening Webhelp projects

David Rivers
David Rivers shows new RoboHelp users how to get started with RoboHelp. You learn to start new projects and open existing projects.

Upgrading a project

If you open a project created in a previous version of RoboHelp, you are asked whether to convert it before opening it.

Important: Make a copy of your project before converting it into the new format.

Pin a project to the list of recently opened projects

By default, the list of recent projects that appears in the Starter pod and in the File menu displays up to the last ten projects opened. Pin a recently opened project so that it always appears in the recent projects’ list. The list displays the pinned projects and recently used projects up to the number of projects set in the Max Projects field.

  1. Select Tools > Options.

  2. On the Recent Projects tab, select a project from the Recently Opened Projects list.

  3. Click Pin. Click OK.

    Note: Click Unpin to remove a pinned project from the recent projects’ list.

Change project settings

  1. Choose File > Project Settings.

  2. On the general tab, change settings as needed:

    Project Title
    Enter a project title. This title appears in the window bar of the output.

    Primary Output/Layout
    Select a primary layout.

    Language
    Select the default project language.

    Advanced
    Click to create or edit lists for localization. Set options in each pane.

    To Do List
    Click Manage to manage the To Do list for your project. For more information, see Using the To Do list.

    Index
    Select an option for saving keywords:
    • Index File (HHK) saves new index keywords in the project index file (HHK).

    • Topics saves new index keywords in individual topic files (HTM).

    • Binary Index uses a binary index in Microsoft HTML Help projects.

Adobe recommends

Changing project settings

David Rivers
Learn how to change project settings, such as the primary layout and the default language.

Set options on the Stop List pane

Use the Stop List tab to modify words contained in the Stop List file ProjectName.stp. A Stop List contains common words (for example, “a” or “the”) that the search ignores for an accurate result.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

Reset To Default
Removes the new entries and restores the default list.

New
Adds a word. Click New. Type the word. Press Enter.

Delete
Deletes a selected word.
Note: In Microsoft HTML Help projects, the stop list file can’t be larger than 512 K. If the file is larger, words at the end of the file are not included in the CHM file.

Set options on the Phrases pane

Modify words in the Phrases file ProjectName.phr. This tab contains a phrase list the Smart Index Wizard includes in keyword searches. For example, make project settings one phrase, not two words. You can add, rename, and delete words.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

Reset To Default
Removes the new entries and restores the default list.

New
Click New. Type the new word. Press Enter.

Set options on the “Always Ignore” Words pane

Modify words in the Always Ignore Words file ProjectName.ign. This list contains “noise” words such “as,” “the,” or “a.” The Smart Index wizard uses the list to keep the noise words out of the index.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

Reset To Default
Removes the new entries and restores the default list.

New
Click New. Type the new word. Press Enter.

Set options on the LNG File pane

Change text elements in the user interface for Multiscreen HTML5, WebHelp, WebHelp Pro, FlashHelp, FlashHelp Pro, AIR Help, printed documentation, or HTML Help output.

See the complete list of available changes you can make in the LNG file tab.

When you edit the LNG file, your changes supersede settings made in Project Settings in other locations.

 Select an element, and click either of the following:
Edit
Modify LNG file text for each user interface element listed. In Edit mode, you can also right-click on the edited line to undo the edits, cut, copy, paste, delete, or select all.
Note: You can change the string to show expanding or collapsing topic TOCs in settings for master pages. For more information, see Master pages.

Reset To Default
Erases the new entries and restores the default list.

Note: For quick access to these options, you can select Edit > LNG File.

Set options on the Synonyms pane

Define words as synonyms. For example, you can define “find” and “locate” as synonyms for “search.” In the generated output, when a user searches for “search,” results for “find” and “locate” are also displayed.

Reset To Default
Removes the new entries and restores the default list.

Edit
Select a word, click Edit. Type the new name. Press Enter. Right-click the word to display a drop-down box with the Undo, Cut, Copy, Paste, Delete, and Select All options.

New
Click to add a new word in the Synonym table and specify a synonym for it.

Delete
Click to delete the Word and its synonyms.

Rename a project

When you rename a project, the main project file (.xpj) and all other project files are renamed.
Note: The TOC, index, and glossary files are not renamed.
When you rename a project, the project closes and reopens. Any changes made since last saving are saved.
Note: You cannot rename projects under version control.
  1. Open the project.

  2. Select File > Rename Project.

  3. In the Project Name box, enter the new project name (do not enter a filename extension).

  4. Click OK. To make the changes take effect, the program closes and then reopens the project.

Note: If you are creating Microsoft HTML Help, the name of the compiled HTML Help file (CHM file) is based on the project filename. If you change the project name, the name of the CHM file changes as well. You can rename the CHM file to restore the old name.

Viewing projects

Help systems are displayed in a browser or viewer, depending on the output type, the application platform, and the platforms of your end users. Help systems are displayed in a main window. Users can view topics in the right pane and navigate with tabs, buttons, and toolbars in the left pane and along the top.

View your project often to test links and make sure that styles appear properly. View each single-source in the viewer required for the specified output type.

Define chapter layout

You can define a chapter layout for a project to order topics and folders logically in the Project Manager pod. RoboHelp uses this chapter layout to auto-create a TOC.

Adobe recommends

Organizing topics and chapter layout

David Rivers
Learn how to organize topics to define the chapter layout for printed documents.

Notes:

  • If you rename a folder or a topic, the topics and folders retain their order.

  • If you delete a topic or a folder, the remaining topics retain their order.

  • If you add a new topic or a folder, it is added at the top inside the parent folder.

  • If you drop a topic or a folder on a non-topic/folder item (such as CSS, image, or baggage), it moves to the last position inside the parent folder of the target.

  • When you upgrade a project from an older version of RoboHelp, all the topics appear randomly. You can customize the order of topics later.

  • You can right-click a folder or topic in the Project Manager pod and select Explore to open the topic or the folder in Windows Explorer.

  • You can drag folders from the Project Manager pod to the TOC pod. The dragged folders convert to TOC books, and all the topics change to pages.

  • The TOC items don’t change dynamically as you change them in the Project Manager or in a topic.

Drag folders

  • Drag a topic or a folder above or below another topic or folder. For linked documents, you can drag only above the linked documents.

  • You cannot drag topics into or out of a linked document.

Manage files

List topics by title or filename

  1. In the Project Manager pod, open the Project Files folder.

  2. Select View > By Topic Title or By File Name.

Using the To Do list

The To Do list helps you track project tasks. You can customize the list by adding, deleting, or modifying the existing To Do tasks.
Note: To Do settings are retained when you upgrade a project from an older version of RoboHelp to a newer version.

You can generate a report on the customized To Do list.

Edit items on the To Do list

  1. Select File > Project Settings.

  2. Click the General tab.

  3. Click Manage.

  4. Do either of the following:

    • To add a task to the list, click Add. Type the name of the task item.

    • To edit or remove a task, select the task and click Edit or Delete.

Note: From the Project Settings dialog box, you cannot see the Ran Smart Index item in the default To Do list. This precaution ensures that you do not delete this item by mistake. By default, RoboHelp sets the option Ran Smart Index for all the topics on which you run the Smart Index wizard.

Update the To Do list for a topic

  1. Right-click a topic in the Project Manager pod and select Properties. Click the Status tab.

  2. Select or deselect items on the To Do list.

Generate a status report

You can generate a Project Status report to view the number of topics using the To Do list.

 Select Tools > Reports > Project Status.

Edit the list of recently opened projects

Recently opened projects are listed in the RoboHelp Starter pod.

  1. Select Tools > Options.

  2. Click the Recent Projects tab.

    • To change the number of files listed, specify a number in the Max Projects box.

    • To remove a file from the list, select it and click Remove.

Add files to the Baggage folder

RoboHelp sometimes doesn’t automatically add references to external elements to the Baggage Files folder. If needed, add files to the Baggage Files folder so the external elements appear correctly in the output:

  1. Select View > Pods > Project Manager.

  2. Right-click the Baggage Files folder. Select New > Baggage File.

    Note: If the Baggage Files folder isn’t listed, click the Toggle Project Manager View button .
  3. Double-click the source file for any of the following:

    • Bitmaps and icons used with HTML Help controls

    • Image files used in style sheets, topic backgrounds, and scripts

    • The JavaScript file that supports Dynamic HTML effects, such as pop-ups and drop-down hotspots

  4. Click Yes.

    Note: You can create a link to a baggage file by pressing the SHFT key while dragging and dropping it into a topic.

Remove files from the Baggage folder

To remove a file from the Baggage folder:

 Select the file and click Delete.

Map file types

Map file types to associate them with the applications used for editing them.

Associate a file extension with an application

  1. Select Tools > Options.

  2. Click File Association tab.

  3. For associated programs, click Add.

  4. Enter a filename extension.

  5. Select an editor to edit documents with the specified filename extension.

    When you select a program, its location appears in the Edit With box. The programs appear alphabetically.
    Note: Only those programs appear in the list whose registry entry is set to “NoOpenWith.”
  6. Select a program to view the file.

    You can also browse to a program not listed in the program list.

Add an HTML editor mapping

  1. Select Tools > Options.

  2. Click File Association tab.

  3. For HTML editors, click Add.

  4. Select from the recommended or other programs registered to edit or view .html or .htm files.
    Note: When you select a program, its name and location appear in the Name and Location box. You can also browse for a program that does not appear in the program list.
  5. Click OK. The selected program appears in the list of HTML editors.
    Note: To change the HTML editor, browse and select a new program.

Remove topics from projects

Before you remove files, back up all project files and view and print reports if your project is not under version control. To avoid broken links, don’t remove files in Windows Explorer or version control software.
  1. Select one or more files:
    • To remove a topic, use the Project Manager pod.

    • To remove multiple topics, use the Topic List pod.

  2. Press Delete. If prompted, do NOT remove references to removed topics.

    Note: You can choose to remove the references, but if you do that, you do not get to review the effect of the removal in other topics. Electing NOT to remove the references, forces the links to display in Broken Links, from which you can review each topic to see if any editing is required.

Manage folders

Create folders

The Project Manager contains default folders for project organization. You can create folders and subfolders only in these folders: HTML Files (Topics), Images, Multimedia, Style Sheets, and Baggage Files.

Note: Do not use Windows Explorer to create subfolders to add, move, or rename files. RoboHelp does not recognize these changes.
  1. Select the Project Files folder in the Project Manager pod.
    Note: If the Project Files folder isn’t listed, click the Toggle Project Manager View button .
  2. Right-click the folder, and select New > Folder.

  3. Enter a name for the folder. Avoid special characters and spaces.

  4. Press Enter.

Tips:

  • Move files and folders in Project Manger by dragging.

  • You can drag topics from the Topic List into multiple folders in the Project Manager.

Project Manager folders

In the Project Manager pod, you edit, delete, and create project files. Two views are available in Project Manager. Both views include a set of commonly used options for authoring. One view displays all the project files gathered together in a single folder called Project Files; the other view groups the project files into various virtual folders based on file type. Click the Toggle Project Manager View button  or , to change views.

The Project Manager view that displays project files in various virtual folders contains the following folders:

HTML Files (Topics)
Stores the topics of a project. Files are sorted alpha numerically (A-Z, 0-9). You can add folders within this folder. You can use the structure to generate a TOC automatically and create browse sequences.

Images
Images used in your project are stored in this folder. Image maps and their associated links (hotspots) are also listed. You can drag an image from this folder into the Design Editor to add images to topics. You can also rename images in this folder by selecting the image and pressing F2.

Multimedia
All sound and video files used in your project are saved in this folder. Adobe Captivate demos (SWF files) are also stored here. You can drag sound or video files into the Design Editor to add multimedia to topics. You can also find out where the files are referenced in your project.

Style sheets
Style sheets control the formatting of topics. When you change a style sheet, all topics associated with it are updated. The RoboHelp default style sheets (CSS files) and any others you add to your project are stored in this folder. Edit a style sheet by double-clicking its icon.

Baggage Files
Certain files are automatically added to the Baggage Files folder in the Project Manager to display the following correctly in the generated project:
  • Bitmap and icon files used with HTML Help controls

  • Image files used in topic backgrounds and scripts

  • The JavaScript file (ehlpdhtm.js) that supports Dynamic HTML effects such as related topics pop-ups, smart pop-ups, and drop-down hotspots.

  • The support file for skins and the navigation pane in browser-based outputs (TOC, index, glossary, and full-text search.

You can drag files from the Baggage Files folder into topics to create links to the files.

Broken Links
Stores links to files that are not present in the project. To restore or remove a broken link, double-click it.

URLs
Stores links to web addresses, FTP sites, newsgroups, e-mail addresses, and HTML topics in external CHM files. From this folder, you can add a URL to an index. You can drag a URL into the Design Editor.

Table Of Contents
Stores the default TOC and all other TOCs created in the project.

Index
Stores the default index and all other indexes created in the project.

Glossary
Stores the default glossary and all other glossaries created in the project.

See Also
Double-click the See Also folder to display the See Also pod. You can add the See Also keywords in the See Also pod.

Rename folders

Use the Project Manager to rename folders.

  1. Select the Project Files folder in the Project Manager pod.

  2. Right-click the folder. Select Rename.

  3. Type the new name. Don’t include special characters, and avoid spaces, especially for WebHelp and FlashHelp.

  4. Press Enter.

Move folders

Use the Project Manager pod to move folders.

  1. Select Project Files in the Project Manager pod.

  2. Drag the subfolder to its new location.

Remove custom folders

Before you remove the folder, move any items in it that you want to keep.

  1. Select the custom folder in the Project Manager pod.

  2. In the toolbar, click Delete.

File and folder icons

The Project Manager icons indicate the components and files included in your project.

Note: Icons with a red check mark indicate that the file is checked out (applicable only to topics under version control).

Icon

Description

Closed folders. Closed folders that contain files display a plus sign. Click the plus sign to show the folder contents. Right-click for more options.

Open folders. Open folders display a minus sign with the contents shown below. Click the minus sign to collapse the folder.

,

Toggle view. Click to switch between a simplified view with fewer folders or one showing all folders.

Show/hide files. Click to select the files you want to show in the Project Manager.

Empty folders. Empty folders display no signs.

HTML files (Topics). Double-click page icons to open a Design editor. Right-click for more options.

HTML topics with bookmarks. Topics with bookmarks have a plus sign. Click the plus sign to show all bookmarks.

Missing files. A red X indicates files that the program cannot locate. These files are not in the project path. Either they have been deleted, or they are saved in a different folder of the project.

Bookmarks. Bookmarks appear alphabetically below their respective topics. Double-click to open a topic. Drag bookmarks into topics in Design Editor to create links.

Framesets. Double-click to open a dialog box for changing frame attributes.

URLs, web addresses, FTP sites, newsgroups, e-mail addresses, or HTML topics in external CHM files. Double-click to open a dialog box for adding keywords to a link. Drag URLs into topics open in Design Editor to create links.

Images (GIF, JPEG, and JPG formats). Double-click to preview the image, identify topics that use it, and view file information. Drag images into topics in Design Editor to add them.

Image maps. Images with clickable links or hotspots. Click the plus sign to display links. Double-click to preview the image, identify topics that use it, and view file information. Drag the image maps into topics in Design editor to add them.

Image map links (hotspots). Double-click to identify topics that use image maps.

Sound files (AU, MID, RMI, and WAV formats). Double-click to identify topics that use them and view file information. Drag sound files into topics in Design Editor to add them.

Video files (AVI and MOV formats). Double-click to identify topics that use them and view file information. Drag video files into topics in Design Editor to add them.

Adobe Captivate files (SWF files). Double-click to identify topics that use them and view file information. Drag Adobe Captivate files into topics in Design Editor to add them.

Custom windows. Double-click to modify window properties.

Style sheets (CSS). Double-click to modify styles.

Text-only files For What's This? Help (.TXT format). Double-click to create or modify text-only topics files.

Map Files For Context-Sensitive Help (.HH) Includes imported map files or automatically generated files.

All map IDs. Links map IDs to HTML topics for context-sensitive Help. Double-click to work with map IDs and map files.

Table of contents folder. Shows the default and other table of contents in the project.

Table of contents folder. Expand to view the table of contents listed.

Table of contents. Double-click to open the selected table of contents pane.

Index folder. Shows the default and other indexes (if any) listed.

Index folder. Expand to view the indexes listed.

Index. Double-click to open the selected index pane.

Glossary folder. Shows the default and other glossaries (if any) listed.

Glossary folder. Expand to view the glossaries listed.

Glossary. Double-click to open the selected glossary pane.

See also. Double-click to open the See Also pane and add to See also keywords.

Baggage files (BMP, ICO, XML, JS, other image files). Files such as bitmaps and icons used with HTML Help controls, including custom buttons for link controls and startup screens. If your project includes Dynamic HTML, the file EHLPDHTMJS is included in your Baggage Files folder. Other image files are included as well, such as topic backgrounds and scripts.

You can map filename extensions to applications. For example, map GIF files to Adobe Photoshop®. When you right-click a GIF file from the Images folder and select Edit, the file opens in Photoshop.