Multiple TOCs

About multiple TOCs

You can create multiple tables of contents for a single project. You can use this feature for single-source publishing. For example, you can create separate tables of contents for a project that contains multiple languages or outputs for different audiences.
Note: To set a TOC as default, right-click a TOC in the Project Manager pod and select Set As Default.

If you merge subprojects into a master project, the tables of contents of the subprojects are available in the master project.

Move books and pages to TOCs

  1. In the Project Manager pod, double-click tables of contents in the Table Of Contents folder.

  2. Drag books and pages from one Table Of Contents pod to another.

Create multiple TOCs for a project

  1. Do one of the following:

    • In the Project Manager pod, right-click the Table Of Contents folder. Select New Table Of Contents.

    • Click the Create/View Table Of Contents button . In the Select TOC dialog box, click New.

  2. Type a name.

  3. (Optional) Select Copy Existing Table Of Contents to base the new table of contents on an existing one. Click the browse button  to locate the HHC file in the project folder, and select it.

  4. Click OK.

By default, an empty table of contents with the same name as of the project appears in the Table Of Contents folder.

Note: Click the Auto-Create TOC button , to automatically create a table of contents.

Adobe recommends

Auto-creating a TOC

David Rivers
Learn how to add a table of contents easily to your project. RoboHelp uses the layout already defined in the Project Manager pod to auto-create a TOC.

Merge TOCs

Follow this procedure to merge the tables of contents within a project.

  1. In the Table Of Contents pod, select the book or page where you want to merge the table of contents.

  2. Click the Insert TOC Placeholder button . The Insert TOC Placeholder dialog box appears.

  3. From the Select Table Of Contents menu, select the table of contents to merge.

  4. Click OK.

When you generate a layout, select the merged table of contents from the list in the Layout screen of the wizard. The selected table of contents appears in the output view of the Help.

Create browse sequences from a table of contents

You can use multiple tables of contents to generate browse sequences.

  1. Select Tools > Browse Sequence Editor.

  2. Click Auto-Create Using TOC.

    In the Auto-create Browse Sequences using ToC dialog, you can choose one fo the following options:

    Create a sequence using TOC as is:
    Default. Create a browse sequence based on the TOC. Use this option if there is a limited number of entries in the TOC.

    Create a separate sequence for each book down to level:
    Choose this option and specify the deepest level to be sequenced from the TOC.

  3. In the Select TOC drop-down list, choose the type of TOC:

    • All-Test

    • CSH

    • Developers

    • ePub

    • Feature Topics

    • HTML5-CSH

    • Salesbuilder (Default)

  4. Click OK, to apply the changes.