Adobe AIR layout

You use the Adobe AIR layout to generate Help as an Adobe AIR application, browser-based Help (with the theme and skin of an Adobe AIR application), or a packaged data file that can be viewed in an AIR Help viewer.

Adobe AIR is a cross-platform runtime for building and deploying applications that connect the desktop to the web.

Note: On Linux, the AIR Runtime is not supported after Version 2.6. AIR Help will still run on Linux using Version 2.6.

For a list of benefits of generating output in the Adobe AIR layout, see About output types.

For more information about Help applications using Adobe AIR, see www.adobe.com/go/learn_rh_article_airhelp_en.

Configure the Adobe AIR layout

You configure the Adobe AIR layout from the Adobe AIR option in the Single Source Layouts pod. In the Adobe AIR dialog box, you can select the output type, configure the installer settings, and define how the Help content is presented to the users.

 Select Adobe AIR from the Single Source Layouts pod and do one of the following:
  • Right-click and select Properties from the context menu.

  • Select Edit > Properties.

Select Help output

You can select one of the four output options for Adobe AIR:
 In the General tab of the Adobe AIR dialog box, select the output type:
Adobe AIR Application
Generates Adobe AIR output as embedded Help. The Help system is created as a single AIR application installer. You can install the AIR application locally or distribute it to your users. Users can update their installed Help system based on Adobe AIR whenever an update is available on the web. For more information about autoupdates, see the AutoUpdating section in the Adobe AIR Help article by Peter Grainge.
Note: You need JRE 1.6 or higher installed on your system to install the Adobe AIR application.

Browser Based Help
Generates browser-based Help as an Adobe Flex application that you can use as online or embedded Help. You can upload this output to the server with specific configurations. Users can view this Help using a browser with Adobe Flash plug-in 9.0 or later installed.
Note: Browser-based Help does not support Adobe AIR application features such as commenting, favorites, resources, RSS, and auto-update.

AIR Application And Browser Based Help
Generates the Help system in two formats simultaneously: Adobe AIR application and browser-based Help. You can view the AIR application after installing it on your computer. You can view the browser-based Help by uploading it to a server. The two Help systems are independent of each other.

Help Content Only
Generates the Help system as a data file (RHA) that you can view in a Help viewer. Use the Help Viewer wizard in RoboHelp to create a Help viewer. To view multiple files in a single view, you can write the location of all those files in a HelpConfig file.
Note: For the syntax of the HelpConfig file, see Create and locate a Help content configuration file.

For a step-by-step description of how to merge the output of multiple projects into a single .air file, see www.adobe.com/go/learn_rh_merge_rha_en .

Configure Help settings

 In the General tab of the Adobe AIR dialog box, set the following.
Output Location of AIR File
Click Browse to select a folder for the Help application installer (AIR file) and specify a name. By defa-ult, RoboHelp names the Help application installer by appending .air to your project name.

Output Location of Start Page (Browser-based Help Only)
Specify the first page to display in browser-based Help.

Help Title
Specify a title for your Help application. This title appears in the title bar of the Help and in Program Files.

Version
Specify a version number for the generated Help application. Typically, you set 1.0 as the version number for the initial release of your Help application, and increment the version number for subsequent releases. The incremental version numbers help your users identify updated Help content in their local installations.

Help ID
Specify a unique identifier for the Help application. The Help ID can be alphanumeric and include periods and hyphens.
Note: When you deliver updated Help, change only the version number. The installed AIR Help uses the combination of Help ID and Version to identify whether a later version of Help is available.

Configure the Help application installer

You configure the settings for the Help application installer.

 In the General tab of the Adobe AIR dialog box, set the following under the Installer Settings group:
Digital Certificate
A digital signature ensures that the Help system (or its updates) has not been altered or corrupted since it was created. All Adobe AIR applications require a digital signature and can't be installed without one. If your organization has purchased one from a certificate authority, click Browse to select it. Otherwise, click Create to create a self-signed (and reusable) certificate. See Create a self-signed digital certificate.

Password
Enter the password assigned to the digital certificate.

Include Timestamp
Select to include a timestamp on the digital certificate. The timestamp provides information on how long the certificate is valid.

Program Menu Folder
Specify the program menu folder name. For example, on Windows, the string that you specify is appended to form the path Start > Programs > [program menu folder name] > [Help system title].

Create content categories

Create content categories to publish the output as a package of user-centric Help systems (for example, a package of Help systems for different user roles, geographies, products, or platforms).

End users view the output as an integrated package of Help systems and have the flexibility to select the Help system they want to access from a drop-down list. Each Help system has its own TOC, index, browse sequences, and search.

 In the Content Categories tab of the Adobe AIR dialog box, do the following:
  • To create a content category, click New and specify a name.

  • To rename a content category, select the category. Click Rename and specify another name.

  • To delete a content category, select the category and click Delete. Click Yes to confirm.

  • To change the order of the content categories in the drop-down list from which users select, use Up or Down keys.

  • To specify a content category as the default catgory, click Set As Default.

Configure content

You configure the presentation of content in the Help application. If you’ve created content categories, configure the presentation of content for each category.
 In the Content tab of the Adobe AIR dialog box, set the following for each content category:
Content Title
Specify a title for the content category. The title appears in a drop-down list and helps users to navigate to a content category.
Note: If you’ve not created content categories, skip this field. RoboHelp uses the title you specified in Help Settings in the General tab.

Table Of Contents
Select the TOC to be displayed in the generated Help. See TOCs.

Index
Select the index to be displayed in the generated Help. See Indexes.

Glossary
Select the glossary to be displayed in the generated Help. See Glossaries.

Variables Set
Select a variable set to override the default variable set in the generated Help. See User-defined variables.

Default Topic
The topic that appears when Help opens. By default, the first topic in the table of contents is the default topic.

Language
Specify the output language for the layout if the language is different from the language of the project. RoboHelp uses this language setting for the UI strings and language-related UI elements in the preview and generated output.

Encoding
Specify the character encoding format if the web server to which you’re publishing has character encoding different from UTF-8.

Map Files
Specify the map files that contain topic IDs associated with map IDs to provide context-sensitive Help.

Browse Sequences
Select the browse sequences for this content category.

Conditional Build Expression
Specify a conditional build expression to apply to the output. See Conditional build tag expressions.

Apply To All Topics
Specify whether to apply a master page or a CSS to all the topics. If you do not select the Apply To All option, the master pages associated with individual topics become effective. If no master pages are applied to topics, they are generated as is. See Applying a master page or CSS at the time of generation

Exclude Unreferenced Topics From Output
Select this option to exclude any topic that exists in the project but is not the default topic in the layout or is not referenced from the selected TOC, index, or browse sequence, or any referenced topic.
Note: RoboHelp displays the unreferenced topics that are excluded from the output in the Output View pod.

Exclude Unreferenced Baggage Files From Search
Select this option to exclude any topic that exists in the project but is not referenced from the selected TOC or any referenced topic (if Exclude Unreferenced Topics From Output is selected). If Exclude Unreferenced Topics From Output is deselected, RoboHelp excludes baggage files that are unreferenced from any topic in the project.

Set the Help viewer window and branding options

Appearance settings define the appearance for the Help viewer window.

 In the Adobe AIR dialog box, select the Template group and set the following:
Template
Select a template from the pop-up menu.

Skin
Select a skin from the pop-up menu. Alternatively, click Gallery to select a skin from the skins available for the selected template. You can preview a skin before selecting it.

Copyright
Specify the entity that owns the copyright of the Help application. This entity is usually the name of the company publishing the Help content. The copyright notice appears in the About box (Help > About).

Description
Specify a description for the Help. The description appears in the About box (Help > About).

Favicon
(Browser-based Help) Specify an icon to associate with the Help system. The icon appears in the browser tab.

Width and Height
Set the width and height of the Help window.

Specify Branding options
Click to specify an icon for your Help system in different sizes and specify other branding options.

The following sizes are used by the operating system to display the Help system icon in predefined locations, such as the title bar, the taskbar, and the About box:

  • 128x128

  • 48x48

  • 32x32

  • 16x16

If you do not specify your own icon, the operating system defaults are used. For best results, provide an image for each of the specified sizes. In addition, make sure that the icons look presentable in both 16- and 32-bit color modes. Icon files must be in the PNG format.

You can also display your company logo in the top-right corner of the Help application and copyright information or any brand-related information in the status bar. The image size for the logo is 32x32.

Template for the Help application

Choose the template that you want to use for your Help application. You can select one of the following three templates:
Note: Templates are not applicable if you selected the Help Content Only output type.
Classic Help
The Classic Help template divides the page into a top pane, left pane, and a content pane.

Multi Tab Accordion
The Multi Tab Accordion template divides the page into a top pane, left pane, and a content pane.

Uni Pane
The Uni Pane template divides the page into a top pane and a content pane.

All the templates have different appearance and navigation options. They also have some common features. These features are support for TOC, index, glossary, search, print, and the Content pane. The following table shows the differences among three types of templates:

Features

Classic Help

Multi Tab Accordion

Uni Pane

How do I

See Browse sequences.

Yes

No

No

Search

Yes

Yes

Yes

Search results that show context

No

Yes

Yes

Showing/hiding the left pane

Yes

Yes

No

Viewing status bar

Yes

Yes

Yes

Note: Press F11 to show or hide the left and top panes.
You can choose any of the templates to use in the Help system and preview it before generating it.
Note: You can customize a template. By default, all the available options for content display and navigation in a template are selected.

Configure content presentation

You configure how the Help application behaves when a user uses it.
 In the Adobe AIR dialog box, select the View group, and set the following:
Enable Auto Update
Enables the AIR application to synchronize the AIR file installed on a desktop with the current content on the network drive or an HTTP server location. Do one of the following:
Content updates within your network
Select File from the Type menu and click Browse to select the folder and file with the content updates.

Content updates outside your network
Select HTTP from the Type menu and enter the URL of the XML file that contains the updates to the Help contents.

The Auto-update feature helps your users update the Help application whenever an update is available. You can send the auto-update in the form of an XML file or host it on a web server. See Hosting updates for AIR Help.

Add
Click to specify Mac OS and Linux locations to update the installed Help if you are hosting the XML file on a local or network drive.

Add Resources
Select and click the Add button to add external links that appear in the Favorites group in the Help application.

You can add resources such as technical support pages, knowledgebase articles, RSS feeds, and related websites.

Show Online Content
Specify the full path from where the AIR Help viewer picks up the published browser-based Help. For example, http://www.example.com/[browserhelpfolder].

This option is applicable only if you select the output type as Adobe AIR Application or AIR Application And Browser Based Help.

Note: If you select this option, make sure that you publish browser-based Help to the location pointed by the server URL. Otherwise, the AIR application shows offline content.

Configure search

In the Adobe AIR dialog box, select the Search group, and set the following:

Enable Highlight Search Results
Select to enable highlighting of search results. Topics that match the search criteria appear with the search term highlighted. Click the Text pop-up menu to set the highlight color.

Show Context In Search Results
Select to have the search results displayed along with the first few lines of the topic.

Enable Substring Search
Select to have search results include not only the exact search string but also text in which the string is embedded. For example, a search for “log” returns topics containing the words “catalog” and “logarithm.” A substring search takes longer than a whole-string search.

Enable External Content Search
Select to display content from identified URLs outside the Help system. For information about how to specify URLs and associate them with search terms, see External content search.

Hide Rank Column In Search Results
Select to not display the Rank column in search results.

Show Total Number Of Search Results
Select to show the number of search results for a specific search string.

Allow AND Search In Output
Select to display only those topics that have all the words that are specified without using quotation marks in the Search box. By default, RoboHelp performs OR search when a user types multiple words without enclosing them in quotation marks. This means that RoboHelp finds all topics that have any of the words specified in the Search box.
Note: AND search can be used in combination with phrase search.

Select the Enable AND Search By Default option if required. If you allow AND search disable it by default, end users have the option to enable it in the output.

Note: In merged projects, child projects inherit the setting of the parent project. In projects with DUCC (content categories), the setting applies to all content categories.

Exclude Baggage Files Types From Search
Select the types of baggage files to exclude from search.

Configure collaboration

Collaboration settings are available for Adobe AIR Application only.

 In the Adobe AIR dialog box, select the Collaboration group, and set the following:
Enable Topic Rating
Enables users to rate any topic on a scale of 0-5 stars.

Enable Commenting
Select to enable commenting.

Enable Comment Moderation
Select to allow acceptance or rejection of comments by authorized users (moderators).
Note: When you distribute the output, make sure that you share the moderator password. See Distribute Adobe AIR output.

Set Location For Comments And Topic Ratings
Depending on whether you want a trust-based system or user authentication, select one of the following options:
  • Select Network Folder. Click Browse to choose the shared network folder where the comments will be stored. Click Add to add locations on Mac and Linux systems if required. See URL formats for Windows, Mac, and Linux.

    Specify the password that moderators need to provide to access the moderation dashboard.

    Select Pending or Accepted to specify how you want to handle unmoderated comments. If you select Pending, unmoderated comments are not displayed to users.

    Storing comments in a shared network folder is suitable in trust-based work environments, where shared reviews by internal stakeholders are part of the content development process.

  • Select RoboHelp Server and specify the server URL.

    Storing comments on RoboHelp Server enables you to authenticate users before allowing them to view or post comments.

Configuration File Path
Specify the path and name of the file that stores the configuration for comment syncing and auto-update. When the AIR application is distributed, users can copy the default configuration file from the !SSL folder of the project to the location specified in the configuration file path and modify the default settings according to their preferences. For example, they can disable commenting or change the location of storing comments.

You can enter the path in any of the following formats:

  • A relative path (relative to the install folder)

  • An absolute location, such as a shared network drive or a file location in the user drive

  • A web URL pointing to the location where you’ve posted the XML file

Configure a server to host browser-based Help

You can directly upload the generated browser-based Help to a server. Consult your system administrator for information about which server to use.

Note: Server configuration is not applicable if your output type is Adobe AIR Application.
  1. Select Server in the Adobe AIR dialog box.

  2. Click New. Specify the following options in the New Destination dialog box:
    Descriptive Name
    Name for the server to publish the Help system to. For example, if you are publishing a Help system for internal review, enter “Internal Review Server.”

    Connection Protocols
    Select the protocol for connecting to the server or the sharing platform. Select FTP, HTTP, File System, or SharePoint.
    These are the FTP server connection details:
    Hostname
    Enter the host name of the FTP server.

    Port
    Enter the port number. Typically, FTP connections use the default port, 21.

    User ID and Password
    If your FTP server requires user authentication, enter the user ID and password that your system administrator provided for you.

    Anonymous User
    Select Anonymous User if your FTP server allows anonymous FTP. You do not require a user ID and password for connecting to the FTP server.

    Specify these details for the HTTP server connection:

    Host Name
    Enter the host name of the server.

    Server Directory
    Enter the directory on the HTTP server to place the Help system contents. Some HTTP servers require a trailing slash (/) at the end of the path.

    Select File System and enter the destination path if you have access to a network path where you can directly upload your Help system contents.

    For the File System server connection, specify the destination path.

    For the Microsoft SharePoint server connection, specify the SharePoint directory path. If the SharePoint site path is mapped as a network drive on the system or added in network paths, you can use the browse button to select the network path.

  3. Set the following options:

    Check For Deleted Files
    Check for files that have been deleted from the destination.

    Prompt Before Overwriting Files
    Receive a warning before overwriting files on the server.

    Republish All
    Republish all files to the destination, overwriting existing files on the server.
    Note: If you are setting options for a master project, and a copy of the subproject is in the output folder, ensure that Republish All is not selected.

  4. To publish Help, click Save And Generate.

Notes:

  • For merged Help systems, publish individual projects to the same location. Do not use Republish All in the master project.

  • Set layout options once and automatically generate the primary layout by selecting the Generate button.

  • Generate or publish multiple layouts in a batch.

  • If the output is corrupt, check if any topic file has the & character. Rename the topic and regenerate the output.

  • For a list of video formats supported in Adobe AIR output, see http://kb2.adobe.com/cps/402/kb402866.html .

Create a self-signed digital certificate

You can create a digital certificate to test or privately distribute the Adobe AIR Help application. However, if you distribute Help through your website, be sure to procure a digital certificate from a certificate authority (CA), such as Thawte or VeriSign. Use the digital certificate to sign the Help system.

Digital certificates from certificate authorities can be verified through the web. They assure end-users that the Help application installer is genuine and free from malware. See www.adobe.com/go/learn_air_digital_certificate for more information.
  1. Click Create near the Digital Certificate label.

  2. In the Create Self-Signed Digital Certificate dialog box, enter the following details:
    Publisher Name
    Specify the name of the publisher. Usually, it is the name of your company. If you are creating a Help application based on Adobe AIR for another company, specify the name of your client. Optionally, you can specify the organizational unit and organization name.

    Country
    Select the country of the publisher.

    Type
    Select the encryption standard for the digital certificate. The 2048-RSA standard provides stronger encryption than the 1024-RSA standard.

    Save As
    Click Browse to select a folder and save the digital certificate that you created. Self-signed digital certificates are saved with a .p12 extension.