Table styles

With Style Editor, you can create and customize table styles according to your requirements. Applying a table style instead of inline formatting helps you add standard and easy-to-maintain tables. If you modify a table style, all tables using that style also change.

You can modify the appearance of existing tables by applying a style. RoboHelp asks you if you want to remove inline formatting also.

For tips and workarounds related to customizing tables, see the Table section in Peter Grainge’s RoboHelp tour.

Global table styles

You can select predefined styles for a table. These styles are available globally and can be used across projects to define different tables. Global table styles are present at C:\Documents and Settings\[user name]\Application Data\Adobe\RoboHTML\[version]\Templates\Tables. For Windows Vista®, global table styles are present at C:\users\[user name]\AppData\Roaming\Adobe\RoboHTML\[version]\Templates\Tables.
Note: If you delete the Tables folder from the suggested location, the global table styles are still visible in the Global Styles list. You can always recover the styles from C:\Program Files\Adobe\Adobe RoboHelp [version]\RoboHTML\Gallery\Tables.
In addition to the predefined global styles, you can copy table styles from a project folder and paste at C:\Documents and Settings\[user name]\Application Data\Adobe\RoboHTML\[version]\Templates\Tables. These table styles are available globally for all the projects.
Click the Apply Global Table Style  icon on the Tables And Borders toolbar to apply a style on the table.

Apply table styles

To apply a table style on an existing table, do the following:

  1. Select an existing table in a topic.

  2. Click the Apply Global Table Style icon  on the Tables And Borders toolbar to apply a style on the table.

  3. In the Select Table Style dialog box, select Clean Table Inline Formatting. Selecting Clean Table Inline Formatting removes any inline styles used in the table.

  4. Select a style from the Available Styles list or select a global table style (table template).

  5. Click OK.
    Note: You can double-click a style in the Table Style dialog box to apply it to a table.

Create and manage table styles

Besides using global table styles (table templates) and predefined table styles in the CSS, you can create custom table styles to ensure consistent table layouts, borders, alignment, shading, and fonts. You can vary characteristics such as the colors, fonts, bold, italics, and alignments applied to rows and columns.

John Daigle demonstrates some easy ways to create and manage tables and table styling.

Create table styles

  1. Select Format > Styles.

  2. Click Create New Style and select Table Style.

  3. Name the new table style and click OK.

  4. Apply formatting to the whole table, first or last column or row, or a group of rows or columns. From the Apply Formatting To list, select the columns or rows to format. For example, you can make the background of the first row blue and the background of first column yellow.

  5. Select font, size, and color.

  6. Select border and border color.

  7. Click Apply. The new style appears in the CSS Styles list of the Table Styles dialog box. Select this style to create tables with the same style later.

Notes:

  • Click the Apply Global Table Style icon  on the Tables And Borders toolbar to apply a style to the table.

  • Based on the sequence of changes, in the first and last cell of a row, the row color overrides the column color.

The appearance of a table is the result of several classes, such as Table, TR, and TD. RoboHelp applies these subclasses to the respective table item when you apply a table class. Therefore, if you want to change a table style through code or script, write a class attribute (class=”myTableClass”) in the table tag. RoboHelp applies all the table patterns for the remaining items of the table in Design Editor.

Apply conditional build tags to tables

Conditional build tags let you exclude content from output.
  1. Select a row, column, table, or text in a table.

  2. Select Format > Apply Conditional Build Tags > New/Multiple.

  3. Select tags. Click OK.