Version control with Microsoft SharePoint

RoboHelp supports version control with Microsoft SharePoint 2010 and above natively, which means you do not need to install any third-party plugins.

The RoboHelp installer automatically installs all needed components, including the following prerequisites for the version control feature to work smoothly:

  • Dotnet framework 4.0

  • SQLServer Compat 3.5 SP2

Configure RoboHelp settings for SharePoint

  1. In RoboHelp, click Tools > Options > Version Control to display the version control settings.

  2. In the SharePoint Settings area, enter the path of a file comparison program that is installed on the system and the arguments (parameters) for it. RoboHelp uses it in file comparison operations. You can download the free comparison program Winmerge from http://winmerge.org/

    Note: If you use Winmerge, enter the path to winmerge that is installed on your system, in the Path parameter, and %1 %2 as the Arguments. %1 and %2 denote the two files to be compared.
  3. Configure the following options:

    Notify Before Overwriting Writable Files
    Notifies the user before overwriting any writable files that are not checked out.

    Replace Local File Even If Server Version Is Same
    Forces RoboHelp to fetch the latest files from the server, even if local file version and server version is the same.

    Default Checkin Option
    Select whether to check in the files as a major version or as a minor version. The default is to check in as a major version.
    Note: The Default Checkin Option comes into effect when while checking in, the check in dialog is suppressed.

RoboHelp does not display notifications for version control operations by default. To display notifications, enable the relevant options in the Display Confirmation Dialog When area in the Version Control page of the Options dialog box (Tools > Options).

Configure SharePoint document library settings

To add a RoboHelp project to a document library in SharePoint, configure the document library settings:

  1. Log on to SharePoint.

  2. Click Site Actions > View All Site Content.

  3. Click the document library to be edited from the list of document libraries that are displayed.

  4. Click the Library tab and select Library Settings.

  5. Click Version Settings and then configure the following settings:

    Require content approval for submitted items
    Select No.

    Create a version each time you edit a file in this document library?
    Select Create major and minor (draft) versions.
    Note: The Create major versions option is also supported. In this case, files cannot be checked in as minor versions.

    Keep the following number of major versions
    Deselect this option.

    Keep drafts for the following number of major versions
    Deselect this option.

    Who should see draft items in this document library?
    Users with read access.

    Require documents to be checked out before they can be edited? (Force Checkout)
    Select Yes.

Note: To provide users with read / write access to the RoboHelp files on your SharePoint server, ensure that the appropriate SharePoint user permissions are provided to the users.

Add a project to a SharePoint document library

  1. Click Add to Version Control icon or select File > Version Control > Add to Version Control.

  2. Select RoboHelp SharePoint Connector and click OK.

  3. Specify the SharePoint site that contains the Document Library, and the username and password to log on to SharePoint. Click OK to log on to SharePoint.

    Note: You can use LDAP authentication if it is configured on the SharePoint server, by selecting the option Use Windows Authentication.

    When you connect to the SharePoint site, all the document libraries in that site are displayed.

  4. Create a folder inside a document library or use an existing empty folder to upload the RoboHelp files and click OK.

    RoboHelp adds the project files to SharePoint.

    Note: You can add the project to any folder inside the document library. The folder must be empty. You cannot add the project directly to a document library.