


1.                        
Getting started

 


1.1.                   
Resources

Before you begin working with your software, take a few moments to read an overview of activation and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tuto­rials, RSS feeds, and much more.


1.2.                   
Activation and registration

 

1.2.1.                
Help with installation

For more information on installation issues, see the Technical Communication Suite Help and Support page at 
www.adobe.com/go/learn_tcs_en
.

1.2.2.                
Activate the software

During the installation process, your Adobe software contacts Adobe to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at 
www.adobe.com/go/activation
.

A single-user retail license activation supports two computers. For example, you can install the product on a desktop computer at work and on a laptop computer at home. If you want to install the software on a third computer, first deactivate it on one of the other two computers. Choose Help > Deactivate.

1.2.3.                
Register

Register your suite to receive complimentary installation support, notifications of updates, and other services. Register only once for Adobe Technical Commu­nication Suite.

1)           To register, enter your Adobe ID when prompted when you install or launch the software.


tip:  If you choose to skip entering your Adobe ID during installation or launch, you can register within next 30 days by choosing Help > Product Registration. You can also set a reminder to register after a few days of software installation.


1.3.                   
Adobe Product Improvement Program

You can participate in the Adobe Product Improvement Program. After you have used your Adobe software a few times, a dialog box appears, asking whether you want to participate in the program.

If you choose to participate, data about your use of Adobe software is sent to Adobe. No personal information is recorded or sent. The Adobe Product Improvement Program only collects information about the features and tools that you use in the software and how often you use them.

You can opt in to or opt out of the program at any time:

•                

To participate, choose Help > Product Improvement Program and click Yes, Participate.

 

•               To stop participating, choose Help > Product Improvement Program and click No, Thank You.

 

Adobe provides more information about the Product Improvement Program in a frequently asked questions (FAQ) list on the 
Adobe website
.


1.4.                   
Services, downloads, and extras

You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets to complete your work.

1.4.1.                
Adobe Exchange

Visit the Adobe Exchange at 
www.adobe.com/go/exchange
 to download samples as well as plug-ins and extensions from Adobe and third-party devel­opers. Use these plug-ins and extensions to automate tasks, customize work­flows, create specialized professional effects, and apply more creativity in work.

1.4.2.                
Adobe downloads

Visit 
www.adobe.com/go/downloads
 to find free updates, trials, and other useful software.

1.4.3.                
Adobe TV

Visit Adobe TV at 
http://tv.adobe.com/channel/technical-communication/
to view instructional and inspirational videos on Technical Communication Suite.


1.5.                   
Adobe Technical Communication Suite 4 overview

Adobe Technical Communication Suite software is an end-to-end solution for authoring, reviewing, managing, and publishing technical information and training content. You can use it to create and maintain technical documenta­tion, user assistance systems, knowledgebases, simulations, software demon­strations, and other support information.
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The tight integration of component products in the suite enables true single-source authoring. You can author content once and publish it in multiple formats and languages. For example, you can author content in Adobe FrameMaker and output it in multiple formats using Adobe RoboHelp.

You can also enrich content through interactive 3D models, rich media, multi­layered images, demonstrations, and embedded SWF movies. Using the cross-platform Adobe AIR Help format, you can push updates to your Help content even after you have delivered it.

This latest release of Adobe Technical Communication Suite includes the following components:

•                

Adobe®® FrameMaker®® 11: Author and publish technical content, with XML, DITA standards support, and excellent PDF publishing capabilities. Includes content management support such as EMC Documentum 6.5 SP1 and Microsoft SharePoint Server 2007 SP 2.

 

•               Adobe®® RoboHelp®® 10: Author and publish procedural- or process-based online Help and knowledgebases. Also includes RoboScreenCapture for still image capturing, and RoboSource Control for managing project source files.

 

•               Adobe®® Captivate®® 6: Rapidly create powerful and engaging simulations and interactive content. Author rich eLearning content that includes branching scenarios, Table of content, quizzes, and SCORM- and AICC-compliant multimedia content.

 

•               Adobe®® Acrobat®® X Pro: Reliably create, combine, and control Adobe PDF documents for easy, secure distribution, collaboration, and forms data collection. Create stunning portfolios that combine several file types, such as image formats, FLV file, PDF, SWF file, and interactive 3D.

•               Adobe®® Presenter®®: Create engaging presentations and courses rapidly and easily.

 

•               Adobe®® RoboScreen Capture®®: Capture your screen and edit it to create illustrations.

 

•               Adobe®® RoboSource Control®®: Configuration and workflow manage­ment for your content.

 

•               Adobe®® Bridge®® CS6: Digital asset management with centralized access to your photo and design files with ease.

 

•               Adobe®® Illustrator®® CS6: Edit and enhance images and screenshots before using them in your projects.

 

1.5.1.                
Top features of Adobe Technical Communication Suite

Seamless content creation

 

Create, review, manage, and publish technical information seamlessly. You can publish your content in XML, DITA, PDF or as printed manuals.

Create Rich PDF

 

FrameMaker excels at creating richly formatted PDF output. Using FrameMaker, you can add 3D, graphics, audio, video, multimedia, and interactive content. Embed Adobe Captivate demos and simulations in online Help projects and PDF documents. For more information, see Rich media.

 

Single-sourcing (tighter FrameMaker and RoboHelp integration)

 

You can create content once in FrameMaker and publish it for print/DVD world as XML, DITA, PDF file, or printed guides. You can single source the same content in RoboHelp and create online content as .chm, webhelp, AIR, or EPUB files. Further, you can directly generate online Help from FrameMaker. Single-sourcing reduces content creation time as duplication is prevented. Single-sourcing also reduces errors as reviews are singular, and saves localization costs as same content is being lever­aged across mediums. For more information, see Using FrameMaker with RoboHelp.

 

Multi-device output

 

Devices are in. Users now demand content to be displayed through smart­phones or Internet-enabled devices, such as Kindle. With RoboHelp 9, you can now create EPUB-content that appears well across various devices.

DITA Support and multi-channel publishing

 

Author your DITA projects in FrameMaker and then leverage the power of RoboHelp to create online Help. You can create .chm file, webhelp, Flashhelp, Javahelp, Oraclehelp, Eclipsehelp, XHTML, EPUB, or AIR files. With FrameMaker 10, there is no need to convert DITA documents into books only for linking-purpose. You can directly link to DITA docu­ments. For more information, see Authoring and publishing workflow using FrameMaker and RoboHelp.

 

Review and Collaboration

 

Technical Communication Suite includes Acrobat that lets you collabo­rate on documents. Use Acrobat.com to share PDF files, set up and manage reviews through e-mails, and collaborate on PDF documents. Initiate reviews from within FrameMaker, RoboHelp, and Adobe Capti­vate, without having to exit authoring applications for setting up reviews. Generate PDFs that can be commented with Adobe Acrobat Reader. Document reviewers do not need to have Acrobat or Technical Commu­nication Suite installed on their systems to comment documents using Acrobat Reader. For more information, see Review and collaboration.

 

Create Cross-platform output

 

Deliver your Help projects in the cross-platform Adobe AIR format. You can push updates to your Adobe AIR Help projects even after you have delivered them.

 

Easy multimedia recording

 

You can also record a new Adobe Captivate demonstration from within FrameMaker or RoboHelp. You can publish captivate output as SWF file, Zipped package, PDF, or Autorun movie on CD. For more information, see Publishing Projects. You can use Adobe Captivate Reviewer applica­tion to efficiently review and comment on Adobe Captivate projects.

Create secure PDFs and PDF Portfolios

 

Reliably create, combine, and control Adobe PDF documents for easy, secure distribution, collaboration, and forms data collection. Create quality portfolios. For more information, see Rich media.

 

Effective copy-editing

 

Use AuthorAssistant with FrameMaker to improve content consistency and translatability. For more information, see Style and linguistic checks using SDL AuthorAssistant 2010 SP1.

 

Automate manual tasks

 

Use ExtendScript to automate daily mechanical tasks that require manip­ulation of simple or complex objects. You can use ExtensScript with FrameMaker, Photoshop, and RoboHelp. It allows robust automation of tasks across products. For more information, see Working with Extend­Script.

 

SCORM, AICC, and PENS support through Adobe Captivate 5

 

Adobe Captivate 5 supports most e-learning content creation standards for single-click publishing to learning management systems (LMS). SCORM (Shareable Content Object Reference Model) is a set of specifica­tions used to produce reusable e-learning objects. It defines communica­tion between a client (such as Adobe Captivate) and a host (usually an LMS). For more details, see Learning management system (LMS).

 

Enhanced image-editing

 

Capture images and screenshots for your Help projects using Robo­ScreenCapture and use the powerful features in Adobe Illustrator CS6 to edit and enhance them. You can also animate the different layers of a Photoshop image in Adobe Captivate.

 




2.                        
Rich media

 


2.1.                   
Adding rich media

You can create an engaging experience for your customers using the rich media capabilities of the Adobe Technical Communication Suite. The simplicity of authoring your content once, and publishing it for multiple channels and devices opens the floodgates to a multitude of possibilities. Never before, was it so simple to integrate 3D, graphics, audio, video, multimedia, and interactive content in your publishing workflows.
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Rich media opens opportunities to provide various types of content within your documentation. You can even combine various media types to create documen­tation that users don’t only just read, but watch, listen to, and interact with as well. For example, you could use a camcorder to record a narration and add the video to accompany a demo that you’ve added.

The following table lists the media you can add to your documents while authoring in the various TCS applications.



 	
 

 


 	
FrameMaker

 


 	
RoboHelp

 


 	
Adobe Captivate

 





	
3D
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Graphic/Image
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Audio
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Video
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Interactive/SWF
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2.1.1.                
Rich media and FrameMaker

 


Adding rich media to FrameMaker documents

In FrameMaker, place the cursor at the place you want to insert the file.

Choose File > Import > File. The Import dialog box opens.

In the Import dialog box, do one of the following:

 

Navigate to the file and click Import.

 

Click Browse URL to navigate to a file

Click Browse CMS, and navigate to the file on your configured shared reposi­tory.

 

If the file type is not recognized, an Unknown File Type dialog box displays, select the closest content type and click Convert.

In the Imported Graphic Scaling dialog box, select an option to fit the rich media object and click Set.

 

The rich media object is placed in your document, inside an anchored frame.

•                

Graphic and 3D objects are rendered and a representation is displayed.

 

•               Audio and video objects display an icon.

 

•               Interactive content displays the default poster image. If the SWF does not have a default poster image, a Play button is displayed instead.

 

Related links:


Extended rich media support



Import graphics



Import movies, SWF files, and 3D objects



Importing and linking files



Specify poster images for audio, videos, 3D, and SWF content

The poster image is the default image that displays unless the movie is played. By default, either standard icons or the first frame of the movie is used as it’s poster image. The set poster command lets you specify an image to be displayed as a poster for the movie.

Right-click the movie or SWF content, and choose Set Poster, and browse to the image file to use as the poster.You can also play a video and select any frame as a poster.


Working with 3D models

You can add 3D models to your FrameMaker documents. When you publish the document to PDF, these models are interactive and users can move the objects around. For more information on using 3D and Acrobat see Interacting with 3D models.

A 3D model inside a PDF.
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3D models are supported only inside PDFs. You can view the PDF using Adobe Acrobat or Adobe Reader.

When you publish the FrameMaker files to HTML or other formats, the default view of the 3D model is rendered as an image. However, in RoboHelp you can specify the Preserve 3D Images option (Project Settings > FrameMaker Docu­ment > Edit > Image), 3D models are published as embedded PDF files that open when users navigate to that page.

You can also specify the basic 3D settings right inside FrameMaker. Access to the original 3D application is not required. Use the 3D options to change the background color, lighting, and render modes for the 3D model. Right-click and choose 3D to access these controls.


Setting multimedia preferences

In FrameMaker Preferences, specify if you want to embed multimedia objects in PDF.

1)            

Choose File > Preferences > General.

 

2)           Check the following as required:

 

•               Embed Adobe Flash files in PDF

 

•               Embed 3D objects in PDF

 

•               Embed multimedia objects in PDF

 

2.1.2.                
Rich media and RoboHelp

 


Inserting graphics

In RoboHelp, place your cursor at the location to insert the file.

Choose Insert > Image. The Image dialog box opens.

In the Image Name field, specify the file to import or use the browse button and navigate to the file.

Optionally, specify the Size, Margins, and Borders.

Click OK to add the graphic.


Adding multimedia content

You can add multimedia content to your documents you author in RoboHelp.

In RoboHelp, place your cursor at the location to insert the file.

Choose Insert > Multimedia/Demo. The Multimedia dialog box opens.

In the Multimedia Name field specify the file to import or use the browse button and navigate to the file.

Optionally, specify the Size, Margins, and Borders.

Click OK to add the content.

 

The selected file is added to the RoboHelp topic.

 

Related links:


Multimedia



Adobe Captivate demos


2.1.3.                
Adobe Captivate integration (TCS only)

If you have Microsoft® Word® and Adobe Captivate installed on the same computer, you can publish Adobe Captivate projects in various layouts in Microsoft Word. These layouts are handout, lesson, step-by-step, and story­board.

With RoboHelp 10 installed as part of Technical Communication Suite 4, you can add topics with handout and step-by-step output generated from an Adobe Captivate 6 project.


Create demo, step-by-step, and handout topics from an Adobe Captivate project

 

1)            

In RoboHelp, choose File >New >Adobe Captivate Topic.

 

2)           Specify the Adobe Captivate project name.

 

3)           Select the type of topic that you want to add and specify a topic title and filename:

 

a)           Demo Topic: Contains slides from the Adobe Captivate project with the demo.

 


note:  Previous versions of RoboHelp allowed you to launch Adobe Captivate from within RoboHelp and add topics with the demo output of an Adobe Captivate project.

 

b)           Step-By-Step Topic: Contains the list of steps recorded in the Adobe Captivate project. The topic does not include the background image of the slides but does include images of interactive objects (buttons, links, and so on) in the steps.

 

c)           Handout Topic: Contains all the slides as they appear with the layout options you choose.

 

4)           Click OK.

 


note:  A new project with the specified name is opened in Adobe Captivate. RoboHelp is minimized. You cannot access RoboHelp while Adobe Capti­vate is open.

 

5)           Record the slides and edit them as required. Save the project and close Adobe Captivate.

 

Adobe Captivate publishes the recording as a SWF file, a step-by-step document, and a handout document depending on the options you selected. In the open RoboHelp project, you'll find new topics) added with the output.

 

The topics containing the Adobe Captivate output store the absolute path of Adobe Captivate project in topic properties. Therefore, moving the Adobe Captivate project is not recommended. RoboHelp project keeps the absolute path of the captivate project. Later, you can edit the Adobe Captivate generated topics or SWF file using the same project.

 

These topics should be edited with Captivate only. Any changes made within the Design editor are lost if you update the topics again with capti­vate.

 


Edit, rename, or delete step-by-step and handout topics

 


Edit a step-by-step or handout topic

 

•                

Select the topic in Project Manager, right-click, and select Edit.

 

If the RoboHelp project contains topics created from the same project, RoboHelp checks whether you want those topics to be updated along with the selected topic. You can specify the topics) you want RoboHelp to update.

 

You can edit a step-by-step or handout topic in Design Editor. However, these changes are overwritten if you update the topic later using the Edit option from the context-sensitive menu. You can update a demo from within RoboHelp in versions earlier than Adobe Captivate 6. However, Adobe Captivate 6 is required to create or update topics in RoboHelp.

 


Delete a step-by-step or handout topic

 

1)            

Select the topic in Project Manager, right-click, and select Delete.

 


Import step-by-step and handout topics

You can import step-by-step and handout output from existing Adobe Capti­vate projects. RoboHelp adds a topic for each type of output you select.

2.1.4.                
Import Adobe Captivate project in RoboHelp (TCS only)

 


Create demo, step-by-step, and handout topics from an Adobe Captivate project

 

1)            

In RoboHelp, choose File >Import >Adobe Captivate Project.

 

2)           Navigate to a .cp or .cptx file and select it.

 

3)           In the import Adobe Captivate Topic dialog, select the type of topics you want to create from the Adobe Captivate project and specify the filenames and titles.

a)           Demo Topic: Contains slides from the Adobe Captivate project with the demo. To generate HTML 5 output, select HTML 5.

 


note:  Previous versions of RoboHelp allowed you to launch Adobe Captivate from within RoboHelp and add topics with the demo output of an Adobe Captivate project.

 

b)           Step-By-Step Topic: Contains the list of steps recorded in the Adobe Captivate project. The topic does not include the background image of the slides but does include images of interactive objects (buttons, links, and so on) in the steps.

 

c)           Handout Topic: Contains all the slides as they appear with the layout options you choose.

 

4)           Click OK.

 

TCS launches Adobe Captivate and generates the specified outputs. Once the outputs are created, Adobe Captivate is closed and the outputs are imported to RoboHelp.

 

Adobe Captivate publishes the recording as a SWF (and HTML 5 if you selected it) file, a step-by-step document, and a handout document depending on the options you selected. In the open RoboHelp project, you'll find new topics added with the output.

 

The topics containing the Adobe Captivate output store the absolute path of Adobe Captivate project in topic properties. Therefore, moving the Adobe Captivate project is not recommended. RoboHelp project keeps the absolute path of the Adobe Captivate project. Later, you can edit the Adobe Captivate generated topics or SWF file using the same project.

 

These topics should be edited with Adobe Captivate only. Any changes made within the Design editor are lost if you update the topics again with Adobe Captivate.

 


Edit, rename, or delete step-by-step and handout topics

 


Edit a step-by-step or handout topic

 

•                

Select the topic in Project Manager, right-click, and select Edit.

 

If the RoboHelp project contains topics created from the same project, RoboHelp checks whether you want those topics to be updated along with the selected topic. You can specify the topics) you want RoboHelp to update.

 

You can edit a step-by-step or handout topic in Design Editor. However, these changes are overwritten if you update the topic later using the Edit option from the context-sensitive menu. You can update a demo from within RoboHelp in versions earlier than Adobe Captivate 6. However, Adobe Captivate 6 is required to create or update topics in RoboHelp.

 


Delete a step-by-step or handout topic

 

1)            

Select the topic in Project Manager, right-click, and select Delete.

 


Import step-by-step and handout topics

You can import step-by-step and handout output from existing Adobe Capti­vate projects. RoboHelp adds a topic for each type of output you select.


2.2.                   
Insert Photoshop images

You can insert native Adobe Photoshop images to your projects. On publishing, the PSD files are rasterized and attributes such as Photoshop filters, layer visi­bility are maintained. To insert a Photoshop file:

FrameMaker

 

Choose File > Import, and then browse to the PSD file.

 

Adobe Captivate

 

Choose File > Import > Photoshop File.

 

Adobe Captivate lets you select individual layers to import, or flatten the layers to import. If you import individual layers, each layer is treated as a separate image in Adobe Captivate.

Related links:


Import Adobe Photoshop files


2.2.1.                
Editing Photoshop and Illustrator graphics

You can import native Adobe Photoshop (PSD) and Adobe Illustrator (AI) files into your FrameMaker documents. And you can open these graphics for editing from within FrameMaker. FrameMaker supports layers, and you can import graphics with multiple layers into your document.

 

To edit the graphic:

Click the imported graphic to select it.

Right-click and choose one of the following:

 

Edit with Illustrator

 

Edit with Photoshop

 

The graphic opens in the selected application. Edit the graphic and save it.

 

The graphic is updated in your document.

 


2.3.                   
Insert Adobe Captivate demo

You can include Adobe Captivate demos into your documents to create truly rich and engaging content. You can insert Adobe Captivate demos in FrameMaker and RoboHelp. Publish an existing Adobe Captivate project as a SWF file, and then import the SWF file into your document. You can also specify poster images for the multimedia demos.

FrameMaker

 

Choose File > Adobe Captivate > Insert Adobe Captivate Demo, and then browse to the location where you want to save the SWF file. Enter a SWF filename and click Save. Adobe Captivate is launched and a new Adobe Captivate project is created and the SWF content is placed in your docu­ment.

 

RoboHelp

 

Choose Insert > Adobe Captivate Demo, and then browse to the SWF file.

 

SWF file within the documentation.
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Related links:


Specify poster images for audio, videos, 3D, and SWF content



Import a SWF file



Adobe Captivate demos



2.4.                   
Using PDF Portfolios

PDF Portfolios let you package several documents into a single PDF file. Port­folios provide unified navigation, search, and seamless transition between documents. You can also add a cover page to introduce your users to the port­folio and reinforce your brand by adding images, logos, and other messaging information.

Portfolios provide you a mechanism to package disparate media, into a single PDF package. Your customers can view the portfolio using the free Adobe Reader: no special software is required.

You can collect PDF files, native MS Office documents, images, videos, SWFs, and even online videos, such as YouTube videos, in your portfolio.

Collect your files and then use Acrobat to create your portfolio.

Related links:


PDF Portfolios





3.                        
Using FrameMaker with RoboHelp

 


3.1.                   
Publishing options

Enterprises today deliver content across multiple channels, formats, and on devices. Adobe provides several technical publishing tools that extend the tradi­tional authoring and publishing options. Depending on your deployment needs, you can use Adobe FrameMaker and Adobe RoboHelp in the following ways:

 

Stand-alone publishing from FrameMaker and RoboHelp

 

In this approach, you author content in respective tools for the required delivery formats. You create PDFs from FrameMaker, and online Help formats such as WebHelp or CHM files from RoboHelp. Content is authored exclusively according to the output formats.

 

Single-sourcing with FrameMaker and RoboHelp

 

You create content in FrameMaker, leveraging the existing templates, standards, and processes, and then import the content into RoboHelp to publish several online Help formats. Here, your primary authoring envi­ronment is FrameMaker; RoboHelp provides multi-channel publishing capabilities such as ePub, Adobe AIR-based Help, WebHelp, and PDF.

 

Extended single sourcing with Adobe Technical Communication Suite

 

With the Adobe Technical Communication Suite, you gain enhanced publishing capabilities. When employed as a suite, Adobe FrameMaker and RoboHelp get extended features that allow dynamic linking and advanced single-sourcing capabilities. In addition, as you move from unstructured authoring to structured authoring, your authoring and publishing workflows remain the same.

 

Multi-channel, multi-device, automated publishing with FrameMaker Server

 

Adobe FrameMaker Server 10 extends server-based, automated, and scheduled publishing capabilities that you can synchronize with your product engineering processes and schedules. FrameMaker Server lever­ages the Technical Communications Suite workflows to create multi-channel, multi-device content delivery capabilities.

Collaboration framework with RoboHelp Server

 

With the new capabilities of RoboHelp Server and RoboHelp HTML, you can publish browser- and platform-independent Help, and allow users to provide feedback on the content. RoboHelp Server provides centralized comment moderation, a host of reports on content usage and user feed­back with optional user authentication.

 

Related links:


FrameMaker Server 10 Help



3.2.                   
Authoring and publishing workflow using FrameMaker and RoboHelp

If your authoring and publishing environment includes these two tools, you have multiple options of incorporating their strengths into your workflow.

You can map FrameMaker formats directly to RoboHelp styles in a standard CSS that ensures consistency in appearance and behavior across the entire project. In addition, within FrameMaker, you can use markers to denote context-sensitive topics, which you can directly reuse in RoboHelp to create a context-sensitive Help system.

FrameMaker and RoboHelp as independent products

 

If you have FrameMaker and RoboHelp as independent products, you can retain your authoring workflow. In this workflow, you author content in FrameMaker for print and PDF output. Then you use RoboHelp to generate richly formatted online Help. Both FrameMaker and RoboHelp provide enhanced features for importing FrameMaker content into Robo­Help projects. You can also use them together to create online Help formats such as WebHelp and Help based on Adobe AIR.

 

Adobe Technical Communication Suite

 

Adobe® Technical Communications Suite provides technical communica­tors a streamlined workflow to author content once and deliver in multiple formats. You can author in FrameMaker and publish richly formatted PDF for print and online viewing. Technical Communication Suite provides more features than the component applications that make the suite. You can integrate FrameMaker and RoboHelp authoring and publishing and dynamically link FrameMaker and RoboHelp content.

Adobe Technical Communication Suite includes Adobe Captivate and Adobe Photoshop—tools that you can use to include rich multimedia capabilities in your output formats. In addition, you can use Adobe Acrobat to set up shared reviews and consolidate review comments and edits. You can later import these comments and edits into your FrameMaker documents.

 

3.2.1.                
Authoring considerations for optimizing for online output

If your authoring process in FrameMaker is optimized for print output, consider the following before linking or importing FrameMaker documents into RoboHelp projects.

Heading formats

 

Determine the best mapping of FrameMaker heading formats to Robo­Help styles. FrameMaker documents define various heading formats specifically for print documentation. Among these formats are side heads and heading styles that start on a new page. These formats don’t apply to online formats. You generally map these heading styles to a few standard styles in the RoboHelp project.

 

Page layout settings

 

Often FrameMaker chapter templates specify an even number of pages so that new chapters begin on a recto (right) page. For online Help, ignore these pagination considerations.

 

Headers and footers

 

RoboHelp ignores headers and footers during conversion, including legal text such as “Confidential” and copyright lines. Include such text in the headers and footers in a separate step, after conversion. Similarly, in RoboHelp, re-create watermark text or images that you used in the printed documentation. Use the master page feature in RoboHelp to make these corrections.

 

Navigation

 

In print, cross-references specify page numbers which are irrelevant in Help. Converting to online Help removes chapter and section titles in headers and footers. You can enhance navigability by using breadcrumbs, and back and next buttons instead.

 

Redundant content

 

To provide context in different sections of a printed document, writers generally add redundant information such as brief summaries of concepts covered previously. Because online Help is a random-access, nonlinear medium, it requires less redundant content. Use cross-references and conditional text options to minimize redundant content in your outputs.

 

Chapter versus topic

 

In printed documentation, chapters signal stand-alone logical units, which readers use to grasp the scope of content. Online Help segregates content at topic level, accessed one topic at a time. You can group the content into chapter-like folders that expand when a user navigates the table of contents. Even so, only one topic appears at a time. In this case, try to provide comprehensive information without adding redundancy by grouping related topics together.

 

Context sensitivity

 

Although you can assign map IDs to topics in RoboHelp, you can also assign context-sensitive Help markers in FrameMaker documents. Robo­Help reads these markers and assigns the map IDs to the generated topics. Ensure that the topics created in FrameMaker contain sufficient informa­tion.

For example, a short procedure as a stand-alone topic does not provide conceptual context for the reader. To avoid creating topics with incom­plete information, assign context-sensitive Help markers to topics at a higher level. In this way, the generated Help topic contains the concept, procedure, and any relevant graphics.

3.2.2.                
Prepare FrameMaker documents for conversion to Help

If the FrameMaker document that you are importing is an unstructured FrameMaker book, you can define a single FrameMaker template for the conversion. You can then specify this template as the project template that over­rides the formats of individual documents at the RoboHelp project level. You can also reuse the conversion settings across other projects by exporting the conversion settings.

Carefully examine the FrameMaker templates before importing the documents into RoboHelp, such as when you use a general-purpose FrameMaker template. If this template contains formats that aren’t used in the book, omit those formats in the template you use for the conversion.

1)           Create a FrameMaker template that contains the formats you need in Help. Alternatively, customize the FrameMaker template. You don’t have to apply the template manually. You can set RoboHelp to apply a selected template to FrameMaker files before they are linked or imported to Robo­Help.

 

In Structured FrameMaker, the element definition document (EDD) or the DTD used in the structured FrameMaker template automatically controls formatting. Because structured FrameMaker enforces a valid structure and format, structured documents do not contain format over­rides.

 

2)           Create the required DHTML effects such as expanding text and drop-down text using the RoboHelp menus in FrameMaker.

 

3)           Apply context-sensitive Help markers to the required topics.

 

4)           Enclose graphics, callouts, and graphic or text frames you created with FrameMaker graphic tools in anchored frames. RoboHelp imports only those FrameMaker graphics that are enclosed in anchored frames.

By default, graphics and multimedia files imported into a FrameMaker document are placed in anchored frames. If your FrameMaker document contains graphics in graphic frames, place them in anchored frames before linking or importing the FrameMaker files into RoboHelp.

 

5)           To maintain the original quality of images, insert them in FrameMaker documents by reference. RoboHelp copies the referenced images directly from the source if the complete image is visible inside the anchored frame. Similarly, if the images are large, insert them in the source document by reference.

 

6)           Fix any issues in the document such as unresolved cross-references, missing fonts, and irregular numbering issues.

 

7)           Set up alternative text or captions for the images and graphics to create accessible online content.

 

8)           Apply conditional text settings in FrameMaker documents.

9)           Edit the FrameMaker TOC reference pages to have indented hierarchical headings with different styles.

Related links:


Pagination, topic naming, and context-sensitive Help



Create alternative text for images


3.2.3.                
Linking options for documents

When you link a document to a RoboHelp project, you have two options. To specify the linking options, in RoboHelp choose File > Project Settings. Click the Import tab and select one of the following:

Create a Reference

 

You create a reference to an external document. In this case, the source document is not copied into the RoboHelp project folder and remains outside the project. You can edit and update the source document inde­pendently. Later, in RoboHelp, you can update the topics generated from the linked document.

Use the linking by reference option to bring in content that is shared across multiple projects. Because only a single copy of the document exists, any change in the source document is reflected in all projects to which this document is linked.

 

Create a Copy and Link

 

You create a copy of the source document and link to the RoboHelp project. In this case, a copy of the source document is copied into the RoboHelp project and is visible in the Project Manager pod. You can edit and update the copy without affecting the source document. You update the topics generated from the copied document whenever you edit the document.

 

Use the Create a Copy and Link option to restrict access to the source document. This option allows editing only in the copy available in the RoboHelp project. For example, if you want to bring in content from a static FrameMaker document, link the document by copying it to the RoboHelp project.note:  
FrameMaker books are always linked by refer­ence, irrespective of the linking option you choose.


3.2.4.                
Trade-offs between linking and importing

 

•               Link FrameMaker and Word documents when your entire authoring is in one or both of these tools. You can make full use of RoboHelp’s advanced integration features, such as converting TOC, index, and glossaries, and creating context-sensitive Help. Whenever the source content changes, you can quickly update the topics generated in RoboHelp from the linked documents. In such cases, RoboHelp converts your FrameMaker or Word documents to multiple Help outputs with a few clicks, with little, or no native authoring in RoboHelp.

 

•               Import FrameMaker and Word documents when you have multiple inde­pendent documents and carefully use RoboHelp’s integration features. In addition, ensure that the documents you import are stable and don’t require updates independently until you have finished publishing the online Help.

 

•               Avoid editing the generated topics in RoboHelp so that you don’t lose your edits if you have to update the generated topics or overwrite them. Topics generated from linked documents can be preserved with their edits, but topics generated from imported documents are overwritten.

 

•               If you are making minimal updates to a large RoboHelp project, it is best not to link or import documents into RoboHelp. Doing so can disturb the natively created TOC, index, and glossary, pagination, and context-sensi­tive Help settings.

 

3.2.5.                
Linking and importing FrameMaker documents

The RoboHelp workflow for linking or importing FrameMaker documents allows you to do the following:

•                

Create a RoboHelp project by importing a FrameMaker book or DITAMAP.

•               Link or import FrameMaker book or DITAMAP into a RoboHelp project.

•               Link or import FrameMaker documents into a RoboHelp project. You can import FM, MIF, DITA, and XML files.

When you link a FrameMaker book or DITAMAP, HTML files are not created until you define the project settings and generate the Help topics. At the same time, you can see the added files in their hierarchical order. Importing the FrameMaker documents and editing the HTML files generated from them in RoboHelp does not affect the source FrameMaker documents.

Before you import FrameMaker documents, check them in FrameMaker for errors such as unresolved cross-references and format overrides.


Create a RoboHelp project by linking or importing FrameMaker books or documents

You can create a RoboHelp project by importing FrameMaker books or docu­ments.

1)           On the RoboHelp Starter page, click More under Import, or select File > New > Project.

 

2)           On the Import tab of the New Project dialog box, select FrameMaker Document and click OK.

 

Importing a FrameMaker book or ditamap to create RoboHelp project


[image: srf_FM_to_project.png]


 

3)           Select the FrameMaker book or document from the Files Of Type pop-up menu. Then browse to select the FrameMaker book, and click Open.

 


Import a FrameMaker book or DITAMAP into RoboHelp project

1)            

Create a project or open an existing project in RoboHelp.

 

2)           Select File > Import > FrameMaker Document.

 

Importing a FrameMaker book or ditamap into a RoboHelp project


[image: srf_FM_in_project.png]


 

3)           Select FrameMaker Book or FrameMaker DITAMAP from the Files Of Type pop-up menu.

 

4)           Browse to select the FrameMaker book or DITAMAP file and click Open.

 

5)           Optionally, select a DITAVAL file and click Open. Click Cancel to proceed without a DITAVAL file.

 

If you are importing a FrameMaker document, you can select the components that you want to import from the Content Settings wizard that appears. You can select the TOC, index, and glossary, and specify the conversion settings.


note:  FrameMaker documents created in versions earlier than 6.0 (FRM files) can be imported but not linked.


Link a FrameMaker book or DITAMAP into RoboHelp project

1)            

Create a project or open an existing project in RoboHelp.

 

2)           Select File > Link > FrameMaker Document.

 

Linking a FrameMaker book or ditamap into a RoboHelp project


[image: srf_FM_linking_in_project.png]


 

3)           Select FrameMaker Book or FrameMaker DITAMAP from the Files Of Type pop-up menu.

 

4)           Browse to select the FrameMaker book or DITAMAP file and click Open.

 


note:  FrameMaker documents created in versions earlier than 6.0 (FRM files) can be imported but not linked.


Generate HTML topics from linked FrameMaker documents

Linking FrameMaker documents does not automatically create the topics. You generate the topics after you set the project and conversion settings.

1)            

Do one of the following:

 

•               Right-click the linked FrameMaker document from the Project Manager pod and then select Update > Generate.

 

•               Select File > Update > Generate.

 

However, if you are importing a FrameMaker document, topics are generated immediately according to the conversion settings you specify. In addition, you can select the components that you want to import from the Import wizard that appears. You can select the TOC, index, and glossary, and specify the conver­sion settings.

3.2.6.                
Convert a FrameMaker TOC

When you import a FrameMaker book to a RoboHelp project, you can also import the table of contents (TOC). Import the TOC into the RoboHelp project to retain the navigation structure you defined in the FrameMaker book.

1)            

Select File > Import > FrameMaker Document.

 

2)           In the Content Settings dialog box, select Convert FrameMaker Table Of Contents, and browse to select the FrameMaker TOC file.

 

3)           Select one of the following options:

 

Add To Existing TOC

 

Appends the TOC entries to any existing RoboHelp TOC in the project. Select an existing RoboHelp TOC from the list.

 

Create New Associated TOC

 

Enter a name for a new associated TOC that is added to the RoboHelp project.
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Styles in the FrameMaker TOC determine which TOC items become books, sub-books, or pages. The most important element in determining the level is the left-most indent, followed by the font size and font weight. TOC entries that have indented items under them become books in the RoboHelp TOC. If all the TOC entries have the same indention, font size, and weight, the TOC in Robo­Help appears flat.

•               To make a heading a main book, include indented heading levels beneath that heading, or use smaller fonts or no bold for the subsumed headings.

 

•               To make a heading a sub-book, place the heading under a main heading. Then include indented heading levels beneath the sub-book heading, or use smaller fonts or no bold for the subsumed headings.

 

•               To make a heading a page, don’t include any heading levels beneath that heading. Indent the page heading, or use smaller fonts or no bold.

 

3.2.7.                
Differences between FrameMaker and RoboHelp TOCs

You can either import the FrameMaker TOC or automatically create a TOC in RoboHelp from generated topics.

•                

In FrameMaker, the TOC is generated according to the heading styles that you include in the TOC. In RoboHelp, the TOC is generated according to the topic titles. If you use topic name markers in FrameMaker to name the topics when you import FrameMaker documents, filenames in RoboHelp differ from the topic titles.

 

•               Autocreating a TOC for a FrameMaker 9 book can create multiple layers of content because of the folder structure in a FrameMaker 9 book.

 

•               In RoboHelp, you can place a TOC placeholder in another TOC, thus allowing you to create nested TOCs.

 

Related links:


Hierarchical structure in a FrameMaker book



Tips on generating TOCs


3.2.8.                
Import FrameMaker index entries

RoboHelp creates an index based on the index markers in the document you are importing. However, the index file generated in the FrameMaker book is not imported into the RoboHelp project.

1)           Select File > Import > FrameMaker Document and select the FrameMaker book or document.

 

2)           Select Convert Index in the Content Settings dialog box, and select one of the following options:

 

Add To Existing Index

 

Add the FrameMaker index entries to the existing RoboHelp index of the project.

 

Create New Associated Index

 

Enter a name for a new associated index that is added to the RoboHelp project.

 

Add To Topic

 

Add the FrameMaker index entries to individual topics in which they appear.

 

3.2.9.                
Import glossary definitions

RoboHelp creates a glossary based on glossary markers in the document you are importing. The text inside the glossary marker is the glossary term, and the paragraph text that contains the marker is the definition.

1)            

Select File > Import > FrameMaker Document and select the FrameMaker book or document.

 

2)           Select Convert Glossary in the Content Settings dialog box, and select one of the following options:

 

Add To Existing Glossary

 

Add the FrameMaker glossary to the RoboHelp glossary of the project. You can select the glossary from the list.

 

Create New Associated Glossary

 

Enter a name for a new associated glossary that is associated with the existing glossary in the RoboHelp project.

 


3.3.                   
Synchronizing linked FrameMaker documents with RoboHelp projects

You can update a linked FrameMaker document if the source FrameMaker document has changed or conversion settings in the RoboHelp project have changed.note:  
Linking eliminates the need to reimport the FrameMaker docu­ment and overwrite the topics when you update. 

Update the topics generated from linked FrameMaker documents in the following scenarios:

•                

Source FrameMaker documents changed after you added or linked them to the RoboHelp project.

 

•               You changed the pagination settings in the RoboHelp project.

 

•               You changed the style mapping in the RoboHelp project.

 

•               You updated the CSS in the RoboHelp project.

 

•               You edited the topics generated from the linked documents.

 

Icons of the project files in the Project Manager pod indicate whether the docu­ments are in sync with the RoboHelp topics.

On the other hand, if the documents were imported into the project, the Project Manager pod does not indicate the synchronization status. If either the FrameMaker documents or the conversion settings change, reimport the FrameMaker documents and overwrite the RoboHelp topics already generated. When you update the documents, RoboHelp updates the converted HTML topics, TOC, index, and glossary.

3.3.1.                
FrameMaker book synchronization status indicators



 	
 

Icon

 


 	
Description
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FrameMaker book missing. The source FrameMaker book that you have linked to the RoboHelp project is either moved to another folder or deleted. Locate the source book and link them to the new location.
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FrameMaker book out of sync because of changes in the source document. Update the RoboHelp topics.
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Topics generated from the linked FrameMaker book are out of sync because of changes in the RoboHelp Project Import Settings. Update the RoboHelp topics generated from the FrameMaker book.
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Topics generated are in sync with the linked FrameMaker book.

 






3.3.2.                
FrameMaker document synchronization status indicators



 	
 

Icon

 


 	
Description
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Linked FrameMaker document missing. The source FrameMaker book that you have linked to the RoboHelp project is either moved to another folder or deleted. Locate the source book and link them to the new location.
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FrameMaker document out of sync because of changes in the source document. Update the RoboHelp topics.
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Topics generated from the linked FrameMaker document are out of sync because of changes in the RoboHelp Project Import Settings. Update the RoboHelp topics generated from the FrameMaker document.
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Topics generated are in sync with the linked FrameMaker document.






3.3.3.                
Update FrameMaker documents

1)            

From the Project Manager pod, right-click a FrameMaker book and select Update, then choose one of the following:

 

Generate

 

Generates HTML topics from the linked FrameMaker document for the first time. After generating the topics, the option changes to Update.

 

Update

 

Updates topics generated from the selected book or document alone.

 

Update All

 

Updates all topics generated from all linked FrameMaker documents.

 

Force Update

 

Overwrites the current set of topics generated from the selected FrameMaker book or document. Use this option to force update the topics generated from the linked FrameMaker book or document.

 

Force Update All

 

Updates all linked documents and overwrites all generated topics.

 

Alternatively, you can select the linked FrameMaker book or document and update the RoboHelp topics generated from the linked FrameMaker book or document.

3.3.4.                
Preserve changes to a topic during an update

Normally, when you update a linked document, all topics generated from it are updated, overwriting any other changes you made in the generated topics. However, you can selectively preserve changes in generated topics and retain your edits.

1)           Right-click the linked document in the Project Manager pod and select Properties.

 

2)           In the FrameMaker Document Settings dialog box, select the File Update Settings tab.

 

3)           On the left column, select the edited files you want to preserve changes during update and click OK.

 

Any files that you had selected earlier for preserving changes are displayed in the right column.

 

Set alert when editing generated topics

 

You can set RoboHelp to alert you when you edit topics generated from linked documents. When you save the changes to such topics, RoboHelp alerts you that the changes would be lost when the linked documents are updated.

1)           Select Tools > Options.

 

2)           In the General tab, select Show Alert On Modification Of Auto Generated Topics From Linked Documents and click OK.

 

Mark topic edits for preservation

 

If you enabled alerts when saving changes to generated topics, you can mark the topic edits for preservation during an update. Topics marked for preservation during updates are automatically added to the list of preserved topics in the File Update Settings dialog box.

1)            

Edit a generated topic and save the changes.

 

2)           In the alert message that appears, select Preserve Modifications To This File and click OK.

 

3.3.5.                
Delete a generated topic

When you delete a generated topic, you have two options. You can regenerate the deleted topic when you update the linked FrameMaker document or completely remove the deleted topic from your project. By default, RoboHelp regenerates the deleted topic when you update the FrameMaker document.

1)            

In the Project Manager pod, expand the linked FrameMaker document to display the topics generated from it.

 

2)           Right-click the topic that you want to delete, and select Delete.

 

3)           Do one of the following:

•                

Click OK to delete the topic from the project permanently. The deleted topic is not regenerated when you update the FrameMaker document.

 

•               Select Generate This File On Next Update and click OK to delete the topic. When you update the FrameMaker document, the deleted topic is gener­ated again.

 

3.3.6.                
Regenerate a deleted topic

If you delete a topic generated from a linked FrameMaker document, the topic is removed from the project. However, you can regenerate topics deleted from a linked document.

1)           Right-click the linked FrameMaker document in the Project Manager pod and select Properties.

 

2)           In the FrameMaker Document Settings dialog box, select File Update Settings tab.

 

3)           On the right column, select the deleted files that you want to retrieve and click OK.

 

4)           Update the FrameMaker document.

 

3.3.7.                
Edit a linked FrameMaker document

You can edit linked FrameMaker documents directly in FrameMaker.

1)            

Right-click a document and select Edit.

 

2)           Edit the FrameMaker document.

 

3)           Click Save. The modified FrameMaker document now appears in the Project Manager pod with a different icon. This icon indicates that the source content is now out of sync with the topics generated from the linked FrameMaker document.note:  
Force an update of the document after you edit the source in FrameMaker. 

3.3.8.                
Delete a linked document

You can directly delete documents linked by copy from the Project Files folder, and you can delete the references of the documents linked by reference.

1)            

Right-click a document and select Delete.

 

When you delete a linked file, all its associated documents, such as CSS, images, baggage files, and multimedia files, are also deleted.

 

Notes:

 

•               If a referenced file is moved to a different location, its icon changes. You can restore the link to the document by pointing to its new location.

 

•               Do not rename files generated after linking a document.

 

•               You cannot drag the generated topics outside the source document folder to some other location in the Project Manager pod.

 

3.3.9.                
Restore a link to a missing or renamed document

If any of the linked documents are moved or renamed, RoboHelp displays a missing link icon for the linked document in the Project Manager pod. You can restore the link to a moved or renamed file and have all the topics already gener­ated from the document retained in the project.

1)            

In the Project Manager pod, right-click the document that has the missing link icon.

 

2)           Select Restore Link To FrameMaker File, and browse to select the new location of the missing file.

 


3.4.                   
FrameMaker document components converted to Robo­Help


 RoboHelp converts most of the FrameMaker components when you link or import FrameMaker documents. The following tables list the major FrameMaker document components and show how they are converted in RoboHelp.



 	
 


FrameMaker files 





	
Book files

 


	
Documents contained within the book are converted (FM, XML, MIF, HTM, and HTML files). XHTML files that are included in the FrameMaker book must be valid XHTML. Validate the XHTML in FrameMaker itself. All other files in the FrameMaker book are ignored. Child books, folders, and groups in FrameMaker 9 books are converted and appear as folders in the RoboHelp projects. See Hierarchical structure in a FrameMaker book.

 





	
TOC

 


	
Converted, if selected. See Convert a FrameMaker TOC.

 





	
Text insets

 


	
Text insets in the FrameMaker documents are considered part of the FrameMaker document itself and are flattened in the RoboHelp topic.

 





	
Index and glossary

 


	
Index and glossary files generated in the FrameMaker book are not converted. Instead, the index markers and glossary markers in the imported FrameMaker documents are converted if selected. See Import FrameMaker index entries and Import glossary definitions..

 








 	

Variables and conditional text 





	
Variables

 


	
Converted. User-defined variables in FrameMaker are converted as such in RoboHelp and can be redefined. Apply relevant conditional text tags to suppress variables that shouldn’t appear in online format. For example, you can suppress the Table Continuation variable in table headers for tables that break across pages in the FrameMaker documents.

 





	
Conditional tags

 


	
Converted as RoboHelp conditional build tags.

 





	
Equations

 


	
Convert equations to images and insert them in the RoboHelp topics after conversion.

 








 	

Markers 





	
Cross-references, hypertext, URLs

 


	
Converted to hypertext links. You can map the cross-reference formats in RoboHelp so that you can remove the volume, chapter, and page references that are not relevant in online format. Unresolved cross-references and hypertext entries appear as text in online Help. URLs become live hypertext links in the online Help output. See Convert FrameMaker cross-reference formats to RoboHelp styles.

 





	
Index and glossary markers

 


	
Converted to an index and glossary when creating project. See Import FrameMaker index entries and Import glossary definitions.





	
Topic name markers

 


	
Converted if you select this option in the project conversion settings. Use topic name markers to create topic titles and topic filenames from the marker text. See Pagination, topic naming, and context-sensitive Help.

 





	
Context-sensitive Help markers

 


	
Converted if you select this option in the project conversion settings. Use Context Sensitive Help Makers in FrameMaker to specify text in FrameMaker document for generating Context Sensitive Help. See Pagination, topic naming, and context-sensitive Help.

 





	
Custom markers

 


	
Converted. You can use these markers for delineating topics from FrameMaker source, or to pass processing instructions to RoboHelp for images and tables.

 








 	

Formats 





	
Paragraph formats

 


	
Converted. You can map FrameMaker paragraph formats to RoboHelp styles or import the source formatting. See Convert FrameMaker paragraph formats to RoboHelp styles 





	
Character formats

 


	
Converted. You can map FrameMaker character formats to RoboHelp styles or import the source formatting. See Convert FrameMaker character formats to RoboHelp styles.





	
Table formats

 


	
Converted. You can map FrameMaker table formats to RoboHelp styles or import the source formatting. See Convert FrameMaker table formats to RoboHelp table styles.

 





	
Footnote properties and table footnotes

 


	
Converted. Because table title and table footnotes are paragraph formats in FrameMaker, you specify conversion settings for these paragraph formats separately.

 





	
Lists

 


	
Converted according to the settings you define. See List-mapping scenarios.

 








 	

Page layouts 





	
Master pages

 


	
FrameMaker master pages are ignored. Master pages are used for layout, borders, and page numbers in FrameMaker, so they are not applicable to online Help. RoboHelp provides master page support for breadcrumbs, mini-TOCs, and headers and footers that can be selected when you publish a single source layout.





	
Reference pages

 


	
Ignored. However, you can use the advanced scripting support in RoboHelp to convert images and graphics placed in the reference pages that are associated with paragraph formats.





	
Page layout, size, and pagination

 


	
Ignored. These elements are not applicable to online Help. See Pagination, topic naming, and context-sensitive Help.

 





	
Headers/footers

 


	
Ignored. Headers and footers in FrameMaker usually contain chapter names, chapter numbers, and page numbers, which are not applicable in online formats. After you generate topics, you can create headers and footers in RoboHelp.

 





	
Rotated text

 


	
Converted to text, such as in table cells. (Rotated text is not supported in HTML).

 








 	

Images and anchored frames 





	
Images

 


	
Only converted if they are inside anchored frames. If the images are not in anchored frames, reinsert them after you have imported the FrameMaker files. By default, FrameMaker places the imported and linked images in anchored frames, so they are converted. However, images placed in graphic frames are not converted. If images contained in anchored frames are missing, RoboHelp creates blank images with the filename in a sequential manner. See Image conversion settings.

 





	
Drawings

 


	
Drawings created within anchored frames are converted to images. You can define the image conversion settings. See Image conversion settings.

 





	
Anchored frames

 


	
Converted to images. See Image conversion settings.

 





	
ALT text on images and anchored frames

 


	
Converted. If no ALT text is provided in the FrameMaker document for images RoboHelp applies the filename of the converted images as the ALT text. See Create alternative text for images.

 





	
Text frames, graphic frames, and images inside anchored frames

 


	
Anchored frames and their content convert to images. All content within an anchored frame, including text frames, multiple images, and callouts convert to a single image. RoboHelp inserts the filename of the created image as the ALT text if no ALT text is defined for the anchored frame.

 





	
Equations

 


	
Enclose equations in anchored frames so that they are converted to images when RoboHelp converts them.








 	

Structured FrameMaker components 





	
DITAMAP files

 


	
Converted like FrameMaker books

 





	
DITA documents

 


	
Converted like FrameMaker documents

 





	
XML files in book

 


	
Converted like FrameMaker documents

 





	
XHTML files in book

 


	
Converted like FrameMaker documents

 





	
Content references

 


	
Text or files inserted into FrameMaker documents as content references appear as part of the topics where they appear. They do not appear as references in the online Help outputs. See Content reference.

 







3.5.                   
Conversion basics

 

3.5.1.                
Converting FrameMaker formats to RoboHelp styles

You can define how the FrameMaker formats are converted to RoboHelp styles on the project level. All FrameMaker format definitions in the FrameMaker document appear in the Conversion Settings dialog box, even if they aren’t used. For structured documents, FrameMaker formats that are mapped to elements in the structured template are listed. You specify the following:

•                

FrameMaker template used for conversion. This step is optional.

 

•               RoboHelp style sheet for style mapping.

 

3.5.2.                
Select a FrameMaker template for conversion

If the FrameMaker document that you are importing is an unstructured FrameMaker book, you can define a single FrameMaker template for conver­sion. For example, suppose the documentation set contains a Getting Started Guide, Installation Guide, User Guide, and an Administration Guide. These documents can have different page layouts and formats in print, none of which are relevant for online output. In such cases, you can define one template that contains format definitions for all documents you want to convert.

You can then specify this template as the project template, which overrides the formats of individual documents at the RoboHelp project level. You can also reuse the conversion settings across other projects by exporting the conversion settings.

1)            

Select File > Project Settings.

 

2)           Click the Import tab of the Project Settings dialog box. Select Apply FrameMaker Template Before Import.

 

3)           Click Browse to select the FrameMaker template you want to use for the project.

 

3.5.3.                
Select the CSS for style mapping

You can select the cascading style sheet (CSS) that RoboHelp uses to map the FrameMaker formats to RoboHelp styles. By default, RoboHelp uses the RHStyleMapping.css file for the project. You can also use a custom CSS. You can later edit the styles either in RoboHelp or in an external CSS editing appli­cation such as Adobe® Dreamweaver®.

1)            

Select File > Project Settings.

 

2)           Click the Import tab of the Project Settings dialog box. Do one of the following:

 

•               Select the CSS file from the CSS For Style Mapping menu.

 

•               Click Add next to the CSS for Style Mapping pop-up menu, and select a CSS file.

Use this option to specify a custom CSS for the project. When you select this option, RoboHelp copies the selected CSS file into the root folder of the project, and uses the selected CSS for style mapping.

 

3.5.4.                
Upgrading from RoboHelp 7 to RoboHelp 9

RoboHelp 7 allowed document-level conversion settings for the FrameMaker documents that you added to a RoboHelp project. With RoboHelp 9, the conversion settings are applied project-wide, allowing you to have a consistent set of conversion parameters. If you are opening a RoboHelp 7 project that had FrameMaker documents added by reference or by copy, you can retain the document-specific settings defined in RoboHelp 7 project.

When you upgrade a RoboHelp 7 project, you can either retain the earlier docu­ment-level settings or convert to the project-level settings supported in Robo­Help 9. After you upgrade your project, you cannot open the project in RoboHelp 7.

If you choose to retain the RoboHelp 7 settings, you can add or remove docu­ments to an upgraded project with the document-level conversion settings. You can define document-level conversion settings for the newly added FrameMaker documents also. This option allows you to retain the RoboHelp 7 behavior for your upgraded project. However, to take advantage of the enhanced features of RoboHelp 9 and its integration with FrameMaker, you should upgrade the project completely. For example, RoboHelp 7 provided limited mapping options for autonumbering and list styles. On the other hand, RoboHelp 9 allows you to map complex autonumber formats and multilevel list styles to RoboHelp styles or HTML lists.

 note:  
You can discard the document-level settings any time, even if you choose to retain them at the time of upgrading. However, discarding the document-level settings is irreversible.



Retain or discard RoboHelp 7 settings when upgrading

To retain the document-level settings for converting FrameMaker content into your RoboHelp project, you override the project-level settings of the converted project with the document-level settings inherited from the RoboHelp 7 project. By default, RoboHelp allows you to retain the document-level settings by over­riding the project-level settings.

1)            

Open the RoboHelp 7 project in RoboHelp 9.

2)           Select File > Project Settings.

 

3)           In the Import tab of the Project Settings dialog box, do one of the following:

 

•               To retain the document-level settings in the upgraded project, select the Override Project Settings At Document Level option. This is the default behavior.

 

•               To discard the document-level settings and use project-level settings, deselect the Override Project Settings At Document Level option.

 


Edit document-level conversion settings

If you retain the document-level settings that override the project-level settings for a project converted from an earlier version of RoboHelp, you can edit these settings.

1)           In the Project Manager pod, right-click the added FrameMaker document and select Properties.

 

2)           In the FrameMaker Document Settings dialog box, select the Conversion Settings tab, and set the following.

Apply FrameMaker Conditional Text Build Expression

 

Select to apply conditional text settings before converting the added FrameMaker document.

 

Convert AutoNumber To HTML List

 

Select to convert the FrameMaker autonumbering to HTML lists in the converted HTML topics.

 

Context-Sensitive Help Marker

 

Specify the context-sensitive Help marker that RoboHelp should use for generating context-sensitive Help.

 

User-Defined HTML Tag

 

Select the user-defined HTML tag that you want to use instead of the stan­dard <p> tags in the generated topics. note:  
To select FrameMaker formats on which the user-defined tag must be applied, select the FrameMaker formats from the Project Settings dialog box.


Topic Name Pattern

 

Specify the topic name pattern for topics generated from the added FrameMaker document.

 

FrameMaker Styles For Pagination

 

Specify the list of FrameMaker paragraph formats on which pagination for online Help topics should be done. You specify the FrameMaker para­graph formats separated by commas.

 


note:  
Pagination is based on FrameMaker paragraph formats. 

3.5.5.                
Hierarchical structure in a FrameMaker book

You can enforce a hierarchical structure and grouping within the book. You can also include child books within a book, and create folders and groups within a book.

When you link or import a FrameMaker book, the Project Manager pod in RoboHelp shows the FrameMaker book’s hierarchy. When linked or imported into RoboHelp, child books inherit the TOC, index, and glossary from the parent book.

Hierarchy of FrameMaker book reflected in the Project Manager pod when you link a FrameMaker book into RoboHelp


[image: srf_book_projmgr_pod.png]


3.5.6.                
Convert FrameMaker cross-reference formats to RoboHelp styles

By default, all cross-reference styles in the source document are used in the generated topics without mapping. Define the mapping of these formats because FrameMaker documents can contain page and volume references in cross-references that are not relevant to Help formats.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           Select a cross-reference format from the Cross Reference group in the Conversion Settings dialog box.

 

4)           Select a RoboHelp style to map to it, or type the RoboHelp style field to redefine the cross-references in the FrameMaker document.

 

5)           Double-click a building block to append it to the RoboHelp cross-refer­ence definition.

 

3.5.7.                
Content reference

Text or files that you have inserted into the FrameMaker documents as content references appear as part of the topics where they are referenced. They do not appear as references in the online Help outputs.

3.5.8.                
Conversion settings

You can create a standard set of conversion settings for importing FrameMaker content into RoboHelp projects and then use these settings consistently across multiple projects.

You define these settings once. For subsequent projects, import these settings to the project. In this way, you can quickly set up the project environment and publish FrameMaker content in several online formats.

These settings include:

•                

Specified FrameMaker template

 

•               Cascading style sheets (CSS) for RoboHelp projects

 

•               Style mapping between FrameMaker formats and RoboHelp styles

 

•               Format conversion settings, image conversion settings, and other settings

 

Related links:


Demystifying Mapping Files



Export conversion settings

1)            

Select File > Project Settings.

 

2)           On the Import tab, click Export.

 

3)           Specify a name for the RoboHelp Import Settings file (ISF file) and click Save.

 


Import conversion settings to a project

1)            

Select File > Project Settings.

 

2)           On the Import tab, click Browse.

 

3)           Select a RoboHelp Import Settings File (ISF file) and click Open.

 


3.6.                   
Automap

Automap picks up RoboHelp style names and maps them to the imported FrameMaker document’s styles. Instead of having to map each FrameMaker format with a corresponding RoboHelp style, use Automap to automatically map similar style names from the selected CSS in RoboHelp.

Automap compares FrameMaker/CSS format names with the style names present in RoboHelp’s mapping in CSS (By default, the style CSS is RHStyle­Mapping.css).

For example, when you choose Automap at a paragraph level, the following could be mapped:

 



 	
FrameMaker/CSS format name

 


 	
Similar RoboHelp Style

 





	
Heading 1

 


	
h1

 





	
my Numbered+

 


	
myNumbered

(Space and special characters are removed during automapping)

 





	
Body

 


	
p

 






Unlike FrameMaker format names, CSS style names cannot have spaces and special characters. While mapping, RoboHelp ignores spaces and special char­acters in the FrameMaker format names.

A special case is that RoboHelp automaps FrameMaker’s Heading1 to Heading6 (or Heading 1 to Heading 6) paragraph styles to h1 to h6.

Automap works for Paragraph, Character, and Table formats. Table styles require handling for appearance as well as caption styles. You can also set Automap for an individual format.

When you select Automap for all paragraph, character, or table styles and automap is applied to some of the styles, RoboHelp give you the option to over­write the previously mapped styles. You can select the styles you want to over­write.

In the project settings dialog, you can also click Export to export the conversion settings as a .isf file.

3.6.1.                
Automap Paragraph, Character, and Table formats at project level

 

1)            

Select File > Project Settings.

 

2)           Click the Import tab of the Project Settings dialog and do the following.

 

a)           Select Apply FrameMaker Template before import.

b)           Specify the name\location of the relevant FrameMaker template.

 

c)           Click Edit (FrameMaker Document).

 

3)           In the Conversion Settings dialog, do the following as required:

 

a)           Select Paragraph and then select Automap Paragraph Styles

 

b)           Select Character and then select Automap Character Styles.

 

c)           Select Table and then select Automap Table Styles.

 

When you select Automap for all Paragraph, Character, or Table styles, and one or more of the relevant formats are already mapped, RoboHelp displays Automap Options dialog. In the Automap Options dialog, choose to retain or override the individual formats’ mapping.

 

3.6.2.                
Automap paragraph styles at style level

 

1)            

In the conversion settings dialog, expand Paragraph and select a style.

 

If the style is mapped, the dialog displays a preview of the mapped FrameMaker and RoboHelp styles. If the Automap has failed, the Robo­Help Style field displays the message: [Automap failed. Add stylename to the CSS.]

 

2)           If the Automap has failed, do one of the following in the RoboHelp Style drop-down list:

 

•               Add the stylename to the mapping CSS.

 

•               Select the RoboHelp style name to map to the selected FrameMaker format.

•               Select [Source]. RoboHelp retains the appearance of the FrameMaker text in the online Help format.

 

3)           Select the properties for the mapped RoboHelp style:

 

Exclude From Output

 

Select to discard the content in FrameMaker document that is applied with the selected FrameMaker paragraph format.

 

Pagination

 

Select to create a Help topic at each occurrence for the selected FrameMaker paragraph format.

User-Defined HTML Tag

 

Select or enter a user-defined HTML tag for the selected paragraph format.

 

If the selected FrameMaker format has auto numbering properties defined, specify how auto numbering is converted.

 

3.6.3.                
Automap character styles at style level

 

1)           In the conversion settings dialog, expand Character and select a style.

 

If the style is mapped, the dialog displays a preview of the mapped FrameMaker and RoboHelp styles. If the Automap has failed, the Robo­Help Style field displays the message: [Automap failed. Add stylename to the CSS.]

 

2)           If the Automap has failed, do one of the following in the RoboHelp Style drop-down list:

 

•               Add the stylename to the mapping CSS.

 

•               Select the RoboHelp style name to map to the selected FrameMaker­character format. Optionally, click Edit Style to edit the selected RoboHelp character style.

•               Select [Source]. RoboHelp retains the appearance of the FrameMaker text in the online Help format.

 

3)           Select the properties for the mapped RoboHelp style:

 

Exclude From Output

 

Select to discard the content in FrameMaker document that is applied with the selected FrameMaker paragraph format.

 

Pagination

 

Select to create a Help topic at each occurrence for the selected FrameMaker paragraph format.

User-Defined HTML Tag

 

Select or enter a user-defined HTML tag for the selected paragraph format.

 

If the selected FrameMaker format has auto numbering properties defined, specify how auto numbering is converted.

 

3.6.4.                
Automap table styles at style level

 

1)            

In the conversion settings dialog, expand Table and select a style.

 

If the style is mapped, the dialog displays a preview of the mapped FrameMaker and RoboHelp styles. If the Automap has failed, the Robo­Help Style field displays the message: [Automap failed. Add stylename to the CSS.]

 

2)           If the Automap has failed, do one of the following in the RoboHelp Style drop-down list:

 

•               Add the stylename to the mapping CSS.

 

•               Select the RoboHelp style name to map to the selected FrameMaker table format. Optionally, click Edit Style to edit the selected Robo­Help table style.

 

•               Select [Source]. RoboHelp retains the appearance of the FrameMaker table in the online Help format.

 

3)           Specify the Caption Style and other table properties for the style:

 

a)           Select the RoboHelp caption style name to map to the selected table format’s caption. Or select [Source]. RoboHelp retains the appear­ance of the table caption in the online Help format. You can also select Automap for an individual table’s caption style.

 

b)           Specify the preferred Table Size and Cell Size properties in the online Help output.

 


3.7.                   
Pagination, topic naming, and context-sensitive Help

When you link or import a FrameMaker document, you define how FrameMaker content is presented as topics in RoboHelp. With Technical Communication Suite, you can set how the content is paginated, topics named, and map context-sensitive Help topics for integration with a product.

3.7.1.                
Considerations for pagination and topic titles

Determine the pagination option suited to your environment based on the following factors:

Completeness of content in the topic

 

Ensure that the topic generated contains relevant and complete informa­tion for the reader. For example, if you set pagination for Heading 3 level paragraph, it is possible that the topic contains only the task information, without the required contextual information that is covered in another Heading 3 level topic. To avoid such disconnected topics, set the pagina­tion at a higher level so that complete information is available in a single Help topic.

 

Drop-down text

 

Ensure that the paragraph format for the drop-down text body is not set for pagination. The paragraphs applied with this format must accompany the drop-down text caption paragraph format.

Even though it is easy to define pagination and topic title generation based on FrameMaker paragraph formats, this approach has the following limitations:

Lack of topic-level controls

 

Because the pagination settings are set at the project level, you cannot exercise discrete control over topics that are not in the defined heading levels. For example, suppose you want to make an H3 level topic a separate Help topic. If you set pagination at H2 for your project, you can’t do so. The H3 topic is included under the topic immediately above it.

 

Uniform topic naming convention

 

Help topics use the same file-naming conventions that you define in the conversion settings, especially if your authoring environment is Struc­tured FrameMaker. You can’t deviate from these conventions.

 

Lack of flexibility in topic titles

 

You cannot selectively alter the titles or filenames of the topics without changing the source content. When you search for content in RoboHelp, topic titles are displayed in search. An intuitively titled topic helps the reader quickly identify the most relevant information from search results.

 

Possibility of inconsistency in documents from multiple books

 

Linked and imported FrameMaker documents from multiple books can lead to inconsistent heading styles for generated topics.

 

For example, suppose you link to or import FrameMaker documents from a user guide and reference guide. In this case, topic titles can reflect differ­ences in style for instructional content and reference content. If topic titles are derived from the paragraph text at which pagination is set, the Help topics generated can have inconsistent titles.

 

3.7.2.                
Advantages of setting pagination from within FrameMaker

Using custom markers in FrameMaker, you can overcome these drawbacks for smaller projects and do the following:

Create workflow-based content

 

With the intelligent use of custom markers in FrameMaker, you can create RoboHelp topics that present users information about the workflow. You can create Help topics irrespective of the heading styles applied in the FrameMaker document.

 

Optionally, define the titles of the topic

 

This option becomes useful when you want to combine many topics and assign a relevant title to the combined topic, rather than derive the topic title text from one of the heading styles.

 

Optimize topic length

 

Because you define from FrameMaker how Help topics are created in RoboHelp, you can precisely control the topic length suited for topic-based authoring. However, if you use the mini-TOC feature for your Help topics, limit the number of headings included in a topic. A long mini-TOC can make the topic contents accessible only through scrolling.

 

After you define these markers in your FrameMaker documents, you can set the conversion settings in RoboHelp to create and name topics according to your preferences.

3.7.3.                
Pagination options

You can define how FrameMaker content is segregated as different Help topics in RoboHelp.

 

Create separate HTML topics based on FrameMaker paragraph formats

 

You specify the heading styles in FrameMaker that should be used as the page break. For example, if the FrameMaker file contains ten topics, each with subtopics, tasks, and tables, you can have each topic convert into a separate HTML file. If each of these topic headings is at Heading 1 format, you can set each Heading 1 topic to be created as a separate HTML topic. On the other hand, if you set the pagination at Heading 2, separate HTML files are created for each Heading 2 topic,

 

Define Page Break markers in FrameMaker content

 

You can insert Page Break markers at the beginning of the paragraph in FrameMaker documents. Typically, you create page breaks at the heading levels that you choose. If you use this option, avoid defining pagination setting based on paragraph formats.

 

Use custom markers defined in FrameMaker

 

If you are converting legacy content in FrameMaker that used custom markers to define pagination using other tools, you can use this option. Avoid using the Page Break markers in such documents.

3.7.4.                
Topic name options

You can define how topics that are generated from FrameMaker content will be named within RoboHelp. By default, you can define the text of the paragraph set for pagination as the topic name. In addition, you can define other naming conventions. If the filenames use sequential numbering, such as help­topic001.html and helptopic002.html, you can define the pattern for such conventions.

 

Based on paragraph text

 

When you set heading styles for pagination, the heading text becomes the default filename for the topic file created in RoboHelp. For example, suppose you define Heading 2 for pagination, and the FrameMaker docu­ment has two Heading 2 topics, “Introduction” and “Beyond basics.” In this case, RoboHelp creates the topics introduction.htm and beyond_ba­sics.htm. Thus, you get intuitively named HTML files that indicate the topic title.

Topic Name Pattern

 

Topics are named according to the selected pattern. You can select one of the following or create a topic name pattern using the Topic Name Pattern building blocks provided by RoboHelp. In addition, you can add standard static text, such as “HelpTopic,” followed by sequential number as the topic name pattern.

 



 	
Building block

 


 	
Converted topic name pattern

 





	
default

 


	
HTML topic generated has the filename consisting of the paragraph text.





	
<$filename_no_ext>-<$paratext>

 


	
HTML topic generated has the filename consisting of the filename of the FrameMaker document without the .fm extension and the topic title, separated by a hyphen. For example, the FrameMaker document named “Chapter.fm” with "1-Introduction" as paragraph text is converted to an HTML topic with the filename "Chapter-1-Introduction.htm”

 





	
<$filename_no_ext>-<n>

 


	
HTML topic generated has the filename consisting of the filename of the FrameMaker document without the .fm extension and the paragraph number separated by a hyphen. For example, the FrameMaker document "Chapter.fm" is converted to an HTML topic with the filename "Chapter-1.htm"

 





	
<$paratext_no_num>

 


	
HTML topic generated has the filename consisting of the paragraph text of the paragraph format at which pagination is set, without the paragraph number. For example, a heading 1 paragraph "1. Introduction" is converted to an HTML topic with the filename "Introduction.htm"

 





	
<$paratext>

 


	
HTML topic generated has the filename consisting of the paragraph text of the paragraph format on which pagination is set. For example, a heading 1 paragraph "Introduction" is converted to an HTML topic with the filename "Introduction.htm"

 






Topic Name Marker

 

Topics are named after the marker applied in the FrameMaker document. Ideally, you specify the topic name as the marker text, so that topic names reflect their content. If you select this option, the pagination settings applied on the Paragraph Styles pane are ignored. Use this option to precisely control the creation of separate Help topics from the FrameMaker documents.

Page Break Marker

 

If you are creating new content in FrameMaker, and do not want to use custom markers to define pagination, you can use the Page Break marker. When you define the topic title, FrameMaker automatically creates the topic name based on the topic title.

Avoid using this option when your FrameMaker document already contains custom markers for pagination, or when you want to define pagi­nation based on FrameMaker paragraph formats.

 

3.7.5.                
Define topic name settings

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker document.

 

3)           In the Other Settings tab, select the required option:

 

3.7.6.                
Context-sensitive Help markers in FrameMaker documents

If you are using Technical Communications Suite, you can define the context-sensitive Help map IDs within FrameMaker itself, in addition to using other markers.

You can convert the context-sensitive Help markers that you insert in your FrameMaker documents and reuse them as map IDs. You specify the context-sensitive Help marker in the Project Settings dialog box before linking FrameMaker documents. You can also specify this setting when you import FrameMaker documents. You can work with context-sensitive Help markers in FrameMaker documents in two ways:

Automatic conversion of map IDs from FrameMaker documents

 

You apply context-sensitive Help markers in your FrameMaker docu­ments, and specify the marker type in the conversion settings. RoboHelp imports the markers from FrameMaker documents and adds the map IDs from the strings contained in the context-sensitive Help markers.

 

Manually adding map IDs

 

You can use the map IDs you received from your development team in two ways:

 

•               From within FrameMaker, use the CSH marker option to enter the map IDs for the topics that you want generated. This option is available only if you are using the Technical Communications Suite.

 

•               From within FrameMaker, use the map ID as the text for the marker that you want to use the context-sensitive Help marker. When you link or import the FrameMaker documents, you specify the context-sensitive Help marker in the conversion settings.

 

If you are using the first option, avoid specifying the context-sensitive Help marker in the conversion settings.


Specify the context-sensitive Help marker

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           In the Other Settings group of the Conversion Settings dialog box, select Context-Sensitive Help Marker.

 


3.8.                   
Converting FrameMaker content

 

3.8.1.                
Convert FrameMaker paragraph formats to RoboHelp styles

By default, RoboHelp converts all paragraph formats from FrameMaker to RoboHelp CSS styles. It retains the appearance and behavior of the FrameMaker formats in the RoboHelp project. To ensure consistency of the online Help proj­ects, map the FrameMaker formats to RoboHelp styles and edit them.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           On the Conversion Settings panel, select the FrameMaker format from the Paragraph group.

 

4)           From the RoboHelp Style menu, select the RoboHelp style that you want to map to the FrameMaker format. To retain the appearance of FrameMaker text in the online Help format, select [Source].

 

To edit the selected RoboHelp style, click Edit Style.

 

5)           Select the properties for the mapped RoboHelp style:

 

Exclude From Output

 

Select to discard the content in FrameMaker document that is applied with the selected FrameMaker paragraph format.

 

Pagination

 

Select to create a Help topic at each occurrence for the selected FrameMaker paragraph format.

User Defined HTML Tag

 

Select or enter a user-defined HTML tag for the selected paragraph format.

 

If the selected FrameMaker format has auto numbering properties defined, specify how auto numbering is converted.

 

Related links:


Custom HTML tags



Autonumber style mapping



Styles and style sheets



Mapping FrameMaker Styles to RoboHelp


3.8.2.                
Convert FrameMaker character formats to RoboHelp styles

You can map the FrameMaker character formats to character styles in Robo­Help.

You can also edit the styles in RoboHelp.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           Select the FrameMaker character format from the left pane of the Conver­sion Settings dialog box.

 

4)           Select the RoboHelp character style from the pop-up menu. Optionally, you can do the following:

•                

To import the FrameMaker character format, select [Source] from the pop-up menu.;

 

•               To edit the selected RoboHelp style, click Edit Style.

 

•               To exclude the text in the FrameMaker document applied with the selected character format, select Exclude From Output.

•               To apply a user-defined HTML tag to the imported text in HTML output, select User Defined HTML Tag, and select the tag from the pop-up menu. You can also enter a new HTML tag. The custom HTML tag for the char­acter format replaces the <span> tag in the generated HTML file.

 

3.8.3.                
Exclude a FrameMaker paragraph format from Help topics

You can exclude the content in FrameMaker documents that has a specified paragraph format from the converted output. Use this option to remove content such as special notices that are not required in online output.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           In the project settings, select a FrameMaker paragraph format in the left pane.

 

4)           Click Exclude From Output.

 

3.8.4.                
Custom HTML tags


 You can define or apply a custom HTML tag instead of the standard <p> tag for paragraph styles and <span> tag for character styles in the HTML output for the formats that you import from FrameMaker. You can define separate HTML tags for each format in the FrameMaker document.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           In the Conversion Settings dialog box, select the user-defined HTML tag option.

 

4)           Type the name of the custom HTML tag or select an existing tag to use instead of the default HTML tag.

 

3.8.5.                
Apply FrameMaker conditional text build expressions

You can apply the Show/Hide settings of the conditional text build expressions to the content in your FrameMaker documents imported into RoboHelp proj­ects. RoboHelp imports the content after applying the Show/Hide settings to the FrameMaker content. Any text that is hidden is not brought into RoboHelp project.

1)            

Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           In the Other Settings group of the Conversion Settings dialog box, select Apply FrameMaker Conditional Text Build Expression.

 

3.8.6.                
Autonumber style mapping

Choose the conversion setting for converting autonumber formats in the FrameMaker document to the Help format. If the FrameMaker document contains hierarchical numbered lists, you can choose one of the following:

Ignore Autonumber

 

Choose this option if the autonumber text is relevant only in print format. The converted paragraph does not contain autonumbering. For example, suppose you ignore autonumbering for the FrameMaker paragraph format “Section2 Level.” In this case, “Section 1.1: System Requirements” in the source appears as “System Requirements” in the RoboHelp topic generated.

 

Convert Autonumber To Text

 

Choose this option to retain the appearance of the FrameMaker numbered lists. The autonumber part loses its sequencing properties and appears as part of the paragraph text in RoboHelp topic.

 

Convert Autonumber To HTML List

 

Choose this option to convert the autonumber to HTML lists using HTML tags such as <ol>, <ul>, and <li>.

 

Convert Autonumber To RoboHelp List

 

Choose this option if you want to edit the generated HTML topics in RoboHelp or use the RoboHelp styles to control the numbering proper­ties.

 

3.8.7.                
List-mapping scenarios

RoboHelp allows you to convert list properties of FrameMaker paragraph formats in several ways. Consider the following scenarios:

Related links:


Best practices in mapping list styles



FrameMaker numbered list mapped to [Source]

The FrameMaker paragraph format autonumber property converts to a list according the autonumber conversion settings you define for that FrameMaker paragraph format.

Ignore Autonumber

 

The autonumber part of the FrameMaker paragraph format is ignored. The converted paragraph style in the RoboHelp topic doesn't contain the list part.

 

Convert Autonumber To Text

 

The autonumber part of the FrameMaker paragraph converts to text and appears as paragraph text in the RoboHelp topic.

 

Convert Autonumber To HTML List

 

Autonumber format converts to list items using HTML tags such as <ol>, <ul>, and <li>.

 

Converted Autonumber To RoboHelp List

 

Autonumber properties of the paragraph style convert to a RoboHelp list.

 

Example:

•                

Create a paragraph style “FM_Para1” in FrameMaker with autonum­bering defined as <a+> and apply it to paragraphs. The resulting para­graphs are ordered as “a, b, c, ...."

 

•               Map the FrameMaker paragraph format “FM_Para1” to [Source].

 

Generated paragraphs in RoboHelp topics have the list style applied to them, where the list has properties similar to those in the source document.


FrameMaker numbered list mapped to RoboHelp unnumbered style

You can map a FrameMaker paragraph format with autonumbering properties to a RoboHelp paragraph style that is not linked to any list style. In this case, the autonumber is converted to a list according to the autonumber conversion settings you define for the paragraph format.

Ignore Autonumber

 

The FrameMaker paragraph autonumber is ignored and doesn't appear in the RoboHelp topic. However, the paragraph style is mapped.

 

Convert Autonumber To Text

 

The FrameMaker autonumber part is converted to text and appears as a part of paragraph text in RoboHelp topic. The paragraph style is mapped.

 

Convert Autonumber To HTML List

 

The FrameMaker paragraph format is converted to HTML list items using HTML tags such as <ol>, <ul>, and <li>.

 

Convert Autonumber To RoboHelp List

 

The autonumber properties of the FrameMaker paragraph format are ignored. The paragraph style is mapped.

 


FrameMaker unnumbered format mapped to RoboHelp numbered style

In this case, the converted paragraph has the RoboHelp paragraph style and inherits the RoboHelp list style. The Autonumber conversion options do not affect the paragraph behavior in the RoboHelp topic.

For example:

•                

In the FrameMaker document, create a paragraph format "FM_Para 1" without autonumber properties.

 

•               Define a RoboHelp list style “RH_List1” in the RH style mapping CSS.

 

•               Create a paragraph style “RH_Para1” and link the first level of list style “RH_List1” to the paragraph style “RH_Para1”.

 

•               Map the FrameMaker paragraph style “FM_Para1” to RoboHelp para­graph style “RH_Para1”.

 

The generated paragraph in the RoboHelp topic inherits the properties of the list style “RH_List1”.


FrameMaker numbered list mapped to RoboHelp numbered list

The converted paragraph style has the RoboHelp paragraph style and inherits the RoboHelp list style. The Autonumber conversion options do not affect the paragraph behavior in the RoboHelp topic.

For example:

•                

In FrameMaker, create a paragraph format “FM_Para1” with autonum­bering defined as <a+> and apply it to a paragraph so that the paragraph has an ordered list such as “a, b, c, ….”

 

•               Define a numeric list style “RH_List1” in the RoboHelp style mapping CSS with the first level definition as <x>.

 

•               In RoboHelp, define a paragraph style “RH_Para1” and link the first level of list style “RH_List1” to the paragraph style “RH_Para1”.

 

•               Map the FrameMaker paragraph format “FM_Para1” to the RoboHelp paragraph style “RH_Para1”.

 

The generated paragraph in the RoboHelp topic inherits the properties of list style “RH_List1” and displays a list of type “1, 2, 3, ...."

3.8.8.                
Convert FrameMaker table formats to RoboHelp table styles

You can map FrameMaker table formats to RoboHelp table styles. Alternatively, you can import the table formats from the FrameMaker document. You can also edit the table formats in RoboHelp. Cells in the FrameMaker document that are merged (straddled) cannot be unmerged (unstraddled); however, the straddled cells appear merged in the RoboHelp topic.

If the FrameMaker table formats contained table titles and table footnotes, convert these paragraph formats in FrameMaker to RoboHelp paragraph styles separately. Decide whether you want to retain automatic numbering in the table title styles and specify the autonumbering properties for the mapped RoboHelp paragraph style. For example, if the table title formats in the FrameMaker docu­ments included the chapter number, such as “Table 2-3: Quarterly Results”, you can choose to ignore the autonumbering part and have only “Quarterly Results” appear as the table title.

1)           Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           Select the FrameMaker table format from the left pane of the Conversion Settings dialog box.

 

4)           Select the RoboHelp table style from the pop-up menu and click OK. Optionally, to edit the table style in RoboHelp, click Edit Style.

Related links:


List-mapping scenarios


3.8.9.                
Image conversion settings

Some FrameMaker documents, especially those optimized for high-quality printing through PDF, contain images in EPS format. You can let RoboHelp use Adobe Distiller to convert such images to online formats.

You specify the following image conversion settings in the Conversion Settings dialog box:

Use PDF To Generate Images

 

Select this option to generate web-friendly images formats from graphics linked and inserted in FrameMaker documents. You should use this option especially if you have vector graphics formats such as EPS or AI, or graphics with text content in them.

Preserve 3D Images

 

Select this option to convert the 3D graphics as a PDF file, with the 3D rendering intact within the PDF file. To ensure that the 3D image retains its rendering, enable embedding in FrameMaker.

 

Preferred Dimensions

 

Specify the dimensions for the images. Select one of the following:

 

Scale

 

Scale images as a percentage of the existing size. The aspect ratio of the images is maintained.

 

Width and Height

 

Specify the absolute image size as Height and Width, in points. Select Maintain Aspect Ratio to ensure that the images are not skewed.

 


note:  To convert the images in FrameMaker documents to the actual dimensions of the images, specify the height and width as 0 pt. The <img> tag for such images in the generated HTML does not have the height and width values. This conversion is irrespective of the dimen­sions of the anchored frames that contained the images.

 

Maximum Dimensions

 

Set the maximum dimensions for images in online format. Images that exceed the maximum dimensions you specify are automatically scaled down to fit the maximum size you specify. If you scale the images and specify an aspect ratio, RoboHelp scales the images within the maximum dimensions specified and maintains the aspect ratio.

Use this option to avoid large images causing the browser window to scroll horizontally or vertically. For example, if you specify the window size to be 800 x 600 pixels, you can specify the maximum dimensions to be 640 x 480, so that the images do not exceed the window size.

 

Margins

 

Set the margins for the images:

 

•               Set equal margins on all sides by setting the margin in All Sides.

 

•               To set margins on individual sides, set the margins on each side.

 

Borders

 

Set a border for the images:

 

•               To set a uniform border on all sides, select All from the Border pop-up menu. Alternatively, you can specify the side on which you want the border to appear from the pop-up menu.

 

•               To set the border style, select the style from the Style pop-up menu.

 

•               To set the border color, select the color from the Color pop-up menu.

 

•               To set the border width, select it in, in points, from the Width menu.

 

Format

 

Define the image format, color depth, and quality settings for the web-supported images that are converted from the images in the FrameMaker document:

 

As Is

 

Select this option for retaining the images in the current web-supported format.

 

JPG

 

Select this option for multicolor images such as screenshots or photo­graphs. JPG format with a high color depth provides the best online quality, but increases the file size.

 

GIF

 

Select this option if the FrameMaker document contains only line art, such as schematic diagrams.

 

BMP

 

Select this option for screenshots and other images. BMP files provide good quality at an increased file size.

 

PNG

 

Select this option for screenshots and photographs.

 

JPEG Quality

 

Set the quality percentage for JPG images.

Color Bit Depth

 

Set the color bit depth for bitmap images. JPG and PNG formats can have either 8- or 24-bit color depth, while BMP images can be have color bit depths of 1, 4, 8, 16, 24, or 32. GIF images can have only 8-bit color depth.

 

Grayscale

 

Select this option if you want monochrome images.

 

Related links:


Preparing Anchored Frames for Conversion


3.8.10.            
Preserve converted images

RoboHelp converts the images and anchored frames in the FrameMaker docu­ments each time the topics are updated or generated. You can skip updating the images if the corresponding images or SWF files from the corresponding anchored frames are already present in the RoboHelp project. Use this option in the following cases:

•                

You want to avoid regenerating the images each time the FrameMaker document is updated

•               You have edited the images in the RoboHelp project using another image-editing tool, and want to prevent overwriting of the edited images

 

•               You want to preserve the earlier generated image in the RoboHelp project even though the image in the FrameMaker document has changed

 

If the order in which the images appear in the document or the image name has changed, you should clear this option and allow RoboHelp to update the images.

1)            

In the Image tab of the Conversion Settings dialog box, select Do Not Re-Generate Images.

 

3.8.11.            
Create alternative text for images

To create accessible content, create alternative text for images so that visually impaired users can access the content through screen readers. If you link or import completed FrameMaker books into RoboHelp for publication, add alter­native text to graphics used in the FrameMaker documents. These entries are not visible in PDF files, but they appear in online content when the mouse hovers over the images.


3.9.                   
RoboHelp options within FrameMaker

When you use FrameMaker as part of Adobe Technical Communications Suite, you get several options that enable you to streamline online Help publishing with RoboHelp.

3.9.1.                
Pagination with Page Break marker

If you are creating a new document within FrameMaker that you want to published from RoboHelp, you can avoid the traditional ways of having to define custom markers for pagination and topic naming. You can add Page Break markers to denote the topics that should be converted as separate Help topics, and define their topic names.

 note:  
If you define page break markers within FrameMaker documents, Robo­Help silently paginates based on these markers in addition to any other pagina­tion settings that you defined in conversion settings.



Add Page Break marker

1)            

Within FrameMaker, click the heading text, and select Adobe RoboHelp > Apply Page Break Marker.

 

2)           In the Page Break Marker dialog box, enter the topic title. The topic name is automatically populated based on the title text that you enter.

For example, if you enter the topic title as “RoboHelp Conversion Settings”, the topic is named “RoboHelp_Conversion_Settings.htm”.

 


Remove all Page Break markers

1)            

Select Adobe RoboHelp > Remove All Page Break Markers.

 

3.9.2.                
Context-sensitive Help marker

You can add the context-sensitive Help map IDs that you received from your product development team to paragraphs within FrameMaker content. For best results, ensure that you are applying the map IDs to heading styles that you identified for pagination.


Apply a context-sensitive Help marker

1)            

Click on the paragraph text that you want to insert the context-sensitive Help marker.

 

2)           Select Adobe RoboHelp > Apply CSH Marker.

 

3)           Enter the map ID and click OK.

 

3.9.3.                
Apply index markers

1)            

Click on the paragraph text that you want to insert the index marker.

 

2)           Select Adobe RoboHelp > Apply Index Marker.

 

3)           Enter the index entry and click OK.

 

3.9.4.                
Create Dynamic HTML effects

You can create dynamic HTML effects such as drop-down text and expanding text in your FrameMaker documents if you want to have the published online Help formats to have these options.

Use the drop-down text effect to provide alternative task options and basic conceptual topics, summarize the questions on an FAQ, and shorten nested procedures. Text that you mark as drop-down body is displayed in your PDF output. But the text appears online only when the user clicks the drop-down text caption on the Help page.

Similarly, you can use expanding text DHTML effect to display expanded defi­nitions, key terms, or links to overview topics embedded in a paragraph. Expanding text requires an expanding text caption that contains the link and expanding text body that is displayed when a user clicks the expanding text link. Expanding text body is not displayed in PDF. It appears only in the Help page when a user clicks the text that contains the expanding text link.

These DHTML effects require two components: a caption and body. You apply the drop-down text effects to paragraphs and the expanding text effect to char­acters. When the drop-down text effect is created, two paragraph formats, DropDownCaption and DropDownBody, are added to the FrameMaker docu­ment. When the expanding text effect is created, two character formats—ExpandingTextCaption and ExpandingTextBody—are added. These formats are imported to the RoboHelp project when you import the FrameMaker documents. The effects are visible in the created HTML topics.

If the HTML topic generated contains only the captions without the accompa­nying body formats, links are generated and visible in the HTML topic. If the HTML topic generated contains a text body without the corresponding captions, no links are generated. In addition, if a paragraph to which the drop-down text body format is applied is also specified for conversion to an autonumbered list, the list conversion is ignored.


Create drop-down text in a FrameMaker document

1)            

Select the text or paragraph on which you want to place the drop-down text caption.

2)           Select Adobe RoboHelp > Dynamic HTML Effects > Drop Down Caption.

 

3)           Select the text that should appear as drop-down text in your online Help page.

 

4)           Select Adobe RoboHelp > Dynamic HTML Effects > Drop Down Body.

 


Create expanding text in a FrameMaker document

1)            

Select the term or phrase on which you want to place the expanding text caption.

 

2)           Select Adobe RoboHelp > Dynamic HTML Effects > Expanding Text Caption.

 

3)           Select the text that should appear as expanding text in your online Help page.

 

4)           Select Adobe RoboHelp > Dynamic HTML Effects > Expanding Text Body.

 


3.10.             
HTML publishing workflow using Technical Communica­tion Suite and standalone products

Adobe Technical Communications Suite provides technical communicators a streamlined workflow for authoring content once and delivering it in multiple formats. You can author in FrameMaker and import FrameMaker documents into RoboHelp to publish Help in several formats, including Adobe AIR Help and WebHelp.

The suite provides more features than the individual suite applications used as standalone products. The following table lists some differences in the workflow for importing FrameMaker documents when you use the suite and when you use the standalone products.

 



 	
Task in the workflow

 


 	
Technical Communication Suite

 


 	
FrameMaker and RoboHelp as stand-alone applications

 





	
Importing FrameMaker documents into RoboHelp project

 


	
Link to or import the FrameMaker source documents into the RoboHelp project.


	
Import FrameMaker documents.

 





	
Synchronizing FrameMaker source files and RoboHelp topics

 


	
The Project Manager pod in RoboHelp indicates whether the linked documents are out of sync. You can update the linked documents to have the changes reflected in RoboHelp projects. You can choose to preserve the changes in the generated topics.

 


	
Reimport the FrameMaker documents and overwrite the topics generated earlier.

 





	
Updating the topic structure when pagination settings are changed

 


	
Update the FrameMaker document in RoboHelp.


	
Reimport the FrameMaker documents and overwrite the topics generated earlier.






3.10.1.            
Mixed sources of documents

Typically, you use the suite workflow to convert your existing FrameMaker books to online Help format; that is, you link the entire book into RoboHelp. If you have well-shaped FrameMaker documents, you can optimize the workflow with minimal changes to the FrameMaker source or generated topics in Robo­Help. Use this method when your author primarily in FrameMaker and want to use RoboHelp as the publishing tool.

However, sometimes it’s necessary to reuse content from diverse sources in RoboHelp projects. An example is updating a small online Help project by including conceptual information from a reference guide and troubleshooting information from a maintenance guide. Perhaps these documents are authored in different tools and templates, and perhaps they follow different writing guidelines.

Documents can have these sources, among others:

 

•               Documents authored in earlier versions of FrameMaker

•               Documents authored in structured and in unstructured FrameMaker

 

•               Documents authored in FrameMaker and in Microsoft Word

 

3.10.2.            
Project-wide conversion settings

RoboHelp allows you to define project-wide settings for each source type. For all FrameMaker documents, you define the conversion settings only once, whether they are linked to or imported into RoboHelp. Similarly, the conver­sion settings of Microsoft Word documents remain the same for linked as well as imported documents.

Project-wide conversion settings promote consistency not just in your project but across multiple projects. You can quickly set up a RoboHelp project without having to define individual conversion settings for paragraphs, tables, images, and so on.

Project-wide conversion settings work best when you author the entire docu­ment either in FrameMaker or in Word and use RoboHelp as the publishing tool. In this case, you simply optimize the source content for publishing to online Help formats and do little or no content modification in RoboHelp. However, if you have a mixed authoring environment or content from multiple sources, complex scenarios arise. Differences in the following can add complexity:

 

FrameMaker templates

 

RoboHelp allows you to select a template to be applied to the FrameMaker documents that you link or import. Different document types could have different templates with different paragraph and other formats defined.

 

Topic naming patterns

 

This complicating factor arises when you base the topic names on the paragraph text. Depending on how you have written the headings, the RoboHelp topics could have inconsistent names. For FrameMaker docu­ments, you can define topic naming based on custom markers. You can’t define topic naming based on custom markers in Word.

 

Context-sensitive Help marker text

Defining context-sensitive Help in the source documents itself gives you complete control over how the online Help is created. However, defining context sensitivity in the source can introduce significant complexity. If you have multiple types of source documents, you usually have several types of markers that differ in syntax.

 

Related links:


Compare style mapping approaches: FrameMaker and RoboHelp


3.10.3.            
Tips for creating context-sensitive Help

To overcome the challenges, keep the following tips in mind when you plan your project:

 

Determine the workflow

 

If you’re working on a large RoboHelp project created natively, it makes more sense to continue authoring in RoboHelp if the content inputs are minimal. Linking and importing external documents can increase the complexity of the project, especially if you defined TOCs, indexes, glossa­ries, and context-sensitive Help settings in RoboHelp. If, however, you are creating a project from scratch or significantly revising an existing project, link to and import external documents to avoid updating content manu­ally in RoboHelp.

 

Identify the source documents

 

Before you define the project settings in RoboHelp, identify the sources of content that you intend to use in your project. If all your source docu­ments are well-shaped FrameMaker documents, link the documents. If your source documents are of several types, import the documents.

 

Explore your linking and importing options

 

Even though you can choose to convert the TOC, index, and glossary from the source documents, explore your options carefully. For example, importing a TOC works best when you want to retain the TOC structure in your source documents. Similarly, if you are importing a set of FrameMaker and Word documents in different versions, consider care­fully before using context-sensitive Help markers or index markers. Their use is advantageous only if you are making significant revisions. If the update is minimal, sometimes the best option is to import the content and add the map IDs or index entries natively in RoboHelp.


Scenarios for creating a project



 	
Source documents

 


 	
Method to use

 


 	
Options available

 





	
Single unstructured or Structured FrameMaker book


	
Link FrameMaker book

 


	
Use RoboHelp as the publishing tool, with little or no content authoring in RoboHelp

•                

Define pagination based on either FrameMaker paragraph formats or custom markers

 

•               Create context-sensitive Help using custom markers in FrameMaker

 

•               Convert TOC, index, and glos­sary

 





	
Multiple unstructured or Structured FrameMaker books

 


	
Link FrameMaker books

 


	
Use RoboHelp as the publishing tool, with little or no content authoring in RoboHelp

•                

Define pagination based on either FrameMaker paragraph formats or custom markers

 

•               Create context-sensitive Help using custom markers in FrameMaker

 

•               Convert TOC, index, and glos­sary

 





	
Single or multiple FrameMaker books in versions earlier than 7

 


	
Import FrameMaker books

 


	
•               Define pagination based on either FrameMaker paragraph formats or custom markers

 

•               Create context-sensitive Help using custom markers in FrameMaker

 

•               Convert TOC, index, and glos­sary

 





	
Independent FrameMaker documents

 


	
Import FrameMaker documents

 


	
•               Define pagination based on either FrameMaker paragraph formats or custom markers

 

•               Convert TOC, index, and glos­sary

 





	
Single Word document with a well-shaped TOC and index

 


	
Link Word document

 


	
•               Define pagination based on Word paragraph styles

•               Define context-sensitive Help marker using the custom footnote option in Word and use the marker text for context-sensitive Help

 

•               Convert TOC, index, and glos­sary

 

•               Use RoboHelp as the publishing tool, with little or no content authoring in RoboHelp

 





	
Multiple Word documents

 


	
Import the documents

 


	
•               Define pagination based on Word paragraph styles

•               Define context-sensitive Help marker using the custom footnote option in Word and use the marker text for context-sensitive Help

 





	
Mix of FrameMaker books and Word documents

 


	
Link FrameMaker and Word documents

 


	
•               Define pagination based on FrameMaker and Word paragraph styles, separately

 

•               Use context-sensitive Help marker in source documents

 





	
Mix of independent FrameMaker and Word documents

 


	
Import the documents

 


	
•               Define pagination based on FrameMaker and Word paragraph styles, separately

 

•               Use context-sensitive Help marker in source documents

 







Scenarios for updating a RoboHelp project



 	
 

Source documents

 


 	
Method to use

 


 	
Options available

 





	
Single unstructured or Structured FrameMaker book


	
Link FrameMaker book

 


	
•               Define pagination based on either FrameMaker paragraph formats or custom markers

 

•               Create context-sensitive Help using custom markers in FrameMaker

 





	
Multiple unstructured or Structured FrameMaker books

 


	
Link FrameMaker books

 


	
•               Define pagination based on either FrameMaker paragraph formats or custom markers

 





	
Multiple FrameMaker books or independent FrameMaker documents

 


	
Import FrameMaker books and documents

 


	
•               Define pagination based on either FrameMaker paragraph formats or custom markers

 





	
Single Word document with a well-shaped TOC and index

 


	
Link Word document

 


	
•               Define pagination based on Word paragraph styles





	
Multiple Word documents

 


	
Import the documents

 


	
•               Define pagination based on Word paragraph styles





	
Mix of independent FrameMaker and Word documents

 


	
Import the documents

 


	
•               Define pagination based on FrameMaker and Word paragraph styles, separately

 






Related links:


Trade-offs between linking and importing



3.11.             
Publishing the current document


note:  This feature is available only if FrameMaker is part of the Adobe Technical Communications Suite.

You can quickly publish the current document, book, DITA file, or DITAMAP using the Publish option in FrameMaker. You can select from a set of several online output formats, and then specify the publishing options that you defined for the FrameMaker- RoboHelp workflow.

If you want to quickly publish the entire book or DITAMAP from FrameMaker, ensure that you have defined the publishing workflows such as the FrameMaker to RoboHelp style mapping, pagination, and other conversion settings. In a production environment, create separate RoboHelp projects and Import Settings Files (ISF) for each output format.

Optionally, you can also specify the DITAVAL file to create output based on conditions specified in the DITAVAL file.

1)           Select File > Publish.

 

2)           In the Publish Settings dialog box, select the output format.

 

3)           Select the folder where the published output will be saved. By default, FrameMaker chooses the same location as the source file.

 

4)           Specify the RoboHelp settings that will be used for the conversion and click Publish.note:  
Even though these settings are not mandatory, to get optimum output, you should specify the relevant settings. FrameMaker does not alert you to specify these settings when you initiate the Publish action. 

RoboHelp Project

 

Specify the RoboHelp Project file (XPJ) that you have created.

ISF File

 

Specify the Import Settings File (ISF) that contains the required conver­sion settings.

 

Master Page

 

Specify the RoboHelp master page (HTT) that will be used for the Help pages.

 


3.12.             
Using custom markers in FrameMaker to create context-sensitive Help in RoboHelp

Used together, FrameMaker and RoboHelp provide features for end-to-end authoring and publication workflow. If your authoring and publishing environ­ment involves these two products, you have multiple options of incorporating their strengths into your workflow.

Optimize FrameMaker content to create context-sensitive Help in RoboHelp by using custom markers in FrameMaker. FrameMaker provides multiple ways to use markers in your documents. Predefined FrameMaker markers, such as index and conditional text, can simplify the creation of RoboHelp Help. You can also create custom marker types and use them for pre- and post-processing of your FrameMaker documents.

Related links:


Markers


3.12.1.            
Defining topic pagination, title, and filename

Typically, you define the conversion settings in RoboHelp to create Help topics based on FrameMaker paragraph formats. These conversion settings are project-wide: the same settings are applied to all linked and imported FrameMaker documents.

 

For example, you can choose to create separate Help topics for each occurrence of H1 or H2 heading formats. In addition, you can base the topic filenames on the topic title. This approach is ideal for large, well-structured FrameMaker books that have been optimized for online publication with minimal customi­zation efforts in conversion.

Related links:


Pagination, topic naming, and context-sensitive Help


3.12.2.            
Setting the pagination in RoboHelp

RoboHelp usually bases the pagination of documents linked to or imported from FrameMaker on FrameMaker paragraph formats. However, to control how content in FrameMaker documents is converted to Help topics, you can base the pagination on the topic name markers in FrameMaker documents.


Base pagination on custom markers

 

1)           Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker document.

3)           In the Other Settings tab, select Topic Name Marker, and enter the custom marker type you defined in FrameMaker.


Convert context-sensitive Help markers from FrameMaker documents

You can convert the context-sensitive Help markers that you insert in your FrameMaker documents and reuse them as map IDs. You specify the context-sensitive Help marker in the Project Settings dialog box before linking FrameMaker documents. You can also specify this setting when you import FrameMaker documents. You can work with context-sensitive Help markers in FrameMaker documents in two ways:

Automatic conversion of map IDs from FrameMaker documents

 

You apply context-sensitive Help markers in your FrameMaker docu­ments and specify the marker type in the conversion settings. RoboHelp imports the markers from FrameMaker documents and adds the map IDs from the context-sensitive Help markers.

 

Manually adding a map ID file

 

If you received map IDs from your development team, use these map IDs as the context-sensitive Help marker text strings for the marker to be used as context-sensitive Help marker in your FrameMaker documents. Later, you create a map ID file by associating the map IDs from the development team and the context-sensitive Help marker text you inserted in the FrameMaker documents. You then add this file to the project. When you link to or import the FrameMaker documents, you specify the context-sensitive Help marker in the conversion settings.

 

1)           Select File > Project Settings.

 

2)           In the Import tab of the Project Settings dialog box, click Edit under FrameMaker Document.

 

3)           In the Other Settings group of the Conversion Settings dialog box, enter the Context-Sensitive Help Marker type.

 

Related links:


Map files and map IDs



3.13.             
Comparison of master pages in FrameMaker and Robo­Help

 

When you are authoring in FrameMaker, you use the page layout and format­ting supplied by master pages in your template to create consistent page layout and flow. Similarly, RoboHelp enables you to define master pages that you can apply to your topics to get uniform appearance and define the navigation features. (In versions earlier than RoboHelp 8, master pages were called topic templates).

The following table lists the parameters that you define in FrameMaker master pages and their corresponding features in RoboHelp.



 	
FrameMaker feature

 


 	
Function

 


 	
Corresponding RoboHelp feature

 


 	
Function

 





	
Page layout

 


	
Determines the page size

 


	
Not applicable for page size, but you can define the layout of HTML pages using tables and placeholders.

 


	
You define the topic layout in the Window settings in RoboHelp. This setting defines the components of the topic layout such as index, TOC, and search box.

 





	
Page orientation

 


	
Determines the page orientation as portrait or landscape.

 


	
Not applicable

 


	
Online Help format doesn't support page orientation.

 





	
Number of sides

 


	
Determines if the document should have facing pages.

 


	
Not applicable

 


	
Online Help format doesn't support facing pages.

 





	
Dynamic text in header and footer

 


	
Document navigation aids such as cross-reference to book title or chapter, usually implemented using variables or cross-references to heading styles.

 


	
Placeholders for breadcrumbs and Mini-TOCs.

 


	
Breadcrumbs provide powerful navigation aids in online format. Mini-TOCs give a quick overview of the topic structure.

 





	
Static text in header and footer

 


	
Static text such as copyright notice, company name, and date of modification of the page.

 


	
Header and footer

 


	
You can specify the header and footer text that should appear in all topics.

 





	
Page numbering


	
Defines the page number format.

 


	
Not applicable

 


	
Online Help format doesn't support page numbers.

 






If you intend to link or import Microsoft Word documents into your project apart from topics natively created in RoboHelp, don’t convert the header and footer text in the Word documents. When you link or import FrameMaker documents, you can apply a FrameMaker template to the documents before­hand. However, master pages are ignored during conversion.

Sometimes headers and footers in documents being linked or imported contain critical information that must be present in the Help topics. In this case, add the information to the master pages that you create in RoboHelp. For example, if a confidentiality clause must be present in all topics, include it in all master pages.

3.13.1.            
Working with master pages in RoboHelp

A Help topic in RoboHelp has three components: content, layout, and styling. For single sourcing, the best practice is to separate content from styling and layout. Although CSS files help to separate styling from the content, layout remains embedded in the HTML code. By using master pages, you can separate layout and styling from the content. In addition, you can associate a CSS with each master page. RoboHelp master pages are separate files that are included in the project, and have an HTT extension. By default, RoboHelp does not apply any master page to the topics that you create. The style and formatting are applied according to the default style sheet. One easy way to ensure consistent layout and navigation of Help pages created across projects is to import the master pages into your project from a repository. Then use them consistently in your project.

3.13.2.            
Placeholders in master pages

Master pages act as templates for Help topics and include a style sheet (CSS). You define the placement of headers, footers, and placeholders for the body, breadcrumbs, and mini-TOC. In addition, master pages can include snippets and user-defined variables, allowing you to reuse content among topics more effectively. RoboHelp allows you define the placeholders for body, bread­crumbs, and mini-TOC.

 


Body placeholder

A topic created from a master page includes content from the master page, such as copyright information. You can remove the placeholder text and enter your content in the page. However, when you apply a master page to an existing topic, the content of the topic replaces the body placeholder at the time of preview and generation. If you inserted a header and footer manually, they are overwritten by the header and footer in the master pages.


Breadcrumbs placeholder

The breadcrumbs placeholder shows the breadcrumbs that are generated auto­matically when Help is built. RoboHelp allows you to define breadcrumbs that indicate the hierarchical level of the current topic, based on the TOC. Links in the breadcrumb trail connect to the adjacent level in the hierarchy. The reader uses breadcrumbs to quickly navigate to the parent topic, chapter, or to the home page. The home page often contains links to additional Help topics and support pages.

You can add breadcrumb placeholders in your master pages above or below the body placeholder, or both above and below. Place breadcrumbs both above and below the body placeholder in long topics through which readers must scroll vertically. You can apply conditional build tags to the mini-TOC and bread­crumbs placeholders but not to the body placeholder. However, you can apply a conditional build tag to the content inside or outside the body placeholder.


Mini-TOC placeholder

Mini-TOCs provide a useful navigation aid for long articles with many subsec­tions. With RoboHelp, you automatically generate Mini-TOCs in topics that contain subsections, child topics, and bookmarks. Mini-TOCs serve the purpose of chapter or section TOCs that you created manually in FrameMaker. Use Mini-TOCs to give a quick summary of and links to the contents of the topic.

You can show or hide the mini-TOC on the generated topic. When used with the drop-down text effect, Mini-TOCs provide an effective means of creating easily navigable Help pages such as FAQs. Even though you can insert a mini-TOC placeholder in your topic, the best practice is to place it in the master pages. Inserting a mini-TOC placeholder allows you to update a large RoboHelp project to the new layout in one step. Similarly, you can change the master page that you apply to the topics at any time, either before or during output genera­tion.

3.13.3.            
Best practices for mini-TOCs

Consider the following when you create and apply master pages with mini-TOCs in your RoboHelp project:

Need for mini-TOC

 

Many topics contain only one coherent piece of information that does not require structuring through subheadings or bookmarks within the topic. For such topics, a mini-TOC is not be required. You can create a separate master page without the mini-TOC placeholder and apply it to such topics to suppress the mini-TOC.

 

Topic length

 

If your topic is a long article with many subsections, the mini-TOC can be long and overly nested. In such cases, try to restructure and divide the content into multiple topics. For example, if you use lower heading levels such as Heading 5 and Heading 6 to highlight definition lists, try to orga­nize them under a higher-level heading, and apply paragraph styles other than heading styles.

 

Number of levels

 

RoboHelp includes heading levels 2 through 6 in the mini-TOC by default. However, if the topics have many lower-level headings, the mini-TOCs can become long and deeply nested. To avoid this, limit the number of levels in the mini-TOC to give a quick overview of your topic contents.

 

Placement

 

Place a mini-TOC placeholder in a master page if your project is large or you are updating an existing project. Inserting a mini-TOC placeholder in each topic can be time-consuming; applying a master page with a mini-TOC placeholder is easy.

 

3.13.4.            
Creating and applying master pages

You can create and maintain multiple master pages in a project, and can import them from other projects. To ensure consistent appearance, best practice is to import master pages from a controlled repository. Within your project, you can also create a master page from an existing topic, edit its properties, and apply master pages to one, some, or all the topics. RoboHelp also allows you to over­ride the master page or CSS settings for the entire project for each single-source layout. For different output results, you can apply different master pages or a different CSS. Each single-source layout except the Printed Documentation layout provides an option to apply master pages or CSS. You can choose to apply a master page or a CSS across all the topics in a project.

Related links:


Master pages





4.                        
Review and collaboration

Technical Communication Suite includes Acrobat that lets you collaborate on documents. Using Acrobat you can share PDF files, set up and manage reviews, and collaborate on PDF documents. FrameMaker, RoboHelp, and Adobe Captivate also let you initiate reviews, so that you can send content for review without exiting the authoring application.


4.1.                   
Reviews

Your reviewers do not require Acrobat to participate in reviews. Create a PDF and use Acrobat to set up a review. Reviewers can add annotations on the review PDF. Reviewers can use the free Adobe Reader to post annotations on a PDF.

 Review types 



 	
 


 	
Invite reviewers

 


 	
Annotation Tools

 


 	
Track reviews

 


 	
Collect Comments

 


 	
Concurrent view of comments

 





	
Simple PDF

 


	
Manual

 


	
•               Adobe Reader: Sticky Note & Highlight

 

•               Acrobat: All commenting tools

 


	
No

 


	
Manual

 


	
No

 





	
Reader Extended PDF

 


	
Manual

 


	
All commenting tools

 


	
No

 


	
Manual

 


	
No

 





	
E-mail Review

 


	
Automatic e-mail

 


	
All commenting tools

 


	
Yes

 


	
Automatic

 


	
No

 





	
Shared Review using Acrobat.com

 


	
Automatic e-mail

 

 


	
All commenting tools

 


	
Yes

 


	
Automatic

 


	
Yes

 





	
Shared review using internal server (WebDAV, Sharepoint, or shared folder)

 


	
Automatic e-mail

 


	
All commenting tools

 

Reviewers need read/write access to shared location

 


	
Yes

 


	
Automatic

 


	
Yes

 






Related links:


Preparing for a PDF review



Starting a review



Participating in a PDF review



Tracking and managing PDF reviews



4.2.                   
Send documents for review

You can send content for review from within the authoring environments provided by Technical Communication Suite. RoboHelp, FrameMaker, and Adobe Captivate all provide integrated review functionality so that you can set up and send content for review without having to leave the applications.

 

FrameMaker

 

Choose File > Save As Review PDF.

 

RoboHelp

 

Choose Review > Create PDF for Review.

 

Adobe Captivate

 

Choose File > Collaborate > Send for Shared Review.

 


4.3.                   
Incorporating review comments

Using Technical Communication Suite, you can set up a review from within the authoring environments. FrameMaker and RoboHelp provide built-in mecha­nisms to track changes and edits. You can also import the comments made on a review PDF and import them into source files. To import comments from the review PDF:

FrameMaker

 

Choose File > Import > PDF Comments.

 

RoboHelp

 

Choose Review > Import Comments from PDF.

 

Related links:


PDF review



Import PDF comments



4.4.                   
Collaboration

Use Collaborate Live to review a PDF with one or more remote users in an online session. In a Collaborate Live session, the participants view a document with a live chat window. When a participant shares a document, the page number and magnification are also shared, so that everyone sees the same part of a document.

To start a Collaborate Live session, you must have Acrobat X installed. Partici­pants in a Collaborate Live session must have Acrobat X or Adobe Reader®® X.

Related links:


Initiate a Collaborate Live session



Participate in a Collaborate Live session





5.                        
Working with ExtendScript

In Adobe Technical Communication Suite, you can use scripts to automate many of the features and thus save so much of time and effort. A script is a set of commands that instructs an application to do a specific task that you perform manually. These tasks can be simple and affect only one object. For example, setting the table properties in a FrameMaker body page. These tasks can also be complex and affect many objects in different applications. For example, setting the dpi properties of images to a predefined value in FrameMaker, import the images to Photoshop, and do some editing.

In short, scripts automate repetitive tasks and streamline tasks that can be too time consuming to do manually. Adobe Technical Communication Suite provides ExtendScript ToolKit to develop and debug scripts in many of the applications in the suite.


5.1.                   
ExtendScript toolkit

ExtendScript is based on JavaScript. Use ExtendScript ToolKit (ESTK) to develop and debug ExtendScript. ESTK provides the following features that make scripting easy:

 

•               A built-in syntax checker that verifies whether the syntax is correct and provides possible suggestions

 

•               Support for Object Model Viewer that provides the information on different classes and methods

 

•               Ability to run the script without saving the file

 

Adobe Technical Communication Suite provides ESTK support for the following components:

•                

FrameMaker 11

 

•               Media Encoder

 

•               Bridge CS6

 

•               PhotoShop CS6

 

•               RoboHelp 10

 

5.1.1.                
Accessing ESTK

Do the following to access ESTK:

1)            

Click Start > All Programs > Adobe Technical Communication Suite 4> Adobe Extended Toolkit CS 6.

 

2)           In the ESTK window’s top-left drop down-list, select the application for which you prepare the script.

 

3)           Prepare the script using the editor.

 

4)           Run the script using the Play button displayed at the top-right corner.

ESTK Window


[image: es_estk_window.png]



note:  You can also access ESTK from a supported Technical Communication Suite component. Refer to the User's Guide of the component for more details.


Using object model viewer

Object Model Viewer in ESTK helps you to get the information on different classes and the methods in ExtendScript. Press F5 or click Help > Object Model Viewer to open Object Model Viewer.

Under Browser, select the object model for which you want the information. It displays all the classes in the selected object model and the details such as type, properties and method, and a short description of the class. It also provides a search functionality. You can search for a class or a method for which you want the information.

Object Model Viewer


[image: es_objectmodelviewer.png]



5.2.                   
Preparing scripts

ExtendScript is similar to JavaScript. You can easily develop ExtendScript for any of the applications in Adobe Technical Communication Suite if you are familiar with JavaScript.

The following sections provide examples for scripts that automates a specific activity in FrameMaker 10 and RoboHelp 9.

5.2.1.                
Adding text to a FrameMaker document and enabling change bar

The following script adds a sample text to a FrameMaker document and then enables the change bar. Open a FrameMaker document before running the script.

Copy and paste the script to ESTK and select FrameMaker 11 as the target appli­cation. Click the Play button to run the script.

 

var doc = app.ActiveDoc

var tl = new TextLoc()

var firstPgf = doc.MainFlowInDoc.FirstTextFrameInFlow.FirstPgf

tl.obj = firstPgf

doc.AddText (tl, "Hello")

doc.AutoChangeBars =1;

 

The script creates a text location using the new TextLoc()method. Assign the first page of the document as the text location. Using the AddText() method, add a sample text. Set the AutoChangeBars property to 1 to enable the change bar.

5.2.2.                
Changing the table properties in a FrameMaker document

The following script changes the left indentation of all the tables in a FrameMaker body page by 1 inch. It also changes the width of the columns to 2 inches. Open a FrameMaker document that has tables with two columns before running the script.

var doc =app.ActiveDoc

var flow = doc.MainFlowInDoc

var tbl = 0;

var textItems = flow.GetText(FTI_TblAnchor)

for (var i = 0; i < textItems.len; i += 1)

{

   tbl = textItems[i].obj;

tbl.TblLeftIndent = (2*72 * 65536);

var tblColWidths = new Metrics (2 * 72 * 65536, 2 * 72 * 65536);

tbl.TblColWidths = tblColWidths;

}

The script creates the document’s main flow using the MainFlowInDoc method. Use the GetText(FTI_TblAnchor) method to list all tables in the main flow. Using a for loop, for each table, use the TblLeftIndent()method to change the left indentation.

Use the TblColWidths() method to change the width of the column. This method accepts the argument in a metric form. So, create the arguments as a metric object using the new Metrics()method.


note:  By convention, there are 72 points per inch. Multiply the inch value with 65536 to get the correct value. 1 inch is equal to 1 * 72 * 65536 points.

5.2.3.                
Importing a FrameMaker document to a RoboHelp project

The following script, while executing, imports a FrameMaker document to a RoboHelp project. Open a FrameMaker document before executing the script. The script automatically launches RoboHelp.

doc=app.ActiveDoc

var path=doc.Name;

createScript(path)

function  createScript(path)

{    

script="doc.importFrameMakerDoc (\""+path+"\",\"\",\"\", \"\", false, \"\", \"\");";

sendRoboHelp(script);

}

function sendRoboHelp(script)

{   
    

var bt = new BridgeTalk();

bt.target = "RoboHelp";

bt.body = script;

bt.send();

}

Using the doc variable, create a reference to the active FrameMaker window. Use the Doc.Name property to get the path of the active FrameMaker window. Call the user-defined createScrip() function by passing the path variable. In the function, create the following string: script="doc.importFrameMakerDoc (\""+path+"\",\"\",\"\", \"\", false, \"\", \"\");"; 


doc.importFrameMakerDoc is a RoboHelp function that takes the following parameters to import a FrameMaker document to RoboHelp:

•               File path

 

•               Folder name

 

•               FrameMaker TOC file path

 

•               TOC name

 

•               Add index to topics

 

•               Index name

 

•               Glossary name

 

The example uses default settings to import the document to RoboHelp. Provide document’s path. Provide false for the Add Index to Topics param­eter. As a general JavaScript rule, the quotes in a string are provided inside the escape character “\”. The user-defined sendRoboHelp() function invokes RoboHelp. Create a new BridgeTalk object which is used to connect to a different application in Technical Communication Suite. Using the target property, provide the name of the application on which you want to run the script. Use the body property to provide the script that you want to run. The send()method sends the script to the target application and executes the script.

5.2.4.                
Changing the effect of an image using Photoshop

The following script applies an effect to a Photoshop image. Open an image in Photoshop before running the script.

preferences.rulerUnits = Units.PIXELS

docRef = app.activeDocument

docRef.activeLayer.applyPinch(80)

docRef.save()

The script sets the ruler units in pixels. Then, selects the active Photoshop image. It applies the Photoshop effect, applyPinch, in the active layer of the image. After applying the effect, it saves the file.




6.                        
Using External Resources

 


6.1.                   
Style and linguistic checks using SDL AuthorAssistant 2010 SP1

SDL AuthorAssistant is a quality assurance tool developed by SDL. It improves consistency and translatability of your technical content. The following FAQ introduces and familiarizes SDL AuthorAssistant in the context of TCS and FrameMaker.

Adobe recommends you to also go through the SDL documentation before you start using SDL AuthorAssistant. SDL provides elaborate documentation on how to install, configure, and use SDL AuthorAssistant (see the FAQ on addi­tional information for details).

6.1.1.                
FAQ about SDL AuthorAssistant 2010 SP1 for FrameMaker 10 and TCS 3.0

 


What is SDL AuthorAssistant?

A quality assurance tool for documentation that is freely available for all FrameMaker 10 and TCS 3.0 users.

SDL AuthorAssistant is a plug-in for FrameMaker that checks documents for corporate writing styles and standards, standard spelling, and grammar.


My editor reviews all the content. So how does SDL AuthorAssistant matter?

SDL AuthorAssistant helps you automate most of your style guide rule checks and linguistic checks. It reduces many of the manual editorial tasks.

With a constant increase in the number of things an editor has to remember, it is tough to do an air-tight editorial in shorter timelines. Especially, if you have a huge number of style checks and multiple word lists: some company-specific, some product suite-specific, and some specific to the product.

SDL AuthorAssistant reduces the number of misses. It provides consistency across documentation sets, across cross-geographical writer teams, and when you have multiple writers working on the same book or document.


What tasks can SDL AuthorAssistant perform?

 

•               Verify grammatical usage, use of passive voice, or future tense.

 

•               Standardize frequently used acronyms.

 

•               Check wordiness, lengthy sentences, deprecated terms, misused words, and other style issues.

 

•               Check against previously translated content, so that you can improve content reuse and reduce the downstream costs of localizing content.

 


Where can I get the SDL AuthorAssistant plug-in?

 

Download the plug-in from the following location: 
www.adobe.com/go/FM_AuthorAssistant/
 


Which are the languages supported by SDL AuthorAssistant?

SDL AuthorAssistant includes specific checks that apply for documents authored in any of the following languages:

 

•               English

 

•               German

 

•               French

 

Other European languages are also supported, but with a reduced set of avail­able checks. Asian languages and right-to-left languages are not supported.


Where can I get additional information about SDL AuthorAssistant?

 

•               The details of system requirements, installation instructions, and licensing agreement are available at the following location:

 



www.adobe.com/go/FM_AuthorAssistant/
 

•               To get started with SDL AuthorAssistant, watch the movie tutorial SDL AuthorAssistant Tutorial (Start > All Programs > SDL > SDL AuthorAs­sistant 2010).

 

•               For detailed installation procedures, see SDL AuthorAssistant 2010 Instal­lation Guide (Start > All Programs > SDL > SDL AuthorAssistant 2010).

 

•               For configuring SDL AuthorAssistant, use the Online Help in the SDL AuthorAssistant Configuration dialog box (SDL AuthorAssistant > Configure).

 


Need I connect to a server to do the checks?

SDL AuthorAssistant is a client software application. It performs checks based on the rules you specify in the SDL AuthorAssistant Configuration dialog box (SDL AuthorAssistant > Configure). You can reuse the same configuration later by saving the rules as a profile (.pfl file) on your computer. You can also import and use a profile created elsewhere.

So, if you have configured SDL AuthorAssistant or use a profile stored locally (either by creating or importing), you can check your documents without connecting to a server.

However, if you prefer to create and manage profiles centrally, you need an authoring management system for the server from SDL. For details, contact SDL.


Can I use SDL AuthorAssistant for any other versions of FrameMaker?

Yes, the plug-in supports the following releases in addition to FrameMaker 10:

 

•               FrameMaker 8 (needs activation)

 

•               FrameMaker 9

 


I use an older version of SDL AuthorAssistant. Can I upgrade?

Yes, the upgrade and compatibility information is available in the SDL Autho­rAssistant 2010 SP1 Installation Guide and the release notes.


I use SDL AuthorAssistant for FrameMaker 9. If I upgrade to FrameMaker 10, can I use the same installation of SDL AuthorAssistant?

For FrameMaker 10, you require SDL AuthorAssistant 2010 SP1 version. Even if you have an earlier version of SDL AuthorAssistant (working with FrameMaker 9), you must download and upgrade to SDL AuthorAssistant 2010 SP1.

On the same machine, if you have both FrameMaker 9 and FrameMaker 10, you can use the same installation of SDL AuthorAssistant 2010 SP1 for both.

1)           Install SDL AuthorAssistant 2010 SP1 for either FrameMaker 9 or FrameMaker 10.

 

2)           In the maker.ini file of the FrameMaker version for which you installed SDL AuthorAssistant (in step 1), copy the entry related to SDL AuthorAs­sistant in the [APIClients] section.

 

3)           In the maker.ini file of the FrameMaker version for which you want to extend the SDL AuthorAssistant service, paste the content in the [APIClients] section.

 

For example, if you have installed SDL AuthorAssistant 2010 SP1 for FrameMaker 10, copy the following data from maker.ini in C:\Program Files\Adobe\FrameMaker10 to maker.ini in C:\Program Files\Adobe\FrameMaker9:

 

SDLAuthorAssistant=Standard, SDLAuthorAssistant, C:\Program Files\SDL\SDL AuthorAssistant 2010\S42AA_Adobe.dll, all

 


note:  
File locations on your system can vary. 


How do I verify if SDL AuthorAssistant is installed?

On successful installation of SDL AuthorAssistant,

•               The option SDL AuthorAssistant appears in the FrameMaker menu.

This option appears only when you are in the Document view and not Resource Manager view (book window).

 

•               An icon


[image: io_sdl_icon.png]


 appears in the Windows system tray.


What is the general workflow of SDL AuthorAssistant?

 


[image: io_sdl_workflow.png]


 

 


How do I configure SDL AuthorAssistant?

 

1)           After installing SDL AuthorAssistant, open FrameMaker in Document view.

2)           Select SDL AuthorAssistant > Configure.

 

3)           Use the SDL AuthorAssistant Configuration dialog box (that appears) to configure.

 

•               
General configuration: Use the General tab to import or export a profile that contains rules for checks. Also, specify the result format and markup.

 


note:  
SDL AuthorAssistant includes a profile Global AMS Style Rules.pfl (the default location is C:\Program Files\SDL\SDL AuthorAssistant 2010), which contains a starter set of rules. 

•               
Configuring style and linguistic checks: Use the Style and Linguistic Checks tab to configure grammar and linguistic checks, create style rules, and add them to the profile.

 

The following table details the configuration that you can either ignore or are conditional:



 	
 

Configuration

 


 	
Tab

 


 	
Condition

 





	
Specify if XML elements have to be checked or ignored

 


	
Structure

 


	
Does not apply because,

 

•               For XML files, FrameMaker defines the structure.

 

•               For non-XML files, the configu­ration is of no use.

 





	
Check documents against translation memories

 


	
Translation Memory

 


	
Does not apply unless you have a Translation Memory available. For details, see SDL documentation.

 





	
Check documents against termbases

 


	
Terminology

 


	
Does not apply unless you have a Term Database available. For details, see SDL documentation.

 







How do I ensure that all authors in my team use the same configuration?

After you configure SDL AuthorAssistant, export the settings into a profile and distribute it across your department, for a consistent setup.

In the General tab of SDL AuthorAssistant Configuration dialog box (SDL AuthorAssistant > Configure),

•                

Click Export to export all the settings into a .pfl file.

 

•               Click Import and specify the .pfl file that contains the settings to configure a new desktop with your rule check settings.

 


How do I check documents?

The following are the checking options:

 

•               
Check an active document or a selection: Click SDL AuthorAssistant > Check Text - Active Document. To check only a section of the document, select the section of text before you check.

 

•               
Check multiple documents or book: Click SDL AuthorAssistant > Check Text - Multiple Documents and then select the appropriate option in the Multiple Document wizard. The documents that you select are automati­cally checked in sequence. Closed documents are automatically opened for checking.

 

•               
Check documents from report: Click SDL AuthorAssistant > Check Text - From Report.

In this case, first run the report on the documents and then run checks from the report results. When you check from reports, instead of checking the entire document, SDL AuthorAssistant limits the checks to issues contained in the report. This option is effective when you have large docu­ments to check.

When you check documents, the suggestions are displayed in a separate dock­able window, SDL AuthorAssistant Results. It displays the source sentence with the issues highlighted in red color in an editable text box. The bottom half of the window explains the error and provides alternatives.

You can:

 

•               Accept suggested alternatives if any

 

•               Type a correction and click Apply to change the sentence in the document

 

•               Revert any changes

 

•               Recheck the changes you make before applying them

 

•               Move to the next error, ignoring the issue (click Next).

 

After correcting a sentence, click Apply/Next to apply the change and move on to the next error in the document.


How do the reports work?

The options SDL AuthorAssistant > Reporting - Active Document and SDL AuthorAssistant > Reporting - Multiple Documents let you obtain check reports. You can select a mix of .fm and .xml files or .book file for the reports.

SDL AuthorAssistant generates the report in HTML and opens it in the default browser.

The report generated by SDL AuthorAssistant has the following details:

 

•               Metadata for the report, such as the time it was generated, number of files checked, and the author name.

 

•               A cumulative summary of total errors categorized by the error type in the selected files.

 

•               Filenames in case you have generated the report for multiple files. You can click each link to see the list of errors categorized by the error type. Each error category also shows the exact error and the instances of each in the document.

 

•               The concluding section of the report summarizes the settings that were enabled and disabled when the report was run, details of translation memories, and termbases used.

 

Apart from providing information, reports provide a convenient option to perform checks. For details, see Check documents from report in How do I check documents? 

You can also import the results of a report into a spreadsheet for further anal­ysis. SDL provides a sample report (Start > All Programs > SDL > SDL Autho­rAssistant 2010 > SDL Global AMS Report Analysis).

Open the report and select Load before data... to import the CSV file created when you ran the report. You can then select Load after data... to import report data created after you have made corrections using the Check Text option, so that you can see the impact of the changes that you have made.


6.2.                   
Manage and add assets using Adobe Bridge

Adobe Bridge lets you organize, browse, and locate assets that you use to create content. Adobe Bridge keeps native Adobe files (such as PSD, AI, and PDF) as well as non -Adobe files for easy access.

Adobe Bridge workspace


[image: br_workarea_io.png]


A.

Application bar

B.

Panels

C.

Selected item

D.

Thumbnail slider

E.

View buttons

F.

Search

 

Using Adobe Bridge you can view, search, sort, filter, and manage images. Adobe Bridge also lets you rename, move, and delete files; edit metadata; rotate images; and run batch commands. You can also view files and data imported from your digital still and video camera.

To add an asset into your FrameMaker, RoboHelp, or Captivate file:

1)            

Browse to the asset in Bridge.

 

2)           Click on the asset to select it.

 

3)           Drag it to the document to add it.

 

Related links:


Adobe Bridge online help



6.3.                   
Convert and encode media assets using Media Encoder

Recording video and audio to a digital format involves balancing quality with file size and bitrate. Most formats also use compression to reduce file size. Adobe Media Encoder makes it easy for you to encode media assets, or convert assets from one format to another. Support for queue and watched folders gives you the flexibility to automatically convert media assets.

Adobe Media Encoder


[image: ua_mainWindow_io.png]


A.

Encoding queue

B.

Progress bar

C.

Queue controls

D

Preview

For more information, see 
Adobe Media Encoder online help
.
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OEBPS/ehlpdhtm.js
// Dynamic HTML JavaScript 

// Copyright © 1998-2012 Adobe Systems Incorporated. All rights reserved.

// Version=9.0



// Warning:Do not modify this file. It is generated by Adobe RoboHelp® and changes will be overwritten.



//// Segment Begin -- (JavaScript 1.0)



/// Section Begin - General and relative topics(JavaScript 1.0)



//{{HH_SYMBOL_SECTION

var HH_ChmFilename = "";

var HH_WindowName = "";

var HH_GlossaryFont = "";

var HH_Glossary = "";

var HH_Avenue = "";

var HH_ActiveX = false;

//}}HH_SYMBOL_SECTION



//Begin to support previous generic parameters

//Get the information about the browser.

var gstrBsAgent 	= navigator.userAgent.toLowerCase();

var gnBsVer	   		= parseInt(navigator.appVersion);



var gbBsOpera		= (gstrBsAgent.indexOf('opera') != -1);

var gbBsKonqueror	= (gstrBsAgent.indexOf('konqueror') != -1);

var gbBsSafari		= (gstrBsAgent.indexOf('safari') != -1);

var gbBsIE  		= (gstrBsAgent.indexOf('msie') != -1) && !gbBsOpera && !gbBsKonqueror && !gbBsSafari;

var gbBsNS  		= (gstrBsAgent.indexOf('mozilla') != -1) && ((gstrBsAgent.indexOf('spoofer') == -1) && (gstrBsAgent.indexOf('compatible') == -1)) && !gbBsOpera && !gbBsKonqueror && !gbBsSafari;



var gbBsMac			= (gstrBsAgent.indexOf('mac') != -1);

var gbBsWindows		= ((gstrBsAgent.indexOf('win') != -1) || (gstrBsAgent.indexOf('16bit') != -1));

var gbBsSunOS		= (gstrBsAgent.indexOf("sunos") != -1);



var gbBsIE3Before 	= ((gbBsIE) && (gnBsVer <= 2));

var gbBsNS3Before 	= ((gbBsNS) && (gnBsVer <= 3));



var gbBsNS2			= ((gbBsNS) && (gnBsVer <= 2));

var gbBsNS3			= ((gbBsNS) && (gnBsVer == 3));

var gbBsIE300301	= ((gbBsIE) && (gnBsVer == 2) && ((gstrBsAgent.indexOf("3.00") != -1)||(gstrBsAgent.indexOf("3.0a") != -1)||(gstrBsAgent.indexOf("3.0b")!=-1)||(gstrBsAgent.indexOf("3.01")!=-1)));

var gbBsIE302		= ((gbBsIE) && (gnBsVer == 2) && (gstrBsAgent.indexOf("3.02") != -1));



var gbBsNS4			= ((gbBsNS) && (gnBsVer >= 4));

var gbBsNS6			= ((gbBsNS) && (gnBsVer >= 5));

var	gbBsNS7			= false;



var gbBsIE4			= ((gbBsIE) && (gnBsVer >= 4));

var gbBsIE5			= false;

var gbBsIE55		= false;

var gbBsIE7			= false;



var gbBsOpera6		= false;

var gbBsOpera7		= false;



var gbBsKonqueror3	= false;

var gbSafari3 		= false ;

var gbAIR			= (gstrBsAgent.indexOf('adobeair')!=-1);

var gbChrome 		= (gstrBsAgent.indexOf('chrome')!=-1);

var isLocal 		= document.location.protocol.substring(0, 4) == "file";

var gbChromeLocal        = window.chrome && isLocal ;

var gbInsideCHM 	= document.location.href.search("::")>0 && document.location.href.search("chm")>0;

var gbBsIsMobile	= (gstrBsAgent.indexOf("mobile") != -1);

if(gbBsIsMobile == false)

{

	gbBsIsMobile = isTouchDevice();

}

function isTouchDevice() {

	return !!('ontouchstart' in window) ? 1 : 0;

}



gbBsIE = (navigator.appName.indexOf("Microsoft") != -1) && !gbBsOpera && !gbBsKonqueror && !gbBsSafari;;

if (gbBsIE)

{

	if (parseInt(navigator.appVersion) >= 4) {

		gbBsIE4 = true;

		if (gbBsIE4) {

			var nPos = gstrBsAgent.indexOf("msie");

			var strIEversion = gstrBsAgent.substring(nPos + 5);

			var nVersion =  parseFloat(strIEversion);

			if (nVersion >= 5)

				gbBsIE5 = true;

			if (nVersion >= 5.5)

			{

				if(nVersion >= 7)

					gbBsIE7 = true;

				gbBsIE55 = true;

			}

		}

	}

}

if (gbBsNS6)

{

	var nPos=gstrBsAgent.indexOf("gecko");

	if(nPos!=-1)

	{

		var nPos2=gstrBsAgent.indexOf("/", nPos);

		if(nPos2!=-1)

		{

			var nVersion=parseFloat(gstrBsAgent.substring(nPos2+1));

			if (nVersion>=20020823)

				gbBsNS7=true;

		}

	}	

}

if (gbBsOpera)

{

	var nPos = gstrBsAgent.indexOf("opera");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+6));

		if (nVersion >= 6)

		{

			gbBsOpera6=true;

			if (nVersion >=7)

				gbBsOpera7=true;	

		}

	}

}

if (gbBsKonqueror)

{

	var nPos = gstrBsAgent.indexOf("konqueror");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+10));

		if (nVersion >= 3)

		{

			gbBsKonqueror3=true;

		}

	}

}



if(gbBsSafari)

{

	var nPos = gstrBsAgent.indexOf("version/");

	if(nPos!=-1)

	{

		var nVersion = parseFloat(gstrBsAgent.substring(nPos+8,nPos+9));

		if (nVersion >= 3)

		{

			gbSafari3=true;

		}

	}

}



if(gbChrome)

{

	//for the time being use same tests as safari

	gbBsSafari 	= true ;

	gbSafari3	= true;

}



function insertAdjacentHTML(obj, where, htmlStr)

{

	if (gbBsIE || gbBsOpera7)

	{

		obj.insertAdjacentHTML(where, htmlStr);

	}

	else if (gbBsNS6 || gbBsSafari)

	{

		var r = obj.ownerDocument.createRange();

		r.setStartBefore(obj);

		var	parsedHTML = r.createContextualFragment(htmlStr);

		

		switch (where){

		case 'beforeBegin':

			obj.parentNode.insertBefore(parsedHTML,obj);

			break;

		case 'afterBegin':

			obj.insertBefore(parsedHTML,obj.firstChild);

			break;

		case 'beforeEnd':

			obj.appendChild(parsedHTML);

			break;

		case 'afterEnd':

			if (obj.nextSibling){

			obj.parentNode.insertBefore(parsedHTML,obj.nextSibling);

			} else {

			obj.parentNode.appendChild(parsedHTML);

			}

			break;

		}

	}

}





function setAttribute(obj, attr, val)

{

	if (gbBsIE)

	    obj.setAttribute(attr,val);

	else

	{

	    if (obj.setAttribute)

	        obj.setAttribute(attr,val);

	    else

	        obj.setProperty(attr,val,null);

	}       

};



function getAttribute(obj, attr)

{

   if (gbBsIE)

	    return obj.getAttribute(attr);

	else

	{

	    if ((obj.getAttribute)&&(obj.getAttribute(attr)))

	        return obj.getAttribute(attr);	  

	     else if ((obj.getPropertyValue)&&(obj.getPropertyValue(attr)))

	        return obj.getPropertyValue(attr) ;

	     else if ((obj.getPropertyCSSValue)&&(obj.getPropertyCSSValue(attr)))

	        return obj.getPropertyCSSValue(attr) ;

	     else

	        return null ;

	}          

};



// Utilities functions.

function BsscHasExtJs()

{

	if( gbBsIE3Before || gbBsNS3Before)

		return false;

	return true;

}



// Register event handler

var gBsOnLoads 			= new Array();	// An array holds all the onload event handler.

var gBsOnClicks 		= new Array();	// An array holds all the onClick event handler.

var gBsOnUnLoads 		= new Array();	// An array holds all the OnUnLoad event handler.

var gBsOnMouseOvers 	= new Array();	// An array holds all the OnMouseOver event handler.

var gBsOnMouseOuts 		= new Array();	// An array holds all the OnMouseOut event handler.



var gbOrignalOnMouseDown = null;



function BsscRegisterOnLoad(funcHandler)

{

	var nLength = gBsOnLoads.length;

	gBsOnLoads[nLength] = funcHandler;

}



function BsscRegisterOnClick(funcHandler)

{

	var nLength = gBsOnClicks.length;

	gBsOnClicks[nLength] = funcHandler;

}



function BsscRegisterOnUnLoad(funcHandler)

{

	var nLength = gBsOnUnLoads.length;

	gBsOnUnLoads[nLength] = funcHandler;

}



function BsscRegisterOnMouseOver(funcHandler)

{

	var nLength = gBsOnMouseOvers.length;

	gBsOnMouseOvers[nLength] = funcHandler;

}



function BsscRegisterOnMouseOut(funcHandler)

{

	var nLength = gBsOnMouseOuts.length;

	gBsOnMouseOuts[nLength] = funcHandler;

}



function BsGeneralOnLoad()

{

	if (!gbBsIE4 && !gbBsNS4)

		return;



	// Make everything visible in navigator

//	if (gbBsNS4) {

//		// Make some special effects items visible

//		var arr ;

//		if (gbBsNS6)

//		    arr = document.getElementsByTagName('*');

//		else

//		    arr = document.layers ;

//		for (var iLayer = 0; iLayer < arr.length; iLayer++) {

//			arr[iLayer].visibility = "visible";

//			arr[iLayer].left = 0 + 'px';

//		}

//	}	

	

}



// If resize the netscape browser, need to reload it.

function BsReDo()

{

  if (innerWidth != origWidth || innerHeight != origHeight)

     location.reload();

}

// End of the local functions.



// The following functions are used by the html files.

function BSSCOnLoad(event)

{

	if( !BsscHasExtJs() )

		return;

	for (var nElement = gBsOnLoads.length - 1; nElement >= 0; nElement--)

		gBsOnLoads[nElement]();

}



function BSSCOnClick(event)

{

	if (!BsscHasExtJs()) return;

		

	for (var nElement = gBsOnClicks.length - 1; nElement >= 0; nElement--)

		gBsOnClicks[nElement]();

}



function BSSCOnUnload(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnUnLoads.length - 1; nElement >= 0; nElement--)

		gBsOnUnLoads[nElement]();

}



function BSSCOnMouseOver(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnMouseOvers.length - 1; nElement >= 0; nElement--)

		gBsOnMouseOvers[nElement]();

}



function BSSCOnMouseOut(event)

{

	if (!BsscHasExtJs()) return;

	for (var nElement = gBsOnMouseOuts.length - 1; nElement >= 0; nElement--)

	{

		gBsOnMouseOuts[nElement]();

	}

}

// End of invocation of the event handle functions.



// Add the GereralOnLoad to the onload array.

if (typeof(BsscRegisterOnLoad) != "undefined")

{

	BsscRegisterOnLoad(BsGeneralOnLoad);

}

if (gbBsNS4&&!gbBsNS6) {

	origWidth = innerWidth;

	origHeight = innerHeight;

	onresize = BsReDo;

}

//End to support previous generic parameters



//Begin to support previous HHActiveX invoking

function BsHHActivateComponents()

{

	if( HH_ActiveX && (HH_ChmFilename != "") && ((self == top) || (self == top.frames[0])))

	{

		var objBody = getElementsByTag(document,"BODY")[0];

		if( typeof(objBody) == "object" )

		{

			insertAdjacentHTML(objBody, "beforeEnd", '<OBJECT ID="HHComponentActivator" CLASSID="CLSID:399CB6C4-7312-11D2-B4D9-00105A0422DF" width=0 height=0></OBJECT>');

			if (HHComponentActivator.object)

				HHComponentActivator.Activate(HH_ChmFilename, HH_WindowName, HH_GlossaryFont, HH_Glossary, HH_Avenue);

		}

	}

}



function BsHHActivXOnLoad()

{	

	if( gbBsIE4 )

		BsHHActivateComponents(); 

}



if( typeof(BsscRegisterOnLoad) != "undefined" )

{

	BsscRegisterOnLoad(BsHHActivXOnLoad);

}

//End to support previous HHActiveX invoking



//Begin to support previous relative topics

//If webHelp needs Related Topics DHTMLcode, it's supposed to add it here

var gbPopupMenuTimeoutExpired = false;

var gbInPopupMenu = false;

var gbPopupMenuTopicList = null;

var gOlddocumentClick = null;



//////////////////////////////////////////////////////////////////////////////////////////

//

// Popup Menu code

//

//////////////////////////////////////////////////////////////////////////////////////////



var g_bIsPopupMenuInit = false;

function _WritePopupMenuLayer()

{

	if (!g_bIsPopupMenuInit)

        {

	  if (gbBsNS4&&!gbBsNS6) {

//Do not try to write ininle styles for NS!  NS can not handle it and will not stop downloading the html page...

	   	document.write("<DIV CLASS='WebHelpPopupMenu' ID='PopupMenu'></DIV>");

	  } else{

	  document.write("<DIV ID='PopupMenu' STYLE='position:absolute; left:0px; top:0px; z-index:4; visibility:hidden;'></DIV>");

	  if (!(gbBsNS4&&!gbBsNS6)) {

		document.write("<STYLE TYPE='text/css'>");

		if (gbBsMac&&gbBsIE4) {

			document.write(".PopupOver {font-family:'Arial'; color:white; background:navy; font-size:10pt; font-style:normal;font-weight:normal;text-decoration:none;}");

			document.write(".PopupNotOver {font-family:'Arial'; color:black; background:#c0c0c0; font-size:10pt; font-style:normal;font-weight:normal;text-decoration:none;}");

		} else {

			document.write(".PopupOver {font-family:'Arial'; color:white; background:navy; font-size:8pt; font-style:normal;font-weight:normal;text-decoration:none;}");

			document.write(".PopupNotOver {font-family:'Arial'; color:black; background:#c0c0c0; font-size:8pt; font-style:normal;font-weight:normal;text-decoration:none;}");

		}

		document.write("</STYLE>");

	   }

          }

	  g_bIsPopupMenuInit = true;

	}

}



//Seek for the bsscright frame 

function _SeekFrameByName( cRoot, strName )

{

	if( cRoot == null )	return null;

	if( cRoot.frames == null )	return null;

	if( cRoot.frames[strName] != null )	return cRoot.frames[strName];

	for (var i=0; i<cRoot.frames.length; i++)

	{

		var cObj = null;

		if (!gbBsNS6) 

			cObj = _SeekFrameByName( cRoot.frames(i).document, strName );

		else

			cObj = _SeekFrameByName( cRoot.frames[i], strName );

		if( cObj != null )		return cObj;

	};

	return null;

}

function _GetFrameByName( cRoot, strName )

{

	if( cRoot == null )	return null;

	var cRet = _SeekFrameByName(cRoot, strName);

	if( cRet != null )	return cRet;

	if (cRoot.parent != cRoot)

		return _GetFrameByName( cRoot.parent, strName );

	else

		return null;

}



var gfn_arguments = null;

function _PopupMenu_Invoke(fn_arguments)

{

	gfn_arguments = fn_arguments;

	if (gbBsOpera6&&gbBsMac)

	{

		var wndOldPopupLinks= window.open(document.location.href, "popuplinks");

		wndOldPopupLinks.close();

		setTimeout("_PopupMenu_Invoke_2();",100);

	}

	else

	{

		_PopupMenu_Invoke_2();

	}

}



function GetXOffset(el) {

    var offX = 0;

    while (el && typeof (el.offsetLeft) != 'undefined' && typeof (el.offsetParent) != 'undefined') 

    {

        offX = offX + el.offsetLeft;

        el = el.offsetParent;

    }

    return offX;

}



function GetYOffset(el) 

{

    var offY = 0;

    while (el && typeof (el.offsetTop) != 'undefined' && typeof (el.offsetParent) != 'undefined') 

    {

        offY = offY + el.offsetTop;

        el = el.offsetParent;

    }

    return offY;

}



function _PopupMenu_Invoke_2()

{

	var fn_arguments = gfn_arguments;

	gfn_arguments = null;

	

	// Make sure we have reasonable arguments

	var argLen = fn_arguments.length;

	if (argLen < 3) {

		return false;

	}



	// Check to see if we only have one target

	var strTarget = "";

	var targetDoc = null;

	if (fn_arguments[1] == '') {

		if (BSSCPopup_IsPopup()) {

			targetDoc = parent;

			strTarget = "TARGET= _parent";

		}

		else

			targetDoc = window.document;

	} else {

		targetDoc = _GetFrameByName( parent, fn_arguments[1] );



		strTarget = "TARGET='" + fn_arguments[1] + "'";

	}



	if ((!gbBsIE4 && !gbBsNS4 && !gbBsOpera7 && !gbBsKonqueror3 &&!gbBsSafari) || ((gbBsMac) && (gbBsIE4) && (window.event.srcElement.tagName == "AREA"))) {

	

		var argLen 	= fn_arguments.length;



		// Create the window that the hyperlinks will go into

		var nHeight = argLen * 15;

		var nWidth = 400;

		var strParam = "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=auto";

		strParam += ",height=" + nHeight + ",width=200";

		strParam += ",resizable";



		var wndTemp=null;

		// Create a temporary window first to ensure the real popup comes up on top

		if (!gbBsOpera)

			wndTemp = window.open("", "temp", strParam);



		// Create the real popup window

		var wndPopupLinks=null;

		if (gbBsOpera&&gbBsMac)

		{

			wndTemp = window.open(document.location.href, "temp", strParam);

			wndPopupLinks= window.open(document.location.href, "popuplinks", strParam);

		}

		else

			wndPopupLinks= window.open("", "popuplinks", strParam);

		wndPopupLinks.document.open("text/html");



		// Close the temporary

		if (wndTemp)

			wndTemp.close();



		var sHTML="<html><head>";

		sHTML += "<";

		sHTML += "/head>";

		sHTML+="<body onBlur=\'self.focus();\'>";

		var strParaLine = "";

		for (var i = 0; i < (argLen - 2) / 2; i++) {

			strParaLine = "";

			strParaLine += "<a href=\"javascript:";

			if (gbBsIE) {

				strParaLine += "onBlur=null; ";

			}

			strParaLine += "opener.location=\'";

			strParaLine += fn_arguments[2 * i + 3];

			strParaLine += "\';close();\"";

			strParaLine += strTarget;



			strParaLine += ">";

			strParaLine += fn_arguments[2 * i + 2];

			strParaLine += "</a>";

			strParaLine += "<br>";

			sHTML+=strParaLine;

		}

		sHTML+="</body></html>";

		wndPopupLinks.document.write(sHTML);

		wndPopupLinks.document.close();

		window.gbInPopupMenu = true;

		if (!gbBsIE) {

			wndPopupLinks.focus();

		}

		return false;

	}



	if (((argLen < 5) && ((isNaN(fn_arguments[2])) || (gbPopupMenuTopicList == null))) ||

		((argLen < 4) && ((!isNaN(fn_arguments[2])) && (gbPopupMenuTopicList != null)))) {

		// Get the place that we will be putting the topic into

		var strURL = "";

		if (isNaN(fn_arguments[2]) ||  (gbPopupMenuTopicList == null)) {

			strURL = fn_arguments[3];

		}

		else 	{

			strURL = gbPopupMenuTopicList[fn_arguments[2]].strURL;

		}



		if (targetDoc != null) {

			targetDoc.location.href = strURL;

		}

		else {

			if (fn_arguments[1] != null && typeof(fn_arguments[1]) != "undefined")

				window.open(strURL, fn_arguments[1]);

			else

				window.open(strURL);

		}		

		window.gbInPopupMenu = true;

		return false;

	}

	

	var strMenu = "";

	if (gbBsNS4&&!gbBsNS6) {

		strMenu = '<TABLE BORDER="1" CELLSPACING=0 CELLPADDING=3 BGCOLOR="#c0c0c0">';

	} else {

		strMenu = '<TABLE STYLE="border:2px outset white;" CELLSPACING=0';

		if (gbBsMac) {

			strMenu += ' CELLPADDING=4';

		} else {

			strMenu += ' CELLPADDING=2';

		}	

		strMenu += ' BGCOLOR=#c0c0c0>';

	}

	// Add each of the items

	var i = 2;

	while (i <= argLen - 1) {

		strMenu += '<TR><TD><NOBR>'

		// If the destination is a number then look it up in the topic list

		if (isNaN(fn_arguments[i]) ||  (gbPopupMenuTopicList == null)) {

			strMenu += '<DIV class="PopupNotOver" STYLE="padding-left:3pt; padding-right:3pt;"><A HREF="' + fn_arguments[i + 1] + '"' + strTarget;

		} else {

			strMenu += '<DIV class="PopupNotOver" STYLE="padding-left:3pt; padding-right:3pt;"><A HREF="' + gbPopupMenuTopicList[fn_arguments[i]].strURL + '"' + strTarget;

		}

		strMenu += ' onclick="PopupMenu_HandleClick(event);"';

		strMenu += ' onmouseover="PopupMenu_Over(event);"';

		strMenu += ' onmouseout="PopupMenu_Out(event);"';

		strMenu += '>';

		if (isNaN(fn_arguments[i]) || (gbPopupMenuTopicList == null)) {

			strMenu += '<SPAN CLASS="PopupNotOver">' + fn_arguments[i] + '</SPAN>';

		} else {

			strMenu += '<SPAN CLASS="PopupNotOver">' + gbPopupMenuTopicList[fn_arguments[i]].strTitle + '</SPAN>';

		}

		strMenu += '</A></DIV></NOBR></TD></TR>';



		if (isNaN(fn_arguments[i]) || (gbPopupMenuTopicList == null)) {

			i += 2;

		} else {

			i += 1;

		}

	}

	strMenu += "</TABLE>";



	if (gbBsMac) {

	// totally hack. because ie5 in mac need something. </TABLE> is one of them. mac is mad.

		strMenu +="<TABLE></TABLE>";

	}



	var layerPopup = null;

	var stylePopup = null;

	var nEventX = 0;

	var nEventY = 0;

	var nWindowWidth = 0;



	var nPopupHeight = 0;

	var nPopupWidth = 0;



	var e = fn_arguments[0];

	if (typeof (window.event) != 'undefined' && typeof (window.event.clientX) != 'undefined' && typeof (window.event.clientX) == 'number') 

    {

	    nEventX = window.event.clientX;

	    nEventY = window.event.clientY;

	}

	else 

    {

        if (typeof (e.clientX) != 'undefined') 

        {

	        nEventX = e.clientX;

	        nEventY = e.clientY;

	    }

	    else if (typeof (e.pageX) != 'undefined') 

        {

	        nEventX = e.pageX;

	        nEventY = e.pageY;



	        nEventX -= getScrollLeft();

	        nEventY -= getScrollTop();



	    }

	}



	_BSPSGetClientSize();



	var bFoundBrowser = true;

	if (gbBsIE4 || gbBsOpera7) 

    {

	    layerPopup = getElement("PopupMenu");

		layerPopup.innerHTML = strMenu;

		stylePopup = layerPopup.style;

	    nPopupHeight = layerPopup.scrollHeight;

	    nPopupWidth = layerPopup.scrollWidth;

	    if (gbBsMac) 

        {

	        nPopupWidth = 80; // we have no idea how to get the dynamic width of the popup.

	    }

	}

	else if (gbBsNS6 || gbBsKonqueror3 || gbBsSafari) 

    {

	    layerPopup = getElement("PopupMenu");

		layerPopup.style.visibility = "hidden";

		layerPopup.innerHTML = strMenu;

	    nPopupHeight = layerPopup.offsetHeight;

	    nPopupWidth = layerPopup.offsetWidth;

	}

	else if (gbBsNS4) 

    {

	    layerPopup = document.layers.PopupMenu;

	    layerPopup.visibility = "hide";

	    stylePopup = layerPopup.document;

	    stylePopup.write(strMenu);

	    stylePopup.close();



	    nPopupHeight = layerPopup.clip.height;

	    nPopupWidth = layerPopup.clip.width;

	}

	else

	    bFoundBrowser = false;



	if (bFoundBrowser)

    {

	    if (nEventY + nPopupHeight + 20 < gBsClientHeight) 

        {

	        nEventY += 20;

	    }

	    else 

        {

            nEventY = gBsClientHeight - nPopupHeight - 20;

	    }



        if (nEventX + nPopupWidth + 20 < gBsClientWidth) 

        {

            nEventX += 20;

        }

        else 

        {

            nEventX = gBsClientWidth - nPopupWidth - 20;

        }



        var par = layerPopup.offsetParent;

        var offX = 0, offY = 0;

        if (typeof(par) != 'undefined' && par) 

        {

            offX = GetXOffset(par);

            offY = GetYOffset(par);

        }



        nEventX += getScrollLeftElement(par);

        nEventX -= offX;

        nEventY += getScrollTopElement(par);

        nEventY -= offY;

    }



	if (gbBsIE4 || gbBsOpera7) 

    {

	    stylePopup.top = nEventY;

	    if (typeof (stylePopup.top) != 'number' ) 

        {

	        stylePopup.top = nEventY + "px";

	    }

	    stylePopup.left = nEventX;

	    if (typeof (stylePopup.left) != 'number' ) 

        {

	        stylePopup.left = nEventX + "px";

	    }



	    stylePopup.visibility = "visible";

	    if (!gOlddocumentClick && document.onclick)

	        gOlddocumentClick = document.onclick;

	    document.onclick = PopupMenu_HandleClick;

	}

	else if (gbBsNS6 || gbBsKonqueror3 || gbBsSafari) 

    {

	    if (gbBsNS6 || gbChrome || gbSafari3)

	        layerPopup.style.top = nEventY + "px";

	    else

	        layerPopup.style.top = nEventY;

	    if (gbBsNS6 || gbChrome || gbSafari3)

	        layerPopup.style.left = nEventX + "px";

	    else

	        layerPopup.style.left = nEventX;

	    // set again to avoid the stupid frash in netscape 6.

	    layerPopup.innerHTML = strMenu;

	    layerPopup.style.visibility = "visible";

	    //window.captureEvents(Event.MOUSEDOWN);

	    if (!gOlddocumentClick && document.onclick)

	        gOlddocumentClick = document.onclick;

	    window.onclick = PopupMenu_HandleClick;

	}

	else if (gbBsNS4) 

    {

	    layerPopup.left = nEventX;

	    layerPopup.top = nEventY;

	    layerPopup.visibility = "visible";

	    window.captureEvents(Event.MOUSEDOWN);

	    if (!gOlddocumentClick && document.onmousedown)

	        gOlddocumentClick = document.onmousedown;

	    window.onmousedown = PopupMenu_HandleClick;

	}



	if(window.addEventListener)

	{

		var popupDivElem = getElement("PopupMenu");

		if(typeof(popupDivElem) != 'undefined')

			popupDivElem.addEventListener("touchstart", onPopupDivTouched, false);



		window.document.addEventListener("touchstart", onPopupParentTouched, false);

	}

	



	window.gbInPopupMenu = true;

	window.gbPopupMenuTimeoutExpired = false;

	setTimeout("PopupMenu_Timeout();", 100);

	return false;

}



function PopupMenu_Timeout()

{

	window.gbPopupMenuTimeoutExpired = true;

}



function PopupMenu_Over(e)

{

    if (gbBsIE4||gbBsOpera7)

		e.srcElement.className = "PopupOver";

    else if (gbBsNS6)

		e.target.parentNode.className = "PopupOver";

	return;

}



function PopupMenu_Out(e)

{

    if (gbBsIE4||gbBsOpera7)

		e.srcElement.className = "PopupNotOver";

    else if (gbBsNS6)

		e.target.parentNode.className = "PopupNotOver";

	return;

}

function onPopupDivTouched(e)

{

	if(typeof(e) != 'undefined' && e)

		e.stopPropagation();

}



function onPopupParentTouched(e)

{

	if(window.removeEventListener)

	{

		var popupDivElem = getElement("PopupMenu");

		if(typeof(popupDivElem) != 'undefined')

			popupDivElem.removeEventListener("touchstart", onPopupDivTouched, false);

		window.removeEventListener("touchstart", onPopupParentTouched, false);

	}



	PopupMenu_HandleClick(e);

}



function PopupMenu_HandleClick(e)

{

	if (window.gbPopupMenuTimeoutExpired) {

		window.gbInPopupMenu = false;

		if (gbBsNS4 && !gbBsNS6) {

			window.releaseEvents(Event.MOUSEDOWN);

		}



		var layerPopup = null;

		if (gbBsNS4&&!gbBsNS6) {

			layerPopup = document.layers.PopupMenu;

			layerPopup.visibility = "hide";

		} else {

			layerPopup = getElement("PopupMenu");

			layerPopup.style.visibility = "hidden";

		}

	

		if (gOlddocumentClick)

		{

			if (gbBsNS4 && !gbBsNS6)

				document.onmousedown = gOlddocumentClick;

			else

				document.onclick = gOlddocumentClick;

		}

	}

	return;

}



function BSSCPopup_ClickMac()

{

	if ((!DHTMLPopupSupport()) && (gbBsIE4 || gbBsOpera7))

	{	

		var bClickOnAnchor = false;

		var el;

		if ((window.event != null) &&

		    (window.event.srcElement != null))

		{

		    el = window.event.srcElement;

			while (el != null)

			{

				if ((el.tagName == "A") || (el.tagName == "AREA")) 	{

					bClickOnAnchor = true;

					break;

				}

				if (el.tagName == "BODY") {

					break;

				}

				el = getParentNode(el);

			}

		}

		if (BSSCPopup_IsPopup())

		{

			if (!bClickOnAnchor) {

				parent.window.gPopupWindow = null;

				self.close();

			}

		}

		else

		{

			bClosePopupWindow = true;

			if ((bClickOnAnchor) &&

				(el.href) &&

			    ((el.href.indexOf("javascript:BSSCPopup") != -1) || (el.href.indexOf("javascript:null") != -1) || (el.href.indexOf("javascript:void(0)") != -1)))

			{

				bClosePopupWindow = false;

			}

			if (bClosePopupWindow)

			{

				if (window.gPopupWindow != null && !window.gPopupWindow.closed )

				{

					window.gPopupWindow.close();

				}

			}

		}

	}

}



function BsPopupOnClick()

{

	if (!gbBsIE4 && !gbBsOpera7)

		return;



	BSSCPopup_ClickMac();

}



function _BSSCOnError(message)

{

	if(-1 != message.indexOf("denied") 

		|| -1 != message.indexOf("Object required"))

	 return true;

}



//End to support previous relative topics



/// Section End - General and relative topics (JavaScript 1.0)



/// Section Begin  - Popup (JavaScript 1.0)

//Begin to support previous popup functions



//variables used to isolate the browser type

var gBsStyVisShow	= null;

var gBsStyVisHide	= null;

var gBsClientWidth	= 640;

var gBsClientHeight = 480;



// here is the varible for judge popup windows size. these parameter is for IE5.0, it may need adjust for others.

var gBRateH_W		= 0.618; // 1.618 Golden cut.

var gBMaxXOfParent	= 0.8; 

var gBMaxYOfParent	= 0.8;

var gBscrollHeight   = 16;

var gBscrollWidth   =  16;

var gBpermitXDelta	= 3;

var gBpermitYDelta	= 3;





var arrayPopupURL = new Array();

var arrayAbsPopupURL = new Array();

var arrayIntervalId = new Array();



var arrayDirty = new Array();



function getBRateH_W()

{

	return 0.618 ;

}



function getBscrollWidth()

{

	return 16 ;

}



function getBscrollHeight()

{

	return 16 ;

}



function getBMaxXOfParent()

{

	return 0.8 ;

}



function getBMaxYOfParent()

{

	return 0.8 ;

}



function setIntervalID(nIndex,id)

{

    arrayIntervalId[nIndex] = id;

}



function getIntervalID(nIndex)

{

	if (nIndex == -1 || arrayIntervalId.length <= nIndex) 

	    return -1;

	else

        return arrayIntervalId[nIndex];

}



function setAbsPopupURL(nIndex, strURL)

{

	arrayAbsPopupURL[nIndex] = strURL;

}



function getAbsPopupURL(nIndex)

{

	if (nIndex == -1 || arrayAbsPopupURL.length <= nIndex) return null;

	else 

		return arrayAbsPopupURL[nIndex];

}



function getPopupURL(nIndex)

{

	if (nIndex == -1 || arrayPopupURL.length <= nIndex) return null;

	else 

		return arrayPopupURL[nIndex];

}



function getPopupID(nIndex)

{

	return gstrPopupID + nIndex;

}



function getPopupShadowID(nIndex)

{

	return gstrPopupShadowID + nIndex;

}



function getPopupTopicID(nIndex)

{

	return gstrPopupTopicID + nIndex;

}



function getPopupIFrameID(nIndex)

{

	return gstrPopupIFrameID + nIndex;

}



function getPopupIFrameName(nIndex)

{

	return gstrPopupIFrameName + nIndex;

}





function getPopupTopicStyle(nIndex)

{

	return getElement(getPopupTopicID(nIndex)).style;

}



function getPopupShadowStyle(nIndex)

{

	return getElement(getPopupShadowID(nIndex)).style;

}



function getPopupIFrame(nIndex)

{

	if(gbAIR)

	{

		return window.frames[getPopupIFrameName(nIndex)];

	}

	else

	{

		if (gbBsNS6||gbSafari3)

			return eval("window.frames['" + getPopupIFrameName(nIndex) + "']");

		else

			return eval("document.frames['" + getPopupIFrameName(nIndex) + "']");

	}

}



function getPopupDivStyle(nIndex)

{

	return getElement(getPopupID(nIndex)).style;

}



function getPopupIFrameStyle(nIndex)

{

	return getElement(getPopupIFrameID(nIndex)).style;

}





function findDiv(strURL)

{

	for (var i = 0; i < arrayPopupURL.length; i ++ ) {

		if (arrayPopupURL[i] == strURL) {

			return i;

		}

	}

	return -1;

}



var gnToken = -1;

function takeToken()

{

	gnToken ++;

	if (gnToken > 10000) gnToken = 0;

	return gnToken;

}



function IsValidToken(nToken)

{

	return (gnToken == nToken);

}



function addDiv(strURL)

{

	for (var i = 0; i < arrayPopupURL.length; i ++) {

		if (arrayPopupURL[i] == null) {

			arrayPopupURL[i] = strURL;

			return i;

		}

	}	

	arrayPopupURL[i] = strURL;

	arrayDirty[i] = true;

	return i;

}



function setDirty()

{

	for (var i = 0; i < arrayPopupURL.length; i ++ )

		arrayDirty[i] = true;

}



function IsDirty(nIndex)

{

	if (nIndex == -1)

		return true;

	else 

		if (arrayDirty.length > nIndex) 

			return arrayDirty[nIndex];

		else

			return true;

}



function hideAll()

{

	for (var i = 0; i < arrayPopupURL.length; i ++ )

	{

		getPopupDivStyle(i).visibility = gBsStyVisHide;

		getPopupIFrameStyle(i).visibility = gBsStyVisHide;

		if(gbBsIE)

		    removeThis(document.all(getPopupID(i)));

	}

	if(gbBsIE)

		arrayPopupURL.length = 0;

}



function getCurrentPopupIFrame()

{

	for (var i = 0; i < arrayPopupURL.length; i ++)

		if (getPopupDivStyle(i).visibility == gBsStyVisShow)

			return getPopupIFrame(i);

	return null;

}



function setClear(nIndex)

{

	if (nIndex != -1)

		arrayDirty[nIndex] = false;

}



function _BSSCCreatePopupDiv(strURL)

{

	var nIndex = findDiv(strURL);

	if (nIndex == -1 ) {

		nIndex = addDiv(strURL);

		BsPopup_CreateDiv(nIndex);

	}

	else {

		if (IsDirty(nIndex)) {

			if("object" == typeof(getPopupIFrame(nIndex).document))

				getPopupIFrame(nIndex).document.location.href = strURL;

		}

	}

	return nIndex;

}



//Here is the browser type 

function _BSPSGetBrowserInfo()

{

	if (gbBsNS4&&!gbBsNS6)

	{

		gBsStyVisShow	= "show";

		gBsStyVisHide	= "hide";

	}

	else

	{

		gBsStyVisShow	= "visible";

		gBsStyVisHide	= "hidden";

	}

}



_BSPSGetBrowserInfo();



//Get client size info

function _BSPSGetClientSize()

{

	if( typeof( window.innerWidth ) == 'number' )

	{

		gBsClientWidth	= innerWidth;

		gBsClientHeight = innerHeight;

	}

	else if( document.documentElement && ( document.documentElement.clientWidth || document.documentElement.clientHeight ) )

	{

		gBsClientWidth = document.documentElement.clientWidth;

		gBsClientHeight = document.documentElement.clientHeight;

	} 

	else if( document.body && ( document.body.clientWidth || document.body.clientHeight ) ) 

	{

		gBsClientWidth = document.body.clientWidth;

		gBsClientHeight = document.body.clientHeight;

	}

}



var gstrPopupID = 'BSSCPopup';

var gstrPopupShadowID = 'BSSCPopupShadow';

var gstrPopupTopicID = 'BSSCPopupTopic';

var gstrPopupIFrameID = 'BSSCPopupIFrame';

var gstrPopupIFrameName = 'BSSCPopupIFrameName';



var gstrPopupSecondWindowName = 'BSSCPopup';



var gPopupWindow = null;

var gnPopupClickX = 0;

var gnPopupClickY = 0;



var gnPopupScreenClickX = 0;

var gnPopupScreenClickY = 0;



var gbPopupTimeoutExpired = false;



function DHTMLPopupSupport()

{

	if (((gbBsIE4) && (!gbBsMac))||gbBsOpera7|| gbBsNS7 || gbSafari3||gbAIR) {

		return true;

	}

	return false;

}



function BSSCPopup_IsPopup()

{

	if (DHTMLPopupSupport() && (this.name.indexOf(gstrPopupIFrameName) != -1)) {

		return true;

	} else if ((gbBsNS4 || gbBsIE4 || gbBsOpera7) && (this.name.indexOf(gstrPopupID) != -1)) {

		return true;

	} else {

		return false;

	}

}



// If there is a hyperlink in a popup window, display the hyperlink in

// the original window. (bsscright)

//commenting this as we are opening popup links in its parent

//also in multiscreen bsscright is not the the name of topic frame, relevant only in webhelp

/*if (BSSCPopup_IsPopup() && !gbBsIE4 && !gbBsOpera7) {

document.write("<base target=\"bsscright\">");

}*/



// Local functions.

function BsPopup_CreateDiv(nIndex)

{

	if(!DHTMLPopupSupport())

		return;

	// DO NOT SET Width and height for the div, otherwize it will make IE4 popup do not work when view the topic alone.

	var strPopupDiv = "<DIV ID='" + getPopupID(nIndex) + "' STYLE='position:absolute; top:-100; left:0; z-index:600; visibility:hidden;'>";

	strPopupDiv += "<DIV ID='" + getPopupShadowID(nIndex) + "' STYLE=\"position:absolute;top:0; left:0;  background-color:#C0C0C0;\"></DIV>";

	strPopupDiv += "<DIV ID='" + getPopupTopicID(nIndex) + "' STYLE=\"position:absolute;top:0; left:0;  background-color:#FFFFFF;border:1px #000000 outset;\">";

	strPopupDiv += "<IFRAME title=\"Popup Window\" ID='" + getPopupIFrameID(nIndex) + "' name='" + getPopupIFrameName(nIndex) + "' src = '" + getPopupURL(nIndex) + "' frameborder=0 scrolling=auto></IFRAME>";

	strPopupDiv += "</DIV></DIV>";



	var objBody = getElementsByTag(document, "BODY")[0];

	if( typeof(objBody) != "object" )

		return;



	insertAdjacentHTML(objBody, "beforeEnd", strPopupDiv);

}



function handleLoadNS()

{

	if (this.id)

	{

		var nIndex = parseInt(this.id.substring(gstrPopupIFrameID.length));

		BSSCPopup_PostWork(nIndex);

	}

}



function BSSCPopup_PostWork(nIndex)

{

	getPopupDivStyle(nIndex).visibility = gBsStyVisShow;

	getPopupIFrameStyle(nIndex).visibility =gBsStyVisShow;



	setClear(nIndex);

	window.gbPopupTimeoutExpired = true;



	try{

		BSSCPopup_ChangeTargettoParent(getPopupIFrame(nIndex).document);

		if (gbBsNS6)

			getPopupIFrame(nIndex).document.body.addEventListener("click",BSSCPopupClicked,false);

		else

			getPopupIFrame(nIndex).document.body.onclick = BSSCPopupClicked;

	}catch(e){}



	if (!gbOrignalOnMouseDown && document.onmousedown)

		gbOrignalOnMouseDown = document.onmousedown;



	if (gbChrome || gbBsNS6)

		document.addEventListener("mousedown", BSSCPopupParentClicked,false);

	else

		document.onmousedown = BSSCPopupParentClicked;

}



function BSSCPopup_Timeout(nIndex, nToken)

{

    if (!IsValidToken(nToken)) return;



	if (gbBsNS6||((getPopupIFrame(nIndex).document.readyState == "complete") &&

		(getPopupIFrame(nIndex).document.body != null))) {

		BSSCPopup_PostWork(nIndex);

	} else {

		setTimeout("BSSCPopup_Timeout(" + nIndex + "," + nToken + ")", 100);

	}

}



// VH 08/10/00 

// do not change target to parent if the href is using javascript

function BSSCPopup_ChangeTargettoParent(tagsObject)

{

	var collA = getElementsByTag(tagsObject, "A");

	BSSCPopup_ChangeTargettoParent2(collA);



	var collIMG = getElementsByTag(tagsObject,"IMG");

	BSSCPopup_ChangeTargettoParent2(collIMG);

}



function BSSCPopup_ChangeTargettoParent2(colls)

{

	if (colls != null)  {

		for (var j = 0; j < colls.length; j ++ )

		{

			var strtemp = colls[j].href;

			if (strtemp)

			{

				strtemp = strtemp.toLowerCase();

				if (strtemp.indexOf("javascript:") == -1)

				if (colls[j].target == "")

					colls[j].target = "_parent";

			}

		}

	}

}



function BSPSPopupTopicWinHelp(strURL)

{

	_BSSCPopup(strURL);

	return;

}



function DelayBSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight )

{

//before doing any thing clear the interval function

    var intervalID = getIntervalID(nIndex);

    if(intervalID!=-1)

        clearInterval(intervalID);

        

    BSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight );

}



function _BSSCPopup(strURL, width, height)

{

	var cuswidth = 0;

	var cusheight = 0;

	if ("undefined" != typeof(width) && "undefined" != typeof(height)) {

		cuswidth = width;

		cusheight= height;

	}

	

	if (DHTMLPopupSupport()) {

		if(!gbAIR && !gbInsideCHM)

			rhPopupEx.createPopup(strURL, width, height);

		else 

		{	

			var nToken = takeToken(); // take  token first.

			var nIndex = _BSSCCreatePopupDiv(strURL, nToken, cuswidth, cusheight);

			window.gbPopupTimeoutExpired = false;

			var ntWidth = gBsClientWidth;

			var ntHeight = gBsClientHeight;

			_BSPSGetClientSize();

			if (ntWidth != gBsClientWidth || ntHeight != gBsClientHeight) {

				setDirty();

			}

	

			if (IsDirty(nIndex)) 

			{

				if(gbAIR)

				{

				    var tempappTimer = setInterval(function(){DelayBSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight )}, 400);

				    setIntervalID(nIndex,tempappTimer);

				}

				else

				{

					if (gbBsMac) {

						setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight  +")", 400);

					} else {

						setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 100);

					}

				}

			}

			else {

				MoveDivAndShow(nIndex ,nToken, cuswidth, cusheight);

			}

		}

	} else {

		_BSSCPopup2(strURL, cuswidth, cusheight);

	}

	return;

}



if (gbBsIE55)

{

	var ehlpdhtm_fOldBefureUnload = window.onbeforeunload;

	var gnBsUnload=0;

	window.onbeforeunload = window_BUnload;

}

	

function window_BUnload()

{

	gnBsUnload++;

	if (gnBsUnload>1)

		return;

	for (var i = 0; i < arrayPopupURL.length; i ++)

		removeThis(document.all(getPopupID(i)));

	arrayPopupURL.length = 0;	

	if (ehlpdhtm_fOldBefureUnload)

		ehlpdhtm_fOldBefureUnload();

}



function _BSSCPopup2(strURL, width, height)

{

	if (gbBsOpera6&&gbBsMac)

	{

		var wmTemp = window.open(document.location.href, gstrPopupSecondWindowName);

		wmTemp.close();

		setTimeout("_BSSCPopup3(\""+strURL+"\","+width+","+height+");",100);

	}

	else

		_BSSCPopup3(strURL, width, height);

}

		

function _BSSCPopup3(strURL, width, height)

{

	if (window.name == gstrPopupSecondWindowName) {

		window.location = strURL;

	} else {

		if (!gbBsMac || !gbBsNS4) {

			BSSCHidePopupWindow();

		}

		var nX = 0;

		var nY = 0;

		var nHeight = 300;

		var nWidth = 400;

		if (width > 0 && height > 0) {

			nHeight = height;

			nWidth = width;

		}

		_BSPSGetClientSize();



		nX = window.gnPopupScreenClickX;

		nY = window.gnPopupScreenClickY;



		if (nY + nHeight + 40 > screen.availHeight) {

			nY = screen.availHeight - nHeight - 40;

		}

		if (nX + nWidth + 40 > screen.availWidth) {

			nX = screen.availWidth - nWidth - 40;

		}



		// Launch a separate window

		var strParam="titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes";

		if (gbBsNS) {

			if (gbBsNS6) {

				strParam += ",Height=" + nHeight + "px,Width=" + nWidth+"px";

				strParam += ",screenX=" + nX + ",screenY=" + nY;

				strParam += ",dependent=yes";

			}

			else {

				strParam += ",OuterHeight=" + nHeight + ",OuterWidth=" + nWidth;

				strParam += ",screenX=" + nX + ",screenY=" + nY;

				strParam += ",dependent=yes";

			}

		}

		else {

			strParam += ",height=" + nHeight + ",width=" + nWidth;

			strParam += ",left=" + nX + ",top=" + nY;

		}

		if (gbBsSafari)

		{

			if (window.gPopupWindow)

				window.gPopupWindow.close();		

			window.gPopupWindow = window.open(strURL, "", strParam);

			window.gPopupWindow.name = gstrPopupSecondWindowName;

			window.gPopupWindow.moveTo(nX, nY);

			window.gPopupWindow.document.location.reload();

		}	

		else

		{

			var wmTemp=null;

			if (gbBsKonqueror3)

			{

				if (window.gPopupWindow)

					window.gPopupWindow.close();

			}

			if (gbBsOpera&&gbBsMac)

			{

				wmTemp= window.open(document.location.href, "Temp", strParam);

			}

			window.gPopupWindow = window.open(strURL, gstrPopupSecondWindowName, strParam);

			if (!gbBsIE)

				window.gPopupWindow.focus();

				

			if (wmTemp)

				wmTemp.close();

		}



		if (gbBsNS4)

			setEventHandle();

		else if (gbBsIE4 || gbBsOpera7||gbBsKonqueror3)

			setTimeout("setPopupFocus();", 100);

	}

	return;

}



function setEventHandle()

{

	window.gPopupWindow.captureEvents(Event.CLICK | Event.BLUR);

	window.gPopupWindow.onclick = NonIEPopup_HandleClick;

	window.gPopupWindow.onblur = NonIEPopup_HandleBlur;

}



function setPopupFocus()

{

	window.gPopupWindow.focus();

}



function NonIEPopup_HandleBlur(e)

{

	window.gPopupWindow.focus();

}



function NonIEPopup_HandleClick(e)

{

	// Because navigator will give the event to the handler before the hyperlink, let's

	// first route the event to see if we are clicking on a Popup menu in a popup.

	document.routeEvent(e);



	// If a popup menu is active then don't do anything with the click

	if (window.gPopupWindow.gbInPopupMenu) {

		window.gPopupWindow.captureEvents(Event.CLICK);

		window.gPopupWindow.onclick = NonIEPopup_HandleClick;

		return false;

	}



	// Close the popup window

	if(e.target.href)

	{

		if(e.target.href.indexOf("javascript:")==-1) 

		{

			if (e.target.target=="")

				window.location.href = e.target.href;

			else

				window.open(e.target.href, e.target.target);

			this.close();

		}

	} 

	else

		this.close();

	return false;

}



function BSSCPopup_AfterLoad(nIndex, nToken, cuswidth, cusheight)

{

	if (!window.getPopupIFrame(nIndex).document) {

		_BSSCPopup2(getPopupURL(nIndex), cuswidth, cusheight);

		return;

	}

	

    if (!IsValidToken(nToken)) return;



	if (gbSafari3||gbAIR)

	{

			setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

		BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight);

		return;

	}

	

	if (gbBsNS6)

	{

		setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

		setTimeout("BSSCPopup_ResizeAfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

		return;

	}

	

	if ((window.getPopupIFrame(nIndex).document.readyState == "complete") &&

		(window.getPopupIFrame(nIndex).document.body != null)) {

			if (window.getPopupIFrame(nIndex).document.location.href.indexOf("about:blank") != -1) { // add this check. IE will use about:blank" as the default vaule for Iframe.

				window.getPopupIFrame(nIndex).document.location = getPopupURL(nIndex);

				setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

			}

			else

				{

					setAbsPopupURL(nIndex, window.getPopupIFrame(nIndex).document.location.href); // change URL to abs url.

					BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight);

				}

	} else {

		setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

	}

}



function BSSCPopup_ResizeAfterLoad(nIndex, nToken, cuswidth, cusheight)

{

	if (window.gbPopupTimeoutExpired) return;



    if (!IsValidToken(nToken)) return;



	getPopupDivStyle(nIndex).visibility = gBsStyVisHide;

	getPopupIFrameStyle(nIndex).visibility = gBsStyVisHide;

	if(gbBsIE)

	{

	    //fix for Popup Blank issue

	    getPopupIFrameStyle(nIndex).visibility = gBsStyVisShow;

		getPopupDivStyle(nIndex).visibility = gBsStyVisShow;

	}



	// Determine the width and height for the window

	_BSPSGetClientSize();



	var size = new BSSCSize(0, 0);



	if (cuswidth <= 0 || cusheight <= 0)

				BSSCGetContentSize(window.getPopupIFrame(nIndex), size);

			else {

		size.x = cuswidth;

		size.y = cusheight;

	}



	// Determine the width and height for the window

	var nWidth = size.x;

	var nHeight = size.y;



	// for small popup size, we should allow any size.

	// The popup size should be ok if bigger than 0

	if (nWidth < 0 || nHeight < 0) return; 	// there must be something terribly wrong.		

	

	//make the width and height same for all the browsers now

	nWidth = nWidth + 22;

	nHeight = nHeight + 10;

	

	getPopupDivStyle(nIndex).width = nWidth+ "px" ;

	getPopupDivStyle(nIndex).height = nHeight+ "px" ;

	

	getPopupShadowStyle(nIndex).width = nWidth + "px" ;

	getPopupShadowStyle(nIndex).height = nHeight + "px" ;

	

	

    	getPopupTopicStyle(nIndex).width = nWidth + "px" ;

	getPopupTopicStyle(nIndex).height = nHeight + "px" ;

	

	getPopupIFrameStyle(nIndex).width = nWidth + "px" ;

	getPopupIFrameStyle(nIndex).height = nHeight + "px" ;

		

	if (gbBsIE55 || gbBsNS6 || gbSafari3||gbAIR)

	{

		getPopupIFrameStyle(nIndex).top = 0;

		getPopupIFrameStyle(nIndex).left = 0;

	}

	

	var strURL = getPopupURL(nIndex);

	if (strURL.indexOf("#") != -1&&gbBsNS6)

		getPopupIFrame(nIndex).location.reload();

	else if (strURL.indexOf("#") != -1||gbBsNS6)

		getPopupIFrame(nIndex).location.href = strURL;  // reload again, this will fix the bookmark misunderstand in IE5.

		

	MoveDivAndShow(nIndex, nToken, cuswidth, cusheight);

}



function getScrollLeft()

{

	if( typeof( window.pageXOffset) == 'number' ) 

		return window.pageXOffset ;

	else if( document.body && ( document.body.scrollLeft || document.body.scrollTop ) ) 

		return document.body.scrollLeft ;

	else if( document.documentElement && document.documentElement.scrollLeft  ) 

		return document.documentElement.scrollLeft;

	else

		return 0 ;	

}



function getScrollTop()

{

	if( typeof( window.pageYOffset) == 'number' ) 

		return window.pageYOffset ;

	else if( document.body && document.body.scrollTop ) 

		return document.body.scrollTop ;

	else if( document.documentElement && document.documentElement.scrollTop  ) 

		return document.documentElement.scrollTop;

	else

		return 0 ;	

}



function getScrollLeftElement(el) 

{

    var x = 0;

    while (el && typeof (el.scrollLeft) == 'number') 

    {

        if (el == document.body) 

        {

            var top = document.body.scrollLeft || document.documentElement.scrollLeft;

            x += top;

        }

        else

            x += el.scrollLeft;

        el = el.offsetParent;

    }

    return x;

}



function getScrollTopElement(el) 

{

    var x = 0;

    while (el && typeof (el.scrollTop) == 'number') 

    {

        if (el == document.body) 

        {

            var top = document.body.scrollTop || document.documentElement.scrollTop;

            x += top;

        }

        else

            x += el.scrollTop;

        el = el.offsetParent;

    }

    return x;

}





function MoveDivAndShow(nIndex, nToken, cuswidth, cusheight)

{

	if (window.getPopupIFrame(nIndex).document.location.href != getAbsPopupURL(nIndex)) { // if redirect, reload again.

			window.getPopupIFrame(nIndex).document.location = getPopupURL(nIndex);

			if(gbAIR)

			{

				BSSCPopup_AfterLoad(nIndex ,nToken ,cuswidth ,cusheight );

			}

			else

				setTimeout("BSSCPopup_AfterLoad(" + nIndex + "," + nToken + "," + cuswidth + "," + cusheight + ")", 200);

			return;

	}



	// Determine the position of the window

	var nClickX = window.gnPopupClickX;

	var nClickY = window.gnPopupClickY;

	var nTop = 0;

	var nLeft = 0;

	

	var nWidth = parseInt(getPopupDivStyle(nIndex).width);

	var nHeight = parseInt(getPopupDivStyle(nIndex).height);

	

	if (nClickY + nHeight + 20 < gBsClientHeight + getScrollTop()) {

		nTop = nClickY + 10;

	} else {

		nTop = (getScrollTop() + gBsClientHeight) - nHeight - 20;

	}

	if (nClickX + nWidth < gBsClientWidth + getScrollLeft()) {

		nLeft = nClickX;

	} else {

		nLeft = (getScrollLeft() + gBsClientWidth) - nWidth - 20;

	}



	if(!gbBsIE55)

	{

		if (nTop < getScrollTop()) nTop  = getScrollTop() + nTop;

		if (nLeft< getScrollLeft())  nLeft = getScrollLeft() + nLeft;

		

		if(nTop+nHeight>gBsClientHeight + getScrollTop())

		{

			nTop = (getScrollTop() + gBsClientHeight) - nHeight - 20;

		}

	}

    

   	if (isNaN(nLeft))

		getPopupDivStyle(nIndex).left = nClickX + "px";	

	else

		getPopupDivStyle(nIndex).left = nLeft+ "px";	

	

	if (isNaN(nTop))

		getPopupDivStyle(nIndex).top = nClickY  + "px";

	else

		getPopupDivStyle(nIndex).top = nTop + "px";



	// Set the location of the background blocks

	getPopupShadowStyle(nIndex).left = 6 + "px";

	getPopupShadowStyle(nIndex).top = 6 + "px";

	if (gbBsIE55)

	{

		getPopupShadowStyle(nIndex).left = 4;

		getPopupShadowStyle(nIndex).top = 4;

	}

	

	if (gbBsMac&&gbBsIE4) {

		// Total hack on the iMac to get the IFrame to position properly

		getPopupIFrameStyle(nIndex).pixelLeft = 100;

		getPopupIFrameStyle(nIndex).pixelLeft = 0;

		// Explicitly call BSSCOnLoad because the Mac doesn't seem to do it

		getPopupIFrame(nIndex).window.BSSCOnLoad();

	}



	if(gbChrome)

	{

		BSSCPopup_PostWork(nIndex);	

	}

	else if (gbBsNS6&&IsDirty(nIndex))

		getElement(getPopupIFrameID(nIndex)).addEventListener("load", handleLoadNS, false);

	else

		BSSCPopup_Timeout(nIndex , nToken );

	return;

}



function	BSSCSize(x, y)

{

	this.x = x;

	this.y = y;

}



function BSSCGetContentSize(thisWindow, size)

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsNS4 && !gbSafari3 && !gbAIR)

		return;





	if ((gbBsMac&&gbBsIE4)||gbBsOpera7) {

		size.x = 320;

		size.y = 180;

		return;

	}



	// Resize the width until it is wide enough to handle the content

	// The trick is to start wide and determine when the scrollHeight changes

	// because then we know a scrollbar is necessary. We can then go back

	// to the next widest size (for no scrollbar)



	var ClientRate = gBsClientHeight / gBsClientWidth;



	

	var GoldenSize = new BSSCSize(0,0);

	GoldenSize.x = gBsClientWidth * getBMaxXOfParent();

	GoldenSize.y = gBsClientHeight *getBMaxYOfParent() ;



	if (ClientRate > gBRateH_W) {

		GoldenSize.y = GoldenSize.x * gBRateH_W;

	}

	else {

		GoldenSize.x = GoldenSize.y / gBRateH_W;

	}



	// Try to using parent specified max x.

	var x = 0;

	var maxgoldx = GoldenSize.x;

	var maxx = gBsClientWidth * getBMaxXOfParent();

	

	// This double resize causes the document to re-render (and we need it to)

	if (!gbBsIE5 && !gbChrome && !gbAIR)

		thisWindow.moveTo(10000,10000); // this is used to fix the flash on IE4.

	if(!gbAIR)

	{

	thisWindow.resizeTo(1, 1);

	thisWindow.resizeTo(maxgoldx, getScrollHeight(thisWindow) + getBscrollHeight());

	}

		

	var miny = getScrollHeight(thisWindow) + getBscrollHeight();

	

	if (miny > GoldenSize.y) // the popup does not fix in the parent wanted golden area. so try to expand itself as large as it can

	{

		if(gbBsIE55)

		{

			thisWindow.resizeTo(maxx , getScrollHeight(thisWindow) + getBscrollHeight());

		}

		

		miny = 	getScrollHeight(thisWindow) + getBscrollHeight();

		maxy = gBsClientHeight * getBMaxYOfParent();

		

		if (miny > maxy) { // the popup must have a scroll, OK let it be.

			miny = maxy;

			size.x = maxx;

			size.y = maxy;

			thisWindow.document.body.scroll = 'yes'; // At this time we do want to show scroll any more. so it will looks better a little.

		}

		else { // popup still can fit in the parent area by someway. now we choose the same h/w rate as parent.

			size.y = miny;

			

			//  downsize from maxx , now I try to using binary divide.

			x = maxx;

			deltax = -maxx/2;

			//j = 0;

			while (true) {

				x = x + deltax;

				if(!gbAIR)

				thisWindow.resizeTo(x, miny);

				diffy = getScrollHeight(thisWindow) + getBscrollHeight() - x * ClientRate;

				if (diffy >  gBpermitYDelta ) // it is higher than wanted, so x need to be wide a little bitter

					deltax = Math.abs(deltax) /2;

				else if (diffy <  -gBpermitYDelta) // it is shorter than wanted, so x need to be narrow a little bitter

					deltax = -Math.abs(deltax) /2;

				else 

					// the y is close enough to wanted.

					break;

				if (Math.abs(deltax) < gBpermitXDelta) // the next change is too slight and it can be ignore.

					break;

			}

			size.x = getScrollWidth(thisWindow); //+ gBscrollWidth;

			size.y = getScrollHeight(thisWindow);// + gBscrollHeight;	

			thisWindow.document.body.scroll = 'no';

		}

	}

	else {

		if (getScrollWidth(thisWindow) > maxgoldx) {

			size.x = maxx; 

			size.y = miny;	

			thisWindow.document.body.scroll = 'yes';

		}

		else {

			//  downsize from maxgoldx , now I try to using binary divide.			

			x = maxgoldx;

			deltax = -maxgoldx/2;

			while (true) {

				x = x + deltax;

				if(!gbAIR)

				thisWindow.resizeTo(x, miny);

				diffy = getScrollHeight(thisWindow) + getBscrollHeight() - x * getBRateH_W();

				if (diffy >  gBpermitYDelta ) // it is higher than wanted, so x need to be wide a little bitter

					deltax = Math.abs(deltax) /2;

				else if (diffy <  -gBpermitYDelta) // it is shorter than wanted, so x need to be narrow a little bitter

					deltax = -Math.abs(deltax) /2;

				else 

					// the y is close enough to wanted.

					break;

				if (Math.abs(deltax) < gBpermitXDelta) // the next change is too slight and it can be ignore.

					break;

			}

			size.x = getScrollWidth(thisWindow);

			size.y = getScrollHeight(thisWindow) ;

			thisWindow.document.body.scroll = 'no'; // At this time we do not want to show scroll any more. so it will looks better a little.



		}

	}

	if (gbBsNS6)

		size.y = size.y + 20 ;	

	

	if(!gbAIR)

	thisWindow.resizeTo(size.x, size.y);

	return;

}



function getScrollWidth(thisWindow)

{

   var w =  thisWindow.document.body.scrollWidth ? thisWindow.document.body.scrollWidth : thisWindow.window.pageXOffset  ; 

   return w ? w : 0;

} 



function getScrollHeight(thisWindow)

{

   var h = thisWindow.document.body.scrollHeight ? thisWindow.document.body.scrollHeight : thisWindow.window.pageYOffset  ; 

   return h ? h : 0;

}





function BSSCPopupParentClicked()

{

	if (!window.gbPopupTimeoutExpired) {

		return false;

	}

	

	document.onmousedown = gbOrignalOnMouseDown;



	// Simply hide the popup

	hideAll();



	window.gbPopupTimeoutExpired = false;



	return true;

}



function isInsideHyperLink(obj)

{

	if (obj&&obj!=getParentNode(obj))

	{

		if (obj.tagName=="A"||obj.tagName=="IMG" || obj.tagName=="VIDEO")

			return true;

		else

			return isInsideHyperLink(getParentNode(obj));

	}

	else

		return false;

}



function BSSCPopupClicked(e)

{

	if (!window.gbPopupTimeoutExpired) {

		return false;

	}



	var popupIFrame = getCurrentPopupIFrame();

	if (popupIFrame == null) {

		return true;

	}



	if (gbBsIE4 && (!((popupIFrame.window.event != null) &&

		(popupIFrame.window.event.srcElement != null) &&

		isInsideHyperLink(popupIFrame.window.event.srcElement)))) {

		document.onmousedown = gbOrignalOnMouseDown;

		

		// Simply hide the popup

		hideAll();

		window.gbPopupTimeoutExpired = false;

		return true;

	}

	else if (!gbAIR && (gbBsNS6 || gbChrome) && (!((e != null) &&

			(e.target!= null) && isInsideHyperLink(e.target))))

	{

	    document.removeEventListener("mousedown", BSSCPopupParentClicked,false);

	    if(gbOrignalOnMouseDown)

		    document.addEventListener("mousedown", gbOrignalOnMouseDown,false);

		// Simply hide the popup

		hideAll();

		window.gbPopupTimeoutExpired = false;

		return true;		

	}

}



//trace the mouse over's position for hotspot

function  BSPSPopupOnMouseOver(event)

{

	rhPopupEx.setClickPosition(event.clientX, event.clientY);	

	if (gbBsIE4 || gbBsOpera7||gbBsKonqueror3) {

		window.gnPopupClickX = event.clientX + getScrollLeft();

		window.gnPopupClickY = event.clientY + getScrollTop();

		window.gnPopupScreenClickX = event.screenX;

		window.gnPopupScreenClickY = event.screenY;

	} else if (gbBsSafari) {

		window.gnPopupClickX = event.clientX + getScrollLeft();

		window.gnPopupClickY = event.clientY + getScrollTop();

		window.gnPopupScreenClickX = event.screenX + window.screenX;

		window.gnPopupScreenClickY = event.screenY + window.screenY;

	} else if (gbBsNS4) {

		window.gnPopupClickX = event.pageX - window.pageXOffset;

		window.gnPopupClickY = event.pageY - window.pageYOffset;

		window.gnPopupScreenClickX = event.screenX - window.pageXOffset;

		window.gnPopupScreenClickY = event.screenY - window.pageYOffset;

	}

}



function BSSCHidePopupWindow()

{

	if (window.gPopupWindow != null) {

		if (gbBsNS4) {

			if ((typeof window.gPopupWindow != "undefined") && (!window.gPopupWindow.closed)) {

				window.gPopupWindow.close();

				window.gPopupWindow = null;

			}

		}

	}

	return;

}



// Add the PopupOnClick to the onclick array.

if (typeof(BsscRegisterOnClick) != "undefined")

{

	BsscRegisterOnClick(BsPopupOnClick);

}

//End to support previous popup functions



/// Section End  - Popup (JavaScript 1.0)



/// Section Begin - Embedded Stub (JavaScript 1.0)



function BSSCCreatePopupDiv()

{

	return;

}



function WritePopupMenuLayer()

{

	if (BsscHasExtJs()) {_WritePopupMenuLayer();}

}



function BSSCPopup(strURL, width, height)

{

	var re = new RegExp("'", 'g');

	strURL = strURL.replace(re, "%27");



	if (BsscHasExtJs())	{

		_BSSCPopup(strURL, width, height);

	}else{

		//Create a temporary window first to ensure the real popup comes up on top

		var wndTemp = null;

		if (!gbBsNS3) {

			wndTemp = window.open("", "temp", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=3,width=4");

		}

		// Create the real popup window

		var wndPopup = window.open(strURL, "BSSCPopup", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=300,width=400");

		// Close the temporary

		if (!gbBsNS3) {

			wndTemp.close();

		} else {

			wndPopup.focus();

		}

	}

}



var gbWndTemp = null, gbWndPopupLinks = null;

var gbstrParaTotal = "";



function PopupMenu_Invoke()

{

	if (typeof(wfRelatedTopic) == 'function' && typeof(IsFlashSupported) == 'function')

	{

		if (Number(gsSkinVersion) > 2 && IsFlashSupported())

		{

			return wfRelatedTopic(PopupMenu_Invoke.arguments);

		}

	}

	if (BsscHasExtJs()) {

		return _PopupMenu_Invoke(PopupMenu_Invoke.arguments);

	}

	if (gbBsNS3Before || gbBsIE3Before )	{

		var argLen 	= PopupMenu_Invoke.arguments.length;

		if (argLen < 5) {

			window.document.location.href = PopupMenu_Invoke.arguments[3];

			return false;

		}

		gbWndTemp = null;

		gbWndPopupLinks = null;

		gbstrParaTotal = "";

		for (var i = 0; i < (argLen - 2) / 2; i++) {

			var strParaLine = "";

			if (gbBsNS2){

				strParaLine += "<a href=\"";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 3];

				strParaLine += "\">"

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 2];

				strParaLine += "</a>";

			} else {

				strParaLine += "<a href=\"javascript:";

				strParaLine += "gotoUrl(\'";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 3];

				strParaLine += "\');\"";

				if (PopupMenu_Invoke.arguments[1] != '') {

					strParaLine += " TARGET='" + PopupMenu_Invoke.arguments[1] + "'";

				}

				strParaLine += ">";

				strParaLine += PopupMenu_Invoke.arguments[2 * i + 2];

				strParaLine += "</a>";

			}

			strParaLine += "<br>";

			gbstrParaTotal += strParaLine;

		}

		var nHeight = argLen * 15;

		var nWidth = 400;

		var strParam = "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=auto";

		strParam += ",height=" + nHeight + ",width=200,resizable";

		

		//Create a temporary window first to ensure the real popup comes up on top

		//var wndTemp = null;

		if (!gbBsNS3) {

			gbWndTemp = window.open("", "temp", "titlebar=no,toolbar=no,status=no,location=no,menubar=no,resizable=yes,scrollbars=yes,height=3,width=4");

		} 

		gbWndPopupLinks = window.open("", "popuplinks", strParam);



		setTimeout("Wait_PopupMenuReady()", 100);

	}

	return true;

}



function Wait_PopupMenuReady() 

{

	if (gbWndPopupLinks != null && "object" == typeof(gbWndPopupLinks.document)) {

		PopupMenu_InvokeReady();

	}

	else 

		setTimeout("Wait_PopupMenuReady()", 100);

}



function PopupMenu_InvokeReady()

{

	if (gbWndPopupLinks != null) {

		gbWndPopupLinks.document.open("text/html");

		gbWndPopupLinks.document.write("<html><head>");

		if (gbBsNS2) {

			gbWndPopupLinks.document.write("<base href=\"" + location +"\">");

		} else {

			//YJ: IE301,302 and NS3.x works fine

			gbWndPopupLinks.document.write("<");

			gbWndPopupLinks.document.write("script>");

			gbWndPopupLinks.document.write("function gotoUrl(aUrl) {opener.window.location=aUrl; close();}");

			gbWndPopupLinks.document.write("<");

			gbWndPopupLinks.document.write("/script>");

		}

		gbWndPopupLinks.document.write("<");

		gbWndPopupLinks.document.write("/head>");

		gbWndPopupLinks.document.write("<body onBlur=\'self.focus();\'>");

		gbWndPopupLinks.document.write(gbstrParaTotal);

		gbWndPopupLinks.document.write("</body></html>");

		gbWndPopupLinks.document.close();



		// Close the temporary

		if (!gbBsNS3 && gbWndTemp != null) {

			gbWndTemp.close();

		}else {

			gbWndPopupLinks.focus();

		}



		return true;

	}

	return false;

}



/// Section End - Embedded Stub (JavaScript 1.0)



//// Segment End -- (JavaScript 1.0)



//// Segment Begin -- (JavaScript 1.2)

/// Section Begin  - DHTM (JavaScript 1.2)



//Begin to support extended and dropdown text effects.

function IsParagraph(el)

{

	return( el.tagName == "P" || el.tagName.indexOf("H") == 0 ) ? true : false;

}



//Begin to support extended and dropdown text effects.

function kadovIsParagraph(el)

{

	return IsParagraph(el);

}





function InitEachChild(el)

{	

	for(var i=0; i<getChildNodes(el).length; i++)

	{

		var child = getChildNodes(el)[i];

		if( child.tagName == "SCRIPT" || child.tagName == "!" )

			continue;



		if( child.id != "" )

		{

			// to wipe out the onload effects

			if (gbBsIE4&&!gbBsMac)

			{

				var onLoadEffect = getAttribute(child.style, "x-on-pageload" );

				if( (onLoadEffect != null) && (onLoadEffect > "") )

					setAttribute(child.style, "x-on-pageload", "" );

			}

			

			var href = getAttribute(child,"href");

			if( href != null && href > "" && href.indexOf( "BSSCPopup" ) >= 0 )

				FilePopupInit(child.id); // Init for Popup

			else if( child.className == "dropspot" || child.className == "expandspot" || 

					 child.className == "glossterm" )

				TextPopupInit(child.id);// Init for Expanding/Glossary or DropDown text

			else if( child.className == "trigger")

				InitTrigger(child.id);// Init for Trigger

			else

			{

				InitEffects(child.id);// Init for DHTML effects

				CEngine.SetOneTargetInitialState( child.id );

			}

		}

		

		if( (child.tagName == "IMG") && (getAttribute(child,"dynsrc") > "") )

			child.start = "mouseover";// to start a AVI file. fileopen doesn't work



		InitEachChild(child);

	}

}



function kadovInitEachChild(el)

{	

	InitEachChild(el);

}



function RetrieveTextInner(el)

{	

	var x = "";

	if( (!el) || (el.tagName == "!") || (el.tagName == "SCRIPT" ))

		return x;



	if( IsParagraph(el) )

	{

		var strNewID = " ";

		if( el.id != "" )

			strNewID += "id=" + el.id + "_NewSpan ";

		x = "<span" + strNewID + "style='" + el.style.cssText + "'>" + el.innerHTML + "</span>";

	}

	else

	{

		for(var i=0; i<getChildNodes(el).length; i++)

			x += RetrieveTextInner( getChildNodes(el)[i] );

	}

	return x;

}



function kadovRetrieveTextInner(el)

{

	return 	RetrieveTextInner(el);

}



function RetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance )

{	

	var nTagOpen = strRawHTML.indexOf( strTagOpen, 0 );

	if( nTagOpen < 0 )

		return strRawHTML;



	var nTagClose = strRawHTML.indexOf( strTagClose, nTagOpen);

	if( nTagClose < nTagOpen )

		return strRawHTML;

		

	if( typeof(nDistance) == "number" && nDistance > 0 )

		if( (nTagClose - nTagOpen) != nDistance )

			return strRawHTML;

		

	var strCleanOnce = strRawHTML.substring(0, nTagOpen) + strRawHTML.substr(nTagClose + strTagClose.length) ;

	return 	RetrieveCleanHTML( strCleanOnce, strTagOpen, strTagClose );

}



function kadovRetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance )

{	

	return RetrieveCleanHTML( strRawHTML, strTagOpen, strTagClose, nDistance );

}	



function AdjustObjectTag(strRawHTML, nStartPos)

{// adjust object tag for related topics HTML control, because innerHTML misses out the item settings

	

	//Is there any DTC?

	var strDTCTagOpen = '<!--Metadata type="DesignerControl" startspan';

	var strDTCTagClose = '<!--Metadata type="DesignerControl" endspan-->';

	var nDTCTagOpen = strRawHTML.indexOf( strDTCTagOpen, nStartPos );

	if( nDTCTagOpen < 0 )

		return strRawHTML;

	var nDTCTagClose = strRawHTML.indexOf( strDTCTagClose, nDTCTagOpen );

	if( nDTCTagClose < nDTCTagOpen)

		return strRawHTML; // no Design Time Controls;

		

	//Is the DTC HTML Help Control?

	var strRTObjTagOpen = 'classid=clsid:ADB880A6-D8FF-11CF-9377-00AA003B7A11';

	var strRTObjTagClose = '</OBJECT>';

	var nRTObjTagOpen = strRawHTML.indexOf( strRTObjTagOpen, nDTCTagOpen );

	if( nRTObjTagOpen < nDTCTagOpen )

		return strRawHTML;

	var nRTObjTagClose = strRawHTML.indexOf( strRTObjTagClose, nRTObjTagOpen );

	if( nRTObjTagClose < nRTObjTagOpen )

		return strRawHTML; // is not a HTML help control

		

	// Is it a related Topics html help control?

	var strRTObjLabel = '<PARAM NAME=\"Command\" VALUE=\"Related Topics';

	if( strRawHTML.indexOf(strRTObjLabel, nRTObjTagOpen) < 0 )

		return strRawHTML;

	

	// does the commented object tag contain a items parameters		

	var strRTItemsOpen = '<param name="Items" value="';

	var strRTItemsClose = '$$**$$" >';

	var strRTItemsClose2 = '$$**$$">';



	var nRTItemsOpen = strRawHTML.indexOf(strRTItemsOpen, nDTCTagOpen);

	if( nRTItemsOpen < nDTCTagOpen )

		return strRawHTML;

	var nRTItemsClose = strRawHTML.indexOf(strRTItemsClose, nRTItemsOpen);

	if (nRTItemsClose == -1)

		nRTItemsClose = strRawHTML.indexOf(strRTItemsClose2, nRTItemsOpen);

	if( nRTItemsClose < nRTItemsOpen )

		return strRawHTML;

		

	// found a items string

	var strItems = strRawHTML.substring( nRTItemsOpen + strRTItemsOpen.length, nRTItemsClose);

	if( strItems.length < 1 )

		return strRawHTML;

	

	// to reconstruct the item(s) param tag(s)

	var strItemsArray = strItems.split('$$**$$');

	if( strItemsArray.length < 1 )

		return strRawHTML;

	var strRunTimeItemParam = "";

	for( var i = 0; i < strItemsArray.length; i++ )

	{

		strRunTimeItemParam += '<PARAM  NAME="Item' + (i+1);

		strRunTimeItemParam += '"' + '  VALUE="';

		strRunTimeItemParam += strItemsArray[i];

		strRunTimeItemParam += '">';

	}

	

	// to insert the reconstructed item params into runtime object tag

	var strAdjustedHTML = strRawHTML.substring(0,nRTObjTagClose) + strRunTimeItemParam + strRawHTML.substring(nRTObjTagClose, strRawHTML.length);

	return AdjustObjectTag(strAdjustedHTML, nDTCTagClose + strDTCTagClose.length);

}



function kadovAdjustObjectTag(strRawHTML, nStartPos)

{// adjust object tag for related topics HTML control, because innerHTML misses out the item settings

 return AdjustObjectTag(strRawHTML, nStartPos);

}



function TextPopupOnLoad( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	var src = null;

	if(el.id)

	{

		for (var i=0;i<gPopupData.length;i++)

			if (gPopupData[i].el==el.id)

			{

				src=gPopupData[i].popupId;

				break;

			}

	}

	if (!src)	

		return 0;



	var name = src;

	if( src.substr(0,1) == "#" ) 

		name = src.substr(1, src.length-1);

	var srcDiv = getElement(name);

	if( !srcDiv )

		return 1;



	//srcDiv.style.display = "none";

	return 0;

}

function kadovTextPopupOnLoad( el )

{

	return TextPopupOnLoad( el );

}

function getElementsByTag(obj,sTagName)

{

	if(obj.getElementsByTagName)

		return obj.getElementsByTagName(sTagName);

	else if(obj.all)

		return obj.all.tags(sTagName);

	return null;

}



function getElement(sID)

{

	if(document.getElementById)

		return document.getElementById(sID);

	else if(document.all)

		return document.all(sID);

	return null;

}



function getParentNode(obj)

{

	if(obj.parentNode)

		return obj.parentNode;

	else if(obj.parentElement)

		return obj.parentElement;

	return null;

}



function getChildNodes(obj)

{

	if(obj.childNodes)

	{

		var children = new Array();

		for (var i = 0; i < obj.childNodes.length; i++)

		{

			if (obj.childNodes[i].nodeType == 1)

				children[children.length] = obj.childNodes[i];

		}

		return children;

	}

	else if(obj.children)

		return obj.children;

	return null;	

}



function removeThis(obj)

{

	if(obj.parentNode)

		obj.parentNode.removeChild(obj);

	else

		obj.outerHTML="";

}



function TextPopup( el )

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsSafari && !gbBsNS6 && !gbBsKonqueror3 )

		return;

	

	if (window.event)

		window.event.cancelBubble = true;



	if( typeof(el) == "string" )

		el = getElement(el);



	if (!el||el==window)

		return;



	for(var i=0; i<getChildNodes(el).length; i++)

	{

		var child = getChildNodes(el)[i];

		if( child && (child.tagName == "IMG") )

		{

			if(child.className == "Twisties")

			{

				if( child.style && (child.style.display == "") )

					child.style.display = "none";

				else if(child.style)

					child.style.display = "";

			}

		}



		if( child && (child.tagName == "SPAN") )

		{

			if(child.className == "MTText")

			{

				if( child.style && (child.style.display == "") )

					child.style.display = "none";

				else if(child.style)

					child.style.display = "";

			}

		}

	}

	

	var src = null;	

	if(!src&&el.id)

	{

		for (var i=0;i<gPopupData.length;i++)

			if (gPopupData[i].el==el.id)

			{

				src=gPopupData[i].popupId;

				break;

			}

	}

	if(!src)

		return;

		

	var name = src;

	if( src.substr(0,1) == "#" ) 

	name = src.substr(1, src.length-1);



	var srcDiv = getElement(name);

	if( !srcDiv )

		return;



	if( srcDiv )

	{

		if( srcDiv.style.display == "" )

			srcDiv.style.display = "none";

		else

		{

			if(srcDiv.className == "expandtext")

			{

				var inner = RetrieveTextInner(srcDiv);

				if( inner == "" )

					inner = srcDiv.innerHTML;

				if(inner.indexOf("&nbsp;") != 0 && inner.indexOf(" ") != 0 && inner.indexOf("&#160;"))

				{

					//insertAdjacentHTML(srcDiv, 'afterBegin', "&nbsp");

					try

					{

						if(srcDiv.childNodes)

						{

							var firstChild = srcDiv.childNodes[0];

							var newText = document.createTextNode(" ");

							srcDiv.insertBefore(newText, firstChild);

						}

					}

					catch(e)

					{

					}

				}

			}



			srcDiv.style.display = "";

		}

	}

	if(gbBsIE4)

		event.returnValue=false;

	return;

}



function kadovTextPopup( el )

{

	TextPopup( el );

}



function FindParentParagraph( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	if( (!el) || el.tagName == "BODY" )

		return null;

	if( IsParagraph(getParentNode(el)) )

		return getParentNode(el);

	else

		return FindParentParagraph( getParentNode(el) );

}



function kadovFindParentParagraph( el )

{

	return FindParentParagraph( el );

}



//Begin HTML code invoked function

function RegisterEventHandler( obj, strEvent, strEventHandler )

{

	CCSSP.RegisterEventHandler( obj, strEvent, strEventHandler );

}



function kadovRegisterEventHandler( obj, strEvent, strEventHandler )

{

 RegisterEventHandler( obj, strEvent, strEventHandler );

}





function textPopupData(el, popupId)

{

	this.el = el;

	this.popupId = "#"+popupId;

}



var gPopupData = new Array();



function TextPopupInit( el, popupId)

{

	if (!gbBsIE4 && !gbBsOpera7 && !gbBsSafari && !gbBsNS6 && !gbBsKonqueror3)

		return;

		

	if( typeof(el) == "string" )

	{

		if (popupId)

		{

			gPopupData[gPopupData.length]=new textPopupData(el, popupId);

		}

		el = getElement(el);

	}

		

	if( el != null )

	{

		CCSSP.RegisterEventHandler( el, "onclick", "TextPopup(\"" + el.id +"\");" );

		CCSSP.RegisterEventHandler( window, "onload", "TextPopupOnLoad(\"" + el.id +"\");" );

	}

}



function kadovTextPopupInit( el, popupId)

{

	return TextPopupInit( el, popupId);

}

//End HTML code invoked function



//End to support extended and dropdown text effects.



//Begin to convert iWrite format to RoboEditor Format for DHTML effects

function InitTriggersInHead( )

{

  if( Object.xDelayedInitElements )

  {

     var x = Object.xDelayedInitElements;

     for(i=0; i<x.length; i++)

     	InitTrigger( x[i] );

  }

}



function kadovInitTriggersInHead( )

{

	InitTriggersInHead( );

}



//Begin HTML code invoked function

function FilePopupInit( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);



	if( el != null )

		CCSSP.RegisterEventHandler( el, "onmouseover", "BSPSPopupOnMouseOver(event);" );

}

function kadovFilePopupInit( el )

{

	FilePopupInit( el );

}



function InitTrigger( element, a_targets )

{

//	if( !gbBsIE4 )

	//	return;

	var srcElement = element;

	if( typeof(srcElement) == "string" )

	{

		srcElement = getElement(element,0);

		if(srcElement == null)

			return;

	}

	

	//if( !IsParentVisible(srcElement) )

	//	return;

	

	var targets = null;

	if(typeof(a_targets) != "undefined")

		targets = a_targets;

	if(!targets)

		targets = getAttribute(srcElement, "x-targets" );

	if (!targets)

		targets = getAttribute(srcElement.style,"x-targets");

	if (!targets)

		return;	

	var arrOneTarget = targets.split( "," );

	for( var i = 0; i < arrOneTarget.length; i ++ )

		bsscFXInit( element, arrOneTarget[i], null, null, null, null );

}



function kadovInitTrigger( element )

{

	InitTrigger( element )

}



function IsParentVisible( el )

{

	if( typeof(el) == "string" )

		el = getElement(el);

	if( (!el) || el.tagName == "BODY" )

		return true;

	if( el.style.display == 'none' ) //el.visibility == 'hidden' || 

		return false;

	else

		return IsParentVisible( getParentNode(el) );

}



function kadovIsParentVisible( el )

{

	return IsParentVisible( el );

}

function InitEffects( element, effectsList )

{

	//if( !gbBsIE4 )

	//	return;

	var srcElement = element;

	if( typeof(srcElement) == "string" )

	{

		srcElement = getElement(element,0);

		if(srcElement == null)

			return;

	}

	

	//if( !IsParentVisible(srcElement) )

	//	return;



	if(effectsList)

	{

		//srcElement.setAttribute("style", effectsList);

		var str = effectsList;

		var nStart = 0;

		var indx = str.indexOf(":", nStart);

		var effect = null;

		var value = null;

		while(nStart >= 0 && indx > 0 && indx < str.length)

		{

			effect = effectsList.substr(nStart, indx-nStart);

			var indx2 = str.indexOf(";", nStart);

			if(indx2 == -1)

				indx2 = str.length;

			value = effectsList.substr(indx+1, indx2);

			if(effect && value)

			    setAttribute(srcElement,effect, value);

			nStart = effectsList.indexOf("x-on", indx2+1);

			indx = str.indexOf(":", nStart);

		}

		

	}

	

	InitEffect( srcElement, "x-on-hover" );

	InitEffect( srcElement, "x-on-pageclick" );

	InitEffect( srcElement, "x-on-pageload" );

	InitEffect( srcElement, "x-on-trigger-1" );

	InitEffect( srcElement, "x-on-trigger-2" );

}



function kadovInitEffects( element )

{

	InitEffects( element );

}

//End HTML code invoked function



function InitEffect( element, prop )

{

	var values = null;

	if( getAttribute(element,prop))		

		values = getAttribute(element, prop );	

	else if( getAttribute( element, "currentStyle" )  && element.currentStyle.getAttribute)

		values = element.currentStyle.getAttribute( prop );

	else  if (element.style.getAttribute)

		values = element.style.getAttribute( prop );

		

	if( !values )

		return;

    

	var functions = new Array();

	var nIdx = 0, nStart = 0;

	var nNext = values.indexOf( "\)", 0);

	while( nNext >= 0 && nNext < values.length )

	{

		functions[nIdx] = values.substr( nStart, nNext-nStart+1);

		nStart = nNext + 1;

		nIdx++;

		nNext = values.indexOf( "\)", nStart);

	}

		

	for( var i=0; i<functions.length; i++)

	{

		var id = getAttribute(element, "id" );

		var translatedProp = TranslateProp(prop);



		var lp = functions[i].indexOf( "(" );

		var fnname = functions[i].substring(0, lp);

		var srcargs = functions[i].substring(lp+1, functions[i].length-1);

		

		var nClickTimes = 1;

		var arrForClickCount = srcargs.split( "," );

		for( var j = 0; j < arrForClickCount.length; j++ )

		{// to locate and get the "clicks=99" settings

			var nPageClick = arrForClickCount[j].indexOf("clicks");

			if( nPageClick >= 0 )

			{

				nPageClick = arrForClickCount[j].indexOf("=");

				if( nPageClick > 0 )

				{

					nClickTimes = arrForClickCount[j].substring( nPageClick + 1, arrForClickCount[j].length) * 1;

					break;

				}

			}

		}

		var args = srcargs;

		if( j < arrForClickCount.length )

		{// to strip out the "clicks=99" from the arguments string

			args = "";

			for( var k = 0; k < arrForClickCount.length; k ++ )

			{

				if( k != j )

				{

					args += arrForClickCount[k];

					if( k < arrForClickCount.length - 1 )

						args += ",";

				}

			}

		}

		bsscFXInit( null, id, translatedProp, fnname, args, nClickTimes );

	}

}



function kadovInitEffect( element, prop )

{

	InitEffect( element, prop );

}



function TranslateProp( prop )

{

	switch( prop )

	{

	case "x-on-hover" :     return "bsschover";

	case "x-on-pageclick" : return "bsscpageclick";

	case "x-on-pageload" :  return "bsscpageload";

	case "x-on-trigger-1" : return "bssctrigger1";

	case "x-on-trigger-2" : return "bssctrigger2";

	}

	return null;

}



function kadovTranslateProp( prop )

{

	return TranslateProp( prop );

}



//End to convert iWrite format to RoboEditor Format for DHTML effects



//Begin the definition of one entry to DHTML effects

function bsscFXInit( trigger_ID, target_ID, event_type, 

	action_type, action_setting, event_addional )

{

	//if( typeof(target_ID) != "string" )//MUST have a target_ID

	//	return; // we don't support Navigator yet

	

	if( typeof(event_type) == "string" )

		event_type = event_type.toLowerCase();

	if( typeof(action_type) == "string" )

		action_type = action_type.toLowerCase();

	if( typeof(action_setting) == "string" )

		 action_setting = action_setting.toLowerCase();

	

	// to get the target element then add it to the target list

	var eleTarget = CCSSP.GetObject( target_ID );

	if( (eleTarget != null) && (event_type != null) && (action_type != null) )

	{

		

		CEngine.AddOneTarget( target_ID, eleTarget );

		CEngine.BuildTargetObject(target_ID, event_type, action_type, action_setting, event_addional);

	}

	

	// to validate the trigger_ID parameter

	if( typeof(trigger_ID) == "string" && trigger_ID != "" )

		CEngine.BuildTriggerObject( trigger_ID, target_ID );

}	

//End the definition of one entry to DHTML effects



/// Section End  - DHTM (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM (JavaScript 1.2)



//Begin JavaScript libary for cross-platform positioning object.

function CCSSP(){} // constructor of CCSSP class



CCSSP.GetObject = function( obj )

{//convert object name string or reference into a valid object reference

	if( typeof(obj) == "object" )

		return obj;

	else if( typeof(obj) == "string" && obj != "")

	{

		if (gbBsNS6)

		    return getElement(obj);	

		else if( gbBsNS4 )

			return eval("document." + obj);

		else

			return eval("document.all(\"" + obj + "\")");

	}

	else

		return null;

}



CCSSP.MoveObjectTo = function(obj, x, y)

{//positioning an object at a specific pixel coordinate

	if( gbBsNS4 && !gbBsNS6) 

		obj.moveTo(x,y);

	else

	{

		if (x == '')

	        x = 0 ;

	    if (y == '')

	        y = 0 ;

	    obj.style.left = parseInt(x) + 'px';

	    obj.style.top = parseInt(y) + 'px'; 

	}

}



CCSSP.SetTimer = function(obj, timeout)

{

	if( obj.timer == null )

	{

		if(gbAIR)

		{

			obj.timer = setInterval(function(){CEngine.PerformAnimation( obj.aniIndex)}, timeout );

		}

		else

			obj.timer = setInterval("CEngine.PerformAnimation(" + obj.aniIndex + ")", timeout );

	}

}





CCSSP.MoveObjectBy = function(obj, dx, dy)

{//moveing a object by x and/or y pixel

	if (gbBsNS6)

	{

	    var left = parseInt(obj.style.left);

	    obj.style.setProperty('left',(left + dx ) + 'px',0) ;

	    var top =  parseInt(obj.style.top);

	    obj.style.setProperty('top' , (top + dy) + 'px' ,0);

	}

	else if( gbBsNS4 )

		obj.moveBy(dx,dy);

	else

	{

		obj.style.pixelLeft += dx;

		obj.style.pixelTop += dy;

	}

}



CCSSP.SetObjectBGColor = function(obj, color)

{//set the background color of an object

	if  (gbBsNS6)

	    obj.style.setProperty( "background-color" , color , 0);

	else if( gbBsNS4 )

		obj.bgColor = color;

	else

		obj.style.backgroundColor = color;

}



CCSSP.ShowObject = function(obj, bShow)

{// set the object to be visible or invisible

	if (gbBsNS6)

	    obj.style.setProperty('visibility', (bShow == true) ? 'visible' : 'hidden',null);

	else if( gbBsNS4 )

		obj.visibility = (bShow == true) ? 'show' : 'hide';

	else

		obj.style.visibility = (bShow == true) ? 'visible' : 'hidden';// when hidden, it still occupy some space.

}



CCSSP.GetObjectLeft = function(obj)

{// retrieve the x coordinate of a posionable object

	if (gbBsNS6)

	    return obj.style.left ;

	else if( gbBsNS4 )

		return obj.left;

	else

		return obj.style.pixelLeft;

}



CCSSP.GetObjectTop = function(obj)

{// retrieve the y coordinate of a posionable object

	if (gbBsNS6)

	    return obj.style.top ;

	else if( gbBsNS4 )

		return obj.top;

	else

		return obj.style.pixelTop;

}



CCSSP.GetObjectContainLeft = function(obj)

{// retrieve the x coordinate of a posionable object relative to it's parent element

	if( typeof(obj.pageX) != 'undefined')

		return obj.pageX;

	else if( typeof(obj.clientLeft) != 'undefined' )

		return obj.clientLeft;

	else

	    return obj.offsetLeft;	

}



CCSSP.GetObjectWindowLeft = function(obj)

{// retrieve the x coordinate of a posionable object relative to browser window

	if( gbBsNS4 && !gbBsNS6)

		return obj.pageX;

	else

	{

		var nOffsetWindowLeft = 0;

		for(var element = obj; element; element = element.offsetParent)

			nOffsetWindowLeft += CCSSP.GetObjectContainLeft(element);

		return nOffsetWindowLeft;

	}

}



CCSSP.GetObjectContainTop = function(obj)

{// retrieve the y coordinate of a posionable object relative to it's parent element

	if( typeof(obj.pageY) != 'undefined')

		return obj.pageY;

	else if( typeof(obj.clientTop) != 'undefined' && obj == document.body)

		return obj.clientTop;

	else

		return obj.offsetTop;	

}



CCSSP.GetObjectWindowTop = function(obj)

{// retrieve the y coordinate of a posionable object relative to browser window

	if( gbBsNS4 && !gbBsNS6)

		return obj.pageY;

	else

	{

		var nOffsetWindowTop = 0;

		for(var element = obj; element; element = element.offsetParent)

			nOffsetWindowTop += CCSSP.GetObjectContainTop(element);

		return nOffsetWindowTop;

	}

}



CCSSP.GetObjectHeight = function(obj)

{// retrieve the height of a posionable object

	if( gbBsNS4 && !gbBsNS6)

		return obj.clip.height;

	else

		return obj.offsetHeight;

}



CCSSP.GetObjectWidth = function(obj)

{// retrieve the width of a posionable object

	if( gbBsNS4 && !gbBsNS6)

		return obj.clip.width;

	else

		return obj.offsetWidth;

}



CCSSP.RegisterEventHandler = function( srcObj, rawEventName, funcHandler )

{ // to add the "funcHandler" as the "rawEventName" 's handler to the "srcObj" object,the original event handler will be combined



	if( srcObj == window && rawEventName == 'onload' )

	{

		var bSet = false;

		if( window.addEventListener )

		{

			window.addEventListener( 'load', new Function("event", funcHandler ),false);

			bSet = true;

		}

		else if( window.attachEvent )

		{

			window.attachEvent('onload', new Function("event", funcHandler ), false);

			bSet = true;

		}

		

		if( bSet )

			return;

	}

	

	if (gbBsNS4 && !gbBsNS6)

		return ;

		

	var oldHandler = "";



	if (gbBsMac &&gbBsIE4&&!gbBsIE5)

	{

		if (typeof(srcObj[rawEventName.toLowerCase()])=="unknown")

		{ //search for <SCRIPT> tag which define the event handler

			for( var i = 0; i < document.scripts.length; i++ ) 

			{

				var script = document.scripts[i];

				if( (script.htmlFor == srcObj.id || script.htmlFor == srcObj ) && script.event == rawEventName )

				{

					oldHandler = script.innerHTML;

					break;

				}

			}

		}

	}

	else

	{

		var oldInlineHandler = srcObj[rawEventName.toLowerCase()];

		if( oldInlineHandler != null && typeof(oldInlineHandler) != "undefined")

		{

			var functionDefinition = oldInlineHandler.toString();

			var bodyStart = functionDefinition.indexOf( "{" );

			var bodyEnd = functionDefinition.lastIndexOf( "}" );

			if( bodyStart > 0 || bodyEnd > bodyStart )

				oldHandler = functionDefinition.substr( bodyStart + 1, bodyEnd - bodyStart - 2 );

		}

		else if( gbBsIE4 )

		{ //search for <SCRIPT> tag which define the event handler

			for( var i = 0; i < document.scripts.length; i++ ) 

			{

				var script = document.scripts[i];

				if( (script.htmlFor == srcObj.id || script.htmlFor == srcObj ) && script.event == rawEventName )

				{

					oldHandler = script.innerHTML;

					break;

				}

			}

		}

	}

	if( oldHandler.indexOf(funcHandler) >= 0 )

		return;// to prevent register the funtion twice.



	if( gbBsNS4 ) // only "onload, onresize, onfocus" apply to window

	{// other raw events will apply to layer

		var noOn = rawEventName.substring(2, rawEventName.length);

		if( typeof(noOn) == "string" && noOn.length > 3 ) {

			if (srcObj.captureEvents)

				srcObj.captureEvents( Event[noOn.toUpperCase()] );

		}

	}

	

	var newHandler = oldHandler;

	if( newHandler.length == 0 )

		newHandler = funcHandler;

	else

		newHandler += "; " + funcHandler;	

	if ((gbBsNS6)&&(srcObj.addEventListener))

	    srcObj.addEventListener( noOn.toLowerCase(), new Function("event", newHandler ),false);

	else

	    srcObj[rawEventName.toLowerCase()] = new Function( newHandler );	

}



CCSSP.GetWindowHeight = function()

{// retrieve the height of available content in browser window

	if( gbBsNS4 )

		return window.innerHeight;

	else

		return document.body.clientHeight;

}



CCSSP.GetWindowBottom = function()

{// retrieve the bottom postion of browser window

	if( gbBsNS4 )

		return window.outerHeight + window.pageYOffset;

	else

		return document.body.clientHeight + getScrollTop();

}



CCSSP.GetWindowWidth = function()

{// retrieve the width of available content in browser window

	if( gbBsNS4 )

		return window.innerWidth;

	else

		return document.body.clientWidth;

}



CCSSP.GetWindowRight = function()

{// retrieve the right postion of browser window

	if( gbBsNS4 )

		return window.outerWidth + window.pageXOffset;

	else

		return document.body.clientWidth + getScrollLeft();

}



CCSSP.TrimString = function( objString, subtrim )

{// to trim the "subtrim" in the beginning and ending of a string object

	if( typeof(subtrim) != "string" || subtrim == null )

		return objString;

	var strHead = objString.substring(0, 1);

	var strRear = objString.substring(objString.length-1, objString.length);

	if( strHead != subtrim && strRear != subtrim )

		return objString;

	

	var spacePos = objString.indexOf(subtrim);

	if( spacePos < 0 )

		return objString;

	else if( spacePos == objString.length - 1 )

		return objString.substring(0, spacePos);

	else

	{

		var newString = objString.substring( spacePos + 1, objString.length);

		return CCSSP.TrimString( newString, subtrim );

	}

}



CCSSP.TrimSpace = function( objString )

{

	var Trim1 = CCSSP.TrimString( objString, " ");

	if( typeof(Trim1) != "string" || Trim1 == null )

	    return Trim1;

	var strHead = Trim1.substring(0, 1);

	if(strHead == "\"")

	    return CCSSP.TrimString( Trim1, "\"");

	return CCSSP.TrimString( Trim1, "\'");

}



CCSSP.GetEventElement = function( navEventObject )

{// to get the element who fired the current event

	if(gbBsNS4) 

		return navEventObject.target;

	else

		return event.srcElement;

}



CCSSP.PrepareFilter = function( Obj )

{//to prepare for making the filter work

	Obj.style.filter = "";

	if(Obj.style.position == "absolute" )

		return;

	if(gbBsIE7)

	{

		if( Obj.style.zoom != "")

			return;

		Obj.style.zoom = 1;

	}

	else

	{

		if(Obj.style.width != "" || Obj.style.height != "")

			return;

		Obj.style.height = CCSSP.GetObjectHeight(Obj);

	}

}



CCSSP.IsDescendant = function( progenitor, progeny )

{

	if( typeof(progeny) == "undefined" || progeny == null )

		return false;

	else if( progeny == progenitor )

		return true; 

	else if( progeny.id == progenitor.id ) 

		return true; 

	else if( getParentNode(progeny) == getParentNode(progenitor))

		return false;

	else

		return CCSSP.IsDescendant( progenitor, getParentNode(progeny));

}



CCSSP.IsTextTag = function( Obj )

{

	if( typeof( Obj.tagName ) == "undefined" )

		return false;

	return( Obj.tagName.indexOf("H") == 0 || Obj.tagName == "P" || 

			Obj.tagName == "FONT" || Obj.tagName == "SPAN" );

}



//End JavaScript libary for cross-platform positioning object.



/// Section End  - CCSSP DHTM (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM 1 (JavaScript 1.2)



//Begin the definition of class CTrigger

function CTrigger( TriggerElement )

{

	// object : the trigger element. Never be null. 

	this.eleTrigger = TriggerElement;

	

	// number : the click counter number: only 3 values: 0,1,2;

	this.nCounter = 0; 

	

	//object as associative array of string:

	// the associate target ID strings; one element at least.			

	this.objStrTarget = new Object();

	this.eleTrigger.style.cursor = "pointer";

	if( this.eleTrigger.tagName == "AREA" && getAttribute(this.eleTrigger,"href") == "" )

		setAttribute(this.eleTrigger , "href", "#"); // to make a hand cursor for image map

}



CTrigger.prototype.AddTargetID = function( strTargetID )

{// add one target ID string to the objStrTarget

	if( typeof(strTargetID) != "string" )

		return ;

	if( typeof(this.objStrTarget[strTargetID]) != "string" )

		this.objStrTarget[strTargetID] = strTargetID;

}



CTrigger.prototype.OnTriggerClick = function(event)

{// to activate all asociated target

	var strEventType = ( (this.nCounter++)% 2 == 0 ) ? 

		"bssctrigger1" : "bssctrigger2";

		

	// to enumerate associative target element's ID string

	for( var strTargetID in this.objStrTarget ) 

		CEngine.SendEventToOneTarget( strTargetID, strEventType ,event);

}

//End the definition of class CTrigger



//Begin the definition of class CTarget

function CTarget( TargetElement )

{

	// object : the target element. Never be null.

	this.eleTarget = TargetElement;

	this.objManager = new Object(); // object: the event manager

} 



CTarget.nPageClickCounter = 0;// static class property.



CTarget.prototype.GetAgencyObject = function(str_action_type,action_setting )

{// return the action agency ( effect )object's refernece 

	switch( str_action_type )

	{

	case "show":return new CAgencyShow( this.eleTarget, true ) ;

	case "hide":return new CAgencyShow( this.eleTarget, false ) ;



    case "flyin" : 

    	return new CAgencyFly(this.eleTarget, action_setting, true);

    case "flyout" : 

    	return new CAgencyFly(this.eleTarget, action_setting, false);

    case "spiralin" : 

    	return new CAgencySpiral(this.eleTarget, action_setting, true);

    case "spiralout" : 

    	return new CAgencySpiral(this.eleTarget, action_setting, false);

    case "zoomin" :

    	return new CAgencyZoom(this.eleTarget, action_setting, true);

    case "zoomout" : 

    	return new CAgencyZoom(this.eleTarget, action_setting, false);

    case "elastic" : 

		return new CAgencyElastic(this.eleTarget, action_setting);

		

    case "fadein" : 

    	return new CAgencyAlpha(this.eleTarget, action_setting, true) ;

    case "fadeout" :

    	return new CAgencyAlpha(this.eleTarget, action_setting, false) ;

    case "rockrollstatic" :

    case "rockroll" :

    	return  new CAgencyWave(this.eleTarget, action_setting, false) ;

 

    case "glow":

    	return  new CAgencyGlow(this.eleTarget,action_setting);

    case "dropshadow":

    	return new CAgencyDropShadow(this.eleTarget,action_setting);

    case "transition" :

    	return new CAgencyRevealTrans(this.eleTarget,action_setting) ;

    case "blur" :

    	return  new CAgencyBlur(this.eleTarget,action_setting) ;



    case "fliph" : // all these 4 do NOT need any parameters

    case "flipv" :

    case "invert":

    case "gray" :

    	return new CAgencyChangeFilter(this.eleTarget, str_action_type) ;

    

    case "fontchange": // the effects below change the style on the fly, so won't work in Navigator

    	return new CAgencyFontChange(this.eleTarget,action_setting) ;

    case "boderchange": 

    case "stylechange":

    	return new CAgencyChangeStyle(this.eleTarget,action_setting);



	default: return null;

	}

}



CTarget.prototype.SetEventManager = function( 

	one_event_type,str_action_type,action_setting,event_additional)

{// to set the event manager with specified action 

	if( typeof( one_event_type ) != "string" ||	

		typeof( str_action_type ) != "string"||

		typeof( action_setting ) != "string" )

		return false;

	if( typeof(this.objManager[one_event_type]) == "undefined" )

	{

		this.objManager[one_event_type] = new Object();

		this.objManager[one_event_type].length = 0;

	}

	

	var eventAgency = this.GetAgencyObject(str_action_type,action_setting);

	if( eventAgency != null )

	{

		var ct = this.objManager[one_event_type].length ++;

		this.objManager[one_event_type][ct] = eventAgency;

		

		if( one_event_type == "bsscpageclick" )

		{// to deal with the "number of pageclick" stuff

			if( typeof(event_additional) == "number" )

				this.objManager[one_event_type][ct].nPageClick = event_additional;

			else // set the default number 

				this.objManager[one_event_type][ct].nPageClick = 1;

			

			if( (typeof(this.objManager.nMinPageClickIndex) == "undefined") ||

			    (this.objManager[one_event_type][ct].nPageClick < 

					this.objManager[one_event_type][this.objManager.nMinPageClickIndex].nPageClick) )

				this.objManager.nMinPageClickIndex = ct;

		}

		

		//hide the object blindly,SetState function will take care of the final correct state

		if( ((one_event_type == "bsscpageclick") && 

			 (this.objManager[one_event_type][ct].nPageClick == 1)) ||

			one_event_type == "bsscpageload" ||

			one_event_type == "bssctrigger1" )

			CCSSP.ShowObject( this.eleTarget, false );

		

		if( one_event_type == "bssctrigger1" || one_event_type == "bssctrigger2" )

			if( typeof( this.strTriggerEvent ) == "undefined" )

				this.strTriggerEvent = ( one_event_type == "bssctrigger1" ) ? "bssctrigger2" : "bssctrigger1";

			

		return true;

	}

	return false;

}



CTarget.prototype.OnEvent = function( strBsscEvent,event )

{// response to the event ( bssc format )

	if( typeof(this.objManager[strBsscEvent]) == "object" )

	{ // to get the event agency from the event manager

		var eventAgency = this.objManager[strBsscEvent];

		for( var i = 0; i < eventAgency.length; i++ )

		{

			if( strBsscEvent == "bsscpageclick" && 

			 	eventAgency[i].nPageClick != CTarget.nPageClickCounter )

				 continue;

			else if( strBsscEvent == "bsschover" && event.type == "mouseout" )

				eventAgency[i].EndEffect();

			else // to invoke the unified function in effect object	

				eventAgency[i].UpdateEffect(); 

		}

	}

}



CTarget.prototype.SetState = function( strBsscEvent )

{

	if( typeof(this.objManager[strBsscEvent]) != "object" )

		return false;



	// to get the event agency from the event manager

	var eventAgency = this.objManager[strBsscEvent];

	

	if( strBsscEvent == "bsscpageclick" )

	{// we only set the initial state for the minium number of pageclick 

		if (this.objManager.nMinPageClickIndex == 'undefined')

		    this.objManager.nMinPageClickIndex = 0 ;

		eventAgency[this.objManager.nMinPageClickIndex].PrepareEffect();

		return true;

	}

	else

	{

		for( var i = 0; i < eventAgency.length; i++ )

			eventAgency[i].PrepareEffect(); // to invoke the unified function in effect object	 

		if( i > 0 )

			return true;

		else

			return false;

	}

}

//End the definition of class CTarget



//Begin the definition of CEngine class

function CEngine(){}// all properities are going be "class" properities



// object : as associative array of trigger objects

CEngine.objTrigger = new Object();

// object : as associative array of target objects 

CEngine.objTarget = new Object(); 



// Array : each element is a CAgencyXXX animation object

CEngine.arrAnimation = new Array();

CEngine.PerformAnimation = function( nIndex )

{// animation : update effects function

	CEngine.arrAnimation[nIndex].UpdateEffect();

}



CEngine.AddOneTrigger = function(TriggerID,TriggerElement)

{// add one Trigger object into the trigger array

	if( typeof(TriggerID) != "string" || TriggerElement == null ||

	    typeof(TriggerElement) != "object" )

		return;

	if( typeof(CEngine.objTrigger[TriggerID] ) != "object" )

		CEngine.objTrigger[TriggerID] = new CTrigger(TriggerElement);

}

	

CEngine.AddOneTarget = function(TargetID, TargetElement)

{// add one Target object into the target array

	if( typeof(TargetID) != "string" || TargetElement == null ||

		typeof(TargetElement) != "object" )

		return;

	if( typeof(CEngine.objTarget[TargetID]) != "object" )

		CEngine.objTarget[TargetID] = new CTarget( TargetElement );	

}



CEngine.SendEventToOneTarget = function(strTargetID, strBsscEvent,event )

{// to activate one target object

	if( typeof(CEngine.objTarget[strTargetID]) == "object" ) 

	{

		if( strBsscEvent == "bssctrigger1" || strBsscEvent == "bssctrigger2" )

		{//now, the "bssctrigger1" and "bssctrigger2" work like a toggle

			if( strBsscEvent == CEngine.objTarget[strTargetID].strTriggerEvent )

				strBsscEvent = (strBsscEvent == "bssctrigger1") ? "bssctrigger2" : "bssctrigger1";

			CEngine.objTarget[strTargetID].strTriggerEvent = strBsscEvent;

		}

		CEngine.objTarget[strTargetID].OnEvent( strBsscEvent,event );

	}

}



CEngine.SendEventToAllTarget = function( strBsscEvent,event )

{ //to activate all target associative to the BSSC event

	for( var strTargetID in CEngine.objTarget ) //to enumerate all target

		CEngine.SendEventToOneTarget( strTargetID, strBsscEvent,event );

}



CEngine.SetOneTargetInitialState = function( strTargetID )

{// only invoked after ALL effects for the target have been set

	if( typeof(CEngine.objTarget[strTargetID]) == "object" ) 

	{// to get target object

		var objTarget = CEngine.objTarget[strTargetID];

		if( objTarget.SetState( "bsscpageload" ) == false )

		{

			objTarget.SetState( "bsscpageclick" );

			objTarget.SetState( "bssctrigger1" );

		}

	}

}



CEngine.AdjustPageClickCounter = function()

{

	var nAdjustedClickCounter = CTarget.nPageClickCounter;

	var bAdjusted = false;

	for( var strTargetID in CEngine.objTarget ) //to enumerate all target

	{// try to find the minum pageCliclConter greater than CTarget.nPageClickCounter

		var objEventPageClick = CEngine.objTarget[strTargetID].objManager.bsscpageclick;

		if( objEventPageClick != null )

		{

			for( var i = 0; i < objEventPageClick.length; i++ )

			{

				var nOtherPageClick = objEventPageClick[i].nPageClick;

				if( nOtherPageClick == CTarget.nPageClickCounter )

					return;

				if( nOtherPageClick > CTarget.nPageClickCounter )

				{

					if( !bAdjusted )

					{

						nAdjustedClickCounter = nOtherPageClick;

						bAdjusted = true;

					}

					else if( nOtherPageClick < nAdjustedClickCounter )

						nAdjustedClickCounter = nOtherPageClick;

				}

			}

		}

	}

	CTarget.nPageClickCounter = nAdjustedClickCounter;

}



CEngine.OnPageLoad = function(event)

{ 	

	// first, to set all target's initial state

	for( var strTargetID in CEngine.objTarget )

		CEngine.SetOneTargetInitialState( strTargetID );

	

	// to invoke all target's onpageload handler

	CEngine.SendEventToAllTarget( "bsscpageload",event );

}



CEngine.OnPageClick = function(event)

{ // to invoke all target's onpageclick handler

   	var src = CCSSP.GetEventElement( arguments[0] );

   	if( src == null )

		return;

		

	var objClickedTrigger = null;

	for( var strTriggerID in CEngine.objTrigger )

	{ // to detect which trigger is clicked

		if( CCSSP.IsDescendant( CEngine.objTrigger[strTriggerID].eleTrigger,src) )

		{

			objClickedTrigger = CEngine.objTrigger[strTriggerID];

			break;

		}

	}

	

	if( objClickedTrigger != null) // the clicked trigger found

		objClickedTrigger.OnTriggerClick(event);

	else // no trigger is clicked

	{ // to send PageClick event to all target

		CTarget.nPageClickCounter++;

		CEngine.AdjustPageClickCounter();

		CEngine.SendEventToAllTarget( "bsscpageclick" ,event);

	}

}	



CEngine.OnMouseOver = function(event)

{ // to invoke all target's onpageload handler

	var src = CCSSP.GetEventElement( arguments[0] );

	if( src == null )

		return;

		

	var strHoveredTargetID = null;

	for( var strTargetID in CEngine.objTarget )

	{ // to detect which Target is hovering on

		if( CCSSP.IsDescendant( CEngine.objTarget[strTargetID].eleTarget, src ) )

	    {

			strHoveredTargetID = strTargetID;

			break;

	    }

	}

	

	if( strHoveredTargetID != null ) // the hovered target found

		CEngine.SendEventToOneTarget( strHoveredTargetID, "bsschover",event );

}



CEngine.BuildTargetObject = function(target_ID,event_type,action_type,

			action_setting, event_additional)

{// to build target object 

	// to get the target object

	if( typeof( CEngine.objTarget[target_ID] ) != "object" )

		return false;// the engine's AddOneTarget function might have failed.

	var TargetObject = CEngine.objTarget[target_ID];

	

	// to prepare the parameters for the event manager

	var arrEvent = event_type.split("|"); // to split the combined event_type string

	var arrAction = action_type.split("|");//to split the combined action_type string

	for( var trim = 0; trim < arrEvent.length; trim++ )

		arrEvent[trim] = CCSSP.TrimSpace(arrEvent[trim]);

	

	for( trim = 0; trim < arrAction.length; trim++ )

		arrAction[trim] = CCSSP.TrimSpace(arrAction[trim]);

	

	var arrSetting = new Array(); 

	if( typeof(action_setting) == "string" )

		arrSetting = action_setting.split("|");// to split the combined action_setting string

	// to calibrate the arrays

	for( var i = arrSetting.length; i < arrAction.length; i++ )

	{

		if( typeof(arrSetting[i]) != "string" )

			 arrSetting[i] = "";

	}				 



	// to prepare for dealing with the absolute posioning element

	TargetObject.eleTarget.ABSX = CCSSP.GetObjectLeft( TargetObject.eleTarget );

	TargetObject.eleTarget.ABSY = CCSSP.GetObjectTop( TargetObject.eleTarget );



	if( arrEvent.length > 1 )

	{// if event is combined, it must be : "bssctrigger1 | bssctrigger2"

		if( arrAction.length != 2 )

			return false; // if event is combined, there must be 2 actions

		for( i = 0 ; i < 2; i++ )

		{

			if( TargetObject.SetEventManager(arrEvent[i], arrAction[i], 

				arrSetting[i], event_additional) == false )

				return false; // the event manager has not been set up

		}

	}

	else // the event_type string is not combined

	{

		for( i = 0 ; i < arrAction.length; i++ )

		{

			TargetObject.SetEventManager(event_type, arrAction[i], arrSetting[i], event_additional);

			// to validate the event manager

			if( typeof(TargetObject.objManager[event_type]) != "object" ||

					typeof(TargetObject.objManager[event_type][i]) != "object" )

				return false; // the event manager has not been set up

		}

	}

	return true;

}



CEngine.BuildTriggerObject = function(trigger_ID, target_ID)

{// to build the trigger object

	var arrTrigger = trigger_ID.split("|"); // to split the combined trigger_ID string

	for( var i = 0; i < arrTrigger.length; i ++ )

	{// to get the trigger element then add it to the trigger list

		arrTrigger[i] = CCSSP.TrimSpace( arrTrigger[i] );

		var eleTrigger = CCSSP.GetObject( arrTrigger[i] );

		if( eleTrigger == null )

			continue; // the trigger_ID string in the HTML code maybe wrong

		CEngine.AddOneTrigger( arrTrigger[i], eleTrigger );



		// to get the target object

		if( typeof( this.objTrigger[arrTrigger[i]] ) != "object" )

			continue;// the engine's AddOneTarget function might have failed.

		CEngine.objTrigger[arrTrigger[i]].AddTargetID( target_ID );

	}

}

//End the definition of CEngine class



/// Section End  - CCSSP DHTM 1 (JavaScript 1.2)



/// Section Begin  - CCSSP DHTM 2 (JavaScript 1.2)



//Begin the definition of CAgencyXXXX classes



//Begin of the CAgencyShow definition

function CAgencyShow( element, bIsShow )

{

	this.ele = element;

	this.bIsShow = bIsShow;

}



CAgencyShow.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject( this.ele, !this.bIsShow );

}



CAgencyShow.prototype.UpdateEffect = function()

{

	CCSSP.ShowObject( this.ele, this.bIsShow );

}



CAgencyShow.prototype.EndEffect = function()

{

	CCSSP.ShowObject( this.ele, !this.bIsShow );

}

// End of the CAgencyShow definition



// Begin of CAgencyFly definition

function CAgencyFly( element, settings, bIsIn )

{

	this.ele = element;

	this.bIsIn = bIsIn;

	this.duration = 1000; // default

	this.direction = "right";



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

		

	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyFly.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencyFly.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var newX = this.startX*(1.0-percent) +  this.finalX*percent;

		var newY = this.startY*(1.0-percent) +  this.finalY*percent;

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencyFly.prototype.EndEffect = function()

{

	clearInterval( this.timer );

	this.timer = null;



	if( this.bIsIn ) // FlyIn

		CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	else // FlyOut

		CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencyFly.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );



	this.startX = 0;

	this.startY = 0;

	this.finalX = 0;

	this.finalY = 0; 

	

	var offsetLeft = CCSSP.GetObjectWindowLeft(this.ele) + this.ele.offsetWidth;

	var offsetTop = CCSSP.GetObjectWindowTop(this.ele) + this.ele.offsetHeight;

	var offsetRight = CCSSP.GetWindowRight();

	var offsetBottom = CCSSP.GetWindowBottom();



	if( this.bIsIn )

	{ // FlyIn

		this.finalX = this.ele.ABSX;

		this.finalY = this.ele.ABSY;



		switch( this.direction )

		{

		case "right": this.startX = offsetRight; this.startY = this.finalY; break;

		case "left": this.startX = -offsetLeft;  this.startY = this.finalY; break;

		case "down": this.startY = offsetBottom; this.startX = this.finalX; break;

		case "up":  this.startY = -offsetTop;    this.startX = this.finalX; break;

		case "downright":

  			this.startX = ( offsetBottom < offsetRight) ? offsetBottom : offsetRight;

			this.startY = this.startX;		break;

		case "upright":

  			this.startX = (offsetTop < offsetRight)? offsetTop : offsetRight;

			this.startY = -this.startX;		break;

		case "upleft":

			this.startX = -((offsetTop < offsetRight)? offsetTop : offsetRight);

			this.startY = this.startX;		break;

		case "downleft":

			this.startX = -(( offsetBottom < offsetRight) ? offsetBottom : offsetRight);

			this.startY = -this.startX;     break;

		}

	}

	else

	{ // FlyOut

		this.startX = this.ele.ABSX;

		this.startY = this.ele.ABSY;



		switch( this.direction )

		{

		case "right": this.finalX = offsetRight;  this.finalY = this.startY; break;

		case "left": this.finalX = -offsetLeft;   this.finalY = this.startY;  break;

		case "down": this.finalY = offsetBottom;  this.finalX = this.startX; break;

		case "up":  this.finalY = -offsetTop;     this.finalX = this.startX; break;

		case "downright":

  			this.finalX = ( offsetBottom < offsetRight) ? offsetBottom : offsetRight;

			this.finalY = this.finalX;		break;

		case "upright":

  			this.finalX = (offsetTop < offsetRight)? offsetTop : offsetRight;

			this.finalY = -this.finalX;		break;

		case "upleft":

			this.finalX = -((offsetTop < offsetRight)? offsetTop : offsetRight);

			this.finalY = this.finalX;		break;

		case "downleft":

			this.finalX = -(( offsetBottom < offsetRight) ? offsetBottom : offsetRight);

			this.finalY = -this.finalX;     break;

		}

	}

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyFly definition



// Begin of CAgencySpiral

function CAgencySpiral( element, settings, bIsIn )

{

	this.ele = element;

	this.bIsIn = bIsIn;

	this.duration = 1000; // default



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}



	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencySpiral.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencySpiral.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var rf = (this.bIsIn)? (1.0 - percent) : percent; 

		var t = (1.0-rf) * 4.0 * Math.PI

		var rxP = (this.bIsIn)? this.startX : this.finalX; 

		var ryP = (this.bIsIn)? this.startY : this.finalY; 

		var rx = (Math.abs(rxP) < 200) ? Math.abs(rxP) : 200;

		var ry = (Math.abs(ryP) < 200) ? Math.abs(ryP) : 200;



		var newX = Math.ceil(-rf*Math.cos(t)*rx) + this.ele.ABSX;

		var newY = Math.ceil(-rf*Math.sin(t)*ry) + this.ele.ABSY;

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencySpiral.prototype.EndEffect = function()

{

	clearInterval( this.timer );

	this.timer = null;

	

	if( this.bIsIn ) // In

		CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	else // Out

		CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencySpiral.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );

	this.startX = (this.bIsIn)? CCSSP.GetWindowRight() : this.ele.ABSX;

	this.startY = (this.bIsIn)? CCSSP.GetWindowBottom() : this.ele.ABSY;

	this.finalX = (this.bIsIn)? this.ele.ABSX : CCSSP.GetWindowRight();

	this.finalY = (this.bIsIn)? this.ele.ABSY : CCSSP.GetWindowBottom(); 

	

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of CAgencySpiral



// Begin of CAgencyElastic

function CAgencyElastic( element, settings)

{

	this.ele = element;

	this.duration = 1000; // default

	this.direction = "right";



	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

		

	if( this.ele.style.position != "absolute" )

		this.ele.style.position = "relative";

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyElastic.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, false );

}



CAgencyElastic.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var newX = this.startX;

		var newY = this.startY;

		var rf = Math.exp(-percent*3);

		var t = percent * 1.5 * Math.PI

		var rx = (Math.abs(this.startX) > Math.abs(this.startY)) ? this.startX : this.startY;

		switch (this.direction )

		{

		case "left":   

		case "right" : newX = rf*Math.cos(t)*rx + this.ele.ABSX; break;

		case "up":	   

		case "down" :  newY = rf*Math.cos(t)*rx + this.ele.ABSX; break;

		}

		CCSSP.MoveObjectTo(this.ele, newX, newY);

		CCSSP.SetTimer(this,20);

	}

}



CAgencyElastic.prototype.EndEffect = function()

{

	CCSSP.MoveObjectTo(this.ele, this.finalX, this.finalY);

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyElastic.prototype.ResetParameters = function()

{

	CCSSP.ShowObject(this.ele, true );

	this.startX = this.ele.ABSX;

	this.finalX = this.ele.ABSX;

	this.startY = this.ele.ABSY;

	this.finalY = this.ele.ABSY;

	

	switch (this.direction)

	{ 

	case "left":  this.startX = -this.ele.offsetWidth; break;

	case "right": this.startX = this.ele.offsetWidth;  break;

	case "up":    this.startY = -this.ele.offsetHeight;break;

	case "down":  this.startY = this.ele.offsetHeight; break;

	}

	CCSSP.MoveObjectTo(this.ele, this.startX, this.startY);

	this.startTime = (new Date()).getTime();

}

// End of CAgencyElastic



// Begin of CAgencyZoom

function CAgencyZoom( element, settings, bIsIn)

{

	this.ele = element;

	this.duration = 1000; // default

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}



	this.bIsIn = bIsIn;

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyZoom.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, false);

}



CAgencyZoom.prototype.UpdateEffect = function()

{

	if( this.timer == null )

		this.ResetParameters();



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else

	{

		var nFactorIn = Math.ceil(50+50*percent);

		var nFactorOut = Math.ceil(100+200*(1-percent));

		var AlterFontsize = ((this.bIsIn)? nFactorIn : nFactorOut) + "%";

		var AlterFactor = ((this.bIsIn)? nFactorIn : nFactorOut) / 100;

		

		this.UpdateEffectAllChildren(this.ele, AlterFontsize, AlterFactor);

		var arr ;

		if (this.ele.all)

		    arr = this.ele.all ;

		else

		    arr = this.ele.getElementsByTagName ('*');

		for(var index = 0; index < arr.length; index++)

			this.UpdateEffectAllChildren(arr[index], AlterFontsize, AlterFactor);

			

		CCSSP.SetTimer(this,20);

	}

}



CAgencyZoom.prototype.UpdateEffectAllChildren = function(child, FontSize, Factor)

{

	if( CCSSP.IsTextTag(child) )

		child.style.fontSize = FontSize;

	else

	{

		if( typeof(child.orgWidth) == "number" )

			child.style.width = Factor * child.orgWidth;

		if( typeof(child.orgHeight) == "number" )

			child.style.height = Factor * child.orgHeight;

	}

}



CAgencyZoom.prototype.EndEffect = function()

{

	this.EndEffectAllChildren(this.ele);

	var arr ;

	if(this.ele.all)

	    arr = this.ele.all ;

	else

	    arr = this.ele.getElementsByTagName('*');

	for(var index = 0; index < arr.length; index++)

		this.EndEffectAllChildren(arr[index]);

	

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyZoom.prototype.EndEffectAllChildren = function( child )

{	

	if( CCSSP.IsTextTag(child) )

		child.style.fontSize = child.orgFontSize;

	else

	{

		if( typeof(child.intactWidth) != "undefined" )

		{

			child.width = child.intactWidth;

			child.height = child.intactHeight;

		}

		else if( typeof(child.style.intactPixelWidth) != "undefined" )

		{

			child.style.pixelWidth = child.style.intactPixelWidth;

			child.style.pixelHeight = child.style.intactPixelHeight;

		}

	}

}



CAgencyZoom.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	this.ResetParametersAllChildren( this.ele );

	var arr ;

	if (this.ele.all)

	    arr = this.ele.all ;

	else

	    arr = this.ele.getElementsByTagName('*');

	for(var index = 0; index < arr.length; index++)

		this.ResetParametersAllChildren(arr[index]);

		

	this.startTime = (new Date()).getTime();

}



CAgencyZoom.prototype.ResetParametersAllChildren = function( child )

{

	CCSSP.ShowObject(child, true );

	if( (child.tagName == "DIV") && (getParentNode(child).tagName == "TD") )

		child.width = "100%";// if the div is inside a cell of table, we need the this hack

	

	if( CCSSP.IsTextTag(child) )

		child.orgFontSize = child.style.fontSize;

	else

	{

		if( child.width > "" || child.height > "" )

		{

			child.orgWidth = child.intactWidth = child.width;

			child.orgHeight = child.intactHeight = child.height;

		}

		else if( ( typeof(child.orgWidth) != "number" ) && (typeof(child.orgHeight) != "number") )

		{

			child.orgWidth = child.style.intactPixelWidth = child.style.pixelWidth;

			child.orgHeight = child.style.intactPixelHeight = child.style.pixelHeight;

		}

	}

}

// End of CAgencyZoom



//// the following effects will use IE's exclusive "filter" function ////

// Begin of CAgencyAlpha definition

function CAgencyAlpha( element, settings, bIsIn )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;

	this.bIsIn = bIsIn;



	// to set the default value

	this.startOpacity = (this.bIsIn) ? 0 : 100;

	this.endOpacity = (this.bIsIn) ? 100 : 0;

	

	this.duration = 1000; // default

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "speed" : this.duration = 100000/arrOneSet[1]; break;

		}

	}

	

	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyAlpha.prototype.PrepareEffect = function()

{// to set the visual filter function

	// the visual filter ONLY work when set by "Width and Height" or

	// absolute position for DIV, SPAN and normal tag ( such as p )

	// but, "absolute" cause the following elements overlap, so:

	CCSSP.PrepareFilter( this.ele );

	CCSSP.ShowObject(this.ele, !this.bIsIn );

}



CAgencyAlpha.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( this.timer == null )

		this.ResetParameters();

	if( typeof(this.ele.filters.alpha) != "object" )

	{

		this.EndEffect();

		return;

	}



	var percent = ((new Date()).getTime() - this.startTime)/this.duration;

	if( percent >= 1.0 )

		this.EndEffect();

	else if( typeof(this.ele.filters.alpha) == "object" )

	{

		this.ele.filters.alpha.opacity = this.startOpacity*(1.0-percent) + this.endOpacity*percent;

		CCSSP.SetTimer(this,20);

	}

}



CAgencyAlpha.prototype.EndEffect = function()

{// to remove the visual filter function

	clearInterval( this.timer );

	this.timer = null;

	this.ele.style.filter = "";

	CCSSP.ShowObject(this.ele, this.bIsIn );

}



CAgencyAlpha.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	CCSSP.ShowObject(this.ele, true );

	this.ele.style.filter = "alpha(opacity=" + this.startOpacity + ")";

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyAlpha definition



// Begin of CAgencyWave definition

function CAgencyWave( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	this.duration = 0; // default

	this.strength = 10;

	this.freq = 1;

	this.lightstrength = 1;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "duration" : this.duration = 100000/arrOneSet[1]; break;

		case "strength" : this.strength = arrOneSet[1]; break;

		case "freq" : this.freq = arrOneSet[1]; break;

		case "lightstrength" : this.lightstrength = arrOneSet[1]; break;

		}

	}



	this.timer = null;

	this.aniIndex = CEngine.arrAnimation.length;

	CEngine.arrAnimation[this.aniIndex] = this;

}



CAgencyWave.prototype.PrepareEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);



	CCSSP.ShowObject(this.ele, true );

}



CAgencyWave.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( this.timer == null )

		this.ResetParameters();

	if( (typeof(this.ele.filters) == "undefined") || (typeof(this.ele.filters.wave) != "object" ) )

	{

		this.EndEffect();

		return;

	}



	if( this.duration > 0 )

	{

		var percent = ((new Date()).getTime() - this.startTime)/this.duration;

		if( percent >= 1.0 )

		{

			this.EndEffect();

			return;

		}

	}

	

	this.ele.filters.wave.phase += 5;

	this.ele.filters.wave.phase %= 100;

	CCSSP.SetTimer(this,50);

}



CAgencyWave.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	clearInterval( this.timer );

	this.timer = null;

}



CAgencyWave.prototype.ResetParameters = function()

{

	this.PrepareEffect();

	this.ele.style.filter = "wave(strength=" + this.strength + ",freq=" + 

	 this.freq +", lightstrength=" + this.lightstrength +",phase=0);";

	this.startTime = (new Date()).getTime();

}

// End of the CAgencyWave definition



// Begin of CAgencyGlow definition

function CAgencyGlow( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.glowColor = "green";

	this.glowStrength = "3";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "color" : this.glowColor = arrOneSet[1]; break;

		case "strength" : this.glowStrength = arrOneSet[1]; break;

		}

	}

}



CAgencyGlow.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

	if( this.ele.style.backgroundColor != "" )

	{//style.backgroundColor somehow stop the visual filter

		this.ele.intactBackgroundColor = this.ele.style.backgroundColor;

		this.ele.style.backgroundColor = "";

	}

}



CAgencyGlow.prototype.UpdateEffect = function()

{// to set the visual filter function

	this.PrepareEffect();

	this.ele.style.filter = "glow(Color=" + this.glowColor + ", Strength=" + 

		this.glowStrength + ", enabled=true" +")";

}



CAgencyGlow.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	if( typeof(this.ele.intactBackgroundColor) != "undefined" )

		this.ele.style.backgroundColor = this.ele.intactBackgroundColor;

}

// End of the CAgencyGlow definition



// Begin of CAgencyDropShadow definition

function CAgencyDropShadow( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.shadowColor = "black"; 

	this.shadowOffx = "1";

	this.shadowOffy = "1";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "color" : this.shadowColor = arrOneSet[1]; break;

		case "offx" : this.shadowOffx = arrOneSet[1]; break;

		case "offy" : this.shadowOffy = arrOneSet[1]; break;

		}

	}

}



CAgencyDropShadow.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

	

	if( this.ele.style.backgroundColor != "" )

	{//style.backgroundColor somehow stop the visual filter

		this.ele.intactBackgroundColor = this.ele.style.backgroundColor;

		this.ele.style.backgroundColor = "";

	}

}



CAgencyDropShadow.prototype.UpdateEffect = function()

{// to set the visual filter function

	this.PrepareEffect();

	this.ele.style.filter = "dropshadow(color=" + this.shadowColor + ", offx=" + 

		this.shadowOffx + ", offy=" + this.shadowOffy + ")";

}



CAgencyDropShadow.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

	if( typeof(this.ele.intactBackgroundColor) != "undefined" )

		this.ele.style.backgroundColor = this.ele.intactBackgroundColor;

}

// End of the CAgencyDropShadow definition



// Begin of CAgencyRevealTrans definition

function CAgencyRevealTrans( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.duration = 1.0; //The value is specified in seconds.milliseconds format (0.0000).

	this.transition = 0;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "type" : this.transition = arrOneSet[1]; break;

		case "duration" : this.duration = 100/arrOneSet[1];	break;

		}

	}

}



CAgencyRevealTrans.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject( this.ele, false);

}



CAgencyRevealTrans.prototype.UpdateEffect = function()

{// to set the visual filter function

	if( typeof( this.ele.filters.RevealTrans ) == "object" )

	{

		if( this.ele.filters.RevealTrans.status == 2 )

			this.ele.filters.RevealTrans.stop();  

	}



	this.PrepareEffect();

	

	this.ele.style.filter = "RevealTrans(duration=" + this.duration + 

		", transition=" + this.transition + ")";

	

    if( typeof( this.ele.filters.RevealTrans ) == "object" )

    {

		this.ele.filters.RevealTrans.apply();

		CCSSP.ShowObject( this.ele, true);

		this.ele.filters.RevealTrans.play();  

	}

	else

		CCSSP.ShowObject( this.ele, true);

}



CAgencyRevealTrans.prototype.EndEffect = function()

{

    if( typeof( this.ele.filters.RevealTrans ) == "object" )

		this.ele.filters.RevealTrans.stop();  

	this.ele.style.filter = "";

}

// End of the CAgencyRevealTrans definition



// Begin of CAgencyBlur definition

function CAgencyBlur( element, settings )

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.strength = "5";

	this.direction = "90";

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "strength" : this.strength = arrOneSet[1]; break;

		case "direction" : this.direction = arrOneSet[1]; break;

		}

	}

}



CAgencyBlur.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyBlur.prototype.UpdateEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);

	this.ele.style.filter = "blur(strength=" + this.strength + 

		", direction=" + this.direction + ")";

}



CAgencyBlur.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

}

// End of the CAgencyBlur definition



// Begin of CAgencyChangeFilter definition

function CAgencyChangeFilter( element, settings ) // flipH, flipV, invert, grey,

{// because of "visual filter" style, this won't work in Navigator

	this.ele = element;



	// to set the default value

	this.filterFunction = settings;

}



CAgencyChangeFilter.prototype.PrepareEffect = function()

{

	CCSSP.PrepareFilter(this.ele);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyChangeFilter.prototype.UpdateEffect = function()

{// to set the visual filter function

	CCSSP.PrepareFilter(this.ele);

	this.ele.style.filter = this.filterFunction;

}



CAgencyChangeFilter.prototype.EndEffect = function()

{// to remove the visual filter function

	this.ele.style.filter = "";

}

// End of the CAgencyChangeFilter definition



// The effects below change the style on the fly, so they won't work in Navigator



// Begin of CAgencyFontChange definition, 

function CAgencyFontChange( element, settings )

{//this class can be replace by CAgencyChangeStyle,provided the "settings" is standard CSS string.

	this.ele = element;

	

	// to retrieve the original font style

	this.RetrieveOldFont( this.ele );

	

	// to set the default font to change

	this.newfontFamily = this.ele.oldFontFamily;

	this.newfColor = this.ele.oldColor;

	this.newtextDecoration = this.ele.oldTextDecoration;

	this.newfontWeight = this.ele.oldFontWeight;

	this.newfontStyle = this.ele.oldFontStyle;

	this.newfontSize = this.ele.oldFontSize;

	this.newBackgroundColor = this.ele.oldBackgroundColor;

	

	var arrAllSet = settings.split(",");

	for( var i = 0; i < arrAllSet.length; i ++ )

	{// to retrieve the setting

		arrAllSet[i] = CCSSP.TrimSpace(arrAllSet[i]);

		var arrOneSet = arrAllSet[i].split("=");

		for( var j = 0; j < arrOneSet.length; j++ )

			arrOneSet[j] = CCSSP.TrimSpace(arrOneSet[j]);

		switch( arrOneSet[0] )

		{

		case "font-family" : this.newfontFamily = arrOneSet[1]; break;

		case "color" : this.newfColor = arrOneSet[1]; break;

		case "underline" : this.newtextDecoration = (arrOneSet[1]=="on")? "underline" : "none"; break;

		case "bold" : this.newfontWeight = (arrOneSet[1]=="on")? "bold" : "normal"; break;

		case "italic" : this.newfontStyle = (arrOneSet[1]=="on")? "italic" : "normal"; break;

		case "size" : this.newfontSize = arrOneSet[1]; break;

		case "background-color" : this.newBackgroundColor = arrOneSet[1]; break;

		}

	}

}



CAgencyFontChange.prototype.RetrieveOldFont = function(objChild)

{

	if( typeof(objChild.oldFontFamily) == "undefined" )

		objChild.oldFontFamily = objChild.style.fontFamily;

	if( typeof(objChild.oldColor) == "undefined" )

		objChild.oldColor = objChild.style.color;

	if( typeof(objChild.oldTextDecoration) == "undefined" )

		objChild.oldTextDecoration = objChild.style.textDecoration;

	if( typeof(objChild.oldFontWeight) == "undefined" )

		objChild.oldFontWeight = objChild.style.fontWeight;

	if( typeof(objChild.oldFontStyle) == "undefined" )

		objChild.oldFontStyle = objChild.style.fontStyle;

	if( typeof(objChild.oldFontSize) == "undefined" )

		objChild.oldFontSize = objChild.style.fontSize;

	if( typeof(objChild.oldBackgroundColor) == "undefined" )

		objChild.oldBackgroundColor = objChild.style.backgroundColor;

}



CAgencyFontChange.prototype.PrepareEffect = function()

{

	// as for expanding text, the child is created after the constructor called

	var arr = this.ele.getElementsByTagName ('*');

	for(var index = 0; index < arr.length; index++)

		this.RetrieveOldFont(arr[index]);

	CCSSP.ShowObject(this.ele, true );

}



CAgencyFontChange.prototype.UpdateEffect = function()

{// to change the font

	this.PrepareEffect();

	this.UpdateEffectAllChildren( this.ele );

	var arr = this.ele.getElementsByTagName ('*');

	for( var index = 0; index < arr.length; index++)

		this.UpdateEffectAllChildren(arr[index]);

}



CAgencyFontChange.prototype.UpdateEffectAllChildren = function(objChild)

{

	objChild.style.fontFamily = this.newfontFamily;

	objChild.style.color = this.newfColor;

	objChild.style.textDecoration = this.newtextDecoration;

	objChild.style.fontWeight = this.newfontWeight;

	objChild.style.fontStyle = this.newfontStyle;

	objChild.style.fontSize = this.newfontSize;

	objChild.style.backgroundColor = this.newBackgroundColor;

}



CAgencyFontChange.prototype.EndEffect = function()

{// to reinstate the original font style

	this.EndEffectAllChildren( this.ele );

	var arr = this.ele.getElementsByTagName ('*');

	for( var index = 0; index < arr.length; index++)

		this.EndEffectAllChildren(arr[index]);

}



CAgencyFontChange.prototype.EndEffectAllChildren = function( objChild )

{

	if( typeof(objChild.oldFontFamily) != "undefined" )

		objChild.style.fontFamily = objChild.oldFontFamily;

	if( typeof(objChild.oldColor) != "undefined" )

		objChild.style.color = objChild.oldColor;

	if( typeof(objChild.oldFontWeight) != "undefined" )

		objChild.style.fontWeight = objChild.oldFontWeight;

	if( typeof(objChild.oldFontStyle) != "undefined" )

		objChild.style.fontStyle = objChild.oldFontStyle;

	if( typeof(objChild.oldFontSize) != "undefined" )

		objChild.style.fontSize = objChild.oldFontSize;

	if( typeof(objChild.oldTextDecoration) != "undefined" )

		objChild.style.textDecoration = objChild.oldTextDecoration;

	if( typeof(objChild.oldBackgroundColor) != "undefined" )

		objChild.style.backgroundColor = objChild.oldBackgroundColor;

}

// End of the CAgencyFontChange definition



// Begin of the CAgencyChangeStyle definition

function CAgencyChangeStyle( element, settings )

{//this class can be replace by CAgencyChangeStyle,provided the "settings" is standard CSS string.

	this.ele = element;

	

	// to retrieve the original style

	this.oldstyle = this.ele.style.cssText;

	

	// to set the default style

	this.newStyle = this.oldstyle;

	

	if( typeof(settings) == "string" && settings.length > 1 )

		this.newStyle = this.oldstyle + " " + settings;

}



CAgencyChangeStyle.prototype.PrepareEffect = function()

{

	CCSSP.ShowObject(this.ele, true );

}



CAgencyChangeStyle.prototype.UpdateEffect = function()

{// to change the style

	this.ele.style.cssText = this.newStyle;

}



CAgencyChangeStyle.prototype.EndEffect = function()

{// to reinstate the original style

	this.ele.style.cssText = this.oldStyle;

}

// End of the CAgencyChangeStyle definition



//End the definition of CAgencyXXXX classes



//Begin to collaborate with other event handler settings 

CCSSP.RegisterEventHandler( window, "onload", "CEngine.OnPageLoad(event);BSSCOnLoad(event);InitTriggersInHead(event);");

CCSSP.RegisterEventHandler( document, "onclick", "CEngine.OnPageClick(event);BSSCOnClick(event);");

CCSSP.RegisterEventHandler( document, "onmouseover", "CEngine.OnMouseOver(event);BSSCOnMouseOver(event);" );

CCSSP.RegisterEventHandler( document, "onmouseout", "CEngine.OnMouseOver(event);BSSCOnMouseOut(event);" );

CCSSP.RegisterEventHandler( window, "onunload", "BSSCOnUnload();");







// function related to autosize popup, custom popup and textonly popup

var gMsgSeparator = "::";



function isInsidePopup()

{

	return (window.name.indexOf("BSSCPopup")!=-1);

}



if(isLocal && (gbChrome || gbBsNS6))

{

	if(window.addEventListener)

		window.addEventListener("message", onRcvContentSizeMsg, false);

}



function getDocHeight(D) {

    return Math.max(

        Math.max(D.body.scrollHeight, D.documentElement.scrollHeight),

        Math.max(D.body.offsetHeight, D.documentElement.offsetHeight),

        Math.max(D.body.clientHeight, D.documentElement.clientHeight)

    );

}



function getDocWidth(D) {

    return Math.max(

        Math.max(D.body.scrollWidth, D.documentElement.scrollWidth),

        Math.max(D.body.offsetWidth, D.documentElement.offsetWidth),

        Math.max(D.body.clientWidth, D.documentElement.clientWidth)

    );

}



function trim(stringToTrim) {

	return stringToTrim.replace(/^\s+|\s+$/g,"");

}



function parseMsgData(strData)

{

	var nvPairs = strData.split(","); //get name value pairs

	if(nvPairs.length>0)

	{

		var obj = new Object();

		for(var i=0; i<nvPairs.length; i++)

		{

			trim(nvPairs[i]);

			var nvPair = nvPairs[i].split(":");

			if(nvPair.length == 2)

			{

				obj[nvPair[0]] = nvPair[1];

			}

		}

		return obj;

	}

	return null;

}





function replyContentSize(targetWnd)

{

	targetWnd.postMessage("sendContentSize" + gMsgSeparator + ",height:" + getDocHeight(document) + ",width:" + getDocWidth(document), "*");

}







var	gLastHeight = 0;

var	gLastWidth = 0;

function onRcvContentSizeMsg(event)

{

    var msg = event.data.split(gMsgSeparator);

    var msgType = msg[0];

    var msgData = msg[1];

    switch(msgType)

    {

    case "sendContentSize":

	    {

	       		var  	stepSize = 50;

			

			var obj  = parseMsgData(msgData);

	       		rhPopupEx.setHeight(parseInt(obj.height));

			rhPopupEx.setWidth(parseInt(obj.width));

			

			if(typeof(rhPopupEx.gLastGoodHeight) == 'undefined' || rhPopupEx.gLastGoodHeight == 0)

			{

				rhPopupEx.gLastGoodHeight = rhPopupEx.height;

				rhPopupEx.gLastGoodWidth = rhPopupEx.width;

			}

			else

			{

				if(rhPopupEx.height < gLastHeight) 

				{

					rhPopupEx.gLastGoodHeight = rhPopupEx.height;

					rhPopupEx.gLastGoodWidth = rhPopupEx.width;

				}

			}



			if(rhPopupEx.canDoBetter())

			{

				gLastWidth = rhPopupEx.width;

				gLastHeight = rhPopupEx.height;

				

				rhPopupEx.resizePopup(rhPopupEx.width+stepSize, 1);

				requestContentSize(event.source);

				

			}

			else{

				rhPopupEx.setHeight(rhPopupEx.gLastGoodHeight);

				rhPopupEx.setWidth(rhPopupEx.gLastGoodWidth);

				rhPopupEx.gLastGoodHeight = 0;

				rhPopupEx.gLastGoodWidth = 0;

				gLastHeight = 0;

				gLastWidth = 0;

				rhPopupEx.resizeMoveAndShowPopup();

			}

	    }

	break;

     case "getContentSize":

	replyContentSize(event.source);

        break;

     case "updateLinks":

	BSSCPopup_ChangeTargettoParent(document);

	break;

     case "getCpHTML5Size":

	replyCpHTML5Size(event.source, msgData);

	break;

     case "setCpHTML5Size":

	onGetReplyCpHTML5Size(event.source, msgData);

	break;

    }

}



function requestContentSize(targetWnd)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("getContentSize" + gMsgSeparator + " ", "*");

}



function requestUpdateLinks(targetWnd)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("updateLinks" + gMsgSeparator + " ", "*");

}



function onPopupClicked(e)

{

	var target = null;

	var popupIFrame = rhPopupEx.getPopupIFrame();

	if(!e) 

		e = popupIFrame.contentWindow.event;

	if(e)

	{

		if(e.target)

			target = e.target;

		else 

			target = e.srcElement;

	}

	if(!gbAIR)

	{

		if(target && isInsideHyperLink(target))

			return;

	}

	if(window.removeEventListener)

		window.removeEventListener("mousedown", onPopupParentClicked, false);

	else if(window.document.detachEvent)

		window.document.detachEvent('onmousedown', onPopupParentClicked);

	rhPopupEx.removePopup();

}



function onPopupParentClicked(e)

{

	if(window.removeEventListener)

		window.removeEventListener("mousedown", onPopupParentClicked, false);

	else if(window.document.detachEvent)

		window.document.detachEvent('onmousedown', onPopupParentClicked);

	rhPopupEx.removePopup();

}



var rhPopupEx = new RHPopupEx;

function RHPopupEx()

{

	this.strPopupID = 'BSSCPopup';

	this.strPopupShadowID = 'BSSCPopupShadow';

	this.strPopupTopicID = 'BSSCPopupTopic';

	this.strPopupIFrameID = 'BSSCPopupIFrame';

	this.strPopupIFrameName = 'BSSCPopupIFrameName';

	this.strPopupURL = '';

	this.strBookmark = '';

	this.width = 0;

	this.height = 0;

	this.clientWidth = 0;

	this.clientHeight = 0;

	this.gHeight = 0;

	this.gWidth = 0;

	this.bCustomHeight = false;



	//scrollbar height and width

	this.scrollbarheight = 20; //can we ask the browser for this info

	this.scrollbarwidth = 20;



	this.init = function()

	{

		this.getVisibilityStyle();

		this.strPopupURL = '';

		this.strBookmark = '';

		this.width = 0;

		this.height = 0;

		this.clientWidth = 0;

		this.clientHeight = 0;

		this.gHeight = 0;

		this.gWidth = 0;

		this.removePopup();

	}



	this.setPopupURL = function(strURL)

	{

		var indx = strURL.indexOf("#");

		if(indx != -1)

		{

			this.strPopupURL = strURL.substring(0, indx);

			this.strBookmark = strURL.substring(indx);

		}

		else

			this.strPopupURL = strURL;

	}

	this.setWidth = function(width)

	{

		this.width = width;

	}

	this.setHeight = function(height)

	{

		this.height = height;

	}

	this.setClickPosition= function(x, y)

	{

		this.clickX = x + getScrollLeft();

		this.clickY = y + getScrollTop();

	}



	this.createPopup= function(strURL, width, height)

	{

		this.init();

		if ("undefined" != typeof(width) && "undefined" != typeof(height)) {

			this.setWidth(width);

			this.setHeight(height);

			this.bCustomHeight = true;

		}

		if(typeof(strURL) == 'undefined' || strURL == '')

			return false;

		this.setPopupURL(strURL);

		this.createPopupContainer();

	}



	this.createPopupContainer = function()

	{

		// DO NOT SET Width and height for the div, otherwize it will make IE4 popup do not work when view the topic alone.

		var strPopupDiv = "<div id='" + this.strPopupID + "' style='position:absolute; top:-100; left:0; z-index:600; visibility:hidden;'>";

		strPopupDiv += "<div id='" + this.strPopupShadowID + "' style=\"position:absolute;top:0; left:0; background-color:#C0C0C0;\"></div>";

		strPopupDiv += "<div id='" + this.strPopupTopicID + "' style=\"position:absolute;top:0; left:0;  background-color:#FFFFFF;border:1px #000000 outset;"; 

		if(gbSafari3 && gbBsIsMobile)

			strPopupDiv += "overflow:auto; -webkit-overflow-scrolling:touch;";

		strPopupDiv += "\">";

		strPopupDiv += "<iframe height=\"10px\" width=\"200px\" title=\"Popup Window\" id='" + this.strPopupIFrameID + "' name='" + this.strPopupIFrameName + "' src='" + this.strPopupURL + "' frameborder=0 scrolling=auto";

		strPopupDiv += " onload=\"rhPopupEx.OnLoadRHPopup();\"";

		strPopupDiv += "></iframe></div>";  

		strPopupDiv += "</div>";



		var oBody = getElementsByTag(document, "body")[0];

		if( typeof(oBody) != "object" )

			return;



		insertAdjacentHTML(oBody, "beforeEnd", strPopupDiv);

	}



	this.removePopup = function()

	{

		var popup = this.getPopupContainer();

		if(popup)

			removeThis(popup);

	}



	this.getPopupContainer = function()

	{

		var elem  = document.getElementById(this.strPopupID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupIFrame = function()

	{

		var elem  = document.getElementById(this.strPopupIFrameID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupShadow = function()

	{

		var elem  = document.getElementById(this.strPopupShadowID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}

	this.getPopupTopic = function()

	{

		var elem  = document.getElementById(this.strPopupTopicID);

		if(typeof(elem) != 'undefined' && elem != null)

			return elem;

		return null;

	}



	this.hidePopup = function()

	{

		this.getPopupContainer().style.visibility = this.strStyVisHide;

		this.getPopupIFrame().style.visibility = this.strStyVisHide;

	}



	this.showPopup = function()

	{

		this.getPopupContainer().style.visibility = this.strStyVisShow;

		this.getPopupIFrame().style.visibility = this.strStyVisShow;

	}



	this.getVisibilityStyle = function()

	{

		if (gbBsNS4&&!gbBsNS6)

		{

			this.strStyVisShow	= "show";

			this.strStyVisHide	= "hide";

		}

		else

		{

			this.strStyVisShow	= "visible";

			this.strStyVisHide	= "hidden";

		}

	}



	this.getClientWndSize = function () {

	    var viewportwidth;

	    var viewportheight;



	    // the more standards compliant browsers (mozilla/netscape/opera/IE7) use window.innerWidth and window.innerHeight

	    if (typeof window.innerWidth != 'undefined') {

	        viewportwidth = window.innerWidth;

	        viewportheight = window.innerHeight;

	    }

	    // IE6 in standards compliant mode (i.e. with a valid doctype as the first line in the document)

	    else if (typeof document.documentElement != 'undefined'

         && typeof document.documentElement.clientWidth != 'undefined' && document.documentElement.clientWidth != 0) {

	        viewportwidth = document.documentElement.clientWidth;

	        viewportheight = document.documentElement.clientHeight;

	    }

	    // older versions of IE

	    else {

	        viewportwidth = document.getElementsByTagName('body')[0].clientWidth;

	        viewportheight = document.getElementsByTagName('body')[0].clientHeight;

	    }

	    this.clientWidth = viewportwidth;

	    this.clientHeight = viewportheight;

	    //golden ratio

	    this.gHeight = this.clientHeight * 0.8;

	    this.gWidth = this.clientWidth * 0.8;

	    

	    this.clientWidth -= this.scrollbarwidth;

	    this.clientHeight -= this.scrollbarheight; 

	}



	this.resizePopup = function(width, height)

	{

		//set height and width

		this.getPopupContainer().style.width = width + "px" ;

		this.getPopupContainer().style.height = height + "px" ;

	

		this.getPopupShadow().style.width = width + "px" ;

		this.getPopupShadow().style.height = height + "px" ;	

	

    		this.getPopupTopic().style.width = width + "px" ;

		this.getPopupTopic().style.height = height + "px" ;

	

		this.getPopupIFrame().style.width = width + "px" ;

		this.getPopupIFrame().style.height = height + "px" ;

	}



	this.getPopupContentSize = function()

	{

		var wnd = this.getPopupIFrame().contentWindow;

		this.setHeight(getDocHeight(wnd.document));

		this.setWidth(getDocWidth(wnd.document));

	}



	this.canDoBetter = function()

	{

		if(this.width < this.gWidth /*&& this.height > this.gHeight*/)

			return true;

	}



	this.computePopupWndSize = function()

	{

		if(!gbChromeLocal)

		{

			try

			{

				this.getPopupContentSize();



			//try to check if we have available width, increasing the width may decrease the height for reflowable content

			//whenever a change is detected we save that size

			//increasing width by an amount does not always decrease height, but increasing further may decrease it based on the 

			//reflow content

			

			var  	stepSize = 50;

			var	lastWidth = 0;

			var	lastHeight = 0;

			var lastGoodHeight = this.height;

			var lastGoodWidth = this.width;



			while(this.canDoBetter())

			{

				lastWidth = this.width;

				lastHeight = this.height;

				this.resizePopup(this.width+stepSize, 1);

				this.getPopupContentSize();

				//if no change in height detected

				if(this.height < lastHeight) //may be there is no reflow content to reduce height on increasing width

				{

					lastGoodHeight = this.height;

					lastGoodWidth = this.width;

					

				}

				//alert("height = " + this.height + "width=" + this.width)

			}



			//adding extra 20 pixel in height to be sure no scroll bar comes even if content fits in size computed

			lastGoodHeight += 20;

			//adding extra 5 pixel in width

			lastGoodWidth += 5;



			this.setHeight(lastGoodHeight);

			this.setWidth(lastGoodWidth);



			this.resizeMoveAndShowPopup();

			}

			catch(e)

			{

				requestContentSize(this.getPopupIFrame().contentWindow);

			}

		}

		else

			requestContentSize(this.getPopupIFrame().contentWindow);

	}



	this.resizeMoveAndShowPopup = function()

	{

		var bNeedHScroll = false;

		var bNeedVScroll = false;



		if(this.height > this.gHeight)

		{

			this.setHeight(this.gHeight);

			//need vertical scroll bars

			bNeedVScroll = true;

			this.setWidth(this.width+this.scrollbarwidth);

		}		

		if(this.width > this.gWidth)

		{

			this.setWidth(this.gWidth);

			//need horizontal scroll bars

			bNeedHScroll = true;

			this.setHeight(this.height+this.scrollbarheight);

		}



		var nClickX = this.clickX;

		var nClickY = this.clickY;

		var nTop = 0;

		var nLeft = 0;

		var shadowpos = 5; //shadow pos relative to popup frame

	

		var scrollTop = getScrollTop();

		var scrollLeft = getScrollLeft();



		if (nClickY + this.height + shadowpos < this.clientHeight + scrollTop) {

			nTop = nClickY;

		} else {

			nTop = nClickY - this.height - shadowpos;

			if(nTop < scrollTop)

			{

				nTop = (scrollTop + this.clientHeight) - this.height - shadowpos;

				if(nTop < scrollTop)

				{

					nTop = scrollTop;

					this.height = this.clientHeight - shadowpos;

					//need vertical scroll bars

					if(bNeedVScroll == false)

					{

						bNeedVScroll = true;

						this.setWidth(this.width+this.scrollbarwidth);

					}

				}

			}

		}

		if (nClickX + this.width + shadowpos < this.clientWidth + scrollLeft) {

			nLeft = nClickX;

		} else {

			nLeft = nClickX - this.width - shadowpos;

			if(nLeft < scrollLeft)

			{

				nLeft = (scrollLeft + this.clientWidth) - this.width - shadowpos;

				if(nLeft < scrollLeft)

				{

					nLeft = scrollLeft;

					this.width = this.clientWidth - shadowpos;

					//need horizontal scroll bars

					if(bNeedHScroll == false)

					{

						bNeedHScroll = true;

						this.setHeight(this.height+this.scrollbarheight);

					}

				}

			}

		}





		//set height and width

		this.resizePopup(this.width, this.height);



		//set position

		this.getPopupContainer().style.left = nLeft + "px";

		this.getPopupContainer().style.top = nTop + "px";



		// Set the location of the background blocks

		this.getPopupShadow().style.left = shadowpos + "px";

		this.getPopupShadow().style.top = shadowpos + "px";



		if(this.strBookmark != '')

		{

			//alert(this.strBookmark);

			this.getPopupIFrame().contentWindow.location.href = this.strPopupURL + this.strBookmark;

		}



		try{

			BSSCPopup_ChangeTargettoParent(this.getPopupIFrame().contentWindow.document);

		}catch(e)

		{

			//comes here for chrome local

			requestUpdateLinks(this.getPopupIFrame().contentWindow);

		}

		this.showPopup();

		this.postWork();

	}



	this.postWork = function()

	{

		try{

			if(gbBsIsMobile == false)

			{

				if (window.addEventListener){  

					this.getPopupIFrame().contentWindow.addEventListener('click', onPopupClicked, false);  

				} else if (window.document.attachEvent){  

					this.getPopupIFrame().contentWindow.document.attachEvent('onclick', onPopupClicked);

				}

			}

		}catch(e)

		{

			//alert popup does not close on clicking on it, valid for chrome local

		}



		if(window.addEventListener)

		{

			window.addEventListener("mousedown", onPopupParentClicked, false);

			window.document.addEventListener("touchstart", onPopupParentClicked, false);

		}

		else if(window.document.attachEvent)

			window.document.attachEvent('onmousedown', onPopupParentClicked);



	}



	this.OnLoadRHPopup = function()

	{

		rhPopupEx.hidePopup();



		if(gbBsIE4 && rhPopupEx.getPopupIFrame().contentWindow.document.location.href.indexOf("about:blank") != -1)

		{

			rhPopupEx.getPopupIFrame().contentWindow.document.location.href = rhPopupEx.strPopupURL;

			return;

		}

		

		this.getClientWndSize();

		if (rhPopupEx.width == 0 || rhPopupEx.height == 0) 

		{

			rhPopupEx.computePopupWndSize();

		}

		else

			rhPopupEx.resizeMoveAndShowPopup();



	}

}



function supports_video() {

  return !!document.createElement('video').canPlayType;

}



function supports_mp4_video()

{

	if(!supports_video()) 

		return false;

	var v = document.createElement("video");

  	var playType = v.canPlayType('video/mp4');

	//alert(playType);

	if(playType == "" || playType == "no")

		return false;

	else

		return true;

}



function getUrlParam(paramName, url)

{

  if(url == null || url == 'undefined')

        url = document.location.href;

  paramName = paramName.replace(/[\[]/,"\\\[").replace(/[\]]/,"\\\]");

  var regexS = "[\\?&]"+paramName+"=([^&#]*)";

  var regex = new RegExp(regexS);

  var results = regex.exec(url);

  if( results == null )

    return "";

  else

    return results[1];

}



function send_flv_command(strMultimediaFlvName, strMultimediaFlvCommand)

{

	try

	{

		if(strMultimediaFlvName != null && typeof(strMultimediaFlvName) != undefined)

		{

			var flashMediaPlayer = document.getElementById(strMultimediaFlvName);

			if(flashMediaPlayer != null && typeof(flashMediaPlayer) != undefined)

			{

				if(strMultimediaFlvCommand != null && typeof(strMultimediaFlvCommand) != undefined)

				{

					flashMediaPlayer.TakeMultimediaAction(strMultimediaFlvCommand.replace("%20", " "));

				}

			}

		}

	}

	catch(err)

	{

		//alert(strMultimediaFlvName + ' ' + strMultimediaFlvCommand);

	}

}



function onLoad_FLV_Player(strMultimediaFlvName)

{

	if(strMultimediaFlvName != null && typeof(strMultimediaFlvName) != undefined)

	{

		var strMultimediaFlvNameHRef = getUrlParam('flv_name');

		if(strMultimediaFlvNameHRef != null && typeof(strMultimediaFlvNameHRef) != undefined)

		{

			if(strMultimediaFlvNameHRef == strMultimediaFlvName)

			{

				var strMultimediaFlvCommand = getUrlParam('flv_cmd');

				send_flv_command(strMultimediaFlvName, strMultimediaFlvCommand);

			}

		}

	}

}



function requestCpHTML5Size(targetWnd, iframeid)

{

	if(targetWnd && targetWnd.postMessage)

		targetWnd.postMessage("getCpHTML5Size" + gMsgSeparator + ",id:"+ iframeid, "*");

}



function replyCpHTML5Size(targetWnd, msgData)

{

	var obj  = parseMsgData(msgData);

	

	var pc = getProjectContainer();



	

	

	targetWnd.postMessage("setCpHTML5Size" + gMsgSeparator + ",id:" + obj.id + ",height:" + parseFloat(pc.style.height) + ",width:" + parseFloat(pc.style.width), "*");

}



function onGetReplyCpHTML5Size(targetWnd, msgData)

{

	var obj  = parseMsgData(msgData);

	var iframeelem = getElement(obj.id);

	if(typeof iframeelem != 'undefined')

	{

		iframeelem.style.width = obj.width + "px" ;

		iframeelem.style.height = obj.height + "px" ;

	}

}



function onHTML5OutputLoad(id)

{

	var iframeelem = getElement(id);

	if(typeof iframeelem != 'undefined')

	{

		var wnd = iframeelem.contentWindow;

		if(gbBsIE4)

		{

			try{

				var h = getDocHeight(wnd.document);

				var w = getDocWidth(wnd.document);



				iframeelem.style.width = w + "px" ;

				iframeelem.style.height = h + "px" ;

			}

			catch(e) {}

		}

		else

		{

			requestCpHTML5Size(wnd, id);

		}

	}

}



//End to collaborate with other event handler settings



/// Section End  - CCSSP DHTM 2 (JavaScript 1.2)



//// Segment End -- (JavaScript 1.2)
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