


1.                        Getting Started

 

Adobe FrameMaker is an automated multi-channel and multi-device publishing solution. FrameMaker enables publication departments accomplish multichannel publication tasks.

Before you begin working with your software, take a few moments to read an overview of activation and the many resources available to you. You have access to instructional videos, plug-ins, templates, user communities, seminars, tuto­rials, RSS feeds, and much more.

 

1.1.                   Resources

 

Before you begin working with FrameMaker, take a few moments to read an overview of activation and the many resources available to you. In addition to the links below, you have access to instructional videos, plug-ins, templates, user communities, seminars, tutorials, RSS feeds, and much more online.

 

•               Activation and registration 

•               Adobe TV instructional videos for FrameMaker 

•               Adobe FrameMaker discussion forum 

•               Framers -- An email list for FrameMaker discussions 

1.2.                   Activation and registration

To review complete system requirements and Adobe Recommendations for your Adobe®® FrameMaker®® 11 software, see the FrameMaker product page at www.adobe.com/products/framemaker.

1.2.1.                Install the software

1)            

Close any Adobe applications open on your computer.

 

2)           Insert the installation disc into your disk drive, and follow the onscreen instructions.

 

1.2.2.                Help with installation

For help with installation issues, see the Installation Support Center at www.adobe.com/go/learn_fm_install_en.

1.2.3.                License activation

During the installation process, your Adobe software contacts an Adobe server to complete the license activation process. No personal data is transmitted. For more information on product activation, visit the Adobe website at www.adobe.com/go/activation.

1.2.4.                Register

Register your product to receive complimentary installation support, notifica­tions of updates, and other services.

1)            

To register, follow the onscreen instructions in the Registration dialog box, which appears when you first start the software.

tip:  If you postpone registration, you can register at any time by choosing Help > Registration.

1.3.                   Help and support

Visit the Adobe Support website at www.adobe.com/support/framemaker to access documentation, along with tutorials and troubleshooting information. You can also access customer support information from this page.

Online Help also includes a link to the complete, updated PDF version of Help.

1.3.1.                Adobe Community Help

 Adobe Community Help is an integrated environment on Adobe.com that gives you access to community-generated content moderated by Adobe and industry experts. Think of Community Help as collections of related items rather than books. Adobe continually curates and adds to these collections.

Bookmark the FrameMaker Help hub page http://www.adobe.com/support/robohelp to find the best content on the web about FrameMaker, including these resources:

•                

Videos, tutorials, tips and techniques, blogs, articles, and examples for designers and developers.

 

•               Complete online Help, which is updated regularly.

•               All other content on Adobe.com, including knowledgebase articles, downloads and updates, Adobe Developer Connection, and more.

 

Viewing online Help content

 

•               When you launch Help from within the product, your default web browser (Internet Explorer, Safari, Chrome, Firefox, etc.) will launch with the product Help content displayed.

 

•               You can then use your browser’s native functionality to search, bookmark, comment, or rate the content.

 

Downloading offline Help content

 

•               The first time you launch Help from within the product, Adobe Help Manager launches in the background and checks for the availability of new or updated content.

 

Adobe Help Manager is an AIR-based content installation utility that downloads offline help content and notifies you when new updates are available, ensuring that you always have the most up-to-date and accurate reference information from Adobe.

 

•               If no new content is available, the application will shut down until the next time you select Help.

 

•               If new content is found, a small pop-up notification will be displayed on your desktop, usually in the lower-right corner of your screen.

 

•               When you click on the notification message, the Help Manager will launch and show you all of the help content that is available for download in the Local Content preferences.

 

•               You can select individual packages by highlighting the desired product or Help package title and clicking on the Update button.

 

•               To update all of the content that is available, select the ‘Download’ button on the General preferences pane. Note: The total download size for all of the applicable content is displayed – large updates may take several minutes or more to download.

 

•               During this download, you may continue to browse and search Help content with your web browser.

 

•               If you prefer to have your Adobe applications use the local, installed Help files by default, select “Display local help content only’ in the General pref­erences tab.

 

•               Or you can simply choose to continue viewing online content and the Help Manager will automatically switch to offline help if Internet access is no longer available.

1.3.2.                Services, downloads, and extras

You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets and see various resources to get your work done.

Adobe Exchange

Visit the Adobe Exchange at www.adobe.com/go/exchange to download samples as well as plug-ins and extensions from Adobe and third-party devel­opers. The plug-ins and extensions can help you automate tasks, customize workflows, create specialized professional effects, and more.

Adobe downloads

Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

Adobe Labs

Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

•                

Prerelease software and technologies

 

•               Code samples and best practices to accelerate your learning

 

•               Early versions of product and technical documentation

 

•               Forums, wiki-based content, and other collaborative resources to help you interact with like-minded users

 

Adobe Labs fosters a collaborative software development process. In this envi­ronment, customers quickly become productive with new products and tech­nologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.

Adobe forums

To reach out to experts in the Adobe RoboHelp community, visit http://forums.adobe.com/community/framemaker. If you comment on a Help page, the comment is automatically posted on the forum. The experts and other users can respond to your comment.

Adobe TV

Visit Adobe TV at http://tv.adobe.com to view instructional and inspirational videos. The Technical Communications channel features videos relevant for technical communicators. The videos on the FrameMaker http://tv.adobe.com/show/learn-robohelp-9/#/show/learn-robohelp-9 channel help you get started.

FrameMaker Developer Center

Visit FrameMaker Developer Center for articles written by internal and external RoboHelp users on various user-requested topics.

Previous FrameMaker Help

Download the documentation of older versions of FrameMaker from the FrameMaker Help hub page.

1.3.3.                Other resources

Online Help also includes a link to the complete, updated PDF version of Help.

Visit the Adobe Support website at www.adobe.com/support to learn about free and paid technical support options.

Visit the following resources to interact with the FrameMaker community.

 

•               Adobe Forums: http://forums.adobe.com/community/framemaker 

•               Adobe Blogs: http://blogs.adobe.com/ 

•               Adobe TV: http://tv.adobe.com/product/framemaker/  

1.4.                   Services, downloads, and extras

You can enhance your product by integrating various services, plug-ins, and extensions in your product. You can also download samples and other assets to Help you get your work done.

1.4.1.                Adobe downloads

Visit www.adobe.com/go/downloads to find free updates, trials, and other useful software.

1.4.2.                Adobe Labs

Adobe Labs at www.adobe.com/go/labs gives you the opportunity to experience and evaluate new and emerging technologies and products from Adobe. At Adobe Labs, you have access to resources such as these:

•                

Prerelease software and technologies

 

•               Code samples and best practices to accelerate your learning

 

•               Early versions of product and technical documentation

 

•               Forums, wiki-based content, and other collaborative resources to Help you interact with like-minded users

 

Adobe Labs fosters a collaborative software development process. In this envi­ronment, customers quickly become productive with new products and tech­nologies. Adobe Labs is also a forum for early feedback. The Adobe development teams use this feedback to create software that meets the needs and expectations of the community.

1.4.3.                Adobe TV

Visit the technical communications channel on Adobe TV at http://tv.adobe.com/channel/technical-communication for instructional videos on authoring.

1.5.                   What’s new

Adobe®® FrameMaker®® 11 supports XPath and allows you to create and use XSLT expressions to publish hypertext outputs from your structured content. Two new views, XML view and Author view, help you author and manage struc­tured content with ease. The new Error console helps you identify and correct errors in your structured content. Structured authoring is more usable with hierarchical element insert and banner text to guide you about the contents of various elements. Line numbers help you identify location of the content. Quick catalogs make locating and inserting the right elements and formats easier. Rich media support is enhanced to include image hotspots, 3D object part links, and interactive links to multimedia and 3D objects.

1.5.1.                Enhancements to XML and DITA support

 

New views

In addition to the default WYSIWYG view, FrameMaker has two new views:

Author view

Author View is meant for structured documents only. Author View simplifies structured authoring by keeping out unstructured-FrameMaker features, such as page numbers and formatting tools, not relevan for XML authors.

Related links:

Author view

XML view, author view, and WYSIWYG view

XML view

The XML view allows you to work with the plain XML code of your structured FrameMaker XML files. The sophisticated XML code view automatically vali­dates the structure and inserts the required attribute values and closing tags.

Related links:

XML view

XML view, author view, and WYSIWYG view

XPath

Generating hypertext outputs using XSLT

XPath expressions to locate XML nodes

You can use XPath syntax in the XML view to search through XML files for nodes or node sets. Using the XPath pod or XPath toolbar, you can execute XPath queries on:

•               current files

 

•               all open files

 

•               all the files in a folder

 

•               or all the files in a ditamap\book

 

Related links:

XPath

XML view

Run XSLT from XML view

You can run XSL from XML View to create hypertext outputs from XML files. Further, you can create and save reusable transformation scenarios in an XML file. The output is created using Xalan or SAXON parsers that get installed on your machine with FrameMaker. You can choose the parser using which you create the output.

Related links:

Generating hypertext outputs using XSLT

Hierarchical element insert

Using the Elements quick catalog, you can select and insert multiple levels of elements. When you select an element in the quick catalog, FrameMaker displays the elements available within the selected element. Select a hierarchy of elements that you want to insert.

A graphic displaying hierarchical element insert

[image: gs_quick-catalog-hierarchical-elements.png]

Related links:

Hierarchical element insert

Quick catalogs

Guided structured authoring with banner text

Banner text in a FrameMaker file instructs you about what to enter in an element. You can control the instructional text you want to display for each of the elements. Banner text is available for container type elements and is controlled using the BannerText element. FrameMaker does not treat banner text as real content in the document. Banner text is included in FM and MIF output, but is not included in XML output.

Related links:

Banner text

Configure and generate book output from ditamap

You can configure the generation of the output from a ditamap. You can generate two configurable, unstructured outputs from a ditamap: Composite Document 11.0 and Book 11.0 with FM components.

Related links:

Create ditamap-to-book output

Generating hypertext outputs using XSLT

Roundtripping OLE objects

FrameMaker now supports round-tripping OLE objects, such as Visio objects and PowerPoint presentations in XML. An XML Processing Instruction is added to FrameMaker to handle the OLE object roundtripping.

Related links:

Direct OLE support in XML

Assign IDs to elements

You can now assign IDs to multiple instances of an element in one go:

•                

Instances of an element across a FrameMaker file

 

•               Instances of an element across topicrefs in a ditamap

 

•               Instances of an element in all open files

 

You can also choose to assign IDs to the instances of the specializations of the selected element.

Related links:

Assign IDs to elements

Smart paste

FrameMaker allows you to paste HTML, MS® Word, MS® Excel, and MS® Outlook content as DITA content. You can also create and configure XSLs for other FrameMaker structured applications. Using XSL, FrameMaker identifies the content while it is in the clipboard and structures it with the most appro­priate hierarchy or sequence of elements. Then you can use the smart paste command to paste it to FrameMaker as DITA content.

Related links:

Smart paste hypertext and MS® Word contents as structured content

Error Console

The error console replaces the Error log, which was there in earlier FrameMaker versions. While opening a document, the new FrameMaker Error console displays structural and other issues in a document, if any. The error console displays location (line\char) of the error and a description of the error. This information helps you locate and understand the error.

Related links:

Error console

1.5.2.                Usability enhancements

FrameMaker brings several interface enhancements that simplify various tasks, and thus increasing productivity.

Identify and refer to content using line numbers

Line numbers help the author and reviewer identify particular lines for providing feedback. Line numbers are set at a document level (for .fm and .mif files) and appear before each inserted line in a FrameMaker document.

A graphic displaying line numbers

[image: gs_view-line-number.png]

Related links:

Line numbers

Quick catalog

Quick catalogs appear next to the instruction pointer for elements, paragraph formats, character formats, variables, and conditional text when you use the appropriate keyboard shortcut.

A graphic displaying a quick catalog

Related links:

Quick catalogs

Hierarchical element insert

1.5.3.                Extended rich media support

 

Interactive multimedia links for 3D objects

FrameMaker 11 allows you to insert links to interactively control embedded U3D (Universal 3D), FLV file, and SWF file in the PDF output.

Related links:

Interactive Links for 3D/Multimedia Objects

Object styles

Object styles work similar to Paragraph and Character formats. You can save your frequently used object properties as a style. You can apply these object styles to various objects, such as images, anchored frames, and text frames for consistent size and appearance.

Related links:

Object Styles

Hotspots

A hotspot is an active area in a document that you can link to different areas of the document, to another document, or to a URL. With hotspots, you can add multiple links in different parts of a graphic without having to divide the graphic into separate parts. For example, in a world map, you can create hotspots in each of the countries linking to more information about that country.

Related links:

Hotspots

3D object part links

Various 3D-objects’ parts can be linked to textual objects within the same or in other documents. A use for adding 3D object part links can be to link them to a description of each of the parts.

Related links:

3D object part links

1.5.4.                CMS integration enhancements

 

CMS connector framework

FrameMaker 11 extends the support to any standard content management system (CMS) through providing a set of full-featured APIs\Extendscript. With CMS APIs\ExtendScript, you can implement additional authoring and content management capabilities beyond the ones provided by the CMS. In addition, you can create your own user interface or extend the existing user interface features.

Custom attributes in CMS

You can add the custom attributes in FrameMaker that exist on your Docu­mentum® or Sharepoint CMS.

Related links:

Add custom CMS attributes

1.5.5.                Publishing server enhancements

 

Kindle, multiscreen, and epubs publishing in FrameMaker Publishing Server

FrameMaker Publishing Server can now publish three new formats: kindle, multiscreen, and epubs.




2.                        FrameMaker Basics

 

2.1.                   User interface

 

2.1.1.                Basics

 

The Welcome screen

From the FrameMaker Welcome screen, you can perform the following tasks:

•               Open recently accessed documents

 

•               Create documents, books, CMS connections, and DITA maps in case of Structured FrameMaker

 

•               Access FrameMaker templates

•               Access FrameMaker Help and guides

 

•               Access other resource pages and updates from Adobe

Workspace overview

A particular arrangement of elements, such as panels and pods that you use frequently while working on documents, is called a workspace. You can dock, stack, minimize, or make these elements free-floating in your workspace. You can select from several preset workspaces or create one of your own. Once you have arranged the panels and pods, you can save the workspace settings for use later.

The FrameMaker interface has the following components.

•                

The Application bar across the top contains a workspace switcher, menus, and other application controls.

 

•               The document window displays the file you’re working on. Document windows can be tabbed and, in certain cases, grouped and docked.

 

•               Panels help you monitor and modify your work. Examples include char­acter, paragraph, and table designers; and marker, variables, cross-refer­ences panels. You can minimize, group, stack, or dock panels.

 

•               The status bar shows text formatting and pagination information for the current document.

 

Preferences dialog

The preferences dialog (Edit > Preferences) has the following settings:

General preferences

Use these preferences to specify settings, such as:

•                

Product interface

•               File saving, naming, and backup

 

•               Handling of embedded objects

 

General preferences

[image: ba_general_preference.png]

A.

Select structured or unstructured interface

B.

Specify the diagonal size of your monitor

C.

Select to create a backup file when you save a file for the first time

D.

Specify the number of minutes after which FrameMaker automatically saves the open file

E.

Select to display errors, if any, when you open a file in FrameMaker

F.

Text size smaller than the one specified in this field is displayed as XXXX

G.

Select to automatically lock and check-out a file when you download it

H.

Select to check in a file every time you save it

I.

Select to display learning resource links on the bottom of the starter page

J.

Select the type of cross-platform file naming for FrameMaker to follow

K.

Select to add a FrameImage facet to bitmap graphics imported by copying

L.

Select to prevent multiple people from opening the same file

M.

Select to remember missing font names

N.

Select the file types to be embedded in the PDF

Interface preferences

Use this dialog box to specify whether FrameMaker should auto-collapse panels to icons or always open documents as tabs.

Default interface properties

[image: ba_interface_preference.png]

A.

Select tooltip appearance type: Normal, Fast, or Hidden

B.

When disabled, you must click on the panel tab/panel icon to collapse it. When enabled, just click on another panel or in the document to collapse a panel.

C.

Select to hide all docked panels permanently

D.

 When you close panels they are hidden but are still active in memory. Deselect this optionto remove panels when you close them. To display them again, choose them from FrameMaker menus.

E.

Select to open all documents as tabbed documents. Deselect to open docu­ment windows as floating windows.

F.

Floating document windows display the document name only in the title bar. Deselect to display document name in title bar and tab bar.

G.

Opens composite documents as tabbed documents. Deselect to open composite document windows as floating windows.

H.

Switch between dark or light levels of UI brightness

I.

Select to make FrameMaker application icon greyscale

Alerts

These settings control the display of warnings.

Alerts

[image: ba_alerts_preference.png]

A.

Select to show warnings on actions that clear the history

B.

Specify if you want the warning to appear once for a history clearning command or every time you run that command

C.

Select when you want FrameMaker to display dialogs with alerts

Panels and Pods

The pod location criteria determine what should be displayed in the pod list area for an instance by way of identifying its location in the document.

Panels and pods

[image: ba_pods_struc_preference.png]

A.

In structured interface, you can specify either the paragraph styles or the element names. In unstructured FrameMaker, you can only specify para­graph styles.

B.

Specify the first paragraph style (Paragraph style or element in Structured Framemaker)

C.

Specify the second paragraph style (Paragraph style or element in Struc­tured Framemaker)

Related links:

Panels

Documentum

Use these preferences to set up Documentum file versioning, specify DFS SDK path, and add custom CMS properties to FrameMaker for Documentum.

Documentum CMS preferences

[image: ba_cms_documentum_preference.png]

A.

Specify how existing objects are overwritten and saved

B.

Select to show hidden objects

C.

Select to show private cabinets

D.

Specify the path to DFS SDK

E.

Enter the name of a custom attribute to add

Sharepoint

Use these preferences to set up Sharepoint file versioning and add custom CMS properties to FrameMaker for Sharepoint.

Sharepoint preferences

[image: ba_cms_sharepoint_preference.png]

A.

Specify how existing objects are overwritten and saved

B.

Enter the name and type of a custom attribute to add

Dictionary

Use these preferences to specify Proximity or Hunspell dictionaries for Spelling, Hyphenation, and Thesaurus for various languages.

Spelling options

Use these preferences to set up Spelling Checker.

Spelling Options

[image: frm_preferencesSpell.png]

A.

Auto Spell check

B.

Select all that you want spell checker to find

C.

Click to get default spelling options

D.

Select all that you want spell checker to ignore

XML

Use these preferences to set up syntax colors and other display options for XML content in FrameMaker.

XML preferences

[image: ba_xml_preference.png]

A.

Select the color preferences for various parts of XML syntax

B.

Select to display line numbers in the document

C.

Select to word wrap

D.

Select the font family for displaying the xml tags and content

2.1.2.                Panels

 

Dock and undock panels

A dock is a collection of panels or panel groups displayed together in a vertical orientation. A dock is an arrangement of non-floating panels. You dock and undock panels by moving them into and out of a dock.

Docking a panel to the right of the document window. The blue highlight indicates the drop zone on the dock.

[image: ba_docking.png]

note:  Docking is not the same as stacking. A stack is a collection of floating panels or panel groups, joined top to bottom.

•                

To dock a panel, drag it by its tab into the dock, at the top, bottom, or in between other panels.

•               To dock a panel group, drag it by its title bar (the solid empty bar above the tabs) into the dock.

 

•               To remove a panel or panel group, drag it out of the dock by its tab or title bar. You can drag it into another dock or make it free-floating.

 

Move panels

As you move panels, blue highlighted drop zone areas appear where you can drop the panel. For example, move a panel up or down in a dock by dragging it to the narrow blue drop zone above or below another panel. If you drag to an area that is not a drop zone, the panel floats freely in the workspace.

•                

To move a panel, drag it by its tab.

•               To move a panel group or a stack of floating panels, drag the title bar.

 

Manipulate panel groups

•                

To move a panel into a group, drag the panel’s tab to the highlighted drop zone at the top of the group.

Adding a panel to a panel group

[image: ba_add_panel_group.png]

 

•               To rearrange panels in a group, drag a panel’s tab to a new location in the group.

 

•               To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.

 

•               To move a group, drag the title bar (the area above the tabs).

 

Stack floating panels

When you drag a panel out of its dock but not into a drop zone, the panel floats freely. You can position the floating panel anywhere in the workspace. You can stack floating panels or panel groups so that they move as a unit when you drag the topmost title bar.

You can collect floating panels and group them into a stack.

[image: ba_panel_stack.png]

•                

To stack floating panels, drag a panel by its tab to the drop zone at the bottom of another panel.

 

•               To change the stacking order, drag a panel up or down by its tab.

 

note:  Be sure to release the tab over the narrow drop zone between panels, rather than the broad drop zone in a title bar.

 

•               To remove a panel or panel group from the stack, so that it floats by itself, drag it out by its tab or title bar.

 

Resize panels

•                

To minimize or maximize a panel, panel group, or stack of panels, double-click a tab. You can also single-click the tab area (the empty space next to the tabs).

 

•               To resize a panel, drag any side of the panel.

Manipulate panels collapsed to icons

You can collapse panels to icons to reduce clutter on the workspace. In some cases, panels are collapsed to icons in the default workspace.

Collapse panels to icons

[image: ba_expanded_icons.png]

A.

Panel icons

B.

Panel icons expanded

•                

To collapse or expand all panel icons in a dock, click the double arrow at the top of the dock.

•               To expand a single panel icon, click it.

•               To resize panel icons so that you see only the icons (and not the labels), adjust the width of the dock until the text disappears. To display the icon text again, make the dock wider.

 

•               To collapse an expanded panel back to its icon, click its tab, its icon, or the double arrow in the panel’s title bar.

 

•               To add a floating panel or panel group to an icon dock, drag it in by its tab or title bar. (Panels are automatically collapsed to icons when added to an icon dock.)

 

•               To move a panel icon (or panel icon group), drag the icon. You can drag panel icons up and down in the dock, or into other docks (where they appear in the panel style of that dock). You can also drag panel icons outside the dock (where they appear as floating, expanded panels).

 

2.1.3.                Tabbed documents

When you open more than one file, the document windows are tabbed. You can open documents as floating windows by clearing the Open Documents As Tabs option in the Interface Preferences dialog box.

Documents appear as tabs in the document view.

[image: ba_doc_win.png]

However, when you add a generated file, such as a Table Of Content, the gener­ated file appears minimized in the lower left corner of your workspace. There are multiple ways in which you can organize floating and tabbed document windows.

•                

To dock a document window in a group of document windows, drag the window into the group.

•               To rearrange the order of tabbed document windows, drag a window’s tab to a new location in the group.

 

•               To undock a document window from a group of windows, drag the window’s tab out of the group.

 

note:  When you minimize a floating document window, it covers a part of the FrameMaker status bar. You cannot move the minimized window to a new location.

2.1.4.                Tips on working with the new interface

Adjust the UI brightness

 

Adjust the UI brightness by using the UI Brightness slider under > Inter­face.

Combine document windows

 

To consolidate all document windows, floating, minimized, or docked, right-click the tab bar of the docked document window and select Consol­idate All To Here from the menu.

 

Float document windows

 

Click Arrange Documents icon on the top Application bar and select Float All In Windows. This arranges all the document windows as cascaded floating panels.

 

Tile documents

 

Use the Arrange Documents icon to tile document windows vertically or horizontally. This is specially useful for manually comparing documents and layering them side by side.

 

Bring hidden pods to the front

 

Sometimes while working with floating document windows or when switching workspaces, the pods may seem difficult to bring to the front.

•               Undock the pods by dragging them out using the pod title bar.

 

•               Dock all floating document windows. Right-click the docked tab bar and select Consolidate All To Here or drag and dock the floating document windows.

 

Minimize pods to icons

 

Right-click on the pods tab bar and select Collapse To Icons from the menu. This option is available only if the pods are floating and not docked. To collapse docked pods, click anywhere in the tab bar.

 

Reopen the pods

 

Choose View > Pods and click any pod name. The entire group of pods open at the bottom of the workspace.

 

Reopen a panel

 

Choose Windows and select Panels and select the panel you want to reopen.

Collapse all open panel groups to icons

 

Right-click the tab bar of the panel group and select Collapse To Icons.

 

Exit the full screen mode

 

Right-click outside the text frame in the document window and select Toggle Screen Mode.

 

Related links:

Keys for screen modes

2.1.5.                Quick catalogs

Quick catalogs appear next to the instruction pointer for elements, paragraph formats, and character formats when you use the appropriate keyboard shortcut.

A character formats quick catalog

[image: ba_quickcatalogcharformats.png]

Following are the keyboard shortcuts for the various pop-up menus and other actions related to elements:



	
 

Quick catalog/Action

 


	
Keyboard Shortcut

 





	
Elements quick catalog

 

note:  See Hierarchical element insert for more details. 


	
Enter

 

Or

 

Ctrl+1

 





	
Wrap element

 


	
Ctrl+2

 





	
Change element

 


	
Ctrl+3

 





	
Insert conditional tags

 


	
Ctrl+4

 





	
Insert conditional tags

 


	
Ctrl+5

 





	
Insert attributes for an element

 


	
Ctrl+7

 





	
Character formats quick catalog

 


	
Ctrl+8

 





	
Paragraph formats quick catalog

 


	
Ctrl+9

 





	
Variables quick catalog

 


	
Ctrl+0

 






2.1.6.                Customize and manage workspaces

 

Default workspaces

You can choose from default workspaces or create custom workspaces and switch between them. The default workspaces are designed so that you can quickly switch between workspaces according to what you want to accomplish. For example, the Review workspace has review toolbars, commonly used pods, and panels prearranged to help you review a document quickly.

 

•               Authoring

 

•               DITA Authoring (available only in Structured FrameMaker)

 

•               Manage Content

 

•               Manage Graphics

 

•               Review

 

•               Structured Authoring (available only in Structured FrameMaker)

 

Save a custom workspace

1)            

Configure the workspace the way you want it and choose Save Workspace from the workspace switcher on the Application bar.

 

2)           Type a name for the workspace and click OK.

 

FrameMaker remembers the last used workspace across sessions. If you were working in the Review workspace and you close and relaunch FrameMaker, it loads the Review workspace.

Switch workspaces

1)            

Select a workspace from the workspace switcher in the Application bar.

 

Use the workspace switcher to switch between workspaces designed for your workflow.

[image: ba_wkspace_switcher.png]

Reset a workspace

By saving the current configuration of panels as a named workspace, you can restore that workspace even if you move or close a panel. The names of saved workspaces appear in the workspace switcher in the Application bar.

1)            

Select the Reset Workspace option from the workspace switcher in the Application bar.

 

Rename a custom workspace

1)            

Select Manage Workspace from the workspace switcher in the Applica­tion bar.

 

2)           Select the workspace and click Rename.

 

3)           Type a new name and click OK twice.

 

Delete a custom workspace

1)            

Select Manage Workspace from the workspace switcher in the Applica­tion bar, select the workspace, and then click Delete.

 

2.1.7.                Interface view options

 

Display pages more quickly

1)            

Do the following:

 

•               Open the document by bypassing the update of imported graphics, cross-references, and text insets. (Opening a document without updating references makes a document open faster but can slow down the display of individual pages.)

•               Turn off the display of graphics by choosing View > Options, dese­lecting the Graphics option, and clicking Set.

important:  If you deselect the Graphics option and generate a PDF, the graphics do not appear in the PDF.

 

•               Display small text as gray bars by choosing File > Preferences > General, entering a point size in the Greek Screen Text Smaller box, and clicking Set. Whenever text in your document is in a point size smaller than the size you specified, it appears on the screen as a gray bar.

 

Change the preset display units

Some text boxes in dialog boxes require a unit of measurement (such as points or inches) for the value you enter. You can specify the default units for font size and line spacing (font size units) and for other measurements (display units). The default units of measurement appear after the values in the text boxes. If you enter a value without a unit of measurement, FrameMaker uses the default unit.

 

•               To change the preset units, make the appropriate window is active. Select View > Options. Select the values for Display Units and Font Units, and then click Set.

 

•               To enter different units in a box, make the appropriate window active. Enter an abbreviation for the unit along with the numeric value. Use cm for centimeters, mm for millimeters, " or in for inches, pc, pi, or pica for picas, pt or point for points, dd for didots, cc or cicero for ciceros, Q for Q units (refers to font size and line spacing for the Japanese language only).

FrameMaker converts the entry to the preset display units when you click a command button in the dialog box. For example, if your document display units are picas and you want to set a paragraph indent of 1 inch, enter 1" in the First Indent box. When you click Apply, the measurement changes to the number of picas that corresponds to 1 inch.

 

Change the spacing of ruler or grid intervals

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Select View > Options. Select a new setting from the Rulers menu or the Grid menu, and click Set.

 

Show or hide visual guides

You can show several of these visual guides in a document window:

•                

Borders around text frames, graphic frames, and imported objects

 

•               Markers, paragraph returns, and other symbols in running text

 

•               Rulers along the top and left side of the window

 

You can also show a grid of horizontal and vertical lines for drawing, resizing, and aligning graphics. All visual guides are nonprinting, so you do not need to hide them when you print.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Do the following:

 

•               To show or hide borders, select View > Borders.

•               To show or hide the text symbols, select View > Text Symbols.

 

•               To show or hide the rulers, select View > Rulers.

 

•               To show or hide grid lines, select View > Grid Lines.

 

•               To show the element boundaries, select View > Element Boundaries or Element Boundaries (As Tags) in Structured FrameMaker. FrameMaker automatically toggles these two options.

 

Text symbols



	
 

Text symbol

 


	
Meaning
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End of paragraph
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End of flow and end of table cell
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Tab
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Anchored frame and table anchor
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Marker
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Forced return
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Manual equation alignment point
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Nonbreaking space
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Discretionary hyphen
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Suppress hyphenation






Display a subset of menu commands

You can display a subset of menu commands called quick menus. The quick menus do not have commands for formatting text, editing some aspects of graphics, and inserting some objects such as markers and variables.

If you do not see the full set of menu commands, the quick menus is probably displayed.

note:  If you’re using a structured document, your application developer can change the commands available in the complete menus.

•                

To display quick menus, select View > Menus > Quick.

 

•               To restore the complete menu, select View > Menus > Complete.

 

•               To customize menus, add, move, or remove menus and commands as described in the online manual Customizing FrameMaker on the Adobe website www.adobe.com/go/lr_FrameMaker_support_en.

 

Display a high-contrast workspace

FrameMaker uses system colors to draw window backgrounds, text, and other graphics. Users who have trouble discerning colors or variations in contrast, or who have low visual acuity, can set high-contrast color schemes and custom text and background colors. This setting makes the information in the user interface easier to view.

1)           Open the Windows Control Panel, double-click Accessibility Options, and select the Display tab.

2)           Change contrast globally or change the color theme, as follows:

•               To change the appearance of all operating system windows at once, select the Use High Contrast option.

 

•               To change the color theme, click Settings and select one of the High Contrast Appearance Scheme options.

 

note:  FrameMaker does not adjust colors of all items. Some of these include the background color, and the fill color of graphic objects.

Use custom system cursors

You can use custom system cursors instead of the built-in FrameMaker cursors. For example, you can use your preferred system cursors for operations, such as text select or precision select, instead of the default FrameMaker cursors.

1)            

After you install FrameMaker, locate the maker.ini file in the FrameMaker folder.

2)           Open the maker.ini file in a text editor.

 

3)           Change the value of UseSystemCursor to On.

 

4)           Save the maker.ini file and restart FrameMaker.

 

Customize the display of filenames

FrameMaker contains an option for displaying the filename before the path­name in the frame titles of document windows. The position at the end of a long pathname often obscures the filename in titles.

1)            

In the initialization file, maker.ini, set the value of the flag DisplayFileLeafFirst to On . This setting displays the filename in the title of the document or book window.

 

This setting also displays the filename in the dialog box listing all open files. By default the flag is set to Off , the line is marked as a comment, and the filename is displayed in the format pathname filename, as previously.

The flag does not affect how the root name of the folder or directory tree appears in individual filenames in the book window.

2.1.8.                Use status bar controls

The FrameMaker status bar provides all the navigational controls, pagination information, and zoom controls.

Navigational controls on the status bar

[image: ba_nav_controls.png]

A.

First page

B.

Previous

C.

Go to page number

D.

Next

E.

Last page

F.

Go to line number

G.

Go to insertion point

H.

Zoom controls

Zoom in and out

 

•               To magnify or decrease magnification, text, and objects, click the + (Increase Zoom) or - (Decrease Zoom) buttons on the status bar. FrameMaker zooms in or out on the area of the page containing the inser­tion point or selection. If the document doesn’t contain an insertion point or a selection, FrameMaker zooms in on the center of the page.

 

•               To display text and objects at a particular magnification, select a percentage from the Zoom pop-up menu.

 

•               To display the entire page in the current window, select Fit Page In Window from the Zoom pop-up menu.

 

•               To fit the page or text frame to the window, select Fit Window To Page or Fit Window To Text Frame from the Zoom pop-up menu. If the view options are set to display facing pages, the window is resized to accommo­date two pages side by side.

 

•               To change the available zoom settings, click Set from the Zoom pop-up menu, select the percentage you want to change and enter the new percentage. Enter any percentage from 25% to 1600%. Click Set. To return to the default percentages, click Get Defaults.

 

•               To make 100% zoom match the page size, select File > Preferences > General. For Monitor Size, specify the diagonal size of your monitor, and then click OK. If screen-to-paper fidelity is not critical, leave Monitor Size set to Default, which ensures cross-application compatibility.

 

note:  You can customize the default zoom settings. For information, see the online manual Customizing FrameMaker on the Adobe website www.adobe.com/go/lr_FrameMaker_support_en . 

Turn pages and set scrolling

You can page through a document window using controls in the status bar.

You can also define how FrameMaker displays pages when you scroll up and down, left and right, or two pages at a time.

If the document you are paging through is part of an open book, FrameMaker sometimes displays an alert message prompting you to choose to open the next or previous document in the book. For example, if you click Previous Page on the first page of a document, clicking Yes in the alert message box opens the previous document in the book. The last page of that document appears.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose View > Options.

 

3)           Choose one of the following options from the Page Scrolling pop-up menu:

 

•               To display pages from top to bottom (for example, page 2 below page 1), choose Vertical.

 

•               To display pages from left to right (for example, page 2 to the right of page 1), choose Horizontal.

 

•               To display pages two at a time, side by side, choose Facing Pages.

 

•               To display as many pages as will fit in the window from left to right, choose Variable.

 

4)           Click Set.

 

Go to another page

1)            

Do one of the following:

 

•               To go to the next page, click the Next Page button.

 

•               To go to the previous page, click the Previous Page button.

 

•               To go to the first page in the document, click the First Page button.

 

•               To go to the last page in the document, click the Last Page button.

 

•               To go to a specific page, click in the Page Number area and specify the page number you want to display.

 

•               To go to a specific line number, click in the Line Number area and specify the line number you want to display.

•               To go to the page containing the insertion point, click the Insertion Point button.

•               To move quickly through the pages, scroll vertically.

 

tip:  In case of structured documents, click or select in the Structure View to display the corresponding page in the document window. This is often the quickest way to go to the page you want.

2.1.9.                Using toolbar shortcuts

You can access all commonly used commands from the following toolbars for use in structured or unstructured documents. You can display a toolbar from the View > Toolbars menu.

Graphics Toolbar

 

Provides all the shortcuts for graphic creation and edits.

Quick Access Bar

 

Provides all the commands for opening and saving documents, editing text, graphics, and tables.

 

Text Formatting

 

Provides all the text formatting commands, such as font styles.

 

Table Formatting

 

Provides all the table editing commands, such as add rows, columns, merge cells, and text alignment options for table cells.

 

Paragraph Formatting

 

Provides all the commands for formatting paragraphs, such as tab stops, text alignment, spacing, as well as the paragraph tag list.

 

Object Alignment

 

Provides commands to change sequence, alignment, and orientation of objects.

 

Object Properties

 

Provides commands to group objects, change layer order, reshape, scale, and snap objects.

 

Track Text Edits

 

Provides all the commands for tracking, accepting, and rejecting text edits.

 

You also have keyboard shortcuts for all commands accessible through the tool­bars and menus. For a list of all the keyboard shortcuts see Keyboard Shortcuts.

Related links:

Keyboard Shortcuts

2.1.10.            Using pods

 

About pods

These frequently used dialog boxes have an interface designed to simplify your work:

•               Conditional text pod

 

•               Cross-references pod

 

•               Marker pod

 

•               Fonts pod

 

•               Insets pod

 

•               Variables pod

 

•               Reference pods

 

 

Explaining the pod interface
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A.

Select document

B.

Pod-specific toolbar buttons

C.

Search pod entries

D.

Arrow on column headers indicates sort order

E.

Pod list area.

F.

Details of each instance include location. You can customize the location using Pods Location Criteria dialog box.

About the pod list area

The Select pop-up displays a list of all open documents, including books and DITA maps. If you select All Open Docs, the pod list area displays all the vari­ables from all the open documents. If you select a specific open document, the pod list area displays variables from the selected document even when you switch to other open documents. The pod list area continues to display the list of instances from the selected document.

If you select the Current option, the pod list area displays the list of instances from the selected document. The list area refreshes when you switch between open documents. However, when you switch between pods, you may need to click the Refresh button.

If you select an open document

•               Single-click an instance in the pod to display the corresponding instance in the document. For example, if you select an image instance from the Insets pod, the corresponding image is also selected in the document view.

•               Double-click an instance to do the following for each pod:

Conditional text pod

 

Displays the Add/Edit Condition Tag panel for the selected condition.

 

Cross-references pod

 

Displays the Cross-Reference panel for editing the selected cross-refer­ence.

 

Markers pod

 

Displays the Marker panel so that you can edit the selected marker defini­tion.

 

Fonts pod

 

Displays the Replace Font panel for selecting a replacement font.

 

Insets pod

 

Displays the Object Properties panel for the selected inset.

 

Variables pod

 

Adds the selected variable at the insertion point in the current document.

 

Reference pod

 

Displays the results of the search for locations where a particular element is referenced. This pod is only relevant for DITA documents.

 

•               Click a column name to sort the data in the list area in ascending or descending order.

 

Setting pod location criteria

 

The pod location criteria determine what should be displayed in the pod list area for an instance by way of identifying its location in the document.

For example, you can define two Paragraph tags that should be displayed as the location identifier for a marker. FrameMaker searches backwards for the first match of the first Paragraph tag that you have specified and displays it in the pod. Suppose you specify the first Paragraph tag as Topic_Title in the Location Criteria dialog box. FrameMaker locates a marker and traverses backwards to display the first topic title in which the marker occurs. If you specify the second Paragraph tag as Article_Name, then FrameMaker displays the exact article name to which the topic belongs.

Pod location criteria
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A.

In structured interface, you can specify either the paragraph styles or the element names. In unstructured FrameMaker, you can only specify para­graph styles.

B.

Specify the first paragraph style.

C.

Specify the second paragraph style.

1)            

Choose .

 

2)           Select Panels and Pods.

 

3)           Select Element Name if you want the pod to display the element names in which the instance is located.

 

4)           Specify valid element names and click OK.

 

For example, select Paragraph Style and specify head 2 and head 3 in the Style 1 and Style 2 boxes. In the Markers pod, for each instance of a marker, the first head 2 and head 3 it occurs under is displayed in the pod.

The Markers pod displays the setting for marker location

[image: ba_pods_location_example.png]

A.

Marker is selected in the document view

B.

Paragraph styles that you specify in Pod Location Criteria

C.

 Markers pod displays the first head3 title and head2 title in which the marker occurs.

2.1.11.            Document window overview

The first time that you launch FrameMaker, it prompts you to select the product interface. Subsequently, it opens with the last used interface.

All features of unstructured FrameMaker are available in the structured work­space, including the paragraph and character catalogs for formatting docu­ments. You can work on both structured and unstructured documents.

Contents and structure information

[image: ba_structure_view.png]

Related links:

About elements

Document window

A document window appears when you open a structured or unstructured FrameMaker document. The window shows the document text formatted, with graphics and other items in place, and everything laid out in a page design. If more than one document is open, a document window appears for each one.

The document window is the only window available in the unstructured work­space. In the structured workspace, you can also view element boundaries in the document window.

Structure View window

The Structure View window displays the underlying XML structure. The view uses bubbles to represent elements and their relationship to one another. It also identifies errors in the document structure. In Structure View, you can insert, select, expand, collapse, move, merge, or split elements. When you work with structured documents, you’ll use the document window and the Structure View together. These windows help you organize elements in a valid structure.

Both windows are editable, and anything you do in one is mirrored in the other. You can have the two views open side by side, to keep track of both contents and structure. If you click or select in one view, an insertion point or selection appears at the equivalent place in the other view. Any editing you do in one is reflected in the other. It’s easier to make your changes in Structure View, where you can drag and drop bubbles to rearrange elements or select bubbles to edit them in other ways. If you click or select in an unstructured flow in a document window, Structure View is empty.

1)           To display, choose Structure Tools > Structure View.

 

Elements catalog

The Elements catalog lists the elements you can use at the current location and provides commands for adding and editing elements. It also displays other information about the current location, such as whether you can type text there. The information in the Elements catalog comes from content rules in the defi­nition for the current element.

The catalog is preset to show only the elements that are valid at the current loca­tion, though you can have it display more elements if you want greater flexi­bility. The catalog is empty if you click or select in an unstructured flow, if the document has no element definitions, or if no more elements are required at the current location.

 

1)           To display, click the Element Catalog button at the upper-right corner in the document window.

 

The Element Catalog uses the following symbols to identify whether an element is valid:

Heavy check mark

 

The element is valid at the current location. If you insert the element, the current (parent) element will be correct and complete up to this location.

 

Plus sign (+)

 

The element is an inclusion (SGML only) in the current element and is valid at the current location. The plus sign always appears next to a heavy check mark. Inclusions are valid only in SGML documents, so this sign does not appear in XML documents.

 

tip:  Although inclusions are as valid as elements identified with just a heavy check mark, you might find it helpful to list inclusions separately. If a document has many inclusions, it can be difficult to find other valid elements in the catalog.

 

Question mark (?)

 

The element is a possible replacement for the element right after the inser­tion point or for the selected elements. It is valid at the current location, but will make child elements after it invalid. If you insert an element with a question mark, the current (parent) element will be complete and correct up to this location, but you’ll have to correct errors after the new element.

 

Light check mark

 

The element is valid later in the current element. If you insert one of these elements, the current (parent) element will be correct but incomplete up to this location. You’ll have to go back and fill in missing child elements.

 

No symbol

 

If an element in the catalog has no symbol, it is not valid at the current location or later in the current element. It may be valid earlier in the current element or outside the element.

 

The Element Catalog may also include the following indicators to provide other information about the current location:

 

<TEXT>

 

You can type text at this point.

 

<UNDEFINED>

 

The current element does not have a definition in the document. The element was probably pasted from a document with different element definitions. (This does not appear when the catalog is set to display all elements.)

 

<INVALID>

 

The contents of the current element are invalid. (This does not appear when the catalog is set to display all elements.)

 

You can use buttons in the Element Catalog to insert an empty element, wrap an element around contents, and change the type of an existing element.

Change the default interface

1)            

Select File > Preferences > General.

 

2)           In the Product Interface list, select FrameMaker or Structured FrameMaker.

3)           Click Set. You are prompted to restart FrameMaker for the preference change to take effect.

 

2.1.12.            Working with the Structure View

 

Expand or collapse structure

In the Structure View, you can expand or collapse elements, showing or hiding a detailed outline of your document. (When elements are expanded or collapsed in Structure View, text in the document window does not change.)

An element is sometimes defined to have attributes, which provide supple­mental information about the element. You can also expand and collapse the attributes associated with an element.

tip:  Collapse elements to get a higher-level look at the document structure. Collapsed elements are also easier to move around. It’s especially helpful to collapse long lists of items and procedures with many steps.

•                

To expand or collapse elements, click the plus (+) or minus (-) symbol on the left side of element bubbles.

 

•               To expand or collapse attributes, click the plus (+) or minus (-) symbol on the right side of element bubbles.

 

•               To expand or collapse all child elements or attributes, hold down Shift while you click a plus or minus sign.

 

View element boundaries in the document window

Element boundaries shown in the document window mark the beginning and end of each element. Working with visible boundaries helps you see how the document content is divided into elements. Viewing the boundaries also makes it easier to place an insertion point properly or to make the right selection.

For most elements, the boundaries appear as opening and closing brackets ( [ ] ) or as two boxes with an element tag. For some elements (graphics, footnotes, markers, tables, and equations), the element location is marked only by one box with a tag.

When elements are inside other elements, their brackets or tags nest to show the hierarchy.

 

•               To surround each element with brackets, choose View > Element Bound­aries.

 

•               To surround each element with a text label, choose View > Element Boundaries (As Tags).

 

•               If the book window is active, select View > Show Element Boundaries or View > Hide Element Boundaries.

 

•               To hide element boundaries, choose View > Hide Element Boundaries or Element Boundaries (As Tags)

 

note:  The brackets and tags that mark element boundaries are characters that both print and occupy document space. Hide them before printing to suppress them in print output. Also hide them to see the document layout unaltered by element boundaries.

Expand and collapse elements in document window

If you are viewing element boundaries as tags in the document window, you can perform the following operations:

•                

Collapse all elements, even in the document view.

 

•               Collapse a parent element to hide the child elements, without collapsing them.

 

•               Collapse child elements, when collapsing the parent element.

 

•               Collapse all elements to the same level, when collapsing an element.

 

•               Select the element, by clicking the element tag.

 

•               Toggle the collapsed state of an element, by double clicking the element tag.

 

•               View expanded element structure, when any operation (for example, Find/Change) results in a selection, within a collapsed element structure.

 

•               Have the document view and structure view synchronized with respect to the collapsed state of the elements.

 

Show and hide attributes for new elements

You can show or hide attributes for new elements in Structure View. The view can display all the attributes in the flow, none of the attributes, or only required attributes or attributes that have a value. This setting applies to new elements as you enter them.

 

1)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Select View > Attribute Display Options, choose the display option you want, and click Set.

 

 

Change the scope of elements available in a structured document

When adding elements to a structured document, insert only elements that are valid at the current location. (Valid elements have heavy check marks, heavy check marks and a plus sign, and question marks in the Element Catalog.) If you add elements this way, you can work from the beginning of a document to the end and be sure that its structure is valid at every point along the way.

Sometimes you want to work more loosely, and in these cases you can make more elements available. For example, some draft documents must adhere strictly to a predefined structure but follow the structure only as a guideline. Or, you can plan your document to conform to a structure without having all the information to complete it from start to finish.

When more elements are available, the additional elements appear in the Element Catalog and are available if you insert elements from the keyboard. You can also list inclusions after other valid elements in the catalog.

 

1)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Select Element > Set Available Elements. You can also click Options in the Element Catalog.

 

3)           Select one of the following options in the Show Tags For area:

 

•               To show only elements that are valid for the current location, select Valid Elements For Working Start To Finish. Use this option if you plan to go through a document from start to finish and fill in the elements in their correct order and hierarchy.

 

•               To show elements that are valid for the current location or later in the current element, select Valid Elements For Working In Any Order. Use this setting if you plan to build a valid document but not necessarily by working from start to finish. This is helpful if you don’t have all the information you need.

 

•               To show elements allowed anywhere in the current element, select Elements Allowed Anywhere In Parent. Use this setting if you want more flexibility for filling in elements. You can insert elements that are invalid and correct the errors later.

 

•               To show all elements defined for the document, select All Elements. Use this setting if you’re not building a valid document, if you want flexibility and will correct errors later, if you’re wrapping elements around contents, or if you want to see what’s available elsewhere in the document.

 

•               To show a set of elements that you specify, select Customized List. Use this setting to work with a subset of the elements, to display elements in a fixed order, or to work with a list that is static instead of context sensitive.

 

4)           If you selected Customized List, click Edit and create or change a list of elements.

 

To move element tags between the Show and Don’t Show lists, use the arrow buttons or double-click the element tags. Transfer all of the elements from one list to another by holding down Shift as you click an arrow button. Click the Move Up and Move Down buttons to arrange the elements in the Show list in the order you want them to appear in the Element Catalog. Click Set when the list is the way you want it.

 

note:  A customized list of tags is always the same regardless of the location of the insertion point, so be careful to include all the tags you need. The only indication of validity is a check mark next to a tag.

 

5)           To list inclusions separately in the Element Catalog, turn on List After Other Valid Elements.

 

This groups the inclusions right after the other valid elements. Use this setting if you have a large number of inclusions that you rarely need.

 

6)           Click Set.

 

2.2.                   Accessibility features in FrameMaker

 

The FrameMaker software provides a number of features that improve access for visually impaired users. In particular, it:

•                

Provides support for high-contrast viewing for users with low visual acuity.

 

•               Creates tagged Adobe PDF files when converting FrameMaker files to tagged PDF, making it easier for people who use screen reader software to navigate a document in the proper reading order. For information on how to turn your FrameMaker documents into tagged Adobe PDF files, see Tagged PDF.

 

•               Supports assistive technology, such as screen reader software for the Windows®® platform.

Screen readers let visually impaired users interact with the computer by inter­preting what is happening on the screen and sending that information to speech-synthesis devices. The screen reader will follow the logical structure of the document. Screen readers can read FrameMaker documents viewed in FrameMaker, or tagged PDF documents viewed in Adobe Acrobat®® or Adobe Reader®®. Refer to your screen reader documentation for information on instal­lation and use with documents viewed in FrameMaker or Acrobat.

For more information on accessibility in Adobe Acrobat and Adobe PDF docu­ments, see the Acrobat online Help and the Adobe website.

 

2.2.1.                Launch the soft keyboard

1)           From the Start menu, select Programs > Accessories > Accessibility > On-Screen Keyboard.

 

2)           Click OK. You can then start using the onscreen keyboard.

 

Related links:

Display a high-contrast workspace

2.3.                   Opening, saving, and closing documents

 

2.3.1.                Open a document

In addition to FrameMaker documents, you can open text files, files in MIF (Maker Interchange Format), files in MML (Maker Markup Language), and XML and SGML documents. If the required filter is installed, you can also open files created in other applications, such as Microsoft®® Word. Much of the file’s formatting is retained when you open the file.

To open files created using FrameMaker 7 or earlier, you must save them as MIF files.

Open a file

1)            

Select File > Open.

2)           Locate the document and click Open.

Opening a document usually updates graphics imported by reference, text insets, cross-references, and system variables (if any exist). Recently opened files are listed at the bottom of the File menu.

Messages alerting you to possible issues with the file sometimes appear. You can click OK and resolve the problems later.

Open a text file

Text-only files do not contain graphics or formatting information. When you open a text-only file, you are asked to confirm that it is a text file.

1)            

Select File > Open, and open a .txt file. The Unknown File Type dialog box appears.

2)           Select the Text option.

 

3)           Click Convert.

4)           Select one of the following options:

 

•               To break the text into paragraphs only at blank lines, select Merge Lines Into Paragraphs. Use this option for a paragraph-oriented text file, such as a file containing document text.

 

•               To break the text into paragraphs at the end of each line, select Treat Each Line As A Paragraph. Use this option for a line-oriented text file, such as a file containing computer code.

 

•               To convert the text into a table, select the Convert Text To Table. Use this option if the content of your source file is tabulated.

 

Select additional options in the Convert To Table dialog box, such as number of columns, cell separators, and heading rows, to obtain the data in the appropriate tabular form.

5)           Select the desired Encoding scheme. By default, the ANSI (Windows) encoding scheme is selected.

 

6)           Click Read. The text appears in a document that is created from a special template. You can customize the template so that documents created from text files are formatted differently.

Open a document in use

A lock file (*.lck) is created every time you open a document. This lock file prevents others from changing the file while you work in it. A lock file is in the same folder as the original document and is removed when you close the docu­ment. You can turn off file locking.

If you try to open a document that’s already open and if you have write permis­sion to the document, a dialog box displays the name of the document, who opened it last and when, and the computer on which it is open. You sometimes see this dialog box after a system crash when you open a document you were last using.

1)            

Open the file and do one of the following:

 

•               If you want to look at the file but not change it, click Open For Viewing Only, and then click Continue. The document appears in View Only format.

 

•               If you want to edit a copy of the file, click Open Copy For Editing, and then click Continue. A copy of the file is opened and when you save this file you are prompted to provide a new filename.

 

•               If you want to edit the file and you know that no one else is using it, click Reset Lock And Open, and then click Continue. Use this option after a system crash to edit a document that was open at the time of the crash.

 

Open a document without updating references

A document opens more slowly if it contains many cross-references to other files, large imported graphics, or many text insets. You can open a document faster by bypassing the update of imported graphics, cross-references, and text insets. However, if you use this method to open documents, keep in mind that FrameMaker does not warn you about missing items or unresolved cross-refer­ences. For this reason, it is best to occasionally open a document in the usual way.

1)           Choose File > Open, and select the file you want to open.

 

2)           Control-click Open.

 

After the file is open, FrameMaker imports and displays graphics as needed on a page-by-page basis. You can manually update cross-references and text insets by using Edit > Update References. If the page display is too slow, reopen the document in the usual way.

SGML, XML, MIF, and MML are all text formats, so they open as text in unstructured FrameMaker.

In the case of .xml or .mif files in structured FrameMaker, control-clicking the Open button opens them as text files. You are prompted to specify the text reading options in the Reading Text File dialog box. Opening these files as text lets you view or edit the markup.

Markup in an SGML file

[image: do_SGML_markup.png]

Reopen a file after a system crash

If your system crashes, the file is saved automatically in the following situations:

•                

If you selected Automatic Save in the Preferences dialog box, autosave files (whose filename contains .auto) are created at the specified interval. This file is deleted when you save and close a file.

 

•               If your system becomes unstable, FrameMaker tries to create a recover file (filename contains .recover) with your most recent changes.

 

An automatically saved copy of the file contains recent changes to the file.

1)            

Open the file you were working on last.

 

2)           Do one of the following:

 

•               If a recover file exists, open it when prompted and check whether your latest changes are there. If they are, save the recover file with the same name as the document you were originally working on and then delete the recover file.

 

•               If no recover file exists, open the autosave file when prompted and save it with the same name as the document you were originally working on. The autosave file contains all the changes you made until the time of the last automatic save. The amount of work lost depends on the time interval you set between saves and when your system crashed.

 

Troubleshooting unavailable fonts

 

You sometimes get an alert message that indicates the document you are opening uses unavailable fonts. Fonts can become unavailable for a few reasons:

•               The document was edited on a different system using fonts that are not installed on your system.

 

•               A font is removed or has become damaged.

 

•               The default printer for your system has changed.

 

If the Remember Missing Font Names option in the Preferences dialog box is selected, FrameMaker preserves the names of unavailable fonts. Selecting this option causes the original fonts to reappear when you open the document on a computer that has the fonts installed, even if you save the document with substi­tute fonts.

To fix the problem of missing fonts, consider the following options:

Check for damaged fonts

 

Determine whether the fonts that are unavailable in FrameMaker are installed on your system and available in another application. If another application can use fonts that FrameMaker cannot use, the fonts may be damaged. Reinstall them using the original media. For more information on troubleshooting font problems, isolating damaged fonts or a damaged fonts folder, or reinstalling PostScript fonts, see the Adobe website.

 

Remap unavailable fonts

 

If you cannot install or reinstall the unavailable fonts, you may want to permanently remap the unavailable fonts to available fonts, so that the alert message does not appear when you open the document. You do this by deselecting the Remember Missing Font Names option in the Prefer­ences dialog box before you open the file. However, be aware that doing this causes you to lose the original font information referenced in the document.

 

Switch printers

 

FrameMaker reads font information stored in the printer driver so that it can make fonts stored at the printer available for use within FrameMaker. In some cases, changing the default printer can change one or more fonts available in FrameMaker.

 

Obtain and install the missing fonts

 

For example, if you and a co-worker are editing the same documents, and you would like to use the same fonts as your co-worker, consider purchasing and installing copies of the fonts.

 

2.3.2.                Add metadata to a document

FrameMaker includes built-in support for Extensible Metadata Platform (XMP). Metadata, or file information, is descriptive information that can be searched and processed by a computer. Use it to provide information about the contents of a document, and to preserve information about a document that will be opened in other Adobe applications. If you export the file to PDF, much of this metadata will appear in Acrobat.

Metadata tags travel with the document and describe its content. By embedding them in your documents, you make the documents easier to track, manage, and retrieve.

note:  Metadata in a book file sometimes overrides metadata in a document file. If your document is part of a book file, open the book file and select the document before you add metadata.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose File > File Info.

 

3)           Enter the desired information in the box next to any or all categories.

 

4)           For Marked, choose Yes if the document is copyrighted, or No if the docu­ment is explicitly in the public domain. Choose Unknown if you’re not sure.

 

5)           Click Set.

 

2.3.3.                Save documents

You can save a document using its current name and location, or save a copy of the document using a different name or location. You can save a document in several formats, including Hypertext Markup Language (HTML), Extensible Markup Language (XML), and Portable Document Format (PDF).

When a document or a book has unsaved changes, an asterisk (*) appears in the Page Status area of the status bar.

An asterisk indicates unsaved changes.

[image: do_asterisk_page_status.png]

Related links:

Adobe PDF

Import properties from a template

Save a document

1)            

Do one of the following:

 

•               To save changes in the current file, choose File > Save.

 

•               To save the file in a different folder or with a different filename, choose File > Save As.

2)           If you choose the Save As command, or if the file has never been saved, specify the new filename and location. If you want to save the file in a different format, choose the format from the pop-up menu.

 

3)           Click Save. If you choose Text Only format, specify how to treat the text and tables in the document.

 

Save a book

1)            

Do one of the following:

 

•               To overwrite the current version on the disk, choose File > Save Book.

 

•               To save the file in a different folder or using a different name, choose File > Save Book As.

2)           If you choose the Save Book As command, or if the file has never been saved, specify the new filename and location.

 

Save all open documents

1)            

Hold down Shift and choose File > Save All Open Files.

 

Return to the saved version of your document

1)            

Choose File > Revert To Saved and click OK.

 

File formats you can save in

You can use the Save As command to save a file in the following formats:

Document 11

 

Saves the FrameMaker 11 document or book as a document or book that you can open and edit in FrameMaker.

 

View Only 11.0

 

Produces a book or document that you can open but cannot edit. If you accidentally save a file in View Only format, you can make it editable by pressing Esc Shift+f l (lowercase L) k. Then you can save the document or book in Document or Book format.

 

Document 10.0

 

Saves the FrameMaker document or book as a document or book that you can open and edit in FrameMaker.

 

note:  To save a FrameMaker 11 document as a FrameMaker 9.0 or prior version’s document, save the document as a MIF 7.0 document, open the MIF 7.0 document in FrameMaker 9.0 or prior, and Save the document as the relevant FrameMaker 8.0 document.

 

MIF 11.0

 

Creates a text file containing FrameMaker 10 statements that describe all text and graphics. To avoid overwriting your original document, save the MIF file under a different name. (For example, add a .mif extension to the name.) For information on MIF, see the online manual MIF Reference.

 

MIF 7.0

 

Creates a text file containing FrameMaker 7.0 statements that describe all text and graphics. To avoid overwriting your original document, save the MIF file under a different name. (For example, add a .mif extension to the name.) For information on MIF, see the online manual MIF Reference.

 

Text Only

 

Creates a text file without graphics or formatting information. To avoid overwriting your original document, save the text file under a different name. (For example, add a .text extension to the name.)

PDF

 

Creates a Portable Document Format (PDF) file that can be viewed in Adobe Acrobat® and other applications that support PDF files.

 

SGML

 

Creates an SGML file with the content, elements, and attributes from your document.

 

HTML

 

Creates an HTML document that can be viewed on the World Wide Web. For information on adjusting the mapping of paragraph and character tags to predefined HTML elements, see “Set up and adjust HTML mappings.”

 

note:  When you save a structured FrameMaker document as HTML, all attributes with the same name are mapped to the same value, even if the attributes have different values for different elements. To use different values for these attributes after exporting, use a text editor to edit the resulting file.

 

XML

 

Creates an XML document that can be used for data exchange and viewed on the World Wide Web.

Microsoft RTF

 

Create files in Rich Text Format 1.6 (RTF), which is supported by many word processors and can be read by other applications. Most formatting is preserved as formats are usually converted to word-processing styles.

 

note:  You can use the Print command to save a PostScript® ®file.

 

Related links:

Create PostScript files

Using Save As to export to other formats

Set up and adjust HTML mappings

Filename extensions for saved files

When you save a file for the first time in Windows, FrameMaker automatically adds these extensions: .fm for documents, .book for book files, and .mif for MIF files. With these extensions, the files are recognized as FrameMaker files by the Windows operating system.

If you don’t want these special extensions added to the filenames you assign, enclose the filenames in double quotation marks. Windows doesn’t recognize a file without one of these extensions as a FrameMaker file, but you can still open the file in FrameMaker.

If you assign an extension that’s registered by another application, such as .doc, the extension is not replaced by the FrameMaker extension and you can still open the file in FrameMaker.

Save documents in Text Only format

Saving a document in Text Only format creates a text file with the text encoding of your choice: ANSI (Windows), or ASCII. (On Japanese-language systems, you can also use JIS, Shift-JIS, or EUC. On other Asian-language systems, you can use encoding for the supported languages.) Only ordinary text—those in text frames and tables—is saved; graphics, text in graphic callouts, footnotes, and formatting information are not saved. Reformat line lengths and hyphen­ation as needed before saving the file.

If some characters are not available in the text encoding that you choose, those characters are replaced in the text file. For example, when you save a document in Text Only format using ANSI (Windows) or ASCII encoding, spaces (including thin, en, em, and numeric spaces) are converted to regular spaces.

1)            

Choose File > Save As.

2)           Specify the filename and location, and choose Text Only format.

 

3)           Click Save.

4)           Do one of the following:

 

•               To break each line into a separate paragraph, click At The End Of Each Line. This option maintains a file’s original line breaks and blank lines. Use this option for a line-oriented file such as computer code.

 

•               To merge adjacent lines into paragraphs and insert a carriage return only at blank lines, click Only Between Paragraphs. Use this option for paragraph-oriented files, such as files containing document text.

 

5)           If you want to save table text, select Include Text From Table Cells. Then do the following:

 

•               Specify the order in which you want the table cells saved (row by row or column by column).

 

•               Choose whether to separate cells with tabs or with carriage returns by choosing items from the pop-up menus.

 

6)           If the text file will be used on a platform that uses a different text encoding, choose an appropriate encoding from the Text Encoding pop-up menu, and then click Save.

 

Related links:

Control hyphenation

Indentation, alignment, and spacing

Use Save As to export XML from unstructured documents

You can export both structured and unstructured files to XML. The mapping used to specify what element to create for each paragraph tag in the source FrameMaker file is defined on a reference page. The export function creates an XML file and a corresponding cascading style sheet (CSS), which can be used with the document.

1)            

Do one of the following:

 

•               Select File > Save As XML.

 

•               Select File > Save As and choose XML from the pop-up menu. Give the filename an extension of .xml.

 

2)           Specify the file location.

 

3)           Click Save.

 

Back up and save automatically

FrameMaker can back up and save your work automatically.

1)            

Choose .

 

2)           In General preferences, do the following:

 

•               To create a backup file every time you save, select Automatic Backup On Save. This option creates a copy of the file before your latest changes are saved. If a backup file exists, the new backup file over­writes it. (The filenames of backup files contain .backup.)

 

•               To create an autosave file at regular intervals, select Automatic Save and enter an interval (in minutes) in the box. This causes a copy of the file to be saved periodically without your having to choose File > Save. (The filenames of autosave files contain .auto.) When you save manually or revert to the last saved version with the Revert To Saved command, the autosave file is deleted.

3)           Click OK.

 

2.3.4.                Close documents

You can close a document at any time. If you have unsaved changes, you’ll be asked whether you want to save the changes. (A document with unsaved changes contains an asterisk in the Page Status area of its status bar.)

If imported graphics, text insets, cross-references, or system variables were updated when you opened your document, the document is marked as changed (with an asterisk in the status bar) when it opens. Similarly, because printing a document updates existing cross-references, printing a file sometimes causes a document to be marked as changed.

 

1)           Do one of the following:

 

•               To close a document, choose File > Close.

 

•               To close all open documents, hold down Shift and choose File > Close All Open Files.

 




3.                        Templates and Page Layout

 

3.1.                   XML view, Author view, and WYSIWYG view

FrameMaker has three views that help you author your content:

•                

XML view allows you to work with the plain XML code of your structured FrameMaker XML files.

 

•               Author view simplifies structured authoring by keeping out unstructured FrameMaker features and features not relevant for XML authors, such as page numbers.

 

•               WYSIWYG view is classic FrameMaker, unstructured and structured. This view displays page breaks, headers and footers, all keyboard short­cuts, and all menus.

 

 

3.1.1.                XML view

The XML view allows you to work with the plain XML code of your structured FrameMaker XML files. In the XML view, you can expand /collapse elements.

XML View

A.

Collapsed elements in the XML view

B.

Errors console

C.

Tree view

FrameMaker indents the child elements by one tab space compared to their parent elements. Word wrap keeps the content of the elements visible in the width of the window. The XML view supports Unicode. You can edit multilin­gual content in the XML view. You can also copy/paste content from clipboard.

When you edit/change references such as conrefs, links, and cross references in XML Code View, FrameMaker updates them in the WSIWYG View also. XML view automatically validates the XML content with the DTD and helps you ensure that the content is well formed at all times. While you are working in the XML view, FrameMaker automatically inserts attribute values and close tags for the tags you insert in the file.

A Find/Change dialog in the XML view helps you search through the XML code. You can also use regular expressions such as with ampersand and pipeline to search through text. XML code view also has support for XPath. You can build and use XPath expressions to locate XML content. For more information on XPath, see XPath.

The following features can be accessed using the Code view only:

•                

XPath 

•               Generating hypertext outputs using XSLT 

Errors console

The Errors console in the XML view describes the errors, if any, in the open XML files. The error console also displays the filename of the error. To go to the file and location of the error, click an error row.

Display error pod

 

•                

To display the Error Pod, select View > Pod > Errors.

 

Tree view

 XML View provides a tree-like outline that allows you to navigate and view the structure of your XML document. The Up and Down arrow keys let you move up and down in the tree view. Left and Right arrow keys respectively allow you to collapse and expand the elements.

Display tree view

 

•                

To display the tree view, select View > Outline.

 

3.1.2.                Author view

The Author view provides a WYSIWYM (What You See Is What You Mean) view of your structured FrameMaker documents. The WYSIWYM environ­ment of structured FrameMaker simplifies structured authoring by keeping out unstructured FrameMaker and features not relevant for XML authors.

Author view
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The Author view includes the visual tools for structured authoring, such as the element tags, Structure View, Element Catalog, Attributes editor.

The XML Author view does not have the following features that hold relevant only for unstructured FrameMaker authoring:

•                

Page breaks (no pagination for up to 20 pages)

 

•               Headers and footers

 

•               Master pages

 

•               Keyboard shortcuts and menus related to content formatting and unstruc­tured workflows, which are not retained when a document is saved as XML

 

•               Menus not relevant to structured authoring

 

Using XML Author View, Structured FrameMaker you can concentrate on the structure and content of the document rather than the appearance.

3.1.3.                WYSIWYG view

WYSIWYG is the classic FrameMaker view, which supports structured and unstructured authoring. The WYSIWYG view has all the features of FrameMaker.

WYSIWYG unstructured view

WYSIWYG structured view

The following can be managed using the WYSIWYG view only:

•                

Templates 

•               Formats 

•               Master pages and reference pages 

•               Page layouts 

•               Multiflow documents 

3.1.4.                Switch between the views

You can switch between the three views by clicking the relevant icon in the Application bar.

Icons of the three views in the Application bar

A.

XML view

B.

Author view

C.

WYSIWYG view

Author view and XML view support only structured files. When you have unstructured files open and you switch from WYSIWYG view to Author or XML view, FrameMaker does not display the unstructured files. When you quit FrameMaker from Author view or XML view and there are unsaved unstruc­tured files, FrameMaker alerts you.

3.2.                   Templates

Multiple components make up a FrameMaker template. These components include paragraph formats, character formats, master page layouts, reference pages, and cross-reference formats. Both unstructured and structured templates require careful planning and upfront design before you create a template.

3.2.1.                About unstructured templates

A template is a document that stores properties that are used in more than one place. You can create a document from a template to give it all the template properties, or you can import specific properties from the template later. Templates give your documents consistent layout and formatting.

Templates can store the following properties:

•                

Paragraph, character, and table formats that work with formatting infor­mation in the element definitions

 

•               Page layouts that determine the number and position of columns on pages, and background items such as running headers

 

•               Reference pages that store repeatedly used graphics and formatting infor­mation

 

•               Variables you use as placeholders for text that FrameMaker updates

 

•               Formatting information for cross-references, equations, and conditional text

 

•               Definitions for colors you can apply to text and objects

 

•               Document-wide settings, including footnote properties, custom marker types, and feathering options for line spacing

 

•               Specifications for combined Japanese and Western fonts (on Japa­nese-language systems)

 

3.2.2.                About structured templates

Structured FrameMaker comes with Structured Templates for letters, memos, faxes, envelopes, reports, outlines, newsletters, books, FAQs, and single source books.

Structured templates can store the following properties:

•                

Element definitions that specify allowable contents, attributes, and formatting for elements

 

•               Paragraphs and characters that work with formatting information in the element definitions

 

•               Variables you use as placeholders for text that FrameMaker updates

 

•               Formatting information for cross-references and conditional text

 

•               Definitions for colors you can apply to text and objects

 

note:  If you’re working with structured files, an application developer can set up special documents that handle the translation to and from the structured applica­tion. These documents can include a template that formats the structured files in FrameMaker. This template is applied automatically when you import from the structured application.

3.3.                   Formats

 

3.3.1.                Paragraph formats

Paragraph formats contain settings for how the text looks and the format applies to the entire paragraph. Paragraph formats are the basis of document formatting in unstructured FrameMaker documents though they can also be the basis of document formatting in structured FrameMaker documents.

Paragraph Designer

The Paragraph Designer is used to create and manage paragraph formats.

Paragraph Designer
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A.

Basic properties

B.

Default font properties

C.

Pagination related properties

D.

Numbering lists

E.

Advanced properties

F.

Properties for Asian text

G.

Table cell properties

H.

Paragraph tag list

I.

Edit the tab stop properties

J.

Commands menu

The Paragraph Catalog lists all the paragraph formats available for a document. To apply a paragraph tag, select the text and select the tag from the Paragraph Catalog.

Paragraph Catalog
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Create a paragraph format

1)            

Click in a paragraph whose format is like the one you want to create. Be careful not to select multiple paragraphs so that no properties are set to As Is.

 

2)           Choose New Format from the Commands pop-up menu in the Paragraph Designer and enter a name for the new format in the Tag box.

 

3)           To later update the new format or copy it to other documents by using the File > Import > Formats command, select Store In Catalog. Formats that aren’t stored in the catalog can be applied to other paragraphs only by copying and pasting.

 

4)           To apply the new format to the current paragraph, select Apply To Selec­tion.

 

5)           Click Create.

 

6)           If you didn’t select Apply To Selection in step 4, choose the new format name from the Paragraph Tag pop-up menu.

 

7)           Modify any of the properties you want.

 

Don’t set any property to As Is. Paragraph formats must have all proper­ties specified.

8)           Click Update All.

 

3.3.2.                Character formats

Character tags allow you to format one or more characters or words inside a paragraph. By applying character tags, you can quickly format text without overriding the properties of the entire paragraph. Creating character tags helps maintain format consistency as well as apply format changes globally. Character tags also serve as building blocks for other FrameMaker features, such as cross-reference formats or variables.

Character Designer

The Character Designer is used to create and manage character formats. All character formats are listed in the character catalog.

Character Designer
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A.

Character tag list

B.

Font properties

C.

Set the language for the character tag

D.

Commands menu

E.

Tsume property

F.

Text background color properties

Select As Is for the properties that you want the paragraph tag to determine. For example, when creating an Italics character tag, set all other properties to As Is and change just the Angle setting to Italic. The font, font size, style, and other settings of the paragraph tag are preserved.

In FrameMaker, these PDF comments are imported with the highlighting retained due to the implementation of the text background color feature.

Set the text background color from the character and paragraph designers.

The Character Catalog lists all the character formats available for a document. To apply a character tag, select the text and select the tag from the Character Catalog.

Character Catalog

[image: pl_character_catalog.png]

 

Create a character format

1)            

In the Character Designer, choose Set Window To As Is from the Commands pop-up menu. Properties set to As Is do not change when you apply the character format. When set to As Is, text boxes are blank, check boxes are dim, and pop-up menus display As Is.

 

2)           Change only the properties you want to include in the character format.

 

3)           Choose New Format from the Commands pop-up menu in the Character Designer, and enter a name for the new format in the Tag box.

 

4)           Select Store In Catalog.

5)           To apply the new format to the current selection, select Apply To Selec­tion.

 

6)           Click Create.

 

3.3.3.                Manage formats

FrameMaker provides features to manage various paragraph, character, and table formats from the respective designers and catalogs.

Update formats

You can change format properties and then use them to redefine, or update, the stored formats and all the text in the document tagged with them.

When you update a format, you can update all properties or just one group of properties. For example, you can change the default font family for all formats in a document without changing any other properties.

Importing paragraph or character fonts is also possible through the File > Import > Formats command.

Update a paragraph or character format

 

1)            

For paragraph format changes, indicate the scope of the changes you want to make by doing one of the following:

 

•               To update one paragraph format or all paragraph formats in the document with a property group from a paragraph, click in that paragraph or select consecutive paragraphs.

 

•               To update more than one paragraph format but not all paragraph formats, select consecutive paragraphs that use the formats you want to update.

 

2)           Choose the appropriate designer.

 

3)           Display the properties by doing one of the following:

 

•               To display the properties of a paragraph including any overrides, click in the paragraph.

 

•               To display properties of a format stored in the catalog, choose the format from the Paragraph Tag or Character Tag pop-up menu.

 

4)           Change any properties, and then click Update All. FrameMaker asks whether you want to remove overrides.

 

tip:  If you change properties in a designer and then decide against updating the format, you can cancel the operation and reset the properties by clicking in text. You can also choose Reset Window From Selection from the Commands pop-up menu in the designer.

Update specific format properties or single property group

1)           Choose one of the following:

 

•               If you are updating specific properties, set Window to As Is; then change only properties you want to update.

 

•               If you are updating a single property group of a paragraph format, choose Format > Paragraphs > Designer, and delete the tag from the Paragraph Tag box if the box is not empty. Deleting the tag sets the box to As Is; FrameMaker does not change the tags of the formats that you update. Then display the property group; change the prop­erties as needed.

 

2)           Choose Global Update Options from the Commands pop-up menu.

 

3)           Click the current property group in the Use Properties area.

 

4)           Do one of the following:

 

•               To update all formats in the document, click All Paragraphs And Catalog Entries or All Characters And Catalog Entries.

 

•               To update all paragraphs or characters in the selection and all para­graphs or characters with the same tags, click All Matching Tags In Selection.

 

•               To update formats with a specific tag, click All Tagged and choose a tag from the pop-up menu.

 

5)           Click Update All in the Designer dialog box.

 

Rename or delete formats

When designing a template or importing a catalog from a template, you some­times must rename or delete a format.

Deleting a format from a catalog does not affect any paragraphs or characters that have the same tag. The paragraphs or characters simply have a tag that isn’t in the catalog.

1)           Choose a designer, and choose the format to rename or delete from the Paragraph Tag or Character Tag pop-up menu.

 

Do this even if the format you want is already displayed. This step ensures that the properties do not include any format overrides or As Is settings.

 

2)           Do one of the following:

 

•               To rename, enter a new name in the Paragraph Tag or Character Tag box and click Update All, and then OK.

•               To delete a format, click Delete, and then Select the format in the scroll list and click Delete. Click Done.

 

•               To delete all unused formats from a catalog, click Delete. Then click Delete until all formats have been removed, and click Done. Choose File > Utilities > Create And Apply Formats, and then click Continue. Any paragraph or character format used in the document is added back to the catalog.

 

To avoid creating paragraphs for every override in your document, import the formats from your template. Importing formats from a template over­rides any changes to paragraph and character tags and does not create additional tags in your document.

Apply formats

Paragraph formats apply at paragraph level, character formats at character or word level, and table formats apply to complete tables.

•                

Paragraph and table formats: Place the cursor inside the paragraph or the table, and select a format from the catalog.

 

•               Character format: Select the text and click a format from the catalog.

 

Tips for creating new formats

When working from a stable template, you rarely have to create a format. If you’re designing a new template or if the template you’re using is incomplete, you may have to create new formats. The easiest way to create a format is to modify the properties of an existing format.

When you’re creating new formats, consider these suggestions:

•                

Use consistent naming conventions for similar kinds of paragraphs or text items within a paragraph, such as Head1 and Head2.

 

•               To apply formats by using the keyboard, name the formats so that often-used ones are unique or alphabetically first in their letter group, such as “H1 Head2” or “H2 Head2.”

 

•               Give each format a name that’s easy to remember, recognize, and type. If you assign a tag based on its use and not its appearance (for example, Emphasis rather than Italics), you can later change the format properties without having to change the tag.

 

•               Be aware of capitalization. Tags are case sensitive. Also, you sometimes want related tags to appear together in the catalog, with names such as Body and BodyIndent.

 

•               If you have many formats, precede them with a period to avoid excessive scrolling in the catalogs; an initial period brings often-used formats to the top of the catalog. To force occasionally used formats to the bottom of the catalog, precede them with a z or a tilde (~).

 

 

Specify formats for the paragraphs that follow

Well-designed templates often connect formats so that FrameMaker automati­cally applies a format to the paragraph that follows the current one.

1)            

Click in the paragraph.

 

2)           Display the Basic properties of the Paragraph Designer, and choose a tag from the Next Pgf Tag pop-up menu. FrameMaker applies this tag when you press Return to create a paragraph.

 

3)           Click Apply To Selection.

 

Add graphics to paragraph formats

A paragraph format can include a line or other graphic that appears above or below a paragraph. Perhaps all top-level headings in a document rest on a long thin line.

1)            

On a reference page, draw or import the graphic in a reference frame, or locate one already there that you want to use.

 

2)           Click in the paragraph you want to change. To place a line above or below several adjacent paragraphs, select all the paragraphs.

 

3)           Display the Advanced properties of the Paragraph Designer, and choose the name of a reference frame from the Frame Above Pgf or from the Frame Below Pgf pop-up menu. All reference frames appear in the pop-up menus.

 

4)           Click Apply To Selection.

 

tip:  Because the Frame Above Pgf and the Frame Below Pgf settings can’t place graphics to the right or left of a paragraph, you can’t use these settings to place boxes around text. Box text by using a single-cell table with outside ruling.

 

3.3.4.                Format catalog

FrameMaker offers enhanced features to manage and apply paragraph, char­acter, and table formats. This is possible from the respective catalog. A catalog shows all formats in the current document by default. You can set which formats you want to see in the catalog. Catalogs also help in applying and managing the formats.

FrameMaker marks the used formats in a catalog. The unused formats are unmarked. This usage information is not updated as soon as you apply the formats in the document. Clicking Refresh Catalog at the bottom of the catalog, updates the usage information. The latest usage information is also updated when opening a document.

 note:  Formats in use in the current document are marked in the catalog. Whereas the format applied to your current selection is shown in the status bar 

Display formats

You can configure the formats that are visible in a catalog and their order too.

•                

Open a (paragraph, character, or table) catalog and click Options.

 

•               Select one of the following

•                

Show All, to see all available formats.

 

•               Show used before unused, to see used formats before unused formats in the catalog.

 

•               Show only used formats, to hide unused formats in the catalog, but retain them in the template.

 

•               Show only unused formats, to hide used formats in the catalog, but retain them in the template.

 

•               Delete all unused formats, to delete all unused formats from the template, without warning or confirmation.

 

•               Customized List, to customize which formats you see and in what order you see them.

 

•               Format being used in the current document are marked in the catalog. While editing the document, the usage status might not get updated auto­matically. To refresh the list click Refresh Catalog.

 

note:  The display options you set are workspace properties and are applicable to FrameMaker documents opened on your machine.

Delete formats

Formats can be deleted from respective catalogs.

•                

Open the catalog if not already open.

 

–              Paragraph catalog from Format > Paragraphs > Catalog.

 

–              Character catalog from Format > Characters > Catalog.

 

–              Table catalog from Table > Format > Catalog.

 

•               Click Delete.

 

•               In the Delete Formats from Catalog window, select a format and delete it.

 

•               Click Done to delete formats from document or click Cancel to undo the operation.

 

3.3.5.                Fonts

  

Replace fonts using the Fonts pod

You can use the Fonts pod to identify all the fonts used in an open document or all open documents. The pod list area lists all the fonts used in a document. You can replace any font used in a document using the fonts pod including missing fonts. The missing fonts are indicated by a red cross sign.

Fonts pod lists all the fonts used in open documents.

[image: pl_fontspod.png]

A.

Select all open documents or currently open document.

B.

Display only missing fonts or all fonts used in a document.

C.

Replace font to display the Replace Fonts panel.

D.

Refresh the list of fonts displayed in the pod list area.

E.

Missing fonts indicated by a red cross sign.

To replace a missing font:

1)            

Select a font from the list and click the Replace icon.

 

2)           From the Replace Font panel, select the new font from the Replace With list box and click Apply.

Replace fonts pod lists all the paragraphs in a document that use a selected font.

[image: pl_replace_fonts.png]

A.

Name of the selected font.

B.

Replace With list box lists all the fonts installed on your system.

C.

Locations list displays all the paragraphs in the document that use the selected font.

D.

Refresh the locations list.

E.

Go To Location takes you to the location in the document that uses the selected font.

Manual font changes

Format changes you make using the Format menu commands take effect imme­diately.

When changing font properties, keep in mind the following:

•                

To remove other style properties, choose Plain.

 

•               If you change the font properties of selected text, those properties are retained when you later update the properties of the entire paragraph.

•               You can change the font properties of text created with the Text Line tool as well as paragraph text.

 

•               Do not use the Courier®® font when Adobe® Type Manager® ®is turned off or not installed. If you do use Courier without ATM, FrameMaker prod­ucts do not accurately display the Courier font.

 

•               If a font has more than one weight—for example, Helvetica®® Condensed Bold and Helvetica Condensed Black—the Format > Style submenu lists only Bold. To choose other weights, use the Default Font properties of the Paragraph Designer or use the Character Designer instead.

 

Font changes using the designers

To change the default font properties of an entire paragraph, use the Paragraph Designer. The font families and styles available depend on which fonts are installed.

To change specific text within a paragraph, select the text and use the Character Designer.

You’ve probably seen many of the settings in other word processors, but a few can be new to you.

Numeric Underlining

 

To use a single offset and thickness for an underline regardless of the char­acter’s font or size, choose Numeric Underlining. Regular and numeric underlining does not affect tab characters. If you want the tab space to be underlined, format that tab stop so that it uses a nonbreaking space as a leader.

 

Numeric and regular underlining

[image: pl_mt_everest.png]

 

Change Bar

 

To display a change bar next to text, select Change Bar.

 

Color

 

To display the text in a different color, choose a color from the Color pop-up menu. If you define your own colors, they appear in the pop-up menu.

 

Spread

 

To add or subtract space between characters, enter a percentage for Spread. Spread—also called tracking—is expressed as a percentage of an em space. Normal spread is 0%.

 

-10% spread (top), 0% spread (center), 10% spread (bottom)
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Stretch

 

To set the width of the character shapes, enter a percentage for Stretch.

 

Capitalization

 

To display all characters in uppercase but use slightly smaller capital letters for text that was in lowercase, choose Small Caps.

 

Using a designer to apply a capitalization style to text changes only the appearance of the text (for example, makes lowercase text appear in uppercase letters). To permanently change the text itself, use the Capital­ization dialog box to replace selected text with text that is all uppercase, all lowercase, or initial caps.

 

Language

 

To change the language associated with the text, choose from the Language pop-up menu. The language you choose affects the text in system variables as well as both spell-checking and hyphenation. Also, changing the language to None prevents the selected text from being spell-checked.

 

Pair Kern

 

To adjust the space between two characters in the same word, select Pair Kern. The kerning pairs that have been defined depend on the font.

Kerning pairs turned on and off
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Tsume

 

To move a Japanese character closer to the characters next to it, select Tsume. The amount of space a variable-width character, such as a paren­thesis, can move is determined by the metrics for that character.

 

Adjust superscripted, subscripted, and small cap text

Adjustments to the properties of subscript, superscript (including footnote references), and small cap text apply to all such text in the document.

1)            

In the Text Options dialog box, specify a size, offset, and stretch percentage.

 

When calculating the size and offset, FrameMaker multiplies the percentage you enter by the point size of the affected characters. For example, a 40% superscript offset value raises a 10-point character 4 points.

 

The stretch percentage is the amount that characters are condensed or expanded.

 

2)           Click Apply.

 

Condense and expand characters

You can achieve some effects by stretching characters.

Text unchanged (top) and condensed 75% (bottom)
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1)            

Depending on whether you are changing the entire paragraph or specific text in the paragraph, choose one of the following:

 

•               Default Font from the Properties pop-up menu in the Paragraph Designer.

 

•               Character Designer.

 

2)           Enter a percentage in the Stretch box. A value of 100% means that the width of characters is as defined for the font. A value less than 100% condenses the width; a value greater than 100% expands the width.

 

3)           Click Apply To Selection.

 

tip:  In Japanese documents, use a stretch value greater than 100 to simulate heitai (horizontally stretched characters). Use a stretch value less than 100 and increase the point size of text to simulate chotai (vertically stretched characters). 

You can also change the width of a text line by dragging to stretch the text.

1)            

Select the text line you want to change, and then drag one of its handles until the text is stretched to the shape you want. Dragging a corner handle changes the point size as well as the character width. You can also select a grouped object that includes a text line.

 

 

Create or change combined fonts of Japanese and Western characters

In addition to containing the full Japanese syllabaria, Japanese fonts include a set of Western characters to facilitate entering non-Japanese characters and numbers. You can define your own combined font—a font that uses a specified Western font with a specified Japanese font.

If you’re working on a system that supports Japanese text and if combined fonts are included as part of a template, they are available to you automatically. (The specified fonts must be installed.) If your system supports the typing of Japanese text in documents and dialog boxes, combined fonts appear at the top of the font lists along with regular Western and Japanese ones.

FrameMaker supports Japanese single-byte, half-width katakana characters in combined fonts. Changes to the combined fonts apply to the entire document.

1)            

In the Combined Fonts dialog box, do one of the following:

 

•               To create a new combined font, enter a name in the Combined Font Name box.

 

•               To change a combined font, select its name from the Combined Fonts list.

 

2)           Do the following:

 

•               To specify the Japanese font, choose from the pop-up menu of font families in the Asian Text area.

 

•               To specify the Western font, choose from the pop-up menu of font families in the Western Text area.

 

•               To adjust the relative size and baseline offset of the Western text, enter values for Size and Offset. The size and offset of the Western text are percentages of the Asian point size. Use a negative offset to move the text below the baseline.

 

3)           Click Add or Change.

 

4)           Click Done.

 

note:  You can turn off the Allow Bolded And Obliqued Styles setting in the Asian Text area of the Edit Combined Fonts dialog box so that bolding or italicizing the Western font does not automatically enbold or italicize the Asian text.

1)            

To copy a set of combined fonts, choose File > Import > Formats and select Combined Fonts.

3.3.6.                Indentation, alignment, and spacing

 

Change paragraph alignment

The alignment property of a paragraph determines how the paragraph is posi­tioned between the left and right indents, not between the edges of the text column.

1)            

Do one of the following:

 

•               To use the ruler, drag the indent symbol to a new location on the ruler.

 

A. First indent   B. Left indent   C. Right indent 

[image: pl_indent_symbols.png]

 

tip:  To align an indent with a ruler marking, turn on the snap grid (use Graphics > Snap). When you drag an indent symbol, it snaps to locations corresponding to the snap grid.

 

•               To use an indent value, display the Basic properties of the Paragraph Designer. Enter the indents you want in the First, Left, and Right boxes, and then click Apply To Selection.

•               Choose an alignment from the Alignment pop-up menu on the formatting bar or in the Basic properties of the Paragraph Designer.

 

note:  If you use Shift+Enter or Shift+Return to insert a forced return within a fully justified paragraph, the line that ends with the forced return is not justified.

 

Change tab stops

If you press Tab and the insertion point doesn’t move, a tab stop hasn’t been defined.

You can choose from four types of tab stops—left, center, right, and decimal.
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 A. 

Left tab stop

 B. 

Center tab stop

 C. 

Right tab stop

 D. 

Decimal tab stop

You can also specify a pattern of characters—a leader—to fill the space between a tab and the character following it. Typically, a leader is a series of periods. Tab leaders are useful in tables of contents that have a wide gap between columns.

Change tabs in formatting bar

1)            

Display the Paragraph Format toolbar. Only the tab stops common to all the selected paragraphs appear on the top ruler.

 

2)           Do one of the following:

 

•               To add a tab stop, click a tab stop symbol from Paragraph Format toolbar and click the desired position below the top ruler.

•               To move a tab stop, drag it to a new position.

 

tip:  To align tab stops with ruler markings, turn on the snap grid (Graphics > Snap). When you drag a tab symbol, it snaps to locations corresponding to the snap grid.

 

•               To add multiple tab stops at regular intervals, on the top ruler, double-click the existing tab stop that you want to duplicate. Enter the interval between tabs in the Repeat Every box and click Edit.

 

•               To change a tab stop, double-click it, enter a new tab position in the New Position box, and choose a different alignment. The position is the distance from the left edge of the column to the tab stop. Then click Edit. You can also drag a new tab stop on top of an existing one on the ruler to replace it.

 

•               To delete a tab stop, drag it off the bottom of the top ruler.

 

•               To delete all tab stops, double-click a tab stop and click Delete All.

 

Change tabs in Paragraph Designer

1)            

Display the Basic properties of the Paragraph Designer.

 

2)           In the Tab Stops area, create, edit, or delete, choosing the appropriate settings.

 

3)           Click Apply To Selection.

 

Define a leader or decimal tab character

1)            

Double-click the tab stop on the ruler.

 

2)           Do one of the following:

 

•               In the Leader area of the dialog box, click one of the predefined tab leaders or enter your own custom leader, and then click Edit.

 

•               To specify a decimal character—for example, a comma when you’re working with European decimals—enter the decimal character in the Align On box in the Alignment area and click Edit.

Change paragraph and character spacing

Vertical spacing is the space between paragraphs and lines. Horizontal spacing is the space between words and characters. Spacing properties go by different names in different contexts. The space between characters is often called pair kerning; adjusting the letterspacing in a line is spread or tracking; the line spacing of a paragraph— measured from the baseline of one line to the baseline of the next—includes its leading.

Adjust vertical spacing

When adjusting vertical spacing, keep in mind the following:

•                

If a paragraph falls at the top of a column, FrameMaker ignores the Space Above setting. If the paragraph falls at the bottom of a column, FrameMaker ignores the Space Below setting.

 

•               When an anchored frame is positioned below the current line and its anchor symbol appears in the last line of a paragraph, the space below the paragraph usually appears between the frame and the next paragraph. If the frame is anchored in a straddle paragraph, the space below is discarded. If the frame is a straddle frame but is not anchored in a straddle paragraph, the space below appears between the anchor symbol and the frame.

 

•               In a multicolumn layout, you can also adjust vertical spacing in columns by vertically justifying, or feathering, the text in them.

Several properties affect the vertical spacing of a paragraph: the space above the paragraph, the space below the paragraph, and the line spacing.

1)            

Display the Basic properties of the Paragraph Designer and do one of the following:

 

•               Specify values for Space Above and Space Below. The space between paragraphs is determined by the Space Below setting of the first paragraph or the Space Above setting of the second paragraph, whichever is larger.

•               Choose a type of line spacing from the Line Spacing pop-up menu, or enter a value in the box.

2)           To allow extra space between lines to accommodate superscripts, subscripts, rubi text, and larger font sizes that appear in the paragraph, turn off Fixed.

 

3)           Click Apply To Selection.

 

 

Adjust horizontal spacing

As FrameMaker fills a line of text, it adjusts the space between characters according to kerning and tracking properties. The spacing between words is based on the following values, which are stored as part of the paragraph format:

•                

The minimum spacing is the smallest space allowed between words.

•               The maximum spacing is the largest space allowed between words before FrameMaker tries to hyphenate words or add space between letters in justified paragraphs.

•               The optimum spacing is what FrameMaker tries to achieve.

 

These values are expressed as a percentage of the standard space character for the default font of a paragraph. Values below 100% create tighter word spacing with a more justified look; values above 100% create looser spacing, with a more ragged right edge.

1)           To adjust the space between words, click a paragraph or select several paragraphs whose spacing you want to change.

 

2)           Display the Advanced properties of the Paragraph Designer and specify the minimum, optimum, and maximum space to allow between words.

 

3)           Click Apply To Selection.

 

note:  Lines of text in a justified paragraph can have more than the maximum space between words if FrameMaker can’t fit a word on a line and can’t hyphenate it. To avoid this, add extra space between characters in justified text by choosing Allow Automatic Letter Spacing in the Word Spacing area.

 

4)           To apply pair kerning or spread, in the Character Designer, choose Pair Kern option or fill in the Spread field.

Adjust spacing in Japanese documents

If your system supports the typing of Japanese text in documents and dialog boxes, you can adjust the following spacing properties:

•               Special group of properties in the Paragraph Designer that controls some aspects of Japanese character spacing.

•               Size, spacing, and alignment of rubi text throughout a document.

 

•               Spacing of variable-width Japanese characters through selection of the Tsume font property.

 

Adjust the space around characters and punctuation

1)            

In the Paragraph Designer, display the Asian properties.

2)           Do the following:

 

•               To adjust the space between Japanese characters and Western ones, use the upper group of boxes; to adjust the space between Japanese characters, use the lower group of boxes. Enter minimum, maximum, and optimum percentages.

•               To determine the space between characters and special punctuation characters (yakumono), choose from the Punctuation pop-up menu. Squeeze As Necessary means that space around punctuation is reduced only when special punctuation handling (kinsoku shori) occurs. Never Squeeze means that no space adjustment is made around punctuation. Always Squeeze means that space is always reduced around punctuation.

 

•               To achieve a monospaced look in Japanese text, choose Never Squeeze from the Punctuation pop-up menu and turn off Tsume.

 

Adjust rubi text size, placement, and spacing

Rubi text is made up of small characters (usually kana) appearing above other text, called oyamoji. Your settings affect rubi text throughout a document.

1)            

In the Format > Document > Rubi Properties dialog box, choose a value from the Size pop-up menu or enter a value in the box. The value you enter can be a percentage of the point size of the underlying oyamoji, a point size, or any other unit of measurement, including Q units.

 

2)           Do the following:

 

•               To let rubi text overhang non-oyamoji text, click Let Rubi Overhang Surrounding Hiragana.

 

•               To remove preceding or trailing space when rubi text appears at the start or end of a line, click Align All Characters At Line Boundaries.

 

3)           Click an option in the Rubi Alignment For Japanese Oyamoji or the Rubi Alignment For Other Oyamoji area. The illustrations in the dialog box show how rubi text is spaced and aligned when it’s above Japanese or non-Japanese characters and when its length is less than or greater than the underlying text.

 

4)           Click Set.

3.3.7.                Lists and autonumbering

    You create numbered and bulleted lists by using paragraph formats that have an autonumber format defined. As you add autonumbered paragraphs to your document, FrameMaker numbers them appropriately and renumbers existing autonumbered paragraphs if necessary.

Autonumbered paragraphs are numbered consecutively in a text flow. If your document contains several text flows, autonumbered paragraphs in each flow are independent of the others.

You define autonumbering in the Numbering properties of the Paragraph Designer. An autonumber format does not have to specify paragraph numbering. When used without building blocks, it is handy for inserting auto­matic text or symbols. An autonumber format can include a series label, a counter, tabs, and any additional text you need.

Series label

 

Series labels identify different types of autonumber series within the same text flow. For example, to number figures independently of tables or head­ings, you specify a different series for each formatting item ((headings, figures, and tables).

On the other hand, table and figure numbers must all be in the same series to be based on section numbers.

 

Counter

 

A counter is a placeholder (building block) that FrameMaker replaces with a number or letter in the autonumber. For example, the counter <n+> increments the paragraph’s number by 1; if the paragraph is the second in a series, FrameMaker replaces <n+> with the number 2. You can use multiple counters in a format.

 

You can also add chapter <$chapnum> and volume <$volnum> building blocks in a format.

 

Tabs, text, and punctuation

 

An autonumber format can also include tabs, text, bullets, spaces, or punctuation.

 

Format text as numbered lists

Creating a numbered list sometimes involves formatting the first item in the list with a paragraph format that resets the counter to 1, and then formatting the remaining items with a different format that increments the counter. For example, perhaps you apply a Step1 format to the first item in a list and then StepNext to the rest. The template also sometimes defines formats that let you apply a single format to all items in a numbered list.

1)            

Display the Numbering properties of the Paragraph Designer and enter a series label in the Autonumber Format box if you need more than one autonumber series in the document.

A series label consists of any single printable character followed by a colon (for example, S:). If you use a series label, it must appear at the beginning of the format.

 

2)           Enter any text you want to have appear automatically with the auto­number format. You can enter tabs or counters from the Building Blocks scroll list. When you select an item, it appears at the insertion point in the Autonumber Format box.

 

3)           Select a Character Format for the autonumber in the Character Format scroll list. If you don’t specify a format, the autonumber appears in the paragraph’s default font.

4)           Choose a position for the autonumber from the Position pop-up menu. Autonumbers at the end of paragraphs are rare except in equation formats.

 

5)           Click Apply To Selection.

 

6)           If you inserted a tab (\t) in step 2, set a corresponding tab stop for the para­graph format.

 

Format text as bulleted lists

In addition to the regular bullet symbol found in all text fonts, you can use any character in any installed font, including a dingbat font such as Zapf Dingbats®.

1)           Click in a single paragraph or select adjacent paragraphs that you want to make into a bulleted list.

2)           Display the Numbering properties of the Paragraph Designer and click the bullet and tab symbols (\b and \t) in the Building Blocks scroll list.

 

3)           Click Apply To Selection.

 

4)           If you inserted a tab (\t) in step 1, set a corresponding tab stop for the para­graph format.

 

Specify a special bullet symbol

Before specifying a special bullet symbol, create a character format that uses the font of the bullet symbol you want to use. For example, to use 9-point Zapf Dingbats, create a character format using that font. Give the format a descrip­tive name such as BulletFont.

1)           Display the Numbering properties of the Paragraph Designer and enter the character corresponding to the bullet symbol you want in the Autonumber Format box.

 

For example, if you want a Zapf Dingbats square bullet, enter a lowercase n, which appears as ■ in that font. To find the character that corresponds to the bullet symbol you want, see the character set for that font.

 

2)           Click the tab symbol (\t) in the Building Blocks scroll list or enter spaces.

 

note:  You sometimes must use special codes to enter characters such as nonbreaking spaces or em spaces.

 

3)           In the Character Format scroll list, click the bullet character format that you created.

 

4)           Click Apply To Selection.

Remove autonumbering or a bullet from a paragraph

1)            

Turn off Autonumber Format in the Numbering properties of the Para­graph Designer. Click the option twice to turn off the setting; clicking it only once changes it to As Is.

 

2)           Click Apply To Selection.

Counters in autonumber formats

A counter consists of angle brackets (< >) that surround a display style and an increment value. The Custom Autonumbering feature supports the Unicode text encoding standard.

[image: pl_autonum_counters.png]

 

 A. 

Display style

 B. 

Increment value

To indicate the display style, use a counter with one of the following letters.



	
 

For this numbering style

 


	
Use

 





	
Numeric (1, 2, 3, …)

 


	
n

 





	
Lowercase Roman (i, ii, iii, iv, …)

 


	
r

 





	
Uppercase Roman (I, II, III, IV, …)

 


	
R

 





	
Lowercase alphabetic (a, b, c, …, aa)

 


	
a

 





	
Uppercase alphabetic (A, B, C, …, AA)

 


	
A

 






To indicate how an autonumber is incremented, use a counter with an incre­ment value, as shown in the following examples.



	
 

To

 


	
Use

 





	
Keep the value the same

 


	
<n>

 





	
Set the value to 1 or to any other number you enter after the equal sign


	
<n=1>

 





	
Increase the value of the counter by 1

 


	
<n+>

 





	
Keep the value the same but not display it

 


	
< >

 





	
Reset to zero (or any other number) but not display it

 


	
< =0>

 






By default, each counter is initially set to zero. The counter can maintain its current value, be incremented by 1, or be reset to a different value. For example, use <n=1> in the format that resets numbering to 1 at the beginning of a new set of numbered steps.

To keep the value the same but not display it, place a blank space between the angle brackets. If you leave out the blank space, the angle brackets appear as part of the autonumber format.

Base autonumbering on book component numbers

You can insert <$volnum>, <$chapnum>, <$sectionnum>, or <$subsec­tionnum> building blocks in paragraph formats. The book component numbers are determined by the settings in the Numbering Properties dialog box.



	
 

Example

 


	
Autonumber format

 





	
Volume 3

 

Chapter 3

 


	
Volume <$volnum>

 

Chapter <$chapnum>

 






The following table illustrates how you can combine the chapter building block with other building blocks:



	
 

Example

 


	
Autonumber format

 





	
Section 1.1

 

Section 1.1.1

 

Figure 1-1

 

Table 1-1

 


	
S:Section <$chapnum>.<n+><=0>

 

S:Section <$chapnum>.<n>.<n+>

 

F:Figure <$chapnum>-<n+>

 

T:Table <$chapnum>-<n+>

 






Base autonumbering on section numbers

Table and figure numbers must all be in the same series for autonumbering in sections, as shown in the following table:



	
 

Section number

 


	
Figure number

 


	
Table number

 





	
Section 1

1.1

1.2

 


	
Figure 1-1

Figure 1-2

 


	
Table 1-1

Table 1-2

 





	
Section 2

2.1

 

2.2

 


	
Figure 2-1

Figure 2-2

 


	
Table 2-1

Table 2-2

 






To achieve this type of numbering, construct autonumber formats in a single series using the same series label for each format. The following table shows possible autonumber formats. The formats are presented in a table so that you can clearly see the position of each counter in the string. Counter position deter­mines how the counter is incremented.



	
Paragraph format

 


	
Autonumber format

 


	
 





	
SectionTitle

 


	
H:Section

 


	
<$chapnum>

 


	
< =0>

 


	
< =0>

 


	
< =0>

 





	
Head1

 


	
H:

 


	
<$chapnum>

 


	
.<n+>

 


	
< >

 


	
< >

 





	
FigureTitle

 


	
H:Figure

 


	
<$chapnum>

 


	
< >

 


	
-<n+>

 


	
< >

 





	
TableTitle

 


	
H:Table

 


	
<$chapnum>

 


	
< >

 


	
< >

 


	
-<n+>

 






Whenever a paragraph tagged SectionTitle occurs, the section number is incre­mented by 1, and the remaining counter values are reset to zero. Each <n+> counter in the remaining formats refer to a different type of item, so they’re incremented independently.

The < > counters keep FrameMaker from resetting values back to zero.

Use multiple counters in an autonumber format

An autonumber format can contain more than one counter. For example, perhaps autonumbers for a series of section and subsection titles each contain two counters.



	
 

These counters

 


	
In this format

 


	
Would appear as

 





	
<$chapnum>.<n=0>

 


	
Head1

 


	
1.0

 





	
<$chapnum>.<n+>

 


	
Head2

 


	
1.1

 





	
<$chapnum>.<n+>

 


	
Head2

 


	
1.2

 





	
<$chapnum>.<n=0>

 


	
Head1

 


	
2.0

 






The counters in each format are independent of each other. The position of a counter in the string determines how it’s displayed and incremented. When incrementing a counter, FrameMaker bases its value on the corresponding counter in the previous autonumber paragraph in the same flow.

The following example shows multiple counters in section titles and subtitles. The counter before the period is incremented independently from the counter after the period.



	
Example

 


	
Autonumber format

 


	
Tag

 





	
1.0 Getting started

 

  1.1 Installing

 

  1.2 Backing up

 

    1.2.1 Errors

 

  1.3 Entering data

 


	
<n+>.<n=0>\t

 

<n>.<n+>\t

 

<n>.<n+>\t

 

<n>.<n>.<n+>\t

 

<n>.<n+>\t

 


	
Head1

 

Head2

 

Head2

 

Head3

 

Head2

 






The following example demonstrates outline style autonumber formats.



	
 

Example

 


	
Autonumberformat

 


	
Tag

 





	
I Getting started

 

  A Installing

 

  B Backing up

 

II Entering data

 

  A Opening a file

 

  B Saving a file

 


	
<R+>< =0>\t

 

< ><A+>\t

 

< ><A+>\t

 

<R+>< =0>\t

 

< ><A+>\t

 

< ><A+>\t

 


	
Head1

 

Head2

 

Head2

 

Head1

 

Head2

 

Head2

 






The autonumber in the heading Opening a file is reset to A; the second counter in the previous paragraph’s format resets the numbering to zero without displaying it, so <A+> increments the counter to 1 or A.

The < > counter in the Head2 format keeps the value of the first counter the same but doesn’t display it. If the < > counter is not in that position, the <A+> in the Head2 format refers to the first counter (not the second), and FrameMaker produces the following result:

Incorrect outline style autonumber format

[image: pl_outline_style.png]

Reset a series

Some numbering series—such as a list of numbered steps—start at 1 every time they are used. You can reset such a series in two ways.

The first example shows how to restart series numbering by using the <n=1> building block for the first step in the series, and then using <n+> for subse­quent steps.



	
 

Example

 


	
Autonumber format

 


	
Tag

 





	
Step 1. Unpack it.

 

Step 2. Back it up.

 

Step 3. Run setup.

 

Step 1. Save your file.

 


	
S:Step <n=1>.\t

 

S:Step <n+>.\t

 

S:Step <n+>.\t

 

S:Step <n=1>.\t

 


	
Step1

 

StepNext

 

StepNext

 

Step1

 






The second example shows another way to reset the counter so that you don’t have to use a unique format to start a numbered list. Instead, a paragraph that introduces the list uses a format that resets the counter.



	
 

Example

 


	
Autonumber format

 


	
Tag

 





	
To install the software:

 

Step 1. Unpack it.

 

Step 2. Back it up.

 

Step 3. Run setup.

 


	
S:< =0>

 

S:Step <n+>.\t

 

S:Step <n+>.\t

 

S:Step <n+>.\t

 


	
StepIntro

 

Step

 

Step

 

Step

 






The < =0> counter in the StepIntro format resets the S series to zero but doesn’t display the number.

If a counter is incremented, any omitted counters in the series to the right of it are reset to zero. For example, the following autonumber formats are equiva­lent:

S:<n+>< =0>\t

S:<n+>\t

About Japanese numbering options

The following counters in autonumber formats are allowed in Japanese text and with Japanese fonts.



	
Building block

 


	
Meaning

 


	
Characters, in this order

 





	
<zenkaku a>

 


	
Fixed-width lowercase Roman alphabet

 


	
[image: pl_zenkaku_a.png]

 

 





	
<zenkaku A>

 


	
Fixed-width uppercase Roman alphabet

 


	
[image: pl_zenkaku_B.png]

 

 





	
<zenkaku n>

 


	
Fixed-width Arabic numbers

 


	
[image: pl_zenkaku_n.png]

 

 





	
<kanji kazu>

 


	
Standard kanji numbering, where double-digit numbers are made up from the traditional kanji characters for ten, one hundred, and so on


	
[image: pl_kanji_kazu.png]

 

 





	
<kanji n>

 


	
Numbers used for street addresses, phone numbers, postal codes, and so on, where double-digit numbers are made up from the kanji characters for zero through nine

 


	
[image: pl_kanji_n.png]

 

 





	
<daiji>

 


	
Numbers used in financial or banking contexts made up of old-style kanji numerals

 


	
[image: pl_daiji.png]

 

 





	
<hira gojuon>

 


	
Hiragana characters in the standard order

 


	
[image: pl_hira_gojuon.png]

 

 





	
<kata gojuon>

 


	
Katakana characters in the standard order

 


	
[image: pl_hira_gojuon00001.png]

 

 





	
<hira iroha>

 


	
Hiragana characters in the literary order (rare)

 


	
[image: pl_hira_iroha.png]

 

 





	
<kata iroha>

 


	
Katakana characters in the literary order (rare)

 


	
[image: pl_kata_iroha.png]

 

 






3.4.                   Master pages and reference pages

  

3.4.1.                About body, master, and reference pages

 FrameMaker documents contain three types of pages that help you set up your page layout:

•                

Master pages specify the page layout and the background text for docu­ment pages (for example, page headers and footers).

 

•               Reference pages can contain frequently used graphics, formatting infor­mation, hypertext commands, mappings for HTML conversion, and boil­erplate matter.

 

•               Body pages show the background text and graphics from the corre­sponding master page and contain the document content.

 

[image: pl_01.png]

 

 A. 

Master pages: first and right

 B. 

Body pages: first chapter page and right page

 C. 

Reference page

Master pages

FrameMaker uses master pages to keep track of a document’s page layout. A double-sided document contains at least two master pages, one for left pages and one for right pages. A single-sided document uses the right master page only. Documents can also contain custom master pages, which you can use for special types of pages. You can also create layouts directly on body pages for one-time-only use.

If your page layout is complex, or if you need to create design components such as page headers and footers, work with the components directly on the master pages. You can draw or import graphics—such as lines, boxes, or company logos—anywhere on a master page, as well as type text on them. Graphics and text appear on the corresponding body pages exactly as they appear on the master page, as part of the body page’s background.

Master page and body page

[image: pl_02.png]

Master pages can contain the following types of text frames:

•                

A template text frame contains a tagged text flow—a flow with a name. When you add a body page, the template text frame is copied to the new body page. You then type the document’s text in this text frame on the body page. You can type text in a template text frame on a master page, but the text does not appear on body pages.

 

•               A background text frame contains an untagged text flow—a flow with no name. Its contents appear on corresponding body pages, but you can edit them only on the master pages. Background text frames are typically used for page headers and footers.

 

Master page

[image: pl_03.png]

 A.

Untagged background text frame

 B. 

Template text frame

When you add text and illustrations to your document on body pages, FrameMaker adds body pages as necessary and automatically uses the page layout from the left or right master page.

On body pages, you type in a text frame copied from the template text frame.

[image: pl_04.png]

Reference pages

You can use reference pages to store frequently used graphics that you want to position consistently throughout a document, and then use the graphics on body pages where they are needed. If you place a graphic in a reference frame—an unanchored graphic frame on a reference page—you can use the frame as a property of a paragraph format. For example, to design a heading with a line below it, draw the line in a reference frame, and then include the reference frame in the paragraph format of the heading.

Reference page and body page

[image: pl_36.png]

Reference pages can also hold boilerplate material or clip art that you can copy and paste on body pages—for example, symbols for cautions and notes. And specialized reference pages can contain hypertext commands, formatting infor­mation for generated lists and indexes, definitions of custom math elements, and mappings for converting to XML and HTML.

A document normally contains at least one reference page. You can add your own graphics to an existing reference page, and you can create additional refer­ence pages (up to 100).

3.4.2.                Create custom master pages

Documents may need body pages with layouts that differ from those of the left and right master pages. For example, you can create a different look for the first page of a document, or you can include a landscape page in a portrait document. For such cases, you create custom master pages. (A document can contain up to 100 master pages.)

After you create the custom master page, change its column layout, and add background text and graphics. You then assign the custom master page to one or more body pages.

Create a custom master page that is empty or based on another master page’s layout

1)            

Display the master page that you want to use as a basis for the new master page.

 

2)           Choose Special > Add Master Page and enter a name for the new master page in the Name text box.

 

3)           Do one of the following:

 

•               To create a master page with a layout that matches the layout of an existing master page, choose the master page from the Copy From Master Page pop-up menu.

 

•               To create an empty master page, click Empty.

 

4)           Click Add.

 

Create a custom master page based on a body page’s layout

1)            

Make the column layout changes you want on a body page.

 

2)           With the body page displayed, choose Format > Page Layout > New Master Page.

 

3)           Enter a name for the master page and click Create.

Related links:

Assign master pages to body pages

3.4.3.                Reorder, rotate, or delete custom master pages

 

Reorder custom master pages

When you reorder custom master pages, the Right and Left master pages always remain at the beginning.

1)            

Open a master page, and then choose Format > Page Layout > Reorder Custom Master Pages.

 

2)           Select a master page in the Custom Master Pages list, and click Move Up or Move Down to move the page accordingly.

3)           Click Set. If you were previously viewing a custom master page, note that a different master page may now be visible.

 

Rotate a master page

You can create a custom master page that changes the orientation of a body page. For example, you can create a rotated orientation for a body page with a wide table.

Right page uses a rotated master page.

[image: pl_16.png]

1)            

On a new master page, set up any text frames and background text and graphics that you want to have the same orientation (unrotated) as headers and footers on the other master pages.

2)           Choose one of the Format > Customize Layout > Rotate Page commands. When FrameMaker rotates the page, part of the page will probably be out of view. You can adjust the window size to see as much of the page as possible.

 

3)           Create the text frames, background text, and background graphics that you want to display rotated.

tip:  You can type in rotated text frames, or you can unrotate the page to make typing faster. To unrotate a page, choose Format > Customize Layout > Unrotate Page. When you’re finished, you can rotate the page again.

Related links:

Creating and modifying background text frames

Rename or delete a custom master page

1)            

Display the master page, and choose Special > Delete Page.

 

note:  You cannot rename the master pages named Left and Right, and you cannot delete the left or right master page or any master page currently assigned to a body page.

3.4.4.                Assign master pages to body pages

You can assign a master page to a body page at any time. FrameMaker uses the template text frame from the master page and displays background text and graphics.

You can also choose to assign no master page to a body page. Because it’s not associated with a master page, this type of body page has no headers, footers, or other background text or graphics. (If the body page contains a text frame, the text frame is unaffected.) For example, if each chapter in a book must contain an even number of pages, and if the last page of a chapter contains no body text, you may not want that page to use a master page, so that it will be blank.

Assign a different master page

1)            

With a body page displayed, choose Format > Page Layout > Master Page Usage.

 

2)           In the Use Master Page area, do one of the following:

 

•               To assign the left or right master page, click Right (in a single-sided document) or Right/Left (in a double-sided document).

 

•               To assign a custom master page, choose the page name from the Custom pop-up menu.

 

•               To assign no master page, choose None from the Custom pop-up menu.

 

3)           In the Apply To area, do one of the following:

 

•               To apply the change to the current body page, click Current.

 

•               To apply the change to a range of pages, enter the starting and ending page numbers in the Pages text boxes.

•               To apply the changes only to odd or even pages within a range, select Even or Odd.

 

•               To apply the changes only to pages within a range that currently use a particular master page, choose a page from the pop-up menu in the Apply To area.

 

4)           Click Apply.

 

note:  If the master page contains a template text flow not found on the body page, FrameMaker adds the text frames that contain that flow to the body page. If the body page contains a flow not found on the master page, FrameMaker leaves the text frames that contain that flow unchanged. This action could result in over­lapping text frames.

Assign a master page to pages with specified paragraph tags

You can assign master pages to body pages that contain specified paragraph tags. For example, you may want all pages that include the Title paragraph tag to be formatted with a custom master page called First.

You map the paragraph tags to the master pages using the Reference Pages mapping table. When you choose the Apply Master Pages command, the master page will be applied to the body pages on which the referenced paragraph tag appears.

In this example, the First master page will be applied to body pages containing Title para­graph tags.
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1)            

Choose View > Reference Pages.

 

2)           Click the Next Page button until the five-column UnstructMasterPage­Maps table appears.

 

tip:  If the mapping table does not appear in the reference pages, choose Format > Page Layout > Apply Master Pages.

 

3)           For Book Update (Yes Or No), type Yes or No to determine whether the specified master page is applied when you choose Apply Master Pages from a book.

 

4)           Edit the mapping table by doing the following:

 

•               Under the Paragraph Tag Name column heading, type the name of the paragraph tag to which you want the master page to be applied. This column is required for master pages to be applied. Spell the paragraph tag name correctly, using the same capitalization that the paragraph tag uses.

 

•               Under the Right-Handed Master Page column heading, type the name of the master page you want to apply. This column is required for master pages to be applied. The specified master page is applied to all body pages, including left-handed pages in double-sided docu­ments on which the paragraph tags appear, unless you specify a different master page under the Left-Handed Master Page column. Master page names are case-sensitive.

 

•               Under the Left-Handed Master Page column heading, type the name of the master page that you want to apply to the left-handed body pages on which the paragraph tags appear in double-sided docu­ments. This column is optional.

 

•               Under the Range Indicator column heading, type Single to apply the master page only to the body page on which each paragraph tag appears; type Span pages to apply the master page to the entire span of pages to which the paragraph tag is applied; or type Until changed to apply the master page to all pages, until the next body page with a different paragraph tag listed in the mapping table is encountered. If this cell is blank, master pages are applied to single pages.

 

•               Add notes to the Comments column. Text you type in this column does not affect how master pages are applied in any way.

 

•               To map additional master pages to paragraph tags, add and fill out additional table rows.

5)           When you are done, choose View > Body Pages.

 

6)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

7)           Choose Format > Page Layout > Apply Master Pages, and then click Yes to override manually applied master pages.

 

Adobe FrameMaker searches each body page for the first occurrence of any paragraph tag specified in the Master Page Maps table. When it finds text containing the specified paragraph tag, it applies the specified master page.

Assign a master page to body pages of structured documents

To assign master pages to body pages containing elements in structured docu­ments, you map the elements to the master pages using the Reference Pages mapping table. When you choose Apply Master Pages, the master page is applied to the body page on which the referenced element appears.

1)            

In Structured FrameMaker, choose View > Reference Pages.

 

2)           Click the Next Page button until the eight-column StructMasterPageMaps table appears.

 

tip:  If you are working on a document created in a previous version of FrameMaker, choose Format > Page Layout > Apply Master Pages, so that the mapping table appears in the reference pages.

 

3)           To the right of Book Update (Yes Or No), type Yes or No to determine whether the specified master page is applied when you choose Apply Master Pages from a book.

 

4)           Edit the mapping table by doing the following:

 

•               Under the Element/Paragraph Tag Name column heading, type a valid prefix (E: for element tag, or P: for paragraph tag), followed by the name of the element or paragraph tag to which you want the master page to be applied. If no prefix is applied, an element tag is assumed. Spell the name correctly, using the same capitalization that the element or paragraph tag uses. This column is required for master pages to be applied.

 

•               Under the Right-Handed Master Page column heading, type the name of the master page you want to apply. The specified master page is applied to all body pages, including left-handed pages in double-sided documents on which the elements or paragraph tags appear, unless you specify a different master page under the Left-Handed Master Page column. Master page names are case-sensitive. This column is required for master pages to be applied.

•               Under the Left-Handed Master Page column heading, type the name of the master page that you want to apply to the left-handed body pages on which the elements or paragraph tags appear in double-sided documents. This column is optional.

 

•               Under Attribute Name, type a valid attribute name to further define the mapping context.

 

•               Under Attribute Value, type a valid attribute value to further define the mapping context.

 

•               Under Context, type a value for an element’s context label to further define the mapping context.

 

•               Under the Range Indicator heading, type Single to apply the master page only to the body page on which each element or paragraph tag appears; type Span pages to apply the master page to the entire span of pages to which the element or paragraph tag is applied; or type Until changed to apply the master page to all pages until the next body page with a different element or paragraph tag listed in the mapping table is encountered. If this cell is blank, master pages are applied to single pages.

 

•               Add notes to the Comments column. Text you type in this column does not affect how master pages are applied in any way.

 

•               To map additional master pages to elements or paragraph tags, add and fill out additional table rows.

5)           Choose View > Body Pages.

 

6)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

7)           Choose Format > Page Layout > Apply Master Pages, and then click Yes to override manually applied master pages.

 

FrameMaker searches each body page for the first occurrence of any element or paragraph tag specified in the Master Page Maps table. When it finds text containing the specified element or paragraph tag, it applies the specified master page.

3.4.5.                Display master pages

When working with master pages, you move back and forth between them and the body pages. When a master page is visible, its name and the number of master pages in the document appear in the Page Status area of the status bar.

Page Status area of status bar

[image: pl_master_statusbar.png]

1)            

Choose View > Master Pages. The master page used by the current body page appears, with the text frame and column borders visible.

 

View other master pages when a master page is visible

1)            

Do one of the following:

 

•               Click the Next Page or Previous Page button.

 

•               Press the Page Up or Page Down key.

 

•               Use the scroll bar.

 

Return to body pages while master pages are visible

1)            

Choose View > Body Pages. The most recently displayed body page appears. If FrameMaker detects any layout overrides on body pages, an alert message asks how you want to handle them.

Related links:

About layout overrides

3.4.6.                View, create, and delete reference pages

  

Display reference pages

1)            

Choose View > Reference Pages. The name of the current reference page appears in the Page Status area of the status bar.

 

Page Status area

[image: pl_ref_statusbar.png]

 

If the document doesn’t contain any reference pages, the Add Reference Page dialog box appears. Create the first reference page by entering a page name and clicking Add.

 

View other reference pages when a reference page is visible

•                

Click the Next Page 

[image: P_NextPage_16x13_N.png]

or Previous Page 

[image: P_PreviousPage_16x13_N.png]

button.

 

•               Press the Page Up or Page Down key.

 

•               Use the scroll bar.

 

Create a reference page

1)            

Display reference pages and choose Special > Add Reference Page.

2)           Enter a name for the reference page and click Add.

 

Return to body pages

1)            

Choose View > Body Pages. The most recently displayed body page appears.

 

Rename or delete a reference page

You can rename a reference page—for example, to avoid overwriting the refer­ence page when you import reference pages from a template that contains a reference page with the same name.

If you delete a reference page that contains a graphic used in a paragraph format, the graphic no longer appears in paragraphs using that format. When this happens, the Frame Above or the Frame Below pop-up menu in the Advanced properties 

[image: ParaDesAdvanced.png]

of the Paragraph Designer is set to As Is for the para­graphs.

1)            

Display the reference page and do one of the following:

 

•               To rename the page, click the page name in the status bar, and type the new name. Click Set.

 

•               To delete the page, choose Special > Delete Page.

 

3.4.7.                Use reference frames on reference pages

You can use a graphic as part of a paragraph format if you have placed the graphic in a reference frame on a reference page.

Graphics in reference frames
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When you select a reference frame on a reference page, its name appears in the status bar after the word Frame.

 

Create a reference frame on a reference page

1)            

Click the Graphic Frame tool 
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 on the Tools panel, and then drag to draw the frame. To draw a square frame, Shift-drag.

 

2)           Enter a name in the Name text box and click Set. Use a short, descriptive name you can recognize later when the name appears in the Frame Above and the Frame Below pop-up menus in the Advanced properties 

[image: ParaDesAdvanced00002.png]

 of the Paragraph Designer.

 

3)           Put a graphic in the frame. You can draw the graphic, import a graphic file, or combine drawn and imported graphics.

4)           Adjust the frame’s size and shape if necessary. When you use a reference frame above or below a paragraph on a body page, the whole frame—not just the graphic inside it—appears on the body page. The height of the frame affects the spacing of text above and below the frame.

 

5)           Use the Text Line tool to type the frame’s name above the frame. Typing the name helps you identify the frame when you view the reference page. It does not rename the reference frame.

 

Rename a reference frame

1)            

Select the reference frame and click the frame’s name in the status bar.

 

2)           Enter the new name and click Set. You should also type the new name in the text line above the reference frame. If you rename a reference frame used in a paragraph format, you need to update the format so that it uses the new frame name.

 

 

Change other properties of a reference frame

1)            

Select the frame and use either Graphics > Object Properties or the options on the Tools panel.

 

Set up boilerplate graphics on reference pages

You can set up boilerplate graphics—for example, margin symbols—in anchored frames on a reference page. Then you can copy the anchored frames to body pages. When you do this, the graphics appear correctly positioned in their anchored frames.

You can copy and paste boilerplate graphics onto body pages.
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You can also place graphics directly on reference pages and then copy and paste them anywhere on body pages.

1)            

Create a reference page with the same column layout as the body page on which you want to display the graphic. This ensures that the graphic is positioned correctly when you copy it to body pages. To set up the column layout, you can copy the text frame from a body page and paste it on the reference page.

 

On the reference page, set up the anchored frame exactly as you want it to appear on body pages.

 

2)           Draw the graphic in the anchored frame, or paste or import it into the frame. You may want to add some text outside the anchored frame to identify the graphic. For example, in the illustration, Caution Symbol identifies the graphic.

 

3.5.                   Page layouts

You can make changes to a document’s basic page layout directly from a body page. FrameMaker automatically updates both the left and right master pages, and updates the layout of any body pages that use those master pages. If any of these body pages contain layout overrides, you are asked to confirm that you want to make the updates.

If your document uses another master page—for example, for the first page of the document—you must make any layout changes on that master page.

3.5.1.                Change page size

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Page Size.

 

3)           Do one of the following:

 

•               Choose a standard size from the Page Size pop-up menu. The correct dimensions appear in the Width and Height text boxes.

•               Enter dimensions in the Width and Height text boxes. Custom appears in the pop-up menu. The custom page size you specify can be small, depending on the document’s margin settings, or as large as 216 inches by 216 inches (approximately 548 centimeters by 548 centimeters).

 

4)           Click Set.

 

note:  If the document contains custom master pages, FrameMaker prevents change to a page size that cannot accommodate the text frames on those master pages.

3.5.2.                Change pagination

You can change a single-sided document to double-sided documents or the reverse. When you set up a double-sided document, you specify whether the first page is a left or a right page.

1)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Pagination.

 

3)           Select one of the options in the Pagination area. If you select Double Sided, also specify whether the first page is a left or right page. If you are applying pagination in a book, you can choose Read from File to use the page side specified in the file, or you can choose Next Available Side to avoid a blank page.

 

Depending on which option you selected, a blank page may be added to the previous file in the book so that the document can start on the page you specified.

 

4)           Click Set. If the document contains custom master pages or page layout overrides, an alert message asks how you want to proceed.

 

3.5.3.                Add or delete empty pages

You can specify that you want a document to have an even or odd number of pages. If necessary, FrameMaker adds a blank page at the end of the document to achieve the correct pagination.

Conversely, a document may contain unwanted blank pages at the end, left there because you deleted or reworked text. You can tell FrameMaker to delete these empty pages whenever you save or print the document.

FrameMaker deletes a blank page only if it uses the left or right master page, doesn’t contain the start of a flow, and has no layout overrides. FrameMaker doesn’t delete a page if it contains an empty paragraph but is otherwise blank.

If you use the document window to change the pagination of a document that is part of a book, the settings may be overridden when you update the book. You can make sure that the book pagination is correct by changing a document’s setup from the book window.

1)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Pagination.

3)           From the Before Saving & Printing pop-up menu, choose an option and click Set.

 

If blank pages are not added or deleted as expected, make sure that all pages in the document are autoconnected.

Related links:

About layout overrides

3.5.4.                Change page margins and number of columns

The margin is the distance between the page edge and the text frame. For a single-sided document, you set margins for the top, bottom, left, and right sides of the text frame. For a double-sided document, you set the top, bottom, inside, and outside margins for a symmetrical look.

To set up asymmetrical left and right margins, you change the text frames directly on the master pages. For example, you could make the text frames on both the left and right pages appear on the right side of the page, leaving an area of white space on the left.

You can divide a text frame into two or more equally spaced columns of equal widths. To create a multicolumn layout with unequal column widths or gaps, use one text frame for each column of text and position the text frames one by one. Draw the text frames or set up one text frame the way you want it and then duplicate it.

1)            

Place the insertion point in the main text flow or click in the page margin. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Column Layout.

 

If the layout is asymmetrical (for example, with a different number of columns, or a different inside or outside margin on the left and right master pages), an alert message asks whether you want to proceed. To retain the asymmetry, change the layout directly on the master pages.

 

3)           To change the margins, enter the values in the Margins area. The margins and the gap (space) between columns determine the individual column width.

 

4)           To change the number of columns or the gap between columns, enter new values in the Columns area.

 

All columns will be the same width and will be separated by a uniform gap.

 

5)           Click Update Entire Flow. If the new column width is too narrow to accommodate some anchored frames or tables in the document, an alert message asks whether you want to proceed. If you click OK, you can manually resize the tables and frames.

 

Related links:

Changing page layout on specific pages

Add a template text frame on a master page

Adding text frames on body pages

3.5.5.                Headers, footers, and other background text

    You set up headers and footers by displaying master pages and typing text in background text frames. The contents of background text frames appear on body pages, but you can only edit them on master pages. The headers and footers might include the page number, date, chapter number and title, section number and title, author, revision number, and draft release (such as prelimi­nary and final).

Header and footer text frames on master page
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You create and edit header and footer text as you do any other paragraph text. You can apply paragraph and character formats, add and move tab stops, and add graphics such as a line above or below the text. In addition, you can add system variables for information such as the page number or the current date, and you can change the size and placement of the header and footer text frames. When you modify these text frames on a master page, FrameMaker automati­cally updates any body pages that use that master page.

You can also add other background text on master pages. For example, in the FrameMaker fax template, the informational headings are in a background text frame on the master page.

Background text frames
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A.

Informational headings in background text frames

B.

Template text frame

 

Related links:

Entering header or footer information

Creating and modifying background text frames

When you create a new, blank document, FrameMaker creates background text frames for headers and footers on the left and right master pages. To make it easy to add centered and right-aligned information in headers and footers, FrameMaker automatically adds center and right tab stops at the center of the text frame and at the right margin. You can draw background text frames for additional header and footer information or for other background text.

note:  You can create single lines of background text by using the Text Line tool, but you can’t apply paragraph formats to the text or insert variables in it.

 

Add a background text frame on a master page

 

1)           Draw the text frame by using the Text Frame tool.

 

2)           In the Add New Text Frame dialog box, click Background Text and click Add. The new text frame, like all text frames for background text on master pages, is untagged.

3)           Double-click in the text frame to place the insertion point, and then insert the header, footer, or other background text.

Resize or move a background text frame

 

1)           Select the text frame by Control-clicking the text frame.

 

2)           Do any of the following:

 

•               To resize the text frame, drag a handle.

 

•               To move the text frame, drag its border (not a handle).

 

 

Entering header or footer information

You can create simple headers and footers by typing text in the header and footer text frames on the master pages. In addition, you can specify items such as the current chapter and page numbers, the document’s total page count, and the current date. FrameMaker displays a system variable in the header or footer on the master page and replaces it with the correct value on each body page that uses that master page.

You can also create running headers and footers in which the text changes from page to page. In the following figure, the running header contains the current section heading; the footer contains the page number and some text typed directly into the background text frame.

Running headers and footers
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To create running headers and footers, you insert running header/footer vari­ables in background text frames on master pages.

 

Enter text, page numbers, dates, and other information

 

1)           On a master page, click in the header or footer where you want to add information.

 

2)           Do any of the following:

 

•               To insert static text, type the text.

 

•               To insert system variables, access the Variables pod and double-click the variable name in the Variables scroll list. You can insert any system variable, such as:

 

Numbering for book components

Volume Number, Chapter Number, Section Number, or Sub Section Number

 

Page numbers

 

Current Page # or Page Count

 

Date information

 

Current Date (Long), Current Date (Short), Modification Date (Long), Modification Date (Short), Creation Date (Long), or Creation Date (Short)

 

Other variables

 

Chapter Title Name, Filename (Long), Filename (Short), Table Continu­ation, or Table Sheet

 

•               To insert user variables, access the Variables pod and double-click the variable name (if already defined) in the Variables scroll list.

tip:  To add centered information in headers and footers, press Tab to move the insertion point to the centered tab stop. To add right-aligned informa­tion, press Tab again to move the insertion point to the right-aligned tab stop.

 

Related links:

System variables

User variables

3.5.6.                Changing page layout on specific pages

You can create an asymmetrical layout by adding or changing text frames directly on the master pages. For example, you may want the left margin to be wider than the right on both left and right pages. Or you may want a single-column layout on the left page and a two-column layout on the right. You can even create a layout that contains columns with different widths or with different gaps by using several text frames on a page—one text frame for each column.

About layout overrides

When you make changes on a master page, FrameMaker automatically updates all body pages using that master page. When you make layout changes on a body page (for example, by changing the number of columns, the gap between columns, or the margins), you create an override to its master page’s layout. You can then do any of the following:

•                

Update the master page and all corresponding body pages with your changes.

 

•               Create a master page based on the body page changes.

•               Do neither of the above, leaving the override as a one-time-only page layout.

 

Related links:

Updating body and master page layouts

Create custom master pages

Creating one-time-only page layouts

Change margins and column layout on specific pages

The following steps always produce either a single-column layout or a multi­column layout with equal-width columns.

If you want to create a multicolumn layout with unequal column widths or gaps, use one text frame for each column, and position the text frames one by one.

1)            

Select the text frame whose margins you want to change by Control-clicking the frame.

 

2)           Choose Format > Customize Layout > Customize Text Frame.

 

3)           Do the following:

 

•               To change the margins, specify the new size and position in the Unrotated Size and Offset From areas. The Offset From Top and Offset From Left options specify the top and left margins. The bottom and right margins are then determined by the text frame’s width and height.

 

•               To change the number of columns or the gap between columns, change the values in the Columns area.

 

4)           Click Set.

 

tip:  Another way to change the margins is to select a text frame and then drag a resize handle. When you resize a multicolumn text frame, the column widths change to fit within the text frame, but the column gap remains the same.

Related links:

Add a template text frame on a master page

Adding text frames on body pages

Add a template text frame on a master page

For a master page to contain unequal-width columns of text, or to set up the layout for a newsletter or other document in which the articles don’t flow continuously from the first page to the last, you use multiple text frames—one for each column. For example, for a page with two unequal-width columns, you would add a second template text frame. You can add a template text frame by drawing it or by duplicating an existing one.

1)            

To draw the text frame, use the Place A Text Frame tool on the Graphics Toolbar. To draw more than one text frame, draw them in the order you want them connected.

 

2)           In the Add New Text Frame dialog box, click Template For Body Page Text Frame, and choose a tag from the Flow Tag pop-up menu. Choose the current flow tag, unless you’re setting up a text frame for a different flow in a multiflow document.

 

3)           In the Columns area, specify the number of columns in the text frame and (if it’s more than 1) the gap between adjacent columns. If you’re setting up a layout with unequal-width columns, set the number of columns to 1, because you use a separate text frame for each column.

 

4)           Click Add.

 

5)           Move the text frame as needed.

 

tip:  To copy an existing text frame, select the frame, choose Edit > Copy, and then choose Edit > Paste. FrameMaker copies the text frame, its contents, and its prop­erties (including the flow tag).

Adding text frames on body pages

When you draw a text frame on a body page, you are prompted for the number of columns and the gap between them. However, FrameMaker does not assign a flow tag and does not connect the text frame to existing text frames on the page. To use the new text frame as part of the document’s text flow, connect it to the flow. If the new text frame is the first one in the flow, also select Autocon­nect so that new pages are automatically added as needed.

Related links:

Connect text frames

Updating body and master page layouts

You can change template text frames on more than one master page and then update all corresponding body pages in one step. However, if you make column layout changes on a body page, you must update the corresponding master page before you can update the other body pages that use that master page.

Before FrameMaker updates body pages, it checks whether any body pages have column layouts that override their master page. If any pages contain layout overrides, you specify whether to keep the overrides.

 

Update body pages with master page changes

 

1)           After making layout changes on master pages, display body pages.

2)           If FrameMaker displays an alert message, specify whether to keep or remove layout overrides, and then click Continue. If you keep layout over­rides, FrameMaker updates those body pages with the master page’s back­ground text and graphics, but does not update the template text frames.

 

Update a master page with body page changes

 

1)           Choose Format > Page Layout > Update Column Layout. A message asks you to confirm the master page and body pages that are to be updated.

 

2)           Click Update.

 

3)           If FrameMaker displays an alert message, specify whether to keep or remove layout overrides on the pages being updated, and then click Continue.

 

Related links:

About layout overrides

Creating one-time-only page layouts

You may need to change the layout of only one body page in a document. For example, you can make a text frame longer to fit one more line of text on the page, or shrink a text frame to make room for a graphic placed directly on the body page. When you change the column layout of a body page without updating the master page, you create a layout override.

Related links:

Change margins and column layout on specific pages

Adding text frames on body pages

3.5.7.                Align text across columns

 

Balance text across columns

In a layout that uses a multicolumn text frame, you can balance the text across columns that aren’t full of text—for example, columns on partly empty pages that precede forced page breaks, and columns on the last page of a document. You can balance text across columns throughout a text flow or in an individual text frame.

Balancing off and on
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Balance text across columns throughout a text flow

 

1)           If a document window is active, place the insertion point in the main text flow or click in the page margin. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Column Layout.

 

3)           Select Balance Columns and click Update Entire Flow.

 

Balance text across columns in a single text frame

 

1)           Click in the text frame and choose Format > Customize Layout > Customize Text Frame.

Select Balance Columns and click Set.

 

Feather text to the bottom of text frames

When FrameMaker feathers text, it first adds space between paragraphs, up to a limit that you set. If more adjustment is necessary, it adds space between lines, up to another limit that you set. FrameMaker does not feather the text in a text frame in which text runs around graphics.

Before and after feathering

[image: pl_21.png]

In a multicolumn text frame that contains straddles—paragraphs, tables, or anchored frames—FrameMaker adds vertical space to align the last baselines of text in adjacent columns above each straddle.

Before and after feathering with straddling
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When text is feathered, the display of pages may be slower. For this reason, you may want to feather text only after you finish editing a document.

1)            

If a document window is active, place the insertion point in the main text flow. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Page Layout > Line Layout.

 

3)           Select Feather, and enter the maximum amount of space FrameMaker can add between lines (Maximum Interline Padding) and between paragraphs (Maximum Inter-Pgf Padding).

 

FrameMaker will not exceed the padding limits you set. If it’s not possible to feather text in a column without exceeding the limits, FrameMaker does not feather text in that column.

 

4)           Click Update Flow.

 

note:  Feathering leaves room for the largest possible descender in the largest font size used in the line, even if no character with such a descender actually appears. If the last line in a column seems too high, check to see whether the column contains a nonprinting character (such as an anchor symbol) in a font that’s larger than that of the surrounding text.

Synchronizing baselines

When you synchronize (align) text in a flow, FrameMaker creates an invisible grid in each text frame and aligns the baseline of the first line of each specified paragraph to the grid. FrameMaker also aligns the first line after an anchored frame and tries to align the first line in each column.

note:  If feathering and synchronization are both on for a flow, feathering takes precedence over synchronization. However, the first lines in the columns are synchronized with each other.

Before and after synchronizing
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Because headings in large fonts often appear at the tops of columns, you can specify a first-line synchronization limit. This limit controls whether the base­line of a heading is placed on the first grid line when the heading falls at the top of a column, even when the heading’s default font is larger than the grid can accommodate. To place the baseline of a heading on the first grid line, FrameMaker lets the heading extend above the top of the column as shown in the illustration. FrameMaker does not synchronize font sizes larger than the limit you set.

 

Synchronize baselines across columns

 

1)           Check the paragraph formats of the paragraph types you want to synchro­nize to make sure they all have the same default font size and line spacing. Fixed line spacing should be on.

 

2)           Click in the flow you want to synchronize (or select the documents in the book that you want to affect) and choose Format > Page Layout > Line Layout.

 

3)           Select Baseline Synchronization and turn off Feather.

 

4)           In the Synchronization area, enter the line spacing you want to use for the text frame grid in the Synchronize Pgf’s With Line Spacing Of text box. Use the same line spacing as in the paragraphs you want to synchronize. Otherwise, FrameMaker will not synchronize the paragraphs with the text frame grid.

 

5)           In the First-Line Synchronization Limit text box, enter the largest font size to align at the top of a column. For example, suppose the line spacing for body paragraphs is 12 points, the column grid is 12 points, and the head­ings are 18 points. If you want the headings to be aligned when they appear at the top of a column, specify 18 as the first-line limit.

 

6)           Click Update Flow. As no descenders appear above the first line in a column, the first grid line is offset from the top of the column a distance equaling two-thirds of the specified line spacing.

 

Synchronize baselines in adjacent text frames

 

If the tops of adjacent text frames start at different positions on a page, you may need to adjust their tops to line up their grids.

 

1)           Line up the grids by resizing adjacent text frames so that the distance between their tops is evenly divisible by the grid. For example, if the grid is 12 points, you can start a text frame 144 points (12 times 12 points) from the top of an adjacent text frame.
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 A. 

Grid spacing

 B. 

Distance evenly divisible by the grid

 

tip:  Use the snap grid to correctly position the text frames. To do so, specify a snap grid equal to the text frame grid. Then resize the text frames until their tops snap to the grid.

 

 

3.6.                   Multiflow documents

A document can have separate text flows, each with its own text frame connec­tions. For example, a bilingual document may contain side-by-side translations of the same text.

When a text frame fills in a multiflow document, you can tell FrameMaker not to add a new page. That way, you can add pages yourself and control the connec­tions. Because each flow’s autonumbering is independent of the numbering in other flows, you can maintain separately numbered lists, headings, and figure titles for each flow.

3.6.1.                Set up a multiflow document

 

About text flows and flow tags

A text flow is a series of connected text frames through which the text flows in a document. Most documents have a single text flow, from the first page to the last, in which FrameMaker handles the text frame connections automatically. You make the text frame connections yourself only for documents in which you need to weave several text flows together—for example, with a newsletter in which you need to continue a front-page article on the back page, skipping over other articles on the intervening pages.

The current text frame’s flow tag appears in the Tag area of the status bar.

Tag area of status bar
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Set up a side-by-side flow

You set up a document with side-by-side text flows by laying out and connecting the text frames on the master pages. Because the text frame connec­tions are the same throughout the document, you usually don’t need to make further changes on the body pages.

1)            

Set up the flows on one of the master pages. Use a text frame for each flow and assign a different flow tag to each text frame. Make sure that Autocon­nect is on for each flow so that FrameMaker adds a new body page when­ever text reaches the end of one of the flows.

 

Left and right master pages for a side-by-side flow
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2)           Repeat the previous step for the remaining master pages. All master pages should have the same flow tags. Otherwise, FrameMaker will not alternate properly between the left and right master pages when adding body pages.

important:  To create a new body page correctly when text reaches the bottom of a text frame, the appropriate left or right master page must contain all of the flow tags on the current body page. If any flow tag is missing, FrameMaker creates the new page with the current body page’s master page instead.

 

3)           Update the body pages with the master page changes by displaying body pages.

 

Related links:

Add a template text frame on a master page

Change a flow’s tag or Autoconnect setting

Set up a flow for a newsletter or magazine

You set up a newsletter or magazine that requires nonparallel, multiple flows by establishing a column layout on the master pages. However, the master pages act only as the basic layout grid. You resize, delete, connect, and disconnect the text frames on the body pages until they look right. This approach gives you the greatest flexibility in determining the way text flows through the document.

note:  If you are creating a newsletter or magazine that has articles that flow consecutively from the first page to the last, you do not need to use the techniques described here. Instead, you can use a single text flow. You can create special effects by making text run around graphics, and by making paragraphs, tables, and frames straddle columns. For an example of this technique, see the newsletter template provided with FrameMaker.

1)            

Decide on the number of columns, and place that number of single-column text frames on each master page. All of the text frames should be in the same flow. You can use these text frames as the layout grid within which you’ll have text flow.

 

First master page
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Left and right master pages with the same flow

[image: pl_31.png]

 

2)           Turn off Autoconnect so that FrameMaker will not automatically add pages.

 

3)           Update body pages with the master page changes by displaying body pages.

 

4)           On each body page, resize, disconnect, and connect text frames as neces­sary. Don’t update the master pages as you make changes on the body pages.

 

5)           To synchronize text baselines in the newsletter, make sure that the text frames are placed appropriately. If the document contains several text flows, synchronize baselines for each flow.

 

6)           Manually create new disconnected body pages as necessary.

 

7)           Connect text frames between pages as necessary.

 

Related links:

Add a template text frame on a master page

3.6.2.                Control the flow of text

A flow’s basic properties are its Autoconnect setting and its flow tag. In a docu­ment with one flow or parallel flows, Autoconnect is usually on to tell FrameMaker to add a new page whenever the flow’s text frames are full. The new page takes the column layout of the appropriate master page (left or right), and the text frames on the new page are automatically connected to the text frames on the original pages.

When working on a document with nonparallel, multiple flows, you usually turn off Autoconnect. This allows you to add a new, disconnected body page wherever you want, and to control the connections between it and existing pages. If Autoconnect is off, and if the flow contains more text than it can hold in its text frames, the text overflows at the end of the last text frame in the flow. The bottom border of an overflowing text frame appears as a solid line when borders are visible.

Overflowing text frame
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If you try to type in an overflowing text frame, you hear a beep. Overflowing text is not deleted; it is hidden from view. As soon as you connect the overflowing text frame to another text frame, the hidden text reappears in the next text frame.

If you need to assign a flow tag (for example, when creating side-by-side text flows), you can do so at any time. (In a new, blank document, the main flow is tagged A.) You need to assign a tag only once for a flow. After that, connecting a text frame to the flow assigns the tag to the text frame. If you change the flow tag or the Autoconnect setting in one text frame in a flow, the change is made to the entire flow.

Change a flow’s tag or Autoconnect setting

You normally change flow tags and the Autoconnect setting on master pages. If two text frames are connected, you must disconnect them before you can change one of their flow tags.

1)            

Click in a text frame in the flow.

 

2)           Choose Format > Customize Layout > Customize Text Frame.

 

3)           Enter a tag for the flow in the Flow Tag text box. You should keep flow tags short so that they do not obscure other information in the Tag area of the status bar. You cannot assign a tag that is already used on the current page.

 

note:  If you want two text frames on a page to have the same flow tag, connect the text frames.

 

4)           If you want FrameMaker to add a new page when you fill the last column on a page, select Autoconnect.

 

5)           Click Set.

 

Related links:

Connect text frames

Disconnect text frames

Add a new, disconnected page

In documents with one main flow or two parallel flows, you normally don’t add disconnected body pages; you let FrameMaker add connected pages automati­cally when necessary. In a multiflow document in which Autoconnect is off, or in other specialized documents, you can add new, disconnected body pages. When the text reaches the end of a text frame, you add a new page and connect the text frames.

1)           From a body page, choose Special > Add Disconnected Pages.

 

2)           Choose the location and number of pages you want to add.

 

3)           Choose a master page from the Use Master Page pop-up menu and click Add.

 

Delete disconnected pages

When you delete disconnected pages in a multiflow document, FrameMaker also deletes the pages’ contents.

1)           Click in a page you want to delete and choose Special > Delete Pages.

 

2)           Specify the first and last disconnected pages you want to delete and click Delete. If you want to delete only one page, enter its page number in both text boxes.

 

Connect text frames

When two text frames are connected, the text flows from the end of the first text frame to the beginning of the second. You can connect a text frame on a master page to any other text frame on the same master page, and you can connect a text frame on a body page to any text frame on any body page. You can also connect a text frame in the middle of a flow.

When you connect two text frames, FrameMaker assigns the first text frame’s flow tag to the second frame. If the first text frame is untagged, the second frame’s tag is used. That way, all connected text frames belong to the same flow and have the same tag. If the first text frame contains overflowing text, the text flows into the second frame when you make the connection.

1)            

Select the two text frames in the order in which you want text to flow. To select the text frames, Control-click the text frames.

 

If the text frames are on different pages, the first frame is deselected when you select the second one, but FrameMaker keeps track of the first selec­tion.

 

note:  To add a text frame to the middle of a flow, first select the text frame you want to add, and then select the frame that should follow it.

 

2)           Choose Format > Customize Layout > Connect Text Frames. If the first text frame you selected isn’t on a page that’s currently visible, an alert message asks whether you want to connect to that frame.

 

Disconnect text frames

You disconnect text frames when you want to create separate flows—for example, to place an article in a specific location in a newsletter, or to create a pull-quote. If you need to start a new flow in the middle of a column, you can split the text frame that contains the column in two, and then disconnect the two text frames.

You can disconnect a text frame from the preceding text frame, the following one, or both. You can also remove a text frame from the middle of a flow.

Disconnecting text frames does not affect existing text in the frames. To move text to a different text frame, cut and paste it after disconnecting the frames.

note:  When you disconnect text frames on the same body page, FrameMaker creates separate flows with no flow tags. When you disconnect text frames on different body pages, FrameMaker creates separate flows with the same flow tag. In either case, if you’re creating a newsletter-type document where Autoconnect is off for each flow, the flow tags do not matter. FrameMaker does not create new pages automatically and, thus, there is no need to make text frame connections.

1)           Select the text frame you want to disconnect by Control-clicking the text frame.

 

2)           Choose Format > Customize Layout, and then choose Disconnect Previous, Disconnect Next, or Disconnect Both.

 

Remove a text frame from the middle of a flow

1)            

Select the text frame immediately preceding the one you want to remove. To do this, Control-click the text frame.

 

2)           Select the text frame immediately following the text frame you want to remove.

3)           Choose Format > Customize Layout > Connect Text Frames. If the first text frame you selected isn’t on a page that’s currently visible, an alert message asks whether you want to connect to that frame.

 

Split or unsplit text frames

You can split a text frame in two, and then disconnect the two text frames to start a new flow. For example, you may want a new article with its own flow to start in the middle of a text frame.

The second of three text frames is split, disconnected from the first text frame, and retagged.
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Split text frames

 

1)           Click in the line above where you want to split the text frame and choose Format > Customize Layout > Split Text Frame. FrameMaker splits the text frame below the line that contains the insertion point, creating two separate but connected text frames.

 

2)           Select the bottom text frame by Control-clicking the text frame.

 

3)           Disconnect the text frame from the previous one by choosing Format > Customize Layout > Disconnect Previous. If the flow was tagged, FrameMaker removes the flow tag. If Autoconnect was on before you disconnected the text frames, it is now off for both text frames.

 

4)           Resize the text frames as necessary.

 

Unsplit text frames

 

•               If you haven’t made any other changes since splitting the text frame, choose Edit > Undo.

•               If you made another change but you have not yet disconnected the two text frames, delete the lower frame and then resize the remaining text frame to the size of the original unsplit frame.

 

•               If you have already disconnected the two frames, cut the text from the second text frame and paste it at the end of the first text frame. Then delete the second text frame and resize the first one to the size of the original unsplit frame. If you need to turn Autoconnect back on or reassign a flow tag for the text flow, use Format > Customize Layout > Customize Text Frame.

 

Cross-reference a disconnected text frame

When an article in a newsletter or magazine continues from one page to another, you can use cross-references to tell the reader where to turn to continue reading and to indicate where the end of the article is continued from.

Indicate where the flow continues, and where it is continued from.
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1)            

Resize the two text frames to make room for the cross-references. Drag the bottom of the first text frame upward and the top of the continuation text frame downward.

 

2)           Draw a small text frame below the text frame on the first page, and another above the text frame on the continuation page. Don’t connect either text frame to any other text frame.

 

3)           Insert a cross-reference in the empty text frame on the first page, referring to the continuation page of the article.

 

4)           Insert a cross-reference in the empty text frame on the continuation page, referring to the first page of the article.

 

 

Tracking a text flow

In a document with many flows, it’s easy to lose sight of where a flow continues. You can zoom out to see more of a text flow or move from one text frame in a flow to the next.

1)            

Zoom out to 25% and adjust the window size to see as many pages as necessary.

 

2)           Click in the flow you want to check and choose Edit > Select All In Flow. The flow is highlighted, showing how it traverses the pages of the docu­ment.

 

3)           To move through a flow’s text flow’s text frames, do one of the following:

 

•               To display the next connected text frame, click in the last line of a text frame and press the Down Arrow key.

•               To display the preceding connected text frame, click in the first line of a text frame and press the Up Arrow key.

 

3.7.                   Variables

 

3.7.1.                About variables

You can include text that frequently changes and appears often in your docu­ment as variables. Variables are also useful for providing information that is updated automatically, such as the current date. In FrameMaker, you have system variables and user variables. System variables are maintained by FrameMaker, such as current date or filename. User variables are variables that you define in FrameMaker, such as company name or product name.

System variables

Each system variable has a name and a definition. Although you cannot rename system variables, you can edit their definitions. A system variable definition can contain the following items:

•                

Building blocks for system information, such as the month, day, year, and filename

 

•               Text characters, such as the comma and the spaces that appear in the date May 1, 2010 

•               Building blocks for character format changes

 

For example, the Table Sheet variable that appears in a table title as (Sheet 3 of 5) has the following definition.
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 A. 

Text you type

 B. 

Building blocks

You can change the definition—the way the information is displayed—by adding, removing, or rearranging building blocks and by editing the text in the definition. For example, you can change the format used to display the current date.

The most common way to use system variables is in document templates as part of background text frames, such as headers and footers. A background text frame is on a master page and doesn’t have a flow tag. For example, the Current Page # and Running H/F variables can reside only in a background text frame on a master page. The values of these variables appear on the corresponding body pages. You can use system variables to create running headers and footers that contain chapter titles, section headings, or information that changes from page to page.

System variable names appear on master pages.
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FrameMaker provides values on body pages.
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The values of system variables inserted on master pages are updated automati­cally. However, if you place a system variable on a body or reference page, the value is updated only when you open or print the file.

You can also manually update the value of the variable when the file is open. Access the Variables pod and click Update.

note:  Variables and variable names support the Unicode text encoding stan­dard.

 

Default values for system variables

 



	
System variable

 


	
Default definition (US English version)

 


	
Example of display

 





	
Current Page #

 


	
<$curpagenum>

 


	
3

 





	
Page Count

 


	
<$lastpagenum>

 


	
18

 





	
Current Date (Long)

 


	
<$monthname> <$daynum>, <$year>

 


	
October 11, 2010

 





	
Current Date (Short)

 


	
<$monthnum>/<$daynum>/<$shortyear>

 


	
10/11/10

 





	
Modification Date (Long)

 


	
<$monthname> <$daynum>, <$year>, <$hour>:<$minute00> <$ampm>

 


	
September 24, 2011, 10:48 am

 





	
Modification Date (Short)

 


	
<$monthnum>/<$daynum>/<$shortyear>

 


	
9/24/11

 





	
Creation Date (Long)

 


	
<$monthname> <$daynum>, <$year>

 


	
July 1, 2010

 





	
Creation Date (Short)

 


	
<$monthnum>/<$daynum>/<$shortyear>

 


	
7/1/10

 





	
Filename (Long)

 


	
<$fullfilename>

 


	
c:\Memos\Staffing.fm





	
Filename (Short)

 


	
<$filename>

 


	
Staffing.fm

 





	
Table Continuation

 


	
(Continued)

 


	
(Continued)

 





	
Table Sheet

 


	
(Sheet <$tblsheetnum> of <$tblsheetcount>)

 


	
(Sheet 1 of 2)

 





	
Volume Number

 


	
<$volnum>

 


	
3

 





	
Chapter Number

 


	
<$chapnum>

 


	
3

 





	
Section Number

 


	
<$sectionnum>

 


	
3

 





	
Sub Section Number

 


	
<$subsectionnum>

 


	
3

 





	
Chapter Title Name

 


	
<$chaptertitlename>

 


	
Cyclonic storms

 





	
Running H/F 1

 


	
<$paratext[Title]>

 


	
The Turbulent Oceans

 





	
Running H/F 2

 


	
<$paratext[Heading1]>

 


	
Threat of Extinction

 





	
Running H/F 3

 


	
<$marker1>

 


	
Plate tectonics

 





	
Running H/F 4

 


	
<$marker2>

 


	
Volcanoes

 





	
Running H/F 5–12

 


	
<$paratext[paratag]>

 


	
Lava

 





	
Running H/F 13

 


	
<$marker3>

 


	
Lava

 





	
Running H/F 14

 


	
<$marker4>

 


	
Lava

 





	
Running H/F 15

 


	
<$marker5>

 


	
Lava

 





	
Running H/F 16

 


	
<$marker6>

 


	
Lava

 





	
Running H/F 17

 


	
<$marker7>

 


	
Lava

 





	
Running H/F 18

 


	
<$marker8>

 


	
Lava

 






You can use the <$chaptertitlename> variable to propagate the folder name in the template associated with the folder.

 

Related links:

Add a folder

User variables

Each user variable has a name and a definition. A definition includes text and optional building blocks for the character format of the text. For example, suppose you define a variable as follows:

<BookTitleFormat>The Earth Sciences

If the BookTitleFormat character format is defined as italics, this variable appears on the page as The Earth Sciences.

You can change the definition of any user variable, for example, when the book title changes. When you change the definition, all occurrences of the variable in your document are updated to use the new definition.

The standard templates don’t provide any user variables. If you’re using one of these templates, create your own user variables. If you’re using a template created at your site, perhaps it already includes some user variables.

Valid variables in structured documents

 You can add a system variable to a structured flow, with or without a special variable element. You do not use special variable elements for user variables but insert them directly in elements defined for text.

The following building blocks in running header/footer variables are used in elements:



	
 

Building block

 


	
Meaning

 





	
<$elemtext[tag]>


	
The text (up to the first paragraph break), excluding its autonumber, but including any prefix and suffix specified in the element definition.

 





	
<$elemtextonly[tag]>

 


	
The text (up to the first paragraph break), excluding its autonumber and any prefix and suffix specified in the element definition.

 





	
<$elemtag[tag]>

 


	
The tag of the source element





	
<$elemparanum[tag]>

 


	
The entire autonumber of the first paragraph of the element.

 





	
<$elemparanumonly[tag]>

 


	
The autonumber counters of the first paragraph, including any characters between them.

 





	
<$attribute[AttributeName]>


	
The value of the attribute with the specified name (or, if no value is specified, the default value)

 





	
<$attribute[AttributeName:ElementName]>

 


	
The value of the attribute of the specified element (example, structured book element)

 






Variables in FrameMaker are exported as entities, and usually the entity name is the same as the variable name. However, if you create a variable whose name is not a valid XML or SGML name, the entity name is not the same as the vari­able name.

Here are some examples of invalid names:

•                

A name with multibyte (Asian-language) characters.

 

•               A name that includes anything other than alphanumeric characters, hyphens, or periods.

 

•               A name containing more characters than the number specified by the value of NAMELEN in the XML or SGML declarations for the particular application.

 

3.7.2.                Working with variables

 

Variables pod

You can use the Variables pod to insert, edit, or delete system and user variables.

Variables pod
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Related links:

Using pods

Insert a variable

You can insert most system variables on a body, reference, or master page.

1)           Access the Variables pod from View > Pods > Variables.

 

2)           Click to place the insertion point where you want the variable to appear in the document. If you’re inserting the Current Page # variable or a running header/footer variable, click in a background text frame on a master page.

3)           Double-click a variable from the Variables pod to insert it in your docu­ment. Alternatively, click the Insert icon on the pod toolbar.

 

The Variables pod contains the variables allowed at the insertion point in the document. For example, if the insertion point is in a text frame on a body page, the scroll list doesn’t contain the Current Page # variable. If the insertion point is in a text frame on a master page, then more variables are displayed in the Variables pod.

In most cases, the value of a variable inserted on a master page appears on both the master and the corresponding body pages. However, if you insert the Current Page # variable, a number sign (#) appears on the master page, and the actual page number appears on the body page. If you insert a running header/footer variable, the variable name appears on the master page, and the value appears on the body page.

Insert variable elements in structured documents

You can use an element to insert a variable in a structured flow. You can also insert a variable directly in text, without using a special variable element. For example, you can include the Chapter Title Name as part of a body element.

FrameMaker comes with a set of system variables. The format rules of a variable element determine which variable to use with it. You cannot change a system variable element to use a different variable.

The values of system variables you insert are updated when you open or print the document. You can also update system variables manually. (System vari­ables in headers or footers are updated when the page is redisplayed.)

1)            

Click where you want to insert the variable.

2)           Select a system variable element in the Element Catalog and click Insert.

 

3)           If the Attributes for the New Element dialog box appears, enter attribute values for the element and click Insert Element.

The current value of the variable appears at the insertion point. A bubble for the variable appears in the Structure View, with a text snippet that shows the beginning of the variable text.

 

4)           To update all variables in the current document, click Update on the pod toolbar. To update variables in all open documents, first select All Open Docs and then click Update on the pod toolbar.

 

If your application has user variables already defined, you can insert variable elements in your document. You can insert a user variable directly in text, without using a variable element. Perhaps your application has user variables already defined. You can define and maintain other user variables as needed. If the value of a user variable changes, it is updated automatically wherever it occurs.

Edit or delete a variable occurrence

If a variable is added to a master or reference page, you cannot edit its occur­rence in the body pages. In the master or reference page, you can swap the vari­able with another variable or edit the variable definition. If you edit a variable definition, then all occurrences of the variable in the document are updated.

Alternatively, you can convert a variable to editable text and then edit the text in the document. If you convert the variable to text, however, the text is no longer updated when the variable definition changes.

You can delete variable occurrences from a body page but you cannot delete a variable included in the header or footer of a master page from the body page. Also, backspacing the insertion point over a variable in the document doesn’t delete the variable. You can remove or edit a variable in the following ways:

•                

To delete one occurrence of a variable:

 

a)           Select the variable name from the Variables pod and click Edit.

b)           From the Add/Edit Variables panel or the Edit System Variables panel, select the instance from the Location list and click Delete.

•               To copy or move a variable, select it and choose Edit > Copy, Edit > Cut, or Edit > Paste.

•               To replace a variable, select the variable in the Document view, and then double-click a different variable in the Variables pod.

 

•               To delete a variable in a text inset, delete the variable in the source docu­ment.

 

note:  Deleting a variable definition converts all occurrences of the variable in your document to editable text.

Convert a variable to text

1)            

Select the variable, click Convert To Text from the Variables pod.

 

2)           Do one of the following:

 

•               To convert a single occurrence of a variable, click Selected Variable.

 

•               To convert all occurrences of a particular variable, select the variable in the Variables Named scroll list. For structured documents, you can also choose the variable element tag from the Variables With Element Tag pop-up menu.

 

•               To convert all variables in the document, click All Variables.

 

3)           Click Convert.

 

Import variable definitions

1)            

To import variable definitions from another document, choose File > Import > Formats.

Update variables across all files in a book

1)            

Update the variables in one document from the book.

2)           Select all the remaining files in the book and choose File > Import > Formats.

 

Create a user variable

A user variable is useful for a product name that can change or for a long manual name that is difficult to type each time. You can add a new variable and edit its definition from the Add/Edit Variable panel.

Add or edit existing user variable definitions from the Add/Edit Variable panel
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If you don’t specify a character format in the variable definition, the variable uses the format at the insertion point. If you change the character format for the variable, the change applies only to the variable, not to the text that follows.

1)           Click Create New User Variable from the Variables pod.

 

2)           Enter the name and definition of the variable. Use these guidelines:

 

•               Variable names are case-sensitive.

•               The complete definition, including typed text and character formats, can be up to 255 characters long.

•               You cannot use system variable building blocks for user variables.

 

•               To include an angle bracket in a variable definition as text, precede it with a backslash (\).

•               Enter a sequence of characters beginning with a backslash (\).

 

•               To create a multiline variable such as multiline address, append \r for each line. Do not press Enter to insert a line break.

 

3)           To change the character format within the variable definition, do the following:

 

•               To use a character format stored in the Character Catalog, place the insertion point in the Definition box where you want to change the character format. Then click the character format in the Character Formats scroll list. The scroll list includes all the formats in the Character Catalog of the current document.

important:  Don’t use a character format whose tag includes angle brackets.

 

•               To return the character format to the paragraph default font at the end of the variable, place the insertion point in the Definition box where you want to change the character format. Then click <Default Font> in the Character Formats scroll list.

 

4)           Click Add.

5)           To add more user variables, repeat steps 3 through 5.

 

Edit a variable definition

You can edit both system variables and user variables. For a system variable, you can edit its format by changing its building blocks in the Edit System Variable panel. To do so, select the system variable in the pod and click the Edit button.

Edit system variable definitions from the Edit System Variable panel
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If the variable is in a header or footer on a master page, redisplay a body page to see the updated definition.

For user variables, you can change the variable name and the variable format from the Add/Edit Variable panel.

Add or edit existing user variable definitions from the Add/Edit Variable panel
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note:  If a variable is in a text inset that uses the source document formats, change the variable definition in the source document.

1)            

Select the variable from the Variables pod and click Edit 
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.

2)           Do one of the following:

 

•               For user variables, edit the variable name or change its definition in the Add/Edit Variable panel and click Edit.

•               For system variables, edit the definition and click Edit.

Insert a building block for system-supplied information or for a character format at the insertion point. Click the building block in the Building Blocks scroll list. Only the building blocks appropriate for the variable appear in the scroll list. For example, <$fullfile­name> and <$filename> appear for the filename variables. All the character formats in the Character Catalog appear at the bottom of the scroll list.

 

All instances of the variable in the document are updated with the new format.

 

Changing definitions of date and time variables

 

FrameMaker includes both long and short versions of variables for the current date, the date the document was last modified, and the document creation date. FrameMaker provides the following building blocks for date and time variables.

 



	
Building block

 


	
What it displays

 


	
Example

 





	
<$second>

<$second00>

 


	
Seconds


	
8 or 32

08 or 32

 





	
<$minute>

 

<$minute00>

 


	
Minutes

 


	
8 or 32

08 or 32

 





	
<$hour>

<$hour01>

<$hour24>

 


	
Hours

 


	
8 or 12

08 or 12

08 or 22

 





	
<$ampm>

<$AMPM>

 


	
Morning or evening designation

 


	
am or pm

A.M. or P.M.

 





	
<$daynum>

<$daynum01>

 


	
Number of the day

 


	
8 or 28

08 or 28

 





	
<$dayname>

<$shortdayname>

 


	
Name of the day

 


	
Monday

Mon

 





	
<$monthnum>

<$monthnum01>

 


	
Number of the month

 


	
8 or 12

08 or 12

 





	
<$monthname>

<$shortmonthname>

 


	
Name of the month

 


	
August

Aug

 





	
<$year>

<$shortyear>

 


	
Year

 


	
1997

97

 






FrameMaker uses the language of the current paragraph to determine the language used in date and time variables. For example, the current day name variable sometimes appears as Wednesday in an English paragraph but as Mier­coles in a Spanish paragraph. If you change the language of a paragraph, the system variables in the paragraph are updated to use the new language.

If your system supports the typing of Japanese text in documents and dialog boxes, the following additional building blocks are available for Japanese dates.

 



	
Building block

 


	
Example

 





	
<$daynumkanjikazu>

 


	
[image: pl_10a.png]

 or

[image: pl_10b.png]

 





	
<$daynumkanjinumeric>

 


	
[image: pl_va_daynumkanjikazu_a.png]

 or

[image: pl_va_daynumkanjinumeric.png]

 





	
<$monthnumkanjikazu>

 


	
[image: pl_va_daynumkanjikazu_a00004.png]

 or

[image: pl_va_monthnumkanjikazu.png]

 





	
<$monthnumkanjinumeric>

 


	
[image: pl_va_daynumkanjikazu_a00005.png]

 or

[image: pl_va_monthnumkanjinumeric.png]

 





	
<$imperialyear>

 


	
1 or 10 





	
<$imperialyear01>

 


	
01 or 10 





	
<$imperialyearspecialkanjikazu>

 


	
[image: pl_va_imperialyearspecialkanjikazu_a.png]

 or

[image: pl_va_imperialyearspecialkanjikazu_b.png]

 





	
<$imperialyearspecialkanjinumeric>

 


	
[image: pl_va_imperialyearspecialkanjinumeric_a.png]

 or

[image: pl_va_imperialyearspecialkanjinumeric_b.png]

 





	
<$imperialyearkanjikazu>

 


	
[image: pl_va_daynumkanjikazu_a00006.png]

 or

[image: pl_va_imperialyearkanjikazu.png]

 





	
<$imperialyearkanjinumeric>

 


	
[image: pl_va_daynumkanjikazu_a00007.png]

 or

[image: pl_va_imperialyearkanjinumeric.png]

 





	
<$imperialera>

 


	
[image: pl_va_imperialera.png]

 






Japanese dates appear in a variable when the variable uses a Japanese font family and the Language property is set to Nihongo.

 

3.7.3.                Creating variables for running headers and footers

A running header/footer variable gives information about the contents of a page and can change from page to page. Running header/footer variables can include the number and title of the current chapter, the name of the current first-level section, or the current page number.

tip:  You can also use the <$chapnum> , <$volnum>, <$sectionnum>, or <$subsectionnum> building blocks to add chapter, volume, section, or sub-section numbers to headers and footers.

About running header/footer variables

Running headers and footers use common system variables and 12 system vari­ables provided especially for running headers and footers.

Running header/footer variables sometimes reference a paragraph with a particular tag—usually a title or heading paragraph—or marker text. You can use these variables with their default definitions. You can also customize them by changing the tag that appears in the variable definition.

You insert a running header/footer variable in a background text frame on a master page in the same way that you insert variables elsewhere.

By default, the Running H/F 1 and Running H/F 2 variables use definitions that reference the Title and Heading 1 paragraph tags, respectively. The Running H/F 3 and Running H/F 4 variables use definitions that reference markers. The Running H/F 5–12 variables use definitions that reference paragraph tags you specify. You can change these default definitions either before or after you insert the variable.

Running headers and footers based on paragraph tags

The following table contains examples of running headers and footers that reference paragraph tags.



	
Running header/footer variable definition

 


	
Explanation

 


	
Examples of display

 





	
<$paratext[Head1]>

 


	
The text of the first paragraph that FrameMaker finds with the tag Head1

 


	
Types of plate boundaries

 





	
<Header><$paratext [Head1]>

 


	
The text of the first paragraph with the tag Head1 (The text appears in the Header character format—uppercase, italic letters.)

 


	
TYPES OF PLATE BOUNDARIES 





	
<$paranum[SectTitle]>

 


	
The complete autonumber of the first paragraph with the tag SectTitle

 


	
Chapter 2

 





	
<$paranumonly[SectTitle]>

 


	
The autonumber counters for the first paragraph with the tag SectTitle

 


	
2

 





	
<$paratag[Chapter]>

 


	
The tag of the first paragraph with the tag Chapter

 


	
Chapter

 





	
<$paratext[SectTitle, AppendixTitle]>

 


	
The text of the first paragraph with either the SectTitle or AppendixTitle tag

 


	
PLATE TECTONICS

 






Displaying paragraph text, tags, or autonumbers

The most common use of running headers and footers is to show the text, auto­number, or tag of paragraphs with a specified tag. For example, a running header perhaps shows the current section heading or chapter number.

FrameMaker searches each body page to find a paragraph with the specified tag. Then it places the paragraph text, autonumber, or tag in the running header or footer for that page. If a page doesn’t contain a paragraph with the specified tag, FrameMaker searches backward through the preceding pages and uses informa­tion from the first appropriate paragraph it finds.

The following building blocks in running header/footer variables reference a paragraph tag.



	
 

Building block

 


	
What it displays

 





	
<$paratext[paratag]>

 


	
The paragraph text

 





	
<$paranum[paratag]>

 


	
The paragraph autonumber, including any text in the autonumber format

 





	
<$paranumonly[paratag]>

 


	
The paragraph autonumber counters, including any characters between them

 





	
<$paratag[paratag]>

 


	
The paragraph tag

 






Follow these guidelines for using paragraph tag building blocks:

•                

Don’t use a paragraph tag that includes brackets.

 

•               Replace paratag in the building block with the tag of the paragraph for which you want to display information. Don’t delete the brackets.

•               You can include more than one paragraph tag in the [paratag] part of a building block. When you include multiple paragraph tags, FrameMaker uses the first paragraph it finds with one of the tags. Separate the tags with commas, as in the following example: <$paratext[Head1, Head2]>

 

Display text from a marker

If the text you want for a header or footer doesn’t appear in its own paragraph, you can show text associated with a marker. For example, you can use a marker to show an abbreviated version of a title or to summarize the contents of a page. When text symbols are visible, marker symbols indicate the location of markers.

Page header contains abbreviated heading.

[image: pl_va_pageheader.png]

In this example, the marker in the heading contains the marker text Plate boundaries. A running header/footer variable then displays the marker text in the page header.

You can use two marker types for running headers or footers: Header/Footer $1 and Header/Footer $2.

1)            

Insert a Running H/F variable in the header or footer on a master page. By default, the Running H/F 3 and Running H/F 4 variables use definitions that look for markers.

 

2)           Edit the definition of the variable to use a <$marker1> or <$marker2> building block. The <$marker1> building block displays the text of a Header/Footer $1 marker. The <$marker2> building block displays the text of a Header/Footer $2 marker.

 

3)           Display a body page and click where you want to insert a marker.

 

4)           Choose Special > Marker.

 

5)           In the Marker dialog box, choose either Header/Footer $1 or Header/Footer $2 from the Marker Type pop-up menu, enter the marker text, and click New Marker. When you enter the marker text, make sure that the spaces, punctuation, and capitalization are as you want them.

note:  You can’t format marker text in the Marker Text box. To format the marker text, insert a character-format building block before the marker building block in the system variable definition.

Display a condition tag

In a document that uses conditional text, you can show a condition tag that appears on the current page in the running header or footer. A predefined vari­able is not included for this purpose. You can redefine any of the existing running header and footer variables to use the condition tag building block. Unlike the system variables that reference a paragraph or a marker, variables with the condition tag building block search only on the current page.

1)            

Insert a Running H/F variable in the header or footer on a master page.

 

2)           Edit the definition of the variable to use the <$condtag [hitag, … ,lotag, nomatch]> building block.

 

Replace hitag, lotag, and the ellipsis with one or more condition tags you want FrameMaker to find. Replace nomatch with the text you want to display if FrameMaker doesn’t find one of the tags in the definition. If you don’t want to display any text when no match exists, enter a nonbreaking space (a backslash followed by a space) in place of nomatch.

FrameMaker searches a page for the condition tags you specify. If it finds one of the tags, the tag appears in the running header or footer. If it finds more than one tag, the tag that appears first in the definition appears as the value of the variable.

Display the security level

If your document contains classified information, you can use condition tags in running headers or footers to display the highest security level on a page.

1)           Apply condition tags, such as Top Secret and Secret, to the classified infor­mation.

2)           Set up headers or footers to include these tags on pages that contain clas­sified information. For example, define the building block as <$condtag[Top Secret,Secret,Unclassified]>. This building block displays Top Secret on pages that contain both Top Secret and Secret information and Unclassified on pages that contain neither condition tag.

 

Create a dictionary-style header or footer

You can use dictionary-style headers or footers to show the range of informa­tion that appears on one body page or on two facing body pages. Dictio­nary-style headers or footers appear frequently in documents such as dictionaries, indexes, and glossaries.

Headers show first entry on left and last on right.

[image: pl_va_header_leftright.png]

1)            

Insert a different running header/footer variable in the header or footer of each of two facing master pages.

2)           Edit the definition of the variable on the left master page to use the <$para­text[paratag]> building block. Replace paratag with the paragraph tag of dictionary terms.

 

3)           In the same way, edit the definition of the variable on the right master page to use the <$paratext[+,paratag]> building block. The plus sign (+) tells FrameMaker to find the last paragraph on the page matching the tag rather than the first paragraph.

 

 

3.8.                   Templates

When you set up a template, you lay out master pages, define and apply formats, and define special text, such as cross-reference formats and variables.

tip:  For templates you create, set up a template folder that contains the related templates as well as a document that describes the templates and how to use them.

 

3.8.1.                Design the page layout

1)            

Create a document. You can start with either a custom new document or a copy of an existing document you plan to modify.

tip:  To see how facing pages look as you design the page layout, display them side by side. Choose View > Options, and then choose Facing Pages from the Page Scrolling pop-up menu. Make the document window larger and zoom out, if necessary, to fit both pages in the window.

 

2)           Define the column layout. If you started with a custom document, you have already specified the margins and the number of columns. If you’re modifying an existing document, you may want to change the column layout.

3)           Add and name any custom master pages you will need.

 

4)           Enter background text and graphics on the master pages, including headers and footers.

 

If a running header or footer shows the text or an autonumber of a docu­ment paragraph, such as a chapter or section title, it contains a Running H/F variable that refers to the paragraph. To set this up, determine the tag for that paragraph.

 

5)           Define the custom document properties, such as numbering and text options, and specify the view options.

 

Designing text formats

After designing the page layout, define how you want the text to be formatted:

•                

If your document will be opened or printed on computers other than your own, use fonts that are widely available.

 

•               Paragraph formats provide the foundation of text formatting, so set them up before setting up the character formats.

•               When creating a character format, set all the options in the Character Designer as As Is, and then specify only the settings you want to change. This way, the format will work with any paragraph format.

 

•               Use tags that express the purpose rather than the appearance of the text. For example, name a format for emphasized text Emphasis rather than Bold. Then if you decide to change to italics for emphasized text, you can redefine the Emphasis format without having to retag any text.

 

•               Use names that are easily recognizable. For example, you might name the formats for numbered lists Step1 and StepNext rather than st1 and stn. Or, if you want to use the keyboard to apply paragraph and character tags, consider naming your tags st1 Step1 and stn StepNext. That way the tags and descriptions are quickly available from the keyboard.

 

•               If the template uses more than one series of autonumbers, add a series label to the format for each autonumber. For example, define step autonumbers as S:<n+>, where S: is the series label.

 

•               In paragraph formats, use either Space Above or Space Below consistently to add space above or below the paragraph. (FrameMaker uses only the larger of the two values to determine the space between paragraphs.)

 

 

Standardizing graphics, frames, and tables

If the documents will contain graphics, frames, or tables, follow these guidelines to maintain consistency:

•                

Place standard items on a reference page. You can include graphics that users will need again and again—for example, a symbol that calls attention to notes and cautions, or an anchored frame with a standard height and width. Users can copy and paste these items as needed.

 

•               Create a paragraph format for anchored frames to provide consistent spacing around graphics. For example, a paragraph format named Frame could contain a Space Below setting of 20 points and a Line Spacing setting of zero. Then, each frame could be anchored to a blank paragraph with the Frame tag. Alternatively, you can use single-cell tables and their titles for graphics and their captions.

 

•               If you will use text frames for graphic callouts, create a paragraph format for the callouts. If you will use text lines for callouts, create a character format. (You can’t apply a paragraph format to a text line.)

 

•               Choose a color model and redefine colors and color views if necessary.

 

•               Prepare standard table formats. Not all the properties you set for tables can be imported into another document. The width of text in actual tables varies greatly, as do other properties. So, regardless of how you prepare your tables, users will probably need to adjust some of these properties themselves. Think of your tables as models for users to start with.

 

 

Setting up numbering

The page numbering for new documents is set to Restart at 1. If you are building a template for continuous page numbering in books, you may want to set the page numbering in the template to Continue Numbering From Previous Page In Book. In addition, you may want to set the chapter numbering to Continue Numbering From Previous File In Book.

 

Define special text and fonts

You may need to do the following to set up special text items:

•                

Select a footnote numbering style and number format, and other footnote properties.

 

•               Define formats for cross-references. Standardize as much of the cross-reference format as possible. For example, if cross-references should always be introduced by see, include that word in the format definition.

 

•               Consider defining user variables for product names, document names, and other items that may change during the course of the project.

 

•               Define condition tags, condition indicators, and view settings for condi­tional text.

 

•               Define custom marker types if you have to create specialized indexes.

 

•               Define equation sizes and fonts if any documents will have equations.

 

•               If your documents will contain Japanese-language text, define the combined fonts you want to use and set the properties of rubi text.

 

Set up HTML options

If documents based on your templates will be converted to HTML, you will need to set up the mappings and conversion macros that define how documents are converted.

•                

Set up the mappings from FrameMaker paragraph formats and character formats to HTML tags.

 

•               Create the conversion macros that convert cross-reference formats to a form suitable for online documents.

 

•               Create any other conversion macros you may need (for example, to place a logo at the top of every new web page, or to define the title of the HTML document).

 

3.8.2.                Create templates for generated files

When you generate a table of contents, an index, or another kind of generated file, if the folder that contains the source document or book file contains a file whose name matches the generated filename, FrameMaker uses the formatting of the existing file when generating the new one. In effect, the existing file serves as the new generated file’s template, just as if you had imported formats from it. Use this feature to create generated file templates that contain page layouts, paragraph and character formats, and the formatting information that appears on the reference page.

You can also update the formats in a generated file by importing formats from a template. However, you’ll probably need to generate the file again after importing formats to see all the formatting.

1)            

Open the document or book file from which you want to generate the table of contents, index, or other file.

 

2)           Generate the file.

 

3)           Format the generated file. This formatted file is your template.

 

4)           Save the generated file. Make sure that this generated file template is in the folder that contains the document or book file that you will use to create a new generated file.

 

Related links:

Import formats from a template or document

3.8.3.                Create templates to change conditional text settings

If you often change the view of conditional documents in a book, you may find it helpful to have a template for each view. You can then change the view of all the files in the book at the same time by importing the conditional text settings from one of the templates into the book file.

If you want to change the view of a single document that contains conditional text, it is easier to change the document’s Show/Hide settings.

1)            

Set up a basic template for the conditional document with all conditions and condition indicators visible. You’ll import conditional text settings from this template before editing a document.

2)           Set up a template for each combination of conditions you want to view. Use these templates to view or print one version of the document at a time. You can also use the template to change variable definitions that are unique to a view.

 

 

3.8.4.                Change templates for blank paper and text files

You can change the custom template for blank paper so that it contains the formats you want. The template can contain the same formats as any other template, except for the page layout. The master page layout, number of columns, and margins are determined when you create the blank paper docu­ments.

You can also change the custom template that FrameMaker uses when you open text files.

note:  You can change the filename that FrameMaker looks for when it creates a blank paper document or opens a text file.

Change the template for blank paper

1)            

Change a document so it contains the formats and settings you want. Leave existing master pages empty and do not create custom master pages.

2)           Remove all text frames from both the left and right master pages—even if a document is single-sided. (If the document is single-sided, choose Format > Page Layout > Pagination, select Double Sided, and click Set. Then select and delete the text frames on the master pages.)

 

3)           Choose Special > Delete Pages and delete all body pages.

 

4)           Save the document, using the Custom file in the FrameMaker fminit folder. (When you choose New > Adobe FrameMaker document from the context menu in a folder or on the desktop, the Shellnew.fm file is used.)

 

Change the template for text files

1)            

Change a document so it contains the formats and settings you want. For example, you can place headers and footers, a Paragraph Catalog, and master page graphics in the template document.

 

2)           Delete all text on the body pages.

3)           Click in the empty text frame on page 1, and tag it with the paragraph format you want all text in the document to use. The default template uses the Body paragraph format.

 

4)           Save the document, using the txttmplt file in the FrameMaker fminit folder.

 

3.8.5.                Import formats from a template or document

You can import paragraph formats, table formats, variable definitions, and other properties from any document. You can also retain or remove any format overrides in the document—for example, changes that were made to a para­graph but not stored in the Paragraph Catalog.

Import formats

1)            

Open the document that contains the formats you want to import.

 

2)           Make the appropriate document window or book window active. If a book window is active, select the documents you want to update.

 

3)           In the document or book you’re updating, choose File > Import > Formats.

 

4)           Do one of the following:

 

•               To import formats from a document, choose the document from the Import From Document pop-up menu. The pop-up menu lists all open, saved documents.

•               To reapply formats from the current document, choose Current from the Import From Document pop-up menu.

 

5)           Select the Import and Update settings you want to apply to the current document. By default, all options are selected. To deselect or select all options at once, click Deselect All or Select All. If you’re updating variable definitions, cross-reference formats, or math definitions, and if any of these items use character formats, select Character Formats so that the formats are added to the document.

6)           To remove changes that you made to individual formats and didn’t save in a catalog, do the following:

 

•               To remove page breaks that are not a part of a Paragraph Catalog format, select Manual Page Breaks.

 

•               To remove paragraph, character, page layout, and table formatting overrides, select Other Format/Layout Overrides.

 

7)           Click Import.

 

Related links:

About layout overrides

About import and update settings

When you import formatting information from a template, FrameMaker merges the information into the document rather than completely replacing the information. For example, when you import paragraph formats, FrameMaker adds the formats to the document’s Paragraph Catalog. If any formats have the same name in both documents, the imported format overwrites the original format. Any formats that are not overwritten remain in the document.

note:  Format names are case-sensitive, so Body is not the same as body.

Paragraph formats

 

The template’s Paragraph Catalog is merged into the document, and all formats in the catalog are reapplied in the document. The template’s PDF bookmark settings are also copied into the document.

 

Character formats

 

The template’s Character Catalog is merged into the document, and all formats in the catalog are reapplied in the document.

Page layouts

 

The template’s master pages are merged into the document, and body pages are updated with the master page changes. If the template and the document both have a master page with the same name, the template’s master page replaces the document’s. FrameMaker copies the change bar properties, all the settings in the Page Size and Pagination dialog boxes, and most settings in the View Options dialog box.

 

Table formats

 

The template’s Table Catalog and ruling styles are merged into the docu­ment, and all formats in the catalog are reapplied in the document.

 

Color definitions

 

The template’s color definitions and views are merged into the document.

 

Document properties

 

The template’s custom marker types and footnote properties; the volume, chapter, page, paragraph, footnote, and table footnote numbering styles in the Numbering Properties dialog box; the characters in the Allow Line Breaks After setting in the Text Options dialog box; and the Feather settings in the Line Layout dialog box are merged into the document. The PDF Setup settings (other than the bookmark settings) are also merged into the document. On Japanese-language systems, the rubi properties and kumihan rules (Japanese-language typesetting rules) are also merged into the document.

 

Reference pages

 

All the template’s reference pages (except for FrameMath reference pages) are merged into the document. If the template and the document both have a reference page with the same name, the template’s reference page replaces the document’s. To import FrameMath reference pages, select Math Definitions.

 

Variable definitions

 

The template’s variable definitions are merged into the document.

 

Cross-reference formats

 

The template’s cross-reference formats are merged into the document, and internal cross-references are updated.

 

Conditional text settings

 

The template’s condition tags and Show/Hide settings are merged into the document and applied to conditional text.

 

Math definitions

 

The template’s equation size and font settings, custom math element defi­nitions, and FrameMath reference pages are copied into the document. If a custom math element in the document is deleted when the reference pages are merged, FrameMaker replaces the math element in equations with the name of the element enclosed by question marks.

 

Combined fonts

 

On Japanese-language systems, the specifications for combined Japanese and Western fonts are merged into the document and applied to text that uses combined fonts.

 

3.9.                   Line numbers

Line numbers in FrameMaker files help you identify particular lines of content. Line numbers are set at a document level (for a .fm file) and appear before each inserted line in a FrameMaker document.

While using line numbers and change bars, ensure that they do not overlap.

Line numbers and change bars displayed in a FrameMaker file

[image: nf_LineNumbersInFile.png]

3.9.1.                Insert line numbers

To insert line numbers, complete the following steps:

note:  You can also use the View > Line Numbers to display/hide line numbers.

1)            

Select Format > Document > Line Numbers.

2)           In the line number properties dialog, select Show line numbers and specify the following:

 

[image: nf_LineNumbers.png]

 

 

a)           Width: Distance of line numbers from the column. The distance is relative to the columns that contain text.

 

b)           Font: Font of the line numbers

 

c)           Size: Size of the line numbers

 

d)           Color: Color of the line numbers

 

e)           Restart at Each Page: Selecting this option restarts line numbers for each page

 

3.9.2.                Some highlights of line numbers

1)            

Support for multicolumn and multiflow formats: For files with multi­column formats, line numbers appear for text in each of the columns. For multi-flow documents, the line numbers are calculated according to the text flows and continue accordingly.

 

2)           Recalculation: When you insert text within a paragraph with line numbers are enabled, the line numbers are recalculated to accommodate the new text.

 

3)           Document level property: Line numbers are a document level property, so you can enable/disable this feature for a document (.fm file). Line numbers can be set at a document level to continue from previous page or restart at each page.

 

4)           Text flows: For multi-flow documents, the line numbers follow the text flows and continue according to the text flows.

 

5)           XML documents: Line numbers do not persist in XML documents. However, you can enable line numbers in the application template.

 

6)           Printing: Line numbers are visible in the print and PDF created using Save As PDF.

 

3.10.             Create documents

In FrameMaker, you can create either structured or unstructured documents. Structured documents are required for working with SGML and XML formats.

3.10.1.            Create an unstructured document

You can create an unstructured document from the WYSIWYG view.

1)           Choose File > New > Document.

 

2)           Specify the basic page layout:

 

•               To create a standard one-column document, click Portrait or Land­scape.

 

•               To create a document with exactly the page size, margins, and number of columns you want, click Custom, specify values and click Create.

 

note:  The Units setting controls the units that FrameMaker displays for measurements in your document. These units appear in dialog boxes and in the document window’s status bar.

 

3)           Save the document in the desired format.

 

Related links:

WYSIWYG view

Switch between the views

3.10.2.            Create a document based on a structured application

If you want to create a structured document, make sure that you have an EDD and a structure application available. You can use the EDD file and sample structure application included with FrameMaker in the Structure folder, or you can create your own. For information on creating a structured application and EDD, see the online manual, Developing Structured Applications with Adobe FrameMaker 9 on the Adobe website, www.adobe.com/go/lr_FrameMaker_­support_en.

1)            

Choose File > New > XML.

 

2)           In the New XML dialog, choose one of the following:

 

•               Structured Applications: Choose from DITA, S1000D, or any other structured applications set up on FrameMaker on your computer.

 

•               DITA: Choose to create a DITA topic, such as Task, Concept, or Reference.

•               S1000D: Choose to create an S1000D module, such as Crew or IPD.

 

3)           Save the document in the desired format.

 

 

3.10.3.            Create an XML document based on a DTD

You can create a structured document based on the DTD. For the formatting of the document, you need to create an EDD and do further work. For XML roundtripping, you need to create an XML application based on the DTD. For information on creating a structured application and EDD, see the online manual, Developing Structured Applications with Adobe FrameMaker 9 on the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

1)            

Select File > New > XML.

 

2)           In the New XML dialog, select other XML.

 

3)           Select DTD Based XML and click OK.

 

4)           Specify the following:

 

a)           Root Element: Specify the name of the root element.

 

b)           Public ID: Enter a public ID. A public ID in an XML document makes it portable to other computers.

 

c)           System ID: Specify the path to the relevant DTD. The System ID is the URL of the DTD relevant to an XML file.

5)           Click OK.

 

FrameMaker makes the elements in the specified DTD available in the document. .

 

3.10.4.            Create a blank XML document

You can create a blank XML document without a structured application or a DTD. An XML document without a DTD allows you to create markup tags without having to define them first. XML aware programs can parse a well-formed XML document even when it does not have an associated DTD.

1)            

Select File > New > XML.

 

2)           In the New XML dialog, select Other XML.

 

3)           Click Empty XML.

 

4)           Click OK.

 

3.10.5.            Create a document from a template

FrameMaker comes with standard templates, or you can use any document as a template. If the document contains text and graphics, you can delete them and then insert your own.

1)            

Choose File > New > Document.

note:  To create a structured document, work in Structured FrameMaker and choose a structured template.

 

2)           Select a template or document, and click New. The new, untitled docu­ment contains the properties and content from the template.

 

note:  To view information about the standard templates, choose File > New > Document, click Explore Standard Templates, and select a template in the scroll list. After viewing the information, click Create to create an empty document from the selected template, or click Show Sample to view a document that contains sample text and graphics.




4.                        Text

 

4.1.                   Adding and editing text

 

4.1.1.                Add text and special characters

The insertion point marks where you enter or edit text. The location of the insertion point determines the paragraph to which paragraph formatting commands are applied.

You can also insert special text items, such as cross-references, footnotes, vari­ables, and markers from the Special menu. When you click a special text item, such as a cross-reference, variable, or text inset, you select the entire item.

If you can’t place the insertion point in or next to text, consider these possible reasons:

•                

The text is background text that was typed on a master page. Display the master page that contains the text and place the insertion point in the text on that page.

 

•               The text was automatically generated, as with paragraph autonumbers, cross-references, or headers and footers.

 

Related links:

Change tab stops

Search for items

Special characters

In addition to standard characters, you can type bullets, dashes, fixed-width spaces, mathematical symbols, international characters, and other special char­acters.

note:  In FrameMaker, character (ALT) sequences are not implemented for Dingbats and Symbol fonts because Unicode equivalents of codepage 1252 for these fonts are provided by default. The character (ALT) sequences are imple­mented for the MakerRoman font family only.

For a list of characters in the Symbol and Zapf Dingbats fonts, a list of accented characters in the standard character set, and information on inserting the Euro currency symbol, see the online manual FrameMaker Character Sets.

 

Some special characters are entered or displayed differently in dialog boxes. In Windows, you enter a sequence of characters beginning with a backslash (\), these sequences are listed in Dialog boxes.

 

Tabs

Each time you press Tab, a tab symbol

[image: Tab.png]

 is embedded in the text. The symbol does not appear in the printed document, but it is visible onscreen when text symbols are visible.

If the current paragraph has tab stops set, FrameMaker moves the insertion point and text one tab stop each time you press Tab. If tab stops are not set, pressing Tab doesn’t move the insertion point and text. If you press Tab more times than you have tab stops, the Tab symbols overlap. If you later add tab stops to the paragraph, FrameMaker positions the text correctly at the tab stops.

FrameMaker uses tab stops that are absolute rather than relative. With relative tab stops, each time you press Tab, the insertion point moves to the next avail­able tab stop. With absolute tab stops, the nth tab on a line moves the insertion point to the nth stop. If that tab stop is to the left of the insertion point, the inser­tion point does not move.

Special spaces

When you press the spacebar, you insert a proportional space (whose width depends on the characters on either side of it). You can also insert special fixed-width spaces—for example, to increase the space between two words. When you type a special space between two words, the words always remain together on one line.

You can use the following types of special spaces:

•                

An em space is the same width as the point size of the font you use. For example, if you use a 10-point font, an em space is 10 points wide.

•               An en space is half the width of an em space.

•               A numeric space is the same width as the font zero (0) character. All digits are typically the same width. This space is useful for aligning numbers in a column without using tabs.

 

•               A thin space is one-twelfth the width of an em space. A thin space is used to separate a number and the unit of measure that follows it, or characters that appear too close together—such as ” /)”.

 

•               A nonbreaking space is the same width as the default space width for the font.

 

When Smart Spaces is on, you can’t type more than one proportional space in a row. However, you can type multiple fixed-width spaces.

Smart quotes

When Smart Quotes is on, FrameMaker uses a curved left or right quotation mark whenever you press the
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,
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, or
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 key. If you prefer straight quotation marks, turn off Smart Quotes.

Smart Quotes doesn’t apply to text in dialog boxes. For information on typing quotation marks and apostrophes in dialog boxes, see the online manual FrameMaker Character Sets.

 

1)            

To set smart specials, in the book window, select the documents you want to affect.

 

2)           Choose Format > Document > Text Options.

 

3)           Change the Smart Spaces or Smart Quotes option and click Apply.

 

tip:  When you select Smart Quotes, FrameMaker doesn’t change any quotation marks that are already in the document. To find straight quotation marks and apostrophes, and change them to curved quotation marks and apostrophes, use the Spelling Checker or the Find/Change command.

4.1.2.                Copy, move, and delete text

Pasted text retains its character format properties. If the pasted text contains paragraph symbols
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, the paragraph format associated with each paragraph is also pasted. Otherwise, the pasted text takes the paragraph format of the para­graph in which it is pasted.

You copy text more quickly if you bypass the clipboard, which is possible only if the original text and the new location are visible and exist in the same docu­ment. You must use the clipboard to copy and paste text from one document to another.

note:  Text pasted into a new document retains the character and paragraph tags that were assigned to it in the original document. If the text has no equivalent tag in the current document, an asterisk appears next to the tag name in the status bar when the cursor is within the pasted text.

1)            

To copy text without using the clipboard, place the insertion point where you want to insert the copied text, hold down Alt, and select the text you want to copy.

 

4.1.3.                Drag and drop text

FrameMaker allows you to drag and drop text. You can drag and drop text across various FrameMaker documents and across other applications that support the drag and drop feature.

In addition, FrameMaker allows you to drag and drop elements.

 

•               To copy an element, hold the CTRL key while dropping the element in its new location.

 

•               If you drop an element in an invalid location, the cursor changes to a ‘?’ to indicate that the location is invalid.

 

You can also drag and drop rows and columns of a table.

•                

In a table, to move a whole row or column, select the column or row, and hold the ALT key while dropping it to the new location.

 

•               In a table, to copy a whole row or column, select the column or row, and hold the CTRL and ALT keys together while dropping it to the new loca­tion.note:  If you do not hold the ALT key while dragging columns or rows, only the contents of the columns and rows are copied. 

4.2.                   Working with elements in structured documents

 

4.2.1.                About elements

The basic unit of information in structured documents is called an element. Elements hold other elements, text, graphics, tables, cross-references, and markers.

You can add elements to a document to build its structure, and you can edit existing elements in many ways.

If you create a FrameMaker document by opening a structured file, you do not need to add elements to it. The document already contains elements. You can edit the document’s elements, and add more elements.

 

To build a document’s structure, you can either add elements to the document and then fill in the contents, or select existing contents and wrap them in elements.

 

A structured document has element definitions stored in its Element Catalog. These definitions describe the allowable contents for each type of element the document can have. They sometimes specify attributes and formatting for the elements. If all the elements in a document have contents and attributes that meet these specifications, the document is valid.

 

Valid contents for elements

 

An element’s definition has content rules that determine what the element can contain. For example, perhaps the definition of a Section element specifies that a Section must begin with a Head element, then must have a Para element, and then can have any combination of Para, Figure, and other Section elements. A Para element sometimes allows text and CrossRef elements, in any order.

 

The Element Catalog indicates valid elements for the current location with a heavy check mark. It shows that text is allowed with the <TEXT> tag.

 

Two classes of elements

 

Elements fall into two basic classes determined by their allowable contents:

•               A container element can hold text, other elements, or both. Container elements, such as heads and paragraphs, build the document’s structure.

 

•               An object element is a single object—a marker, cross-reference, system variable, equation, or anchored frame. You cannot type in these elements or add child elements to them.
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 A. 

Containers have round-cornered bubbles.

 B. 

Object elements have square-cornered bubbles.

 

A container element can be defined to remain empty. For example, perhaps a table cell is empty as part of a table’s design. If an element contains only spaces or nonprintable characters such as tabs, its text snippet in the Structure View is <WHITESPACE>.

 

Attributes for elements

 

An element can have attributes, which provide information about the element that is not part of the element’s contents. Your document uses attributes for several purposes:

 

•               To control the formatting of an element. For example, perhaps a Type attribute in a List element has two possible values—Bulleted and Numbered.

 

Attributes can provide formatting information.
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•               To record descriptive information about an element, such as level of clas­sification. An attribute value can even trigger a custom routine that hides the element when the document is displayed.

 

•               To store source and destination information for elements, typically for cross-referencing. A Section element sometimes has an ID attribute that stores a unique value. A cross-reference element that points to the Section stores the same value in a Reference attribute, to maintain the connection between the elements.

 

You typically enter and edit the values for attributes, unless the attributes are defined to be read-only. Cross-reference IDs are often read-only and are generated by FrameMaker.

 

4.2.2.                Import element definitions

If you’re not sure whether a document has element definitions, open the Element Catalog and click in a text flow. If you see elements in the catalog, the document has definitions. You sometimes must select the All Elements option to get elements to appear. Select Element > Set Available Elements for the All Elements option.

If you are using a structured template, then element definitions are usually defined in it. However, sometimes your application developer may provide you with an EDD or DTD that you can directly import into your documents.

1)           Open the template, EDD, or DTD with the element definitions. The template, EDD, or DTD must be named and saved.

 

2)           Create a blank document or open the document or book that you want to update. If a book window is active, select the documents you want to update.

 

3)           In the document or book you’re updating, choose File > Import > Element Definitions.

 

4)           Choose the template, EDD, or DTD from the Import From Document pop-up menu. The pop-up menu lists all open and named documents.

 

5)           To remove special formatting and book-related changes in the document, do the following:

 

•               To remove format rule overrides, select While Updating, Remove Format Rule Overrides. Use this setting if you have made text or paragraph formatting changes to elements and now want to return to the formatting described in the EDD or DTD.

 

•               To remove element information derived from a book file, select While Updating, Remove Information Inherited From Book. Use this setting if the document used to be included in a book but is now a stand-alone document.

 

6)           Click Import. FrameMaker adds the element definitions to the docu­ment’s Element Catalog, replacing existing definitions.

 

4.2.3.                Insert elements

To add an element to a document, you either insert an empty element and enter contents, or wrap an element around existing contents. Before you can begin, your document must have element definitions in its Element Catalog.

If you haven’t yet fully planned your document, consider inserting just the high-level elements, such as Section and Head elements, and then use this struc­ture as an outline for developing the document.

You can also enter all the elements in their correct order and hierarchy as you go, or concentrate on contents rather than on structure, and then validate later to correct errors.

The Element Catalog shows the elements that are available at the current loca­tion. You can change the scope of elements available—for example, to show elements that are not valid at the current location. Ask your application devel­oper for a summary of what each element can contain.

If you have turned on element boundaries, then once you insert or wrap an element, a pair of element boundaries appears in the document window, and a new bubble appears in the Structure View.

Empty element boundaries (left) and bubble for the new element (right)
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Insert an element using the Element Catalog

1)            

If the document does not have element definitions, import the definitions from a structured template, EDD, or a DTD.

 

2)           Specify the scope of elements available.

 

3)           Click where you want to insert the element. If you’re inserting it between other elements, work in the Structure View rather than the document window.

 

4)           Select an element tag in the Element Catalog, and click Insert. If only one element appears in the catalog, you can click Insert without selecting it.

You can also double-click an element tag to insert the element.

 

note:  The Element Catalog always displays only those elements that are valid at the insertion point.

5)           If the Attributes For New Element dialog box appears, enter attribute values for the element and click Insert Element.

This dialog box appears only if the element has attributes and if an option is set in the New Element Options dialog box to prompt for attribute values when you insert new elements.

 

6)           If you insert a table, a marker, a graphic, or a cross-reference, provide more information about the element in the dialog box that appears.

 

7)           Add content to the elements. You can add content as you insert elements, or after you build the structure of your document.

 

Press Return to insert elements

In many cases, pressing Return inserts an element automatically. Whenever you press Return, FrameMaker checks the current element’s definition for the following conditions—in the following order—and sometimes inserts a child element:

One valid element

 

If only one child element is valid at the current location, pressing Return adds that element. For example, after you add a Section, perhaps a Head is the only element permitted next. You can also use this technique to create repeating elements, such as body paragraphs and list items.

 

More than one valid element

 

If more than one child element is valid, pressing Return highlights the Tag area to prompt you for an element tag. Type until the tag you want appears, and then press Return to insert the element.

 

End of an element

 

If the insertion point is at the end of an element and no more child elements are valid, pressing Return looks for valid elements in ancestors after this location. If a valid element is found, the insertion point moves to the ancestor and the element is inserted (if only one is valid) or the Tag area is highlighted (if more than one element is valid).

 

Other conditions

 

If none of the preceding conditions are true, pressing Return causes a beep and no element is inserted.

 

Set options for inserting new elements

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Element > New Element Options.

3)           Specify how you want to be prompted for attribute values when you add new elements:

 

•               To enter all possible attribute values as you add elements, select Always Prompt For Attribute Values.

 

•               To enter only required attribute values as you add elements, select Prompt For Required Attribute Values.

 

•               To enter attribute values after adding elements, select Do Not Prompt For Attribute Values.

 

4)           To allow FrameMaker to insert child elements automatically for new elements, select Allow Automatic Insertion Of Children.

 

5)           Click Set.

 

tip:  To speed up the process of adding new elements, select the Do Not Prompt For Attribute Values and Allow Automatic Insertion Of Children options.

4.2.4.                Add text in a structured document

 

Place the insertion point anywhere inside a text frame in a document window. An insertion point also appears at the corresponding place in the Structure View. To place the insertion point in the middle of text, use the document window rather than the Structure View. When placing the insertion point at the beginning or end of an element, or between elements, click in the Structure View.

The Element Catalog describes what the current element can contain. You can enter text whenever <TEXT> appears in the catalog.

1)           Place the insertion point:

 

•               To place at the beginning or end of text, click to the left or right in the first or second half of the text snippet. After you click, a line on the left or right side of the triangle insertion point indicates that the point is at the beginning or end of text.

 

•               To place between two elements, click to the right of the vertical line connecting the elements, between the two bubbles.

 

Insertion point between two elements
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2)           Begin typing. Don’t press Return unless you want to insert a new element, or begin a new paragraph in an unstructured flow.

 

4.2.5.                Edit elements

You can edit a document’s structure in many ways—including changing an element to a different type, rearranging elements, and splitting and merging elements.

After editing one part of a document, sometimes you edit the document further to correct content errors. For example, if you split a Section element in two, you sometimes need to add a Head element for the new second Section. Use the Structure View as a guide for finding errors as you work, or validate the docu­ment when you’re finished.

Change elements

You can change an existing element to another element of the same type. For example, you sometimes want to convert a Para element into a Note element, or a series of Para elements into ListItem elements that you can include within a List element.

However, not all elements can be converted to other elements. For example, if you change a Para element containing text to a Marker element containing the same text, the name of the element changes, but the text is not converted to marker text.

note:  If you want to change contents to a table, use Table > Convert To Table to convert text rather than changing an element.

 

Changing elements to another type

 

1)           Select the element. You can select more than one element, even if the elements do not have the same tag. All the elements are changed to the new type of element. However, the elements’ children are not changed, but they sometimes become invalid because the parent changed.

 

2)           Select an element tag in the Element Catalog and click Change. Sometimes attributes in the element become invalid and need to be corrected.

 

Merge elements

You can merge two or more elements into a single element. Merging places the contents of the second element (including any child elements) at the end of the first element.

Merging two Sections, before and after
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You sometimes must edit the document after merging elements.

note:  If you want to combine table cells, use Table > Straddle rather than merging the cells. You cannot combine other table parts.

1)            

Select the elements you want to merge. The elements can be of different types, but they must be siblings and next to each other in their parent element.

 

2)           Choose Element > Merge.

 

Merging retains the attributes for the first element only.

Split an element

You can split an element into two elements that have the same tag and are at the same level. For example, perhaps you split a Section element in two.

Splitting a Section, before and after
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You sometimes must edit the document after splitting an element. In the example above, after splitting you would add a Head for the new second Section.

note:  You cannot split an element that is a table part (such as a row or cell).

1)            

Click where you want to split the element. The contents after the insertion point go in the new second element.

 

2)           Choose Element > Split.

Splitting sometimes results in two elements with identical attributes. However, if the original attribute had a Unique ID attribute, the second element loses its ID value.

Wrap elements around existing content

You can add structure to content already in a document by wrapping a new element around the content. The content can be any part of a document, including other elements. The element’s content is formatted as specified in the element’s format rules.

note:  You cannot wrap content in elements that are for parts of tables (such as rows or cells), but you can wrap text or other elements that are within a cell or a table title element. If you want to convert text and elements to a table, use Table > Convert To Table rather than wrapping.

After wrapping an element, you sometimes must edit the document to correct structure errors. For example, if you wrap Para elements in a Section element that requires a Head element, you’ll need to insert the Head element.

 

Wrap an element using the Element Catalog

 

1)           Select the contents you want to wrap in an element. If you’re selecting text, use the document window. If you’re selecting entire elements, use the Structure View.

 

2)           Select an element tag in the Element Catalog, and click Wrap.

3)           If the Attributes For New Element dialog box appears, enter attribute values for the element and click Insert Element.

This dialog box appears only if the element has attributes and if an option is set in the New Element Options dialog box to prompt for attribute values when you insert elements.

 

Wrap elements throughout a document

 

1)           In the document window, wrap text ranges, system variables, and other items that are inside paragraphs. Don’t worry about errors you see in the Structure View. You’ll correct many of these errors when you wrap the lowest levels in parent elements. You can correct the other errors when you’re finished.

 

2)           Wrap paragraphs, headings, and other paragraph-level items in their elements.

 

3)           In the Structure View, wrap the elements you have so far in parent elements, such as Section and List.

Wrapping helps in manually providing a structure to an existing unstructured document. When you wrap the first element in the document, the Structure View immediately changes to show a default invalid structure, as follows:

•                

A highest-level element is added with the tag NoName, unless you begin by wrapping the contents in a valid highest-level element. NoName is a placeholder for your valid highest-level element.

 

•               All tables become structured and are given default element tags, such as TABLE and ROW.

 

•               Objects become elements with default tags such as CROSSREF, GRAPHIC, and EQUATION.

•               Footnotes become FOOTNOTE.

 

•               Rubi text becomes RUBI and RUBIGRP elements.

 

note:  Variables and markers do not become structured object elements. 

You can correct the structure of the document when you’re finished wrapping elements.

 

tip:  If your application developer has set up a conversion table for the document, you can apply the table to wrap elements throughout the document all at one time. This is much faster than wrapping text manually.

 

Unwrapping the contents of elements

 Unwrapping deletes an element but leaves its contents in the same place in the document. You usually unwrap elements as part of a larger editing process. For example, if you plan to convert ListItem elements into Para elements, some­times you must unwrap the parent List element first. Then use Edit > Find/Change to convert the ListItem elements to Para elements.

Unwrapping ListItems, before and after
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You sometimes must edit the document after unwrapping an element. For this example, you would change the ListItem elements to valid elements or rewrap them.

note:  You cannot unwrap an element that is a table part (such as a row or cell).

1)            

Select the element with the contents you want to unwrap.

 

2)           Choose Element > Unwrap.

Move or copy elements

You can move an element to another location in a document by dragging its bubble in the Structure View. When you move or copy an element, its contents, including descendants, all move along with it. This does not affect the contents of the clipboard.

tip:  If you’re moving an element that has many descendants, collapse the element first.

You can also move or copy an element by cutting or copying it to the clipboard and pasting, even across documents. If you paste an element from another document, sometimes the element is not defined in your document. If you don’t plan to add a definition for the element, change the element to a valid one. You cannot cut and paste elements in a book file.

1)            

Do one of the following:

 

•               To move an element, drag the bubble to the location you want.

 

•               To copy an element, hold down Alt and drag the bubble to the loca­tion.

 

As you drag the bubble to copy, the pointer changes to a hollow, stacked up-and-down arrowhead, and a horizontal arrow moves to indicate where the copy goes if you release the mouse button.

 

As you drag the bubble to move, the pointer changes to a solid up-and-down arrowhead, and an arrow moves to indicate where the bubble goes if you release the mouse button.

 

If the element is valid in the location where the arrow points, a check mark or question mark appears in the bubble.

 

Nudge an element one place

1)            

Drag the element’s bubble slightly to one side or up or down. As you drag a small distance, the pointer changes to a single arrow. (If you drag too far, the arrow changes to an up-and-down arrowhead.)

Nudging a List one place, before and after
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When you release, the element moves one place in the indicated direction, as follows:

 

•               Moving an element up places it right above the sibling right before it. Moving an element down places it below the sibling after it.

•               Moving an element to the left makes it a sibling of its parent. Moving an element to the right makes it a child of the sibling before it.

 

4.2.6.                Hierarchical element insert

Using the Elements quick catalog, you can select and insert multiple levels of elements. When you select an element in the quick catalog, FrameMaker displays the elements available within the selected element.

Hit Enter and use the pointer or the arrow keys (or the pointer) to select a hier­archy of elements that you want to insert. When you hit Enter, if there is only one valid element at the pointer’s position, FrameMaker inserts the element.

Use the following keys to navigate through the hierarchy of elements in quick catalogs:



	
 

Key\Key action

 


	
Type of navigation\action

 





	
Place cursor in an element and hit Enter

 


	
Display the quick catalog

 





	
Right arrow

 


	
Display the elements available within the selected element

 





	
Left arrow

 


	
Hide one level hierarchy of elements

 





	
tab

 


	
scroll down

 





	
shift+tab

 


	
scroll up

 





	
Alphabets\combination of alphabets

 


	
Type an alphabet or combination of alphabets to select an element. For example, press B to select Body and Type T,O to go to Topic.

 






The list of elements in the quick catalog appears according to the settings in the Set Available Elements dialog. If Show Element Descriptive Tags is selected, the element tool tips in the catalog display the element descriptions.

Hierarchical element insert takes care of auto insertions for the last selected element in the hierarchy, as specified in the EDD. If there are auto insertion rules in place for elements apart from the last element, they are ignored.

Hierarchical element insert

4.2.7.                Select and edit text

 

Select text in flow

1)            

To select all the text in a flow, click in the flow and choose Edit > Select All In Flow.

 

Select text in structured document window

You can select entire elements and any part of the document contents in a docu­ment window. A corresponding selection also appears in the Structure View.

If an element has contents, you can select all or part of the contents without selecting the element itself. If an element consists of a single object, such as a graphic or a cross-reference, select the entire element.

When you select an entire element, its contents are selected along with it.

tip:  Work with element boundaries showing, so that you can see the beginning and end of each element. After selecting, check the status bar for the correct tag name of the selection parent element. The tag name appears following the “E:” text.

1)           To select text in an element, do one of the following:

 

•               To select text without selecting the whole element, drag through the range of text. Be careful not to drag across an element boundary. If you do, you select the entire element.

 

•               To select one element, drag from anywhere inside the element to outside one of its element boundaries.

 

•               To select more than one elements, drag through the elements. FrameMaker selects each element as you drag across one of its boundaries.

 

 

Select element content in Structure View

You can select entire elements or the element contents in the Structure View. A corresponding selection also appears in the document window.

If an element has contents, you can select all of the contents without selecting the element itself. If an element is a single object, such as a graphic or a cross-reference, you select the entire element. (Elements that are allowed contents have round-cornered bubbles; elements that are a single object have square-cornered bubbles.)

When you select an entire element, its contents are selected along with it.

1)            

To select element content, do one of the following

 

•               To select an element, click the middle of its bubble.

 

•               To select more than one element, click the first bubble and then Shift-click the other bubbles. You can also drag to the right of the vertical line connecting the elements. Start above the first element you want to select, and drag down to the last element you want to select.

 

•               To select contents of an element without descendants but not select the entire element, double-click the text snippet.

 

•               To select the contents of an element with descendants but not select the entire element, double-click to the right of the vertical line connecting the first level of descendants.

 

4.2.8.                Remove elements

You can remove any element, with or without its contents. For example, you sometimes want to delete a Section element and its contents, or delete the Section but leave the contents in place, so you can place them in a different element.

For elements that are defined to contain text or other elements, you can also delete the contents and leave the empty element in the document. For elements that are single objects without contents, you must delete the entire element.

•                

To remove an element and its contents, select the element and press Delete.

 

•               To remove an element but not its content, select the element and choose Element > Unwrap. FrameMaker reformats the contents based on the new context, if necessary.

 

•               To remove the contents of an element but not the element itself, select the contents and press Delete.

•               To remove an element and its contents and replace it with another element, select the element. Then select the replacement element in the Element Catalog, and click Insert. A new empty element replaces the selected element and its contents.

 

•               To remove all elements from a document to base it on paragraph and character formats, choose Special > Remove Structure From Flow. If the document has additional structured flows, repeat this command for each flow.

FrameMaker removes all elements from the current text flow. If the formatting was created or modified by format change lists in the element catalog, the removed elements become format overrides in the document.

note:  To create named formats for each removed element variation and save them in the catalog, use the Create And Apply Formats command.

 

4.2.9.                Assign attribute values

Attributes store supplementary information about an element that does not appear with the contents of the document. You can see attributes and their values in the Structure View.

Attributes in the Structure View
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An attribute’s definition specifies the type of values that are acceptable (such as text or numeric) and sometimes includes a list of possible values or a numeric range.

The definition also determines whether the value is optional, required, or read only. It sometimes provides a default value. You can assign values to an attribute if the attribute is not read only.

If an attribute’s current value does not conform to the specifications in its defi­nition, the attribute is invalid.

note:  FrameMaker can provide the values for ID and ID Reference attributes used in cross-referencing. (These attributes are often defined to be read only.)

Enter attribute values as you insert elements

You enter some attribute values as you insert elements, particularly for required attributes and attributes that affect formatting. Optional attributes can perhaps wait for a later pass.

Some font property values used in an element definition document (EDD) require that you use specific units. For example, if the Offset Horizontal value is set as a percentage of an em space, typing 5pt creates an offset of 5 em spaces instead of 5 points.

Do not use multibyte (Asian-language) characters when entering attribute values. Sometimes these characters are not exported to SGML correctly because multibyte characters are not supported in the SGML workflow.

note:  Attribute names support the Unicode text-encoding standard.

1)            

Make sure you are prompted for attribute values when you insert elements.

 

2)           Insert the element. If attributes are defined for the element, the Attributes For New Element dialog box appears, listing all the attributes (except read-only ones) defined for the element.

 

3)           For each attribute value to provide, select the attribute in the Attribute Name scroll list, enter the value in the Attribute Value box, and click Set Value. If an attribute is required, you must enter a value for the element to be valid.

If an attribute has a set of predefined values, choose from the Attribute Value pop-up menu rather than entering a value.

 

The value you can enter, such as text or a number, is determined by the attribute’s type.

 

A description of the selected attribute (its type, whether a value is required, and so on) appears in the dialog box below the Attribute Value area.

 

4)           Click Insert Element.

 

Enter or edit attribute values for elements already in a document

To change an attribute name rather than a value, use Edit > Find/Change. Sometimes this is necessary if you imported element definitions that use different attribute names with identical meanings, such as Security instead of SecurityLevel. The new attribute name must be defined for the element.

1)            

Select the element with the attribute value you want to change.

 

You can select more than one element of the same type, and apply the change to all. The elements must be contiguous. For example, if several Para elements in a row have a Security attribute, you can change the value of that attribute for all the Para elements at one time.

 

2)           Double-click an attribute name or value in the Structure View to display the Attributes dialog box.

Alternatively, access the Attributes modal panel from Elements > Edit Attributes.

 

3)           For each attribute value to enter or edit, select the attribute in the Attribute Name scroll list, enter the value in the Attribute Value box, and click Set Value.

 

If an attribute has a set of predefined values, choose from the Attribute Value pop-up menu rather than entering a value.

 

4)           Click Done.

 

4.2.10.            Types of attributes

An attribute’s type determines the kind of values that are allowed in the attri­bute. For example, the value version 1 is not valid for an attribute defined as an integer, but the value 1 is valid. Numeric types (such as integer or real number) can also be limited to a predefined range by their attribute definition.

Choice

 

An attribute with a list of predefined values.

 

ID Reference

 

An attribute with a value that is a Unique ID value from another element. It is typically used for element-based cross-references.

 

ID References

 

An attribute with a value of one or more Unique ID values from another element. (Sometimes the developer specifies this attribute if you’re exporting to a structured application that uses multiple values for source information.)

 

Integer

 

An attribute with a whole number value (no decimal parts). Examples of valid integers are 22, -22, and +322. An integer can be defined to fall within a range.

 

Integers

 

An attribute with a value of one or more integers. Enter each number on a separate line in the Attribute Value box.

 

Real

 

An attribute with a real number value, with or without a decimal part (the value can also be expressed in scientific notation). Examples of valid real numbers are 2, 22.4, -0.22, and 2.3e-1. A real number can be defined to fall within a range.

 

Reals

 

An attribute with a value of one or more real numbers. Enter each number on a separate line in the Attribute Value box.

 

String

 

An attribute with a value of a series of characters (text).

 

Strings

 

An attribute with a value of one or more strings. Enter each string on a separate line in the Attribute Value box.

 

Unique ID

 

An attribute with a value of a unique text string. An element can have only one ID attribute (which can be of type Unique ID or Unique IDs). All ID values must be unique in the document or book. An element with a Unique ID attribute can be the source for an element-based cross-refer­ence.

 

Unique IDs

 

An attribute with a value of one or more unique text strings. Enter each string on a separate line in the Attribute Value box. (Sometimes the devel­oper specifies this attribute if you’re exporting to a structured application that uses multiple values for source information.)

 

4.2.11.            Copy attribute values

You can use the clipboard to copy and paste attribute values from one element to another. If you paste values to an element that does not have corresponding attributes defined, the attributes are invalid. To preserve element-based cross-references, an ID attribute value is not pasted.

If you copy an attribute from another document, the attribute sometimes is not defined in the current document.

1)           Select the element with the attribute values you want to copy, and choose Edit > Copy Special > Attribute Values. All attribute values associated with the element are copied to the clipboard.

 

2)           Select a different element and choose Edit > Paste.

 

3)           (Optional) To delete an undefined attribute copied from another docu­ment, select the element with the undefined attribute, open the Attributes dialog box, select the attribute, and click Delete Attribute. In the next dialog box that appears, remove the attribute for the current element or for all elements that have the attribute.

 

4.2.12.            Find and edit elements and attributes

You search for elements and attributes in a structured document to keep track of them or to make changes to them quickly. Searching is especially useful when you want to apply the same change to more than one occurrence of an element or attribute.

You can also search for many other items in FrameMaker, including strings of text, specific formatting, unresolved cross-references, and objects (such as anchored frames) that are not elements.

note:  The Find/Change feature supports the Unicode text-encoding standard.

Search for element tags, attribute names, or attribute values

You can search for an element tag, attribute name, and attribute value either separately or in combination. For example, you can search for an element tagged List to find each List element, or perhaps you limit the search to find only List elements that have a Security attribute set to Classified.

1)            

Choose Edit > Find/Change.

 

2)           Choose Element from the Find pop-up menu.

3)           Select the options you want in the Find Element dialog box.

The settings can be used in many combinations. These are a few examples:

 

•               To find any element, leave all three boxes empty.

 

•               To find a specific element, type an element tag but leave the Attri­bute Name and Attribute Value boxes empty.

 

•               To find any element with a specific attribute, type an attribute name but leave the Element Tag and Attribute Value boxes empty.

 

•               To find any element with a specific attribute value, type an attribute value but leave the Element Tag and Attribute Name boxes empty.

 

•               To find a specific combination of element and attribute, type an element tag and choose an attribute name.

 

•               To find a specific combination of element and attribute value, type an element tag and choose an attribute name and an attribute value. (If the attribute type is Choice, type the value.)

 

•               To find a specific element with an attribute that has no value, type an element tag, choose an attribute name, and choose <No Value> from the Attribute Value pop-up menu.

Leave a box empty if you do not want to restrict the search. An empty box has the same effect as searching for any element, or choosing either <Any Attribute> or <Any Value>.

 

4)           Click Set.

 

5)           In the Find/Change dialog box, select Consider Case, Whole Word, Use Wildcards, or Find Backward.

 

6)           Click Find.

 

note:  After searching the main flow, FrameMaker looks at other text frames and text lines. Because a search is flow by flow, it sometimes appears to jump around the document.

Change elements or attributes you find

After you find an element, attribute, or attribute value, you can change it to another element, attribute, or value. For example, you can quickly and globally change the value of a SecurityLevel attribute from Declassified to Top Secret.

When changing items in a document, you can change each occurrence of the item as it is found or have FrameMaker automatically make the change throughout the document.

tip:  After pasting material from another document or importing new element definitions, use the Find/Change command to clean up your document. For example, pasting a table from an unstructured document gives the table and its parts default, invalid element tags. You can use Find/Change to change CELL elements, for example, to TableCell elements.

1)            

Choose Edit > Find/Change.

 

2)           In the Find/Change dialog box, choose Element from the Find pop-up menu.

3)           Select the options you want in the Find Element dialog box, and click Set. Then choose an option from the Change pop-up menu in the Find/Change dialog box, and type the replacement tag or value.

 

The Find Element dialog box and the Change pop-up menu work together. These are a few examples of combinations you can use:

 

•               To change one element to another, type an element tag in the Find Element dialog box but leave Attribute Name and Attribute Value empty. Then choose Element Tag To in the Change pop-up menu and type an element tag.

 

•               To change one attribute to another, type an attribute name but leave Element Tag and Attribute Value empty. Then choose Attribute Name To and type an attribute name that is defined for this element.

 

•               To change one attribute value to another, type an attribute value but leave Attribute Name and Attribute Value empty. Then choose Attribute Value To and type a value.

 

•               To change an attribute with a specific name to a certain value, type an attribute name but leave Element Tag and Attribute Value empty. Then choose Attribute Value To and type a value.

 

•               To change a specific element with a specific attribute value to another element, type an element tag and choose an attribute name and attribute value. Then choose Element Tag To in the Change pop-up menu and type an element tag.

 

•               To remove an attribute value, type an attribute value but leave Element Tag and Attribute Name empty. Then choose Attribute Value To and leave the Choose box empty.

 

If you try to make a change that is not allowed—for example, if you try to remove an element tag—an alert message appears explaining the problem.

 

4)           Click Find.

 

5)           When FrameMaker finds the element or attribute, do one of the following:

 

•               To make the change but not continue searching for other occur­rences of the item, click Change.

 

•               To make the change and continue searching for other occurrences, click Change & Find.

 

•               To change all occurrences of the item, specify all occurrences in the document or only occurrences in the current selection and click Change All.

 

4.2.13.            Find and correct errors in document structure

An error in a structured flow can be a structure problem, such as an element in an invalid location, or an invalid attribute, such as an attribute with a missing required value. In Structure View, when a collapsed element has invalid content in its structure, the plus sign on the left of the element name is red.

You can also validate a document to find errors. After you know where the errors are located, use the Element Catalog and the Structure View as guides to help you correct them.

If you’ve made any formatting changes to text in elements, the elements perhaps do not conform to their format rules.

Use the Structure View to find errors

When an element doesn’t conform to content rules and attribute descriptions in the document’s element definitions, the Structure View identifies the error for you.

Missing elements

 

If an element is missing one or more child elements required by the element definitions, a small red hole appears on the vertical line where the child element should be.

 

At least one required child element is missing. 
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Elements at an invalid location

 

If an element is at a location not allowed by the content rules, the vertical line next to it is broken from the position of that element to the end of the parent element.

The Para element is invalid at this location.
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Undefined elements

 

If an element is not defined for the document, its bubble is red. This some­times happens if you have pasted the element from another document.

 

Invalid attributes

 

If an attribute has an invalid value or is not defined for the document, it appears with a red x to the left of the attribute name and its value is red.

The DraftVersion attribute is invalid. 
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Attributes missing a required value

 

If an attribute does not have a value, <no value> appears to the right of the attribute name. If the attribute requires a value, <no value> is red and a red hole appears to the left of it.

 

The XRefLabel attribute is missing a required value.
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Validate a document

When FrameMaker validates a document, it searches for elements that do not conform to content and attribute rules in the document’s element definitions. If FrameMaker finds an error, it selects the element and describes the error.

You can validate an entire document, the current flow, or the current element. If you validate the current element, FrameMaker does not check the descen­dants of the element’s child elements. For example, if you validate the Section element below, FrameMaker makes sure that the Head element, the two Para elements, and the List element are valid, but does not check the List Item elements in List.

 Only the section’s child elements are validated. 
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If the document has conditional text, only the versions that are showing are vali­dated.

You can also validate an entire book including all its files, only the book file, or only the current element in the book file.

1)            

Choose Element > Validate.

2)           Select Entire Document, Entire Book, Current Flow, or Current Element to specify the scope of the validation.

 

3)           To exclude missing elements or attribute values from the search, select Ignore Missing Elements or Ignore Missing Attribute Values.

 

If these settings are selected, FrameMaker does not look for places where a required child element or a required attribute value is missing. Consider selecting these if you are not trying to build a complete document yet.

 

4)           Click Start Validating.

 

FrameMaker starts checking at the beginning of the current element. If you’re validating only the current element, it checks the element with the insertion point or the selected element. If more than one element is selected, it checks the first element in the selection.

 

5)           If FrameMaker finds an error, click Start Validating again when you’re ready to continue validating.

 

The top of the Element Validation dialog box shows the tag of the element and a brief message about the problem.

 

You can correct the error, ignore it, or click Allow As Special Case. If you mark it as a special case, FrameMaker won’t identify the error the next time you validate the document.

 

6)           Repeat step 5 until FrameMaker does not find any more errors.

 

When FrameMaker reaches the end of the document, it returns to the beginning and continues validating. When FrameMaker reaches the end of a flow, it continues to the next one.

note:  When validating a book, FrameMaker tells you if a file in the book has invalid content, but for a more detailed evaluation, you must open and validate the file.

Validation of the elements in an EDD includes attributes in if-then clauses. For example, suppose that the possible values of an attribute are A or B or C, and a context rule says If [attrval = “D”]. This is flagged as an error and reported as an invalid structure when the element definitions are imported.

Similarly, if an element’s text formatting rules or prefix/suffix rules use attribute names in the context specifications, the attribute name and case must match the attribute definition in the element’s definition.

If an attribute’s value is changed to the same value it previously had, the action is not flagged as a change. This enhances performance by eliminating unneces­sary value checking.

Clear all special cases

1)            

Choose Element > Validate.

 

2)           Click Clear Special Cases. FrameMaker clears the special cases in the document, the flow, or the element—whichever scope is selected in the dialog box.

 

Validation error messages

The following error messages can appear at the top of the Element Validation dialog box. (In the descriptions, tag represents an element tag, name represents an attribute name, and value represents an attribute value.)

Current flow is unstructured

 

The current flow does not have elements in it.

 

Element is undefined

 

The element is not defined in the document. You perhaps copied this element from another document.

 

Missing element before tag

 

At least one required element is missing before the specified element.

 

More contents required at end

 

At least one more child element is required at the end of the current element.

 

No current element

 

There is no insertion point or selection. (This message appears when the scope is set to Current Element.)

 

No current flow

 

There is no insertion point or selection. (This message appears when the scope is set to Current Flow.)

 

Not highest-level element

 

The element is not permitted at the highest level in the document.

<TEXT> not permitted in this element

 

The element contains text, but text is not allowed.

 

<TEXT> not valid at this position

 

The element is allowed to have text but not at this location.

 

The name attribute refers to an undefined ID value

 

The attribute is an ID Reference and refers to a Unique ID value that doesn’t exist in the document (or in the book, if you’re validating a book).

 

The name attribute is undefined for this element

 

The definition of this element does not include a name attribute.

 

This element should be a type

 

The element is the wrong type, where type can be graphic, marker, cross-reference, equation, or system variable. For example, a cross-refer­ence element sometimes consists of text instead of a cross-reference.

 

Value must be a type for name attribute

 

The attribute value is the wrong type for the attribute.

 

Value for name attribute must be in the range from n to n

 

The attribute’s numeric value is out of the specified range.

Value for name attribute is not one of the allowed choices

 

The attribute’s value must match a value from the pop-up menu of valid choices.

Value for name attribute must be unique

 

A Unique ID value must be unique for all elements in the document or book.

 

Value required for name attribute

 

The attribute does not have a required value.

 

tag excluded in this element

 

The tag element is not allowed because of an exclusion rule for the parent or one of its ancestors.

 

tag not permitted in this element

 

The tag element is not allowed anywhere in the parent element.

 

tag not valid at this position

 

The tag element is allowed in the parent element but not at the current location.

 

Correct errors in elements

After you have identified errors in elements and attributes, use the Element Catalog and Structure View as guides for correcting them:

•                

To correct an element in an invalid location, move the element to a valid location, or change it to an element that is valid for its current location.

 

You can select an invalid element, or if you’re validating, FrameMaker selects the element for you. When the element is selected, the Element Catalog shows which elements are valid at that location.

li or ListItem is valid at this location.
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•               To correct an element with invalid contents (with the text snippet <INVALID CONTENT>), change it to an element that allows those contents.

 

•               To correct a structure with a missing child element, insert the required element.

 

You can click where an element is missing, or if you’re validating, FrameMaker places the insertion point there for you. When the insertion point is at the location of the missing element, the Element Catalog shows which elements are valid at that location.

Title is required at this location.
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•               To correct an invalid attribute value, change the value to one that is valid for the attribute.

 

•               To remove an undefined attribute, select the element with the undefined attribute, open the Attributes dialog box, select the attribute, and click Delete Attribute. In the next dialog box that appears, remove the attribute for the current element or for all elements that have the attribute.

 

•               To resolve a cross-reference with an invalid ID, select the cross-reference, choose Special > Cross-Reference, and change to a source that has a valid ID.

 

4.3.                   Search for items

 

4.3.1.                Searching documents and books

If you are searching in a document (Edit > Find/Change), FrameMaker begins searching at the insertion point and continues through the document. It searches only pages of the type the insertion point is on—for example, only body, master, or reference pages. When FrameMaker reaches the end of the document, it continues the search at the beginning. After searching the main text flow, it searches other text in the document. Because FrameMaker searches flow by flow rather than page by page, it sometimes appears to jump around within the document while searching.

If you are searching throughout a book, FrameMaker begins searching from the active document, or from the first document of the book if the book window is active, and continues searching until all documents in the book have been searched. If a document cannot be opened, the document is skipped and a message appears in the Book Error Log.

note:  When you are searching through a book, bookmap, or DITA map, you cannot search the master or reference pages.

 

In addition to text, you can search for any of the following items in a selection, in a document, or throughout an entire book. You can also search in a map from the Resource Manager view.

Text formats and tags

 

Character format properties, or specific paragraph or character tags. In structured FrameMaker, Element appears right after text, so you can search for element tag, attribute name, attribute value, or simultaneously for all three.

 

Markers

 

Any markers, regardless of their marker types, markers of a specific type, or markers that contain specified text.

 

Cross-references

 

Any cross-references, regardless of their formats, cross-references that use a specific format, or unresolved cross-references—cross-references that FrameMaker is unable to update. When an unresolved cross-reference is found, the marker text of the cross-reference appears in the Find box.

 

Text insets

 

Any text imported by reference. You can also search for unresolved text insets—insets that cannot be updated from their sources. However, you can’t search for graphics subscribers or OLE linked objects. (To list OLE links, choose Edit > Links.)

 

Variables

 

Any variables, regardless of their variable names, or specific variables.

 

Rubi

 

Any rubi text, when Japanese fonts are installed on your system.

 

Anchored frames

 

Frame that contains graphics and helps you locate them. Graphics placed in non-anchored frames are not found.

 

Footnotes

 

Any text or table footnotes.

 

Tables

 

Any tables regardless of their table format tags, or tables with a specific tag.

 

Conditional text

 

Any conditional text, regardless of its condition tags, text with specific condition tags, or unconditional text. FrameMaker cannot find condi­tional table rows or hidden conditional text.

 

Automatic hyphen

 

Words that are hyphenated automatically.

Text and character format on the clipboard

 

Text that matches the clipboard text, capitalization, and character format­ting.

Searching for Unicode text

FrameMaker uses the UTF-8 encoding format. Therefore, every character in a .fm or XML document containing Unicode-encoded text uses multiple bytes. As a result, only the string entered in the Find field is used to perform the search operation.

Searching in a range is applicable only to Unicode characters, and users can search for any character that belongs to the Basic Multilingual Plane (BMP). Unicode code points can also be used for performing search and replace opera­tions. For example, you can provide \uXXXX as the input to locate a character that has code point XXXX. Thus, to search for letter “A” whose code point is u+0041, you can specify \u0041 in the Find/Change dialog box.

A code point is any value in the Unicode codespace, which is a range of integers from 0 to 10FFFF16. This particular range is defined for the codespace in the Unicode standard only. Other character-encoding standards sometimes use other codespaces.

You can also use wildcard characters while searching for Unicode text.

note:  In Asian documents with multibyte characters, the bracket characters [ ] do not work as wildcards.

Replacing items

When changing items, keep the following in mind:

•                

If you choose Change or Change & Find when no text is selected in the document, FrameMaker inserts or applies the replacement item at the insertion point.

 

•               The Clone Case option in the Find/Change dialog box maintains the capi­talization in the source text. For example, if you select Clone Case and type tea in the Find box and coffee in the Change box, FrameMaker replaces tea with coffee and Tea with Coffee. 

•               You can type any text, including special characters not found on the keyboard—for example, em spaces and paragraph symbols.

•               You can’t change marker text by using the Find/Change dialog box. If FrameMaker finds the marker text you specify, and if you type different text in the Change box and click Change, FrameMaker replaces the marker—not the marker text—with the text in the Change box. To change marker text, use the Special > Marker command.

4.3.2.                Search for backslashes and wildcard characters

You can enter any characters in the Find/Change box. However, the following characters require special treatment:

•                

For backslashes, specify two backslashes (\\) in the box. A single backslash usually indicates a special character.

 

•               For wildcard characters used as ordinary characters, when the Use Wild­cards option is selected, precede the wildcard character with a backslash in the box.

 

Related links:

Typing in dialog boxes

4.3.3.                Search for character format properties

1)            

Copy the text with the character format you want to find. FrameMaker uses only the first 126 characters copied into the clipboard.

 

2)           Select Edit > Find/Change. In the Find/Change dialog box, choose Text & Character Formats In Clipboard from the Find pop-up menu. Don’t type the text you want to find in the Find box.

 

3)           Click Find.

 

To prevent FrameMaker from applying a property to found text, set the prop­erty to As Is.

tip:  After making some changes in the Change To Character Format dialog box, you can reset the dialog box to match the format of the current text by pressing Ctrl+Shift+F9.

4.3.4.                Search for special characters and nonprinting symbols

You can search for any text, including single characters, phrases, and special characters that aren’t on your keyboard. You’ll need to type the backslash sequence.

For example, you could find empty paragraphs by searching for \P\p (beginning of paragraph followed by end of paragraph).

You can use most of these sequences for both searching and replacing—for example, replacing a forced return symbol with an end-of-paragraph symbol. However, you cannot replace with the end-of-flow, start-of-paragraph, start-of-word, or end-of-word sequence.

Related links:

Typing in dialog boxes

4.3.5.                Search for markers

FrameMaker uses markers for cross-references, indexes, and other purposes. It can find any type of marker or just the marker type you specify. When text symbols are visible, a symbol
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indicates a marker.

FrameMaker can also find markers with specific marker text.

1)           In the Find/Change dialog box, do one of the following:

 

•               To find any marker in the document, choose Any Marker from the Find pop-up menu, and leave the Find box blank.

 

•               To find a specific type of marker, choose Marker Of Type from the Find pop-up menu, and enter the marker type in the Find box.

 

•               To find a marker with specific text, choose Marker Text from the Find pop-up menu, and enter the marker text in the Find box.

2)           Click Find. If the Marker dialog box is open (Special > Marker), the marker text for the found marker appears there.

 

important:  If you want to replace the text in a found marker, use the Marker dialog box to edit the marker text. If you use the Find/Change dialog box, you’ll replace the marker rather than the marker text. 

4.3.6.                Search for conditional text

You can search for visible text that has specific condition tags. When FrameMaker finds visible conditional text, it selects all adjacent text that uses these condition tags.

FrameMaker cannot find conditional table rows.

1)            

Make sure that the text with the condition tags you want to find is visible.

 

2)           In the Find/Change dialog box, choose Conditional Text from the Find pop-up menu.

 

3)           Do the following:

 

•               To find text with a particular condition tag, move the condition tag to the In list.

 

•               To find text that doesn’t have a particular condition tag, move the tag to the Not In scroll list.

 

•               If you don’t care whether found text has a particular tag, move the tag to the As Is scroll list.

 

•               To find all conditional text, move all tags to the As Is scroll list.

 

•               To find unconditional text, select Unconditional.

 

note:  To move a condition tag between scroll lists, select the tag and click an arrow, or double-click the tag. To move all tags from one scroll list to another, select a tag in the list and Shift-click an arrow.

 

4)           Click Set, and then click Find.

 

4.3.7.                Troubleshoot a search

If you don’t find the item even though you’re sure it is there, check the Find/Change dialog box for the following possible problems:

•                

Text spelling.

•               Number and type of spaces.

 

•               Search options.

 

•               Hidden conditional text.

 

•               Insertion point on master page when searching a master page.

 

•               Selection of Book option when searching entire book.

 

4.4.                   Check spelling

 

4.4.1.                FrameMaker dictionaries

 FrameMaker automatically creates a personal dictionary for you and a docu­ment dictionary for each of your documents. You can use either the Spelling Checker or Auto Spell Check options, to add or delete words in these dictio­naries, or you can manage the dictionaries directly. When you work with a dictionary directly, you can examine and edit its contents or merge it with another dictionary. You can create multiple personal dictionaries and then use them one at a time.

If you make changes either to a personal or to a document dictionary, mark all paragraphs for rechecking before you spell-check the document again.

You perform many of the following tasks in the Dictionary Functions dialog box.

About FrameMaker dictionaries

The FrameMaker Spelling Checker uses several dictionaries to check text for spelling errors. When you spell-check a document, FrameMaker compares each word in it with the words in the following dictionaries:

•                

The main dictionary contains words found in a standard dictionary. You can’t add words to or delete words from this dictionary.

 

•               The default site dictionary contains some technical terms. You can add words common to your site or workgroup—for example, the company name and product names. The site dictionary is normally in the site.dict file in the FrameMaker dict folder.

•               Your personal dictionary contains words you use often. Because FrameMaker uses this dictionary whenever you spell-check any docu­ment, use this dictionary for words that are neither document-specific nor site-specific (for example, your name). You can add or delete words. You can also create several personal dictionaries and switch between them.

 

•               The document dictionary contains words that are acceptable in a partic­ular document. FrameMaker uses this dictionary regardless of who is editing the document. You can add words to or delete words from it. Unlike the other dictionaries, the document dictionary is part of the docu­ment rather than a separate file.

 

You have editorial control over your document, personal, and site dictionaries. You can choose different dictionaries, merge one dictionary into another, and edit and delete dictionaries.

 

Dictionaries for other languages

 

In FrameMaker, the dictionaries, hyphenation, and Thesaurus are Unicode enabled.

 

FrameMaker provides dictionary and hyphenation support for the following languages: Bulgarian, Catalan, Croatian, Czech, Danish, Dutch, Estonian, Finnish, Greek, Hungarian, Italian, Latvian, Lithuanian, Norwegian, Nynorsk, Polish, Portuguese, Romanian, Russian, Slovak, Slovenian, Spanish, Swedish, and Turkish.

 

note:  By default, dictionaries of all languages supported in FrameMaker are installed.

FrameMaker provides full authoring support (without dictionaries and hyphenation) for Japanese, Korean, Traditional Chinese, and Simplified Chinese.

 

In addition, full authoring support (including language rules, dictionary, hyphenation, and thesaurus) is extended for US English, French, Danish, Dutch, German, Italian, Norwegian, Swedish, Swiss German, Canadian French, and British English.

 

Choose Dictionary Functions dialog box

1)            

Make the appropriate document window or book window active.

 

2)           Choose Edit > Spelling Checker.

3)           Click Dictionaries.

Delete the contents of the document dictionary

1)            

Choose Clear from the Document Dictionary pop-up menu and click OK.

 

Locate a personal dictionary

1)            

To find the name of the personal dictionary, choose Edit > Spelling Checker, and then click Dictionaries.

 

Import dictionary entries

1)            

Select Edit > Spelling Checker and click Dictionaries.

 

2)           Select Import Dictionary from the Personal Dictionary pop-up menu and click OK.

 

3)           Locate or specify the name of the file that contains the personal dictionary you want to use and click Use.

 

Check the spelling of a document without using the personal dictionary

1)            

Choose Set To None from the Personal Dictionary pop-up menu and click OK.

 

Copy the contents of a dictionary to a file

1)            

Choose Write To File from the Personal Dictionary or Document Dictio­nary pop-up menu and click OK.

 

2)           Specify the file to which you want to copy the dictionary contents. You can edit this file and then use it as a new dictionary.

If a book window is active when you choose this command, the document dictionaries are copied to a single file.

Merge the contents of a dictionary with the current personal or document dictionary

1)            

Choose Merge From File from the Personal Dictionary or Document Dictionary pop-up menu and click OK.

 

2)           Specify the file you want to merge with the current dictionary.

 

tip:  You can use the Merge From File command to merge a single dictionary into multiple book files so that all the files in your book share the same dictionary.

Create another personal dictionary

1)            

Place words, with a hyphen at each hyphenation point, in a document. Type as the first line in the document: <MakerDictionary 3.0> 

2)           When you save the file, choose Text Only format and click Save. Then click Only Between Paragraphs and click Save.

 

Change site dictionaries

You can specify a different site dictionary for each of several projects. You can also edit your site dictionary directly.

If FrameMaker is used across a network at your site, a system administrator probably manages the site dictionary.

1)            

Specify the dictionary in the maker.ini file.

note:  Use caution when editing an ini file.

 

Edit dictionary files

1)            

If you’re editing a personal or document dictionary, use FrameMaker to write the dictionary contents to a file.

 

2)           Edit the file. If you use FrameMaker to edit a dictionary, be sure to do the following:

 

•               When you open the file, select Treat Each Line As A Paragraph in the Reading Text File dialog box and click Read.

 

•               When you save the file, choose Text Only format and click Save. Then click Only Between Paragraphs and click Save.

 

3)           Merge the dictionary file with another dictionary. If you removed words from the dictionary, delete the original dictionary before merging the file. Otherwise, the deleted words remain in the dictionary.

 

Add unknown words to a dictionary

If your document contains many correctly spelled words that FrameMaker questions, expedite spell-checking by adding the words to a dictionary in a sepa­rate operation before you begin to spell-check.

1)           Make the appropriate document window or book window active.

 

2)           Choose Edit > Spelling Checker.

 

3)           Click Dictionaries.

 

4)           Click Write All Unknown Words To File and click OK.

5)           Specify a filename for the dictionary file, and click OK or Save. The resulting dictionary file doesn’t include typing errors such as repeated words, capitalization errors, or extra spaces.

 

6)           Edit the dictionary file with a text editor or with FrameMaker. Delete any words you don’t want to add to your dictionary, such as misspelled words.

7)           In the Spelling Checker dialog box, click Dictionaries.

 

8)           Choose Merge From File from the Personal Dictionary or Document Dictionary pop-up menu, and click OK. If you expect the words to appear in several documents, merge the words with a personal dictionary, or merge them into all the files in a book.

 

9)           Name and save the dictionary file.

 

note:  To add a few words to a dictionary, you can select Learn Word from right click menu. Above method is help if you have many words highlighted by red squiggly line.

Add hyphenated compound words to personal dictionary

A document sometimes contains hyphenated compound words. By default, FrameMaker spell-checks each word in a hyphenated compound word rather than checking the hyphenated compound word as a whole. For example, when spell-checking the word heavy-duty, FrameMaker checks heavy and then checks duty. By changing the default settings, you can spell-check hyphenated compound words as single words, and you can add hyphenated compound words to your personal dictionary.

1)            

Choose Edit > Spelling Checker and click Options.

2)           Select Unusual Hyphenation and click Set.

3)           In the Word box in the Spelling Checker dialog box, enter the hyphenated compound word you want to add to your personal dictionary. Include a hyphen at the beginning of the compound word, and type a backslash (\) before each hyphen that connects words.

For example, to add the word heavy-duty, type -heavy\-duty.

 

4)           Click Learn.

 

4.4.2.                Spelling and typing errors

When correcting errors, keep in mind the following:

•                

If FrameMaker questions something that you don’t consider to be a typing error, you can turn off the option to find that type of potential error. For example, you can stop FrameMaker from questioning the use of straight quotation marks.

 

•               If FrameMaker adds a word that contains uppercase letters to a personal or document dictionary, when Unusual Capitalization is selected in the Spelling Checker Options dialog box, it considers any other capitalization of the word a spelling mistake. For example, if FrameMaker learns Trin­idad, it questions the spelling of trinidad. However, if it learns trinidad, in all lowercase letters, it does not question any type of capitalization of the word.

 

•               FrameMaker does not spell-check superscript and subscript text or manu­ally micropositioned text, such as text with a manual baseline shift).

 

•               To correct a typing error (for example, repeated words such as and and), make sure that the correctly typed text is in the Correction box and click Correct. FrameMaker lists only one suggestion for mistyped text. If the suggestion is not correct, you can enter the correct text in the Correction box, or type it directly in the document window.

 

Spell-check a document, book, or map

The Spelling Checker checks for repeated words, unusual hyphenation or capi­talization, punctuation errors, straight quotation marks (when curved must be used), and extra spaces. You can spell-check the current page, the open docu­ment, the entire book, bookmap or DITA map, or selected files within the book. However, the spell check only checks on pages of the type you are viewing, for example, master pages or body pages.

FrameMaker begins spell-checking from the active document or from the first document of the book if the book window is active. It continues spell-checking until all documents in the book have been checked. If a document cannot be opened, the document is skipped and a message appears in the Book Error Log. When spell-checking throughout a book, you cannot spell-check master or reference pages.

An alert message prompts you to save the document before continuing with the next document. When the last document in the book has been checked, a Spelling OK or Finished checking spelling message appears.

To check the spelling in specific documents of a book or map, you can select them in the resource manager view, and then choose Selection to spell-check only those files, books, or maps if you decide to spell-check the entire book or map.

FrameMaker draws a red squiggly line under words, to indicate spelling mistakes—words not present in the dictionary. A green squiggly line under the word indicates a punctuation mistake. To correct, right click on a highlighted word and select the desired option.

note:  For the words highlighted in green, the options to add to dictionary are not applicable, and hence are not available.

In FrameMaker, Auto Spell Check feature is enabled by default. If for some reason you disabled it, you can enable it again by going to File > Preferences > General. This option spell checks the open file as soon as it is turned on.

When you spell-check throughout a book or map, words added to your personal dictionary are applied to all documents. Words added to the document dictio­nary are used only in the current document, not in any other document in the book. When the Spelling Checker finds a questionable word, it suggests the most likely correction along with some other possibilities.

1)            

In the document, choose Edit > Spelling Checker and click Start Checking.

 

note:  Auto spell check is session specific and not document specific. If the same document is opened on a different machine, settings for Auto spell checker might differ.

Correct spelling errors automatically

You can have FrameMaker automatically correct future occurrences of a misspelled word or typing error. FrameMaker keeps track of the errors to correct automatically until you exit or until you instruct FrameMaker to stop making the corrections.

Before changing a particular misspelling or typing error automatically, verify the changes to make. If you use the Automatic Correction option when correcting a repeated word, FrameMaker corrects every repeated word even though some are correct (such as had had). Similarly, if thst is a misspelling of both test and that, you don’t want to change it automatically to either word.

1)           Choose Edit > Spelling Checker and click Start Checking.

 

2)           When FrameMaker questions a word or typing error, select and click Correct.

 

4.4.3.                Spell-check text insets

1)            

Open the inset source file and check the spelling there.

4.4.4.                Change Spelling Checker options

When you spell-check a document, FrameMaker also checks for errors that don’t involve spelling—for example, repeated words, extra or misplaced spaces, or unusual capitalization. You can specify the kinds of typing errors to check.

You can also limit the spell-check so that FrameMaker overlooks certain types of words. For example, perhaps you want to overlook words that contain numbers.

1)            

Choose Edit > Spelling Checker and click Options.

 

2)           Do the following:

 

•               In the Find area, specify the kinds of typing errors you want to find. For example, select Unusual Capitalization if you want to find words with uppercase letters in inappropriate locations (for example, GReen).

•               In the Ignore area, specify the kinds of words you want to overlook. For example, select Words With Digits if you want to ignore words that contain numbers.

 

Keep in mind that the more words FrameMaker overlooks, the greater the possibility that your document contains mistakes. For example, if you choose to ignore words containing a period, you also skip over a sentence that begins without a space after the preceding period.

 

•               If you change the Spelling Checker options and then want to reset the default options, click Get Defaults. If you exit FrameMaker without resetting the default options, your current settings become the default options.

3)           Click Set.

4.4.5.                Recheck after changing Spelling Checker options

FrameMaker ordinarily rechecks only paragraphs that have been edited since the prior check. If you change options after spell-checking a document, consider running the Spelling Checker again after instructing FrameMaker to mark all paragraphs for rechecking.

4.4.6.                Assign text to be ignored by Spelling Checker

To ignore certain text, change its Language property to None. For example, perhaps you don’t want to spell-check paragraphs of computer code.

When you set the language of text to None, FrameMaker no longer provides hyphenation for it.

4.4.7.                Check spelling in different languages

All text is assigned a language. When you spell-check, FrameMaker uses the main dictionary of the language assigned to the text. You can change the language used to spell-check text by changing the language assigned to the text. You can also add Unicode (UTF-8)-encoded words to user and personal dictio­naries in FrameMaker.

The FrameMaker CD contains dictionaries for all supported languages. However, the default installation contains only one dictionary in a single language.

1)            

To change the language of text in a document, use the Language property in the Default Font properties of the Paragraph Designer to change the language of one of the following:

 

•               A single paragraph, or all the paragraphs in a document.

 

•               A range of text within a paragraph, or the language of a text line.

 

Note the following about Asian-language documents:

•                

In an Asian-language document, some special characters are not displayed in the Spelling Checker as they are in a Western-language document. For example, a backslash is displayed as a yen symbol, and a nonbreaking hyphen is displayed as a blank.

 

•               In an Asian-language document that contains Roman text, make sure that you turn off the Straight Quotes option in the Spelling Checker dialog box so that the Spelling Checker does not stop on properly spelled words.

 

Related links:

Font changes using the designers

4.4.8.                Control hyphenation

When you add a word to a personal dictionary, FrameMaker suggests hyphen­ation points. You can change them before adding the word. You can also specify that a word is always or never hyphenated. For example, you can hyphenate heavy duty wherever it appears but never hyphenate your company name.

After making hyphenation changes, rehyphenate the document.

tip:  For strict control over hyphenation (for example, before printing the final draft of a book), consider searching your document for all hyphens that FrameMaker has inserted automatically. Choose Automatic Hyphen from the Find pop-up menu in the Find/Change dialog box.

Change word hyphenation

1)            

Show the hyphenation points of the word.

 

2)           Adjust the hyphenation and click Learn. You can add and delete hyphens as necessary.

 

Prevent FrameMaker from hyphenating a word

1)            

Enter the word in the Correction box.

 

2)           Click Show Hyphenation.

 

3)           Remove all hyphens from the word.

 

4)           Insert a hyphen at the beginning of the word.

 

5)           Click Learn.

 

Rehyphenate an entire document

1)            

Make the appropriate document window or book window active.

2)           Choose Edit > Spelling Checker.

3)           Click Dictionaries.

 

4)           Select Rehyphenate Document and click OK. This option works for an open document.

 

In case of a book file, select Rehyphenate All Files In Book and then click OK.

 

4.5.                   Use the Thesaurus

 

4.5.1.                Look up words in the Thesaurus

Use the Thesaurus to look up synonyms, related words, and antonyms for words you specify. The Thesaurus lets you improve on a word already in a docu­ment or search for the right word to insert.

You can look up any one of the words from the first pass and display its synonyms, related words, and antonyms. FrameMaker keeps a history of the last 10 words you looked up.

If more information is available than fits, you can use the arrow buttons at the bottom of the dialog box to view the additional information. FrameMaker displays the synonyms, antonyms, and related words with capitalization that matches the capitalization of the word you looked up.

You can look up words in the following ways:

•                

To look up a word visible in the document window, select the word and choose Edit > Thesaurus.

 

•               To look up a word not visible in the document window, make sure that no text is selected, then choose Edit > Thesaurus. Enter the word and click Look Up.

 

•               To look up a phrase, make sure that no text is selected and choose Edit > Thesaurus. Enter the phrase, including any hyphens, in the Thesaurus Look Up dialog box, and click Look Up

 

note:  If you try to specify a phrase by selecting it in the document window, FrameMaker looks up only the first selected word.

 

•               To look up a synonym, a related word, or an antonym displayed in the Thesaurus dialog box, click the word. Synonyms, related words, and antonyms are shown in bold.

•               To look up a word again, choose the word from the Word pop-up menu in the Thesaurus dialog box.

4.5.2.                Choose a language for the Thesaurus

FrameMaker uses the language of the current text. If a word isn’t selected or the insertion point isn’t in a paragraph, FrameMaker uses the language of the inter­face you chose when you installed FrameMaker. You can override the default language in new documents by creating your own template for custom new documents.

The Thesaurus for a language is installed along with the dictionary for that language.

4.5.3.                Specify a different language when looking up a word

1)            

Click Look Up in the Thesaurus dialog box.

 

2)           Enter the word you want to look up, choose a language, and click Look Up.

4.5.4.                Insert a word from the Thesaurus into the document

1)            

Do one of the following:

 

•               To add the word, place an insertion point in the document.

 

•               To replace a word in the document, select the word.

 

2)           Control-click the word in the Thesaurus dialog box and click Replace.

 

Related links:

Check spelling

4.6.                   Multiple Undo/Redo

 You can undo or redo multiple actions in FrameMaker. For example, saving a .fm file as a .mif file does not clear the history. However some actions cannot be undone and you are prompted to confirm the action. For example, deleting a blank page from a document cannot be undone.

4.6.1.                Undo and Redo commands

A Redo icon 

[image: P_Redo_18x18_N.png]

appears in the toolbar, next to the Undo icon 

[image: P_Undo_18x18_N.png]

. Click this button to redo the most recently undone action in the current document.

A Redo command also appears in the Edit menu and in context menus, under the Undo command, showing the most recent redoable command in the current document.

The Edit menu displays the last command as well as the last command that has been undone.

[image: tx_edit_redo.png]

If no action is available for Undo or Redo in the current document, the corre­sponding menu options and toolbar buttons are unavailable (dimmed).

The History command opens the command History panel, which allows you to undo or redo an action other than the most recent one, along with all of the subsequent actions.

4.6.2.                Document-level command history

FrameMaker maintains a history of undoable commands, so that you can select one or more recent commands to undo or redo.

The command history is available through the Edit menu and context menus. The command history is kept separately for each document, so undoing or redoing an operation in one document does not change the undo capability of another open document.

Cursor movement and object selection actions are not undoable, but when a previous state is restored, it includes the original cursor location and object selection state.

Commands that affect an external file (such as Spelling Checker commands that update the user dictionary) cannot be undone.

4.6.3.                Repeat Last Operation

FrameMaker features a powerful Repeat Last Operation feature that makes it easy for you to repeat the previous operation, when working on a FrameMaker document.

Repeat Last Operation can be performed on a document at the following loca­tions:

•                

The current insertion point

 

•               The current text selection

 

•               The current object selection

 

To perform the Repeat operation, select Edit > Repeat [operation/object name] from the FrameMaker menu.

 

In addition, you can view the history buffer by selecting Edit > History from the FrameMaker menu.

Click once on an entry in the buffer to perform it. Click once more on the entry to undo the operation.

Repeat Last Operation can be performed for the following actions on the docu­ment:

•                

Typing: Repeat Last Operation history buffer remembers the last chunk of characters that were typed. The typing sequence is broken when:

•                

The user clicks in the document.

 

•               The user switches between tabbed documents.

 

•               Paste: Repeat Last Operation can repeat the last paste operation at the current cursor location for both text and graphic objects in the clipboard. The list of graphic objects that can be pasted with Repeat Last Operation, are as follows: Aframe, Arc, Ellipse, Group, Inset, Line, Math, Polygon, Polyline, Rectangle, Rounded Rectangle, TextFrame, TextLine, Unan­chored Frame.

 

note:  The copy operation is not repeatable. 

•               Delete: Repeat Last Operation can repeat deletion of both text as well as graphical objects.

note:  If you delete multiple characters and then use Repeat Last Operation, only a single character is deleted. note:  Character deletion and object dele­tion operations are interchangeable. If you delete a character and then perform a Repeat Last Operation on a graphic object, the graphic object is also deleted. 

•               Apply Character Format Changes: Repeat Last Operation can reapply the properties of the last applied character format to the new text selection.

 

•               Apply Paragraph Format Changes: Repeat Last Operation can reapply the properties of the last applied paragraph format to the new paragraph selection.

 

•               Insert Graphic Objects: Repeat Last Operation can reinsert the last inserted graphic object at the current cursor location. This operation works across documents.

The list of graphic objects that can be inserted are as follows:

Aframe, Arc, Ellipse, Group, Inset, Line, Math, Polygon, Polyline, Rect­angle, Rounded Rectangle, TextFrame, TextLine, Unanchored Frame.

 

•               Insert Table: You can use Repeat Last Operation to reinsert the last inserted table at the current cursor location.

 

•               Set Object Properties: When you apply the Repeat Last Operation command to set object properties, FrameMaker applies the last specified object properties to the new object.

•               Set Text Properties: Repeat Last Operation can repeat the last selected text property such as Plain, Bold, Italic, Underline and Justify to the currently selected text or paragraph.

 

•               Insert Footnote/Anchored Frame: You can use the Repeat Last Operation command to insert a previously inserted Footnote/Anchored Frame at the current cursor position.

 

•               Find/Change: When you apply the Repeat Last Operation command to the Find/Change procedure, FrameMaker performs the last Find/Change operation on any further occurrences of the specified text.

 

•               Apply Conditional Text: Repeat Last Operation can repeat the last applied conditional tag to the currently selected text.

 

The shortcut key for the Repeat Last Operation action is F6. Repeat Last Oper­ation is session-specific and not document specific.

Repeat Last Operation actions can be turned off by editing maker.ini. Edit the following entries:

•                

RepeatTypingEnabled: By default this entry is set to ON. Set this entry to OFF to disable the repeat typing operation.

 

•               RepeatEnabled: By default this entry is set to ON. Set this entry to OFF to disable the repeat last operation actions.

 

note:  Use caution when editing an ini file.

4.6.4.                History panel

 

The Edit > Undo and Redo menus show the most recent command, but a complete command history is available in the History panel, available from Edit > History. This panel allows you to select an action to undo or redo. The command history is shown only for the active document.

In the History panel, the most recent command is highlighted. Commands listed above the most recent are undoable. Commands listed below the most recent are redoable, and are marked with an asterisk (*).

 

The History panel shows a list of commands that have been performed as well as those that have been undone.
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You can undo and redo actions only in the order in which they were originally performed. When you select a command to undo, all later commands (which have been affected by the selected action) are also undone. FrameMaker also moves the selected command and all succeeding commands to the Redo list. Similarly, redoing a command moves it and subsequent commands back to the Undo list.

4.7.                   Equations

 

4.7.1.                About equations

 

Placing and displaying equations

 You can place an equation inline with paragraph text or display it in a para­graph of its own. In either case, FrameMaker creates an anchored frame for the equation. You can position an equation with other objects in an existing graphic frame, to annotate a graphic, for example. The graphic frames that contain equations can be either anchored or unanchored.
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A.

Inline

B.

Display

C.

In a graphic with other objects

 

Inline and display equations in structured documents

 

An equation element provides a frame with an equation object into which you can enter mathematical expressions. Like an anchored frame for graphics, an equation frame is anchored to a specific location in text.

 

You can insert an equation element inline with paragraph text or in a separate display paragraph.
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 A. 

Inline equation

 B. 

Display equation

 

An equation element appears in the document structure where it is anchored to text, regardless of the equation position on the page. In the Structure View, a square-cornered bubble with the snippet <EQUATION> indicates an equation element. The equation itself is not part of the structure.

 

Equation element
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If you export to SGML or XML, FrameMaker writes the equation to a separate graphics file (CGM format). Then FrameMaker adds an entity reference to it from your SGML or XML file.

 

You can change the file format for equations using a read/write rule. If you change the file format to MIF, FrameMaker keeps a track of equations and their respective file names. Saving the equation multiple times, still saves it to its one file, instead of creating multiple files as in FrameMaker 9.

 

For example:



	
 

New behavior

 


	
Old behavior

 





	
Equation 1 is saved in file say eq1.mif 

Editing the FrameMaker content and subsequently saving the file, saves equation 1 to the same eq1.mif. 

FrameMaker does NOT create new files on every save for the same equation.

 


	
Equation 1 is saved in file say eq1.mif 

Editing the FrameMaker content and subsequently saving the file, creates a new file say eq2.mif for the same equation 1.

 

FrameMaker creates new files on every save for the same equation.

 






Equations in graphic frames in structured documents

 

You can also place an equation in an anchored frame that’s already inserted for graphics. Do this to combine the equation with graphic objects. If the anchored frame is an element, the element is part of the document structure. However, the frame contents, including the equation, do not appear in the structure.

 

An equation in an anchored frame with graphics sometimes produces unwanted results if you export to SGML or XML. In general, if you plan to export to SGML or XML, place only one object in a frame.

 

Equations panel overview

The Equations panel contains the commands to create and change equations. It also contains the symbols, operators, functions, and other math elements you insert in equations. To display the panel, click the Equations button

[image: Equation.png]

 at the upper-right in the document window.

[image: tx_equations.png]

 

 A. 

The Equations pop-up menu appears on every page.

 B. 

This part of the panel changes from page to page.

 C. 

The names of the pages appear here, with the current page highlighted.

The Equations panel contains nine pages of math elements and commands. To display a page, click its name at the top of the panel.

Symbols

 

Greek characters, atomic symbols, diacritical marks, and strings.

 

Operators

 

Roots, powers, signs, subscripts, superscripts, and logic symbols.

 

Large

 

Sums, products, integrals, intersections, and unions.

 

Delimiters

 

Parentheses, brackets, curly brackets, and substitution.

 

Relations

 

Equal, less than, greater than, similar to, subset of, superset of, and proportional to.

 

Calculus

 

Integrals, derivatives, partial derivatives, gradients, and limits.

 

Matrices

 

Matrices and matrix commands.

 

Functions

 

Trigonometric, hyperbolic, and logarithmic functions; commands for evaluating expressions; and commands for creating and applying rules.

 

Positioning

 

Controls to adjust the position of an expression and the spacing around it, commands to specify alignment, and commands to set and clear manual line breaks.

 

4.7.2.                Create equations

To create an equation, insert an equation object in the document and then insert math elements in the equation.

tip:  When working with an equation, zoom in until it’s easy to read.

Create an inline equation

1)            

Click in text where you want to insert the equation. If the text is in a rotated text frame, unrotate the frame first by selecting the rotated text frame and pressing Esc g 0 (zero).

 

2)           Choose Special > Equations, or click the Equations button

[image: Equation00001.png]

 at the right side of the document window.

 

3)           On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.

A new equation object appears as a question mark in a frame anchored below the line with the insertion point. The first math element that you insert replaces the question mark prompt.

New inline equation

[image: gr_001.png]

 

4)           Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

 

Inserted elements

[image: gr_002.png]

 

5)           Choose Shrink-Wrap Equation from the Equations pop-up menu. This option shrinks the frame around the equation and places the equation in the line of text at the anchor symbol.

 

Shrink-wrapped inline equation

[image: gr_003.png]

 

6)           If the equation seems too close to the text on either side, insert a space before or after the frame. FrameMaker treats the frame that contains an inline equation as a character and doesn’t provide extra space around it.

 

7)           If the equation is too tall for the line, open up more space above or below the line. Use the Line Spacing pop-up menu on the formatting bar to turn off fixed line spacing.

 

Create an equation in a paragraph of its own (a display equation)

1)            

Click in an empty paragraph.

 

2)           Apply a paragraph format from the Paragraph Catalog, or set up your own format. The paragraph format determines the alignment, vertical spacing, and any autonumber for the paragraph that contains the equation.

tip:  If you created the document from a book or report template, use the Equation paragraph format. You can also copy this format to your docu­ment, but you’ll probably want to make some changes (for example, to the Default Font and Spacing properties).

 

3)           Click the Equations button

[image: Equation00002.png]

at the right side of the document window.

 

4)           On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.

 

A new equation object appears as a question mark in a frame anchored below the empty paragraph. The first math element you insert replaces the question mark prompt.

 

New equation in anchored frame

[image: gr_004.png]

 

5)           Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

 

Inserted elements

[image: gr_005.png]

 

6)           Choose Shrink-Wrap Equation from the Equations pop-up menu. This option shrinks the frame around the equation and places the equation in the empty paragraph.

Shrink-wrapped equation in its own paragraph

[image: gr_006.png]

 

Create an equation in a graphic frame with other objects

1)            

Click the Equations button

[image: Equation00003.png]

at the right side of the document window.

 

2)           Select a graphic frame or an object in a graphic frame.

 

3)           On the Equations panel, choose one of the New Equation commands from the Equations pop-up menu. Small, Medium, and Large specify the font sizes used in the new equation.

 

A new equation object appears as a question mark inside the frame. The first math element you insert replaces the question mark prompt.

 

New equation object

[image: gr_007.png]

 

4)           Insert the math elements in the equation by typing the elements or by clicking items on the Equations panel.

 

5)           To place the equation exactly where you want it, first select it by Control-clicking the equation.

 

6)           Move the equation by doing one of the following:

 

•               Drag it with the mouse.

 

•               Move it with the arrow keys.

 

•               Position it precisely with the Graphics > Object Properties command.

 

Related links:

Move an object

Create equations in structured documents using elements

4.7.3.                Insert math elements

An equation contains expressions made up of math elements—characters, text strings, operators, and other mathematical elements from the Equations panel.

[image: gr_008.png]

 

 A. 

Alphanumeric character

 B. 

Text string

 C.

Expression

 D. 

Operator

After you create an equation object, insert math elements in it by typing them or by clicking them on the Equations panel. The Equations panel can be closed when you insert an item from the keyboard.

note:  Math equations support the Unicode text-encoding standard.

 

About the scope of operations

 

When you insert a math element in an equation, FrameMaker adjusts the math­ematical syntax. The result depends on the scope of operation—the selection or the location of the insertion point. For example, when you insert x in a fraction, the result depends on whether the numerator, the denominator, or the entire fraction is selected.

 



	
If you multiply by x

 


	
The result is
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   or   
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   or   
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In the first example, only the 7 is multiplied by x. In the second example, FrameMaker adds parentheses to show that the entire expression 2y + 7 is multiplied by x. In the last example, the entire fraction is multiplied by x. The size of the insertion point in the first and last examples indicates the scope.

Many mistakes in equations result from an incorrect scope of opera­tion—having too little or too much selected when inserting an element. Be careful to select the range you want before inserting an element.

 

Insert a math element

 

1)            

Select an expression or place the insertion point in an equation.

 

2)           Do any of the following:

 

•               To insert a math element by using the Equations panel, click the element.

 

•               To insert an alphanumeric character or a symbol that appears on the keyboard, type it. You can type parentheses, brackets, plus signs, equal signs, and so on. If you type an open parenthesis, FrameMaker inserts the closing parenthesis.

 

•               To insert an element by typing a backslash sequence, type a backs­lash ( \ ) and the string that identifies the element, and then press Return. For example, to insert the symbol for infinity

[image: infty.png]

, type \infty  and press Return.

 

•               Insert a custom math element.

 

If an element needs one or more operands, a question mark prompt

[image: qstnmark.png]

 appears for each operand; otherwise, an insertion point appears. To move from one operand to another, press Tab.

 

Insert a text string

A text string is a series of characters that is interpreted as a unit. Unlike charac­ters that make up an expression, the characters in a text string don’t usually appear in italics and aren’t multiplied together.

A. Text strings

[image: gr_009.png]

Text strings have no mathematical meaning in FrameMaker. For example, eval­uation commands can evaluate the function tan but not the string “tan”.

1)            

On the Symbols page of the Equations panel, click Start String. Two double quotation marks ( " " ) appear. You can also type an apostrophe ( ' ) or a double quotation mark (") to start the string.

 

2)           Type the text of the string. The quotation marks disappear, and the text appears as you type. To insert a straight apostrophe or straight double quotation mark as part of the string, hold down Control while pressing the key.

 

3)           Click End String on the Symbols page or press Return.

 

Insert, add, or edit a horizontal or vertical list of expressions

An equation object usually contains one equation or expression. You can set up a horizontal or vertical list in which several expressions are contained in the same object. When you select a list, all the expressions in the list are selected as one object.

 

[image: gr_010.png]

 

 A. 

Horizontal list

 B. 

Vertical list aligned on equal signs

FrameMaker aligns the expressions in the list automatically. When you move the list, all the expressions maintain their relative positions.

1)            

Select the expression you want to be the first item in the list or to add to a list.

 

2)           On the Operators page of the Equations panel, click the horizontal list element
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 or vertical list element
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. To add a math element, type the elements or click items on the Equations panel. A horizontal or vertical list appears. The selected expression appears as the first item in the list. A second item appears in the list as a question mark prompt.



	
Before clicking

 


	
After clicking
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In the first example, a horizontal list is inserted. In the second example, a vertical list is inserted, and the selected expression becomes the first item in the list. In the last example, a vertical list is inserted as part of a larger expression.

Insert symbols

The Symbols page on the Equations panel contains the Greek alphabet, other symbols, and diacritical marks.

The Symbols page doesn’t include Greek letters that have Roman-alphabet equivalents, such as the uppercase alpha (A). The following examples show the result of clicking
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on the Symbols page.



	
 

Before clicking

 


	
After clicking
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Diacritical marks appear on the element to the left of the insertion point or on the selected expression. Click the dot or prime button once for each dot or prime diacritical mark you want to insert.

note:  To interpret and mathematically manipulate a summation, product, or partial differential element, insert the element from the Large page or Calculus page. Do not insert from the Symbols page. Elements from the Symbols page are not evaluated.

Insert operators

The Operators page on the Equations panel contains commonly used operators, roots, powers, signs, subscripts, superscripts, and logic symbols.

If an expression is selected when you insert the operator, the expression becomes the first operand. The following examples show the result of clicking the plus sign
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 or the division operator
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on the Operators page.



	
 

Before clicking

 


	
After clicking
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You can represent the division operator as a slash (/), a horizontal bar
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, or a divi­sion sign

[image: divide00004.png]

.

FrameMaker can evaluate exponents mathematically, but not superscripts.
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 A. 

Superscript

 B. 

Exponent

Insert large elements

The Large page on the Equations panel contains sums, products, integrals, intersections, and unions.

If an expression is selected when you insert a large element, the expression becomes the first operand. The following examples show the result of clicking the summation symbol

[image: sum.png]

on the Large page.



	
 

Before clicking

 


	
After clicking
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You can add an operand after inserting a math element from the Large page.

Insert delimiters

The Delimiters page contains delimiters such as parentheses, brackets, and curly brackets.

If an expression is selected when you insert a pair of delimiters, the expression is placed inside the delimiters. The following examples show the result of clicking the parentheses on the Delimiters page.



	
 

Before clicking

 


	
After clicking
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You can also represent parentheses as brackets ([ ]) or curly brackets ({ }).

Insert relations

The Relations page contains relation symbols such as =, <, >,
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,
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,
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,
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, and
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.

All relation symbols—except the binary equal sign
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—apply to the character to the left or right of the insertion point or to the selection. When you insert a rela­tion symbol between multiplied elements, it applies to the elements on either side of the insertion point.

Binary equal signs

[image: equal00005.png]

 appear to the right of the current expression (as shown in the second example). When the insertion point or selection is in a subscript or superscript, the equal sign appears in the subscript or superscript.



	
 

Before clicking

 


	
After clicking
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Insert a binary equal sign at the insertion point

1)           Press Esc m =

 



	
Before clicking

 


	
After clicking
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Insert calculus elements

The Calculus page contains integrals, derivatives, partial derivatives, gradients, and the limit function.

If an expression is selected when you insert the calculus element, the expression becomes the first operand. The following examples show the result of clicking the integral symbol
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on the Calculus page.



	
 

Before clicking

 


	
After clicking
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You can change the position of operands and add operands.

Insert matrices

 

The Matrices page contains elements for matrices ranging in size from 1 by 1 to 3 by 3. After creating a matrix, you can add rows and columns.

If an expression is selected when you insert the matrix element, the expression becomes the first cell in the matrix.



	
 

Before clicking

 


	
After clicking
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Insert functions

The Functions page contains trigonometric, hyperbolic, and logarithmic func­tions, and also the sign, limit, and general functions.

FrameMaker places functions at the insertion point or at the selection. When an expression is selected, the expression becomes the argument of the func­tion—except for the limit and general functions
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 and

[image: limit1.png]

. The following examples show the result of clicking the sin function on the Functions page.



	
Before clicking

 


	
After clicking
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Insert a custom math element

In addition to inserting math elements that are built in FrameMaker, you can insert custom math elements that have been defined for a document.

Custom math elements have no mathematical meaning in FrameMaker. For example, a custom math element for an operator is treated as an operator in an equation. However, FrameMaker cannot evaluate it.

1)            

On the Equations panel, choose Insert Math Element from the Equations pop-up menu.

 

2)           Select the element name and click Insert.

 

4.7.4.                Shrinkwrap or unwrap an equation

 Shrinkwrapping an equation shrinks the surrounding anchored frame so that it’s large enough for the equation. The operation changes the frame anchoring position to At Insertion Point, and places the insertion point after the frame.

Before shrinkwrapping
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After shrinkwrapping
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Shrinkwrap an equation when you finish working with it so that the equation takes minimal space and aligns with the baseline of the surrounding text. Unwrap an equation to enlarge the anchored frame for easy editing.

1)           Click in the equation or select its frame.

 

2)           On the Equations panel, choose Shrink-Wrap Equation or Unwrap Equa­tion from the Equations pop-up menu. The edges of a shrinkwrapped equation sometimes do not appear onscreen. They do appear in the printed document.

 

4.7.5.                Edit equations

You can edit an equation as you edit text—adding, changing, rearranging, and removing math elements, and cutting, copying, and pasting them. As you edit an equation, the syntax of the equation is adjusted as necessary.

You can change a matrix—add or delete rows and columns, delete brackets, and change row height and column width. You can also choose among several representations for some math elements such as parentheses. You can add oper­ands to others such as integrals and summations.

If your equation is shrinkwrapped, unwrap the equation before editing it. This makes the anchored frame full-sized again, giving you more room to work.

 

note:  To edit a rotated equation, first restore the equation or text frame to its unrotated position by pressing Esc g 0 (zero).

Extend a selection using the keyboard

1)            

Press the spacebar. The selection expands to include the next higher expression. The following example shows the result of pressing the spacebar repeatedly.

 



	
Original selection
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Pressed once
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Pressed twice
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Change the selection

1)            

Do one of the following:

 

•               To change the selection to the next subexpression on the right, press the Right Arrow key.

 

•               To change the selection to the next subexpression on the left, press the Left Arrow key.

 

•               To change the selection to the next question mark prompt, press Tab.

 

Replace or delete a math element or equation

1)            

Select the element you want to delete and press Delete. A question mark prompt replaces the element.

 

2)           Do one of the following:

 

•               To replace the element, click the Equations panel or type to insert the replacement.

 

•               To delete the element, press Delete again. FrameMaker removes any elements that are no longer necessary—for example, a plus sign or parentheses.

 

•               Control-click the equation to select the equation, and press Delete.

 

Remove delimiters

After entering or editing an equation, you sometimes end up with extra delim­iters—parentheses, curly brackets, and brackets. You can remove extra delim­iters. If you later use evaluation commands, FrameMaker evaluates the equation as if the delimiters are still present.

•                

To remove all delimiters, select the expression. On the Delimiters page of the Equations panel, click Remove Parentheses.

 



	
Before clicking

 


	
After clicking
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•               To remove one delimiter, place the insertion point to the right of the delimiter and press Delete. If the delimiter has a mate, such as the left parenthesis between a and b in the example, the mate is also removed.

 



	
Before

 


	
After
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Toggle an element format

You can represent some math elements in more than one way. For example, delimiters can appear as
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,
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, or
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. Division can appear as
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,
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, or 
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.

1)            

Select the entire element.

 

2)           On the Operators, Large, Delimiters, or Calculus page of the Equations panel, click Toggle Format. The command is the same on all four pages and operates on any element with multiple formats. Click more than once to get the format you want in some cases.

 

Add an operand to a math element

Radical symbols, gradient symbols, and logarithms can have one or two oper­ands. Integrals and other symbols on the Large and Calculus pages can have one, two, or three operands.

Operands

[image: gr_033.png]

You can add operands to these elements without starting over.

1)            

Click or select anywhere in the expression with the element.

 

2)           Click Add Operand on the Large or Calculus page. A question mark prompt appears where you specify the new operand.

 

Change matrices

You can change the number of rows or columns in a matrix and add or remove brackets around the matrix. You can allow the column width to vary from column to column, depending on the contents, or specify that all columns are equal width. Similarly, you can allow the row height to vary from row to row.

You can also transpose a matrix and perform matrix algebra.

•                

To add a row or column to a matrix, place the insertion point in the matrix. On the Matrices page of the Equations panel, choose Add Row or Add Column from the Matrix Commands pop-up menu.

 



	
Before Add Column

 


	
After Add Column
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Add Row adds a row at the bottom. Add Column adds a column at the far right.

 

•               To delete a row or column from a matrix, select the row or column and press Delete.

 

•               To add or remove brackets around a matrix, select the entire matrix. On the Matrices page of the Equations panel, click Add/Remove Brackets.

 

•               To change the row height or column width in a matrix, select the matrix. On the Matrices page of the Equations panel, choose All Equal or Propor­tional from the Matrix Row Height or Matrix Column Width pop-up menu.

 

Equal row heights (left) and Proportional row heights (right)
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If you choose Proportional, each row is tall enough to hold the tallest cell in the row. Each column is wide enough to hold the widest cell in the column. If you choose All Equal, each row is tall enough to hold the tallest cell in the entire matrix. Each column is wide enough to hold the widest cell in the entire matrix.

4.7.6.                Create and define math elements

 

If you need a math element that doesn’t appear on the Equations panel, you can create a custom element—for example, a new operator such as
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. However, FrameMaker cannot evaluate custom math elements mathematically.

To display a built-in element on the panel differently in your document, you can redefine the element. For example, you can redefine the asin (inverse sine) func­tion so it appears as sin–1. You can redefine the appearance of a built-in element, but you can’t change its type.

You can also import math element definitions from another document.

Custom math element definitions are stored on one or more reference pages whose name begins with FrameMath. Each definition is a text line in an unan­chored graphic frame whose name is the element name.
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 A. 

Graphic frame

 B. 

Text line

Related links:

Add text to graphics

Use reference frames on reference pages

Change equation fonts throughout a document

Math element types

A math element type indicates how the element behaves in relation to other elements around it. For example, a plus sign (+) has the type infix, which means that it has two operands, one to the left and one to the right.

You can define custom math elements of the following types.



	
 

Type

 


	
Example

 


	
Number of operands

 





	
Atom
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None

 





	
Delimiter
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One

 





	
Function
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One, to the right of the element

 





	
Infix
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Two, to the left and the right of the element

 





	
Large
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Up to three, above, below, and to the right of the element

 





	
Limit
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Up to two, below and to the right of the element

 





	
Prefix
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One, to the left of the element

 





	
Postfix
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One, to the right of the element

 





	
Vertical list
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Two, one above the other (The text line that defines a custom vertical list is used as a separator between list items.)

 






You cannot define custom math elements of the following types.



	
 

Type

 


	
Example

 





	
Derivative
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Diacritical mark
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Horizontal list
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Matrix
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Root
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Script
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Substitution
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Vertical division bar
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Define a custom math element or change a built-in math element definition

1)            

Choose View > Reference Pages and display a FrameMath reference page.

 

If the document doesn’t contain a FrameMath reference page, display a reference page and then choose Special > Add Reference Page. Name the new page FrameMath1. Capitalize the letters F and M as shown.

 

2)           Use the Graphic Frame tool to draw an unanchored graphic frame on the page.

3)           In the Frame Name dialog box, enter a name for the math element. If you are redefining a built-in element, enter that element name.

 

4)           Use the Text Line tool to add a text line in the graphic frame.

 

5)           Create the math element in the text line using the following guidelines:

 

•               You can type any characters in the text line, and you can change the character format. You can also move the characters by using micro­positioning shortcuts.

 

•               For all math elements except delimiters, the text line represents just the mathematical symbol, not the operands. When you later insert the element in an equation, FrameMaker places the operands in the appropriate places, based on the type of math element. For example, a large element, such as a summation or an integral sign, has up to three operands—one above, one below, and one to the right of the symbol.

 

•               A custom delimiter can contain only one operand, even though some built-in delimiters contain two or three. To indicate the loca­tion of the operand, insert a space in the text line. If you do not insert a space in the text line, FrameMaker places the operand between two copies of the delimiter.

 

A. Characters in delimiter.    B. Space indicates the operand. 
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•               FrameMaker uses the first text line in the frame for the custom math element. Make sure that only one text line exists in the frame.

 

6)           Select the graphic frame.

 

7)           On the Equations panel, choose Add Definition To Catalog from the Equations pop-up menu.

 

8)           If you’re defining a custom math element, choose an element type from the pop-up menu, and click Add.

 

Find the name of a math element

1)            

Place the insertion point in an equation.

 

2)           On the Equations panel, choose Insert Math Element from the Equations pop-up menu.

 

3)           Turn off Show Custom Only, and then scroll through the element names to find the one you want.

4)           Click Cancel.

 

Change or delete a custom math element definition

1)            

Display the FrameMath reference page that contains the math element by doing one of the following:

 

•               If the custom math element appears in an equation, select the element, and choose Update Definition from the Equations pop-up menu on the Equations panel. Then click Go To Frame.

 

•               If you haven’t inserted the custom math element into an equation, choose View > Reference Pages. Then display the FrameMath refer­ence page you want.

 

2)           Do one of the following:

 

•               Edit the text line that defines the math element. When you display a body page again, FrameMaker uses the modified definition, and shrinkwraps the equations again.

 

•               Delete the graphic frame. If the element appears in an equation, FrameMaker displays the element name, surrounded by question marks, instead of the element.

 

Position math elements in an equation

FrameMaker positions math elements according to their mathematical meaning in an equation. Sometimes you want to microposition elements—repo­sition them so they’re closer to or farther from other elements in the equation.

Before and after micropositioning
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You can also control the amount of white space on each side of an element.
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 A. 

Default spacing

 B. 

Space added to the left and right

 C.

Space removed from the left and right

1)            

On the Positioning page of the Equations panel, do one of the following:

 

•               To position a selected expression, click a Micropositioning arrow. Click as many times as necessary. (Each click moves an expression one pixel on the screen.) Zoom in for greater precision.

 

Micropositioning arrows

[image: gr_045.png]

 

•               To remove micropositioning, click the button at the center of the Microposition area 

[image: MicrPosit.png]

.

 

•               To inspect the position offsets and adjust them numerically, click Position Settings. The exact offsets appear in the Microposition Offset area of the Math Element Position Settings dialog box. To adjust the position, enter values in the Microposition Offset area and click Set.

 

•               To adjust white space, click a plus sign (+) to add white space or a minus sign (–) to remove it. Click as many times as necessary. Each click adds or subtracts one pixel of space. Zoom in for greater preci­sion.

 

note:  To change the spacing around a math element of type infix, prefix, postfix, or delimiter, adjust the space around the adjacent math elements instead. For example, to add space on either side of the plus sign in the expression a+b, select a. Add space to the right. Then select b. Add space to the left. 

•               To adjust spacing values, click Position Settings. The exact spacing appears in the Spacing area of the Math Element Position Settings dialog box. To adjust the spacing values, enter values in the Spacing area, and click Set. To restore the default spacing values, click the button at the center of the Spacing area 
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.

 

Adjust the spacing values for a math element wherever it appears

You can update some math element definitions—infix, prefix, postfix, large, scripts, and the division bar—with new spacing. When you do, FrameMaker adjusts the spacing around the element wherever it appears in the document and rewraps the equations.

You can also change the spread—the space between characters—uniformly in all small, medium, and large equations.

1)            

After you adjust the spacing around the element in an equation, select the element.

 

2)           On the Equations panel, choose Update Definition from the Equations pop-up menu.

 

3)           Do one of the following:

 

•               To update the spacing for the element throughout the document, click Update.

 

•               To reset the spacing to the default, click Get Default.

 

4.7.7.                Set line breaks and align equations

You can control equation breaks across lines and alignment of the lines in a multiline equation, or of the items in a list or matrix. You can also align several equations with one another, even if they appear in different anchored frames.

Aligned along left side of equal signs
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You can manipulate equation objects as you do other objects. You can automat­ically and manually align items in a vertical list and lines in a multiline equation. Manual alignment points override automatic alignment.

Aligned on left side and at manual alignment point
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You can align the items in a horizontal list along their tops, bottoms, or base­lines.

Baseline-aligned
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You can also align the cells in each row of a matrix along their tops, bottoms, or baselines. You can align the cells in each column at the right, left, or center, or along equal signs.

Aligned along:
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 A. 

Baselines

 B. 

Centers

Related links:

Copy and arrange objects

Insert, add, or edit a horizontal or vertical list of expressions

Change equation line breaking

When an equation breaks across lines, the entire equation remains in a single anchored frame. You can set where an equation breaks across lines automati­cally. When you change the line-break width, the equation is reformatted to the new width.

Original equation
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Equation set to break at 1.25"
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You can also force a line break at a specific location in the equation. However, don’t use manual line breaks to create separate equations. Instead, insert a vertical list of expressions.

You can change line breaking in these ways:

•                

To change the automatic line break width, click in the equation or select any part of it. Choose Graphics > Object Properties. Edit the value in the Automatic Line Break After box, and click Set. The value is preset to the width of the equation frame.

 

•               To insert a manual line break, click where you want the equation to break into two lines. On the Positioning page of the Equations panel, choose Set Manual from the Line Breaking pop-up menu. A line-break symbol
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 appears at the insertion point when text symbols are visible.

Manual line break
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•               To remove a manual line break, select the part of the equation that contains the line-break symbol. On the Positioning page of the Equations panel, choose Clear Manual from the Line Breaking pop-up menu.

 

Align display equations

The format of the paragraph that contains the equation controls the alignment (left, center, or right) of a display equation.

Paragraph alignment set to Center
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1)            

Click in the paragraph that contains the equation (not in the equation itself).

 

2)           Choose the alignment from the Alignment pop-up menu in the format­ting bar or in the Paragraph Designer.

 

Set automatic alignment for a vertical list or multiline equation

1)            

Click in the equation or list.

 

2)           On the Positioning page of the Equations panel, choose an item from the Left/Right pop-up menu. When you choose Left Of = or Right Of =, the lines are aligned along one side of an equal sign. A line with no equal sign is aligned along its left side.

 

Set a manual alignment point for a multiline equation or for an item in a vertical list

 

1)           Do one of the following:

 

•               Click in the first line of a multiline equation where you want subse­quent lines to align.

 

•               Click in a vertical list item where you want the item to align with the rest of the list.

 

2)           On the Positioning page of the Equations panel, choose Set Manual from the Left/Right pop-up menu. A manual alignment symbol
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 appears at the insertion point when text symbols are visible. Subsequent lines of a multi­line equation are left aligned with the manual alignment point. A vertical list item aligns with other items in the list at the manual alignment point.

Clear a manual alignment point

1)            

Select the part of the equation that contains the manual alignment point.

 

2)           On the Positioning page of Equations panel, choose Clear Manual from the Left/Right pop-up menu. You can also clear a manual alignment point by setting another.

 

Align items in a horizontal list

1)            

Click in the list.

 

2)           On the Positioning page of the Equations panel, choose an item from the Up/Down pop-up menu.

 

Align cells in a matrix

1)            

Click in the matrix.

 

2)           On the Positioning page of the Equations panel, choose an item from the Up/Down pop-up menu or from the Left/Right pop-up menu. The Left/Right and Up/Down commands affect the whole matrix. To align individual cells, use micropositioning.

 

Check alignment settings for a horizontal or vertical list, or for a matrix

1)            

Do one of the following to select the entire list or matrix:

 

•               Drag through the list or matrix.

 

•               Place the insertion point in the matrix and press the spacebar repeat­edly.

 

2)           On the Positioning Page of the Equations panel, click Position Settings.

 

Left-, center-, or right-align equations in a frame

You can align several equation objects with one another in a graphic frame, just as you align other objects. You can also align several equation objects along a manual alignment point, even when they’re in separate graphic frames.

Equations aligned at manual alignment points
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FrameMaker maintains the alignment of the equation objects as you edit the equations. For example, if two equations are left aligned, the left alignment is maintained as the equations expand or shrink.

1)            

Select the equations to align by Control-clicking the first equation; Control+Shift-click the other equations.

 

Make sure that the last equation you select is the one you want to align with.

 

2)           Choose Graphics > Align.

3)           Select the left/right alignment you want, and click Align.

Align equations along a point

1)            

Set the manual alignment point in one of the equations to align.

 

If you don’t set a manual alignment point, FrameMaker aligns an equation on the left.

2)           Click in the equation and choose Graphics > Object Properties.

 

3)           Choose Manual from the Alignment pop-up menu and specify the loca­tion of the alignment point within the frame in the Alignment Point Offset area. The left offset is the distance from the left edge of the frame to the manual alignment point.

 

Specifying the top offset precisely is unnecessary. You can move the equa­tion up or down later, just as you do any other object.

 

4)           Click Set.

 

5)           Repeat steps 1 through 4 for each equation you want to align. Use the same distance from the left edge for each equation, but change the top offset to position the equation vertically in the frame. If the equations you’re aligning are in different anchored frames, make sure that the left edges align with one another.

 

4.7.8.                Change font settings in equations

A document contains font settings that apply to all equations in it. These settings determine the font sizes and spacing for small, medium, and large equa­tions. They also determine the character format used for Greek characters and for symbols, functions, numbers, strings, and variables.

You can change the preset size of an entire equation. You can also change the character format of individual math elements—for example, to use color or a special font.

You can also change the font sizes and character formats used for all equations in a document.

Change the character format in individual equations

You can’t change the spread, stretch, superscript, subscript, underline, overline, strikethrough, change bar, or pair kerning properties for any element. You also can’t change the font family for individual Greek characters and symbols and for some operators.

•                

To change the preset size or color of an equation, click in the equation, choose Graphics > Object Properties, and do one of the following:

 

–              To change the equation size, choose a size from the Size pop-up menu, and click Set. If the equation is shrinkwrapped, FrameMaker rewraps it.

 

–              To change the equation color, choose a color from the Color pop-up menu, and click Set.

 

•               To change character format, select the element or expression, and change as you do for text.

 

•               To create a superscript or subscript, insert the appropriate operator.

 

•               To change the spread of characters, microposition them by using the posi­tioning page of the Equations panel.

 

•               To place a line over or under an expression, use the diacritical marks on the Symbols page of the Equations panel.

 

Change equation fonts throughout a document

You can change the font size and spacing for all small, medium, and large equa­tions in a document. When you make global font changes, FrameMaker refor­mats and rewraps all shrinkwrapped equations in the document.

Greek characters and symbols in equations normally appear in the Symbol font. You can use fonts such as Mathematical Pi and Universal Greek if these fonts are installed on your system.

Functions, numbers, and strings normally appear in Times New Roman or Times. Variables normally appear in italic. You can change the character format of each of these kinds of elements. For example, you can display all elements in Helvetica, with functions in italic and variables in bold.

note:  Don’t delete formats from the Character Catalog if you’re using them to specify the character format of math elements. If you delete these character formats, all equations in the document are reformatted using the default font.

Use Equation Sizes from the Equations pop-up menu on the Equations panel for the following change:

•                

To change equation fonts throughout the document, do one of the following:

 

–              Specify the font sizes and spread, and click Set. Spread is expressed as a percentage of the font size. Positive spread values cause wider spacing around elements; negative values cause narrower spacing.

 

–              Click Get Defaults.

 

•               To change the font for Greek characters and symbols, choose one of the available fonts from the Math Symbols pop-up menu, and click Set.

 

•               To change the character format for functions, numbers, strings, and vari­ables, first create the character format you want. Then choose the char­acter format from the Functions, Numbers, Strings, or Variables pop-up menu, and click Set. FrameMaker displays the format you created in the pop-up menus.

4.7.9.                Evaluating equations

After you create an expression or equation, you can transform it by changing its mathematical representation. For example, you can multiply polynomials, factor terms, simplify expressions, and combine fractions.



	
 

Original selection
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Expanded
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Multiplied out
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Multiplied out again
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You can also evaluate equations by substituting values and performing compu­tations.



	
 

Original selection
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Expanded
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Value substituted
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Result computed

 


	
[image: gr_061d.png]

 

 






Transform or evaluate an expression

1)            

Select the expression, or part of it.

 

2)           Choose a command on the Matrices or Functions page of the Equations panel. For example, select an expression and then choose Multiply Out from the Multiplication pop-up menu on the Functions page.

 

3)           To transform or evaluate an expression, use the commands on the Matrix Commands pop-up menu of the Matrices page and the commands on the six pop-up menus of the Functions page.

 

Related links:

Change matrices

Matrix Commands pop-up menu

Matrix Transpose

 

Transposes the rows and columns of a selected matrix.

 



	
Selected matrix

 


	
After transposing
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Matrix Algebra

 

Performs matrix multiplication and addition, and evaluates dot and cross products in a selected matrix.



	
Selected matrix (or matrices)

 


	
After matrix algebra
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After performing matrix algebra, you can use the Simplify command to combine like terms.

 

Addition pop-up menu

Add Fractions

 

Adds selected fractions, expressing the result as a single fraction. This command also combines like terms.

 



	
Selected fraction

 


	
After adding
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If the selected expression contains the sum of more than two fractions, Add Fractions adds only the first two. Use this command repeatedly to combine all the fractions.

 



	
Selected expression
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Added once
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Added twice
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Order Sum

 

Arranges polynomials in decreasing powers of a selected variable.

 



	
Before ordering

 


	
After ordering
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Order Sum Reverse

 

Arranges polynomials in increasing powers of a selected variable. In the following example, you select an x—any x—before choosing Order Sum Reverse.

 



	
Before ordering

 


	
After ordering
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Multiplication pop-up menu

Use the Multiplication pop-up menu on the Functions page to factor terms, multiply out expressions, and distribute multiplication and division over addi­tion.

Factor

 

Factors a selected term out of a product.

 



	
Before factoring

 


	
After factoring

 





	
[image: gr_068a.png]

 


	
[image: gr_068b.png]

 





	
[image: gr_068c.png]

 


	
[image: gr_068d.png]

 






Factor Some

 

Factors a selected term from only those terms that contain it.

 



	
Before factoring

 


	
After factoring
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Multiply Out

 

Simplifies the selected expression, distributes multiplication over addi­tion, and expands a selected term raised to a positive integral power.

 



	
Selected expression

 


	
After multiplying
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The Simplify command also simplifies the selected expression.

 

Multiply Out Once

 

Multiplies the first pair of factors on the left side of a selected expression.

 



	
Selected expression

 


	
After multiplying

 





	
[image: gr_071a.png]

 


	
[image: gr_071b.png]

 






If you use this command several times, the results appear in a different form.

 

Distribute

 

Performs a variety of operations depending on the expression you select, as shown in the following examples:

 

•               Distributes division over addition.

 



	
Selected expression

 


	
After distributing
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Use the Add Fractions command to perform the reverse operation.

 

•               Distributes multiplication over addition.

 



	
Selected expression

 


	
After distributing
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Use the Factor command to perform the reverse operation.

 

•               Transforms products and quotients involving radicals and expo­nents into a single expression raised to a power.

 



	
Selected expression

 


	
After distributing

 





	
[image: gr_074a.png]

 


	
[image: gr_074b.png]

 





	
[image: gr_074c.png]

 


	
[image: gr_074d.png]

 





	
[image: gr_074e.png]

 


	
[image: gr_074f.png]

 






Use the Simplify command to perform the reverse operation.

 

Distribute Over Equality

 

Performs the same operation on both sides of an equal sign.

 



	
Selected expression

 


	
After distributing
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Division pop-up menu

Long Division

 

Performs long division in a fraction that contains a polynomial numerator and denominator.

 

In the following example, you select an x—any x—before choosing Long Division. You select an x in the fraction of the first result and choose Long Division again to obtain the second result.

 



	
Before dividing
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Divided once
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Divided twice
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Remove Division

 

Converts division to multiplication in a selected expression by changing positive exponents in a denominator to negative and negative exponents in a denominator to positive.

 



	
Selected expression

 


	
After removing division
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To convert negative exponents to division operators, use the Remove Negative Powers command.

 

Remove Division 1 Level

 

Converts division to multiplication, as Remove Division does, but applies only to the first level of operators.

 



	
Selected expression

 


	
After removing division
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To convert the first level of negative exponents into division operators, use the Remove Negative Powers 1 Level command.

 

Remove Negative Powers

 

Converts negative exponents to positive in a selected expression by replacing multiplication with division and division with multiplication.

 



	
Selected expression

 


	
After removing negative powers
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Remove Negative Powers 1 Level

 

Converts negative exponents to positive, as Remove Negative Powers does, but applies only to the first level. If the selected expression has no negative exponents at the first level, this command has no effect.

 



	
Selected expression

 


	
After removing negative powers
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Evaluation pop-up menu

Number Crunch

 

Changes integers to floating-point numbers in a selected expression and then evaluates the expression.

 



	
Selected expression

 


	
After number crunch
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Use the Show All Digits command to show up to 15 decimal places in a floating-point number.

Number Crunch displays NaN (Not a Number) for operations that result in undefined values. It displays Infinity for operations that result in a value too large to calculate. Small numbers can sometimes be evaluated to zero.

 



	
Selected expression

 


	
After number crunch
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Show All Digits

 

Shows the full internal accuracy of a floating-point number.

 



	
Selected number

 


	
After showing all digits
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Evaluate

 

Evaluates the selected expression. The operations performed depend on the type of expression selected, as shown in the following examples:

 

•               Rewrites an expression raised to a power less than 20 as a product.

 



	
Selected expression

 


	
After evaluating

 





	
[image: gr_084a.png]

 


	
[image: gr_084b.png]

 






•               Computes the factorial of an integer. If the result is too large to calculate, the result appears as Infinity.

 



	
Selected expression

 


	
After evaluating

 





	
[image: gr_085a.png]

 


	
[image: gr_085b.png]

 






•               Computes the determinant of a 1-by-1 or 2-by-2 matrix.

 



	
Selected expression

 


	
After evaluating
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•               Extracts a term from a sum or product.

 



	
Selected expression

 


	
After evaluating

 





	
[image: gr_087a.png]

 


	
[image: gr_087b.png]

 






•               Evaluates a substitution just as the Evaluate Substitution command does.

 

•               Rewrites an Evaluate Between operator as a difference.

 



	
Selected expression

 


	
After evaluating
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•               Rewrites the logarithm of a product as a sum of logarithms and rewrites a logarithm of a power as a product.

 



	
Selected expression

 


	
After evaluating
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•               Rewrites a logarithm to a base in terms of natural logarithms.

 



	
Selected expression

 


	
After evaluating
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•               Rewrites a choice function in terms of factorials.

 



	
Selected expression

 


	
After evaluating
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Evaluate Substitution

 

Performs a specified substitution and then simplifies the expression. When an Evaluate Between operator is selected, this command rewrites the expression as a difference.

 



	
Selected expression

 


	
After evaluating
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Evaluate Integrals

 

Rewrites a selected integral with a polynomial integrand. This command converts a definite integral into an indefinite integral evaluated between the upper and lower bounds. Use Evaluate Integrals several times to inte­grate a polynomial fully.

 



	
Selected expression
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Evaluated once
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Evaluate Derivatives

 

Evaluates a selected derivative, applying the chain rule to complex expres­sions when necessary. This command evaluates a partial derivative only when all dependencies are explicitly written.

This command treats elements in a total derivative as if they depended on the variable of differentiation. Use the Evaluate command to expand an nth derivative before using Evaluate Derivatives to evaluate it.
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Evaluate Derivatives 1 Level

 

Evaluates only the first level of a selected derivative.
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Rules pop-up menu

Use the Rules pop-up menu on the Functions page to store and apply rules that transform expressions.

For example, use Enter Rule to store a rule such as a = a + 3. Then use Apply Rule to substitute a + 3 for a in another expression.

Enter Rule

 

Stores a rule for substituting one expression for another. Select the expres­sion you want to store as a rule before you choose Enter Rule. You can store only one rule at a time.

 

Designate Dummy

 

Designates a selected term to be a dummy variable. Use a dummy variable in a rule to substitute the expression on the right side of the rule for any variable, not just the variable explicitly named on the left. A dummy vari­able appears in boldface. For example, if you designate x in the rule x = a 2– as a dummy variable, you can substitute a 2– or x for any variable in an expression. 

Select the term you want to be a dummy variable before you choose Desig­nate Dummy. Then use the Apply Rule command to replace a selected expression with the expression assigned to the dummy variable.

 

Apply Rule

 

Substitutes one term or set of terms for another in a selected expression, using the rule stored with the Enter Rule command.

 



	
Rule entered
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Selected expression
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After rule is applied
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Before you apply a rule that contains a dummy variable, select the term you want the variable to replace. In the following example, x is the dummy variable in the rule.



	
Rule entered
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Before rule is applied
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Other Rewrites pop-up menu

Simplify

 

Simplifies the selected expression. To evaluate fractions that involve infinity or division by zero, use the Number Crunch command instead of Simplify.

 

The operations performed depend on the type of expression selected, as shown in the following examples:

 

•               Performs integer arithmetic.

 



	
Selected expression

 


	
After simplifying
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When the result is too large to calculate, it appears as Infinity.

 

•               Groups terms in a sum or product.

 



	
Selected expression

 


	
After simplifying
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•               Divides out common factors in a fraction.

 



	
Selected expression

 


	
After simplifying
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Use the Remove Negative Powers command to remove negative powers from the result.

 

•               Interprets the complex number i, represented by the Greek letter iota
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.

 



	
Selected expression

 


	
After simplifying
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•               Distributes exponentiation across multiplication and division.

 



	
Selected expression

 


	
After simplifying
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Simplifying

[image: simp1.png]

 x produces
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 rather than
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.

 

Simplify Some

 

Simplifies the selected expression, as the Simplify command does, but does not multiply fractions.

 



	
Selected expression

 


	
After simplifying
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Isolate Term

 

Isolates a selected expression on one side of the equal sign. This command does not combine terms or solve for the selected expression.

 



	
Selected expression

 


	
After isolating term
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Expand First Term

 

Expands the first term of a selected summation or product.

 



	
Selected expression

 


	
After expanding
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Expand All Terms

 

Expands all terms of a selected summation or product.

 



	
Selected expression

 


	
After expanding
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4.7.10.            Create equations in structured documents using elements

You create an equation by inserting an equation element and then entering the mathematical expressions for the equation. To insert an element, you can use the Element Catalog. You can also use a New Equation command from the Equations pop-up menu in the Equations panel.

note:  The term “math element” refers to part of an expression, such as an oper­ator. It is not a structural element.

You can use any equation element for both inline and display equations. Some documents also have a paragraph element defined that provides formatting properties for the display equations.

The format rules for an equation element suggest a set of font sizes for the equa­tion: Small, Medium, or Large. You can change to a different set of font sizes. This change is not considered a format rule override. If you remove format rule overrides in the document, the equation does not return to its original font size.

Create an inline equation using an element

1)            

Click in text where you want to insert the equation. If the text is in a rotated text frame, unrotate the frame first by pressing Esc g 0 (zero).

 

2)           Select an equation element in the Element Catalog and click Insert.

 

The first math item that you enter replaces the question mark prompt of the new equation object.

 

New equation object

[image: gr_026.png]

 

3)           Enter the equation by typing numerals and other items or by clicking items on the Equations panel.

 

4)           Choose Shrink-Wrap Equation from the Equations pop-up menu in the panel.

Shrink-wrapped frame around an inline equation
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5)           If the equation seems too close to the text on either side, insert a space before or after the frame. FrameMaker treats a frame that contains an inline equation as a character and doesn’t provide extra space around it.

 

If an inline equation is too tall for its line, perhaps turn off fixed line spacing for that paragraph.

 

Create a display equation using an element

1)            

If your document has a paragraph element defined for formatting display equations, click where you want the equation paragraph. Select the para­graph element in the Element Catalog, and click Insert.

 

This element sometimes defines space above and below the equation, alignment in the text column, and an autonumbered caption.

 

2)           Click in an empty paragraph element where you want to insert the equa­tion.

 

3)           Select an equation element in the Element Catalog, and click Insert.

 

New equation object
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4)           Enter the equation.

 

5)           Choose Shrink-Wrap Equation from the Equations pop-up menu.

 

Shrink-wrapped frame around a display equation
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6)           If no equation element is available at the location that you want, perhaps you can use an invalid element. Do one of the following:

 

•               To use an element that is valid in another part of the document, insert the element in a valid location and then move it. You can also use the All Elements setting to make the element available every­where and then insert the element where you want it.

 

•               To insert an invalid equation element with the default tag EQUA­TION, choose a New Equation command from the Equations pop-up menu in the Equations panel. The element has a default tag if no defined equation elements are available.

 

After inserting the element, talk to your developer about making the element valid at this location.

 

Create an equation in an anchored frame element

1)            

Select an anchored frame or a graphic object in the frame.

 

2)           Choose a New Equation command from the Equations pop-up menu in the panel.

The first math item you enter replaces the question mark prompt of the new equation object. The equation does not appear in the document structure.

 

New equation object in a frame with graphic objects
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3)           Enter the equation.

 

Related links:

Equations panel overview

Change the scope of elements available in a structured document

Create equations

4.8.                   Working with multiple languages

 

4.8.1.                About Unicode

  Unicode is an industry standard that allows computers to represent text in most of the world's languages in a consistent way. It is implemented by different character encodings, such as UTF-8, UTF-16, and UTF-32. FrameMaker supports all three encodings but stores files in UTF-8. If you import files encoded in UTF-16 or UTF-32, FrameMaker automatically converts them to UTF-8.

In text processing, Unicode provides a unique number or code point for each character in a language. The Unicode standard does not specify the typeface or the visual rendering of each character. This is handled through Unicode fonts that may include visual renderings for thousands of Unicode characters thereby providing a single typeface across multilingual documents.

4.8.2.                Enable Unicode

The Unicode standard is a character coding system designed to support the worldwide interchange, processing, and display of text in any language or char­acter set. Unicode encoding allows you to create documents containing charac­ters from any number of character sets, and allows sharing of documents between different geographic or linguistic regions.

FrameMaker supports Unicode text encoding for creating, editing, saving, and publishing documents in multiple languages and for creating multilingual documents. Unicode text is supported in FrameMaker markers, catalog entries, and dialogs. PDF export supports Unicode text, bookmarks, tags, and comments. You can import or copy Unicode content from other applications.

Unicode assigns a unique number to every single character, no matter which language or type of computer you use.

Portable

 

Letters and numbers do not change when you move the file from one workstation to another. Adding a foreign language to a document doesn’t cause confusion, because foreign characters have their own designations that don’t interfere with the encoding from other languages in the same projects.

 

Robust

 

Because Unicode-compliant fonts offer a larger number of potential char­acters, specialty type characters are readily available.

 

Flexible

 

With Unicode support, substituting a typeface in a project does not result in substituted characters. With a Unicode-compliant font, a g is a g no matter which typeface is used.

 

All of these things make it possible for a French company to do work for a client in Korea and hand the job off to a partner in the United States without having to struggle with the text. The writer or designer must enable the correct language in the operating system, load the foreign-language font, and continue the project.

 

a)           To enable your computer to author content in languages other than English, start your computer in the UTF-8 locale.

 

b)           To enable the dictionaries or open the thesaurus, select the desired language from the Input Method Editor (IME) Language bar.

 

c)           Start typing the content in the selected language.

 

Certain features support Unicode, such as find and change, markers, hypertext, and catalog entries. You can export to PDF with Unicode book­marks, tags, comments, and so on. You can import or export Unicode content from other applications. Additional dictionaries help you author content in more languages.

 

Related links:

Working with multiple languages

4.8.3.                Adding multilingual text in documents

There are multiple ways to input characters in Unicode in a document. You could configure the regional language or locale settings on your computer to add the required languages for keyboard input. You could also configure and use a soft keyboard layout provided by third-party plug-ins.

Keyboard layouts cannot have simple key combinations for all characters and so FrameMaker provides two alternative input methods that allow access to the entire range of Unicode characters. One is the Hex palette which allows you to specify the code point in any of the three UTF encodings. The other is through a character map, which is a visual table listing all Unicode characters available in the selected font.

The Microsoft Windows XP Service Pack 2 (SP2) and Windows Vista®® oper­ating systems have regional and language settings. Use these settings to add additional languages for keyboard input. These languages and speech settings appear in the Language bar on the desktop. After you select a language and set up a localized keyboard, you can start typing the required text in the document. The keyboard layouts are defined by Microsoft.

You can type words in the selected language or input appropriate Unicode char­acters.

Set up input languages

1)           On your computer, open the Control Panel and double-click the Regional And Language Options icon. The Regional And Language Options dialog box appears.

 

2)           Click the Languages tab.

 

3)           Click the Details button. The Text Services And Input Languages dialog box appears.

 

4)           In the Settings tab, click the Add button. The Add Input Language dialog box appears.

 

5)           Select a language from the Input Language list.

6)           Click OK. The selected language is included in the Installed Services list.

 

7)           Select the desired language in the Default Input Language list.

 

8)           Click Apply and click OK to save the settings and close the Text Services And Input Languages dialog box.

9)           Click the Regional Options tab, and then choose the language you selected in the Default Input Language list.

 

10)       Click Apply and then click OK to save the settings and close the Regional And Language Options dialog box. The Language bar or the Input Method Editor (IME) appears in the system tray of your computer.

 

11)       Open FrameMaker, and then type the content. The text appears in the selected language.

 

note:  If you change the language in the Default Input Language list and the Regional Options tab, the language selected in the Language bar is also updated automatically.

Using third-party keyboard layout software

Several third-party keyboard layout software applications are available for different languages in Windows. When these layouts are activated, FrameMaker starts receiving input according to the keyboard mappings set by the third-party software. FrameMaker does not alter any of the key definitions.

Using the Character palette

The character palette lists all the Unicode characters in the three character sets.

 

Character palette
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A.

Select the font

B.

Scroll for the character in the selected font

1)            

Place the cursor where you want to insert the character in your document.

 

2)           Select File > Utilities > Character Palette.

 

3)           Select the font that supports the language you want to type in. The char­acter palette displays the characters available in the selected font.

 

4)           Click the box containing the character that you want to insert. Use the scroll bar to scan the character palette if needed.

Each character's code point in UTF-32, UTF-16, and UTF-8 is displayed at the bottom of the character palette.

 

5)           If the character inserted in your document does not match what you selected, ensure that the font in the document is the same as the font selected in the character palette.

 

6)           Click outside the character palette to dismiss it.

 

Using the Hex Input palette

The Hex Input palette allows you to add a Unicode character in your document by specifying its code point.

 

Hex Input palette
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A.

Typing area.

B.

View area.

C.

Click UTF-32 to change the default encoding.

D.

Click the arrows to browse the symbols.

1)            

Place the cursor where you want to insert the character in your document.

 

2)           Select File > Utilities > Hex Input to display the Hex Input palette.

 

3)           Type the Unicode number of the character you want to insert. The corre­sponding character is displayed on the right.

 

4)           To toggle between Unicode character sets, click UTF 32.

 

5)           If you cannot find the character you want to insert, either click the arrow keys to search sequentially or click the character to display the Character palette.

Also, ensure that you have selected the appropriate font from the Char­acter palette. The character for the same hex value changes depending on the font that you select.

6)           Click outside the Hex Input to dismiss it.

 




5.                        Tables

 

5.1.                   About tables

  

5.1.1.                Tables formats

Table formats contain settings for how the table looks. To create a table, the format and looks of the table needs to be defined, for example, border width, shading, heading, table and title.

The format of a table determines its appearance. The format includes the following types of properties:

•                

Properties set in the Table Designer, such as table position, cell margins, regular ruling and shading, and whether it has a title.

 

•               Three types of default properties: the number of body, heading, and footing rows; the number of columns; and paragraph formats for the title, heading, footing, and body cells of each column. All three are supplied when you first insert a table. Changing the default properties of a format does not change the appearance of tables using that format, but it changes how a new, empty table looks when you insert it.

 

A new table is always created starting from the formats, which exist in the docu­ment. Similar to paragraph and character formats, table formats are the starting point for new tables, as well as, building blocks for new table formats. After you insert a table, you can perform extensive custom formatting, such as straddling or rotating cells, or applying special ruling or shading to selected cells. Custom formatting is not stored as part of the table format. For this reason, custom formatting is retained when you change or reapply a table format.

tip:  Right-click a table to display a context menu for tables. Or use the QuickAc­cess bar to perform common tasks for tables.

When you insert a table, it’s anchored at the insertion point. A table anchor symbol
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 appears there when text symbols are visible.
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 A. 

Table title

 B. 

Table heading

 C. 

Table body

 D. 

Table footing

Related links:

Using toolbar shortcuts

5.1.2.                Working with tables in structured documents

Structured tables work in much the same way as unstructured tables. The table element definition determines the table’s structure. When you insert the table, at least some row and cell elements are inserted along with it, ready for you to provide the contents.

 

Elements for structured tables and table parts

 

A table and its parts (such as title, rows, and cells) are each represented in an element. You can see and work with these elements in the Structure view.

 

Table and table part elements
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When you insert a table element, some of the table parts are inserted automati­cally. You can use the Element Catalog as a guide for building the rest of the table. If you add more table parts, they can also have an initial structure; for example, a new row element contains cell elements. The content rules for table and table-part elements define an initial structure for that element.

 

A table can also have cells that are defined to remain empty. No valid elements can be inserted in these cells, and you cannot type in them. An empty cell element’s tag describes the use of the cell—look for names such as BlankHeader or SpacerCell.

 

How structured tables are formatted

 

The appearance of a structured table is determined by its table format, various settings in the Table menu, and paragraph formats for text.

 

Table formats

 

A table format controls the spacing, indentation, and alignment of a table in a column, the start position on a page, the location of the title, default margins for cells, the direction of autonumbering in cells, and default ruling and shading. A document stores table formats in a Table Catalog.

 

The format rules for a table element suggest a particular table format. You can apply a different format to the table at any time and the change is not considered a format rule override. (Changing the table format makes a table invalid, though, if the format adds a title and the table’s content rules don’t allow one.)

 

Table menu commands

 

The Table menu has commands for rotating and straddling cells, changing cell height and page breaks, adding rows and columns, and applying custom ruling and shading to cells. These settings take precedence over the table format for particular cells.

 

You can use any of the Table menu commands in a structured table. The commands are not format rule overrides and, except for Add Rows And Columns, do not affect the structure of the table.

 

Paragraph formats

 

Paragraph formats define fonts, line spacing, and other properties for text in the cells and the title. Table-part elements can specify paragraph formats.

DITA support for tables

 

DITA topics support two types of tables. The <table> element uses the OASIS Exchange Table Model (formerly known as the CALS table model). The OASIS table supports the spanning of multiple rows or columns for special layout or organizational needs, and provides a wide variety of controls over the display properties of the data and even the table structure itself.

 

The <table> element organizes arbitrarily complex relationships of tabular information. This standard table markup allows column or row spanning and table captions or descriptions. An optional title allowed inside the table element provides a caption to describe the table.

 

The DITA table is based on the OASIS Exchange Table Model, augmented with DITA attributes that enable it for specialization, conref, and other DITA processing. In addition, the table includes a desc element, which enables table description that is parallel with figure description.

In DITA tables, in place of the expanse attribute used by other DITA elements, the pgwide attribute is used to conform to the OASIS Exchange Table Model. This attribute has a similar semantic (1=page width; 0=resize to galley or column).

 

note:  The scale attribute represents a stylistic markup property that is main­tained (for now) in tables for legacy purposes. External style sheets should enable less dependency on this attribute. You should use the scale attribute judiciously in your topics. 

The other table structure in DITA is called <simpletable>. As the name implies, it is structurally less complex than the OASIS table, and can be used as a simple, regular table for which close control of formatting is not as important. The main advantage of simpletable is for describing lists of data with regular headings, such as telephone directory listings, display adapter configuration data, or API properties.

 

5.2.                   Insert, move, or remove a table

 

5.2.1.                Insert a table

When you insert a new, empty table, you select a format for the table. Table formats are stored in a catalog, as are paragraph and character formats. You can apply a different format to any paragraph in any cell, and you can modify the format of any paragraph.

1)            

Click in the line of text to which you want to anchor the table. You can insert a table anywhere except in a footnote.

2)           Choose Table > Insert Table.

 

3)           Select a format for the table. If the format you need is not in the list, you can import the format from another document.

 

4)           If necessary, enter a different number of rows or columns in the text boxes.

 

5)           Click Insert. An anchor symbol

[image: Anchor00001.png]

 appears at the insertion point when text symbols are visible. (Deleting the symbol deletes the table.)

 

note:  In multicolumn page layouts, the table can straddle columns, and its posi­tion is sometimes affected by straddle paragraphs.

5.2.2.                Insert a table element (structured documents)

A table is anchored to a specific location in text. As you edit the text, the table moves in the document along with the text. An anchor symbol

[image: Anchor00002.png]

 appears at the table’s anchor location in the document window.

When you insert a table, you specify where to anchor it. For example, you can anchor a table in a Para element (as a child element to the Para) or you can anchor it in a Section element (as a sibling to Para and other elements in the section). It depends on how the elements are defined for your document.

1)           Click where you want to insert the table.

2)           Select a table element in the Element Catalog, and click Insert.

 

note:  To add other table-part elements to the table, use the Element Catalog as a guide.

 

3)           To change the table format, select a format in the scroll list. The table element can have a format preselected, but you can change the format and it is not considered a format rule override.

 

Consult your developer before changing a table format. Your element catalog can have a separate element defined for each format you’ll need.

 

4)           If necessary, change the number of rows and columns. Changing these numbers sometimes makes the table invalid.

 

5)           Click Insert. FrameMaker inserts an anchor symbol
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 at the insertion point and a table with predefined descendant elements. The Structure view has bubbles for the new elements.

 

6)           If the Attributes for New Element dialog box appears, enter attribute values for the table element and click Insert Element.

tip:  Select cells in the table and then right-click to display a context menu for working with the cells. You can also use the QuickAccess bar as a quick way to apply table commands.

 

If no table element is available at the location you want, you can use an invalid element. After inserting the table, talk to your developer about making it valid at this location.

5.2.3.                Use an invalid table element

 

•                

To use a table that is valid in another part of the document, either insert the table in a valid location and then move it, or use the All Elements setting to make the table available everywhere and then insert the table where you want it.

 

•               To insert an invalid table with default tags, choose Table > Insert Table and choose TABLE from the Element Tag pop-up menu. (This option appears in the menu if the document has no defined table elements.) The table and table parts have default tags, such as TABLE, HEADING, and ROW. After replacing the table with a valid table, change the table parts to valid elements.

 

tip:  Changing an invalid table with default tags to a valid table can be a laborious process. It’s best to work with tables that are defined.

Related links:

Change the scope of elements available in a structured document

5.2.4.                Nest a table in a table cell

1)            

Click in the cell in which you want to nest a table.

 

2)           Do one of the following:

 

•               Choose Special > Anchored Frame.

 

–              For unstructured documents, this command creates an anchored frame that’s anchored below the current line. Try to set the width and height of the frame to be slightly larger than the width and height of the table you want to insert.

 

–              For structured documents, this command inserts an element. Choose a frame element from the Element Tag pop-up menu in the Anchored Frame panel.

 

•               (Structured documents) Select a graphic element for empty anchored frames in the Element Catalog, and click New Frame.

 

3)           If the anchored frame is wider than the cell, resize the column.

 

4)           Use the Text Frame tool on the Tools panel to draw a text frame in the anchored frame.

 

5)           Click in the text frame and choose Table > Insert Table.

 

important:  If you export a document to SGML or XML, you can lose the contents of anchored frames in it because they are not part of the main structured flow. Work with your application developer if you plan to export to SGML or XML to avoid losing data in the nested table.

Related links:

Anchored frames

Resize columns and rows

5.2.5.                Copy, move, or remove a table

If you copy or move an unstructured table to a structured flow, the table is given a basic structure with default elements named TABLE, HEADING, ROW, and so on. If you copy or move a structured table to an unstructured flow, the table structure may no longer be valid.

1)            

Control-triple-click a cell to select the entire table or click the table bubble in the Structure view.

 

2)           Do one of the following:

 

•               To copy the table, choose Edit > Copy.

 

•               To move the table, choose Edit > Cut. If a dialog box appears, click Remove Cells From Table, and click Cut. Then click where you want to move the table, and choose Edit > Paste. See the Element Catalog before pasting to ensure that you paste the table at a valid location.

 

•               To remove the table (without changing the contents of the clip­board), press Delete.

 

tip:  You can also drag a table bubble in the Structure view to move the table, or Alt-drag the bubble to copy the table.

 

5.3.                   Text and graphics in tables

You format text in a table cell just as you format paragraphs in a regular column of text—for example, with paragraph or character formats.

Each table cell can contain text and anchored frames. (Anchored frames, in turn, can contain graphics or other tables.) As you type text or insert an anchored frame in a cell, the cell height expands as needed.

In addition to typing text in a table, you can also insert cross-references, table footnotes, variables, and markers. The tab character is the only character you have to enter in a special way in a table cell.

You can copy, cut, and paste the contents of cells just as you do text and graphics in any other part of a document. Special system variables let you specify contin­uation text in the titles or heading rows of multipage tables.

For structured documents, you can type text in the current cell when the <TEXT> indicator appears in the Element Catalog. You can also insert foot­notes, cross-references, and other text-related elements in the cell. Use the Element Catalog as a guide.

5.3.1.                Select text or cells in tables

 

Related links:

Navigating through tables

Place the insertion point in a table cell

1)            

Click in the cell, or click to the left of the cell’s text snippet in the Structure view.

Select the contents of a cell

1)            

Click in the cell and press Esc t h a, or double-click the cell’s bubble in the Structure view. You can also triple-click a cell’s contents if it contains just one paragraph.

 

Select a single cell

•                

Control-click the cell.

 

•               (Structured documents) Drag across the cell’s boundary and back, or click the cell’s bubble in the Structure view.

 

Select multiple cells

 

•                

Drag across all the cells, and then Shift-double-click or Shift-click (struc­tured documents) the last cell in the selection.

•               To select an entire row, press Esc t h r, or drag across the cells in the row, or click the row’s bubble in the Structure view.

 

tip:  If you click between table-part elements (such as between two rows) in the Structure view, the insertion point appears in the Structure view but not in the document window. A contiguous selection of cells in the document window doesn’t always appear as contiguous bubbles in the Structure view.

 

•               To select an entire column, press Esc t h c, or drag from a heading cell into the first body cell.

•               To select the entire table, press Esc t h t.

 

5.3.2.                Add or remove a table title

A table title appears above or below a table and is repeated on all pages of a multipage table. Whether a table has a title and how it’s formatted is defined in the table format.

When you insert a table with a title, an empty text frame appears for the title. If the title format has been defined to include an autonumber, the autonumber text appears.

Title centered below (left), autonumbered title left-aligned above (right)
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For structured documents, a table’s element definition sometimes specifies whether the table must have a title. You can add a title to any table, but check in the Structure view to be sure that the title is not invalid in the table. The title element is always the first child element of a structured table, regardless of whether the title appears above or below the table.

1)            

Click in the table and choose Table > Format > Table Designer.

 

2)           In the Format properties of the Table Designer, choose an option from the Title pop-up menu.

 

3)           Specify the gap between the table and the title in the Gap box.

 

4)           Click Apply. If the title has been defined to be autonumbered, the number (such as Table 1) appears in the title cell. You enter the text of the title yourself.

 

tip:  To display the title only on the first page of a multipage table, set the title position to No Title and use a body paragraph as the title. To prevent the title from becoming separated from the table, make sure that the anchor symbol is in the title text and that the table’s Start property is set to Anywhere.

Related links:

Edit a variable definition

5.3.3.                Add “continuation” text

In a multipage table, you can include special “continuation” text in the title or in heading or footing rows. Your document can have variable elements defined for this purpose, such as one that displays (continued) and another that tells the number of sheets in the table.
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 A. and C. 

Table Sheet variable

 B. 

Table Continuation variable

1)            

On the first page of the table, click in the title or in the heading or footing where you want to insert the variable or variable element.

 

2)           Do one of the following:

 

•               Double-click either the Table Continuation variable or the Table Sheet variable from the Variables pod.

 

•               (Structured documents) Select a variable element for continuation text in the Element Catalog, and click Insert.

On the first page of the table, the variable appears as a nonbreaking space
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. On subsequent pages, the variable displays its text—for example, (continued).

5.3.4.                Place graphics in table cells

 

Place a graphic

You can adapt these instructions to position the anchored frame differently or to insert a graphic in a cell that also contains text.

note:  Avoid using cropped anchored frames in heading or footing cells of a table. Such frames are not always cropped when that cell repeats on subsequent pages.

1)            

Click in a paragraph in the cell where you want to place the graphic.

 

2)           Do one of the following:

 

•               To create an anchored frame where you can draw, use Special > Anchored Frame to create an anchored frame that’s anchored at the insertion point.

 

•               To create an anchored frame for an imported graphic, use File > Import > File to import the graphic.

 

3)           If the anchored frame is wider than the cell, resize the column.

 

tip:  To resize a column to match its contents, place the insertion point in the cell that has the desired length of text and press Esc t w.

 

4)           If necessary, choose Graphics > Align to center the graphic in the frame.

Place a graphic in a structured document

If your table cells allow graphic elements, you can draw or import graphics in the cells. A new graphic element can be either an empty anchored frame that you can draw in or an anchored frame with an imported graphic.

1)            

Click where you want to place the graphic in the cell.

 

2)           Select a graphic element in the Element Catalog and click Insert. The element’s definition determines which dialog box appears.

3)           Do one of the following:

 

•               If the Anchored Frame dialog box appears, choose At Insertion Point from the Anchoring Position pop-up menu, and click New Frame.

 

•               If the Import File dialog box appears, select the file to import, and click Import.

 

An anchored frame appears in the cell, and a bubble with the text snippet GRAPHIC appears in the Structure view.

 

4)           If the anchored frame is wider than the cell, resize the column.

 

tip:  To resize a column to match its contents, select the column and press Esc t w.

5)           If necessary, choose Graphics > Align to center the graphic in the frame.

 

Related links:

Anchored frames

Resize columns and rows

5.3.5.                Convert between text and tables

You can convert text that’s already in your document to a table, or you can convert text in a text file as you open or import the file. In a structured docu­ment, the text is wrapped into a structure of table and table-part elements.

After converting text to a table, you can edit the table, removing blank cells or recombining text that was split into two or more cells. In most cases, you can edit the table directly in the document. However, if you converted text that was imported by reference, you must edit the text in the original file.

You can convert any table to text within FrameMaker, or you can copy the table as text to another application. You can also convert all the tables in a document at one time.

In structured documents, when you convert tables to text, all the table and table-part elements, except for the cells, are unwrapped. Change the cells to other elements or make other changes to correct the structure of the document.

Convert text to a table

1)            

Select the text you want to convert.

2)           Choose Table > Convert To Table.

 

3)           If you’re working in a structured document, choose a table element from the Element Tag pop-up menu.

 

4)           Select a format for the table.

 

note:  In a structured document, the table element may have a format preselected, but you can change the format and it is not considered a format rule override.

 

5)           Specify how you want to convert paragraphs by doing one of the following:

 

•               To convert text that uses tabs to separate information, click Tabs.

 

•               To convert text that uses spaces to separate information, click Spaces and then enter the minimum number of spaces that indicate a sepa­rate cell.

 

•               To convert text that uses other characters to separate information, click Other and then type the characters that can be used to separate cells.

 

•               To convert each paragraph (such as those in a bulleted list) to a cell, click A Cell and then enter the number of columns you want in the table.

 

6)           In the Heading Rows box, enter the number of heading rows you want in the new table. If the paragraphs you’re converting don’t include headings and you want to fill in the headings later, select Leave Heading Rows Empty.

7)           Click Convert.

 

note:  When working with structured documents, the Structure view has bubbles for the new elements. If the Attributes for New Element dialog box appears, enter attribute values for the table element and click Insert Element.

Convert a text file to a table as you open the file

1)            

Choose File > Open, and select the text file you want to open.

 

2)           If the Unknown File Type dialog box appears, select Text, and then click Convert.

 

3)           Click Convert To Table, and then click Read.

 

4)           Follow the instructions for converting text to a table, starting from step 3.

 

Convert a text file to a table as you import the file

1)            

Click where you want to import the file.

 

2)           Choose File > Import > File, and select the text file you want to import and the import method.

 

3)           Click Convert To Table and then click Import.

 

4)           Follow the instructions for converting text to a table, starting from step 3.

 

tip:  If you want to merge a text file into an existing table, import the text file and convert it to a table. Then copy the rows and paste them into the existing table.

Touch up a table after conversion

•                

To combine text that is split across two or more rows, cut and paste the text from the lower cells into the upper cell, and delete the extra rows.

tip:  To quickly combine text in adjacent cells, select the cells, choose Table > Straddle, and then choose Table > Unstraddle. Then you can delete empty rows or columns.

•               To fix half-empty columns, cut and paste the text into the correct loca­tions, and delete the extra columns.

 

•               To fix major errors, you can return to the original text (choose Edit > Undo if necessary), edit the text (for example, by deleting extra tabs and forced returns), and then convert the text to a table again.

 

Convert a table to text within FrameMaker

1)            

Click in the table you want to convert to text.

 

2)           Choose Table > Convert To Paragraphs.

 

3)           Click Row By Row or Column By Column, and click Convert.

 

Table converted to text
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 A. 

Row by row

 B. 

Column by column

Copy a table to another application as text

1)            

Copy the table to the clipboard.

 

2)           In another application, choose Edit > Paste. The table is pasted, row by row, with tabs separating table cells, and a paragraph return at the end of each row.

 

Convert all tables in a document to text

1)            

Save the document in Text Only format, and specify how you want the tables converted.

 

Related links:

Nest a table in a table cell

Import unformatted text

5.3.6.                Run text around a table

Text does not run around a table that’s anchored directly in a column of text. You can, however, run text around a table in an anchored frame or in a text frame that’s disconnected from the main flow. (For structured documents, check to see if your developer has set up this application this way.)

A table in an anchored frame moves with the text it’s anchored to. A table in a disconnected text frame remains in place on a page while other text flows around it. The table does not autonumber with tables in the main flow.

important:  The contents of an anchored frame or a disconnected text frame are not part of a document’s main structured flow, so they are not normally exported to SGML. If you plan to export to SGML, work with your application developer to avoid losing data in the table.

Table in an anchored frame and a table in a disconnected text frame
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Run text around a table in an anchored frame

1)            

Use Special > Anchored Frame to create an anchored frame with an anchoring position of Run into Paragraph.

 

2)           Draw a text frame in the anchored frame and then place the table in it.

 

Run text around a table in an anchored frame (structured documents)

1)            

Click in text where you want to anchor the table.

 

2)           Select a graphic element for an empty anchored frame in the Element Catalog, and click Insert.

 

You can also use Special > Anchored Frame to insert an element. Choose a frame element from the Element Tag pop-up menu in the Anchored Frame panel.

 

3)           Choose Run Into Paragraph from the Anchoring Position pop-up menu, set the width and height of the frame, and click New Frame. Try to set the size of the frame to be slightly larger than the size of the table.

 

4)           Draw a text frame in the anchored frame. Select View > Toolbars > Graphics Toolbar and click the Place A Text Frame
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 tool. Drag to draw the frame, and click Set in the dialog box that appears.

 

5)           Click in the text frame and use Table > Insert Table to insert an unstruc­tured table.

 

Run text around a table that remains stationary on the page

1)            

Draw a text frame directly on a page and drag it where you want it. This type of text frame is not connected to the main flow.

2)           Choose Graphics > Runaround Properties, click Run Around Bounding Box, and click Set.

 

3)           Do one of the following:

 

•               For unstructured documents, insert a table in the text frame.

 

•               For structured documents, click in the text frame and choose Table > Insert Table.

 

5.3.7.                Position and autonumber text within cells

When you insert a table, its cell margins—the distance between the cell edge and the cell text frame—are determined by the table format. The indent properties of text in the cell, which are measured from the cell margins, are part of the text’s paragraph format.
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 A. 

Left cell margins

 B. 

Paragraph’s left indent

Set default cell margins

1)            

Click in the table you want to change and choose Table > Format > Table Designer.

 

2)           In the Basic properties of the Table Designer, enter the values for the top, bottom, left, and right margins in the Default Cell Margins area.

 

3)           Click Apply To Selection.

 

tip:  If you want text to look vertically centered, make the top margin larger than the bottom margin. For example, make the top margin 5 points and the bottom margin 3 points.

Customize cell margins or text alignment

 

When you change cell margins or text alignment and later apply a different format to the table, the changes are not overwritten by the new table format’s default settings.

Because cell margins and text alignment are part of a paragraph format, they aren’t normally stored as part of the Table Catalog format. However, the para­graph formats of the first title paragraph and the first paragraph in the heading, body, and footing rows of each column are stored. You can customize the align­ment of any of these paragraphs and then store the table format in the catalog. Future tables using that table format will have the custom settings as their defaults.

 

Customize cell margins

 

1)           Click in the first paragraph of the cell whose margins you want to customize.

 

2)           Choose Format > Paragraphs > Designer to display the Paragraph Designer.

 

3)           Choose Table Cell from the Properties pop-up menu.

4)           In the Cell Margin area, specify the margins you want to customize by doing one of the following:

 

•               To create a margin relative to the default cell margin, choose From Table Format, Plus from the pop-up menu and then enter a value.

 

•               To create a fixed margin measured from the edge of the cell, choose Custom from the pop-up menu and then enter a value.

 

5)           Click Apply To Selection.

 

Customize the vertical alignment of text in a cell

 

1)           Click in the cell you want to customize.

 

2)           Choose Format > Paragraphs > Designer to display the Paragraph Designer.

 

3)           Choose Table Cell from the Properties pop-up menu and then choose Top, Middle, or Bottom from the Cell Vertical Alignment pop-up menu.

 

4)           Click Apply To Selection.

 

note:  The vertical alignment that you apply to a cell will persist even when you apply a different table format from the Table Designer.

Specify the direction of autonumbering in a table

 When you insert a table, the table format determines the direction of autonum­bering within cells—either across rows or down columns. This property also sets the direction of autonumbering for table footnotes.

1)           Click in the table you want to change, and choose Table > Format > Table Designer.

 

2)           In the Basic properties of the Table Designer, choose Row First or Column First from the Numbering pop-up menu.

 

3)           Click Apply To Selection.

 

5.4.                   Formatting tables

 

5.4.1.                Table Designer

You can use the Table Designer and Table menu commands to change the look of tables and create new table formats, and to change formats globally throughout a document.

 Using the Table Designer, you can change the table’s indents, cell margins, spacing, alignment, ruling, and shading. You can also adjust the title position, numbering, and the start position of the table. The space above and below a table, and the table’s alignment and indentation, are determined by the table format. You can control other positioning properties—straddling and text runaround—on a table-by-table basis.

The Table Designer includes several commands for creating, changing, and overriding table formats. The designer contains several groups of properties, displaying one at a time. It’s shown here displaying the Basic group of table properties.

Table Designer
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 A. 

Click to change Format properties.

 B. 

Click to change Ruling properties.

 C. 

Click to change Shading properties.

D.

Choose from the Table Tag pop-up menu to display the stored properties for a selected format.

 E. 

Update all table formats that have the same tag, including the format stored in the Table Catalog.

 F. 

Apply all properties in all property groups to the current table’s format.

From the Table Tag field of the Table Designer, you choose a table format and then a property group. From the lower half of the Table Designer, you change the table’s properties. After making changes, click Apply to change the table’s appearance. Click Apply All, to change the definition of the format and globally change appearances of all tables using this format.

When you use the Table Designer to make a formatting change that doesn’t match the table’s predefined format, the change is a format override. Overrides are lost if you reapply the predefined format to the table. Changes made with the Table menu commands are not lost.

To remove all format overrides from a table, put the cursor in the table and click the desired table format from table catalog.

Related links:

Manage formats

Format catalog

Table position and spacing

Display the Table Designer and a property group

 

1)            

Choose Table > Table Designer.

 

2)           Choose a group of properties from the Properties pop-up menu or click a tab.

 

Apply property changes

 

1)            

Click Apply To Selection. When you make a formatting change that doesn’t match the table’s predefined format, it’s considered a format over­ride.

 

note:  You don’t need to click Update All unless you want to make a global change—change the table format and all tables in the document with the same format. Because Update All redefines a format, use it with caution.

 

Reset properties after changing them in the Table Designer

 

•                

To reset the properties to match the current table, including any format overrides, click in the table or choose Reset Window from Selection from the Commands pop-up menu.

 

•               To reset the properties to match the stored table format, choose the format from the Table Tag pop-up menu. Do this even if its tag is already displayed in the Table Tag box.

 

5.4.2.                Table catalog

Table catalog works just like the paragraph or character catalogs. Commands to format tables, the Table Designer, and the table Catalog can be accessed from Table > Format.

 

Apply or change table format

 

•               Do one of the following

•                

Place the cursor inside the table.

 

•               Select one of more cells of the table.

 

•               If the table catalog is not open, then click Table > Format > Catalog.

 

•               Click the desired format in the catalog.

 

5.4.3.                Create, edit, and delete table formats

 

You can rename or delete a table format when designing a template. You can also rename a table format if you want to copy an entire catalog from a template and don’t want a format to be overwritten.

Deleting a format from a catalog does not affect any tables that have the same tag—the tables simply have a format that isn’t stored in the catalog. If you want to change the format of these tables, you can then retag them.

Related links:

Rows and columns

Table position and spacing

Add or remove a table title

Ruling and shading

About tables

Working with tables in structured documents

Create a table format

1)            

Click in a table that has a format like the one you want to create. (The more similar it is to the format you’re defining, the fewer changes you’ll have to make.)

 

2)           Set up the rows and columns by adding or deleting body, heading, and footing rows and adjusting columns as necessary.

 

3)           Use the Table Designer to modify any of the table’s properties.

 

Don’t set any property to As Is. Table formats must have all properties specified. (An alert message warns you if not all settings are specified so you can go back and change any As Is properties.)

 

4)           Use the Paragraph Designer to create or change any of the following para­graph formats, which are stored as part of a table format: the paragraph formats of the first title paragraph, and the first paragraph in the heading, body, and footing rows of each column.

5)           When the table looks the way you want, choose New Format from the Commands pop-up menu in the Table Designer.

 

6)           Enter a name for the new format in the Tag box.

 

7)           To store the format in the Table Catalog, select Store In Catalog.

 

8)           To apply the new format to the current table, select Apply To Selection.

 

9)           Click Create.

 

Rename a table format

1)            

Click in a table whose format you want to rename.

 

2)           In the Table Designer, choose the tag you want to change from the Table Tag pop-up menu.

 

Make sure that you perform this step even though it means choosing the same tag as the one currently displayed. Choosing a tag from the pop-up menu ensures that the stored format properties—not overrides—are displayed.

 

3)           Type a new name in the Table Tag box, and click Update All.

 

4)           Click OK.

 

Delete a table format

1)            

In the Table Designer, choose Delete Format from the Commands pop-up menu.

 

2)           Select the format in the scroll list and click Delete. You can delete addi­tional formats if you want to.

 

3)           Click Done.

 

Apply a different format to a table

When you apply a different table format, only the properties associated with table formats change in the table. That is, any customizations you’ve made to the table—the column widths, the number of rows and columns, and the settings from the Table menu—are not affected.

The format rules for a table element suggest a particular table format, but you can apply a different format, either when you insert the table or later, and the change is not considered a format rule override. If you remove format rule over­rides in the document, the table will not return to its original format. If a struc­tured document does not have a format that meets your needs, see your developer about redefining a format or creating a new one. 

important:  If a new table format adds a title to the table and the table’s content rules do not allow a title, the title is invalid.

Table with old (left) and new (right) formats; custom rotated cells retained
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1)            

Click in the table.

 

2)           Choose Table > Format > Table Designer.

 

3)           Choose the format from the Table Tag pop-up menu, and click Apply To Selection.

 

Apply a format to several tables

 

You can apply a format to all tables in the document, to all tables with tags (format names) that occur in a selection, or to all tables that have a particular tag. For example, you could apply Format B to all tables currently tagged Format A.

 

1)           Select the tables by doing one of the following:

 

•               To apply a format to all tables in the document, click in any table.

 

•               To apply a format to several tables, but not all tables, in the docu­ment, select consecutive tables or table elements. (To select multiple tables, you must select their anchor symbols.)

2)           Choose Table > Format > Table Designer.

 

3)           Choose the format you want to apply from the Table Tag pop-up menu, and choose Global Update Options from the Commands pop-up menu.

 

4)           Choose the tables you want to reformat by doing one of the following:

 

•               To retag all tables in the document, click All Tables And Catalog Entries.

 

•               To retag the tables in the selection and all tables with the same tags as these tables, click All Matching Tags In Selection.

 

•               To retag all tables with a specific tag, choose a tag from the pop-up menu.

 

5)           Click All Properties in the Use Properties area, and click Update.

 

Redefine table formats

 

To change a table format, you change a table’s properties and then change the corresponding catalog format to match the table.

The properties applied to the catalog format include those set in the Table Designer and the defaults not set in the Table Designer—for example, the default paragraph formats. In addition, properties set in the Table Designer (but not default properties that aren’t changed in the Table Designer) are applied to existing tables in the document that have the same tag.

tip:  If you change properties in the Table Designer and then decide you don’t want to update the format, you can cancel the operation and reset the properties by simply clicking in text. You can also choose Reset Window from Selection from the Commands pop-up menu in the Table Designer.

 

Redefine a table format

 

1)           Click in a table whose format you want to redefine, and choose Table > Format > Table Designer. If the table you click in has format overrides, these overrides—not the catalog format’s definition—appear in the Table Designer.

 

2)           If you want to base the changed format on the catalog format, without any overrides, choose the format tag from the Table Tag pop-up menu, even if the tag you want is already displayed in the Table Tag box.

3)           Do the following:

 

•               Use the Table Designer to change any of the settings for the Basic, Ruling, or Shading properties.

 

•               Change any of the default properties, such as the number of rows and columns, widths of columns, and the paragraph format of the title and of the first paragraph of each column. These properties are supplied when you first insert a new, empty table.

 

4)           Click Update All. If any of the tables being updated contain format over­rides, an alert message asks whether you want to remove them.

 

Change properties in several table formats

You can change specified properties of several table formats at the same time. For example, you can change all table formats from centered to left-aligned.

1)            

Select the tables whose formats you want to redefine by doing one of the following:

 

•               To redefine one table format or all table formats in the document, click in any table.

 

•               To redefine several table formats, but not all formats in the docu­ment, select consecutive tables whose formats you want to redefine. (To select multiple tables, select their anchor symbols.)

2)           In the Table Designer, display the group of properties from which you want to apply one or two properties.

 

3)           (Structured documents) Delete the tag from the Table Tag box if the box isn’t empty. Deleting the tag sets the box to As Is, which keeps FrameMaker from changing the tags of the formats that you update.

 

4)           Change the properties as needed.

 

5)           Choose Global Update Options from the Commands pop-up menu.

 

6)           Choose the table formats you want to apply the properties to.

 

7)           Click the current property group in the Use Properties area and click Update. If any of the tables being updated contain format overrides, an alert message asks whether you want to remove them.

 

FrameMaker applies the properties to the Table Catalog formats you specified and to all tables in the document with the same tags.

 

5.4.4.                Ruling and shading

When you insert a table, its regular ruling and shading are determined by the table format. You can use the Table Designer to change a format’s ruling or shading properties for particular tables that use the format.

Custom ruling and shading aren’t limited to entire rows or columns and aren’t part of the table format. If you customize the ruling or shading of a table and later apply a different format to the table, the custom ruling or shading is not overwritten by the new format.

Set up regular ruling or shading

1)            

Click in the table you want to change and choose Table > Format > Table Designer.

 

2)           Do one or more of the following:

 

•               In the Ruling properties of the Table Designer, specify the ruling for columns, body rows, heading and footing rows, and outside edges.

 

•               In the Shading properties of the Table Designer, specify the shading for heading and footing rows and for body rows or columns.

 

3)           Click Apply To Selection.

 

Create, change, or delete ruling styles

You can create additional ruling styles (such as Double, Thick, or Thin line styles), and edit or delete existing ones. If you edit a ruling style, the change applies to both the regular and custom ruling that use that style.

tip:  When editing ruling styles, zooming in to a high percentage lets you see slight differences in line thickness.

 

Create or change a ruling style

 

1)           Choose Table > Format > Custom Ruling & Shading.

 

2)           Select a style in the scroll list that you want to edit or, if you’re creating a style, select one like the style you want to create.

 

3)           Click Edit Ruling Style.

 

4)           Enter the width, and choose a color and pen pattern for the style.

 

5)           Click Single or Double to specify single or double lines. If you click Double, specify a value for the gap separating the lines.

 

6)           If you’re creating a style, type a name in the Name box, and click Set.

 

Delete a ruling style

 

1)           Choose Table > Format > Custom Ruling & Shading.

 

2)           Select the style you want to delete.

 

3)           Click Edit Ruling Style and click Delete. If the style was used for a table’s regular ruling, the occurrences of the style use no ruling. If the style was used for custom ruling, the table’s regular ruling is restored.

 

Create or remove custom ruling or shading

A table’s custom shading is not stored as part of the format. Wherever the regular and custom settings are in conflict, the custom settings prevail.

1)            

Select the cells, rows, or columns that you want to customize.

 

2)           Choose Table > Format > Custom Ruling & Shading.

 

3)           Do one of the following:

 

•               Specify a fill percentage and color for the shading.

•               Select a custom ruling style. The scroll list shows the document’s predefined ruling styles.

 

•               Choose From Table to remove custom shading.

 

4)           To prevent inadvertent changes, turn off Custom Cell Ruling or Custom Cell Shading and click Apply.

 

Display a cell’s ruling and shading settings

 

1)           Select the cells, rows, or columns that have the ruling and shading proper­ties you want to see.

 

2)           Choose Table > Custom Ruling & Shading, and click Show Current Settings.

 

In the dialog box, Mixed means that the selected cells use more than one custom ruling style, fill, or color. From Table means that the selected cells use the regular ruling or shading set in the Table Designer.

5.4.5.                Rows and columns

You can easily add, delete, copy, move, or resize rows and columns, either by using the clipboard or by dragging. Sort rows and columns by numbers or letters. You can sort by date or time, as long as the information is entered in the table as text.

Add or delete a row or column

 

note:  For structured documents, adding rows or columns can make the structure of the table invalid. For example, a table set up to contain only three columns will be invalid if you add a fourth. It’s best to use the Element Catalog for adding heading or footing rows, because tables are often defined to have a specific number of these rows.

 

Add a row below the current one

 

1)           Press Control+Enter. The new row has the same properties as the previous row.

 

Add a row using the Element Catalog (structured documents)

 

1)           Click where you want to add the row in the Structure view, select a row element in the Element Catalog, and click Insert.

 

Add a row or column

 

1)           Click in a table cell next to where you want to add the row or column.

 

2)           Choose Table > Add Rows Or Columns, and specify the number of rows or columns you want to add and where you want to insert them.

 

3)           Click Add.

 

The new rows or columns have the same properties as the current row or column.

 

Delete a row or column

 

1)           Select the rows or columns you want to delete, making sure that you select entire rows or columns. (If you don’t, the contents of the selected cells are deleted without a prompt for a decision.)

 

2)           Press Delete, click Remove Cells From Table, and click Clear.

 

 

Copy or move rows or columns

The cells on the clipboard replace the current rows or columns according to the following rules:

•                

If the number of rows or columns on the clipboard is equal to the number of selected rows or columns, they are replaced exactly.

 

•               If the number on the clipboard is greater than the number you select to replace, only the number of rows or columns that fit are pasted.

 

•               If the number on the clipboard is less than the number you select to replace, the clipboard contents are repeated so that they fill the rows or columns.

 

tip:  To split a table, cut rows or columns from a table and paste them where you want to make a new table. To combine two tables, cut the rows and columns from one table and paste them into another.

 

Coping or moving rows or columns

 

1)           Select the rows or columns, and do one of the following:

 

•               If you are copying them, choose Edit > Copy.

 

•               If you are moving them, choose Edit > Cut, click Remove Cells from Table, and then click Cut.

 

2)           Click next to where you want to insert the rows or columns, and choose Edit > Paste. You can insert them next to the current row or column, or you can replace the current row or column.

 

tip:  You can also drag a row’s bubble in the Structure view to move the row, or Alt-drag the bubble to copy the row.

 

 

Resize columns and rows

 

Resize a column by dragging

 

•               To change a column width, select a cell in that column and drag its handle until the column is the size you want. Select several columns to resize them together.

 

•               To move the border between two columns so one column grows wider and the other narrower, Alt-drag a selection handle. The overall width of the table doesn’t change.

 

tip:  To align the column border with the snap grid, choose Graphics > Snap before you change the width.

Specify a precise column width

 

 

1)           Select cells in the columns you want to resize (if you’re resizing a single column, just click in it), and choose Table > Resize Columns.

2)           Do one of the following:

 

•               To specify a value for the width, click To Width and enter the value.

 

•               To set the width to a percentage of the original width, click By Scaling and enter a percentage.

 

•               To make the column the same width as another column in the table, click To Width of Column Number and enter the column number.

 

•               To make the widths equal parts of a total, click To Equal Widths Totalling and enter the total width.

 

•               To specify a total width while still keeping the columns’ proportions the same, click By Scaling to Widths Totalling and enter the total width.

 

•               To set the width to match the widest paragraph or frame in the selected cells, click To Width Of Selected Cells’ Contents and enter a maximum width.

 

3)           Click Resize.

 

Copy and paste a column width

 

1)           Click in the column whose width you want to copy.

 

2)           Choose Edit > Copy Special > Table Column Width.

 

3)           Click in the column you want to change and choose Edit > Paste. Only the column width is pasted; the contents of the cells remain unchanged.

 

Adjust the height of a row

 

The height of a row changes automatically to fit the cell’s contents, but you can increase the height further if you want.

note:  When working with a structured document, adjusting the height of a row does not affect the structure of the table, and it is not a format rule override.

 

1)           Click in the row that has the height you want to increase, and choose Table > Row Format.

 

2)           Enter values for the minimum and maximum row height and then click Set.

 

Make all rows the same height

 

1)           Determine the height of the tallest row in a table: Hold down Alt+Shift while drawing a selection border around the row.

2)           Note the height, which appears in the status bar.

 

3)           Select the entire table, and choose Table > Row Format.

 

4)           Specify this value for the minimum row height and click Set.

Sort columns and rows

When sorting by numbers, currency symbols are ignored, but negative signs are recognized. For example, -9 or (9) sorts before 9 in an ascending sort. The comma and decimal separators displayed in numbers are treated according to the Regional options set for numbers and currencies on your system.

Text always comes after numbers in a sort. Text strings in tables are sorted based on the default system locale.

tip:  You can sort by date or time as long as you enter it as text, use a consistent format, and include leading zeros. For example, if you’re using dd/mm/yy and hh:mm:ss formats, enter 04/12/2017 or 09:30:25 . 

1)           Save your document, so that you can revert to your last saved version if the sort gives unexpected results.

 

2)           Make sure the table contains no hidden conditional rows in the table (use Special > Conditional Text).

 

3)           Do one of the following:

 

•               To sort all columns or all rows in a table, click anywhere in the table.

•               To sort only certain rows, select cells in the rows you want to sort.

4)           Choose Table > Sort.

 

5)           If you’re sorting all rows or all columns, click Select All Body Rows.

 

6)           Do any of the following:

 

•               To sort the rows of the table, click Row Sort. If the rows contain heading or footing cells as well as body cells, only the body cells are sorted.

 

•               To sort the columns of the table, click Column Sort.

 

•               To sort uppercase letters apart from lowercase letters, select Consider Case.

 

7)           Choose a primary sort key by selecting from the Sort By box and clicking Ascending Sort or Descending Sort.

 

You can sort straddle cells as long as they don’t extend past a row or column that you’re using as a sort key. (Use Table > Unstraddle and try again.)

 

8)           Optionally, choose a second and third sort key from the Then By areas.

 

9)           Click Sort.

 

note:  Adobe FrameMaker correctly sorts numbers preceded by the special symbols ()+-,. and $. However, combining several of these symbols in a cell some­times adversely affects sorting. For example, a table cell containing -2 will fall correctly between -1 and -3, but a cell containing -2+3 will not (Frame interprets the sequence as -23).

note:  The Table sorting feature supports the Unicode text encoding standard.

5.5.                   Table position and spacing

 

5.5.1.                Specify table position and spacing

 

Normally, a table appears below the line of text containing the anchor symbol. However, you can force a table to start at the top of a page or column, or you can let the table float.

If a text column where a floating table is anchored is too small to contain the table, a floating table moves to the first text column that can contain it. However, the line of text containing the table’s anchor symbol does not move. If the table moves to the next text column, text fills the space below the line containing the anchor symbol.

The space between a table and the paragraph above it is determined by the table’s space above setting or the paragraph’s space below setting, whichever is larger. The space between a table and the paragraph below it is determined by the table’s space below setting or the paragraph’s space above setting, whichever is larger. When the table is at the top or bottom of a column, the above or below setting is ignored.

1)            

Click in the table you want to change, and choose Table > Table Designer.

 

2)           In the Basic properties of the Table Designer, do one or more of the following:

 

•               Enter indent values in the Left and Right boxes.

 

•               Enter spacing values in the Above and Below boxes.

 

•               Specify alignment from the Alignment pop-up menu.

 

•               Specify placement from the Start pop-up menu.

 

3)           Click Apply to Selection.

 

tip:  If you want a table to start at the top of a page with no text preceding it, anchor it on the previous page and set the table to float. If you want it to always float, make its orphan setting a large number such as 200.

If the anchor symbol for a top-of-column table appears below a paragraph that straddles columns, the table appears in the next column but just below the straddle paragraph, instead of at the top of the column.

A top-of-column table anchored below a straddle

[image: ta_15.png]

Related links:

Set the minimum number of rows on a page or in a column

5.5.2.                Straddle or unstraddle tables and cells

Tables can straddle columns in multicolumn layouts, and their positions are sometimes affected by straddle paragraphs. Straddling does not affect the struc­ture of a table and is not a format rule override.

Straddle a table

1)            

Do one of the following:

 

•               Anchor the table in a straddle paragraph. A table anchored in a straddle paragraph, whatever the table’s width, always straddles the full width of the text frame.

 

•               In case of structured documents, anchor the table in a paragraph element that’s formatted to straddle the columns. If the table is wide enough, it straddles the full column width. If it is not wide enough, the plane of the table nevertheless straddles the full width.

 

A table anchored in a straddle paragraph

[image: ta_16.png]

 

•               Extend the table width into a second column of the body area. If you want the table to straddle both the side-head area and the body area, extend it into the side-head area as well.

 

Straddling all columns and straddling side-head area

[image: ta_17.png]

 

Unstraddle a table

•                

To unstraddle a table that’s anchored in a straddle paragraph or paragraph element, move the anchor to a nonstraddle paragraph or nonstraddle element.

 

•               To unstraddle a table that’s anchored in an unstraddled paragraph or paragraph element, resize the column widths of the table to fit in the text column.

 

Straddle or unstraddle cells

If you straddle cells that have contents, the contents of those cells also merge, creating a separate paragraph for each merged cell.

1)            

Do one of the following:

 

•               Select the cells you want to straddle, and choose Table > Straddle.

 

•               Select the cells you want to unstraddle, and choose Table > Unstraddle. The contents of the straddle cell appear in the upper left new cell, not back in the original cells.

 

important:  The contents of an anchored frame or a disconnected text frame are not part of a document’s main structured flow, so they are not normally exported to SGML. If you plan to export to SGML, work with your application developer to avoid losing data in the table.

 

Related links:

Rows and columns

Resize columns and rows

5.5.3.                Rotate cells and tables

When you rotate a cell in a table, you can type in it just as you do in any other cell.

You can also rotate an entire table by placing the table in an anchored frame that is rotated. (For structured documents, check with your developer to see if the application is set up for rotated tables.) A rotated table can be in an anchored frame on a page of unrotated text or on a rotated page (one that uses a rotated master page). Place the table on a rotated page instead of rotating the table itself if you want background items (such as headers or footers) or body text to be rotated with the table. You cannot edit a table in a rotated page.

Rotating a cell or a page with a table does not affect the structure of a table, and it is not a format rule override.

note:  For structured documents, a rotated table in an anchored frame is not part of a document’s main structured flow and is not normally exported to SGML. If you plan to export to SGML, consider rotating the page rather than just the table. If you must rotate just the table, work with your application developer to avoid losing data in the table.

Table on a rotated page (left), rotated table on a regular page (right)
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Rotated cells

[image: ta_53.png]

Related links:

Rotate a master page

Assign master pages to body pages

Resize columns and rows

Create anchored frames

Add text to graphics

Insert, move, or remove a table

Rotate cells

1)            

Select the cells you want to rotate, and choose Graphics > Rotate.

 

2)           Specify the orientation you want for the cells and click Rotate.

 

tip:  As you type in a rotated cell, the cell height increases and the text doesn’t wrap. You can limit the height of rotated cells so that text wraps when it reaches the limit.

Insert a rotated table in a page of unrotated text

1)            

Insert an anchored frame, and draw a text frame in it.

 

2)           Insert the table in the text frame.

 

3)           Select the text frame, choose Graphics > Rotate, and rotate the text frame counterclockwise. You can adjust the size of the text frame or the anchored frame to view the entire table.

 

Insert a rotated table in a page of unrotated text (structured documents)

1)            

Click in the text where you want to anchor the table.

 

2)           Select a graphic element for empty anchored frames in the Element Catalog and click Insert.

 

3)           Choose Below Current Line from the Anchoring Position pop-up menu, set the width and height of the frame, and click New Frame. Try to set the size of the frame to be slightly larger than the size of the table.

 

4)           Draw a text frame in the anchored frame. Select View > Toolbars > Graphics Toolbar and click the Place A Text Frame tool
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 in the Tools panel. Drag to draw the frame and click Set in the dialog box that appears.

 

5)           Click in the text frame and use Table > Insert Table to insert an unstruc­tured table.

 

6)           Choose Graphics > Rotate and rotate the text frame. You can adjust the size of the text frame or the anchored frame to view the entire table.

 

Create a rotated table on a page with other rotated text

1)            

Create a rotated master page and apply it to the body page where the table appears.

 

If document editing causes the table to move to a different page, you’ll need to reapply master pages.

 

Edit a rotated table

1)            

Unrotate the text frame, edit the table, and then rotate it back when you’re finished.

 

5.5.4.                Insert page breaks in a table

If all the rows of a table don’t fit in a text column, some of the rows move to the next page or column. You can control how the table breaks between pages or columns. For example, you can set the minimum number of rows that can appear on a page or column, or specify that two rows always appear together on the same page or column. You can also force a break at any row in a table.

When you insert a table, the minimum number of rows in a column or on a page is determined by the table format. You can change this number in the Table Designer.

Keeping two rows together and forcing a page break are not part of the table format; they are custom settings, which you make on a case-by-case basis. If you apply a different format to the table, these settings are not overwritten.

 

Set the minimum number of rows on a page or in a column

If a table doesn’t fit on one page or in one column, the location of the page break is based on the number of orphan rows allowed for the table. The orphan row property determines the minimum number of body rows that must be kept together on a page or in a column.

note:  When working with structured documents, changes to page breaks do not affect the structure of a table and are not format rule overrides.

1)            

Click in the table you want to change, and choose Table > Table Designer.

 

2)           In the Basic properties of the Table Designer, enter the number of rows in the Orphan Rows box. The number can range from 1 and 255.

3)           Click Apply to Selection.

 

tip:  Specifying a large orphan row setting, such as 99, prevents a table from breaking across columns or pages.

Keep rows together

1)            

Select the row you want to keep together with the next or previous row, and choose Table > Row Format.

 

2)           In the Keep With area, choose Next Row or Previous Row, and click Set.

 

Add or remove a page break in a table

Just as you can have a table or paragraph always start at the top of a page or column, you can do the same with a specific row in a table. Later, you can remove the page break if you want to.

1)            

Click in the row you want to change, and choose Table > Row Format.

 

2)           Do one of the following:

 

•               To force the row to the top of the next column, choose Top Of Column or one of the Top Of Page options from the Start Row pop-up menu.

 

•               To remove a page break, choose Anywhere from the Start Row pop-up menu.

 

3)           Click Set.

 




6.                        Graphics

 

6.1.                   Graphics and objects

 

6.1.1.                About graphics and objects

  

Working with illustrations

In FrameMaker, you can draw rectangles, ovals, and polygons, as well as straight and curved lines. You can create complex illustrations by combining several objects, and include text in illustrations. You can also specify object properties (such as fill pattern, line width, and color), and resize, reshape, rotate, and rear­range objects.

You can place illustrations directly on the page, in anchored graphic frames that move with the text, or in unanchored graphic frames that crop the edges of the illustration.

•               Text frames control placement of the document text.

 

•               Graphic frames, which can be anchored or unanchored control the posi­tion and appearance of graphics.

 

•               Anchored frames hold graphics related to specific text and move along with the text as you edit it.

 

•               Unanchored frames are used to crop graphics that stay in the same place on the page. You can also use unanchored frames to hold reference art. You draw unanchored graphic frames with the Graphic Frame tool on the Tools panel.

note:  Graphics placed in unanchored frames are not exported to HTML, Microsoft Word, or RTF.

 

If you want the graphic to appear at a specific location on a page (for example, for a logo or a bleed tab), draw or import the graphic directly on the page. If you need to crop a graphic or include it as reference art on a reference page, you place it in an unanchored graphic frame.
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 A. 

Graphic drawn on page

 B. 

Text line

 C. 

Anchored frame

 D. 

Text frame for document text

 

You can use text frames along with graphics—for example, as callouts or captions. You can also use text frames in anchored frames to create effects such as sidebars. For single lines of text in graphics, you can also use the Text Line tool.

Tools palette overview

You use the dockable Tools panel to select drawing tools and to apply proper­ties. To display the Tools panel, choose Graphics > Tools or View > Toolbars > Graphics Toolbar.

Graphics toolbar

[image: gr_toolspalette.png]

 A. 

Selection tools

 B. 

Drawing tools

 C. 

Drawing properties

D.

Hotspot mode

About paths

An object’s path is an imaginary line through the center of the object’s border. The path appears as an outline when you draw an object.
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 A. 

Border

 B. 

Path

FrameMaker uses the path to position objects. For example, when you use the Align command to align objects, the objects are aligned along their paths, not along the outside of their borders. When the snap grid is on as you draw, FrameMaker aligns the path with the snap grid.

Objects are aligned along their paths.

[image: gr_05.png]

About graphic elements in structured documents

When working with structured documents, you use special elements to place graphics. A graphic element provides an anchored frame for holding graphic objects. The frame is anchored to a specific location in text. As you edit the text, the frame and its contents move in the document along with the text. The element appears in the document’s structure, but the graphic or equation itself is not part of the structure.

A new graphic element is either an empty anchored frame or an anchored frame with an imported graphic. When you insert the element, its format rules deter­mine whether you see a dialog box for setting up a frame or for importing a graphic file:

•                

For an element that is an empty anchored frame, you specify the size of the frame, its anchoring position, and some formatting properties such as alignment. You can fill in the frame by drawing, pasting, or importing graphic objects in it.

 

•               For an element that is a frame with an imported graphic, you specify the file to import. The graphic appears below the line with the anchor symbol, in a frame large enough for it.

After you’ve inserted a graphic element, you can place different contents in the frame, resize the frame, change the anchoring position, and edit the frame in other ways. These changes are not considered to be format rule overrides.

Related links:

Create anchored frames

Multiple Undo/Redo

Anchored frames

Crop or mask graphics

Use reference frames on reference pages

Add text to graphics

6.1.2.                Draw objects

When you draw an object, the pointer is a cross-hair
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. After you draw, the pointer normally changes back to an arrow 
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 so you can select objects, or to an I-beam
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 so you can select or type text. To draw another object, you usually have to click a drawing tool again.

When you draw an object directly on a page, it doesn’t move with the text, although text can run around the object. If you want the object to be “anchored” to surrounding text (that is, to move as you edit the text), you can draw the object in an anchored frame, or draw it on a page and then move it into an anchored frame.

When you draw an object, it uses the drawing properties that are selected on the Tools panel. The object is also selected, to make changing these properties easier.

Related links:

Apply and change drawing properties

Use gravity and grids to align objects

Resize and reshape objects

Draw a straight line

1)            

Click the Line tool

[image: P_Line_Md_N.png]

.

 

2)           Click at the start and end of the line. You can also drag from the beginning to the end of the line. To draw a horizontal or vertical line, or a line at a 45-degree angle, Shift-click, or Shift-drag.

 

tip:  To draw several lines that touch one another, use the Polyline tool to draw several connected lines as a single object. You can also use the Line tool to draw the lines and then use the Gravity feature to make sure that they touch one another.

Draw a polyline or polygon

1)            

Click the Polyline tool 

[image: P_PLine_18x18_N.png]

or the Polygon tool 
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.

 

2)           Click at each vertex in turn. To draw a horizontal or vertical segment, or a segment at a 45-degree angle, Shift-click.

 

3)           Double-click at the last vertex.

 

Click at each vertex and then double-click to end.

[image: gr_06.png]

Draw an arc

1)            

Click the Arc tool 

[image: P_ArcShape_Md_N.png]

.

 

2)           Put the pointer where you want to start the arc and drag along the path of the arc. To draw a circular arc, Shift-drag.

 

Drag and then release.

[image: gr_07.png]

If the arc isn’t the shape you want (for example, if it’s concave rather than convex), don’t release the mouse button. Drag the cross back to the starting point and draw the arc again, dragging along the path you want the arc to trace.

Initially, the angle of the arc will be 90 degrees.

Draw a freehand curve

1)            

Click the Adobe FreeHand tool 
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 .

 

2)           Place the pointer where you want to start the freehand curve, and drag along the path of the curve. The snap grid is ignored for all but the first point of a freehand curve; however, you may want the snap grid to be off when you draw the curve.

Drag and then release.
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When you release the mouse button, FrameMaker approximates a curve along the path you drew and displays reshape handles and control points so you can reshape the curve.

tip:  For more precise control over the shape of a freehand curve, create a curve by drawing polylines or polygons and then smoothing them.

Draw a rectangle, a rounded rectangle, or an oval

1)            

Click the Rectangle tool 
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 , the Oval tool 
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 , or the Rounded Rectangle tool 
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 .

 

2)           Drag diagonally across the area in which you want the object to appear. To draw a square or circle, Shift-drag.

 

Drag and then release.
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tip:  To draw a border around a graphic, draw a rectangle with a fill pattern of None around the graphic.

Draw a regular polygon

1)            

Draw a circle or square that is slightly larger than the regular polygon you want to create. If you draw a rectangle or an oval, the polygon you create won’t be regular.

 

2)           Select the object and choose Graphics > Set # Sides.

 

3)           Specify the number of sides and the start angle of the polygon, and click Set.

 

Original object and regular polygon, with number of sides = 3 and start angle = 45°
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Draw several objects of the same type without clicking the tool each time

1)            

Do one of the following:

 

•               For all objects except text lines, Shift-click the tool. To stop using the tool, click another drawing tool or one of the selection tools  
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,
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 on the Tools panel.

 

•               For text lines, press Return at the end of a text line and continue typing.

6.1.3.                Select objects

You can select objects that are on the same page or in the same graphic frame. When you select a graphic frame, any selected objects are deselected. When an object is selected, handles appear around it.

Smart Select tool 

[image: P_SelectText_Md_N00001.png]

 

Allows you to place an insertion point or select text when the pointer is over text, and to select objects when the pointer is over an object. When the Smart Select tool is active, the pointer changes shape as you move it—to an I-beam
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 over text or to a hollow arrow
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 over objects. In general, use the Smart Select tool as you work.

 

Object Select tool 
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Use the Select Object tool when you’re working with text lines and text frames as objects—for example, when you want to move or resize a text frame. When you click in text with the Select Object tool active, you select the text line or text frame as an object rather than put an insertion point in the text.

 

note:  After you draw an object, FrameMaker reverts to the Smart Select tool. If you want to keep the Select Object tool active after drawing an object, Shift-click the tool on the Tools panel.

 

Related links:

Keys for selection

Select an object or multiple objects

1)            

Do one of the following:

•               To select one object, click it. If the object is transparent—that is, if it has a fill pattern of None—click its border. When you click overlap­ping objects, FrameMaker selects the object in the foreground.

 

•               To select several objects, point outside the objects and drag diago­nally to draw a selection border around them. All objects you want to select must be completely within the selection border.

 

Drag to select several objects.
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note:  If you move the object rather than draw a selection border (because the pointer was over an object), immediately choose Edit > Undo. Then press Shift-drag to draw a selection border.

•               To select all objects in a graphic frame, select the frame or any object in the frame, and then choose Edit > Select All in Frame.

 

•               To select all objects on a page, click outside any objects or text on the page and choose Edit > Select All on Page.

 

Deselect objects

1)            

Do one of the following:

 

•               To deselect an object, click outside the object.

 

•               To deselect one of several selected objects, Shift-click the object (not a handle). You can also Control-click the object.

•               To deselect all selected objects, drag-and-drop the page away from any objects.

 

•               To deselect several objects in the same area, point outside all the objects and Shift-drag diagonally to draw a selection border around the objects. When you release the mouse button, all objects that are completely within the selection border are deselected. If any objects within the selection border were not selected when you began drag­ging, they are selected.

 

6.1.4.                Apply and change drawing properties

An object’s drawing properties include the fill pattern, pen pattern, line width, line ends, color, and whether the line is solid or dashed. You change drawing properties from pop-up menus on the Tools panel.

Pop-up menus on the Tools panel
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You can change drawing properties before you draw an object, or you can select objects that you’ve already drawn and then change their properties. After you change a property, it becomes the current property—that is, it will be applied to any object you draw. For example, if you choose a line width of 1 point, this is applied to all newly drawn objects until you choose another line width or exit FrameMaker.

You can make objects look alike by applying one object’s properties to another object.

You can also change the colors in the Color pop-up menu and customize the following choices that appear on the Tools panel:

•               The values assigned to the line widths that appear in the Line Widths pop-up menu.

•               The Line end style, which determines the appearance of any line ends that don’t have an arrowhead.

 

•               The pattern that FrameMaker uses when you choose the dashed line style from the Line Styles pop-up menu. (The pattern that appears in the pop-up menu doesn’t change, but FrameMaker uses the new pattern.)

 

The new line width settings remain until you change them. The other new settings remain until you change them or exit FrameMaker.

None of the changes described here are applied automatically to existing objects. However, you can apply the new settings to both new and existing objects.

note:  Dashed line pattern and polylines may appear solid on screen and in print if the lines are especially thick and contain acute angles or have round or projecting caps. To make the lines print correctly, change the Line Ends Options setting to Butt, use a smaller line width, or redraw the object using separate lines.

Related links:

Change line width settings

Work with color in objects

Fonts

Apply a fill pattern or pen pattern to a selected object

 

1)            

Choose the pattern from the Fill Pattern pop-up menu 
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 or Pen Pattern pop-up menu 
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. You can fill any objects except lines, text lines, and equa­tions.
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 A. 

Pen pattern

 B.

Fill pattern

 

The eight gray fill and pen patterns have the following percentages: 100, 90, 70, 50, 30, 10, 3, and 0 (no ink, typically white).

tip:  To make an object transparent (so objects in back of it show through), choose a fill pattern of None. If you don’t want the object to have a border, choose a pen pattern of None. To see the border of an object that uses both a pen and a fill pattern of None, choose View > Borders.

 

Choose a line width for a line or an object’s border

1)            

Choose a width from the Line Widths pop-up menu 
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. You can change the line width of any object except text lines.

 

Change the ends of an arc, a line, a polyline, or a freehand curve

1)            

Choose the line end from the Set Line End Style pop-up menu 
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. You can use no arrowhead or place an arrowhead at the beginning, at the end, or at both ends.

 

Make a line or object’s borders solid or dashed

1)            

Choose a solid or dashed style from the Dashed Line Pattern pop-up menu 
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.

 

Inspect an object’s drawing properties or apply them to other objects

1)            

Select the object that has the properties you want to inspect or copy.

 

2)           Hold down Shift and choose Graphics > Pick Up Object Properties. The properties of the selected object become the current properties on the Tools panel. Any object you draw picks up those properties.

 

3)           To apply the properties to existing objects, select the objects you want to change. In the Tools panel, click the current drawing properties you want to apply to the selected objects.

 

 

Current drawing properties
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Change line width settings

1)            

Choose Set from the Line Width pop-up menu on the Tools panel.

2)           Do one of the following:

 

•               To change the line widths, enter the new line widths and click Set. You can enter the values in any order. When you click Set, the line widths are sorted from smallest to largest. The widths that appear in the pop-up menu don’t change.

 

•               To revert to the line widths you had when you started FrameMaker, click Get Defaults.

Change the line end style

1)            

Choose Set from the Set Line End Style pop-up menu on the Tools panel.

2)           Select a line end style and click Set.
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 A. 

Butt

 B. 

Round

 C. 

Projecting

Change the dashed line style

1)            

Choose Set from the Set Dashed Line Pattern pop-up menu on the Tools panel.

2)           Click one of the patterns and click Set.

 

You can also create custom dashed line pattern.

tip:  To create a dotted line that uses round dots, use a dashed line pattern of short dashes with a round line cap.

Change the arrow style

You can choose from among several preset arrow styles. Arrow styles are deter­mined by their base angle, tip angle, and length.
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 A. 

Base angle

 B. 

Tip angle

 C. 

Length

None of the changes described here are applied automatically to existing objects. However, you can apply the new arrow style to both new and existing objects.

1)            

Choose Set from the Set Line End Style pop-up menu on the Tools panel.

2)           Do one of the following:

 

•               Click a preset arrow style and click Set.

 

•               Fill in a custom base angle, tip angle, length, and style, and then click Set. You can use the following values for the custom options.

 



	
Option

 


	
Values

 





	
Base Angle

 


	
Between 10 and 175 degrees (and at least 5 degrees greater than the tip angle)

 





	
Tip Angle

 


	
Between 5 and 85 degrees

 





	
Length

 


	
Between 0 and 255 points

 





	
Style

 


	
Filled   
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Hollow   
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Stick   
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FrameMaker ignores the Base Angle option when you use Stick. The length you specify applies to objects that have a line width of 1 point. When you use a thicker line width, the arrowhead is longer.

 

The following table contains sample custom arrows and their settings.

 



	
Arrow

 


	
Base Angle

 


	
Tip Angle

 


	
Length
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70 degrees

 


	
30 degrees

 


	
10 points
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80 degrees

 


	
30 degrees

 


	
10 points
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70 degrees

 


	
15 degrees

 


	
10 points
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70 degrees

 


	
30 degrees

 


	
5 points
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120 degrees

 


	
30 degrees

 


	
5 points

 






6.1.5.                Add text to graphics

You can add single lines of text or text frames to a graphic.
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 A. 

Text line

 B. 

Text frame

A text line is a single line of text that FrameMaker treats independently from other text. Text lines grow or shrink in length as you edit them, but they don’t wrap to the next line. You typically use text lines for single-line callouts and for text you want to resize in the same way that you resize other objects.

You can assign character formats and a spell-checking language to text lines. However, text lines can’t have paragraph formats, and they can’t contain anchored frames, markers, variables, cross-references, or conditional text.

Unlike a text line, a text frame can contain more than one line of text. You use text frames for multiline callouts, paragraphs of text, and any other text you want FrameMaker to wrap automatically from line to line. When graphics overlap text in a text frame, you can run the text around the graphics.

tip:  When you resize a text frame created with the Text Frame tool  
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, the font size remains the same. However, when you resize a text line created with the Text Line tool 
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, the font height and width change proportionally.

Related links:

Resize and reshape objects

Font changes using the designers

Indentation, alignment, and spacing

Add a text line to a graphic

1)            

Click the Text Line tool 
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. The pointer changes to a crossed I-beam
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 when you move it to the document window. The small horizontal line across the pointer indicates the baseline position of the text.

 

2)           Click in the document to place an insertion point, and then type the text. FrameMaker uses the last character format you typed or selected in the document.

The text line is left aligned on its alignment point (where you clicked).

1)           To create several text lines, press Return at the end of one text line to create another. You can then select the text lines independently and move them as needed.

 

tip:  To change the character format of text in a text line, use the font commands on the Format menu or the Character Designer. To change the font of several text lines at the same time, select the text lines as objects and change their format.

 

Add a text frame

1)            

Click the Text Frame tool 
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.

 

2)           Drag diagonally where you want to add the text frame.   

3)           Specify the number of columns and the gap between them, and then click Set.

 

4)           Double-click in the text frame to place an insertion point in it, and then type the text.

 

Fix text frames that overflow

When the text you type overflows the text frame, the insertion point moves below the bottom of the frame and the new text doesn’t appear. The bottom border of the text frame appears as a solid line when borders are visible.

Overflowing text frame
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You can enlarge the frame so the text fits, or you can connect the flow of the text frame to another frame (see Disconnect text frames). You can also decrease the font size of the text.

1)            

Control-click the text frame to select it.

 

2)           Drag a handle to enlarge the frame.

 

Create reverse text in a text frame

You can create reverse text (text that appears in a light color on a dark back­ground) for special emphasis. The reverse text can be in a text frame or a text line.

1)            

Set the desired fill pattern and color of the text frame.

2)           Set the text frame’s pen pattern to None.

 

3)           Change the color of the text with the Character Designer or the Paragraph Designer.

 

4)           If necessary, change the indentation and alignment of the text with the Paragraph Designer.

 

Create a reverse text line over an object

1)            

Draw an object to act as the background for the text. Generally, it’s best to use a nearly black fill pattern for the object.

2)           Outside the background object, add a text line and type its text.

3)           Control-click the text line to select it.

 

4)           Move the text line so part of it disappears into the background object.

 

Draw object and text line and then move line part of the way.
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5)           Choose a light color from the Color pop-up menu on the Tools panel. The text appears partially cut out of the background object.

 

If the text doesn’t appear in front of the object, choose Graphics > Bring to Front. If you still have trouble, make sure that the current color view of the document shows the text line’s color as Cutout.

 

6)           Move the text line so all its letters appear cut out of the background object.

 

Choose a light color and then move the text line all the way.
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Add a title to an illustration

You can include a text line or text frame in a graphic as a title. You can also use a paragraph above or below an anchored frame as a title for the frame’s graphic. However, you may find it easier to use table commands instead.

Single-cell table with table title below
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You can also use multicell tables to achieve various effects with graphics and text. For example, the next example is a two-cell table. The first cell contains several autonumbered paragraphs; the second cell contains the figure.

One-row table containing two cells
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Use the guidelines provided here for setting up the paragraph formats, table formats, and anchored frames you’ll need if you want to use single-cell tables and their titles for illustrations and their captions.

1)            

Use the Table > Insert Table command to create a single-cell table wide enough for your figure.

2)           Use the Table > Table Designer command to specify the location of the title (see Add or remove a table title).

 

3)           Type the text of the title.

 

4)           Format the table title.

5)           Store the format for the table title in the Paragraph Catalog (see Create a paragraph format).

 

6)           Change the cell’s paragraph format to turn off fixed line spacing so that the size of an anchored frame can affect the paragraph’s line spacing.

 

7)           Create an anchored frame in the cell, anchored at the insertion point (see Create anchored frames). If necessary, the cell grows vertically to accom­modate the frame’s height.

 

8)           Put the graphic in the anchored frame and resize the frame.

 

9)           If the frame is wider than the cell, change the column’s width. You can select the table cell and drag a handle to change the width, or you can use the Table > Resize Columns command (see Resize columns and rows).

 

10)       Store the table format in the Table Catalog (see Create, edit, and delete table formats).

 

11)       The next time you add a table for a figure and its title, either use the Table > Insert Table command or copy and paste the table.

 

Run text around graphics

You can make the text in a text frame run around a graphic that overlaps the text. (However, text will not run around a text line or an equation.) When a graphic is placed directly on a page or in an unanchored frame, the text can follow the contours of the graphic, or it can align vertically at the edge of an imaginary box bounding the graphic.

Text run around contour and run around bounding box
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You can also run text around anchored frames—for example, to set a small graphic or a drop cap at the beginning of a paragraph.

When text in a text frame runs around a graphic, FrameMaker does not feather text in that frame.

1)            

Draw or place the graphic on a page. When you place the graphic on a master page, it appears as a background graphic on all associated body pages. You can then make the text on all the associated body pages run around the graphic.

 

Make sure that you click in the page margin before importing or pasting the graphic. Otherwise, the document contains an insertion point, which will cause the graphic to be placed in an anchored frame.

 

2)           Select the graphic. If the graphic is made up of several objects, select all the objects.

 

3)           If you want to run text around the contour of an imported graphic, make sure the graphic is behind the text frame. To do so, select the graphic and choose Graphics > Send to Back.

 

4)           If the graphic’s runaround properties aren’t set as you want them, choose Graphics > Runaround Properties, and do one of the following:

 

•               To make text run around the graphic, click a runaround style and enter a gap.

 

•               To prevent text from running around the graphic, click Don’t Run Around.

 

note:  If the Style setting is As Is when you display the Runaround Proper­ties dialog box, you selected several graphics that have different runaround properties.

 

5)           Click Set.

tip:  If the settings don’t produce exactly the results you want, add an object (with a pen and fill pattern of None) near the graphic to create the desired contour for the text to run around.

Related links:

Anchored frames run into paragraph text

Feather text to the bottom of text frames

6.1.6.                Copy and arrange objects

 

Cut, copy, or paste an object by using the clipboard

1)            

Select the object and choose Edit > Cut, or Edit > Copy.

 

2)           Do one of the following:

 

•               To paste the object on a page, click in the margin of the page.

 

•               To paste the object in an existing graphic frame, click the frame’s border to select the frame.

 

•               To paste the object in text, click in the text where you want to paste the object.

 

3)           Choose Edit > Paste. When you paste the object in a graphic frame or on a page that is the same size as the one from which you copied or cut the object, FrameMaker puts the object in the same relative location. Other­wise, FrameMaker centers the object.

 

When you paste an object into text, FrameMaker creates an anchored frame to hold the object, and centers the object in the frame. An anchor symbol
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 appears at the insertion point when text symbols are visible.

Copy an object by dragging

1)            

Select the object.

2)           Point on the object (not on a handle), and Alt-drag the duplicate of the object, or right-drag the object and then choose Copy Here from the menu. To constrain the duplicate’s movement to either a horizontal or vertical direction, hold down Shift while you drag.

 

Delete an object

1)            

Select the object and press Delete.

 

Move an object

1)            

Select the object.

 

2)           Do one of the following:

 

•               Drag in the direction you want to move the object.

 

•               To move the object horizontally or vertically, Shift-drag.

 

•               To move an object into a graphic frame, drag it until the pointer is in the frame.

•               To move an object out of a graphic frame, drag it until the pointer is outside the frame. As you drag, the frame’s border may temporarily crop the object.

 

When you drag the object, the status bar shows the distance from the upper-left corner of the object to the upper-left corner of the page (or frame, if the object is in a graphic frame). When rulers are visible, lines in the rulers show you the object’s position. If the snap grid is on, objects snap to the invisible grid as you drag them.

 

tip:  If your screen does not redraw properly when moving an object, press Ctrl+l (lowercase L) to redraw the screen.

•               To move an object in small increments, hold down Alt and press an arrow key to move 1 point, or hold down Alt+Shift and press an arrow key to move 6 points. However, do not use an arrow key on the numeric keypad.

 

The preceding distances assume a 100% zoom setting. The actual distance moved depends on the current zoom setting, so you can do finer work when you’re zoomed in closer. For example, at 200% zoom, the distance is halved. At 50% zoom, the distance is doubled.

•               To specify the exact position of an object, select the object, choose Graphics > Object Properties, do one of the following and apply the changes:

 

–              For all objects except text lines and equations, specify the offset from the top and left edges of the page or graphic frame in the Offset From area.

 

A. Offset from left   B. Offset from top 
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–              For text lines and equations, specify the offset in the Alignment Point Offset area.

Left-aligned text line
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A.

Offset from left

B.

Offset from top

 

Change the stacking order of objects

When you draw or paste an object, FrameMaker places it in front of all other objects on the page or in a graphic frame. You can control how objects overlap by putting them in front of or in back of other objects.

Circle in front and circle in back
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1)            

Select one of the objects and do one of the following:

 

•               To put an object in front of other objects, choose Graphics > Bring to Front.

 

•               To put an object in back of other objects, choose Graphics > Send to Back.

 

tip:  To create a drop shadow, stack two objects and offset them slightly.

Use gravity and grids to align objects

You can align objects (except graphic frames) with one another along either a horizontal line (by specifying top/bottom alignment) or a vertical line (by spec­ifying left/right alignment.

1)           Select the objects and choose Graphics > Align. To align a single object in a graphic frame or on a page—for example, along the left side of a graphic frame—select only the object you want to align.

 

2)           Choose the alignment you want and click Align. To align objects in only one direction, set the other direction to As Is.

 

FrameMaker aligns the objects—along their paths—with the last object you select. For example, “Top Align” aligns selected objects with the last selected object and is not necessarily the object that is currently highest in the anchored frame.

If you selected objects by dragging a selection border, FrameMaker aligns the objects with the object in the foreground.

Objects have gravity along their paths and at their corners. Rectangles and ovals also have gravity at their centers. Some points on an object exert a greater pull than others. For example, the corners of a triangle attract the pointer more than its sides do.

With Gravity on, an object attracts the pointer as you draw, resize, or reshape a nearby object. Gravity has no effect when you move objects.

Gravity extends the same distance on the screen regardless of the zoom setting. When you zoom in, objects and the space between them appear larger, so you can drag a handle or draw closer to an object without the object attracting the pointer.

 

Use gravity to align objects

 

It’s easier to make objects touch when you use the Gravity feature. If Gravity and Snap are both selected in the Graphics menu, gravity takes precedence.

1)           If Gravity isn’t already on, choose Graphics > Gravity.

2)           Drag a handle of an object, or draw an object, close to the object to which you want to connect. As you drag, the handle jumps so the two objects touch each other.

 

Gravity ensures perfect alignment.
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Align objects on a grid

 

The visible grid appears as horizontal and vertical lines onscreen, but not on the printed page. A graphic frame contains its own visible grid, which begins at the upper-left corner of the frame.

The invisible snap grid attracts objects to it. As you draw, rotate, resize, or drag objects (and when you drag indent and tab stop symbols on the ruler), they snap to the invisible grid.

note:  If Snap and Gravity are both selected in the Graphics menu, gravity takes precedence.

•               To show or hide the visible grid, choose View > Grid Lines. If the visible grid doesn’t appear in a text frame, change the frame’s fill pattern to None.

 

•               To turn the snap grid on or off, choose Graphics > Snap.

 

•               To change the grid spacing, choose View > Options, and do any of the following, and then click Set:

 

–              To set the space between lines in the visible grid, choose the spacing from the Grid Lines pop-up menu.

 

–              To set the interval for the snap grid, enter the interval in the Grid Spacing text box.

 

–              To set the snap interval for rotating objects, enter the number of degrees in the Snap Rotate text box.

 

tip:  If you intend to use the grids together, make the visible grid spacing a multiple of the snap grid interval. For example, if the snap grid spacing is 0.125 inch, you could make the visible grid spacing 0.125 inch, 0.25 inch, or 0.5 inch.

 

Align text lines

When you create a text line, it is left aligned on its alignment point (where you clicked). You can change the alignment to centered or right aligned. FrameMaker then maintains the text line’s alignment when you insert text.

1)           Select the text line and choose Graphics > Object Properties.

 

2)           Choose a new alignment from the Alignment pop-up menu and click Align.

 

Distribute objects

You can move objects—distribute them—so they have an equal amount of space between them. You can distribute objects horizontally and vertically.

Objects before and after distributing (with zero edge gap)
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Equidistant centers and equidistant edges
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If you specify the exact space between the objects (the edge gap), FrameMaker moves all objects except the one at the left or top. If you specify that the objects’ centers or edges should be equidistant, FrameMaker leaves the left and right, or top and bottom, objects where they are and moves the others.

1)            

Select the objects and choose Graphics > Distribute.

 

2)           Choose the spacing you want and click Distribute. To distribute objects in only one direction, set the other direction to As Is.

 

When you specify a large edge gap, objects may move off the page and disappear from sight. If they do, immediately choose Edit > Undo.

Make lines intersect cleanly

Lines intersect cleanly when they are the same thickness, meet at right angles, and use a projecting cap; lines don’t intersect cleanly when they use a projecting cap but don’t intersect at right angles. Notice the different intersections created by using the three line cap styles.
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 A. 

Projecting

 B. 

Butt

 C. 

Round

1)            

Do one of the following:

 

•               If the lines don’t meet at a right angle, try a round cap for both lines.

•               If the lines aren’t the same thickness, try a butt cap for the thinner line when the lines meet at their endpoints and for the stem of a T when they meet in a T.

 

For information on changing the line cap style, see Change the line end style.

 

Related links:

Apply and change drawing properties

Group and ungroup objects

When several objects (except graphic frames) are part of the same graphic, you can group the objects. You can then edit and arrange them as a single object.

You can combine a group of objects with other objects to form an even larger group. Because FrameMaker groups and ungroups objects hierarchically, the first set of grouped objects is maintained as a set when you group other objects with it.

•               To group objects, select the objects and choose Graphics > Group. One set of handles appears around the group.

 

Objects selected and then grouped
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•               To ungroup objects, select the group and choose Graphics > Ungroup. Handles appear on each object in the group. When a group has been grouped with other objects, you must choose Ungroup more than once to ungroup all objects.

 

6.1.7.                Join lines and curves

You can create complex outlines by joining individual lines, polylines, arcs, and smoothed polylines that were created with FrameMaker drawing tools. Joining creates a single continuous curve. You can then change the new curve’s proper­ties, such as its line width, pen and fill patterns, and color.

Objects drawn, and then positioned and selected
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Objects joined, and then fill pattern added
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1)            

Position the objects so that their endpoints touch. The ends of the lines or curves must be within 1 point of each other and the objects cannot be grouped. If necessary, choose Graphics > Gravity and zoom in.

 

2)           Select the objects and choose Graphics > Join. The new curve takes on the properties of the last object selected before joining—for example, the object’s line width, pen pattern, or color. (In the preceding illustration, the last object selected before joining was the arc.)

 

note:  If you join lines or curves by mistake, immediately choose Edit > Undo. Joining creates a single continuous object that cannot be “unjoined” at a later time in the way that grouped objects can be ungrouped.

6.1.8.                Flip and rotate objects

You can create a mirror image of an object by flipping it up and down or left and right.

You can rotate all objects (except equations and graphic frames) any number of degrees. You can rotate graphic frames and equations in 90-degree increments.

All objects (except equations and text lines) rotate around their centers.

Equations and text lines rotate around their alignment points.

You may find it easier to edit objects—for example, to align and distribute them—in their unrotated position. After you edit an object, you can rerotate the object to restore it to its rotated position.

note:  If you rotate an imported PICT image or a page containing an imported PICT image, the image may print poorly. To improve printing, convert the image to TIFF or EPS and reimport the image.

Related links:

Distribute objects

Flip an object

1)            

Select the object and choose Graphics > Flip Left/Right or Graphics > Flip Up/Down. If the object contains text, the text isn’t flipped. For example, the text in a flipped text line doesn’t appear flipped, but the alignment point of the text line is flipped.
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 A. 

Original

 B. 

Flipped up/down

 C. 

Flipped left/right

Create a symmetrical object

1)            

Draw one half of the object and copy it.

 

Draw and then make a copy.
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2)           Flip the copy and move it until it touches the original.

 

Flip and then move.
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Rather than move the duplicate to the original, you can use the Distribute command with an edge gap of zero to ensure exact alignment of the objects.

Rotate objects by dragging

1)            

Select the object.

 

2)           Hold down Alt and drag a handle.

 

When the snap grid is on, the object snaps to multiples of the angle spec­ified in the View Options dialog box. To constrain the rotation to 45-degree increments, also hold down Shift while you drag.

 

Rotate an object precisely

 

1)           Select an object and do one of the following:

•                

To rotate from the object’s current position, choose Graphics > Rotate, specify the direction and amount of rotation, and click Rotate. If you rotate several ungrouped objects in this way, each object rotates around its center.note:  This method also works for equations and graphic frames. 

•               To rotate the object’s by a certain degree, choose Graphics > Object Prop­erties, enter the angle of rotation and click Set.

 

6.1.9.                Crop or mask graphics

When you want to crop the edges of a graphic, place the graphic in an anchored or unanchored graphic frame. An anchored graphic frame moves with the surrounding text. An unanchored graphic frame stays wherever you place it on a page, even when the text around it moves as the result of editing.

Uncropped and cropped graphics in graphic frames
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When you want to mask an area of a graphic, particularly if the part you want to mask is in the middle of a graphic, you can cover the area with nonbordered objects.

Related links:

Create anchored frames

Crop the edges of a graphic frame

1)            

Do one of the following to create a graphic frame:

 

•               To create an unanchored frame, click the Graphic Frame tool 
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 on the Tools panel and then drag to draw the frame. To draw a square frame, Shift-drag.

 

•               To create an anchored frame, use Special > Anchored Frame.

 

2)           Do one of the following to put the graphic in the frame:

 

•               Drag the graphic into the frame.

 

•               Select the graphic, choose Edit > Copy or Edit > Cut, select the frame border, and then choose Edit > Paste.

 

3)           Resize the frame around the graphic.

 

Mask an area within a graphic frame

1)            

Put graphic objects (such as rectangles and polygons) with a white fill and pen pattern in front of the parts you want to mask.

 

6.1.10.            Measure object size and position

As you arrange and resize objects in an illustration, you may want to know an object’s dimensions and exact position.

The size of an object is the size of the rectangle that encloses its path. The posi­tion is the distance from the top and left edges of the page or graphic frame.

Object size and object position
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Measure an object

1)            

Do one of the following:

 

•               Select the object and choose Graphics > Object Properties. The width and height of the object appear in the Size area of the Object Properties dialog box.

 

•               With Snap off, select the object, point on one of its handles, and hold down the mouse button. The dimensions appear in the status bar. If you move the mouse by mistake and resize the object, immediately choose Edit > Undo.

 

View the position of an object

1)            

Select the object.

 

2)           Choose Graphics > Object Properties. For all objects except equations and text lines, the distance from the upper left corner of the page or graphic frame to the object’s topmost and left-most point appears in the Offset From area. For equations and text lines, the distance from the upper left corner of the page or graphic frame to the alignment point at the baseline of the text line or equation appears in the Alignment Point Offset From area.

 

View the position of an object as you move it

1)            

Look in the status bar. The distance between the object and the upper-left corner of the page or graphic frame appears in the status bar. When rulers are visible, guidelines in the rulers also show the position of the object.

 

Measure any distance on the page

1)            

Point where you want to start measuring.

 

2)           Shift+Control-drag to force a selection border to appear, but don’t release the mouse button.

 

3)           When the selection border encompasses the area you want to measure, look in the status bar for the dimensions.

 

Dimensions appear in the status bar.
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In the example, the important dimension is the height (35 points between the bases of the triangles).

6.1.11.            Resize and reshape objects

As you refine a graphic, you can change the size and shape of objects. Reshaping possibilities are unlimited. For example, you can add a corner to a polyline or polygon, move a corner to change its shape, and smooth a polyline to create a freehand curve.

Original polygon and then with corner added
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Corner moved and then smoothed
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You can resize all objects, including text lines. When you resize a text frame created with the Text Frame tool 
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, the text remains the same size. When you resize a text line created with the Text Line tool 
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, the font height and width change proportionally.

Before and after resizing a text line (not a text frame)
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You can change the shape of lines, polylines, polygons, curves, and arcs as follows:

•                

Reshape a line, polyline, or polygon by moving its corners one at a time. You can also add and remove corners.

•               Reshape a curve by changing the position of its reshape handles (which define the curve and control its location) and its control points (which adjust the curvature). You can also add and remove reshape handles to change the number of points that define the curve.
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 A. 

Reshape handle

 B.

Control point

•                

You reshape an arc by dragging its endpoints or by changing the percentage of a circle that the arc represents.

 

Resize an object by dragging

1)            

Select the object and do one of the following:

 

•               To change either the width or the height, drag a side handle.

 

•               To change both the width and the height, drag a corner handle.

•               To increase or decrease the dimensions proportionally, Shift-drag a corner handle.

The object’s dimensions appear in the status bar as you drag.

Resize an object precisely

1)            

Select the object and choose Graphics > Scale.

 

2)           Do one of the following:

 

•               To increase or decrease the height and width proportionally, enter a scale factor and click Scale. The scale factor is always relative to the object’s current size (100% means no change).

•               To specify the exact dimensions you want, enter the dimensions and click Scale. The dimensions shown when you display the dialog box are the object’s current (unrotated) dimensions.

Resize imported graphics

You can resize imported graphics back to the original size. You can also change the size of imported bitmap graphics.

 

Resize your imported graphics back to 100%

 

1)           Select the object and choose Graphics > Object Properties.

 

2)           For Scaling Percent, type100%, and click Set.

 

Change the size of bitmap graphics

Changing the dpi value or the scaling factor changes the size of a bitmap graphic.

1)            

Do one of the following:

 

•               Select the bitmap, choose Graphics > Object Properties, and click Set dpi.

 

•               Select the bitmap, choose Graphics > Scale, and specify a scale factor.

 

•               Shift-drag a corner handle of the bitmap. Holding down Shift while you drag maintains the proportions of the graphic.

 

note:  If the graphic is a TIFF file (or other format that uses dpi settings), scaling must be done through the Object Properties to ensure that the dpi value is not lost when scaled using the Scale dialog.

 

Move a corner of a polyline or polygon

1)            

Select the object and choose Graphics > Reshape. Reshape handles appear on the object, replacing the selection handles.

 

2)           Drag a handle. To move the handle horizontally or vertically, Shift-drag.

 

Add or remove a corner or reshape handle

1)            

Select the line, polyline, polygon, or curve, and choose Graphics > Reshape.

 

2)           Control-click where you want to add a reshape handle (or corner), or Control-click the handle you want to remove.

 

Reshape a curve

1)            

Select the curve and choose Graphics > Reshape. Reshape handles appear at the locations that define the curve. Control points also appear around one of the handles.

 

2)           If the control points aren’t the ones you want, click the handle where you want to change the curve. Control points appear around the handle that you click—the two control points that correspond to the handle and the next closest one on each side of the handle.

 

3)           Drag a handle to change the position of the curve at the handle, or drag or rotate a control point to change the curvature. When you begin to drag, a lever appears that touches the curve at the handle. You can achieve different effects by dragging along the lever or by rotating it.

 

Choose Reshape and drag handle.
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Drag a control point.
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As you drag a reshape handle, the control points move as well, so the result is a smooth curve. As you drag a control point, the curvature changes on both sides of the handle, so the result is also a smooth curve.

Crimp a curve

1)            

Select the curve and choose Graphics > Reshape.

 

2)           If the control points aren’t the ones you want, click the reshape handle where you want to change the curve.

 

3)           Drag a handle or control point with the right mouse button.

 

Crimping a curve.
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Reshape an arc

1)            

Select the arc and choose Graphics > Reshape. Reshape handles appear on the object, replacing the selection handles.

 

2)           Drag a handle. As you drag, the start and end angle of the arc and the percentage of a circle that the arc represents appear in the status bar.

 

Drag to reshape an arc.
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Reshape an arc precisely

 

1)           Select the arc and choose Graphics > Object Properties.

 

2)           Enter a new Start Angle and End Angle, and click Set.

 

Change the corner radius of a rounded rectangle

You can define the curvature of the corners of a rounded rectangle by specifying the radius of an imaginary circle drawn in the corner of a rectangle. The longer the radius, the more curved the corners.

Radius (r) = .125" and radius (r) = .25"
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When you specify a corner radius, you also change the current drawing proper­ties. New rounded rectangles you draw have this corner radius until you change it with the Object Properties command or until you exit FrameMaker.

1)            

Select a rounded rectangle and choose Graphics > Object Properties.

 

2)           Enter the corner radius and click Set. The largest meaningful radius is one-half the length of the shortest rectangle side. For example, if the rect­angle is 2 inches by 4 inches, the largest meaningful radius is 1 inch (one-half of 2 inches).

 

Smooth and unsmooth objects

You can smooth polylines, polygons, rectangles, and rounded rectangles. When you smooth a polyline, polygon, or rectangle, you change its angles to smooth curves. When you unsmooth a curve, you restore its angles.

Before and after smoothing
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Each time you smooth a rounded rectangle, you increase the curvature of its corners (its corner radius).

1)            

Do one of the following:

 

•               To smooth an object, select the object and choose Graphics > Smooth. After smoothing a polygon or polyline, reshape handles and control points appear so you can reshape the curve

 

•               To unsmooth an object, select the object and choose Graphics > Unsmooth. If you later smooth the object, its shape is sometimes different from the original.

 

6.2.                   Using color in text and objects

  

6.2.1.                About color and color models

 

Before you begin

Applying color to frames and objects is a common publishing task, whether you are publishing in print or exporting to the web. FrameMaker provides color libraries to choose from colors defined by a color vendor. You define and modify colors by adjusting the color model you’re using or by choosing a predefined ink from a color library based on the color model.

Before applying color to your documents, prepare in these ways:

Identify the output format of your document

 

The final output of your color document can greatly affect color decisions:

 

•               For online output, use the RGB or HLS color models. Your guide to correct color is how your documents look on your monitor.

 

•               For desktop printing, use the CMYK model to define your colors and test them on the printer you’ll be using.

 

•               For commercial printing, use colors from a library supported by your commercial printer. Don’t rely on the onscreen versions of library colors; use a swatch book.

Learn the limits of the medium

 

Become familiar with the range of colors available on your monitor or printer. For example, a system set to display 256 colors cannot display tints below 16% accurately in FrameMaker.

 

By default, FrameMaker publishes CMYK values when printing or saving as Adobe PDF. If you opt to use RGB values while saving as a PDF, FrameMaker converts colour values to RGB and creates separations in equivalent RGB values. EPS graphics, however, are separated according to the color values spec­ified within the EPS graphic itself.

FrameMaker retains the color values specified within Encapsulated PostScript (EPS) graphic objects, including CMYK colors, RGB colors, grayscale, spot colors, device-independent colors (such as CIE L*a*b color). The graphical information within an EPS file is passed directly into the output PostScript stream, bypassing any Windows GDI processing. EPS graphic objects can be created from text, vector graphics, or images of any type supported by Adobe PostScript. This capability allows EPS graphics to be saved or exported from many Adobe applications, as well as other third-party application programs.

Color models

When you use a color model to define colors, you manually adjust its compo­nents, such as the amount of pure red or the amount of saturation.

You can choose from three color models: CMYK, RGB, and HLS.

CMYK

 

Use the CMYK model to create color separations for four-color process printing. Colors are created by combining cyan, magenta, yellow, and black (CMYK) inks. In color separation, each color component is printed on a separate plate, in a different concentration, depending on the desired color.

 

RGB

 

Use the RGB model to create colors that are viewed on a monitor (for example, for online documentation). Colors are created by combining red, green, and blue (RGB) light.

HLS

 

Use the HLS model if you are familiar with color wheels. This model is most like the one artists use to mix colors and is often used in software color pickers. Colors are created by adjusting hue, lightness, and satura­tion (HLS). Hue controls the amount of red, green, yellow, blue, and so on. Lightness controls the lightness or darkness of a color. Saturation controls the amount of gray in the color.

 

6.2.2.                Manage color libraries

When you use a color matching system—a color library—you choose from colors defined by a color vendor. Commercial printers can precisely match the formula represented in a vendor swatch book.

Every color from a library is defined as either a spot color or a process color. A spot color is printed on a printing press with premixed inks by using a single printing plate. A process color is printed on a press by overlapping dots of cyan, magenta, yellow, and black (CMYK) on separate plates.

Before choosing a color from a color library, ask your commercial printer for a list of supported libraries. For best results, choose colors from a swatch book, rather than relying on the onscreen representation of the color.

FrameMaker includes these libraries:

Crayon

 

Adobe developed the Crayon library to provide access to common RGB colors using everyday names in alphabetical order. Do not use Crayon colors as spot colors.

 

DIC

 

The DIC Color Guide provides spot colors. It is used mostly in Japan.

 

FOCOLTONE

 

The FOCOLTONE® Color System provides 860 process (CMYK) colors.

 

Grays

 

The Grays library, developed by Adobe, provides both process and spot shades of gray in 1% increments.

 

MUNSELL

 

The Munsell System provides colors defined on the RGB model.

 

Online

 

The Online color library provides 216 “web-safe” colors that have a consistent appearance on all platforms when viewed with a web browser.

 

PANTONE

 

Most of the libraries in the PANTONE® MATCHING SYSTEM are for spot colors. Only the two PANTONE process libraries are for selecting process colors. Separate PANTONE libraries are available for colors that are printed on coated and uncoated paper. The PANTONE ProSim Euro library uses color definitions that match the printing systems prevalent in Europe.

 

TOYO

 

The TOYO Color Finder provides over 1000 colors based on the most common printing inks in Japan.

 

TRUMATCH

 

The TRUMATCH® 4-Color Selector provides over 2000 process colors that cover the CMYK visible color spectrum in even steps.

 

View color definitions in a color library

1)            

Choose View > Color > Definitions, choose a library from the Color Libraries pop-up menu, and then click About.

 

Add a color library for use in FrameMaker

You can add any library file formatted in the ASCII Color Format (.acf), version 2.1 or earlier, or in the Binary Color Format (.bcf), version 2.0. You can’t use FrameMaker to save a .bcf library file.

1)            

Place the library file into the Fminit\Color folder and restart FrameMaker.

 

6.2.3.                Work with color in objects

The method you use to apply a color or a lightened version of a color (a tint) depends on the current selection. Any entry in a Color pop-up menu can be applied to FrameMaker text or objects. FrameMaker supplies a set of 16 stan­dard colors that you can add to.

You can apply two types of tints:

•                

Color-level tints are tints you define and name by using View > Color > Definitions.

•               Object-level tints are tints you apply to an object that lighten the original color of the object by a specified percentage.

note:  You can’t colorize TIFF files.

Related links:

Font changes using the designers

Apply a color or tint to text or an object using formatting features

1)            

Select the text or object to color or tint.

 

2)           Apply color to paragraphs, selected text, graphics, text lines, and equations using the appropriate formatting feature. Features include paragraph or character catalog or designer, or the Tint and Color pop-up menus on the Tools panel. The following table shows what features to use for tasks that vary:

 



	
To apply color or tint to

 


	
Use

 





	
A text frame

 


	
The Fill pop-up menu on the Tools panel to change the frame fill pattern from None. Then use the Color pop-up menu or the Tint pop-up menu to assign a color

 





	
Cells in a table

 


	
The Color pop-up menu in the Custom Ruling and Shading dialog box, or in the Table Designer

 





	
Change bars

 


	
The Color pop-up menu in the Change Bar Properties dialog box

 





	
Conditional text

 


	
The Color pop-up menu and the New Color button in the Edit Condition Tag dialog box

 





	
All drawn objects and text

 


	
The Color pop-up menu in the Tools panel (hold down Shift+Alt and choose a color).

 






Apply a tint to an object using a fill pattern

1)            

Select the object you want to tint.

 

2)           Choose one of the first eight fill patterns from the Fill pop-up menu on the Tools panel. The fill patterns apply the following percentages to the current color of the object.

 



	
Fill Pattern

 


	
Tint Percentage

 





	
[image: gr_212.png]

 


	
100%
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90%
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70%
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50%
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30%
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10%
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3%
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0% (color of paper)

 






Define and modify colors and tints

You create or modify colors and tints by adjusting the color components in the color model or by choosing a predefined ink from a color library. New colors and tints appear in all Color pop-up menus and scroll lists.

You can also use the New Color button in the Add Condition Tag and Edit Condition Tag dialog boxes to select unique colors for condition tags. Unique colors let you distinguish one tag from another.

tip:  You can’t change the 16 standard colors, except for their Print As and over­print properties. However, you can define your own colors using lowercase versions of these names (black, blue, and so on). The Crayon library has its own versions of these colors, which you can use or redefine under another name.

All define procedures require the appropriate document window or book window to be active and View > Color > Definitions, selected.

1)           Do one of the following:

 

•               To define a new color, enter a new name in the Name box.

 

•               To modify an existing color (or base color), choose its name from the pop-up menu to the right of the Name box. You can also type its name until the color definition appears.

 

2)           Specify how to print the color by choosing one of these options from the Print As pop-up menu:

 

Tint

 

A tint is always displayed and printed in the same manner and on the same plate as its base color. The base color also determines the color compo­nents.

 

Spot

 

Defines a spot color.

 

Process

 

Defines a color printed with CMYK inks.

 

Don’t Print

 

Defines a color that is not printed.

 

3)           To change the color model, choose from the Model pop-up menu. (Base color determines the color model of the tint.)

 

4)           Adjust the color components by dragging the sliders or entering values. If you’re defining a tint, choose a color from the Base Color pop-up menu and set the percentage. To reset any changes you’ve made, click the Current color box.

 

note:  Perhaps your monitor cannot accurately display the color or tint that you define. For example, a tint value of less than 10% of the base color prob­ably does not display accurately onscreen, or on some printers.

5)           To make this color print on top of other colors when printing separations, choose Overprint from the Overprint pop-up menu.

 

6)           To create a color, click Add (or click the New color box); to modify the current color, click Change.

 

7)           Define or modify additional colors as needed, and then click Done.

Define a color from a color library

 

1)           Choose a library from the Color Libraries pop-up menu.

 

2)           Choose a color from the library of predefined colors. If you know the name, you can quickly scroll to it by starting to type its name.

3)           Click Done. The color you choose appears as the Ink Name in the Color Definitions dialog box.

 

note:  Colors from color libraries often have a preferred color model and type. When you choose a color, the color model or type sometimes changes automatically. Ordinarily, do not change these settings or the color defini­tions of a library color. If you do, the Ink Name disappears and the color no longer matches the formula defined by the vendor. To restore the original definition, choose the color again from the library and click Change.

 

4)           To make this color print on top of other colors when printing separations, choose Overprint from the Overprint pop-up menu and click Add.

 

5)           Define additional colors as needed, and then click Done.

tip:  If you want to use the operating system color picker to define a color, choose Common Color Picker. You use these color pickers just as you do in other applications.

 

Delete a color or tint

 

1)           Choose a color or tint from the Name pop-up menu. (You can’t delete the basic 16 colors.)

 

2)           Click Delete. If the color is in use, an alert message asks whether you want to change items that use this color to black. If you delete the base color of a tint, the tint becomes a percentage of black.

 

3)           Repeat the process to delete more colors. When you’re finished, click Done.

 

note:  Color definition names support the Unicode text encoding standard.

 

Assign a color to an object

1)            

Choose the color from the Color menu.

2)           To use a tint of the color, choose a tint value from the tint menu. If the value you want doesn’t appear on the menu, choose Other from the menu, enter a tint value, and click Set.

 

If an object isn’t visible after you assign it a color, make sure that the color isn’t in the Invisible scroll list in the Define Color Views dialog box for the current view.

You can also assign the same color to all objects in a document.

note:  To control whether an object overprints or knocks out objects beneath it, use the Overprint pop-up menu. For information, see Knock out and overprint colors.

Set up and display color views

A color view specifies which colors are visible. For example, if your document uses black and a spot color, one view could display both colors and another view could display only the spot color.

Both colors visible and only one color visible
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For each view you set up, specify which colors you want to display, which to display as cutouts, and which not to display at all. Cutouts display as white when overlapping different colored objects.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose View > Color > Views.

 

3)           Select a view number and move the color names to the appropriate scroll lists. Tints do not appear in this dialog box; they appear along with the color they were based on.

 

To move a color, select it and click an arrow, or double-click it. To move all colors, select a color and Shift-click an arrow. To reset any changes you’ve made, click Get Default.

 

tip:  Leave View 1 unmodified, with all colors (except white) in the Normal scroll list. When you draw an object in a color that is invisible in the current view, FrameMaker automatically switches to View 1.

 

4)           Repeat step 3 for each view you want to set up, and then click Set. The currently selected view is displayed.

6.3.                   Anchored frames

 

Related links:

Display master pages

6.3.1.                About anchored frames

  You often want to keep an illustration with particular document text. In FrameMaker, you do this by putting the illustration in a graphic frame anchored to the text—an anchored frame. When you edit the text, the frame and its contents move along with the text automatically.

You can use an anchored frame for an illustration in a column of text—below the line that contains the anchor symbol
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, or at the top or bottom of the column. You can use an anchored frame for small graphics that appear in line with para­graph text or for art that appears between columns or in the page margin.

You can also use an anchored frame to achieve special effects such as posi­tioning an anchored frame in the top corner of a paragraph with the paragraph text running around the graphic.
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 A. 

Graphic in the top corner of a paragraph

 B. 

Illustration in a column of text

 C. 

Margin art

 D. 

Small graphic in a line of text

If you want an illustration to stay at a specific place on the page—for example, as a logo on letterhead stationery—don’t use an anchored frame. Instead, draw, paste, or import the illustration directly onto a body or master page without placing an insertion point in the text. Then move the illustration to the desired position.

By default, an anchored frame has no pen or fill pattern, which makes it invisible on the page unless borders are visible.

6.3.2.                Create anchored frames

An anchored frame is created automatically when you paste or import a graphic at an insertion point. You can keep the properties assigned to the frame, or you can change them.

When you create an anchored frame using the Special > Anchored Frame command, you specify the location of the frame and its size and position. You can also specify other properties that depend on the frame’s position. For example, when the frame is placed in the line at the insertion point, you can specify its distance from the baseline of the text. When the frame is placed in a column of text, you can specify its alignment. You can change any of the prop­erties, including the frame’s position, at any time.

When you create an anchored frame, you can use Object Properties to set unique tags to your anchor. These tags simply create a structure for the layout of your document. You can uniquely define an element for your frame that maps to tags in PDF format.

When you tag your document, you name each document property. Using tags allows you to easily change the appearance of your document without changing the content.

Create an anchored frame automatically

1)            

Do one of the following:

 

•               Paste an object into text at the insertion point by cutting or copying the object, clicking in text where you want to insert the anchor symbol, and choosing Edit > Paste.

 

•               Import a graphic into text by clicking in text, choosing File > Import > File, and selecting the graphic file you want to import. You can also import a graphic in other ways, depending on the platform. (See Import and link methods.

 

The pasted or imported object appears in an anchored frame that is centered below the current line. After the frame is created, you can change its properties.

 

Create an anchored frame with specific options

1)            

Click in text where you want to place the anchor symbol and choose Special > Anchored Frame. You can create an anchored frame in a text frame or in a table cell, but not in a text line.

 

2)           Choose the frame’s anchoring position and specify its properties. The properties that appear in the Anchored Frame dialog box depend on the anchoring position.

 

3)           Click New Frame. An anchor symbol
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 appears at the insertion point when text symbols are visible.

 

6.3.3.                Inline anchored frames

To position an anchored frame in line with paragraph text—for example, to hold a small graphic such as a picture of a keycap—choose the At Insertion Point anchoring position in the Anchored Frame dialog box. When you put a space on either side of the anchored frame, the frame moves along from one line to another as you edit the document, as if it were a word (rather than being attached to the preceding or following word).

You can adjust the frame’s position up or down relative to the baseline of text by dragging the frame or by specifying a value for the Distance above Baseline option in the Anchored Frame dialog box. A value of zero aligns the bottom of the frame with the baseline of the text. A positive number moves the frame up; a negative number moves it down.

Zero distance and negative distance

[image: gr_af_02.png]

If the frame obscures text in the line above or below, turn off fixed line spacing to allow the line height to change with the contents of the line.

Fixed line spacing on and off

[image: gr_af_03.png]

tip:  To shrink an anchored frame to the dimensions of its contents and place it in the line at the anchor symbol, select the frame or an object in the frame and press Esc m p. To enlarge a frame and place it below the line that contains the anchor symbol, select the frame or an object in it and press Esc m e.

Related links:

Adjust horizontal spacing

Anchored frames in a column of text

To position an anchored frame in a column of text, choose the Below Current Line, At Top of Column, or At Bottom of Column anchoring position in the Anchored Frame dialog box.

Below current line and at top of column

[image: gr_af_04.png]

An anchored frame positioned at the top or bottom of the column moves only when its anchor symbol moves to another column.

important:   To place an anchored frame below a line that contains a run-in head, place the anchor symbol in the body paragraph, not in the run-in head. Otherwise, the anchored frame obscures the text below the run-in head. 

When you choose the Below Current Line, At Top of Column, or At Bottom of Column anchoring position, you can set the following properties.

Horizontal alignment

 

Choose the frame’s horizontal alignment from the Alignment pop-up menu. You can align the frame at the left, center, or right. In a double-sided document, you can also align the anchored frame closer to or farther from the binding edge.

 

Farther from binding
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Cropping

 

To prevent a wide frame from extending beyond the edge of the column, use the Cropped option.

Cropped off and on
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Floating

 

Use the Floating option to let the frame float to the next column that can hold it if the frame and its anchor symbol won’t fit in the same column.

 

Floating off and on
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When Floating is off, both the frame and anchor symbol move to the first column that can hold them. White space remains at the bottom of the column. When Floating is on, the anchor symbol doesn’t move, but the frame floats to the next column that can hold it. Text from the next column fills the space between the anchor symbol and the frame.

 

Anchored frames in multicolumn layouts

An anchored frame in a multicolumn text frame can straddle columns, and its position may be affected by straddle paragraphs.

In a straddle paragraph

 

When a frame is anchored in a straddle paragraph, the frame straddles columns just as the paragraph does.

Wider than a column

 

An uncropped anchored frame that extends into a second column of the body area straddles columns in the body area. A frame that extends into the side-head area straddles the side-head area as well.

 

Straddling side-head area and all columns, and straddling only columns
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A cropped anchored frame straddles columns only when it’s anchored in a straddle paragraph.

 

At top or bottom of column

 

When the anchor symbol for a top-of-column anchored frame appears below a straddle paragraph, the frame appears in the column just below the straddle paragraph rather than at the top of the column.

 

Anchored at top of column and at bottom

[image: gr_af_09.png]

 

A bottom-of-column anchored frame is positioned similarly when the anchor symbol appears above a straddle paragraph.

 

You can force the anchored frame to appear at the top or bottom of the column (above or below a straddle paragraph) by making the frame straddle the columns. To do so, turn off Cropped in the Anchored Frame dialog box and resize the anchored frame until it extends into another column.

Anchored frames outside a column of text

To position an anchored frame outside a column of text, choose the Outside Column anchoring position in the Anchored Frame dialog box. For informa­tion on positioning an anchored frame so it always appears in the page margin, even in a multicolumn document.

When you choose the Outside Column anchoring position, you can set the following properties.

Side of column

 

You can position the anchored frame at the left or right side of the column, or along the side that’s closer to or farther from the edge of the page.

 

Anchored at left and at right
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For a double-sided document, you can also position the frame closer to or farther from the binding edge.

 

Farther from binding
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Distance above baseline

 

You can adjust the frame’s position up and down relative to the baseline of text by dragging the frame or by specifying a value for the Distance above Baseline option in the Anchored Frame dialog box. A value of zero aligns the bottom of the frame with the baseline of the text. A positive number moves the frame up; a negative number moves it down.

 

Zero distance and negative distance above baseline
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You can’t position the anchored frame above the top or below the bottom of the text frame. If the setting would place the anchored frame above or below the text frame, FrameMaker puts it as high or as low as possible. If you later edit the text so that the anchor symbol moves away from the top or bottom of the text frame, FrameMaker adjusts the anchored frame’s position.

 

Distance from column

 

You can adjust the frame’s position left and right relative to the edge of the column by dragging the frame or by specifying a value for the Distance from Column option in the Anchored Frame dialog box. A value of zero aligns the edge of the frame with the edge of the column. A positive number moves the frame away from the column; a negative number moves it into the column.

 

Zero distance and positive distance from column
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The distance is always relative to the edge of the column, so the frame may appear between columns on a multicolumn page. You can change the page margins and column layout to widen the gap between columns to make room for the frame. Or, if you’re working in a structured document, see your developer to widen the gap between columns to make room for the frame.

 

Related links:

Change page margins and number of columns

Change margins and column layout on specific pages

Anchored frames in the page margins

To position an anchored frame so it always appears in the margin (even in a multicolumn layout), choose the Outside Text Frame anchoring position in the Anchored Frame dialog box. You can then specify the options described in the previous section. However, the distances you specify are from the edge of the text frame, which may differ from the edge of the text column on multicolumn pages.

Closer to page edge and farther from page edge
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In a single-column layout, the Outside Text Frame option has the same effect as the Outside Column option.

Anchored frames run into paragraph text

To position an anchored frame in the top corner of a paragraph (with the para­graph text in that column running around the frame), choose the Run into Para­graph anchoring position in the Anchored Frame dialog box. For example, you can set a small graphic or a drop cap at the beginning of a paragraph.

When the anchored frame is taller than the paragraph, the text from subsequent paragraphs runs around the frame unless the paragraph that contains the anchor symbol is a straddle paragraph.

Frame spanning paragraphs and in a straddle paragraph
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When you choose the Run into Paragraph anchoring position, you can set the following properties:

Alignment

 

You can align the anchored frame on the left or right side of the paragraph. For a double-sided document, you can also choose Side Closer to Binding or Side Farther from Binding.

 

Closer to binding
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The frame is aligned with the paragraph’s left indent when it appears at the left side of the paragraph, and with the right indent when it appears at the right side. When the paragraph has a first-line indent, the anchored frame does not change the position of the indent.

 

Graphic extending beyond first-line indent

[image: gr_af_17a.png]

 

Larger first-line indent
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When you want to preserve a first-line indent, make the first-line indent setting for the paragraph larger than the width of the anchored frame. Or, if you’re working with a structured document, see your developer about making the first-line indent setting for the paragraph larger than the width of the frame.

 

Gap

 

You can specify the gap between the anchored frame and the paragraph text that runs around it.

 

Related links:

Indentation, alignment, and spacing

Insert anchored frames in structured documents

In a structured document, a graphic element provides an anchored frame for holding graphic objects. The frame is anchored to a specific location in text. As you edit the text, the frame and its contents move in the document along with the text.

When inserting a graphic element, you specify where you want to anchor the element’s frame. For example, you might anchor the frame in a Para element (and the graphic will be a child element to the Para), or you might anchor it in a Section element (as a sibling to Para and other elements in the Section). It depends on how the elements are defined for your document. The formatting properties you set are independent of the element’s format rules, not overrides to them.

In the document window, an anchor symbol
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 appears at the anchor location in text when View > Text Symbols is turned on. The frame can appear in various positions on the page—including in-line with text, next to or below a paragraph, or in a page margin. You specify an anchoring position relative to the anchor symbol.

Several positions for anchored frames

[image: gr_af_31.png]

A graphic element appears in the document’s structure where it is anchored to text, regardless of the frame’s position on the page. In the Structure View, the element is represented by a square-cornered bubble with the snippet <GRAPHIC>.

Graphic element

[image: gr_af_32.png]

Insert an anchored frame element

1)            

Click where you want to anchor the frame.

 

2)           Select an anchored frame element in the Element Catalog and click Insert.

 

You can also use Special > Anchored Frame to insert an element. If more than one frame element is available, choose the one you want from the Element Tag pop-up menu in the Anchored Frame panel.

 

3)           Choose the frame’s anchoring position and specify its size and formatting properties. The properties that appear in the dialog box depend on the anchoring position you choose. See Inline anchored frames for details.

 

4)           Click New Frame. The anchored frame appears in the document window, with an anchor symbol
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 at the insertion point when View > Text Symbols is turned on. A bubble with the text snippet <GRAPHIC> appears in the Structure View.

 

If no anchored frame element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

Use an invalid anchored frame element

1)            

Do one of the following:

 

•               To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere, and then insert the element where you want it.

 

•               To insert an invalid anchored frame element with a default tag, choose Special > Anchored Frame, and choose GRAPHIC from the Element Tag pop-up menu. (This option appears in the menu if no defined frame elements are available.)

 

6.3.4.                Fill and edit anchored frames

You can draw graphics in an anchored frame, drag or paste graphics from another part of the document. Or, import or paste graphics from another docu­ment or application. Use these methods to place graphics and text in unan­chored graphic frames and in anchored frames.

You can position a graphic in an anchored frame and then use a text frame or text line inside the anchored frame for the figure title. However, you might find it easier to position and number the title consistently if you put the figure in a single-cell table and then set up the table title as a figure title.

An anchored frame’s contents are clipped when they extend into or beyond the frame’s border. Display the frames border by clicking it (if the border isn’t visible, choose View > Borders).
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 A. 

Frame border

 B. 

Cropped graphic

 C. 

Cropped callout

You can change the size of an anchored frame, its anchoring position, and the properties you set when you created the frame. When working with a structured document, these changes do not affect the structure of the document and are independent of the element’s format rules.

You can also manipulate anchored frames as you do other objects. For example, you can change a frame’s drawing properties (such as pen width), and you can duplicate, delete, move, or resize it.

Related links:

Add a title to an illustration

Add text to graphics

Draw objects

Resize and reshape objects

Flip and rotate objects

Move an object

Filling anchored frames in structured documents

In a structured document, you can draw graphics in an anchored frame, drag, or paste graphics from another part of the document, or import or paste graphics from another document or application. Although the graphic element is part of the document’s structure, the contents you put in the frame are not.

You can even use an anchored frame to hold text, such as text in a sidebar. To do this, draw a text frame in the anchored frame. Keep in mind, though, that the text is not part of the document’s structure.

A frame’s contents are preserved when you export to XML or SGML. FrameMaker writes the contents to a separate file and adds an entity reference to it from your XML or SGML file.

important:  To prepare for export to XML or SGML, put only one graphic in each frame for the best results. If your graphics are bitmaps, do not use a display bit depth of 1 bit or 24 bits; reset your display to 8 bits. Ask your application devel­oper for other advice to be sure your frames’ contents will be fully preserved.

After filling a frame with graphics, you can edit the graphics in many ways—for example, by changing line widths, applying fill colors, and aligning, stacking, or grouping several objects.

Put graphics or text in a graphic frame

1)            

Do one of the following:

 

•               To draw a graphic or add text, use one of the tools on the Tools panel.

important:  Be sure to start drawing the object inside the frame. Otherwise, the object is placed on the page and not in the frame.

 

•               To move a graphic into a frame, drag the graphic until the pointer is within the frame’s borders. The object jumps into the frame when you drag across the frame’s border.

 

•               To paste a graphic into a frame from the Clipboard, select the frame and choose Edit > Paste.

 

•               To import a graphic into a frame, select the frame and choose File > Import > File. You can also import a graphic in other ways, depending on the platform.

note:  If a graphic looks as though it’s in the anchored frame, but it doesn’t move with the frame as you edit the surrounding text, the graphic is prob­ably in front of the frame rather than in the frame—perhaps because you pasted it on the page rather than in the frame. Drag the graphic away from the frame and then drag it back into the frame.

 

Prevent an anchored frame from clipping its contents

1)            

Do one of the following:

 

•               If there’s room outside the anchored frame, make the frame larger.

•               If there’s room inside the anchored frame, move the object away from the edge of the frame.

 

•               If the contents are clipped only by the width of the border, use the Tools panel to make the anchored frame’s border narrower or to change the pen pattern to None (see Apply and change drawing properties).

 

•               If a frame and its contents are clipped by the edge of a column of text, choose Special > Anchored Frame, turn off Cropped, and then click Edit Frame.

 

Change a frame’s anchoring position and drawing properties

1)            

Select the frame and do one of the following: choose Special > Anchored Frame.

 

•               To change the frame’s anchoring position, choose Special > Anchored Frame. Change the settings and click Edit Frame.

 

•               To change the drawing properties, Select the frame and use the Tools panel to specify the properties you want. For example, you can change a frame’s pen pattern to make the frame’s border printable or change its fill pattern to shade the interior of the frame.

 

Resize an anchored frame

1)            

Do one of the following:

 

•               To resize the frame quickly but approximately, select the frame and drag one of its handles. The size appears in the status bar as you drag.

 

•               To resize the frame precisely, select the frame and specify its size with the Graphics > Object Properties, Graphics > Scale, or Special > Anchored Frame command.

 

•               To resize an anchored frame to fit the object in the frame, press Esc M P.

 

•               To resize a graphic within an anchored frame, select the object and drag one of its handles, or choose Graphics > Scale and enter the dimensions.

 

Copy, move, or delete an anchored frame

 

Copy or move an anchored frame by using copy and paste

 

1)           Select the frame and choose Edit > Copy or Edit > Cut. You don’t need to select the anchor symbol.

 

2)           Click in text where you want to insert the frame and choose Edit > Paste. The anchor symbol appears at the insertion point when text symbols are visible. When working with a structured document, look at the Element Catalog before pasting to verify that the location is valid for graphic elements.

 

In some cases (for example, when a frame is positioned at the top or bottom of a column), the frame does not change position even though the anchor symbol moves. If you find it difficult to reposition a frame anchored to the outside of a rotated text frame or column, unrotate the text frame, position the anchored frame, and then rerotate the text frame.

tip:  If you’re working with a structured document, you can also drag a frame’s bubble in the Structure View to move the frame or Alt-drag the bubble to copy the frame.

 

Move an anchored frame without moving its anchor symbol

 

1)           Do one of the following:

 

•               For quick but approximate repositioning, drag the frame.

 

•               For more precise repositioning, move the frame in small increments with the arrow keys.

 

•               For greatest precision, specify the location of the frame with the Special > Anchored Frame command.

 

Some anchored frames cannot be moved without moving their anchor symbols. However, you can move a frame vertically when it’s anchored at the insertion point, outside the column of text, or outside the text frame. When a frame is anchored outside the column or text frame, you can’t move it above the top or below the bottom of the text frame.

 

note:  When you move a frame into a column, the text in the column doesn’t adjust to accommodate the frame. Use the Run into Paragraph anchoring position to move the frame completely inside the column and to run the text around the frame automatically. You can also change the para­graph indents to make room for the frame.

 

Move a frame’s anchor symbol

 

1)           Select the frame. You don’t need to select the anchor symbol.

 

2)           Choose Edit > Cut, click in text where you want to insert the anchor symbol, and choose Edit > Paste. The anchor symbol appears at the inser­tion point when text symbols are visible.

 

In some cases—for example, when the frame is positioned at the top or bottom of a column of text—the frame may not change position even though the anchor symbol moves.

 

Delete an anchored frame

 

1)           Select the frame and press Delete.

Add object attributes for tagged PDF

 

If you plan to export your document to a tagged PDF or to XML, you can include object attribute information for your anchored frames.

Alt text is different from graphics or standard text. Alt text is typically used for describing an image so that screen readers can read it aloud. Actual text is for reading aloud the actual text, as in the case of a drop cap. For example, if the author is using a drop cap for the letter A in the word “Adobe” but still wants the screen readers to read the word as “Adobe” and not as “dobe,” this can be done by filling in actual text. The attribute will be saved to alt text and actual text in tagged PDF and XML.

When you provide alternate text attribute on an anchored frame, the corre­sponding figure elements in PDF and graphic elements in XML get an “alt text” attribute. Actual Text attribute is processed only for tagged PDF. XML export ignores this attribute.

note:  Object attributes support the Unicode text encoding standard.

1)            

Select the frame and choose Graphics > Object Properties.

 

2)           Click Object Attributes.

 

3)           In the Text Attributes section, add your alt text and actual text, and then click Set.

 

note:  Screen readers may ignore actual text when alt text is present.

6.4.                   Hotspots

A hotspot is an active area in a document that you can link to different areas of the document, to another document, or to a URL. You can apply hotspots to the following objects:

1)            

Graphic objects

 

2)           Images

 

3)           Anchored frame

 

4)           Graphics frame

 

5)           Text frame

 

6)           Text line

 

7)           Equations

 

FrameMaker supports the following shapes for hotspots:

1)            

Line

 

2)           Arc

 

3)           Polyline

 

4)           Freehand curve

 

5)           Rectangle

 

6)           Rounded rectangle

 

7)           Oval

 

8)           Polygon

 

You can create hotspots in graphic objects and link them to textual objects in the same or other documents. You can superimpose an invisible hotspot over an image to link to any relevant text or detail in the document.

With hotspots, you can add multiple links in different parts of a graphic without having to divide the graphic into separate parts. For example, in a world map, you can create hotspots in each of the countries linking to more information about that country within a document, in other documents, or at a web address.

Hotspots in a graphic

 

Hotspots are supported everywhere in the FrameMaker documents, including the master pages. A use case for hotspots on master page is a clickable logo for every page of the document that takes the user to a URL.

Hotspots look like other graphic objects. In edit mode, you can select the hotspots and edit the hotspot properties. In view mode, when you hover the mouse over the hotspot, the cursor changes to indicate active, clickable area.

You can link a hotspot in one document to another. PDFs support only rectan­gular hotspots. Hotspots of any other shape are converted to rectangular hotspots when you create the PDFs. Other outputs, such as HTML support hotspots of other shapes such as oval. If you want to scale, rotate, and translate hotspots with the anchor frame, group the hotspots with the anchor frame. While saving XML, FrameMaker saves the graphic containing the hotspots in a MIF file. While opening the XML file again, FrameMaker brings back the hotspot information into the FrameMaker file from the MIF file. Some other output types that support hotspots are: HTML, Webhelp, FlashHelp, Airhelp, and Multiscreen output.

The hotspot pod displays the available hotspots in a document or all open docu­ments. Using the hotspots pod, you can edit/delete/delink the existing hotspots.

6.4.1.                Create hotspots using hotspot properties

1)            

Insert a hypertext marker of type Named Destination. Apart from a Named Destination marker, you can link hotspots to URLs.

 

2)           Right-click an object and in the pop-up menu, select Hotspot Properties.

3)           In the Create Hotspot dialog, do one of the following:

 

a)           Specify the target document for the link. FrameMaker displays the available markers (Specify Named Destination command instance) in the selected document. Select the appropriate instance.

 

b)           Enter the target URL. The URL length is limited to 1011 bytes. 1011 bytes can contain 1011 single-byte characters, such as for English, or 506 double-byte characters, such as for Greek.

4)           Specify a tool tip. Maximum tool tip length is 1023 bytes. 1023 bytes can contain 1023 single-byte characters, such as for English, or 511 double-byte characters, such as for Greek. Tool tip is optional.

 

5)           Click Save.

 

You can now test the link by holding Ctrl+Alt keys and clicking the hotspot. You can generate PDF or other outputs.

 

6.4.2.                Create hotspots using graphics toolbar

1)           In the Graphics toolbar, click HotSpot Mode (

[image: nf_HotSpot_Mode.png]

).

 

2)           Create any graphics object.

 

FrameMaker launches the Hotspot dialog.

 

3)           In the HotSpot dialog, do one of the following:

 

a)           Specify the target document for the link. FrameMaker displays the available markers (Specify Named Destination command instance) in the selected document. Select the appropriate instance.

 

b)           Enter the target URL. The URL length is limited to 1011 bytes. 1011 bytes can contain 1011 single-byte characters, such as for English, or 506 double-byte characters, such as for Greek.

4)           Specify a tool tip. Maximum tool tip length is 1023 bytes. 1023 bytes can contain 1023 single-byte characters, such as for English, or 511 double-byte characters, such as for Greek. Tool tip is optional.

 

5)           Click Save.

 

You can now test the link by holding Ctrl+Alt keys and clicking the hotspot. You can generate PDF or other outputs.

 

6.4.3.                Delink a hotspot

You can delink a hotspot to remove the hotspot information from graphic object.

•                

In the Hotspot pod, select the hotspot entry and click Delink.

 

Or

 

Select a hotspot and then from the Graphics menu, select Delink Hotspot.

 

Or

 

Right click a hotspot and then from the pop-up menu select Delink Hotspot.

 

6.4.4.                Create hotspots in vector graphics

You can create multiple hotspots in vector graphics, such as a CGM file, imported in a FrameMaker document. The various parts of the CGM graphic can be made different hotspots.

6.5.                   Object Styles

You can save your frequently used object properties as a style. You can apply these object styles to various objects, such as images, anchored frames, and text frames for consistent size and appearance. For example, you can create and apply an object style to all the anchored frames in a document, or across docu­ments, to make them of the same size.

Object styles include the following properties:

•                

Position and size (width, height, top, left, and angle)

 

•               Fill (fill pattern, tint, and color)

 

•               Stroke (line and arrow style, line width, pen pattern)

•               Text line (alignment)

•               Text frame (flow properties and column properties)

 

•               Anchored frame (anchoring position and related properties)

 

•               Graphics (scaling and resolution)

 

•               Equation (alignment, size, and automatic line breaks)

 

•               Runaround type and width

 

Object styles are relevant for the following objects in FrameMaker:

•                

Images

 

•               Anchored frame

 

•               Graphic objects

 

•               Text frame

 

•               Text line

 

•               Equations

 

6.5.1.                Object style designer
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A.

List of object properties

B.

Reset all properties to default

C.

Refresh object style properties

D.

Select an object style name

E.

Update all

F.

Apply

 

6.5.2.                Object style catalog

 

[image: gr_object_catalog.png]

 

A.

Object style names

B.

Check mark indicates that style is applied in the current document

C.

Delete a style from the document

D.

Options to display the styles in the catalog

E.

Refresh the list of styles displayed in the catalog

6.5.3.                Create an object style

1)            

Select Graphics > Object style designer.

 

Object Designer appears with all the property values blank.

 

2)           In the Object Designer Dialog, type a name for the object style.

 

3)           Edit the property values and click Save.

 

6.5.4.                Create an object style from an object’s properties

1)            

Select the object based on which you want to create an object style.

 

2)           Select Graphics > Object Style Designer.

 

Object Style Designer displays the properties relevant to the selected object and populates the values of these properties from the selected object.

3)           In the Object Designer Dialog, type a name for the object style.

 

4)           Edit the property values, if necessary, and click Save.

 

6.5.5.                Apply an object style

 

1)            

Select Graphics > Object Style Catalog.

 

2)           Select one or more objects on which you want to apply the style.

 

3)           In the Object Style Catalog, click the name of an object style to apply.

 

6.5.6.                Import object formats from another document

 

1)            

Select File > Import > Formats.

 

2)           In the Import Formats dialog, select Object Styles.

 

3)           Select Import.

 

6.6.                   Using RoboScreenCapture

RoboScreenCapture is a screen capture tool that can be used for capturing and editing images. You can use these images in your help systems like online tuto­rials, manuals, training handouts, presentations, marketing materials, and web pages.

Integration of FrameMaker with RoboScreenCapture helps you do the following:

•                

Open RoboScreenCapture from FrameMaker.

 

•               Insert images created in RoboScreenCapture into FrameMaker.

 

•               Edit images imported by reference into FrameMaker using RoboScreen­Capture. You can use the right-click option Edit with RoboScreenCapture for an image to launch and edit the image in RoboScreenCapture.

 

Changes made to the image are reflected in FrameMaker after the image is saved and closed in RoboScreenCapture.

note:  This option is available only for image formats supported by RoboScreen­Capture.

You can use RoboScreen Capture to perform the following tasks:

•                

Capture screens in 10 modes, including Adobe FreeHand, Virtual Screen, and Multi-Region

 

•               Capture screens using a drop-down menu, assign your own keyboard shortcuts, and even control RoboScreenCapture with voice commands

 

•               Capture difficult-to-grab screens such as DirectX, Direct3D, 3Dfx, Voodoo, and Glide mode games

 

•               Capture more than is visible on the screen, such as long Web pages

 

•               Edit images

 

•               Save your screen capture in over 20 image formats

 

•               Automatically save screen captures to image files

 

•               Quickly add image stamps, frames, drop shadows, and more

 

•               Change image colors, flip or rotate images, and crop images to a smaller size

 

•               Add identifying stamps to each screen capture, such as a company name or logo

 

•               Call-out specific areas of your capture with shapes, shadow effects, and more.

 

6.6.1.                Capturing and inserting images

You can use RoboScreenCapture from FrameMaker to capture a screenshot from an application running on your computer, and save it in RoboScreenCap­ture. You can then import the file into an open FrameMaker document.

1)            

Open the FrameMaker document into which you want to insert images.

 

2)           Select File > Launch RoboScreenCapture. The RoboScreenCapture appli­cation opens.

 

3)           From RoboScreenCapture, capture a screenshot of the desired application using the various options in the Capture menu.

 

4)           Save the file, and close RoboScreenCapture.

 

5)           In Adobe FrameMaker, select File > Import > File. The Import dialog box appears.

 

6)           Select the file created in RoboScreenCapture.

 

7)           Select Import by Reference from the Import dialog box.

 

8)           Click Import.

 

6.6.2.                Editing imported images

You can use RoboScreenCapture to edit images inserted by reference into FrameMaker documents.

1)            

Open FrameMaker.

 

2)           Select File > Open, and open a document with the image you want to edit.

 

3)           Select the image you want to edit.

 

4)           Right-click the image, and select Edit With RoboScreenCapture. The RoboScreenCapture application opens with the image open for editing.

 

5)           Edit the image.

 

6)           Select File > Save.

 

7)           Select File > Exit to close the RoboScreenCapture application.

 

The edited image is updated in FrameMaker and is ready for use in the docu­ment.

6.7.                   Editing images with Adobe Illustrator

FrameMaker allows you to edit imported graphics with Adobe Illustrator.

 note:  Adobe Illustrator should be installed on the same system as Adobe FrameMaker for this feature to work. 

•               Open FrameMaker.

 

•               Select File > Open, and open a document with the image you want to edit.

 

•               Select the image you want to edit.

 

•               Right-click the image, and select Edit With Illustrator. The Illustrator application opens with the image open for editing.note:  The image types that can be edited with Illustrator are as follows: 



	
File Type

 


	
Saved Directly or Exported?

 





	
EPS

 


	
Saved Directly. Select File > Save from Illustrator to save the file.

 





	
AI

 





	
AIT

 





	
SVG

 





	
PNG

 


	
Export the file from Illustrator. Select File > Export from Illustrator and select the right file type and save.

 

 

 

 

 

 

 

 





	
BMP

 





	
DXF

 





	
EMF

 





	
JPG

 





	
PSD

 





	
PCT

 





	
TIF

 





	
WMF

 






•               Edit the image.

 

•               Select File > Save or File > Export (depending on the image type) to save the edited image.

 

•               Select File > Exit to close the Illustrator application.

 

The edited image is updated in FrameMaker and is ready for use in the docu­ment.




7.                        Dynamic Documents

 

7.1.                   Markers

FrameMaker markers provide you multiple ways in which you can mark your documents. You can choose from pre-defined markers, such as Author, Comment, Conditional Text, ContextString, Cross-Ref, Equation, Glossary; or create custom markers.

The Markers pod makes it easier to work with and troubleshoot hundreds of markers in a long document or book files. You can display all the markers in the current document, all open documents, selected file, or a book.

7.1.1.                Add a marker

For example, to add a marker of Comment type:

1)            

Place the cursor in the document where you want to insert a comment.

 

2)           Choose View > Pods > Markers to display the Markers pod if not already open.

 

3)           Click the Insert icon.

 

4)           Choose Comment from the Marker type box.

 

5)           Type your comment in the Marker Text text box and click New Marker.

 

6)           Save document.

 

note:  You can enter a tab character in marker text by typing either \t or the hexa­decimal code \x08. However, if you generate a list of markers, only tabs entered as hexadecimal codes appear. If you generate an index of markers, only tabs entered as \t appear.

To add a marker to a structured document:

1)            

Choose Special > Marker.

 

2)           Select a marker element in the Element Catalog and click Insert.

 

3)           Choose a marker type from the pop-up menu. You can use any predefined marker type except Conditional Text. You can also define your own marker types.

 

note:  For structured documents, consult your developer before changing a marker type. Your document may have a separate element defined for each marker type you’ll need.

 

4)           If the Attributes for New Element dialog box appears, enter attribute values for the marker element and click Insert Element.

If no marker element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

 

7.1.2.                Generate a list of markers

For example, to generate a list of all your Comment markers:

1)            

Select Special > List Of > Markers to display the Set Up List of Markers dialog box.

 

2)           Select the Comment marker type from the right pop-up menu and click the left arrow to transfer it into the Include Markers of Type list on the left.

 

3)           Check the Create Hypertext links checkbox.

 

4)           Click the Set button. All your Comment type markers are listed in a sepa­rate window.

 

7.1.3.                Delete a marker

1)            

Select the marker from the Markers pod and click the Delete icon. The marker is deleted from the document.

7.1.4.                Create a custom marker

You can also define custom markers for single-sourcing or automation. For example, you can use custom markers to mark text that can be extracted into a separate reference guide. You can mark graphic objects that require special processing, such as conversion from one format to another. You can then use a script to automatically extract all those graphics marked with the custom marker for further processing.

1)           Choose View > Pods > Markers.

 

2)           Click the Insert Icon.

 

3)           From the Marker Type combo box, select Edit.

 

4)           Type a name for the custom marker in the Edit Custom Marker Type box.

 

5)           Click Add and click Done. The new Marker type is added to the list of markers.

7.1.5.                Add a custom marker to your document

1)            

From the Markers pod, click Insert.

 

2)           Select the custom marker type.

3)           Type the marker text and click New Marker. A custom marker gets added to your document.

 

7.2.                   Hypertext and view-only documents

 

7.2.1.                Distributing hypertext documents

You can distribute hypertext documents online as part of an online system. Readers can page through the contents sequentially or explore at random, following the links you provide. Create a simple online system from documents that you print (including a table of contents and index that contain hypertext links). Create a more elaborate online environment that contains extensive navigation aids such as document maps and navigation buttons.

When you set up an online system, you create a series of hypertext documents. In each document, you designate active areas. An active area contains a hyper­text command that instructs FrameMaker how to respond when a reader clicks it.

For example, readers click in a list to learn about a specific item, click part of a graphic for a more detailed drawing of that part, or click in an index for infor­mation about the indexed term. They can choose a topic from a pop-up menu, or click buttons to navigate through a document.

When creating documents for online distribution, follow these guidelines:

•                

Write several short documents rather than one long one. A long docu­ment takes longer to open.

 

•               Keep all the documents that make up the system together in one folder. A single folder filename specifications for imported graphics and for hyper­text commands.

 

•               To distribute the documents as FrameMaker files, use fonts that are readily available. Perhaps use fonts such as Times and Helvetica because these fonts are available on most computers and on all PostScript printers.

 

You can save a hypertext document in Portable Document Format (PDF) or in Hypertext Markup Language (HTML) for distribution on the World Wide Web or on an intranet.

You can also distribute your hypertext documents to readers in View Only 9.0 format. Readers can use FrameMaker to open, read, search, and print such documents and they can use the embedded hypertext links. They can’t edit the documents, however.

Related links:

Generating HTML

Generating PDFs

7.2.2.                View-only documents and books

You distribute online documents and books in View Only format. Readers can view, search, copy, and print—but not edit—a view-only document or book using FrameMaker.

tip:  Readers see the contents of a view-only document exactly as it appeared when you made it view-only. Before changing a document to View Only format, use the View menu to turn off the display of the grid, the ruler, text symbols, and borders. To display a view-only document without the menu bar or scroll bars, see the online manual MIF Reference.

Save a document in View Only format

1)            

Choose File > Save As.

 

2)           Specify View Only format and click Save.

 

 

tip:  To switch several documents between View Only format and Document format, select the files in the book and press Esc Shift+f l (lowercase L) k. Choose the option, and click Continue. 

Save a book in View Only format

1)            

In the book window, choose File > Save Book As.

 

2)           Specify View Only format and click Save.

 

When a view-only book is open, you can click
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 and
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 to toggle between displaying filenames and text.

Change a document to View Only format without saving it

1)            

Choose Special > Hypertext and click Make View-Only.

 

Change a view-only document to Document format

1)            

Do one of the following:

 

•               If the Hypertext panel is open, click Make Editable.

 

•               Press Esc Shift+f l (lowercase L) k. This keystroke also works for a book.

 

Make a view-only book editable or an editable book view-only

1)            

In the book window, select any documents that you want to change from view-only to Document format.

 

2)           Press Esc Shift+f l (lowercase L) k.

 

3)           To make the selected files editable, click the option. To make the selected files view-only, deselect the option.

 

4)           Click Continue.

 

Navigate to specific pages in view-only documents

You can display pages in view-only documents by following links in the docu­ments, by using controls in the document window, or by using menu commands.

1)            

Do one of the following:

 

•               Click any active area whose hypertext command jumps to a different location.

 

•               Click the page buttons in the status bar.

 

•               Use the scroll bar or the Page Up and Page Down keys.

 

•               Use the commands on the Navigation menu.

 

•               Right-click anywhere in the document window and choose a command from the context menu.

 

If you customized your view-only window environment as described in the online manual MIF Reference, sometimes some viewing methods are not available.

Jump backward or forward to links

 

You can jump back to previous links and then jump forward again. Press Esc+V, Shift+N to jump forward. You can jump forward only if you have previously jumped backward.

1)            

Do one of the following to jump backward:

 

•               Click an active area with a Jump Back or Jump Back & Fit to Page command.

 

•               Choose Navigation > Go Back.

 

•               Right-click anywhere in the document window and choose Go Back from the context menu.

 

Open a new window

If a link is set to display a document in the active window, you can force FrameMaker to open a new window instead.

1)           Shift-click an active area. FrameMaker doesn’t open a new window unless the link is to a different document.

 

Menu commands available in view-only documents

Some FrameMaker commands are available in view-only documents. For example, copy text and graphics from a view-only document and paste them in an editable document, search for text and paragraph tags, and print.

View-only document windows use four FrameMaker menus: File, Edit, Naviga­tion, and Window. To use some menu commands, place an insertion point. For other menu commands, such as Edit > Copy, select items. View-only book windows use three FrameMaker menus: File, Edit, and Windows.

If you customize your view-only window environment, sometimes commands are not available.

7.2.3.                Set up hypertext active areas

A reader navigates through a hypertext system by clicking active areas. An active area can be a range of text, a graphic, or a part of a graphic containing hypertext commands. You can set up active areas on body pages. You can also set them up on master pages so they appear in the same location on all body pages. For example, you can set up navigational buttons on master pages. When a reader clicks an active area, the hypertext command of the area is executed.

Related links:

Hypertext commands

Prepare text areas

A text area can be a word, a phrase, or an entire paragraph. If the reader clicks in a text area that contains a hypertext command, FrameMaker finds the hyper­text command, highlights the area, and performs the command.

1)            

Do one of the following:

 

•               To designate a word or a phrase as an active area, select the text and change its character format. Changing the character format defines the boundaries of the text area. Most formatting differences are recognized. Only pair kerning, spread, stretch, change bars, language, and case are ignored.

 

tip:  To designate a word or phrase as an active area without changing its appearance, use a character format that sets all properties to As Is.

 

•               To designate an entire paragraph as an active area, make sure that the paragraph contains no character format changes. If the para­graph contains only one hypertext command and no character format changes, FrameMaker highlights the entire paragraph. It then performs the command when a reader clicks anywhere in the paragraph.

 

•               To designate several adjacent words or phrases in a text string as active areas, use the same character format for the entire text string. Then insert the various hypertext commands. FrameMaker divides the text into active areas based on the locations of the markers. When a reader clicks in the text, FrameMaker determines the active area and executes the correct hypertext command.

 

Markers divide text into active areas.
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Highlighting markers in view-only documents

 

When you click an active area in a view-only document, FrameMaker doesn’t usually select the cross-reference marker or the hypertext marker that identifies the linked information. (If the document is in FrameMaker Document format, the marker is selected.) You can use MIF to specify that the markers are selected.

Prepare graphics

Graphics provide visual cues for hypertext actions. Readers can click an icon to display information on a topic, or an arrow to display the next page.

An active area over a graphic can contain a hypertext command that jumps to another location. It can also contain a command that divides the graphic into a matrix of hypertext commands.

note:  If you’re preparing documents for distribution in HTML, use active areas over anchored graphics to create image maps. Unanchored graphics on master and body pages aren’t converted to HTML.

1)            

Draw a text frame that covers the entire graphic you want to make active. Later, you place a hypertext command in the text frame.

 

Make sure that the graphic is not set to have text run around it.

 

2)           Set the text frame fill and pen patterns to None. This action makes the text frame transparent so that readers see the graphic behind the frame.

 

3)           Choose Graphics > Bring To Front to place the text frame in front of the graphic, if it isn’t already there. Unless you placed the graphic on the page after drawing the text frame, the text frame is already in front of the graphic.

 

Prepare the same area on multiple pages

You can create an area that appears in the same location on more than one page. Set up the area on a master page and insert the hypertext command there. For example, you can create buttons on master pages that readers can click body pages to display the next or previous page.

Navigation buttons on master page appear on body pages.
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You can override active master page graphics on individual body pages if you want to send the reader somewhere else. For example, create a Next Page button with an override on the last body page of each document because the document has no more next pages to display.

Have an active area appear on more than one page

 

1)            

Set up the area on a master page rather than on a body page. The active area appears in the background of corresponding body pages. When the reader clicks that area on a body page, the hypertext command on the master page is activated.

When you draw the text frame on a master page, FrameMaker asks whether you want to create a template frame or a background frame. Place text frames for active areas in background (untagged) text frames.

 

Override a master page command on an individual body page

1)            

Do one of the following:

 

•               Place a graphic or a different hypertext command over the area on the body page. For example, you can create an inactive, shaded button covering the Next Page button on the last body page of each document.

 

Graphics on body pages can override master page commands.
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•               Place a text frame that contains its own hypertext command over the graphic on the body page.

 

 

Related links:

Add text to graphics

Run text around graphics

7.3.                   Hypertext commands

Hypertext commands let your readers navigate through the view-only docu­ments. If you’re distributing the documents in View Only 9.0 format, hypertext commands can also display alerts, close documents, exit FrameMaker, and start other applications.

Many hypertext commands can contain a path. In a path, a slash (/) separates folder levels.

If your hypertext documents are used on several platforms, use filenames that are valid on all the platforms.

note:  A hypertext command that contains a single-character filename some­times does not work.

 

Relative path

 

FrameMaker searches for a relative path beginning in the folder that contains the current document. To go up one folder level, use two periods (..). For example, suppose a hypertext command refers to a document named Trombone that is stored in a folder named Brass. If the Brass folder is in the same folder as the current document, use the path Brass/Trom­bone.

If the Brass folder is at the same level as the folder that contains the current document, use ../Brass/Trombone.

 

Absolute path

 

FrameMaker searches for an absolute path beginning at the top of the file system. The absolute path begins with the drive letter specifier, a colon, and a slash.

For example, suppose a hypertext command refers to a document named Trombone in a folder named Brass. If the Brass folder is at the top level of drive letter E, use the path E:/Brass/Trombone.

Absolute paths are not recognized across platforms, so always use relative paths if your hypertext documents are viewed on multiple platforms.

 

7.3.1.                Insert, edit, and delete hypertext commands

You use a marker to insert a hypertext command in a prepared area. After you insert a command and save the document in View Only format, the area becomes active. When a reader clicks an active area, FrameMaker highlights the area and executes the command.

Hypertext command marker
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After inserting a hypertext command, you can test the command without saving the document in View Only format.

note:  To insert a hypertext command in a text inset, insert the command in the text inset source document.

 

Insert a hypertext command

 

1)           Click in a prepared area where you want to insert a hypertext command. You can insert hypertext commands in text frames but not in text lines (graphic objects created with the Text Line drawing tool). To prevent extra spacing in the hypertext command when exporting, insert your markers at the beginning or end of a word.

 

2)           Choose Special > Hypertext and select a hypertext command from the Command pop-up menu. The syntax for the command appears below the pop-up menu, and the command name appears in the box.

3)           Enter parameters in the box as needed (for example, a filename and linkname).

Hypertext commands must always appear in lowercase. The parameters can be uppercase or lowercase, but they are case-sensitive. The entire command can be up to 255 characters long. (Each character in a Japanese font counts as two characters.)

 

note:  If you enter a filename parameter for a file that isn’t in the same folder as the current document, specify a path to the document.

 

4)           If you want FrameMaker to validate the command when you insert it, select Validate Command upon Insertion.

 

5)           Click New Hypertext Marker. FrameMaker checks the syntax in the box. If Validate Command upon Insertion is selected, FrameMaker also vali­dates the command. For example, FrameMaker validates a Jump to Named Destination command by verifying that the destination link exists in the specified document.

If FrameMaker finds an error, an alert message describes it, but the command is still inserted in a marker of type Hypertext. A marker symbol
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 appears at the insertion point when text symbols are visible.

note:  Hypertext markers support the Unicode text encoding standard.

 

Edit a hypertext command

 

1)           If the document is in View Only format, do one of the following to change it to Document format:

 

•               If the Hypertext panel is open, click Make Editable.

 

•               Press Esc Shift+f l (lowercase L) k.

 

2)           Choose Special > Hypertext if the Hypertext panel isn’t open.

3)           Select the marker that contains the command you want to edit. To select a marker in an otherwise empty text frame, double-click anywhere in the frame. You can also use the Find command to find and select hypertext markers. The hypertext command appears in the Hypertext panel.

tip:  If no other markers appear near the marker you want to edit, drag through the marker to display its hypertext command in the Hypertext panel.

 

4)           Edit the command in the box, and click Edit Hypertext Marker. Even if text around the marker is selected, only the command in the marker is affected.

 

5)           If you want to return the document to View Only format, do one of the following:

 

•               Click Make View Only in the Hypertext panel.

 

•               Press Esc Shift+f l (lowercase L) k.

 

Delete a hypertext command

 

1)           Select the marker that contains the command and press Delete. To select a marker in an otherwise empty text frame, double-click anywhere in the frame. You can also use the Find command to find and select hypertext markers.

7.3.2.                Hypertext commands supported in FrameMaker

FrameMaker supports the following hypertext commands.

Alert

 

Displays an alert message.

 

Alert With Title

 

Displays an alert message with a user-defined title.

 

Specify Named Destination

 

Marks the location that is displayed when either a Jump to Named Desti­nation or an Open Document command is executed

 

Jump To Named Destination

 

Displays the location in the current or a different document that contains a corresponding destination link). The page is displayed in the active window.

Jump To Named Destination & Fit To Page

 

Displays the location in the current or a different document that contains a corresponding destination link. Then resizes the window to fit the docu­ment page displayed.

Jump To First Page

 

Displays the first page of the current or a different document. The page is displayed in the active window.

 

Jump To Last Page

 

Displays the last page of the current or a different document. The page is displayed in the active window.

 

Go To URL

 

Launches browser and displays the specified web page.

Jump To Page Number

 

Displays a specific page in the current or a different document. The page is displayed in the active window.

 

Jump To Previous Page

 

Displays the previous page of the current document. The page is displayed in the active window.

 

Jump To Next Page

 

Displays the next page of the current document. The page is displayed in the active window.

 

Jump Back

 

Displays the last location the reader viewed. The page is displayed in the active window.

 

Jump Back & Fit To Page

 

Displays the last location the reader viewed and then resizes the window to fit the document page displayed.

 

Open Document

 

Displays the page that contains the corresponding Specify Named Desti­nation command. The page appears in a new window (leaving the active window open) only if the page is in a different document.

Open Document & Fit To Page

 

Displays the page that contains the corresponding Specify Named Desti­nation command and then resizes the new window to fit the document page displayed. The page appears in a new window (leaving the active window open) only if the page is in a different document.

Open Document As New

 

Opens a document as a new, unnamed document. The document displays in a new window, leaving the active window open.

 

Open Document At First/Last Page

 

Displays the first or last page. The page appears in a new window (leaving the active window open) only if the page is in a different document.

Open Document At Page Number

 

Displays a specific page. The page appears in a new window (leaving the active window open) only if the page is in a different document.

 

Pop-up menu

 

Displays a pop-up menu of items, each containing a hypertext command.

 

Button Matrix

 

Allows the user to choose from a matrix of items that execute hypertext commands.

 

Message Client

 

Communicates with other applications. Also creates a link to a URL on the World Wide Web or an intranet for use in documents that are later converted to HTML.

 

Close Current Window

 

Removes the active window from the screen.

 

Close All Hypertext Windows

 

Removes all view-only windows from the screen.

 

Exit Application

 

Exits the FrameMaker application.

 

7.3.3.                Create a button matrix

You can create a button matrix of equal-sized cells that correspond to hypertext commands. When a reader clicks a cell in a hypertext document, FrameMaker highlights the cell and executes the corresponding hypertext command. For example, the button matrix could be a group of musical instruments.

A button matrix with three cells
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If the reader clicks one of the instruments, FrameMaker highlights the area around the instrument and executes the corresponding hypertext command.

Possible contents for text frame on reference page
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note:  You can use the Hypertext panel as an aid in identifying the syntax of the commands to type. Type the commands directly in the text frame. Don’t use the Hypertext panel to insert a hypertext marker.

1)            

Place the graphic in your document. Choose an appropriate graphic for setting up a matrix of equal-sized cells.

 

2)           Prepare the graphic to be an active area by drawing a single text frame around the entire graphic.

 

3)           Click in the text frame to place the insertion point.

 

4)           Insert a Button Matrix command in the text frame (leaving the frame otherwise empty). This command uses the following syntax:

 

   matrix rows columns flowname                  

In this example, rows and columns are the numbers of rows and columns in the matrix, and flowname is the flow tag of a text frame you’ll create on a reference page. The flowname cannot contain embedded spaces.

For the example shown earlier, with two rows and three columns, and with the corresponding hypertext commands in a reference page text frame whose flow tag is InstrumentTypes, the command would be as follows:

 

   matrix 1 3 InstrumentTypes

5)           Draw a text frame on a reference page and assign a flow tag that matches the flowname in the Button Matrix command.

6)           Click in the text frame to place the insertion point, and then type one hypertext command in each paragraph in the text frame. The commands correspond to the items in the first row of the matrix, from left to right, followed by the second row, and so on. Each command must fit on one line. You can resize the text frame if necessary.

 

Related links:

Control the flow of text

7.3.4.                Create pop-up menus

Your hypertext document can display a pop-up menu from which readers can choose an item that links to related information. The pop-up menu can, in turn, contain one level of submenus.

Hypertext pop-up menu and submenu
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Create a pop-up menu of hypertext commands

 

1)           Create the graphic button that the reader clicks to display the pop-up menu.

 

2)           Prepare the graphic to be an active area by drawing a single text frame around the entire graphic.

 

3)           Insert a Pop-up Menu command in the text frame (leaving the frame otherwise empty). This command uses the following syntax:

 

   popup flowname                     

In this example, flowname is the flow tag of a text frame you’ll create on a reference page. The flowname cannot contain embedded spaces.

 

4)           Draw a text frame on a reference page and assign a flow tag that matches the flowname in the Pop-up Menu command.

 

5)           Click in the text frame to place the insertion point, type the menu name in the flow, and press Return. (The first item in the text frame is always considered the title of the pop-up menu.)

6)           Type a menu item in each subsequent paragraph. The contents of each paragraph appears as a command in the pop-up menu. If necessary, widen the text frame so that each item fits on a single line.

 

7)           Insert a hypertext command in each line except the line that contains the menu name. For example, you can use a Jump to Named Destination command to display related information. You can use an Alert command to provide a short message to your readers or a Pop-up Menu command to display a submenu of items.

 

Text frame for sample hypertext pop-up menu
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note:  You cannot open the pop-up menu until you insert at least one hypertext marker on the reference page.

Create a pop-up submenu of hypertext commands

 

1)           Locate the text frame on the reference page that describes the pop-up menu for which you want to create a submenu.

 

2)           Insert a Popup Menu command in the line for which you want the submenu to appear. This command uses the following syntax:

 

   popup flowname                     

In this example, flowname is the flow tag of a text frame you’ll create on a reference page. The flowname cannot contain embedded spaces.

 

3)           Create the submenu. Don’t use a Popup Menu command in the submenu, because you can’t create a submenu within a submenu.

 

Text frame for sample hypertext pop-up submenu
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Related links:

Create hypertext links

Add text to graphics

Control the flow of text

7.3.5.                Create alert messages

You can create a hypertext command to display an alert message that contains a title and a message. If you don’t specify a title in the command, the alert message contains the default title “FrameMaker—Alert”. 

You can also specify a default title for all hypertext alert messages in a docu­ment.

Create an alert message

 

1)           Insert one of the following hypertext commands:

 

•               To display a hypertext alert message with the default title, insert an Alert command. This command uses the following syntax:

 

   alert message                           

•               To display an alert message with a title other than the default, insert an Alert with Title command. This command uses the following syntax:

 

   alerttitle title :message                           

In this example, title is the title of the alert message and message is the text you want to display in the alert message. The total number of characters in title and message cannot exceed 243 characters.

For example, the following command displays an alert message whose title is “Unavailable” and whose alert message is “This document is currently under construction.”

   alertitle Unavailable:This document is currently under construction

 

Specify a default title for alerts in a document

 

1)           Draw a text frame on a reference page and assign the frame a flow tag of AlertTitle.

 

2)           Type the default title in the text frame. For example, if “Not Available Online” appears in the flow, that title, not “FrameMaker—Alert,” appears in the title bar of any alert message created with the Alert command.

 

The default title also appears in the title bar of any alert message created with the Alert With Title command in the following form, without a title:

 

   alerttitle :message               

Related links:

Add text to graphics

Control the flow of text

7.3.6.                Hypertext commands in HTML and PDF documents

In a document converted to HTML or PDF, some FrameMaker hypertext commands work in the same way that they work in view-only FrameMaker documents. Others do not. The following table describes the differences.



	
 

Command

 


	
PDF

 


	
HTML

 





	
Alert, Alert with Title

 


	
Appears as a note, with no title

 


	
Does not work

 





	
Jump to Named Destination

 


	
Works as described

 


	
Works as described

 





	
Jump to Named Destination & Fit to Page

 


	
Works as described, but doesn’t fit to page

 


	
Works as described, but doesn’t fit to page

 





	
Jump to First Page, Jump to Last Page, Jump to Page Number, Jump to Previous Page, Jump to Next Page

 


	
Works as described

 


	
Does not work

 





	
Jump Back, Jump Back & Fit to Page

 


	
Does not work

 


	
Does not work

 





	
Open Document

 


	
Works as described

 


	
Works as described

 





	
Open Document & Fit to Page, Open Document as New, Open Document at First Page, Open Document at Last Page, Open Document at Page Number

 


	
Works as described, but doesn’t fit to page or open a separate window

 


	
Works as described, but doesn’t fit to page or open a separate window

 





	
Pop-up menu

 


	
Does not work

 


	
Does not work

 





	
Button Matrix

 


	
Does not work

 


	
Works as described, if the text frame containing the command is in an anchored frame in the main text flow

 





	
Message URL

 


	
Works when PDF is opened in browser; however, the link sometimes does not work in Acrobat

 


	
Works as described

 





	
Message Client

 


	
Does not work

 


	
Does not work

 





	
Close current window, Close All Hypertext Windows, Exit Application

 


	
Does not work

 


	
Does not work

 






7.3.7.                Use hypertext commands to retrace link navigation

You can create hypertext commands that allow readers to retrace the links they followed in a document window. (FrameMaker maintains a stack of the last 255 links in each window.) For example, perhaps you use these commands on master pages to create a navigation aid that lets readers retrace their steps.

1)            

Insert a Jump Back command. This command uses the following syntax:

 

   previouslink filename:linkname                  

In this example, filename and linkname define the location FrameMaker displays when the stack is empty. If the stack is empty and if you haven’t provided a filename and linkname, FrameMaker leaves the current page displayed.

tip:  If the linked information is in a document whose page size differs from the current document, display the information in a window that is resized to fit the page. Use the Jump Back & Fit to Page command.

 

Related links:

Add links to URLs

Create links to new documents

Create links to specific topics

View-only documents and books

Create links that simulate a TOC

7.3.8.                Insert hypertext command elements in structured documents

A hypertext document is the same as any other FrameMaker document except that it is saved in View Only 9.0 format so that readers cannot edit it. The docu­ment can have structure, and you can use elements to embed hypertext commands in the active areas. But the structure does not have any effect on how the reader works with the finished document.

When working with structured documents, insert a hypertext command using an element. In all other respects, you set up a hypertext document as described for structured documents the same as unstructured documents.

1)            

Click in an area that has been prepared for hypertext.

2)           Select a hypertext element in the Element Catalog and click Insert.

 

3)           If the Attributes For New Element dialog box appears, enter attribute values for the element and click Insert Element.

4)           Choose a hypertext command from the Command pop-up menu. The syntax for the command appears below the pop-up menu, and the command name appears in the box.

 

5)           Enter parameters in the box (for example, a filename and linkname).

 

Hypertext commands must be in lowercase. The parameters can be in uppercase or lowercase, but they are case sensitive. The entire command can be up to 255 characters long.

 

note:  If you enter a filename parameter for a file that isn’t in the same folder as the current document, specify a path to the document.

 

6)           If you want FrameMaker to check for errors in the command, select Vali­date Command upon Insertion.

 

7)           Click New Hypertext Marker. If text symbols are showing, a marker symbol
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 appears in the document window. A bubble for the marker appears in the Structure View, with a text snippet that shows the hypertext command.

 

FrameMaker checks the syntax for errors. If Validate Command upon Insertion is selected, it also checks the command. For example, if the command is Jump To Named Destination, FrameMaker verifies that the destination link exists in the specified document. If it finds an error, an alert message describes the error but the command is still inserted.

 

Related links:

Hypertext commands

7.4.                   Create hypertext links

 You can create links to information in different locations in the same document or in different documents. For example, you can create links that jump to specific topics or pages, and you can use FrameMaker cross-references as links. You can also allow your readers to retrace their jumps.

If your documents are distributed in PDF or HTML, some of these commands do not work.

7.4.1.                Create links to specific topics

You can create a link from one location in a hypertext document to a topic in another location. You use one command to specify the topic you want to display, and you use another to mark the spot on the linked page.
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 A.

Specify the topic to display.

 B.

Mark the topic.

FrameMaker can display the linked information in the same window or in a new window (leaving the active window open).

7.4.2.                Identify a linked topic

1)            

Insert a Specify Named Destination command. This command uses the following syntax:

 

   newlink linkname                  

In this example, linkname is a word or phrase that identifies the destina­tion. A linkname with a trailing space differs from a linkname without a trailing space. Also, the linkname is case sensitive; French Horn is not the same as french horn.
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 A.

Jump to Named Destination command: gotolink trombone

 B.

Specify Named Destination command: newlink trombone

 

note:  If you omit the Specify Named Destination command, the Jump To Named Destination and Open Document commands do not work when clicked unless they reference a filename. In that case, the other file opens, showing the first page.

 

7.4.3.                Create a link to a specific topic

1)            

Insert one of the following hypertext commands:

 

•               To display the linked information in the same window, insert a Jump to Named Destination command. This command uses the following syntax:

 

   gotolink filename:linkname                        

•               To display the linked information in a different window, insert an Open Document command. (The information appears in a new window only if it’s in a different document.) This command uses the following syntax:

   openlink filename:linkname                        

In this example, filename is the name of the document \to display, and linkname is the descriptive word or phrase that you used in the corresponding Specify Named Destination command.

 

tip:  If the linked information is in a document whose page size differs from the current document, display the information in a window that is resized to fit the page. Use the Jump To Named Destination & Fit To Page command or the Open Document & FitTo Page command.

 

7.4.4.                Create links to pages

You can create a link to the first, last, previous, or next page in the same docu­ment or in a different document. You can also create a link to a specific page number.

tip:  You can create navigation aids for your readers by creating links to the next and previous pages on the master pages of a document.

1)            

Insert one of the following hypertext commands:

 

•               To display the linked page in the same window, insert a Jump to Page Number, Jump to First Page, or Jump to Last Page command. The commands use the following syntax:

 

  gotopage filename:pagenumber 
gotopage filename:firstpage
 gotopage filename:lastpage

 

•               To display the linked page in a different window, insert an Open Document At Page Number, Open Document At First Page, or Open Document At Last Page command. The page appears in a new window only if the page is in a different document.) These commands use the following syntax:

 

  openpage filename:pagenumber 
openpage filename:firstpage  
 openpage filename:lastpage

 

note:  When you insert a hypertext command to display a specific page number, use the actual page number in the document. For example, if the destination document MyDoc uses Roman numerals for page numbers and begins on page v, the command to display the third page is openpage MyDoc:vii.

 

•               To display the next or previous page of the current document, insert a Jump To Previous Page or Jump To Next Page command. (If the first page of the document is already displayed, Jump To Previous Page has no effect. If the last page of the document is displayed, Jump To Next Page has no effect.) These commands use the following syntax:

 

  previouspage
 nextpage

In these examples, filename is the name of the document to display, and pagenumber is the number of the page to display. When the page to display is in the current document, don’t include the filename and colon. The following table contains examples of the commands.

 



	
Command

 


	
Effect

 





	
gotopage 8

 


	
Displays, in the same window, page 8 of the current document

 





	
openpage Trombone:8

 


	
Displays, in a different window, page 8 of the document Trombone in the current folder

 






7.4.5.                Create links to new documents

You can create a link to another document and have FrameMaker open the document in another window as a new, unnamed document. For example, you can create an online system for your site document templates.

1)           Follow the instructions to insert an Open Document As New command. This command uses the following syntax:

 

   opennew filename                  

In this example, filename is the name of the document you want to use as a template.

7.4.6.                Create links to web pages

You can create a link to a web page on the Internet or a company intranet.

1)           Insert a Go To URL command. This command uses the following syntax:

 

   message URL address                  

In this example, address is the name of the URL you want to jump to, such as http://www.adobe.com.

7.4.7.                Creating links using cross-references

You use FrameMaker cross-references as hypertext links. When the reader clicks a cross-reference in a view-only document, FrameMaker jumps to the source information. If a cross-reference is present in the same text area as a hypertext command, the cross-reference takes precedence over the hypertext command.

You can use MIF to specify that cross-references are inactive in your hypertext document. You can also specify that clicking an active cross-reference always causes FrameMaker to open a new window.

Related links:

Hypertext commands in HTML and PDF documents

Insert hypertext command elements in structured documents

7.5.                   Create ways to start, open, and close applications

You can use hypertext commands to start other applications. For example, a reader can start a database application from a view-only document to retrieve and display data.

The hypertext commands for closing files and exiting FrameMaker work in the same way as the commands on the File menu.

If a reader executes a command to close a file that contains unsaved changes, FrameMaker prompts the reader to save the document before closing.

In addition, you can create hypertext commands that link to a Universal Resource Locator (URL) when the document is converted to Hypertext Markup Language (HTML).

7.5.1.                Create a way to start another application

1)            

Insert a Message Client. This command uses the following syntax:

 

   message system application path,windowstate   message winexec application path,windowstate                  

In these examples, application is the application filename, path is an optional command line parameter, and windowstate specifies the state of the window that is opened. The possible windowstate values are listed in this table.

 



	
State

 


	
Definition

 





	
SW_HIDE

 


	
Hides the window and activates another window

 





	
SW_MAXIMIZE

 


	
Maximizes the specified window

 





	
SW_MINIMIZE

 


	
Minimizes the specified window and activates the next window in the Alt+Tab order

 





	
SW_RESTORE

 


	
Activates and displays the window (If the window is minimized or maximized, Windows restores it to its original size and position.)

 





	
SW_SHOW

 


	
Activates the window and displays it in its current size and position

 





	
SW_SHOWDEFAULT

 


	
Sets the show state based on the SW_ flag specified in the STARTUPINFO structure passed to the CreateProcess function by the program that started the application

 





	
SW_SHOWMAXIMIZED

 


	
Activates the window and displays it as a maximized window

 





	
SW_SHOWMINIMIZED

 


	
Activates the window and displays it as a minimized window

 





	
SW_SHOWMINNOACTIVE

 


	
Displays the window as a minimized window (The active window remains active.)

 





	
SW_SHOWNA

 


	
Displays the window in its current state (The active window remains active.)

 





	
SW_SHOWNOACTIVATE

 


	
Displays a window in its most recent size and position (The active window remains active.)

 





	
SW_SHOWNORMAL

 


	
Activates and displays a window (If the window is minimized or maximized, Windows restores it to its original size and position.)

 






If you omit the windowstate value, the window state is set to SW_SHOWNORMAL. For more information on window states, see the documentation for the Windows software development kit.

 

For example, to start PaintBrush and open the Ship.pcx file on drive letter C in a minimized window, you would use the following command:

 

   message system pbrush.exe C:/Ship.pcx, SW_MINIMIZE

7.5.2.                Create a way to open a file or another application

1)            

Insert a Message Client command. This command uses the following syntax:

 

   message openfile path                  

In this example, path is the path to the file, application, or AppleScript script.

 

For example, consider the Tuba.eps file located in the Graphics folder on the drive named HardDrive. To start the application that created the Tuba.eps file and to open the file, use the following command:

 

   message openfile /HardDrive/Graphics/Tuba.eps

To run the DocReport script (located in the Scripts folder on the drive named HardDrive), use the following command:

 

   message openfile /HardDrive/Scripts/DocReport

7.5.3.                Create a way to close or exit documents

1)            

Insert one of the following hypertext commands:

 

•               To create a way to close the current view-only document, insert a Close active window command. This command uses the following syntax:

 

   quit

•               To create a way to close all open view-only documents, insert a Close All Hypertext Windows command. The Close All Hypertext Windows command also closes view-only documents that have already been closed to an icon. This command uses the following syntax:

 

   quitall

 

•               To create a way to exit FrameMaker, insert an Exit command. This command uses the following syntax:

 

   exit

 

Related links:

Create links to web pages

Hypertext commands

7.6.                   Test and troubleshoot hypertext documents

After writing the document and inserting hypertext commands, test the commands. To speed up testing of hypertext commands, execute commands without first changing a document to View Only format. Also force the destina­tion of a hypertext jump to appear in a separate window.

FrameMaker validates all the commands in a document.

Errors in hypertext commands or in their placement in the document, or formatting errors in active areas can cause problems with the behavior of the commands. For example, an incorrect linkname prevents a hypertext command from being executed correctly.

Some common hypertext problems and possible solutions:

Clicking an active area has no effect

 

Check for the following possible problems:

 

•               The document is not in View Only 9.0 format.

 

•               If the active area is highlighted correctly when you click, a command sometimes contains a linkname that doesn’t match the corre­sponding link at the destination.

 

•               If the active area isn’t highlighted when you click, sometimes the marker that contains the hypertext command is not of type Hyper­text.

 

•               If the active area is over a graphic, sometimes the text frame containing the hypertext marker is not in front of the graphic.

 

The jump goes to the wrong page

 

Sometimes the command contains a correct filename but an incorrect linkname or an invalid page number.

 

Only part of the active area is highlighted

 

Check for the following possible problems:

 

•               If you’re trying to make a range of text active, sometimes the text contains an extra hypertext marker or the character format changes within the range of text.

 

•               If you’re trying to make an entire empty text frame active, sometimes the frame contains an extra empty paragraph, or extra characters or markers.

 

Items are missing from a pop-up menu

 

The hypertext commands for missing menu commands are incorrect. If the pop-up menu does not appear, no commands are correct.

 

7.6.1.                Force the linked destination to appear in a different window

1)            

If the document is view-only, Shift-click an active area. Otherwise, Control-Alt-Shift-click an active area.

 

7.6.2.                Generate a list or index of hypertext markers

You can check the text of hypertext commands by generating a list or index of hypertext markers. The generated list contains the text of all hypertext markers inserted on body pages and their page numbers.

1)            

Use the Special > List Of > Markers or Special > Index Of > Markers command.

 

Related links:

Generating TOCs and other lists in structured documents

Generate indexes

Generate and update books

7.7.                   Add hypertext links to generated files

 

When you generate an index or a list such as a table of contents, FrameMaker can insert hypertext links in the generated file. These links can greatly enhance the usefulness of an online index or table of contents. When you click a topic or page number in the generated file, the appropriate page in the linked document is displayed.

You can use generated hypertext documents for the following purposes:

•                

To distribute a generated table of contents or index in View Only format as a navigation tool for your online documents.

 

•               To debug documents. For example, when creating an index, generate the index with hypertext links. Then fix index marker errors by jumping to the exact locations of the markers.

 

Generating a list of hypertext markers produces a list of markers drawn only from body pages. Hypertext markers on master pages are not included.

tip:  You can activate the hypertext commands in a generated document without changing the document to View Only format.

1)            

Do one of the following:

 

•               From an individual FrameMaker document, select Create Hypertext Links when you use the File > Utilities > Compare Documents command.

 

•               When adding a generated file to a book, turn on Create Hypertext Links in the Set Up dialog box. If the generated file is already created, select the generated file in the book window. Then choose the appro­priate Set Up command from the Edit menu.

 

7.7.1.                Add linked thumbtabs to indexes

You can make a generated online index easier to navigate by adding thumbtabs. Readers click a thumbtab letter to display the page in the index that contains entries starting with that letter.

1)           Generate the index with hypertext links.

 

2)           In the index, choose View > Master pages.

 

3)           On a master page, use the Text Line tool to create the thumbtab letters and then draw a text frame over each thumbtab letter.

4)           Insert a Jump to Named Destination command in the text frame for each thumbtab letter. For example, in the text frame over the thumbtab letter A, insert a Jump to Named Destination command with the syntax gotolink A. (Each group title in the index already contains a corresponding Specify Named Destination command as a result of generating the index with hypertext links.)

 

If the index contains a collapsed group title, such as PR,– insert a Jump To Named Destination command with the same syntax for each of the thumbtab letters in the range. For example, insert gotolink P-R in the three text frames for P, Q, R.

 

5)           If the index uses more than one master page, copy the thumbtabs to the other master pages.

 

6)           Save the index in View Only 9.0 format.

 

7.7.2.                Control how source documents are displayed

When you click an active area in a generated hypertext document, FrameMaker opens a new window and displays the correct page in the linked document. The linked marker or paragraph is highlighted and centered in the window. You can change the display of the linked document—for example, to display the docu­ment in the active window.

1)            

Generate the hypertext document.

 

2)           In the generated file, choose View > Reference Pages and display the refer­ence page that contains the special flow for the generated file.

 

The flow tag of the special flow is the same as the document suffix. For example, the special flow for a table of contents is tagged TOC, and the special flow for an index is tagged IX. To determine a flow tag, click in the text frame and look in the Tag area of the status bar.

 

Your flow tags are displayed in the tag area of the status bar.
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3)           In the special flow, find the paragraph that controls how the linked docu­ment is displayed.

 

In a table of contents, the paragraph tag is ActiveTOC; in an index, it is named ActiveIX. The paragraph looks like the following:

 

openObjectId <$relfilename>:<$ObjectType> <$ObjectId>

 

To determine a paragraph tag, click in the paragraph and look in the Tag area of the status bar.

 

4)           Edit the paragraph so that it contains the display command you want.

 

In addition to the display commands, you can use the Message Client command to send messages to applications that use the Application Program Interface (API).

 

5)           Save the generated file, and then regenerate it.

7.7.3.                Display commands for generated documents

When the reader clicks an active area in a generated hypertext document, FrameMaker displays the correct page in the linked document. The following table lists some of the hypertext commands you can use to control how the linked document is displayed. Type the commands exactly as shown. Use the <$relfilename> building block to create a relative path from the generated file to the linked document. Use <$fullfilename> for a full path. The following exam­ples show only the <$relfilename> building block.



	
 

To display


	
Type

 





	
The linked marker or paragraph centered in the active window

 


	
gotoObjectId <$relfilename>:<$ObjectType> <$ObjectId>

 





	
The linked marker or paragraph centered in the active window resized to fit the page

 


	
gotoObjectIdFitWin <$relfilename>:<$ObjectType> <$ObjectId>

 





	
The linked marker or paragraph centered in a new window

 


	
openObjectId <$relfilename>:<$ObjectType> <$ObjectId>

 





	
The linked marker or paragraph centered in a new window resized to fit the page

 


	
openObjectIdFitWin <$relfilename>:<$ObjectType> <$ObjectId>

 





	
The page containing the linked marker or paragraph, with nothing highlighted, in the active window

 


	
gotopage <$relfilename>:<$pagenumonly>

 





	
The page containing the linked marker or paragraph, with nothing highlighted, in a new window

 


	
openpage <$relfilename>:<$pagenumonly>

 





	
An alert that displays the filename of the linked document

 


	
alert <$relfilename>

 






7.7.4.                Overriding the generated file display command

You can specify how a specific document is displayed by overriding the display command contained in the ActiveTOC or ActiveIX paragraph in the generated file. For example, sometimes you want a generated index that references several files, including a glossary file, to display the glossary in one window and all the other files in another window.

1)            

Draw a text frame on a reference page in the linked document, and assign the frame the flow tag HypertextLinks.

 

2)           Do one of the following:

 

•               To display the document in the same window, type gotoObjectId 

•               To display the document in a different window, type openObjectId 

3)           Save the document and regenerate. When you click in the generated file, display the linked document using the command specified in the Hyper­textLinks flow. Don’t use the command in the ActiveTOC or ActiveIX paragraph.

 

7.7.5.                Incorporating generated files into an online system

If you’re using a generated hypertext document as a debugging tool, the docu­ment is ready to use when you generate it. If, however, the generated file is part of a hypertext online system, do the following before distributing the docu­ments to readers in View Only format:

•                

Set up links from the documents back to the generated file. You can use any of the hypertext commands. For example, you can create an Index or Table of Contents button that jumps back to the generated file.

 

•               Add active areas to the master pages of documents for navigating through the online system. For example, you can create buttons for paging forward and backward.

 

•               Add links to other parts of the online system in the source documents and in generated files.

 

 

Related links:

Generating TOCs and other lists in structured documents

Generate indexes

Test and troubleshoot hypertext documents

Compare versions to view changes

Add text to graphics

Create links to specific topics

7.8.                   FluidView format

A document in FluidView format appears as one continuous page, without headers, footers, or margins. When you resize the document window, the text is reformatted to fit within the width of the new window.

FluidView is not available in FrameMaker by default. To make it available, make the following entry in cmds.cfg file at: fminit\configui.

*** Fluid view commands ***
<Command FluidView
 <Label Fluid View>
 <KeySequence \!VF>
 <Definition \x500>
 <Mode All>>
<Command PageView
 <Label Page View>
 <KeySeqLabel !VF>
 <Definition \x500>
 <Mode All>>

 

In most cases, you work with FluidView documents just as you work with view-only documents. For example, you can click hypertext links to navigate within and between documents. A FluidView document differs from a view-only document in the following ways:

•                

Document appears onscreen as one continuous page. Clicking the Page Up or Page Down button on the bottom of the document window displays the previous or next screen of text instead of the previous or next page.

 

•               The printed version of a FluidView document sometimes does not match what you see on the screen. You can use headers and footers, multiple columns, and other page layout options to optimize the printed appear­ance of the document.

 

Keep in mind the following points as you create FluidView documents:

•                

When users open a FluidView document that contains more than one text flow, the main flow always appears in the document window. However, you can create links to other flows in the document. When a user clicks an active area that points to another flow, the new flow appears in the Fluid­View document.

 

•               Although a FluidView document is sometimes as long as a FrameMaker document, try to keep the length of each document under 200 in. A page break appears every 200 in. Footnotes and graphic frames anchored at the bottom of a column appear at these page breaks instead of at the end of the document.

 

•               Set anchored frames in your document to one of three anchoring posi­tions: Below Current Line, At Insertion Point, or Run Into Paragraph. Frames anchored at positions other than positions sometimes produce unexpected results.

•               You can change the view-only window display or selectively disable menu commands. These expert controls are available through a Maker Inter­change Format (MIF) file.

 

7.8.1.                Change a document to FluidView format

1)            

Click in the text flow that you want to display in FluidView format. Only one text flow in a document can appear in FluidView format at a time.

 

2)           Press Esc Shift+v Shift+f. This shortcut hides the headers, footers, margins, page breaks, and any background graphics; removes multi­column formatting; and makes the document view-only.

 

3)           Close the document, and click Save when prompted.

 

Sometimes you save the document in FluidView format and then reopen it. In these cases, the main text flow (tagged A) always appears, even if a different text flow is visible when you change the document to FluidView format. However, when you click an active area that points to another flow, the new flow appears in the FluidView document.

7.8.2.                Change the side-head area setup

You can use side heads in one format and not in the other. For example, you can display headings in the side-head area in FluidView and in the body-text area in the printed copy.

1)            

Use Format > Page Layout > Column Layout to turn side-head formatting on or off while the document is in Document format.

 

2)           Press Esc Shift+v Shift+f to change the document to FluidView format.

 

3)           Press Esc j p Shift+s to turn side-head formatting on or off in FluidView.

 

7.9.                   Cross-references

 

7.9.1.                About cross-references

 

Cross-references in unstructured documents

FrameMaker provides two types of cross-references—to paragraphs and to specific spots within paragraphs. In both cases, FrameMaker uses markers to keep track of the source of cross-references.

It is easier to create and maintain paragraph cross-references because FrameMaker automatically creates a marker on the paragraph tag in the source files. In the case of spot cross-references, you have to first mark the spot with a marker and then create a cross-reference to the marker.

note:  The Cross-reference feature supports the Unicode text encoding standard.

Cross reference markers

FrameMaker uses a marker (of type Cross-Ref) to keep track of the source of each cross-reference. If you move a marker and then update cross-references, the marker’s new location is used to update the cross-reference.

For paragraph cross-references, the marker text contains a number assigned to the marker, the paragraph tag, and text of the paragraph being cross-referenced. When you insert a paragraph cross-reference, a cross-reference marker is inserted automatically at the beginning of the source paragraph if necessary. (The marker text is not updated, so the tag and text sometimes don’t match the cross-reference.)

For spot cross-references, the marker text is the text you type when creating the marker on the source text. It is important to mark the text in the source first so that it appears in the cross-reference panel at the time you create the spot cross-reference.

Cross-references in structured documents

 

When working with structured documents, FrameMaker keeps cross-refer­ences, variables, and footnotes up to date for you. To add a cross-reference in FrameMaker, you normally use an element designed for that purpose. The cross-reference element points to a location, or source, that can be in the same document or a different document. The source is also normally an element, such as a Chapter, Section, Figure, or Table element.

An element-based cross-reference shows text from the source element.
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If a cross-reference points to a source in an unstructured flow, the source can be either a whole paragraph or a marked spot in text. It is also possible to point to a paragraph or a spot in a structured flow, but it’s best to point to another element. (Cross-reference elements are often defined to be invalid if they point to anything other than an element.)

 

ID and ID Reference attributes in structured documents

 

FrameMaker uses attributes in cross-reference and source elements to maintain the connection between the two elements. The source element has an ID attri­bute that stores a unique identifier in the document or book. The cross-refer­ence element has an ID Reference attribute that also stores the source’s identifier as a way of keeping track of what the reference points to.

 

If you insert a cross-reference to a source that has an ID attribute but does not yet have a value for the attribute, FrameMaker automatically provides the value.

An ID that FrameMaker generates is an eight-character string that conforms to the XML or SGML reference concrete syntax.

FrameMaker tries to ensure that your IDs are unique in the following ways:

 

•               When FrameMaker generates an ID, it is unique within the document. The ID is unique even within the book, because documents in a book have different filenames and part of the generated IDs comes from the file­name.

•               If you enter an ID that is not unique, the ID is not accepted. FrameMaker does not test for whether an entered ID is used in a different document in a book but you can validate the book to find duplicate IDs.

 

•               If you paste a copy of an element with a duplicate ID, the pasted element loses its ID.

 

It is still possible for a document to have IDs that are not unique. For example, duplicate IDs occur if you show hidden conditional text that contains an element with the same ID as another element. The duplicate IDs are identified as invalid in the Structure View.

Invalid value
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An ID Reference attribute is sometimes defined to require a value. If an attribute requires a value but does not have one, the cross-reference probably points to a paragraph or spot within text rather than an element. FrameMaker identifies the attribute as invalid in the Structure View.

Missing a required value
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Cross-reference pod overview

The cross-reference pod lists all the cross-references in the current document, selected document, or all open documents. It allows you to add, edit, delete, or search for cross-references from a single panel. You can also filter cross-refer­ences to view only external or unresolved cross-references. This helps to trou­bleshoot unresolved cross-references across multiple open documents.

 

Cross-reference pod
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A.

Select the file.

B.

List all, external, or unresolved cross-references.

C.

Insert a cross-reference in a document.

D.

Edit a selected cross-reference.

E.

Delete a selected cross-reference.

F.

Go to the location of the selected cross-reference in the document.

G.

Refresh pod data.

H.

Search for a cross-reference.

7.9.2.                Insert cross-references

Within a document, when you copy and paste text that contains a cross-refer­ence marker, the marker is not duplicated. The cross-reference still refers to the text in its original location.

Insert a paragraph cross-reference

Paragraph cross-references refer to a heading or some other text that occupies a whole paragraph.

1)           If you’re cross-referencing another document, open that document. You must have write permission to the document to add a cross-reference marker to it.

 

2)           Click where you want to insert the cross-reference.

You can insert a cross-reference in text frames but not in text lines (graphic objects created with the Text Line drawing tool).

 

3)           Click the Add icon on the cross-references pod.

4)           If you’re cross-referencing information in another document, choose the name of that document from the Document pop-up menu in the cross-reference panel.

 

5)           Choose Paragraphs from the Source Type pop-up menu. All the tags in the document’s Paragraph Catalog appear in the Paragraphs Tags scroll list.

 

6)           In the Paragraph Tags scroll list, select the tag of the paragraph you want to cross-reference. For example, if you’re cross-referencing a paragraph tagged Head1, select Head1 in the Paragraph Tags scroll list. All Head1 paragraphs then appear in the Paragraphs scroll list.

7)           In the Paragraphs scroll list, select the paragraph to cross-reference.

8)           Choose the format of the cross-reference from the Format pop-up menu.

9)           Click Insert. FrameMaker inserts a cross-reference at the insertion point in your document. In the source document, FrameMaker adds a marker
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 at the start of the paragraph being cross-referenced. FrameMaker inserts a marker only if a cross-reference marker isn’t already there.

10)       Save both the documents for the cross-reference to work correctly.

 

If the paragraph extends beyond the page on which it begins, the page number in the cross-reference, if included, is that of the beginning page.

Insert a cross-reference to a paragraph in a text inset

If you insert a paragraph cross-reference to a text inset, the cross-reference marker is sometimes lost when the text inset is updated. To prevent the marker from being lost, first insert a cross-reference to the paragraph in the text inset’s source document.

1)            

Open the source of the inset by double-clicking the inset and then clicking Open Source from the Text Inset Properties panel.

 

2)           Insert a cross-reference to the paragraph anywhere in the source docu­ment.

 

3)           Delete the cross-reference text. The marker remains.

4)           Save the source document, and then in the document that contains the text inset, update the text inset by choosing Edit > Update References.

 

5)           Insert a spot cross-reference, this time in the document that contains the inset. The cross-reference uses the marker in the updated inset.

 

Insert a cross-reference to a word or phrase

Spot cross-references refer to an individual word or phrase—a spot—in a para­graph. For example, use a spot cross-reference if you have a paragraph that spans two pages and you want to refer to the text on the second page of your reference.

1)            

Click where you want to insert the marker. For example, click at the start of a word, next to an anchored frame symbol, or anywhere within a column of text.

2)           Click the Add icon on the Markers panel.

3)           Choose Cross-Ref from the Marker Type pop-up menu.

 

4)           Enter an identifying word or phrase for the marker in the Marker Text box.

The marker text can be up to 255 unicode characters long.

For example, if you insert a marker where inertia is defined, you can enter Definition of inertia. This text appears in the cross-reference panel to Help you identify the source. It doesn’t appear in the cross-reference itself.

5)           Click New Marker. A marker symbol
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 appears at the insertion point when text symbols are visible.

6)           Insert a spot cross-reference by choosing cross-reference Markers from the Source Type pop-up menu. Then select the marker text in the cross-reference Markers scroll list, choose a cross-reference format, and click Insert.

 

tip:  The Markers pod displays the marker text of all markers including Cross-Refs. However, you can also generate a list of all types of Cross-Ref markers from Special > List Of > References.

Insert a cross-reference in a structured document

When inserting a cross-reference, you normally use a cross-reference element and point the reference to another element. The source element can be an entire section or chapter, a table or graphic, a paragraph, or a location within a para­graph (such as a definition).

FrameMaker uses attributes to maintain the connection between a cross-refer­ence element and a source element. The source element has an ID attribute with a value that uniquely identifies the location in the document. When you insert a cross-reference to the source, the same value is stored in an IDRef attribute for the cross-reference element.

If you insert a cross-reference to a source that has an ID attribute but does not yet have a value for the attribute, FrameMaker automatically provides the value.

note:  An element can be a source for cross-references only if it has a unique ID attribute. If you want to insert a cross-reference to a source that does not have an ID attribute, ask your application developer to add the attribute to the source element definition.

1)           If the source element is in another document, open that document. If the source element does not have a value assigned to its ID attribute, you must have write permission to the other document so that FrameMaker can provide an ID.

 

2)           Click where you want to insert the cross-reference element. You can insert a cross-reference in text frames but not in text lines (graphic objects created with the Text Line drawing tool).

 

3)           Select a cross-reference element in the Element Catalog and click Insert.

 

You can also use Special > cross-reference to insert an element. If more than one element is available, choose the one you want from the Element Tag pop-up menu in the cross-reference panel.

 

4)           If you’re cross-referencing information in another document, choose the name of that document from the Document pop-up menu.

 

5)           Choose Elements Listed in Order or Elements Listed by ID from the Source Type pop-up menu. The tags of all elements for which an ID attri­bute is defined (in the source document’s element definitions) appear in the Element Tags scroll list.

 

tip:  List elements by IDs if you provided the IDs and have used values that identify the elements’ contents. (If FrameMaker provided the IDs, the values are random strings that are helpful in finding the element you want.)

 

6)           Select the tag of the source element in the Element Tags scroll list. For example, if you’re cross-referencing a Section element, select Section. All Section elements in the source document appear in the Elements scroll list.

Some elements use context labels to provide information about the element’s location in the structure. For example, if Section elements can be nested within other Section elements, the labels can identify whether the elements are first-, second-, or third-level sections.

 

Context labels
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If an element uses context labels, a <no label> entry also appears in the scroll list for occurrences not described by the labels. In the example, Section(<no label>) represents Section elements that are at a fourth level or lower in the document.

 

7)           Select the element you want to cross-reference in the Elements scroll list.

 

8)           To change the cross-reference format, choose from the Format pop-up menu.

 

note:  Consult your developer before changing a cross-reference format. 

9)           Click Insert. FrameMaker places the cross-reference at the insertion point. A bubble for the reference appears in the Structure View, with a text snippet that shows the first part of the text from the reference.

 

10)       If the Attributes for New Element dialog box appears, enter attribute values for the cross-reference, and select Insert Element.

If no cross-reference element is available at the location you want, you can use an invalid element. After inserting the element, talk to your developer about making it valid at this location.

Use an invalid cross-reference element

1)            

Do one of the following:

 

•               To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.

 

•               To insert an invalid cross-reference element with a default tag, choose Special > cross-reference, and choose CROSSREF from the Element Tag pop-up menu. (This option appears in the menu if no defined cross-reference elements are available.)

 

 

Provide a value for an ID attribute

If the ID attributes are not read only, you can provide the IDs with values that are more meaningful. Give the source elements their IDs before inserting cross-references to them.

1)            

Enter an ID in the Attributes dialog box. You can use any combination of characters on your keyboard, up to 255 characters.

tip:  Keep in mind that the ID appears in the cross-reference panel and in the Structure View. Use a brief name that you’ll remember or recognize later. For example, assign the ID value Art to an element for a chapter titled The Art Department. 

If you plan to export to XML or SGML, follow the naming rules for the syntax you’ll be using in XML or SGML. Ask your developer for recom­mendations on name length and characters allowed.

 

You can also edit an ID (unless the attribute is defined to be read only), but any cross-references pointing to the element will be unresolved.

 

tip:  If you change an element’s ID, you can update existing cross-references to the element. Search for elements that have an ID Reference attribute with the old ID, and replace the old ID with the new one.

 

Related links:

Display the source of a cross-reference

Resolve cross-references

7.9.3.                Edit cross-references or display the source

If you want to edit the text of the cross-reference as you do regular text, you must convert it to text. After conversion, the text can no longer be updated as a cross-reference.

Convert a cross-reference to text

1)            

If you’re converting a single cross-reference, select it; otherwise, click in the document.

 

2)           Choose Special > cross-reference.

 

3)           Click Convert to Text.

 

4)           Indicate the scope of cross-references to convert and click Convert.

Choose a different source or format for a cross-reference

1)            

Double-click the cross-reference. If the source is located in a different document, click OK to open the source document.

 

2)           Specify a source or format in the same way that you would when inserting a cross-reference, and then click Replace.

 

Display the source of a cross-reference

•                

Double-click the cross-reference, and then click Go to Source. FrameMaker displays the page that contains the source of the cross-refer­ence and places the insertion point at the beginning of the source para­graph.

 

•               (Windows) Alt-Control-click the cross-reference.

 

note:  If the source is in a different document, hold down Shift while using one of the preceding shortcuts to open the document without closing the current docu­ment.

 

7.9.4.                Create and edit cross-reference formats

A cross-reference format defines the appearance of a cross-reference: its wording, the source information it shows, and, optionally, any special text formatting. The building blocks of the format are replaced with source informa­tion and are updated when necessary—for example, if the source page number changes.
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 A. 

Text that appears literally

 B.

Building blocks.

FrameMaker templates include several cross-reference formats. You can change them or create others. If another document contains the cross-reference formats you want, you can import them into your document. For structured documents, ask your developer to create one or modify an existing format.

1)            

Choose Special > cross-reference.

 

2)           Click Edit Format.

 

3)           Type a name for the cross-reference format in the Name box. Format names are case-sensitive page and Page would be different formats.

 

4)           Do any of the following:

 

•               To use text (such as See or on page) in a cross-reference format, click in the Definition box and enter the text.

•               To include a building block that refers to source information, such as a page number, chapter number, or heading text, click in the Defi­nition box and then click the building block in the Building Blocks scroll list. The building block appears at the insertion point.

 

•               To change the character format within the cross-reference, click in the Definition box and then click the character format at the bottom of the Building Blocks scroll list. The building block appears at the insertion point. To return to the default paragraph format before the end of the cross-reference, insert <Default ¶ Font> in the definition.

 

5)           Click Add and then click Done. The new cross-reference format appears in the Formats pop-up menu in the cross-reference panel.

 

Related links:

Import formats from a template or document

Generate and update books

Including text in a cross-reference

You can include specific characters or words in the cross-reference. In most cases, you simply enter the text in the Definition box. But a few characters are entered or displayed differently.

For example, an angle bracket (< or >) in a cross-reference format ordinarily signals a building block. To include an angle bracket as part of the text, precede it with a backslash (\).

note:  Some special characters are entered or displayed differently in dialog boxes. Enter a sequence of characters beginning with a backslash (\); these sequences are listed in Typing in dialog boxes.

Related links:

Include book component numbers in headers or footers

Including source information in cross references

You use building blocks to include information about the source of the cross-reference, such as its paragraph text (but not the cross-reference marker text), paragraph autonumber, or volume, chapter, or page number. Building blocks for source information appear in angle brackets ( < and > ) and begin with a dollar sign ($). The following building blocks are grouped by the type of infor­mation they represent.

 

Source file

 

FrameMaker provides the following building blocks for referring to the source file.

 



	
Building block

 


	
Description

 





	
<$filename>

 


	
The name of the source document

 





	
<$fullfilename>

 


	
The full path of the source document

 





	
<$volnum>

 


	
The volume number of the document that includes the source paragraph

 





	
<$chapnum>

 


	
The chapter number of the document that includes the source paragraph

 






Source paragraph

 

FrameMaker provides the following building blocks for referring to the source paragraph.

 



	
Building block

 


	
Description

 





	
<$pagenum>

 


	
The page number of the source paragraph

 





	
<$paratext>

 


	
The text of the source paragraph, excluding its autonumber (If the character format of text in the source paragraph was changed by applying a Character Catalog format, the font family, superscript, and subscript properties are preserved in the text of the cross-reference.)

 





	
<$paratag>

 


	
The tag of the source paragraph

 





	
<$paranum>

 


	
The source paragraph’s entire autonumber, including any text in the autonumber format

 





	
<$paranumonly>

 


	
The source paragraph’s autonumber counters, including any characters between them

 






Paragraph preceding the source paragraph

 

A cross-reference to a subsection often identifies the section that contains it. For example, this cross-reference to a subheading identifies the main heading under which it is found: See “Types of Plate Boundaries” in “Plate Tectonics.” In the example, Types of Plate Boundaries is the source paragraph, and Plate Tectonics is the main heading under which the source paragraph appears.

 

In each of the building blocks, replace tag (in brackets) with the tag of the para­graph to which you want to refer, but don’t delete the brackets. For example, if you want to refer to the text of the preceding paragraph tagged Head1, use <$paratext[Head1]>.



	
Building block

 


	
Description

 





	
<$pagenum[tag]>

 


	
The page number of the preceding paragraph with the specified tag

 





	
<$paratext[tag]>

 


	
The text of the preceding paragraph with the specified tag, excluding its autonumber (If the character format of text in the source paragraph was changed by applying a Character Catalog format, the font family, superscript, and subscript properties are preserved in the text of the cross-reference.)

 





	
<$paratag[tag]>

 


	
The tag of the preceding paragraph with the specified tag

 





	
<$paranum[tag]>

 


	
The entire autonumber of the preceding paragraph with the specified tag, including any text in the autonumber format

 





	
<$paranumonly[tag]>

 


	
The autonumber counters of the preceding paragraph with the specified tag, including any characters between them

 






important:  Don’t use a paragraph tag that includes brackets ([   ]).

Structured FrameMaker elements

 

Use the following building blocks to create cross-reference formats that refer to structured FrameMaker elements

 



	
Building block

 


	
Description

 





	
<$elempagenum>

 


	
The page number of the source element

 





	
<$elemtext>

 


	
The text of the source element (up to the first paragraph break), excluding its autonumber, but including any prefix and suffix specified in the element definition

 





	
<$elemtextonly>

 


	
The text of the source element (up to the first paragraph break), excluding its autonumber and any prefix and suffix specified in the element definition

 





	
<$elemtag>

 


	
The tag of the source element





	
<$elemparanum>

 


	
The entire autonumber of the source element’s first paragraph (or of the paragraph containing the source element), including any text in the autonumber format

 





	
<$elemparanumonly>

 


	
The autonumber counters of the source element’s first paragraph (or of the paragraph containing the source element), including any characters between the counters

 





	
<$attribute[name]>

 


	
The value of the attribute with the specified name (or, if no value is specified, the default value)

 






Including character formats in cross-references

All formats in the document’s Character Catalog appear at the end of the Building Blocks scroll list. You insert them as you do other building blocks.

If you don’t insert a character format in a cross-reference format, FrameMaker uses the font at the insertion point when a cross-reference is inserted with that format. If you change the character format for the cross-reference, the change applies only to the cross-reference, not to the text following it in the paragraph.

Don’t use a character tag that includes angle brackets (<   >).

Examples of cross-reference formats

The first four examples in the following table include building blocks that refer to the source paragraph.



	
Example


	
Building block sequence

 





	
Chapter 4, “Climatic Effects.”


	
<$chapnum>, “<$paratext>.”





	
Section 2.3.4, Volcanoes.

 


	
Section <$paranumonly>, <TitleFont><$paratext>.

 





	
See Plate tectonics, next.

 


	
See <TitleFont><$paratext> <Default ¶ Font>, next.

 





	
Page 23

 


	
Page <$pagenum>

 





	
See “Magma” in “Volcanoes.”


	
See “<$paratext>” in “<$paratext[Head1]>.”






The last example includes a building block that refers to a paragraph preceding the source paragraph. In this example, the cross-reference format could also be the following:

See “<$paratext>” in “<$paratext[Title, Head1]>.”

In this case, the cross-reference refers to either the chapter title (Title) or the section heading (Head1), whichever is closer to the Magma source paragraph.

You can use the </> building block as a substitute for <Default Para Font> in cross-reference definitions.

Edit or delete a cross-reference format

When you change or delete cross-reference formats, the changes are reflected immediately in all cross-references that use the affected formats.

You can change the format of cross-references in a text inset (text imported by reference) if the inset uses the formats of the document into which it is imported. If the inset uses formats from the source document, change the formats in the source document.

1)            

Choose Special > cross-reference, and click Edit Format.

 

2)           In the Formats scroll list, select the format you want to edit or delete, and do one of the following:

 

•               Edit the definition. Click Change, and then click Done. If the Update cross-reference panel appears, indicate the scope of cross-references to update, and then click Update.

 

•               Click Delete, and then click Done. If cross-references in the docu­ment use the format, you are asked whether you want to convert these cross-references to text.

 

7.9.5.                Update and resolve cross-references

If you edit the source of a cross-reference or if the pagination of the source document changes, the cross-reference is no longer accurate. You can update cross-references to be sure that they show correct information from the source. You can use the cross-reference pod to display a list of all the unresolved cross-references in a document or book. You can use this list to troubleshoot unresolved cross-references.

Normally, FrameMaker updates all cross-references when you open a docu­ment. It also updates all internal cross-references and cross-references to open documents when you print a document. You can also update cross-references manually. If the document contains unresolved cross-references—cross-refer­ences to sources that FrameMaker can’t find—you’ll need to Help locate the sources.

FrameMaker does not update cross-references when opening a document in the following circumstances:

•                

When cross-references refer to information in hidden conditional text. Show the text that contains the sources of the cross-references before updating the cross-references.

 

•               When fonts or dictionaries are missing.

 

•               When opening a document saved with an earlier version of FrameMaker.

 

•               When opening a MIF file.

 

Suppress automatic updating of cross-references in a document or book

If a document contains many cross-references, you can improve its opening time by suppressing automatic updating of the cross-references. After you suppress automatic updating, cross-references are updated only when you print or when you manually give instructions to update. They are no longer updated when you open the document. However, internal cross-references and cross-references to open documents are still updated automatically when you print.

1)           Do one of the following

 

•               To suppress updating in a document, choose Edit > Update Refer­ences, choose Suppress Automatic Updating Of All cross-references from the Commands pop-up menu. Select Suppress Automatic Updating Of All cross-references and click Set.

 

•               To suppress updating in a book window, choose Edit > Suppress Automatic Reference Updating, select Suppress Automatic Updating, and then click Set.

 

2)           Click Done.

Update cross-references manually

Update a document at any time while you edit it or any other documents that are sources for the cross-references.

1)            

Choose Edit > Update References.

 

2)           Select All cross-reference and click Update. If FrameMaker can’t resolve all the cross-references, the Update Unresolved cross-references dialog box appears.

 

Related links:

Generate and update books

Resolve cross-references

Occasionally, FrameMaker can’t update a cross-reference for the following reasons:

•                

The marker or source of the cross-reference has been moved to a different file, or the file itself has been moved or renamed.

•               The source has been deleted, or if the source is a paragraph or spot, the marker indicating the source has been deleted.

 

•               The file containing the marker is currently open by someone else on the network server.

 

•               The value for the source element’s ID attribute or the cross-reference’s ID Reference attribute has been changed or deleted. The ID value must be the same at both locations.

 

Resolve cross-references using the cross-references pod

 

You can view the list of all unresolved cross-references from the cross-refer­ences pod. The pod list area displays the unresolved cross-reference, format of the cross-reference, document name, page number, source document, and the source type. All unresolved cross-references are indicated by a red cross symbol. You can select any cross-reference from the pod list area and the cross-reference is selected in the document.

 

•               Select Unresolved cross-references from the References list box in the cross-references pod.

 

Generate a list of unresolved cross-references

 

You can generate a list of unresolved cross-references. The generated list includes the page number of each unresolved cross-reference and indicates whether each missing source is internal (in the current document) or external (in a different document). The list includes additional information—for example, the tag and text of the source paragraph (unstructured documents), or the ID, element tag, and text of the source element (structured documents). The tag and text are not always accurate because they aren’t updated after you initially insert the cross-reference. For spot cross-references, the list includes the marker text.

 

1)           Choose Special > List of > References. When prompted, specify whether you want to create the generated file as a stand-alone document or add it to a book.

 

2)           Move Unresolved Cross-Refs to the Include References scroll list, and then click Set.

 

Resolve a cross-reference when a marker has been moved to another file or the file has been renamed

 

1)           Choose Edit > Update References.

 

2)           Choose Update Unresolved cross-references from the Commands pop-up menu.

 

3)           In the Total of Unresolved cross-references scroll list, select the file that used to contain the source of the unresolved cross-reference. The text below the scroll list indicates how many cross-references to the selected file are unresolved.

 

4)           In the Look In scroll list, select the file that contains the source, and click Open.

 

If FrameMaker can’t perform the update, select a different file in the Look In scroll list, and then try again.

5)           To resolve cross-references to any other file listed in the Total of Unre­solved cross-references scroll list, repeat steps 3 and 4. Then click Done.

 

Resolve a cross-reference when a marker has been deleted

 

1)           Choose Edit > Find/Change.

 

2)           Choose Unresolved cross-reference from the Find pop-up menu and click Find. The Find/Change panel finds the first unresolved cross-reference and provides information to Help you locate the source.

 

3)           Do one of the following:

 

•               If you do not need the cross-reference, delete it.

•               If FrameMaker finds an unresolved paragraph cross-reference, double-click the cross-reference to display the cross-reference panel, specify a different source, and click Replace.

•               If FrameMaker finds an unresolved spot cross-reference, insert a new cross-reference marker in the appropriate text. Use the same marker text that appears in the Find/Change panel.

 

Resolve a cross-reference when the ID and ID Reference values do not match (structured documents)

 

1)           Do one of the following:

 

•               Edit the ID or the ID Reference value so the two values match. ID attribute values are often read-only, so you sometimes have to edit the ID Reference.

 

•               Re-create the cross-reference.

 

Related links:

Insert a cross-reference in a structured document




8.                        Books and Long Documents

 

8.1.                   About books

 

A book file contains the filenames of the documents that make up the book, such as chapters and appendixes, generated files such as a table of contents, and other books. The filename and location of each file are added to the book file and a link is established between the file and the book.

 

A book can also be organized into a hierarchical setup of related documents using folders and groups. Folders act as chapters, sections, or sub sections depending on their hierarchical level within a book. You can also include related books within a book to build a complex documentation set.

 

A book file contains pagination and numbering settings for each file in the book. During a book update, FrameMaker updates the numbering throughout the book and can create and update the generated files as well.

Although books can include non-FrameMaker documents, such as .mif or .txt files, their processing is different from .fm files.

8.1.1.                Book building workflow

 

1)           Create a book and add files to it. These files can be .fm, .xml, .MIF, or even .book files.

 

2)           Organize files into folders or groups if necessary.

 

3)           Set up volume, chapter, page, and paragraph numbering.

 

4)           Add generated files, such as a TOC, list of tables or images, or an index.

 

5)           Update the book. This step populates a new TOC and index.

 

6)           Fix broken links and troubleshoot numbering and cross references.

 

7)           After fixing any errors, generate and update the book again.

 

note:  FrameMaker book file references the files included in the book. A file can therefore be included in multiple books.

8.1.2.                Set up hierarchical books

 

In FrameMaker, you can create hierarchical books that can include multiple books and files organized under folders or groups.

Hierarchical mixed FrameMaker book
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Saving a hierarchical book as a FrameMaker 8 book flattens the hierarchical structure. FrameMaker flattens the hierarchical structure to a single level.

 

8.2.                   Create books

 

8.2.1.                Create a book

1)            

Choose File > New > Book. If a document is active, an alert message asks if you want to include it in the book. A new book window appears showing the contents of the book.

 

2)           Choose File > Save Book As. A .book extension is added to the filename.

 

8.2.2.                Add files to a book

1)            

In the book window, choose Add > Files or click
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.

 

2)           Select the document file or files you want to add to the book, and then click Add.

You can add files by dragging them into a book window.

 note:  You can also add files by specifying an HTTP path and filename in the Add Files to Book dialog box. When doing this ensure that you specify a correct path and filename else you may get a message that the file is not in a recognized format and an uneditable dummy file is added to the book. 

Associate a structured application with an xml file

You can associate a structured application with the .xml files included in a book.

1)           Right-click the .xml file in the book window and select Properties.

 

2)           Select the structured application name from the Use Structured Applica­tion list box and click Continue.

 

8.2.3.                Add generated files to a book

1)            

Open the book window and select the file next to where you want the generated file to appear.

 

2)           Do one of the following:

 

•               Choose Add > Table of Contents or choose Add > List of, and then choose a type of list from the menu.

•               Choose Add > Standard Index, or choose Add > List of, and then choose the type of specialized index you want to create.

 

note:  You can also create TOCs, lists, and index for individual files in a book. For example, choose Special > List of Figures to create a standalone list of figures for the current document. You can also opt to create a book with a copy of the current file and its corresponding generated file. The generated files are always created in the same folder as the source file.

8.2.4.                Add a folder

You can add folders to your book and organize related documents in it. FrameMaker treats a folder as a logical container; it does not create a physical folder on the disk. A folder can have one or more folders, groups, or files within it.

Depending on the level at which you add a folder, it can act like a chapter, section, or subsection. You can set special numbering styles for a folder and all its contents. You can also choose to exclude files from being published by selecting Exclude from the context menu.

When you select a file in a book and add another file, the new file is added below and at the same level as the selected file. When you select a folder and add a file, the new file is added at the end of the files in the folder.
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A.

.Select One.fm and add Four.fm.

B.

Select Folder1 and add A.fm.

note:  If a file is already present in a book, you cannot add it again within a folder.

Rename a folder

1)            

Right-click the folder and select Properties.

 

2)           Type a new folder name in the Title box and click Set.

 

Associate a template with a folder

 Associate a template with a folder to publish a cover page for the files in the folder. Any template associated with a folder is published like any other file in a book. Use the <$chaptertitlename> variable to include the folder name in the template associated with the folder. You can use this variable for a folder occur­ring at any level in a book.

1)            

Right-click the folder and select Properties.

 

2)           Select the Template Path checkbox, browse, and select the template file­name and click Open.

 

3)           Click Set. The folder icon changes to indicate that a template is associated with the folder.

 

important:  A template associated with a folder is published in a PDF like any other file in a book.

 

To open a template associated with a folder, right-click on the folder and select Open. This opens all the files under the folder including the template file.

Related links:

File menu (book window)

Add file information for a folder template

You can specify file information, such as author name, file title, keywords for a template associated with a folder.

1)           Right-click the folder that has a template associated with it and select File Info.

 

2)           Specify the file information and click Set.

8.2.5.                Add a group

You can create groups in a book file. Like folders, groups are also logical containers in a book file; they do not exist on the disk. The difference between a group and a folder is that a group does not change the hierarchy of the files within it. Also you cannot set up numbering styles for a group.

For example, the chapter number increments sequentially if the chapter is in a group. For files organized under a folder, the chapter number remains the same but the section number can increment sequentially. You cannot explicitly change the chapter number for files in a folder as the files inherit this property from the folder.

Book 1
File 1         Chapter number = 1
File 2         Chapter number = 2
   File 3         Section number = 2.1
      File 4         Sub-section number = 2.1.1
Group 1          
   File 5      Chapter number = 3    File 6      Chapter number = 4 
Folder 1         Chapter number = 5
File 7      Chapter number = 5; Section number = 1    File 8      Chapter number = 5; Section number = 2            

8.2.6.                Add a child book

 You can also add books within books. These can be unstructured book files or DITA maps. You can now include multiple child books at multiple levels in a book.

1)           Open the parent book in which to add a child book.

 

2)           In the book window, choose Add > Files or click
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3)           Navigate to and select the .book file you want to add as a child book and click Add. Double-clicking the child book opens it in a separate Resource Manager panel.

 

note:  You can click the Browse URL button in the Add File dialog box to select a book residing on a WebDAV server.

 

A child book is treated as a placeholder within the parent book. You cannot edit a child book from within the parent book view. All maintenance tasks must be performed in the child book separately. For example, any book-wide operation on the parent book, such as spell check or find/replace works only on parent book files and not on the child book files. You should search and update child books separately.

Similarly, when updating a parent book for pagination and cross-references, ensure that you first update the child books and then update the parent book. This is because numbering and pagination information is stored at a book level. A book update on the parent book does not affect the page numbering within the files in a child book if the files in the child book are closed.

However, if the files from the child book are already open, then they are updated but not saved. You should always explicitly save all open files after a book update command or after applying a book-wide command.

When saving a parent book file as a PDF, FrameMaker updates information for only those files that belong to the parent book. To ensure that the information is correctly represented in the PDF for child books as well, do one of the following:

•               First update all child books and then their parent books before saving a book file as a PDF.

 

•               Open all files, including the files in the child books before saving the parent book file as a PDF. After creating the PDF, ensure that you save all the open files to preserve any updates.

8.3.                   Managing books

 

8.3.1.                Manage book files

 

Display filenames or heading text in the book window

1)            

Do one of the following:

 

•               Click the Display Heading Text icon
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.

 

•               Click the Display File Names icon
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Exclude book components from output

1)           Right-click the book component to exclude and select Exclude.

 

If you exclude a folder or group, all files within the folder or group are excluded from the outputs. When you update a book, the numbering is automatically updated to account for the excluded files.

 

Selecting book components

Select all book components

 

Choose Edit > Select > All.

 

Select all generated files in a book

 

Choose Edit > Select > Generated Files.

 

Select all nongenerated files in a book

 

Choose Edit > Select > Nongenerated Files.

 

Select only FrameMaker files, such as .fm, .book, .mif files

 

Choose Edit > Select > FrameMaker Files.

 

Select all excluded files

 

Choose Edit > Select > Excluded Components

 

Select all the files that are not marked as Excluded

 

Choose Edit > Select > Nonexcluded Components.

 

Select all the book components at the first hierarchical level

 

Choose Edit > Select > Chapter Components.

 

Select all book components at the second hierarchical level

 

Choose Edit > Select > Section Components.

 

Select all book components at the third hierarchical level

 

Choose Edit > Select > Sub-section Components.

 

Rearrange and delete files

When working with structured books, you can rearrange and delete files by working with element bubbles in the Structure View. After you update the book, the text snippets identify the files.

If you delete a file from a structured book you’ve updated, the file may retain some structure information inherited from the book. Remove this information from the file to make it a stand-alone document again.

1)            

In the book window, select one or more files. Do either of the following:

 

•               Drag the selected files to the desired position in the book window.

 

•               Choose Edit > Delete. Filenames are removed from the book window, but the files remain on the disk.

 

 

Rename files

When you rename a file in a book, FrameMaker renames the corresponding file on the disk and updates cross-references, hypertext links, and text inset links in other files in the book.

When you add a generated file (such as a table of contents or index) to a book, the file is assigned a name based on the book’s filename. If you leave generated files with the default filename and rename the book, then the filename is changed in the book, but not on disk. If you rename the generated file so it doesn’t have the default name, renaming the book won’t rename the generated file.

For example, in New.book, you have a generated file with the default name NewTOC.fm. If you rename the book to Samples.book, FrameMaker renames the generated file to SamplesTOC.fm in the book window, but not on disk. But if you rename the generated file as Contents.fm and then rename the book, the generated TOC remains Contents.fm in the book window as well as on disk.

1)            

Select the file you want to rename, and either choose Edit > Rename or right-click and choose Rename.

2)           Type the new name of the file and press Enter. When the alert message appears, click OK to update other files in the book.

 

Revert to a previously saved version

This procedure affects files that have been added or deleted, as well as settings that have been applied to documents in the book, such as numbering, pagina­tion, color definitions, and file setup specifications. The contents of documents are not changed.

1)            

Choose File > Revert to Saved Book.

note:  This command clears the command history. To undo only selected commands, use the History panel instead of Revert To Saved Book.

Open, close, or save files

You can use a book window to open, save, print, and close individual files in a book. You can also open, save, and close all the files in a book and print and update the format of several files or all files.

When you open a non-FrameMaker document from the book window, the appropriate application, if available, is launched.

1)            

Do one of the following:

 

•               To open one file in a book or map, make sure only the file is selected and double-click it.

•               To open several files in a book, select the files you want to open and press Enter.

 

•               To open all files in the book, hold down Shift and choose File > Open All Files in Book.

 

note:  Using Open All Files in books can be time consuming if there are many cross-references and text insets to update in the file. You can suspend the automatic update of cross-references or text insets by choosing Edit > Suppress Automatic Reference Updating from a book window, selecting the appropriate check box, and then clicking Set. When you open an individual document that has settings for automatic update, cross-references and text insets are still updated.

 

•               To close all files in a book, hold down Shift and choose File > Close All Files In Book.

 

•               To save all files in a book, hold down Shift and choose File > Save All Files in Book. The book file is also saved.

 

Compare documents

FrameMaker can compare two versions of a document to show you what has changed. FrameMaker compares not only the text in the two versions, but also the footnotes, markers, anchored frames, text insets, variables, and cross-refer­ences.

note:  For structured documents, FrameMaker additionally compares the struc­ture of the two documents and optionally can compare the attributes within those structures

1)            

Open both versions of the documents.

 

2)           In the document window of the newer version, choose File > Utilities > Compare Documents.

 

3)           Specify the older version of the document to be compared.

 

4)           Choose the report format. You can either have a summary document or a composite document.

 

The summary document gives a report of the differences in the files. Composite documents (which have a CMP suffix) show the differences in the files side by side.

 

5)           To set up the comparison options, click Options. The options screen is displayed as follows:

Comparison options
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 note:  To compare attributes within the structures, select Compare Attri­butes For Elements. If this option is not selected, attributes within the struc­tures are not compared. 

6)           Click Compare. The results are displayed in the selected reporting format.

 

7)           All differences are displayed with Track Changes. You can accept or reject the changes as desired.

 

 

Apply book-wide commands

Many FrameMaker commands can be used across some or all documents in a book. You can change view options, spell-check, or change the page layout of selected files in the book, among other options.

If the document associated with a book is open, FrameMaker applies the book-wide command to the document, but the document is not saved or closed. Therefore, in the case of open documents, you should explicitly save the changes before you close them.

If the document associated with the book is closed, FrameMaker silently opens the document, applies the book-wide commands, then saves and closes the document. If FrameMaker is unable to open a closed file or if other problems occur when you apply the command to a selected file, a message appears in the Book Error Log.

1)            

In the book window, select the file or files you want to change.

 

2)           Choose the desired command, such as Edit > Spelling Checker.

 

tip:  For .mif and .xml files, open the files before applying a book-wide command.

In structured documents, you can edit attributes, set available elements, and set new element options in the book.

8.3.2.                Add metadata to books and documents

 Metadata tags travel with a document and describe its content. If you export the file to PDF, much of this metadata will appear in Adobe® Acrobat®.

Metadata, or file information, is descriptive information that can be searched and processed by a computer. Use it to provide information about the contents of a document, and to preserve information about a document that will be opened in other Adobe applications. If you export the file to PDF, much of this metadata will appear in Acrobat.

Metadata tags travel with the document and describe its content. By embedding them in your documents, you make the documents easier to track, manage, and retrieve.

note:  Metadata in a book file sometimes overrides metadata in a document file. If your document is part of a book file, open the book file and select the document before you add metadata.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose File > File Info.

 

3)           Enter the desired information in the box next to any or all categories.

 

4)           For Marked, choose Yes if the document is copyrighted, or No if the docu­ment is explicitly in the public domain. Choose Unknown if you’re not sure.

 

5)           Click Set.

 

8.3.3.                Document and page numbering

 

About numbering

Each file in a book can have its own numbering system. For example, you might start page numbering at i on the title page, at 1 in the first chapter, and then number continuously through subsequent chapters. You can also add volume, chapter, section, and sub section numbers to page numbers—for example, the chapter 2 in the page number 2-1. All body pages in a document have the same numbering style.

The numbering properties in the book will override the numbering properties in documents that belong to the book. If you are setting up page numbering in a book, make sure you change the numbering properties by selecting documents in the book window instead of making changes in the individual documents.

You can change volume, chapter, section, sub section, page, paragraph, foot­note, and table footnote numbering in your documents.

After you set up numbering in books, you can add Volume Number, Chapter Number, Section Number, Sub Section Number, and Current Page # variables to page headers and footers. You can also use the <$volnum>, <$chapnum>, <$sectionnum>, <$subsectionnum>, and <$pagenum> building blocks to cross-reference formats, paragraph auto numbers, or generated files.

 

Numbering for files in a folder

 

Numbering for files within a folder is also determined by the level at which the folder exists in the book. For a file inside a first level folder, the chapter number is inherited from the parent book and cannot be edited. You can only set the section number for the files. For a file in a first level folder the Chapter tab is disabled in the Numbering Properties dialog box.

 

Similarly, a file within a second level folder inherits the chapter and section numbers but you can set the sub section numbers.

Numbering for files in a child book

 

In case of a book within a book, the number settings are determined by the level at which the child book is included. For example, all files in a child book at the first level inherit the chapter number from the parent book but the section numbers increment for each file in the child book.

note:  Generated files, such as the TOC or an Index file for a parent book having child books do not reflect any custom numbering settings on the child book. For example, the TOC of the parent book shows Numeric [14] page numbers even when the numbering for files in the child book is set to Roman [XIV]. 

Related links:

Numbering in Hierarchical Books

Set up numbering

1)            

If the document is part of a book, open the book and select the document in the book window.

 

2)           Choose Format > Document > Numbering.

 

3)           Select an option from the pop-up menu.

4)           Set options.

 

note:  If a book window was active when you opened the dialog box, you can select Read From File, which uses the numbering value specified in the associated document. If you selected more than one file in the book window, you can choose As Is to use the numbering values specified in the selected documents.

 

5)           Click Set.

 

Insert book component numbers in cross-references

1)            

Create a cross-reference format that includes the volume, chapter, section, or sub section number building block. The cross-reference format might look like this: See page <$chapnum><$sectionnum><$subsec­tionnum><$pagenum>–

 

tip:  To keep the chapter number on the same line as the page number, use a nonbreaking hyphen in the cross-reference format.

 

Include book component numbers in headers or footers

To number pages by chapter, you can use a Chapter Number (or Volume Number) variable or a running header/footer variable for the chapter numbers. You can also use Section Number or Sub Section Number variables. The numbers are updated automatically whenever you update the book.

1)           Display the master page that contains the header or footer.

2)           Place the insertion point in the header or footer where you want to add numbering and double-click the variable you want to add from the Vari­ables pod.

3)           Insert the appropriate punctuation, such as a hyphen or period.

 

4)           To add page numbering, choose Format > Headers & Footers > Insert Page #.

 

The header or footer should look like this on a body page:
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A.

Chapter number variable (<$chapnum>)

B.

Current Page # variable

Include the total page count of a book in a header or footer

You may want a header or footer to show the total number of pages of a book—for example, 4 of 200 on page 4 of a 200-page book.

When you insert the page count in a file’s header or footer with the Page Count variable, the header or footer shows the number of pages in that file, not in the entire book. To show the number of pages in a book, you can use a cross-refer­ence to a special paragraph you create.

1)            

Set up the files in the book for continuous page numbering.

2)           Display the master page for the last page of the last file in the book, and place the insertion point in an otherwise empty paragraph of the header or footer.

 

3)           Insert the Page Count variable by choosing Format > Headers & Footers > Insert Page Count.

 

Page Count variable in a separate paragraph
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4)           Create a paragraph format for the paragraph with the page count and store it in the Paragraph Catalog. Having a unique format for this paragraph makes it easier to cross-reference it later.

 

5)           If you don’t want the page count to appear where you put it, either resize the text frame so the page count is hidden or set the paragraph’s color to White.

6)           In the other files in the book, insert cross-references to the paragraph with the page count on each master page of each document. The cross-refer­ence format should use the <$paratext> building block.

7)           Put the cross-references in the header or footer on each master page of each file in the book, including the last one.

Related links:

Set up numbering

8.3.4.                Print a book file

In structured documents, element boundaries (either as brackets or as tags) are printable characters. Hide these boundaries before you print.

1)            

Update the book before you print files from it.

 

2)           In the book window, do one of the following:

 

•               Select the file or files you want to print, and then choose File > Print Selected Files.

 

•               Choose File > Print Book.

 

3)           Specify printing options and click Print.

Related links:

Print documents

Create a PostScript file

You can create a description of a document called a PostScript file (also called a print file). You might use a PostScript file to download the document later to a PostScript printer or to send the document to a service provider for typesetting.

 

Create a single print file from a document

 

1)           Choose File > Print.

 

2)           Select Print to File and enter the path and filename in the text box, or click Browse to specify a folder and filename.

 

Create a single print file for a book

 

1)           In the book window, choose File > Print Book, or select the documents you want to print and choose File > Print Selected Files.

 

2)           Select Print to File and enter the path and filename in the text box, or click Browse to specify a folder and filename.

3)           Choose Single File from the Save Book As (or Save Selected Files As) pop-up menu. Then click Print.

 

Create a series of separate print files for a book

 

1)           In the book window, choose File > Print Book, or select the documents you want to print and choose File > Print Selected Files.

 

2)           Select Print to File and enter the path and filename in the text box, or click Browse to select a folder and type a filename.

3)           Choose Single File or Separate File for Each Document from the Save Book As or Save Selected Files As pop-up menu. Then click Print.

 

8.3.5.                Change and import formats

You can make format changes in one file and then update all the files in a book by importing the formats from the updated file. To change the format of a subset of files in a book, you can select the files in the book window and then apply the formatting to the selected files.

important:  The format rules in element definitions often specify overrides so that a file can use as few catalog formats as possible. Normally, when importing formats into a structured book, you should not remove format overrides. 

FrameMaker merges the new formatting information into the document rather than replacing the existing information.

If a file isn’t open, it’s updated on the disk. If a file is open, it’s updated only in your computer’s memory and not on the disk. You must save the file to keep the changes.

 

Import formats into book files

1)            

Open or create the file that contains the formats you want to use. The file must be named and saved.

 

2)           In the book window, select the file or files you want to change, and then choose File > Import > Formats.

 

3)           From the Import From Document pop-up menu, select the file or template with the formats you want to import.

 

4)           Select the settings you want to import and update. If you’re updating cross-reference formats, math definitions, or variable definitions that use character formats, also select Character Formats.

 

5)           If you want to remove formatting changes you made but didn’t save in a catalog, do the following:

 

•               To remove page breaks that are not part of a paragraph format, select Manual Page Breaks.

 

•               To remove paragraph, character, page layout, and table formatting overrides, select Other Format/Layout Overrides.

 

In most cases, you should not select Other Format/Layout Overrides in a structured book because the element definitions may use format over­rides. However, you can select Other Format/Layout Overrides in an unstructured book without any repercussions.

 

6)           Click Import.

Related links:

About formatting overrides

Import element definitions into structured books

The definitions are stored in the Element Catalog for the book and the other files. You may need to import element definitions in the following cases:

•                

To add structure to an unstructured book. After importing the definitions, you can insert elements in the book file.

 

•               To update the element definitions in a book or its files. You need to update definitions whenever the application developer revises the definitions in your template.

 

•               To give a book and all its files the same element definitions. You may want to update a book if its files were created from different templates.

 

When you import element definitions into a book, FrameMaker replaces the definitions in the book and all its files with the new definitions and reapplies format rules from the definitions. It also validates the book file.

1)            

Open the book you want to update and the template, document, or book with the definitions to import.

 

2)           In the book window, select the files into which you want to import element definitions, and choose File > Import > Element Definitions.

 

3)           Choose the template or document from the Import From Document pop-up menu. The menu lists all open, saved documents and books.

 

4)           To remove format rule overrides in the files, select While Updating, Remove Format Rule Overrides. Use this setting if you have made text or paragraph formatting changes to elements and now want to return to the formatting described in the element definitions.

 

5)           Click Import. FrameMaker updates the element definitions in the book file and in the files listed in the Update scroll list.

 

Related links:

EDDs

8.3.6.                Set up a book file to create a master TOC or index

When you produce several related books, you may want to create a master table of contents (TOC) or index for the books.

1)            

Create a book file that contains the files in all the books in order.

If you’re adding files that were generated in the original books, add them to the new book as document files. If you need to update those generated files, do so from their original book file, not from the master book file.

 

2)           Add a table of contents, an index, or other generated file to the new book file. This generated file will be the master file.

 

3)           Using the book window, specify how volume, chapter, and page numbers for each document should appear in the master generated file.

 

note:  When you update the book, the book’s numbering options will over­ride the documents’ numbering options, unless you select Read From File.

 

4)           Using the book window, specify the appropriate pagination and page layout options.

 

5)           Generate and update the file.

Related links:

Tables of contents or other lists

Document and page numbering

Page layouts

8.4.                   Generate and update books

 

8.4.1.                Generate and update a book

After setting up a book and specifying page and paragraph numbering for each file in the book, you need to generate and update the files. Although you generate and update in one step, the two processes are different.

 Generating creates the table of contents, other generated lists, and indexes in the book file. The first time you generate a list or index, it uses the page layout (master pages) and reference pages of the first nongenerated document in the book file.

 Updating corrects numbering, revises cross-references so they reflect the numbering, reimports text insets, and adds or deletes empty pages where required. For structured documents it also revises the book’s element tags from information in the files and reapplies format rules from the book’s element defi­nitions.

Be sure to generate and update a book whenever you make any of the following changes to a document or a book file:

•                

Editing that affects pagination, such as content addition

 

•               Rearranging, adding, excluding, or removing files in the book

 

•               Changing conditional text settings or indicators

 

•               Editing that affects a generated file, such as changing a chapter title or adding a Section element in a structured document

 

•               Changing the setup of documents or generated files

 

•               Changing formatting information in the special text flow on a reference page of a generated file

 

•               Adding a new color (so that color separations will be accurate)

 

•               Importing new or revised element definitions (structured documents)

 

•               Changing the highest-level element in one of the book’s files (structured documents)

 

Update a book

 

1)           In the book window, choose Edit > Update Book, or click the Update Book icon 
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.

 

2)           Select whether you want to update numbering, cross-references, text insets, or generated files, such as tables of contents and indexes.

 

3)           Move the names of the files you want to generate to the Generate scroll list.

To move a filename between scroll lists, select the filename and click an arrow or double-click the filename. To move all filenames from one scroll list to the other, Shift-click an arrow.

 

note:  If no files are present, the book has no generated files. If no files appear in the lists—or if you move all the files to the Don’t Generate list—you should still continue to the next step to update the book’s pagina­tion, numbering, text insets, and cross-references.

 

4)           Click Update.

5)           Save the open files to keep the changes. Open files are updated only in your computer’s memory and not on the disk. If a file isn’t open, the changes are made on the disk—even if the file is in the View Only format.

 

Update a book with child books and .xml files

 

When you update a parent book, the child book files are not automatically updated. To update the numbering and cross-reference information in child book files, make sure all child book files are open before you update the parent book. Updates to the child book files are not saved and you are prompted to save changes when you close them.

 

Similarly, if a .xml file is already open, FrameMaker updates the numbering but does not save the changes. Therefore, when you close the .xml file you may be prompted to save changes.

 

Generated files, such as table of contents or index files from the child book are not included in the published output. This is because the generated files in the parent book contain information for the child book files as well. Also run book-wide operations separately for each book.

Update a structured book

 

Before you update a structured book the first time, each file in the book is repre­sented by an element called BOOK-COMPONENT. When you update, the element for each structured file changes to the tag of the highest-level element in that file—typically a tag such as Chapter that describes the file as a whole. (If a file has more than one flow, the tag comes from the highest-level element in flow A.)

The elements for any unstructured files in the book are still called BOOK-COMPONENT. To change BOOK-COMPONENT to an element tag, add structure to the files and then generate and update again.

 

Related links:

Troubleshooting books

8.4.2.                Remove inherited information from structured files

When you generate and update a book, the files in the book inherit structure information from the book file. A file’s Element Catalog may have inclusions and exclusions from the book, and other inherited information in the file may affect the formatting of its text elements.

If you delete a file from a book to use the file as a stand-alone document, reapply the file’s element definitions to remove any structure information that came from the book. If the file’s text formatting was affected by this structure infor­mation, reapplying the definitions also restores the file’s original formatting.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           In the file, choose File > Import > Element Definitions.

 

3)           Leave the Import from Document pop-up menu set to Current, select While Updating: Remove Information Inherited from Book, and click Import.

 

8.4.3.                Edit and validate book structure

A new book file has a structure with a highest-level element called NoName and an element called BOOK-COMPONENT for each document and generated file you added to the book. When you update the book, the elements for structured files change to the tag of the highest-level element from the file.

In most cases, you need to make a few corrections in the structure of a book file after updating. For example, you should change the NoName element to the highest-level element defined for the book. And if any file elements are still called BOOK-COMPONENT, add structure to those files and then generate and update again.

The book’s element definitions may also require you to group elements in higher-level elements such as FrontMatter, Body, and Appendixes.

Typical structure for a book file
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tip:  To open a file quickly, double-click its bubble in the Structure View.

You can edit the structure of a book in most of the same ways that you edit a document—by inserting, wrapping, and changing elements; merging and split­ting; dragging and deleting bubbles in the Structure View; and so on. However, you cannot merge or split elements that represent files, and you cannot undo a cut or paste in a structured book that contains anything other than the default structure.

Validate structure

You can validate an entire book (including its files), only the book file, or only the current element in the book file. If you validate the entire book, the structure of the book and each file is checked against the Element Catalog for the book.

1)            

In the book window, choose Element > Validate.

2)           Select Entire Book, Book Elements Only, or Current Element to specify the scope of the validation.

 

3)           To exclude missing elements or attribute values from the search, turn on Ignore Missing Elements or Ignore Missing Attribute Values.

 

If these settings are on, FrameMaker does not look for places where a required child element or a required attribute value is missing. You may want to turn these on if you are not trying to build a complete book at this time.

 

4)           Click Start Validating.

 

5)           If FrameMaker finds an error, specify whether to allow the error to remain, and then click Start Validating again.

The top part of the Element Validation dialog box shows the tag of the element and a brief message about the problem.

 

6)           Repeat step 5 until FrameMaker does not find any more errors.

 

Related links:

Import element definitions into structured books

Clear all special cases

1)            

Choose Element > Validate.

 

2)           Click Clear Special Cases. FrameMaker clears the special cases in the entire book, only the book file, or only the current element—whichever scope is selected in the dialog box.

 

Related links:

Generate and update books

8.5.                   Tables of contents or other lists

 

8.5.1.                About generated files

A generated file is a file FrameMaker creates by extracting paragraphs or marker text from a single source document or from several documents in a book. Each time a generated file is updated, all paragraphs and marker text is updated with the current text from the source documents. This way, FrameMaker keeps generated files, such as tables of contents and indexes current and accurate.

You can generate several types of lists and indexes in addition to a table of contents and standard index. For example, you can generate lists and indexes that contain text from paragraphs or from markers that you inserted in text. The result may be a table of contents based on heading paragraphs, a list of illustra­tions based on figure titles, or an index based on special author markers. Most lists and indexes fall into three categories: lists of paragraphs (or elements in structured documents), lists of markers, and indexes of markers. A fourth cate­gory, lists, and indexes of references, is used less often.

8.5.2.                About tables of contents and other lists

In Adobe FrameMaker, tables of contents (TOCs), lists of figures, and other such lists are generated from the text of specified paragraphs in a set of docu­ments. An index is generated from markers you insert in documents.

A table of contents or other generated list is based on the content of its source. The source can be either a single document or a group of documents in a book. In most cases, you must prepare the source documents to get the results you want.

Lists of paragraphs

 

Lists of paragraphs contain the text of specified paragraphs (those with the tags you specify), with one entry per paragraph (or elements in structured docu­ments). You can generate the following lists of paragraphs (or elements in struc­tured documents):

 

•               Tables of contents, which contain headings of specified levels, listed in the order in which they occur in the source documents

 

•               Lists of figures, tables, or paragraphs (or elements), which contain figure captions, table titles, or the text of other specified paragraphs, listed in the order they occur in the source documents

 

•               Alphabetical lists of paragraphs (or elements), which contain the same information as the other lists but present them in alphabetical order

 

note:  Tables of contents and lists support the Unicode text encoding standard.

 

Lists of markers

 

Lists of markers contain entries corresponding to the markers inserted on body pages in the source document. The markers are manually inserted on body pages in the source document (normally as marker elements in structured docu­ments), and the marker text appears in the generated list. For example, you could create a list of reviewers’ comments on a draft by generating a list of markers of type Comment. In a standard list of markers, entries appear in the order that they occur in the source document or book. You can also generate alphabetical lists of markers.

 

Indexes of markers

 

Indexes of markers include standard indexes, author and subject indexes, and indexes of other types of markers. The markers are manually inserted on body pages in the source document, and the marker text appears in the index. You can use syntax (building blocks) in the marker text to specify index levels and special page numbering, sorting, and formatting. Entries are sorted alphabeti­cally, and entries with the same text are merged into a single entry with several page references.

 

An index of Cross-Ref markers
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Lists and indexes of references

 

Lists and indexes of references help you track special categories of information. You can generate lists and indexes of condition tags, external cross-references, unresolved cross-references, fonts, text insets, unresolved text insets, and imported graphics.

 

8.5.3.                Generate a table of contents or list

 Before you generate a table of contents or other paragraph list, do the following to avoid problems in generated lists:

•                

Make sure that tags and elements are applied correctly and consistently. For example, use Heading1 for all first-level headings only.

 

•               Make each item you want to include in the list a single paragraph. For example, you won’t get the desired results if a heading is two lines, with each line in a separate paragraph.

 

•               Validate structured documents to make sure that they do not have struc­ture errors.

 

note:  You usually generate a list of references—such as a list of fonts or unre­solved cross-references—for your own use while working with a document. You do not need to prepare the document before generating such a list.

Generate a table of contents or list for a book

1)            

Open the book window and select the file below where you want the generated file to appear.

 

2)           Do one of the following:

 

•               Choose Add > Table of Contents.

•               Choose Add > List of, and then choose a type of list from the menu.

 

The items you see in the dialog box depend on the type of list you’re gener­ating.

 

3)           In the Add File pop-up menu, specify whether the generated list will appear before or after the current document.

 

4)           Enter a suffix or keep the default one. The suffix indicates the type of generated file. For example, TOC is the usual suffix for a table of contents.

note:  The suffix is not the same as the filename’s extension. The suffix is used with paragraph tags in the generated lists, and appears as part of the generated file’s filename, such as UserGuideTOC.fm.

 

5)           Move items to the Include scroll list. To move an item between scroll lists, select the item and click an arrow, or double-click the item. To move all items from one scroll list to the other, Shift-click an arrow.

 

6)           To have each entry in the generated list be linked to its source, select Create Hypertext Links. These links let you jump to the source of an entry by clicking the entry.

 

7)           Click Add, and then click Update. FrameMaker generates the list. You can view the generated list by double-clicking its name in the book window.

 

8)           Save the generated list in the same folder as the source document or book. If you want to rename the generated file, use the book window to do so—FrameMaker will rename it on the disk and update all references.

 

The first time you generate a list (if you don’t use a template), the list uses the page layout (master pages) of the first non-generated document in the book, and all entries look the same.

If the list already exists in the source document’s folder when you save it, save it in the same folder and don’t change the filename. That way, the list’s formatting is used when you generate the list again. Otherwise, formatting changes won’t be retained when you update the list.

 

tip:  To use a template or an existing generated file in a new book file, add it to the book as a generated file. Then put the existing file in the folder that contains the book file, using the name that appears in the book window.

 

9)           Save any open files in the book. Open files are updated only in your computer’s memory and not on the disk. If a file isn’t open, the changes are made on the disk.

 

Related links:

Formatting lists and indexes

Generate a table of contents or list for a single document

1)            

Do one of the following:

 

•               Choose Special > Table of Contents.

 

•               Choose Special > List of, and then choose a type of list from the menu.

 

2)           When prompted, specify whether you want to create the generated file as a stand-alone document or add it to a book.

 

If you choose Yes to create a standalone document, FrameMaker will create a generated list in the original document’s folder. If you choose No, FrameMaker adds the generated file to an open book, or creates a new book if necessary.

 

3)           Enter a suffix or keep the default one. The suffix indicates the type of generated file. For example, TOC is the usual suffix for a table of contents.

note:  The suffix is not the same as the filename’s extension. The suffix is used with paragraph tags in the generated lists, and appears as part of the generated file’s filename, such as Chapter1TOC.fm.

 

4)           Move paragraph tags, marker types, or reference types to the Include scroll list. To move an item between scroll lists, select the item and click an arrow, or double-click the item. To move all items from one scroll list to the other, Shift-click an arrow.

 

5)           To have each entry in the generated list be linked to its source, select Create Hypertext Links. These links let you jump to the source of an entry by clicking the entry.

 

6)           Do one of the following:

 

•               If you are creating a stand-alone list, click Set. FrameMaker gener­ates and displays the list.

 

•               If you are adding the list to a book, click Add, and then click Update. If a new book is created, choose File > Save Book As, and then save the book.

 

7)           Save the generated list in the same folder as the source document or book.

 

The first time you generate a list (if you don’t use a template), the list uses the page layout (master pages) of the source document or of the first nongenerated document in the book, and all entries look the same. For information on changing the format of a list—changes that won’t be lost when you regenerate the list.

 

8)           Save the list in the same folder as the source document or book.

 

Related links:

Formatting lists and indexes

Rename files

Generating TOCs and other lists in structured documents

Although the steps for generating TOCs and lists in structured documents are the same as for unstructured documents, consider the following additional points:

•                

A generated list is initially unstructured, but you can add structure to it. If a generated list is structured, you’ll lose the structure every time you regenerate it. Do not add structure to a list until it is in its final version.

 

•               The items in the scroll lists vary depending on the type of list you’re gath­ering. For example, the element and paragraph tags in the source docu­ment appear for a table of contents. (Paragraph tags appear after element tags and are preceded by a paragraph symbol
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.) For a list of references, the available reference types appear.

 

•               Some element tags may have context labels that provide information about the element’s location in the structure. For example, if Section elements can be nested within other Section elements, context labels might identify whether the elements are first-, second-, or third-level sections.

 

Context labels
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•                

If an element uses context labels, a <no label> entry also appears in the scroll list for occurrences not described by the labels. In the example above, Section(<no label>) represents Section elements that are at a fourth level or lower in the document.

 

•               If an element has more than one paragraph, only text from the first para­graph will appear in the generated list. For example, the first paragraph within a Section element—usually its Head—will appear.

•               The first time you generate a list (if you don’t use a template), it uses the page layout (master pages) of the first non-generated document in the book, and all entries look the same. The list also has element definitions from the source document.

 

Related links:

Generate indexes

Add a title or other static text to lists and indexes

If you want to add a title or other unchanging text in your list or index, add it after you generate the list or index the first time.

You can also add static text to a template and then use the template to format a list or index.

1)            

Type the title before the first entry on a body page.

 

2)           Use the Paragraph Catalog to give the text a special paragraph format for static text; or create a new paragraph format for the title.

3)           If you create a new paragraph tag, make sure it does not end with the suffix assigned when you created the generated file, such as IX for a standard index or TOC for a table of contents. When you generate the index again, FrameMaker replaces only the paragraphs that have tags ending with the suffix.

 

Related links:

Format a list or index with a template

8.5.4.                Embed TOCs in a document

If you want a small table of contents embedded at the beginning of the source document instead of in a file of its own, you can set up the table of contents with cross-references. A special cross-reference element should already be defined for structured documents.

A TOC embedded at the start of a document
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FrameMaker does not automatically maintain this type of table of contents. If you change the order of references or delete a heading while editing the docu­ment, you’ll need to rearrange the entries or delete an entry in the table of contents yourself.

You can also generate a separate table of contents and then import the generated file by reference at the beginning of the source document. In this case, the text inset with the table of contents is automatically updated when the table of contents changes.

Embed a TOC in a document by using cross-references

1)            

Create a cross-reference format that formats text the way you want the table of contents entries to look. Typically, this format would contain the <$paratext> and <$pagenum> building blocks.

 

2)           At the start of the document, set up a cross-reference to each paragraph you want to appear in the table of contents. Use the cross-reference format you created in the previous step.

 

Embed a TOC in a structured document by using cross-references

1)            

For each item you want to appear in the table of contents, insert a cross-reference element. The document may also have paragraph elements defined for formatting. See your application developer for infor­mation.

 

note:  Make sure that the sequence of entries in the table of contents reflects the sequence of source elements in the document. This isn’t automatic as it is with a generated table of contents.

 

Embed a TOC in a document as a text inset

1)            

Generate a table of contents.

 

2)           Import the table of contents into a document.

 

Maintain a TOC embedded in a document

1)            

Do the following:

 

•               If you change the order of paragraphs or source elements while editing the document, rearrange the cross-references to be in the same order. Then update the cross-references.

 

•               If you delete a paragraph or source element, delete the cross-refer­ence to it.

 

8.5.5.                Update and edit TOCs and lists

You update entries in a list by editing their corresponding paragraphs or markers in the source document and then regenerating the list. If you edit entries by typing directly in the list, your changes will disappear when you regenerate it.

For example, if you fix a typing error directly in a table of contents, that error will reemerge the next time you generate because it still exists in the source para­graph. To permanently fix an error, you must correct it by changing the para­graph or marker text in the source document and then regenerating the list.

important:  If a generated list is structured, you’ll lose the structure every time you regenerate it. Do not add structure to a list until it is in its final version.

Update a TOC or list that is part of a book

1)            

Make changes to the source documents as needed.

 

2)           In the book window, choose Edit > Update Book.

 

3)           Move the lists you want to update to the Generate scroll list, make sure Generate Table Of Contents, Lists, and Indexes is selected, and then click Update.

 

Add or remove paragraph tags included in a TOC or list that is part of a book

1)            

Select the generated file (such as the table of contents) in the book window.

 

2)           Choose Edit > Set Up Table Of Contents or Set Up List of type.

 

3)           Move items between the list boxes as desired, and click Set. Then click Update.

 

Update a TOC or list that is a stand-alone document

1)            

Make changes to the source document as needed.

 

2)           In the source document, choose the command (such as Table Of Contents) from the Special menu, and then choose Yes when prompted to create a standalone document.

 

3)           Move items between the list boxes as desired, and click Set.

 

Find the source of list entries

When you need to revise an entry, you trace the entry back to the corresponding paragraph or element in the source document.

1)            

If you did not select Create Hypertext Links when you generated the list or index, select it now and regenerate the list.

 

2)           In the generated list, Alt-Control-click an entry in a list.

 

FrameMaker opens the source document to the page that contains the corresponding paragraph and selects it. If the element is a marker, the marker text appears in the Marker panel.

 

Find and select a paragraph by using Find/Change

1)            

If you’re revising a marker element in a structured document, choose Special > Marker so you can see the marker text.

 

2)           In the source document (not in the generated list), choose Edit > Find/Change.

 

3)           Choose Paragraph Tag (unstructured documents) or Element (structured documents) from the Find pop-up menu. Enter the tag or element you want to find, and then click Find.

 

note:  When a marker element is selected, the marker text appears in the Marker panel. Don’t click Change in the Find/Change dialog box to change the marker text. If you do, FrameMaker replaces the marker itself. Instead, change the text in the Marker panel, and then click Edit Marker.

Edit or delete list entries

1)            

In an unstructured document, edit or delete the paragraph text.

 

2)           In a structured document, select the element, and do either of the following:

 

•               Change the text in the Marker panel, and click Edit Marker.

 

•               Press Delete.

 

8.6.                   Creating indexes

 

8.6.1.                Create index entries

In a typical index, entries are generated from markers and are sorted alphabet­ically. Entries with the same text are merged into a single entry with several page references. You can add special building blocks to marker text to control the form of the index entry—for example, to specify that it’s a subentry or a cross-reference to another entry.

Index entries

[image: bk_ix_07.png]

A.

Main entry

B.

Subentries

C.

Cross-reference to another entry

D.

Page range

You can also create specialized indexes by using predefined marker types such as Subject or Author, or by using other marker types that you create.

note:  Indexes support the Unicode text encoding standard.

Index marker placed in the source document, and the formatted entry appearing in the index

[image: bk_ix_09.png]

 

Inserting an index marker

 

1)           Click where you want to insert the marker or select the word that you want to include in the Index and click Insert from the Markers pod. You can insert markers only in text frames.

 

2)           Choose a marker type from the pop-up menu. Typically, you’ll use the Index marker type. To create several indexes for a document—for example, a subject index and an author index—use a different marker type for each.

3)           Enter the text of the index entry in the Marker panel. You can enter up to 255 characters (127 Japanese double-byte characters). You can also use any of the following building blocks in marker text to control the form of the index entry and its location in the index.



	
Building block

 


	
Meaning

 





	
: (colon)

 


	
Separates levels in an entry

 





	
; (semicolon)

 


	
Separates entries in a marker

 





	
[ ] (brackets)

 


	
Specifies a special sort order for the entry

 





	
<$startrange>

 


	
Indicates the beginning of a page range

 





	
<$endrange>

 


	
Indicates the end of a page range

 





	
<$nopage>

 


	
Suppresses the page number in the entry

 





	
<$singlepage>

 


	
In a marker that contains several entries, restores the page number for an entry that follows a <$nopage> building block

 





	
Character tag between angle brackets ( < > )

 


	
Changes the character format (for example, <Emphasis>)

 





	
<Default Para Font>

 


	
Restores the paragraph’s default font

 






If you’re working in Japanese fonts, enter all these building blocks except the brackets ([ ]) using single-byte characters.

 

note:  To enter a backslash or any special character used in these building blocks—colon, semicolon, bracket, or angle bracket—as regular characters, precede it with a backslash ( \ ).

 

4)           Click New Marker. A marker symbol

[image: Marker.png]

 appears when text symbols are visible.

 

Related links:

Add, edit, or delete markers and marker types

Insert index marker elements (structured documents)

1)            

Click where you want to insert the marker.

 

2)           Select a marker element in the Element Catalog and click Insert.

 

You can also use Special > Marker to insert an element. If more than one marker element is available, choose the one you want from the Element Tag pop-up menu in the dialog box.

 

3)           To change the marker type, choose from the Marker Type pop-up menu. Changing to another type is not a format rule override, even if the element has a type preselected.

 

Consult your developer before changing a marker type. Your document may have a separate element defined for each marker type you’ll need.

 

You can generate an index from the predefined Index, Subject, and Author marker types. Some custom types may also be available.

 

4)           Type the text of the index entry. You can enter up to 255 characters (127 Japanese characters). You can also use any of the following building blocks in marker text to control the form of the index entry and its location in the index.



	
Building block

 


	
Meaning

 





	
:   (colon)

 


	
Separates levels in an entry

 





	
;   (semicolon)

 


	
Separates entries in a marker

 





	
[ ]   (brackets)

 


	
Specifies a special sort order for the entry

 





	
<$startrange>

 


	
Indicates the beginning of a page range

 





	
<$endrange>

 


	
Indicates the end of a page range

 





	
<$nopage>

 


	
Suppresses the page number in the entry

 





	
<$singlepage>

 


	
Restores the page number for an entry that follows a <$nopage> building block in a marker that contains several entries

 





	
Character tag between angle brackets ( < > )

 


	
Changes the character format (for example, <Emphasis>)

 





	
<Default Para Font>

 


	
Restores the paragraph’s default font

 






note:  To enter a backslash or any of the special characters used in these building blocks—bracket, colon, semicolon, or angle bracket—as a regular character, precede it with a backslash ( \ ).

 

5)           Click New Marker. If text symbols are showing, a marker symbol

[image: Marker00002.png]

 appears in the document window. A bubble for the marker appears in the Struc­ture View, with a text snippet that shows the beginning of the marker’s text.

 

6)           If the Attributes for New Element dialog box appears, enter attribute values for the marker element and click Insert Element.

7)           If no marker element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

 

 

Insert an index marker without typing

1)            

To reduce or eliminate typing when creating index markers, do one of the following:

 

•               Insert an empty marker or marker element (with no text in it) at the beginning of the word. When you generate the index, the text to the right of the marker, up to the first space, becomes the text of an entry.

•               To use text that appears in the document as the marker text, simply select the text in the document. As long as the selected word or phrase doesn’t contain a marker, it automatically appears in the Marker Text box.

 

Place several entries in one marker

1)            

Type several entries in the marker, using a semicolon (;) between entries, as in the following examples.

 



	
Marker text

 


	
Result in index

 





	
Abrasion; Water erosion

 


	
Abrasion   10

Water erosion   10

 





	
<$nopage>Erosion. See Abrasion;<$singlepage>Abrasion

 


	
Abrasion   10

Erosion. See Abrasion

 






In the second row of the example, the <$nopage> building block affects subsequent entries in the marker. To return to a single page number, <$singlepage> is included with the next entry in the marker.

 

You can type any number of spaces after the semicolon to improve read­ability. Initial spaces are ignored when compiling the index unless they’re special ones such as nonbreaking or em spaces. (If you’re working in Japa­nese fonts, only single-byte space characters are ignored.)

 

Create an index subentry

You can group several entries under one entry for a larger category of informa­tion by marking them as subentries. You can also create subentries to suben­tries.

Subentries

[image: bk_ix_10.png]

1)            

Separate the entry from the subentry with a colon (:). For example, to create the first subentry in the illustration, enter Continental drift:fossil evidence 

A subentry is always preceded by the entry to which it is subordinate. If you need two subentry levels, place a colon between the subentry and the sub-subentry. For example, enter Continental drift:fossil evidence:dating of 

Create a cross-reference in an index entry

Indexes often contain cross-reference entries to direct readers to related terms. This makes it unnecessary to duplicate the entries and page numbers for related terms that already appear in the index.

Cross-references

[image: bk_ix_11.png]

Cross-references can also appear as subentries (usually preceded with See also, as in the illustration). You can sort subentries so that they appear at the top or bottom of the list under the same main entry.

1)            

Insert a marker and use <$nopage> at the beginning of the marker text to prevent a page number from appearing with this entry. For example, to create the first cross-reference in the illustration, enter <$nopage>Abra­sion. See also Sandstone 

Related links:

Change sort order

Use page ranges in index entries

You can use a page range such as 36–37 to mark information that spans several pages.

You can create a page range in an entry by manually inserting two markers to indicate the range, one at the beginning of the range and the other at the end. You can also have FrameMaker create page ranges for you automatically when­ever the same marker text occurs on consecutive pages of a document. For example, instead of 3, 4, 5, the entry would automatically appear as a page range (3–5).

Manually create a page range for an index entry

1)            

Insert an index marker at the beginning of the information, with <$star­trange> at the beginning of the marker text. For example, to create the first page number in a range, enter <$startrange>Continental drift:fossil evidence 

2)           Add an index marker (or marker element, if working with a structured document) at the end of the information, identical to the first except that you enter <$endrange> rather than <$startrange> at the beginning of the marker text. For example, to create the second page number in a range, enter <$endrange>Continental drift:fossil evidence 

If both markers appear on the same page, the page range collapses to a single page number.

Automatically create page ranges in an index

1)            

Display the reference page that contains the special text flow for indexes.

 

2)           Type the <$autorange> building block at the beginning of the paragraph whose tag begins with the marker type.

 

To collapse the entries generated from markers of type Index into page ranges when possible, edit the paragraph tag IndexIX to contain the following building blocks: <$autorange><$pagenum> 

Related links:

Edit special text flow for a list or index

8.6.2.                Format text in an index entry

You can change the character format of specified text or of the page number in an entry. For example, you may want a book title to appear in italics, or you may want a particular page number to appear in bold. The character format must be stored in the Character Catalog of the index.

Character formatting.

[image: bk_ix_13.png]

1)            

Enter an index entry.

 

2)           To format part of the entry in a character format, do one of the following:

 

•               To format specific text in an entry, type the character tag between angle brackets ( < and  > ) before the text and type <Default Para Font> after it. For example, to create the entry “Tidal Waves See Tsunami,” you might enter this marker text: Tidal Waves <Emphasis>See <Default Para Font> Tsunami 

Character format tags affect only the entry they precede. For example, <bold>fruit:strawberry would generate a two-line entry that shows “fruit” as bold and “strawberry” without bold. To format both entries in bold, enter <bold>fruit:<bold>strawberry 

•               To format only the page number, type the character tag between angle brackets at the end of the marker text. For example, to create the entry “Erosion   24,” you might enter this marker text: Erosion<Bold> 

tip:  If you’re using a special character format for many—but not all—page numbers in an index (for example, to use bold for principal entries), you may want to create a custom marker type with that formatting.

 

Related links:

Change paragraph and character formats of entries

Add, edit, or delete markers and marker types

8.6.3.                Work with group titles in indexes

Index entries are initially grouped one letter at a time—all the As, all the Bs, and so on—using the uppercase letter as a group title. In a small index or when only a few entries appear under some letters such as X, Y, and Z , you may want to group letters differently and change the group titles.

FrameMaker inserts group titles as if they were index entries but uses a different paragraph format. It uses the labels and sort positions you specify in the Group­Titles paragraph in the special text flow.

An edited GroupTitles paragraph on the IX reference page
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A.

Sorting information

B.

Group title

The result in the index
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Change the groupings and group titles

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow for the index.

 

2)           Edit the GroupTitles paragraph in the special text flow. For example, edit the group titles (the characters between semicolons, excluding bracketed text), or delete group titles you don’t want. Type text between brackets (  [ ]  ) to specify where you want the group titles sorted.

For example, to collapse all entries that start with V through Z into a single group whose title sorts under V, edit the GroupTitles paragraph so that its last entry is V–Z[V].

 

tip:  The first two entries in the GroupTitles paragraph define what group titles to use for symbols and numbers and where to place these titles. You can change the titles, but changing the sort information of these two groups might give unexpected results.

 

Create an index without group titles

1)            

Edit the GroupTitles paragraph in the special text flow to look like this:

[image: bk_ix_47.png]

 

 

Create an index with neither a group title nor a space between entry groupings

1)            

Delete all the text in the GroupTitles paragraph in the special text flow, but don’t delete the paragraph symbol.

Create quick access to group titles in a hypertext document

1)            

Generate clickable thumbtabs to the group titles to make navigating through the index easier.

 

8.6.4.                Change sort order

Indexes are sorted so that special symbols appear first, numbers appear second, and alphabetic characters appear last. By default, a few punctuation characters are ignored in sorting, and alphabetic characters appear in the correct sort order for the English language.

note:  When generating indexes in multilingual documents, symbols sort based on the Unicode Collation Algorithm (UCA) of the Unicode text encoding stan­dard.

Specify sort order for an index entry

You can change where an entry appears in the index by specifying a sort order. For example, even though 486 would normally appear with other numbers in the index, you may want it to appear under F (as if it were spelled out as four eighty-six). Similarly, if you’re using a See also cross-reference in a subentry, you can ensure that it is the last one under the main entry.

1)            

Add text between brackets ([ and ]) at the end of the marker text, indi­cating exactly how you want the entry sorted.



	
Index marker text

 


	
Result in index

 


	
Explanation

 





	
1950s[Nineteen fifties]

 


	
Neap tides   47

1950s10     

North America   21

 


	
Sorts under N (for Nineteen fifties)

 





	
Erosion:of soil

[Erosion:soil]

 


	
Erosion

rate   32

      of soil   10

 


	
Ignores the word of 





	
<$nopage>Erosion:

see also Wind

[Erosion:aaa]

 


	
Erosion

see also Wind 

      rate    16

 


	
Sorts as the first entry under Erosion 





	
<$nopage>Erosion:

See also Wind

[Erosion:zzz]

 


	
Erosion 

      rate    16

See also Wind 


	
Sorts as the last entry under Erosion 






note:  The sorting information, in brackets, must be the last item in the marker text.

 

Specify sort order for an index

You change the sort order by specifying a sort order and by editing the contents of the IgnoreChars and the SortOrder paragraphs in the special text flow of the reference page for the index.

The SortOrder paragraph in the special text flow contains building blocks that control how characters are sorted in an index.

SortOrder paragraph

[image: bk_ix_42.png]

Each sort order building block represents several characters in a particular order. The following table shows the order for U.S. English. The alphabetic sort order differs slightly for other languages.



	
 

Building block

 


	
Characters, in this order

 





	
<$numerics>

 


	
0 1 2 3 4 5 6 7 8 9

 





	
<$alphabetics>

 


	
A Á  À  Â  Ä  Ã  Å  a á  à  â  ä  ã  å  ª    B b   C Ç  c ç    D d   E É  È  Ê  Ë  e é  è  ê  ë    F f ƒ    Gg   H h   I Í  Ì  Î  Ï  i ì  í  î  ï    J j   K k   L l   M m   N Ñ  n ñ    O Ó  Ò  Ô  Ö  Õ  Ø  o ó  ò  ô  ö  õ  ø  º    P p   Q q   R r   S s   T t   U Ú  Ù  Û  Ü  u ú  ù  û  ü    V v   W w X x   Y Ÿ  y ÿ    Z z

 





	
<$symbols>

 


	
All other characters in ASCII order

 






1)           Choose View > Reference Pages, and display the reference page that contains the special text flow for the index.

 

2)           Replace a building block in the SortOrder paragraph with the specific characters in the order you want them sorted. Follow these rules when entering a new sort order:

 

•               If you replace <$alphabetics> with individual characters, separate the letter groups with a space. (Letter groups—for example, F f ƒ —are characters that are sorted as if they were the same character, unless they are the only characters that differ in the sorted text. In that case, the first character in the string appears first.)

 

•               If you replace <$symbols> with individual characters, use a backs­lash before the angle bracket symbols ( < > ).

 

•               Don’t press Return at the end of a line. Let FrameMaker wrap the characters automatically from line to line.

 

•               To indicate that a letter pair should be sorted as a single character, specify the letter pair between angle brackets (< >)—for example, C Ç  c ç<CH><Ch><ch>. In this example, all the characters or letter pairs are in the same letter group (the letter C ). The letter pair CH is sorted after the letter C, and uppercase letter pairs are sorted before lowercase letter pairs.

 

Related links:

Edit special text flow for a list or index

Sort letter by letter instead of word by word

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow for the index.

 

2)           Add a space at the beginning of the IgnoreChars paragraph in the special text flow of the index. (The space cannot be at the end of the paragraph.)

 



	
Sorted letter by letter

 


	
Sorted word by word

 





	
Seabed

Sea level

Seasonal change

Sea walls

 


	
Sea level

Sea walls

Seabed

Seasonal change

 






Specify characters to ignore

By default, FrameMaker ignores hyphens, nonbreaking hyphens, en dashes, and em dashes when sorting index entries. You can specify other characters to be ignored—for example, underscore characters, periods, brackets, braces, and quotation marks.

An IgnoreChars paragraph with added characters

[image: bk_ix_40.png]

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow for the index.

 

2)           Edit the IgnoreChars paragraph.

 

note:  If you’re working with Japanese fonts, you may want to include the Chouon character

[image: chouon.png]

 in the IgnoreChars paragraph. The Chouon character is normally used in Japanese to lengthen the vowel sound that it follows, but you probably won’t want it to affect the sort order.

Sort symbols, numbers, or other characters in another location in an index

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow for the index.

 

2)           Rearrange the building blocks in the SortOrder paragraph in the special text flow. For example, to put symbols at the end of an English-language index instead of at the beginning, arrange the building blocks as follows: <$numerics><$alphabetics><$symbols>

 

Specify the sort order for Japanese

Kanji characters always need a special sort order defined.

A document that uses Japanese fonts includes the <$kana> building block, which controls sorting of Japanese kana (hiragana and katakana).



	
Building block

 


	
Characters, in this order

 





	
<$kana>

 


	
[image: bk_ix_48c.png]

 

 






Single-byte (half-width) katakana are converted to double-byte katakana in the generated file when sorted. The sort order of kanji is determined by its kana pronunciation (yomigana). Because of this, the <$kana> building block also controls how most kanji sort.

The sort order of kanji without yomigana and of Japanese symbols (double-byte numerics and Roman alphabetics) is not included by default in the <$kana> building block. Instead, kanji is sorted by code value and appended after char­acters sorted by <$kana>.

If you want to sort kanji without yomigana and Japanese symbols differently, add these characters to the <$numerics>, <$alphabetics>, or <$kana> building blocks. For example, double-byte Japanese characters could be added to the <$symbols> building block.

1)            

Enter its pronunciation (yomigana) in brackets in the marker text. (Double-byte bracket characters may be used.)

Sort order for kanji index entry

[image: bk_japanese_marker.png]

 

8.6.5.                Generate indexes

After you insert index markers in your source document, you can generate a standard index or any other index of markers. When you revise your source document, you can generate the index again to update it.

You ordinarily use predefined marker types. However, you can create your own marker types for special effects in indexes, such as displaying principal entries in bold or adding custom text to some page entries but not to others. The custom text might be the word note to follow some page numbers and figure to follow others. Scholarly indexes might use abbreviations, such as ff and passim after page numbers.

You can also generate a special-use index of references, such as an index of fonts used in a document. This type of index is not generated from markers.

Generate an index for a book

1)            

Open the book window and select the file above where you want the generated file to appear.

 

2)           Do one of the following:

 

•               Choose Add > Standard Index.

 

•               Choose Add > Index Of, and then choose the type of specialized index you want to create.

 

3)           Move the marker types you used for the entries to the Include Markers of Type scroll list.

 

Generating a book index

[image: bk_generate_ix.png]

 

To move an item between scroll lists, select the item and click an arrow, or double-click the item. To move all items from one scroll list to the other, Shift-click an arrow.

 

4)           In the Add File pop-up menu, specify whether the generated list appears before or after the current document.

 

5)           Enter a suffix or keep the default one. The suffix indicates the type of generated file. For example, IX is the usual suffix for a standard index.

note:  The suffix is not the same as the filename’s extension. The suffix is used with paragraph tags in the generated lists, and appears as part of the generated file’s filename, such as UserGuideIX.fm.

 

6)           To link each entry in the generated index to its source, select Create Hypertext Links.

 

7)           Click Add, and then click Update. FrameMaker generates the index and displays it in a separate document.

8)           Save the index in the same folder as the source document or book. If you want to rename the generated file, use the book window to do so—FrameMaker will rename it on the disk and update all references.

 

The first time you generate an index, it uses the page layout of the first nongenerated document in the book, and all entries look the same. (You can avoid this unformatted look by using a template.) For information on making changes to the format of an index—changes that won’t be lost when you regenerate it.

 

9)           Save any open files in the book. Open files are updated only in your computer’s memory and not on the disk. If a file isn’t open, the changes are made on the disk.

 

Related links:

Formatting lists and indexes

Generate an index for a single document

1)            

Do one of the following:

 

•               Choose Special > Standard Index.

 

•               Choose Special > Index Of, and then choose the type of specialized index you want to create.

 

2)           When prompted, specify whether you want to create the generated file as a standalone document or add it to a book.

 

If you choose Yes to create a stand-alone document, FrameMaker will create a generated index in the original document’s folder. If you choose No, FrameMaker adds the index to an open book, or creates a new book if necessary.

 

3)           Enter a suffix or keep the default one. The suffix indicates the type of generated file. For example, IX is the usual suffix for a standard index.

note:  The suffix is not the same as the filename’s extension. The suffix is used with paragraph tags in the generated lists, and appears as part of the generated file’s filename, such as UserGuideIX.fm.

 

4)           To link each entry in the generated index to its source, select Create Hypertext Links.

 

5)           Do one of the following:

 

•               If you are creating a stand-alone index, click Set. FrameMaker generates and displays the index.

 

•               If you are adding the index to a book, click Add, and then click Update. If a new book is created, choose File > Save Book As, and then save the book.

 

The first time you generate an index, it uses the page layout of the source document or of the first nongenerated document in the book, and all entries look the same. For information on making changes to the format of an index—changes that won’t be lost when you regenerate it.

 

6)           Save the index in the same folder as the source document or book.

 

Related links:

Formatting lists and indexes

Rename files

Generate a standard index that displays page numbers in a variety of ways

1)            

Create one or more custom marker types, and name them in a way that indicates their intended use. For example, if you want to distinguish index entries that refer to footnotes, you might create a marker type called IndexNote.

 

2)           Index your source document, using the Index marker type for regular entries and your custom marker types for the others.

 

3)           Generate the index. Select the Index marker type along with the custom ones.

 

In the index, edit the special text flow on the reference page for the custom marker (the reference page would be called IX) to add text after the page number or to change character format. For example, you might change the text for IndexNoteIX as follows to have [note] appear after the page number: <$pagenum> [note].

 

4)           Update the index again for your edits to take effect.

 

Related links:

Add, edit, or delete markers and marker types

Manually add text to entries

Change paragraph and character formats of entries

8.6.6.                Update and edit indexes

An index can quickly become outdated. With an index, you typically need to make changes after you review the index for the first time. For example, some entries might not use parallel phrasing, or you may decide to change the orga­nization of some entries.

You edit entries in an index by editing their corresponding paragraphs or markers in the source document and then regenerating the index. If you revise entries by typing directly in the index, your changes will disappear when you regenerate it.

For example, if you fix a typing error directly in an index, that error will reemerge the next time you generate because it still exists in the source marker. To permanently fix an error, you must correct it by changing the marker text in the source document and then regenerating the index.

Related links:

Update and edit TOCs and lists

Update an index that is part of a book

1)            

Make changes to the source document as needed.

 

2)           In the book window, choose Edit > Update Book.

 

3)           Move the lists you want to update to the Generate scroll list, make sure Generate Table of Contents, Lists, and Indexes is selected, and then click Update.

 

Add or remove items included in an index that is part of a book

1)            

Select the generated index in the book window.

 

2)           Choose Edit > Set Up Standard Index (or Set Up Index of type).

 

3)           Move items between the list boxes as desired and click Set. Then click Update.

 

Update an index that is a stand-alone document

1)            

Make changes to the source document as needed.

 

2)           In the source document, choose the command (such as Standard Index) from the Special menu, and then choose Yes when prompted to create a stand-alone document.

 

3)           Move items between the list boxes as desired, and click Set.

 

8.6.7.                Find the source of index entries

When you need to revise an entry, you must trace the entry back to its source—the corresponding marker (or marker element, if working with a struc­tured document) in the source document.

The quickest way to find the source of an index entry is to use the hypertext link on the entry in the generated file. This hypertext link can display and select the corresponding information in the source document. If you’re working with a structured document, you can select the element in the Structure View if you can see its bubble.

Another simple way to find and select a marker in the source document is through the Markers pod. The Markers pod displays marker text, the marker type, and document in which the marker is. You can sort the list on marker type to view all the index marker entries in a document. Selecting an entry in the Markers pod automatically highlights the marker in the document. Double-clicking an entry opens the Markers panel for quick editing.

Using the Markers pod makes it easier to select a specific marker if there are multiple markers at exactly the same location in a document.

important:  If you’re generating extremely large indexes (indexes of more than 50,000 markers), don’t use Create Hypertext Links. Generating indexes of this size with Create Hypertext Links selected takes a long time or might not succeed.

Find the source of an index entry by using a link

1)            

If you did not select Create Hypertext Links when you generated the index, select this option and regenerate.

 

2)           Choose Special > Marker.

 

3)           In the generated index, Alt-Control-click a page reference in an index.

 

FrameMaker opens the source document to the page that contains the corre­sponding marker and selects it. The marker text appears in the Marker panel.

Select a marker by using Find/Change

1)            

In the source document (not in the generated list), choose Edit > Find/Change.

 

2)           Do one of the following:

 

•               If you’re working in an unstructured document, choose Any Marker, Marker of Type, or Marker Text from the Find pop-up menu. Enter the marker type or marker text as needed.

 

•               If you’re working in a structured document, choose Element from the Find pop-up menu, enter the tag of the element you want to find, and click Set.

 

3)           Click Find.

 

note:  When a marker is selected, the marker text appears in the Marker panel. Don’t click Change in the Find/Change dialog box to change the marker text. If you do, FrameMaker replaces the marker itself. Instead, change the text in the Marker panel and then click Edit Marker.

8.6.8.                Add, edit, or delete markers and marker types

You can create your own marker types and then use them in lists or indexes just as you would any other type of marker. After a new marker type has been created, it can be shared with other documents and books.

Edit or delete a marker

1)            

Select the marker (or element) you want to delete and do one of the following:

 

•               Click Delete from the Markers pod.

 

•               Click Delete Marker from the Marker panel.

 

2)           Select the marker (or element) you want to edit, change the text in the Marker panel, and click Edit Marker.

 

Add or delete a custom marker type

1)            

Choose Special > Marker and choose Edit from the Marker Type pop-up menu.

 

2)           Do one of the following:

 

•               Type a new name and click Add.

 

•               Choose a name from the pop-up menu and click Delete.

 

3)           Click Done.

 

tip:  You can also use the book window to edit custom marker types. Select the documents you want to affect, and then press Esc e m t.

Copy a marker type from one document to another

1)            

Do one of the following:

 

•               Copy a marker or text containing a marker and paste it in another document.

•               Choose File > Import > Formats and import Document Properties.

 

Rename a marker type

1)            

Choose Special > Marker and choose Edit from the Marker Type pop-up menu.

 

2)           Choose the marker type you want to rename from the pop-up menu and click Change.

 

3)           Do one of the following:

 

•               To rename the specified markers with a new name, enter the new name in the To text box.

 

•               To rename the specified markers with the name of another marker type, choose the new marker type from the To pop-up menu.

 

4)           Click OK, and then click Done.

8.7.                   Formatting lists and indexes

 

8.7.1.                Format a list or index with a template

The first time you generate a list or index (if you don’t use a template), it uses the page layout of the source document or the first nongenerated document in the book, and all entries look the same. You can change the page design and the formats in the list or index after you generate it, just as you do in any other docu­ment. When you generate the file again, your changes are retained.

1)           Copy the template to the source document’s folder using the same file­name as the list or index.

 

2)           Generate the list or index.

 

tip:  You can also use File > Import > Formats to import a template’s formats. Then generate the list or index again so any changes in the special text flow are reflected in the generated file.

8.7.2.                Edit special text flow for a list or index

 

Many formatting aspects of a list or index are controlled by a special text flow on a reference page in the generated file. The name of the reference page matches the default suffix, such as TOC for a table of contents or IX for a stan­dard index.

For generated lists, each paragraph in the flow corresponds to a paragraph tag or marker type you included in the list. These paragraphs have tags that use the default suffix. For example, a paragraph tagged Heading1TOC in the text flow for a table of contents corresponds to the entries for first-level headings (tagged Heading1 in the source document).

Special text flow on reference page for a table of contents

[image: bk_ix_26.png]

For indexes, the paragraphs in the flow correspond to the marker types you included in the index, the levels of entries and subentries, the sort order, the separator text used, and several other index properties.

Special text flow for an index

[image: bk_ix_27.png]
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If the list or index was created with hypertext links, the special text flow also contains a paragraph that specifies the form of the hypertext commands in the generated file. The paragraph’s tag begins with the word Active.

Special text flows for lists and indexes have special paragraphs with placeholder text. This placeholder text lets you specify how your entries will look when you regenerate the file.

Building blocks placed in each paragraph of the special text flow determine the information that appears in the list or index, and the order in which the infor­mation appears. You can use the following building blocks in the special text flow.



	
Building block

 


	
Meaning

 





	
<$autorange>

 


	
Automatically creates index page ranges

 





	
<$numerics>

<$alphabetics>

<$symbols>

<$kana>

 


	
Specifies the overall sort order in an index

 





	
<$pagenum>

 


	
Displays the page number on which the source paragraph or marker appears

 





	
<$volnum>

 


	
Displays the volume number of the document in which the source paragraph or marker appears

 





	
<$chapnum>

 


	
Displays the chapter number of the document in which the source paragraph or marker appears

 





	
<$paratext>

 


	
Displays the text of the paragraph, excluding any autonumber

 





	
<$paranum>

 


	
Displays the paragraph’s entire autonumber, excluding spaces and tabs at the end of the autonumber (for example, Section 2.1.1)

 





	
<$paranumonly>

 


	
Displays the paragraph’s autonumber counters and the characters between them (for example, 2.1.1)

 





	
<$paratag>

 


	
Displays the source paragraph’s tag

 






1)           In the list or index, choose View > Reference Pages.

2)           Display the reference page that contains the text flow you want.

 

3)           Edit the appropriate paragraphs in the text flow.

 

4)           Choose View > Body Pages.

 

5)           Generate the index again to see the effect of your changes.

 

note:  Make sure that you generate the list or index from the source document, not from the generated file.

Related links:

Use page ranges in index entries

Change paragraph and character formats of entries

8.7.3.                Change paragraph and character formats of entries

You can change the look of entries in a generated list and index by modifying their paragraph formats.

You can also change the character format of any text appearing in a list and of all index page numbers created with the same marker type. For example, you could make all page numbers italic.

note:  If you create a new character format in the source document after you generate the list or index, you may have to use File > Import > Formats to import the character format into the generated list. This is necessary only if you use the new character format in a paragraph or marker that’s part of the list or index. If you created the character format before first generating the list or index, FrameMaker imports it for you into the generated file.

Change the paragraph format of entries

1)            

In the list or index, display the reference page that contains the special text flow. Usually this is TOC for a table of contents and IX for a standard index.

 

2)           Locate the placeholder paragraphs that have paragraph formats corre­sponding to the list or index entries. (For example, Level1IX is the format for the placeholder text for the first-level index entry, and Head1TOC is the format for a Head1 entry in a table of contents.)

 

3)           Change the properties of the paragraph formats, such as indents and font size, and update the paragraph formats, so that they are available the next time you generate the file. The placeholder paragraphs show you how the entries will look.

Formatted placeholder paragraphs

[image: bk_ix_28.png]

 

Change the character format of entries

1)            

In the list or index, create a new character format and store it in the Char­acter Catalog.

 

2)           Choose View > Reference Pages and display the reference page that contains the special text flow.

 

3)           In the paragraph whose tag corresponds to the entries you want to change, do the following:

 

•               In a list, enter the character tag between angle brackets (< >) before the text you want to change. To change back to the paragraph’s default font, enter <Default Para Font>. For example, you could define a format tagged ChapNumFont, and then use it to format chapter numbers in a larger font in a table of contents.

 

Reference page and resulting TOC

[image: bk_ix_29.png]

 

•               In an index, enter the character tag, between angle brackets (< >), to the left of <$pagenum>. For example, if IndexPgNum is a character format defined for italic page numbers in a standard index, you could use it to format just the page numbers in the paragraphs tagged IndexIX.

 

Reference page and resulting index

[image: bk_ix_30.png]

 

tip:  You can also change the character format of text that appears in a list or index by applying a character format directly to the building block rather than preceding the building block with a character tag enclosed in angle brackets. Be careful not to apply the character format to the paragraph symbol.

 

 

8.7.4.                Include book component and paragraph autonumbers

 In a generated list, you can include autonumbers—text and numbers inserted automatically as part of a paragraph format—in addition to (or instead of) page numbers in entries. In an index, you can use autonumbers instead of page numbers if all paragraphs that contain index markers are also autonumbered.

Index using section symbols and section numbers instead of page numbers

[image: bk_ix_31.png]

You can use the following building blocks to add autonumbers:

•                

<$volnum>, <$chapnum>, <$sectionnum>, <$subsectionnum> which include the volume, chapter, section, and sub section counters.

 

Building block for volume and chapter autonumbering, and resulting index

[image: bk_ix_34.png]

 

•               <$paranumonly>, which includes the counters and the characters between them (for example, 2.2 for a paragraph whose autonumber is Section 2.2).

 

Building block for paragraph autonumbering using section numbers, and resulting index

[image: bk_ix_32.png]

 

•               <$paranum>, which includes the counters and all text in the autonumber (except for spaces or tab characters at the end).

 

Building block for paragraph autonumbering using “Section” text and section numbers, and resulting index

[image: bk_ix_33.png]

 

Related links:

Document and page numbering

Include volume and chapter autonumbers

1)            

Choose View > Reference Pages and display the reference page that contains the special text flow.

 

2)           In a list or index, type the <$volnum> or <$chapnum> building block where you want to insert the autonumber.

 

For example, to include the chapter number along with the page number (such as 3-1) in entries generated from markers of type Index, type <$chapnum>- before the <$pagenum> building block in the paragraph tagged IndexIX.

 

tip:  To make sure numbers such as “3-1” don’t break between lines, insert a nonbreaking hyphen by pressing Esc hyphen h.

 

Include paragraph autonumbers

1)            

Choose View > Reference Pages and display the reference page that contains the special text flow.

 

2)           Do one of the following:

 

•               In a list, type the <$paranumonly> or the <$paranum> building block where you want to insert the autonumber.

 

•               In an index, replace the <$pagenum> building block with <$paranum> or <$paranumonly> in the paragraph with the tag that begins with the marker type. For example, to include the paragraph autonumber rather than the page number in entries generated from markers of type Index, replace the <$pagenum> building block in the paragraph tagged IndexIX.

 

8.7.5.                Change page number separators

A typical index entry such as Erosion 1, 23 –includes a space after the entry text, a comma and a space between page numbers, an en dash to show a page range, and nothing after the last number. You can change the en dash to the word to, or change this separator text in any other way. For example, you could change the separator text so that a comma appears after the entry, such as Erosion, 1.

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow.

 

2)           Edit the Separators paragraph. (Look for the paragraph containing 1, 23–.) You can change any separator, but you must use the placeholder numbers 1, 2, and 3.

A custom Separators paragraph on the IX reference page

[image: bk_ix_35.png]
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8.7.6.                Manually add text to entries

You can add text to all entries generated from paragraphs with a particular tag or markers of a particular type. For example, you can enclose page numbers in brackets.

Brackets added in a TOC

[image: bk_ix_36.png]

You can also use custom marker types with added text to display page numbers in a variety of ways in an index. For example, suppose you want to generate the following scholarly index.

Custom page numbers added in an index

[image: bk_ix_37.png]

To do this, you need two custom markers: one for page numbers followed by ff, and one for page numbers followed by note. You might call these markers Indexff and IndexNote.

When generating the index, you include all three marker types (Index plus the two new ones). After generating the index for the first time, you can edit the special text flow for the marker types on the reference page.



	
Marker type

 


	
Edit to the reference page

 


	
Result

 





	
Indexff

 


	
<$pagenum> ff 


	
15 ff 





	
IndexNote

 


	
<$pagenum> note 


	
15 note 






The next time you generate the index, the changes appear in the generated index.

1)           Choose View > Reference Pages, and display the reference page that contains the special text flow for the list or index.

 

2)           Enter the text where you want it to appear. For example, to enclose all page numbers in brackets, enter brackets around the page number building blocks: <$paratext>[<$pagenum>] 

8.7.7.                Use tabs and tab leaders in a list or index

You can use tabs to align page numbers in a list or index. You can also use tabs to add tab leaders, such as a row of dots, between entry text and page numbers.

Right-aligned tab stop with leader dots in a TOC

[image: bk_ix_38.png]

Tab stops make index page numbers line up in columns.

[image: bk_ix_39.png]

1)            

Choose View > Reference Pages and display the reference page that contains the special text flow.

 

2)           Do one of the following:

 

•               For a list, select the space between the <$paratext> and <$pagenum> building blocks in the paragraph whose tag matches the entries you want to change.

 

•               For an index, select the space before the number 1 in the Separators paragraph.

 

3)           Press Tab.

 

4)           Change the paragraph format by adding a tab stop where you want to align the page numbers. Define the format to include leader dots, if you want. Then update the paragraph formats so the changes are available the next time you generate the list or index.

 

 

8.7.8.                Rearrange information in list entries

You can specify the order in which the parts of a list entry appear. For example, you can specify that the page number appear first, followed by the paragraph text.

1)            

Choose View > Reference Pages, and display the reference page that contains the special text flow for the table of contents or list.

 

2)           Rearrange the building blocks. For example, to put the page number first, followed by the paragraph text, rearrange the building blocks: <$pagenum>   <$paratext>.

 

8.7.9.                Resolve cross-references

 

Resolve a cross-reference when a marker has been deleted

1)            

Choose Unresolved Cross Reference from the cross-references pod. Ensure that you have the correct filename selected. The pod shows all unresolved cross-references.

 

2)           Do one of the following:

 

•               If you do not need the cross-reference, delete it.

•               If FrameMaker finds an unresolved paragraph cross-reference, double-click the cross-reference to display the cross-reference dialog box, specify a different source, and click Replace.

•               If FrameMaker finds an unresolved spot cross-reference, insert a new cross-reference marker in the source text. Select the new marker from the cross-reference dialog box and click Replace.

 

Resolve a cross-reference when the ID and ID Reference values do not match (struc­tured documents)

1)            

Edit the ID or the ID Reference value so the two values match. (ID attri­butes are often read-only, so you may have to edit the ID Reference.)

8.8.                   Footnotes and endnotes

 Footnotes are notes placed at the bottom of a page that comments on or cites a reference for a designated part of the text. Endnotes are notes placed at the end of a chapter or book that comments on or cites a reference for a designated part of the text.

8.8.1.                Create and edit footnotes

 

Insert, edit, and delete footnotes

When you insert a footnote reference and footnote, FrameMaker gives it a number, formats the text of the footnote, and inserts a separator if the footnote is the first one in a column.

[image: bk_xr_07.png]
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As you insert, move, and delete footnotes, FrameMaker adjusts the numbering. As you edit the surrounding text, FrameMaker moves the footnotes from page to page as needed. FrameMaker allows document footnotes to be numbered consecutively across all files in a book.

The footnote reference and the footnote itself usually appear in the same column. When you insert a footnote reference in a table, the footnote appears at the end of the table. If the table flows onto a second page, all the footnotes appear on the second page regardless of the page on which the footnote refer­ence appears.

Insert a footnote

note:  The Footnotes feature supports the Unicode text encoding standard.

1)            

Click where you want the footnote reference to appear. You can insert a footnote reference in a column of text or in a table cell.

 

2)           Choose Special > Footnote. FrameMaker inserts the footnote reference, displays the footnote number at the bottom of the column or below the table, places the insertion point after the footnote number, and renumbers any footnotes that follow. (Footnotes are numbered consecutively in a text flow. If your document contains several text flows, footnote numbering in each flow will be independent of the others.)

 

3)           Type the text of the footnote at the insertion point. When you finish typing the footnote, return to the main text by clicking in it or by choosing Special > Footnote again.

 

tip:  To place two footnote references together, place a space or a comma between them—for example, references 5    6 or references 5,6 . Otherwise, the second foot­note won’t be created. If you place a comma between the footnote references, you should manually format the comma in superscript. 

Insert a footnote element (structured documents)

 

1)            

Click where you want the footnote reference to appear.

2)           Select a footnote element in the Element Catalog and click Insert.

 

FrameMaker inserts the footnote reference, displays a footnote number at the bottom of the column or end of the table, and renumbers any foot­notes that follow. A bubble for the footnote appears in the Structure View, with a text snippet that shows the beginning of the footnote text.

 

You can also use Special > Footnote to insert a footnote element. If more than one footnote element is available, choose one from the Element Tag pop-up menu in the dialog box that appears.

 

3)           If the Attributes for New Element dialog box appears, enter attribute values for the element and click Insert Element.

4)           Type the text of the footnote at the insertion point. When you finish typing the footnote, return to the main text by clicking in it or by choosing Special > Footnote.

 

Use an invalid footnote element

If no footnote element is available at the location you want, you might use an invalid element. After inserting the element, talk to your developer about making it valid at this location.

1)            

Do one of the following:

 

•               To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.

 

•               To insert an invalid footnote with the default tag FOOTNOTE, choose Special > Footnote. (A default footnote is created if no defined footnote elements are available.)

 

 

Edit a footnote

1)            

Select the footnote text and edit it as you do other text. You can’t change a footnote number, because FrameMaker maintains the numbering.

Duplicate, move, or delete a footnote

1)            

Select the footnote reference (not the footnote text). Alternatively, in Structure View, click the footnote’s bubble.

 

2)           Do one of the following:

 

•               To duplicate or move the footnote, use Edit > Copy or Edit > Cut, and then Edit > Paste.

 

•               To delete the footnote, press Delete.

 

Keeping a footnote in the same column as its reference

FrameMaker sometimes can’t keep footnotes in the same column as the corre­sponding footnote reference. For example, if you insert a footnote reference at the bottom of a column of text so there is no space for the footnote below it, FrameMaker moves the footnote to the bottom of the next column. In such cases, you can force a column or page break before the footnote reference to keep the reference and the footnote together in the same column.

Adding text to a footnote may cause the last footnote in a column or on a page to move to the bottom of the next column or page. To reduce the chance of a footnote not fitting in a column, allocate more space for footnotes in a column.

Related links:

Change footnote properties

Insert multiple references to a footnote

You can create a single footnote that has several footnote references—for example, a table footnote with references in several cells.

Two references for one footnote

[image: bk_xr_08.png]

important:  If you add or remove a footnote that appears before the footnote being cross-referenced, the cross-reference may refer to the wrong number. Choose Edit > Update References to update the numbering.

1)            

Insert the first footnote reference.

 

2)           If necessary, create a cross-reference format for additional footnote refer­ences.

 

The cross-reference format must display the footnote number correctly. For example, if footnote references are displayed in superscript, and if the document contains a Superscript character format, a cross-reference format defined as <Superscript><$paranumonly> displays the auto­number of a paragraph as a superscript. When you use it to refer to a para­graph that contains a footnote, it displays the footnote number in superscript.

 

3)           Click where you want to insert the additional footnote reference.

 

4)           Choose Special > cross-reference to insert a cross-reference to the foot­note where you clicked. Use the cross-reference format you created in step 2.

5)           Click Insert. FrameMaker inserts a cross-reference that is identical to the original footnote reference.

 

Insert multiple references to a footnote (structured documents)

You need to have a special cross-reference element already defined for the addi­tional references. The element should display a reference number in the same way that the original footnote reference does. For example, if the number is in superscript in the original reference, the number in the cross-reference element should also be in superscript.

1)            

Insert the footnote element.

 

2)           Where you want an additional footnote reference, insert a cross-reference element that was defined to display only a footnote reference.

 

 

Format footnotes

You can change any of the footnote properties—for example, the style of numbers, the numbering format, or the paragraph format to use for footnote text.

FrameMaker uses different formats for document and table footnotes.

Change footnote properties

Changes except the paragraph format are applied to both new and existing foot­notes.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Document > Footnote Properties. To edit table footnote properties, choose Table Footnote from the pop-up menu.

 

3)           Do the following:

 

•               To adjust the maximum height allowed for footnotes in a column, enter a value in the Maximum Height Per Column text box.

 

•               To use a different paragraph format for new footnotes, enter the format’s tag in the Paragraph Format text box. (The format must be stored in the document’s Paragraph Catalog.) To use a different format for an existing footnote, apply the format to it directly.

tip:  By default, documents may include paragraph formats named Foot­note and TableFootnote to be used for new footnotes. To change the look of footnotes, change these formats.

 

•               Specify the format of the footnote reference in the main text and of the footnote number in the footnote. Either number can be in the superscript, baseline, or subscript position, and either can have a prefix and suffix.

 

4)           Click Set.

 

 

Change footnote numbering style

note:  If you’re working with documents that are part of a book, it’s a good idea to set the properties from the book window rather than directly from the docu­ment window. When the book is updated, the book properties will override the document properties.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Document > Numbering. Choose either Footnote or Table Footnote from the pop-up menu.

 

3)           Choose a numbering style from the Format pop-up menu. If you choose Custom, you can specify a set of custom footnotes in the Custom Numbering dialog box; click Set when you’re done.

 

Your custom style can use any combination of numbers, letters, and symbols, which will be used in the order you enter them. If you use symbols in a custom style and your document contains more footnotes than symbols, the symbols are repeated. For example, if you use the two symbols * and †, and the document contains three footnotes, the third footnote is marked **. The footnote number will appear in the default font of the footnote’s paragraph format.

 

Custom footnote numbering

[image: bk_xr_05.png]

 

note:  Some special characters are entered or displayed differently in dialog boxes. You enter a sequence of characters beginning with a backslash (\).

 

4)           Choose whether you want document footnote numbers to be restarted on each page, start numbering footnotes at a specific number, or be continued from the previous chapter in the book. When you number sequentially, you can start from any number. The numbering of table foot­notes always starts over with each table.

 

5)           Click Set.

 

 

Change the footnote separator

The footnote separator is a graphic frame automatically placed between the bottom of the body text or table and the first footnote. It usually contains a line or other design element to provide visual separation between the body text and footnotes. The height of the frame determines the space between the body text or table and the footnote.

Separator frames for document and table footnotes are stored on a reference page. Their names are the same as the paragraph formats used for these foot­notes—by default, Footnote and TableFootnote.

Reference page
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Footnote separator on body page
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1)            

Choose View > Reference Pages and display the page that contains the footnote separator frame.

 

2)           Resize the frame or edit its contents. You can change the size or position of the line in the frame, or remove or replace the line. If you reduce the height of the frame, the first footnote is positioned closer to the bottom of the text or table. If you move the line downward in the frame, the first footnote stays in the same position but the line moves closer to it.

tip:  To add space, but not a line, between the body text or table and the footnotes, leave the separator frame empty.

3)           Choose View > Body Pages.

 

 

Using footnotes in multicolumn layouts

The placement of footnotes in multicolumn layouts depends on the location of the footnote reference and on the presence or absence of side heads or text that straddles columns.

Side heads

 

In a single-column document with side heads, footnotes in the body column run the width of the body column, but footnotes in a side head span the side-head area and the body column.

 

Footnotes in side head span body column and side-head area.
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If you want a footnote in a side head to be aligned with footnotes in the body column, change the indents of the footnote in the side head area by adding a distance equal to the width of the side-head area plus the gap.

 

Straddles

 

In a multicolumn format where some text straddles all columns and other text does not, footnotes may or may not straddle the columns. Footnotes whose references appear in straddle text always straddle the columns, and these footnotes appear at the bottom of the text frame. Footnotes whose references appear in nonstraddle text straddle the columns if the foot­notes’ paragraph format is set to Across All Columns (in the Pagination properties of the Paragraph Designer).

Footnote across all columns
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If the paragraph format is set to In Column, the footnote appears either just above the next straddle paragraph (if there is one on the page) or at the bottom of the column.

 

Footnote in column
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If the footnotes appear out of order, select Across All Columns for the footnote paragraph format to force all footnotes to appear in numerical order at the bottom of the page.

 

 

8.8.2.                Create and maintain endnotes

 

Create an endnote

1)            

Type the first endnote at the end of the document and assign it the para­graph format for endnotes. The paragraph format should include an auto­number so the endnotes will be numbered consecutively.

 

2)           Click where you want to insert the endnote reference and cross-reference the endnote. Use the cross-reference format you created for endnotes.

 

For example, if endnote references are to be displayed in superscript, and if the document contains a Superscript character format, the cross-refer­ence format <Superscript><$paranumonly> displays the autonumber of the endnote paragraph as a superscript.

Create an endnote in structured documents

 

1)            

Insert the endnote element at the end of the document, and type the text of the note.

 

2)           Click where you want to insert the reference to the endnote.

 

3)           Insert a cross-reference element that was defined to display an endnote reference.

note:  Make sure that the sequence of endnotes is the same as the sequence of references in the document. FrameMaker does not automatically sequence endnotes as it does with footnotes.

 

Maintain endnotes

•                

If you change the order of endnote references while editing the document, rearrange the endnotes to match the order of the references. Then update the cross-references to update the endnote reference numbers.

•               If you delete an endnote, delete all references to it. Otherwise, the refer­ence will be an unresolved cross-reference.

 

8.9.                   Conditional documents

 

8.9.1.                About conditional text

Sometimes you author different types of content for different output formats using the same FrameMaker document. This document can contain conditional text and conditional graphics for each type of output. For example, to create both a PDF print version and an HTML Help version of a document, mark the different content for each using condition tags.

You can also use conditional text to include comments to yourself or to your reviewers. You can hide the comments before you print the final copy.

Conditional text differs from one version of a document to another. Uncondi­tional text is common to all versions.

You can make any unit of text conditional, from one character to entire sections. Anchored graphics, tables, cross-references, footnotes, markers, and table rows can be conditional. You make an item conditional by applying condition tags.

 Two versions of a data sheet: Conditional text can be used to create two data sheets in one document. The text and graphics common to both data sheets are unconditional. The text and graphics that appear in only one data sheet are assigned a condition tag that identifies the data sheet.
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A.

The art and first paragraph contain both conditional and unconditional information.

B.

.Unconditional text.

The condition tags of the current selection (or at the insertion point) appear in parentheses in the Tag area of the status bar.

Tag area of status bar
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You can change the appearance of conditional text so that it’s easy to identify by using condition indicators—style and color changes.

Condition indicators (strikethrough and underline) identify two conditions.
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You can view all versions of the document or hide selected versions. You can show or hide condition indicators. Whatever you display appears in the printed document.

Conditional text pod

 

Conditional Text pod
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G.
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H.

Search
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List of conditional tags and their attributes

Planning conditional documents

When planning a conditional document, assess the nature of the material and the number of people maintaining the document. Plan to treat conditional material consistently to make the document easier to use and maintain. Inform others of the conventions you followed as you applied condition tags.

Use these guidelines when planning a conditional text project:

Number of versions

 

Define how many versions you intend the finished project to contain. For example, to create a manual that describes a program that runs on two platforms, you likely produce at least two versions. Sometimes you want these versions with editorial comments added to text during review. In this case, you can add more versions: UNIX with comments, UNIX without comments, Windows with comments, and Windows without comments.

 

Number of condition tags required

 

Decide how many condition tags you want to produce the desired versions. A unique set of condition tags defines each version of a docu­ment. For example, a Windows condition tag showing, a UNIX condition tag hidden, and a Comments condition tag hidden defines a version of a finished Windows manual. In this example, decide whether to use one condition tag for Windows comments and another for UNIX comments. You can also use a single condition tag for both Windows and UNIX comments.

 

Organization of content

 

Assess how much of the document can be conditional and how you can organize the material to simplify development and maintenance. Perhaps you can organize a book so that conditional text is limited to a few docu­ments. You can keep versions of a chapter in separate files rather than in conditional text. Then use a different book file for each version of the book. Alternatively, in a structured document, you sometimes want to specify entire chapters of a book for printing only.

 

Graphics

 

If a document contains graphics imported by reference into a conditional anchored frame, create separate folders for the graphics in each version. Creating separate folders simplifies file management when you copy or archive a version of the document with its graphics files.

 

Variables

 

Words and phrases that are used repeatedly in a document are easier to work with as variables than as conditional text.

 

Decide whether your conditional documents need different variable defi­nitions for each version. For example, a data sheet can use a variable with the product name, while the conditional document describes two prod­ucts. You can create a template for each version of the document. Each template has only one version visible and defines the variables for that version. You can use File > Import > Formats to switch the variable defi­nitions from one version to another.

 

Tagging strategy

 

Determine the smallest unit of conditional text. For example, if a condi­tional document is translated to another language, a whole sentence is the smallest amount of text you make conditional. Because word order often changes during translation, using conditional text for part of a sentence complicates translation. Other strategies include these guidelines:

 

•               Decide whether to make spaces and punctuation conditional. If condi­tional text begins or ends with punctuation, make the punctuation condi­tional. Conditional punctuation makes the text easier to read when you’re viewing more than one version.

 

•               To avoid word spacing problems, set standards for handling spaces following conditional text. Define them as either always conditional or always unconditional.

 

•               Decide the order in which conditional text appears and use this order throughout the document. The order can Help subsequent authors main­tain the document.

 

Multiple authors

 

If a conditional document has several authors, follow these guidelines:

 

•               Plan document organization and workflow. For example, break a document into small files so several people can work on different parts of the document at the same time.

 

•               Decide how to provide explanatory notes to other authors. To Help explain a conditional document, add helpful comments and apply the predefined Comment condition tag to them.

 

8.9.2.                Create, edit, and delete condition tags

 You can define unique condition indicators for every condition tag that you create in a FrameMaker document. If your conditional document is used to create more than two versions, define color indicators. You can perform create and edit tasks use the Conditional Text pod.

tip:  If another document contains the conditional text settings that you want to use in your current document, import them by choosing File > Import > Formats.

Create or edit a condition tag

1)            

In the Conditional Text pod, do one of the following:

•               To create a condition tag, click Create a New Tag. The Add/Edit Condition Tag panel appears.

 

•               Enter a name in the Tag Name box. To facilitate keyboard shortcuts, use meaningful names that begin with a unique first letter.

 

note:  Condition Tag names support the Unicode text encoding stan­dard.

 

•               Select a tag to edit, and click Edit. Modify the name in the Tag Name box.

 

2)           Select a style from the Style list.

 

3)           Do one of the following:

 

•               Select a color from the Color list.

 

•               Click New Color. Define the required color settings for the new color you are creating, and click Add. Click OK to confirm, and then click Done. Select the new color preference in the Color list.

 

4)           Click Add. The Conditional text pod shows the changes. If an existing condition tag is modified, changes are applied across the current FrameMaker document.

 

Delete a condition tag from a document

1)            

Select the tag you want to delete. Click Delete, and click OK to confirm.

 

FrameMaker removes the condition tag from any text that uses it. If any text is tagged only with the condition tag that you are deleting, the Delete Condition Tag dialog box appears. You have the option to either make the text unconditional or to delete the text. Select the appropriate option and click OK.

 

tip:  You can delete condition tags that aren’t used in a document when you’re unsure which condition tags are used. Use Special > List of > References to generate a list of references that includes condition tags.

8.9.3.                Apply and remove condition tags

To make text conditional, you apply tags, or copy and paste condition tag settings. You can apply multiple tags to text in a FrameMaker document.

You can distinguish text to which a single condition tag is applied, from text with multiple condition tags.

You apply a new condition tag to selected text to which another condition tag is already applied. In this case, the color of the text is changed to a different color. This color is midway of all colors of the condition tags that you have already applied to the current text.

You can also use the Find/Change command to paste condition tag settings.

tip:  You can merge two versions of a document into one conditional document. When you merge two versions, FrameMaker compares them and creates a composite conditional document.

Apply a condition tag to an item

1)            

Select the text or item you want to make conditional, as described in the following table:

 



	
To make this conditional

 


	
Select





	
Text in a text frame, table cell, or footnote

 


	
Text

 





	
Anchored frame and its contents

 


	
Frame border or anchor symbol

 





	
An entire table

 


	
Table anchor symbol

 





	
Table row

 


	
Whole row

 





	
Cross-reference or variable


	
Cross-reference or variable text

 





	
Footnote

 


	
Footnote reference (the number in the main text)

 





	
Marker

 


	
Marker symbol

 






note:  You can make text in text frames conditional, but not text in text lines.

 

2)           To apply a condition to the selected text or item:

a)           Select the condition from the Conditional Text pod

 

b)           Select Conditional option

 

c)           Select the In option

3)           Click Apply. FrameMaker applies the settings to the selected text. If you apply a hidden condition tag, the selected text disappears, unless it is also tagged with a condition that is displayed.

FrameMaker has a new feature that allows you to apply a conditional tag to the whole element, even if only a part of the element is selected. The conditional text element boundaries feature is only applicable to structured documents.

To enable this feature, edit maker.ini and set the value of ApplyCondTillElementBoundaries to On. Restart FrameMaker.

Now, selecting some text within an element and applying a condition, will apply the condition to the whole element and not just to the selected text.

Additionally, with this feature, a single cell in a table can be selected and a condi­tion applied. The condition is then applied across the entire corresponding row in the table.

Copy and paste condition tag settings

1)            

Place the insertion point in text that uses the condition tag settings you want to copy.

 

2)           Choose Edit > Copy Special > Conditional Text Settings.

 

3)           Make a selection or click to place the insertion point.

 

4)           Choose Edit > Paste.

Avoiding unresolved cross-references

Sometimes you insert a cross-reference to a paragraph, and the first word in the paragraph is conditional. The Cross-Ref marker that FrameMaker inserts is also conditional (with the condition tag settings of the first word). The marker is hidden when you hide the conditions of the first word. As a result, the cross-reference is sometimes unresolved if condition tag settings of the cross-reference and of the cross-reference marker differ.

To avoid this situation, select just the Cross-Ref marker at the beginning of the source paragraph, and make it unconditional. Then the marker is always visible. The cross-reference is resolved no matter which version is visible.

Remove condition tags from an item

Removing a condition tag from an item is different from deleting a tag from a document. When you remove a tag from an item, the tag remains in the docu­ment so it can be applied to other items later. When you delete a tag from the document, FrameMaker removes the condition tag from any text that uses it. Then it deletes the tag from the Conditional Text pod.

1)           Select the item with the tag you want to remove and choose the Uncondi­tional option from the Conditional Text pod and click Apply. The item remains in your document but the conditional tag no longer applies to it.

 

8.9.4.                Generate conditional output using Boolean expressions

You can generate conditional output by building a Boolean expression with combinations of condition tags and Boolean operators.

For example, your document contains the Comment, Print, Help, and PDF condition tags. To show text tagged with the Print and PDF condition tags only, click Build Expression, and define the following expression in the Build Expres­sion dialog box:

"Print" AND "PDF"

After you apply this expression, the document displays only text marked with the Print and PDF condition tags. Alternatively, to include text tagged with either the PDF or Print condition tags in the output, you can modify the expres­sion as follows:

   "PDF" OR "Print"

 

Build a conditional expression

1)            

Select Show/Hide Conditional Text icon from the Conditional Text pod.

 

2)           Select the Show As Per Expression option.

note:  All conditional expressions created and applied in the document, are listed in the Expression pop-up menu.

 

3)           Click the Build Expression button.

 

4)           In the Manage Conditional Expressions dialog box, enter a name for the conditional expression.

5)           Select a tag from the Condition Tag list and click the arrow button, or double-click the tag you want to add. The tag appears in the Expression area.

 

6)           Click the AND, OR, or NOT button.

 

7)           Repeat steps 4 and 5 to add tags and build the required expression. Place the cursor in the Expression area to create or edit an expression.

 

tip:  Click the Clear button in the Build Expression dialog box to completely clear an expression.

8)           Click Add.

 

Apply a conditional expression

1)            

Select Show/Hide Conditional Text icon from the Conditional Text pod.

 

2)           Select the Show As Per Expression option.

 

3)           Select the conditional expression from the Expression menu, and click Apply.

 

Import conditional expressions

You can import conditional expressions that you defined in the source docu­ment to one or more target documents. When you import the conditional text settings, conditional build expressions and the status of the Show As Per Expres­sion setting are added to the target documents. Conditional expressions that exist in the target documents are replaced by those imported from the source document.

1)           Select File > Import > Formats.

 

2)           In the Import Formats dialog box, deselect all options, and then select Conditional Text Settings.

 

3)           Select the source document from the Import From pop-up menu, and click import.

Any conditional expressions defined in the source document are imported into the target documents.

 

Edit a conditional expression

You can edit an existing conditional expression. You can also redefine an expression. You can quickly create a new conditional expression by editing an expression and then saving it with another name.

note:  Name of an existing conditional expression cannot be changed.

1)            

Select Show/Hide Conditional Text icon from the Conditional Text pod.

 

2)           Click the Build Expression button.

 

3)           In the Manage Conditional Expressions dialog box, select the conditional expression you want to edit.

 

4)           Make the required changes, click Edit, and click Done.

 

8.9.5.                Working in conditional documents

You can view or print all unconditional and conditional text simultaneously. You can also hide the conditional text of one or more versions. FrameMaker ignores hidden conditional text when formatting a document. When text symbols are visible, hidden conditional text is represented onscreen by a condi­tional text marker
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.

Markers show where conditional text is hidden.
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Change the view of conditional documents

A conditional document can display any number of conditions at a time and can have any of its condition indicators on or off. For example, you can change the view to display the condition tags for one particular version, for several versions, or for all versions. To display more than one version, you leave the condition indicators on. Also leave them on if you’re displaying one version and want to see which part is conditional.

You can view conditional text by selecting one of the following options:

Show All

 

Shows all text to which condition tags have been applied.

 

Show As Per Condition

 

Shows text based on a specific condition tag.

Show As Per Expression

 

Shows text based on an expression that includes a complex combination of condition tags and Boolean operators.

 

a)           To change the view of a conditional document, click Show/Hide Conditional Text from the Conditional Text pod.

 

b)           Do one of the following to select the conditional text that you want to show or hide in the document:

 

•               Select the Show All option.

 

•               Select the Show As Per Condition option. Move the desired condi­tion tags between scroll lists. If any condition tag in the Show list is applied to text in your document, the relevant conditional text appears in the document. You can select the Show If All Conditions Applied option only if all condition tags selected in the Show list are applied to that text.

 

•               Select the Show As Per Expression option, and then select an expres­sion from the pop-up menu.

 

c)           Indicate whether you want to display condition indicators, and click Apply.

 

note:  Condition indicators are style and color parameters that are used to distinguish conditional text from plain text. For example, you can create a Condition Tag called Private Comment and configure its Style as Double Underline, and its Color as Blue.

 

Viewing imported conditional text

When you import text containing passages of conditional text, all the condition tags applied to text in the source document are also imported. You can use them to show or hide imported conditional text. Even if you import the text by refer­ence and it appears in a text inset, you can change the view of conditional text in the inset.
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The following conditions determine whether text is shown or hidden:

•                

When the Show All option is selected in the destination document, all conditional text appears.

 

•               When the Show As Per Condition option is selected in the destination document, conditional text matching any selected condition tags in the Show list appears in the document. When the Show If All Conditions Applied option is selected in the destination document, all conditional text in the document is displayed only if all the tags that you selected in the Show list are applied to text in the document.

 

•               When the Show As Per Expression option is selected in the destination document, only conditional text that is based on the selected expression appears.

note:  If you don’t select any of these options, conditional text is initially shown or hidden according to the settings in the destination document. If imported condition tags don't match tags in the destination document, conditional text is initially shown or hidden according to the settings in the source document.

Find and edit conditional text

When you work in a conditional document, FrameMaker generally ignores hidden text. For example, the Find/Change and Spelling Checker commands check only displayed text. However, you can cut, copy, and paste hidden text by selecting the conditional text marker and by using the Edit commands.

In a conditional document, work with text symbols turned on. Conditional text markers alert you to text that is in other versions of the document. You can change conditional text in the following ways:

•                

To find conditional text, search for items tagged with a visible condition tag. FrameMaker finds conditional text in text frames, graphic frames, and table cells. It also finds conditional table rows.

 

•               Use the Edit menu commands as you normally do.

When you copy text, FrameMaker copies its conditional text markers and condition tag settings. When you paste text with a condition tag that’s not in the destination document, FrameMaker adds the tag to the destination document. When you try move or delete hidden conditional text, FrameMaker displays an alert message. You can delete the text or cancel the command.

 

•               Use Paragraph and Character Designers to apply format changes to hidden text.

Paragraph and character format changes you apply to selections don’t update conditional text hidden within the selection. To apply a format change to all paragraphs or characters, including hidden conditional text, click Update All in the designer. Or, you can choose Update All from the Paragraph Format pop-up menu on the formatting bar.

Applying format changes with Import > Formats also updates hidden conditional text.

•               To spell-check or search through all text, show all conditional text before using Edit > Spelling Checker or Edit > Find/Change.

 

Finalizing conditional documents

Before you produce a finished version of a conditional document, follow these guidelines:

•                

Change your view of the document to include only the version you want to print, and turn off condition indicators.

 

•               If your document contains variables, make sure that the variable defini­tions are correct for the version you’re printing.

 

•               Spell-check the document. This feature finds double spaces and punctua­tion problems caused by incorrectly tagged conditional text.

 

•               Update cross-references. If the document contains unresolved cross-references, perhaps they point to cross-reference markers in hidden conditional text. Show the version and update the cross-references again.

•               Create a copy of the document for each version before manually adjusting line and page breaks. Use the copy for each version for making the adjust­ments and for printing. These adjustments differ with each version. Use the original document for future edits.

 

•               If the document is part of a book, update the book and its generated files. If the book contains documents with different condition indicators for the same tag, FrameMaker displays an alert message. It also alerts you if some condition tags are displayed in one document but are hidden in another. If this situation occurs, click Cancel to stop book generation. Correct the conditional text settings of your documents.

•               After generating an index, check it for double question marks (??), which indicate missing or incorrect index markers.

 

Editing elements in conditional structured documents

You can insert, wrap, merge, and split elements in conditional structured docu­ments as you can in other documents. FrameMaker applies the following condi­tions as needed:

•                

When you insert an element, the new element takes the condition tags of the location of the insertion point.

 

•               When you wrap an element, the new element generally takes the condition tags of the location of the selection. If the selection crosses boundaries, the next two conditions apply.

 

•               When you wrap a selection that crosses the boundaries of two conditions, the new element does not take any condition tags. The contents of the element keep their tags.

 

•               When you wrap a selection that crosses the boundary of conditional and unconditional text, the new element does not take any condition tags. The contents are still partly conditional and partly unconditional.

 

•               When you merge two or more elements that have different condition tags, the new element does not take any condition tags. The contents of the element keep their tags.

 

•               When you split an element, the two elements have the same condition tags as the original element.

 

Validate each version in a conditional document showing only one version at a time.

note:  If a filter is applied to a structured document, this expression overrides all conditional text in the document. When you apply a filter to a structured docu­ment to generate output, conditional indicators are disabled. If you switch back to conditional text to generate the output, re-enable the conditional indicators.

8.10.             Troubleshooting books

Even though you can update and generate a book without error messages, the book may still have some problems that need correcting.

Generated file is empty

 

Make sure the name of the generated file is preceded by a generated files icon
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 in the book window. If it isn’t, the file was added as a document to the book file rather than as a generated file (see Create a book). When a file is added as a document file, FrameMaker won’t generate it. Also check that the setup of the generated file is correct.

 

Slow performance

 

To improve performance, open as many files in the book as possible before you use Edit > Update Book or File > Import > Formats in a book window. After using the command, save all the files in the book.

 

note:  In addition, if you experience slow performance while working with books, minimize or remove the Show/Hide Conditional Text panel from your workspace.

Chapter starts on wrong side

 

You need to correct your documents’ pagination.

8.10.1.            Interpreting error messages

The Book Error Log reports all errors that occur when you apply a command to a book. In addition, many error messages contain hypertext links so that you can click the message in the Error Log to display the location of the error.

Unresolved Cross-Refs

 

The Book Error Log lists all files that contain unresolved cross-references.

 

Inconsistent Show/Hide Settings, Inconsistent Use Condition Indicators, or Inconsistent Condition Indicator

 

The indicated file contains conditional text settings that differ from those in the previous file in the book. You can make the settings in each file the same (by using Special > Conditional Text) or you can update the settings throughout the book at once. To do this, change the settings in one file and then use File > Import > Formats to apply the settings to the entire book.

 

Inconsistent Numbering Properties

 

The numbering properties specified in the component are different from the book’s numbering properties. The book’s numbering properties over­ride those of the document. See Document and page numbering.

 

Inconsistent Color Settings

 

The indicated file contains color separation settings or color definitions that differ from those in the previous file in the book.

 

Couldn’t Open File

 

The Book Error Log will indicate if the file was saved using an older format, if it used unavailable fonts, or if it cannot locate the file. For more information on the problem, open the file to see the alert message that appears.

 

Book Not Self-Consistent

 

The contents of generated files, the page count, or cross-references continued to change while generating and updating files in the book. For example, if a book contains both a list of markers and an alphabetical list of markers, and if both contain hypertext links, the number of markers grows each time the files are generated. If this happens, move one of the generated lists out of the Include scroll list when you use the Generate/Update command again.

 

Inconsistent Element Boundary Settings

 

In a structured book, element boundaries are showing in some files in the book but not in others. Fix the settings in individual files to make them consistent.

 

8.10.2.            Troubleshooting TOCs and lists

 

Minor problems in the source document may cause corresponding problems in the list. For example, an incorrectly tagged paragraph may cause an extra entry to appear in the list or to be missing from it. Or an empty paragraph may cause an extra line to appear in the list.

Extra entries or lines

 

Incorrect formatting in the source document can cause extra paragraphs to appear in a list such as a table of contents. To correct this, do the following:

 

•               If the list contains an entry that doesn’t belong there, check the corresponding paragraph tag or marker type in the source docu­ment and either apply a different format to the paragraph or change the marker type.

•               If the list contains an extra line with only a page number, delete the corresponding empty paragraph in the source document. If you need extra space between paragraphs in the source document, use the spacing properties of the paragraphs’ formats rather than insert an empty paragraph.

 

Missing entries

 

To include entries that appear in the source document, but not in the list, do one of the following:

 

•               If all entries with a particular paragraph tag or marker type are missing, make sure the Include scroll list in the Set Up dialog box contains the correct items.

 

•               If an occasional entry is missing, check the tag of the corresponding paragraph or element, or the type of the corresponding marker in the source document. If any of these are incorrect, the information won’t be included in the list.

 

Split entries

 

A multiline heading in the source document can be a problem if the line breaks were created by pressing Return so that each line is a separate para­graph. The list will contain an entry for each paragraph in the heading. Fixing the list requires using only one paragraph for the heading in the source document.

 

Avoid using forced returns in a heading; forced returns appear in the generated TOC. Instead, to force a heading to break into two lines where you want, change the right indent of the heading paragraph in the source document. If the heading is centered, you may want to change both the left and right indents. You can also use nonbreaking spaces to force a heading to break acceptably.

 

Incomplete entries (unstructured documents)

 

When an element contains more than one paragraph, the list includes an entry for only the first paragraph. A multiline heading in the source docu­ment can be a problem if each line is a separate paragraph.

 

Avoid using forced returns in a heading; forced returns appear in the generated TOC. Instead, to break a heading into two lines (while still including all of its text in the list), use nonbreaking spaces to force a break. Or you can adjust the right indent for the heading to force a break, or the right and left indents if the heading is centered, though this will be a format rule override.

note:  Be aware that these techniques create overrides to both paragraph styles and element definitions. As such, they may not be retained when importing formats or element definitions, or when changing the context of the element by editing other parts of the structured document.

 

Incorrect pagination (books with xml components)

 

If you have a mix of structured xml and unstructured files in a book, some­times the page numbers are incorrect when you generate a PDF. This problem could be because the pagination information for xml files is obtained from the template and the template could have a dual pagination setting.

To avoid this problem, always open the xml files and then update the book. This way all the components in the book have correct pagination information and the PDF that you then generate also has correct page numbers.

 

Bad line breaks

 

Bad line breaks in the list or its source document may separate informa­tion that belongs together in the list. To correct this, do one of the following:

 

•               Change the characters after which FrameMaker allows line breaks. For example, FrameMaker normally allows a line break after an en dash (–). To disallow breaks after an en dash, use Format > Docu­ment > Text Options.

•               In the special text flow on the reference page, use nonbreaking spaces between the text and page number for each entry so that a page number does not appear on a line by itself. See Edit special text flow for a list or index.

 

Disappearing titles

 

A title you entered may disappear when you regenerate, unless you give the title a paragraph format.

 

Disappearing formatting

 

If your formatting changes aren’t retained when you regenerate (see Formatting lists and indexes), do the following:

 

•               If you changed the filename or location of the list, change the name and location back. FrameMaker won’t find any formatting changes unless you save the list in the same folder as the source document and use the filename that FrameMaker assigns.

 

•               To retain paragraph and character format changes, store them in the list’s Paragraph Catalog or Character Catalog, making them avail­able the next time you generate the list.

•               To retain other changes, make them in the special text flow, as described in Edit special text flow for a list or index.

 

8.10.3.            Troubleshooting indexes

Missing entries

 

If an entry is missing entirely from the generated index, do the following:

 

•               Check whether the corresponding marker (or marker element) is an incorrect marker type. You can do this by generating a list of markers that includes all marker types and then searching the list for the entry you want.

•               Check whether the corresponding marker (or marker element) is in hidden conditional text by using Special > Conditional Text to show all conditional text, and then generating the index again.

•               Check whether the marker (or marker element) was deleted acci­dentally.

 

Entries containing double question marks

 

Double question marks (??) in a page range indicate that FrameMaker can find only one of the two markers that define the range. If you see double question marks, do the following:

 

•               Check that neither marker (or marker element) is missing.

 

Missing <$startrange> and the resulting page range

[image: bk_ix_17.png]

 

•               Check that the spelling, punctuation, and capitalization of the marker text match exactly.

 

Inconsistent spelling and the resulting page range

[image: bk_ix_18.png]

 

•               Check that <$startrange> appears in the first marker (or marker element) and that <$endrange> appears in the second marker (or marker element).

 

<$endrange> comes first and causes the resulting page range

[image: bk_ix_19.png]

 

Missorted entries

 

Most sorting problems are the result of incorrect marker text. If you see missorted entries, do the following:

 

•               Check that the colons and semicolons are used correctly. If a semi­colon appears where a colon belongs, two main entries appear rather than one subentry. If a colon is missing, a subentry appears incor­rectly as a main entry.

 

Missing colon and the resulting missorted entry

[image: bk_ix_21.png]

 

•               Check that sorting information is present and correct, and appears between brackets ([  ]) at the very end of the marker text (see Change sort order). For example, if you want to sort a cross-reference as the last subentry, the sorting information in the marker text for it should end with :zzz.

Missing :zzz and the resulting missorted entry

[image: bk_ix_22.png]

 

•               If sorting errors occur in a pattern—for example, if all numeric entries appear at the end of the index rather than at the begin­ning—check that the sorting information in the special text flow on the reference page is correct.

Page numbers with See or See also cross-references

 

A cross-reference index entry may incorrectly contain a page number. Make sure that <$nopage> appears at the beginning of the marker text for the cross-reference entry.

 

Missing <$nopage> and the page number wrongly appears

[image: bk_ix_23.png]

 

Bad line breaks

 

If entries break between numbers in a page range or between the end of the entry and the first page number, do the following:

 

•               Change the characters after which FrameMaker allows line breaks. To disallow line breaks after certain characters, such as an en dash (–), use Format > Document > Text Options.

 

•               To force the end of an entry to appear on the same line as the page number, use a nonbreaking space, an en space, or an em space as the separator between them.

 

•               If you specified in the special text flow on the reference page that spaces or hyphens appear between page numbers in a range, make sure they are nonbreaking (see Edit special text flow for a list or index).

 

•               Change the volume or chapter numbering for the source document’s page numbers (see Set up numbering). If the book’s pages are numbered by chapter (11, 12, …, 21, 22, …),---- the volume or chapter number should be followed by a nonbreaking hyphen.

Bad line breaks

[image: bk_ix_24.png]

 

Disappearing titles

 

A title you entered may disappear the next time you generate the index, unless you follow the steps in “Add a title or other static text to lists and indexes”.

 

Disappearing formatting

 

If your formatting changes aren’t retained when you regenerate (see Formatting lists and indexes), do the following:

 

•               If you must rename a generated file, do so using the book window. FrameMaker will rename the file in the book window and on disk.

 

•               To retain paragraph and character format changes, store them in the index’s Paragraph or Character Catalog, making them available the next time you generate the index. For details, see “Redefining (updating) formats”.

 

•               To retain other changes, make them in the special text flow, as described in Edit special text flow for a list or index.

 




9.                        Working with Documents

 

9.1.                   Importing and linking files

 

9.1.1.                Import and link methods

You can import other Adobe FrameMaker documents, documents created in other applications, text files, and graphic files. You can also import SWF files and 3D objects into FrameMaker documents. An imported object can simply be copied into the document. It can also be linked—such as when you import by reference—so that it remains tied to its source for easy updating.

Related links:

Import text

Import graphics

Embedding objects

Use the clipboard

Perhaps the easiest way to import text and graphics is by copying to and pasting from the clipboard. When using this method, keep in mind the following:

1)            

Select the object or text you want to copy and Choose Edit > Copy. The contents is copied to the clipboard.

 

2)           Place the insertion point in the document where you want to paste the content, and then choose Edit > Paste.

 

When using this method, keep in mind the following:

•                

You can convert tab-delimited text to a table using the Table > Convert To Table command.

•               Text formatting is lost unless you’re pasting into another FrameMaker document.

 

•               Choosing Edit > Paste Special offers you more options. For example, you can choose to paste text in the RTF format or as an embedded Microsoft Word document. If you want to apply FrameMaker formats, then paste clipboard content as text. For graphics you can paste clipboard content as an embedded bitmap, a device independent bitmap, or a metafile.

 

Use drag-and-drop

Import and export are greatly simplified when you can drag an object to its new location.

FrameMaker supports the following drag-and-drop operations:

•                

Move a graphic from one open FrameMaker document window to another by dragging the graphic. You can also copy it by Control-dragging it or display a context (shortcut) menu when you drop it by right-dragging it.

 

•               Drag a graphic between a FrameMaker document window and any other application that supports drag-and-drop operations.

 

•               Drag a graphic file from a folder or the desktop into an open document window.

 

•               Drag one or more document files into the application window to open the files, or you can drag a single file into a document window to embed that file.

 

Use the File > Import > File command

 

Import by copying

Importing by copying makes it easy to transfer the imported material from one location to another, but it increases the document size. In addition, if you change the source material, you need to reimport it to update the document with the latest version.

1)            

Choose File > Import > File, choose the file you want to copy, and then select Copy Into Document.

 

Import by reference

Importing by reference keeps the imported text or graphics linked to the source file. FrameMaker stores the path to the source file in the document. Each time you open the document, FrameMaker locates the file on the disk and displays it. If the source file was revised, FrameMaker updates the document with the latest version. Importing by reference can reduce total file size because it lets you use the same material in several places without storing the contents of imported images or text in the FrameMaker document. Text imported by reference is called a text inset.

1)            

Choose File > Import > File, choose the file you want to copy, and then select Import By Reference

 

For information on how the path is stored when importing by reference, see Using paths when importing by reference.

Use the File > Import > Object command

The main benefit of using Object Linking and Embedding (OLE) is to display visualizations of data created in programs other than FrameMaker. The File > Import > Object option associates the imported object with the program used to create it so that you can edit the object in its native software. For example, you can insert a pie-chart created using Microsoft Excel in a FrameMaker docu­ment. Each time you double-click the inserted object, FrameMaker opens it in Microsoft Excel for you to edit.

note:  You cannot embed or link an object whose native software is not installed on your computer. For example, if you open a document having a Photoshop image embedded through File > Import > Object, you need to have Photoshop installed on your computer to be able to edit this image.

Consider the following factors when deciding whether to import text and graphics by reference or to use OLE to embed or link them instead:

•                

If the material you want to include comes from another FrameMaker document, use import by reference. This provides many more import options.

 

•               If you want to collapse a linked file to an icon instead of displaying the full contents of the file in your document, use OLE linking.

 

•               If the material you want to include is in a format that FrameMaker can’t open, use OLE.

 

•               If you edit or view your document on multiple platforms, use import by reference. OLE works only in Windows.

 

•               If the text or graphics you want to include comes from an application that doesn’t support OLE, use import by reference.

 

9.1.2.                Text insets

 

Text inset pod

You can use the Insets pod to manage and troubleshoot all objects linked or embedded in your FrameMaker documents.

 

Insets pod

[image: do_insets_pod.png]

A.

Select the file

B.

List text, graphics, or all insets in the selected document

C.

List resolved, unresolved, or all insets in the selected document

D.

Import a file or object into an open document

E.

Go to the inset location

F.

Edit the selected object’s properties

G.
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H.

Delete the selected graphic inset along with its anchored frame

I.

Convert to text - valid for text insets only

J.

Refresh the pod data

K.

Search for an inset

L.

Type of inset

M.

Source filename

N.

Document name of the inset

O.

Page and other references

View the properties or source of text insets

You can view the filename and file type of the source document, the date it was last modified, the date the text inset was last updated, and the inset’s update setting. You can also display the source of a text inset.

1)            

Click the text inset to select it and choose Edit > Text Inset Properties. You can also double-click the inset in the Insets pod.

2)           If you want to open the source of the text inset, click Open Source. The source is opened as a FrameMaker document.

Control the updating of text insets

You can control how and when text insets are updated from their source docu­ments. For example, you can specify either automatic or manual updating, and you can manually update a single text inset or several insets in the document.

note:  Text imported by reference is automatically updated only if its date stamp indicates that it is out of date. However, because the time settings may differ between file systems or networks, it’s possible that an out-of-date text inset won’t be updated automatically. In this case, you can manually update the inset.

Change the updating of a selected text inset

1)            

Select the inset to update.

 

2)           Choose Edit > Text Inset Properties and click Settings.

 

3)           Specify manual or automatic updating and click Import.

 

Suppress the updating of all text insets in a document

1)            

Choose Edit > Update References.

 

2)           Choose Suppress Automatic Updating from the Commands pop-up menu, and then choose the items you don’t want to be updated automat­ically.

 

3)           Click Set and then click Done.

 

Suppress the updating of all text insets in selected book files

1)            

In a book window, select the file or files you want to update.

 

2)           Choose Edit > Suppress Automatic Reference Updating.

 

3)           Select Suppress Automatic Updating and click Set.

 

Manually update a single text inset

1)            

Select the inset, choose Edit > Text Inset Properties, and then click Update Now.

 

Manually update multiple insets in a document

1)            

Choose Edit > Update References.

 

2)           Select the types of insets you want to update and click Update.

tip:  To interrupt the updating of text insets, press Control+c.

Convert text insets to editable text

When you convert a text inset to editable text, FrameMaker no longer updates it. You can convert a single text inset or all the text insets in a document.

1)            

If you’re converting one text inset, click it to select it.

 

2)           Choose Edit > Text Inset Properties. You can also double-click the inset in the Insets pod.

 

3)           Click Convert to Text, specify whether to convert the selected inset or all insets in the document, and then click Convert.

 

Locate the source of unresolved text insets

If FrameMaker can’t locate the source file for a text inset during updating (or if the format of the source file has changed since the last update), an alert message appears. After dismissing the alert message, you can use the Insets pod to locate the unresolved text inset and then re-import the text. The Insets pod displays the complete path of a referenced file.

Alternatively, you can also search for unresolved insets.

1)            

Choose Edit > Find/Change.

 

2)           Choose Unresolved Text Inset from the Find pop-up menu and click Find to select the first unresolved text inset.

 

3)           Choose Edit > Text Inset Properties, note the path and file type of the inset, and then click Cancel.

 

4)           Using the path and file type information, re-import the text.

 

tip:  If a document contains many unresolved text insets, you can generate a list of unresolved text insets.

Related links:

Import formatted text

Import unformatted text

Generating TOCs and other lists in structured documents

9.1.3.                Using paths when importing by reference

When you import by reference with File > Import > File, the path to the text or graphic can be either absolute or relative. A relative path begins at a current folder or one folder up the hierarchy and specifies the file’s location from there. An absolute path begins at the root of the file system (the topmost folder) and fully specifies the file’s location from there. Following are two examples of abso­lute paths.

•                

d:\Graphics\Mountain.gif

 

•               \\DocServer\Graphics\Mountain.gif

 

FrameMaker stores relative paths whenever possible so that it can find an imported file even when you move both the document and the source file—as long as you keep the files in the same relative locations. If you save the document in a different folder, FrameMaker adjusts the paths of the imported files accord­ingly. However, if the path to the imported file traverses the root (the topmost folder) of the file system, FrameMaker uses absolute paths that begins at the root.

To ensure that FrameMaker uses relative paths, make sure that it does not have to traverse the root to locate the file.

9.1.4.                Import text

 You can use the File > Import > File command to import text on all platforms. This method provides more flexibility than using the clipboard.

However, if you’re working on only one platform, you might want to use a plat­form-specific approach. For information, see Embedding objects.

The text you import can be formatted or unformatted. Unformatted text contains only the words; it has no information on fonts, indents, spacing, auto­numbering, and so on. Formatted text contains these types of information.

Import formatted text

You can import formatted text into a FrameMaker document by importing from the following sources:

•                

A text flow from another part of the same document

•               A text flow from another FrameMaker document

 

•               A text flow from another FrameMaker document that is a Maker Inter­change Format (MIF) file

 

•               A file created in another application, such as Microsoft Word, which has an installed filter

 

When you import text from another FrameMaker document, you also import cross-references, footnotes, variables, markers, tables, and anchored frames. Conditional text in the flow is also imported. When you import text from another application, some of these special items may be imported, depending on the capabilities of the other application and the filter used.

1)            

Click where you want to insert the text and choose File > Import > File.

 

2)           Specify the file that contains the flow you want to import and the import method.

 

3)           Click Import.

 

4)           If the Unknown File Type dialog box appears, select a file type and click Convert. The dialog box that appears next depends on the import method you chose in step 2. The Import Text Flow by Reference dialog box contains settings for specifying how to update the imported flow. Choose a body page flow or a reference page flow. Typically, the text you import will come from body pages. Reference pages can contain flows with boil­erplate text or graphics for use on body pages.

 

5)           Specify how to format the imported text by doing one of the following:

 

•               To apply the current document’s formats to the imported text when­ever their tags match, click Reformat Using Current Document’s Formats. If the tags don’t match, the formatting of imported text is unaffected. Usually, you would also select the options to remove manual page breaks and other format overrides (such as font prop­erties or tab settings) so that the imported text looks like text in the current document with the same tags.

•               To remove the formatting from the imported text and apply the character and paragraph formatting used at the insertion point, click Reformat As Plain Text. (Text in tables or anchored frames retains the formatting it had in the source document.)

 

•               To keep the formatting from the source document, click Retain Source’s Formatting. Formats in the imported text aren’t added to the current document’s format catalogs. If you later modify the current document’s formats, the imported text formats won’t be affected—even if the tags in the current document and imported text match.

 

6)           If you are importing the text by reference, specify how to update the text inset by doing one of the following:

 

•               To update the text inset whenever you open the document, click Automatic.

 

•               To update only when you specify, click Manual.

 

7)           Click Import. If you imported the text by reference, it appears as a text inset. (A text inset is linked to the source document and can’t be edited outside that source document.)

 

Import unformatted text

When you import the text from an unformatted text file, you specify whether to import it by copying or by reference and how to treat lines in the text file. The imported text adopts the character and paragraph formatting used at the inser­tion point.

1)            

Place the insertion point where you want to insert the text, and then choose File > Import > File.

 

2)           Specify the text file you want to import, and the import method.

3)           Click Import. The dialog box that appears depends on the import method (Import By Reference or Copy Into Document) you chose.

4)           Specify how to treat the imported text by doing one of the following:

 

•               To break the text into paragraphs only at blank lines, click Merge Lines into Paragraphs. Use this option for a paragraph-oriented text file such as a file containing document text.

 

•               To break the text into paragraphs at the end of each line, click Treat Each Line As A Paragraph. Use this option for a line-oriented text file such as a file containing computer code.

 

•               To convert the imported text to a table, click Convert To Table. Specify a table format and other settings. Use this option only if the file contains delimited text, such as text output from a database program.

 

5)           If you are importing the text by reference, specify how to update the text inset by doing one of the following:

 

•               To update the text inset whenever you open the document, click Automatic.

 

•               To update only when you specify, click Manual.

6)           If necessary, choose a character encoding from the Text Encoding pop-up menu. Do this only if you know that the preselected encoding is incorrect. If you force an incorrect encoding, character substitution sometimes occurs or some characters appear as question marks.

 

7)           Click Import. If you imported the text by reference, it appears as a text inset.

9.1.5.                Import graphics

You can import Adobe® Photoshop®, JPEG 2000, SVG, and Adobe® Illustrator® files into FrameMaker. Use File > Import > File to import graphics.

You can import a graphic into an anchored or unanchored graphic frame, into a rectangle that serves as a bounding box, or directly onto a page. If you want the graphic to move with text as you edit the document—for example, a graphic in longer documents or documents intended for HTML conversion—import the graphic into an anchored frame. If you want the graphic to stay where you place it—for example, if the graphic is the logo of a letterhead—import it onto the page and position it where you want it.

When you import a graphic, you can specify an import filter on the basis of the graphic’s format. When you import a bitmap image, you also specify its scale in dots per inch (dpi). The larger the dpi value, the smaller the graphic is on the page.

When you copy an image, or copy an image by reference, into a document, you can specify an HTTP path from which to import the graphic. The HTTP path is preserved in the XML roundtrip.

Related links:

Using paths when importing by reference

Import a graphic

1)            

Specify the position of the graphic by doing one of the following:

 

•               To place the imported graphic in a graphic frame, select an existing frame or place an insertion point in a text frame.

•               To place the imported graphic directly on a page, click in the page margin.

•               To use a drawn rectangle to define the size of the imported bitmap graphic, select an existing rectangle or draw one (do not select an anchored or unanchored frame). The graphic replaces the rectangle if the Fit in Selected Rectangle option is selected when you import; however, the aspect ratio of the graphic remains unchanged.

 

•               To replace an existing graphic, select it.

 

2)           Choose File > Import > File.

 

3)           Select the graphic file you want to import, or specify the HTTP path of the graphic file to import, and the import method.

4)           Click Import.

 

5)           If the Unknown File Type dialog box appears when you click Import, select a file type in the scroll list and click Convert.

6)           If you're importing a bitmap graphic, choose a scaling option or Fit in Selected Rectangle and click Set.

tip:  For the best printed results, choose a dpi value that divides evenly (or leaves only a small remainder) into the resolution of your printer or typesetter. For the best screen representation, choose a dpi value that divides evenly into your screen resolution. (Windows screens typically have a resolution of 96 dpi.)

Related links:

Import and link methods

Resize imported graphics

Embedding objects

Import JPEG 2000 files

FrameMaker supports JPEG 2000, a version of the JPEG image-compression format.

When importing JPEG 2000 files, the filter converts the supported color modes of RGB, CMYK, Grayscale, and LAB and discards unsupported modes such as Index. The filter does not support 16-bit-per-channel images.

1)            

Choose File > Import > File.

 

2)           Specify the file you want to import, and select Import By Reference or Copy Into Document.

 

3)           Click Import. If the Unknown File Type dialog box appears, select JPC, J2C, JPX, JPF, J2K, or JP2, and click Convert.

 

Import SVG images

When importing a Scalable Vector Graphic (SVG), the SVG Import dialog box allows the user to select the rasterization quality of the image. By increasing the rasterization quality, printed and PDF versions are crisper; however, increasing the rasterization also increases the file size of the image, and it takes longer to import it.

FrameMaker prints Scalable Vector Graphic (SVG) images to PostScript printers by rendering the images as vector graphics using Encapsulated Post­Script (EPS). For non-PostScript printers, FrameMaker uses the FrameImage format.

In addition, when you create a PDF file from a document containing an SVG image, the image appears as vectors, which improves its look in Acrobat and allows you to zoom in on it without pixelation.

note:  Embedded SVG image animations are not functional in FrameMaker.

1)            

Choose File > Import > File.

2)           Click Import.

 

3)           Specify the file you want to import, and select Import By Reference or Copy Into Document.

4)           Click Import.

 

5)           In the Import SVG dialog box, specify the raster quality.

 

6)           Specify image dimensions if they are different from the default size (you can’t scale proportionally in this dialog box).

 

7)           Click Set.

 

note:  Depending on the rasterization quality and available memory, it might take several minutes for the SVG image to import.

Import Adobe Photoshop files

FrameMaker supports importing of Adobe Photoshop (PSD) files. FrameMaker converts PSD files to native FrameImage format and converts the color space (Photoshop RGB, CMYK, LAB, Indexed, Grayscale, or Bitmap) to RGB.

You import PSD files the same way you import other types of graphics.

Import Adobe Illustrator files

When you import an Adobe Illustrator file into FrameMaker, the file is treated as a graphic, and only one page can be imported at a time. You can import it either by copy or by reference. Both process and spot colors can be displayed and printed.

note:  Graphics that use transparency do not always print as expected to a Post­Script Level 1 or non-PostScript printer. If you run FrameMaker using the -noapi option ( ./maker.exe -noapi ), you won’t be able to import PDF files.

1)            

In FrameMaker, choose File > Import > File, and specify the Illustrator file you want to import.

 

2)           Select either Import By Reference or Copy Into Document.

 

3)           Click Import.

 

4)           If the file has more than one page, specify the page number you want by typing the page number into the box.

 

5)           Click Select.

 

Illustrator files are imported at the page size of the file. Resize the anchored frame to crop any white space from the image.

Locate missing graphics

When you open a document that contains graphic files imported by reference, FrameMaker looks for the referenced graphic files. If it can’t find a graphic file, it displays a dialog box.

Locate a graphic FrameMaker can’t find

1)            

When FrameMaker displays the Missing File dialog box, do one of the following:

 

•               To find and display the graphic, use the scroll list to select it and click Update Document to Use New Path. FrameMaker continues to use the new path to try to find other missing files while opening the document. That way, if you move all your graphic files to a new loca­tion, you specify the new path only once.

 

•               To skip the graphic file, click Skip This File. The skipped graphic appears as a gray rectangle in the document. The next time you open the document, FrameMaker tries to find the file again.

 

•               To skip other graphic files if they can’t be found, click Ignore All Missing Files.

 

2)           Click Continue.

 

View an imported graphic’s filename

1)            

Select the graphic that has been imported by reference and choose Graphics > Object Properties. The graphic’s name and path appear in the panel.

 

Insert imported graphic elements into structured documents

Some graphic elements are defined for you to import a graphic along with the element. When you insert the element, FrameMaker displays an import dialog box. The graphic you import appears in an anchored frame below the line with the anchor symbol, and the frame is automatically sized large enough for the graphic.

Imported graphic in an anchored frame

[image: do_anchored_frame.png]

After inserting the element, you can edit the frame by moving it, resizing it, and so on.

You can also import a graphic into an existing anchored frame—for example, if you used a graphic element that placed an empty frame in the document.

When you import a graphic element, you can make it part of your document (imported by copying) or keep it linked to its original application or document (imported by reference).

For information on inserting an imported graphic that’s not an element (which you can do only in an unstructured flow), see Import graphics.

Related links:

Fill and edit anchored frames

Import and link methods

Insert an imported graphic element

1)            

Click where you want to anchor the frame.

 

2)           Select an imported graphic element in the Element Catalog, and click Insert.

 

You can also use File > Import > File to insert an element. Select a file and click Import. If more than one imported graphic element is available, choose the one you want from the Element Tag pop-up menu in the next dialog box that appears.

 

3)           Select the graphic file you want to import and specify whether to import by copying or by reference.

 

4)           Click Import.

5)           If the Unknown File Type dialog box appears, select a file type in the scroll list and click Convert.

 

6)           If the graphic you’re importing is a bitmap, choose a scaling option from the pop-up menu and click Set. The larger the dpi (dots-per-inch) value, the smaller the graphic is on the page.

 

An anchored frame with the imported graphic appears in the document window, with an anchor symbol
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 at the insertion point. A bubble with the text snippet <GRAPHIC> appears in the Structure View.

If no imported graphic element is available at the location you want, you can use an invalid element. After inserting the element, talk to your developer about making the element valid at this location.

Related links:

Import by copying

Change the scope of elements available in a structured document

Use an invalid imported graphic element

1)            

Do one of the following:

 

•               To use an element that is valid in another part of the document, either insert the element in a valid location and then move it, or use the All Elements setting to make the element available everywhere and then insert the element where you want it.

 

•               To insert an invalid element with the default tag GRAPHIC, use File > Import > File to import a graphic. (The element has a default tag if no defined imported graphic elements are available.)

 

Add an imported graphic to an existing anchored frame

1)            

Select the frame and use File > Import > File to import the graphic.

 

9.1.6.                Import movies, SWF files, and 3D objects

You can import SWF files (for example, Adobe Captivate demos) into FrameMaker documents by copying or by reference.

You can also import 3D objects (U3D format) into documents by copying or by reference. You can set parameters for the 3D object, such as default view, rendering mode, background color, and lighting scheme. You can also choose to render a 3D object in an anchored or unanchored frame.

For a series of tutorials and demonstrations on using rich media in FrameMaker authoring, watch the episodes on the Technical Communications channel on Adobe TV.

Related links:

Disable embedding Adobe Flash, 3D, and multimedia objects in PDF

Print options

Rich Media in Technical Documentation

Import movies

You can add movies to documents by embedding media files. FrameMaker supports the following media formats.

•                

AIF/AIFF (Audio Interchange File Format) WMV

 

•               ASF (Advanced Systems Format File)

 

•               AU (Audio File)

 

•               AVI (Audio Video Interleave File)

 

•               FLV (Flash Video File)

 

•               IVF (Indeo Video Format File)

 

•               KAR (Karaoke MIDI File)

 

•               M1V (MPEG-1 Video File)

 

•               M3U (Media Playlist File)

 

•               MID (MIDI File)

 

•               MOV (Apple QuickTime Movie)

 

•               MP2 (MPEG Layer II Compressed Audio File)

 

•               MP3 (MP3 Audio File)

 

•               MP4 (MPEG-4 Video file)

 

•               MPA (MPEG-2 Audio File)

 

•               MPE (MPEG Movie File)

 

•               MPEG (MPEG Movie)

 

•               MPG (MPEG Video File)

 

•               QT (Apple QuickTime Movie)

 

•               WAV (DTS-WAV File)

 

•               WMV (Windows Media Video File)

 

For more information see Embedding objects.

When you print a document containing a QuickTime movie, only the movie title appears.

note:  Don’t move or delete the original QuickTime movie file, even if you used the Copy into Document option when you imported it. Even with this option, the entire QuickTime movie is not copied into your document.

Import a SWF file

note:  Ensure that you have installed Adobe® Flash® Player on your computer to play SWF files.

note:  SWF files embedded inside PDF documents, do not need Adobe Flash Player, to play. Acrobat Pro and Acrobat Reader can play these files.

1)            

Place the insertion point in your document where you want the SWF file to appear.

 

2)           Select File > Import > File.

3)           Navigate to, and select, the SWF file you want to insert.

 

4)           Select the Copy Into Document or Import by Reference option.

 

5)           Click Import.

 

6)           In the Graphic Scaling dialog box, select the desired DPI, and then click Set.

 

When you click Set, the first frame of the SWF file appears in the document. If you imported the file by reference, double-click the first frame to play the SWF file in a separate Adobe Flash Player window. If you copied the SWF file into the document, a bitmap image of the first frame is displayed. Click the frame to acti­vate the SWF file. If the first frame is blank, the anchored frame containing the SWF file appears blank.

note:  You can’t use any graphic operations on a SWF file in a FrameMaker document.

note:  In FrameMaker, SWF files and FLV files are saved as RichMedia objects in PDF.

Import 3D objects

1)            

Place the insertion point in your document where you want the 3D object to appear.

 

2)           Select File > Import > File.

 

3)           Navigate to and select the U3D file you want to import.

 

4)           Select the Copy Into Document or Import By Reference option.

 

5)           Click Import.

 

6)           Select the desired DPI and click Set.

 

When you click Set, the bitmap of the 3D object appears in the document. If you imported the 3D object by copying it, the U3D file is embedded in the document as a device-independent bitmap (DIB) in the document. If you imported the 3D object by reference, a bitmap image linked to the source U3D file is inserted in the document. Regardless of the method of importing the 3D file, the file is rendered in the DIB facet in the document.

When you import the 3D object into a document and save it in PDF or XML format, all information about the 3D object is preserved.

Save a document containing 3D objects

You can save a document containing 3D objects in PDF and XML formats.

1)           Select File > Open, and then open the FrameMaker book or file containing 3D objects.

 

2)           Select File > Save As PDF.

 

3)           You can change the save location and the filename if you want, and then click Save.

 

4)           Click Set in the PDF Setup dialog box to generate PDF with the default settings. Or, set additional options, and then click Set. The U3D file imported into the book or file is saved along with all its views. When you open the PDF, the view you last selected for the 3D object in the document displays in the PDF.

 

note:  By default, FrameMaker is configured to embed 3D objects in PDFs. However, you can disable this option.

In the PDF, click the 3D object to view the 3D toolbar and to activate the inter­active features of the 3D object. The Adobe Acrobat 3D toolbar, which is displayed above every 3D object in a PDF, lets you zoom, pan, rotate, and analyze 3D designs.

Save documents containing 3D objects as XML

You can save a FrameMaker file containing a 3D object as XML. When you open the XML file in FrameMaker, the 3D object is preserved through XML roundtrip. The 3D object is extracted and saved as an independent U3D file, along with the XML file. When the file is opened again in FrameMaker, the 3D object appears at the location where it was inserted.

To preserve changes made to a 3D object during a roundtrip in an XML file, add a new attribute called insetdata with the following properties in the Graphic section of the DTD file, along with other attributes such asOffset and DPI:

    insetdata CDATA #IMPLIED

Similarly, you must add the following lines in the XSD file:

    <xsd:attribute name="insetdata" type="xsd:string" use="optional"/>

note:  The insetdata attribute does not support read/write rules.

If you don’t modify the DTD and XSD files, U3D files can still be exported to XML. However, changes made to the U3D file in FrameMaker are not preserved during a roundtrip.

1)            

Select File > Open, and open the FrameMaker file containing 3D objects.

 

2)           Select File > Save As XML.

 

3)           You can change the save location and the filename, and then click Save.

 

note:  When you open the XML file in a 3D compatible XML Editor, the relevant graphic element contains a reference to the U3D file, with the filename and loca­tion of the U3D file. If you open the XML file in FrameMaker, the 3D object appears as a bitmap image.

Print a FrameMaker file with 3D objects

You can print a document with 3D objects. The 3D objects are printed as bitmap images.

1)            

Open the document containing 3D objects.

 

2)           Select File > Print.

 

3)           Set the remaining print options as necessary, and then click Print.

Configure a 3D model imported into FrameMaker

You can configure a 3D model you have imported into a document by setting its background color, lighting schemes, changing views, and rendering mode.

Set the background color for a 3D object

You can change the color that appears behind a 3D object. The default back­ground color is white.

1)            

Select a 3D object.

 

2)           Select Graphics > 3D Menu option > Background Color.

3)           Select the desired color and click OK.

 

Set lighting schemes for a 3D object

You can select from a wide range of 3D lighting schemes to cast a 3D object using different light sources. The default lighting scheme for all 3D objects is Lights From File.

1)            

Select a 3D object.

 

2)           Select Graphics > 3D Menu option > Lighting, and choose one of the following light sources: Lights From File, No Lights, White Lights, Day Lights, Bright Lights, Primary Color Lights, Night Lights, Blue Lights, Red Lights, Cube Lights, CAD Optimized Lights, or Headlamp.

 

Set views for 3D objects in FrameMaker

The 3D object you import into a document can contain predefined views. You can change the view set for the object; the selected view is rendered when the document is saved. When you convert this FrameMaker document to a PDF, all predefined views of the 3D object are available in the PDF. The last view that you selected in the document before saving becomes the default view in the PDF.

1)            

Select a 3D object.

 

2)           Select Graphics > 3D Menu option > Show Existing Views, choose a view from the list that appears in the dialog box, and click OK.

 

note:  If you save the document as a PDF, all views of the U3D objects are avail­able in the converted document.

Render a 3D object in a document

The rendering modes for 3D objects vary from the Wireframe, Solid, to Trans­parent Bounding box. The default rendering mode is Solid.

1)            

Select a 3D object.

 

2)           Select Graphics > 3D Menu option > Rendering Mode, and then choose one of the following rendering modes: Bounding Box, Transparent Bounding Box, Transparent Bounding Box Outline, Vertices, Shaded Vertices, Wireframe, Shaded Wireframe, Solid, Transparent, Solid Wire­frame, Transparent Wireframe, Illustration, Solid Outline, Shaded Illus­tration, or Hidden Wireframe.

 

Poster file for a media file

You can set a poster file to an imported media file. Importing a SWF file into FrameMaker, displays the first frame of the SWF file as the poster for the SWF file.

SWF file with first frame as the poster
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For a SWF file whose first frame cannot be read, and for all other media types, FrameMaker displays the relevant placeholder image.

For structured documents, if an attribute is defined in the DTD with the name posterfile for a graphic object, the attribute is automatically mapped to the poster property of the anchored frame. You can also map any attribute to a poster using a rule in the read write file. The file referred in the attribute becomes the poster.

Set a poster image

FrameMaker sets the selected image as the poster. If the image that has been set as a poster is missing, FrameMaker sets a special image as the poster.

 

1)           Right click the inserted media file.

 

2)           Select Set Poster.

 

3)           Select the image file (JPEG, PNG, BMP, or GIF) and click OK.

 

Reset the poster image

1)            

Right click the inserted media file.

 

2)           Select Set Default Poster.

 

9.1.7.                Import other files

You can import PageMaker, QuarkXPress, PDF, RTF, MIF, Microsoft Word, and Microsoft Excel files into FrameMaker. Use File > Import > File to import these files.

note:  FrameMaker lets you import PageMaker 6.5 or 7.0 and QuarkXPress 3.3 or 4.1 documents.

Import PageMaker and QuarkXPress files

1)            

In FrameMaker, choose File > Open, and specify the PageMaker or QuarkXpress file you want to import.

 

2)           Choose the appropriate file type in the Unknown File Type dialog box:

 

•               If importing a PageMaker file, choose PageMaker [version] Docu­ment or PageMaker [version] Template.

 

•               If importing a QuarkXPress file, choose QuarkXpress Document (3.3-4.1x).

 

3)           Click Convert. If the Missing File dialog box appears, navigate to the folder that contains the missing file, click the name of the file, and click Continue.

 

FrameMaker imports the main components of PageMaker and QuarkXPress files.

Master Pages

 

FrameMaker adds a new master page for each master page in the docu­ment you are importing. All master-page items are placed on their corre­sponding master pages in FrameMaker. If you have custom-named master pages in PageMaker, FrameMaker uses the same name.

 

For QuarkXPress documents, FrameMaker imports all text objects on master pages as text flows, and preserves all body-page overrides. FrameMaker drops any overrides for other objects on body pages.

 

Sections

 

FrameMaker ignores sections and imports their contents only.

 

Layers

 

FrameMaker treats all layers in an imported document as one layer. The page items are drawn according to their stacking order on the page, starting with items on the master page and then items on the body page.

 

Character styles

 

FrameMaker creates new character formats for the character styles in the document you’re importing. If a character style has the same name as a character format in FrameMaker, the attributes in the character format are replaced by the corresponding attributes from the imported file. FrameMaker doesn’t import PageMaker or QuarkXPress character attri­butes that aren’t supported by FrameMaker.

Paragraph styles

 

FrameMaker creates new paragraph formats for the paragraph styles in the document you’re importing. If a paragraph style has the same name as a paragraph format in FrameMaker, the attributes in the paragraph format are replaced by the corresponding attributes from the imported file. FrameMaker doesn’t import PageMaker or QuarkXPress paragraph attri­butes that aren’t supported by FrameMaker.

 

FrameMaker creates a paragraph format (right) for each paragraph style (left) in the PageMaker document you’re importing.

[image: do_para_style_import.png]

 

Paragraphs with local overrides in the original document are also treated as overrides by FrameMaker.

 

Importing tagged text from PageMaker displays the actual tag names in the FrameMaker document. Deselect Export Tags in the PageMaker Text Export dialog box to import the text only, not the tag name.

 

Paragraph rules

 

FrameMaker imports paragraph rules as a single-line frame defined in the reference pages. All other settings applied to the rules, such as line colors, line styles, and so on, are not imported.

 

Drawing objects

 

FrameMaker imports all drawing objects. If fill and stroke colors are different, the fill color is used for both stroke and fill. The runaround settings are dropped.

 

Non-printing objects

 

FrameMaker doesn’t import non-printing objects.

 

Tate-Chu-Yoko

 

Because FrameMaker doesn’t support vertical text, FrameMaker treats Tate-Chu-Yoko as horizontal text.

 

Color definitions

 

FrameMaker creates color definitions to match custom colors or colors from a color library that are defined in the PageMaker or QuarkXPress file. However, if a color definition with the same name exists in FrameMaker, the FrameMaker color is used, and no new color is created.

 

Graphics

 

FrameMaker uses its filters to import linked (referenced) graphics files. If it doesn’t have the appropriate filter, FrameMaker doesn’t import the graphics files. For embedded graphics, FrameMaker uses the image data to import the graphics.

 

When importing a floating graphic, FrameMaker positions the graphic at the same position as in the original file. When importing an inline graphic, FrameMaker positions the graphic in the text flow in the same text posi­tion as in the original file.

 

OLE objects

 

FrameMaker supports OLE. FrameMaker imports OLE objects as long as FrameMaker supports the graphic format.

 

Grouped objects

 

FrameMaker supports hierarchical grouping of objects.

 

Hyperlinks

 

FrameMaker supports hyperlinks. For PageMaker documents, FrameMaker imports object and page item anchors as cross-references.

 

Table of contents

 

FrameMaker imports the table of contents generated in QuarkXPress or PageMaker as regular text.

 

Pasteboards

 

FrameMaker imports all pasteboard objects inline in their corresponding anchored frame. FrameMaker creates a separate section in the reference pages for the pasteboard objects it imports.

 

Indexing

 

FrameMaker imports all index entry markers but treats the index as regular text.

 

Import PDF files

When you import a PDF file into a FrameMaker document, the PDF file is treated as a graphic. Only one page of the PDF file can be imported into the FrameMaker document at a time. Both process and spot colors can be displayed and printed.

Graphics that use transparency do not always print as expected on a PostScript Level 1 or non-PostScript printer.

1)            

Specify the position of the graphic.

 

2)           Choose File > Import > File.

 

3)           Select the PDF file you want to import and click Import.

4)           If the PDF file has more than one page, specify the page number in the Select PDF Page dialog box. Use the slider to display a thumbnail image of the page you want, and then click Select.

 

Import MIF files

MIF is a text format that lets you exchange information between FrameMaker and other applications. All types of format and page layout information are translated to MIF commands. FrameMaker interprets the commands in the MIF file, turning them back to formatting and layout properties.

You can import the text of a specified flow of a MIF file as you do any FrameMaker file. When you import by copying, all reference and master pages are imported as well as the body pages. The body text appears on a disconnected page. For information on MIF, see the online manual MIF Reference.

Related links:

Connect text frames

Import formatted text

Import Microsoft Word files

 You can import Microsoft Word documents with DOC or DOCX filename extensions into FrameMaker documents.

If you saved your Microsoft Word document in the Word 97-2003 format, you can import it using the Microsoft Word or the Microsoft Word 2007 filter. However, if you want to import a Microsoft Word 2007 document, you must use the Microsoft Word 2007 filter. You can import RTF files using the Micro­soft RTF 1.6 filter in the Unknown File Type dialog box.

1)            

Place the insertion point in the document where you want to insert the text, and then choose File > Import > File.

 

2)           Specify the file you want to import, select the Import by Reference or Copy Into Document option, and then select Import.

 

Depending on the document you are importing, the Microsoft Word or Microsoft Word 2007 filter is selected in the Unknown File Type dialog box.

 

3)           Click Convert. The Import Text Flow by Copy or the Import Text Flow by Reference dialog box appears.

 

4)           In the Flow to Import area, select a Body Page Flow or a Reference Page Flow.

 

5)           In the Formatting of Imported Flow area, select one of the following options:

 

•               To select the Remove Manual Page Breaks option and the Other Format Overrides option, click Reformat Using Current Docu­ment's Formats.

 

•               To convert the imported content to plain text and then insert it in the document, click Reformat as Plain Text.

•               To retain the imported content in its original format and then insert it in the document, click Retain Source's Formatting.

6)           In the Import Text Flow by Reference dialog box, select one of the following options in the Updating of Imported Flow area:

 

•               To update the imported flow area automatically, click Automatic.

 

•               To update the imported flow area manually, click Manual.

 

7)           Click Import.

 

note:  Bookmarks within Word documents become cross-reference markers; annotations in Word documents become conditional text with the condition “Comment” when imported by reference; hidden text in Word documents becomes conditional text with the condition “Hidden” when imported.

Import Microsoft Excel files

You can import Microsoft Excel documents with XLS or XSLX extensions into FrameMaker documents.

If you saved your Microsoft Excel document in the Excel 97-2003 Workbook format, you can import it using the Microsoft Excel or the Microsoft Excel 2007 filter. However, if you want to import a Microsoft Excel 2007 document, you must use the Microsoft Excel 2007 filter.

1)            

Click where you want to insert the file, and choose File > Import > File.

 

2)           Specify the file you want to import, select Import by Reference or Copy Into Document option, and click Import.

 

Depending on the document you are importing, the Microsoft Excel or Microsoft Excel 2007 filter is selected in the Unknown File Type dialog box.

 

3)           Click Convert. The Import Text Flow By Copy or the Import Text Flow By Reference dialog box appears.

 

4)           In the Flow To Import area, select Body Page Flow or Reference Page Flow.

 

5)           In the Formatting Of Imported Flow area, select one of these options:

 

•               To select the Remove Manual Page Breaks option and the Other Format Overrides option, click Reformat Using Current Docu­ment's Formats.

 

•               To convert the imported content to plain text and then insert it in the document, click Reformat As Plain Text.

 

•               To retain the imported content in its original format and then insert it in the document, click Retain Source's Formatting.

 

6)           In the Import Text Flow By Reference dialog box, select one of the following options displayed in the Updating Of Imported Flow area:

 

•               To update the imported flow area automatically, click Automatic.

 

•               To update the imported flow area manually, click Manual.

 

7)           Click Import.

 

9.1.8.                Import formatting properties

 

Import formats

You can import a wide variety of formatting information—including page layouts, paragraph and table formats, variable and color definitions, and condi­tional text settings. If your source document has any conditionl expressions created, they, along with their Show As Per Expression status are also imported into the target documents. Similarly, in structured documents, any Filter By Attribute settings that you defined are also imported.

 

1)            

Open the template with the formats. The template must be named and saved.

 

2)           Open the document or book that you want to update. If a book window is active, select the documents you want to update.

 

3)           In the document or book you’re updating, choose File > Import > Formats.

 

4)           Choose the template from the Import from Document pop-up menu. The menu lists all open, named documents.

 

You can also choose the current document to reapply the formats the document already has. This is useful mainly for removing formatting changes, as described in step 6.

 

5)           Select the Import and Update settings you want to apply to the current document.

•               If you’re updating cross-reference formats, math definitions, or vari­able definitions, and if any of these items uses character formats, also select Character Formats so that any new formats are added to the document.

 

•               If the HTML mappings have been modified, select Reference Pages.

 

6)           If you want to remove formatting changes that are not saved in catalog formats, do the following:

 

•               To remove page breaks that are not part of a paragraph format, select Manual Page Breaks.

 

•               To remove paragraph, character, page layout, and table formatting overrides, select Other Format/Layout Overrides.

 

important:  In most cases, do not select Other Format/Layout Overrides in a structured document because the element definitions sometimes use format overrides.

7)           Click Import.

 

Format settings

When you import formats, FrameMaker merges the new formatting informa­tion into the document. For example, if you import table formats, the formats are added to the Table Catalog. If a format already in the catalog has the same name as an imported format, the imported format replaces the original one. Any formats that are not overwritten remain in the catalog.

Paragraph formats

 

The template’s Paragraph Catalog is merged into the document, and all formats in the catalog are reapplied in the document.

Character formats

 

The template’s Character Catalog is merged into the document, and all formats in the catalog are reapplied in the document.

 

Page layouts

 

The template’s master pages are merged into the document, and body pages are updated with the master page changes. If the template and the document both have a master page with the same name, the master page of the template replaces that of the document. FrameMaker copies the change bar properties, all the settings in the Page Size and Pagination dialog boxes, and most settings in the View Options dialog box.

 

Table formats

 

The template’s Table Catalog and ruling styles are merged into the docu­ment, and all formats in the catalog are reapplied in the document.

 

Color definitions

 

The template’s color definitions and views are merged into the document.

 

Reference pages

 

The template’s reference pages (except for FrameMath™ reference pages) are merged into the document. If the template and the document both have a reference page with the same name, the reference page of the template replaces that of the document. To import the FrameMath refer­ence pages, select Math Definitions.

 

Document properties

 

The template’s custom marker types and footnote properties; the volume, chapter, page, paragraph, footnote, and table footnote numbering styles in the Numbering Properties dialog box; the characters in the Allow Line Breaks After setting in the Text Options dialog box; and the Feather settings in the Line Layout dialog box are merged into the document. The PDF Setup settings (other than the bookmark settings) are also merged into the document. On Japanese-language systems, the rubi properties and kumihan rules (Japanese-language typesetting rules) are also merged into the document.

 

Variable definitions

 

The template’s variable definitions are merged into the document.

 

Cross-reference formats

 

The template’s cross-reference formats are merged into the document, and internal cross-references are updated.

 

Conditional text settings

 

The template’s condition tags and Show/Hide settings are merged into the document.

 

Math definitions

 

The template’s equation size and font settings, custom math element defi­nitions, and FrameMath reference pages are copied into the document. If any custom math elements in the document are deleted when the refer­ence pages are merged, FrameMaker replaces the math elements in equa­tions with the name of the math element enclosed in question marks.

 

note:  In FrameMaker equations, the term “math element” refers to part of an expression. A math element is not a structural element.

 

Combined fonts

 

On Asian-language systems, the specifications of combined fonts are merged into the document.

 

About formatting overrides

The formatting information for a document can come from format rules in element definitions and from predefined formats stored in catalogs. It is possible for a document to have overrides to both sources of information:

•                

A format rule override is a deviation from a text element’s format rules. For example, if the rules specify a paragraph format for an element and you apply a different format, or if the rules specify boldface text and you change the text to italics, you are overriding the element’s format rules.

 

•               A format override is a deviation from a catalog format for text or a table. For example, a paragraph format may specify the Times font family. If you change some text that uses that format to the Palatino font (without saving the change in the format), you are overriding the format. Format rules often use a few catalog formats and specify format overrides to them to describe many different formatting variations.

Generally, avoid using either type of override in your structured document. Let the document handle the formatting automatically, and see your application developer if you’d like to change any of the formatting properties.

If your document does have overrides, you can remove them throughout the document all at once when you import and update.

important:  If you need to remove both kinds of overrides from a document, import formats and remove format overrides first, and then import element defi­nitions and remove format rule overrides. Removing the rule overrides last ensures that the elements conform to their format rules.

Find and remove overrides

You can use the Find option to search and remove format overrides at para­graph, character, and table format levels.

1)           Select Edit > Find.

 

2)           From the Find pop-up menu, select Paragraph, Character, or Table format override.

 

3)           From the Change pop-up menu, select Remove Override.

 

4)           Click Find.

5)           For each instance of format override, click Change to remove the override.

 

Import properties from a template

You can import element definitions and other properties into your document from any FrameMaker document. Typically, this other document is a template that you did not use for creating the document. (If you created your document from the appropriate template, you don’t need to import properties; the docu­ment already has the properties it needs.)

If your document’s template has been revised, import from the template again to update your document.

You can also import properties into all the files in a book at once.

Related links:

Import formats into book files

9.2.                   Embedding objects

 

9.2.1.                Embed text and graphics with OLE

You can use OLE to embed text or graphics in a FrameMaker document. Embedded material retains its association with the application that created it (but does not retain a dynamic link to its source document). This lets you double-click an embedded object to open the object in the application that created it. Be sure to use an application that supports OLE as a server to create the object you want to embed.

You can also embed multimedia objects such as video or movie files (.avi or .mov files) and sound files (.wav files).

note:  If you specify an HTTP filename when importing a file as an imbedded object, you get an error indicating that the file does not exist. It is recommended that you save the file to your computer before importing it as an object.

Embed only part of a file with OLE

1)            

In its own application, open the file and copy the part you want to embed.

 

2)           In FrameMaker, click where you want to embed the text or graphics, and choose Edit > Paste Special.

 

3)           Click Paste, select a format for the object (look for a format that starts with “embedded”), and then click OK.

Embed an entire file with OLE

1)            

Click where you want to embed the text or graphics and choose File > Import > Object. You can then embed a new, empty file, or specify an existing one.

 

Embed by dragging with OLE

1)            

Do one of the following from an application that supports drag-and-drop features:

 

•               To move text or graphics into a FrameMaker document, drag the object.

 

•               To make a copy of an object instead of moving it, Control-drag the object.

 

•               To choose between moving or copying when you release the mouse button, right-drag the object.

 

9.2.2.                Link to a text or graphic object with OLE

When you link to an OLE text or graphic object in a document, FrameMaker not only maintains information about the application that created the object but also keeps a dynamic association with the source document. If the source mate­rial changes, its representation in the FrameMaker document is updated as well. Be sure to use an application that supports OLE as a server to create the object you want to link to.

You edit linked text or graphics by editing the original source document.

Link to part of a file

1)           In its own application, open the file and copy the part you want to link to.

 

2)           In FrameMaker, click where you want to place the linked text or graphics, and choose Edit > Paste Special.

 

3)           Click Paste Link, select a format for the object (look for a format that starts with “linked”), and then click OK.

Link to an entire file

1)            

Click where you want to place the linked file and choose File > Import > Object. Click Create from File and then select Link.

2)           Specify the file you want to link to and click OK.

 

9.2.3.                Edit OLE objects

You edit an OLE object by using the application that originally created it. When you finish editing, the changes appear in the FrameMaker window.

Edit an embedded OLE object

1)            

Double-click it. The object appears in the creating application where you can edit it.

 

Edit a linked OLE object

1)            

Do one of the following:

 

•               Double-click the OLE object. Either the object appears in a new window in the application that created it or the menus in the FrameMaker window temporarily merge with the menus of the creating application. In either case, the changes you make are reflected in the original document.

 

•               Edit the original document outside FrameMaker, in the application that created it.

 

9.2.4.                Control the updating of OLE links

You can control how and when OLE linked objects are updated from their source documents. For example, you can specify either automatic or manual updating, and you can manually update a single linked object or several objects in the document.

You cannot specify updating for OLE embedded objects because an embedded object is not dynamically linked with the original document.

Change the updating of a linked OLE object

1)            

Select the object, and choose Edit > Links.

2)           Select the linked source from the list, click either Automatic or Manual as the update type, and then click OK.

 

Suppress the updating of all linked OLE objects

1)            

Choose Edit > Update References.

 

2)           Choose Suppress Automatic Updating from the Commands pop-up menu, and then choose the items you don’t want to be updated automat­ically.

 

3)           Click Set, and then click Done.

 

Manually update a single OLE link object

1)            

Choose Edit > Links, select the source file you want to update, and then click Update Now.

 

Cancel an OLE link

When you break an OLE link, the text or graphic remains in your document, but is no longer updated when the source changes. The text becomes editable.

1)            

Select the object, choose Edit > Links, and then click Break Link.

 

9.2.5.                Import text into structured documents

You can import text into a structured FrameMaker document from the following sources:

•                

A text flow from another part of the document, from another structured FrameMaker document, or from a MIF file. Any conditional text in the flow, cross-references, tables, markers, footnotes, variables, and anchored frames are imported.

 

•               A file created in another application for which an import filter is installed on your system. Special items such as cross-references and tables may also be imported—depending on the application and the filter used.

 

If the text you import is structured, you can retain or remove the structure. If the text is formatted, you can retain or remove the formatting, or reformat the text using formatting information in the current document.

Imported text can be copied into the document, which is equivalent to using the Copy and Paste commands, or it can be imported by reference as a text inset, in which case it retains a link to its source file. When you import by reference, the text inset displays in the document window but is not editable. If the inset is structured, its structure appears in the Structure View but is not editable.

A text inset remains linked to its source document.

[image: do_text_inset.png]

1)            

Click where you want to insert the text.

 

2)           Choose File > Import > File.

 

3)           Select the file with the text you want to import, and specify whether to import by copying or by reference.

 

4)           If the Unknown File Type dialog box appears, select a file type, and click Convert.

 

The dialog box that appears next depends on the import method you chose in step 3. The Import Text Flow By Reference dialog box contains settings for updating the imported flow.

 

Specify how you want to format and update your import text flow.
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5)           Choose a body page flow or a reference page flow from a pop-up menu. Most often, you import text on body pages. Reference pages can contain flows with boilerplate text for use on body pages.

 

6)           Specify how to handle the structure and formatting of the imported text by doing the following:

 

•               To retain the structure of the flow and apply the current document’s formats and element format rules to the text, select Reformat Using Current Document’s Formats. If element tags in the two documents don’t match, the formatting of the imported text is unchanged. Usually, you would select the options for removing page breaks and other format overrides so that the imported text looks like text in the current document.

 

•               To remove the structure and formatting from the text, and apply the formatting used at the insertion point, select Reformat as Plain Text. (Text in tables or anchored frames retains the formatting it had in the source document.)

 

•               To remove the structure but retain the formatting, select Retain Source’s Formatting. Formats used in the imported text are not added to the current document’s catalogs. If you later modify the current document’s formats, the imported formats won’t be affected—even if the tags in the current document and imported text match.

 

7)           If you’re importing by reference, specify how to update the text inset by doing one of the following:

 

•               To update the text inset whenever you open the document, select Automatic.

 

•               To update only when you specify, select Manual.

 

8)           Click Import.

Related links:

Import text

9.3.                   3D object part links

To link a 3D object’s parts to textual objects in the document, use 3D object part links. A use for adding 3D object part links can be to link them to a description of each of the parts.

[image: do_3d_link.png]

 

A.

List of the selected 3D object’s parts

B.

List of the markers that you can make link destinations for the 3D object’s parts

9.3.1.                Create 3D links

You can create 3D object links and link them to Specify Named Destination command or URL.

1)            

Ensure that your document has Specify Named Destination hypertext. Specify Named Destination hypertext can exist either in the same docu­ment or in other documents.

 

2)           Right-click a 3D object and select 3D Menu > Link to Text.

3)           In the Link to Text dialog, do the following:

 

a)           To insert a link, select a part of the 3D object, then select a Marker, and click Insert Link to Text.

 

b)           To delete a link, select a part name linked to a marker and click Delete Link to Text.

 

c)           To modify a link, select a part name linked to a marker, select a different marker, and click Update link to Text.

 

d)           To view linked parts, select Show Only Linked Parts. When you select a linked part, the linked marker is selected.

 

4)           Click OK.

 

9.4.                   Interactive Links for 3D/Multimedia Objects

 

9.4.1.                About interactive links for 3D\multimedia objects

You can insert links to interactively control embedded U3D (Universal 3D), FLV, and SWF objects in the PDF output. You can insert links to 3D and multi­media objects that control various aspects of these objects:

•                

View: Calls different views of the 3D\multimedia object. (For 3D only)

 

•               Parts: Focuses on different parts of the 3D\multimedia object. (For 3D only)

 

•               Animation: Calls animation in the 3D\multimedia object. (For 3D only)

 

•               JavaScript™: Attach custom JavaScript™ code to the link.

 

You can also create a multimedia links table for the 3d\multimedia object of the type View, Parts, or Animation. For example, the multimedia links table of the type parts includes links that focus on different parts of the 3D\multimedia object.

You can also set a poster that appears for SWF, FLV, and MP4 files while the video is not playing.

9.4.2.                Insert a link to a 3D object

 

1)            

Insert a 3D object in your document.

 

2)           Type text for creating the link.

 

3)           Select Graphics > Create link to graphic.

 

4)           In the Create Multimedia Link dialog, specify the following:

 

a)           Select Object Type: Select U3D.

 

b)           Select an Object: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker selects the object name automatically.

 

c)           Hypertext Element Tag: If you are working in structured FrameMaker, specify the element tag for the hypertext for the links.

 

d)           Link Type: For U3D, you can select JavaScript™, View, Parts, or Animation. If you select JavaScript™, in the Details field add the JavaScript™ code that you want to execute on the click of hypertext. Otherwise, Details displays the options relevant to the selected link type. Select one of the options.

 

5)           Select Insert.

 

9.4.3.                Insert links to an SWF file

 

1)            

Insert an SWF file in your document.

 

2)           Type text for creating the link.

 

3)           Select Graphics > Create link to graphic.

 

4)           In the Create Multimedia Link dialog, specify the following:

 

a)           Select Object Type: Select SWF.

 

b)           Select an Object: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker selects the object name automatically.

 

c)           Hypertext Element Tag: If you are working in structured FrameMaker, specify the element tag for the hypertext for the links.

 

d)           Link Type: For SWF, you can select JavaScript™, play, or stop.

 

5)           If you have selected JavaScript™ in Link type, add the JavaScript™ code in Details.

 

6)           Select Insert.

 

9.4.4.                Insert links to an FLV file

 

1)            

Insert an FLV file in your document.

 

2)           Type text for creating the link.

 

3)           Select Graphics > Create link to graphic.

 

4)           In the Create Multimedia Link dialog, specify the following:

 

a)           Select Object Type: Select FLV.

 

b)           Select an Object: Select the name of the object for which you want to insert the links. If there is only one object of the selected object type, FrameMaker selects the object name automatically.

 

c)           Hypertext Element Tag: If you are working in structured FrameMaker, specify the element tag for the hypertext for the links in the table.

 

d)           Link Type: For FLV, you can select the following:

 

•               Play: Plays the FLV video

 

•               Pause: Pauses the video

 

•               Rewind: Rewinds the video to the starting point

 

•               Nextcuepoint: Takes the video to the next cue point

 

•               Prevcuepoint: Takes the video to the previous cue point

 

•               Seek: Seek helps you select further options for creating defined points.

 

5)           If you have selected Seek in Link type, do one of the following:

 

a)           Defined Points: This option allows you to use the cue points embedded in the video itself.

 

b)           Create Point: This option allows you to create a seek point in the video. After selecting this option, play the video and click Create Link in the video window to insert a seek point.

 

6)           Select Insert.

 

9.4.5.                Set poster for a SWF, FLV, or MP4 files

You can set a poster that appears for SWF, FLV, and MP4 files while the video is not playing.

1)           Select a SWF, FLV, and MP4 file.

 

2)           Right-click the file and from the pop-up menu, select Set Poster.

 

3)           For an FLV, SWF, or MP4 file, the Set Poster dialog appears.

a)           Select From Media and click Play.

 

b)           While the video is playing, at the appropriate moment click Capture Frame for Poster.

c)           Click Save As and save the poster file (.dib) to disc.

 

d)           Click Apply.

 

9.4.6.                Set poster for a 3D object

You can set a poster that appears for U3D files while the video is not playing.

1)           Select a 3D object.

 

2)           Right-click the object and from the pop-up menu, select Set Poster.

 

The Select Poster File dialog appears.

 

3)           Navigate to a poster file (.jpeg, .png, .gif, .dib, or .bmp format) and select it.

 

9.4.7.                Insert multimedia links table

You can add multimedia links table for U3D and FLV objects.

1)            

Select Graphics > Create link table for graphic.

 

note:  If the Create link table for graphic command is disabled, place your cursor in a text area in the document.

 

2)           In the Insert Multimedia Link Table dialog, select:

 

a)           Select Object Type: Select U3D or FLV.

 

b)           Select an Object: Name of the object for which you want to insert the links.

 

c)           Table Format: Select a table format for the links table.

 

d)           Table Element Tag: If you are working in structured FrameMaker, specify the element tag for the links table.

 

e)           Hypertext Element Tag: If you are working in structured FrameMaker, specify the element tag for the hypertext for the links in the table.

 

f)            Select Table Type: Select the type of action for the multimedia links. For U3D the options are View, Parts, or Animation. For FLV, you can choose Seek.

 

3)           Select Insert.

 

9.4.8.                Edit multimedia links

You can edit the multimedia links using the markers pod.

1)            

Select View > Pods > Markers.

 

2)           In the Markers pod, double-click a hypertext marker of type multimedia.

 

3)           In the Edit Multimedia Link dialog, modify the options as required and click Save.

 

9.4.9.                Attach custom JavaScript™ to a 3D object

You can attach custom JavaScript™ to a 3D object to control it.

1)            

Right-click a 3D object and in the 3D context menu, select 3D Menu > Select JavaScript™.

 

2)           In the Select JavaScript™ file dialog, navigate to a JavaScript™ file and click Select.

 

note:  If you copy-paste a 3D object, the JavaScript™ attached with it is also copied to the new instance of the object.

 

9.4.10.            Use object handle in JavaScript™

You can refer to a 3D, SWF, or FLV object’s name in a JavaScript™ using the FM_ prefix.

The following JavaScript™ example uses the FM_ prefix with the object name. This example JavaScript™ code makes the relevant object transparent.

1)            

Insert an object in FrameMaker and name it as my3d in properties in the 3D menu.

 

2)           Attach the following JavaScript™ code to the object. The object my3d is referred to in this code as FM_my3d.

 

var i,count,tempObj;
count=FM_my3d.context3D.scene.meshes.count;
var selObj;
for( i=0;i<count;i++){
selObj=FM_my3d.context3D.scene.meshes.getByIndex(i);
tempObj=FM_my3d.context3D.scene.nodes.getByName(selObj.name);
tempObj.renderMode="transparent";
}

 

3)           Create the PDF and click the link. The 3D object turns transparent.

 

9.4.11.            Activate 3D/multimedia objects by default

When you open a PDF, the 3D/multimedia objects in PDF are not activated by default. Click the objects to activate them. To activate the 3D/multimedia objects in the PDF by default, complete the following steps:

1)            

Right-click an FLV, SWF, or 3D object and in the context menu, select PDF View Options > Activate by Default.

 

9.4.12.            Display 3D/multimedia objects in pop-up windows

You can choose to display the 3D/multimedia objects in a pop-up, when you click the relevant link. This option is useful when the links and the 3D/multi­media object are on different pages.

1)           Right-click an FLV, SWF, or 3D object and in the context menu, select PDF View Options > Open in Pop up Window.

 

note:  You can close the pop-up by clicking the cross in the upper-right corner of the pop-up window.

9.5.                   Export text and graphics

You can use the following techniques to export text and graphics:

•                

Copy and paste between files and applications.

 

•               Save a document in another format.

 

•               Use print options to create a PostScript or EPS file.

•               Create a Portable Document Format (PDF) file.

 

•               Save as HTML, which can convert a document’s graphics to GIF, PNG, or JPEG format.

 

•               Save as XML.

 

•               Send the document as an e-mail attachment.

 

•               Use drag-and-drop techniques.

 

Related links:

Create PostScript files

Import Adobe Illustrator files

About HTML documents

Use drag-and-drop

Specifying graphics conversion

9.5.1.                Using Save As to export to other formats

You can export a FrameMaker document to other applications by saving it in other formats. When you save a document in a word-processing format, it can be used in that application with most of its formatting intact. The available formats depend on the platform you’re using and the filters installed.

Two text-based file formats—Rich Text Format (RTF) and Maker Interchange Format (MIF)—are interchange formats. These formats are widely recognized by other programs and can often serve as a bridge from FrameMaker to an application that does not recognize the native format.

Saving MIF files

 

You can save FrameMaker files in the MIF 7.0 (MIF-Classic) or MIF 9.0 (MIF-Unicode) formats. When you choose to save a FrameMaker document as a MIF file, you can select the MIF 7.0 or MIF 9.0 option.

MIF-Classic

 

Choosing this format generates a MIF that is like the original format, which is forward-compatible. All Unicode content that can’t be repre­sented in the earlier format is replaced with a character that you can configure using the configuration file, maker.ini.

 

note:  Use caution when editing an ini file.

 

MIF-Unicode

Choosing this format generates a MIF that contains Unicode strings. All string data is in UTF-8 format.

 

You can also save a document as an HTML, XML, or PDF file.

 

Related links:

Save a document

Publishing as PDF files

Saving structured documents as HTML

9.5.2.                Send files in e-mail

You can send a document as an e-mail attachment if a mail system compatible with the Messaging Application Programming Interface (MAPI) is installed on your computer. If your computer is not yet configured for MAPI, Windows guides you through some dialog boxes when you first try to send a document. If you need assistance, ask your network administrator for help.

note:  The send e-mail menu and shortcut works only for single documents and not on a book file. You cannot send a book file via e-mail.

1)           Choose File > Send.

 

2)           Pick an e-mail profile to use from the Choose Profile dialog box, and click OK.

 

3)           Fill in the e-mail fields, and then send the message as you normally do.

 

9.5.3.                Save a document containing SWF files as PDF, HTML, and XML files

You can save a document containing SWF files in PDF, HTML, and XML formats. Also, you can print documents containing SWF files.

Save documents containing SWF files as PDF

1)            

Select File > Open, and then open the FrameMaker book or file containing SWF files.

 

2)           Select File > Save As PDF.

 

3)           You can change the save location and the filename if you want, and then click Save.

 

4)           Click Set in the PDF Setup dialog box to generate a PDF with the default settings. Or, set additional options, and then click Set. The SWF file imported into the book or file and it is saved. If you have installed Flash Player on your computer, you can open the PDF and play the SWF file.

 

note:  By default, FrameMaker is configured to embed SWF files in PDFs. However, you can disable this option (see Disable embedding Adobe Flash, 3D, and multimedia objects in PDF).

When you open a PDF containing a SWF file, the Manage Trust For Multimedia Content dialog box appears. Select the Play The Multimedia Content This One Time or Play The Multimedia Content And Add This Document To My List Of Trusted Documents option and click Play. Ensure that you have installed Adobe Reader® 8 or later, or Adobe Acrobat 3D version 8 or later, to view the generated PDF containing SWF files.

When the imported media file is saved as a PDF and played, Acrobat plays SWF and FLV files with its own in-built native media player. Playback of all other media files is possible only if the relevant codecs are installed on the system

Save documents containing SWF files as HTML

You can import a SWF file into a document and save it as an HTML file. When you do this, a CSS file generates automatically. If you imported a SWF file by copying it into an Unstructured document, the SWF files are saved as GIFs with the HTML file. If you imported a SWF file by copying it into a Structured docu­ment, the SWF files are saved separately. When you open the HTML file, click the SWF content to play it.

1)            

Select File > Open, and then open the FrameMaker book or file containing SWF files.

 

2)           Select File > Save As HTML.

 

3)           You can change the save location and the filename if you want, and then click Save.

 

Save documents with SWF files as XML

You can save a FrameMaker file containing a SWF file as XML. When you open the XML file in FrameMaker, the SWF file is preserved through XML roundtrip. To ensure roundtripping of SWF files, make sure that the XML file contains correct read write rules before you save the file as XML.

note:  Ensure that you create or open an XML file containing a graphic element definition before importing a SWF file into it.

1)            

Select File > Open, and then open the XML file containing SWF files.

 

2)           Select File > Save As XML.

 

3)           You can change the save location and the filename if you want, and then click Save.

 

If the SWF content was embedded in the FrameMaker file, and the document is saved as XML, the SWF content is saved as an independent SWF file. In addi­tion, a reference to the SWF file is created in the XML.

Print a FrameMaker file with SWF files

You can print a FrameMaker document with SWF files. The SWF files are printed as frames. If the first frame contains an image, the bitmap of the image is printed.

1)            

Open the FrameMaker document containing SWF files.

 

2)           Select File > Print.

 

3)           Set the remaining print options as necessary, and then click Print. For information on the other options, see Print options.

 

9.5.4.                Save a structured document in SGML or XML

You can save any structured FrameMaker document as SGML or XML. The contents, elements, and attributes from the document are preserved; however, formatting is not preserved. You can save to a different structured document type than the original (such as SGML to XML), but you may encounter errors due to differences in DTDs.

When you save Unicode content as an XML file, Adobe Product X.0 specifies the encoding automatically. By default, Adobe Product X.0 uses the UTF-8 encoding format.

Before saving a document as SGML or XML, you should validate it and correct any errors in the elements and attributes (see “Validating documents” on page 39). Otherwise, the markup may be invalid.

When saving structured XML documents, make sure valid XML element names start with a letter and contain only alphanumeric characters, periods, or hyphens. Spaces, underscores, and other characters in XML element names are invalid characters, and are either converted to hyphens (-) or generate errors.

Headings, tables, and reference pages are not used in XML export, and the default tag names are simply the format names.

Default encoding settings for exporting structured documents are ISO-8859-1 for SGML and UTF-8 for XML. If the structured document is an imported SGML or XML file, FrameMaker uses the encoding settings in the original file instead of the default settings.

1)            

Select File > Save As.

 

2)           Specify a filename and location. You may want to add the appropriate extension (such as .sgm or .xml) to the filename.

 

3)           Select SGML or XML from the pop-up menu and click Save. If the docu­ment has an application associated with it, the document is saved.

 

4)           If the Set Structured Application dialog box appears, choose an applica­tion name from the Set Structured Application pop-up menu and click Continue. Then do one of the following:

•                

To associate an application with the document, choose the name of an application.

 

•               To use default mapping and no read/write rules, choose <No Applica­tion>.

 

If FrameMaker finds any structure errors when you save a document, it lists error messages in a view-only error log. If a message refers to an error in the FrameMaker document, the message is linked to the document. For most errors, you can click the message to go to the location of the problem.

When you open the structured documents, import element definitions into them. You’ll probably need to make a few corrections to their structure.

Related links:

Import element definitions into structured books

9.6.                   Smart paste hypertext and MS® Word contents as struc­tured content

FrameMaker allows you to paste HTML, MS® Word, MS® Excel, and MS® Outlook content as DITA content. You can also create and configure XSLs for other FrameMaker structured applications. Using XSL, FrameMaker identifies the content while it is in the clipboard and structures it with the most appro­priate hierarchy or sequence of elements. Then you can use the smart paste command to paste it to FrameMaker as DITA content.

The content you paste is structured according to an XSL specified in the relevant structured application. In FrameMaker, the XSLs are specified for the following DITA documents:

•                

Topic

 

•               Task

 

•               Concept

 

•               Reference

 

The XSL filename and path are specified using the Stylesheet element (Stylesheets > XSLTPreferences > SmartPaste > Stylesheet).

The smart paste XSLs for DITA are at: $STRUCTDIR\xml\DITA_1.2\app\tech­nicalContent\xslt\.

The XSL added in the DITA_1.2_topic application for smart paste
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9.6.1.                Smart paste content in a DITA file

 

1)           Copy HTML, MS® Word, MS® Excel, or MS® Outlook content.

 

2)           Place your cursor in one of the following types of DITA topics: topic, task, concept, or reference.

 

3)           Select Smart Paste from the context menu. (keyboard shortcut for Smart Paste: Esc+s+p+t)

 

The pasted content is structured in appropriate elements that the struc­ture allows.

 

9.6.2.                Add smart paste XSL for a custom XML application

You can also create an XSL for smart pasting content for your custom struc­tured application.

1)            

Create an XSL appropriate for your EDD.

 

2)           Open the structapps.fm file.

3)           Under Stylesheets > XSLT preferences, add the SmartPaste element and the following elements under it:

 

a)           Stylesheet: Path to the relevant XSL file.

 

b)           StylesheetParameters: This element has two child elements: Param­eterName and ParameterExpression. See a DITA application in structapps.fm for details.

 

4)           Save the file.

 

5)           Select StructuredTools > Read Application Definitions.

Now you can use smart paste for an XML file based on your custom appli­cation.

 

9.7.                   Managing files using WebDAV

 

9.7.1.                About WebDAV

WebDAV technology enables you to read and write files over a modified hyper­text transfer protocol. Files reside on the server within a directory structure and are checked out to your local machine. Your local machine has a directory struc­ture that mirrors the WebDAV server structure, so when you check out files, the files are downloaded to your machine and placed in the mirrored folder.

FrameMaker has built-in support for Web Distributed Authoring and Versioning (WebDAV) server technology. WebDAV is a standard protocol that is supported by most Content Management Systems (CMS). Use WebDAV to download and upload documents, and lock documents so others cannot modify them at the same time as you do. Use a WebDAV enabled CMS to work in a collaborative environment without worrying about version control.

In FrameMaker, you can author and edit XML files, FrameMaker books and files, and MIF files, located on the WebDAV server. For more information about WebDAV, visit www.webdav.org.

WebDAV server

 

A server implementing the WebDAV protocol. You can store and access files on any WebDAV server using FrameMaker and a WebDAV client, assuming you have login access to the server.

 

URL

 

In the context of WebDAV, URL refers to the path to a file (asset) on a WebDAV server. You can open any file on a WebDAV server by speci­fying its URL in the Browse URL dialog box.

 

WebDAV offers distinct advantages over traditional file servers.

Multiple users can download copies of a file managed by a WebDAV server, but only one user at a time can check-out the file. Users who check out a file can share their work with other users while keeping a file checked-out by updating the file on the server. However, other users can’t change a checked-out file until it is checked in. This check out/check in system allows multiple users to access the same file but prevents users from overwriting each other’s work.

Because WebDAV works over web accessible networks, location doesn’t matter. Team members can share files regardless of their proximity.

9.7.2.                Getting started

You can directly open, update, and save files to the server by specifying the URL of a file.

 

Advantages of using Browse URL

 

•               You don't have to explicitly set up the server connection.

 

•               You don't have to explicitly download all linked and associated files, such as referenced images when you download a file.

 

•               You don't have to download all book components or files associated with a .xml, such as schema, DTD, or EDD.

 

•               You don't have to explicitly update or upload a file. A file is automatically updated on the server when you save it and checked-in to the server when you close it.

The Browse URL workflow is also Unicode and IPv6 compliant and integrated with all FrameMaker workflows.

 

9.7.3.                Using the Browse URL workflow

The Browse URL dialog box is integrated in all FrameMaker workflows. The Browse URL button appears in all FrameMaker dialog boxes related to file management.

New

 

You can specify the HTTP URL of the template you want to use for a new document. You can either type the complete URL of the template in the New dialog box or use the Browse URL dialog box to select the template.

 

Open

 

You can open any HTTP file on a server by typing its URL in the filename of the file Open dialog box. You can open all the FrameMaker file types supported through local file paths using HTTP paths. These file types include .fm, .book, .mif, .xml, .ditamap, and .bookmap. You can also open text file, Microsoft Office file formats, such as RTFs, and QuarkXPress documents.

 

Import

 

You can import files by specifying their HTTP paths. You can import them by reference or copy them into your document. You can import an HTTP text inset, add a cross-reference to an HTTP file, import graphics, U3D objects, or SWF files by specifying their HTTP paths.

Save

 

You can specify a URL in the Save As dialog to upload the file to a WebDAV enabled server. You can save a file in all FrameMaker formats.

note:  You cannot do a batch conversion of documents for HTTP WebDAV direc­tories.

Browse URL
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Rename a file or folder
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Delete selected file or folder
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File details that you can sort according to any column

J.

Specify the complete URL for a file

Save a WebDAV server connection

 When working with Browse URL you don’t have to explicitly set up a server. If a WebDAV server has an authentication process setup, you need to provide login credentials the first time you access a file on the server. If you work frequently with a server, you can save the server connection in the Browse URL for quicker access.

1)           Access the Browse URL dialog box and type the HTTP path to the WebDAV enabled server in the filename box.

 

2)           If prompted, specify your login ID and password.

 

3)           To save the server connections, click the Store URL 
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button.

 

4)           Specify a nickname for the server connection and click OK.

Once saved, the server connection is displayed each time you access the Browse URL dialog box.

To delete a saved server connection, click the Remove URL 
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button.

Setting preferences

1)            

Choose Edit> Preferences and set the following options.

 

Checkout HTTP Files On Open

 

Clear this option if you do not want to check out a file from a WebDAV server when opening the file.

Upload HTTP Files On Save

 

Clear this option if you want to check in a file only once when you close the file.

 

General preferences

[image: frm_preferenceswebdav.png]

Using HTTP paths to open files

You can open any file on a WebDAV server by specifying its URL.

For xml files, FrameMaker silently downloads all HTTP references, such as the xml schema or the DTDs associated with the xml file. Other references, such as text or graphic insets or cross-referenced files are also downloaded.

You can also reference or import graphic file objects in your documents by specifying their URLs. You can include links to documents by specifying their HTTP paths in hypertext markers.

Add, open, and save documents

You can create, save, or open files directly from a WebDAV server by specifying the file URL.

Create a file

1)            

Choose File > New > Document and click the Browse URL button.

 

2)           Select the server name from the right panel or specify the HTTP path to the server.

 

3)           Specify a filename and click Ok.

 

You can create a DITA topic, ditamap, or a bookmap on a WebDAV server.

1)           Choose DITA > New DITA File and select any option from the menu.

2)           Click the Browse URL button in the new file dialog boxes to create a DITA file on a WebDAV server.

Open a file

If you selected the Checkout HTTP Files On Open option from the Preferences dialog box, a file is automatically locked and checked-out when you download it. An asterisk symbol appears against the filename indicating that it is checked-out.

 

Open a n unstructured FrameMaker file

 

1)           Choose File > Open and click the Browse URL button.

 

2)           Select the server name from the right panel, navigate to the folder, and double-click the file to open it.

Alternatively, specify the complete HTTP path to the file and click Open.

Open a DTD

 

1)           Choose Structure Tools > Open DTD and click the Browse URL button.

 

2)           Select the server name from the right panel, navigate to the folder, and double-click the file to open it.

Alternatively, specify the complete HTTP path to the DTD file and click Open.

Open a schema

 

1)           Choose Structure Tools > Open Schema and click the Browse URL button.

 

2)           Select the server name from the right panel, navigate to the folder, and double-click the file to open it.

Alternatively, specify the complete HTTP path to the schema file and click Open.

Save a file

You can automatically upload changes to the WebDAV server. To do so, ensure that you have selected the Upload HTTP Files On Save option in the Preferences dialog box.

1)           Choose File > Save As and click the Browse URL button.

 

2)           Select the server name from the right panel, navigate to the folder, and click Save.

Save a DTD

 

1)           Choose Structure Tools > Save As DTD and click the Browse URL button.

 

2)           Select the server name from the right panel, navigate to the folder, and click Save.

Import files

Import a file:

 

Choose File > Import > File and click the Browse URL button.

 

Import a DTD:

 

Choose Structure Tools > Import DTD and click the Browse URL button.

 

Import a schema:

 

Choose Structure Tools > Import Schema and click the Browse URL button.

 

Import a CSS file:

 

Choose Structure Tools > Import CSS and click the Browse URL button.

 

Close a file

By default, when you close a file the file is automatically checked-in.

Associate a template with a folder

You can specify the HTTP path of the template when associating it with a folder in a hierarchical book.

1)           In the book window, right click the folder for which you want to specify a template and click Properties.

 

2)           Select the Template Path option and click the add template button 
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 to browse for a file.

 

3)           Specify the complete HTTP path in the filename box or click Browse URL to locate the file on the server.

4)           Click OK, Open, and Set to associate a template for the selected folder.

 




10.                Editing Content

 

10.1.             Identify changes by tracking edited text

The Track Text Edits feature highlights added and deleted text for visual distinction. Editors and reviewers can use this feature to track, display, and preview changes by showing or hiding the edits. You can set the color for addi­tions and deletions.

You can set the scope for tracking edits to the current document, the current book or DITAMAP, or selected documents from a BOOK or DITAMAP.

FrameMaker tracks the changes with a user name and timestamp of the changes. If you share the document with other writers, such as in a team envi­ronment, this allows you to determine the author and time of edits in the docu­ment. By default, FrameMaker uses the login name of the current user as the user name.

note:  Changes to formatting and element attributes are not tracked.

The following table shows tracked and untracked text edits in Unstructured documents.



	
 

Tracked text edits

 


	
Untracked text edits

 





	
Adding and deleting text using the keyboard

 


	
Adding rows in tables

 





	
Adding text between deleted text

 


	
Modifying content in cross-references

 





	
Cutting, copying, and pasting text

 


	
Modifying content in markers

 





	
Inserting and deleting anchored frames

 


	
Modifying content in equations

 





	
Adding, editing, and deleting headers and footers

 


	
Adding or deleting text using APIs

 





	
Inserting and deleting footnotes

 


	
Inserting, modifying, and deleting graphics

 





	
Adding, editing, or deleting text within footnotes

 


	
Changing formatting

 





	
Modifying text using the Find/Change feature

 


	
Text within hypertext marker

 





	
Correcting spelling errors using the Spelling Checker feature

 


	
Adding and removing Page break

 





	
Replacing text using the Thesaurus feature

 


	
Converting table to text

 





	
Inserting, deleting, and pasting cross-references

 


	
Replacing variables

 





	
Adding and deleting markers

 


	
Replacing cross-references

 





	
Importing and deleting file by reference or by copying


	
Adding and deleting the Conditional Text marker

 





	
Inserting, pasting, and deleting variables

 


	
Importing by copying into MIF files

 





	
Editing text within a table cell

 


	
Inserting Rubi

 





	
Inserting, pasting, and deleting tables

 


	
 





	
Inserting and deleting equations

 


	
 





	
Changes to text in Rubi

 


	
 






The following table shows tracked and untracked text edits in Structured docu­ments.



	
 

Tracked text edits

 


	
Untracked text edits

 





	
Inserting elements using the Return key

 


	
Deleting root element

 





	
Inserting or deleting text within an element

 


	
Editing attributes of an element

 





	
Deleting elements

 


	
Merging elements

 





	
Cutting, copying, and pasting text

 


	
Splitting elements

 





	
 


	
Unwrapping and wrapping text

 





	
 


	
Dragging or dropping elements in the structure view window

 






10.1.1.            Set color preferences for text edits

You can set the color preferences for text that is added or deleted in addition to the default formatting that FrameMaker applies: text that you add is underlined; deleted text is shown with strikethrough. Avoid setting the same text color that you defined for conditional text so that text edits are clearly visible. In addition, when you preview or view the text edits, turn off conditional text indicators to clearly differentiate the text edits.

1)            

Do one of the following:

•               On the Book window, select View > Track Text Edits > Configure Color.

 

•               When in the document view, select Special > Track Text Edits > Configure Color.

 

2)           Select or define the colors that you want for added text and deleted text, and click Set.

 

10.1.2.            Set scope for tracking text edits

You can set the scope for tracking edits as either for the current book, DITAMAP, or document. When you open a book or DITAMAP, the scope is set to Book or MAP by default. To set the scope explicitly, do one of the following:

1)            

Do one of the following:

 

•               To set the scope to the entire current book, from the book or DITAMAP view, select View > Track Text Edits > Scope > Book or DITAMAP.

 

•               To set the scope to entire book or Ditamap when focus is in docu­ment, select Special>Track Text Edits>Scope> Book or Ditamap.

 

•               To set the scope to only the current document, select Special > Track Edits > Scope > Document.

 

•               If only a document is open, for the current document, select Special > Track Text Edits > Scope > Document.

 

•               To set the scope to selected files in a book, from the book view, select the files you want, and then select View > Track Text Edits > Scope > Selected Documents.

 

•               To set the scope to selected documents of Book or Ditamap when focus is in document, select the files and select Special>Track Text Edits>Scope>Selected Documents.

 

note:  You can set the scope to Book or DITAMAP only when they are open.

10.1.3.            Turn text edit tracking on or off

By default, the Track Text Edits feature is turned off. Do one of the following:

1)            

Do one of the following:

 

•               In the Book or DITAMAP window, select View > Track Text Edits > Enable. This option toggles on and off.

 

•               In the Document window, select Special > Track Text Edits > Enable. This option toggles on and off.

 

note:  It is recommended that you have the documents open when you enable track text edits. FrameMaker will not enable track text edits if the document has errors that prevent FrameMaker from opening it.

 

10.1.4.            Manage text edits in a document

•                

To find specific text edits, select Special > Track Text Edits, and then select Show Next or Show Previous.

 

•               To accept or reject individual text edits, select the text edit, and select Special > Track Text Edits > Accept Edit or Reject Edit.

 

•               To accept or reject all text edits, select Special > Track Text Edits, and then select Accept All or Reject All.

 

Once you accept a text insertion or deletion, that text edit becomes part of the file. If you accept an insertion of text, the inserted text is retained. If you accept a deletion of text, the deleted text is removed. If you reject an insertion of text, the inserted text is removed. If you reject a deletion of text, the deleted text is retained in the file. The inserted or retained text acquires the formatting of its surrounding text.

10.1.5.            Update the user list

 

10.1.6.            Filter edits by author or reviewer name

1)            

Select Special > Track Text Edits > Show Reviewer Name> [user name].

 

After selecting the reviewer name, you can do the following operations:

•                

Show Next/Previous: Displays changes made by the selected reviewer.

 

•               Accept/Reject All: Accept all changes or reject all changes made by the reviewer.

 

note:  To populate the reviewer names in a book or a map, open the book or the map, choose the desired scope and click Update Userlist.

 

note:  The reviewer names are automatically populated for a document.

 

 

10.1.7.            Preview a document with text edits

Before you accept all text edits, preview the final document to see how the text edits are incorporated in the document. You can also preview the original docu­ment without the text edits highlighted in the document.

Preview operations can also be done on all/selected documents of the Book or Ditamap by selecting the appropriate scope.

When you preview a document with text edits, the document display switches from the Tracking mode to the Preview mode. In the Preview mode, avoid making non-trackable changes to your document. For example, do not edit or apply conditions to text in the Preview mode. Such changes are not tracked and you may get an unexpected result in the final document.

By default, the preview of a tracked document is turned off.

note:  When you select the Preview Final or Preview Original option for the first time in your document, the Preview Off option is enabled. You can’t undo the Preview Final or Preview Original command in a document.

•                

To preview the final document with text edits, select Special > Track Text Edits > Preview Final.

 

•               To preview the original document with text edits, select Special > Track Text Edits > Preview Original.

FrameMaker incorporates accepted edits in the document. It deletes rejected edits and restores the document to its original state.

 

If you modify the document with the Track Text Edits feature on and Preview Final or Preview Original selected, FrameMaker switches from Preview mode to Tracking mode. In this case, you can’t undo the changes you make.

 

•               To turn off Preview mode, select Special > Track Text Edits > Preview Off.

10.1.8.            Saving and publishing a document with text edits

When you save a document after inserting text edits, the suggested edits are retained. When you print the document to a printer, FrameMaker prints the text editions as they appear in the document.

When you publish the document as a PDF, the text edits are retained and published to the output. If you publish a FrameMaker document to HTML or RTF, the text edits are accepted, and the document is published with the edited content. If the Preview mode is turned on, the document is published based on the Preview Final or Preview Original option you selected.

You can save a document with tracked text edits as XML. You can open the XML document in FrameMaker, enable tracking of text edits, and then edit the document. When you save the FrameMaker document back to XML, the edited information is preserved through the XML roundtrip.

If Conditional Text roundtripping is disabled, all Track Text Edits information is lost during the XML roundtrip. By default, Conditional Text roundtripping is enabled for any XML application.

Related links:

Print documents

Using Save As to export to other formats

10.2.             Track changes at book or map level

FrameMaker enables you to track changes across an entire book or a map.

To use this feature:

1)            

Open a book or a map file in FrameMaker.

 

2)           Set the scope of the track changes. Click View>Track Text Edits>Scope and set the scope as Book or a Map.

 

note:  Notice that you can set the scope of the track changes from View>Track Text Edits>Scope. You can limit the scope to the currently enabled document, the selected documents or to the whole book (when a book is open).

 

note:  When the document is in focus, you can set the scope of track changes from Special>Track Text Edits.

 

3)           Click View >Track Text Edits > Enable to enable track changes.

 

4)           Optionally, set the colors of the added and deleted text for the track changes from View >Track Text Edits> Configure Color.note:  The set colors apply to the selected scope. For example, if Book is selected as the scope, then the set colors apply to all documents in the book. Conversely, if Document is selected as the scope, the set colors apply only to the current document. All other documents in the book have the default colors for track changes. 

5)           Make changes to the content as desired across all documents in the book.

 

6)           From the review toolbar, select the scope of the track changes for review. Select Book or Map as the scope.

note:  You can also select the scope as Document to limit the scope to the currently selected document, or set the scope to Selected Documents only.

 

note:  The Enable, Disable, and Preview features apply only to the selected scope.

 

7)           Use the review icons (Accept Edit, Reject Edit, Show Next, Show Previous, Accept All and Reject All) to navigate through the review as desired. Notice how FrameMaker moves automatically between all documents in the book for review.

 

8)           Additionally, you can view and edit changes from selected users. Click the Reviewer drop down (see the above screenshot) and select Update User List to refresh the user list. Next, select the users whose changes you want to review from the Reviewer drop down. FrameMaker then navigates through changes only from the selected users.

 

10.3.             Identify revised text with change bars

 

10.3.1.            About change bars

A change bar is a vertical line that visually identifies new or revised text. You can have change bars appear automatically whenever you insert, change, or delete text.

Change bars identify new or revised text.
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Sometimes you want to flag only important changes to your document rather than flag every change. If you’re sending out the second revision of a document for review, you probably want reviewers to focus on substantive changes. In these situations, you can select specific text to mark with change bars rather than add the change bars automatically.

In structured documents, adding change bars manually to particular text is useful for marking revisions or for identifying changes in structure, attributes, or formatting. Perhaps your custom application has an element defined for this purpose. The Change Bar feature does not track changes that affect only struc­ture, attributes, or formatting.

Sometimes you want to remove the change bars from text later. For example, between drafts of a manual, you want to remove the old change bars before adding new ones.

You can insert change bars in the newer of two versions of a document by comparing the versions.

note:  Sometimes you add change bars to an entire paragraph of text and then update the paragraph format, for example, by importing formats from another document. Don’t remove format overrides during the update if you want to retain the change bars. Adding change bars to an entire paragraph alters the paragraph format, and the alteration counts as a format override.

Related links:

Compare versions to view changes

10.3.2.            Apply change bars automatically

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Document > Change Bars.

 

3)           Specify the thickness of the change bars and the distance from the column of text to the change bars.

 

4)           Choose the position of the change bars from the Position pop-up menu. Choose Side Closer To Page Edge or Side Farther From Page Edge to vary the position of the change bars from side to side based on the page layout.

 

The position is relative to the edges of the column that contains the changed text, regardless of the number of columns on the page.

5)           Choose a color for the change bars from the Color pop-up menu.

 

6)           Select Automatic Change Bars, and click Set.

 

Automatic Change Bars don’t detect changes in graphics imported by reference unless the name of the imported file has been changed. Automatic change bars also don’t detect changes that affect only formatting. For example, if you only change the tag of a paragraph from Body to Bullet, no change bar appears. In this case you can add a change bar manually if necessary.

note:  If cross-references are updated when Automatic Change Bars is selected, change bars appear next to all changed cross-references.

10.3.3.            Apply change bars manually to text in paragraphs

1)            

To apply change bars to selected text, choose Format > Style > Change Bar.

 

2)           To apply change bars to paragraphs, click in a paragraph or drag through several paragraphs.

3)           Choose Format > Paragraphs > Designer and display the Default Font properties.

 

4)           Select Change Bar, and click Apply To Selection.

 

10.3.4.            Create and apply change bar character format

You can also apply change bars to text using a change bar character format that you create and apply as a character format. You can set the change bar character format to remain active when you update your document with new formats and remove format overrides.

1)           Click in any paragraph and choose Format > Characters > Designer.

 

2)           In the Character Designer, choose Set Window to As Is from the Commands pop-up menu.

 

3)           Select Change Bar, and then choose New Format from the Commands pop-up menu.

 

4)           Enter a tag name and click Store in Catalog.

 

5)           Click Create.

 

10.3.5.            Remove change bars

You can remove all the change bars in a document at the same time or selec­tively. You can remove the change bars from a single document or from selected files in a book.

Clear all change bars in a document

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents you want to affect.

 

2)           Choose Format > Document > Change Bars.

 

3)           Select Clear All Change Bars, and click Set.

 

Remove specific change bars

1)            

Do one of the following:

 

•               Select the text and choose Format > Style > Change Bar. If some of the selected text isn’t marked with a change bar, choose Format > Style > Change Bar twice to remove the change bars.

 

•               To remove a change bar applied by a character format, select the text and apply the Default Font from the Character Catalog.

 

tip:  To examine and change text marked with change bars, use the Find/Change command. You can search for text that has the Change Bar property set or for text that uses a character format that sets the Change Bar property.

 

10.4.             Compare versions to view changes

 

10.4.1.            About compare documents

Sometimes you receive a revised document with unmarked changes. You can get specific information on the changes by comparing the new version to an older version. When you compare two versions of a document, FrameMaker creates a composite document and a summary document.

 

Composite document

 

The composite document is a conditional document that combines the newer and older versions; it shows the differences side by side. You can specify the condition tag to apply to changed text. You can also specify whether FrameMaker marks changes with change bars.

 

In the composite document, FrameMaker considers differences to be insertions or deletions. For example, if the contents of a graphic frame have changed, both versions appear in the composite. The older version is marked as deleted; the newer version is marked as inserted. Variables in the composite document use the newer definitions, but they aren’t marked as changed. Only inserted and deleted variables are considered changes.

Summary document

 

The summary document contains a general summary and a revision list for each type of item being compared. You can create the summary as a hypertext docu­ment, with links to the actual pages where the changes occurred. By creating a hypertext summary document, you can quickly display changed pages for reading or editing.

In the summary document (named Summary.fm), differences are considered insertions, deletions, or changes. If an item has moved, it’s marked as deleted and inserted. FrameMaker displays the number of the page on which the change occurs in the newer version, the older version, and the composite document. For insertions, the page number given for the older version is the page where the item would be inserted to match the newer version. For deletions, the page number for the newer version is the page where the item would have appeared if it hadn’t been deleted

 

10.4.2.            Items compared

When comparing two versions of a document, FrameMaker checks the contents of flows with the same names on body and reference pages. It looks at text, foot­notes, anchored frames, tables, variables and their definitions, cross-references and their formats, footnote text, marker types, and marker text. FrameMaker doesn’t compare structure elements; it does compare the element contents.

The following are some specific differences that FrameMaker can find:

Anchored frames

 

FrameMaker compares the objects in the frame. If the objects are different, or if they are in different positions, FrameMaker marks the entire anchored frame as changed.

Cross-references

 

FrameMaker checks whether a cross-reference is external or internal. It also checks the cross-references format name, the marker text at the source, and the path of the referenced file (for external cross-references). If any of these properties are different, FrameMaker marks the cross-refer­ence as changed.

 

Text insets

 

FrameMaker compares the modification date, the filename, the relative paths of text insets, and the way the inset was imported. For example, for imported insets, it checks whether the lines were merged into paragraphs. If any of these items are different, it marks the entire text inset as changed.

 

Imported graphics

 

FrameMaker compares the contents and dpi scaling of the imported graphic. For example, it checks whether the object has been flipped or rotated, and compares the size of the bounding box. It also compares how the graphic was imported—by reference or by copying. When you import a graphic by reference, FrameMaker compares the paths. If any of these properties are different, it marks as changed the line that contains the anchored frame of the imported graphic.

 

Equations

 

FrameMaker compares the size of the equation, the location of the equa­tion within its graphic frame, and the math expressions. If any of these items are different, it marks the entire equation as changed.

 

Tables

 

FrameMaker checks the number of rows and columns, whether cells are straddled, and whether cells are rotated. If any of these properties are different, FrameMaker marks as changed the line that contains the table anchor. If text in cells has changed, only the new table appears in the composite document. FrameMaker marks as changed the line in the cell that has changed. If more than 75% of the cells have changed, it marks the entire table as changed.

 

FrameMaker doesn’t compare these items:

 

•               Master page flows, header and footer flows, or untagged flows

 

•               Graphic objects or text lines not in anchored frames

 

•               Anchored frame positions

 

•               Footnote properties or numbers

 

•               Paragraph, character, or table tags

 

•               Text or table formatting

 

•               Tags in the Paragraph Catalog, Character Catalog, or Table Catalog

 

•               Contents of text insets

 

FrameMaker doesn’t check the formatting of text or tables. Therefore, it doesn’t notice different ruling or shading in a table or a different color assigned to text.

 

Both the English version of FrameMaker and the Japanese version running on a Japanese OS can compare Japanese text.

10.4.3.            Compare two versions of a document

1)            

Open both versions of the document. If the documents contain condi­tional text, all conditions must be visible.

 

2)           In the newer version, choose File > Utilities > Compare Documents.

 

3)           Choose the older version from the pop-up menu, and specify the docu­ments you want FrameMaker to create. All open, named documents, except the current document, are listed in the Older Document pop-up menu.

 

4)           Click Options, do the following, and click Set:

 

•               Specify how to display inserted text in the Mark Insertions With area. Select the default condition tag (Inserted) or a different condi­tion tag. You can choose not to mark inserted text.

 

•               Specify how to display deleted text in the Mark Deletions With area. Select the default condition tag (Deleted), a different condition tag, or text that you specify. To omit deleted text from the composite document, click Replacement Text and leave the box empty.

 

•               To mark all changes (insertions and deletions) with change bars in the composite document, select Mark Changes With Change Bars. FrameMaker uses the current change bar settings for the document.

 

tip:  To add change bars to the newer version of a document, select Mark Changes With Change Bars. Choose Replacement Text in the Mark Dele­tions With area and leave the Replacement box empty.

5)           Click Compare. When the comparison is complete, FrameMaker displays the summary and composite documents. If the two versions are the same, neither document is created.

 

6)           To make the summary report a hypertext document, select Create Hyper­text Links In Summary. When you click the page number of a change in the summary, FrameMaker displays the page. You can display pages of the newer version, the older version, or the composite document that contains that change.

 

10.4.4.            Comparing documents that contain multiple flows

You can compare documents with multiple flows. To prevent FrameMaker from comparing the wrong flows, make sure that each flow has a unique tag and that the flows have the same tag.

A document can contain different flows with the same name, such as separate flows named “A” on disconnected pages. In such cases, an alert message lists the duplicate flows when you try to compare the documents. FrameMaker compares flows only if each document contains one flow of the same name.

10.4.5.            Compare documents that contain conditional text

FrameMaker ignores hidden text and graphics that are not showing.

1)            

Do one of the following:

 

•               To compare the full texts of two documents that contain conditional text, show all conditions before performing the comparison.

•               To compare specific texts of two documents that contain condi­tional text, show conditions based on a specific expression before performing the comparison.

•               To ignore conditional text while comparing documents, hide all conditions before performing the comparison.

2)           Compare the documents.

 

Any hidden conditional items in the newer document remain, hidden, in the composite document that is produced.

10.5.             Determine word and character count

When reviewing changes, you sometimes want to know the number of words and characters in the document. Counting the number of characters in a docu­ment is useful for Asian-language documents with double-width (multibyte) characters. The word count report gives the number of single-width characters, double-width characters, and the total number of characters.

1)            

Choose File > Utilities > Document Reports.

 

2)           Select Asian Character Count or WordCount, and then click Run.

 

10.6.             Import PDF comments

You can import comments from a tagged PDF directly into the source FrameMaker document and reduce the time taken to fix comments. You can incorporate suggestions and edits from multiple reviewers participating in a shared PDF review much faster into the source document.

However, for comments to import correctly, it is important that you generate a tagged PDF and after generating the PDF you do not modify the source FrameMaker document. If you make changes in the source FrameMaker docu­ment, and then import PDF comments, the comments may not be imported at the correct location.

When saving a FrameMaker file as a PDF, ensure that you select the Generate For Review option in the PDF Setup For Selected File dialog box. Selecting this option creates a tagged PDF.

You can import comments only from PDFs created using FrameMaker 9 or above.

 

Related links:

About tagged Adobe PDF

Generating a tagged PDF file

10.6.1.            Types of comments supported

FrameMaker can import the following types of PDF comments and annota­tions:

•                

Text additions

 

•               Text deletions

 

•               Text replacements

 

•               Sticky notes

 

•               Underlined text

 

•               Highlighted text

 

Other types of comments or annotations are not imported.

10.6.2.            Placement of comments

When you import the PDF comments, they are inserted at the same location in the source FrameMaker document as tracked text edits, tracked markers, or simple text formatting. Text additions, deletions, and replacements are inserted as text edits. Sticky notes are inserted as comment type markers. FrameMaker tracks these text edits and markers irrespective of whether the feature is enabled or disabled.

PDF comments of type Highlight are imported with the highlighting retained due to the implementation of the Text Background Color feature.

If the source document has changed after you sent the PDF for review, the exact insertion points for some comments can be indeterminable. FrameMaker inserts such comments as tracked markers in approximate locations. Comments applied to unnamed text flows, non-text objects, or objects locked for editing are also inserted in approximate locations as markers.

note:  FrameMaker does not allow insertions into objects like variables, text lines, and graphics. Also, cross-references, text insets, bullets, and numbering are locked for editing in FrameMaker. Comments on these objects are inserted as markers. If a reviewer adds a comment in response to another comment in the PDF, it is inserted as a marker.

10.6.3.            Import comments

1)            

Open the document or book file to import PDF comments.

 

2)           Click File > Import > PDF Comments.

 

3)           Read the instructions in the Import Comments From Adobe Acrobat dialog box. Click Yes to proceed.

 

4)           In the Import Comments From PDF dialog box, choose the PDF file from which you want to import comments.

 

5)           Select the types of comments that you want to import.

 

All comments

Select to import all supported types of comments from the PDF.

 

Only Insert, Delete, and Replace type of comments

 

Select to import only text additions, deletions, and replacements.

 

Apply custom filters

 

Select to specify filters for the comments that you want to import. You can filter comments by parameters like type, author, status set by the author, checking state, and insertion date.

 

6)           If the source document was modified after you created the PDF for review, FrameMaker confirms whether you want to proceed with the import.

 

If the modification date of the source file is newer than the creation date of the tagged PDF, FrameMaker confirms whether you want to proceed with the import.

 

7)           FrameMaker imports the comments from the PDF and displays an import summary. The summary displays the number of comments that FrameMaker imported and placed in their exact locations, imported and placed in approximate locations, and failed to import.

 

8)           Click OK to close the Import Summary dialog box and return to the docu­ment window.

 

10.6.4.            Structured documents and PDF comments

You can import comments into a structured document just as you would into an unstructured document. Comments on text ranges or objects locked for editing in the structured document are inserted as markers. For example, prefixes or suffixes of elements are locked for editing in a structured document.

A comment or annotation can span multiple elements. FrameMaker does not mark a parent element for deletion if one or more of its child elements fall outside the text range marked for deletion.

Also, you can import comments in books but they do not get imported in child books or DITA maps included in hierarchical books.

10.7.             Roundtripping tables, equations, and anchored frames

You can roundtrip tables, equations, and anchored frames between Structured FrameMaker and XML.

10.7.1.            Roundtripping table properties

Read-write rules handle the roundtripping of table formatting properties. New R/W rule mapping for the table cell properties is as follows:


Table 1:        (Sheet  of )

	
 

Property

 


	
Non-CALS R/W Rule

 


	
CALS R/W Rule

 


	
Attribute Value

 





	
FP_CellAngle

 


	
cell angle

 


	
rotate

 


	
Integer

 





	
FP_CellOverrideFill

 


	
fill override

 


	
NA

 


	
Integer corresponding to FDK values

 





	
FP_CellUseOverrideFill

 


	
use fill override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_CellOverrideShading

 


	
shading override

 


	
NA

 


	
Tag of FO_Color

 





	
FP_CellUseOverrideShading

 


	
shading override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_CellOverrideBottomRuling

 


	
bottom ruling override

 


	
NA

 


	
Tag of FO_RulingFmt

 





	
FP_CellUseOverrideBRuling

 


	
bottom ruling override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_CellOverrideLeftRuling

 


	
left ruling override

 


	
NA

 


	
Tag of FO_RulingFmt

 





	
FP_CellUseOverrideLRuling

 


	
left ruling override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_CellOverrideRightRuling

 


	
right ruling override

 


	
NA

 


	
Tag of FO_RulingFmt

 





	
FP_CellUseOverrideRRuling

 


	
right ruling override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_CellOverrideTopRuling

 


	
top ruling override

 


	
NA

 


	
Tag of FO_RulingFmt

 





	
FP_CellUseOverrideTRuling

 


	
top ruling override

 


	
NA

 


	
0 = False

 

Nonzero value = True

 






The read-write rule mapping for the table row properties is as follows:


Table 2:        (Sheet  of )

	
 

Property

 


	
Non-CALS R/W Rule

 


	
CALS R/W Rule

 


	
Attribute Value

 





	
FP_RowKeepWithNext

 


	
keep with next

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_RowKeepWithPrev

 


	
keep with next

 


	
NA

 


	
0 = False

 

Nonzero value = True

 





	
FP_RowStart

 


	
row placement

 


	
NA

 


	
Integer corresponding to FDK values

 






In the following example, the prop5 attribute controls the bottom ruling of the table.

element "tablecell"
{
is fm table cell element;
attribute "prop1" is fm property right ruling override;
attribute "prop2" is fm property use right ruling override;
attribute "prop3" is fm property top ruling override;
attribute "prop4" is fm property use top ruling override;
attribute "prop5" is fm property bottom ruling override;
attribute "prop6" is fm property use bottom ruling override;
attribute "prop7" is fm property left ruling override;
attribute "prop8" is fm property use left ruling override;
attribute "prop9" is fm property cell angle;
}

In the following example, the att1, att2, att3, and att4 attributes control the shading properties of the table cell:

element "tablecell2"
{
is fm table cell element;
                 attribute "att1" is fm property shading override; attribute "att2" is fm property use shading override; attribute "att3" is fm property bottom ruling override; attribute "att4" is fm property use bottom ruling override;
attribute "att5" is fm property fill override;
attribute "att6" is fm property use fill override;
}

10.7.2.            Roundtripping equations and anchored frames

You can roundtrip equations and anchored frames between Structured FrameMaker and XML. When you save a Structured FrameMaker document to XML, FrameMaker creates MIF files for the equations and anchored frames in the document. FrameMaker saves every anchored frame and equation in a different MIF file.

note:  To test this feature, you can use the ReportPlain XML application in the samplesStructapps.fm file at: <installation_directory>/Adobe/AdobeFrameMak­er11/Structure. This XML application has Equation and Frame elements.

You can change the type of files that are created for storing equations and anchored frames by specifying the following flag in the maker.ini file.

To specify the default vector format for xml, edit maker.ini (user area) file and add flag DefaultvectorformatforXMLexport flag. For example, the following sets default vector format for xml to CGM.

 DefaultvectorformatforXMLexport= CGM 

10.8.             Direct OLE support in XML

Structured FrameMaker supports round-tripping OLE objects, such as Visio objects and PowerPoint presentations. FrameMaker uses an XML Processing Instruction to handle the OLE object roundtripping.

You can control the OLE support using the DirectOLESupportInXml flag in the maker.ini file. To enable this feature, set the flag as On. The default value of this flag is Off; when this flag is Off, the OLE is saved as a .mif file.

Also, notice the following entries in the maker.ini file:

53="pptx"  OLE2 OLE2  OLE2     FMGFXImport "pptx" frame.exe ^.pptx
54="VSD"  OLE2 OLE2  OLE2      FMGFXImport "VSD" frame.exe ^.vsd

These entries assign an automatic filetype filter to a file when it is imported. If necessary, youcan add more filters (with respective OLEs).

10.8.1.            Insert an OLE object

 

1)           Select File > Import > Object. The Insert Object dialog appears.

 

2)           Navigate to the OLE object and select:

 

•               Create from File

 

•               Link

 

3)           Click OK.

 

note:  You can also paste an OLE object using the Paste Special command and selecting Paste Link. 




11.                Structured Authoring

 

11.1.             Introduction to structured authoring

 

11.1.1.            About structured authoring

 Structured authoring is a publishing workflow in which you use technology to define and enforce a consistent organization of information in documents. In traditional unstructured publishing, content is written according to rules and approved styles described in style guides and enforced by editors.

In an unstructured authoring workflow, you create relatively free-flow narrative based documents. For example, you can have headings, followed by paragraphs, or graphics with captions or alternate text. In case of structured authoring the content rules enforce a consistent structure across similar pieces of information. For example, you can decide to enforce these content rules:

 

•               A bulleted list must contain at least three items.

 

•               A heading must be followed by a paragraph.

 

•               A table must have a heading row.

 

•               A graphic must have a caption.

 

These content rules are defined in either a document type definition (DTD) or an XML schema. Conformance to these content rules is automatically checked against the DTD or schema.

For example, consider the structure of a home address. Suppose that the content rules require address to contain an employee name, house number, street, city, and ZIP code. In unstructured authoring, an address without a house number can be discovered only through editing or review. In structured authoring, the structure is validated and automatically checked for completeness. Consistent organization and sequence are therefore enforced and assured.

Structured authoring improves consistency across documents. Consistency simplifies the management of documents in a content repository. Content can be automatically grouped at specified element levels.

 

Structured authoring has these benefits:

 

•               Enforces a consistent organization of information

 

•               Automatically validates the organization of information

 

•               Complies with required document structures

 

•               Allows publishing to multiple output formats

 

•               Supports content reuse and exchange with XML

 

•               Uses metadata for versioning

 

•               Simplifies database publishing

 

•               Reduces localization cost

 

Using FrameMaker

Using XML and structured authoring, you can define content tags that are divorced from formatting rules.

FrameMaker provides a useful structured environment for authoring in XML.

•                

User-friendly WYSIWYG structured authoring environment (authoring visually)

 

•               Easier transition from unstructured to structured FrameMaker

 

•               Complete DITA and DocBook support

 

•               Ability to create multiple outputs such as direct print and PDF outputs

 

•               Ability to merge XML content along with FrameMaker components in books

 

11.1.2.            About SGML, XML, and XHTML

Using FrameMaker, you can import and export structured documents in either SGML or XML (including XHTML 1.0) format. Once you import a structured file, it is no longer an SGML or XML file; it is a structured FrameMaker docu­ment. To return it to its original format, save it as an SGML or XML file.

About SGML

Standard Generalized Markup Language (SGML) is the international standard for all markup languages for data exchange and storage.

SGML is a descriptive, rather than procedural, markup language, meaning the same document can be processed by different systems. Each system applies different processing instructions to relevant sections. You can transfer SGML documents from one system (hardware and software environment) to another without any loss of data.

SGML was the first language to implement the Document Type Definition (DTD), which formally defines the document by its components and structure. Documents of the same type can then be verified and processed uniformly.

A document that conforms to the structure of a DTD is said to be valid.

About XML

Extensible Markup Language (XML) is a generalized format for representing structured information, especially for the web. Like HTML and SGML, XML requires the use of elements and structure.

However XML differs from HTML in that it is extensible. You can define not only your tags but also their order, relationships among them, and the way they are processed and displayed. In terms of markup, XML has tags or elements which are similar to HTML markup except that they are defined by you.

Use XML to define and implement a structure that is appropriate for your content. An XML document that conforms to the structure of a DTD is said to be valid. An XML document that uses tags that conform to the standard XML specifications is said to be well-formed.

About XHTML 1.0

Extensible Hypertext Markup Language (XHTML) is an extension of HTML that is based on XML and is designed to work with XML-based applications. It can be viewed, edited, and validated with standard XML tools. Using XHTML is an easy way to migrate from HTML to XML while retaining forward and backward compatibility of your content.

Differences between XML and HTML

 

Whereas HTML describes formatting, XML describes content itself. Humans can read HTML documents rendered in a browser. Both machines and humans can read XML.

Instead of style-based, paragraph-oriented word processing and desktop publishing, XML provides a foundation for structured authoring. XML describes content according to elements that are organized in a hierarchical tree. In word-processing environments (such as unstructured FrameMaker), the relationship among the various document components is apparent through formatting on the page. The document file, however, does not capture these relationships because a word processor document is made up of a string of para­graphs. For example, unstructured FrameMaker does not capture the subordi­nation of a Body paragraph tag to its preceding Heading1 tag. Structured authoring, however, does capture the hierarchical relationships among the document components.

11.1.3.            XML schemas, EDDs, and DTDs

   

Building blocks of schemas and EDDs

 

Elements

 

The basic building blocks of structured documents are elements. Elements represent pieces of a document's content (its text, graphics, and so on) and together make up the document's structure. Elements can be simple elements or complex elements.

 

A simple element in XML contains just text. A complex element can have attri­butes and can:

 

•               be empty.

 

•               contain other elements.

 

•               contain only text.

 

•               contain both elements and text.

 

Elements can have values within a specified range of valid values.

All structured documents in FrameMaker use elements. Each element has a name, or tag, such as Section, Head, or List. The element tags that are available are determined by the document element definitions.

Attributes

 

Attributes supply additional information about an element. For example, the DTD designer for a manual could use an attribute called version for its book element to allow the user to specify a book’s revision status. In FrameMaker, the attributes for an element are a part of the definition of the element itself. In XML or SGML, the attributes of an element occur separately in an attribute definition list declaration (ATTLIST) in the DTD.

 

Attributes can have a default value or a fixed value. Attributes can also be either mandatory or optional. For example, if you have a topic element, the topic ID could be a mandatory attribute for topics being cross-referenced. You can also have value ranges for attributes or enumerate the legal values for an attribute.

 

Element rules

 

Following seven rules control how the elements are used in terms of their sequence, number of occurrences, and group.

All

 

Indicates that child elements can appear in any sequence but must appear at least once.

 

Choice

 

Indicates one or the other child element can occur.

 

Sequence

 

Indicates the order in which the child elements appear.

 

minOccurs

 

Indicates the minimum number of times a child element can occur.

 

maxOccurs

 

Indicates the maximum number of times a child element can occur.

 

Element Groups

 

Elements can be grouped under a group declaration.

 

Attribute Groups

 

Attributes can be grouped under a attributeGroup declaration.

 

XML schemas

An XML schema defines the legal building blocks of an XML document. Unlike the EDD, DTDs and schema files do not provide formatting information.

XML schemas define the following:

•                

List of elements that can appear in a document

•               Attributes that can appear in a document for an element

 

•               Hierarchy of elements - which elements can appear as child elements

•               Sequence of child elements

•               Number of child elements

•               The data types for elements as well as attributes

•               Default and fixed values for elements and attributes

XML namespaces

 

XML namespaces allow the same document to contain XML elements and attri­butes taken from different vocabularies, without naming collisions.

Opening or importing a schema

 

You can import an XML document that references a schema file, and you can specify a schema file in your structure application to use for validating a docu­ment upon export to XML.

 

To specify a schema file for use in exporting to XML, modify the structapps.fm file. The element schema, a child of the XmlApplication element, specifies the schema file path for export.

 

EDDs

An EDD is a structured document. Use the structured editing features to create and edit the EDD.

The EDD contains both structural rules for the document (Document Type Definition or DTD) and styling rules, which dictate how elements of a specific type are styled. An application developer generally creates the EDD from an existing DTD file or from scratch. For more information, see the Structured Application Developer’s Guide located in the OnlineManuals folder.

Create a DTD from an EDD

DTDs or Document Type Definitions define the elements that you can include in a structured document. It defines the elements, their attributes, order of elements and what elements can contain other elements.

1)           Open the EDD.

 

2)           Add the StructuredApplication element, then type in the name of the XML application that you created in the previous section.

 

3)           Select StructureTools > Save as DTD.

 

4)           Enter a filename. Ensure that you specify the .dtd extension.

 

If your EDD is valid, you should not see an error log. However, it is possible to build SGML style General rules in FrameMaker that are not permitted in XML.

 

5)           A message dialog box provides you with information that FrameMaker has finished writing the DTD.

 

6)           Open the DTD. If you have not specified the StructuredApplication in step 2, you can select it from the Use Structured Application dialog box that is displayed.

 

The DTD is now ready to be used.

11.1.4.            Structured templates

All FrameMaker structured applications require a structured template. Struc­tured FrameMaker templates contain definitions of all the elements that can be used in the document as well as the document’s page layout and formatting.

Structured templates are like unstructured templates with the most obvious difference being the element catalog.

The element catalog displays the element definitions defined in the EDD. To create a structured document as a first step, you import the definitions from either an EDD or a DTD. The element definitions in an EDD or DTD are popu­lated in the element catalog. You use the element catalog dialog to insert valid elements in your document and build a structure that complies with the rules in the EDD.

11.1.5.            Structured application definitions

Two off-the-shelf structured applications available for technical documentation are DITA and DocBook.

DITA

DITA or Darwin Information Typing Architecture provides an off-the-shelf DTD and set of rules designed specifically for writing online documentation, such as software help files. It defines a tag structure suited to authoring, producing, and delivering technical documentation. The types of tags in DITA include <topic>, <title>, <shortdesc>, <prolog>, <body>, and <concept>. Following are some distinguishing DITA features:

•                

DITA is topic-oriented. Each topic can be a piece of modular writing that can be reused in multiple contexts.

 

•               Because DITA separates content from context, multiple architectures of information are possible in DITA. DITA can also be extended to allow for the definition of information types.

 

•               DITA is topic-based. It provides three basic topic types but it allows for specialization of these topic types for individual needs.

•               DITA uses a ditamap which contains links to the XML files in the docu­mentation set. Each XML file can be a topic or a collection of topics.

 

•               DITA outputs can be multiple ranging from PDF and HTML to variable documents. However, all output forms require some development work.

 

•               DITA is better suited for larger documentation sets.

 

DocBook

DocBook is also an open standard, designed for technical articles and documen­tation. DocBook provides a DTD for writing technical books and articles, with a structure that such forms imply. DocBook tags include <article>, <section>, <title>, <articleinfo>, and <pubdate>.

Following are some distinguishing DocBook features:

•                

DocBook is more book or section oriented.

 

•               DocBook is hierarchical by nature and has to be developed for true single-sourcing. The content is not independent of its context.

•               DocBook has a fixed but a large set of elements and attributes.

•               DocBook provides an XML include file that contains all the other files.

 

•               DocBook outputs include PDF, HTML, and HTMLHelp. It can be extended for other output forms with some development work.

 

•               DocBook is easy to set up and is better suited for small to medium docu­mentation sets.

 

11.2.             Migrating from unstructured FrameMaker to XML

  

11.2.1.            Components of a structured authoring environment

In unstructured FrameMaker, setting up an authoring environment requires only a template file. The template file defines the formats and the styles and a style guide defines how to work correctly with the template. In structured FrameMaker, you require more than just a structured template.

 

To establish a basic structured authoring environment in FrameMaker, you require an EDD or a DTD. You can create custom EDDs and DTDs or use off-the-shelf EDDs and DTDs. Additionally, you need to link the element defi­nitions with formatting information. You can link elements in the EDD to formatting in three ways:

 

Formatting template

 

You can assign formatting based on the various tags (paragraph tags, char­acter tags, and so on) in a template. If you already have a formatting template, you can reuse information in that template.

 

Format change lists

 

You can create named formatting definitions in the EDD. The format change lists let you provide partial formatting specifications and inherit the rest from a few base paragraph tags. You can reuse format change lists for related elements.

 

Embedded formatting

 

You can specify formatting by writing the formatting into each element definition.

After you create the EDD and the formatting, you combine the two components to create a single structured template. To create the structured template, you open the formatting template and import element definitions (File > Import > Element Definitions) from the EDD. The resulting file is your structured template.

Apart from the EDD and the structured template, you also need:

 

read/write rules

 

The read/write rules control translation from FrameMaker structure to XML and back. Specifically, read/write rules help manage table translation and other complex formatting.

 

Structured application

 

The structured application lists all of the component files in your structure implementation and provides configuration information. For example, you can use the structured application to specify whether and how to export conditional text tagging.

 

11.2.2.            Getting started with structure

Following are the basic steps to get started with structured authoring in FrameMaker.

Content analysis

Before building the proposal template, analyze existing proposals to identify their components. Based on this analysis, you create a content map. The proposal example results in the following sequence:

1)            

Title

 

2)           Executive summary: Title, One paragraph

 

3)           Project description: Title, One or more paragraphs

 

4)           Cost: Title, One or more paragraphs

 

5)           Schedule: Title, One or more paragraphs

 

note:  You could probably build the EDD for this simple example without formal content analysis. For larger projects, though, content analysis is critical.

Choose an EDD strategy

You can build an EDD in multiple ways:

•                

Create the entire EDD yourself.

 

•               Import a DTD or schema to create an EDD that contains structure defini­tions.

 

•               Use a conversion rules table to structure an existing sample document. Then create a first draft of the EDD that contains basic element definitions and formatting that matches your unstructured template.

 

•               Modify an existing EDD— one of the samples supplied with FrameMaker or an EDD from another source.

 

Build the proposal EDD

Based on the content analysis, you can now create the proposal EDD.

1)            

Make sure you are in structured FrameMaker. To switch from unstruc­tured to structured FrameMaker, select File > Preferences > General. In the Product Interface pop-up menu, select Structured FrameMaker. Close and restart FrameMaker.

 

2)           Select StructureTools > New EDD to create an EDD file. Default elements are inserted in the EDD.

 

note:  The EDD is itself a structured FrameMaker document. You use the same guided editing environment to create the EDD that you use to edit other structured documents.

 

3)           Select Structure Tools > Structure View to display the Structure View panel.

 

4)           Create the top-level Proposal element. Position your cursor to the right of the Tag bubble in the Structure View, and type in Proposal. As you type, the letters appear in both the Structure View and the document window.

 

5)           Click the Elements Catalog button to display the Elements catalog.

 

6)           In the Structure View, click to the right of the red box (which indicates that additional information is required). Notice that the contents of the Elements catalog change because of the new cursor location. In the Elements catalog, select Container and click Insert. The Container element and a child GeneralRule element are inserted. The general rule specifies which elements are allowed inside the proposal element. During the content analysis, you identified the following: title, executive summary, project description, cost, and schedule.

 

7)           Type a general rule for Proposal: Title, ExecSummary, ProjectDescription, Cost, Schedule 

note:  Element names cannot contain spaces.

 

8)           Insert a ValidHighestLevel element as a sibling of the GeneralRule element. To do so, click underneath the GeneralRule element to position your cursor, click the ValidHighestLevel element in the Elements catalog, and then click Insert.

The Proposal element is complete. You must now provide definitions for each of the child elements: ExecSummary, ProjectDescription, Schedule, and Cost.

Define the child elements

1)            

Position your cursor at the bottom of the structure.

 

2)           Using the Elements catalog, insert an Element bubble. Name the element ExecSummary, make it a container, and specify the following as the general rule: Title, Para+ 

3)           Repeat step 2 to define the remaining elements. The general rules are shown in the following table:

 



	
Element

 


	
General Rule

 





	
Project Description

 


	
Title,Para+

 





	
Cost

 


	
Title,Para+

 





	
Schedule

 


	
Title,Para+

 





	
Title

 


	
<TEXT>

 

(Type the word TEXT with angle brackets around it.)

 





	
Para

 


	
<TEXT>

 

(Type the word TEXT with angle brackets around it.)

 






4)           Save your EDD file as proposal_EDD.fm.

 

Test the EDD

To test the EDD, you import it into a document and then verify that you can create the structure you expect. At this point, the document does not have any formatting, but you can still verify the structure.

1)            

Create a new, blank, portrait document by selecting File > New > Docu­ment, and then click Portrait.

 

2)           Make sure that the EDD and the new document file are both open. From the new document, select File > Import > Element Definitions. In the Import from Document pop-up menu, select the proposal EDD and click Import.

 

note:  If your EDD is not displayed in the list, make sure that the EDD file is open and that you have saved it. Until you save a document, it is not available in this list.

 

The structure definitions in your EDD are imported into the blank docu­ment. To verify that the definitions were imported, position your cursor in the main text flow and then display the Elements catalog. You should see the Proposal element.

 

3)           Insert a Proposal element. The Title element, which is required as the first child of Proposal, should now appear in the Elements catalog.

 

4)           Insert the Title element. Continue inserting elements until your proposal structure is complete.

 

note:  If your structure is incorrect, go back to your EDD, correct it, and then re­import the element definitions. You can also check your EDD against the online proposal_edd, which is available at the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

 

5)           Save your file as structured_proposal.fm.

 

11.2.3.            Add formatting to the EDD

You have now built an EDD that provides structure for a simple proposal. However, when you type content, no formatting is applied. Following section describes how to provide formatting, and how to automatically insert the correct text for the various titles. By default, text uses the Body paragraph tag.

Change the Body tag definition

1)            

In structured_proposal.fm, select Format > Paragraphs > Designer and change the default definitions of the Body and Heading1 paragraph tags. For example, change the font or place a line above the Heading1. To make your changes obvious, you may also want to assign unique colors to the two tags.

 

2)           In proposal_EDD.fm, modify the Para element definition to include a formatting rule. To specify that Para should always use the Body para­graph tag, click under the GeneralRule element, add a TextFormatRules element, and then add an ElementPgfFormatTag element. Type Body as the text for the ElementPgfFormatTag element.

 

For the Title element, you need more complex formatting rules. Title should automatically display section titles, such as Executive Summary, Project Description, and so on. You must write a context rule that specifies what text to display for each type of heading, and specify that Title uses the Heading1 paragraph tag.

 

3)           In proposal_EDD.fm, modify the Title element definition to use the Heading1 paragraph tag. Add the same TextFormatRules and ElementP­gfFormatTag elements as you did for the Para ­element.

 

note:  Like the paragraph tags, the information you enter is case-sensitive and space-sensitive. For example, “Heading1” is not the same as “heading1” or “Heading 1.”

Next, add a prefix rule to the Title element. Prefix rules let you specify text that should appear at the beginning of the element. Based on the Title’s position, you’ll specify which text should be displayed.

Add a prefix rule

1)            

Position your cursor in the Title element to insert a child of Container after TextFormatRules.

 

2)           Insert a PrefixRules element.

 

3)           Insert a ContextRule element. The If and Specification elements are inserted automatically. For the Specification text, type ExecSummary.

4)           Position your cursor underneath the Specification element and insert a Prefix element.

 

5)           For the Prefix element text, type: Executive Summary 

6)           Repeat steps 3– 5 for the other elements that need titles—ProjectDescrip­tion, Schedule, and Cost—and insert the appropriate text for each prefix.

 

Test the results

1)            

Save the EDD.

 

2)           Import the element definitions into your structured_proposal.fm file to test the results. Each section should display the title text you’ve specified. The completed EDD is available at the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

 

11.2.4.            Build a structured application

To enable XML import and export for structured proposals, you need to set up a structured application, which lists the components of the structured authoring environment.

First, you need to create a document type definition (DTD) that matches the EDD.

Create a DTD

1)            

Open the proposal_edd.fm file in structured FrameMaker.

 

2)           Select StructureTools > Save As DTD. Specify the filename (proposal.dtd) and where you want to save the file, and then click Save.

 

3)           In the Use Structured Application dialog box, leave the default selection, <No Application>, and click Continue.

 

4)           In the Select Type dialog box, select XML and then click OK. The DTD file is written out to the location you specified.

 

You also need a structured template that contains formatting and EDD infor­mation.

Create a structured template

1)            

Open the structured_proposal.fm file.

 

2)           Delete all content from the file. A structured template must be empty.

 

3)           Save the file as proposal_template.fm.

 

Now, you are ready to configure the structured application.

Configure the structured application

1)            

Select StructureTools > Edit Application Definitions. This command opens the structapps.fm file - in which application definitions are stored— from the following location:

%appdata%\Adobe\FrameMaker\10\ 

note:  Like the EDD, the application definition file is itself structured.

2)           Insert an XMLApplication element as a child of the StructuredSetup element.

 

3)           Type Proposal for the application name.

 

4)           Insert a DTD element and specify the following as the DTD element text:

 

  $STRUCTDIR/proposal/proposal.dtd

 

5)           Insert a Template element and specify the following as the Template element text:

 

  $STRUCTDIR/proposal/proposal_template.fm

 

6)           Select File > Save to save the structapps.fm file.

 

7)           Select StructureTools > Read Application Definitions to update FrameMaker with the new application definition.

 

note:  To verify that the application is installed correctly, select Structure­Tools > Set Structured Application to display the Set Structured Application dialog box. If you set up the applications definitions correctly, Proposal appears in the drop-down list object.

 

Finally, you need to copy the application files into the directory where the struc­tured application definition expects them.

Copy the application files

1)            

Locate your FrameMaker installation folder using the file explorer (the default FrameMaker installation path on a Windows computer is Program Files\Adobe\FrameMaker9), and navigate to the Structure\xml folder.

 

2)           In the xml folder, create a proposal folder.

 

3)           Copy the proposal.dtd and proposal_template.fm files into the proposal folder.

 

11.2.5.            Test XML roundtripping

Once you have configured the structured application, you can test XML roundtripping.

1)            

Create a valid structured proposal in FrameMaker.

 

2)           Export the FrameMaker file to XML. To do so, select File > Save As and choose XML as the output format. If prompted, select the Proposal appli­cation.

 

3)           Open the exported XML file in a text editor or an XML editor and verify that you have a valid XML file.

 

4)           In an XML or a text editor, modify the file you just exported. You can also create an XML file that validates against the proposal DTD. Save the new XML file.

 

5)           In FrameMaker, open the XML file. Verify that the XML file imports correctly and that formatting is applied automatically.

 

11.2.6.            Implementing structured FrameMaker

 

The term content analysis describes a process in which you review existing documents to understand how they are designed and what implicit structure they contain. Begin your analysis by making a list of the documents your orga­nization produces. Your list might include user guides, reference guides, white papers, tutorials, training manuals, and online help. Make a list of the major components for each document type. For each component, list whether the item is required, optional, and how often it occurs in that document. The following table shows a high-level analysis for a book:



	
 

Component

 


	
Requirement

 


	
Occurrence

 





	
Front matter

 


	
Mandatory

 


	
1

 





	
Table of contents

 


	
Mandatory

 


	
1

 





	
Preface

 


	
Optional

 


	
0 or 1

 





	
Chapter

 


	
Mandatory

 


	
2 or more

 





	
Appendix

 


	
Optional

 


	
0 or more

 





	
Glossary

 


	
Optional

 


	
0 or 1

 





	
Index

 


	
Mandatory

 


	
1

 






For major components, such as lessons (for training manuals) or chapters (for books), work your way down the document hierarchy into smaller and smaller chunks, until you reach the bottom level of the hierarchy.



	
 

Component

 


	
Requirement

 


	
Occurrence

 





	
Glossary

 


	
Optional

 


	
1

 





	
Title

 


	
Mandatory

 


	
1

 





	
GlossEntry

 


	
Mandatory

 


	
1 or more

 





	
Term

 


	
Mandatory

 


	
 





	
<TEXT>

 


	
 


	
 





	
Definition

 


	
Mandatory

 


	
1 or more

 





	
<TEXT>

 


	
 


	
 





	
CrossRef

 


	
Optional

 


	
1 or more

 






You must do a content analysis for every document type you want to create in your structured environment. Once you have developed a content model for each document, you can look for opportunities to refine the model and reuse names. For example, suppose that a Help deliverable consists of topics and the chapters in a book also consist of topics. If you create a Topic element that is usable for both printed and online materials, you can minimize the number of elements in your structure definition and perhaps reuse information in both output formats.



	
 

Printed Topic

 


	
Online Topic

 


	
Combined Topic

 





	
Topic

 


	
Topic

 


	
Topic

 





	
Title

 


	
Title

 


	
Title

 





	
Para

 


	
Para

 


	
Para

 





	
Steps

 


	
Steps

 


	
Steps

 





	
Can contain Para, List, Table, Graphic, Note

 


	
Can contain Para, List, Table

 


	
Can contain Para, List, Table, Graphic, Note

 





	
 


	
RelatedTopics

 


	
RelatedTopics

 






It’s unlikely that your documents are perfectly consistent. You need to decide whether to create a structure that is loose (allowing many variations) or strict (very few variations are permitted). You will have problems at both ends of the spectrum:

•                

A very loose structure is quite complex, and can be difficult to maintain because so many variations are permitted.

 

•               A very strict structure may disallow element combinations that are needed.

 

It’s very difficult to find the right balance between these two extremes. One approach is to allow variations only where they add value.

note:  A similar problem occurs when creating unstructured FrameMaker templates. You want to minimize the number of tags that must be maintained while providing all of the tags that are needed to create your content.

Once the analysis is complete, you can decide whether to use an existing struc­ture or to build your own. Numerous XML implementations are available; DocBook and the Darwin Information Typing Architecture (DITA) are specifi­cations used for technical documentation. Standard structures are also defined for military documents (mil-specs or mil-standards), aircraft maintenance manuals, and others. The following table describes some of the factors that influence whether you will use a standard specification or build your own struc­ture.



	
 

Use a standard

 


	
Build your own

 





	
You are required to deliver content that follows the standard. For example, many U.S. military contractors are required to deliver documentation that follows a published standard

 


	
You want to create a structure that matches your content analysis precisely.

 





	
Your content requirements closely match an existing structure. You only need to make minimal changes to the standard structure.

 


	
Your content analysis indicates that your information does not match existing structures very well.

 





	
You do not want to spend a significant amount of time building a structure, and you are willing to change the organization of your content to fit it into an existing structure.

 


	
The structure needs to match the content precisely.

A longer implementation period is an acceptable cost to ensure you can build exactly what you need

 





	
You do not have the technical expertise or resources available to build your own structure.

 


	
You have resources available, whether in-house or as consultants, who can build the structure.

 






11.2.7.            Building structure files

Decide whether to use an existing standard or create your own structure.

 

Create structure files without using an existing standard

 

1)           In FrameMaker, create an EDD that matches your structure requirements.

 

2)           Test the EDD to verify that the structure definitions are correct.

 

3)           Add formatting to the EDD, and test the EDD to verify that the formatting works correctly.

 

4)           Create a DTD from the EDD.

 

You now have the two structure definition files you need—one for FrameMaker (EDD) and one for XML (DTD).

 

Use an existing standard

 

1)           Obtain a copy of the standard files, and modify the provided DTD or schema file to match your requirements.

 

2)           Open the completed structure file in FrameMaker to create an EDD, and add formatting to the EDD.

 

note:  FrameMaker includes several variations of DocBook as sample struc­tured applications. If you plan to create DocBook-based structure, consider modifying one of the provided applications.

 

Once you have your structure definitions, you need to set up the structured application.

 

Set up the structured application

 

1)           Open the structapps.fm file (select StructureTools > Edit Application Definitions).

 

2)           Add a new application definition to the file with pointers to your EDD and DTD/schema files.

 

After setting up the application, you’ll want to fine-tune the import/export settings.

 

Using the Structured Application Designer

 

The Structured Application Designer allows you to create a structured applica­tion using a graphical wizard.

To launch the structured application designer, click StructureTools > Struc­tured Application Designer. The Structured Application Designer is displayed as follows:

Structured Application Designer

[image: sa_struct_appln_designer.png]

 

1)           Select a base application on which the new application is based. To load a new set of base applications, click Load Applications... and select the rele­vant structured application file. The list of applications is automatically populated from the selected structured application file.

 

2)           Optionally, enter the DTD, the Read Write Rule file, the EDD, and the template files, along with any document type specifications.

 

3)           Enter the name for the new application.

 

4)           By default, the application is saved in the structapps.fm file in your application directory. To change the filename, click Save As and select or enter a new filename.

 

5)           Optionally, to set advanced settings, click Advanced Settings... and make your desired selections.

To create a Read Write Rule file, based on an existing DTD, specify the DTD and click New from the RW Rules section. The Read Write Rule File Maker is then displayed.note:  If you do not specify a DTD, an empty Read Write Rule File is created. You can then add rules using the Read Write Rule File Maker. 

•               To update an existing Read Write Rule file, select the file and click Update. Make your changes in the Read Write Rule File Maker.

 

•               To generate a new EDD, select the DTD and click new from the EDD section. All elements are loaded in the EDD interface. From the EDD interface, you can select Element Paragraph Format Tags for every element.

 

•               Click Import Format settings to import format settings from another EDD.

 

•               Click Save to save your changes or Reset to roll back to the last saved state.

 

•               To update an EDD, select the EDD and click Update.

 

•               To generate a new template, select the corresponding EDD file and click New from the Template section.

 

Fine-tune the import/export settings

 

1)           Set up a read/write rules file with the necessary mappings, and set up XSL transformation files with any additional changes.

 

2)           Add a reference in the structured application definition to the read/write rules file and the XSL transformation files.

 

3)           Add any other required configuration settings, such as handling of condi­tional text and external cross-references, in the structured application definition.

 

Using the Read Write Rule File Maker

 

FrameMaker includes a powerful Read Write Rule File Maker that helps you author rules easily. This helps simplify rule generation, since you have all the settings at one place, and do not have to remember any rule syntax.

 

To launch the Read Write Rule File Maker, click StructureTools > New Read/Write Rules. Select the Launch Rule File Maker option and click OK.note:  Optionally, you can specify the DTD to be used when creating the rules.

The Rule File Maker is displayed as follows:

 

Rule File Maker

[image: sa_rule_file_maker.png]

 

The Rule File Maker has two basic sections:

•                

Import-Export Settings: These settings are applicable for the reading and writing operation.

 

•               Export-Only Settings: These settings are not covered in the Import - Export Settings and are only applicable for the writing operation.

 

The Import-Export Settings section is divided into four sections:

1)            

Markup Elements: Allows editing of all markups present in the specified DTD. To see a list of all elements, select ‘select from DTD’ from the value drop-down. FrameMaker, then displays a list of elements. You can select multiple elements from the list and click OK to insert the selected elements into the Read Write Rule File Maker.

 

2)           Global Settings: Displays the list of settings that are applied to ALL elements globally.

 

3)           Entities: Displays the list of all entities that are present in the DTD.

 

4)           Advanced Settings: Contains advanced settings for Books and Character Maps.

 

The Export Only Settings section is divided into three sections:

1)            

FM Objects: Lists the type of FM Objects present. In addition, each FM Object category lists the markups mapped as that object. For example, if you map markup M1 to the Table FM Object in the Import-Export Settings section, the Table list in the Export Only Settings section displays the markup M1.

2)           Global Settings: Displays the list of settings that are applied to ALL elements globally.

 

3)           Advanced Settings: Contains advanced settings for SGML, DITA, Vari­ables, and Character Maps.

 

When saving the rules, FrameMaker saves only the elements and the rules that have been modified (modified elements have their values marked in bold, on the right pane). Default behaviors are not saved.

 

11.3.             Converting unstructured files to structured documents

 FrameMaker provides a mapping feature to help you transfer your unstruc­tured documents into structure. Your results depend on the following factors:

•                

Document consistency. Documents that implement a formatting template consistently, with few or no formatting overrides, will convert better than documents that are full of overrides and custom paragraph or character tags.

 

•               Similarity between unstructured and structured documents. A new docu­ment structure that is similar to the organization in the unstructured documents eases the conversion process.

 

11.3.1.            Conversion workflow

The conversion process creates structured elements from FrameMaker format­ting components, such as paragraph tags, character tags, markers, cross-refer­ences, and table components.

To begin the conversion process, select an unstructured document that is repre­sentative of your typical content. Ideally, this document should contain exam­ples of all of the formatting tags that would occur in your documents. These tags should be shown in logical sequences (as they would occur in documents), so a formatting template that shows examples of each paragraph tag in alphabetical order is not a good example document.

1)            

Open the example document.

 

2)           Import element definitions from the EDD into the example document.

 

3)           Select StructureTools > Generate Conversion Table. Select Generate New Conversion Table, then click Generate.

 

FrameMaker scans the document and creates a list of the formatting components that occur in this document. Tags that are defined in the formatting catalogs but not used in the document are not included in the list.

 

note:  FrameMaker assumes that the name of the formatting component will be the same as the name of the structure element.

 

4)           Modify the mapping rules to match the structure. For example, FrameMaker assumes that the formatting tag names match the element names, so in the preceding example, the Body paragraph (P:Body) is mapped to the Body element. To change this mapping, change the second column (“In this element”) to read Para instead of Body.

 

5)           Once you have mapped all of the formatting components, add additional entries to the table to create hierarchy. For example, if a Section element typically contains a Heading and one or more Para elements, you add a row to the table and specify how to create the Section element.

 

6)           Add a root element mapping that specifies the top-level tag in the docu­ment, as shown here:

 

  RE:RootElement                                    Proposal

 

7)           Save the conversion rules table.

 

8)           To test the conversion rules table, open your example document, then select StructureTools > Utilities > Structure Current Document. Select the conversion rules table document in the pop-up menu, and then click Add Structure.

FrameMaker creates a new, untitled, structured document. Keep refining and testing your conversion rules until you are satisfied with the docu­ment produced. You can add tags to the conversion rules table by typing them or by scanning additional documents.

 

9)           To add tags automatically:

 

a)           Make sure that the conversion rules table is open. Open the file that contains additional formatting components.

 

b)           Select StructureTools > Generate Conversion Table. Select Update Conversion Table and select your conversion rules document in the pop-up menu.

 

c)           Click Generate. FrameMaker scans the second sample document and adds additional formatting components to the end of the conversion rules table.

 

11.3.2.            Conversion rule examples

The order in which conversion rules are listed is significant. You must go from lower-level elements to higher-level elements. For example, assume that you have the following mapping rules:

  G:                           Graphic
 P:caption                           Caption
 E:Graphic,E: Caption                           Figure

The rule in which Graphic and Caption are wrapped into a Figure element must occur after the rules in which Graphic and Caption are created.

If you need to map several paragraph tags to the same element and then wrap them into different parents, you use the third column for a qualifier. It’s common, for example, to have a ListItem element that’s used for both bulleted lists and numbered lists. Once the bullet and step paragraphs are wrapped in the ListItem element, you need a way to distinguish whether they belong in OrderedList or UnorderedList. To make this distinction, you use the qualifier column, as shown in the following example:

  bullet                           ListItem                        b
 step1                           ListItem                        st
 step2+                           ListItem                        st
 E:ListItem[b]+                           UnorderedList
 E:ListItem[st]+                           OrderedList

To specify the root element of a document, you use the following:

  RE:RootElement                           Chapter

You can only specify one root element per conversion table.

Graphics and tables are often anchored into the preceding paragraph in the unstructured document. When you structure the document, the Graphic and Table elements end up as children of the preceding Para element.

If you want the Graphic element to be converted as a sibling of Para (shown in the preceding figure on the right) rather than a child, use the “promote” command:

  G:                           Graphic(promote)

11.4.             XML with FrameMaker

 

11.4.1.            Create, open, and save XML files

 

Create an XML file

To create an XML file:

1)           Select New > XML from the File menu. The new XML dialog is displayed as follows:

New XML file creation dialog

[image: sa_new_XML_wizard.png]

 

2)           You can create an XML file, either from an existing template or using a structured application.

 

•               To create an XML file using a template, select the Template option, click Choose Template, and select the template.

 

•               To create an XML file using a structured application, select the Structured Application option, and select the structured application from the list.

note:  To load a different structured application file, click Load Appli­cations and select the structured application definition document. The list of applications is automatically populated from the definition document.

 

note:  Clicking New Structured Application... opens the structured application designer.

 

3)           Specify the path and filename to save the new XML file.

 

4)           Click OK to create the XML file.

 

Open an XML file

1)            

In Structured FrameMaker, choose File > Open.

2)           Select the file you want to open, and click Open.

 

3)           If the Use Structured Application dialog box appears, choose an applica­tion name from the Use Structured Application pop-up menu, and click Set. Then do one of the following:

 

•               To associate an application with the file, choose the name of an application.

 

•               To use default mapping and no read/write rules, choose <No Appli­cation>. (You may want to use this option to browse a file you don’t intend to save.)

 

The WebDAV feature is extended to allow authoring and editing of XML files located on the WebDAV server.

 

Save an XML file

•                

Select File > Save As XML. In the Save Document dialog box, click Save.

 

•               Select File > Save As. In the Save Document dialog box, select XML in the Save as type list, and click Save.

 

•               Select File > Workgroup > Save As. In the Save To Server dialog box, select XML in the Format list, and click Save.

 

FrameMaker saves the file in XML format and preserves the .xml extension.

Save a FrameMaker file as XML

1)            

In structured FrameMaker, select File > Save As XML.

 

2)           Select the folder in which to save the file.

 

3)           Specify a filename with an .xml extension.

 

4)           Choose XML (*.xml) from the Save As Type pop-up menu.

 

5)           Click Save.

 

View XML in Notepad

FrameMaker allows you to view an open XML file in Notepad or in any other text editor that you specify.

To view an XML file:

1)            

Open the XML file in FrameMaker.

 

2)           Click View > View in Notepad. FrameMaker opens the XML file in Notepad.

 

You can edit the TextEditorPlugin.ini file in the path %AppDate%/Adobe/FrameMaker/10 and set the following entries as desired:

•                

TextEditorName: Set this entry to the path of your chosen text editor. By default this entry is set to Notepad.

 

•               SaveFileBeforeOpening: By default this entry is set to No. When this entry is set to Yes, FrameMaker automatically saves the XML file before opening it in Notepad, ensuring that all your changes are in place.

 

11.4.2.            Handling conditional text and XML

  Structured FrameMaker allows you to export and import all conditional text (visible and hidden), along with information about the condition tags, such as their show/hide status, color, and style.

To preserve conditional text when saving and opening XML files, the XML file that FrameMaker generates contains the following:

•                

Conditional text tags corresponding to the conditional text present in the document.

 

•               Condition indicators—color and effect— associated with each conditional text tag.

 

•               The status—show or hide—for each condition tag.

 

•               Start and end markers for sections corresponding to each tag.

 

In addition to normal text, support for conditional text in XML allows an entire table or table rows to be conditional. The same applies to footnotes, markers, and anchored graphics. Also, conditional text can be inside a text inset (XML or text).

11.4.3.            Handling Whitespace in XML

If the imported XML file contains multiple whitespaces, by default, FrameMaker retains the first whitespace and drops the rest. The following are the whitespaces that are dropped:

•                

Space

 

•               Tab

 

•               Blank line / New line (except hard return)

 

For example, if the imported XML contains:

•                

[SPACE][SPACE][SPACE], FrameMaker converts it to a single [SPACE]

 

•               [TAB][TAB][TAB], FrameMaker converts it to a single [TAB]

 

•               [TAB][SPACE][SPACE], FrameMaker converts it to a single [TAB].

 

Disable dropping whitespaces on import

To disable dropping whitespaces, set the property RemoveExtraWhiteSpacesOnXMLImport in maker.ini to FALSE. note:  Use caution while editing an ini file. 

Preserve whitespaces for specific elements

If the xml:space attribute is set to preserve (xml:space=”preserve”), then FrameMaker preserves all whitespaces on XML import. You can use this setting to preserve whitespaces for certain elements alone and let FrameMaker drop whitespaces for all other elements.

For example, consider the code:

<poem>
<version1 xml:space="default">
<line>Jack[SPACE][SPACE][SPACE]and Jill</line>
<line>Went[TAB][SPACE]up the hill.</line>
</version1>
<version2 xml:space="preserve">
<line>Roses[SPACE][SPACE][SPACE]are red</line>
<line>Violets[TAB][SPACE]are blue.</line>
</version2>
<version3>
<line>Hickory[SPACE][TAB]dikory dock</line>
<line>The mouse[TAB][TAB]ran up the clock.</line>
</version3>
</poem>

 

For version1, the xml:space is set to default. FrameMaker uses the default behavior and drops whitespaces. The output of version1 is as follows:

 

Jack[SPACE]and Jill
Went[TAB]up the hill.

 

For version2, the xml:space is set to preserve. FrameMaker preserves all the whitespaces. The output of version2 is as follows:

Roses[SPACE][SPACE][SPACE]are red
Violets[TAB][SPACE]are blue.

For version3, FrameMaker uses the default behavior as no xml:space attribute is set. FrameMaker drops the whitespaces. The output of version3 is as follows:

Hickory[SPACE]dikory dock
The mouse[TAB]ran up the clock.

 

11.4.4.            Handling cross-references in XML

  Structured FrameMaker allows you to generate and retain external cross-refer­ences when saving and opening XML files.

For example, if your FrameMaker file contains a cross-reference to another file, when you save your file in XML, FrameMaker generates tags representing the cross-reference along with information about the referenced file. When opening the same XML file, FrameMaker converts the cross-reference tags and the information they contain into a FrameMaker cross-reference.

FrameMaker supports a new attribute, srcfile, to retain external cross-refer­ence information when generating XML documents.

When you export a file containing an external cross-reference to XML, the srcfile attribute of the cross-reference contains the name of the referenced file and the ID of the referenced element in the file.

note:  FrameMaker converts file paths in the generated XML to URIs.

11.4.5.            Using the configuration file editor

Every structured application may include an XML configuration file. The configuration file is optional and contains attributes and their suggested and default values. To call the editor, click Element > Launch Config File Maker... The configuration editor is displayed as follows:

Configuration file editor

[image: sa_xml_config_editor.png]

 

•               To load an existing configuration file, click Load Configuration File and select the file.

 

•               Set the configuration values as desired. Click the value column of the choice or default to be changed and enter the new value.

 

•               To insert a new choice, right click the row above which the choice is to be placed, and select Insert Above.

 

•               To delete a choice, right click the choice and select Delete.

 

•               To save the configuration, click Save.

 

•               To save the configuration as a new configuration file, click Save As and enter the new filename.

 

When opening a structured application, FrameMaker reads the corresponding configuration file (if it exists) and populates the attribute values automatically.

The attribute editor allows you to change these values, when using the struc­tured application.

11.4.6.            Using the attribute editor

FrameMaker includes a powerful attribute editor that helps you to edit element attributes easily. To load the editor, click Element > Edit Attributes.... The attri­bute editor is displayed as follows:

Attribute editor

[image: sa_xml_attrib_editor.png]

The editor reads the attributes from the configuration file supplied when creating a structured application.

 

•               To view just the attributes that are required and specified, click the Required and Specified option.

 

•               To set a value, click the value column of the selected attribute. Enter the value. The value is set automatically.

 

•               To delete a value, click the value of the selected attribute and press Delete.

 

•               To delete all user set values, click Reset All.

 

•               To restore all values to the defaults specified in the config file, click Restore Defaults.

 

11.4.7.            Options for processing XML

  FrameMaker provides options for processing XML. FrameMaker also allows XML import and export to support XSL transformations (see XML with XSL transformation), and the Schema language for grammar and rule definition (see XML with schema). You can import an XML document that uses schema, auto­matically creating a Document Type Definition (DTD) from the referenced schema, or you can create an Element Definition Document (EDD) directly from a schema definition. This release also enables validation against an associ­ated schema upon both import and export.

11.4.8.            XML with XSL transformation

  XSL (EXtensible Stylesheet Language) is a style sheet language for XML docu­ments. XSLT (Extensible Stylesheet Language Transformation) is the means by which transformations defined in XSL are applied to XML documents.

XSL is a set of the following three specifications:

XSLT

 

A language for transforming XML documents.

XPath

 

A language for navigating in XML documents.

 

XSL-FO

 

A language for formatting XML documents.

 

FrameMaker includes an XSLT processor that allows you to associate an XSLT file with an XML structure application or XML document, and apply the trans­formations defined in that document when importing from or exporting to XML. FrameMaker supports W3C XSLT 1.0 recommendations.

•                

New elements in the structure application (XSLTPreferences in the stylesheets element of XMLApplication) allow you to specify an XSLT file as part of your XML structure application, to be used for both import and export.

•               The xml-stylesheet processing instruction (PI) now allows you to specify an XSL file in an XML markup document, which supersedes any XSLT specified in the structure application when importing that docu­ment.

Upon import, XSL transformations are applied before the default read rules or any additional read rules you have defined. That is, the result of applying an XSL transformation on import is a new file, which (if it is an XML file) is passed to the read/write rules.

Upon export, XSL transformations are applied after the default or explicit write rules. The result of applying read/write rules on export is a new XML file, which, if it is valid, is passed to the XSLT processor.

11.4.9.            XML with Cascading Style Sheets

     When an XML document is opened in FrameMaker, FrameMaker processes CSS2 by mapping the CSS information to appropriate EDD rules in the EDD document.

The following scenarios describe the processing of CSS2 in FrameMaker:

•                

You open an EDD in FrameMaker and use the Import CSS Styles option in the StructureTools menu. FrameMaker checks whether the current document is an EDD. If so, the Open dialog box appears and you can specify the CSS file path. The CSS is then imported into the EDD. You can then import the element definitions from the EDD into a template to use when you open an XML file. If the EDD contains formatting rules, the CSS properties are appended to the existing rules if the properties are unique. Alternatively, the CSS properties you import will overwrite the existing formatting rules of the EDD. You can also export XML style information to an EDD for all elements in a document that use the Cascading Style Sheets 2 (CSS2) format, using the Generate CSS2 option in the Structure­Tools menu.

 

•               When you open an XML file that is associated (using xml-style sheet PI) with style sheets, FrameMaker reads the DTD and the style sheet associ­ated with the XML document, and then generates a temporary template to use for opening the XML file. However, if a template is already specified in the “Structured Application” (used to open the XML file), FrameMaker uses that template to open the XML file and will not generate any new template from the DTD and style sheets.

 

note:  An XML file opened in FrameMaker can contain multiple CSS files. FrameMaker supports the author’s style sheet only, and not the user’s style sheet.

Import CSS element styles into an EDD file

   You can import element formatting from CSS into EDD to ensure consistent formatting across different XML applications. The CSS file can be referenced in the XML document or manually imported. Multiple CSS files can be imported sequentially for multi-level formatting.

When importing element styles, FrameMaker retains the context information (element property or selector) from the CSS and imports it into the appropriate EDD contexts.

note:  FrameMaker imports style information only at the element level.

You can also set CSS preferences in XML using Structured FrameMaker. For more information, see the Structured FrameMaker Developer's Guide, located in the Documents folder.

1)            

Open the EDD file in structured FrameMaker.

 

2)           Select StructureTools > Import CSS Styles. The Import CSS dialog box appears.

 

3)           Select a CSS file, and click Open.

 

4)           If the Structured Application element in the EDD file doesn’t define an application name, the Use Structured Application dialog box appears. Select the application that was used to create the EDD file. Click Continue.

The CSS file is imported into the EDD file.

note:  If the EDD already contains formatting rules, the CSS properties are appended to the existing rules. If the CSS properties overlap some of the existing rules, the CSS properties replace the existing rules in the EDD. The EDD doesn’t support all properties and selectors defined in CSS 2.0. If a property or selector in the CSS file can’t be mapped to an equivalent EDD rule, that property or selector is ignored. No error is displayed when this happens, and no error log is created.

After importing the CSS styles, you can import element definitions from the EDD into a template and use the template to open an XML file.

As an alternative to the CSS import process, you can use FrameMaker to open an XML file that already has CSS styles associated with it. When you open the XML file, FrameMaker reads the DTD and CSS files and generates a temporary template that is used to open the XML file.

Export CSS for a FrameMaker XML file

You can export XML style information available in your document for all elements using the Cascading Style Sheets 2 (CSS2) format, to an EDD file. You can then import these CSS Style definitions from the EDD file to new XML files. Cascading Style Sheets let authors attach styles, such as fonts and spacing, to structured XML files. CSS2 format is a W3C standard.

When you choose the Generate CSS2 command, styles from well-formed struc­tured documents are generated, based on the formatting information available in the EDD associated with the source document. FrameMaker exports style information only at the element level. For example, if you apply a style to only one particular word in the Text element, that one instance of style is not exported.

You can set CSS 2 preferences in the XML application. For example, you can determine whether the CSS 2 file is automatically generated when you export to XML. For more information, see the online manual, Developing Structured Applications with Adobe FrameMaker on the Adobe website, www.adobe.com/go/lr_FrameMaker_support_en.

1)            

Open the template or document with an associated EDD in Structured FrameMaker.

 

2)           Select StructureTools > Generate CSS2.

 

11.4.10.       XML with schema

  FrameMaker allows you to import XML markup documents that are associated with W3C's XML Schema language. FrameMaker automatically creates a DTD and EDD from the schema. FrameMaker validates the document structure against the associated schema upon both import and export to XML, but does not retain all schema information upon export.

For complete details of how schema is mapped to DTD, see the Structure Appli­cation Developer’s Guide.

note:  This release offers support for schema that is equivalent to what was previ­ously available for DTD. That is, EDD has not been extended to accommodate features in schema that are not available in DTD. For this reason, schemas are read-only, and you cannot export the EDD back out to schema.

Schema workflow

You can import an XML document that references a schema file, and you can specify a schema file in your structure application, to use for validating a docu­ment upon export to XML.

1)           For a specific XML document, you can include the path of the schema file in the XML using attributes - noNamespaceSchemaLocation or schemaLocation depending on whether your schema includes a target namespace or not.

 

2)           To specify a schema file for use in exporting XML, modify the structapps.fm file. Use the Schema element as part of the XMLApplication to provide the schema file path for export.

 

3)           Open the XML in Frame using a structured application. Edit it.

 

4)           Save the XML using a structured application. The Schema element in the structapps.fm file is output in the file and validation is performed against it.

 

In this workflow, a DTD is generated automatically as an intermediary file from the schema given in the XML document, and you do not modify it. However, you can also use a schema file to generate an EDD; see Generate an element catalog (EDD) from a schema.

Changes to the structure application for schema support

The new element Schema, a child of the XmlApplication element, speci­fies the path of a schema file in the structapps.fm structure application file. If instance documents use namespaces, the property Namespace in XmlApplication must be set to true.

In order for a structure application to be selectable in the Use Structured Appli­cation list while importing a document that is associated with a schema, the schema’s root element must be included in the application’s DOCTYPE in the XmlApplication element.

Generate an element catalog (EDD) from a schema

You can create an EDD from a schema definition, or import the elements from a schema definition into an existing EDD. FrameMaker converts the schema definition to DTD first, and then creates or imports elements to an EDD.

Use the following commands in the StructureTools menu:

•                

Open schema: This command converts a specified schema to DTD, and creates an EDD from the DTD.

•               Import schema: This command converts a specified schema to DTD, and imports elements from the DTD into an existing EDD.

 

Each command opens a File Choose dialog box that allows you to specify the schema file, then a Save dialog box in which you specify where to save the resulting DTD file.

1)           In Structured FrameMaker, select StructureTools > Open Schema.

 

2)           Choose a schema file.

 

3)           Choose a path for the DTD to be output.

 

4)           Examine the resulting DTD and make any modification you want.

 

5)           Create an EDD from the generated DTD, as described in the Structure Application Developer’s Guide.

6)           Use this EDD to create a template that can be included in the Structured Application.

7)           Provide your DTD path along with the Schema Location in the input XML. This will make sure that FrameMaker works correctly with your template. Validation of input and output XML is still performed against the schema.

 

View or edit XML namespaces

An XML namespace is a collection of names for specific element types and attri­bute names within an XML document. The scope of a namespace extends beyond its containing document.

Because a single XML document can contain elements and attributes that can be used by multiple software applications, you can use namespaces to differen­tiate which elements and attributes are to be used by which applications. Soft­ware applications that process XML use namespaces to recognize which tags and attributes they are designed to process.

Names from XML namespaces may appear as qualified names, which contain a single colon, separating the name into a namespace prefix and a local part. The prefix, which is mapped to a Uniform Resource Identifier (URI) reference, selects a namespace. The combination of the universally managed URI name­space and the document's own namespace produces identifiers that are univer­sally unique.

 

Using XML namespaces in FrameMaker

 

FrameMaker supports namespace usage for all elements in an XML document. When you import an XML document containing namespaces, all namespace information is preserved.

You can view, edit, add, or delete namespaces to an XML document in Struc­tured FrameMaker using the Namespaces command. You can also use this command to view the definition of the prefix on an element tag and select the element that defines the prefix.

 

By default, namespaces in FrameMaker are handled as namespaces, appearing in the Namespaces dialog box. However, you can disable namespaces in the application and have them handled as attributes instead, appearing in the Struc­ture View.

 

1)           Open the document in Structured FrameMaker.

 

2)           Select an element in the Structure View.

 

note:  Elements that contain namespaces appear in Structure View with an asterisk (*) next to their names.

 

3)           Choose Element > Namespaces.

 

4)           In the Namespaces dialog box, click Select Defining Element to view the namespace for the selected element in the Structure View.

 

5)           Make any desired changes to the Declared Namespaces, Prefix, or Path and then click Add, Change, or Delete. To close without saving your changes, close the dialog box without clicking an option.

 

11.5.             New XML dialog

To display the New XML dialog, select File > New > XML. FrameMaker has the New XML dialog that allows you to create:

1)            

DITA

 

2)           S1000D

 

3)           XML content based on other Structured Applications set up in FrameMaker

 

4)           Blank XML document

 

The New XML dialog also maintains a history of the recent XML files you worked with and allows you to open these files quickly.

11.5.1.            Create an XML document

1)            

In the New XML dialog, select one of the following:

 

a)           Structured Applications: Displays the structured applications set up on FrameMaker that can create new XML topics, including the DITA topics and S1000D modules

 

b)           DITA: Displays the available DITA templates

 

c)           S1000D: Displays the available S1000D modules

 

2)           Select one of the displayed modules/topics and click OK.

3)           If you are creating a DITA topic, specify the name in the New DITA topic dialog and click Save.

New XML dialog

[image: xg_XML_new.png]

11.5.2.            Create a blank XML document

1)            

In the New XML dialog, select XML Document.

 

2)           Select Empty XML Document and click OK.

 

Create an empty XML document

[image: xg_XML_empty.png]

11.5.3.            Create a blank XML document based on a DTD

1)            

In the New XML dialog, select XML Document.

 

2)           Select DTD-based XML Document and click OK.

 

3)           In the Customize XML dialog, specify the following and click OK:

 

a)           Public ID

 

b)           System ID

 

c)           DTD

 

d)           Root element

 

FrameMaker creates a document based on the specified DTD.

11.6.             Error console

While opening a document, the new FrameMaker error console displays struc­tural and other issues in a document, if any. This console also provides the following information about document issues:

•                

Exact location of the issue within the document

 

•               Name of invalid elements, if any

 

Error console displaying error details

[image: error_console.png]

 

11.7.             Filter By Attribute

 

11.7.1.            About Filter By Attribute

Elements in a structured document can have one or more attributes associated with them. Using FrameMaker, you can filter a structured document based on the value of these attributes. Other XML applications may also use the same attribute-value pair to filter the documents. In this way, single sourcing work­flows can be preserved across other XML applications.

The Filter by Attribute feature simplifies the task of filtering a structured docu­ment for complex output scenarios. You define a filter using a Boolean expres­sion containing attribute-value pairs. You can create multiple filters, save them, and use them for filtering a document based on different output scenarios.

When a filter is applied to the document, elements that have filter attributes that do not meet the filter criteria are filtered out. You can specify how the filtered out content is treated, as hidden, highlighted with a color, or applied with a condition tag. When an element is filtered out, all the child elements are also filtered out.

Each attribute can have more than one value defined, each with its own condi­tions, such as Equals To, Any, and Contains Only. You can provide a list of values with the delimiter that you defined for attribute settings.

note:  You cannot filter a document based on Conditional Tags and Attribute values simultaneously.

The following table compares the Show/Hide feature using Conditional Text and the Show/Hide feature using Filter By Attribute.



	
 

Conditional Text

 


	
Filter By Attribute

 





	
Based on conditional tags

 


	
Based on attributes

 





	
Must be defined in a document

 


	
Exists in a structured document

 





	
Condition indicators are available to visually display the content, based on various conditions

 


	
No indicators

 





	
Only one expression can be saved at a time

 


	
Multiple expressions can be saved at a time

 





	
Available in both structured and unstructured FrameMaker

 


	
Available in structured FrameMaker only

 

(unstructured documents do not have elements and attributes)

 





	
Allows hiding an entire document, resulting in an empty-content document

 


	
Does not allow the hiding of the entire document, as it does not allow hiding of the root element

 





	
Allows selection of even the smallest portion of a document for hiding

 


	
The smallest unit that can be hidden using this feature is an element.

 





	
Each condition tag has two options to choose from: SHOW or HIDE

 


	
Allows better level of granularity in terms of creating a hide condition, because an attribute can have several values (based on its definition). Hence, each attribute value has a separate SHOW or HIDE possibility.

 






note:  The conditional indicators are disabled when a filter is used. It can be enabled only when no filter is applied to the document.

11.7.2.            Build a filter

A filter is defined by a Boolean expression of attribute-value pairs. You can build a filter using the Build Expression dialog box, which provides a simple interface to build the expression using Boolean operators. You can define attri­bute-value pairs using the Define Attribute Values dialog box. You can select multiple values for each attribute.

You can save a filter as a named expression. You can build and save multiple filter expressions in a structured document. However, you can apply only one filter at a time. The last filter you apply in a document is the active filter.

Use the Manage Attribute Expressions dialog box to manage the filters.

1)            

Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.

 

2)           Click New. The Build Expression dialog box appears.

 

3)           Enter a unique name for the filter in the Expression Tag field.

 

4)           Select an attribute from the Attributes list.

 

5)           Specify a value in the New Value field, and click Add. The new attribute value is included in the Defined Values list.

If you want to remove a value, select it in the Defined Values list, and then click Delete. You can add multiple values to an attribute, each with its own conditions such as Equals To, Any, or Contains Only.

 

note:  Attribute names are case-sensitive, but attribute values are not case sensitive.

 

6)           Click Add Attribute to include the attribute in the Expression list.

 

note:  Use the Clear button to delete all expressions in the Expression area.

7)           Click a button to insert a Boolean operator in the expression. You can build a complex expression through the Boolean operators and multiple attribute-value pairs. Click Clear to clear the expressions built.

 

8)           Click OK to close the Build Expressions dialog box. The new expression is added to the Manage Attribute Expression dialog box. Click OK to complete the procedure.

 

Guidelines for building a filter

Keep in mind the following points when building a filter:

•                

Ensure that you enter valid attributes in the filter. All valid attributes are listed in the Attributes list of the Build Expression dialog box.

 

•               Ensure that when you supply more than one value to the attribute, you are using the custom delimiter that you defined for attribute in the attribute Configuration File Settings.

•               Enclose the value of the attribute in double quotation marks.

 

Correct: (Language=“French” OR Language=“German” OR Language=“Japanese”) 

Incorrect: (Language=French OR Language=German OR Language=Japanese) 

note:  FrameMaker doesn’t support expressions where the attribute value is missing. For example, “(Language=“”)” is not supported in an expression.

 

•               By default FrameMaker encloses all attribute-value pairs within paren­theses. All attribute-value pairs for a specific attribute are placed within the same pair of parentheses. To place the attribute-value pairs for a specific attribute in different pairs of parentheses, build the expressions for each value separately.

 

Correct: (Language=“French” OR Language=“German” OR Language=“Japanese”) 

Correct: (Language=“French” OR Language=“German” OR Language=“Japanese”) AND (Version=“1.0”) 

Correct: (Language=“French” OR Language=“German”) AND (Language=“Japanese”) 

Incorrect: Language=“French” OR Language=“German” OR Language=“Japanese”

•               Only use the OR operator between attribute-value pairs for an attribute. Do not use the AND operator.

 

Correct: (Language=“French” OR Language=“German” OR Language=“Japanese”) AND (Version=“1.0” OR Version=“2.0”) 

Incorrect: (Language=“French” OR Language=“German” AND Language=“Japanese”) AND (Version=“1.0” OR Version=“2.0”) 

•               When the NOT operator is used, ensure that it is placed before the opening parenthesis of an attribute-value group.

 

Correct: NOT (Language=“French” OR Language=“German” OR Language=“Japanese”) AND (Version=“1.0” OR Version=“2.0”) 

Correct: (Language=“French” OR Language=“German” OR Language=“Japanese”) OR NOT (Platform=“Windows”) 

Incorrect: (NOT Language=“French” OR Language=“German” OR Language=“Japanese”) AND (Version=“1.0” OR Version=“2.0”) 

Incorrect: (Language=“French” OR Language=“German” OR Language=“Japanese”) OR (Platform=“Windows” NOT Platform=“UNIX”) 

•               If you have multiple attributes in a filter, insert the Boolean operator between two groups of attribute-value pairs.

 

Correct: (Language=“French” OR Language=“German”) AND (Platform=“Windows” OR Platform=“UNIX”) 

Incorrect: (Language=“French” OR Language=“German”) (Platform=“Windows” OR Platform=“UNIX”) 

Process a filter

FrameMaker generates customized output of a structured document after processing the filter you applied to the document.

Consider a scenario in which you want the following elements and attributes to be applied to the various paragraphs in a structured document.



	
 

Paragraph

 


	
Element

 


	
Attribute

 


	
Value assigned

 





	
Paragraph 1

 


	
TextContent1

 


	
Language

 


	
Japanese

 





	
Version

 


	
2.0

 





	
Platform

 


	
Windows

 





	
Paragraph 2

 


	
TextContent1

 


	
Language

 


	
Japanese

 





	
Version

 


	
2.0

 





	
Platform

 


	
UNIX

 





	
Paragraph 3

 


	
TextContent2

 


	
Language

 


	
Japanese

 





	
Version

 


	
2.0

 





	
Paragraph 4

 


	
TextContent2

 


	
Language

 


	
English

 





	
Version

 


	
1.0

 





	
Paragraph 5

 


	
SysReq

 


	
Platform


	
Windows

 





	
Paragraph 6

 


	
SysReq

 


	
Platform


	
UNIX

 





	
Paragraph 7

 


	
LegalContent

 


	
Copyright

 


	
Condensed

 






1)           Copy the Sample XML code, which is based on this scenario, to create an XML file with the elements, attributes, and attribute values (listed in the previous table).

2)           Open the XML file in FrameMaker. These elements, attributes, and attri­bute values appear in the Structure View window.

 

3)           Type text in the relevant elements.

 

For example, type Japanese text relevant to version 2.0 on Windows in the TextContent1 element.

4)           Create the following filter to generate a Japanese document for the Windows platform:

 

   (Language=“Japanese”) AND (Platform=“Windows”)

 

How FrameMaker processes a filter

 

FrameMaker matches each attribute-value pair in the filter with every element in the document. The result of matching the attribute-value pair with an element is indicated by one of the following values:

 

True:

 

The attribute in the filter is an attribute of the element being matched, and the value in the filter matches the value of the attribute of the element.

 

False:

 

The attribute in the filter is an attribute of the element being matched, but the value in the filter does not match the value of the attribute of the element.

 

Don’t-Care:

 

The attribute in the filter is not an attribute of the element being matched.

 

The following table demonstrates how the filter is processed:

 

   (Language=“Japanese”) AND (Platform=“Windows”)

 



	
Paragraph

 


	
Element

 


	
Attribute

 


	
Value assigned

 


	
Verification of element based on the filter


	
Result

 





	
Paragraph 1

 


	
TextContent1

 


	
Language

 


	
Japanese

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
True

 

True

 





	
Version

 


	
2.0

 





	
Platform

 


	
Windows

 





	
Paragraph 2

 


	
TextContent1

 


	
Language

 


	
Japanese

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
True

 

False

 





	
Version

 


	
2.0

 





	
Platform

 


	
UNIX

 





	
Paragraph 3

 


	
TextContent2

 


	
Language

 


	
Japanese

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
True

 

Don’t-Care

 





	
Version

 


	
2.0

 





	
Paragraph 4

 


	
TextContent2

 


	
Language

 


	
English

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
False

 

Don’t-Care

 





	
Version

 


	
1.0

 





	
Paragraph 5

 


	
SysReq

 


	
Platform

 


	
Windows

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
Don’t-Care

 





	
True

 





	
Paragraph 6

 


	
SysReq

 


	
Platform


	
UNIX

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
Don’t-Care

 

False

 





	
Paragraph 7

 


	
LegalContent

 


	
Copyright

 


	
Condensed

 


	
Is Language=Japanese?

 

Is Platform = Windows?

 


	
Don’t-Care

 

Don’t-Care

 






Based on the results of filter processing as listed in this table, and the rules used to process filters, FrameMaker computes the final value of the filter to determine whether to include or exclude elements from the output. The overall computation returns one of the following values:

 

True (or) Don’t-Care:

 

The element is included in the output.

 

False:

 

The element is excluded from the output.

 

The operator precedence that FrameMaker uses while processing filters is listed in the descending order of precedence:

 

a)           Parenthesis

 

b)           NOT

 

c)           AND

 

d)           OR

 

Additional filter processing in the example

 

For element TextContent1 in Paragraph 1, the filter is processed as follows:

 

1)           The attribute-value pair Language=“Japanese” evaluates to True and the attribute-value pair Platform=“Windows” evaluates to True.

 

2)           The result of computing the filter is True and True, and the final compu­tation of the element based on the rules is True. Hence, Paragraph 1 is included in the output.

 

The following table demonstrates how the entire document is filtered:

 



	
Paragraph

 


	
Element

 


	
Attribute-value pair matching against each element

 


	
Result based on the rules

 


	
Action

 





	
Paragraph 1

 


	
TextContent1

 


	
Is Language=Japanese?

 


	
True

 


	
True AND True=True

 


	
Include in output

 





	
 


	
 


	
Is Platform=Windows?

 


	
True

 


	
 


	
 





	
Paragraph 2

 


	
TextContent1

 


	
Is Language=Japanese?

 


	
True

 


	
True AND False=False

 


	
Exclude from output

 





	
 


	
 


	
Is Platform=Windows?

 


	
False

 


	
 


	
 





	
Paragraph 3

 


	
TextContent2

 


	
Is Language=Japanese?

 


	
True

 


	
True AND Don’t- Care=True

 


	
Include in output

 





	
 


	
 


	
Is Platform=Windows?

 


	
Don’t-Care

 


	
 


	
 





	
Paragraph 4

 


	
TextContent2

 


	
Is Language=Japanese?

 


	
False

 


	
False AND Don’t-Care=False

 


	
Exclude from output

 





	
 


	
 


	
Is Platform=Windows?

 


	
Don’t-Care

 


	
 


	
 





	
Paragraph 5

 


	
SysReq

 


	
Is Language=Japanese?

 


	
Don’t-Care

 


	
Don’t-Care AND True=True

 


	
Include in output

 





	
 


	
 


	
Is Platform=Windows?

 


	
True

 


	
 


	
 





	
Paragraph 6

 


	
SysReq

 


	
Is Language=Japanese?

 


	
Don’t-Care

 


	
Don’t-Care AND False=False

 


	
Exclude from output

 





	
 


	
 


	
Is Platform=Windows?

 


	
False

 


	
 


	
 





	
Paragraph 7

 


	
LegalContent

 


	
Is Language=Japanese?

 


	
Don’t-Care

 


	
Don’t-Care AND Don’t-Care=Don’t-Care

 


	
Include in output

 





	
 


	
 


	
Is Platform=Windows?

 


	
Don’t-Care

 


	
 


	
 






Paragraphs 1, 3, 5, and 7 are included in the output, based on the rules used to process filters.

note:  When an element is included in the output, the inclusion or exclusion of each of its child elements is determined by processing each child element. However, when a parent element does not satisfy the filter and is excluded from the output, its child element is also excluded from the output even if the child element satisfies the filter. In addition, FrameMaker does not process the root element while running the filter. Hence, the root element is always included in the output.

 

Rules used to process filters

The following table lists the rules that FrameMaker uses for processing filters.



	
 

Rule Description

 


	
Operator/Resultant Value

 





	
<Don't-care> OR <Don't-Care>

 


	
<Don't-Care>

 





	
<Don't-care> OR <True>

 


	
<True>

 





	
<Don't-care> OR <False>

 


	
<False>

 





	
<True> OR <Don't-care>

 


	
<True>

 





	
<False> OR <Don't-care>

 


	
<False>

 





	
<Don't-care> AND <Don't-Care>

 


	
<Don't-Care>

 





	
<Don't-care> AND <True>

 


	
<True>

 





	
<Don't-care> AND <False>

 


	
<False>

 





	
<True> AND <Don't-care>

 


	
<True>

 





	
<False> AND <Don't-care>

 


	
<False>

 





	
NOT <Don't-care>

 


	
<Don't-care>

 





	
<True> OR <True>

 


	
<True>

 





	
<False> OR <True>


	
<True>

 





	
<True> OR <False>

 


	
<True>

 





	
<False> OR <False>

 


	
<False>

 





	
<True> AND <True>

 


	
<True>

 





	
<False> AND <True>

 


	
<False>

 





	
<True> AND <False>

 


	
<False>

 





	
<False> AND <False>

 


	
<False>

 





	
NOT <True>


	
<False>

 





	
NOT <False>

 


	
<True>

 






Sample XML code

Copy the following code to a FrameMaker document, and then save it as an XML file.

      <?xml version="1.0" encoding="UTF-8" ?>
    <Doc>
       <Para>
          <TextContent1 Language="Japanese" Version="2.0" Platform="Windows">TextContent1
          with Language="Japanese" Version="2.0" Platform="Windows"</TextContent1>
          </Para>
       <Para>
          <TextContent1 Language="Japanese" Version="2.0" Platform="UNIX">TextContent1
      with Language="Japanese" Version="2.0" Platform="UNIX"</TextContent1>
          </Para>
       <Para>
          <TextContent2 Language="Japanese" Version="2.0">TextContent2 with
      Languaue="Japanese" Version="2.0"</TextContent2>
          </Para>
       <Para>
          <TextContent2 Language="English" Version="1.0">TextContent2with
      Language="English" Version="1.0"</TextContent2>
          </Para>
       <Para>
          <Sysreq Platform="Windows">Sysreq with Platform="Windows"</Sysreq>
          </Para>
       <Para>
          <Sysreq Platform="UNIX">Sysreq with Platform="UNIX"</Sysreq>
          </Para>
       <Para>
          <LegalContent Copyright="Condensed">LegalContent with
      Copyright="Condensed"</LegalContent>
          </Para>
       </Doc>

11.7.3.            Import filters

You can import the Filter By Attribute settings that you defined in a structured document to other structured documents. The properties of the filter include the following:

•                

Filter expressions. The filter expressions that you created in the source document.

 

•               Attribute values that are defined in the filter. Each attribute can be more than one values.

•               The Show Per Expression state. For example, if your source document has many filters defined, but when these filters are imported to target docu­ments, the first filter is chosen for Show Per Expression, the same settings are applied to the target documents.

 

When you import filters, the attribute values in the source documents are added to the attribute values in the target documents. If attributes in the target docu­ments already have some values, the imported values are appended to them. FrameMaker reports an error if the target documents do not have attributes present in the filter expressions in the source document.

1)            

On the document window, select File > Import > Formats.

 

2)           On the Import Settings dialog box, deselect all options, and then select Filter By Attribute.

 

3)           In the Import From Document pop-up menu, select the source document that is open.

 

4)           Click Import.

 

11.7.4.            Apply a filter

Use the following instructions to apply a filter you have created to your struc­tured document.

1)            

Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.

 

2)           Select Show As Per Expression to preview the elements that satisfy the filter when it is applied to the document.

 

note:  If you select the Show All option, then the active filter, if any, is disabled, and all elements in the document are available for viewing and editing in FrameMaker. Also, any conditional text that is hidden appears. You can’t undo the Show All operation.

 

3)           Select a filter in the list.

 

4)           In the Filtered Text option, select how the content that does not meet the filter conditions should be treated. You can choose from the following:

 

•               Hide the content that is filtered out

 

•               Preview the filtered out content with a specified color.

•               Apply a condition tag to the filtered out content. In addition, you can also remove any condition tag already applied to the filtered out content.

 

5)           Click Apply.

 

note:  You can’t undo the Apply command after applying a filter.

 

11.7.5.            Save a document after applying a filter

When you save a document as a FrameMaker or MIF file, all filters using attri­bute values, including the filter you have applied to the document, are saved. The attribute values you have defined for this feature are also saved.

note:  When you save a document in the XML format, all filters using attribute values, are saved. However, the attribute values you have defined for this feature aren’t saved.

11.7.6.            Modify a filter

Use the following steps to modify a filter:

1)            

Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.

 

2)           Select a filter from the list.

 

3)           Click Edit. The Build Expression dialog box appears.

 

4)           Modify the filter in the Expression area.

 

5)           Click OK to close the Build Expression dialog box.

 

The modified content of the filter appears in the Selected Expression area of the Manage Attribute Expressions dialog box.

11.7.7.            Delete a filter

Use the following steps to delete a filter:

1)            

Select Special > Filter By Attribute. The Manage Attribute Expressions dialog box appears.

 

2)           Select a filter in the list.

 

3)           Click Delete.

4)           If the filter you are deleting has been applied to the document, FrameMaker displays a message indicating that the selected expression is currently applied to the document. Click OK.

 

5)           Click OK to confirm the deletion.

 

6)           Click Done to close the Manage Attribute Expressions dialog box.

 

note:  When you delete an active filter in a document, all elements that were excluded by the filter are again made available for viewing, editing, or generating output.

11.7.8.            Disable applying condition tags to filtered content

You can disable the option of applying a condition tag to content filtered with a Filter By Attribute option.

1)            

Set ApplyAsCondition=Off in the maker.ini file.note:  Use caution when editing an ini file. 

11.8.             Banner text

Banner text in a FrameMaker file instructs you about what to enter in an element. Banner text is controlled using the BannerText element in the EDD. You can control the instructional text you want to display for each of the elements.

FrameMaker does not treat banner text as real content in the document. Banner text is included in FM and MIF output but is not included in XML output.

Operations, such as the following, are not relevant to banner text:

•                

Find/Replace text

 

•               Conditional Text

 

•               Spelling checker

 

•               Track changes

 

•               Copy and cut

 

•               Import PDF comments

 

The RedisplayBannerTextForemptyElements flag in maker.ini determines whether the banner text gets re-displayed after it is deleted once. If this flag is OFF, the banner text doesn't show up after deleting it or reopening the file after saving it. If the flag is ON, banner text always shows up for empty elements.

Banner text indicates what you should enter in various elements

[image: nf_BannerText.png]

11.8.1.            Display\hide banner text

Element banner text is visible in Author view and WYSIWYG view. Use the following command to display\hide banner text:

•                

Select View > Element Banner Text.

 

11.8.2.            Port content as banner text for elements

You can port additional content as banner text for elements in a file using the following steps:

1)            

Export the element catalog as an EDD from the template. FrameMaker creates an EDD with using the elements in the structured template.

 

note:  Locate the appropriate template from structapps.fm.

 

2)           In the EDD, locate the BannerText element for a container element and edit the text.

 

3)           Import the element definitions from the edited EDD to the file.

4)           Select StructuredTools > Read Application Definitions.

 

11.8.3.            Banner text settings in the maker.ini file

You can configure banner text using the following settings in the maker.ini file:



	
 

Property

 


	
Description

 





	
BannerTextFontFamily

 


	
Font family of banner text

 





	
BannerTextFontWeight

 


	
Font weight of the banner text

 





	
BannerTextFontAngle

 


	
Angle of the banner text,

 





	
BannerTextFontVariation

 


	
Any variation of the font width

 





	
BannerTextBKcolor

 


	
Banner text background color

 





	
RedisplayBannerTextForemptyElements

 


	
When set as On, the Banner text is displayed even when you close and reopen a file. When set as Off, if you close and reopen a file, the banner text in the file is not visible.

 






11.9.             XPath

You can use XPath syntax in the XML code view to search through XML files for nodes or node sets.

You can use the following in FrameMaker’s XML view to run an XPath query:

•                

XPath pod

 

•               XPath Toolbar

 

XPath pod

[image: sa_xpath_builder.png]

A.

Enter an XPath query

B.

Check to enable auto-suggest

C.

Select Axes

D.

Save an XPath query’s results

E.

Double-click a matching node of the query to open the file

F.

Select a recently run XPath query - History displays up to 15 of the last queries

G.

Select scope of the XPath search

 

[image: sa_xpath_toolbar.png]

 

A.

Enter XPath query

B.

Run

 

11.9.1.            Search for nodes/node-sets using the XPath toolbar

Use the XPath toolbar to search for XML nodes or node sets in the open XML files:

1)            

Enter an XPath query. For example, /task searches for task as a root node. //task searches for task element even if it is not a root node.

 

2)           Click Run.

 

FrameMaker searches through the file and displays the matching nodes /node sets in the XPath pod. Click the search results to view the matching node/node set.

 

11.9.2.            Search for nodes/node-sets using the XPath pod

Use the XPath pod when you want to search for XML nodes.

1)           Select View > Pods > XPath.

 

2)           In Query Builder, enter an XPath query.

 

You can use the standard XPath syntax to search for elements. History displays the last 15 queries.

3)           Select Enable Auto-Suggest for suggestions on your queries as you type them.

 

4)           To Add Axes to the Auto-suggest list, select Axes.

 

5)           Specify the scope of searching:

 

a)           Current File: Search the specified xml node in the current file only.

 

b)           All Open Files: Search across all the open XML files for the specified node and displays the results.

 

c)           Folder: FrameMaker lets you select a folder in which the search is performed for the specified node/node set.

6)           Click Run.

 

FrameMaker searches through the file according to the specified scope and returns the matching nodes /node sets. Click a search results to view the matching node/node set in the XML file. Double-click a result to open the relevant file in FrameMaker.

 

7)           To save the results of your query, click

[image: frm_XPathSave.png]

and specify the name of the XML file. You can save the results of an XPath query in an XML file.

 




12.                Structured Authoring Using DITA

 

12.1.             Why DITA

DITA changes the way content is created, stored, managed, and consumed. It also changes the tools that are used and the way authors have to think about content.

 

12.1.1.            Content reuse and modularity

 

You can reuse content not just for print and the web but also for multiple custom outputs. Reuse at a heading or line level can be chaotic and challenging to implement and manage, especially at an enterprise-wide level. DITA facili­tates reusability at a more manageable content level: the topic. A topic is the smallest chunk of information that can stand alone as meaningful information. Topics are then assembled into documents using DITA maps, which are hierar­chical lists of pointers or links to topics. These pointers are called <topicref> elements.

Topics can also be reused in other topics. Each topic is assigned a unique ID. From a topic, you can include a content reference (conref) to another topic using its unique ID. At a finer level of granularity, you can also assign property tags to individual topic elements for conditional assembly.

12.1.2.            Multichannel publishing

 

Modular topics allow for dynamic assembly of content at any level of granu­larity. You can create multiple documents from reusable topics. Assembly can be conditional, dependent on properties or metadata tags that you attach to a topic. For example, the audience property can be <beginner> or <advanced>, and the platform property <Windows> or <Solaris>.

12.1.3.            Ease of authoring and publishing

 

By segregating content from presentation, DITA allows you to reuse modular topics. You can reuse a topic by specifying it in multiple topic maps. For example, you can have the same topic appearing in multiple topic maps and set a new context by using a relationship table. This also aids publishing because the content is independent of format definitions.

 

12.1.4.            Minimalism in content

 

Minimalism in documentation means providing users only the information they need for accomplishing a specific task. This approach requires the break­down of sequential information into smaller, concise, and consistent chunks that can be reused.

 

12.1.5.            Information typing

 

Topics can be specialized into few information types, notably a task type, and two supporting types called concept and reference.

 

Task

 

A series of steps and explanations that enable users to finish a defined unit of work.

 

Concept

 

Explanation of key conceptual information related to a task.

 

Reference

 

Facts relevant to a task. Often reference topics are presented in table or list form to give users quick access to information.

 

Glossentry

 

List of glossary terms and definitions.

 

DITA also provides an architecture for creating new information types based on the existing ones. You can create specific document type definitions through the process of specialization—new structural types or new domains of information. Structural specialization defines new types of structured information, such as new topic types or new map types. Domain specialization creates new markup that can be useful in multiple structural types, such as new kinds of keywords, tables, or lists.

12.1.6.            Reduced localization costs

 

Modular, topic-based content with unique topic IDs allows concurrent authoring and localization of DITA map content. This approach reduces local­ization costs as well as time to market. In addition to topic orientation and content reuse, these DITA features also reduce localization costs.

 

•               All DITA topics are stored in Unicode.

 

•               DITA provides the ability to specify the language setting on nearly every element in a DITA topic.

 

•               The <translate> attribute allows you to indicate items ready for transla­tion.

 

12.1.7.            Challenges in implementing DITA

 

Some challenges in migrating to DITA:

 

•               Repurposing existing content

 

•               Preparing content for reuse

 

•               Breaking down sequential content into modular, reusable components

 

•               DITA specialization for specific needs

 

•               Post-processing of outputs

 

12.2.             DITA support in FrameMaker

FrameMaker 10 provides support for DITA v1.2. For more information on DITA integration with FrameMaker see the online manual Integrating DITA Specialization with Adobe FrameMaker on the Adobe website .

12.2.1.            Basic DITA terms

DITA topic

 

A base <topic> element in DITA requires only three elements: a unique ID, a topic title, and a topic body. It can have multiple optional elements, such as paragraphs <p>, unordered lists <ul>, and tables <table>.

 

DITA task topic

 

A task <topic> type specializes topic element names and topic structure. The root element of a task topic is named <task>, and its body element is <taskbody>. A task topic can have one task prerequisite and one context element followed by steps. Each step must have a command, optional information, a step example, choices, and a step result. You can provide the task result, examples, and any task postrequisites after a set of steps.

 

DITA concept topic

 

A <concept> topic type specializes topic element names and topic struc­ture. A concept topic can have any number of paragraphs, lists, or tables in the first section or example. Subsequent topic consists of sections and examples which can appear in any order.

The root element of a concept topic is named <concept>, and its body element is <conbody>.

DITA reference topic

 

A <reference> topic type specializes topic element names and topic struc­ture. The root element of a reference topic is <reference>, and its body element is <refbody>. The <refbody> element includes a <properties> element which is a table of property types, values, and descriptions. The element <refsyn>, reference syntax, is a specialization of the <section> element.

 

DITA glossentry topic

 

A glossentry topic type is a specialization for glossary entries. It consists of glossary term, <glossterm>, and glossary term definition, <glossdef> pairs.

 

DITA map

 

The DITA map is like a table of contents listing and linking the topics for a specific output. DITA maps assemble topics into sequence and hierarchy tailored to specific delivery requirements. You can have multiple maps, each one arranging the topics for different requirements, such as a refer­ence manual, a tutorial, or online Help. A DITA map file has the extension .ditamap.

 

Bookmap

 

A bookmap is a specialization of a DITA map. You can save a DITA map as a bookmap. In a bookmap, highest-level <topicref> elements in your DITA map become chapters in the FrameMaker book, containing any nested <topicref> elements. Formatting is determined according to which structured application you have selected for books in the DITA Options dialog box.

Relationship table

 

Links between topics are defined and maintained using relationship tables.

 

Conref

 

DITA implements reuse of content units with the <conref> attribute. For example, if the same table appears in multiple topics, you can author it once and include it by reference.

 

Xref

 

References to external sources of information, such as a web page. When you open a file, the DITA feature automatically resolves <xref> elements and displays any associated text within FrameMaker.

 

Specialization

 

DITA allows the addition of new elements through specialization of base DITA elements. Through specialization, DITA can accommodate new topic types and element types as needed for specific industries or compa­nies.

Open Toolkit

 

Open Toolkit is a free, open-source, end-to-end, single-source publishing system. It takes your DITA topics and DITA maps and generates multiple output format deliverables, such as print (PDF), web (HTML), and Help.

12.2.2.            Set attribute display options

Attributes are used to help describe XML elements or provide additional infor­mation that can be used, for example, to identify an element or apply formatting controls. Before working with attributes, you must be able to identify attributes in a document and expand or collapse them as required.

1)            

Select View > Attribute Display Options.

2)           Do one of the following:

 

•               If you want elements to display only attributes that are either required or have values in the Structure View, select Required And Specified Attributes.

 

•               If you want elements to display all the attributes assigned to them in the Structure View regardless of values or requirements, select All Attributes.

 

•               If you want all elements to display their attributes collapsed in the Structure View, select No Attributes.

 

3)           Click Set.

 

12.3.             DITA options

Use the DITA Options dialog box to set general, import, and export-related DITA options. DITA options are global settings for the authoring environment. If you change the DITA settings, you should restart FrameMaker to have the new settings take effect.

 

DITA options

[image: di_dita_options.png]

12.3.1.            Application mapping

With the FrameMaker Application Mapping Manager, you can define separate structured applications for each doc type that your XML file contains. These mappings are retained within the DOCTYPE declaration of each XML file. Such individual mapping allows documents to be opened and processed with the correct set of structured applications and type. This means that you can specify a custom combination of doc type and DITA public IDs.

Application Mapping Manager

[image: di_dita_app_mapping_manager.png]

Add an application mapping

You can create an application mapping tag. After you define a tag, you can then add or edit mapping for different doc types and their related application and type.

1)           On the DITA Options dialog box, click Applications Mappings.

 

2)           On the DITA Applications Mapping Manager dialog box, select New Mapping... from the Mapping Tag pop-up menu.

 

3)           On the DITA Applications Mapping dialog box, do the following, and click OK.

 

Mapping Tag

 

Enter a name for the custom mapping tag.

 

Mapping Type

 

Select the type of application mapping. If you are creating a mapping, select APP_MAPPING as the type.

 

Edit an application mapping

You can define how each doc type is mapped to each structured application.

1)           On the DITA Applications Mapping Manager dialog box, select the mapping tag.

Mappings that are already defined in the selected mapping tag are listed.

 

2)           Select the mapping from the Defined Mapping table. You can edit the following:

 

Doctype

 

Specifies the doc type of the DITA file. Doc types that are defined in the template are available for selection and editing.

 

Application

 

Specify the structured application that FrameMaker uses to open the doc type.

 

Type

 

Specify the type of the document. It can be a Topic, Map, Composite, or None.

 

3)           Click Add/Edit.

 

Delete a defined mapping

1)           On the Application Mappings Manager dialog box, select the mapping tag.

 

2)           On the Defined Mappings table, select the mapping you want to delete, and click Delete.

 

Delete an application mapping tag

1)            

On the Applications Mapping Manager dialog box, select the mapping tag, and click Delete.

 

12.3.2.            Set the DITA version

You can set the DITA version of FrameMaker. This is a global setting.

By default, FrameMaker is set to DITA 1.2. Within this option, you can open and work on documents created with earlier version DITA. However, if you add any elements or attributes that are available only with DITA 1.2, the document becomes a DITA 1.2 document. If you open that document later with an earlier version of DITA, you will get validation errors.

12.3.3.            Set the file type for new documents

You can set the default file type that FrameMaker will use when you create a new document. The default ‘New’ type specifies the filename extension for a new topic (.xml or .dita). This extension is applied only if you do not specify an extension for the new file.

 

1)           Select DITA > DITA Options.

 

2)           Select *.xml or *.dita in the Default ‘New’ Type list.

 

12.3.4.            Element IDs

You can set FrameMaker to automatically assign IDs to elements when an ID is a required attribute for the element. When you use this option, you cannot manually assign IDs to topics or elements from FrameMaker.

The ID value assigned to the selected element is composed of values repre­senting the year, month, day, hours, minutes, and seconds, plus two randomly generated values. It is designed to be unique per-user for 100 years.

Specify the ID format

1)            

In the DITA Options dialog box, specify an ID prefix in the Default ID Prefix field. This prefix is associated with new IDs generated by DITA.

 

Automatically assign IDs to elements

1)           In the DITA Options dialog box, deselect the Auto Add IDs If Required By Element option.

 

12.3.5.            Set File Open options

You can specify how FrameMaker should treat the references in a document when it opens it. Specify the options to optimize the document open perfor­mance.

You can set FrameMaker to automatically reload the following references when opening a file:

 

Topicrefs

 

Select Auto Load Topic Refs on File Open if you want the Topicrefs in the DITAMAP to automatically loaded when you open the map in FrameMaker.

 

Conrefs

 

Select Auto-Load Conrefs On File Open if you want the content references in the DITAMAP to automatically loaded when you open the map in FrameMaker.

 

Xrefs

 

Select Auto-Load Xrefs On File Open if you want the DITA cross-refer­ences in the DITAMAP to automatically loaded when you open the map in FrameMaker.

 

(For Documentum Connector only) Graphics

 

Select Auto-Load Graphics On File Open if you want the graphics in the DITAMAP to automatically loaded when you open the map in FrameMaker.

 

12.3.6.            Set Navtitle options

The <navtitle> attribute specifies the navigation title of a topic and this can be different from the first level heading that shows in the main browser window. The <locktitle> attribute ensures that if present, the <navtitle> attribute is always used. If the Always Update Navtitle While Updating Topicref option is not selected, then <navtitle> is displayed if <locktitle> is set to yes when you update references in a DITA map file.

1)           On the DITA Options dialog box, set the following:

 

•               Select the Always Update Navtitle While Updating Topicref option to display the title from the topicref files. The <navtitle> attribute specifies the navigation title of a topic and this can be different from the first level heading that shows in the main browser window. The <locktitle> attribute ensures that if present, the <navtitle> attribute is always used.

If the Always Update Navtitle While Updating Topicref option is not selected, then <navtitle> is displayed if <locktitle> is set to yes when you update references in a DITA map file.

•               Select the Always Display NavTitle On File Open option to display <navtitle> if <locktitle> is set to yes when you open a DITA map file. If this option is not selected, then the title from the <topicref> files is displayed and <navtitle> is not updated.

12.3.7.            Conditionalize prolog or comments

You can have the prolog, and comments to be hidden from the body of the document when FrameMaker opens a DITA file.

If you enable conditionalizing prolog and comments, FrameMaker applies the <DITA-Prolog> or <DITA-Comment> condition tag to these elements when a DITA file is imported. By default, these conditions are set to Hide in the struc­tured template. In addition, the text thus conditionalized is saved (exported) regardless of whether it is showing (“OutputAllTextWithoutPIs”). If, on import, no associated condition tag is found in the structured template, the condition tags are added and set to Show (in red).

If the Conditionalize option is not selected, all <prolog> and <draft-comment> elements are imported and displayed using the formatting from the EDD and structured template with no condition tags applied.

12.3.8.            Manage index terms

You can let FrameMaker convert the <indexterm> elements in the DITA file to FrameMaker index maker entries when opening a DITA file, and then converting them back to indexterm elements when exporting the FrameMaker document to DITA file.

 

1)           On the DITA Options dialog box, select Indexterm To Index Marker Conversion.

12.3.9.            Enable active links in PDF for external links

By default, when you create a PDF from a DITA file, external references are not converted to clickable links (active links). To enable clickable links for these references, you must allow FrameMaker to add hypertext markers to the element, and automatically populate them with the required syntax. Within a DITA file, the external references are created through inserting an <xref> element, and setting its “source” attribute as “external”.

If you use this option, when you open a DITA file, FrameMaker assigns a <link-asis> character format to the <xref> element, and places a hypertext marker there. FrameMaker adds the marker text with the value of the <href> of the <xref> element, preceded by “message URL.” This generates an active URL that can be saved as PDF. (Previously, only <fm-xref> elements could produce an active link in a PDF file generated from within FrameMaker using this appli­cation.)

note:  This process doesn’t make “internal” <xref> elements clickable in a PDF. To accomplish that, you can use <fm-xref >wherever the associated text can be gleaned from the source of <fm-xref>. 

1)           On the DITA Options dialog box, select the Add Hypertext Marker To External Xrefs option.

 

12.3.10.       Set table options

You can set FrameMaker to track the number of columns across tables whole importing a file into a structured document. By default, this option is selected.

 

1)           On the DITA Options dialog box, select or deselect Select the Count Columns In Tables On File Open option.

 

12.4.             DITA topics

DITA provides a standard for structuring topics and content within topics. That standard is based on three broad information categories into which almost all technical information can be classified: task, concept, and reference.

These topic types are considered specializations of the base class of <topic>, from which they inherit a consistent core structure. Elements common to the three standard DITA information types are <title>, <description>, <prolog>, and <body>. A DITA document must contain at least one topic and can contain many subtopics.

The <task>, <concept>, and <reference> elements inherit common structure from their parent information type, <topic>.
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DITA structure supports reuse of independent topics in any arrangement to form new documents. In fact, one of the main reasons for the topic-based nature of DITA is to let authors reuse information.

Content reuse can take any of these forms:

•                

Compiling independently created and saved topics into new documents

 

•               Automating links and cross-references to, from, and within topics and documents

 

•               Identifying and formatting information for various kinds of distribution

 

•               Formatting information so it can be handled by diverse processes

 

•               Segmenting authoring responsibility across multiple authors or groups

 

Reuse can occur at the topic level (that is, when you rearrange output through DITA maps). Reuse can also occur at the subtopic level, such as when you refer­ence a specific document component within multiple topics via content refer­ence attributes.

12.4.1.            Create a DITA topic

The DITA Options dialog box provides an option for automatically wrapping new topic-level elements, such as <topic>, <concept>, <reference>, <task>, and <glossentry> in a <dita> element (the default). Select this option and then create a topic.

1)            

Select DITA > DITA Options, and choose Wrap New Topics In Dita Element.

 

2)           Click Save.

 

3)           Select DITA > New DITA File > New <topic>.

 

4)           Specify a filename and click Select. A new window appears for your new DITA topic with the default title text TOPIC help.

 

You can insert any DITA topic type from the Elements Catalog. For example, to build an article, you can include any number of DITA concept, task, or refer­ence topics.

note:  If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box.

12.4.2.            Create a DITA concept, task, reference, or glossary entry

1)            

Select DITA > New DITA File > New and then one of these: <concept>, <task>, <reference>, or <glossentry>.

 

2)           Specify a filename and click Select. A new document window appears for your DITA topic with some default title text. The default titles are CONCEPT title, TASK title, REFERENCE title, and GLOSSENTRY GLOSSTERM.

 

note:  If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box. In FrameMaker, you can also save a DITA file without a title.

12.4.3.            Create a DITA concept

1)            

Select DITA > New DITA File > New <concept>.

 

2)           Specify a filename and click Select. A new window appears for your new DITA concept with the default title text CONCEPT title.

 

note:  If you do not provide a filename extension for the new file, an extension is added based on the type specified in the Default File Type option in the DITA Options dialog box. In FrameMaker, you can also save a DITA file without a title.

12.4.4.            Create a DITA task

1)            

Select DITA > New DITA File > New <task>.

 

2)           Specify a filename and click Select. A new window appears for your new DITA task with the default title text TASK title.

 

12.4.5.            Create a DITA reference

You can create a reference topic that includes content, such as additional infor­mation, a tip, a warning, or a simple note.

1)            

Select DITA > New DITA File > New <reference>.

 

2)           Specify a filename and click Select. A new document window appears for your DITA reference topic with the default title text REFERENCE title.

The new DITA reference file is saved as an XML file. The Element Catalog displays the valid DITA elements for a reference topic.

 

12.4.6.            Create a DITA glossentry

1)            

Select DITA > New DITA File > New <glossentry>.

 

2)           Specify a filename and click Select. A new document window appears for your DITA reference topic with the default title text GLOSSENTRY GLOSSTERM.

You can add glossary terms and glossary definitions.

 

12.4.7.            Using indexterm elements

DITA supports the <indexterm> marker elements of FrameMaker. The API client converts FrameMaker index markers with colon-delimited subentries to nested XML <indexterm> elements for seamless export. It reverses the conver­sion for seamless import. In addition to support for the basic <indexterm> element, these types are supported:

Index-see

 

Include a “See” reference.

 

Index-see-also

 

Include a “See Also” reference.

 

Index-sort-as

 

Override the default sort order of the term.

 

Start and End attributes

 

Define a start and end range for index entries

 

12.4.8.            Assign an ID to an element

You can configure DITA to assign a generated ID to a selected element. The ID value assigned to the selected element is composed of values representing the year, month, day, hours, minutes, and seconds, plus two randomly generated values. It is designed to be unique per user for 100 years. You can specify an ID prefix in the Options dialog box. If you specify an ID prefix for each user, the generated IDs are unique for each member of your team.

1)            

Select an element in the Structure View.

 

2)           Select DITA > Assign ID To Element, or right-click the element, and select Assign ID To Element.

 

DITA generates an ID automatically and assigns it to the selected element.

12.5.             DITA maps and bookmaps

 

12.5.1.            DITA maps

A DITA map file opens as a new Resource Manager panel. The icons on the resource manager toolbar are buttons-specific DITA maps. You use them to add child and sibling <topicref> elements and <conref> attributes. You can build any number of hierarchical levels in a DITA map. You can also include other DITA maps within a DITA map.

DITA map resource manager panel
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A.

Insert a child <topicref> element below the selected file.

B.

Insert a sibling <topicref> element below the selected file.

C.

Save the DITA map.

D.

Delete the selected map item.

E.

Click to switch to the Document view, which shows the Structure View.

F.

Toggle button to Show File References or Show All Elements.

G.

Toggle button to Show Navtitle or Show Filename.

H.

Click to update the titles from referenced map items.

I.

Use the arrow keys to move a selected file in the DITA map.

J.

Display the Find/Change panel.

K.

DITA map files.

L.

Status bar displays the complete path of the selected file.

You can add other types of elements to a DITA map by either switching to the Document view or by using the Structure view with the resource manager. Using the Element Catalog, you can insert other elements valid at the insertion point in a DITA map.

 

DITA map Document View, Structure View, and the Element Catalog

[image: di_dimap_docview.png]

note:  To switch back to the resource manager view from the Document view, select View > Resource Manager option.

Save a DITA map

You can save a DITA map in multiple outputs depending on your post-processing requirements. You can save a DITA map as a FrameMaker book file or a composite document to utilize the powerful print capability of FrameMaker. You can set custom numbering properties and pagination infor­mation in a FrameMaker book file and not in a DITA map or bookmap file.

In addition, you can, at the time of saving, specify a DITAVAL file for gener­ating conditional outputs.

Following is a list of some of the key formats in which you can save a DITA map file.

Composite Document 10.0 (*.fm)

 

Save all the .xml files in the DITA map as a single composite FrameMaker document. A composite document contains the content from all the files included in a DITA map.

Book 10.0 (*.book)

 

Save the DITA map as a .book with .xml components. In this case, .xml files are not converted to .fm files.

 

Book 10.0 with fm components (*.book)

 

Save the DITA map file as a .book file and each .xml file converted to a .fm file.

PDF (*.pdf)

 

Generate a PDF directly from the DITA map. This option works in the same way as it does for a FrameMaker document or a FrameMaker book file.

 

 

Saving a DITA map as a composite FrameMaker document

Another way to use all FrameMaker features with DITA content is to save your DITA map as a composite FrameMaker document. A composite document is a single FrameMaker file containing the content from all files included in a DITA map.

1)           Open the .ditamap file or the .bookmap file and choose File > Save Ditamap As.

 

2)           Specify a name for the composite file and select Composite Document 10.0 (*.fm) option from the Save As Type pop-up.

 

You can also select the Prompt For DitaVal File to specify a DITAVAL file for conditional output.

 

3)           Click Save.

 

Saving a DITA map as a FrameMaker book

You can also include DITA topics in a FrameMaker book and take advantage of all the hierarchical features available for a book, such as folders and groups. You can opt to save a DITA map as a book with DITA XML files or a book with FrameMaker components in which all DITA XML files are converted to FrameMaker files.

You can set numbering properties for all DITA components and directly print a PDF from a FrameMaker book. The content in the FrameMaker book can be XML or FM files. You cannot set numbering properties for components in a DITA map.

note:  You can save a DITA map as a FrameMaker book but you cannot save a FrameMaker book as a DITA map. Therefore, numbering or pagination proper­ties set on a FrameMaker book cannot be cycled back to the DITA map. If you update the DITA map, you should recreate the book file and set the numbering and pagination properties again.

Saving a DITA map as a PDF

FrameMaker provides the ability to directly print a DITA map as a PDF.

1)           Open the .ditamap file or the .bookmap file and choose File > Save As PDF.

 

2)           Specify a name for the PDF file and click Save.

 

You can also specify a DITAVAL file for conditional output.

 

3)           Set PDF options from the PDF Setup dialog box and click Set.

 

Create a DITA map

1)            

Select DITA > New DITA File >New <map>. The Enter A New DITA Map filename dialog box appears.

 

2)           In the filename field, specify a unique name for the map file.

 

note:  If you do not provide a filename extension for the new file, a default name is added based on the type specified in the Default File Type option in the DITA Options dialog box. DITA map files are assigned a .ditamap extension.

 

3)           Click Select. A new resource manager window appears for your DITA map with the default title text MAP title.

 

4)           Click the Switch To Document View icon on the DITA map. In the Docu­ment View, you can specify a map title or add elements and attributes other than <topicref> and <conref>.

5)           In the Document View, select MAP title and specify a title for your DITA map.

Insert a topicref in a DITA map

You can insert a child or sibling <topicref> element in a DITA map. The command inserts a new <topicref> element at the current insertion point of an open DITA map file, or overwrite a selected <topicref> element to reference a new file.

 

Insert a topicref from the resource manager panel

 

1)           Open a DITA map file.

 

2)           Select the file below which you want to add a <topicref> element.

3)           Select Insert Sibling Topicref.

4)           Select a file, or in the filename field, specify the name of the topic file.

 

5)           Click Select. The topic reference is inserted in the DITA map file.

 

note:  You can use the arrow icons on the resource manager toolbar to promote a child <topicref> to a sibling <topicref> or convert a sibling <topicref> to a child <topicref>.

 

Insert from the Document View

 

1)           Open a DITA map file and click 
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to switch to the Document view.

 

2)           Right-click at the desired insertion point and select Insert Topicref.

Alternatively, select the <topicref> element from the Element Catalog and click Insert. The Select A Topicref File dialog box appears.

 

3)           Select a file, or in the filename field, specify the name of the topic file.

 

4)           Click Select. The topic reference is inserted in the DITA map file.

 

Open all topic references in a DITA map

1)            

Open a DITA map file containing topic references.

 

2)           Select DITA > Open All Topicrefs.

3)           Click OK to confirm the message displayed. The linked topic reference files are opened in separate windows.

 

12.5.2.            Bookmaps

A bookmap is specialized DITA map that allows you to organize and print your DITA topics as a book. A bookmap also opens in a similar Resource Manager panel. The icons on the resource manager toolbar are identical to the icons for a DITA map.

12.5.3.            DITA locktitle and navtitle attributes

The <navtitle> attribute specifies the topic title that appears during navigation. The <locktitle> attribute ensures that the value of the <navtitle> attribute is used during navigation if it is present.

12.5.4.            About relationship tables

You can create a list of related topics for a topic that you would recommend to your reader. The list of related topics is stored in a relationship table <reltable> that defines the relationship between topics. Relationships are expressed as links in the output, with each topic in a relationship having links to the other topics by default.

A relationship table is a part of the ditamap file. You can specify multiple rela­tionship tables in a ditamap. At the time of generating outputs, FrameMaker converts the <topicref> elements to links and displays them in the related links section in the topics. You can fine-tune the output from your DITA map by setting different attributes on <topicref> elements. The attributes that you can use are <linking>, <collection-type>, and <type> which can be set on a <topicref>, <relcell>, and <relcolspec>.

For example, the <linking> attribute controls how relationships to other <topicref> elements are expressed as links.

When you save a ditamap as a composite FrameMaker document, these links are converted to hyperlinks and they appear in a Related Links section.

Format of a relationship table

 

A relationship table contains a <relheader> element that has a row of <relcol­spec> elements that define the columns in the table. The <relrow> element creates a relationship between the cells in each row, and this relationship is expressed as links in the <topicref> elements in the cells <relcell>.

The <topicref> elements in <relcell> should be related to <topicref> elements in other cells of the same row. By default, <topicref> elements in the same cell are not related to each other, unless you change the collection-type attribute of the relcell to indicate that they are related.

 

The <relcolspec> element contains the <type> attribute which defines the type of <topicref> in the corresponding column in a body row. The types can be task, concept, reference, or any other specialized DITA topic type. Cells in the body row allow only that type of <topicref> element which is mentioned in <relcol­spec>.

The collection-type attribute indicates how a set of sibling <topicref> elements relate to each other. A <family> collection type represents a tight grouping in which each of the referenced topics not only relates to the current topic but also relate to each other. A <sequence> collection type indicates the order of the child topics and FrameMaker links them in the specified order in the output.

note:  FrameMaker does not support <choice> collection type and treats them as <unordered>.

12.5.5.            Create a relationship table

1)            

Open a DITA map file and switch to the document view because you can add <topicref> elements to a <reltable> in the document view.

 

2)           Place the insertion point at the end of the DITA map.

 

3)           Select reltable from the Element Catalog and click Insert. A reltable element with two columns and two rows is added to your DITA map.

 

4)           The first column is for the <relcolspec> element that contains the type attribute which defines the type of topicref in the corresponding column in the body row.

 

5)           The second column allows only that type of topicref insertion which is specified in <relcolspec>.

 

note:  You cannot add a <conref> element in a <reltable>.

12.6.             DITA content references (conrefs)

FrameMaker supports both direct and indirect referencing of content as per the DITA 1.2 standard. If your default structured application is based on DITA 1.2, you can use both direct and indirect content referencing. A DITA conref attribute inserts a content reference as a text inset and tags it with the <DITA-Conref> conditional text tag. The conref attribute is used to refer­ence element with an ID or key so that its content can be reused.

Direct content referencing

 

You reference an element with its path in conref attribute and its unique ID.

 

Indirect content referencing

 

You reference an element with its key in the conref attribute and its unique ID.

 

Indirect content referencing range

 

You reference and element with its key in the conref attribute and its unique ID, along with the range of subsequent elements. The range of elements to be referenced is specified by the unique ID of the last element in the range as conrefend attribute.

 

note:  To specify a range for the content reference, the elements within the range must be of the same type. At least the start and end elements must have unique IDs. 

DITA conref manager
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A.

Check to reference content using keys (DITA 1.2 only option).

B.

Check to reference a file using path.

C.

List of elements that can be referenced.

D.

Check to display all applicable elements including elements without IDs.

E.

Select the last element to define range of elements, with first element selected in Element Data (DITA 1.2 only option).

F.

List of Element Data for selected Element Tag.

You can add a conref to footnote or an index marker as well. All referenced elements appear as insets in a FrameMaker document. You can use the Insets pod to work with DITA content references.

12.6.1.            Create a direct content reference

1)            

Open a DITA file containing a topic type.

 

2)           In Structure View, place your cursor at the appropriate location where the content reference is to be added.

 

3)           Select DITA > Insert Conref.

4)           In the DITA Conref dialog box, select file from which the element is to be referenced. By default, the current file is selected.note:  With DITA 1.1, you can only reference elements from a file. 

5)           Select the element to be referenced. Based on the selection, the available elements in the selected file are listed.note:  By default, FrameMaker displays only the elements that have IDs assigned. To display all elements, select Show All. 

6)           Select the ID of the element to be referenced, and click Insert.

 

12.6.2.            Create an indirect content reference

1)            

Open a DITA file containing a topic type.

 

2)           In Structure View, place your cursor at the appropriate location where the content reference is to be added.

 

3)           Select DITA > Insert Conref.

4)           In the DITA Conref dialog box, select Refer To A Key, and click Edit.

 

5)           On the Key Reference dialog box, select the available keyspaces from the list. note:  If you haven’t specified any keyspaces, click Keyspace to define keyspaces. 

6)           Select the element type that you want to reference.

7)           From the list of elements, select the ID of the element that you want to reference, and then click OK.

 

8)           On the DITA Conref dialog box, click Insert.

 

12.6.3.            Create content reference to a range of elements

1)            

Open a DITA file containing a topic type.

 

2)           In Structure View, place your cursor at the appropriate location where the content reference is to be added.

 

3)           Select DITA > Insert Conref.

4)           In the DITA Conref dialog box, do one of the following:

 

Refer to a key

If you have defined keyspaces for the reference target, you can reference a range of elements that are contained in the keyspace.

 

a)           In the DITA Conref dialog box, select Refer To A Key, and click Edit.

 

b)           On the Key Reference dialog box, select the key from the Key list. note:  If you haven’t specified any keyspaces, click Keyspaces... to define keyspaces. 

c)           Select the element type that you want to reference.

d)           From the list of elements, select the ID of the element that you want to reference, and then click OK.

 

e)           On the DITA Conref dialog box, select the end element of the range from the Conref End Element pop-up menu, and click Insert.

 

Refer to a file

 

You can reference a range of elements using their IDs in a referenced file.note:  Ensure that Refer To A Key is deselected. 

a)           On the DITA Conref dialog box, click Browse next to Refer To A File list, select the file, and click Select in the browse dialog box.

 

b)           Select the element tag that you want to reference.

 

c)           From the list of elements, select the ID of the first element in the range that you want to reference.

 

d)           From the Conref End Element pop-up menu, select the last element in the range of elements that you want to reference, and click Insert.

 

12.6.4.            Create a content reference to a DITA topic

1)            

Open a DITA topic file.

 

2)           Collapse the <body> element and place the insertion point below it.

 

3)           Select DITA > Insert Conref. The DITA Conref window appears.

 

4)           From the Source File list, select the file from which you want to conref the topic.

 

note:  The Source File list displays a list of open files only. Use the Browse button to open a file not already open.

 

5)           In the Element Tag pane, select a tag. The Element Data list displays a list of elements matching the selected element tag from the source file.

 

6)           From the Element Data list, select the desired element and click Insert. The content of the selected element is inserted in your open file.

 

By default, the text color of an element inserted by reference is blue. However, you can modify it using the structured-template designer.

 

tip:  By default, error messages are generated when you open a file that contains a <conref> element or an <xref> element that can’t be resolved. Error messages also appear if the file references a file that has an unresolvable reference. If you prefer not to receive these messages, choose DITA > DITA Options, and deselect both Auto-Load Conrefs On File Open and Auto-Load Xrefs On File Open. 

12.6.5.            Create a conref to an image

1)            

Open the DITA topic file in which to insert a content reference to the image.

 

2)           Place the insertion point at a valid point in the Structure View.

 

3)           Select DITA > Insert Conref.

 

4)           From the Source File list, select the image source file.

 

5)           From the Element Tag pane, select the image tag. The Element Data list displays a list of images in the selected source file. Only those elements that are valid appear in the Element Tag list.

 

note:  If the image you want to reference is not in the Element Data list or if the entry states NO ID|NO CONTENT, the image element does not have an ID assigned to it. Assign it an ID, save the source file, and repeat the steps to insert the content reference.

 

6)           Select the image ID from the Element Data list and click Insert. The image is inserted in your open file.

 

If you change the image in the source file, click DITA > Update References to reflect the changes in your target file.

12.6.6.            Create a conref to a table or its cells

You can create a <conref> to a complete table element, table heading, table body, table row, or a table cell.

note:  In a simpletable, the table heading is a false element and therefore cannot be conref’d. 

Insert a conref to a table

 

1)           Open the DITA topic file in which to insert a content reference to a table.

 

2)           Place the insertion point at a valid point in the Structure View.

 

3)           Select DITA > Insert Conref.

 

4)           From the Source File list, select the table source file.

 

5)           From the Element Tag pane, select the type of the source table element, such as <simpletable>. The Element Data list displays a list of tables in the selected source file.

 

note:  If the table you want to conref is not in the Element Data list or if the entry states NO ID|NO CONTENT, the table element does not have an ID assigned to it. Assign it an ID, save the source file, and repeat the steps to insert the content reference.

 

6)           Select the table ID from the Element Data list and click Insert. The table is inserted in your open file.

 

Insert a conref to a table row

 

1)           Open the DITA topic file in which to insert a content reference to a table row.

 

2)           Insert a table element in the document. Ensure that it has the same number of columns as the source table.

3)           Select the table row in which to insert a content reference.

 

note:  Selecting the table row in the Document View may select only the individual cells and not the row element. Look at the Structure View and ensure that you have selected the entire table row element, such as <strow>.

 

4)           Select DITA > Insert Conref.

 

5)           From the Source File list, select the file that is the source of the table row. Notice that the Element Tag list displays only the table row element, <strow>.

 

6)           Select the table row ID from the Element Data list and click Insert. The content of the source table cell is inserted in the selected table row. A blue border is added to the row to indicate that it is a content reference.

 

note:  The source table row must have an ID assigned to it. If no ID has been assigned to the table row element, it doesn’t appear in the Element Data list even if its cells have individual IDs. Assign an ID to the table row, save the source file, and repeat the steps to insert the content reference.

 

Insert a conref to a table cell

 

1)           Open the DITA topic file in which to insert a content reference to a table cell.

 

2)           Place the insertion point at a valid point in the Structure View and insert a table element.

3)           Select the table cell in which to insert a content reference.

 

4)           Select DITA > Insert Conref.

 

5)           From the Source File list, select the file that contains the source table cell.

 

6)           From the Element Tag list, select the type of the source table element, such as <stentry>. The Element Data list displays a list of table cells in the selected source file.

 

note:  The table cell must have an ID assigned to it. If no ID has been assigned to the table cell element, it does not appear in the Element Data list. Assign it an ID, save the source file, and repeat the steps to insert the content reference.

 

7)           Select the table cell ID from the Element Data list and click Insert. The content of the source table cell is inserted in the selected table cell.

 

note:  You cannot insert a content reference to a column in a table. If the column doesn’t have too many cells, you can insert content references to individual column cells instead.

 

12.7.             DITA cross-references and links

 

12.7.1.            About DITA cross-references

In unstructured FrameMaker, an internal cross-reference is one that references a topic or section within the same file. An external cross-references is a topic or section in a different file. But in the case of DITA, an external cross-reference or an <xref> is to a website. When you import a DITA file, internal DITA cross-references are converted to FrameMaker cross-reference objects. When you export, the FrameMaker cross-reference objects are converted back to DITA cross-references. You can create a FrameMaker cross-reference to any element that a DITA <xref> element can reference from the DITA cross-refer­ence panel.

 

DITA cross-reference panel
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A.

Check to reference content using keys (DITA 1.2 only option).

B.

Name of key from keyspace (DITA 1.2 only option)

C.

Click to access Key Reference dialog box (DITA 1.2 only option).

D.

Check to reference a file using path.

E.

List of elements to cross-reference.

F.

Check to display all elements valid as per DTD.

G.

List of DITA <xref> elements. It also lists the specialized <xref> elements.

H.

Specify custom display formats.

I.

List of Element Data for selected Element Tag.

J.

Insert external cross-reference.

K.

Insert an internal cross-reference.

You can also troubleshoot internal cross-references using the FrameMaker cross-reference pod.

12.7.2.            Insert cross-references in a DITA file

If the cross-reference element is available in your document, you can define the destination and link text for internal and external <xref> elements.

Insert an internal cross-reference

1)            

Open the DITA topic or ditamap file in which to insert a cross-reference.

 

2)           Place the insertion point at a valid point in the document.

3)           Select Special > cross-reference.

4)           From the Source File list, select the file to cross-reference.

 

5)           From the Element Tags list, select the type of the source element, such as <concept>. The Element Data list displays a list of concept elements in the selected source file.

 

note:  Select the Show All Elements option to view all element data in the Element Data list.

 

6)           Select the element instance from the Element Data list.

7)           In the Display Using Text field, type a description that is displayed in place of the text of the selected element.

 

Alternatively, select a predefined format for the text from the Format menu.

 

8)           Click Insert. The Update button is displayed if you are modifying an existing <xref> element.

 

note:  If the Insert or the External Xref buttons are disabled, the cursor is at a point in the structure where an <xref> element is not valid. Look at the Structure View and the Element Catalog to ensure that the cursor is at a valid position before you insert a cross-reference.

 

Insert an external cross-reference

1)            

Open the DITA topic or ditamap file in which to insert a cross-reference.

 

2)           Place the insertion point at a valid point in the document.

3)           From the Element Catalog, select Xref, and click Insert. The DITA cross-reference panel appears.

 

Alternatively, select Special > cross-reference option.

 

4)           In the Display Using Text field, type a description that is displayed in place of the text of the selected element.

 

Alternatively, select a predefined format for the text from the Format menu.

 

5)           Click External Xref. The DITA External Xref dialog box appears.

6)           In the Xref Target (href) field, type the URL of the external website.

 

7)           In the Xref Link Text field, you can type a description that is displayed in place of the actual URL. This step is optional.

 

8)           Click OK. A cross-reference to an external website is created in your docu­ment.

 

note:  You can edit an external reference by double-clicking it in the Docu­ment View.

 

12.7.3.            Updating DITA references

You can configure DITA to update the content of <topicref>, <conref>, or <xref> elements.

Update DITA maps

While working in DITA maps, you sometimes have to update one or more <topicref> elements, which also updates the DITA maps.

The Update Selected Topicref option is available only when you’ve selected either a <topicref> or a DITA map in the resource manager. The Update All Topicrefs In File option is available only when your insertion point is not in a <topicref> element. In addition, the Update All Topicrefs In File option honors the setting of the <locktitle> attribute. If it is set to Yes, the <navtitle> attribute of the <topicref> element is not updated.

You can also select the Update All Conrefs in File and Update All Xrefs in File options to update both internal as well as external cross-references.

1)            

Select DITA > Update References.

 

2)           Do one of the following:

 

•               If a <topicref> element is selected, click the Update Selected Topicref option. DITA updates the content of the selected <topicref> element.

•               If a <topicref> element is not selected, click the Update All TopicRefs In File option. DITA updates all <topicref> elements in the current file to reflect any changes to titles in referenced files.

3)           Click OK.

 

Updating DITA topics

While working in DITA topics, you sometimes have to update all <conref> or <xref> elements.

1)            

Select DITA > Update References.

 

2)           Do one of the following:

 

•               Select the Update All Conrefs In File option. DITA updates all <conref> elements in the current file to reflect any changes to the source content.

•               Select the Update All Xrefs In File option. DITA updates all <xref> elements in the current file to reflect any changes to titles in refer­enced files.

3)           Click OK.

 

12.7.4.            About DITA links

The <related-links> is a container element that has a set of <link> elements. A <link> element contains the <linktext> element which is the literal line of text for a link. When importing a DITA file in FrameMaker, these <linktext> elements are converted to <fm-linktext> which is a FrameMaker cross-refer­ence object.

DITA link manager panel
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A.

Check to link content using keys (DITA 1.2 only option).

B.

Check to link to a file using path.

C.

Lists the open DITA files.

D.

List of element tags that can be linked from the selected file and the instances of those elements.

E.

DITA <link> and <linktext> elements.

F.

Specify custom display formats.

G.

Click to select key from DITA Keyspace Manager (DITA 1.2 only option).

H.

Select a file not listed in the Source File menu.

I.

Edit the selected file.

J.

Insert external links.

K.

Insert an internal link.

You can insert links to:

•                

DITA topics in the same file or a different file. These links are called internal links. They are represented as a FrameMaker cross-reference object.

 

•               An external web page, and local or remote files, by providing a URL. These links are called external links. A hypertext marker is used to represent an external DITA link to a URL.

 

DITA external link panel
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A.

Check to link content using key (DITA 1.2 only option).

B.

Check to link a file using path.

Insert an internal link

1)            

Open the DITA topic or ditamap file in which to insert a DITA link.

 

2)           Place the insertion point at a valid point in the document.

3)           Insert the <related-links> element from the Element Catalog.

4)           Double-click the <link> element and select the source file.

 

5)           From the Element Tags list, select the type of the source element, such as <concept>. The Element Data list displays a list of concept elements in the selected source file.

 

note:  Select the Show All Elements option to view all element data in the Element Data list.

 

6)           Select the element instance from the Element Data list.

7)           In the Display Using Text field, type a description that is displayed in place of the text of the selected element.

 

Alternatively, select a predefined format for the text from the Format menu.

 

8)           Click Insert. The Update button is displayed if you are modifying an existing <link> element.

 

note:  If the Insert or the External Link buttons are disabled, the cursor is at a point in the structure where a <link> element is not valid. Look at the Structure View and the Element Catalog to ensure that the cursor is at a valid position before you insert the link.

 

Insert an external link

1)            

Open the DITA topic or ditamap file in which to insert an external link.

 

2)           Place the insertion point at a valid point in the document.

3)           Insert the <related-links> element from the Element Catalog.

4)           Double-click the <link> element and click the External Link button in the DITA Link panel.

 

5)           In the Link Target (href) field, type the URL of the external website.

 

6)           In the Link Text field, you can type a description that is displayed in place of the actual URL. This step is optional.

 

7)           Click OK. A link to an external website is created in your document.

 

note:  You can edit an external reference by double-clicking it in the Docu­ment View.

 

12.8.             Find References

You can search through a document or recursively through multiple files in a folder for links such as conref, topicref, link, or xref. By default, the Find Refer­ences dialog box populates the ID of the current topic and element, if any is selected. Typically, you select the element which is referenced elsewhere, and then call this option.

 

 

1)           Select DITA > Find References. Or, to find the reference of the current element, right-click within the element, and select Find References. The element ID is populated automatically.

 

2)           On the Find References box, enter the ID of the element, if necessary.

3)           Optionally, to limit the search within a keyspace, select the keyspace for the current document.

 

4)           Set the search scope. If you select a folder, you can recursively search for references to the element in all the files in the folder.

 

5)           Click Search.

 

12.9.             Assign IDs to elements

You can assign IDs to one or all instances of an element in one go across a fram­emaker file, topicrefs in a ditamap, or in all open files. You can also assign IDs to the instances of the specialization of the selected element.

Assign ID dialog
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A.

Name of the element that is assigned IDs

B.

Check to assign IDs to specialization instances of the selected element

C.

Select to assign IDs to all element instances in the current file

D.

Select to assign IDs to all element instances in all the topicrefs in a ditamap

E.

Select to assign IDs to all element instances in all the open files

 

12.9.1.            Assign ID to an element

 

1)            

In a FrameMaker file, select an instance of the element for which you want to assign IDs.

 

2)           Select DITA > Assign ID to Element.

12.9.2.            Assign IDs to all instances of an element

 

1)            

In a FrameMaker file, select an instance of the element for which you want to assign IDs.

 

2)           Select DITA > Assign ID to Elements.

a)           If necessary, select the element name in the drop-down. By default, the element selected before selecting Assign ID to Elements is selected in the drop-down.

 

b)           Select Include specialization to assign IDs to specializations of the selected element. If you are in a DITAMAP, select Process Topicrefs in Ditamap to assign IDs to all instances of the selected element in the topics in the ditamap.

 

c)           If you have multiple files open, select All Open Files to assign IDs to all the instances of the selected element in all the open files.

 

d)           Select Assign.

 

12.10.       Conditional processing

Using a conditional processing profile, you can filter information based on specific criteria at processing time. Most DITA elements have the following attributes for conditional processing:

Product

 

The product to which the content applies.

 

Platform

 

The platform on which the product is deployed, such as Windows, UNIX, or Linux.

 

Audience

 

The intended audience for the content.

 

Rev

 

The revision number of the content. You can only flag revisions, not exclude them.

 

Otherprops

 

Any other property.

 

These attributes allow you to control the inclusion of specific elements based on the attribute values and the conditions specified in a processing file.

note:  DITA also provides you the option of flagging elements. FrameMaker does not support flagging of DITA elements. You can only use the filtering operation of DITA conditional processing in FrameMaker.

12.10.1.       The ditaval file

This conditional processing profile is created to identify which values need to be conditionally processed for a particular output, build, or other purpose. The profile file is known as the ditaval file. The filename has the extension .ditaval to identify it to conditional processing systems.

In FrameMaker, DITA conditional processing supports following operations:

•                

Include (Filtering)

•               Exclude (Filtering)

 

•               Passthrough

 

note:  Passthrough is the same as Include as the elements are included in the output.

Content is filtered according to the conditions specified in a ditaval file. An element is included or excluded according to these rules:

•                

If all the values in an attribute are set to exclude, then the attribute evalu­ates to exclude.

•               If any of the attributes evaluates to exclude, the element is excluded from the output.

The following example is from a DITA topic:

<p audience="teacher" platform="windows mac"> WIN: MAC: Only for teachers.</p> <p audience="student" platform="windows linux"> WIN: LIN: Only for students.</p> <p audience="teacher student" platform="windows"> WIN: Only for teachers and students.</p> 
<p audience="teacher principal" platform="windows mac"> WIN: MAC: Only for teachers and principal.</p>
<p audience="teacher" platform="mac"> MAC: Only for teachers.</p>
<p audience="student" platform="mac"> MAC: Only for students.</p>
<p audience="teacher student" platform="mac"> MAC: Only for teachers and students.</p>
<p audience="teacher principal" platform="mac"> MAC: Only for teachers and principal.</p>

The following is an example of the ditaval file defined for the DITA topic:

<val>
    <prop att="audience" val="student" action="include" />
    <prop att="audience" val="teacher" action="exclude" />
    <prop att="audience" val="principal" action="exclude" />
    <prop att="platform" val="windows" action="include" />
    <prop att="platform" val="linux" action="include" />
    <prop att="platform" val="mac" action="exclude" />
 </val>

The output generated is as follows:

WIN: LIN: Only for students.
WIN: Only for teachers and students

You can create a ditaval file in FrameMaker or any text editor, such as notepad. Though it is not essential to save the ditaval file with a .ditaval extension, ensure that the values are space delimited in the ditaval file. It is important to have the values in the correct format for accurate conditional processing. You can save the ditaval file with any extension.

note:  Conditions in the ditaval file having an action different from the standard values, such as include, exclude, and passthrough, are considered invalid and therefore ignored. Flag is not a supported value and is therefore ignored.

12.10.2.       Invalid entries in a ditaval file

•                

A condition with action different from the standard values, such as 'include', 'exclude', 'passthrough', and 'flag' is ignored.

 

•               A condition statement that contains spaces of any kind, such as tab, newline for attribute name, values, or action is ignored. A warning message is displayed on the console.

 

•               A condition with the action specified as ‘flag’ is not processed and does not affect the generated output. A warning message is displayed on the console.

 

•               A condition in the ditaval file that has a missing or blank attribute name is ignored and does not affect the generated output. A warning message is displayed on the console.

 

•               In a ditaval file, you can define only one occurrence of a 'prop' element with no 'att' attribute specification, including empty value or an all spaces value. If more than one condition statement exists the first valid occur­rence is processed and the others ignored.



	
Conditions in the ditaval file

 


	
Processing time

 





	
<val>

 


	
NA

 





	
<prop />

 


	
Ignored. Invalid condition.

 





	
<prop action=”          “ />

 


	
Ignored. Invalid because the action value is blank.

 





	
<prop action=”include“ />

 


	
Valid. Processed correctly.

 





	
<prop action=”filter” />

 


	
Ignored. Invalid action value, filter.

 





	
<prop action=”exclude” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
<prop action=”passthrough” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
</val>

 


	
NA

 






•               In a ditaval file, you can define only one occurrence of a 'prop' element with no ‘val’ value specification. If more than one condition statement for the same attribute exists, the first valid occurrence is processed and the others ignored. A warning message is displayed on the console to notify that a condition has been ignored.

 



	
Conditions in the ditaval file

 


	
Processing time

 





	
<val>

 


	
NA

 





	
<prop att=”audience” />

 


	
Ignored. Invalid condition. Action is not specified.

 





	
<prop att=”audience” action=”          “ />

 


	
Ignored. Invalid because the action value is blank.

 





	
<prop att=”audience” action=”exclude“ />

 


	
Valid. Processed correctly.

 





	
<prop att=”audience” action=”filter” />

 


	
Ignored. Invalid action value, filter.

 





	
<prop att=”audience” action=”include” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
<prop att=”audience” action=”flag” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
</val>

 


	
NA

 






•               Similarly, you can define only one occurrence of a 'prop' element with specific 'att' attribute and ‘val’ value pairs. If more than one condition statement exists, the first valid occurrence is processed and the others ignored. A warning message is displayed on the console to notify that a condition has been ignored.

 



	
Conditions in the ditaval file

 


	
Processing time

 





	
<val>

 


	
NA

 





	
<prop att=”audience” val=”student”/>

 


	
Ignored. Invalid condition. Action is not specified.

 





	
<prop att=”audience” val=”student” action=”          “ />

 


	
Ignored. Invalid because the action value is blank.

 





	
<prop att=”audience” val=”student” action=”flag“ />

 


	
Valid. But ‘flag’ is not processed by FrameMaker.

 





	
<prop att=”audience” val=”student” action=”filter” />

 


	
Ignored. Invalid action value, filter.

 





	
<prop att=”audience” val=”student” action=”include” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
<prop att=”audience” val=”student” action=”exclude” />

 


	
Ignored. Repeated condition. First occurrence is processed.

 





	
</val>

 


	
NA

 






12.10.3.       Specifying the ditaval file

You can specify a .ditaval file when saving a .ditamap in the following cases:

 

•               Saving as Adobe PDF

 

•               Saving as FrameMaker Book with FrameMaker components

 

•               Saving as a Composite Document

 

•               Publishing the current document (When used as part of Adobe Technical Communication Suite only)

 

•               From FrameMaker Server, publishing to multiple channels

 

 

1)           Select the .ditamap and choose File > Save As PDF.

 

2)           Select the Prompt For Ditaval File check box and click Save.

 

3)           Browse and select the .ditaval file and click Choose.

 

4)           Click Set to create the PDF file.

 

Based on the conditions specified in the ditaval file, the output PDF file contains the appropriate content from the ditamap and XML files.

For Print Output, you can enable ditaval filtering feature by specifying ‘Prompt­ForDitaval =1’ in the ditafm.ini file. When you enable this option, a dialog box, Choose DitaVal File, appears each time you print a ditamap.

note:  Use caution while editing an ini file.

note:  You can access the ditafm.ini file from the <installation_direc­tory>/Adobe/AdobeFrameMaker10/fminit/ directory.

12.11.       Automating conversion of base files to specialized files

FrameMaker facilitates automatic conversion of base files to specialized files, after the user inputs the specialized DTD. To perform the conversion:

1)            

Click DITA > DITA Specialization. The conversion screen is displayed as follows:

DITA Specialization wizard

[image: di_specialization_screen.png]

 

2)           Specify the source files (Read/Write Rules, EDD and Template File). Spec­ifying these files are optional. However, for proper specialization, specify these files.

 

3)           Specify a Public ID as desired. Specifying a Public ID is optional.note:  If you do not provide a Public ID, the XML files created from these specialized files may not be portable to other systems. The XML files will contain the absolute path of the DTD that may not be available on other systems. 

4)           Specify the destination folder and the names of the corresponding output files and click OK.

 

The conversion can take a couple of minutes depending on the size of the input files.note:  When you select the Create New Structured Application option, the system opens the structured application dialog. The user selects the desired base application. The system then automatically adds the document types and advanced settings to the new application. note:  Logs are generated and shown on screen during the conversion process. 

Related links:

Integrating DITA Specialization with FrameMaker 10




13.                Generating Output

 

13.1.             Publishing options

From FrameMaker, you can generate PDF and HTML outputs by specifying the conversion settings. If you are authoring in FrameMaker as part of a large team, you can use advanced options to publish content in several ways that extend the traditional authoring and publishing options. Depending on your deployment needs, you can use Adobe FrameMaker and Adobe RoboHelp in the following ways:

 

Stand alone publishing from FrameMaker and RoboHelp

 

In this approach, you author content in respective tools for the required delivery formats. You create PDFs from FrameMaker, and online Help formats such as WebHelp or CHM files from RoboHelp. Content is authored exclusively according to the output formats.

 

Publish XML or HTML output from FrameMaker using XSLT

 

In this approach, you author content in Structured FrameMaker. You use the XSLT feature in FrameMaker to generate XML or HTML output.

Single-sourcing with FrameMaker and RoboHelp

 

You create content in FrameMaker, leveraging the existing templates, standards, and processes, and then link the content into RoboHelp to publish several online Help formats. Here, your primary authoring envi­ronment is FrameMaker; RoboHelp provides multi-channel publishing capabilities such as ePub, Adobe AIR-based Help, WebHelp, and PDF.

 

Extended single sourcing with Adobe Technical Communication Suite

 

With the Adobe Technical Communication Suite, you gain enhanced publishing capabilities. When employed as a suite, Adobe FrameMaker and RoboHelp get extended features that allow dynamic linking and advanced single-sourcing capabilities. Within FrameMaker, you can quickly publish the current book, document, or DITA file using the suite-level workflows that you have defined.

 

Multi-channel, multi-device, automated publishing with FrameMaker Publishing Server

 

Adobe FrameMaker Server 11 extends server-based, automated, and scheduled publishing capabilities that you can synchronize with your product engineering processes and schedules. FrameMaker Publishing Server leverages the Technical Communications Suite workflows to create multi-channel, multi-device content delivery capabilities. See the FrameMaker Publishing Server 11 help.

 

Collaboration framework with RoboHelp Server

 

With the new capabilities of RoboHelp Server and RoboHelp HTML, you can publish browser- and platform-independent Help, and allow users to provide feedback on the content. RoboHelp Server provides centralized comment moderation, a host of reports on content usage, and user feed­back with optional user authentication.

 

13.2.             Publishing the current document

note:  This feature is available only if FrameMaker is part of the Adobe Technical Communications Suite.

You can quickly publish the current document, book, DITA file, or DITAMAP using the Publish option in FrameMaker. You can select from a set of several online output formats, and then specify the publishing options that you defined for the FrameMaker- RoboHelp workflow.

If you want to quickly publish the entire book or DITAMAP from FrameMaker, ensure that you have defined the publishing workflows such as the FrameMaker to RoboHelp style mapping, pagination, and other conversion settings. In a production environment, create separate RoboHelp projects and Import Settings Files (ISF) for each output format.

Optionally, if you are publishing a DITAMAP or DITA content, you can specify a DITAVAL file to create conditional output.

 

1)           Select File > Publish.

 

2)           In the Publish Settings dialog box, select the output format.

 

3)           Select the folder where the published output will be saved. By default, FrameMaker chooses the same location as the source file.

 

4)           Specify the RoboHelp settings that will be used for the conversion and click Publish.note:  Even though these settings are not mandatory, to get optimum output, specify the relevant settings. FrameMaker does not alert you to specify these settings when you initiate the Publish action. 

RoboHelp Project

 

Specify the RoboHelp Project file (XPJ) that you have created.

ISF File

 

Specify the Import Settings File (ISF) that contains the required conver­sion settings.

 

13.3.             Generating PDFs

  

If you regularly publish PDF documents, see this PDF Creation Handbook for a list of production processes, tips, and best practices for authoring and publishing from FrameMaker.

13.3.1.            Adobe PDF

 You can save and distribute a FrameMaker document or book file as Adobe PDF. Readers can view it with Acrobat, Adobe Reader, or any application that supports Adobe PDF files.

When you save a FrameMaker document as Adobe PDF, the following changes occur:

•                

Cross-references and hypertext commands become links in the PDF file.

 

•               In structured documents, elements you specify in the PDF Setup dialog box become bookmarks in the PDF file.

•               Hypertext alert messages become notes in the PDF file.

 

•               Hypertext URL messages become Web links in the PDF file.

 

•               Other hypertext commands convert to equivalent HTML links.

 

•               Paragraphs you specify in the Bookmarks panel of the PDF Setup dialog box become bookmarks in the PDF file. In structured documents, element tags become bookmarks.

•               Text flows used on body pages can become article threads in the PDF file.

•               The PDF file contains tagged PDF information if you select the Generate Tagged PDF option.

 

•               The PDF file can include document information such as the author name and keywords.

 

Related links:

Add links to URLs

Hypertext commands in HTML and PDF documents

Save structured documents as PDF

Tagged PDF

Add metadata to a document

13.3.2.            Create ditamap-to-book output

You can configure the generation of the output from a ditamap. Using the ditafm-output.ini file (at %APPDATA%\Adobe\FrameMaker\11), you can configure the various options for your output, such as:

•                

Type of output to generate (book with FM components or compound FM document)

 

•               Templates to use for chapter, section, subsection ToC, index, and front matter in the generated book

 

•               Chapter numbers, pagination, para numbers, footnotes, and table foot­note numbers

 

Configurable output formats

You can generate two configurable, unstructured outputs from a ditamap:

1)            

Composite Document 11.0: A Composite FrameMaker document is created based on the ditamap. The content from all the referenced Topics/Maps is collated to create a single FrameMaker document for output. The template for the generating FM document from the ditamap is configurable.

 

2)           Book 11.0 with FM components: You can save a ditamap as Book 11.0 with FM components. The Book 11.0 with FM components format has the same structure as the ditamap and includes numbering and pagination for better PDF layout. FrameMaker creates all the components of Book 11.0 with FM components in the folder you specify. You can also generate a flat book using the GenerateFlatBook option in the ditafm-output.ini file.

 

Save ditamap as a configurable output

With a ditamap in focus, do the following:

1)            

Select File > Save Ditamap As.

 

2)           In the Save Document, select one of the following:

 

a)           Composite Document 11.0

 

b)           Book 11.0 with fm components

 

3)           Click Save.

 

Configure the output

You configure the output using the ditafm-output.ini file at %APPDATA%\Adobe\FrameMaker\11. The main options in the file are:



	
 

Option

 


	
When set to 0

 


	
When set to 1

 





	
GenerateFlatBook

 


	
Creates a nested book from a ditamap retaining its structure, hierarchy, and levels.

 


	
Creates a flat book from a ditamap, where All topicrefs are flattened at the chapter level.





	
SavePDFViaBookRoute


	
Generates a compound .fm document and then a PDF

 


	
Generates a book and then PDF. Use this option if you need book components, such as index, ToC, and FrontMatter.





	
MapTableTitletoFMTableTitle


	
Does not repeat title of table when a table continues across multiple pages

 


	
Repeats title of table for multiple pages when the table breaks across multiple pages

 





	
MoveFigureTitleToFollowImage

 


	
The figure titles appear in the output book as they are in the ditamap.


	
Moves the figure title to below the image in the generated file. (In DITA, by default the figure titles are placed above the images).

 






Following are some other flags that control the output:



	
 

Flag

 


	
Description

 





	
OutputFilesOrder

 


	
Specify the order of the files in the output. Use the following values delimited with pipeline to specify the order: BookTitle|TOC|Files|ListofFigures|ListofTables|Index

 





	
TemplateImportFlags

 


	
Specify which all formats you want to import from the publishing template. Use the following values delimited by pipelines (th e order of the values is irrelevant): PGF|FONT|PAGE|TABLE|REFPAGE|XREF|COLOR

 





	
ChapterNumberingFirst

 


	
Use this flag for giving numbering options to the first chapter. Specify one of the following values: Restart, Continue, ReadFromFile, or UseSame.

 





	
ChapterNumberingDefault

 


	
Use this flag for giving numbering options to the chapters after the first chapter. Specify one of the following values: Restart, Continue, ReadFromFile, or UseSame.

 





	
SectionNumberingFirst

 


	
Use this flag for giving numbering options to the first section in the chapter. Specify one of the following values: Restart, Continue, ReadFromFile, or UseSame.

 





	
SectionNumberingDefault

 


	
Use this flag for giving numbering options to the sections after the first section. Specify one of the following values: Restart, Continue, ReadFromFile, or UseSame.

 





	
Pagination

 


	
Use this flag to specify pagination as single or double by specifying the values as DoubleSided or SingleSided. This flag exists for chapter, section, and subsection sections of the ini file.

 






13.3.3.            Publishing as PDF files

 You convert a FrameMaker document to PDF file by setting options in the PDF Setup dialog box, and then saving the document as PDF. You can also print the document to a PostScript file, and then convert it.

note:  When one Save As PDF operation is in progress, you cannot initiate another Save As PDF operation. If another Save As PDF operation is triggered using FrameMaker Developer Kit (FDK), the PDF is not generated.

Saving a book with .fm components

 

When you save an unstructured book with .fm components, FrameMaker silently opens and prints all the files to the PDF. The files are closed without saving any changes after printing the PDF.

 

Saving a book with .fm and .xml components

 

FrameMaker silently opens and updates the numbering for all .fm files in the book.

However, to update the numbering and cross-reference information in a .xml file, ensure that you open the file first. FrameMaker updates the numbering, prints the files to the PDF, and closes the files it opened without saving changes. When you close the .xml file, you are prompted to save changes.

Saving a book with child books

 

When you update the parent book, FrameMaker updates the numbering and cross-reference information in the files from the parent book. To update the numbering in the child book files, make sure that all child book files are open before you update the parent book.

FrameMaker updates the numbering, prints the files to the PDF, and closes the files it opened without saving changes. When you close the child book files, you are prompted to save changes.

FrameMaker does not include generated files, such as table of contents or indexes from the child books in the PDF for the parent book. This is because the generated files in the parent book contain all the information for the child book files as well.

ParentBook_Table_of_Contents
ParentBook_File_One
ParentBook_File_Two
   ChildBook_1_File_One
   ChildBook_1_File_Two
   ChildBook_2_File_One
   ChildBook_2_File_Two

 

Related links:

Create PostScript files

Generate and update books

Save a document or book as Adobe PDF

 

1)            

Open the document or book you want to save as Adobe PDF.

 

2)           To ensure that links work properly, open those book files that the docu­ment or book references.

 

3)           In the original document or book file, do one of the following:

 

•               Select File > Save As PDF. In the Save Document dialog box, click Save.

 

•               Select File > Save As (or File > Save Book As), and choose PDF from the pop-up menu. Replace the filename extension with .pdf. You can also change the save location and the filename. Then click Save.

4)           Click Set to generate PDF with the default settings in the PDF Setup dialog box. Otherwise, set additional options, and then click Set.

 

Save a set of interlinked books as PDF

1)            

Open all the books to convert to PDF.

 

2)           If the first book file, select File > Save Book As, and then choose PDF from the pop-up menu. Replace the filename extension with .pdf. You can also change the save location. Make the relative nesting of the converted PDF files the same as the nesting of the original book files. Then click Save.

3)           Set up bookmarks and article threading.

 

4)           Repeat the process for the other linked books.

 

Specify general settings

 

1)           In the PDF Setup dialog box, choose Settings from the pop-up menu, or click the Settings tab.

 

2)           Choose an option from the PDF joboptions pop-up menu for creating Adobe PDF files. The options include predefined settings plus any custom joboptions created in Adobe PDF Creation Add-On.

 

tip:  In a book, the joboptions saved with the first file are applied to all files in the book. To get the desired results in the exported PDF file, open the first file. Then choose Format > Document > PDF Setup, adjust the settings, and click Set.

3)           To start Acrobat and open the generated PDF file automatically, set View Generated PDF In Acrobat.

 

4)           Type an opening page number and choose a zoom level.

 

5)           Choose an option from the Registration Marks pop-up menu.

 

6)           Specify a default page size. (FrameMaker uses the unit of measure speci­fied using View > Options.)

 

7)           Specify the pages to convert to Adobe PDF. Convert all of the pages in the file, or specify a range of pages. Leave the End Page text box empty to create a range from the Start Page number to the end of the file.

 

note:  To ensure that the exported PDF file includes bookmarks, tags, and hypertext links, select All for the Page Range.

 

8)           Select Convert CMYK Colors To RGB to convert CMYK colors to RGB when FrameMaker prints and creates PDF files.

By default, FrameMaker converts CMYK colors to RGB when it prints and creates PDF files. To convert CMYK colors to sRGB, CalRGB, or another type of RGB, set this option. Also set the values in the Acrobat Distiller PDF joboptions file. If you deselect this option, FrameMaker preserves CMYK colors.

note:  The setting in the PDF joboptions file takes precedence over the option in the PDF Setup dialog box. So if your documents still print RGB, correct the settings in the PDF joboptions file.

 

The CMYK route has a few advantages over the RGB route in that it also provides support for spot colors. The RGB route does not support bigger page sizes but this is not a limitation in the CMYK route.

Set bookmarks

Bookmarks options define bookmark levels, create bookmarks from paragraph tags, and set up article threading.

1)            

In the PDF Setup dialog box, choose Bookmarks from the pop-up menu, or click the Bookmarks tab.

 

2)           Select Generate PDF Bookmarks.

 

3)           To specify at which level bookmarks appear expanded in the exported PDF, select an option from the Bookmarks Expanded through Level pop-up menu. You can type a value, such as 2, to specify that only the top two levels are expanded.

4)           To indicate which paragraphs to convert to PDF bookmarks, move para­graph tags between scroll lists. The paragraphs in the Include Paragraphs scroll list indicate bookmarks in the PDF file. To move a tag between scroll lists, select the tag and click an arrow or double-click the tag. To move all the tags from one scroll list to the other, Shift-click an arrow. To omit bookmarks, deselect Generate PDF Bookmarks.

 

5)           To change bookmark levels for the included paragraphs, select a para­graph tag and click a Bookmark Level arrow. To change the level of all items, Shift-click a Bookmark Level arrow. If the indent for a tag exceeds six levels, n> precedes the paragraph tag. n indicates the indentation level of the paragraph tag.

 

6)           To include paragraph tags along with the paragraph text in the book­marks, select Include Paragraph Tags in Bookmark Text. Use this option to check the assigned levels of bookmarks in a draft of the PDF file. (Dese­lect this option when you print the final draft of the document.)

 

7)           Set up article threading by doing one of the following:

 

•               To have the reading order of each article follow the same order that the insertion point moves, select Articles and choose Thread by Column from the pop-up menu. This setting is usually the most appropriate in multicolumn formats.

 

•               For a reading order of text frame to text frame, select Articles and choose Thread by Text Frame from the pop-up menu. This setting is usually the most appropriate in single-column formats.

 

•               To create no article threads, deselect Articles.

 

important:  In case of hierarchical books, ensure that the first or the last file in the parent and its child books are not common files. If you include the same file from the same folder in the child and the parent book, specifically as the first or last component, bookmarks are not generated in the PDF.

Adding links from other documents

When you save a document as a PDF file, you can use named destinations to identify paragraphs that cross-references and hypertext links reference. To add links to the document from other documents after you create the PDF files, select this option. Selecting this option increases the size of the PDF file.

If this setting is deselected and you add a link or cross-reference from one FrameMaker document to another, resave both documents as PDF.

note:  For documents created with a version of FrameMaker earlier than 6.0, optimize the PDF file size to take advantage of this option.

 

Add links from other documents after creating a PDF file

 

1)           In the PDF Setup dialog box, choose Links from the pop-up menu, or click the Links tab.

 

2)           Select Create Named Destinations for All Paragraphs.

 

PDF joboptions

In addition to the standard PDF joboptions that are added when you installed FrameMaker, you can create and share your own settings. To ensure consistent navigation, bookmarks, and page layout, ensure that you create and use the same joboptions across your team. You can save the joboptions to your file system, and then send it to others in your team.

 

For documents created with older versions of FrameMaker and older Distiller joboptions, selecting File > Save As PDF sometimes results in an alert stating that the specified PDF or Distiller joboptions file doesn’t exist.

About the Adobe PDF printer

If you have Adobe PDF Creation Add-On installed, you can still convert docu­ments to PDF by creating a PostScript file and then distilling that file yourself. The name of the printer you use to create PostScript files is Adobe PDF.

13.3.4.            Reduce PDF file size

You can control PDF file size in the following ways:

•                

Deselect the Create Named Destinations for All Paragraphs option on the Links page of the PDF Setup dialog box.

 

•               To control font embedding, create or modify a joboptions file. Select Adobe PDF Creation Add-On in the Settings page of the PDF Setup dialog box.

•               To control font embedding, you can create or modify a joboptions file using Adobe PDF Creation Add-On and then select it in the Settings page of the PDF Setup dialog box.

•               Select Optimize when saving a PDF file.

13.3.5.            Optimize files created in previous FrameMaker versions

You can create named destinations only for paragraphs referenced in hypertext links or cross-references, thereby reducing file size. However, documents created in versions of FrameMaker earlier than 6.0 undergo a special conversion to take advantage of this method of marking.

The Options command changes the default optimization options, which remain in effect until you change them, even if you exit and restart FrameMaker. The Optimize File command uses the settings specified in the Optimization Options dialog box to prepare your documents for reducing PDF file size.

Set optimization options

1)            

Choose Format > Document > Optimize PDF Size > Options.

 

2)           Do the following:

 

•               Specify whether to optimize the size of all linked documents, or the specified document only.

 

•               For a previously optimized document, select Force Optimization to reoptimize. If this option is selected, also select Clear Existing Opti­mization Info to remove previous optimization changes.

 

•               To display a prompt to open linked files, select Prompt When Opening.

 

•               To display a prompt to save a linked document opened for optimi­zation, select Prompt When Saving. If selected, specify whether to display a prompt to appear for each file you save, or only for previ­ously optimized files.

 

•               Specify whether to overwrite existing files (recommended), or to write files to a directory you specify (for testing) when you click Browse.

 

•               To stop optimization in case of an error, select Cancel On Error.

 

3)           Click Set.

 

Optimize documents for PDF file size

1)            

Choose Format > Document > Optimize PDF Size > Optimize File.

 

2)           Select the document or book you want to optimize and click Select.

 

13.3.6.            Conversion settings

 

Specify PDF-conversion settings without saving as PDF

Sometimes you want to import PDF-conversion settings to other documents, before conversion.

1)            

Make the appropriate document window or book window active. If a book window is active, select the documents to affect. You can also select the book icon if you want the Document Information changes to affect the book.

 

2)           Choose Format > Document > PDF Setup, specify the settings, and then click Set.

 

Import PDF-conversion settings

You can import all the settings in the PDF Setup dialog box from one document to another.

1)            

In a document or book with selected files, choose File > Import > Formats and select Document Properties and Paragraph Formats.

 

Related links:

Import formats from a template or document

13.3.7.            Disable embedding Adobe Flash, 3D, and multimedia objects in PDF

By default, FrameMaker embeds FLA files, 3D objects, and multimedia objects in PDFs. When embedded, these objects are embedded as a bitmap image in the PDF. You can open the PDF, locate the image, and then click the image to play the object. To ensure that the Adobe Flash, 3D, or multimedia files play in the PDF created, select these options.

1)            

Select File > Preferences > General.

 

2)           Do the following, as needed, and then click Set.

 

•               Clear the Embed Adobe Flash Files In PDF option.

•               Clear the Embed 3D Objects In PDF option.

•               Clear the Embed Multimedia Objects In PDF option.

 

13.3.8.            Tagged PDF

 

About tagged Adobe PDF

The tagged PDF feature creates Adobe PDF files from FrameMaker with logical document structure and extensive metadata for repurposing content. Logical structure refers to the organization of the document, such as the title page, chap­ters, sections, and subsections.

Tagged Adobe PDF provides the following capabilities:

•                

Ensures that information is in the correct reading order on a page.

 

•               Includes paragraph attributes used to correctly reflow the document contents into different-sized devices, such as eBook reading devices.

 

•               Ensures the reliable translation of text into Unicode. This approach recog­nizes ligatures and hyphens, so that a Windows screen reader can correctly read all characters and words.

 

•               Recognizes alternative text descriptions for graphics in anchored frames.

 

•               Enables the document to be exported more reliably to Rich Text Format (RTF) and XML from Acrobat 7.0 for reuse in other documents.

 

Tagged Adobe PDF files include author content, such as pages, articles, para­graphs, tables, and graphics in anchored frames. Tagged PDF files do not include the following information found in standard PDF files:

•                

Comments, such as online notes, graphic markups, and text markups.

 

•               Pagination artifacts, including all content that comes from master pages (such as page numbers and running headers), and any graphic objects outside anchored frames.

 

•               Layout and typographic artifacts, such as colored bars between columns of text, horizontal lines separating footnotes from text, and table borders.

•               Printing artifacts, such as crop marks, registration marks, and page infor­mation printed outside the crop marks.

 

Generating a tagged PDF file

The Generate Tagged PDF option works only if you’re using Acrobat Distiller 5.05 or later.

1)            

In the PDF Setup dialog box, choose Tags from the pop-up menu, or click the Tags tab.

 

2)           Make sure that Generate Tagged PDF is selected.

 

3)           Set up the paragraph structure level by doing the following:

 

•               To change structure levels for the included paragraphs, select a para­graph tag and click a Logical Structure Level arrow. To change the level of all items by one level, Shift-click a Logical Structure Level arrow. If the indent for a tag exceeds six levels, n> precedes the para­graph tag, where n is the indentation level of the paragraph tag.

 

•               To indicate the paragraphs to include in the PDF structure, move paragraph tags between scroll lists. The paragraphs in the Include Paragraphs scroll list are used to define the structural relationship between FrameMaker paragraph tags in the PDF file. To move a tag between scroll lists, select the tag and click an arrow or double-click the tag.

 

4)           Click Set.

 

13.3.9.            Troubleshooting PDF conversion

Follow these guidelines to ensure valid conversion to PDF:

•                

For the best display of bitmap graphics, import them into the FrameMaker document at a dpi value that divides evenly into the resolution of the intended display device.

•               To improve the display performance of PDF files, avoid using complex master pages that contain multiple complex graphics. You can also improve graphics display and reduce file size by selecting Optimize when saving a PDF file in Acrobat.

 

•               To convert a book that has a table of contents or an index, include the TOC or index file in the book file before you save as PDF.

 

•               If performance is slow when viewing a large document converted to PDF, reopen the FrameMaker document or book and deselect Articles. Then convert to PDF again.

 

•               To print a book as separate files, all PDF files are created in the same folder, regardless of the location of the original documents. For this reason, give all the original documents in the separate folders unique names before saving as PDF. Otherwise, some files overwrite others.

 

•               For documents created with a FrameMaker version earlier than 6.0, opti­mize the document to reduce file size.

 

•               Don’t remove the Adobe PDF Creation Add-On printer instance. It is used to create PDF files from FrameMaker documents.

 

•               Set the output format of the PostScript driver to Optimize for Portability.

•               Do not create hypertext links to filenames that use accented characters in their names. Such filenames can change when you save as PDF, causing the hypertext links to fail.

 

•               To include graphic content in tagged Adobe PDF files, place graphic objects in anchored frames. Add alternate text descriptions for the graphics.

 

Related links:

Add object attributes for tagged PDF

13.3.10.       Save structured documents as PDF

The procedures for saving structured documents as Adobe PDF are the same as for unstructured documents, except for setting bookmarks. In structured docu­ments, you create bookmarks from element tags, rather than from paragraph tags.

important:  Tagged PDF is based on paragraph format tags. Each tag is mapped to an element in the PDF structure. A FrameMaker structured document doesn’t retain the structure when exported to Tagged PDF. The paragraph levels in the Tags panel of the PDF Setup dialog determine the relative structure level of the PDF file.

1)            

Open the document or book to save as PDF.

 

2)           Open the book files that the original document or book references.

 

3)           In the original document or book file, choose File > Save As (or File > Save Book As), and choose PDF from the pop-up menu. Replace the filename extension with .pdf. You can also change the location and the filename. Then click Save.

 

4)           In the PDF Setup dialog box, choose Bookmarks from the pop-up menu, or click the Bookmarks tab.

 

5)           Select Generate PDF Bookmarks.

 

6)           To specify at which level bookmarks appear expanded in the exported PDF, select an option from the Bookmarks Expanded through Level pop-up menu. You can type a value, such as 2, to specify only the top two levels expanded.

 

7)           Choose Elements from the Bookmark Source pop-up menu.

 

8)           Indicate which elements to convert to PDF bookmarks by moving element tags to the Include scroll list. To omit bookmarks, deselect Generate PDF Bookmarks.

 

Some element tags have context labels that provide information about the element location in the structure. For example, if Section elements can be nested within other Section elements, context labels can identify whether the elements are first-, second-, or third-level sections.

 

Context labels

[image: op_31.png]

 

If an element uses context labels, a <no value> entry also appears in the scroll list for occurrences not described by the labels.

 

9)           To include element tags along with text in the bookmarks, select Include Element Tags In Bookmark Text. Use this option to check the levels of bookmarks in a draft of the PDF file. Deselect this option when you print the final draft.

 

10)       Click Set.

 

13.4.             Authoring for accessibility

Whether you’re publishing a document in HTML, Adobe PDF, or some other format, creating accessible documents requires much more than simply repre­senting the original document accurately. Sighted people can look at a printed page and easily discern the difference between titles, subtitles, columns of text, headers, footers, and so on. Visual clues, such as location of the text on the page, bold text, and large font sizes help them determine the structure of a document so that they can read and navigate it easily.

 

Assistive technologies, such as screen readers can’t depend on these visual clues. Instead, they rely on the underlying computer-based information to provide that same structure. As a result, making documents accessible depends on two things:

•                

Authoring the original documents so that they contain not just content (such as the text in the document) but also information about the struc­ture of the content (such as how the text flows within the page and from page to page).

 

•               Using publishing tools such as Adobe FrameMaker software and Adobe PDF technology that can retain and encode both the content and the structure so that they can be interpreted by Windows-based screen readers.

 

These same requirements apply to any type of publishing environment, regard­less of the file format or application. If you want to make it possible for people with screen readers to navigate documents correctly, the underlying structural information must be present.

13.4.1.            Preparing documents for accessibility

Both FrameMaker documents and tagged Adobe PDF documents can be read by screen readers on Windows.

To make an accessible FrameMaker document or tagged PDF document using FrameMaker, you must create the document with accessibility in mind. Here are some things to consider to optimize your FrameMaker documents for acces­sibility, and Help screen reader applications use them:

Logical reading order

 

Documents are more accessible if they have been authored with a logical structure in mind. Using FrameMaker to define and create document structure, such as titles, chapters, headings, and multicolumn text, can make it easier for assistive technologies, such as screen readers to under­stand the logical reading order of the content without any ambiguity. For example, if a tagged Adobe PDF document has been correctly authored using two columns to create a two-column format, the screen reader will read all the way down the first column and then proceed to the second column. On the other hand, if the writer used tabs to imitate the look of two-column text, the screen reader would not recognize the layout as two-column. Instead, it would simply read horizontally, going from the first line in the first column and then tabbing over to the first line in the second column.

 

The order in which you create frames in the original FrameMaker docu­ment is the order that is represented in the logical structure tree of your tagged Adobe PDF file. Therefore, if you move frames in the FrameMaker layout, the structure of your tagged Adobe PDF file will still show frames in the order created. To correct reading order problems, you can use tools in Acrobat 7.0.

 

note:  Screen readers may not be able to correctly read multicolumn text if it is viewed in FrameMaker. If you want your FrameMaker documents to be read by screen readers using FrameMaker, use single-column formatting. Otherwise, save the document as tagged PDF.

 

Alternate text descriptions for graphic objects

 

The document should contain written descriptions of graphic objects in the document, including drop caps. These graphic objects must be in anchored frames. When a screen reader encounters the graphic in the document, it will read the alternate text. Make sure that you use text that makes sense when read out of context. For example, you might want to add alternative text that begins with “A graphic depicting” and then describe what the graphic depicts. For more information about adding alternate text, see Add object attributes for tagged PDF.

 

Fonts

 

Be sure to use fonts that specify character encoding, so that the display and screen reader deliver the correct characters. For more information, see the online manual FrameMaker Character Sets. 

Navigation

 

The document should include navigational and organization aids, such as a table of contents and useful headings. This provides an easy way for users to move through the document so that they don’t have to read the entire document page by page to find what they’re looking for.

 

13.4.2.            Test accessibility in files using a screen reader

Before making a FrameMaker file or tagged PDF file available for other users, test the file using a screen reader. This will show you how the information in the document will actually be presented to users, and how well such things as the reading order and navigational links will work.

If you encounter errors in a tagged PDF file, make corrections, where possible, in the original FrameMaker file, and then resave it as tagged PDF. That way you maintain a single source file for publishing the content in additional formats, such as XML, SGML, XHTML, and so on.

If you have Acrobat installed, you can also use Acrobat tools to adjust the tagged PDF structure and the reading order. In this case, however, your changes will be saved only in the PDF file, not in the FrameMaker file. For more information on accessibility tools in Acrobat, see the Acrobat online Help or the Adobe website.

 

1)            

Start a screen reader for Windows. See the Install ReadMe file for supported screen readers.

 

2)           Do any of the following, depending on whether you’re reading a FrameMaker file or tagged PDF file:

 

•               Start FrameMaker and open the FrameMaker file in it.

 

•               Start Acrobat and open the tagged Adobe PDF file in it.

 

3)           Use the screen reader to read the document.

4)           Check for problems, including the following:

 

•               The document contains graphics, but there are no text descriptions for those graphics. To solve this problem, open the original docu­ment in FrameMaker and make sure that the graphics are in anchored frames. Then select each graphic, choose Graphics > Object Properties > Object Attributes, and add alternate text descriptions.

 

•               Text in columns isn’t read in the correct order. To solve this problem, touch up the reading order of elements in the logical struc­ture tree of your tagged Adobe PDF file using the Tags panel in Acrobat.

 

13.5.             Generating print output

 

13.5.1.            Preparing color documents for output

 

Preparing color documents for commercial printing

You can print each page of a document as a series of color separations. Color separating splits color images into several pages. Each page contains one component color. A commercial printer uses the separations to make printing plates, one for each color.

You can also print mirror and negative images, which is sometimes required when commercially printing to film.

If color objects overlap in your document, you can overprint. Overprinting prints an object (most often a dark one) on top of another color object. You can also create a knockout, in which the top color is printed but colors behind it are not. You can use trapping to ensure that no gap exists between objects.

Print color separations

When you print color separations, choose which colors to print as spot colors, which to print as process colors, and which not to print at all. Text and graphic objects are printed in black for each separation, with shades of gray indicating the percentages of color saturation. The color name of each separation is printed outside the registration marks (if registration marks are on and if there’s room on the page).

note:  For best results, print CMYK colors as process rather than spot-color inks. You can check plate assignments in the Separations Setup dialog box (File > Print and click Separations Setup).
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 A.

Composite image

 B.

Black separation

 C.

Spot color separation

Imported color graphics are separated if they are in CMYK, TIFF, DCS, or EPS line art format. Also, bitmap images in EPS graphics can be separated as long as they can also be separated in Adobe Illustrator.

You can also separate a document by printing to a single PostScript file and then having a commercial printer separate the file for you.

Make sure that spot colors with identical definitions have the same names. Spot colors with the same definition but with different names appear on different plates when you print color separations.

Process color separations are printed using grids of black dots for each color—the larger the dots, the more color is printed. The halftone screen settings control how close together the dots appear, the orientation of the grid (the screen angle), and the dot shape. For information, consult your printer documentation and your commercial printer.

 

Creating color separations

 

1)           Make sure that you have not set colors to print as black and white instead of shades of gray.

 

2)           Choose File > Print.

3)           Choose an option from the Registration Marks pop-up menu.

4)           To print all pages for one plate and then all pages for the next plate, dese­lect Collate. Select Collate to print all plates for one page before printing all plates for the next page, and so on.

 

5)           Click Separations Setup. If necessary, move the color names to the appro­priate scroll lists and click Set. To move a color, double-click the color. To move all colors, select a color in the list and Shift-click an arrow.

Tints do not appear in this dialog box; they print on the same plate as the base color.

 

If your printer can’t print process color separations, the dialog box contains only the Print As Spot and Don’t Print scroll lists. The scroll list where each color appears by default depends on how the color was defined on its Print As setting.

 

6)           To specify halftone screen settings, click Halftone Screens, adjust the settings, and then click Set.

 

7)           In the Print dialog box, select Print Separations, set the remaining print options as necessary, and then click Print.

 

Knock out and overprint colors

When one color object overlaps another, FrameMaker normally knocks out the overlapped portion so that it does not print in a color separation. It appears as the color of the paper. If you’re producing color separations and printing commercially, registration errors sometimes occur, and small gaps between colors appear.

Accurate and inaccurate registration
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To avoid gaps between colors, you can apply overprinting to the top object so that the overlapped portion is not knocked out.

Knocked out (left) and overprinted (right)

[image: op_knockout_overprint.png]

You can also use overprinting to combine two colors for special effects.
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Knock out or overprint all objects of a particular color

1)            

Define a color.

 

2)           To make this color print on top of other colors when printing separations, do one of the following:

 

•               To have any object that uses this color overprint, choose Overprint.

 

•               To have any object that uses this color knock out, choose Knock Out.

 

Apply knock out or overprint to objects

1)            

Select the object and open the Tools palette or choose Graphics > Object Properties.

 

2)           Choose one of the following from the Overprint pop-up menu:

 

•               To have this object overprint objects beneath it, choose Overprint.

 

•               To have this object knock out objects beneath it, choose Knock Out from.

 

•               To have this object use the overprint setting defined for the color, choose From Color. This option is the recommended setting.

 

Overprinting images created in other applications

If you want images created in other applications to overprint other objects when printed from FrameMaker, note these special cases:

 

•               CMYK TIFF files overprint objects on spot color plates under all of the following conditions: if printed as separations, if their Overprint attribute is set to True, and if their Fill property is set to None.

 

•               EPS files do not overprint other objects when printed as separations.

 

Print negative and mirror images

Your commercial printer sometimes asks you to print negative images in which all text and objects are inverted when you submit printing files on film. Some­times you print flipped images with the emulsion side down. Emulsion is the photosensitive substance on the film surface. These flipped images mirror the normal appearance of the pages.

note:  Sometimes the settings differ depending on the printer driver you’re using, and are unavailable with non-PostScript printer drivers.

1)            

Choose File > Print Setup. Click Properties to access the printer driver options. Locate and set the options that control negative and mirror images.

 

Trap objects

In commercial printing, overprinting to compensate for registration errors sometimes produces unacceptable color mixing. In this case, perhaps you trap the object instead of overprinting it. A trap is a line bordering the object on top. It is wide enough to fill the color gap and to overprint the other object along the border of its cutout.

Without trapping and with trapping
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Having a commercial printer trap your documents saves you the effort of hand-trapping each object individually. Also, manual trapping sometimes must be undone if you later decide to have a commercial printer do the trapping.

1)            

Create a border for the object on top by duplicating the object and setting the duplicate fill pattern to None. Be sure that the duplicated object is exactly over the original.

 

2)           Set the line width of the border as appropriate. Consider the size and contour of the object, the type of printing paper, and the accuracy of the printing press. Consult your commercial printer for information on suit­able line widths for trapping.

The stroke of a line is always centered on an object edge. Therefore, double the line width specification that the commercial printer gives you.

 

3)           Select the border and choose Overprint from the Tools palette.

 

Processing color documents using OPI

You can have a document color separated, or have all objects in a document or book trapped by printing to a PostScript file. Then have a commercial printer process the PostScript file for you. Creating a PostScript file in this way embeds instructions in the file. These instructions conform to the Adobe Document Structuring Convention (DSC). DSC enhances the performance of postpro­cessing products that perform trapping and imposition. DSC also lets you take full advantage of products that support Open Prepress Interface (OPI) version 1.3. OPI reduces the hardware overhead for working with high-resolution color images.

OPI-enhanced PostScript files contain information that the commercial printer software uses to match the placeholder images with the high-resolution ones at print time.

note:  Before beginning, ask your commercial printer for any special instructions for producing PostScript files.

1)            

Ask your service bureau or commercial printer to make high-quality scans of your artwork and keep the high-resolution images. You take the OPI-ready low resolution EPS or TIFF versions of the images to work with.

 

2)           Import (by reference or by copying) the low resolution images into your document.

 

3)           Create a print file, or a series of print files for a book.

 

Printing to Linotronic typesetters

Here are some tips for printing to Linotronic typesetters:

•                

Some Linotronic typesetters automatically place registration marks on the page. Check with your service bureau to see whether to use the Registra­tion Marks setting when you print.

 

•               Not all Linotronic models support thumbnails. Test various thumbnail settings to find the optimum setting. Some Linotronic models print 1 x 2 thumbnails correctly, but not 2 x 2 thumbnails.

 

•               Some Linotronic drivers fail to let you enter a custom paper size even after you have chosen User Defined Size in the Paper Size pop-up menu. To enter a custom paper size, right-click the Linotronic driver and choose Properties. Click the Paper tab, and then select the custom paper size icon from the scroll list of icons.

13.5.2.            Print documents

   

When you print a document, you can specify options such as how many copies to print and whether to print crop marks and registration marks. The available options vary slightly with the platform and the printer you are using. You can also print a book made up of several documents.

When you’re working with structured documents, element boundaries, either as brackets or as tags, are printable characters. If you’re showing these bound­aries in the document window, you can hide them before you print.

If you have turned off graphics in the View Options dialog box, graphics will not appear in the printed document.

The printing feature supports the Unicode text encoding standard.

note:  For PostScript printing, use a PostScript Level 2 or higher output device and make sure that you use a print driver and PPD for such a device.

Related links:

View element boundaries in the document window

Print a book file

Preparing color documents for output

Print to a desktop printer

You can print each page of a document as a composite. A composite page contains all the colors that are used on the page. You print a composite color document when printing to a desktop color printer.

1)            

Choose File > Print.

 

2)           Specify the page range that you want to print.

 

3)           Make sure that Print Separations is unselected.

 

4)           Set the remaining print options as necessary and click Print.

 

Print options

The following print options are available for all printers. All these options are in the Print dialog box. For information on additional options available for your printer, see your printer documentation.

note:  FrameMaker products for Windows have no control over the abilities or limitations of any printer driver. FrameMaker products can only support printer drivers that have been approved for use in the version of Windows FrameMaker is running on. If you are using an outdated printer driver, you may experience problems, such as lost graphics and characters and the inability to open docu­ments. See the Adobe website for information on installing the latest PostScript drivers.

Collating

 

To print one complete copy before printing the next copy, select Collate when you’re printing multiple copies. Printing might be slower when Collate is selected.

Printing double-sided

 

To print a double-sided document when you’re not using a duplex printer, print the odd-numbered pages, turn the paper over in the printer, and print the even-numbered pages. Depending on how your printer produces pages, you may need to select Last Sheet First before you click Print, because turning the paper over in the printer may reverse the page order.

 

Changing page order

 

To print a document starting with the last page, select Last Sheet First.

 

Printing more quickly

 

To print a document more quickly, select Low-Resolution Images. The imported images are printed as gray boxes.

Printing crop marks and registration marks

 

To print a document with crop marks and registration marks, choose an option from the Registration Marks pop-up menu. In some instances, you may want to scale down the printed page image so that crop marks and registration marks will fit on the page.

 

You can choose between Western and Tombo (Japanese) crop marks.

 

Western and Tombo crop marks
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Reducing or enlarging the page image

 

To print a reduced or enlarged page image centered on the page, enter a percentage in the Scale box.

 

Printing thumbnails

 

To print thumbnails (small images of several pages on one page), enter values in the Thumbnails text boxes. In the Rows box, enter the number of thumbnails you want to print down the page. In the Cols box, enter the number of thumbnails you want to print across the page.

Skipping blank pages

 

To prevent printing blank pages, select Skip Blank Pages.

 

Printing colors in black and white

 

To ensure that colored items (FrameMaker drawn images and text) are printed in black and white rather than in shades of gray, select Spot Color As Black/White.

 

Feeding paper manually

 

To print the document on paper that is not in your printer’s paper cassette, choose File > Print Setup. Choose Manual Feed from the Source pop-up menu, and click OK.

 

note:  The Print Document dialog box in FrameMaker contains some options that may also appear in the Windows printer Properties dialog box, such as the number of copies. When you print a document, FrameMaker printer settings override Windows printer settings.

 

Create PostScript files

You can create a description of a document called a PostScript file (also called a print file). You can use a PostScript file to download the document later to a PostScript printer or to send the document to a service provider for typesetting. In addition, you can create an Adobe PDF file.

Related links:

Disable embedding Adobe Flash, 3D, and multimedia objects in PDF

Adobe PDF

Create a single print file from a document

1)            

Choose File > Print.

 

2)           Select Print to File and enter the path and filename in the box, or click Browse to specify a folder and filename.

 

tip:  You can enter a .ps extension for your PostScript file. 

Create a single print file for a book

1)            

In the book window, choose File > Print Book, or select the documents you want to print and choose File > Print Selected Files.

 

2)           Select Print to File and enter the path and filename in the box, or click Browse to specify a folder and filename. Choose Single File from the Save Book As (or Save Selected Files As) pop-up menu. Then click Print.

 

Create a series of separate print files for a book

1)            

In the book window, choose File > Print Book, or select the documents you want to print and choose File > Print Selected Files.

 

2)           Select Print to File and enter the path and filename in the box, or click Browse to select a folder and type a filename. Choose Single File or Sepa­rate File for Each Document from the Save Book As or Save Selected Files As pop-up menu. Then click Print.

 

13.6.             Generating HTML

FrameMaker allows you to save the book and FM files as HTML files. You can define the conversion and pagination settings in FrameMaker, and then save the entire book or a document as HTML. The HTML output thus created can be navigated through the links created from the source document.

 

If you are publishing the content authored into online Help formats other than HTML, such as WebHelp or Adobe AIR-based Help, you can use RoboHelp as the publishing tool. In addition, for enterprise-level publishing, you can use FrameMaker Server to publish content in multiple channels and on devices.

13.6.1.            Preparing documents for conversion to HTML

 

About HTML documents

HTML provides a set of elements that describe how each part of a document is used. For example, the P (paragraph) element is a normal body paragraph; the H1 element is a first-level heading.

HTML elements are conceptually similar to Adobe FrameMaker formats. For example, HTML documents contain body paragraph elements and heading elements, while FrameMaker documents contain paragraphs that use formats designed for body paragraphs and headings.

However, HTML elements differ from FrameMaker formats in the following ways:

•                

HTML documents use a standard set of elements, while FrameMaker documents can contain any number of formats and use any names for the formats.

 

•               HTML elements describe the structure of a document, not its format. A Web browser such as Netscape Navigator or Microsoft Internet Explorer displays each element in a predefined format. Two browsers may display the same element in different ways.

 

HTML documents can contain hypertext links to locations in the same file, or to other files anywhere on the Internet or on an intranet. Most of the FrameMaker hypertext commands are automatically converted to HTML hypertext commands when you save a document as HTML.

Related links:

Hypertext commands in HTML and PDF documents

HTML conversion overview

HTML is an online format optimized only for certain kinds of presentation. For example, you can’t easily create a two-column layout in HTML. For this reason, don’t expect your HTML documents to look identical to the FrameMaker orig­inals. If design items in your documents have no acceptable equivalents in HTML, consider converting to PDF instead of HTML. For information, see Adobe PDF.

 

What is converted

 

When you save a document as HTML, FrameMaker converts only the contents of the main text flow (the flow tagged A). Make sure the text in flow A is the one you want and that all of flow A is connected. (See Connect text frames.)

 

tip:  If your document has multiple flows that you want preserved, consider saving as PDF instead. (See Publishing as PDF files.) When you save as PDF, each flow can be converted to an Acrobat article thread. 

The contents of anchored frames in the flow are converted to graphics (including the text within anchored frames). Graphics and text not in the main flow—whether they appear on master pages (such as headers and footers) or directly on body pages (such as graphics placed directly on the page)—are not converted to HTML. If you want to duplicate the effect of headers so that text or graphics appear at the top of every HTML document (for example, text for a logo or navigation buttons), use macros.

 

Some FrameMaker hypertext commands convert to equivalent HTML links.

HTML export issues

 

When you export to HTML, note the following issues:

 

•               Vector graphics and text frames in anchored frames are converted to bitmaps. If the text in the converted graphic is greeked, you can change the Greek Text Smaller Than setting in the Preferences dialog box.

 

•               If you scale or crop GIF graphics that have been imported by reference, these settings will be lost when converted to HTML.

 

•               HTML files produced by FrameMaker do not display line breaks when opened in Notepad. To view the HTML file correctly, use FrameMaker, WordPad, or a browser that lets you view the source code.

 

•               If the document uses paragraph or character tag names that contain accented characters, you may have problems viewing the characters with some browsers. To avoid this problem, rename paragraph or character tags to use unaccented characters, or delete the cascading style sheet (.css) file that was created with the HTML file.

 

Using templates that map well to HTML

 

To minimize fine-tuning when you save documents as HTML, create your documents from one of the supplied FrameMaker templates. The formats of these templates map easily to HTML equivalents.

Sample chapter template before and after HTML conversion
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Using web-safe colors

 

The Online color library provides 216 “web-safe” colors that have a consistent appearance on all platforms when viewed with a web browser.

Related links:

Hypertext commands

Using color in text and objects

Preserve the FrameMaker look by using style sheets

HTML was designed not as a formatting language but as a way of presenting the structure of a document (its semantics). In some cases, however, you may be concerned with the format of a document as well as its semantics. You may want to preserve the look of your FrameMaker document more than is possible with regular HTML elements alone.

For example, suppose you have a document that uses blue 20-point type for the first letter of a chapter. An HTML style sheet can preserve unique formatting of this kind.

An HTML cascading style sheet is created for you with the same name as the main HTML file but with an extension of .css. It is a standardized file format that many Web browsers can use and interpret. A .css style sheet contains formatting specifications that can duplicate the font, style, size, indents, spacing, and margins of the original document.

The HTML file contains a reference to a .css style sheet. If the browser finds the style sheet, it uses the information to format the Web page. If the browser doesn’t support style sheets, it uses only the built-in formatting defined for each HTML element.

1)            

Save your document as HTML. A .css file is automatically created in the same folder as the HTML file.

 

2)           Copy the HTML style sheet (.css file) to the Web server in the same folder as your HTML files.

 

note:  Style sheets are sometimes called “cascading” because their format rules can overlap—and collide—with rules in other style sheets, such as a personal style sheet set up by someone viewing your converted document. The style sheet that FrameMaker creates takes precedence over other style sheets.

Related links:

Saving structured documents as HTML

Format overrides

 

Changes tracked as format overrides

 

FrameMaker treats changes in text, character, and table properties that differ from the definitions as overrides. In addition, if the current document does not have a definition of the format, it is considered an override, such as when you copy and paste text from other documents.

The following cases are considered override:

 

•               When you apply formatting using the toolbar—such as applying bold, underline, or italics

 

•               When you edit the paragraph, character, or table format in the Designer and then applying only to the selection, without updating the format defi­nition

 

•               When you copy content from another document with a different template, the content copied retains the formatting, but the definitions are not present in the current document.

 

For example, consider a character format named Error, with text color as Red and Weight as As Is. If you change the text color from Red to Black, then it is an override. However, if Weight is change from Regular to Bold, it is not an over­ride (no deviation from definition). However, if a format that had a property set as As Is is changed, it is not tracked as an override.

 

note:  If properties of table cells are changed from Table > Format > Custom Ruling and Shading, then it is not flagged as a table format override.

Managing format overrides for content conversion

 

Accurate conversion depends on the consistent use of formats in your FrameMaker documents. Results will not be as good if your documents use format overrides instead of defined formats stored in the catalogs. For example, a document that uses a Body format for both regular paragraphs and headings will not convert to HTML accurately. If your documents use overrides exten­sively, you should do one of the following:

 

Search and remove format overrides

 

You can search and remove paragraph, character, and table format overrides in a book or document.

1)           Select Edit > Find, and from the Find pop-up menu, select the format override type.

 

2)           In the Change pop-up menu, select Remove Override.

 

3)           Click Find, and then click Change for each instance of the format override.

 

Create and apply a new set of formats based on the overrides

 

You can let FrameMaker automatically analyze the document for format over­rides, and create new formats. Any format used in the document but not stored in a catalog is added to the catalog. Also, if the document uses a format with a format override, a separate format based on the override is added to the catalog.

 

For example, if a document contains a Body paragraph with an override (for example, a left indent), that paragraph will be tagged Body1. If another override is used for Body (for example, a default font change), any paragraph using that override will be tagged Body2. You may want to rename some formats to make them easier to interpret. For example, you could rename Body1 to BodyIndent.

 

1)           Choose File > Utilities > Create And Apply Formats, and then click Continue.

note:  Avoid using this approach if you are using the Technical Communication Suite workflow to publish online Help formats from FrameMaker. You will be required to map all these styles.

 

Add links to URLs

A uniform resource locator (URL) is the location of a document anywhere on the Internet or on an intranet. You can embed a special marker in a FrameMaker document that becomes a link to a URL when the document is saved as HTML or PDF.

1)           Select the text you want to be linked to a URL and apply a character format to it. For example, you might apply an underline format to the words “Click here for more information.”

2)           Click in the formatted area, and choose Special > Hypertext.

 

3)           Choose Message Client from the Command pop-up menu and enter the following in the Syntax text box:

 

message URL url_name 

Replace url_name with the URL you want to link to. For example, to link to the Adobe Systems home page, you would enter the following:

message URL http://www.adobe.com 

4)           Click New Hypertext Marker. When the document is converted to HTML, XML, or PDF, clicking the formatted text displays the location specified by the URL.

 

Related links:

Set up hypertext active areas

Create links that simulate a TOC

You can convert a large file into a series of small HTML subdocuments that are linked to one parent document. The parent document can then function as a linked table of contents for the subdocuments.

FrameMaker document and the simulated TOC in a Web page
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Subdocuments are automatically named sequentially. For example, when you save MyDoc to HTML, the parent document is called MyDoc.html, the first subdocument is MyDoc.1.html, the second one is MyDoc.2.html, and so on. Don’t rename the files; otherwise, the links will become invalid.

The hierarchy of heading levels in the subdocuments is controlled by the Head­ings table.

1)            

Adjust your document’s mappings so that a heading starts a new file. Do this by using the Start New, Linked Web Page option in the HTML Setup dialog box.

note:  Look for a heading whose contents are neither too large nor too small. (Readers might get lost if they have to do too much scrolling or might be frus­trated if the page they jump to has only one paragraph.) Also, you may want to make sure some text appears before the first instance of the heading you choose so that there’s an introduction to the list of links.

 

2)           Give readers an easy way to return from the linked subdocuments to the parent document by defining the EndOfSubDoc or StartOfSubDoc system macro. The text or graphics defined by this macro will appear at the end or the start of each linked Web page as in the following example.

 



	
Macro Name


	
Replace With

 





	
EndOfSubDoc

 


	
<HR><P><A HREF=”<$parentdoc>”> Return to main page</A></P> <P><A HREF=”<$prevsubdoc>”> Go to previous page</A></P> <P><A HREF=

”<$nextsubdoc>”> Go to next page</A></P>

 






3)           Save the file or book as HTML. The parent document will contain the linked table of contents.

 

Related links:

Set up and adjust HTML mappings

Setting up links for image maps

Image maps on a Web page are graphics with areas defined as links. Image maps can add visual interest to otherwise plain text-only links to Web pages.

When you convert a FrameMaker document to HTML or XML, graphics in the main text flow are automatically converted to image maps if you have set them up correctly. They convert in these cases:

•                

When a graphic in an anchored frame has one or more text frames on top of the graphic, and these text frames have valid hypertext markers in them.

•               When a graphic in an anchored frame has a rectangular matrix of links over it.

Related links:

Prepare graphics

Create a button matrix

Specifying graphics conversion

When you save documents as HTML, all graphic files imported by copying into anchored frames are converted to GIF format unless you specify that all the graphics be saved to another format. Each graphic is saved to a separate file. Text in anchored frames is also converted to GIF.

Graphic files imported by reference are left in their original locations unless you specify that copies should be made. In that case, the formats are inspected and converted as needed (preserving the dpi scaling of a graphic). The new files are created in the same folder as the HTML document.

Specify the file format for converted graphics

1)            

Choose File > Utilities > HTML Setup and click Options.

2)           Specify the graphic file format you want. You can choose from the following formats:

 

•               GIF is best used for nonphotographic images with no more than 256 colors.

 

•               JPEG format is best used for images with a wide range of color, such as a 24-bit photograph.

 

•               PNG format is a public-domain format that’s becoming more wide­spread on the Web. Like GIF, it is best used for images with no more than 256 colors.

 

3)           Click OK.

 

Specify that graphics imported by reference be copied and converted

1)            

Choose File > Utilities > HTML Setup and click Options.

2)           Select Copy Files Imported by Reference.

13.6.2.            Set up and adjust HTML mappings

You can change the following HTML mappings:

•                

Paragraph formats map to HTML elements to define paragraph-level formatting (including formats for body paragraphs and headings).

 

•               Character formats map to HTML elements to define character-level formatting (including common mappings for bold or emphasized text).

 

•               Cross-reference formats map to HTML conversion macros to specify how cross-references will be displayed in HTML.

 

After you save a document in HTML format, you may want to refine the mappings.

note:  A few mappings cannot be changed. For example, a FrameMaker table always converts to an HTML table, and an anchored frame always becomes an image with an IMG tag.

Set up or modify HTML mappings

1)            

Choose File > Utilities > HTML Setup. FrameMaker either loads the current mappings into the HTML Setup dialog box or, if no mappings have been created yet, creates default mappings.

 

2)           From the Map pop-up menu, choose the type of formats to map (para­graph, character, or cross-reference).

 

3)           Specify a mapping by choosing a FrameMaker format from the From pop-up menu and an HTML element or macro from the To pop-up menu.

 

tip:  You can click in the document to select a format to adjust. The HTML Setup dialog box immediately shows the current mapping for the format you click.

 

4)           Choose from the following options:

 

•               If you’re mapping paragraph formats and want to include the para­graph autonumber in the converted text, click Include Autonumber. (You don’t have to include an autonumber for items in a list.)

 

•               If you’re mapping to Heading (AutoLevel) and want to start a new Web page whenever this format is found, click Start New, Linked Web Page.

Use this option to break up a long FrameMaker document into several HTML files, each linked to a single file. Whenever the speci­fied format is found, FrameMaker leaves the heading in the original file (the parent file) and makes it a link to a subdocument whose content starts at the heading format and continues until the next instance of the format. For information on using this setting to simulate a table of contents, see Create links that simulate a TOC.

 

•               If you’re mapping to the List Item element for either a bulleted or numbered list, and want to specify how many levels deep the item is (which usually translates as how much the item should be indented), enter a Nest List at Depth value.

 

5)           Click Change to accept the mapping.

 

6)           Repeat steps 2 through 5 as needed.

 

7)           When you finish specifying mappings, close the dialog box and save the document as HTML.

 

If you want to edit the mapping tables on the HTML reference page, be sure to close the HTML Setup dialog box first. Keeping the dialog box open results in an error when you try to edit the tables on that page.

Autolevel mappings for headings

HTML supports six levels of headings. You can convert any FrameMaker para­graph format to a heading by mapping it to Heading (Autolevel). With this special mapping, headings in the document are mapped to H1, H2, and so on, according to their relative levels and based on the highest-level mapping in that file. The advantage of this method is that if the document is broken into separate HTML files, each will always have an H1 mapping and an appropriate hierarchy of headings under that H1.

For example, suppose your document uses Title1, Title2, and Title3 formats. When you convert to HTML, you might want to break up the document into two files, and the second file might contain only instances of Title2 and Title3. The autolevel feature ensures that Title2 maps to H2 in the first file but maps to H1 in the second file.

For more information on how the autolevel headings work, when you choose to split a document into separate HTML files, see Use the Headings reference page.

If you want to fine-tune the autolevel mechanism or override the autolevel func­tion and make mappings to specific heading levels, you must edit special tables on reference pages of the FrameMaker document. For more information, see Edit the HTML Mapping table.

Mappings for lists

FrameMaker automatically maps bulleted lists to HTML unordered lists and numbered lists to HTML ordered lists. If you want to override the automatic mapping, you must edit a table on the HTML reference page of the FrameMaker document. (See Edit the HTML Mapping table.)

In the HTML Setup dialog box, you can define the level of a list by specifying a value for Nest List at Depth. Typically, a browser displays different levels with different amounts of indentation.

You can include a FrameMaker autonumber in the converted text by choosing Include Autonumber. However, most browsers provide their own bullet char­acters and numbers with lists, so you are unlikely to use this option when converting lists.

The following table shows paragraph-based HTML elements.



	
 

Mapping name in the HTML Setup dialog box

 


	
Equivalent HTML element

 


	
Recommended use and typical appearance in a Web browser

 





	
Heading (AutoLevel)

 


	
H1, H2, H3, H4, H5, H6

 


	
Six levels of headings, with H1 the largest and most prominent

 





	
Paragraph

 


	
P

 


	
Normal body paragraphs

 





	
Preformatted Text

 


	
PRE

 


	
Text that closely matches the original’s line breaks and spacing; usually achieved by using multiple spaces and a fixed-width font

 





	
Address

 


	
ADDRESS

 


	
Text set off from the rest denoting an e-mail address or the like; usually indented or italicized

 





	
Block Quote

 


	
BLOCKQUOTE, BQ

 


	
A quotation set off by indenting

 





	
List Item

 


	
LI

 


	
Item preceded by a bullet character when it is part of an unordered list (UL), or by a sequential number when it is part of an ordered list (OL)

 





	
List Item (Continued)

 


	
P

 


	
Body paragraph within a list (not preceded by a bullet or number)

 





	
Data Term

 


	
DT

 


	
Item (such as a term in a glossary) that is to be defined by a DD element

 





	
Data Definition

 


	
DD

 


	
Definition of a term (a DT), such as in a glossary item

 





	
Data Definition (Continued)

 


	
P

 


	
Body paragraph within a data definition

 





	
Throw Away

 


	
None

 


	
Discarded during conversion to HTML

 






The following table shows character-based HTML elements.



	
 

Mapping name in the HTML Setup dialog box

 


	
Equivalent HTML element

 


	
Recommended use and typical appearance in a Web browser

 





	
Blink (Netscape)

 


	
BLINK

 


	
Blinking text (may not work in non-Netscape browsers)

 





	
Citation

 


	
CITE

 


	
A citation, usually displayed in italics or underlined





	
Code

 


	
CODE

 


	
Computer-program code, usually displayed in a fixed-width font such as Courier

 





	
Definition

 


	
DFN

 


	
Definition of a term, usually displayed in italics

 





	
Emphasis

 


	
EM

 


	
Emphasized text, usually displayed in italics or underlined

 





	
Keyboard

 


	
KBD

 


	
Text that a user types, usually displayed in a fixed-width font such as Courier

 





	
Sample

 


	
SAMP

 


	
Text that appears in a fixed-width font such as Courier

 





	
Short Quotation (Intl)

 


	
Q

 


	
Quotation of less than a full paragraph, usually displayed in quotation marks (may not be recognized by all browsers)

 





	
Span (CSS)

 


	
SPAN

 


	
Text that is displayed as specified in an HTML style sheet (by browsers that recognize style sheets) or without special formatting (by other browsers). For use when no other mapping is appropriate—for example, for a drop cap.

 





	
Strong

 


	
STRONG

 


	
Emphasized text, displayed in bold





	
Typewriter

 


	
TT

 


	
Text in a fixed-width font such as Courier

 





	
Variable

 


	
VAR

 


	
A special term or, in programming contexts, the name of a variable, displayed in italics or bold italics

 





	
Plain Text

 


	
None

 


	
Text that cancels any previous character mapping, displayed as appropriate for the paragraph mapping

 





	
Throw Away

 


	
None

 


	
Discarded during conversion to HTML

 






Mappings for cross-reference formats

A typical cross-reference in a printed document such as “See “Syntax” on page 8 for more information” loses its meaning in HTML documents, which don’t use page numbers. For this reason, cross-references are mapped by default to a predefined cross-reference conversion macro called See Also. The See Also macro changes the cross-reference so that it refers to the text of the paragraph but not to the page number (for example, “See “Syntax” for more information”). The cross-reference text in the original document becomes an HTML link in the converted document regardless of what format is used.

You can modify the See Also macro, or you can create your own macros and then map cross-reference formats to them.

When you first map a cross-reference, the See Also macro is the only macro in the To pop-up menu in the HTML Setup dialog box. If you create other conver­sion macros, they will appear in this menu as well. For information on how to create and edit cross-reference macros, see Use HTML conversion macros.

Two other choices in the To pop-up menu let you map a cross-reference in other ways:

•                

Choose Original Cross-Reference Format to leave the text of the cross-reference unchanged.

 

•               Choose Throw Away to delete the text of the cross-reference.

 

Fine-tuning mappings by editing reference pages

You can fine-tune the HTML conversion by editing tables on two special FrameMaker reference pages: the Headings page and the HTML page. If you’re converting a book, the reference pages are BookHeadings and BookHTML. (See Convert books to HTML files.) For general information on reference pages, see Reference pages.

note:  Don’t edit the information on the HTML reference page unless you’re familiar with HTML coding. Most users won’t need to edit the tables on this page.

The reference-page tables are set up automatically the first time you save as HTML or the first time you choose File > Utilities > HTML Setup. The Headings reference page contains one table, the Headings table. The HTML reference page contains the following tables:

•                

The HTML Mapping table. (See Edit the HTML Mapping table.)

 

•               The HTML Options table, which contains the settings you make in the Options dialog box. (See Specifying graphics conversion.)

 

•               The HTML System Macros table, the HTML Cross-Reference Macros table, and the HTML General Macros table. (See Use HTML conversion macros.)

 

•               The HTML Character Macros table. (See Convert special characters.)

 

If the tables are large, the HTML reference page will continue on for as many pages as needed.

Use the Headings reference page

The Headings table on the Headings reference page identifies which tags should be used for headings and what their hierarchy is.

The Headings Table sets up the relative hierarchy of the headings.
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Using this table, you can modify the mappings for headings and the relative levels of those headings.

To Help you identify heading formats, text appears in the same font and point size as the headings do on the body pages of the document.

Edit the Headings table

1)            

Choose View > Reference Pages and display the Headings page. (The Headings page will not exist until you save the document as HTML, or choose File > Utilities > HTML Setup.)

 

2)           Edit the table by doing the following:

 

•               To map a different paragraph format to a heading level, change the paragraph tag in the second column but don’t change the heading level number. For example, if a Tip format is mapped to a level-6 heading but you want the Warning format to be mapped at that level instead, just change Tip to Warning in the second column.

 

•               To change the relative levels of headings, change the numbers in the Heading Level column. For example, to promote the Warning format to a higher heading level, change the 6 to a 5 in the Heading Level column. (You don’t have to change the order of the rows when you do this, but you might want to so that the table is easier to read.)

 

•               To map several formats to a single level of heading, use the same number in the Heading Level column. For example, the Note and Warning formats are both level-6 headings in the following Head­ings table.

 



	
Heading Level

 


	
Paragraph Format

 


	
Comment

 





	
6

 


	
Note

 


	
 





	
6

 


	
Warning

 


	
 






•               To add a format to the Headings table, press Control+Return to add a row and then fill in the Heading Level and Paragraph Format columns.

 

3)           If you removed or added formats in the Headings table, change their mappings in the HTML Mapping table as well. For example, you might change the entry of a SubHead format from H* to P in the HTML Mapping table. For more information on editing this table, see the next section.

 

Edit the HTML Mapping table

The HTML Mapping table on the HTML reference page contains the mappings you assign using the HTML Setup dialog box. (Mappings for headings appear here too, as well as in the Headings table.) You usually don’t need to edit this table directly, but you might want to edit it in the following situations:

•                

To bypass the autolevel mapping of headings and instead map a format explicitly to a heading level such as H1 or H2. (See Autolevel mappings for headings.)

 

•               To change many mappings quickly or globally by using Edit > Find/Change.

 

•               To change a bulleted list to a numbered list, or the reverse.

 

•               To use an HTML element that is not available through the HTML Setup dialog box.

 

•               To document the mappings in the Comments column of the table.

 

The first column of the Mapping table contains a FrameMaker source item prefixed with a letter that indicates the type of item: P for paragraph format, C for character format, or X for cross-reference format. The second column can contain the name of an HTML element or an HTML conversion macro name.

The HTML Mapping table on the HTML reference page
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For information on defining macros, see Use HTML conversion macros.

Edit a mapping using the HTML Mapping table

1)            

Choose View > Reference Pages and display the HTML page.

 

2)           Locate the Mapping table on that page, and find the format whose mapping you want to change.

3)           Make the following changes as needed:

 

•               In the Element column, enter the name of the HTML element or conversion macro that the format is to be mapped to. If you’re not sure of the correct HTML element name, see the tables in Mappings for lists. Enter H* to map to an autolevel heading.

 

•               In the New Web Page column, enter Y for Yes to create a separate HTML document whenever this format is found. Otherwise, enter N for No.

 

•               In the Include Auto# column, enter Y or Yes to include the full auto­number text of this format in the conversion. Otherwise, enter N or No.

 

•               In the Comments column, enter any text to document the purpose of the mapping, special cases, and so on. You can leave this column blank.

 

An edited row might look like this.

 



	
FrameMaker Source Item

 


	
HTML Element

 


	
New Web Page?

 


	
Include Auto#?

 


	
Comments

 





	
P:Fnote

 


	
FOOTNOTE

 


	
N

 


	
N

 


	
Won’t work in all browsers

 






Convert special characters

The FrameMaker character set and the character set used by HTML and the Web are not identical. Because of this, some characters are mapped to substitu­tions when converted to HTML. Some mappings are internal and rely on special HTML codes called entities. (For example, curved quotation marks are changed to the entity for straight ones.) Other substitutions are defined in the Character Macros table. For example, an em dash is defined as two hyphens. If no mapping exists, the character is ignored.

The following characters either have special predefined mappings or are treated specially.



	
 

Character

 


	
Default mapping

 


	
Where defined

 





	
… (ellipsis)

 


	
... (three periods)

 


	
Character Macros table
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(em dash)

 


	
-- (two hyphens)

 


	
Character Macros table
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(en dash)

 


	
- (one hyphen)

 


	
Character Macros table

 





	
¢ (cent)

 


	
&#162; (HTML character reference)

 


	
Character Macros table

 





	
© (copyright)

 


	
&#169; (HTML character reference)

 


	
Character Macros table

 





	
® (registered)

 


	
&#174; (HTML character reference)

 


	
Character Macros table

 





	
? (degree symbol)

 


	
&#176; (HTML character reference)

 


	
Character Macros table

 





	
< and > (angle brackets)

 


	
&lt; and &gt; (HTML entities)

 


	
Internal
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and
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(curved quotation marks)

 


	
&quot; (HTML entity for ")

 


	
Internal

 





	
& (ampersand)

 


	
&amp; (HTML entity)

 


	
Internal

 






You can add or change mappings for characters by adding or editing entries in the Character Macros table. As the previous table illustrates, you can map char­acters to text or to HTML character and entity references (which begin with an ampersand and end with a semicolon).

1)            

Choose View > Reference Pages and display the Character Macros table on the HTML page.

 

2)           Edit a mapping, or create a new row (by pressing Control+Return) and enter a new mapping.

 

If you’re unsure how to type a special character in the first column, look up its keystroke.

For example, to set up mappings for the dagger character, the trademark symbol, and the ae ligature, you could add the following rows.



	
Character

 


	
Replace With


	
Comments

 





	
†

 


	
*

 


	
Dagger symbol

 





	
™


	
(tm)

 


	
Trademark symbol

 





	
æ


	
&aelig;

 


	
ae maps to the HTML entity reference for that symbol

 






13.6.3.            Save a document in HTML format

To convert a FrameMaker document to HTML, simply save it as an HTML file. Saving as HTML sets up definitions for how each FrameMaker format will convert, or map, to an HTML element. You can also save a whole book as HTML. (See Convert books to HTML files.)

FrameMaker automatically creates the mappings of formats to HTML elements upon initial conversion to HTML, but you can fine-tune them, and make further customizations, by creating conversion macros. For information, see Set up and adjust HTML mappings and Fine-tuning mappings by editing reference pages.

Even if you plan to fine-tune the conversion, you should begin by saving as HTML. You can then fine-tune the automatic mappings as needed.

1)            

Choose File > Save As and choose HTML from the pop-up menu.

 

2)           Give the filename an extension of .html, specify the file location, and click Save. The converted file is saved where you specified.

 

3)           Open the HTML file in a Web browser to examine the converted file. If it meets with your approval, you’re done.

 

If you’d like to refine some mappings, continue by following the steps in Set up and adjust HTML mappings.

13.6.4.            Use HTML conversion macros

 You can use the following tables on the HTML reference page to define HTML conversion macros:

•                

The HTML System Macros table, which contains eight predefined macro names you can use to perform special functions at the start or end of Web pages.

 

•               The HTML Cross-Reference Macros table, which contains replacement text for FrameMaker cross-references.

 

•               The HTML General Macros table, which contains general-purpose macros that you define (for example, the title of the converted document).

 

note:  You cannot alter the System or General HTML macros in the HTML Setup dialog box.

After a macro is defined, you can use it by name in other macros, or you can map to it in the HTML Mapping table. The macro name appears in the To pop-up menu in the HTML Setup dialog box, so you can map a format to it without editing the Mapping table directly.

For examples of HTML conversion macros, see the reference pages of the templates that are included with FrameMaker.

Create or edit an HTML conversion macro

1)            

Choose View > Reference Pages and display the HTML page.

 

2)           Edit a macro in a table, or create a row (by pressing Control+Return) and enter a new macro starting with a macro name. (You can’t add macros to the HTML System Macros table; you can only edit their replacement text.)

Replacement text can contain any mixture of text, HTML codes, and FrameMaker building blocks. Be sure that you enter valid HTML code; FrameMaker doesn’t check the HTML syntax.

Use building blocks in HTML conversion macros

You can use the following building blocks in HTML conversion macros to include special types of text.



	
Building block

 


	
Description

 





	
<$paratext>

<$paratag>

<$paranum>

<$paranumonly>

 


	
See Including source information in cross references and Including character formats in cross-references for details.

 





	
<$variable[varname]>

 


	
Contains the text of the variable

 





	
<$defaulttitle>

 


	
Contains the text of the first heading that appears in the current document

 





	
<$nextsubdoc>

 


	
Contains the URL of the next HTML subdocument

 





	
<$prevsubdoc>

 


	
Contains the URL of the previous HTML subdocument

 





	
<$parentdoc>

 


	
Contains the URL of the parent HTML document

 






Building blocks are enclosed in angle brackets (< >) and begin with a dollar sign ($). Enter these building blocks in all lowercase letters.

note:  The General Macros table has a column labeled “Head.” Use this column to define a title or to include special, advanced information about the HTML document (such as keywords that a search engine might use). To fill in this column, you need to know the HTML elements that are permitted in the HEAD section of an HTML document.

Redefining HTML system macros

HTML system macros are a special case because you can redefine them, but you cannot add new ones.

These macros are especially useful when splitting up documents into separate HTML files. For example, you can define the StartOfSubDoc macro so that your company logo appears at the top of every new Web page.

In these descriptions, the parent document refers to the first Web page and subdocument refers to a document linked to the parent document.



	
 

System macro

 


	
Use

 





	
StartOfDoc

 


	
Inserts text at the top of the topmost Web page

 





	
EndOfDoc

 


	
Inserts text at the end of the topmost Web page

 





	
StartOfSubDoc

 


	
Inserts text at the top of each subdocument except the first and last

 





	
EndOfSubDoc

 


	
Inserts text at the end of each subdocument except the first and last

 





	
StartOfFirstSubDoc

 


	
Inserts text at the top of only the first subdocument created

 





	
EndOfFirstSubDoc

 


	
Inserts the replacement text at the end of only the first subdocument





	
StartOfLastSubDoc

 


	
Inserts the replacement text at the top of only the last subdocument created

 





	
EndOfLastSubDoc

 


	
Inserts the replacement text at the end of only the last subdocument

 






Customize titles

The title of an HTML document appears in the window’s title bar. When you add a bookmark to that page, it also appears in the bookmark list. Initially, the <$defaulttitle> building block is used for the title, which uses the first heading in an HTML file as the title for that file. Usually, the default titles are satisfactory. However, you can specify a different title by editing macro tables on the HTML reference page.

System macros and general macros can define two sets of replacement text—one that appears in the body of the code and one that is inserted in the head area.

You can modify the default title, or you can remove the default title and set up your own titles.

Related links:

Set up and adjust HTML mappings

Modify the default titles

1)            

Choose View > Reference Pages and display the HTML reference page.

 

2)           In the HTML System Macros table, locate the four system macros that set up the default titles. Initially, they use the <$defaulttitle> building block to assign the first heading in the file as the title. You can change any or all of them.

 



	
Macro Name


	
Replace With

 


	
Head

 


	
Comments

 





	
StartOfDoc

 


	
 


	
<TITLE><$default­title></TITLE>

 


	
 






3)           Change the default macro for Head. For example, the following macro changes the text of the title to static text.



	
Macro Name


	
Replace With

 


	
Head

 


	
Comments

 





	
StartOfDoc

 


	
 


	
<TITLE> My Book</TITLE>

 


	
 






Set up your own titles

1)            

Choose View > Reference Pages and display the HTML reference page.

 

2)           Remove the four default title replacement texts from the HTML System Macros table.

 

3)           In the HTML General Macros table, define a macro that uses the <TITLE> HTML element in the third column, the Replace With (in HEAD) column. For example, the following macro uses a paragraph autonumber and text for the title, and also as paragraph text in the document.



	
Macro Name


	
Replace With

 


	
Head

 


	
Comments

 





	
MyTitle

 


	
<P><$para­num><$para­text></P>

 


	
<TITLE><$para­num><$paratext>­

</TITLE>

 


	
 






4)           Map the macro to the format that you’re splitting the HTML document on.

 

13.6.5.            Insert HTML code

You may want to insert special HTML code into your document (for example, the code that defines a Java applet).

1)            

Choose View > Reference Pages and display the HTML reference page.

 

2)           In the HTML General Macros table, define a macro whose content is the HTML code.

3)           Choose View > Body Pages and place the insertion point where you want to insert the HTML code.

 

4)           Choose Special > Marker and choose HTML Macro as the marker type.

 

5)           Enter the name of the general macro as the marker text and click New Marker.

 

For example, you could enter the following Java code as a macro definition.



	
Macro Name


	
Replace With

 





	
MyCode

 


	
<applet code="Bullets.class" width="600" height="6" codebase="classes/bullets/" > <param name="bgColor" value="White"> </applet>

 






Where you want to insert this applet, you insert a marker whose marker type is HTML Macro and whose marker text is MyCode.

13.6.6.            Convert books to HTML files

You follow the same basic procedure to save a book in HTML format that you use to save a single document. When FrameMaker maps the files in the book, it stores the mappings on reference pages added to the first file in the book. You can edit the tables on the reference pages in the same way you edit the tables on reference pages of individual documents.

The files in a book may not remain separate files when the book is saved as HTML. To break up a book file into separate HTML files, use the Start New, Linked Web Page option.

1)           Open the book file and choose File > Save Book As.

 

2)           Choose HTML from the pop-up menu.

 

3)           Give the filename an extension of .html and click Save. The converted files of the book are saved where you specified.

 

4)           Examine the converted files by opening them in a Web browser. If they meet with your approval, you’re done.

 

5)           If you’d like to refine some mappings, open the first file in the book file and display its BookHeadings or BookHTML reference page. Edit the tables there. Then save the file and save the book file as HTML again.

 

tip:  If you fine-tuned the mappings for a document and want to use these mappings for a whole book, remove the tables on the BookHeadings and BookHTML reference pages in the book file’s first file. Then copy the tables on the document’s Headings and HTML reference pages and paste them onto the Book­Headings and BookHTML reference pages.

Related links:

Saving structured documents as HTML

Create links that simulate a TOC

Fine-tuning mappings by editing reference pages

13.6.7.            Troubleshooting and tips on HTML conversion

Follow these guidelines to ensure a smooth conversion to HTML:

•                

When converting a book, open all documents before starting. This ensures that there will be no error messages that might interrupt the conversion process.

 

•               Make sure the table formats you use have regular ruling lines defined for at least one body row. Otherwise, the HTML tables will have no lines around table cells.

 

•               Make sure that your documents contain no unresolved cross-references before you save as HTML. Unresolved cross-references appear as broken links in HTML.

 

•               If text or graphics don’t convert when they should, make sure they’re on body pages and not master pages, that they are part of the main text flow (flow A), and that they’re in anchored frames.

 

•               If you want to import the HTML conversion settings from one document to another, use the File > Import > Formats command to copy reference pages.

Related links:

Resolve cross-references

Import formats from a template or document

13.6.8.            Saving structured documents as HTML

The procedures for saving structured documents as HTML are the same as for unstructured documents, with the exception of mappings. In structured docu­ments, all mappings are based on elements and attributes, rather than character, paragraph, and cross-reference formats. Structured FrameMaker elements map to HTML elements to define formats for containers. Structured FrameMaker attributes map to HTML attributes to define cross-references, cascading style sheets, languages, and alt-text for images.

Publishing options for online output formats

In addition to saving FrameMaker documents as HTML from FrameMaker, you can use any of the enterprise-class publishing options provided by Adobe.

 

•               Use RoboHelp to publish FrameMaker content into HTML and other formats. Such formats include WebHelp, HTML, ePub, and Adobe AIR-based Help. In this approach, you define the style mapping and other conversion settings, and import the FrameMaker content into a Robo­Help project. Later, you can publish the required online output formats using RoboHelp’s features. See Adobe RoboHelp Help.

 

•               Use Adobe Technical Communication Suite to create automated work­flows to publish FrameMaker content into several online output formats. Here, you can use FrameMaker as the authoring environment and Robo­Help as the publishing tool. When used as part of the Technical Commu­nication Suite, FrameMaker and RoboHelp provide several advanced features. See the Adobe Technical Communications Suite Help.

 

•               Use the FrameMaker Server and RoboHelp Server for enterprise-level, automated publishing into multi-channel, multi-device output formats.

13.7.             Generating hypertext outputs using XSLT

You can create a hypertext output (XML or HTML) from an XML file using an XSL. You can create and save reusable transformations in an XML file. The reusable transformations include information such as the name and path of the XSLT and the path of the input and output files.

The output is created using a parser installed on the machine and registered with FrameMaker through maker.ini settings. XALAN and SAXON are installed by default on your machine with FrameMaker. XALAN supports XSLT 1.0 and SAXON supports XSLT 2.0. Both XALAN and SAXON are JAXP compliant.

SAXON is the default parser used when XSL is run directly or no transforma­tion-specific parser is specified. However, you can specify a new default processor in the maker.ini file using the following flags:

[XSLTProcessors]
;------------------------------ XSLT Processor------------------------------
;processorName=jar path(all dependent jars should be in same dir), TransformerFactory class, default if default processor(if not
specified - 1st processor would become default.)
XALAN=fminit\XSLTProcessors\xalan\xalan-j_2_7_1-bin\xalan.jar, org.apache.xalan.processor.TransformerFactoryImpl
SAXON=C:\saxonhe9-3-0-5j\saxon9he.jar, net.sf.saxon.TransformerFactoryImpl, Default

13.7.1.            XSL transformations

An XSL transformation includes information such as XSL, Parser, and Output folder, to create an output from XML files. The transformation that you create are stored in an XML file. There are two types of transformations: default and application-specific. The default transformations are stored in the file as speci­fied in the maker.ini file using the TransformationFilePath flag. The applica­tion-specific transformations are stored in an XML file that you specify for the structured application in the structapps.fm file.

13.7.2.            XSLT toolbar

The XSLT toolbar maintains a history of the transformations you use and lets you use Advanced Run feature to create output from multiple XML files. From the toolbar, you can also choose and run a transformation\XSL on the open file. For more information, see Create output from multiple files using Advanced Run.

[image: op_xslt_toolbar.png]

 

A.

Click to select an XSL file

B.

Click to select a transformation

C.

Run the selected transformation or XSL

D.

Click to display the Advanced Run dialog

13.7.3.            Create transformations in a transformation file

1)            

Select XSLT > Manage Transformation.

 

[image: op_transformation_in_file.png]

 

 

2)           In the Manage Transformations dialog, select Transformation File, click New.

 

note:  If you already have an existing Transformation file, click Browse and select it.

 

3)           Click New.

 

4)           In the New Transformation dialog, specify the following information and click SaveAs to create a Transformation file:

 

note:  If you selected an existing Transformation file in Step 1 using Browse button, save the new transformation in the selected transformation file.

 

[image: op_new_transformation_in_file.png]

 

 

a)           Transformation Name: A name for the transformation setting.

 

b)           Use: Either select an XSL file or choose to use the processing instruc­tions (PI) inside the XML file.

 

c)           Processor: Saxon, Xalan, or any other parser registered with FrameMaker.

 

d)           Output: Settings related to the output file, such as location to save, suffix, and how to open the output file.

 

13.7.4.            Create transformations in default/global transformation file

1)            

Select XSLT > Manage Transformation.

 

2)           In the Manage Transformations dialog, select Default Transformation File and then click New.

 

3)           In the New Transformation dialog, specify the following information and click Save:

 

a)           Transformation Name: A name for the transformation setting.

 

b)           Use: Either select an XSL file or choose to use the processing instruc­tions (PI) inside the XML file.

 

c)           Processor: Saxon, Xalan, or any other parser registered with FrameMaker.

 

d)           Output: Settings related to the output file, such as location to save, suffix, and how to open the output file.

 

13.7.5.            Edit an application-specific transformation

Once you have created a transformation, you can associate the transformation file to one or more XML applications in structapps.fm.

1)           In the WYSIWYG view, select StructureTools > Edit Global Application Definitions.

 

2)           In a structured application, locate the TransformationFile element and specify the path and name of the transformations file.
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3)           Save the StructApps.fm file and select StructureTools > Read Application Definitions.

 

Now, you can choose to generate file output with the relevant application’s transformation.

13.7.6.            Generate output using an application-specific transformation

 

1)            

With an XML file in focus in XML View, in the XSLT toolbar select Trans­formation from the Choose drop-down.

 

2)           In the Choose Transformations dialog, select Structured Applications.

 

[image: op_application_transformation.png]

 

 

3)           The relevant application, as specified in structapps.fm, is selected from the drop-down list and the relevant transformations appear in the Transformations field.

 

4)           In Transformations, select the transformation using which you want to generate the output and click OK.

 

5)           In the XSLT toolbar, click Run.

 

FrameMaker generates the hypertext output and displays the file.

 

13.7.7.            Generate output from multiple files using Advanced Run

Using the XSLT toolbar, you can run a transformation on multiple files.

1)            

In the XSLT toolbar, select Advanced Run.
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2)           In the Advanced Run dialog, select a scope for running the transforma­tion:

 

a)           Current File: Generate output from the XML file open in FrameMaker.

 

b)           Select Include Child Elements if the active document is a book or a map. When this option is selected, the XSLT is applied to the child elements, together with the parent element.

 

c)           All Open Files: Generate output from all the XML files open in FrameMaker using a transformation transformations or XSL.

 

d)           Folder: Generate output from all the XML files in a folder using a transformation or XSL. Select Include Sub-Folders, if necessary.

 

3)           Select a transformation or XSL and click Run.

 

The output files are launched in the associated application.




14.                Working with Content Management Systems

 

14.1.             About the Documentum® and SharePoint connectors

FrameMaker provides connectors that enable integration with the following content management systems (CMS):

 

•               EMC Documentum® 6.5 SP1, SP2, and SP3

 

•               Microsoft® SharePoint Server 2007 SP 2 and Microsoft® SharePoint Server 2010

 

Once configured, FrameMaker allows you to perform search, read, write, delete, update, check in, and check out operations on the configured CMS repository.

14.2.             Configure the connectors

To set up the connectors, complete the following tasks:

14.2.1.            Set default file versioning (Documentum® and SharePoint)

You can specify the versioning scheme to be applied when you use FrameMaker to upload a document that exists in a Documentum® or SharePoint repository. The document is overwritten and the specified file versioning settings are applied to the document.

1)            

In FrameMaker, Click Edit > Preferences.

 

2)           In CMS, ensure that Overwrite existing object and save as is selected.

 

3)           Select the versioning option per your requirement. You can choose to have the same, next major, or next minor version for the uploaded docu­ment.

 

4)           Click OK.

 

14.2.2.            Set the Repository Manager view (Documentum® only)

1)            

In FrameMaker, Click Edit > Preferences.

 

2)           In CMS > Documentum®, select Show Hidden Objects to view the hidden files (contained in a repository) in the Repository Manager window.

 

3)           Select Show Private Cabinets to view the private cabinets (contained in a repository) in the Repository Manager window.

4)           Click OK.

 

14.2.3.            Download the Powerlink SDK (Documentum® only)

Download the Documentum® Foundational Services SDK from the EMC website. note:  You need an EMC powerlink login to download the SDK. 

14.2.4.            Specify the DFS SDK path (Documentum® only)

 

1)           Download the Documentum® Foundation Services (DFS) SDK from EMC Community Network.

2)           Extract the zip file.

 

3)           In FrameMaker, Click Edit > Preferences.

 

4)           In CMS > Documentum®, click Browse.

 

5)           In the Browse For Folder window, navigate to the SDK (emc-dfs-sdk-6.5) folder.

 

6)           Click OK in the Browse For Folder window.

 

7)           Click OK in the CMS Preferences window.

 

A message box prompts you to restart FrameMaker.

 

8)           Restart FrameMaker.

 

14.2.5.            Add the FrameMaker types on the Server (Documentum® only)

You can add the FrameMaker types on the Content server using a .dar file.

Add the FrameMaker types on the Server using the .dar file

To add the FrameMaker types on the Content server, you need Administrator or Create Type privilege.

1)            

Download the .dar file from the following location and use it to add the FrameMaker types on the Server:

 

www.adobe.com/go/learn_fm_dar_file_en.

 

14.2.6.            Set up sample Adobe FrameMaker 11 DITA Applications for EMC Docu­mentum® Server (Documentum® only)

A FrameMaker 11 sample application pack is available at www.adobe.com/go/learn_fm_sample_dita_app_pack_en. The application pack includes an indicative set of applications to help content administrators configure FrameMaker 11 to author files on Documentum® server. Download and install the sample application pack to avoid the warnings and XML parser logs when you work with XML files from Documentum® server.

14.3.             Connect to the content management system

 

1)           In FrameMaker, select CMS > Connection Manager.

 

2)           Choose the connection type — Documentum® or Sharepoint.

 

3)           Specify the connection details, such as server name, user name, and pass­word to connect to your CMS. Also, specify a unique name for the connec­tion.

 

note:  The value in the Name field uniquely identifies each connection. All connections are added to the favorites list. The list can store a maximum of sixteen favorites. If you try to store the seventeenth connection, the first connection on the list is removed to accommodate it. The connection list works in a first in, first out manner. note:  To delete a listed connection, select it from the list and click Remove. 

4)           (Documentum® only) Specify the name of the Documentum® repository to which FrameMaker will connect using this connection.

 

5)           Click Connect.

 

The Repository Manager lists the contents of the selected server.

 

14.4.             Use the Repository Manager

Select CMS > Open Repository to view the Repository Manager window. Use the Repository Manager to:

•                

Switch between repositories

 

•               Browse files within a repository

 

•               Manage resources

 

Repository Manager
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A.

Search the repository

B.

Perform advanced search

C.

Add a connection

D.

Close a connection

E.

Delete

F.

Cancel checkout

G.

Select repository

H.

Checkin item

I.

Checkout item

14.5.             Upload files and folders

Using FrameMaker, you can upload files and folders to a Documentum® or SharePoint server.

14.5.1.            Upload files

note:  You can upload XML, DITA, FM, MIF, and book files.

note:  Ensure that the required applications are configured on the CMS server to upload DITA and XML files. If DITA applications are not available on your CMS, contact your Administrator.

 

1)           Select the server from the Repository Manager window.

 

You can choose to upload an open (step 2) or closed (step 3) file.

 

2)           Upload an open file.

a)           Switch between the open documents to select the document to upload.

b)           Select CMS > Upload Active Document.

 

The Select CMS Item window is displayed.

c)           Specify the upload location.

note:  Save the file before uploading. If the file is not saved, the depen­dencies list may not be correctly updated.

 

d)           Click OK.

The selected document and its direct dependencies are uploaded. A message is displayed when the file is successfully uploaded.

 

e)           Click OK.

 

3)           Upload a closed file.

 

a)           Perform one of the following:

 

•               Right-click a list or folder for SharePoint.

 

•               Right-click a cabinet or folder for Documentum®.

b)           Select Upload Document.

 

The Select the file to upload window displays.

 

c)           Specify the file to upload.

 

d)           Click Select.

 

The selected file and its direct dependencies are uploaded. A message is displayed when the file is successfully uploaded.

e)           Click OK.

 

note:  The uploaded file remains on the disk and a copy of it is uploaded to the server. To work on the file again, first check out the file from the server. 

14.5.2.            Upload folders

 

1)           Select the server from the Repository Manager window.

 

2)           Perform one of the following:

 

•               Right-click a cabinet or folder for Documentum®.

•               Right-click a list or folder for SharePoint.

 

3)           Select Upload Folder.

 

The Browse For Folder window displays.

4)           Navigate and select the folder to upload.

5)           Click OK.

 

The selected folder and all its dependencies are uploaded. A message is displayed when the directory is successfully uploaded.

6)           Click OK.

 

14.6.             Manage resources

Using FrameMaker, you can manage the resources, such as cabinets (Docu­mentum®), sites (SharePoint), lists (SharePoint), folders, and files, of your configured Documentum® or SharePoint server.

14.6.1.            Manage cabinets, sites, lists, folders, and files

You can perform the following operations on your CMS resources.

 

Add a cabinet

 

Right-click the root node of the Documentum® server and select New Cabinet.

Delete a resource

 

Right-click a cabinet, folder, or file and select Delete.

When deleting a file in Sharepoint, a dialog prompts you to keep just the current version of the file and delete all other versions, or to delete all the versions of the file.

 

Sharepoint deletion dialog

[image: cn_sharepoint-delete.png]

 

When deleting a file in Documentum®, a dialog prompts you to delete just the file, all versions of the file, or the file and all its dependencies.

 

Documentum® deletion dialog

[image: cn_documentum_delete.png]

 

Upload a file

 

Right-click a cabinet, list, or folder and select Upload Document. FrameMaker uploads the file and all its dependencies, if any.

 

Upload a folder

 

Right-click a cabinet, list, or folder and select Upload Folder.

 

Add a folder

Right-click a cabinet, list, or folder select New Folder.

Review checked out files

 

Right-click a cabinet, site, list, or folder and select Show Checkout Files.

View attributes

 

Right-click a cabinet, site, list, or folder and select Properties. The attri­butes panel is displayed as follows:

 

View attributes panel

[image: cn_connectors_view_properties.png]

 

The panel allows you to modify the value of an attribute. To modify a value, click the value of the desired attribute and modify it.

 

Click OK to save the modified value.

 

Refresh the view

Right-click a cabinet, site, list, folder, or the root node and select Refresh.

 

14.6.2.            Check out files

1)            

In the Repository Manager, select the repository.

2)           Right-click the file and do one of the following:

•               Select Checkout and Edit to check out and open the file.

•               Select Checkout to check out the file.

 

3)           Specify whether to check out all dependent files.

 

4)           Click OK.

 

14.6.3.            Check in files

1)            

In the Repository Manager, select the repository.

2)           Right-click the file and select Checkin.

3)           Specify the version details.

 

4)           Click OK.

 

note:  Select Cancel Checkout to undo the checkout and discard changes made to the file. For Sharepoint, check out of all dependent files will also be automatically canceled.

note:  Save the file before checking in to ensure that all the changes are uploaded correctly. If a file is checked out with its dependents, then all dependent files will also be automatically checked in.

14.6.4.            Manage files

Using FrameMaker you can manage XML, DITA, FM, MIF, and book files. In addition to checking out and checking in files, you can perform the following tasks:

Open a file

 

Right-click and select Open (read only) to view the file in read-only mode. If the file is not checked out, double-clicking or pressing Enter on the file, opens the file in read-only mode, and also downloads all the dependents of the file.

 

Delete a file

 

Right-click, select Delete. Select Delete all versions to delete all versions of the file.

View version details

 

Right-click and select Show Versions.

 

View dependencies

 

Right-click and select Show Dependents. note:  View dependencies is only valid for virtual documents in the case of Documentum®. 

View properties

 

Right-click and select Properties.

Refresh the view

Right-click and select Refresh.

 

14.7.             Search files

FrameMaker allows you to perform basic and advanced search in the config­ured Documentum and Sharepoint repositories.

14.7.1.            Basic Search (Documentum® and Sharepoint)

Basic search searches on the name of the file. To perform a basic search:

1)            

In the Repository Manager, select the repository.

 

2)           Enter the search term in the search field and click the search icon.

 

Basic search tab

[image: cn_search-tab-basic.png]

 

The results are displayed in the search results window.note:  Basic search searches the selected item in the repository. If the selected item is a top-level container, then all files and subcontainers within the main container are searched. 

Search results window

[image: cn_search-result.png]

14.7.2.            Advanced search (Sharepoint)

To perform an advanced search on a Sharepoint repository:

1)            

In the Repository Manager, select the repository.

 

2)           Click the advanced search icon. The advanced search window is displayed as follows:

 

Advanced search window (Sharepoint)
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3)           Enter the search term in the search pane.

 

4)           The condition builder allows you to perform complex searches by combining two or more search criteria.

 

a)           Build a criteria by selecting the property (for example, Created By), the relevant condition (for example, =), and specify a value (for example, Jones). Click Add.

 

b)           Build another criteria by selecting the operator (AND or OR), the property (for example, File Type), the desired condition (for example, =), and specify a value (for example PDF).

 

5)           Click Search.

 

Search results are displayed based on the specified search criteria. In this example, the PDF files created by Jones are displayed.

14.7.3.            Advanced search (Documentum®)

To perform an advanced search on a Documentum® repository:

1)            

In the Repository Manager, select the repository.

 

2)           Click the advanced search icon. The advanced search icon is displayed as follows:

 

Advanced search window (Documentum®)

[image: cn_adv_srch_documentum.png]

 

3)           Enter the search term in the search pane.

 

4)           Select the location, file type, date, and file size values as required.

 

5)           The condition builder allows you to perform complex searches by combining two or more search criteria.

 

a)           Build a criteria by selecting the property (for example, Title) and the condition (for example, begins with), and specify a keyword (for example, Troubleshooting). Click Add.

 

b)           Build another criteria by selecting the operator (AND or OR), prop­erty (for example Modified By), condition (for example, begins with), and specify a keyword (for example, Daniel).

 

6)           Click Search.

 

Search results are displayed based on the specified criteria. In this example, elements that have their titles beginning with Troubleshooting and are modified by users that have their names beginning with Daniel are displayed.

14.8.             Add custom CMS attributes

You may need to create custom attributes according to your unique require­ments in Sharepoint or Documentum. Once you have created these custom attributes, you can provide support for them in FrameMaker. You can add the custom attributes in FrameMaker that exist on your Documentum® or Share­point CMS. You can add the following attribute types in FrameMaker CMS preferences for Sharepoint:

•               Text

 

•               Note

 

•               Number

 

•               Currency

 

•               Integer

 

•               Boolean

 

•               DateTime

 

•               Lookup

 

•               Choice

 

•               URL

 

•               User

 

You can add the following data types for Documentum®:

•                

Boolean

 

•               Integer

 

•               String

 

•               Double

 

•               Time

 

•               ID

 

On file upload, the attributes specified in the CMS preferences are populated in connection manager and search.

Adding custom properties in Sharepoint
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14.8.1.            Add a property for Sharepoint

 

1)            

Select Edit > Preferences.

 

2)           In the Preferences dialog, expand CMS and select Sharepoint and enter the following:

 

a)           Name: Enter a name for the new property.

 

b)           Data Type: Enter data type of the new property: Boolean, Date, Double, Integer, or String.

 

c)           Attribute Type: Enter one of the following: Text, Note, Number, Currency, Integer, Boolean, DateTime, Lookup, Choice, URL, or User.

 

3)           Click OK.

 

14.8.2.            Add a property for Documentum®

 

1)            

Select Edit > Preferences.

 

2)           In the Preferences dialog, expand CMS and select Documentum®.

 

3)           In List of Attributes, enter the name of the new property and click Add. Repeat to add more properties.

 

4)           Click OK.

 

To view the added property, right-click a folder or document within the relevant cabinet. Also, when you use Advanced Search, the Add Criteria area has the new property listed in the Property drop-down.




15.                Scripting in FrameMaker

 

15.1.             What is scripting?

Scripting is a powerful tool that can be used to control and automate many features of Adobe FrameMaker—saving you so much time and effort that it can completely change the way you approach your work.

15.2.             Why use scripting?

Your work is characterized by creativity, but many of the actual hands-on tasks are anything but creative. Most likely, you spend much time doing the same or similar procedures over and over again. Would it not be great to have an assis­tant—one that happily does the mind-numbing tasks, follows your instructions with perfect and predictable consistency, is available any time you need help, works at lightning speed, and never even sends an invoice? Scripting can be that assistant. With a small investment of time, you can learn to script the simple but repetitive tasks that eat up your time. However, while it’s easy to get started, FrameMaker scripts provide the necessary depth to handle sophisticated jobs. As your scripting skills grow, you may move on to more complex scripts that work all night while you’re sleeping.

15.3.             Getting started with scripting

A script is a series of statements that tells an application to perform a set of tasks. The trick is writing the statements in a language that the applications under­stand. FrameMaker support ExtendScript as its scripting language.

There are two ways of running scripts: from within FrameMaker and by using the ExtendScript Toolkit (ESTK).

15.3.1.            Run scripts from within FrameMaker

FrameMaker includes a menu entry that makes it easy to manage and run scripts.

 

•               To run a script:

 

a)           Click File > Script > Run.

 

b)           From the Script browser, select the script to be run.

 

c)           Click Open. The script is run from within FrameMaker.

 

•               To create a script:

 

a)           Click File > Script > New Script

 

b)           Compose your script in the ExtendScript TookKit (ESTK) that is opened.

 

c)           Save the script. Either run the script from within ESTK or run it from within FrameMaker.

 

15.3.2.            Manage your scripts from within FrameMaker

FrameMaker includes a script catalog that allows you to easily manage your scripts. Launch the catalog from File > Script > Catalog.

The Catalog looks as follows:

Scripts Catalog
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The catalog lets you manage favorite scripts, autorun scripts, and registered (notification) scripts.

Select the Favorites option in the catalog to manage your favorite scripts.

You can perform the following operations from this screen:

•                

To add a script as a favorite, click Add. Select the script from the script browser and click Select. The script is then added as a favorite.

 

•               To remove a script from the Favorites list, select the script and then click Remove.

 

•               Click Refresh to refresh the list of favorite scripts.

 

•               To mark a script as an Autorun script, select the script and click Move To AutoRun. The script is then copied from its exiting location into the autorun (startup) folder.

 

Manage favorite scripts

Select the Favorites option in the catalog to manage your favorite scripts.

You can perform the following operations from this screen:

•                

To add a script as a favorite, click Add. Select the script from the script browser and click Select. The script is then added as a favorite.

 

•               To remove a script from the Favorites list, select the script and then click Remove.

 

•               Click Refresh to refresh the list of favorite scripts.

 

•               To mark a script as an Autorun script, select the script and click Move To AutoRun. The script is then copied from its exiting location into the autorun (startup) folder.

 

Manage autorun scripts

Select the Autorun option in the catalog to manage your autorun scripts.

Autorun scripts are run automatically each time FrameMaker is launched. Any script that is placed in the following directories, becomes an autorun script.

•                

<FrameMaker installation folder>\startup 

•               <user’s home folder>\startup 

All scripts are run in alphabetical order.

You can perform the following operations:

•                

To add a script as an autorun script, click Add. Select the script from the script browser and click Select. The script is then placed in the startup folder and added to the autorun list.

 

•               To delete a script from the autorun list, select the script and click Delete.

 

•               Click Refresh to refresh the list of favorite scripts.

 

Manage registered (notification) scripts

Select the Registered option in the catalog to manage your registered scripts. Registered scripts are also called as notification scripts. These scripts are run when the events for which they are registered are triggered.

Notification is the internal mechanism through which a script registered for a particular event is run when the event is triggered.

Any script that is registered to run when an event is triggered is displayed in the notifications list in the catalog.

To unregister a notification script, select the script and click Unregister. The script is then unregistered. Once a script is unregistered, the script is not run, when the event for which it was previously registered is triggered.

note:  To add a notification script, see the section on notifications in the appendix.

Other features

There are two features that are common to every script type that you can manage through the catalog: view and delete broken scripts and select, edit and run a script.

View and delete broken scripts

When a script that has already been added to the catalog is moved or deleted from its current location in the file system, it is termed as a broken script.

To view such scripts, select the Show Broken only option in the catalog. The catalog then displays all the scripts that are broken.

You can then delete such scripts from the catalog. When you delete a script, it is only deleted from the catalog and not from its location in the file system.

Select, edit, and run a script from the catalog

 

•               To run a script from within the catalog, select the script from the list and click Run.

 

•               To edit a script from within the catalog, select the script from the list and click Edit. The script is opened in the ExtendScript ToolKit editor.

 

•               To run a new script (not added to the catalog yet), select the option marked New and click Run. Then, select the script from the script browser and click Open.

 

15.3.3.            Use the ExtendScript Toolkit

FrameMaker includes the ExtendScript ToolKit (ESTK). The ESTK is a devel­opment and debugging tool for ExtendScript scripts.

The ESTK has many features that make it easier to use than a text editor, including a built-in syntax checker that identifies where the problems are in your script and tries to explain how to fix them, and the ability to run your scripts right from the ESTK without saving the file.

All ExtendScript scripts are JavaScripts. The ESTK also includes a JavaScript debugger that allows you to:

•                

Single-step through JavaScript scripts (JS or JSX files) inside an applica­tion.

 

•               Inspect all data for a running script.

 

•               Set and execute breakpoints.

 

note:  For more information on ESTK, navigate to http://www.adobe.com/devnet/scripting.

note:  For more information on using ESTK in Technical Communication Suite, see Working with ExtendScript, in the Technical Communication Suite Using Guide.




16.                Keyboard Shortcuts

 

16.1.             About keyboard shortcuts

You can perform many tasks by using keyboard shortcuts. The plus sign (“+”) indicates that each key must be pressed simultaneously. For example, Control+z means to press the Control key and the z key simultaneously. If the shortcut keystroke does not contain the plus sign (+), press each key in the order the shortcut states. For example, “Esc m p” means to press and release the Esc (Escape) key, then the m key, and then the p key.

16.1.1.            Conventions and function keys

When you use keyboard shortcuts, Caps Lock must be off and, unless otherwise noted, a document window must be active.

The following table lists the terms used for special keys:



	
 

Notation

 


	
Press

 





	
arrow key

 


	
Up, down, right or left arrow keys

 





	
Esc

 


	
The key labeled Esc

 





	
Control

 


	
The key labeled Ctrl or Control

 





	
Alt

 


	
The key labeled Alt

 





	
Shift

 


	
The key labeled Shift

 





	
F2

 


	
The function key labeled F2. (If you should type F   followed by 2, the characters are shown as F 2)

 





	
space

 


	
The spacebar

 





	
plus

 


	
The key labeled with a plus sign (+)

 





	
minus or hyphen

 


	
The key labeled with a hyphen (-)

 





	
period

 


	
The key labeled with a period (.)

 





	
comma

 


	
The key labeled with a comma (,)

 





	
zero

 


	
The key labeled with the numeral 0

 





	
one

 


	
The key labeled with the numeral 1

 





	
Win

 


	
The key with the Windows logo

 






Keyboard shortcut sequences

The following table explains the conventions for showing key sequences and key combinations. When an uppercase letter appears in a shortcut, use the Shift key when typing the letter.

When one or more shortcuts accomplish the same action, the shortcuts are separated by commas; for example: Control+n, Shift+Down Arrow. You can use either Control+n or Shift+Down Arrow to accomplish the same action.



	
 

Keyboard shortcut sequence

 


	
Action

 





	
Esc Shift+t r

 


	
Press and release these keys in succession: the Esc key, the uppercase letter T, and the letter r

 





	
Control+e

 


	
Press Control and type the letter e

 





	
Control+ Shift+hyphen

 


	
Press Shift and Control and type a hyphen

 






Function keys

This table shows the result of pressing a function key or pressing a function key and either the Control, Shift, or Alt key simultaneously.



	
 

Key 


	
Function 


	
Control 


	
Shift 


	
Alt 





	
F1

 


	
Help

 


	
Align top

 


	
 


	
 





	
F2

 


	
Plain text

 


	
Align middle

 


	
 


	
 





	
F3

 


	
Underline

 


	
Align bottom

 


	
Overline

 


	
 





	
F4

 


	
Bold

 


	
 


	
Cascade


	
Exit

 





	
F5

 


	
Italic

 


	
 


	
Tile


	
 





	
F6

 


	
 Repeat Last Operation

 


	
 


	
 


	
 





	
F7

 


	
 


	
 


	
Point on document window

 


	
 





	
F8

 


	
Choose character format by typing

 


	
 


	
Change dialog box settings to As Is

 


	
 





	
F9

 


	
Choose paragraph format by typing

 


	
Transpose characters

 


	
Change dialog box settings to match current text

 


	
 





	
F10

 


	
 


	
 


	
Display context menu

 


	
 






Mouse

The following table lists the terms used for mouse actions.



	
 

Instruction 


	
Action 





	
Click

 


	
Click the mouse button.

 





	
Right-click

 


	
Click the right mouse button.

 





	
Double-click

 


	
Click the mouse button twice rapidly without moving the mouse.

 





	
Triple-click

 


	
Click the mouse button three times rapidly without moving the mouse.

 





	
Shift-click

 


	
Hold down Shift and click the mouse button.

 






16.2.             Navigating through documents



	
 

To go to

 


	
Keyboard shortcut

 





	
Last viewed and open document

 


	
Control+Tab

 





	
Previous page

 


	
Esc p p, Pg Up

 





	
Next page

 


	
Esc p n, Pg Dn

 





	
First page

 


	
Esc p f, Alt+Pg Up, Shift, and click the Previous Page button





	
Last page

 


	
Esc p l (lowercase L), Alt+Pg Dn, Shift, and click the Next Page button

 





	
Go To Page dialog box

 


	
Esc v p, Control+g

 





	
Source of a cross-reference

 


	
Press Alt+Control and click an active area





	
A specific page

 


	
Press Control+g or click the Page Status area and then type the page number

 





	
Page containing the insertion point

 


	
Press Control+g or click the Page Status area and then click Page Containing the Insertion Point

 





	
Start of a word


	
Control+left arrow





	
End of a word


	
Control+right arrow





	
Start of the next word

 


	
Esc b w

 





	
Start of a sentence


	
Control+Home





	
End of a sentence


	
Control+End





	
Start of a paragraph

 


	
Control+up arrow





	
End of the current paragraph

 


	
Control+Down Arrow





	
Start of the next paragraph

 


	
Esc b p

 





	
Top of a column

 


	
Control+Pg Up





	
Bottom of a column

 


	
Control+Pg Dn





	
Start of a flow

 


	
Alt+ Shift+Pg Up





	
End of a flow

 


	
Alt+ Shift+Pg Dn

 





	
Start of a line

 


	
Control+Pg Up





	
End of a line

 


	
Control+Pg Dn






16.3.             Keys for screen modes



	
 

Task

 


	
Keyboard shortcut

 





	
Standard screen mode

 


	
Esc S M s

 





	
Full screen with user interface

 


	
Esc S M u

 





	
Full screen mode

 


	
Esc S M f





	
Toggle screen mode

 


	
Esc S M t

 






16.4.             Keys for views



	
 

Display

 


	
Keyboard shortcut

 





	
WYSIWYG view

 


	
Esc S 1

 





	
Author view

 


	
Esc S 2

 





	
XML view

 


	
Esc S 3

 






16.5.             Dialog boxes

 

16.5.1.            Typing in dialog boxes

        In some cases, you must type a character sequence beginning with a back­slash (\) to enter a character in a dialog box. The sequence appears in the dialog box, but the character appears correctly in the document. The following table shows the sequences to type in a dialog box.

All key sequences described— here– begin with a backslash (\). To indicate a literal backslash in a dialog box, enter two backslashes (\\). In a few cases, you can choose between two backslash sequences for a character. In these cases, the sequences are separated by a comma.



	
 

Character name

 


	
Graphic

 


	
Backslash sequence

 





	
Bullet

 


	
[image: bullet_2.png]

 


	
\b

 





	
Circumflex

 


	
[image: circumflex.png]

 


	
\@

 





	
Dagger

 


	
†

 


	
\d

 





	
Dagger (double)

 


	
‡

 


	
\Shift+d

 





	
 Dash (em)

 


	
[image: emdash.png]

 


	
\m

 





	
Dash (en)

 


	
[image: endash.png]

 


	
\=

 





	
Ellipsis

 


	
…


	
\e

 





	
Florin

 


	
ƒ


	
\Shift+f

 





	
Forced return

 


	
 


	
\r

 





	
 Fraction

 


	
[image: fraction.png]

 


	
\ /

 





	
Grave

 


	
[image: grave.png]

 


	
\{

 





	
Guilsingl left

 


	
[image: guilsingl_left.png]

 


	
\(

 





	
Guilsingl right

 


	
[image: guilsingl_right.png]

 

 


	
\)

 





	
 Hungarumlaut

 


	
[image: hungarumlaut.png]

 


	
\&

 





	
 Hyphen (discretionary)

 


	
-


	
\- (hyphen)

 





	
Hyphen (nonbreaking)

 


	
-


	
\+

 





	
OE ligature

 


	
[image: oe_lig_cap.png]

 


	
\Shift+o Shift+e

 





	
oe ligature

 


	
[image: oe_lig.png]

 


	
\oe

 





	
Per thousand

 


	
‰


	
\%

 





	
 Quote (base single)

 


	
[image: quote_s_close.png]

 


	
\ ,





	
Quote (base double)

 


	
[image: quote_d_close.png]

 


	
\g

 





	
Quote (double left)

 


	
[image: quote_d_open.png]

 


	
\`





	
Quote (double right)

 


	
[image: quote_d_close00001.png]

 


	
\'





	
Quote (single)

 


	
[image: quote_s_open.png]

 


	
\"





	
 Space (em)

 


	
 


	
\sm, \Shift+m

 





	
Space (en)

 


	
 


	
\sn, \Shift+n

 





	
Space (nonbreaking)

 


	
 


	
\space

 





	
Space (numeric)

 


	
 


	
\s#, \#

 





	
Space (thin)

 


	
 


	
\st, \i

 





	
Suppress hyphenation

 


	
 


	
\_ (underscore)

 





	
Tab

 


	
 


	
\t

 





	
Trademark serif

 


	
[image: trademark.png]

 


	
\Shift+t Shift+m

 





	
 Y dieresis

 


	
[image: Y_dieresis.png]

 


	
\Shift+y : (colon)

 






 

16.5.2.            Window manipulation

To use these shortcuts, click in any FrameMaker window.



	
 

Task

 


	
Keyboard shortcut

 





	
Redisplay a document window

 


	
Esc w r, Control+l (lowercase L)

 





	
Close the active window or modeless dialog box

 


	
Alt+F4

 





	
Close the document window

 


	
Esc f q, Esc f c, Control+F4, Control+w, Control+Shift+w

 





	
Minimize the document window

 


	
Esc w c

 






16.5.3.            Display and activation

Use these shortcuts to display a window or dialog box and make it active. If it is already open but is behind another window, these shortcuts bring it to the front.



	
 

To display this window and make it active

 


	
Keyboard shortcut

 





	
Current document window

 


	
Esc Shift+f i d, Shift+F7





	
Find/Change

 


	
Esc Shift+f i f

 





	
Hypertext

 


	
Esc Shift+f i h

 





	
Marker

 


	
Esc Shift+f i m

 





	
Spelling Checker

 


	
Esc Shift+f i s

 





	
Paragraph Designer

 


	
Esc Shift+f i p

 





	
Character Designer

 


	
Esc Shift+f i c

 





	
Conditional Text

 


	
Esc Shift+f i o

 





	
Custom Ruling and Shading

 


	
Esc Shift+f i r

 





	
Table Designer

 


	
Esc Shift+f i t

 





	
Structure View

 


	
Esc Shift+f i v

 





	
Element Validation

 


	
Esc Shift+f i w

 






16.5.4.            Navigation within dialog boxes

Use these shortcuts to move to settings within dialog boxes and pods. When you use a keyboard shortcut in a window or dialog box, the shortcut’s effect depends on the active setting. The active setting is highlighted, has a dotted rectangle around it, or both.



	
 

Task

 


	
Keyboard shortcut

 





	
Move to the next setting

 


	
Tab

 





	
Move to the previous setting

 


	
Shift+Tab

 






16.5.5.            Command buttons



	
 

Task

 


	
Keyboard shortcut

 





	
Click the default button

 


	
Return

 





	
Click the active button

 


	
space

 





	
Cancel a dialog box (but not a window)

 


	
Esc

 






16.5.6.            Radio buttons and checkboxes



	
 

Task

 


	
Keyboard shortcut

 





	
Navigate through a group of radio buttons to turn on a radio button

 


	
arrow keys

 





	
Cycle through checkbox states (off, on, As Is)

 


	
space

 






16.5.7.            Pop-up menus



	
 

Task

 


	
Keyboard shortcut

 





	
Move to the previous menu item

 


	
up arrow

 





	
Move to the next menu item

 


	
Down Arrow

 





	
Search forward and select an item starting with a typed letter

 


	
UnShifted key

 






16.5.8.            Scroll lists



	
 

Task

 


	
Keyboard shortcut

 





	
Move to the previous item in a list

 


	
up arrow

 





	
Move to the next item in a list

 


	
Down Arrow

 





	
Search forward and select an item starting with a typed letter

 


	
UnShifted key





	
Move an item in a scroll list to the opposite scroll list

 


	
Double-click the item





	
Move all items in a scroll list to the opposite scroll list

 


	
Press and click arrow between scroll lists






16.5.9.            Custom menus



	
 

Task 


	
Keyboard shortcut

 





	
Display a custom menu bar

 


	
Esc v m u

 






16.6.             Keys for selection

Use these shortcuts to select objects on the current page.



	
 

Task 


	
Keyboard shortcut

 





	
Select a text line or text frame

 


	
Press Control and click the text line or text frame

 





	
Extend or shorten the selection

 


	
Press Shift and click an object

 





	
Force selection border to appear (when dragging from outside all objects is not possible)

 


	
Press Control+ Shift and drag diagonally

 





	
Select the first object in the draw order

 


	
Esc o Shift+f

 





	
Select the next object in the draw order

 


	
Esc o n

 





	
Extend the selection to the next object in the draw order

 


	
Esc o e

 





	
Deselect a text frame or text line and put the insertion point inside it instead

 


	
Double-click in the text frame or text line

 






16.7.             Menu commands

 

16.7.1.            Context menus



	
 

Task 


	
Action

 





	
Display a pop-up menu of commands that apply to the current selection or context

 


	
Right-click on an object, in a document margin, or in a book window

 






16.7.2.            File menu (document window)



	
 

Task

 


	
Keyboard shortcut

 





	
New>Document

 


	
Esc f n, Control+n

 





	
New>Book

 


	
Esc f Shift+n

 





	
Open

 


	
Esc f o, Control+o

 





	
Close

 


	
Esc f c, Esc f q, Control+w, Control+F4, Control+Shift+w

 





	
Close All

 


	
Esc f Shift+c, Esc f Shift+q

 





	
Save

 


	
Esc f s, Control+s

 





	
Save All

 


	
Esc f Shift+s

 





	
Save As

 


	
Esc f a

 





	
Save As PDF

 


	
Esc f w p

 





	
Save As XML

 


	
Esc f w x

 





	
Revert to Saved

 


	
Esc f r

 





	
Import>File

 


	
Esc f i f

 





	
Import>Formats

 


	
Esc f i o

 





	
Import>Object

 


	
Esc f i b

 





	
Import>Element Definitions

 


	
Esc f i e

 





	
Print

 


	
Esc f p, Control+p

 





	
Print Setup

 


	
Control+ Shift+p

 





	
Send

 


	
Esc f m

 





	
Send All Open Files

 


	
Esc f Shift+m

 





	
Utilities>Compare Documents

 


	
Esc f t c

 





	
Utilities>Document Reports

 


	
Esc f t r

 





	
Utilities>HTML Setup

 


	
Esc f t h

 





	
Utilities>Create and Apply Formats

 


	
Esc f t f

 





	
Utilities>Hex Input

 


	
Win h

 





	
Utilities>Character Palette

 


	
Win i

 





	
Preferences

 


	
Esc f Shift+p

 





	
Exit

 


	
Alt+F4

 






16.7.3.            File menu (book window)



	
 

Task

 


	
Keyboard shortcut

 





	
New Document

 


	
Esc f n, Control+n

 





	
New Book

 


	
Esc f Shift+n

 





	
Open

 


	
Esc f o, Control+o

 





	
Open All Files in Book

 


	
Esc f Shift+o

 





	
Close Book   


	
Esc f c, Control+w

 





	
Close All Files in Book

 


	
Esc f Shift+c

 





	
Save Book

 


	
Esc f s, Control+s

 





	
Save All Files in Book

 


	
Esc f Shift+s

 





	
Save Book As

 


	
Esc f a

 





	
Revert to Saved Book

 


	
Esc f r

 





	
Import>Formats

 


	
Esc f i o

 





	
Import>Element Definitions


	
Esc f i e

 





	
Print Selected Files

 


	
Esc f Shift+f,

 





	
Print Book

 


	
Esc f p, Control+p

 





	
Print Setup

 


	
Control+ Shift+p

 





	
Utilities>Compare Books

 


	
Esc f b

 





	
Preferences

 


	
Esc f Shift+p

 





	
Exit

 


	
Alt+F4

 






16.7.4.            Edit menu (document window)



	
 

Task

 


	
Keyboard shortcut 





	
Undo/Redo

 


	
Esc e u, Control+z, Control+ Shift+z

 





	
Cut

 


	
Esc e x, Control+x, Shift+Delete

 





	
Copy

 


	
Esc e c, Control+c, Control+Insert

 





	
Paste

 


	
Esc e p, Control+v, Shift+Insert

 





	
Paste Special

 


	
Control+ Shift+v

 





	
Clear

 


	
Esc e b

 





	
Copy Special>Attribute Values

 


	
Esc e y a

 





	
Copy Special>Paragraph Format

 


	
Esc e y p

 





	
Copy Special>Character Format

 


	
Esc e y c

 





	
Copy Special>Conditional Text Settings

 


	
Esc e y d

 





	
Copy Special>Table Column Width

 


	
Esc e y w

 





	
Select All in Flow

 


	
Esc e a, Control+a

 





	
Find/Change

 


	
Esc e f, Control+f

 





	
Find Next

 


	
Esc f i n, Esc e Shift+f, Control+ Shift+f

 





	
Spelling Checker

 


	
Esc e s

 





	
Thesaurus

 


	
Esc e t

 





	
Text Inset Properties

 


	
Esc e i

 





	
Update References

 


	
Esc e Shift+u

 





	
History

 


	
Ctrl K, Esc e h

 





	
Auto Spell Check On/Off

 


	
Esc a u s

 





	
Repeat

 


	
F6

 





	
Links

 


	
Esc e k

 





	
Object

 


	
(No shortcut available)

 






16.7.5.            Edit menu (book window)



	
 

Task

 


	
Keyboard shortcut 





	
Undo/Redo

 


	
Esc e u, Control+z, Control+ Shift+z

 





	
History

 


	
Esc e h

 





	
Cut

 


	
Esc e x, Control+x, Shift+Delete

 





	
Copy

 


	
Esc e c, Control+c

 





	
Paste

 


	
Esc e p, Control+v

 





	
Clear

 


	
Esc e b

 





	
Copy Special>Attribute Values

 


	
Esc e y a

 





	
Select>All


	
Esc e a

 





	
Select>Generated Files

 


	
Esc e Shift+a Shift+g

 





	
Select>Nongenerated Files

 


	
Esc e Shift+a Shift+n

 





	
Select>FrameMaker Files

 


	
Esc e Shift+a Shift+f

 





	
Select>Excluded Components

 


	
Esc e Shift+a Shift+e

 





	
Select>Non-Excluded Components

 


	
Esc e Shift+n Shift+e

 





	
Select>Chapter Components

 


	
Esc c l

 





	
Select>Section Components

 


	
Esc s l

 





	
Select>Sub-Section Components

 


	
Esc s s l

 





	
Find/Change

 


	
Esc e f, Control+f

 





	
Find Next

 


	
Esc f i n, Esc e Shift+f, Control+ Shift+f

 





	
Spelling Checker

 


	
Esc e s

 





	
Set Up Generated File

 


	
Esc f d

 





	
Rename


	
Esc f e, F2

 





	
Delete

 


	
Esc f x

 





	
Suppress Automatic Reference Updating

 


	
Esc e Shift+s

 





	
Update Book

 


	
Esc e Shift+u, Esc f g

 






16.7.6.            Add menu (book window)



	
 

Menu command

 


	
Keyboard shortcut 





	
Files

 


	
Esc f f

 





	
Table of Contents

 


	
Esc t o c

 





	
List of>Figures

 


	
Esc l (lowercase L) o f

 





	
List of>Tables

 


	
Esc l (lowercase L) o t

 





	
List of>Elements & Paragraphs

 


	
Esc l (lowercase L) o p

 





	
List of>Elements & Paragraphs (Alphabetical)

 


	
Esc l (lowercase L) o Shift+p

 





	
List of>Markers

 


	
Esc l (lowercase L) o m

 





	
List of>Markers (Alphabetical)

 


	
Esc l (lowercase L) o Shift+m

 





	
List of>References

 


	
Esc l (lowercase L) o r

 





	
Standard Index of Authors

 


	
Esc i x

 





	
Index of>Authors

 


	
Esc i o a

 





	
Index of>Subjects

 


	
Esc i o s

 





	
Index of>Markers

 


	
Esc i o m

 





	
Index of>References

 


	
Esc i o r

 






16.7.7.            Element menu



	
 

Task 


	
Keyboard shortcut 





	
Merge


	
Esc Shift+e m

 





	
Split

 


	
Esc Shift+e s

 





	
Unwrap


	
Esc Shift+e u

 





	
Edit Attributes

 


	
Esc Shift+e Shift+a

 





	
Namespaces

 


	
Esc Shift+e Shift+n

 





	
Element Catalog

 


	
Esc Shift+e Shift+c

 





	
Set Available Elements

 


	
Esc Shift+e Shift+o Shift+c

 





	
New Element Options

 


	
Esc Shift+e Shift+o Shift+i





	
Validate

 


	
Esc Shift+e v

 






16.7.8.            Format menu



	
 

Menu command 


	
Keyboard shortcut 





	
Font

 


	
(No shortcut available)





	
Size

 


	
(No shortcut available)





	
Style>Plain

 


	
Esc c p, F2

 





	
Style>Bold

 


	
Esc c b, F4, Control+b, Control+ Shift+b

 





	
Style>Italic

 


	
Esc c i, F5, Control+i

 





	
Style>Underline

 


	
Esc c u, Control+u, Control+ Shift+u

 





	
Style>Double Underline

 


	
Esc c d

 





	
Style>Overline

 


	
Esc c o

 





	
Style>Strikethrough

 


	
Esc c s, Control+/

 





	
Style>Change Bar

 


	
Esc c h, Control+ Shift+h

 





	
Style>Superscript

 


	
Esc c plus

 





	
Style>Subscript

 


	
Esc c minus

 





	
Style>Small Caps

 


	
Esc c m, Control+e

 





	
Characters>Designer

 


	
Esc o c d, Control+d

 





	
Characters>Catalog

 


	
Esc o c c

 





	
Characters>Default Paragraph Font

 


	
Esc o c p

 





	
Paragraphs>Designer

 


	
Esc o p d, Control+m, Control+ Shift+m

 





	
Paragraphs>Catalog

 


	
Esc o p c

 





	
Page Layout>Column Layout

 


	
Esc o c l (lowercase L)

 





	
Page Layout>Line Layout

 


	
Esc o l l (lowercase L)

 





	
Page Layout> Page Size

 


	
Esc o p s

 





	
Page Layout>Pagination

 


	
Esc o p i

 





	
Page Layout>Master Page Usage

 


	
Esc o m u

 





	
Page Layout>New Master Page


	
Esc o m p

 





	
Page Layout>Update Column Layout


	
Esc o u p

 





	
Customize Layout>Customize Text Frame

 


	
Esc o c f

 





	
Customize Layout>Connect Text Frames

 


	
Esc Shift+c Shift+c

 





	
Customize Layout>Disconnect Previous

 


	
Esc Shift+c Shift+p

 





	
Customize Layout>Disconnect Next

 


	
Esc Shift+c Shift+n

 





	
Customize Layout> Disconnect Both

 


	
Esc Shift+c Shift+b

 





	
Customize Layout> Split Text Frame

 


	
Esc Shift+c Shift+s

 





	
Customize Layout>Rotate Page Clockwise

 


	
Esc p Shift+o

 





	
Customize Layout>Rotate Page Counterclockwise

 


	
Esc p o

 





	
Customize Layout>Unrotate Page


	
Esc p Shift+u

 





	
Customize Layout>Combined Fonts

 


	
Esc o c o

 





	
Document>Numbering

 


	
Esc o d n, Esc e n

 





	
Document>Change Bars

 


	
Esc o b

 





	
Document>Footnote Properties


	
Esc o f

 





	
Document>Text Options

 


	
Esc o t o

 





	
Document>PDF Setup

 


	
Esc o d a

 





	
Document>Rubi Properties

 


	
Esc o r

 





	
Headers & Footers>Insert Page #

 


	
Esc o h p

 





	
Headers & Footers>Insert Page Count

 


	
Esc o h c

 





	
Headers & Footers>Insert Current Date

 


	
Esc o h d

 





	
Headers & Footers>Insert Other

 


	
Esc o h o

 






16.7.9.            View menu (document window)



	
 

Menu command 


	
Keyboard shortcut 





	
QuickAccess Bar

 


	
Esc v q

 





	
Paragraph Formatting Bar

 


	
Esc V p a

 





	
Text Formatting Bar

 


	
Esc V t e

 





	
Table Formatting Bar

 


	
Esc V t a

 





	
Object Alignment

 


	
Esc V o a

 





	
Object Properties Bar

 


	
Esc V o p

 





	
Track Text Edit Bar

 


	
Esc Shift+v e

 





	
Borders

 


	
Esc v b

 





	
Text Symbols

 


	
Esc v t

 





	
Rulers

 


	
Esc v r

 





	
Grid Lines

 


	
Esc v g

 





	
Element Boundaries

 


	
Esc v Shift+e

 





	
Element Boundaries (as Tags)

 


	
Esc v Shift+t

 





	
Options

 


	
Esc v o

 





	
Attribute Display Options

 


	
Esc v Shift+a

 





	
Go to Page

 


	
Esc v p, Control+g, Control+ Shift+g

 





	
Body Pages

 


	
Esc v Shift+b

 





	
Master Pages

 


	
Esc v Shift+m

 





	
Reference Pages

 


	
Esc v Shift+r

 





	
Color>Views

 


	
Esc v c v

 





	
Color>Definitions

 


	
Esc v c d

 





	
Menus>Quick

 


	
Esc v m q

 





	
Menus>Complete

 


	
Esc v m c

 





	
Menus>Modify

 


	
Esc v m m

 






16.7.10.       View menu (book window)



	
 

Menu command 


	
Keyboard shortcut 





	
QuickAccess Bar

 


	
Esc v q

 





	
Text Formatting


	
Esc V t e

 





	
Table Formatting


	
Esc V t a

 





	
Paragraph Formatting


	
Esc V p a

 





	
Object Alignment

 


	
Esc V o a

 





	
Object Properties


	
Esc V o p

 





	
Track Text Edit


	
Esc Shift+v e

 





	
Borders

 


	
Esc Shift+v b s

 





	
Hide Borders

 


	
Esc Shift+v b h

 





	
Show Text Symbols

 


	
Esc Shift+v t s

 





	
Hide Text Symbols

 


	
Esc Shift+v t h

 





	
Show Rulers

 


	
Esc Shift+v r s

 





	
Hide Rulers

 


	
Esc Shift+v r h

 





	
Show Grid Lines

 


	
Esc Shift+v g s

 





	
Hide Grid Lines

 


	
Esc Shift+v g h

 





	
Show Graphics

 


	
Esc Shift+v v s

 





	
Hide Graphics

 


	
Esc Shift+v v h

 





	
Filter By Attribute

 


	
Esc a c

 





	
Show Element Boundaries

 


	
Esc Shift+v Shift+e s

 





	
Hide Element Boundaries

 


	
Esc Shift+v Shift+e h

 





	
Show Element Boundaries (as Tags)

 


	
Esc Shift+v Shift+t s

 





	
Options

 


	
Esc v o

 





	
Attribute Display Options

 


	
Esc v Shift+a

 





	
Zoom>In

 


	
Esc z i

 





	
Zoom>Out

 


	
Esc z o

 





	
Zoom>100 percent

 


	
Esc z z

 





	
Zoom>Fit Page in Window

 


	
Esc z p

 





	
Zoom>Fit Window to Page

 


	
Esc z w

 





	
Zoom>Fit Window to Text Frame

 


	
Esc z f

 





	
Color>Views

 


	
Esc v c v

 





	
Color>Definitions

 


	
Esc v c d

 





	
Menus>Quick

 


	
Esc v m q

 





	
Menus>Complete

 


	
Esc v m c

 





	
Menus>Modify

 


	
Esc v m m

 






16.7.11.       Special menu



	
 

Menu command 


	
Keyboard shortcut 





	
Page Break

 


	
Esc s p b

 





	
Anchored Frame

 


	
Esc s a

 





	
Footnote

 


	
Esc s f

 





	
Cross-Reference

 


	
Esc s c

 





	
Variable

 


	
Esc s v

 





	
Hypertext

 


	
Esc s h

 





	
Marker

 


	
Esc s m

 





	
Equations

 


	
Esc s e

 





	
Filter By Attribute

 


	
Esc a c

 





	
Conditional Text


	
Esc s Shift+c

 





	
Manage Conditional Text

 


	
Esc m Shift+c

 





	
Apply Conditional Text

 


	
Esc s Shift+c

 





	
Show/Hide Conditional Text

 


	
Esc v Shift+c

 





	
Show Condition Indicator

 


	
Esc Shift+v Shift+o s

 





	
Hide Condition Indicator

 


	
Esc Shift+v Shift+o h

 





	
Toggle Conditional Indicators On/Off

 


	
Esc v Shift+o

 





	
Show One Conditional Text Tag


	
Esc q Shift+s

 





	
Select Same Condition Tags

 


	
Esc h Shift+c

 





	
View the condition applied to the text where the cursor is placed

 


	
Esc q Shift+c

 





	
Focus in Conditional Text

 


	
Esc Shift+f i o

 





	
Close Conditional Text dialog box

 


	
Esc Shift+c o

 





	
Turn on or off the Track Text Edit feature

 


	
Esc s t o

 





	
Show Next

 


	
Esc s t n

 





	
Show Previous

 


	
Esc s t p

 





	
Accept Edit

 


	
Esc s t a

 





	
Reject Edit

 


	
Esc s t r

 





	
Accept All

 


	
Esc s t Shift+a

 





	
Reject All

 


	
Esc s t Shift+r

 





	
Preview Final

 


	
Esc s t Shift+f

 





	
Preview Original

 


	
Esc s t Shift+o

 





	
Preview Off

 


	
Esc s p o

 





	
Rubi

 


	
Esc s r

 





	
Table of Contents

 


	
Esc t o c

 





	
List of>Figures

 


	
Esc l o f

 





	
List of>Tables

 


	
Esc l o t

 





	
List of>Elements & Paragraphs

 


	
Esc l o p

 





	
List of>Elements & Paragraphs (Alphabetical)

 


	
Esc l o Shift+p

 





	
List of>Markers (Alphabetical)

 


	
Esc l o m

 





	
List of>Markers

 


	
Esc l o Shift+m

 





	
List of>References

 


	
Esc l o r

 





	
Standard Index

 


	
Esc i x

 





	
Index of>Authors

 


	
Esc i o a

 





	
Index of>Subjects

 


	
Esc i o s

 





	
Index of>Markers

 


	
Esc i o m

 





	
Index of>References

 


	
Esc i o r

 





	
Add Disconnected Pages

 


	
Esc s p a

 





	
Delete Pages

 


	
Esc s p d

 





	
Remove Structure from Flow

 


	
Esc s s f

 






16.7.12.       Graphics menu



	
 

Menu command 


	
Keyboard shortcut 





	
Tools

 


	
Esc g Shift+t, Esc one w

 





	
Group

 


	
Esc g g

 





	
Ungroup

 


	
Esc g u

 





	
Bring to Front

 


	
Esc g f

 





	
Send to Back

 


	
Esc g b

 





	
Align

 


	
Esc g a

 





	
Distribute

 


	
Esc g d

 





	
Reshape

 


	
Esc g r

 





	
Smooth

 


	
Esc g s

 





	
Unsmooth

 


	
Esc g m

 





	
Flip Up/Down

 


	
Esc g v

 





	
Flip Left/Right

 


	
Esc g h

 





	
Rotate

 


	
Esc g t

 





	
Scale

 


	
Esc g z

 





	
Set # Sides

 


	
Esc g n

 





	
Join


	
Esc g j

 





	
Object Properties

 


	
Esc g o

 





	
Pick up Properties

 


	
Esc g Shift+o

 





	
Runaround Properties

 


	
Esc g Shift+r

 





	
Gravity

 


	
Esc g y

 





	
Snap

 


	
Esc g p

 





	
3D Menu Background Color option

 


	
Alt + g + 3 + b

 





	
3D Menu Lighting option

 


	
Alt + g + 3 + l (lowercase L)

 





	
Lights From File

 


	
Alt + g + 3 + l + (lowercase L) + l (lowercase L)

 





	
No Lights

 


	
Alt + g + 3 + l (lowercase L) + n

 





	
White Lights

 


	
Alt + g + 3 +l (lowercase L) +w

 





	
Day Lights

 


	
Alt + g + 3 + l (lowercase L) + d

 





	
Bright Lights

 


	
Alt + g + 3 + l (lowercase L) + b

 





	
Primary Color Lights

 


	
Alt + g + 3 + l (lowercase L) + p

 





	
Night Lights

 


	
Alt + g + 3 + l (lowercase L) + i

 





	
Blue Lights

 


	
Alt + g + 3 + l (lowercase L) + u

 





	
Red Lights

 


	
Alt + g + 3 + l (lowercase L) + r

 





	
Cube Lights

 


	
Alt + g + 3 +l (lowercase L) +c

 





	
CAD Optimized Lights

 


	
Alt + g + 3 + l (lowercase L) + o

 





	
Headlamp

 


	
Alt + g + 3 + l (lowercase L) + h

 





	
Show Existing Views

 


	
Alt + g + 3 + s

 





	
Render Mode option

 


	
Alt + g + 3 +r

 





	
Bounding Box

 


	
Alt + g + 3 +r + b

 





	
Transparent Bounding Box

 


	
Alt + g + 3 + r + t

 





	
Transparent Bounding Box Outline

 


	
Alt + g + 3 + r + o

 





	
Vertices

 


	
Alt + g + 3 + r + v

 





	
Shaded Vertices

 


	
Alt + g + 3 + r + s

 





	
Wireframe

 


	
Alt + g + 3 + r +w

 





	
Shaded Wireframe

 


	
Alt + g + 3 +r + h

 





	
Solid

 


	
Alt + g + 3 + r + l (lowercase L)

 





	
Transparent

 


	
Alt + g + 3 + r + r

 





	
Solid Wireframe

 


	
Alt + g + 3 +r + i

 





	
Transparent Wireframe

 


	
Alt + g + 3 +r + a

 





	
Illustration

 


	
Alt + g + 3 + r + u

 





	
Solid Outline

 


	
Alt + g + 3 + r + d

 





	
Shaded Illustration

 


	
Alt + g + 3 + r + e

 





	
Hidden Wireframe

 


	
Alt + g + 3 +r + n

 






16.7.13.       Table menu



	
 

Task 


	
Keyboard shortcut 





	
Insert Table

 


	
Esc t i

 





	
Table Designer

 


	
Esc t d, Control+t, Control+Shift+t

 





	
Row Format

 


	
Esc t r

 





	
Custom Ruling & Shading

 


	
Esc t x

 





	
Add Rows or Columns

 


	
Esc t a

 





	
Resize Columns

 


	
Esc t z

 





	
Straddle/Unstraddle

 


	
Esc t l (lowercase L)

 





	
Convert to Table/Convert to Paragraphs

 


	
Esc t v

 





	
Sort

 


	
Esc t s

 






16.7.14.       StructureTools menu



	
 

Menu command 


	
Keyboard shortcut 





	
StructureTools>Set Structured Application

 


	
Esc f + Shift+a, Alt + r + u

 





	
StructureTools>Utilities

 


	
Alt + r + l

 





	
StructureTools>Utilities>Convert Structured Documents

 


	
Esc f + t + s, Alt + r + l + c

 





	
StructureTools>Utilities>Convert Documents to Structured Format

 


	
Esc f + t + d, Alt + r + l + d

 





	
StructureTools>Utilities>Structure Current Document

 


	
Esc f + t + Shift+c, Alt + r + l + s

 





	
StructureTools>Utilities>Structure Documents

 


	
Esc f + t + Shift+d, Alt + r + l + t

 





	
StructureTools>New EDD

 


	
Esc f Shift+d Shift+n

 





	
StructureTools>Export Element Catalog as EDD

 


	
Esc f Shift+d Shift+x

 





	
StructureTools>Import CSS Styles


	
Esc f Shift+d Shift+j

 





	
StructureTools>Show Element context

 


	
Esc f Shift+d Shift+e

 





	
StructureTools>Open DTD

 


	
Esc f Shift+d Shift+o

 





	
StructureTools>Import DTD

 


	
Esc f Shift+d Shift+m

 





	
StructureTools>Save as DTD

 


	
Esc f Shift+d Shift+s

 





	
StructureTools>Open Schema

 


	
Esc f Shift+d Shift+y

 





	
StructureTools>Import Schema

 


	
Esc f Shift+d Shift+z

 





	
StructureTools>Edit Application Definitions

 


	
Esc f Shift+d Shift+a

 





	
StructureTools>Read Application Definitions

 


	
Esc f Shift+d Shift+r

 





	
StructureTools>New read/write Rules

 


	
Esc f Shift+d Shift+w

 





	
StructureTools>Check read/write Rules

 


	
Esc f Shift+d Shift+c

 





	
StructureTools>Parse Structured Document

 


	
Esc f Shift+d Shift+p

 





	
StructureTools>Generate Conversion Table

 


	
Esc f Shift+d Shift+g

 





	
StructureTools>Generate CSS2

 


	
Esc f Shift+d Shift+h

 






16.7.15.       DITA menu



	
 

Menu command 


	
Keyboard shortcut 





	
DITA>New DITA File>New <mapi>

 

map<i> refers to an element whose class attribute starts with map/map and can vary from 1 to i.

 


	
Esc Shift+n Shift+m i

 





	
DITA>New DITA File>New <topici>

 

DITA>New DITA File>New <concepti>

 

DITA>New DITA File>New <taski>

 

DITA>New DITA File>New <referencei>

 

topic<i> refers to an element whose class attribute starts with topic/topic and can vary from 1 to i.

 


	
Esc Shift+n Shift+t 1

 

Esc Shift+n Shift+t 2

 

Esc Shift+n Shift+t i

 





	
DITA>New DITA File>Refresh Menu

 


	
Esc Shift+r Shift+m

 





	
DITA>Insert Conref

 


	
Esc Shift+i Shift+c

 





	
DITA>Assign ID to Element

 


	
Esc Shift+a Shift+i

 





	
DITA>Update References

 


	
Esc Shift+u Shift+r

 





	
DITA>Open all Topicrefs

 


	
Esc Shift+o Shift+a

 





	
DITA>Insert Topicref

 


	
Esc Shift+i Shift+t

 





	
DITA>Build FM Document From DITA Map

 


	
Esc Shift+g Shift+d

 





	
DITA>DITA Options

 


	
Esc Shift+d Shift+o

 






16.7.16.       Window menu



	
 

Menu command 


	
Keyboard shortcut 





	
Cascade

 


	
Shift+F4

 





	
Tile

 


	
Shift+F5

 





	
Arrange Icons

 


	
(No shortcut available)

 





	
Refresh

 


	
Control+l (lowercase L)

 






16.8.             Tables

 

16.8.1.            Selection in tables



	
 

To select

 


	
Keyboard shortcut

 





	
A cell

 


	
Press Control and click the cell

 





	
A row

 


	
Press Control and double-click column (vertical) border in the row





	
A column

 


	
Press Control and double-click row (horizontal) border in the row





	
Text in the cell above the current cell

 


	
Esc t m u a

 





	
Text in the cell below the current cell

 


	
Esc t m d a

 





	
All text in current cell

 


	
Esc t h a





	
Current cell, then next cell

 


	
Esc t h e





	
Current row, then next row

 


	
Esc t h r





	
Current column, then next column

 


	
Esc t h c





	
Body cells in current column, then next body cells

 


	
Esc t h b





	
Current table

 


	
Esc t h t, or press Control and triple-click a cell

 





	
Extend or shorten the election

 


	
Press Control+- and click the last cell you want in the selection

 






16.8.2.            Navigating through tables

Use these shortcuts to move to the indicated cell.



	
 

To move to the


	
Keyboard shortcut

 





	
Cell to the right

 


	
Esc t m r

 





	
Cell to the left

 


	
Esc t m l (lowercase L)

 





	
Cell below

 


	
Esc t m d

 





	
Cell above

 


	
Esc t m u

 





	
Rightmost cell in the current row

 


	
Esc t m e

 





	
Leftmost cell in the current row

 


	
Esc t m a

 





	
Top cell in the current column

 


	
Esc t m t

 





	
Bottom cell in the current column

 


	
Esc t m b

 





	
Top-left selected cell

 


	
Esc t m s, Esc t h zero

 





	
Top-left cell

 


	
Esc t m Shift+t

 





	
Beginning of cell

 


	
Control+Page Up

 





	
End of cell

 


	
Control+Page Down

 





	
Next cell and select all text in cell

 


	
Tab, Esc t m n

 





	
Previous cell and select all text in cell

 


	
Shift+Tab, Esc t m p

 





	
Cell below and select all text in cell

 


	
Control+Alt+Tab

 





	
Cell above and select all text in cell

 


	
Control+Alt+Shift+Tab

 





	
Anchor point of a table

 


	
Esc t Shift+i

 






16.8.3.            Tab characters in cells



	
 

To

 


	
Keyboard shortcut

 





	
Type a tab character in a cell


	
Esc Tab

 






16.8.4.            Row and column manipulation

FrameMaker adds or deletes as many rows or columns as are currently selected.



	
 

Task

 


	
Keyboard shortcut

 





	
Add rows above top selected row

 


	
Esc t Shift+r a

 





	
Add rows below bottom selected row

 


	
Esc t Shift+r b, Control+Return, Control+j

 





	
Add columns to left of leftmost selected column

 


	
Esc t c l (lowercase L)

 





	
Add columns to right of rightmost selected column

 


	
Esc t c r

 





	
Delete contents of selected rows or columns, but leave cells in table

 


	
Esc t c e

 





	
Delete selected rows or columns from table

 


	
Esc t c x

 





	
Sort rows and columns

 


	
Esc t s

 






16.8.5.            Row and column replacement

If the Clipboard doesn’t contain whole rows or columns, these shortcuts always replace the selected cells.



	
 

To paste whole rows or columns

 


	
Keyboard shortcut

 





	
By replacing selected rows or columns

 


	
Esc t p r

 





	
Before current selection (above top selected row or to left of leftmost selected column)

 


	
Esc t p b

 





	
After current selection (below bottom selected row or to right of rightmost selected column)

 


	
Esc t p a

 






16.8.6.            Vertical alignment in cells

To use these shortcuts, click in the first paragraph in a cell.



	
 

Alignment

 


	
Keyboard shortcut

 





	
Top alignment

 


	
Esc j t, Control+F1

 





	
Middle alignment

 


	
Esc j m, Control+F2

 





	
Bottom alignment

 


	
Esc j b, Control+F3

 






16.8.7.            Column width



	
 

To resize

 


	
Keyboard shortcut

 





	
Columns so no paragraphs in selected cells wrap

 


	
Esc t w

 





	
Selected column without changing table’s width


	
Press Alt and drag selected cell’s handle





	
Copy column width to Clipboard

 


	
Esc e y w

 






16.8.8.            Table Designer

To use these shortcuts, click in the Table Designer.



	
 

Task

 


	
Keyboard shortcut

 





	
Change all settings to As Is


	
Shift+F8





	
Change all settings to match the selected table

 


	
Shift+F9

 





	
Display previous page of properties

 


	
Page Up

 





	
Display next page of properties

 


	
Page Down

 





	
Apply only the current group of properties

 


	
Press Control and click Apply






16.8.9.            Table formats



	
 

Task

 


	
Keyboard shortcut

 





	
Apply the current table’s format to the catalog and to all tables that have the same tag


	
Esc t u t

 





	
Display the Edit Ruling Style dialog box

 


	
Esc t e

 






16.9.             Book commands



	
 

Task

 


	
Keyboard shortcut

 





	
New Book

 


	
Esc f Shift+n

 





	
Save Book

 


	
Esc f s, Control+s

 





	
Rename File

 


	
Esc f e or F2

 





	
Update Book

 


	
Esc e Shift+u,Esc f g

 





	
Display filenames (in book window)

 


	
Esc Shift+v Shift+m

 





	
Display paragraph headings (in book window)

 


	
Esc Shift+v Shift+x

 





	
Delete File from Book

 


	
Esc f x

 





	
Select All Files

 


	
Esc e a

 





	
Save all files in book

 


	
Esc f Shift+s

 





	
Close all files in book

 


	
Esc f Shift+c

 





	
Select All FrameMaker Files

 


	
Esc e Shift+a Shift+f

 





	
Select All Non-Generated FrameMaker Files

 


	
Esc e Shift+a Shift+n

 





	
Select All Generated FrameMaker Files

 


	
Esc e Shift+a Shift+g

 





	
Select a range of files

 


	
Shift+click

 





	
Select discontiguous files

 


	
Control+click

 





	
Move up a file in book

 


	
Esc m u

 





	
Move a file down in book

 


	
Esc m d

 





	
Print Book

 


	
Esc f p, Control+p

 





	
Print Selected Files in Book

 


	
Esc f Shift+f

 






16.10.       Keys for finding and changing

 



	
 

Task

 


	
Keyboard shortcut

 





	
Search forward

 


	
Esc f i n,Esc e Shift+f, Control+ Shift+f, Alt+Control+s

 





	
Search backward

 


	
Esc f i p, Alt+Control+f, Alt+Control+r

 





	
Change current selection

 


	
Esc r o

 





	
Change all occurrences of Find text in document

 


	
Esc r g

 





	
Change and search again

 


	
Esc r a

 





	
Change settings to As Is in Find Character Format and Change To Character Format dialog boxes

 


	
Shift+F8





	
Change settings to match selected text in Find Character Format and Change To Character Format dialog boxes

 


	
Shift+F9

 





	
Display Set Find/Change Parameters dialog box

 


	
Esc f i s

 





	
Find 


	
Keyboard shortcut 





	
Tab symbol

 


	
\t

 





	
Forced return

 


	
\r

 





	
End-of-paragraph symbol

 


	
\p

 





	
Start of paragraph

 


	
\P

 





	
Nonbreaking space

 


	
\ (space)

 





	
Thin space

 


	
\i, \st

 





	
 


	
 





	
Find 


	
Keyboard shortcut 





	
En space

 


	
\N, \sn

 





	
Em space

 


	
\M, \sm

 





	
Numeric space

 


	
\#, \s#

 





	
End-of-flow symbol

 


	
\f

 





	
` (grave)

 


	
\{

 





	
\ (backslash)

 


	
\\

 





	
Discretionary hyphen

 


	
\- (hyphen)

 





	
Nonbreaking hyphen

 


	
\+

 





	
Suppress hyphenation symbol

 


	
\_ (underscore)

 





	
Start of word

 


	
\<

 





	
End of word

 


	
\>

 





	
 


	
 





	
With Use Wildcards turned on... 


	
 





	
Any number of characters

 


	
*

 





	
Spaces or punctuation

 


	
| (bar)

 





	
Any one character

 


	
?

 





	
The beginning of a line

 


	
^

 





	
The end of a line

 


	
$

 





	
Any one of the bracketed characters ab 


	
[ab]

 





	
Any character except ab 


	
[^ab]

 





	
Any character from a to f 


	
[a-f]

 






16.11.       Documents

 

16.11.1.       Help



	
 

Task

 


	
Keyboard shortcut

 





	
Display online Help

 


	
Esc f h, F1

 





	
Adobe Online

 


	
Esc w w w

 





	
Display Help on using the templates provided with FrameMaker

 


	
Press Control+n and click Explore Standard Templates

 






16.11.2.       Open



	
 

Open

 


	
Keyboard shortcut

 





	
A document in a book file

 


	
Double-click the filename in the book window

 





	
All files in an active book window

 


	
Esc f Shift+o, or press and choose Open All Files in Book from the File menu

 





	
A MIF or an MML file as a text file


	
Press Control and click Open in the Open dialog box

 






16.11.3.       Save and Close



	
 

Task

 


	
Keyboard shortcut

 





	
Display the Save Document dialog box

 


	
Esc f a

 





	
Save a document or book

 


	
Esc f s, Control+s

 





	
Save all open files

 


	
Esc f Shift+s, or press and choose Save All Open Files from the File menu





	
Save all open files in an active book window in a book

 


	
Esc f Shift+s, or press and choose Save All Files in Book from the File menu

 





	
Close all open files

 


	
Esc f Shift+c, or press and choose Close All Open Files from the File menu

 





	
Close all open files in an active book window in a book

 


	
Esc f Shift+c, or press and choose Close All Files in Book from the File menu

 






16.11.4.       Cancel and Undo



	
 

Task

 


	
Keyboard shortcut

 





	
Cancel some FrameMaker commands

 


	
Esc

 





	
Undo some FrameMaker commands

 


	
Esc e u, Control+z

 






16.11.5.       Navigation within a document



	
 

Display


	
Keyboard shortcut

 





	
Previous page

 


	
Esc p p, Page Up

 





	
Next page

 


	
Esc p n, Page Down

 





	
First page

 


	
Esc p f, Alt+Page Up, or press and click the Previous Page button

 





	
Last page

 


	
Esc p l (lowercase L), Alt+Page Down, or press and click the Next Page button

 





	
Go to Page dialog box

 


	
Control+g

 






16.11.6.       Document redisplay

 



	
 

Task

 


	
Keyboard shortcut

 





	
Redisplay a document

 


	
Esc w r, Control+l (lowercase L)






16.11.7.       Zoom



	
 

Zoom

 


	
Keyboard shortcut

 





	
In one zoom setting

 


	
Esc z i

 





	
Out one zoom setting

 


	
Esc z o

 





	
To fit page in window

 


	
Esc z p

 





	
To fit window to page

 


	
Esc z w

 





	
To fit window to text frame

 


	
Esc z f

 





	
To 100 percent

 


	
Esc z z

 






16.11.8.       Hypertext documents



	
 

Task

 


	
Keyboard shortcut

 





	
Go to previous location on the hypertext stack

 


	
Esc v Shift+p

 





	
Go to next location on the hypertext stack

 


	
Esc v Shift+n

 





	
Activate a hypertext command without locking a document

 


	
Press Control+Alt and click an active area

 





	
Lock or unlock a document

 


	
Esc Shift+f l (lowercase L) k





	
Open Hypertext dialog box

 


	
Esc s h

 





	
Move focus to Hypertext dialog box

 


	
Esc Shift+f i h

 





	
Close Hypertext dialog box

 


	
Esc Shift+c h

 





	
Validate a hypertext command

 


	
Esc v h

 





	
Toggle FluidView locked format

 


	
Esc Shift+v Shift+f

 






16.12.       Document design

 

16.12.1.       Master and reference pages



	
 

Task

 


	
Keyboard shortcut

 





	
Rename a master or reference page (display the master or reference page before using this shortcut)

 


	
Esc p Shift+n

 





	
Create a master page (display a body or master page before using this shortcut)

 


	
Esc o m p or Esc p m

 






16.12.2.       Page layout



	
 

Task

 


	
Keyboard shortcut

 





	
Update page layouts (display a body page before using this shortcut)

 


	
Esc o u p

 






16.12.3.       Import formats



	
 

Task

 


	
Keyboard shortcut

 





	
Import the formats from another document

 


	
Esc f i o

 






16.12.4.       Side-head area



	
 

Task

 


	
Keyboard shortcut

 





	
Turn side-head area on or off

 


	
Esc j p Shift+s

 






16.12.5.       Text flows



	
 

Task

 


	
Keyboard shortcut

 





	
Split a text frame below the insertion point

 


	
Esc Shift+c Shift+s

 





	
Disconnect the text frame with the insertion point from the previous frame in a flow

 


	
Esc Shift+c Shift+p

 





	
Disconnect the text frame with the insertion point from the next frame in a flow

 


	
Esc Shift+c Shift+n





	
Disconnect the text frame with the insertion point from both the previous and next frames

 


	
Esc Shift+c Shift+b

 





	
Connect two selected text frames

 


	
Esc Shift+c Shift+c

 






16.13.       Document utilities

 

16.13.1.       Spelling Checker



	
 

Task

 


	
Keyboard shortcut

 





	
Check selected text or a word containing the insertion point

 


	
Esc l (lowercase L) s, or press Control and click Start Checking in the Spelling Checker dialog box

 





	
Check the entire document

 


	
Esc l (lowercase L) e

 





	
Check the current page

 


	
Esc l (lowercase L) p

 





	
Correct a word

 


	
Esc l (lowercase L) c w

 





	
Add a word to your personal dictionary (learn)

 


	
Esc l (lowercase L) a p

 





	
Add a word to the document dictionary

 


	
Esc l (lowercase L) a d

 





	
Add a word to automatic corrections

 


	
Esc l (lowercase L) a c

 





	
Delete a word from your personal dictionary (unlearn)

 


	
Esc l (lowercase L) x p

 





	
Delete a word from the document dictionary

 


	
Esc l (lowercase L) x d

 





	
Clear automatic corrections

 


	
Esc l (lowercase L) c a

 





	
Display the Spelling Checker Options dialog box

 


	
Esc l (lowercase L) Shift+o

 





	
Display the Dictionary Functions dialog box

 


	
Esc l (lowercase L) c d

 





	
Create a file of unknown words

 


	
Esc l (lowercase L) b

 





	
Mark all paragraphs for rechecking

 


	
Esc l (lowercase L) r

 





	
Show a word’s hyphenation

 


	
Esc l (lowercase L) hyphen

 





	
Rehyphenate a document

 


	
Esc l (lowercase L) Shift+r

 





	
Replace a questioned word

 


	
Double-click the word in the Correction scroll list in the Spelling Checker dialog box






16.13.2.       Thesaurus

To use this shortcut, the document window, not the Thesaurus, must be active.



	
 

Task

 


	
Keyboard shortcut

 





	
Replace a selection with the Thesaurus selection

 


	
Esc Shift+t r






16.13.3.       Document comparison



	
 

Task

 


	
Keyboard shortcut

 





	
Display the Compare Documents dialog box

 


	
Esc f t c

 






16.13.4.       Document reports



	
 

Task

 


	
Keyboard shortcut

 





	
Display the Document Reports dialog box

 


	
Esc f t r

 






16.13.5.       HTML and PDF export



	
 

Task

 


	
Keyboard shortcut

 





	
Create and apply formats

 


	
Esc f t f

 





	
Open the HTML Setup dialog box

 


	
Esc f t h

 





	
Open the PDF Setup dialog box

 


	
Esc o d a

 






16.13.6.       Reference Updating



	
 

Task

 


	
Keyboard shortcut

 





	
Display the Suppress Automatic Reference Updating dialog box

 


	
Esc e Shift+s






16.14.       Text formatting

 

16.14.1.       Character and Paragraph Designers



	
 

Task 


	
Keyboard shortcut 





	
Change all settings to As Is

 


	
Shift+F8

 





	
Change all settings to match selected text

 


	
Shift+F9

 





	
Display the previous set of properties

 


	
Page Up

 





	
Display the next set of properties

 


	
Page Down

 





	
Apply only the current group of properties

 


	
Press Control and click Apply

 






16.14.2.       Paragraph formats

Use these shortcuts to format selected paragraphs or the paragraph containing the insertion point.



	
 

Task

 


	
Keyboard shortcut

 





	
Apply a paragraph format by typing the first characters of its tag and pressing Return

 


	
Esc q p, F9, Control+9

 





	
Center a paragraph

 


	
Esc j c

 





	
Left-align a paragraph

 


	
Esc j l (lowercase L)

 





	
Right-align a paragraph

 


	
Esc j r

 





	
Justify a paragraph (left and right)

 


	
Esc j f

 





	
Position the current paragraph in the column, removing any straddling or run-in formatting

 


	
Esc j p n

 





	
Change current paragraph to a run-in head

 


	
Esc j p r

 





	
Change current paragraph to a side head

 


	
Esc j p s

 





	
Make current paragraph straddle all columns

 


	
Esc j p t

 





	
Make current paragraph straddle both the side-head area and columns

 


	
Esc j p Shift+t

 





	
Change line spacing to single spacing

 


	
Esc j one

 





	
Change line spacing to 1-1/2 spacing

 


	
Esc j /

 





	
Change line spacing to double spacing

 


	
Esc j 2

 





	
Change line spacing to fixed (default font size plus leading)

 


	
Esc j x

 





	
Change line spacing to floating (largest font size plus leading)

 


	
Esc j o

 





	
Increase line spacing 1 point

 


	
Esc j plus, Esc plus one

 





	
Decrease line spacing 1 point

 


	
Esc j minus, Esc minus one

 





	
Make paragraphs with the current paragraph’s tag and the Paragraph Catalog definition match the current paragraph’s format (unify)

 


	
Esc j Shift+u

 





	
Start a paragraph anywhere

 


	
Esc j Shift+a





	
Start a paragraph at the top of a column

 


	
Esc j Shift+c





	
Start a paragraph at top of a page

 


	
Esc j Shift+p

 





	
Start a paragraph at the top of a left page

 


	
Esc j Shift+l (L)

 





	
Start a paragraph at the top of a right page

 


	
Esc j Shift+r





	
Turn on hyphenation

 


	
Esc j h

 





	
Turn off hyphenation

 


	
Esc j n

 





	
Repeat last paragraph-related command

 


	
Esc j j

 





	
Display Paragraph Catalog

 


	
Esc o p c

 





	
Display Update Paragraph Format dialog box

 


	
Esc o p u

 





	
Display Space Between Paragraphs dialog box


	
Esc j w

 





	
Display Custom Line Spacing dialog box

 


	
Esc j u

 






16.14.3.       Character formats

Use these shortcuts to change the character format of selected text or of text you are about to type.



	
 

Task

 


	
Keyboard shortcut

 





	
Apply a character format by typing the first characters of its tag and pressing Return

 


	
Esc q c, F8, Control+8

 





	
Change text to default paragraph font; remove character tag from text in a text line

 


	
Esc o c p

 





	
Turn bold on or off

 


	
Esc c b, F4, Control+b, Control+Shift+b

 





	
Turn italic on or off

 


	
Esc c i, F5, Control+i

 





	
Turn underline on or off

 


	
Esc c u, F3, Control+u, Control+Shift+u

 





	
Turn double underline on or off

 


	
Esc c d

 





	
Turn numeric underline on or off

 


	
Esc c 2

 





	
Turn strikethrough on or off

 


	
Esc c s, Control+/

 





	
Turn overline on or off

 


	
Esc c o, Shift+F3

 





	
Change text to plain

 


	
Esc c p, F2

 





	
Turn superscript on or off

 


	
Esc c plus

 





	
Turn subscript on or off

 


	
Esc c minus

 





	
Put text on baseline

 


	
Esc c =

 





	
Change text to small caps

 


	
Esc c m, Control+e

 





	
Turn change bars on or off

 


	
Esc c h, Control+Shift+h

 





	
Turn pair kerning on or off

 


	
Esc c k

 





	
Manually kern text 1 point in specified direction (at 100 percent zoom setting)

 


	
Alt+arrow key

 





	
Manually kern text 6 points in specified direction (at 100 percent zoom setting)

 


	
Alt+Shift+arrow key

 





	
Remove all manual kerning

 


	
Alt+Home

 





	
Increase size 1 point

 


	
Esc c ] (right bracket)

 





	
Decrease size by 1 point

 


	
Esc c [ (left bracket)

 





	
Squeeze 20 percent of an em space

 


	
Esc [ (left bracket) Shift+d

 





	
Spread 20 percent of an em space

 


	
Esc [ (left bracket) Shift+c

 





	
Set font stretch to 100 percent

 


	
Esc [ (left bracket) n

 





	
Reduce font stretch by 5 percent

 


	
Esc [ (left bracket) c

 





	
Increase font stretch by 5 percent

 


	
Esc [ (left bracket) e

 





	
Repeat the last font-related command

 


	
Esc c c

 





	
Toggle Tsume


	
Esc c t

 





	
Display the Character Catalog

 


	
Esc o c c

 






16.14.4.       Object styles

 



	
 

Action

 


	
Shortcut

 





	
Launch the Object Style designer with all the properties, while maintaining selection

 

Launch the Object Style designer with just the object properties. The Object Style designer does not display the object style. The Object Style drop-down is disabled.

 


	
Esc g o

 





	
Launch the Object Style designer with just the style associated with the selected object

 


	
Esc g i

 

Ctrl y

 





	
Display style catalog

 


	
Esc g e

 






16.15.       Character and Paragraph Designers



	
 

Task 


	
Keyboard shortcut 





	
Change all settings to As Is

 


	
Shift+F8

 





	
Change all settings to match selected text

 


	
Shift+F9

 





	
 


	
 





	
Task 


	
Keyboard shortcut 





	
Display the previous set of properties

 


	
Page Up

 





	
Display the next set of properties

 


	
Page Down

 





	
Apply only the current group of properties

 


	
Press Control and click Apply

 






16.16.       Text

 

16.16.1.       Insertion point movement

Use these shortcuts to move the insertion point.



	
To move to

 


	
Keyboard shortcut

 





	
Next character

 


	
Right arrow

 





	
Previous character

 


	
left arrow

 





	
Beginning of a word


	
Control+left arrow

 





	
End of a word


	
Control+right arrow

 





	
Beginning of the next word

 


	
Esc b w

 





	
Beginning of a line

 


	
Home

 





	
End of a line

 


	
End

 





	
Previous line

 


	
up arrow

 





	
Next line

 


	
Down Arrow

 





	
Beginning of a sentence


	
Control+Home

 





	
End of a sentence


	
Control+End

 





	
Beginning of the next sentence

 


	
Esc b s

 





	
Beginning of a paragraph

 


	
Control+up arrow

 





	
End of the current paragraph

 


	
Control+Down Arrow

 





	
Beginning of the next paragraph

 


	
Esc b p

 





	
Top of a column

 


	
Control+Page Up

 





	
Bottom of a column

 


	
Control+Page Down

 





	
Beginning of a flow

 


	
Alt+Shift+Page Up

 





	
End of a flow

 


	
Alt+Shift+Page Down

 





	
Start of first visible text flow

 


	
Control+Shift+i

 






16.16.2.       Insertion point placement

Use these shortcuts to put the insertion point in an unrotated text frame on the current page. The draw order is the order in which FrameMaker displays objects on a page; the first object in the draw order is the one at the back.



	
 

To put the insertion point in the

 


	
Keyboard shortcut

 





	
First column of the first text frame in the draw order

 


	
Esc b f

 





	
Next column, traversing text frames in the draw order

 


	
Esc b n

 






16.16.3.       Text selection

Click in text before using these shortcuts. If you use a shortcut with text already selected, FrameMaker extends the selection.



	
 

To select

 


	
Keyboard shortcut

 





	
Next character

 


	
Esc h c, Esc Shift+h c,Shift+right arrow

 





	
Previous character

 


	
Esc Shift+h Shift+c, Shift+left arrow

 





	
Current word, then next word

 


	
Esc h w, Esc Shift+h w, Control+Shift+right arrow

 





	
Current word, then previous word

 


	
Esc Shift+h Shift+w, Control+Shift+left arrow

 





	
Current sentence, then next sentence

 


	
Esc h s, Esc Shift+h s, Control+Shift+End

 





	
Current sentence, then previous sentence

 


	
Esc Shift+h Shift+s, Control+Shift+Home

 





	
Current line, then next line

 


	
Esc Shift+h l (lowercase L) Esc h l (lowercase L)

 





	
Current line, then previous line


	
Esc Shift+h Shift+l (L)

 





	
Current paragraph, then next paragraph

 


	
Esc h p, Esc Shift+h p, Control+Shift+Down Arrow

 





	
Current paragraph, then previous paragraph

 


	
Esc Shift+h Shift+p, Control+Shift+up arrow

 





	
One line width of text, starting at insertion point

 


	
Esc h d, Shift+Down Arrow

 





	
One line width of text, ending at insertion point

 


	
Esc h u, Shift+up arrow

 





	
To top of a column

 


	
Esc h t, Shift+Page Up

 





	
To bottom of a column

 


	
Esc h m, Shift+Page Down

 





	
To beginning of flow

 


	
Esc h g, Control+Shift+Page Up

 





	
To end of flow

 


	
Esc h n, Control+Shift+Page Down

 





	
All text around the insertion point that has the same character format

 


	
Esc h +Shift+f

 





	
 


	
 





	
To Shift the selection 


	
Keyboard shortcut 





	
Right one character

 


	
Esc h f

 





	
Left one character

 


	
Esc h b

 








	
To select

 


	
Keyboard shortcut

 





	
Extend or shorten a text selection

 


	
Press and click where you want the selection to begin or end

 





	
Remove highlighting

 


	
Esc h zero

 





	
Select a word

 


	
Double-click the word





	
Select a word, then next words

 


	
Double-click the word and then drag

 





	
Deselect a text frame or text line and place the insertion point in it

 


	
Double-click in the text frame or text line

 






16.16.4.       Text editing



	
 

To

 


	
Keyboard shortcut

 





	
Select a paragraph

 


	
Triple-click the paragraph

 





	
Select a paragraph, then next paragraphs

 


	
Triple-click the paragraph and then drag

 





	
Transpose characters

 


	
Control+F9

 





	
Cut

 


	
Esc e x, Control+x, Shift+Delete

 





	
Copy

 


	
Esc e c, Control+c

 





	
Paste text that you cut or copied

 


	
Esc e p, Control+v, Control+y

 





	
Quick-copy text

 


	
Click where you want to place the copied text. Then press Alt and drag through the text you want to copy.

 






16.16.5.       Asian text



	
 

To

 


	
Keyboard shortcut

 





	
Type rubi text

 


	
Esc s r

 





	
Display the Rubi Properties dialog box

 


	
Esc o r

 





	
Define a combined font of Western and Japanese characters

 


	
Esc o c o

 






16.16.6.       Text deletion



	
 

To delete

 


	
Keyboard shortcut

 





	
Previous character

 


	
Backspace

 





	
Backward to the end of the previous word

 


	
Control+h

 





	
Backward to the end of the previous sentence

 


	
Esc k a

 





	
Next character

 


	
Delete

 





	
Forward to the end of a word

 


	
Esc k f, Control+Delete

 





	
Forward to the end of a line

 


	
Control+Shift+Delete

 





	
Forward to the start of the next sentence

 


	
Esc k s

 






16.16.7.       Capitalization

Use these shortcuts to change the capitalization of selected text.



	
 

Task

 


	
Keyboard shortcut

 





	
Change the current word to all lowercase

 


	
Control+Alt+l (lowercase L), Control+Alt+Shift+L

 





	
Change the current word to all uppercase

 


	
Control+Alt+u, Control+Alt+Shift+u

 





	
Change the current word to initial caps

 


	
Control+Alt+c

 





	
Display the Capitalization dialog box

 


	
Esc e Shift+c

 






16.17.       Track Text Edit



	
 

Task

 


	
Keyboard shortcut

 





	
Turn on or off the Track Text Edit feature

 


	
Esc s t o

 





	
Show Next Text Edit

 


	
Esc s t n

 





	
Show Previous Text Edit

 


	
Esc s t p

 





	
Accept Edit


	
Esc s t a

 





	
Reject Edit

 


	
Esc s t r

 





	
Accept All

 


	
Esc s t Shift+a

 





	
Reject All

 


	
Esc s t Shift+r

 





	
Preview Final

 


	
Esc s t Shift+f

 





	
Preview Original

 


	
Esc s t Shift+o

 





	
Preview Off

 


	
Esc s p o

 






16.17.1.       Conditional text display



	
 

Task

 


	
Keyboard shortcut

 





	
Display the Show/Hide Conditional Text dialog box

 


	
Esc v Shift+c

 





	
Turn condition indicators on or off

 


	
Esc v Shift+o

 





	
Select all text around the insertion point that has the same condition tag settings

 


	
Esc h Shift+c

 






16.17.2.       Conditional text window

To use these shortcuts, click in the Conditional Text window.



	
 

Task

 


	
Keyboard shortcut

 





	
Move all condition tags to the As Is scroll list

 


	
Shift+F8

 





	
Change the scroll lists to match the condition tag settings of selected text

 


	
Shift+F9

 





	
Move a condition tag between the In and the Not In scroll lists

 


	
Double-click the tag





	
Move a condition tag from the As Is to the In scroll list

 


	
Double-click the tag in the As Is scroll list






16.17.3.       Condition tags

Use these shortcuts to change the condition tag settings of selected text or table rows.



	
 

Task

 


	
Keyboard shortcut

 





	
Apply a condition tag to selected text by typing the first characters of the tag and then pressing Return

 


	
Esc q Shift+c, Control+4

 





	
Remove a condition tag from selected text by typing the first characters of the tag and then pressing Return

 


	
Esc q Shift+d, Control+5

 





	
Make the selected text unconditional

 


	
Esc q Shift+u, Control+6

 






16.18.       Editing text

 



	
 

Task

 


	
Keyboard shortcut

 





	
Cut

 


	
Esc e x, Shift+Delete, Control+x

 





	
Copy

 


	
Esc e c, Control+c

 





	
Paste

 


	
Esc e p, Control+y, Control+v

 





	
Undo/Redo

 


	
Esc e u, Control+ Shift+z, Control+ z

 





	
Quick-copy text

 


	
Click where you want to put the copied text and then press Alt and drag through the text





	
Transpose characters

 


	
Click between characters and then press Control+F9

 





	
Make selected text lowercase

 


	
Alt+Control+l (lowercase L)

 





	
Make selected text uppercase

 


	
Alt+Control+u





	
Make selected text initial caps

 


	
Alt+Control+c





	
Select a word

 


	
Double-click it

 





	
Select a word, then next words

 


	
Double-click it and drag, double-click it and Shift -click

 





	
Select current sentence, then next

 


	
Press Esc h s, press Control+ Shift+End

 





	
Select current sentence, then previous

 


	
Press Esc Shift+h Shift+s, press Control+ Shift+Home

 





	
Select a paragraph

 


	
Triple-click it

 





	
Select a paragraph, then next paragraphs

 


	
Triple-click it and drag, triple-click it and Shift -click

 





	
Delete previous character

 


	
Backspace

 





	
Delete backward to start of the previous word

 


	
Esc k b

 





	
Delete backward to end of the previous sentence

 


	
Esc k a

 





	
Delete next character

 


	
Delete





	
Delete forward to end of a word

 


	
Esc k f, Control+Delete

 





	
Delete forward to end of a line

 


	
Control+Shift+Delete





	
Delete forward to start of the next sentence

 


	
Esc k s

 






16.19.       Entering special characters



	
 

Character

 


	
Keyboard shortcut

 





	
(bullet)

 


	
Control+q %

 





	
† (dagger)

 


	
Control+q space

 





	
‡ (double dagger)

 


	
Control+q `

 





	
™ (trademark)

 


	
Control+q *

 





	
© (copyright)

 


	
Control+q )

 





	
® (registered trademark)

 


	
Control+q (

 





	
¶ (paragraph symbol)

 


	
Control+q &

 





	
§ (section symbol)

 


	
Control+q $

 





	
… (ellipsis)

 


	
Control+q Shift+i

 





	
(em dash)

 


	
Control+q Shift+q

 





	
(en dash)

 


	
Control+q Shift+p

 





	
‘


	
Control+'

 





	
"


	
Esc "





	
(with Smart Quotes off)

 


	
Control+q Shift+t

 





	
(with Smart Quotes off)

 


	
Control+q Shift+u

 





	
(with Smart Quotes off)

 


	
Control+q Shift+r, Alt+Control+‘





	
(with Smart Quotes off)

 


	
Control+q Shift+s, Alt+Control+'

 





	
Em space

 


	
Esc space m, Control+ Shift+space

 








	
Insert

 


	
Keyboard shortcut

 





	
En space

 


	
Esc space n, Alt+Control+space

 





	
Nonbreaking space

 


	
Esc space h, Control+space

 





	
Numeric space

 


	
Esc space 1 (one)

 





	
Thin space

 


	
Esc space t

 





	
Nonbreaking hyphen

 


	
Esc hyphen h

 





	
Suppress hyphenation symbol

 


	
Esc n s

 





	
Discretionary hyphen

 


	
Esc hyphen Shift+d, Control+hyphen

 





	
Forced return

 


	
Shift+Return

 








	
Accent

 


	
Press Esc, then type this

 


	
Followed by one of these

 


	
Example

 





	
´ (acute)

 


	
' (apostrophe)

 


	
a, A, e, E, i, I, o, O, u, U

 


	
É, é





	
` (grave)

 


	
` (left quote)

 


	
a, A, e, E, i, I, o, O, u, U

 


	
È, è





	
˜ (tilde)

 


	
~ (tilde)

 


	
a, A, n, N, o, O

 


	
Ñ, ñ





	
¨ (dieresis)

 


	
% (percent)

 


	
a, A, e, E, i, I, o, O, u, U, y, Y

 


	
Ü, ü





	
ˆ (circumflex)

 


	
^ (caret)

 


	
a, A, e, E, i, I, o, O, u, U

 


	
Ê, ê





	
° (ring)

 


	
* (asterisk)

 


	
a, A

 


	
Å, å





	
¸ (cedilla)

 


	
, (comma)

 


	
c, C

 


	
Ç, ç






16.20.       Function keys

 



	
 

Key 


	
Function 


	
Control 


	
Shift 


	
Alt 





	
F1

 


	
Help

 


	
Align top

 


	
 


	
 





	
F2

 


	
Plain text

 


	
Align middle

 


	
 


	
 





	
F3

 


	
Underline

 


	
Align bottom

 


	
Overline

 


	
 





	
F4

 


	
Bold

 


	
 


	
Cascade


	
Exit

 





	
F5

 


	
Italic

 


	
 


	
Tile


	
 





	
F6

 


	
 


	
 


	
 


	
 





	
F7

 


	
 


	
 


	
Point on document window

 


	
 





	
F8

 


	
Choose character format by typing

 


	
 


	
Change dialog box settings to As Is

 


	
 





	
F9

 


	
Choose paragraph format by typing

 


	
Transpose characters

 


	
Change dialog box settings to match current text

 


	
 





	
F10

 


	
 


	
 


	
Display context menu

 


	
 






16.21.       Keys for drawing



	
 

Tool

 


	
Keyboard shortcut

 





	
Arc

 


	
Esc one a

 





	
Graphic Frame

 


	
Esc one m

 





	
Adobe FreeHand

 


	
Esc one f

 





	
Last tool selected

 


	
Esc one one

 





	
Line

 


	
Esc one l (lowercase L)

 





	
Object Selection

 


	
Esc one o

 





	
Oval

 


	
Esc one e

 





	
Polygon

 


	
Esc one p g

 





	
Polyline

 


	
Esc one p l (lowercase L)

 





	
Rectangle

 


	
Esc one r

 





	
Rounded Rectangle

 


	
Esc one Shift+r

 





	
Smart Selection

 


	
Esc one s

 





	
Text Frame

 


	
Esc one t f

 





	
Text Line

 


	
Esc one t l (lowercase L)

 





	
Vertical, horizontal, or diagonal line

 


	
Press Shift and draw a line

 





	
Square

 


	
Press Shift and draw a rectangle

 





	
Circle

 


	
Press Shift and draw an oval

 





	
Circular arc

 


	
Press Shift and draw an arc

 





	
Display the Tools palette

 


	
Esc one w, Esc g Shift+t

 





	
Keep a tool active after use

 


	
Press Shift and click a drawing tool

 





	
Return to the Object Selection tool after drawing

 


	
Press Shift and click the Object Selection tool

 






16.21.1.       Pen patterns

“First,” “last,” “next,” and “previous” refer to positions in the Pen pop-up menu.



	
 

To change pattern to

 


	
Keyboard shortcut

 





	
First pen pattern (solid)

 


	
Esc zero p

 





	
Last pen pattern (none)

 


	
Esc 9 p

 





	
Next pen pattern (if at the last pattern, this does nothing)

 


	
Esc plus p

 





	
Previous pen pattern (if at the first pattern, this does nothing)

 


	
Esc minus p

 






16.21.2.       Fill patterns

“First,” “last,” “next,” and “previous” refer to positions in the Fill pop-up menu.



	
 

To change pattern to

 


	
Keyboard shortcut

 





	
First fill pattern (solid)

 


	
Esc zero f

 





	
Last fill pattern (none)

 


	
Esc 9 f

 





	
Next fill pattern (if at the last pattern, this does nothing)

 


	
Esc plus f

 





	
Previous fill pattern (if at the first pattern, this does nothing)

 


	
Esc minus f

 






16.21.3.       Line widths

“Next” and “previous” refer to positions in the Line Widths pop-up menu.



	
 

To change width to

 


	
Keyboard shortcut

 





	
Thinnest line width

 


	
Esc zero w

 





	
Thickest line width

 


	
Esc 9 w

 





	
Next line width

 


	
Esc plus w

 





	
Previous line width

 


	
Esc minus w

 






16.21.4.       Line styles

To change an object’s line style, select the style from the Line Styles pop-up menu.

To change the current dashed line style, choose a pattern in the Dashed Line Options dialog box. “First,” “last,” “next,” and “previous” refer to positions in this dialog box.



	
Task

 


	
Keyboard shortcut

 





	
Apply the solid line style to an object

 


	
Esc one d s

 





	
Apply the dashed line style to an object

 


	
Esc one d d

 





	
Display the Dashed Line Options dialog box

 


	
Esc one d i

 





	
Change to the first dashed line pattern

 


	
Esc zero d

 





	
Change to the last dashed line pattern

 


	
Esc 9 d

 





	
Change to the next dashed line pattern (if at the last pattern, this does nothing)

 


	
Esc plus d

 





	
Change to the previous dashed line pattern (if at the first pattern, this does nothing)

 


	
Esc minus d

 






16.22.       Keys for editing objects

 

16.22.1.       Object selection

Use these shortcuts to select objects on the current page.



	
 

Task

 


	
Keyboard shortcut

 





	
Select a text line or text frame

 


	
Press Control and click the text line or text frame

 





	
Extend or shorten the selection

 


	
Press and click an object

 





	
Force selection border to appear (when dragging from outside all objects is not possible)

 


	
Press Control+ and drag diagonally

 





	
Select the first object in the draw order

 


	
Esc o Shift+f

 





	
Select the next object in the draw order

 


	
Esc o n

 





	
Extend the selection to the next object in the draw order

 


	
Esc o e

 





	
Deselect a text frame or text line and put the insertion point inside it instead

 


	
Double-click in the text frame or text line

 






16.22.2.       Object manipulation



	
 

Task

 


	
Keyboard shortcut

 





	
Move an object horizontally or vertically

 


	
Press and drag the object

 





	
Maintain an object’s proportions while resizing

 


	
Press and drag a corner handle

 





	
Pick up the properties of the currently selected object in the Tools palette

 


	
Esc g Shift+o, or press and choose Pick up Object Properties from the Graphics menu

 





	
Display the reshape handle and control points for the line, polyline, polygon, or freehand curve currently selected

 


	
Esc g r, Control+r, Control+Shift+r

 





	
Move the control point horizontally or vertically

 


	
Press and drag the control point

 





	
Change the curve on only one side of a reshape handle (crimp curve)

 


	
Drag the control point with the right mouse button

 





	
Run text around the contour of a selected graphic

 


	
Esc g w

 





	
Run text around the bounding box of a selected graphic

 


	
Esc g Shift+w

 





	
Turn text runaround off for a selected graphic

 


	
Esc g q

 





	
Quick-copy a selected object

 


	
Press Alt and drag the object





	
Turn display of graphics off or on

 


	
Esc v v

 





	
Add a reshape handle and control points

 


	
Press Control and click a line, polyline, polygon, or freehand curve with reshape handles and control points currently displayed

 





	
Delete a reshape handle

 


	
Press Control and click the reshape handle





	
Drag and drop between open or applications

 


	
Drag (Control-drag to copy)

 






16.22.3.       Object movement

Use these shortcuts to move selected objects.



	
 

To move objects

 


	
Keyboard shortcut

 





	
One point in specified direction (at 100 percent zoom setting)

 


	
Alt+arrow key

 





	
Six points in specified direction (at 100 percent zoom setting)

 


	
Alt+Shift+arrow key

 






16.22.4.       Object alignment

If only one object is selected, the object is aligned to the page or to the anchored or graphic frame that encloses the object.



	
 

To align object along

 


	
Keyboard shortcut

 





	
Tops

 


	
Esc j t, Control+F1

 





	
Top/bottom centers

 


	
Esc j m,Control+F2

 





	
Bottoms

 


	
Esc j b, Control+F3

 





	
Left sides

 


	
Esc j l (lowercase L)

 





	
Left/right centers

 


	
Esc j c

 





	
Right sides

 


	
Esc j r

 






16.22.5.       Object rotation



	
 

Task

 


	
Keyboard shortcut

 





	
Rotate 90 degrees clockwise

 


	
Esc g plus





	
Rotate 90 degrees counterclockwise

 


	
Esc g minus

 





	
Rotate precisely by using the Rotate Selected Objects dialog box

 


	
Esc g t

 





	
Rotate again

 


	
Esc g x

 





	
Return object to its unrotated orientation (zero degrees)

 


	
Esc g zero

 





	
Rerotate object from its unrotated orientation to its previous orientation

 


	
Esc g one

 





	
Set the current orientation of an object as the new unrotated orientation

 


	
Esc g 9

 





	
Rotate an object arbitrarily

 


	
Press Alt and drag a corner or reshape handle





	
Constrain rotation to 45-degree increments

 


	
Press Alt+ and drag a corner or reshape handle

 





	
Rotate a page clockwise

 


	
Esc p Shift+o

 





	
Rotate a page counterclockwise

 


	
Esc p o

 





	
Unrotate a page

 


	
Esc p Shift+u

 






16.22.6.       Graphic frames



	
 

Task

 


	
Keyboard shortcut

 





	
Shrink-wrap an anchored frame (shrink the frame to an object and position the frame at the insertion point)

 


	
Esc m p

 





	
Unwrap an anchored frame (enlarge the frame)

 


	
Esc m e

 





	
Rename a selected reference frame


	
Click frame name in status bar






16.23.       Keys for adding color

 

16.23.1.       Color selection



	
 

Task

 


	
Keyboard shortcut

 





	
Keep a color selected after use

 


	
Press Shift and choose a color from the Color pop-up menu

 





	
Assign a color to all objects in a document, including text

 


	
Press Alt+ Shift and choose a color from the Color pop-up menu in the Tools palette

 





	
Display the Color Definitions dialog box

 


	
Press Esc v c d

 






16.23.2.       Color views



	
 

Task

 


	
Keyboard shortcut

 





	
Display Define Color Views dialog box

 


	
Press Esc v c v

 





	
Choose view number (1, 2, 3, 4, 5, or 6) from the Define Color Views dialog box

 


	
Press Esc v and then the number

 






16.24.       Keys for equations

 

16.24.1.       Equations pop-up menu



	
 

Command

 


	
Keyboard Shortcut

 





	
New Small Equation

 


	
Esc m s

 





	
New Medium Equation

 


	
Esc m m

 





	
New Large Equation

 


	
Esc m l (lowercase L)

 





	
Shrink-Wrap Equation

 


	
Esc m p

 





	
Unwrap Equation

 


	
Esc m e

 





	
Equation Sizes

 


	
Esc p e

 





	
Equation Fonts

 


	
Esc m f

 





	
Insert Math Element

 


	
Esc m i

 





	
Add Definition to Catalog

 


	
Esc m c

 





	
Update Definition

 


	
Esc m Shift+u

 






16.24.2.       Symbols page

 

Greek letters

 

Press Return to end the backslash sequence shown in the third column.

 



	
Element

 


	
Keyboard shortcut

 


	
Backslash sequence

 





	
[image: alpha.png]

 

 


	
Control+Alt+a

 


	
\alpha

 





	
[image: beta.png]

 

 


	
Control+Alt+b

 


	
\beta

 





	
[image: gamma1.png]

 

 


	
Control+Alt+Shift+g

 


	
\Gamma

 





	
[image: gamma2.png]

 

 


	
Control+Alt+g

 


	
\gamma

 





	
[image: delta1.png]

 

 


	
Control+Alt+Shift+d

 


	
\Delta

 





	
[image: delta2.png]

 

 


	
Control+Alt+d

 


	
\delta

 





	
[image: epsilon.png]

 

 


	
Control+Alt+e

 


	
\epsilon

 





	
[image: zeta.png]

 

 


	
Control+Alt+z

 


	
\zeta

 





	
[image: eta.png]

 

 


	
Control+Alt+h

 


	
\eta

 





	
[image: theta1.png]

 

 


	
Control+Alt+Shift+q

 


	
\Theta

 





	
[image: theta2.png]

 

 


	
Control+Alt+q

 


	
\theta

 





	
[image: vartheta.png]

 

 


	
Control+Alt+Shift+j

 


	
\vartheta

 





	
[image: iota.png]

 

 


	
Control+Alt+i

 


	
\iota

 





	
[image: kappa.png]

 

 


	
Control+Alt+k

 


	
\kappa

 





	
[image: lambda1.png]

 

 


	
Control+Alt+Shift+l (L)

 


	
\Lambda

 





	
[image: lambda2.png]

 

 


	
Control+Alt+l


	
\lambda

(lowercase L)

 





	
[image: mu.png]

 

 


	
Control+Alt+m

 


	
\mu

 





	
[image: nu.png]

 

 


	
Control+Alt+n

 


	
\nu

 





	
[image: xi1.png]

 

 


	
Control+Alt+Shift+x

 


	
\Xi

 





	
[image: xi2.png]

 

 


	
Control+Alt+x

 


	
\\x

 





	
[image: pi1.png]

 

 


	
Control+Alt+Shift+p

 


	
\Pi

 





	
[image: pi2.png]

 

 


	
Control+Alt+p

 


	
\pi

 





	
[image: rho.png]

 

 


	
Control+Alt+r

 


	
\rho

 





	
[image: sigma1.png]

 

 


	
Control+Alt+Shift+s

 


	
\Sigma

 





	
[image: sigma2.png]

 

 


	
Control+Alt+s

 


	
\sigma

 





	
[image: varsigma.png]

 

 


	
Control+Alt+Shift+e

 


	
\varsigma

 





	
[image: tau.png]

 

 


	
Control+Alt+t

 


	
\tau

 





	
[image: upsilon1.png]

 

 


	
Control+Alt+Shift+u

 


	
\Upsilon

 





	
[image: upsilon2.png]

 

 


	
Control+Alt+u

 


	
\upsilon

 





	
[image: phi1.png]

 

 


	
Control+Alt+Shift+f

 


	
\Phi

 





	
[image: phi2.png]

 

 


	
Control+Alt+f

 


	
\phi

 





	
[image: varphi.png]

 

 


	
Control+Alt+j

 


	
\varphi

 





	
[image: chi.png]

 

 


	
Control+Alt+c

 


	
\chi

 





	
[image: psi1.png]

 

 


	
Control+Alt+Shift+y

 


	
\Psi

 





	
[image: psi2.png]

 

 


	
Control+Alt+y

 


	
\psi

 





	
[image: omega1.png]

 

 


	
Control+Alt+Shift+o

 


	
\Omega

 





	
[image: omega2.png]

 

 


	
Control+Alt+o

 


	
\omega

 





	
[image: varpi.png]

 

 


	
Control+Alt+Shift+i

 


	
\varpi

 





	
[image: cpartial.png]

 

 


	
Control+Alt+7

 


	
\cpartial

 






Other special symbols

 

Press Return to end the backslash sequence shown in the third column.

 



	
Element

 


	
Keyboard shortcut

 


	
Backslash sequence

 





	
[image: infty.png]

 

 


	
Control+Alt+1

 


	
\infty

 





	
[image: bot.png]

 

 


	
Control+Alt+2

 


	
\bot

 





	
...

 


	
Control+g period

 


	
\ldots

 





	
[image: aleph.png]

 

 


	
Control+Alt+3

 


	
\aleph

 





	
[image: lm.png]

 

 


	
Control+Alt+4

 


	
\Im

 





	
[image: re.png]

 

 


	
Control+m $

 


	
\Re

 





	
[image: wp.png]

 

 


	
Control+Alt+5

 


	
\wp

 





	
[image: emptyset.png]

 

 


	
Control+Alt+0

 


	
\emptyset

 





	
[image: nabla.png]

 

 


	
Control+Alt+6

 


	
\nabla

 





	
°

 


	
Control+m )

 


	
\degree

 





	
‘


	
Control+Alt+`

 


	
\prime

 





	
“


	
Control+m "

 


	
\pprime

 






Strings

 



	
Command

 


	
Keyboard shortcut

 





	
Start String

 


	
' or "

 





	
End String

 


	
Return

 






Diacritical marks

 



	
Element

 


	
Keyboard shortcut

 





	
[image: di01.png]

 

 


	
` (grave)

 





	
[image: di02.png]

 

 


	
~ (tilde)

 





	
[image: di03.png]

 

 


	
Control+g hyphen

 





	
[image: di04.png]

 

 


	
Control+Alt+Shift+v

 





	
[image: di05.png]

 

 


	
Control+g ^

 





	
[image: di06.png]

 

 


	
period

 





	
[image: di07.png]

 

 


	
Control+g ~ (tilde)

 





	
[image: di08.png]

 

 


	
Control+g _ (underline)

 





	
[image: di09.png]

 

 


	
Control+g right arrow

 





	
[image: di10.png]

 

 


	
Control+g @

 






16.24.3.       Operators page

Press Return to end the backslash sequence shown in the third column.



	
 

Element or command

 


	
Keyboard shortcut

 


	
Backslash sequence

 





	
+

 


	
plus

 


	
\plus

 





	
_

 


	
minus (after an operand)

 


	
 





	
?x?

 


	
Control+m * (asterisk)

 


	
\cross

 





	
[image: cdot.png]

 

 


	
Control+m period

 


	
\cdot

 





	
[image: bullet.png]

 

 


	
Control+8

 


	
\bullet

 





	
Toggle Format

 


	
Control+Shift+t, Esc m T

 


	
 





	
[image: fract.png]

 

 


	
Control+Alt+/

 


	
\fract

 





	
[image: div.png]

 

 


	
Control+m /

 


	
\div

 





	
[image: over.png]

 

 


	
 

/

 


	
\over

 





	
?=?

 


	
=

 


	
\equal

 





	
[image: uequal.png]

 

 


	
Control+g =

 


	
\uequal

 





	
[image: jotdot.png]

 

 


	
Control+j

 


	
\jotdot

 





	
?,?

 


	
comma

 


	
\comma

 





	
[image: otimes.png]

 

 


	
<Use the Backslash sequence> 


	
\otimes

 





	
[image: oplus.png]

 

 


	
<Use the Backslash sequence> 


	
\oplus

 





	
[image: wedge.png]

 

 


	
<Use the Backslash sequence> 


	
\wedge

 





	
[image: vee.png]

 

 


	
<Use the Backslash sequence> 


	
\vee

 





	
[image: cap.png]

 

 


	
Control+m i

 


	
\cap

 





	
[image: cup.png]

 

 


	
Control+m u

 


	
\cup

 





	
[image: ucomma.png]

 

 


	
Control+m comma

 


	
\ucomma

 





	
[image: semicolon.png]

 

 


	
;

 


	
\semicolon

 





	
[image: neg.png]

 

 


	
Control+m n

 


	
\neg

 





	
-

 


	
Control+hyphen

 


	
\minus

 





	
[image: mp.png]

 

 


	
Control+m 1

 


	
\mp

 





	
[image: pm.png]

 

 


	
Control+q 1

 


	
\pm

 





	
[image: grad.png]

 

 


	
<Use the Backslash sequence> 


	
\grad

 





	
[image: grad2.png]

 

 


	
Control+q Shift+q (and add operand)

 


	
 





	
[image: change.png]

 

 


	
Control+m Control+d

 


	
\change

 





	
[image: box.png]

 

 


	
Control+m x

 


	
\box

 





	
[image: boxdot.png]

 

 


	
Control+m o

 


	
\boxdot

 





	
[image: box2.png]

 

 


	
Control+m 2

 


	
\box2

 





	
[image: forall.png]

 

 


	
Control+m a

 


	
\forall

 





	
[image: exist.png]

 

 


	
Control+m e

 


	
\exist

 





	
[image: therefore.png]

 

 


	
Control+m t

 


	
\therefore

 





	
[image: atop.png]

 

 


	
Control+a, Esc m v l

 


	
\atop

(lowercase L)

 





	
[image: list.png]

 

 


	
Control+m ; (semicolon),

 


	
\list

Esc m h l (lowercase L)

 





	
[image: times.png]

 

 


	
* (asterisk)

 


	
\times

 





	
[image: abs.png]

 

 


	
Control+g | (bar)

 


	
\abs

 





	
[image: superscript.png]

 

 


	
Esc m ^

 


	
 





	
[image: subscript.png]

 

 


	
Esc m Control+Shift - (hyphen)

 


	
 





	
[image: script3.png]

 

 


	
Control+m Control+^

 


	
 





	
[image: script4.png]

 

 


	
Control+m Control+ Shift - (hyphen)

 


	
 





	
[image: sqrt1.png]

 

 


	
Control+r

 


	
\sqrt

 





	
[image: sqrt2.png]

 

 


	
Control+r (and add operand)

 


	
 





	
[image: sn.png]

 

 


	
Control+Shift+e

 


	
\sn

 





	
[image: power.png]

 

 


	
^

 


	
\power

 





	
[image: dagger.png]

 

 


	
Control+m d

 


	
\dagger

 





	
[image: fact.png]

 

 


	
!

 


	
\fact

 





	
[image: ast.png]

 

 


	
Control+m s

 


	
\ast

 





	
[image: angle.png]

 

 


	
Control+q Shift+p

 


	
\angle

 






16.24.4.       Large page

Press Return to end the backslash sequence shown in the third column.

Use these shortcuts to type each element on the Large page with only one operand. Then use Add Operand and Toggle Format as needed.



	
 

Element or command 


	
Keyboard shortcut 


	
Backslash sequence 





	
[image: sum.png]

 

 


	
Control+Shift+s

 


	
\sum

 





	
[image: prod.png]

 

 


	
Control+Shift+p

 


	
\prod

 





	
[image: int.png]

 

 


	
Control+i

 


	
\int

 





	
[image: oint.png]

 

 


	
NA

 


	
\oint

 





	
[image: bigcap.png]

 

 


	
Control+m Shift+i


	
\bigcap

 





	
[image: bigcup.png]

 

 


	
Control+m Shift+u

 


	
\bigcup

 





	
Add Operand

 


	
Control+Shift+n, Esc m n

 


	
 





	
Toggle Format

 


	
Control+Shift+, Esc m Shift+t

 


	
 






16.24.5.       Delimiters page

Press Return to end the backslash sequence shown in the third column.



	
 

Element or command

 


	
Shortcut

 


	
Backslash sequence

 





	
( ? )

 


	
(

 


	
\id

 





	
[ ? ]


	
[ (left bracket)

 


	
 





	
? }

 


	
{ (left brace)

 


	
 





	
? |

 


	
| (bar)

 


	
\substitution

 





	
< ? >

 


	
Control+m <

 


	
\dangle

 





	
|?|

 


	
Control+g | (bar)

 


	
\abs

 





	
( ?

 


	
Control+m (

 


	
\lparen

 





	
[ ?

 


	
Control+m [ (left bracket)

 


	
 





	
{ ?

 


	
Control+m { (left brace)

 


	
 





	
? |

 


	
| (bar) (and add operand)

 


	
 





	
|? >

 


	
Control+m k

 


	
\ket

 





	
||?||


	
Control+m | (bar)

 


	
\norm

 





	
? )

 


	
)

 


	
\rparen

 





	
? ]

 


	
] (right bracket)

 


	
 





	
? }

 


	
} (right brace)

 


	
 





	
? |

 


	
| (bar) (and add two operands)

 


	
 





	
< ? |

 


	
Control+m b

 


	
\bra

 





	
[image: ceil.png]

 

 


	
Control+q i

 


	
\ceil

 





	
( ?, ? )

 


	
Control+m Shift+n

 


	
\inprod

 





	
[ ?, ? ]

 


	
Control+m Shift+c

 


	
\cmut

 





	
{ ?, ? }

 


	
Control+m Shift+a

 


	
\acmut

 





	
[image: overline.png]

 

 


	
_ (underline)

 


	
\overline

 





	
< ? | ?>

 


	
Control+m Shift+b

 


	
\bket

 





	
[image: floor.png]

 

 


	
Control+q k

 


	
\floor

 





	
[image: choice.png]

 

 


	
Control+m h

 


	
\choice

 





	
[image: downbrace.png]

 

 


	
Control+m Shift+d

 


	
\downbrace

 





	
[image: upbrace.png]

 

 


	
Control+m Shift+p

 


	
\upbrace

 





	
Toggle Format

 


	
Control+Shift+t, Esc m T

 


	
 





	
Remove Parentheses

 


	
Esc m r p

 


	
 






16.24.6.       Relations page

Press Return to end the backslash sequence shown in the third column.



	
 

Element

 


	
Shortcut

 


	
Backslash sequence

 





	
? < ?

 


	
<

 


	
\lessthan

 





	
? > ?

 


	
>

 


	
\greaterthan

 





	
? = ?

 


	
=

 


	
\equal

 





	
? ~ ?

 


	
Control+m ~ (tilde)

 


	
\sim

 





	
[image: subset.png]

 

 


	
Control+q Shift+l (L)

 


	
\subset

 





	
[image: supset.png]

 

 


	
Control+q Shift+i


	
\supset

 





	
[image: leftarrow.png]

 

 


	
Control+q comma

 


	
\leftarrow

 





	
[image: rightarrow.png]

 

 


	
Control+q period

 


	
\rightarrow

 





	
[image: lrarrow.png]

 

 


	
Control+q plus

 


	
\lrarrow

 





	
[image: perp.png]

 

 


	
Control+m r

 


	
\perp

 





	
[image: leq.png]

 

 


	
Control+g <

 


	
\leq

 





	
[image: geq.png]

 

 


	
Control+g >

 


	
\geq

 





	
[image: equiv.png]

 

 


	
Control+q : (colon)

 


	
\equiv

 





	
[image: approx.png]

 

 


	
Control+q ; (semicolon)

 


	
\approx

 





	
[image: subseteq.png]

 

 


	
Control+q Shift+j

 


	
\subseteq

 





	
[image: supseteq.png]

 

 


	
Control+q Shift+m

 


	
\supseteq

 





	
[image: lleftarrow.png]

 

 


	
Control+q \

 


	
\Leftarrow

 





	
[image: rrightarrow.png]

 

 


	
Control+q ^

 


	
\Rightarrow

 





	
[image: llrrarrow.png]

 

 


	
Control+q [ (left bracket)

 


	
\LRarrow

 





	
[image: parallel.png]

 

 


	
Control+m p

 


	
\parallel

 





	
[image: lessless.png]

 

 


	
Control+q l (lowercase L)

 


	
\ll

 





	
[image: greatgreat.png]

 

 


	
Control+q g

 


	
\gg

 





	
[image: notequal.png]

 

 


	
Control+q =

 


	
\notequal

 





	
[image: cong.png]

 

 


	
@

 


	
\cong

 





	
[image: in.png]

 

 


	
Control+q Shift+n

 


	
\in

 





	
[image: ni.png]

 

 


	
Control+'

 


	
\ni

 





	
[image: uequal2.png]

 

 


	
Control+q Shift+o

 


	
 





	
= ?

 


	
Control+g =

 


	
\uequal

 





	
[image: notsubset.png]

 

 


	
Control+q Shift+k

 


	
\notsubset

 





	
[image: propto.png]

 

 


	
Control+q 5

 


	
\propto

 






16.24.7.       Calculus page

Press Return to end the backslash sequence shown in the third column.

Use these shortcuts to type each element on the Large page with only one operand. Then use Add Operand and Toggle Format as needed.



	
 

Element or command

 


	
Shortcut

 


	
Backslash sequence

 





	
[image: int00002.png]

 

 


	
Control+i

 


	
\int

 





	
[image: oint00003.png]

 

 


	
Control+Shift+i

 


	
\oint

 





	
Add Operand

 


	
Control+Shift+n, Esc m n

 


	
 





	
Toggle Format

 


	
Control+Shift+t, Esc m T

 


	
 





	
[image: optotal.png]

 

 


	
Control+g t

 


	
\optotal

 





	
[image: optotal2.png]

 

 


	
Control+g Shift+t

 


	
 





	
[image: oppartial.png]

 

 


	
Control+g p

 


	
\oppartial

 





	
[image: oppartial2.png]

 

 


	
Control+g Shift+p

 


	
 





	
[image: optotal3.png]

 

 


	
Control+g t (and add operand)

 


	
 





	
[image: optotal4.png]

 

 


	
Control+g Shift+t (and add operand)

 

 


	
 





	
[image: oppartial3.png]

 

 


	
Control+g p (and add operand)

 

 


	
 





	
[image: oppartial4.png]

 

 


	
Control+g Shift+p (and add operand)

 

 


	
 





	
[image: var.png]

 

 


	
Control+Alt+d

 


	
\var

 





	
[image: grad00004.png]

 

 


	
Control+q Shift+q

 


	
\grad

 





	
[image: diff.png]

 

 


	
Control+d

 


	
\diff

 





	
[image: curl.png]

 

 


	
Control+m c

 


	
\curl

 





	
[image: partial.png]

 

 


	
Control+Shift+d

 


	
\partial

 





	
[image: diver.png]

 

 


	
Control+m v

 


	
\diver

 





	
[image: lim.png]

 

 


	
Control+Shift+l (L)

 

 


	
\lim

 





	
[image: lap.png]

 

 


	
Control+m l (lowercase L)

 


	
\lap

 






16.24.8.       Matrices page

To insert a matrix of any size, first insert a 1 by 1 matrix. Then add rows and columns one at a time.



	
Command

 


	
Shortcut

 





	
Add/Remove Brackets

 


	
Control+Shift+t

 






Matrix commands pop-up menu

 



	
Command

 


	
Shortcut

 





	
Create 1 x 1 Matrix

 


	
Esc x m

 





	
Add Row

 


	
Esc x r

 





	
Add Column

 


	
Esc x c, Control+Shift+c

 





	
Matrix Transpose

 


	
Esc x t

 





	
Matrix Algebra

 


	
Esc x a

 






Matrix row height pop-up menu

 



	
Command

 


	
Shortcut

 





	
Toggle fixed/proportional

 


	
Esc m t r

 






Matrix column width pop-up menu

 



	
Command

 


	
Shortcut

 





	
Toggle fixed/proportional

 


	
Esc m t c

 






16.24.9.       Functions page

To insert each function (except the general function and limit) from the keyboard, type its name as shown.



	
 

Element

 


	
Shortcut

 


	
Backslash sequence

 





	
? ( ? )

 


	
Control+f

 


	
\function

 





	
[image: lim00005.png]

 

 


	
Control+Shift+l (L)

 


	
\lim

 






Addition pop-up menu

 



	
Command

 


	
Shortcut

 





	
Add Fractions

 


	
Esc m a a

 





	
Order Sum

 


	
Esc m a o

 





	
Order Sum Reverse

 


	
Esc m a Shift+o

 






Multiplication pop-up menu



	
Command

 


	
Keyboard shortcut

 





	
Factor

 


	
Esc m u f

 





	
Factor Some

 


	
Esc m u Shift+f

 





	
Multiply Out

 


	
Esc m u m

 





	
Multiply Out Once

 


	
Esc m u Shift+m

 





	
Distribute

 


	
Esc m u d

 





	
Distribute Over Equality

 


	
Esc m u Shift+d

 






Division pop-up menu



	
Command

 


	
Keyboard shortcut

 





	
Long Division

 


	
Esc m d l (lowercase L)

 





	
Remove Division

 


	
Esc m d d

 





	
Remove Division 1 Level

 


	
Esc m d Shift+d

 





	
Remove Negative Powers

 


	
Esc m d n

 





	
Remove Negative Powers 1 Level

 


	
Esc m d Shift+n

 






Evaluation pop-up menu

 



	
Command

 


	
Keyboard shortcut

 





	
Number Crunch

 


	
Esc m v n

 





	
Show All Digits

 


	
Esc m v period

 





	
Evaluate

 


	
Esc m v e

 





	
Evaluate Substitution

 


	
Esc m v s

 





	
Evaluate Integrals

 


	
Esc m v i

 





	
Evaluate Derivatives

 


	
Esc m v d

 





	
Evaluate Derivatives 1 Level

 


	
Esc m v Shift+d

 






Rules pop-up menu

 



	
Command

 


	
Keyboard shortcut

 





	
Enter Rule

 


	
Esc m r e

 





	
Apply Rule

 


	
Esc m r a

 





	
Designate Dummy

 


	
Esc m r d

 






Other rewrites pop-up menu



	
Command

 


	
Keyboard shortcut

 





	
Simplify

 


	
Esc m o s

 





	
Simplify Some

 


	
Esc m o Shift+s

 





	
Isolate Term

 


	
Esc m o i

 





	
Expand First Term

 


	
Esc m o e

 





	
Expand All Terms

 


	
Esc m o Shift+e

 






16.24.10.   Positioning pages

 

 

Micropositioning

 

The number of points shown in the following table is based on a zoom setting of 100 percent.

 



	
Task

 


	
Keyboard shortcut

 





	
Move up 1 point

 


	
Alt+up arrow

 





	
Move down 1 point

 


	
Alt+Down Arrow

 





	
Move left 1 point

 


	
Alt+left arrow

 





	
Move right 1 point

 


	
Alt+right arrow

 





	
Move up 6 points

 


	
Alt+Shift+up arrow

 





	
Move down 6 points

 


	
Alt+Shift+Down Arrow

 





	
Move left 6 points

 


	
Alt+Shift+left arrow

 





	
Move right 6 points

 


	
Alt+Shift+right arrow

 





	
Remove micropositioning

 


	
Alt+Home

 






Left/right (alignment) pop-up menu

 



	
Command

 


	
Keyboard shortcut

 





	
Left

 


	
Esc m a l (lowercase L)

 





	
Center

 


	
Esc m a c

 





	
Right

 


	
Esc m a r

 





	
Left of =

 


	
Esc m a plus

 





	
Right of =

 


	
Esc m a =

 





	
Set Manual

 


	
Esc m a s

 





	
Clear Manual

 


	
Esc m a d

 





	
Reset Alignment

 


	
Esc m a Shift+r

 






Up/down (alignment) pop-up menu

 



	
Command

 


	
Keyboard shortcut

 





	
Top

 


	
Esc m a t

 





	
Baseline

 


	
Esc m a Shift+b

 





	
Bottom

 


	
Esc m a b

 






Line breaking pop-up menu

 



	
Command

 


	
Keyboard Shortcut

 





	
Set Manual

 


	
Esc m b s

 





	
Clear Manual

 


	
Esc m b c

 






16.24.11.   Navigating in an equation

 

Moving the insertion point

 



	
Move

 


	
Keyboard shortcut

 





	
Left

 


	
left arrow

 





	
Right

 


	
Right arrow

 





	
From beside a fraction to the numerator

 


	
Down Arrow

 






Changing the selection

 



	
Task

 


	
Keyboard shortcut

 





	
Select next prompt

 


	
Tab

 





	
Increase scope of selection

 


	
space

 





	
Select next element to the left

 


	
left arrow

 





	
Select next element to the right

 


	
Right arrow

 






Moving math elements while retaining algebraic equivalency

 



	
Move

 


	
Keyboard shortcut

 





	
Left

 


	
Shift+left arrow

 





	
Right

 


	
Shift+right arrow

 





	
Up

 


	
Shift+up arrow

 





	
Down

 


	
Shift+Down Arrow

 





	
To far left

 


	
Control+Alt+left arrow

 





	
To far right

 


	
Control+Alt+right arrow

 





	
Left into expression

 


	
Control+Shift+left arrow

 





	
Right into expression

 


	
Control+Shift+right arrow

 






Moving math elements without retaining algebraic equivalency

 



	
Swap

 


	
Keyboard shortcut

 





	
With element on left

 


	
Control+m Control+left arrow

 





	
With element on right

 


	
Control+m Control+right arrow

 






16.25.       Filter By Attribute

 



	
 

Task

 


	
Keyboard shortcut

 





	
Open the Manage Attribute Expressions dialog box

 


	
Esc a c

 






16.26.       Hierarchical element insert

 



	
Key\Key action

 


	
Type of navigation\action

 





	
Place cursor in an element and hit Enter

 


	
Display the quick catalog

 





	
Right arrow

 


	
Display the elements available within the selected element

 





	
Left arrow

 


	
Hide one level hierarchy of elements

 





	
tab

 


	
scroll down

 





	
shift+tab

 


	
scroll up

 





	
Alphabets\combination of alphabets

 


	
Type an alphabet or combination of alphabets to select an element. For example, press B to select Body and Type T,O to go to Topic.

 






16.27.       Markers and variables

 

16.27.1.       Marker insertion



	
 

Task

 


	
Keyboard shortcut

 





	
Insert a marker

 


	
Esc m k

 





	
Insert a hypertext marker

 


	
Esc m h

 





	
Open the Edit Marker Types dialog box

 


	
Esc e m t

 






16.27.2.       Variable insertion



	
 

Task

 


	
Keyboard shortcut

 





	
Insert a variable by typing the first characters of its name and pressing Return

 


	
Esc q v, Control+zero

 






16.28.       Working with structure



	
 

Move the insertion point 


	
Keyboard shortcut 





	
To start of the current element

 


	
Esc s Shift+s

 





	
To end of the current element

 


	
Esc s Shift+e

 





	
After the next element

 


	
Esc s Shift+d, Alt+Control+Down Arrow

 





	
Before the previous element

 


	
Esc s Shift+u, Alt+Control+up arrow

 





	
Before the current element’s parent

 


	
Esc s Shift+b, Alt+Control+left arrow

 





	
To start of the next element’s contents

 


	
Esc s Shift+n, Alt+Control+right arrow

 





	
 


	
 





	
Select 


	
Keyboard shortcut 





	
Current element

 


	
Esc h Shift+e

 





	
Next element

 


	
Esc h Shift+n, Alt+Control+Shift+Down Arrow

 





	
Previous element

 


	
Esc h Shift+p, Alt+Control+Shift+up arrow

 





	
Siblings of the current element

 


	
Esc h Shift+s

 





	
Parent of the current element

 


	
Esc h e Shift+p, Alt+Control+Shift+left arrow

 





	
Up by one element

 


	
Alt+Control+Shift+up arrow





	
Down by one element

 


	
Alt+Control+ Down Arrow





	
 


	
 





	
Structure view 


	
Keyboard shortcut 





	
Expand/Collapse all elements under the selected element

 


	
Esc E r

 





	
Expand/Collapse selected element

 


	
Esc E x

 





	
Expand / Collapse all sibling elements

 


	
Esc E X

 








	
Task

 


	
Keyboard shortcut

 





	
To include the parent

 


	
Alt+Control+Shift+left arrow





	
Insert element

 


	
Esc Shift+e i, Control+1 (one)

 





	
Wrap element

 


	
Esc Shift+e w, Control+2





	
Unwrap element

 


	
Esc Shift+e u

 





	
Change element

 


	
Esc Shift+e c, Control+3

 





	
Merge into first element

 


	
Esc Shift+e m

 





	
Merge into last element

 


	
Esc Shift+e Shift+m

 





	
Move element up one level

 


	
Esc Shift+e Shift+p

 





	
Move element down one level

 


	
Esc Shift+e Shift+d





	
Transpose element with previous element

 


	
Esc Shift+e Shift+t

 





	
Transpose element with next element

 


	
Esc Shift+e t

 





	
Split element

 


	
Esc Shift+e s

 





	
Edit attribute value

 


	
Control+7

 





	
Repeat last Element Catalog command

 


	
Esc e e

 





	
Toggle display of element boundaries (as brackets)

 


	
Esc v Shift+e

 





	
Toggle display of element boundaries (as tags)

 


	
Esc v Shift+t

 





	
Validate a document

 


	
Esc Shift+e v

 





	
Display Structure View

 


	
Esc Shift+e Shift+v






16.29.       Element menu



	
 

Task

 


	
Keyboard shortcut

 





	
Merge


	
Esc Shift+e m

 





	
Split

 


	
Esc Shift+e s

 





	
Unwrap


	
Esc Shift+e u

 





	
Edit Attributes

 


	
Esc Shift Shift+e Shift+a

 





	
Choose namespaces

 


	
Esc Shift+e Shift+n

 





	
Choose the Element Catalog

 


	
Esc Shift+e Shift+c

 





	
Choose Set Available Elements

 


	
Esc Shift+e Shift+o Shift+c

 





	
Choose New Element Options

 


	
Esc Shift+e Shift+o Shift+i





	
Validate

 


	
Esc Shift+e v

 






16.30.       Other useful shortcuts

 



	
 

Task

 


	
Keyboard shortcut

 





	
Redraw the document display

 


	
Control+l (lowercase L)

 





	
Quick-copy a selected object

 


	
Alt and drag the object





	
Rotate an object arbitrarily

 


	
Alt and use the left or right mouse button to drag a corner or reshape handle





	
Move an object along vertical or horizontal axis

 


	
Shift and drag object

 





	
Nudge an object 1 point/6 points

 


	
Alt+arrow key/Alt+Shift+arrow key





	
Fit page in window

 


	
Esc z p

 





	
Fit window to page

 


	
Esc z w

 





	
Zoom to 100 percent

 


	
Esc z z

 





	
Lock or unlock a document or book

 


	
Esc Shift+f l (lowercase L) k

 









17.                Content reference to: Ion Resources

 




18.                Favorites

Writers, please enter favorites and their associated URL in the table below. Add or delete table rows as necessary.



	
 

Favorite Name

 


	
URL

 





	
FrameMaker Product Page

 


	
http://www.adobe.com/products/framemaker/

 





	
FrameMaker Forum

 


	
http://www.adobeforums.com/webx/.ee6b312/

 





	
Structured FrameMaker Forum

 


	
http://www.adobeforums.com/webx/.ee6b316/

 









19.                RSS feeds

Writers, please enter RSS feeds and their associated URL in the table below. Add or delete table rows as necessary.



	
 

RSS Name

 


	
URL

 





	
FrameMaker Troubleshooting

 


	
http://www.adobe.com/go/learn_fm_troubleshooting_rss_en

 





	
FrameMaker Top Picks

 


	
http://www.adobe.com/go/learn_fm_toppicks_rss_en
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