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Introduction 

Introduction

Adobe RoboHelp (2015 release) now offers a new degree of usability to both help authors 
and their users. Use new dynamic content filters to empower users to find relevant content 
faster. Leverage the new HTML5 layout and contextual search results to enhance the content 
consumption experience. Publish content as mobile apps for iOS and Android. Work more 
productively with a ribbon UI and enhanced search functionality, including bidirectional and 
multiline searches.

This guide presents you an overview of the new features and workflows in RoboHelp (2015 
release). A large number of narrated videos make it easy for you to become familiar with the 
enhanced UI and help you get started with this release. 

Besides this Getting Started Guide, you will find the RoboHelp User Guide and many other 
resources online at adobe.com. A collection of key RoboHelp resources is presented in the 
Additional resources section of this guide.

http://www.adobe.com
http://www.adobe.com/go/learn_rh_ug_en
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How to get Adobe RoboHelp 
(2015 release)

To try RoboHelp before buying, download a fully func-
tional, 30-day complimentary trial version.

You can buy Adobe RoboHelp (2015 release) through the 
online Adobe Store or by calling 800-585-0774. Learn 
about other ways to buy RoboHelp (2015 release), includ-
ing buying through authorized resellers or purchasing with 
education or government discounts.

If you already have a license for an earlier version of Robo-
Help, see the following table for special pricing. 

Note: Prices listed are the Adobe direct store prices. Reseller prices may vary. Prices do not 
include tax or shipping and handling. 

For more information, call us at +1-877-687-1520 or visit the RoboHelp website.

If you have

Upgrade to Adobe RoboHelp (2015 release)

USD EUR AUD YEN

Adobe 
RoboHelp 11

$399 €399 $399 ¥52500

Adobe 
RoboHelp 10

$599 €599 $599 ¥78900

http://www.adobe.com/go/tryrobohelp
http://www.adobe.com/go/buyrobohelp
http://www.adobe.com/products/catalog/software._sl_id-contentfilter_sl_catalog_sl_software_sl_allsoftware.html?start=60
http://www.adobe.com/products/catalog/software._sl_id-contentfilter_sl_catalog_sl_software_sl_allsoftware.html?start=60
http://www.adobe.com/products/robohelp.html
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Dynamic Content Filters

Re-use the existing conditional tags and expressions to enable 
your audience to dynamically filter the document, TOC, and 
index in the final Responsive HTML5 or mobile app output 
and find what is relevant to them - in just a few clicks. 

Customize the dynamic content filter to enable your users to 
choose what they want to see and find the right information 
faster. 

Simply assign names for existing conditional tags or expressions, categorize them under any 
Group you want (such as region, audience, market segment etc.), enable single or multiple 
selections within a Group, and then display this two-level hierarchy as content filter criteria 
in the final output.

• Easily create content filter 
criteria using existing condi-
tional tags and expressions

• Users self-select what they 
want to see in final HTML5 
output
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Create and apply a dynamic content filter to Responsive HTML5 or Mobile output
1. From the Output tab, choose Responsive Layout or Mobile App.
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2. In the General tab of the Settings dialog box, click Use Dynamic Content in the Output.

If you have previously, applied a filter to the current output, click Customize to edit the 
filter.

3. Enter a title for the filter.

This is displayed as a title for the filter in the output.

4. (Optional) Click Add New Group to create groups for your filter criteria.

5. Select a group and click Add Criteria. You can choose to add conditional tags or condi-
tional build expressions.

6. Use the arrow keys (or drag-and-drop) to move the groups and criteria within the filter.

7. In the output, you can provide users with mutually exclusive criteria (radio buttons) 
within a group. Alternatively, you can allow users to multi-select criteria (check boxes). 
To allow users to multi-select criteria, select Allow Multiple Selections in a Group.

8. Click Save and click Save and Generate.

Enhanced DUCC output

Use the new dynamic content filters to create enhanced DUCC 
output that generates only one set of HTML5 files regardless of 
the number of content categories used. Easily migrate your cur-
rent DUCC outputs to new and more efficient dynamic content filter based outputs. 

Leverage the dynamic content filters to deliver your Responsive HTML5 output much more 
efficiently - eliminate the need of producing multiple sets of outputs to suit different audi-
ence segments and avoid duplication of content on web server.

• Easy migration from content 
categories based output to 
dynamic filter based output

• No need for multiple output 
sets to suit different audi-
ences
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Dynamic filter support in context-sensitive 
Help

Ensure that your application users reach the most relevant Help 
they need. Direct your context-sensitive Help calls to the appro-
priately filtered content when you use dynamic content filters in 
your Responsive HTML5 output.

Provide more targeted contextual Help with URL support in the 
new dynamically filtered output. Simply identify the content filters 
that display the context-specific content, embed the selected content filters in the Help URL 
formed by group name and item separator in a straight-forward syntax, and then use this 
Help URL with the relevant arguments in the content-sensitive Help call in RoboHelp.

This enables you to take your audience directly to the topic that is already filtered with the 
preferences as established by you.

Syntax for filter URL

<help topic url>?filter=<tag1>:<value1>,<tag2>:<value2>...

Example

If the dynamic content filter contains the groups Region (containing filters: US, Canada, UK) 
and Role (Developer, Author), the CSH URL for the filter criteria US + Print is:

<help topic url>?filter=Region:US,Role:Developer

• Embed content filter criteria 
in Help call URL using simple 
syntax

• Directly take your audience 
to pre-filtered context-spe-
cific content
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Tagged Output view

Author your content, apply the appropriate conditional tags and expres-
sions to create dynamic content experience that suits your customer needs, 
and then publish and test the filters in the Responsive HTML5 output.

RoboHelp’s Tagged Output view allows you to test how filtered content 
will look for different combinations of filters. The view clearly displays the 
tags in the output at the locations where you applied in the content. This 
makes it extremely easy to test and debug the way you have set up the 

groups and criteria in the dynamic content filter.

Show tagged output
1. From the Output tab, choose Outputs (SSL) to open the Outputs pod.

2. Right-click on the required output (Responsive Layout or Mobile App).

3. Choose Show Tagged Output.

If the HTML5 output is currently open in the browser, you can display the tagged output by 
inserting the following after the .htm in the URL in the address bar:

?showtags=true

For example: index.htm?showtags=true

• Easily simulate the filtered 
output and test various com-
binations of dynamic content 
filters

• View filter names tagged 
with the content for easy 
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New HTML5 layouts

Use the new highly customizable Responsive HTML5 layouts 
to deliver an amazing content consumption experience. Enjoy 
a superior viewing experience with the layout icons that have 
now been optimized for high resolution retina displays.

Easily show or hide widgets such as glossary and TOC. Convert 
the layout to right-to-left languages (Arabic and Hebrew) to 
meet the needs of a global audience, just by changing one 
property.

With more powerful search options, configure search to appear 
on the content or topic panes, and show informative context and breadcrumbs in the 
results. This helps your readers identify the best choice among results. You can also custom-
ize the search context message for each topic.

Put your readers in charge of what they want to see. They self-select the most relevant con-
tent, made possible with the innovative dynamic content filtering feature in the new HTML5 
layouts.

• Convert layout to RTL lan-
guage in a single step

• Easily customize layout to 
meet exact branding stan-
dards

• Leverage dynamic content 
filtering feature and Capti-
vate video support to 
enhance user experience
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Meet the exact branding standards by easily customizing the HTML5 layout using the new 
layout editor. Choose from new color themes and layouts to begin and then simply custom-
ize from there. No knowledge of HTML5 or CSS3 is required. Provide your users with a dif-
ferent experience for the device (desktop, mobile, and tablet) that they use by customizing 
the function bar, side bar, and TOC in the output. Your content will go with the flow and 
respond to the touch on any device.
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Enhance your Help content by adding scalable HTML5 and SWF video content created with 
the latest release of Adobe Captivate into your RoboHelp files. They will play within your 
topics and resize to fit the device.

Customize the layout:
1. From the Output tab, choose Responsive Layout or Mobile App.

2. In the General tab of the Settings dialog box, click Customize Selected Layout.

3. In the Layout Customization dialog box, select a component from the Layout Compo-
nents list and customize the properties of the component in the Properties pane.
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Enhanced search results in 
HTML5 output

Provide better context about search results to end users by 
showing more details.

By default, the first few sentences of the topic are shown as description in the search results. 
With more powerful search options, now you can easily customize the topic’s description to 
provide more relevant details in the search results. Configure search to appear on the con-
tent or topic panes. Help your readers easily identify the best choice among results.

• Display customizable topic 
description and breadcrumb 
trail in search results

• Display search results in 
topic pane (right) or content 
pane (left)
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Use topic comments as search result description
1. From the Output tab, choose Responsive Layout or Mobile App.

2. In the Search tab, select Use Topic Comment as Search Context and click Save.

3. Open the topic for which you need to change the search description.

4. From the Project tab, choose Properties.

5. In the Status tab of the Topic Properties dialog box, enter the required description in the 
Comment field and click OK.
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Out-of-the-box support for social widgets

Generate Responsive HTML5 or mobile output that is easily shareable on Facebook and 
Twitter with out-of-the-box support for social widgets provided in the new HTML5 layout.

Add the Facebook and twitter icons to output
1. From the Output tab, choose Responsive Layout or Mobile App.

2. In the General tab of the Settings dialog box, click Customize Selected Layout.

3. From the list of layout components, choose Social media.

4. Set the Use Facebook and Use Twitter properties.
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Custom fonts in EPUB files

Embed custom fonts in your EPUB output and ensure that your users see 
high-quality typography exactly as you intended, whether or not they have 
the font installed on their device.

This feature is especially useful if you are using fonts that may not be readily 
available to your end users. Use embedded fonts to enhance the branding 
standard set by your design style guides.

Note: You must have distribution rights for the embedded font.

RoboHelp’s latest release also supports the new embedded custom fonts capability of mini 
EPUB readers and an option to validate EPUB 3 output to meet Apple’s app store require-
ments.

Embed the fonts in EPUB output
1. From the Output tab, choose eBook.

2. In the Content tab of the eBook Settings dialog box, click Embed Fonts.

• Use embedded custom fonts 
for eBook publishing without 
worrying about its availabil-
ity at end user’s device

• Validate EPUB 3 output to 
meet Apple’s app store 
requirements
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3. In the Embed Fonts dialog box, select the fonts to embed in the eBook output.

You can choose the fonts currently used in the project. Alternatively, you can choose 
from all fonts available on your computer.

Optimized HTML5 output

Now experience loading time reduction by about 50%, file size savings of about 20KB per 
topic, and smoother transitions between pages with faster, more responsive HTML5 output.

Maintained TOC state in HTML5 output

Work more conveniently by maintaining the TOC state. As the new responsive HTML5 out-
put remembers the state of the books. You can expand and collapse the chapters and topics 
in a book while still maintaining the state of the structure. You can also expand and collapse 
the chapters and topics across multiple books.
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Mobile app output support

Ensure wider distribution and consumption of content with a simplified 
mobile app generation workflow and native integration with Adobe 
PhoneGap Build. Easily publish and then distribute your content as an 
installable app on major mobile platforms, including iOS, and Android.

Then use the generated QR code or PhoneGap URL to share the app with 
your users. Or download the app and then share it on the app stores. The 

mobile output installs and updates like any other app on your device. 

Manage the branding and design standards of the mobile layout with new easy-to-use 
responsive layout editor. Leverage the power of the Responsive HTML5 layout that comes 
with the new dynamic content filtering feature that lets your users self-select the content 
most relevant to them. 

Deliver Help content for the audiences that are on the go.

• Easily generate installable 
mobile app output from your 
single source content

• Use QR code or Adobe 
PhoneGap URL to share the 
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Generate a mobile app
1. From the Output tab, choose Mobile App.

2. In the Mobile App Settings dialog box, go to the Application Details tab and provide the 
following details:
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3. After you generate the mobile output, you are presented with a dialog box that contains 
the QR code and a PhoneGap URL for the app. Your end users will require one of these 
details to download the app on their devices.
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You can also download the app on your computer and host it in the different app stores.
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Easy to use Ribbon Interface

Work more productively with a modern, workflow-centric, rib-
bon user interface.

The new interface consists of familiar tools and commands that 
make your life simpler. It is designed to help you quickly find the 
commands that you need to complete a task. RoboHelp com-
mands are organized into logical related groups and put together under separate tabs. Each 
tab relates to a type of RoboHelp activity, such as editing, reviewing, or output generation. 
The contextual tabs appear only when you need them.

Create your own Quick Access toolbar to reach your favorite commands in fewest possible 
mouse-clicks. Keep your team's content synchronized and track of the changes made in 
content by specific authors from Review tab. Manage your teams content in the cloud using 
Sharepoint, Google drive, Dropbox, Microsoft SkyDrive, or an internal network drive from 
Collaborate tab. Create outputs for multiple audiences with a single click from Output tab.

• Improve productivity with 
easy-to-access commands, 
organized into logical groups 
and tabs

• Contextual tabs appear only 
when you need them



Work more productively with a modern interface

Enhanced search functionality 24

Enhanced search functionality

Work faster with bidirectional and multi-line searches in the 
TOC, files, and index pods in the Design view.

Set the search scope to the current project or window, a specific 
folder, or all open files. Quickly find the content you are search-
ing for by using advanced filters such as Begins with, Ends with, 
Contains, and Does not contain.

• Improve productivity with 
enhanced search scope and 
advanced search filters

• Work faster with find and 
replace, and back up the modi-
fied files
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Zip through search results in Design mode, and easily edit topics by double-clicking them.

Improve your productivity by finding and replacing text even in the HTML editor, indexes, 
and table of contents. Find All and Replace All works faster than before. Robohelp’s latest 
release also provides an option to back up the modified file for any changes done using find 
and replace feature. Save time by searching for multiple lines in one go.
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Named conditional expressions

Easily manage a large number of conditional expressions in a 
project by giving them descriptive, easy-to-remember names. 
Eliminate the hassle of having to decipher the logic each time 
you need to use expressions.

Use the enhanced dialog box to easily create new named expressions, and rename and 
delete existing expressions.

• Save time spent in decipher-
ing the logic by giving easy-to 
remember names to complex 
conditional expressions
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Create named conditional build expressions
1. From the Project tab, choose Tag > Named Expression.
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2. In the Define Conditional Build Tag Expression dialog box, create an expression in the 
Basic or Advanced modes using the existing conditional build tags.

3. Click Save and enter a name in the Create New Expression dialog box.

Rename a conditional build expression
1. In the Define Conditional Build Tag Expression, choose the expression from the Expres-

sions drop-down list.

2. Click Rename This Expression and edit the name of the expression in the Rename 
Expression dialog box.

Delete a conditional build expressions
1. In the Define Conditional Build Tag Expression, choose the expression from the Expres-

sions drop-down list.

2. Click Delete This Expression.

Enhanced conditional indicators

Maintain readability of content even when multiple tags are applied, using 
enhanced conditional tags indicators. With the new overline, easily find the 
tags that have been applied and where the conditions change within a 
topic. This is especially useful to identify portions of content that are tagged 
for one or more versions of published output.

Now you can easily identify which conditions have been applied to various 
types of content, such as images, tables, and graphics at a glance. This fea-

ture also reduces errors in your final output as the visual conditional indicators ensure that 
the intended conditional tag is applied to the content.

• Easily identify conditional 
tags applied on content and 
Project Manager objects with 
new overline indicators

• Content remains readable 
even when multiple tags are 
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Also make use of the same overline conditional indicators on Project Manager objects, such 
as topics or items in a TOC.
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Remember project state

Enjoy the convenience of having projects opened in exactly the same state in which they 
were closed. No need to remember which topics and pods were opened last; RoboHelp 
automatically restores them. 

You also have the option to switch off this behavior if you do not want RoboHelp to 
remember the project state.

Switch on or switch off the Remembered project state
1. From the File tab, choose Options.

2. In the General tab of the Options dialog box, select or deselect Remember Project State.

3. Click OK.
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Adobe Captivate 8 support

Easily integrate HTML5 and SWF content created with the latest 
release of Adobe Captivate into your RoboHelp files. Import the 
Captivate video as a separate topic or into an existing topic in 
your project. Enhance your Help content with show-me demos, 
how-to movies, and interactive quizzes.

Cutting-edge Responsive HTML5 eLearning lets your users view multimedia show-me 
demos, how-to tutorials and interactive quizzes - all launched from your Adobe RoboHelp 
project.

The output is scalable and responds to the size of the screen. This ensures maximum com-
patibility of delivery when your audience views it on desktop, Android, iOS or Kindle 
devices.

For more information, see Adobe Captivate demos in the RoboHelp documentation.

• Launch Adobe Captivate 8  
videos right from your Robo-
Help project.

• Scalable Captivate 8 videos 
auto-fit to screen of user’s 
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Colored and grayscale icons

You can now choose to use colored or grayscale icons in the new RoboHelp user interface.

Customize the look of the RoboHelp icons
1. Click the drop-down in the Quick Access Toolbar and choose More Commands.

2. In the Customize dialog box, select Show Color Icons to displays colored icons. Or dese-
lect the option to display grayscale icons.

Out-of-the-box user interface themes

Work in your favorite environment. Choose from four out-of-the-box color themes to cus-
tomize the look of the new ribbon user interface.

Set the user interface theme
1. Click the drop-down in the Quick Access Toolbar and choose More Commands.

2. In the Customize dialog box, choose Dark or Light in the Theme drop-down list.

3. Select Show Color Icons to displays colored icons. Or deselect the option to display 
grayscale icons.
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Auto-hide ribbons

Maximize the document viewing area using auto-hide ribbons. The ribbon toolbar stays 
hidden while you are working. Just click on a tab when you want to work with its com-
mands.

Expand or collapse the ribbons
1. Click the Collapse the Ribbon arrow in the upper-right corner of the RoboHelp work-

space.

2. If you prefer the ribbons to be always displayed, simply click the Expand the Ribbon 
arrow.

Contextual tabs in the new ribbon Interface

RoboHelp also reduces clutter with the help of contextual tabs that only appear when you 
need them. The Table tab only appears when you’re working on tables. And the Positioning 
tab only appears when you’re working on positioned text boxes. The interface responds to 
where you are working in your project.
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Customizable Quick Access toolbar

Work faster than ever by keeping your most frequently used opera-
tions at your fingertips. Customize the Quick Access toolbar with 
any operation supported in the main toolbar. In the Customize dia-
log box, easily add the commands that you need and remove the 
ones that you don’t often work with.

Put your favorite commands in the fully customizable Quick Access toolbar to access your 
them in fewest possible mouse-clicks. You can even place the toolbar above or below the 
ribbon.

• Access your most used com-
mands in fewest mouse clicks

• Add or remove commands as 
per your preferences
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Customize the Quick Access Toolbar
1. Click the drop-down in the Quick Access Toolbar and choose More Commands.

2. In the Customize dialog box, go to the Quick Access Toolbar tab.

3. Select the tab containing the commands that you want to add.

4. Move the commands that you need from the left list to the right list.

5. Move any commands that you do not require in the toolbar from the right list to the left 
list.

6. To change the location of the commands in the toolbar, move the command up (left) or 
down (right) in the right list.

7. Finally, if you want to revert back to the RoboHelp default toolbar command, simply 
click Reset.
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Find topics and images in Project Manager

Easily find where topics and images within topics are located in Project Manager.

Locate items in Project Manager
1. Place the insertion point within the topic.

Or click on the image in the topic.

2. Click Project > Locate Item.
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Easy update of CSS styles

Change the formatting of a paragraph style in one place and have RoboHelp to reflect the 
formatting this paragraph style across the entire RoboHelp project for you.

Simply change paragraph formatting such as font or alignment. Then use the Update Style 
button to reflect these changes across all such paragraphs in the project.

Edit CSS styles
1. Place the insertion point within the paragraph that you want to edit and use the format-

ting options in the Edit tab to reformat the paragraph.

2. Click Update Style.

Notice that the same paragraph style across all topics in the project are reformatted.

Embed online videos

New add online videos to your RoboHelp topics by simply specifying the video URL in the 
embed code. Then publish your content to mobile apps or the various output formats 
including responsive HTML5, multiscreen HTML5, WebHelp, WebHelp Pro, and Adobe AIR. 

Embed an online video
1. Select a location in the topic for inserting the online video.

2. Select Insert > Media tab > Multimedia.

3. Choose the multimedia option as Online (URL) and enter the source URL (in embed 
code) of the online video.

For embedding Youtube, Vimeo, and Dailymotion videos, you can alternatively provide 
the http URL instead of the source URL.
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Note: The source URL of the video can be copied from the embed code of the online video. Con-
sider this embed code as an example: <iframe width="560" height="315" 
src="https://www.youtube.com/embed/PAxxJKa3PDo" frameborder="0" allow-
fullscreen></iframe>. Here, the source URL required to embed the video is: https://www.you-
tube.com/embed/PAxxJKa3PDo. This source URL is different from the http URL of the video.

Customize Player Settings

For the offline and online videos that you embed in your RoboHelp topics, customize the 
appearance of the player window by specifying the size, margin, and border. Also configure 
player settings to control the display, playback and sound settings for the local and online 
videos embedded in your projects.

1. Choose the options in the Appearance drop-down to customize the size, margin, and 
border of the video in the output.

2. To customize the playback and sound settings, choose Appearance > Player Settings:
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Additional resources

More information on the full Adobe Technical Communication Suite and the tools it provides 
can be found online.

Version comparison chart

Want to compare the latest version of RoboHelp with the earlier versions, click here. 

Product page

• Adobe Technical Communications homepage

• Adobe FrameMaker homepage

• Adobe FrameMaker XML Author homepage

• Adobe FrameMaker Publishing Server homepage

• Adobe RoboHelp homepage

User guides and Help hub pages

• Adobe RoboHelp (2015 release) User Guide

• Adobe RoboHelp Help Hub

• Adobe FrameMaker (2015 release) User Guide

• Adobe FrameMaker Help Hub

http://www.adobe.com/ca/products/robohelp.html
http://www.adobe.com/ca/products/technicalcommunicationsuite.html
www.adobe.com/products/framemakerpublishingserver.html
http://www.adobe.com/go/learn_rh_ug_en
https://helpx.adobe.com/framemaker.html
https://helpx.adobe.com/robohelp.html
http://wwwimages.adobe.com/www.adobe.com/content/dam/acom/en/products/robohelp/robohelp_2015/pdf/RH_2015_VERSION_COMPARISION.pdf
http://www.adobe.com/products/framemakerxmlauthor.html
http://www.adobe.com/go/learn_fm_ug_en

http://www.adobe.com/ca/products/framemaker.html
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• Adobe FrameMaker XML Author (2015 release) User Guide

• Adobe FrameMaker XML Author Help Hub

• Adobe FrameMaker Publishing Server (2015 release) User Guide

• Adobe FrameMaker Publishing Server Help Hub

https://helpx.adobe.com/framemaker.html
https://helpx.adobe.com/framemaker.html
http://www.adobe.com/go/learn_fmxa_ug_en

http://www.adobe.com/go/learn_fmps_ug_en


Legal notices 

Legal notices

Follow this link: Legal Notices

http://help.adobe.com/en_US/legalnotices/index.html
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