About PreformatIN

The StreamServer can handle PDL (Page Description Language) formatted input as shown in the example below.

The instructions to the StreamServer about how to handle PDL formatted input, are created using the PreformatIN tool.

Samples

You can load an input data sample to the PreformatIN tool, and use this sample as a template when you create the PreformatIN configuration. See Input data samples on page 7.

Conversion of the input documents

PDL formatted input documents must be converted to a format recognized by the StreamServer before they can be identified and extracted. The sample must also be converted before it is loaded into the PreformatIN tool. How to convert the documents depends on the original format:

- Use filters on the input connector to convert AFP and PDF documents. See the AFPIN and PDFIN documentation.
- Use the EMF Print Processor to convert documents generated by Windows applications. See the EMF Print Processor documentation.

Configuration

When you create a PreformatIN configuration, you specify which information to select from the input, and how to label and structure this information as blocks and fields. See Creating a PreformatIN configuration on page 9.

Using single and multi-page TIFF as input

Single and multi-page TIFF files can be stored as dynamic overlays and further processed by a PageOUT process. See Using TIFF files as dynamic overlays on page 12.
Input data samples

The easiest way to map data is to use an input data sample that you load into the PreformatIN tool. The mapping is done by drawing rectangles around the displayed text segments.

Before you can load a sample in the PreformatIN tool, you must import the sample file to a resource set connected to the corresponding Message.

Page size
The page size is automatically set if you use a sample. If you do not use a sample, you must specify the page size (File > Page Setup). The maximum page size is 841x1189mm.
Loading and adjusting samples

To load a sample
2. Browse to and double-click the sample resource. The Filter options dialog box opens.
3. Configure the filter options and click OK. The sample is loaded.
   • See the PDFIN documentation for information on PDFIN filter settings.
   • See the AFPIN documentation for information on AFPIN filter settings.

Displaying boundaries for text segments
Select View > Show boundaries to display the boundaries for all text segments in the sample.

Hiding images, rectangles, and other graphics
Select View > Hide Graphics.

Displaying the sample in gray scale
Select View > Gray scale.
Creating a PreformatIN configuration

In the PreformatIN tool, you create instructions describing which parts of an input page the StreamServer should extract and process, how it should organize the extracted data as labelled fields, and how it should structure the fields. This structure of fields will be used as input in the next stage in the processing chain.

The first thing you do when you create a PreformatIN configuration is to load the sample file, i.e. snap-shot of the input, into the sheet area in the PreformatIN tool. You then create fields and trigger patterns by drawing areas on the PreformatIN sheet. Each drawn area on the PreformatIN sheet will in turn generate a node in the PreformatIN tool Message view. These nodes constitute the actual PreformatIN configuration.

**Static and floating positions**

When you analyze the input data, you will identify portions of data that are in static positions, and other portions that are floating. For example, an article list contains recurring data – the number of lines depends on the number of articles. All text segments below line 1 in this list are floating.

When you map static portions you define a field for each text segment. When you map floating data, you must first define a frame for the data, and one or more blocks in which you define the fields.
Reusing the input layout

You can configure a PreformatIN Event to extract and transfer field data to the Processes. You can also configure PreformatIN to reuse the original input layout. Parts of – or the whole – layout can be temporarily stored as a dynamic overlay. A PageOUT instance can pick up the overlay, and add it to the output.

Example 1  Modifying one single field in PageOUT

One single field is extracted in the PreformatIN instance. The remaining input is sent to the dynamic overlay repository. In the PageOUT instance, the extracted field is converted to a barcode. The dynamic overlay is retrieved from the repository and added to the PageOUT output.

Example 2  Adding a bar code in PageOUT

Nothing is extracted in the PreformatIN instance. All input is sent to the dynamic overlay repository. In the PageOUT instance, the dynamic overlay is retrieved from the repository and added to the PageOUT output. A barcode is also added to the output.

Example 3  Converting from EMF to PDF, and sending an email

The original input is in EMF format. In the PreformatIN instance, a field, including the field variable $email, is defined for the email address in the input. The MailOUT instance is configured to use $email in the To field to send an email to the corresponding email address.
All input is sent to the dynamic overlay repository. In the PageOUT instance, the
dynamic overlay is retrieved from the repository and added to the PageOUT
output. The driver configuration for the output connector is set to PDF to generate
output as PDF.

---

Handling dynamic overlays

Enabling the use of dynamic overlays

1. Select Tools > Options. The Options dialog box opens.
2. Specify the dynamic overlay options. See Options dialog box on page 26.

Removing text, image or graphical object from the dynamic overlay

The whole original input layout is used as a dynamic overlay by default. To
remove parts of the layout from the dynamic overlay, you must define fields and
specify how the content in the fields should be handled. A field can contain text
segments, images and graphical objects.

To remove a part of a text segment, you draw a rectangle around the part to
remove. Parts of an image or graphical object can not be removed. You must draw
a rectangle around the entire object.

Example 4 Removing text and graphical objects from a dynamic overlay

In this example, you have a page containing an image surrounded by text
segments and graphical objects. You want to use just the image as a dynamic
overlay.

1. Select Insert > New Field.
2. Draw a rectangle that covers the entire page.
3. In the Properties view, set:
   - Remove images from dynamic overlay to No
   - Remove text from dynamic overlay to Yes
   - Remove graphics from dynamic overlay to Yes.
Using TIFF files as dynamic overlays

You can use single and multi-page TIFF files as dynamic overlays that can be sent to the PageOUT Process. This is useful, for example, for re-printing archived TIFF files.

To use a TIFF file as dynamic overlay

1. In the Message view in the PreformatIN tool, click the Message.
2. In the Properties view, enter ANY as a Rule to trigger the Event.
3. Select Tools > Options. The Options dialog box opens.

TIFF tags

TIFF tags are extracted from the input file and stored in variables that can be used in the PageOUT Process. For example, the value of the TIFF tag ImageWidth is stored in the variable $ImageWidth. The following variables are available:

<table>
<thead>
<tr>
<th>Variable name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$ImageWidth</td>
<td>The width in pixels.</td>
</tr>
<tr>
<td>$ImageLength</td>
<td>The length in pixels.</td>
</tr>
<tr>
<td>$XResolution</td>
<td>Horizontal DPI.</td>
</tr>
<tr>
<td>$YResolution</td>
<td>Vertical DPI.</td>
</tr>
<tr>
<td>$DocumentName</td>
<td>The name of the document the image was scanned from.</td>
</tr>
<tr>
<td>$ImageDescription</td>
<td>Describes the subject of the image.</td>
</tr>
<tr>
<td>$PageName</td>
<td>The name of the page the image was scanned from.</td>
</tr>
<tr>
<td>$Software</td>
<td>The name and version of the software that created the image.</td>
</tr>
<tr>
<td>$DateTime</td>
<td>Date and time for creation of the TIFF file, in format YYYY:MM:DD HH:MM:SS</td>
</tr>
<tr>
<td>$Artist</td>
<td>The name of the person who created the image.</td>
</tr>
<tr>
<td>$HostComputer</td>
<td>The computer and/or operating system used for creating the image.</td>
</tr>
<tr>
<td>$TargetPrinter</td>
<td>Description of the printing environment.</td>
</tr>
<tr>
<td>$RowsPerStrip</td>
<td>Number of rows per trip. This means that striped TIFF images can be created.</td>
</tr>
</tbody>
</table>
Example: creating a PreformatIN configuration

These examples describe how to configure a PreformatIN Event for the following type of input data:

```
TEL0R

<table>
<thead>
<tr>
<th></th>
<th>INVOICE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invoice number</td>
<td>006563-442404</td>
</tr>
<tr>
<td>Invoice date</td>
<td>03.03.26</td>
</tr>
<tr>
<td>Subscription number</td>
<td>001 (EBP)</td>
</tr>
<tr>
<td>Our reference</td>
<td>600421830-05</td>
</tr>
<tr>
<td>Your reference</td>
<td>445 818 0053</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Calls</th>
<th>Number of</th>
<th>HT/US</th>
<th>Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local</td>
<td>00</td>
<td>136.95</td>
<td>10.95</td>
</tr>
<tr>
<td>Direct</td>
<td>004</td>
<td>690</td>
<td>3.0</td>
</tr>
</tbody>
</table>
```

The first example describes how to reuse the input layout. See *Reusing layout* on page 13. The second example describes how to configure the Event without reusing the input layout. See *Not reusing layout* on page 14.

**Reusing layout**

This example describes how to configure the PreformatIN Event to extract data from a single field, and send the rest of the input dynamic overlay to a repository.

**Load the sample**

The sample is available as a the resource `PhoneInvoice.lxf` in a resource set available to the PreformatIN tool.

1. Select **File > Open Sample**. The Select Resource dialog box opens.
2. Browse to, and select, the resource `PhoneInvoice.lxf` The corresponding sample is loaded.

**Enable the use of dynamic overlays**

1. Select **Tools > Options**. The Options dialog box opens.
2. Select **Use Dynamic Overlay**.

**Define a field for the subscription number**

Select **Insert > New Field** and click on the Subscription number text segment.

**Configure the field properties**

Set **Remove text from dynamic overlay** to **Yes**, and specify the appropriate settings.
Not reusing layout

This example describes how to configure a PreformatIN Event to extract and transfer field data to any type of Process.

Load the sample

The sample is available as a the resource PhoneInvoice.lxf in a resource set available to the PreformatIN tool.

2. Browse to, and select, the resource PhoneInvoice.lxf. The corresponding sample is loaded.

Define static fields

Select Insert > New Field and click on the text segments that you want to define as fields. For each field, select the field and configure the properties in the Properties view.

Define areas for floating text

Select Insert > New Frame and draw a rectangle around the area that contains text in floating positions. A new block is automatically added to the top of the frame.

Define blocks

1. Move and stretch the first block so that it covers all text you want to include in the block. Rename the block.
2. Select Insert > New Block. A new block is added to the frame.
3. Move and stretch the new block so that it covers all text you want to include in the block. Rename the block.
4. Repeat steps 2 and 3 for all blocks.
5. For each block, select the block and configure the properties in the Properties view.

Define fields within blocks

For each block:

1. In the Message tree, select the block. The block is activated on the PreformatIN sheet.
2. Select Insert > New Field and click the first text segment in the block.
3. Configure the field properties in the Properties view.
4. Click the next field, configure the field properties, and so on.

Specify a Message pattern

Select Insert > New Pattern and click the text segment “INVOICE”. The text segment “INVOICE” is automatically specified as the match criterion.
Specify block patterns
For each block:

1. Select the block.
2. Select Insert > New Pattern and click the text segment you want to use as pattern.
3. Rename the pattern and specify the match criterion.
Managing patterns, frames, blocks, and fields

Patterns

Patterns are match criteria for input data. You must specify at least one pattern at Message level. This pattern will be used as the Event trigger. If the StreamServer finds matching input in the specified area, the Event will be triggered.

Block patterns

If the PreformatIN configuration contains blocks, you must specify at least one pattern per block in order to uniquely identify the block.

To create a pattern

1. Select Insert > New Pattern.
2. On the PreformatIN sheet, click the text segment you want to use as pattern.
3. In the Properties view, specify the properties. See Pattern properties on page 29.

Multiple patterns

You can use multiple patterns. By default, the match criteria defined for all patterns must be fulfilled in order to trigger the Event, or to identify a block. This corresponds to specifying the following rule for the patterns:

\[ \text{pattern}_1 \text{ AND pattern}_2 \text{ AND \ldots pattern}_N \]

where \(\text{pattern}_1\) etc. is the pattern name, i.e. the Label property for the pattern.

Rules

The Rule property for the Message and blocks enables you to specify custom rules for when to trigger an Event or identify a block. You can use the logical operators AND, OR and NOT in a rule. You can also use ANY, or a question mark, to match any input.

<table>
<thead>
<tr>
<th>Valid characters for the pattern names in a rule</th>
</tr>
</thead>
<tbody>
<tr>
<td>A-Z</td>
</tr>
<tr>
<td>a-z</td>
</tr>
<tr>
<td>0-9</td>
</tr>
<tr>
<td>_ (underscore)</td>
</tr>
<tr>
<td>. (dot)</td>
</tr>
</tbody>
</table>
Frames

You cannot add blocks directly to the PreformatIN sheet. You first draw a frame, and then add the blocks to the frame. The purpose of the frame is to limit the area in which the StreamServer will search for blocks.

A page can contain any number of frames, and a frame can contain any number of blocks. A frame cannot contain other frames.

To create a frame
1. Select Insert > New Frame.
2. On the PreformatIN sheet, draw a rectangle around the area you want to include in the frame. The first block is automatically added to the frame.

Blocks

You must define blocks for floating data. For example, an article list contains recurring data – the number of lines depends on the number of articles. All text segments below line 1 in this list are floating.

A block can contain any number of fields. A block cannot contain sub-blocks.

Example 7 Block defined for Total amount

The shaded areas within the block indicate the fields.

Block patterns

You must specify at least one pattern for the block. See Patterns on page 16.

Block order

You must specify how to order the blocks. See Message properties on page 29.
To insert a block
1. Select the frame where you want to have the block, and select **Insert > New Block**. A new block is added to the top of the frame.
2. Move the block (drag the double-arrow) to the appropriate position within the frame.
3. Stretch the block (drag the bottom arrow-head) so that it spans over all lines you want to include in the block.

To configure a block
1. Select the block you want to configure. The block properties are displayed in the Properties view.
2. Edit the properties. See **Block properties** on page 30.

Fields

When you configure a PreformatIN Event, you map text segments in the input to areas in the PreformatIN tool. A field in the PreformatIN tool corresponds to an area with one or more text segments.

If you include multiple text segments, the contents of each new text segment will be concatenated to the previous segments, as shown in the example below.

**Example 8 Multiple text segments**

<table>
<thead>
<tr>
<th>Field in PreformatIN:</th>
<th>Sample text in PageOUT:</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Your reference</em></td>
<td><em>Your reference</em></td>
</tr>
<tr>
<td><em>Bruce Buffel</em></td>
<td><em>Bruce Buffel</em></td>
</tr>
<tr>
<td>403 65 Jouburg</td>
<td>403 65 Jouburg</td>
</tr>
</tbody>
</table>

**Defining single or multiple text segment fields**

To define one text segment as a field – click the segment.

To define multiple text segments as a field – draw a rectangle around the segments.
Managing patterns, frames, blocks, and fields

Creating a PreformatIN configuration

To insert a static field
Select **Insert > New Field** and define the field.

To insert a field in a block
1. In the Message tree, select the block.
2. Select **Insert > New Field** and define the field.

To configure a field
1. Select the field you want to configure. The field properties are displayed in the Properties view.
2. Edit the properties. See *Field properties* on page 31.

**Field variables**

You can define field variables, and later on refer to the variable instead of static values. Variables affect performance, so you should only use them when necessary.

To define a variable
1. Select the field you want to configure. The field properties are displayed in the Properties view.
2. Enter the name of the **Variable** and press **Enter**.

**Numeric and date formats**

There are three input format categories for fields:

- **General**. Data will be treated as a regular string of characters. This is the default format.
- **Numeric**. Enables the StreamServer to handle input data as numeric data.
- **Date**. Enables the StreamServer to handle input data as date formatted data.

**Format tables**

Numeric and date formats are made available through format tables. Before you specify numeric or date formats for fields, you must add a format table to a resource set connected to the Message. You can import *Formats.txt* from `<StreamServe installation>\Applications\StreamServer\<version>\Tools\Samples` to the resource set.

The first time you specify a numeric or date format for a field, a resource selection dialog box opens. In this dialog box you must browse to, and select, the format table you want to use. This table will be selected by default the next time you specify a format for any of the fields in the Event configuration.
To select a numeric | date format for a field
1. Select the field. The field properties are displayed in the Properties view.
2. Select the Input format property.
3. At the input field, click Select. The Formats dialog box opens.
4. Select the Numeric | Date category.
5. Double-click the Format that corresponds to the input format.

Example 9  Numeric formats
Input 1000000,25 corresponds to k= d=,
Input 1000,000.25 corresponds to k=,d=.

Example 10  Date formats
Input 31/10/03 corresponds to dd/mm/yy
Input 2003-10-03 corresponds to yyyy-mm-dd

To add a new format
Enter the new format in the Format field and click Add.
You can also add new formats directly to the format table resource.
Sorting

You can use sort criteria to specify the order in which data will be delivered to the subsequent Processes. If no sort criteria is used, data will be delivered in the same order as it arrives. Performance will be less affected if data is sorted at Event level compared to sorting at Process level.

You specify the sort criteria by assigning priorities to blocks. Data associated with blocks with the highest priority will be delivered first, and so on.

To specify sort criteria

1. Select the Message node in the Message tree. The Message properties are displayed in the Properties view.
2. Set Use block sort priority to Yes.
3. Select the first block. The Block properties are displayed in the Properties view.
4. Set the Block sort priority level. The lower the number, the higher the priority.
5. Repeat steps 3 and 4 for all blocks.

Sorting examples

The following examples illustrate how the order of the output from an Event changes when sort criteria is specified for the blocks in the Event.

Example 11  Event output without sorting

All blocks have sort priority set to 0. Output is delivered in the same order as it arrived.
**Example 12  Event output with sorting**

The blocks have sort priority set to 1, 2, and 3. Output is delivered in this order.

<table>
<thead>
<tr>
<th>Input</th>
<th>Configuration</th>
<th>Sorted data</th>
</tr>
</thead>
<tbody>
<tr>
<td>D. Armstrong</td>
<td>Classic Priority = 1</td>
<td>1</td>
</tr>
<tr>
<td>D. Gillespie</td>
<td>Jazz and Blues Priority = 2</td>
<td>2</td>
</tr>
<tr>
<td>J. Brahms</td>
<td>Rock and Pop Priority = 3</td>
<td>3</td>
</tr>
<tr>
<td>J. S. Bach</td>
<td></td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>6</td>
</tr>
</tbody>
</table>
Auto generated property variables

PreformatIN generates a number of variables when processing an input document. The following auto generated variables reflect the page properties of the input document:

- $pageorientation – The page orientation of the current page (Portrait or Landscape).
- $pagemedia – The page media of the current page (A4, Letter, etc.).
- $pagewidth – The page width (mm) of the current page.
- $pageheight – The page height (mm) of the current page.

Usage scenario

In this scenario, a PDF file is received via a PDFIN filter and PreformatIN, and the output is generated by a PageOUT Process and a File output connector with a PDF driver. The input document contains a mix of Portrait and Landscape pages.

By default, the PageOUT Process uses the static page properties configured on the Paper Size tab in the Page Setup dialog box (File > Page Setup). This means the PDF output would contain either Portrait or Landscape pages – not a mix of both.

To enable both Portrait and Landscape pages in the output, the Page Setup option Enable width variable in PageOUT is selected, and the variable value is set to pagewidth. The option Enable height variable is also selected, and the variable value is set to pageheight.

When a page is processed in PageOUT, the width and height is retrieved from the $pagewidth and $pageheight variables of the corresponding input page. This means the output now contains the same mix of Landscape and Portrait pages as the input document.
Auto generated property variables

Creating a PreformatIN configuration
PreformatIN tool GUI reference

Main window

The Main window contains three views:

- **Message view**
  This is where you navigate in, and configure, the PreformatIN structure. Each block, field, and pattern in the Message view corresponds to a block, field, or pattern on the PreformatIN sheet.

- **PreformatIN sheet**
  This is where you draw the frames, blocks, fields, and patterns.

- **Properties view**
  Select a field or block in the Message view, or on the PreformatIN sheet, and configure the corresponding properties in the Properties view.

File menu

- **Save**
  Save the PreformatIN configuration as data embedded in the corresponding Message file in the Design Center Project.

- **Save As**
  Save the PreformatIN configuration as a separate file.

- **Open sample**
  Open a sample on the PreformatIN sheet.

- **Page Setup**
  Specify page width and height.

- **Exit**
  Exit the PreformatIN tool.

Edit menu

- **Go To**
  If there is more than one page, use this option to navigate between the pages.

View menu

- **Patterns**
  High-light the patterns on the PreformatIN sheet.
Hide Graphics

Hide all images, rectangles, etc.

Gray Scale

Display the sample in gray scale.

Show boundaries

Show the boundaries for all text segments in the sample.

Options dialog box

Used for: Specifying options for dynamic overlays.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use dynamic overlay</td>
<td>Enable the use of dynamic overlays.</td>
</tr>
<tr>
<td>Hide embedded images</td>
<td>Remove all images – embedded or linked – from the dynamic overlay.</td>
</tr>
<tr>
<td>Hide other graphical objects</td>
<td>Remove all lines, rectangles, and other graphical objects from the dynamic overlay.</td>
</tr>
</tbody>
</table>
**Message view**

**Used for:** Navigating in, and configuring, the PreformatIN structure. Each block, field, and pattern in the Message view corresponds to a block, field, or pattern on the PreformatIN sheet.

The Message tree structure shown will be displayed in the corresponding Process tool.
PreformatIN sheet

Used for: Creating and configuring the PreformatIN structure. You can load a sample describing the actual input into this sheet. You can then draw the frames, blocks, fields, and patterns around the applicable text segments displayed on the sheet.

Each block, field, and pattern on the PreformatIN sheet corresponds to a block, field, or pattern in the Message view.
Properties view

*Used for:* Viewing and editing properties for patterns, blocks, and fields. Select the object (field etc.) in the Message view, or on the PreformatIN sheet, and edit the properties in this view.

### Message properties

*Used for:* Editing Message properties.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Message name. Will be displayed in the Process tool.</td>
</tr>
<tr>
<td><strong>Rule</strong></td>
<td>Rule defining how to handle multiple patterns specified for the Message. See <em>Patterns</em> on page 16</td>
</tr>
<tr>
<td><strong>Use block sort priority</strong></td>
<td>Select to enable sorting of data.</td>
</tr>
</tbody>
</table>
| **Block order** | **By design** – the blocks in the generated Message are grouped and appear in the order they are added to the Message tree in the PreformatIN tool.  
**By position** – the blocks in the generated Message appear in the same order as in the input data. |

### Pattern properties

*Used for:* Editing pattern properties. Select the pattern in the Message view, and edit the properties in this view.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Pattern name.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Textual description of the pattern.</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>Additional comment.</td>
</tr>
<tr>
<td><strong>Left, Right, Top, and Bottom</strong></td>
<td>Coordinates for the pattern match rectangle displayed on the PreformatIN sheet. Origo is the top-left corner. View only.</td>
</tr>
<tr>
<td><strong>Match</strong></td>
<td>Characters specifying the match.</td>
</tr>
<tr>
<td><strong>Use wildcards</strong></td>
<td>Select whether or not to allow wildcards in the definition of the Match property.</td>
</tr>
<tr>
<td><strong>Ignore column</strong></td>
<td>N/A</td>
</tr>
</tbody>
</table>
Block properties

**Used for:** Editing block properties. Select the block in the Message view, and edit the properties in this view.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Label</td>
<td>Block name. In the Process tool, you can select whether to display this label, or the Description.</td>
</tr>
<tr>
<td>Description</td>
<td>Textual description of the pattern. In the Process tool, you can select whether to display this description, or the block name.</td>
</tr>
<tr>
<td>Comment</td>
<td>Additional comment.</td>
</tr>
</tbody>
</table>
### Properties View

**PreformatIN tool GUI reference**

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Left, Right, Top, and Bottom</strong></td>
<td>Coordinates for the block rectangle displayed on the PreformatIN sheet. Origo is the top-left corner. View only.</td>
</tr>
<tr>
<td><strong>Lines</strong></td>
<td>Number of lines in the block.</td>
</tr>
<tr>
<td><strong>Rule</strong></td>
<td>Rule defining how to handle multiple patterns specified for the block. See <em>Patterns</em> on page 16</td>
</tr>
<tr>
<td><strong>Block sort priority</strong></td>
<td>Set the sort criterion for this block.</td>
</tr>
<tr>
<td><strong>Use block sort priority</strong></td>
<td>N/A</td>
</tr>
</tbody>
</table>

### Field Properties

**Used for:** Editing field properties. Select the field in the Message view – or PreformatIN sheet – and edit the properties in this view.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Label</strong></td>
<td>Field name. In the Process tool, you can select whether to display this label, or the Description.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Textual description of the field. In the Process tool, you can select whether to display this description, or the field name.</td>
</tr>
<tr>
<td><strong>Comment</strong></td>
<td>Additional comment.</td>
</tr>
<tr>
<td><strong>Left, Right, Top, and Bottom</strong></td>
<td>Coordinates for the block rectangle displayed on the PreformatIN sheet. Origo is the top-left corner.</td>
</tr>
<tr>
<td><strong>Sample data</strong></td>
<td>An example of field content.</td>
</tr>
<tr>
<td><strong>Variable</strong></td>
<td>Name of a variable that refers to the field. See <em>Field variables</em> on page 19.</td>
</tr>
<tr>
<td><strong>Keep spaces</strong></td>
<td>Select whether or not to keep leading spaces and trailing spaces defined in the field, when the field is used in the output data.</td>
</tr>
</tbody>
</table>
### Properties

| Class | Field class that can assist formatting in a PageOUT Process. For example, if you specify a font for a class in the Process, the font will be used for all fields belonging to this class.  

- **Label** – For fields containing static data.  
- **Dynamic** – For fields containing dynamic data.  
- **Header** – For fields containing static header data. |
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Alignment</td>
<td>Specify alignment of data in the Process tool.</td>
</tr>
<tr>
<td>Input format</td>
<td>See <em>Numeric and date formats</em> on page 19.</td>
</tr>
<tr>
<td>Job ID</td>
<td>Select whether or not to assign an index to the content of the field to make it searchable in a Job ID repository.</td>
</tr>
<tr>
<td>Remove text from dynamic overlay</td>
<td>Select whether to include the selected text segments in the dynamic overlay.</td>
</tr>
<tr>
<td>Remove images from dynamic overlay</td>
<td>Select whether to include the selected images in the dynamic overlay.</td>
</tr>
<tr>
<td>Remove graphics from dynamic overlay</td>
<td>Select whether to include the selected graphics in the dynamic overlay.</td>
</tr>
<tr>
<td>Remove barcodes from dynamic overlay</td>
<td>Select whether to include the barcodes in the dynamic overlay.</td>
</tr>
</tbody>
</table>