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1 Introduction

Note: The content provided in this tutorial is valid for Adobe® LiveCycle® ES (Enterprise Suite). The content 
provided is subject to change or removal, and may be simplified without notice.

The purpose of this tutorial is to introduce you to the end-to-end process of creating a LiveCycle ES 
application. A LiveCycle ES application is a solution that consists of a process version and its associated 
assets (form designs, images, SWF files, and form fragments), which represents an automated process. This 
tutorial takes you through creating a form design, creating a process that uses the form design, 
configuring a service, and testing the process.

In this tutorial, you will learn how to use these tools to achieve the following tasks:

● Adobe LiveCycle Workbench ES to develop your application. Your application will consist of a process 
and form design. After you develop your process, you can activate it and call it a service. 

● Archive Administration to configure access to your service. 

● Adobe LiveCycle Workspace ES to test your service as an end user.

Note: A prebuilt sample of the result of the tutorial is deployed as part of the samples that you can view at 
anytime. You can see the process in the Processes view by selecting Samples - LiveCycle ES > 
MortgageLoan - Prebuilt. You can also see the form and associated assets in the Resources view by 
selecting Samples - LiveCycle ES > MortgageLoan-Prebuilt.

Stepping through this tutorial
To successfully complete this tutorial, you must complete each of the sections in the order they appear. It is 
assumed that you will be using a single LiveCycle ES environment where the LiveCycle ES server and 
Workbench ES are installed. It is recommended that you read the Audience, Requirements, and Before you 
begin sections before you begin this tutorial.

The following sections describe the main parts of the tutorial and the estimated time it will take to 
complete:

1. Setting Up Your Workbench ES Environment (15 minutes)

2. Creating a Form Design (50 minutes)

3. Creating a Process (45 minutes)

4. (Optional) Exporting and Importing a LiveCycle ES Application (15 minutes)

5. Configuring a Service (15 minutes)

6. Testing a Service Using LiveCycle Workspace ES (15 minutes)

Note: You will need to follow only those tasks described in Exporting and Importing a LiveCycle ES 
Application when you are using a separate LiveCycle ES environment for testing. You cannot import 
your application into the same environment where you created it.
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Audience
This document is intended for developers who are interested in creating an application and becoming 
familiar with creating forms, creating processes, working with Archive Administration, and testing 
human-centric processes within Workspace ES. Before you step through this tutorial, it is recommended 
that you read the following documentation:

● LiveCycle ES Overview at http://www.adobe.com/go/learn_lc_overview

● Preparing to Install LiveCycle ES at http://www.adobe.com/go/learn_lc_prepareInstall

● Installing and Deploying LiveCycle ES for JBoss Using Turnkey at 
http://www.adobe.com/go/learn_lc_installTurnkey

● Installing Your Development Environment at http://www.adobe.com/go/learn_lc_installWorkbench

● The topics “About Workbench ES”, “Before You Begin”, and “Process Concepts”, in 
LiveCycle Workbench ES Help

Requirements
The following list contains the necessary environment requirements to complete this tutorial:

● Either Adobe Acrobat® 8.0 or Adobe Reader® 8.0 must be installed on the computer where you intend 
to install Workbench ES.

● The latest version of Adobe Flash® Player must be installed on the computer where you intend to test 
your application. Download the latest version of Flash Player from 
http://www.adobe.com/go/learn_lc_FlashDownload.

● It is recommended that you use one environment for this tutorial and use the JBoss turnkey installation 
to install your server. It is recommended that you install the LiveCycle ES server and Workbench ES on 
different computers; however, you can also install both on the same computer if you have the 
necessary hardware requirements. The server and Workbench ES are installed separately.

● Download the following required files from http://www.adobe.com/go/learn_lc_firstApplicationZip, 
and download the zipped file that contains the tutorial assets. Extract the files to your hard drive and 
note the location for later in this tutorial.

● financeCorpLogo.jpg

● houseImage.jpg

● loanTestData.xml

● mortgageLoanSchema.xsd

Note: The MortgageLoanAppForm.xdp, MortgageLoan1.0.xml, and MortgageLoanAppEx.lca files are 
the outputs of this tutorial. You can use them as a reference to compare your results. 

● You need to import applications and configure services in the LiveCycle Administration Console.

● The user accounts listed in the following table must be available. If the samples were installed on the 
server, the preconfigured user profiles listed in the table are configured for you.  To verify that the users 
are available, log in to LiveCycle Workbench ES or LiveCycle Administration Console using the user 
name of  kvarsen and the password of password. If you can log in successfully, then you do not need to 
configure the user accounts. 

If you cannot log in successfully, you need to configure the user accounts. To do this, log in to LiveCycle 
Administration Console as the administrator and select Settings > User Management > Users and 

http://www.adobe.com/go/learn_lc_firstApplicationZip
http://www.adobe.com/go/learn_lc_overview
http://www.adobe.com/go/learn_lc_installTurnkey
http://www.adobe.com/go/learn_lc_installTurnkey
http://www.adobe.com/go/learn_lc_prepareInstall
http://www.adobe.com/go/learn_lc_installWorkbench
http://www.adobe.com/go/learn_lc_FlashDownload
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Groups. For more information about creating user accounts, see User Management  Help at 
http://www.adobe.com/go/learn_lc_adminUM. 

Note: If you want to use other user profiles, ensure that you configure the roles appropriately. For 
instance, you may have your own user profile that you want to use instead of Kel Varsen. That user 
profile must have the Application Administrator and Administration Console User assigned. 

The server you log in to must have at least the User service and Workspace ES available.

Before you begin
In a typical scenario, before you begin to create your form design or process, you would identify the 
business process (see Identify the business process), determine the details of the process that you are 
automating (see Determine process details), and understand the environment (see Understanding your 
environment) in which you will develop your form design and process. Because this is a tutorial, the typical 
steps are described; therefore, you do not have to perform these steps.

Identify the business process
Before you develop your application, you must identify the business process. The following scenario is 
used for this tutorial: 

An applicant applies for a mortgage to Fin@nce Corporation. The mortgage application allows the 
applicant to specify the proposed mortgage and contact information. Loans that are less than five 
hundred thousand dollars are considered low-risk, and loans that are five hundred thousand dollars or 
more are considered high-risk. Based on the risk level of the loan, a different representative from the 
bank will approve the loan. A loan officer handles low-risk loans; however, a bank manager must 
handle high-risk loans. The loan officer and bank manager can either approve or decline the applicant 
and then contact them by phone.

User
User 
name Password User profile Purpose

Kel Varsen kvarsen password ● Application 
Administrator

● Administration 
Console User

● Use this user profile to develop and 
configure the application. 

● Use this user profile to log in to 
Workbench ES and LiveCycle 
Administration Console if another 
user profile is not assigned to you. 

Rye Woodard rwoodard password LiveCycle 
Workspace User

The applicant applying for a mortgage 
at Fin@nce Corporation. Use this user 
profile to log in to Workspace ES.

Alex Pink apink password LiveCycle 
Workspace User

The loan officer at Fin@nce Corporation 
who can approve mortgage 
applications. Use this user profile to log 
in to Workspace ES.

Tony Blue tblue password LiveCycle 
Workspace User

The bank manager at Fin@nce 
Corporation who can approve 
mortgage applications. Use this user 
profile to log in to Workspace ES.

http://www.adobe.com/go/learn_lc_adminUM
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Determine process details
Before you create a form design and process, you must the determine the requirements of each.

Form design requirements

A mortgage application form is required as part of the business process. It defines the amount of the 
mortgage and is routed to a different person, based on the amount of the loan. You must include the 
following information on the form: 

Mortgage information: The property sale price and down payment that the applicant is making on 
the property. The user can specify a suggested interest rate and term (years) of the mortgage. The 
amount of the mortgage should be calculated in the form design.

Applicant information: The applicant’s last name, first name, social security number, and telephone 
phone number.

Other information: An approval check box, bank’s corporate logo, form instructions, and the title of 
the form.

Process requirements

A process must be implemented to automate the business process. When you look at the business case, it 
includes the following participants, conditions, routing, and activities.

Participants

● Applicant: The person who initiates the mortgage application

● Loan Officer: The person who handles mortgages that are less than five hundred thousand dollars

● Bank Manger: The person who handles mortgages that are five hundred thousand dollars or more

Conditions

● The amount of the mortgage determines whether the mortgage application is routed to a loan 
officer or bank manager.

Activities and routing

● An applicant fills an electronic form and sends it to Fin@nce Corporation.

● The bank manager or loan officer approves the form.

Understanding your environment
It is important to understand the environment you use to develop and test your application. You can 
perform all development and testing in a single environment, which is called your design-time 
environment. However, you may choose to develop your application in one environment and test it in 
another. This case occurs when developers and testers have their own environments. If you are using 
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separate LiveCycle ES environments, you must follow the steps in Exporting and Importing a LiveCycle ES 
Application to configure and test your application.

Single environment: You create and test your applications in the same environment. For instance, you 
may develop and test your application on the same computer, which is typical of developer 
environments. 

You will not need to export your application for development and testing.

Multiple environments: You develop and test your applications on separate environments. For 
instance, you develop the application in your own environment and then test it or use it in a separate 
environment.

You must export your application from your design-time environment and import it into the separate 
environments for testing or production.
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2 Setting Up Your Workbench ES Environment

You will use Workbench ES for a majority of this tutorial; therefore, you will be introduced to perspectives 
and resources in Workbench ES. In this section, you will set up your environment for the remainder of this 
tutorial. You need to perform the tasks in the following sections:

● Logging in to a LiveCycle ES server

● Setting up assets

For more information about Workbench ES, see LiveCycle Workbench ES Help.

Logging in to a LiveCycle ES server
Before you can create form designs and processes, you must log in to a server. The user profile that you use 
to log in must have the Application Administrator or Super Administrator role assigned. For security 
purposes, after a two-hour period, you are required log in again.

Tip: You can change the default two-hour period by modifying the assertionValidityInMinutes option in 
the config.xml file on the server.

➤ To log in to a server:

1. Start Workbench ES. From the Start menu, select Programs > Adobe > LiveCycle Workbench ES > 
Adobe LiveCycle Workbench

Note: The default install location of the Workbench ES executable file is at \Program 
Files\Adobe\LiveCycle ES\Workbench ES\Workbench\workbench.exe.
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2. Select File > Login. The Adobe LiveCycle Workbench ES login window appears as shown in this 
illustration.

3. In the Username box, type kvarsen and, in the Password box, type password. 

Note: If you or your administrator have assigned a different user profile to access Workbench ES, type 
your assigned user name and password. 

4. Beside the Log On To list, click Configure. The Manage Configured Servers dialog box appears.

5. Click Add New Server . The Adding New Server dialog box appears. 

6. In the Server Title box, type LiveCycle ES Server to describe your server. The name you enter is 
only a mnemonic name that is meaningful to you and is displayed as part of the Log On To list in the 
Adobe LiveCycle Workbench ES login window.

7. In the Hostname box, type either the name or the IP address of the LiveCycle ES server. You may need 
to consult with your administrator to get this information.

8. In the Protocol list, select either Simple Object Access Protocol (SOAP/HTTP) or SOAP/HTTPS. The name 
you choose specifies the connection protocol. You may need to consult with your administrator.

9. In the Server Port Number box, use the provided port number. The value you type is used to specify the 
port number used to connect to the server. You may need to consult with your administrator.

10. Verify your settings and click OK.

11. When you return to the Manage Configured Servers dialog box, click OK.

12. In the Adobe LiveCycle Workbench ES login window, verify that you selected the correct server from 
the Log On To list, and then click Login.

You have logged in to a server.
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Logging out of a LiveCycle ES server
You may want to log in to different servers or stop using Workbench ES. Both require that you log out of 
the server. These steps are provided as a reference if you want to pause your tutorial at the end of a section 
and continue at a later time.

Caution: You should stay logged in to the server during the duration of this tutorial. Do not perform these 
steps unless you want to stop this tutorial and proceed at another time.

➤ To log out of the server:

1. In Workbench ES, select File > Logout. The Adobe LiveCycle Workbench ES logout window appears.

2. Click Logout.

3. Select File > Exit to close Workbench ES.

Working with perspectives
Depending on whether you are creating a form design or process, you may want to use a different 
perspective. In Workbench ES, perspectives, which are a collection of views, are available to develop form 
designs and processes. To develop a form, you use the LiveCycle Form Design perspective and, to develop 
a process, you use the LiveCycle Process Design perspective. 
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You use the LiveCycle Form Design perspective to create and modify a form design. When you develop a 
form, the perspective toolbar is selected. The LiveCycle Designer ES editor provides everything you need 
to design and edit a form.

Resources view

Object paletteDesign View tab

Preview PDF tabData View palette

LiveCycle Designer ES editor

Object Library palette

Hierarchy palette

Forms toolbar

Script Editor
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You use the LiveCycle Process Design perspective to create and modify a process. The 
LiveCycle Process Design perspective contains a number of views that you will use to develop your 
process.

Switching between perspectives
You can switch between the perspectives by clicking the icon that represents each perspective in the 
perspective toolbar. By default, the perspective toolbar is on the left side, below the Workbench ES 
toolbar. Here is an illustration of the perspective toolbar with both perspectives available.

Tip: You can right-click the Open perspective  and dock it in another location.

Setting up assets
The Resources view represents a shared location, called the repository, on the server. The repository is used 
for storing assets. Assets include forms, images, form fragments, and schemas that can be shared. You may 
choose to create folders to organize the assets you add to the repository. The assets and folders are visible 
to other developers logged in to the same server. 

The next step is to create folders and add your assets to the repository.

Process editor

Processes view

Services view

Variables view

Properties view

Process diagram

Resources view Operation
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Creating folders
In the Resources view, you will create folders to organize your forms, images, and schemas used in this 
tutorial.

➤ To create the form, image, and schema folders:

1. Ensure that you are logged in to a server and you are in the LiveCycle Form Design perspective.

2. In the Resources view, right-click LiveCycle ES Server and select New Folder. The Create Folder In 
Repository dialog box appears.

3. In the Folder Name box, type Forms and then click OK.

4. Repeat steps 1-3 to create additional folders named Images and Schemas.

Tip: Consider using consistent naming conventions to make it easier for all developers to locate their 
assets.

You have created folders for organizing your forms, images, and schemas. The Resources view should look 
like this illustration:

Note: You may have additional folders appear if samples have been installed on your server.

New Folders
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Adding assets
Before you start your form design, you must add the required image and schema files for this tutorial. You 
will add an image file that is used for the logo on the form design. You will also add a schema file. A schema 
file contains a list of fields and field types. These assets will help to simplify the form design process later in 
this tutorial.

➤ To add assets to the repository:

1. On your computer, browse to the location where you had downloaded and unzipped the files required 
for this tutorial.

Note: The location where you select the image may be different if you copied the images required for 
this tutorial to a different location.

2. Drag the financeCorpLogo.jpg file to the Images folder in the Resources view. The financeCorpLogo.jpg 
file should appear below the Images folder. 

3. Drag the mortageLoanSchema.xsd file and loanTestData.xml file to the Schema folder in the Resources 
view. The file should appear below the schema folder.

You have added the assets required to complete this tutorial. The next step is to create your form design.
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3 Creating a Form Design

In this section, you will learn how to create and test a form design for a mortgage application. You will 
learn how to do the following tasks in the order shown: 

● Creating a form design

● Adding a logo to your form design

● Saving your form design

● Previewing your form design

● Adding a title to your form design

● Adding form instructions to your form design

● Adding headings to your form design

● Adding fields to your form design using a schema

● Changing Text Field types to Drop-down List types

● Editing captions in your form design

● Changing the position of fields on your form design

● Enhancing the appearance of your form design

● Adding calculations to your form design

You need a form to start the process for handling mortgage applications. The form design is typically 
completed by a form author or form designer. Applicants will fill the form electronically using 
Workspace ES, and a loan officer or bank manager will approve the mortgage application using 
Workspace ES. 

You can create a mortgage application form by using form objects, which represent text boxes, check 
boxes, images, and numeric fields. If you have defined the fields in an XML schema data file, you can drag 
the elements onto the form. The appropriate form objects are created based on the XSD type defined in 
the XML schema file.

For more information about creating form designs, see “Working with Form Designs” and “Working with 
Objects” in LiveCycle Designer ES Help.

Creating a form design
Using Workbench ES, you can create a new form design based on a blank form.

➤ To create a form design:

1. Ensure that you are logged in to the server and have the LiveCycle Form Design perspective open. For 
information, see Logging in to a LiveCycle ES server.

2. Select File > New > Adobe XML Form File (PDF). The New PDF Import Template dialog box appears.

3. Select LiveCycle ES Server > Forms. The selected folder appears in the Enter Or Select The Parent Folder 
box.
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4. In the File Name box, type MortgageAppForm.pdf and then click Finish. 

You have created your blank form design. It will appear in the LiveCycle Designer ES editor, which is where 
you will use various palettes to create your form design. 

Tip: You can double-click the MortgageAppForm.pdf tab to maximize the work area in Workbench ES. 

Tip: In the toolbar, you can click  to zoom in to the form design. You will need to scroll to navigate to 
different areas in your form design.

Adding a logo to your form design
Next, you will add a corporate logo to your form design to indicate that the form belongs to your 
organization. 

Tip: You can press the Tab key to move between fields in any palette.

➤ To add a logo to your form design:

1. Select Palettes > Layout. The Layout palette appears near the lower-right corner.

2. In the Object Library palette, click the Standard category and drag the Image object  onto the form 
design.

3. In the Layout palette, perform the following tasks:

Note: The unit used for measurement does not need to be typed if you have set inches as the default 
unit of measurement.

● In the X box, type .5in.

● In the Y box, type .5in.

● In the Width box, type 1.85in.

● In the Height box, type .75in.

4. If the Hierarchy palette is not visible, Select Palettes > Hierarchy.

5. In the Hierarchy palette, right-click Image1, select Rename Object, type Logo, and then press the Enter 
key.

6. In the Object palette, beside the URL box, click Browse . The Browse For Image File dialog box 
appears.

7. Select LiveCycle ES Server > Images > financeCorpLogo.jpg and click OK.

8. In the Object palette, select Embed Image Data.

You have added a logo to your form design.
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Saving your form design
It is a good idea to save your form design at this point. You can save your form at any time by selecting 
Save from the File menu. Your form design is saved in the server’s repository and is available to others who 
are logged in to the same server.

➤ To save your form design:

● Select File > Save.

You have saved your form design.

Previewing your form design
As you work on your form design, you can preview it at any time to see how it looks to a form filler. To 
continue editing your form design, you must return to Design View.

➤ To preview your form design:

● Click the Preview PDF tab.

➤ To return to editing your form design:

● Click the Design View tab.

You have previewed your form design and returned to Design View.

Adding a title to your form design
Now, you will add a title to your form design to differentiate it from other forms used in your organization 
and to indicate to form fillers that they are using the correct form.

➤ To add a title to your form design:

1. In the Object Library palette, in the Standard category, drag the Text object  onto the form design 
and position it to the right of the logo.

2. Double-click the text in the Text object and, in the Forms toolbar, perform the following tasks: 

● In the Font list, select Arial.

● In the Size list, select 24.

● Click Bold.

3. With the text still selected, type MORTGAGE APPLICATION.

4. In the Hierarchy palette, right-click Text1 and select Rename Object, type Title, and then press the 
Enter key.

5. With Title still selected in the Hierarchy palette, in the Layout palette, perform the following tasks:

● In the X box, type 3in.

● In the Y box, type .75in.

6. Save your form design.
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You have added a title to your form design.

Adding form instructions to your form design
Now, you will add text to your form design to provide instructions or communicate what happens after a 
form filler completes the form. You will also provide instructions for the person who approves or declines 
the mortgage.

➤ To add instructions to your form design:

1. In the Object Library palette, in the Standard category, drag the Text object  onto the form design 
and position it below the logo.

2. Double-click the text and, in the Designer ES editor’s toolbar, perform the following tasks:

● In the Font list, select Arial.

● In the Size list, select the default of 10.

3. With the text still selected, type After you complete this form, one of our 
representatives will contact you within two business days..

4. In the Hierarchy palette, right-click Text1, select Rename Object, type AppInstructions, and then 
press the Enter key.

5. With AppInstructions still selected, in the Layout palette, perform the following tasks:

● In the X box, type .5in.

● In the Y box, type 1.25in.

● In the Width box, type 7.5in.

● In the Height box, type .5in.

● In the Top box, type .25in.

● In the Bottom box, type .25in.

6. Select Palettes > Border. The Border palette appears in the bottom-right corner.

7. In the Border palette, in the Edges list, select the default Edit Individually. 

8. In the upper border  and lower border  lists, select Solid.

9. Select Edit > Duplicate. A copy of the instructions appears slightly below the original copy in the form 
design.

10. In the Hierarchy palette, right-click AppInstructions[1], select Rename Object, type 
RepInstructions, and then press the Enter key.

11. With RepInstructions still selected, in the Layout palette, perform the following tasks:

● In the X box, accept the default of 0.5in.

● In the Y box, type 6in.

12. On your form design, select the text in the RepInstructions object and type For Fin@nce Corp. 
representatives: Indicate if the mortgage is Approved or Declined and 
contact the applicant..



LiveCycle ES Creating a Form Design
Creating Your First LiveCycle ES Application  Adding headings to your form design     21

13. Save your form design.

Tip: You can also use the arrows keys on your keyboard to position the selected object in your form 
design.

You have added form instructions to your form design. Your form design should look like the following 
illustration.

Adding headings to your form design
Next, you add headings to your form design. The headings are form labels used to separate groups of 
fields that a form filler may fill. 

➤ To add headings to your form design:

1. In the Object Library palette, in the Standard category, drag the Text object  onto the form design 
and position it below the first set of instructions.

2. Double-click the text in the text object and, in the Forms toolbar, perform the following tasks: 

● In the Font list, select Arial.

● In the Size list, select 12.

● Click Bold.

3. With the text still selected, type Step 1: Mortgage Information:.

4. In the Hierarchy palette, right-click Text1, select Rename object, type Step1, and then press the Enter 
key.
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5. With Step1 still selected, in the Layout palette, perform the following tasks:

● In the X box, use the default value of 0.5in.

● In the Y box, type 2.5in.

6. Select Edit > Duplicate. A copy of Step 1: Mortgage Information: appears slightly below the original 
copy in the form design.

7. In the Hierarchy palette, right-click Step1[1], select Rename Object, type Step2, and then press the 
Enter key.

8. With Step2 still selected, in the Layout palette, perform the following tasks:

● In the X box, use the default value of 0.5in.

● In the Y box, type 4in.

9. On your form design, select the Step1: Mortgage Information: text, and then type Step 2: 
Applicant Information:.

10. Save your form design.

You have added headings to your form design. 

Adding fields to your form design using a schema
Adding fields (or form objects) to your form design one at a time requires a series of drag actions. You will 
simplify the process of adding fields to your form design by using an imported schema file. 

With an imported schema file, you can drag one field or a group of fields onto your form design. The form 
object that is created is based on the defined data type in the schema file. The additional benefit is that the 
appropriate form objects are automatically bound to the data source and captions are created based on 
the element name in the schema. For details about how form objects are created when importing a 
schema, see LiveCycle Designer ES Help, which is accessible from Workbench ES.

You will also need to embed the schema into the form design. The schema is required to access the data in 
the form design during the creation of your process.

➤ To create a data connection and embed a schema into a form design: 

1. Select Edit > New Data Connection. The New Data Connection dialog box appears.

2. In the Get Data Description From list, select XML Schema and then click Next.

3. Beside the Select XML Schema File box, click Browse . The Open XML Schema File dialog box 
appears.

4. Select LiveCycle ES Server > Schemas > mortgageLoanSchema.xsd [#1.0] and then click OK.

5. In the New Data Connection dialog box, select Embed XML Schema, and then click Finish. A list of fields 
appear in the Data View palette.

Note: Select Palettes > Data View if the Data View palette is not visible.

6. Save your form design.

You have imported and embedded a schema into your form design.
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➤ To add fields to the form design using a schema:

1. Drag MortgageFields from the Data View palette onto the left side of your form design, below Step1: 
Mortgage Information:. A group of fields appear, based on the schema. The data connections will be 
set for each field automatically.

2. In the Layout palette, perform the following tasks:

● In the X box, type .5in.

● In the Y box, type 2.75in.

3. Select Insert > Unwrap Subform so that these fields are no longer grouped together. This makes it 
easier to reposition individual fields later in this tutorial.

4. Drag ApplicantFields from the Data View palette onto the left side of your form design, below Step 2: 
Applicant Information:.

5. In the Layout palette, perform the following tasks:

● In the X box, type .5in.

● In the Y box, type 4.25in.

6. Select Insert > Unwrap Subform.

7. Drag ApprovalFields from the Data View palette centered onto your form design, below the second set 
of instructions and the group of Applicant Fields you added in step 4.

8. In the Layout palette, perform the following tasks:

● In the X box, type 6.0in.

● In the Y box, type 7.0in.

9. Select Insert > Unwrap Subform.

10. Save your form design.
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You have created a data connection based on an XML schema file and added multiple fields to your form 
design. Your form design should look like the following illustration.

Changing Text Field types to Drop-down List types
As you work on your form design, you may want the applicant to enter information into a field by selecting 
from a list of predefined values. You will change the Term and InterestRate fields to a Drop-down List 
object and provide predefined values that appear in the drop-down list.

➤ To change a Text Field type to a Drop-down List type:

1. In the Hierarchy palette, select Term.

2. In the Object palette, click the default Field tab and, in the Type list, select Drop-down List. 

3. Click Add , type 5, and then press the Enter key. 

4. Type the values 10,15,20, 25 and 30, pressing the Enter key after each entry.

5. Repeat steps 1-4 for InterestRate, but type the values 5.00, 5.50, and 6.00.

6. Save your form design.

You have changed a Text Field object to a Drop-Down List object and added items to each drop-down list.
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Using your form design in Workspace ES
You will use your form design in Workspace ES; therefore, a collection of fields with specific data-binding 
names to transport data must be added to your form design. A custom type is provided to simplify the 
process of enabling a form for Workspace ES. 

You must add a custom object named Process Fields to a form design so that it operates correctly in 
Workspace ES.

➤ To add the Process Fields object to your form design:

1. Select Insert > Custom > Process Fields. A group of fields appears in the middle of the form design.

2. Scroll the form design so that the bottom of it appears.

3. With Process Fields still selected on your form design, use the arrow keys to move the group of fields 
approximately one inch above the bottom of your form design. After you complete the task, your 
Process Fields should look like the following illustration in your form design.

4. Save your form design.

You have added the Process Fields object to the form design. Now, Workspace ES can use the form design.

Editing captions in your form design
You may notice that the captions for the fields you dragged onto your form design are already predefined 
in a user-friendly manner. This is not always the case because most schema files are created based on a 
table in a database. Names from a database are okay for a person who is familiar with the database; 
however, it is not usually the text you want to display to the person filling your form. 

You will now edit some of the captions. Editing captions does not affect the binding names. 

➤ To modify the caption of a field:

1. In the Hierarchy palette, select Term.

2. In the Object palette, click the Field tab and, in the Caption box, type Term (Years).

3. Save the form design.

You have modified a caption in your form design.
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Changing the position of fields on your form design
Next, you will position the fields on your form design so that the form design is more visually appealing.

➤ To change the position of fields on your form design:

1. In the Hierarchy palette, select Mortgage and, in the Layout palette, type 3.498in in the Y box, and 
then press the Enter key.

2. Repeat step 1 using PhoneNumber but, in the Y box, type 4.998in.

3. On the form design, select the Mortgage field, hold down the Control key and select the Term field, and 
then select Layout > Align > Left.

4. On the form design, select the Phone Number field, hold down the Control key and select the SSN field, 
and then select Layout > Align > Left.

5. In the Hierarchy palette, select DownPayment, hold down the Control key and select InterestRate and 
FirstName.

6. In the Layout palette, in the X box, type 4in, and then press the Enter key.

7. In the Hierarchy palette, select Declined.

8. In the Layout palette, in the X box, type 6.0in and, in the Y box, type 7.5in, and then press the Enter 
key.

9. Save the form design.

You have changed the positions of some of the fields in your form design. 

Enhancing the appearance of your form design
Next, you will enhance the appearance and usability of your form design. You can modify several fields at 
the same time to quickly change the appearance of your form design. In this tutorial, you will make the 
following enhancements to your form design:

● Changing field sizes

● Changing spacing for captions

● Changing fonts

● Adding default values

● Formatting field values

● Changing a field to use combs

Changing field sizes

You will change the size of fields so that each field will allow enough space for the user to enter 
information and make each field appear next to each other.

➤ To change the size of a field:

1. In the Hierarchy palette, select PropertyPrice, hold down the Control key and select DownPayment, 
Mortgage, Term, InterestRate, LastName, FirstName, PhoneNumber, and SSN.
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2. In the Layout palette, in the Width box, type 3in, and then press the Enter key.

You have changed the size for multiple fields in your form design.

Changing spacing for captions

You will increase the spacing between the caption and the text that a form filler enters.

➤ To change the spacing of a caption:

1. In the Hierarchy palette, select PropertyPrice, hold down the Control key and select DownPayment, 
Mortgage, Term, InterestRate, LastName, FirstName, PhoneNumber, and SSN.

2. In the Layout palette, in the Reserve box, type 1.2in, and then press the Enter key.

You have changed the spacing of the field captions in your form design.

Changing fonts

You will change the fonts so that the size of the caption is a smaller font. You will also change the color of 
the text that a form filler enters.

➤ To change fonts on a form design:

1. Select Palettes > Font. The Font palette appears. Drag and dock it to the left of the form in the 
LiveCycle Form Design perspective. You may need to adjust the size of your other palettes.

2. In the Hierarchy palette, select PropertyPrice, and then hold down the Control key and select 
DownPayment, Mortgage, Term, InterestRate, LastName, FirstName, PhoneNumber, and SSN.

3. In the Font palette, in the Currently Editing Caption and Value list, select Edit Caption and perform the 
following tasks:

● In the Font list, select Arial. 

● In the Font list, select the default of 10.

● In the Style list, select Bold.

4. In the Font palette, in the Currently Editing Caption and Value list, select Edit Value and perform the 
following tasks:

● In the Font list, select Arial.

● In the Size list, select 12.

● Click the Color box and select the blue color swatch.

5. In the Hierarchy palette, select Approved, and hold down the Control key and select Declined. 

6. In the Font palette, perform the following tasks:

● In the Font list, select Arial.

● In the Size list, select 12.

● In the Style list, select Bold.

You have changed the fonts in your form design.
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Adding default values

You will add default values to the PropertyPrice, DownPayment, InterestRate, and Term fields. The purpose 
of defaults is to reduce the amount of text a form filler may need to type.

➤ To change a default value to a field:

1. In the Hierarchy palette, select PropertyPrice.

2. In the Object palette, click the Value tab and, in the Default box, type 0.

3. Repeat steps 1-2 and specify the default for the following fields:

● For DownPayment, in the Default box, type 0.

● For the Term, in the Default list, select 5.

● For InterestRate, in the Default list, select 5.00.

You have specified default values to populate field values in your form design.

Formatting field values

Next, you will format field values so that they appear correctly after the user types them. For instance, in 
the form design, you need a dollar sign to appear in fields that represent money, and you need 
parentheses around area codes of phone numbers.

You can choose from a list of predefined display patterns or you can create a custom pattern. In this case, 
you will create a custom pattern using the numeric symbols 9 and z, as well as the currency symbol ($) and 
the left and right parenthetic characters (). In our example, given the input 1234567.98, the custom 
display pattern ($z,zzz,zz9.99)will display $1,234,567.89. For more information about patterns, 
see LiveCycle Designer ES Help, which is accessible from Workbench ES.

➤ To format the display and edit values:

1. In the Hierarchy palette, select Mortgage and, in the Object palette, perform the following tasks:

● Click the Value tab and, in the Type list, select Calculated - Read Only.

● Click the Field tab and click Patterns. The Patterns - Numeric Field dialog box appears. 

● Click the Display tab and, in the Pattern box, type ($z,zzz,zz9.99)and then click Apply. 

● Click the Edit tab and, in the Pattern box, type ($z,zzz,zz9.99), and then click Apply and click 
OK.

2. In the Hierarchy palette, select PropertyPrice, and then hold down the Control key and select 
DownPayment. 

3. In the Object palette, perform the following tasks:

● Click the Value tab and, in the Type list, select User Entered - Required.

● Click the Field tab and click Patterns. The Patterns - Numeric Field dialog box appears. 

● Click the Display tab and, in the Pattern box, type ($z,zzz,zz9.99), and then click Apply.

● Click the Edit tab and, in the Pattern box, type ($z,zzz,zz9.99), click Apply, and then click OK.

4. In the Hierarchy palette, select PhoneNumber and, in the Object palette, perform the following tasks:
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● Click the Value tab and, in the Type list, select User Entered - Required.

● Click the Field tab and click Patterns. The Patterns - Numeric Field dialog box appears. 

● Click the Display tab, select Telephone (USA - Canada), and then click Apply. 

● Click the Edit tab, select Telephone (USA - Canada), click Apply, and then click OK.

You have formatted the fields in your form design so that fields are displayed with a dollar sign that 
represent monetary amounts and parentheses surround area codes of phone numbers.

Changing a field to use combs

Lastly, you will change a field to use a comb. When you use combs for a field, it divides the field with 
vertical lines. Combed fields are useful for visually indicating to the form filler the correct number of 
characters that must be entered in a field. For instance, you will change the SSN (Social Security Number) 
field to use a comb of nine characters.

➤ To change the SSN field to use a comb:

1. In the Hierarchy palette, select SSN.

2. In the Object palette, click the Field tab, select Comb Of, type 9 in the corresponding box, and then 
press the Enter key.

You have changed the SSN field to use a comb.

Adding calculations to your form design
You will make a form more interactive by adding a calculation to your form design. You add JavaScript by 
using the Script Editor to calculate the mortgage amount in your form design.

Note: You may need to drag the bottom of the Forms toolbar to expand the area for the Script Editor.

➤ To add a calculation to the mortgage amount:

1. In the Hierarchy palette, select Mortgage. 

2. In the Script Editor, select the appropriate options:

● In the Show list, select calculate.

● In the Language list, select JavaScript.

● In the Run At list, select the default Client.

3. In the Script Source field, type the following calculation:

if (PropertyPrice.rawValue > DownPayment.rawValue)
{

this.rawValue = PropertyPrice.rawValue - DownPayment.rawValue;
}
else 
{

this.rawValue = 0;
}

4. In the Script Editor, click Check Script  to ensure that there are no syntax errors.
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5. Save your form design.

You have added a calculation to the Mortgage field.

You have finished the form design. The following illustration shows how your form looks in Design View.

Testing form designs
It is a good idea to test your form before you use it in a process. You will use a sample data file to preview 
your form when it is merged with data. Testing your form with data is recommended to ensure that it 
functions as designed.

➤ To test your form design using sample data:

1. Select Edit > Form Properties. The Form Properties dialog box appears. 

2. Click the Preview tab.

3. Beside the Data File box, click Browse  to find the data file. The Open XML File dialog box appears. 

4. Select LiveCycle ES Server > Schemas > loanTestData.xml file and click OK.

5. In the Form Properties dialog box, click OK.

6. Click Preview PDF to see how the form looks when it contains data.
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You have created and tested your form design. You can now use it in a process. The following illustration 
shows how your form looks in Preview PDF.
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4 Creating a Process

In this section, you will learn how to create, edit, and activate a process using Workbench ES. You will learn 
how to do the following tasks in the order shown:

● Creating the process to handle mortgage applications

● Editing your process version for the mortgage application process

● Activating your process version for the mortgage application process as a service

You create a process by using Workbench ES to automate a business process. When a process is created, a 
process version is automatically created. You can create multiple process versions to represent different 
versions of your process. Each process version has a process diagram. A process diagram is the visual 
representation of that business process that you want to automate. You add elements to the process 
diagram, which include operations, events, routes, and modeling elements.

You can automate human-interaction tasks and electronic tasks. Here, you will create a process that 
requires human interaction. Human interaction tasks require interaction with a user. Such tasks include 
approving a form, signing a form, and reviewing a document.

The mortgage application form that you created is used by the process. Here are the basic steps to create a 
process.

Create a process category: You will create a process category to organize the process you create.

Create a process: You will create a process to represent your business process. As you create your 
process, you will also create a process category to organize processes that you create for loans.

Edit the process version: When you first create a process, the process diagram is empty. You will add 
operations, routes, variables, and swimlanes to the process diagram. In addition, you can define the 
business rules for your process.

Activate a process version: After you save your process version, you will activate it. The result is a new 
service is available that can be invoked or used by other processes.

For more information about working with processes, see LiveCycle Workbench ES Help.

Creating the process to handle mortgage applications
You will create a process to automate the routing of mortgage applications at Fin@nce Corporation. When 
you create a process, you can create additional process categories to organize your processes. You will 
create a process category to store loan-related processes.

➤ To create a process to handle mortgage applications: 

1. Ensure that you are logged in to the LiveCycle ES server and are in the LiveCycle Process Design 
perspective. For information, see Logging in to a LiveCycle ES server.

2. Select File > New > New Process. The New Process dialog box appears. 

3. In the Select An Option for Creating Your Process area, select Create A New Process, and then click Next.

4. In the Name box, type MortgageLoan.
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5. Click New. The New Process Category dialog box appears.

6. In the Name box, type Loans and, in the Description box, type Loan processes, and then click 
Finish. 

7. In the New Process dialog box, in the Category list, ensure that Loans is selected.

8. In the Description box, type Process for routing mortgage loan requests..

9. Click Browse. An Open dialog box appears.

10. Browse to the location where you downloaded files required for this tutorial, select houseImage.jpg 
file, and click Open. The image appears in the Process Image area as shown in the illustration below.

Note: The location where you select the image may be different if you copied the images required for 
this tutorial to a different location.

11. Click Next, accept the defaults provided, and then click Finish.
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You have created a process named MortgageLoan, which you will see in the Processes view. You will see a 
process version created automatically beneath the MortgageLoan process. In addition, an editor named 
MortgageLoan:1.0 (Edit Mode) appears. Workbench ES should look like the following illustration.

Editing your process version for the mortgage application 
process

When you edit a process, you are editing a specific variation of the process called a process version. You will 
perform these tasks to build and edit the details of your process:

● Renaming your pool

● Adding a swimlane

● Modifying your swimlanes

● Saving your process version

● Defining operations in your process diagram

● Assigning values to variables in your process version

● Drawing routes in your process diagram

MortgageLoan process and 
Loans category.

Process editor with empty 
process diagram.
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Renaming your pool
A process diagram is used to visually represent the operations that occur in your business process. Pools 
contain a number of swimlanes and identify the participants in a process, and are often used to represent 
an organization or business entity. 

You will rename the pool to describe the business process where an applicant applies for a mortgage with 
an organization called Fin@nce Corporation.

➤ To rename your pool in the process version:

1. On the MortgageLoan 1:0 tab, click the text POOL to select the pool. The POOL properties appear in the 
Properties view.

2. In the Properties view, in the Name box, type FIN@NCE CORPORATION and, in the Description box, 
type External facing business process used to route mortgage applications 
based on the mortgage amount..

You have renamed the pool in your process version. 

Adding a swimlane
Swimlanes are used to visually organize activities that a participant or a group of participants perform. You 
will add a swimlane to separate operations performed by people who approve the loans at Fin@nce 
Corporation.

➤ To add a new swimlane in your pool:

● On the MortgageLoan tab, right-click the text SWIMLANE0 and select Insert a Swimlane > Below 
Selected Swimlane.

You have added a swimlane to your pool. A new swimlane named SWIMLANE1 appears beneath 
SWIMLANE0. 

Saving your process version
You should save your process version at regular intervals. When you save your process version, it becomes 
visible to other users who are logged in to the same server.

➤ To save your process version:

● Select File > Save. 

You have saved the MortgageLoan process version.

Modifying your swimlanes
You can rename swimlanes to better describe their purpose. You can also change their size and color. You 
will name one swimlane LOW RISK and the other swimlane HIGH RISK.

Tip: You can also modify the height of a swimlane by dragging the lower border up or down.
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➤ To rename the swimlanes in your pool:

1. In the process diagram, select SWIMLANE0. The SWIMLANE0 properties appear in the Properties view.

2. Click the General property group. A list of properties appears.

3. In the Properties view, click the General category and type the following information:

● In the Label box, type LOW RISK to replace SWIMLANE0. 

● In the Height box, type in 250.

● In the Description box, type Fin@nce Corp. representatives who approve loans that 
are low risk..

4. Select SWIMLANE1 in the process diagram.

5. In Properties view, click the General category and perform the following tasks:

● In the Label box, type HIGH RISK to replace SWIMLANE1.

● Click the ellipses button  beside Color and, in the Color palette, select the color red and then 
click OK.

● In the Height box, type in 250.

● In the Description box, type Fin@nce Corp. representatives who approve loans that 
are high risk..

6. Save your process version.

You have modified the names, height, and colors of the swimlanes in your pool. Your process diagram 
should look like the following illustration.
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Defining variables for your process version
You will now define variables for your process version. Variables are used to save data during the execution 
of your process, such as information that enters the process. Variables are used to store information that is 
passed out of your process or to store information that can be referenced during the execution of 
operations in your process. Variables of different types can store different types of information. You will 
create variables of the following types to store the form and the mortgage amount: 

xfaform: This type associates the render and submit operations for an XML-based form. It will be used 
as an input variable to access the form’s data, point to a form design in the repository, and to specify the 
render and submit operations for a form design. This form type is referenced as the form variable for 
the MortgageLoan process.

This variable is required because processes need a form design to be associated with it. A form is the 
mechanism for users to interact with a process.

float: This type saves the amount of the mortgage as a float value. It will be used to determine where to 
route the mortgage application in a conditional statement.

➤ To define a variable to store your form:

1. In the Variables view, click Add A New Variable . The Variable dialog box appears.

2. Type the following information:

● In the Name box, type LoanForm.

● In the Title box, type Loan form data.

● In the Description box type Form submitted and stored in a xfaForm type..

3. In the Type list, select xfaForm. Additional boxes and buttons appear in the Datatype Specific Settings 
area.

4. In the General area, select Required and Input.

5. In the Enduser UI Items area, select Searchable and Visible In UI.

6. Beside the Template URL box, click Browse. The Select Form dialog box appears.

7. Select Forms > MortgageAppForm.pdf [X.Y] (where [X.Y] represents the version of the form design) and 
click OK. 

8. In the Variable dialog box, click OK.

Note: If the form design has an embedded schema, click Schema Settings. The schema appears in the 
Form Schema Settings dialog box. You may need to click Reload From Form if you change the 
schema in your form design.
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➤ To define a variable to store the mortgage amount: 

1. In the Variables view, click Create New Variable . The Variable dialog box appears. 

2. Type the following information:

● In the Name box, type LoanAmount.

● In the Title box, type Amount of Mortgage.

● In the Description box, type Mortgage amount to use as part of the condition for 
routing..

3. In the Type list, select float.

4. Select Required and click OK.

You have defined the necessary variables for the MortgageLoan process.

Defining operations in your process diagram
You use operations to define the steps in the process diagram for your process version. You will use 
operations to represent the people involved in your automated process and for performing operations to 
data in your automated process. You will add the following operations in your process diagram to satisfy 
the established business process:

● An Execute operation to retrieve the data from the form that is used as input into the process

● Two Assign Task operations to involve specific users from Fin@nce Corporation in the process

➤ To define the operations in the process diagram:

1. In the Services view, select Foundation > Set Value - 1.0.

2. Drag the Execute operation to the upper-left corner of the LOW RISK swimlane.

3. In the Properties view, in the General category, perform the following tasks:

● In the Name box, type Get Form Information.

● In the Description box, type Retrieve information from the form and assign values 
to variables.

4. In the Services view, select Process Management > User - 1.0. 

5. Drag two Assign Task operations to these locations in the specified order:

● Upper-right corner in the LOW RISK swimlane

● Lower-right corner in the HIGH RISK swimlane

6. In the LOW RISK swimlane, select the AssignTask1 operation and, in the Properties view, in the General 
category, perform these tasks:

● In the Name box, type Loan Officer.

● in the Description box, type Approver for loans less than $500,000..
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7. In the HIGH RISK swimlane, select the AssignTask2 operation and, in the Properties view, in the General 
category, perform these tasks:

● In the Name box, type Bank Manager.

● In the Description box, type Approver for loans $500,000 or more..

8. Save your process version.

You have defined the process diagram for your process version, which should look like this illustration.

Assigning values to variables in your process version
You use operation properties to assign values to variables in your process version. Other operations in your 
automated process can also use the variables. You will assign the mortgage amount from the filled form to 
the LoanAmount variable and deselect the Approved and Declined options. 

Caution: The steps listed are dependent on the schema that you embedded in your form design.

➤ To map operations to the LoanAmount variable:

1. In the process diagram, select the Get Form Information operation. 

2. In the Properties view, in the Mappings category, click Add A List Entry . An entry appears in the 
table.
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3. Click [Location], and then click the ellipsis  button that appears beside [Location]. The XPath Builder 
dialog box appears.

4. Under Process_data, double-click LoanAmount. The text /process_data/@LoanAmount appears 
in the middle pane.

5. Click OK.

6. Click [Expression], and then click the ellipsis button that appears beside [Expression]. The XPath Builder 
dialog box appears.

7. In the drop-down list located in the lower-middle pane, select Number. 

8. In the bottom-middle pane, double-click Number(object?). 

9. The text number(object?) appears in the middle pane. 

10. In the middle pane, select the text Object? so that it is highlighted. With the object? text selected, 
select Process_data > LoanForm > Object > Data > Xdp > Datasets > Data > MortgageApp > 
MortgageFields, and double-click Mortgage. 

11. The following text appears in the middle pane:
number(/process_data/LoanForm/object/data/xdp/datasets/data/MortgageApp/
MortgageFields/Mortgage).

12. Click OK.

13. Save your process version.

You have assigned the mortgage amount to the LoanAmount variable in your process version. You will use 
this variable later to route the form appropriately.

➤ To deselect the Approved and Declined options:

1. With the Get Form Information operation still selected, in the Properties view, in the Mappings area, 
click Add A List Entry . Another entry appears in the table.

2. Click [Location], click the ellipsis  button beside [Location]. The XPath Builder dialog box appears.

3. Select Process_data > LoanForm > Object > Data > Xdp > Datasets > Data > MortgageApp > 
ApprovalFields, and double-click Approved. The following text appears in the middle pane: 
/process_data/LoanForm/object/data/xdp/datasets/data/
MortgageApp/ApprovalFields/Approved.

4. Click OK.

5. Click [Expression], and then click the ellipsis button beside [Expression]. The XPath Builder dialog box 
appears.

6. In the middle pane, type "0" and then click OK.

Note: Be sure that you type the quotation marks.

7. Repeat steps 1 - 6, but select Process_data > LoanForm > object > data > xdp > datasets > data > 
MortgageApp > ApprovalFields, and double-click Declined. 

8. Save your process version.
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You have deselected the Approved and Declined options in your process version. This will ensure that if 
the applicant accidently selects the Approved or Declined option, they will be deselected.

Setting operation properties in your process version
Each operation you dragged onto the process diagram has several properties that can be configured. You 
configure operation properties to change the way an operation executes. For instance, when the Assign 
Task operation executes, it will require a form specified by a variable in the process version.

➤ To set the Loan Officer operation properties:

1. In the process diagram, select the Loan Officer operation.

2. In the Properties view, click the Initial User Selection category and, in the Select Initial User area, select 
Assign To Specific User.

3. Click Browse. The Select User dialog box appears.

4. In the Search Type list, select User Name, and then click Find. 

5. In the Results pane, select Alex Pink and click Add. Alex Pink appears in the Select User pane. Click OK. 

6. In the Properties view, click the Task Instructions category and, in the Task Instructions list, select Literal 
Value.

7. In the box below the Task Instructions list, type Approve or decline loans..

8. Click the Form Data Mappings category and perform the following tasks:

● In the Input Form Variable box, type /process_data/LoanForm. 

● In the Output Form Data list, select Variable. In the list below, select LoanForm. 

9. Save the process version.

➤ To set the Bank Manager operation properties:

1. In the process diagram, select the Bank Manager operation.

2. In the Properties view, click the Initial User Selection category and, in the Select Initial User area, select 
Assign To Specific User.

3. Click Browse. The Select User dialog box appears.

4. In the Search Type list, select User Name, and then click Find. 

5. In the Results pane, select Tony Blue and click Add. Tony Blue appears in the Select User pane. Click OK. 

6. In the Properties view, click the Task Instructions category and, in the Task Instructions list, select Literal 
Value.

7. In the box below the Task Instructions list, type Approve or deny loans..

8. Click the Form Data Mappings category and perform the following tasks:

● In the Input Form Variable box, type /process_data/LoanForm. 

● In the Output Form Data list, select Variable and in the list below, select LoanForm. 
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9. Save the process version.

You have set the operation properties for the applicant, loan officer, and bank manager.

Drawing routes in your process diagram
Routes are used to define the order in which a process proceeds through the operations that are defined in 
a process diagram. You can draw routes from one operation to another by dragging connectors from one 
operation to another. When an operation is selected in the process diagram, an anchor appears as a small 
circle on each side of the operation.

You can specify conditions and various operations to execute based on the conditional logic of each route. 
You can rename the routes to identify the condition in the process diagram. You can access data that are 
submitted in XML forms using an XPath expression. An XPath expression is a representation of the data 
based on the schema of the form. You must understand the schema that the form uses to build an XPath 
expression. The schema that is used is based on the schema you embedded into the form design when 
you created it.

➤ To draw routes between operations:

1. In the process diagram, select the Get Form Information operation. Anchors appear on the operation. 

2. Drag the right anchor of the Get Form Information operation to the left edge of the Loan Officer 
operation.

3. With the Get Form Information operation still selected, drag the right anchor to the left edge of the 
Bank Manager operation.

➤ To rename routes:

1. Select the route from the Get Form Information operation to the Loan Officer operation.

2. In the Properties view, click the General category and perform the following tasks:

● In the Name box, type If mortgage is less than $500,000.

● In the Description box, type Route mortgages less than $500,000 to the loan 
officer..

● Drag the If Mortgage Is Less Than $500,000 route label and position it above the border that divides 
the HIGH RISK and LOW RISK swimlanes.

3. Select the route from the Get Form Information operation to the Bank Manager operation.

4. In the Properties view, click the General property group and perform the following tasks:

● In the Name box, type If mortgage is $500,000 or more.

● In the Description box, type Route loans $500,000 or more to the bank manager.. 

● Drag the If Mortgage Is $500,000 Or More route label and position it below the border that divides 
the HIGH RISK and LOW RISK swimlanes.

5. Save your process version.

➤ To modify the evaluation order of routes:

1. In the process diagram, select the Get Form Information operation.
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2. In the Properties view, click the Route Evaluation category. A list of routes appears that originate from 
the Get Form Information operation.

3. Select If Mortgage Is $500,000 Or More and click Move Route Up Condition . It now appears first in 
the list of routes.

4. Save your process version.

➤ To add a condition to the If mortgage is $500,000 or more route:

1. In the process diagram, select the If Mortgage Is $500,000 Or More route. The route appears 
highlighted.

2. In Properties view, click the Conditions category.

3. Click Add Route Condition . The Route Properties dialog box appears. 

4. In the Expression box on the left, type /process_data/@LoanAmount.

Tip: You can use the XPath Builder in the Conditions pane to build the expression.

5. In the Operation list, select >= .

6. In the Expression box on the right, type 500000, and then click OK. The route from the Get Form 
Information operation to the Bank Manager operation changes to a dashed line. A condition also 
appears in the Properties view in the Conditions category.

7. Save the process version.
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You have defined the routes used in your process diagram, which should look like this illustration.



LiveCycle ES Creating a Process
Creating Your First LiveCycle ES Application  Activating your process version for the mortgage application process as a service     45

Activating your process version for the mortgage application 
process as a service

When you activate the process, it becomes available as a service on the server. By default, a service is 
available to be initiated programmatically using EJB or SOAP. 

1. In the Processes view, select Loans > MortgageLoan process.

2. Right-click MortgageLoan - 1.0 and select Activate. A check mark appears on top of the process version 
icon in the Processes view as shown in the following illustration.

You have activated your process as a service on the server. You have completed creating the process for 
your application.

Next, you will configure your service so that it can be used from Workspace ES. If you are testing your 
application in a different environment, follow the tasks described in Exporting and Importing a 
LiveCycle ES Application. 

Activated MortgageLoan 
process.
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5 Exporting and Importing a LiveCycle ES Application

In this section, you will learn how to do the following tasks to move an application from one environment 
to another:

● Exporting your application.

● Importing your application.

Note: You do not need to follow the tasks in this section if you are working in the same environment that 
you are planning to use for your application. 

For more information about working with archive files, see LiveCycle Workbench ES Help.

Exporting your application
You use Workbench ES to export your application. The application is exported as an archive file, which is a 
file that contains a specific version of a process version and all of its associated assets.

➤ To export your application:

1. Log in to the server where you are exporting an application. For information, see Logging in to a 
LiveCycle ES server.

2. In the Processes view, select Loans > MortgageLoan.

3. Right-click MortgageLoan - 1.0 and select Create LiveCycle Archive. The Create A LiveCycle Archive File 
dialog box appears. The internal name for the archive file is made unique by the system by appending 
the date and time to the name.

4. Beside the Destination box, click the ellipsis  button. The Save As dialog box appears.

5. Browse to the location to save your archive file and, in the File Name box, type MortgageLoanAppEx, 
and then click Save.

6. In the Create a LiveCycle Archive File dialog box, click OK.

7. Verify that the MortgageLoanAppEx.lca file is created in the location you specified.

You have exported your application to an archive file. The archive file can be used to import your 
application into another server.
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Importing your application
You must use Archive Administration to import an application into another environment. Archive 
Administration is accessed by logging in to LiveCycle Administration Console. The user profile that you use 
must be assigned either the Application Administrator or Super Administrator role.

➤ To log in to the LiveCycle Administration Console:

1. In the URL line of a web browser, type http://[server]:[port]/adminui (where [server] 
represents the network name of the LiveCycle ES server and [port] represents port number of the 
application server). For example, on the computer where you installed LiveCycle ES using the turnkey 
method, in the URL line of the web browser, type http://localhost:8080/adminui. The 
Administration login prompt appears. 

2. Press Enter.

3. In the User Name box, type kvarsen and, in the Password box, type password, and then click Login.

Note: If you or your administrator have assigned a different user profile to access the LiveCycle 
Administration Console, type your assigned user ID and password.

You have logged in to the LiveCycle Administration Console.

➤ To access Archive Administration:

1. On the LiveCycle Administration Console Home page, click Services.

2. On the Services page, click Archive Administration.

You have accessed Archive Administration.

➤ To import your archive file using Archive Administration:

1. In Archive Administration, click Archive Management.

2. On the Archive Management page, click Import.

3. On the Archive Import page, click Browse. The Choose File dialog box appears.

4. Browse to the location where the MortgageLoanAppEx.lca file was saved, select the 
MortgageLoanAppEx.lca file, and click Open.

5. On the Archive Import page, click Preview.

6. On the Archive Preview page, verify the list of resources and objects, and then click Import.

7. On the Import Results page, verify that resources were imported, and click OK

8. Click Logout.

You have imported your application as an archive file into another environment. You are now ready to 
configure your service.
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6 Configuring a Service

In this section, you will learn how to configure a service. Before your service can be used, you must 
configure and enable an endpoint. An endpoint specifies how a service is to be invoked. Here, you will 
configure an endpoint to be invoked from Workspace ES. 

After you configure the endpoint, it appears as a process card in Workspace ES. Your endpoints can also be 
organized in groups, called categories, that you create here. 

Note: The categories you create here are different from the process categories that you created in 
Workbench ES. 

To configure a service, you must perform the following tasks in the specified order:

● Accessing Archive Administration.

● Creating a category for the MortgageLoan service.

● Configuring your service to be used from Workspace ES.

For more information, see Archive Administration Help, accessible from LiveCycle Administration Console.

Accessing Archive Administration
You must log in to the LiveCycle Administration Console to access Archive Administration. Archive 
Administration is an administrative tool for configuring an endpoint. The user profile you use must have 
administrator privileges on the server.

➤ To log in to the LiveCycle Administration Console:

1. In the URL line of a web browser, type http://[server]:[port]/adminui (where [server] 
represents the network name of the LiveCycle ES server and [port] represents the port number of the 
application server). For example, on the computer where you installed LiveCycle ES using the turnkey 
method, in the URL line of the web browser, type http://localhost:8080/adminui. The 
LiveCycle Administration Console login prompt appears.

2. Press Enter.

3. In the Name box, type kvarsen and, in the Password box, type password, and then click Login.

Note: If you or your administrator have assigned a different user profile to access LiveCycle 
Administration Console, type in your assigned user ID and password.

You have logged in to LiveCycle Administration Console.

➤ To access Archive Administration:

1. On the LiveCycle Administration Console Home page, click Services.

2. On the Services page, click Archive Administration.

You have accessed Archive Administration.
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Creating a category for the MortgageLoan service
You will create a category for services that involve loans. The category you create will be visible as a 
container of endpoints in Workspace ES.

Note: The category you create here is different from the process categories you created in Workbench ES. 

➤ To create a category for the MortgageLoan service:

1. On the Archive Administration page, click Category Management.

2. On the Category Management page, click Add.

3. In the Name box, type Loan Applications.

4. In the Description box, type Forms used for all loan applications., and then click Add.

5. Click Archive Administration.

You have created a category that appears in Workspace ES.

Configuring your service to be used from Workspace ES
When you create an endpoint, it is visually represented as a process card within Workspace ES. When that 
process card is selected in Workspace ES, the form design you created will be used to present a form to the 
user.

Now, you will create and configure an endpoint to specify how your service will be invoked. You will also 
configure permissions so that any validated user who can access Workspace ES can invoke your service. 
Finally, you will save the changes to your service. Your service cannot be invoked unless an endpoint has 
been both configured and enabled.

➤ To configure an endpoint to be initiated from Workspace ES:

1. On the Archive Administration page, click Service Management.

2. On the Service Management page, find and click MortgageLoan: 1.0. You may need to use the page 
links near the bottom of the web page to find your process.

Note: Ensure that you click MortgageLoan: 1.0, which represents the process you activated as a service, 
not the installed sample called MortgageLoan-Prebuilt:1.0 link.

3. On the Configure MortgageLoan page, click the End Points tab and, in the list of endpoints, click 
TaskManager.
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4. Click Add.

The following illustration shows the TaskManager endpoint selected in the list before you click Add.

5. On the Add TaskManager Endpoint page, provide a name and description:

● In the Name box, type Mortgage Application.

● In the Description box, type Form used for starting a mortgage application..

6. In Task Instructions box, type Complete the application and one of our 
representatives will contact you within two business days..

7. In the Categorization list, select Loan Applications and, in the Operation Name list, select Invoke.

8. Click Add.

Note: If Status is not Enabled, select the option left of Mortgage Application, and click Enable.

You have configured a Task Manager endpoint for the process, which allows the process to be invoked 
from Workspace ES.

➤ To specify permissions to invoke your service:

1. Click the Security tab and then click Add Principal.

2. On the Select Principal page, select All principals in domain Sample Organization, Finance Corp. You 
must select all principals for the domain that your users belong to.

Note: You can also select the All Principals option, which allows all users that have access to 
Workspace ES to start a process. In production systems, it is recommended that you do not 
select this option.

3. On the Add Permissions page, select INVOKE_PERM, and then click Add.

4. Click Logout.

You have configured your service so that everyone who can access Workspace ES can invoke the service.
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7 Testing a Service Using LiveCycle Workspace ES

In this section, you will learn how to use Workspace ES to test your service. You must perform these tasks in 
the specified order:

● Logging in to Workspace ES

● Starting a mortgage application

● Verifying mortgage application routing

You will log in to Workspace ES using various user IDs in order to test your service:

Rye Woodard: You will use this user profile to fill and submit a mortgage application.

Alex Pink: You will use this user profile to log in as the loan officer.

Tony Blue: You will use this user profile to log in as the bank manager.

Logging in to Workspace ES
You must log in to the system using various user IDs in order to test your service. 

➤ To log in to Workspace ES:

1. In the URL line of a web browser, type http://[server]:[port]/workspace (where [server] 
represents the network name of the LiveCycle ES server and [port] represents the port number of the 
application server). For example, on the computer where you installed LiveCycle ES using the turnkey 
method, in the URL line of the web browser, type http://localhost:8080/workspace. The 
Workspace ES login screen appears.

2. Press Enter.

3. In the Name box, type the appropriate user ID and, in the Password box, type your password, and then 
click Login.

You have logged in to Workspace ES.

Starting a mortgage application
In Workspace ES, you must start a process to fill a form to initiate the mortgage approval service. You have 
already configured an endpoint and assigned it to a category. In Workspace ES, the endpoint you 
configured is visually represented by a process card that is accessible from the category you assigned. 
When you click the process card, the MortgageLoan service is invoked, which displays the form design.
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➤ To fill a form:

1. Log in to Workspace ES using Rye Woodard to start the activity. For information, see Logging in to 
Workspace ES. After you log in, the Welcome screen appears as shown in the following illustration.

1. On the Welcome screen, click Start Process .
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2. On the Start Process tab, click Loan Applications. The mortgage application is displayed as a process 
card as shown in the following illustration.

3. In the process card, click the Fin@nce Corp. icon . The Task Details and Form tabs appear; the Form 
tab is selected.

Note: If you click an area other than the Fin@nce Corp. icon in the process card, the Task Details and 
Form tabs appear but the Task Details tab is selected. 

4. On the Form tab, under Step 1: Mortgage Information, perform the following tasks:

● In the Property Sale Price box, type 750000.

● In the Down Payment box, type 200000. In the Mortgage Amount box, the value of $550,000 
appears.

● In the Term (Years) list, select 25.

● In the Interest Rate list, select 5.50.

● In the Last Name box, type Woodard.

● In the First Name box, type Rye.

● In the SSN box, type 123456789.

Process cardCategory
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● In the Phone Number box, type 1231231234 and press the Enter key.

After you fill the form, it should look like the following illustration.

Note: You will notice that the Submit button is no longer present in the form. Instead, the Complete 
button is used to submit a form.

5. Below the form, click Submit This Task . A prompt appears in the lower-right corner that 
indicates that the task was submitted.

6. Click Logout. A Please Confirm dialog box appears with the prompt “Are you sure you want to logout?”

7. Click OK.

You have filled out a mortgage application and logged out of Workspace ES.

Verifying mortgage application routing
Because you applied for a mortgage of $550,000, you must verify whether the form was routed to the bank 
manager. You will log in as both the loan officer and the bank manager to verify that the loan application 
was correctly routed. The following two results occur:

1. The mortgage application was not routed to the loan officer because the loan amount is more than five 
hundred thousand dollars.

2. The mortgage application is routed to the bank manager because the amount is equal to or greater 
than five hundred thousand dollars.
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Logging in as the loan officer
1. Log in as Alex Pink. For information, see Logging in to Workspace ES. 

2. On the Workspace ES Welcome page, verify that no number appears next to To Do.

3. Click Logout. A Please Confirm dialog box appears. 

4. Click OK.

You have verified that the mortgage application did not route to the Alex Pink, the loan officer.

Logging in as the bank manager and approving the mortgage
1. Log in as Tony Blue. For information, see Logging in to Workspace ES.

2. On the Workspace ES Welcome page, verify that the number 1 appears next to To Do, and then click To 
Do .

3. On the To Do tab, click the image on the Bank Manager card. The Task Details and Form tabs appear.

4. In the Form tab, scroll down to the Approved and Declined fields, select the Approved field, and then, 
below the form, click Complete. A prompt appears in the lower-right corner that indicates that the task 
submitted successfully. Also, the number in the To Do tab decrements by one.

5. Click Logout.

You have verified that the mortgage application was routed correctly. You have selected Approved. All you 
need to do is call your new customer to give them the good news.

You have now completed testing the mortgage application section and this tutorial.
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