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About this tutorial

In this tutorial, you will learn how to change a form’s fixed layout to a flowable layout by using subforms so that the form displays all the
orders that one of your clients requested. You will also learn how to merge a form with data.

Start this tutorial with the form created in the Creating a purchase order form tutorial. You will rework the form to have a flowable layout.
A flowable layout means that the form will adjust to accommodate data so that it displays all the orders that one of your clients requested.

The form design in this tutorial presents information from a data source. The resulting form is a non-interactive form that you can print or
store electronically.

Additional information

For information about See

Other form design tutorials Creating a purchase order form

Creating and using fragments in form designs



http://www.adobe.com/go/learn_lc_qs_poform_9
http://www.adobe.com/go/learn_lc_qs_poformflowable_9
http://www.adobe.com/go/learn_lc_qs_poform_9
http://www.adobe.com/go/learn_lc_qs_poformflowable_9
http://www.adobe.com/go/learn_lc_qs_fragments_9
http://www.adobe.com/go/learn_lc_qs_poform_9
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Creating a purchase order form that has a flowable
layout

Here are the steps to changing a form’s layout to a flowable layout using subforms:
About creating a purchase order form that has a flowable layout
Opening the purchase order form

Enhancing the format of the form

Organizing the form

Formatting the footer

Setting the table to dynamically grow

Fixing the calculation for the Total field

Setting the fields to read-only

Connecting to a data source

Binding the data to fields and table cells

Specifying a data file



About creating a purchase order form that has a flowable layout
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About creating a purchase order form that has a flowable layout

When you finish working through this tutorial, the form you create will look like this purchase order form merged with data.

_/\/'
Finance

corporation

Purchase Order

Ordered By Any Company Name

F.O.Mumber  gegcaznes

F.CL Drate S-Feh-2004

DeliverTa Any Compary Name

Address  coe any B, Address 7805 Any Street
City Any City State ¢ ZipCode j3345 City Any City State o7 ZipCode g,
COuntry  pny Country Country & ny Country
Phone Number (133 456 7800 Phone Number 1133) 4567801
Faxhumber 133y 456 7800 FaxNumber 1123) 4567809
ContactMame e+ Mame Contact Mame Contact Mame
Part Mo, Diescription Quantity LInit Price Arnount
000710-100 Muonitor 1 %350.00 5350.00
00010-200 Desk lamps 3 85500 416500
00025-275 Phone 5 S85.00 542500
00300-896 Address book 2 51500 530,00
Terms and Conditions Total 3570.00
State Tax % 7000 State Tax 46790
Account number: 123456
Federal Tax%  8.00% Federal Tax 57760
Shipping Charge 550,00
Authorized By =
Grand Total 41,165.50

To complete this tutorial, you need a schema and a data file. You can use those that come with Designer ES2 if you have installed the samples.

The schema and data file are in the following location, by default:

« \EN\Samples\Forms\Purchase Order\Schema\Schema\Purchase Order.xsd
+ \EN\Samples\Forms\Purchase Order\Schema\Data\Purchase Order.xml
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Opening the purchase order form

To start, you will open the Purchase Order form that you saved in the previous tutorial.

Select File > Open.

Locate the form that you saved in the previous tutorial and click Open.

Select File > Save As and select Adobe Dynamic XML Form (*.pdf) from the Save As Type list.
Change the name of the file.

Click Save.
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If you plan to create more forms that have a flowable layout instead of forms that have a fixed layout, you can set the default file type
for new forms to Dynamic PDF Form file in the Tools > Options dialog box (Document Handling tab).

Enhancing the format of the form

To enhance the format of the form for printing, you can make the field objects above the table an underline instead of a sunken box.

N
L ]
Flnance P 0. Number
corporation
PO, Date

Purchase Order

Ordered By DeliverTo

Address Address

City State  DpCode City State  ZipCode

Caurvtry Country

Phone Murmbsr Phone Murnbsr

Fax Mumber Fax Mumber

ContactMame _ ontact Marme
- il r,.-n\__,__n_‘,---.,_ﬁ T e, ;"' R TR v e e T e

1 Select the P.O. Number field.
In the Object palette, click the Field tab and, in the Appearance list, select Underlined.
Repeat for the remaining field objects above the table.

O You can change selected objects of the same type all at once.

Select all the field objects above the table, except for the Print Button, Logo, and Purchase Order title.
In the Paragraph palette, click Align Bottom.
View the form in the Preview PDF tab.

N & nn b

Click the Design View tab to continue editing the form design.
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Organizing the form

To create a form that has a flowable layout, you must organize the sections into subforms to merge with data. Subforms are objects that act

as containers for other objects, including fields, boilerplate objects, and other subforms. They help to position objects relative to each other

and provide structure in form designs that have a flexible layout.

1

uu b W N

In the Hierarchy palette, select all the items that appear above the table.

Hierarchy =%, PDF Structure ™. Data View

= J purchaseCrder
-l (Master Pages)
= 7 PurchaseOrder
Bt FrintButton
----- 1 ogo
®ye)] PurchaseorderTitle

=

OrderedByAddress

P DeliverToCity
P DeliverToState
gl DeliverToZipCode
53 DeliverToCountry
P DeliverToPhone
P DeliverToFax
? DeliverToContact

)

----- #1 (Referenced Objects)

Select Insert > Wrap in Subform.
Select the (untitled Subform), right-click, and select Rename Object.
Type Header and press Enter.

To ensure that the Header subform has space above it, make sure that the Layout palette is displayed and, in the Height box under Size
& Position, type 4.5 in.



Organizing the form

6 Collapse all the items in the hierarchy.
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7 Repeat steps 1 and 2 for all the items below the table (total to SignatureField1) and rename this new (untitled Subform) Footer.

? federalTaxPercent
federalTax
shippingCharge
stateTaxPercent
gra

andTotal
TextField3 |

SignatureFieldl
..... ), (Referenced Objects)

*ﬁé@?@*@*@

8 To ensure that there is space before the Footer subform, make sure that the Layout palette is displayed and, in the Top box under

Margins, type 0.25in.

This is what you should see in the Hierarchy palette if you collapse everything under PurchaseOrder.

E| __| PurchaseOrder
i1 Header

" (Referenced Objects)

8
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Formatting the footer

To enhance the format of the footer, you can make the fields below the table show an underline instead of a sunken box. You can also set the
captions and values to be bottom-aligned and set just the values in the fields to be center-aligned.

_-"-""'.,\_._,. _ _,_..-'._ S et __,-_f""".'-,__,_."'.- LR VSR e e ""/."'“‘__K'r e ._F_.. =y e s T _,_p"" -
Terms and Conditions Total
State Tax%e 600fG  State Tax S0.00
Federal Tax®%  800% FederalTax S0.00
Shipping Charge 550,00
Authorized By =
Grand Total L5000

1 Drag to select the fields in the footer, except for the Terms and Conditions and the Authorized By fields.

' Ifyou try to drag to select the fields and you have the Move pointer, click anywhere along the edge of the form design to change the pointer
¢ to an arrowhead shape.

In the Object palette, click the Field tab and, in the Appearance list, select Underlined.
In the Paragraph palette, click Align Bottom.

In the Currently Editing palette, select Edit Value to change the paragraph alignment of just the value.
Click Align Center.

uu A W N
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Setting the table to dynamically grow

In a form that has a flowable layout, you may not know how much data the data source contains; therefore, you cannot specify how many
rows the table should have. You have to set the table to be dynamic. To do this, you include only one body row that is set to repeat, depending

on how much data there is in the data source.

1 Drag to select the rows that are below the first row.

2 Select Table > Delete > Row.
3 In the Hierarchy palette, select Tablel.

Hierarchy x"RDF Structure “gta View  —
= ,j purchaseOrder o

I (Master Pages)
El,j PurchaseCrder

1-{ = Header

- i

= HeaderRow
- [ cell

=l

4  Select Insert > Wrap in Subform.

This action creates a section in the form that contains the table. You need to separate this section from the remainder of the form to
make it dynamically grow to fit the data.

5 With the (untitled Subform) selected in the Hierarchy palette, in the Object palette, click the Subform tab and, in the Content list, select
Flowed.

6 Rename the (untitled Subform) to Table.
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In the Hierarchy palette, select Rowl.
In the Object palette, click the Binding tab and select Repeat Row For Each Data Item.
Now you need to set the entire form to flow.

9 In the Hierarchy palette, select the PurchaseOrder subform.

10 In the Object palette, click the Subform tab and, in the Content list, select Flowed.

Setting the entire form to flow, formats each subform in the form, one after another, leaving no space between them.

Fixing the calculation for the Total field

Now that you have reorganized the contents of your form, the calculation for the total needs to reference the new Table subform.
Select the Total field.
Drag the Script Editor palette bar until the palette is the required size to show multiple lines.

In the Script Source field, revise the script to show the following calculation:

sum (Table.Tablel.Rowl [*] .amount [*])

4 Deselect the Total field to add the script to your form design.

Setting the fields to read-only

For a printable form, you do not want users to edit the fields; therefore, you must set the fields to read-only.

In the Hierarchy palette, open the Header subform and select all the text fields (such as PONumber, OrderedBy, OrderedByAddress).
In the Object palette, click the Value tab and, in the Type list, select Read Only.

In the Hierarchy palette, open the Table subform and select the text fields (partNo and description).

In the Object palette, click the Value tab and, in the Type list, select Read Only.

Repeat for quantity, unitPrice, and amount.

SN 1 A W N =

Repeat for the items in the Footer subform (except for the SignatureField).

Connecting to a data source

To merge data with your form, you need to connect to a data source. After you connect, you need to bind the data to a field in your form
design.

When you bind the fields in a form design to a data source, you create an association between the form design and the data source that allows
you to capture, present, move, process, output, and print information associated with the form design.
1 Select File > New Data Connection.
Select XML Schema and click Next.
If you or your administrator installed the samples that come with Designer ES2, locate the schema named Purchase Order.xsd and click
Open.
This file is located in \EN\Samples\Forms\Purchase Order\Schema\Schema.
4 Click Finish.



Binding the data to fields and table cells

The data appears in the Data View palette.

Data View E

Hierarchy @ PDF Structur
= i DataConnection
=/ general
gﬂ poNum
@ poDate
== order
- companyName
-5 address

-4 stateProv
LA 7ipCode
B8 country
J;H phone

- B fax

LA contactName

| v

ADOBE LIVECYCLE DESIGNERES2 |12

Creating a Purchase Order Form That has a Flowable Layout

The Data View palette displays a hierarchy view of each data source. The top node in the hierarchy represents the data connection and

displays the name that you assigned when you created the connection.

Binding the data to fields and table cells

After you connect to a data source, you need to indicate where you want to see the data in the form design:

+ To bind single fields, such as the PO. Number and P.O. Date, you can use the drag and drop method.

To bind repeating objects, such as the row in the purchase order table, to repeating items in the schema, use the Data Binding box in the
Binding tab of the Object palette. After the row is bound, you can bind cells in the row to nodes in the schema, which makes these

bindings relative to the row binding.

To bind the data to fields in the form design
1 Inthe Data View palette, select poNum and drag it to the PO. Number field.

2 In the Binding Properties dialog box, select Don't Update Any Related Properties, and then click OK.
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Binding associates an existing form field with an item from the data source. In the image, the icon to the right of poNum shows that the
node is bound. Because you chose not to update any related properties, Designer ES2 keeps the formatting you have already applied to
the field object intact.

Hierarchy [ PDF Structuref Data View = .

=a

= ] DataConnection =
=/ general
-5 poNum 8
- poDate
== order
-5# companyName |
~LA address

-LA stateProv
-5 7ipCode
-5 country
52 phone
g fax

~5# contactName
FT ™ 4

3 Repeat for the remaining items in the Data View palette (except for partNum, description, quantity, and unitPrice).

For example, companyName should be bound to the Ordered By field.

To bind the data to table cells in the form
1 In the Hierarchy palette, select Rowl.
2 In the Object palette, click the Binding tab.
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3 Click the triangle beside the Data Binding (Open, Save, Submit) box and select a binding. For example, select DataConnection > item
> item.

]
| Object =Y Accessibility

| Row\i Paginah’on\i Binding ™.

MName: | Rowl u 0 ‘

Default Binding (Open, Save, Submit):

‘ item =.  Normal |
Import/Export Bindings (Execute): DataConnection * general
‘ = . order
one delivery
Repeat Row for Each Data Item item
[v] Min Count: [ ] max: I:l item
terms
[ ]1nitial Count: -
shipping

The following string appears in the Data Binding (Open, Save, Submit) box:

Srecord.item.item[*] .

Q You can type this string into the Data Binding (Open, Save, Submit) box instead of selecting it.

Open the Data View palette.

To ensure that the binding is set the way you prefer, bind each node to a cell by using the drag and drop method. For example, in the
Data View palette, select partNum, and drag it to the cell under the heading Part No.

In the Binding Properties dialog box that appears, select Don’t Update Any Related Properties and click OK.

7 Repeat for the remaining items in the Data View palette under item (description, quantity, and unitPrice).

Specifying a data file

The last task is to point to a data file to merge with the form.

Select File > Form Properties and click the Preview tab.
2 In the Preview area, browse for the location of the data file you want to use.

For example, if you or your administrator installed the samples that come with Designer ES2, locate the data file named Purchase
Order.xml, which is located in \EN\Samples\Forms\Purchase Order\Schema\Data.

Click Open and then click OK.
View the form in the Preview PDF tab.



Specifying a data file

Your form should now look like this illustration.
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corporation

Purchase Order

Ordersd By Any Company Name

_/\/
Finance

Address  goe any Bl

Country Any Country

s7  ZipCode 13345

FPhone Mumbsr (123) 456-7890

DieliverTo Any Com parry Name

F.CL Murnber A745238085

F.O.Dats &-Feb-2004

Address  7gos amy Street

Country Any Country

Phone Murnber

(122) 458-7891

FamMumber  133y456.7000 FawNumber 333y 456 7800
ContactMame b0 Mame Contact Mame Contact Mame
Part N Desaription Cluantity Lnit Price Amount
Q0010-100 Monitor 1 4350.00 4350.00
00010-200 Dresk lamps 3 L5500 S165.00
00025-275 Phone 5 S85.00 5425.00
00300-896 Address book 2 51500 £30.00
Terrns and Conditions Total $970.00
State Tax %o 700G State Tax 6780
Acoount numbsr 123458
Federal Tax % 8.00% FederalTax STT.E0
Shipping Charge 55000
Authorized By W
Grand Total S1,16550

Q The Purchase Order.xml data file that comes with Designer ES2 contains four records. You can modify this XML file so that you can test the
layout of the form to verify that it adjusts to accommodate data by using a data file that contains more data.

(Optional) To test the Purchase Order form to ensure it that is flows the merged data properly:

1 Open the XML file and find the following lines:
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<item>
<partNum>00300-896</partNum>
<description>Address book</descriptions>
<quantitys>2</quantitys>
<unitPrice>15.00</unitPrice>

</item>

Below the previous lines, you can add more items. For example, you can add these lines:

<item>
<partNum>00300-300</partNum>
<description>Clipboard</descriptions>
<quantity>3</quantitys>
<unitPrice>5.00</unitPrice>

</item>

<item>
<partNum>00300-325</partNum>
<description>Paper Punch</descriptions>
<quantitys>l</quantitys>
<unitPrice>8.00</unitPrice>

</item>

<items>
<partNum>00300-350</partNum>
<description>Ruler</description>
<quantity>5</quantity>
<unitPrice>1.00</unitPrice>

</item>

<items>
<partNum>00300-400</partNum>
<description>Scissors</descriptions>
<quantitys>2</quantity>
<unitPrice>2.00</unitPrice>

</item>

<items>
<partNum>00300-425</partNum>
<description>Tape</description>
<quantity>2</quantity>
<unitPrice>2.50</unitPrice>

</item>

<item>
<partNum>00300-450</partNum>
<description>Glue Stick</descriptions>
<quantitys>2</quantitys>
<unitPrice>1.00</unitPrice>

</item>

<item>
<partNum>00300-475</partNum>
<description>Stapler</description>
<quantitys>2</quantitys>
<unitPrice>4.00</unitPrice>

</item>

<items>
<partNum>00300-500</partNum>
<description>Highlighters</description>
<quantitys>l</quantitys>
<unitPrice>5.00</unitPrice>

</item>

<items>
<partNum>00300-550</partNum>
<description>Selfstick Notes</descriptions>
<quantitys>4</quantitys>
<unitPrice>5.00</unitPrice>

</item>
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<item>
<partNum>00300-575</partNum>
<description>Composition Notebook</descriptions>
<quantitys>5</quantity>
<unitPrice>8.00</unitPrices>

</item>

Save the revised data file with a new name.
In the Form Properties dialog box, click the Preview tab and find the revised data file.
Click OK and view the form in the Preview PDF tab again.

What's next?

If you have worked through the tutorials, you know the basics of how to set up a form. You may now want to include the header row in the
table on subsequent pages. You also may want to add page numbering. For additional information about forms with a flowable layout, see
the topic "Working with forms that have a flowable layout" in LiveCycle Designer ES2 Help.
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