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About this tutorial

In this tutorial, you will learn about creating and using fragments to simplify the process of creating collections of forms. 

Before you start, you may want to view a video tutorial that walks you through the steps of working with form fragments. See Form 
Fragments Video Tutorial.

Additional information

For information about See

Fragments "Using fragments" in LiveCycle Designer ES2 Help

Other LiveCycle Designer ES2 tutorials Creating a purchase order form

Creating a purchase order form that has a flowable layout

http://www.adobe.com/go/learn_lc_qs_poform_9
http://www.adobe.com/devnet/livecycle/articles/fragment_tutorial.html
http://www.adobe.com/devnet/livecycle/articles/fragment_tutorial.html
http://www.adobe.com/go/learn_lc_qs_poformflowable_9
http://www.adobe.com/go/learn_lc_designer_9
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Creating and using fragments in form designs

Here are the steps for using fragments to simplify the process of creating collections of forms:

About Creating and using fragments in form designs

Opening the sample fragment in the Fragment Library palette

Creating a fragment

Editing a fragment

Using fragments that contain script

Using fragments when controlling the display of subforms

About Creating and using fragments in form designs
You are tasked with creating a collection of forms. From experience, you know that the first form that you create normally involves some 
trial and error before you get it just right. However, after you create that first form, you begin to find areas where you can create shortcuts 
to speed up and improve the process so that the remaining forms you create go together much faster. 

For example, you discover that the majority of the forms you are creating include a delivery address part. Instead of creating the delivery 
address subform in each new form, you copy the first delivery address subform you created and paste it into a separate XDP file. That way, 
you can easily copy the delivery address subform and paste it into the other forms that you create. When you have to change the delivery 
address part, either you make the change in every form, or you make the change in the separate XDP file and then replace the delivery 
address part in every form.

In LiveCycle Designer ES2, these reusable parts are called fragments, and instead copying the part from a separate file each time you need 
to use the part, you can insert a reference to the required fragment and the fragment appears in the form. Then, when you update a fragment, 
all forms that reference the fragment reflect the changes. 

All fragments are included in the form when it is saved as a PDF file.
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Opening the sample fragment in the Fragment Library palette
The Fragment Library palette contains fragment libraries. A fragment library corresponds to a folder in your file system that contains the 
fragment source XDP files. 

The My Fragments library contains sample fragments that you can insert into a form design or use to create new fragments. 

Next, you will open the fragment library for the sample forms for easy access to the fragments.

1 Select Window > Fragment Library to display the Fragment Library palette.
2 In the Fragment Library palette menu, select Open Fragment Library. 
3 Select Fragments in EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.
4 Click OK. 

Creating a fragment
In this section, you will learn how to create a fragment. 

You can create a fragment in a separate file or in the current form design. 

1 Open the Purchase Order Interactive.pdf sample form located in \EN\Samples\Forms\Purchase Order\Form Fragments\Forms.
2 At the top of the form, select the P.O. Number and P.O. Date Text Field objects.
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3 Select Edit > Fragments > Create Fragment.

4 In the Name box, type PO Info as the name for the fragment.
5 Type Purchase Order Number and Date as the description of the fragment.
6 To define the fragment in a separate XDP file that is stored in the Fragment Library, select Create New Fragment In Fragment Library. 
7 To define the fragment in the current document, select Create New Fragment In Current Document.
8 In the Fragment list, select Open Fragment Library, and then navigate to and select the Fragments folder in 

EN\Samples\Forms\Purchase Order\Form Fragments\Fragments.
9 Leave the Replace Selection With Reference To New Form Fragment option selected so that the P.O. Number and P.O. Date Text Field 

objects in the form design will be replaced with the new form fragment.
10 Click OK. 
11 Save the form design as My PO Interactive.PDF. 
Notice that the look of the P.O. Number and P.O. Date objects has changed. The change is because a reference to the newly created PO Info 
fragment has replaced the objects.

A fragment icon appears in the upper-left corner of a fragment reference and uses the color of the object boundary borders. The objects 
within a fragment reference have gray borders to indicate that you cannot edit them from the fragment reference.

Clicking anywhere within a fragment reference selects it, and dragging anywhere on a fragment reference moves it. You cannot select any 
of the objects in a fragment reference. 
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Similarly, the objects in a fragment reference are not available in the Hierarchy palette because you cannot select or edit them in a fragment 
reference. 

A. Fragment reference icon on a subform B. The objects in a fragment are not available

You can move a fragment reference and its contents in the Hierarchy palette in the same way that you move other form objects. However, 
you cannot drag objects into a fragment reference. 

Editing a fragment
One of the main advantages of fragments is that you can add them to many forms, but when you need to make a change, you only need to 
make it in one place. In this section, we will edit the PO Info fragment.

First, you will add the fragment to the Purchase Order Dynamic Interactive.pdf form so that you can see the effect on more than one form 
design when you edit the PO Info fragment. 

1 Open Purchase Order Dynamic Interactive.pdf. 
2 Select and delete the P.O. Number and P.O. Date objects. 
3 In the Fragment Library palette, drag the PO Info fragment onto the form design. 
4 Save the form design as My PO Dynamic Interactive.PDF.
5 Right-click the PO Info fragment reference and select Fragments > Edit Fragment. The PO Info fragment source file opens in 

Workbench ES2 and you can now edit the fragment.
6 Replace P.O. Number with P.O. No.
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7 Open the My PO Interactive.pdf and My PO Dynamic Interactive.PDF sample forms. The fragment reference in both forms is updated.

You have just learned how to create and modify a fragment. In addition, you can convert a fragment reference to an embedded object or 
create an override on a fragment reference that only affects the fragment reference in the current form.

Next, we will take a closer look at the sample forms and review some interesting things that you can do with fragments.

Using fragments that contain script
Fragments can contain reusable JavaScript functions or values that are stored separately from any particular script object. You use these 
fragments to create custom functions and properties that you want to use in many locations on a form or that you want to use in many forms. 

For example, the countryScript sample fragment controls the interaction between the Country and State/Province drop-down lists in the 
sample forms. The options that appear in the State/Province drop-down list depend on the country selected in the Country drop-down list.

To test a sample script fragment
1 Open the My PO Interactive.pdf sample form and click the Preview PDF tab in the Layout Editor.
2 Under the Ordered By section in the form, select Canada from the Country drop-down list and then click the State/Province drop-down 

list. The list displays provinces to select from. 
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3 Next, select United States from the Country drop-down list and then click the State/Provinces drop-down list. The list displays states to 
select from.

Next, we will take a closer look at the countryScript fragment in the sample forms.

To view the script in the countryScript fragment
1 In the Fragment Library palette, right-click countryScript and select Edit Fragment. 

Notice that the fragment is a child of Variables in the Hierarchy palette. Fragments cannot contain scripts that are associated with other 
form objects, such as event scripts like validate, calculate, or initialize.

2 Select the countryScript script object in the Hierarchy palette.
3 Expand the Script Editor to view the script.

The countryScript fragment is referenced by the drpDeliverToCountry and drpDeliverToStatePrv Drop-down list objects in the 
OrderedByAddress and DeliverToAddress fragments in the sample forms.
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4 In the Fragment Library palette, right-click DeliverToAddress and select Edit Fragment. 
5 Select the drpDeliverToCountry Drop-down list object in the Hierarchy palette and view the script in the Script Editor. Notice how the 

countryScript fragment is referenced in the Script Editor.

Using fragments when controlling the display of subforms 
The Purchase Order Dynamic.xdp sample form uses fragments to configure the footer to display the correct address, depending on the data 
being merged with the form. When the sample form is merged with the Purchase Order Canada.xml file, the FooterCanada fragment is 
instantiated; however, when the form is merged with the Purchase Order US.xml file, the FooterUS is instantiated.

1 Open Purchase Order Dynamic.xdp and click File > Form Properties > Preview.
2 In the Data File field, click the Browse button and select the Purchase Order US.xml data file located in EN\Samples\Forms\Purchase 

Order\Form Fragments\Data. 
3 Click Open and then click OK.
4 Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer shows an American address.

5 Click File > Form Properties > Preview.
6 In the Data File field, click the Browse button and select the Purchase Order Canada.xml data file located in 

EN\Samples\Forms\Purchase Order\Form Fragments\Data. 
7 Click Open and then click OK.
8 Click the Preview PDF tab in the Layout Editor. Notice that the corporate address in the footer now shows a Canadian address.

Next, we will view how this choice section was created.
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To view the FooterCanada and FooterUS fragments
1 Right-click the FooterCanada fragment in the Hierarchy palette.

2 Select the Fragments > Edit Fragment option. You can see that the fragment consists of two Static Text objects, one displaying the 
Canadian address. 

3 Repeat the same procedure to view the FooterUS fragment.

To view the choice section in the Purchase Order footer
1 In the Purchase Order Dynamic.xdp sample form, click the Master Pages tab in the Layout Editor.
2 Scroll to the bottom of the page where the footer is located. Notice that both the FooterCanada and FooterUS fragment references are 

placed one on top of the other in the subform set. However, depending on the data, only one footer appears when the form is rendered. 
Also, because the size was adjusted to fit the bottom of the page, a small icon  appears to notify you that there are property overrides 
on the fragment references.

3 In the Hierarchy palette, select the subform set and, in the Subform Set tab of the Object palette, click Edit Alternatives. The Edit Data 
Nominated Subforms shows the binding, language, and expression for the alternative footer fragments. 
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4 Open the Purchase Order US.xml and Purchase Order Canada.xml files using a text editor. Notice that the value for <americas> 
</americas> is US in Purchase Order US.xml and Canada in Purchase Order Canada.xml. It is this value that determines which fragment 
is instantiated when the data is merged in the form.

What’s next?
You have just seen the various ways in which fragments can simplify and speed up the creation and maintenance of a collection of forms. 
For additional information about fragments, see the topic "Using fragments" in LiveCycle Designer ES2 Help. 

http://www.adobe.com/go/learn_lc_designer_9
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