2.2 System requirements

2.2.1 Minimum hardware requirements

This table provides the minimum hardware requirements that LiveCycle supports.

Operating system

Minimum hardware requirement

Microsoft Windows Server® 2008 R1/R2 (64-bit architecture)

Intel® Pentium® 4, 2.8 GHz processor or equivalent

VMWare ESX 3.0 or later

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

Microsoft Windows Server® 2003 Enterprise Edition or Standard Edition SP2 and R2 SP2 (64-bit architecture)

Intel® Pentium® 4, 2.8 GHz processor or equivalent

VMWare ESX 3.0 or later

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

Sun Solaris 10 (64-bit architecture)

UltraSPARC® IIIi, 1.5 GHz processor

Solaris Containers (Zones) partitioning

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

IBM AIX 6.1

P5 pSeries 520 (Model 52A) 9131-52A, 1.8 GHz processor

LPAR partitioning

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

SUSE Linux Enterprise Server 10.0 and 11.0 (64-bit edition only)

Dual core, 1 GHz processor

VMWare ESX 3.0 or later

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

Red Hat Enterprise Linux AP or ES 5.5 (64-bit edition only)

Dual core, 1 GHz processor

VMWare ESX 3.0 or later

RAM: 4 GB (64-bit OS with 64-bit JVM)

Free disk space: 5.4 GB of temporary space plus 3.4 GB for LiveCycle

2.2.1.1 Intel x86 compatibility

On supported Windows and UNIX -like environments, LiveCycle supports Intel and AMD64 compatible chipsets running either 32-bit or 64-bit supported operating systems.

Note: 32-bit platforms are supported only for development and evaluation purposes.

2.2.1.2 Recommended hardware requirements

For a small production environment:

Intel environments: Pentium 4, 2.8 GHz or greater. Using a dual core processor will further enhance performance.

Sun SPARC environments: UltraSPARC V or later.

IBM AIX environments: Power4 or later

Memory requirements: 4 GB of RAM.

2.2.1.3 Recommended hardware requirements for client-side computers

Adobe® LiveCycle® Workbench 10

  • Disk space for installation:

    1.5 GB for Workbench only

    1.7 GB on a single drive for a full installation of Workbench, Adobe® LiveCycle® Designer 10, and the samples assembly

    400 MB for temporary install directories - 200 MB in the user temp directory and 200 MB in the Windows temporary directory

    Note: If all of these locations reside on a single drive, there must be 1.5 GB of space available during installation. The files copied to the temporary directories are deleted when installation is complete.
  • Memory for running Workbench: 2 GB of RAM

  • Hardware requirement: Intel® Pentium® 4 or AMD equivalent, 1 GHz processor

  • Minimum 1024 X 768 pixels or greater monitor resolution with 16-bit color or higher

  • TCP/IPv4 or TCP/IPv6 network connection to the LiveCycle server

Note: You must have Administrative privileges to install Workbench on Windows. If you are installing using a non-administrator account, the installer will prompt you for the credentials for an appropriate account.

Designer

  • Adobe® Reader® X and Adobe® Acrobat® X Pro (recommended) is required to benefit from all the new features in Designer.

  • Adobe® Flash® Player 10.2 or later.

  • (Optional) Adobe® Flash® Builder® 4.5 or later.

  • (Optional) Adobe® Flex® SDK 4.1 (required for customizing form guide components that are shipped with Designer).

Note: Use the Flex SDK 4.1 included with the Designer installer only. Do not use any other version of Flex SDK obtained from the Adobe web site.
Note: For more information, see Installing Your Development Environment.

End-user hardware requirements:

  • Adobe® LiveCycle® Workspace 10: 1 GB of RAM (includes requirements for Adobe Flash and Adobe Reader)

  • Adobe Flash Player 9 or later: 512 MB of RAM (1 GB recommended)

  • Adobe Reader 8.x or later: 128 MB of RAM (256 MB recommended)

Note: For web browser requirements, see LiveCycle Supported Platform Combinations.

2.2.2 Supported Platforms

For detailed information about the supported combinations of operating systems, application server, databases, JDKs, and so on, see LiveCycle Supported Platform Combinations.

2.2.3 Additional requirements for AIX, Linux, and Solaris

Note: On AIX, Linux and Solaris machines, the LiveCycle installer uses the JDK installed on the machine. Therefore, you must ensure to install the supported JDK version. On other operating systems, the installer uses the JVM bundled with the installer.

2.2.3.1 Installing and configuring UTF-8

When installing LiveCycle on AIX, Linux, or Solaris operating systems, you must install and configure the US English version of UTF-8 locale if it is not already installed. You will need the install media (CDs or DVDs) for the operating system to perform this task.

Note: On Linux platforms, this locale is installed by default and is called en_US.utf8. It can be verified by using the locale -a command.

Installing UTF-8 on AIX

  1. Verify the US English UTF-8 locale is not installed by typing locale -a in a command prompt. Verify that the command output does not contain the entry EN_US.UTF-8.

  2. Access the AIX SMIT utility (in text mode) by typing smitty mle_add_lang at the root in the command prompt.

  3. On the screen that appears, select UTF-8 US English (United States) [EN_US] from both the CULTURAL CONVENTION and LANGUAGE TRANSLATION drop-down lists.
    Note: Keep the INPUT DEVICE/DIRECTORY as the default /dev/cd0 setting.
  4. Press Enter to proceed. A message such as the following will appear:

    installp: Device /dev/cd0 not ready for operation. 
    Please insert media and press Enter to continue.
  5. Insert the appropriate AIX install disk in the disk drive.

  6. When the command is complete, exit the SMIT utility and type locale -a to verify that EN_US.UTF-8 is set as the locale.

Installing UTF-8 on Solaris

  1. Verify the US English UTF-8 locale is not installed by typing locale -a in a command prompt. Verify that the command output does not contain the entry EN_US.UTF-8.

  2. Insert the Solaris install CD #1 in the disk drive and mount it to an appropriate location, for example:

    /cdrom/sol_10_807_sparc/s0
  3. Type the following command as root: localeadm -a nam -d /cdrom/sol_10_807_sparc/s0
    Note: This command installs all locales in the North America (nam) region even if you specify only the en_US.UTF-8 locale.
  4. When the command is complete, type locale -a to verify that EN_US.UTF-8 is set as the locale.
    Note: See this link for FAQs on Solaris Locales.

2.2.3.2 Solaris

Note: Ensure that X Window libraries are installed on your operating system. This is required for Adobe® LiveCycle® PDF Generator 10 and Adobe® LiveCycle® Forms 10. See the documentation for your operating system for more information.
Important: Do not use the Solaris tar command to extract files or errors (such as missing files) will occur. Download the GNU tar tool and use it to extract all files on a Solaris environment.

2.2.3.3 Linux

On Linux operating systems, ensure the following:

  • All Linux distributions: Ensure that X Window libraries are installed on your operating system. This is required for PDF Generator and Forms. See documentation for your operating system for more information.

  • SUSE Linux: You must install the glibc-locale-32bit library that ships with SUSE Linux Enterprise Server; otherwise, LiveCycle will not generate PDF files. This library file is not installed by default, you must use YaST to install it. (See the SUSE Linux Enterprise Server documentation for details.)

    If you plan to install LiveCycle on SUSE Linux 11, you must also install the libstdc++- libc6.2-2.so.3 libraries. SUSE Linux 11 does not include these libraries by default. For more information, see this Novell Web page. These libraries are required for running Adobe Central Pro Output Server

2.2.3.4 Configuring the file limit values on Solaris and Linux

To avoid StuckThread issues on a Solaris or Linux environment, add or increase the rlim values in the /etc/system file.

  1. (Linux) Locate and open the /etc/security/limits.conf file.

    (Solaris) Locate and open the /etc/system file.

  2. (Linux) Add the following lines to the /etc/security/limits.conf file:

    <app_group> soft nofile 8192 
    <app_group> hard nofile 8192

    Replace <app_group> with the user group who will run the application server. You may also replace <app_group> with an asterisk (*) to match all users and user groups.

    (Solaris) Locate and modify the rlim values in the /etc/system file as follows:

    set rlim_fd_cur: The initial (soft) maximum number of file descriptors per process. Set this value to 8192 or more.

    set rlim_fd_max: The hard maximum number of file descriptors per process. Set this value to 8192 or more. (This modification is required only if the default value is lower than 8192). You must have super user privileges to change this value.

    Note: The rlim_fd_max value must be equal to or greater than the rlim_fd_cur value.
  3. Save and close the file.

  4. Restart your computer.

Verify the updated settings

  1. Launch a new shell.

  2. Type ulimit -n and press Enter.

  3. Verify the value returned matches the rlim values you have set.

2.2.4 Privileges required to install on Windows

When installing on Windows, you must use an account that has administrator privileges. If you run the installer using a non-administrator account, enter the credentials of an account that has administrator privileges.

2.2.5 Configuring Windows installation

On 64-bit Windows Server 2008 R1, Windows Server 2008 R2 or Vista operating systems, modify the Admin Approval Mode security option as follows:

  1. (On Windows 2008 R1 and Vista) Go to Start > Control Panel > Administrative Tools > Local Security Policy > Local Policies > Security Options.

    (On Windows 2008 R2 and Windows 7) Go to Start > Administrative Tools > Local Security Policy > Local Policies > Security Options.

  2. Locate User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode and set it to Elevate without prompting.

  3. Restart your computer.

2.2.5.1 Disable the Windows UAC on Vista and Windows Server 2008 R1

  1. To access the System Configuration Utility, go to Start > Run and then enter MSCONFIG.

  2. Click the Tools tab and scroll down and select Disable UAC.

  3. Click Launch to run the command in a new window.

  4. When finished, close the command window and close the System Configuration window.

  5. Restart your computer.

To enable the UAC again, repeat the steps above and select Enable UAC before clicking Launch.

2.2.5.2 Disable the Windows UAC on Windows Server 2008 R2 and Windows 7

  1. To access the System Configuration Utility, go to Start > Run and then enter MSCONFIG.

  2. Click the Tools tab and scroll down and select Change UAC Settings.

  3. Click Launch to run the command in a new window.

  4. Adjust the slider to the Never notify level.

  5. When finished, close the command window and close the System Configuration window.

  6. Restart your computer.

To enable the UAC again, repeat the steps above and adjust the slider to a desired level before restarting your computer.

Important: The Windows User Account Control (UAC) must remain disabled for PDF Generator to work properly. You can run the installation and configuration process by turning on the UAC with the Elevate without prompting option enabled. However, disable UAC to run PDF Generator.

2.2.6 Additional requirements for PDF Generator

Note: You cannot use the Shared Printer Protocol for the SendToPrinter API on Windows 2008 machines that have PDF Generator deployed on them. Use alternate protocols like CIFS or Direct IP.

2.2.6.1 User account for Windows

You must use a user account with administrator privileges for the following tasks:

  • Installing Microsoft Office

  • Installing PDF Generator

  • Installing Acrobat for PDF Generator

  • Running the application server process

2.2.6.2 Using 64-bit application servers with PDF Generator

If you are using a 64-bit application server on a system with PDF Generator, ensure that a 32-bit Java 6 JDK is installed in addition to the 64-bit one the application server uses. Set the environment variable JAVA_HOME_32. This variable is required to point to a 32-bit JDK on systems where a 64-bit application server is in use. The specific path varies based on the installation directory you specified and the operating system you are installing on.

Note: You need to install the 32-bit Sun JDK and configure JAVA_HOME_32 to point to the directory where it resides. Review Sun Java 6 Release Notes > Supported System Configurations and download the 32-bit version for your operating system. However, if you are using AIX, do not set JAVA_HOME_32.
Important: Ensure that JAVA_HOME_32 is set only as an environment variable and is not included in the PATH. If JAVA_HOME_32 is included in the PATH, Java core dumps may appear during EAR deployment or when you restart the server.

2.2.6.2.1 Set the Windows JAVA_HOME_32 variable

  1. Select Start > Control Panel > System.

  2. Click the Advanced tab.

  3. Click Environment Variables and, under System Variables, click New.

  4. Enter the environment variable JAVA_HOME_32. This value is the directory that contains the JDK. For example, type the following:
    D:\Program Files (x86)\Java\jdk1.6.0_26

2.2.6.2.2 Set the JAVA_HOME_32 variable on Linux or Solaris

Set the JAVA_HOME_32 variable for the supported JDK for Bourne and Bash shells as shown in this example:

JAVA_HOME_32=/opt/jdk1.6.0_26 
export JAVA_HOME_32

2.2.6.3 Native file conversion software installation

Before you install PDF Generator, install the software that supports the file formats for which PDF conversion support is required and manually activate the licenses for the software using the user account that is used for running the application server process.

Refer to the individual licensing agreement for each native application that your LiveCycle deployment will support, and ensure that your LiveCycle deployment meets the licensing requirements specified. Typically, each LiveCycle user who will use native application support must also have an activated license on their own computer for the native application.

PDF Generator can be extended to convert these additional file types to PDF files by using the following applications:

Note: PDF Generator supports only English, French, German, and Japanese versions of the supported applications.
  • Microsoft Office 2007, 2010 (DOC,DOCX XLS,XLSX PPT,PPTX, RTF, TXT, Microsoft Office open XML Formats)

  • Microsoft Office Visio 2007, 2010 (VSD)

  • Microsoft Publisher 2007, 2010 (PUB)

  • Microsoft Project 2007, 2010 (MPP)

  • AutoCAD 2008 and 2009 (DWG, DWF)

Note: LiveCycle supports only 32-bit editions of all the above mentioned software.
Note: Native file conversions using AutoCAD for DWG, DXF, and DWF files are supported only on 32-bit environments. Conversions for these file types using Acrobat are supported on both 32-bit and 64-bit platforms.
Note: LiveCycle PDF Generator does not support DWF and DWG files created with AutoCAD 2013.
  • Corel WordPerfect 12, X4 (WPD)

  • Adobe Photoshop® CS3

  • Adobe FrameMaker® 7.2, 8.0 (FM)

  • Adobe PageMaker® 7.0 (PMD, PM6, P65, PM)

  • OpenOffice 3.3 (ODT, ODP, ODS, ODG, ODF, SXW, SXI, SXC, SXD, SXM)

Note: OpenOffice 3.3 or later must be installed on the server to convert the documents created in version 3.3.
Note: On Linux platform, OpenOffice must be installed under /root user. If OpenOffice is installed for specific users, PDFG might not be able to convert OpenOffice documents.

You do not need to install a native software application to convert the following native file formats:

  • Print files (PS, PRN, EPS)

  • Web files (HTML)

  • Image files (JPEG, GIF, BMP, TIFF, PNG)

2.2.6.4 Installing Acrobat for PDF Generator

Install Acrobat X before running the LiveCycle installer. Ensure that you launch Acrobat at least once after installing it to avoid PDF Generator configuration issues. Dismiss all modal dialog boxes that appear on launching Acrobat.
Note: Ensure that Acrobat is installed using the same user account that you will use to install LiveCycle.

However, if LiveCycle is installed and Acrobat X is not installed, install Acrobat X and then run the Acrobat_for_PDFG_Configuration.bat script, located in the folder [LiveCycle root]\pdfg_config. Otherwise, PDF conversions may fail.

The Configuration Manager sets the Acrobat_PATH (case-sensitive) environment variable automatically. You can also choose to set it manually, see 2.2.6.7 Setting environment variables. Restart your application server after setting the environment variable.

Note: Depending on the JDK that you use, download the required JAR files from either Sun or IBM website.

2.2.6.5 Configure Acrobat to use SHX fonts (Windows only)

Note: Perform these steps to configure Acrobat if you want PDF Generator to use SHX fonts to convert AutoCAD DWG files without installing AutoCAD. Also, these steps need to be performed for all user accounts configured in Administration Console.
  1. Open Acrobat.

  2. Select Edit > Configurations.

  3. Select Convert to PDF > Autodesk AutoCAD.

  4. Click Edit Settings.

  5. Click Configuration Preferences.

  6. Click Browse next to the SHX Font File Search Path and specify the path to the SHX font file.

  7. Click OK on each opened dialog.

2.2.6.6 QuickTime 7

PDF Generator requires that QuickTime 7 (Player or Pro) be installed if you want to convert video embedded in files, such as PowerPoint presentations to PDF multimedia files. This application is available from the Apple Downloads site.

2.2.6.7 Setting environment variables

You must set the environment variables in Windows if you plan to create PDF documents from applications such as FrameMaker, Photoshop, PageMaker, and WordPerfect.

The names of these environment variables are listed here:

  • FrameMaker_PATH

  • Notepad_PATH (This should be left blank)

  • OpenOffice_PATH

  • PageMaker_PATH

  • Photoshop_PATH

  • WordPerfect_PATH

  • Acrobat_PATH

These environment variables are optional and need to be set only if you plan to use the corresponding application to convert PDF files through PDF Generator. The value of the environment variable should contain the absolute path of the executable that is used to start the corresponding application.

For example, the variable FrameMaker_PATH may contain the value C:\Program Files\Adobe\ FrameMaker7.2\FrameMaker.exe. However, OpenOffice_PATH is different from others. This variable must be set to the OpenOffice installation folder (instead of the path to the executable). A typical value of OpenOffice_PATH on Windows would be C:\Program Files (x86)\OpenOffice.org 3\.

Paths for Microsoft Office applications such as Word, PowerPoint, Excel, Visio, and Project or for AutoCAD are not required. The Generate PDF service starts these applications automatically if they are installed on the server.

To set the Windows environment variables

  1. Select Start > Control Panel > System.

  2. Click the Advanced tab.

  3. Click Environment Variables and, under System Variables, click New.

  4. Enter the environment variable name you need to set (for example, FrameMaker_PATH). This value is the directory that contains the executable file. For example, type the following:
    C:\Program Files\Adobe\FrameMaker7.2\FrameMaker.exe

2.2.6.8 Service Control Manager command line tool

Before you complete an automatic installation of PDF Generator on Windows, ensure that the Service Control Manager command line tool, sc.exe, is installed in the Windows environment. Some Windows servers do not have this software preinstalled. By default, the sc.exe file is installed in the C:\Windows\system32 directory. Most OS installations have this tool installed. If you do not have the tool installed, it is available in the Windows Resource Kit for your specific version of Windows. To confirm that the tool is installed on your server, type sc.exe from a command prompt. The tools usage is returned.

2.2.6.9 Headless mode configuration

If you are running PDF Generator in a headless mode environment (that is, on a server without a monitor, keyboard, or mouse), the x11 libraries must be installed. Some flavors of Linux do not install these libraries by default; therefore, you must obtain the libraries and install them manually.
Note: Activating x11 forwarding on a shell session causes the SOAP UI to create UI elements during SOAP requests, leading to request failures. To avoid request failures, you must add the -Djava.awt.headless=true JVM argument.

2.2.6.10 Enabling multi-threaded file conversions and multi-user support for PDF Generator

By default, PDF Generator can convert only one OpenOffice, Microsoft Word, or PowerPoint document at a time. If you enable multi-threaded conversions, PDF Generator can convert more than one of the documents concurrently by launching multiple instances of OpenOffice or PDFMaker (which is used to perform the Word and PowerPoint conversions).

Note: Multi-threaded file conversions are not supported with Microsoft Word 2003 and PowerPoint 2003. In addition, Microsoft Excel (2003, 2007 and 2010 versions) is not supported. To enable multi-threaded file conversions, upgrade to Microsoft Word 2007 or 2010 and PowerPoint 2007 or 2010.
Note: Microsoft Excel and Microsoft Visio files are not converted simultaneously. During conversion, EXCEL.exe and VISIO.exe are watched in the task manager. The Visio file is processed only after processing on the Excel file is complete.

Each instance of OpenOffice or PDFMaker is launched using a separate user account. Each user account that you add must be a valid user with administrative privileges on the LiveCycle Server computer. On 64-bit Windows, disable Windows UAC. For more information, see 2.2.5 Configuring Windows installation

After your LiveCycle Server is configured, add LiveCycle user accounts in Administration Console. See the User accounts for multi-threaded file conversions section in the LiveCycle installation guide for your application server. To enable multiuser support for native files and OpenOffice files on a Windows environment, add a minimum of three users with the following permissions.

When you add users for PDF Generator native conversions, grant the user running the application server with the Replace a process level token privilege.For more information, see 2.2.6.12 Granting the Replace a process level token privilege (Windows only)

Dismiss initial dialogs and automatic updates for native applications

Converting native files from PDF Generator requires dismissing any initial registration, activation, and Improvement program dialogs with the option to not show them again. Automatic updates for these applications also needs to be disabled as these update dialogs can cause failures on a running server.

The dialogs and automatic update need to be disabled for the user running the server and all user accounts configured under PDFG Accounts for multi-user support. The dialogs need to be dismissed for the following applications if installed on the server:

  • Microsoft Word (Windows)

  • Microsoft Excel (Windows)

  • Microsoft PowerPoint (Windows)

  • Microsoft Project (Windows)

  • Microsoft Publisher (Windows)

  • Microsoft Visio (Windows)

  • OpenOffice (Windows/ Solaris / Linux)

  • Adobe Acrobat (Windows)

  • Adobe Photoshop (Windows)

  • Adobe FrameMaker (Windows)

  • Adobe PageMaker (Windows)

  • Autodesk AutoCAD (Windows)

  • Corel WordPerfect (Windows)

Disable error reporting on Windows Server 2003 or 2008 (Optional but recommended)

While converting a document to PDF using PDF Generator on Windows Server 2003 or 2008, Windows may report that the executable has encoutered a problem and needs to close. However, it does not impact the PDF conversion as it continues in the background.

To avoid receiving the error, you can disable the Windows error reporting. For more information on disabling error reporting, see the following articles:

Additional configuration required for OpenOffice on Linux or Solaris

  1. Add entries for additional users (other than the administrator who runs the LiveCycle Server) in the /etc/sudoers file. For example, if you are running LiveCycle as a user named lcadm and a server named myhost, and you want to impersonate user1 and user2, add the following entries to /etc/sudoers:

    lcadm myhost=(user1) NOPASSWD: ALL

    lcadm myhost=(user2) NOPASSWD: ALL

    This configuration enables lcadm to run any command on host ‘myhost’ as ‘user1’ or ‘user2’ without prompting for password.

  2. Allow all the LiveCycle users to make connections to the LiveCycle Server. For example, to allow a local user named user1 the permission of making the connection to the LiveCycle Server, use the following command:

    xhost +local:user1@

    For more details, refer to xhost command documentation.

  3. Restart the server.

2.2.6.11 Multi-user support for PDF Generator

To enable multi-user support for native files and OpenOffice files on a Windows environment, a minimum of three users with the following permissions must be added. On a AIX, Linux, or Solaris platform, create at least one user.

Platform

User permissions

Windows 2008 Server

Users with administrative privileges, UAC disabled and with replace a process level token privilege

Windows 2003 Server

Users with administrative privileges

AIX, Linux, and Solaris

Users with sudo privileges

When you add users for PDF Generator native conversions, you must grant the user running the application server with the Replace a process level token privilege. See 2.2.6.12 Granting the Replace a process level token privilege (Windows only).

2.2.6.12 Granting the Replace a process level token privilege (Windows only)

User accounts that are used to start the application server from a command prompt and not as a Windows service requires the Replace a process level token privilege. This setting is required for PDF Generator.

  1. Click Start > Run, and then type gpedit.msc.

  2. On the Group Policy dialog box, select Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignment, and double click Replace a process level token.

  3. Click Add User or Group, add the Windows user account that is used to open the command prompt from which the application server is started.

  4. Restart Windows, and then start the application server.

2.2.7 Additional requirements for Connector for Documentum

If LiveCycle is connecting to Documentum, you must install Document Foundation Classes on machine hosting LiveCycle.

2.2.8 Additional requirements for Connector for IBM Content Manager

Adobe® LiveCycle®10 Connector for IBM® Content Manager requires the following software installed (both available from the IBM website):

  • DB2 Universal Database Client

  • IBM Information Integrator for Content (II4C)

See “Post-Deployment Activities” chapter in the Installing and Deploying LiveCycle document for your application server.

2.2.8.1 Configure the connection for a single IBM Content Manager datastore

  1. Start the DB2 Configuration Assistant.

  2. Click Selected > Add Database Using Wizard.

  3. Select Manually Configure a Connection to a Database and click Next.

  4. Select TCP/IP and click Next.

  5. Specify the following TCP/IP communication options and then click Next:

    • In the Host Name box, type the host name of the server hosting DB2 Content Manager.

    • Leave the Service Name box empty.

    • In the Port Number box, type the port number. The default DB2 Content Manager port number is 50000.

  6. In the Database Name box, type the IBM Content Manager datastore name and, in the Database Alias box, type the alias name for the datastore and then click Next.

  7. Click Next to accept the default data source settings.

  8. In the Operating System list, select the operating system you are using and then click Next.

  9. Specify the following system options and then click Next:

    • In the System Name box, type the server name hosting DB2. If you click Discover, DB2 Content Manager searches for the system name you specified and, if the system is not found, all of the DB2 instances are listed.

    • In the Host Name box, type the name of the host, or click View Details to show the domain and IP address of the system you named in the previous step.

    • In the Operating System list, select the operating system (Windows, Linux, or AIX) on which you deployed DB2 Content Manager.

  10. (Optional) To specify Security options, select Use Authentication Value in Server’s DBM Configuration and click Finish.

  11. In the Test Connection dialog box, test the connection as required.

2.2.8.2 Configure connections for multiple IBM Content Manager datastores

  1. Configure the initial connection by following the steps in 2.2.8.1 Configure the connection for a single IBM Content Manager datastore.

  2. Add additional database connections by modifying the cmbicmsrvs.ini file (the file that stores the datastore information) as follows:

    • From a command prompt window, change the directory to [II4C home]/bin (for example, C:\Program Files\db2cmv8\ on Windows or /opt/IBM/db2cmv8 on AIX, Linux, or Solaris).

    • Run the cmbenv81.bat (Windows) or cmbenv81.sh (AIX, Linux, or Solaris) file to set the environment and the classpath for the Java Utilities of II4C.

    • Change the directory to [II4C working directory]/cmgmt/connectors where [II4C working directory] is one of the following paths:

      (Windows) C:/Program Files/db2cmv8

      (Linux, AIX) /home/ibmcmadm

      (Solaris) /export/home/ibmcmadm

    • Run the command

      java com.ibm.mm.sdk.util.cmbsrvsicm -a add -s <library server database name> -sm <database schema name>

      where <library server database name> is the same as Database Alias configured in step 6 above.

    Note: The following procedure allows users without DB2 rights to share the connection credentials through the cmbicmenv.ini file.

2.2.8.3 Configure a multiuser connection to the IBM Content Manager datastore

  1. From a command prompt window, change the directory to [II4C home]/bin (for example, C:\Program Files\db2cmv8\ on Windows or /opt/IBM/db2cmv8 on AIX, Linux, or Solaris).

  2. Run the cmbenv81.bat (Windows) or cmbenv81.sh (AIX, Linux, or Solaris) file to set the environment and the classpath for the Java Utilities of II4C.

  3. Change the directory to [II4C working directory]/cmgmt/connectors, where [II4C working directory] is one of the following paths:

    (Windows) C:/Program Files/db2cmv8

    (Linux, AIX) /home/ibmcmadm

    (Solaris) /export/home/ibmcmadm

  4. Run the command

    java com.ibm.mm.sdk.util.cmbenvicm -a add -s <library server database name> -u <database user ID> -p <database password>

    where <library server database name> is the same as Database alias configured in step 6 above.

2.2.9 Additional requirements for Connector for IBM FileNet

These requirements are optional and required only if you are installing Adobe® LiveCycle® 10 Connector for IBM® FileNet.

IBM FileNet 4.0

If LiveCycle is connecting to IBM FileNet 4.0 Content Engine, you must install the Content Engine Java Client. Use the IBM FileNet 4.0 content engine client installer located by default in C:\Program Files\FileNet\CEClient. During installation, select only the Java client component on the component selection screen.

For IBM FileNet 4.0 Process Engine settings, copy the pe.jar file from the Process Engine directory to the computer that will host LiveCycle. Create the directory C:\FileNetPE\files and copy the pe.jar file there. The Process Engine client install directory is now C:\FileNetPE.

IBM FileNet 4.5

If LiveCycle is connecting to IBM FileNet 4.5 Content Engine, you must install the Content Engine Java Client. Use the IBM FileNet 4.5 content engine client installer located by default in C:\Program Files\FileNet\CEClient. During installation, select at least one of the components from Application Engine or Process Engine on the component selection screen.

For IBM FileNet 4.5 Process Engine, you must install the IBM FileNet 4.5 Process Engine Client located by default in C:\Program Files\FileNet\BPMClient. During installation, select the Other option on the component selection screen.

IBM FileNet 5.0

If LiveCycle is connecting to IBM FileNet 5.0 Content Engine, you must install the Content Engine Java Client. Use the IBM FileNet 5.0 content engine client installer located by default in C:\Program Files\FileNet\CEClient. During installation, select at least one of the components from Application Engine or Process Engine on the component selection screen.

For IBM FileNet 5.0 Process Engine, you must install the IBM FileNet 5.0 Process Engine Client located by default in C:\Program Files\FileNet\BPMClient. During installation, select the Other option on the component selection screen.