Creating and managing templates

A template provides the basic structure for the form design and contains predefined file-creation information that Designer applies to the form design. Templates contain definitions of objects used in a form design as well as the form design’s page layout. A template can store any properties that you would use in more than one form design, including these:

  • Master page layouts, which influence the format of pages

  • Boilerplate objects, including formatted headers and footers

  • Embedded images or objects that link to frequently used graphics, such as logos or watermarks

  • Any text variables or floating fields that you use as placeholders for data

  • Predefined formula equations and script fragments

  • File properties and file creation information

  • Other properties that facilitate or automate your work

Creating a template

Creating a template is very much like creating a form design. However, in a template, you design the layout and select the file settings and preferences that you would typically need in more than one form design. You can optionally include and define any objects that could be applied to more than one form design. Including layouts and properties that are common to many form designs saves you time because less work is needed to prepare form designs that are based on the template.

One of the easiest way to create a template (TDS) file is by using the New Form Assistant. The New Form Assistant guides you through the steps involved in creating a template, such as previewing and selecting the template you want to use, entering business contact information, and adding email submit and print buttons. However, if you prefer not to use the New Form Assistant, you can select Tools > Template Manager to open the Template Manager dialog box where you can directly select the template you want.

To create a template in the stand-alone version of Designer

  1. Open the New Form Assistant by using one of these methods:

    • Select File > New.

    • In the toolbar, click the Down Arrow next to the New button and select New.

  2. In the New Form Assistant, select Based on a Template and click Next.

  3. Follow the onscreen instructions to customize the template to suit your needs.

  4. Select File > Save As.

  5. In the Save As Type list, select Adobe Designer Template (*.tds).

  6. Click Save.

To create a template with Designer and Workbench

  1. In Designer, select File > New.

  2. Follow the onscreen instructions until the New Form Assistant opens in Designer, and then select Based on a Template.

  3. Follow the onscreen instructions to customize the template to suit your needs.

  4. Select File > Save As.

  5. In the Save As Type list, select Adobe Designer Template (*.tds).

  6. Click Save.

Managing templates

The Template Manager contains a variety of sample templates that are provided with Designer. It can also contain any templates you create and use with Designer.

Use the Template Manager to do these tasks:

  • Preview templates

  • Select a default template for creating form designs

  • Add, delete, and rename templates, as well as add and remove groups

In the Template Manager, you can also add or delete tabs, move templates between tabs, and determine where in the file system Designer stores templates. Each tab corresponds to a folder in the file system. By default, template files are stored in the Designer Templates folder.

By default, templates are stored in the Designer Templates folder (\EN\Templates).

Each time you open Designer, the application copies the template files in the Templates folder to the user profile for each language. This could be an issue in certain multiuser environments where disk quotas are restricted. To save disk space, set up a common directory for templates. For further information about setting up a common directory for templates, see the technical note at http://kb2.adobe.com/cps/524/cpsid_52464.html.

To add a template to the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab in which to add the template.

  3. In the palette menu, select Add Template.

  4. Browse to the appropriate folder, select the template file (TDS) you want to add, and click Open. A copy of the template file is added to the Template Manager.

To delete a template from the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab where the template is stored.

  3. Right-click the template and select Delete Template.

  4. When you are prompted to delete the template, click Yes. The file is removed from your computer’s file system.

To rename a template in the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab where the template is stored.

  3. Right-click the template and select Rename Template.

  4. Type a different name for the template, and press Enter.

To specify a default template in the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab where the template is stored.

  3. Select the template.

  4. Click Set Selected as Default.

To restore the default templates in the Template Manager

You can restore the default templates that are available in the Blank tab and the Common Forms tab in the Template Manager dialog box.

Important: When you restore templates, all of the templates that were provided with Designer in the Blank tab and the Forms tab are restored. Designer replaces any missing templates and overwrites all templates with the same names as the originals.
  1. Select Tools > Template Manager.

  2. Click either the Blank tab or the Forms tab.

  3. In the palette menu, select Restore Default Templates.

To add a tab to the Template Manager

When you add a tab to the Template Manager, a subfolder with the same name is created in the Designer Templates folder.

  1. Select Tools > Template Manager.

  2. In the palette menu, select Add Category.

  3. Type a name for the tab and click OK.

To delete a tab from the Template Manager

When you delete a tab from the Template Manager the corresponding folder is removed from the Designer Templates folder.

  1. Select Tools > Template Manager.

  2. Click the tab you want to delete.

  3. In the palette menu, select Remove Category.

  4. When you are prompted to remove the tab, do one of these actions:

    • To delete the selected tab and its associated category folder and templates, select Remove The Category And Delete All Contained Templates.

    • To move the templates to a different tab before deleting the selected tab and its associated category folder, select Remove The Category And Move The Contained Templates To The Following Category: [tab name], and then click the tab where you want to move the templates.

  5. Click OK.

To move a template to a different tab in the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab you want, right-click the template that you want to move, and select Move Template To > [tab name].

To determine where the template files are stored

  1. Select Tools > Template Manager.

  2. Click the tab you want.

  3. In the palette menu, select Category Properties. The Template Category Properties box displays the location of the templates that are currently listed in the selected tab.

To customize the view in the Template Manager

  1. Select Tools > Template Manager.

  2. Click the tab you want.

  3. In the palette menu, select View and perform one of these actions:

    • To display the template names as icons, select Large Icons.

    • To display the template names in a list, select List.

Importing a template

You can import any template file (TDS) into Designer and copy the template into the Template Manager, create a new form based on the template, or edit the template.

When you import a template, a copy is automatically added either to the templates folder that is indicated in the form’s XML source code or to the folder named Other, if no location is specified. The imported template appears in the Template Manager, listed in the corresponding tab. If a template with the same name already exists in the tab, Designer displays a message prompting you to replace the existing file.

  1. Open the template file you want to import by using one of these methods:

    • Select File > Open, browse to the folder you want, select the template file (TDS), and click Open.

    • In Windows Explorer, double-click the template file (TDS).

    • Drag the template file (TDS) from Windows Explorer into the Designer workspace.

  2. In the Template Options dialog box, select one of these options:

    • To add the template to the Template Manager, select Copy This Template Into The Template Manager.

    • To create a PDF form based on the template, select Create A New Form Based On This Template.

    • To open the template in Designer for editing, select Edit This Template.

  3. Click OK.

Creating and customizing a form based on a template

Template files (TDS) sometimes contain customizable text or images within field captions, text objects, and static images. When you create a form based on a template that contains fields with customizable text or images, the New Form Assistant opens enabling you to change the information displayed in each field to suit your own needs. For example, the sample templates available in the Template Manager contain customizable text and images, which you can replace with your company’s name, address, telephone number, and logo.

The information that you enter for each field is saved and reused to repopulate the same fields in the New Form Assistant the next time you open the template.

To create a form based on a template in the stand-alone version of Designer

  1. Open the New Form Assistant by using one of these methods:

    • Select File > New.

    • In the toolbar, click the down arrow next to the New button and select New.

  2. In the New Form Assistant, select Based on a Template and click Next.

  3. Follow the onscreen instructions to customize the new form to suit your needs.

  4. Name and save the file.

To create a form based on a template with Designer and Workbench

  1. In Designer, select File > New.

  2. Follow the onscreen instructions until the New Form Assistant opens in Designer, and then select Based on a Template and click Next.

  3. Follow the onscreen instructions to customize the new form to suit your needs.

  4. Name and save the file.