Import and link methods

You can import other Adobe FrameMaker documents, documents created in other applications, text files, and graphic files. You can also import SWF files and 3D objects into FrameMaker documents. An imported object can simply be copied into the document. It can also be linked—such as when you import by reference—so that it remains tied to its source for easy updating.

Use the clipboard

Perhaps the easiest way to import text and graphics is by copying to and pasting from the clipboard. When using this method, keep in mind the following:

  1. Select the object or text you want to copy and Choose Edit > Copy. The contents is copied to the clipboard.

  2. Place the insertion point in the document where you want to paste the content, and then choose Edit > Paste.

When using this method, keep in mind the following:

  • You can convert tab-delimited text to a table using the Table > Convert To Table command.

  • Text formatting is lost unless you’re pasting into another FrameMaker document.

  • Choosing Edit > Paste Special offers you more options. For example, you can choose to paste text in the RTF format or as an embedded Microsoft Word document. If you want to apply FrameMaker formats, then paste clipboard content as text. For graphics you can paste clipboard content as an embedded bitmap, a device independent bitmap, or a metafile.

Use drag-and-drop

Import and export are greatly simplified when you can drag an object to its new location.

FrameMaker supports the following drag-and-drop operations:

  • Move a graphic from one open FrameMaker document window to another by dragging the graphic. You can also copy it by Control-dragging it or display a context (shortcut) menu when you drop it by right-dragging it.

  • Drag a graphic between a FrameMaker document window and any other application that supports drag-and-drop operations.

  • Drag a graphic file from a folder or the desktop into an open document window.

  • Drag one or more document files into the application window to open the files, or you can drag a single file into a document window to embed that file.

Use the File > Import > File command

Import by copying

Importing by copying makes it easy to transfer the imported material from one location to another, but it increases the document size. In addition, if you change the source material, you need to reimport it to update the document with the latest version.

 Choose File > Import > File, choose the file you want to copy, and then select Copy Into Document.

Import by reference

Importing by reference keeps the imported text or graphics linked to the source file. FrameMaker stores the path to the source file in the document. Each time you open the document, FrameMaker locates the file on the disk and displays it. If the source file was revised, FrameMaker updates the document with the latest version. Importing by reference can reduce total file size because it lets you use the same material in several places without storing the contents of imported images or text in the FrameMaker document. Text imported by reference is called a text inset.

 Choose File > Import > File, choose the file you want to copy, and then select Import By Reference

For information on how the path is stored when importing by reference, see Using paths when importing by reference.

Use the File > Import > Object command

The main benefit of using Object Linking and Embedding (OLE) is to display visualizations of data created in programs other than FrameMaker. The File > Import > Object option associates the imported object with the program used to create it so that you can edit the object in its native software. For example, you can insert a pie-chart created using Microsoft Excel in a FrameMaker document. Each time you double-click the inserted object, FrameMaker opens it in Microsoft Excel for you to edit.

Note: You cannot embed or link an object whose native software is not installed on your computer. For example, if you open a document having a Photoshop image embedded through File > Import > Object, you need to have Photoshop installed on your computer to be able to edit this image.

Consider the following factors when deciding whether to import text and graphics by reference or to use OLE to embed or link them instead:

  • If the material you want to include comes from another FrameMaker document, use import by reference. This provides many more import options.

  • If you want to collapse a linked file to an icon instead of displaying the full contents of the file in your document, use OLE linking.

  • If the material you want to include is in a format that FrameMaker can’t open, use OLE.

  • If you edit or view your document on multiple platforms, use import by reference. OLE works only in Windows.

  • If the text or graphics you want to include comes from an application that doesn’t support OLE, use import by reference.