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Using ICR Task List

Adobe® Creative Suite® Task List Extension for Integrated Content Review (called ICR Task List in this 
document) is an extension for Adobe Photoshop®, Adobe Illustrator®, and Adobe InDesign® that allows the 
creative professional to manage and work with design tasks that are assigned from Integrated Content 
Review (ICR) 10.0, part of the Adobe Customer Experience Solutions. The extension is compatible with CS5 
and CS5.5. 

The ICR Task List extension can be installed and loaded into your Creative Suite applications, and 
configured for your enterprise along with the ICR solution; it is installed separately. After it has been 
installed and configured, ICR Task List connects directly into and interacts with ICR. It receives tasks from 
ICR, displays information about those tasks to the creative professional from a panel within the Creative 
Suite application, and responds back to ICR when tasks are completed. Tasks are associated with specific 
project assets (such as documents and images) to be uploaded into the ICR repository from the desktop. 

ICR Task List is included with the ICR solution, and is available to creative professionals through the 
Creative Suite product they use to design assets. 

This document is addressed to the creative professional, and describes how to use Adobe® Creative 
Suite® Task List Extension for Integrated Content Review. 

For the IT professional, see the ICR Task List Extension Administrator’s Guide for information about 
installing and configuring the ICR Task List extension. 

For information about installing, configuring, and using Integrated Content Review, see the Integrated 
Content Review 10.0 Solution Guide. 

About ICR Task List
A project that is managed through ICR can include assets whose content is designed in one of the Creative 
Suite products. If one of these assets needs modification, the project manager can assign the task of 
modifying that asset to you, the creative professional. 

The ICR Task List panel communicates with ICR to notify you of such tasks, provide information about 
them, and provide access to the related assets in the ICR repository. ICR Task List allows you to manage 
tasks that are assigned to you, and submit new or modified assets back to the ICR repository.

When you open ICR Task List from the Extensions menu, a panel appears in the main window of the 
Creative Suite product that allows you to:

Receive notification of task assignments from ICR, and other status changes that affect you.

Track tasks that are assigned to you within the application you use.

View task requirements and due dates.

Obtain related assets from the ICR repository.

Notify ICR when a task is completed, and upload new or modified assets. An InDesign asset can be 
uploaded as a file or as an InDesign package.

http://www.adobe.com/go/learn_dep_install_icrtasklist_10
http://www.adobe.com/go/learn_dep_integrated_content_review_10
http://www.adobe.com/go/learn_dep_integrated_content_review_10
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As part of submitting a task, ICR Task List automatically generates and uploads a PDF version of the asset 
for review. If the review results in changes that you need to make to your asset, the commented PDF is 
returned to you as part of a new task.

Getting started
To open the ICR Task List panel in Photoshop, Illustrator, or InDesign, choose Window > Extensions > 
Task List. The first time you open it in a session, you must sign in to the Experience server with your ICR 
user name and password. You can choose for the extension to remember your login information for future 
sessions. 

When you have signed in, a set of icons at the top of the panel allows you to switch between three views:

The other icons that remain visible in all views allow you to refresh the current view, and sign out of ICR 
Task List:

The task list refreshes itself periodically by checking with the Experience server, but you can use the 
manual-refresh button to make sure the content is current at any time.

Active Tasks view Recently Completed Tasks view Notifications view
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(In order to refresh the list automatically, ICR Task List has to poll the server, which can affect performance. 
For this reason, your enterprise might have disabled automatic refresh; if so, you must always use the 
button to refresh the list. For more information, see the ICR Task List Extension Administrator’s Guide.) 

Notifications view

The Notifications list view is the default view that appears when you start the extension. This view shows 
you messages from ICR, including new task assignments and notification of changes in task status. These 
notifications are also sent to your e-mail.

When you move the cursor to the right side of a new task assignment notification, buttons allow you 
to accept or decline it.

When you move the cursor to the right side of a status notification, an X button appears that you can 
click to remove it from this list. 

Icons on the left mark particular kinds of notifications:

An asterisk marks a new task that has been assigned to you. 

A checkmark indicates notification of successful completion for a task you submitted. 

An warning icon (an exclamation mark in a triangle) marks a task for which an attempted 
submission was unsuccessful. 

The warning icon also indicates an expired task (that is, one whose due date has passed), and a 
task that has been withdrawn from ICR.

Successfully 
completed 
submission

New task
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Notification details

Status notifications include all of the information available about the status change. New task notifications 
show a brief description, and allow you to view further details of the task.

Click a new task notification in the list to open it in the Notification details view. This view gives you 
another opportunity to accept or decline a task assignment, and also gives you access to any supporting 
documents and web pages; see “Working with tasks” on page 9. 

Once you have accepted or declined a new task notification, or deleted a status notification, that 
notification disappears from the Notifications view. If you are in the Notification details view, you are 
automatically returned to the Notifications list view.

When you decline a task, it disappears entirely from your ICR Task List panel; you do not see it again 
unless it is reassigned to you.

When you accept a task, it becomes an active task, and appears in the Active Tasks view. 

Active Tasks view

When you have accepted a task that is assigned to you, it becomes an active task. The Active Tasks list view 
shows you a list of all active tasks, organized by due date with the nearest dates at the top. 
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Tasks that are past due are listed in a separate Past Due section; you receive a notification when a task 
passes its due date. 

At the top of the list, a drop-down menu allows you to filter the list of tasks by criteria defined by your 
project managers. For example, you can choose to see only those tasks associated with a particular project 
or campaign.

Each task appears in this list as a short description. Click a task in the list to display the details of that task. 

The Active Tasks details view, like the Notification details view, gives you access to supporting 
documents and web pages; see “Working with tasks” on page 9. 

Because you have already accepted the task, the page now gives you the opportunity to submit it 
when it is complete. If you generate a new document in the course of completing a task, you can 
upload it to the ICR repository when you submit the completed task. see “Submitting completed tasks 
for review” on page 9. 
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Recently Completed Tasks view

The Recently Completed Tasks view provides a history of tasks that have been assigned to you, and 
successfully completed and submitted. Completed tasks are organized by completion date, starting with 
the most recently submitted.

Use the Back button to 
return to the Active 
Tasks list view
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Working with tasks
The Task details view allows you to obtain documents and assets that are already associated with the task, 
and submit your work, adding a new document or asset that you have created or modified.

Submitting completed tasks for review

When you have completed work on a task, you submit it for review, along with the document or asset that 
you have generated in connection with that task.

1. Select the finished task in the Active Tasks list and click to display the Task details view.

2. Click Submit. If you are working in InDesign, you can choose to submit either a file or a package.

Link to specific task details in ICR, such as an 
asset that needs modification

Download assets from ICR repository

Use the links to obtain documents that describe 
the task more fully, and any existing assets related 
to the task.
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3. In the platform-specific file browser, select the file to upload to the Experience server as part of the 
task, and click Open. For InDesign, you can select a file or package. 

For a complete list of file types that you can submit, see “Asset file types and metadata” on page 12.

4. If the file or package you select is open in the application and has not been saved, you are prompted 
to save it. 

5. Add submission comments to describe the task status; these comments are associated with the asset 
in ICR. 
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6. Click Upload.

Results of submission

When you submit a task, ICR Task List does the following:

Automatically generates a PDF of your asset for review.

Adds metadata to your asset in the XMP format, if the file format supports XMP. See “Asset file types 
and metadata” on page 12.

Uploads your new or modified asset to the ICR repository, along with the generated PDF.

Changes the task status to completed.

During the upload process, you see a progress bar, and can click Cancel to abort the submission. If you do 
so, the task returns to its previous status and nothing is submitted to the ICR repository. The panel returns 
to the Task details view. 

When the upload is complete, click Done to return to the Active Tasks view. The task you have just 
submitted moves from the Active Tasks to the Completed Tasks list (see “Recently Completed Tasks view” 
on page 8).

You receive a notification confirming the success or failure of the submission. The notification for a task 
that was unsuccessfully submitted is marked with the warning icon.
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Receiving review comments

The PDF of your new or modified asset can become part of review tasks assigned to other members of 
your team. They can submit the commented PDF back to ICR. 

When the rest of your team has finished reviewing material you have submitted, you are assigned a new 
task of incorporating the review. The commented PDF is a document associated with the new task.

Asset file types and metadata

You can submit any file type that can be opened by your host application, with these exceptions:

InDesign Book files (INDB) cannot be submitted as assets.

Illustrator Template files (AIT) cannot be submitted as assets.

For file types that support the XMP metadata standard, ICR Task List automatically adds metadata to 
describe various features of the asset, such as the project and campaign with which it is associated. 

NOTE: A task submission can fail if ICR Task List cannot add metadata. This typically occurs because the 
asset you have added or modified does not have write permission. Make sure your files are writable 
before submitting them.

These are the file types that can be submitted as assets, for which ICR Task List automatically adds 
metadata: 

You cannot configure the ICR Task List metadata, but you can examine it in the application in which the 
extension is loaded. 

1. In Photoshop, Illustrator, or InDesign, choose File->File Info.

2. Select the "Advanced" or "Raw data"  panel.

Host application File types that support XMP

InDesign INDD
INDT

Illustrator AI
PDF
DWG
PS, EPS
JPG, JPEG
JPE, JPF, JPX, JP2, J2K, J2C
PSD
TIF, TIFF

Photoshop PSD
PS, EPS
AI
JPG, JPEG
PE, JPF, JPX, JP2, J2K, J2C
PNG
TIF, TIFF
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3. Look for the namespace http://ns.adobe.com/livecycle/icr/1.0/.

Similarly, you can examine the metadata that is added to the PDF which ICR Task List generates for review:

1. In Acrobat Pro, choose File->Properties.

2. Select the "Description"  panel and click Advanced.

3. Look for the namespace http://ns.adobe.com/livecycle/icr/1.0/.

http://ns.adobe.com/livecycle/icr/1.0/
http://ns.adobe.com/livecycle/icr/1.0/
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