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Chapter 1: About CS Live

Adobe® CS Live is a set of online services that lets you integrate with Adobe Creative Suite® 5 software to simplify the
creative review process, accelerate website compatibility testing, and more.

Adobe® CS Live online services include these five services togther:

Adobe® BrowserLab Preview dynamic web pages and local content with multiple viewing, diagnostic, and comparison
tools. BrowserLab provides an easy solution for cross-browser testing.

Adobe® Story Accelerate media creation by streamlining the flow of script data into your video productions.

Adobe® CS Review Create and share reviews online and get feedback on design projects all from within your Creative
Suite desktop application. For more information, see CS Review Help.

Acrobat.com Streamline your work with extended teams by using online services for web conferencing, file sharing,
and collaborative document authoring.

SiteCatalyst® NetAverages Take advantage of Internet-wide analytics on user systems, browsers, and more to help
optimize design for web and mobile screens.

For information on how to connect to CS Live, see Connect to CS Live.
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Chapter 2: Acrobat.com

Acrobat.com
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Chapter 3: Adobe CS Review

Adobe CS Review
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Chapter 4: SiteCatalyst NetAverages

SiteCatalyst® NetAverages™ is a reporting service that gives you insight into the latest Internet trends to help you
optimize your web and mobile projects. For more information on the service, see the product page and FAQ.

Browse the information

Select Desktop or Mobile from the toolbar. The page displays a number of data sets in concentric rings and a list of top
trends.

Browse data sets

Each ring in the concentric rings represents a different data set. You can do any of the following to browse the various
data sets.

Click a ring or a ring tab associated with a data set to see more information in a pie chart.
Move the mouse over a subset in the pie chart to see the change over the last month and the last year.
+ Click a subset in the pie chart to view the changes over the last 12 months.

« Click the arrow on the left of the screen to go back to the previous screen.

Browse top trends

The Top Trends section provides the following information for each top trend:

+ In the Current column, the most recent share of the specified product or technology in its category. For example, a
specific browser may have a 12% share of the browser version category.

+ In the Change column, how much the share has changed over time.

You can do any of the following to browse the top trends.

« Click the View Monthly button to view the changes over last month. The button acts as a toggle to go back to the
changes over the last year.

+ Click a top trend in the list to see the information in a pie chart, and then click the highlighted product or
technology in the chart to view the changes over the last 12 months.

s Click the arrow on the left of the screen to go back to the previous screen.

Working with e-mail alerts

Set up an alert to be notified by e-mail when a trend reaches a specified threshold. For example, you may want to be
notified when the share of a specific browser reaches 40% of all browsers.

When the threshold is reached, SiteCatalyst NetAverages sends you an e-mail and lets the alert expire. The e-mail is
sent to the address you use to log in to Adobe.com. Click the links in the alert e-mail for more information.
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Set up an alert

1
2
3

Click a ring or a ring tab associated with a data set you want to track.
In the pie chart that appears, click the subset of data that you want to track.

In the monthly trends chart that appears, click Subscribe to Email Alert and then move the percent slider on the
right side of the chart to the desired threshold.

Click Subscribe to set the alert.

Manage your alerts
Manage your alerts by clicking the My Alerts button in the toolbar.

Update an alert by clicking it in the My Alerts list and then clicking Update Alert in the trends chart that appears

on the right.

+ Delete an alert by clicking the trash can icon next to it in the My Alerts list.
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Chapter 5: BrowserLab

Work in BrowserLab

Adobe® BrowserLab is an online hosted service that lets you test the pages of your web site across a variety of web
browsers and operating systems. The service works by taking screen shots of your web pages in different browsers, and
then displaying them in the BrowserLab application window.

You can use BrowserLab as a standalone service, or integrated with Dreamweaver CS5 and later. The standalone
service lets you test pages that you've posted to a server within the context of a web browser. If you use BrowserLab as
an integrated service with Dreamweaver, you can test your pages from within Dreamweaver without publishing your
pages to a server.

Note: Choose Help > About after logging into BrowserLab to see the most up-to-date list of supported browsers.

If you have a question about BrowserLab that's not answered by these Help topics, you can check the troubleshooting
documentation on adobe.com, or post your question to the Adobe BrowserLab Forum.

Log in to BrowserLab

1 Browse to http://browserlab.adobe.com.
2 Enter your Adobe ID and password, and click Sign In.

Note: Your Adobe ID is your e-mail address, and the same ID you use to log into all other Adobe web services, as well
as the Adobe on-line store. If it’s your first time logging into BrowserLab, you’ll need to click the link in the verification
email before you can log in.

3 Ifyou are logging into BrowserLab from Dreamweaver, click CS Live in the Application bar and sign in.

Test a page

Testing a page in BrowserLab is as simple as browsing to the page.
1 Sign in to the BrowserLab service.

2 Click the Test link at the top of the application window.

3 In the URL text box, enter the URL of the page you want to test.

BrowserLab loads the page with a screen shot. To see a screen shot from a different browser in the default Browser
Set, click the Browser pop-up menu at the upper-left hand corner of the application window, and choose the
browser.

Compare pages
BrowserLab lets you compare side-by-side screen shots of your page as it appears in different browsers. By default,

BrowserLab loads comparison screen shots from the top two browsers in the default Browser Set, but you can compare
versions of pages in any of the available browsers.

BrowserLab also gives you the ability to compare screen shots one on top of another.

1 Sign in to the BrowserLab service.

2 Click the Test link at the top of the application window.

Last updated 5/2/2011


http://kb2.adobe.com/cps/830/cpsid_83015.html
http://kb2.adobe.com/cps/830/cpsid_83015.html
http://forums.adobe.com/community/cslive/browserlab
http://browserlab.adobe.com

CS LIVE
BrowserLab

In the URL text box, enter the URL of the page you want to test.
Choose one of the following options from the View menu (to the right of the URL text box):

2-up View places two screen shots side-by-side. To change the browser for a given screen shot, click the Browser
pop-up menu at the upper-left corner of the application window, and choose the browser you want.

Onion Skin View superimposes one screen shot over another. To change the browser for a given screen shot, click
the Browser pop-up menu at the upper-left or upper-right corner of the application window, and choose the
browser you want. The slider at the top middle of the page controls the transparency of the two screen shots.
Moving the slider to the left will make the left-selection browser's screen shot more visible. Moving the slider to the
right will make the right-selection browser's screen shot more visible.

Navigate pages

1

To navigate back and forth between pages, use the Back and Forward buttons next to the URL text box, just as you
would in a browser. You can also select pages from the history pop-up menu by clicking the arrow on the right side
of the URL text box, and selecting a page from the history.

Note: The history maintains the history of distinct pages; it does not maintain the history of different versions of the
same page.

To follow active links on a page, Control-click (Windows) or Command-click (Mac OS) the link.

Note: Only links to other web pages are clickable. Links such as email links, links to executable files, and so forth, are
not clickable.

Edit Browser Sets

BrowserLab tests the appearance of your page in a default Browser Set. You can change the default Browser Set, as well

as create custom Browser Sets of your own.

Change the default Browser Set

1
2
3
4

In BrowserLab, click the Browser Sets link at the top of the application window.
Select the Default Browser Set if it isn't already selected.
Add or delete browsers from the Browser Set by making selections in the Available Browsers column.

(Optional) Change the browser order (i.e. the order in which BrowserLab displays screen shots of your tested pages)
by dragging the browsers in the Browser Order column up or down.

Create a custom Browser Set

1

2
3
4
5

In BrowserLab, click the Browser Sets link at the top of the application window.

Click Add New Browser Set.

Type a name for your custom Browser Set and press Enter/Return.

Add or delete browsers from the Browser Set by making selections in the Available Browsers column.

(Optional) Change the browser order (i.e. the order in which BrowserLab displays screen shots of your tested pages)
by dragging the browsers in the Browser Order column up or down.

Edit an existing Browser Set

1
2

In BrowserLab, click the Browser Sets link at the top of the application window.

Select the Browser Set you want to edit.
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3 Add or delete browsers from the Browser Set by making selections in the Available Browsers column.

4 (Optional) Change the browser order (i.e. the order in which BrowserLab displays screen shots of your tested pages)
by dragging the browsers in the Browser Order column up or down.

Delete an existing Browser Set

1 In BrowserLab, click the Browser Sets link at the top of the application window.
2 Select the Browser Set you want to delete.

3 Click the delete button (red X) and confirm that you want to delete the Browser Set.

Rename an existing Browser Set
1 In BrowserLab, click the Browser Sets link at the top of the application window.

2 Select the Browser Set you want to rename.

3 Click the Rename This Set button (pencil), type the new name, and press Enter/Return.

Test a page in a particular browser

You can test a page in an available browser at any time. That is, the browser that you test in does not need to be part
of a Browser Set.

1 Sign in to the BrowserLab service.

2 Click the Test link at the top of the application window.

3 Inthe URL text box, enter the URL of the page you want to test.
4

Click the Browser pop-up menu at the upper-left hand corner of the application window, and choose a browser.
The browser can be from the default Browser Set, from your list of custom Browser Sets, or from the list of all
available browsers.

Refresh screen shots
< To refresh a screen shot, click the Refresh the Screenshots button next to the URL text box.

Note: You can also use the Refresh button to refresh cached screenshots that the URL history might be maintaining.

Change magnification

% To change the magnification of a page, click the Magnification pop-up menu in the upper-right corner of the
application window and use the slider to select a magnification.

Set screen shot delay time

By default, BrowserLab loads the web page you're interested in and takes screen shots immediately after the page is
loaded. You can, however, set a delay time so that BrowserLab loads the page, but does not take the screen shot until
after a specified time. This is particularly useful if you have moving or animated elements on the page (such as Flash
files or AJAX elements) that might take a few extra seconds to load completely.

% To setascreen shot delay time, type or use the arrow controls to specify a number in the Delay box. (It's to the right
of the URL text box.) The minimum delay you can set is 0 seconds, and the maximum delay is 10 seconds.
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Work with rulers and guides

Rulers and guides can help you make pixel-perfect comparisons between images.

Display rulers
% To toggle rulers on or off, press the R key on your computer keyboard. The ruler displays pixel units.

Create a horizontal or vertical guide
« To create a horizontal or vertical guide, drag from the corresponding ruler, and release the mouse button when
you've reached the desired position. You can always readjust the guide by dragging it again.

« To remove a guide, drag the guide back to its corresponding ruler until it disappears.
+ To remove all guides, double-click the box at the upper-left corner of the ruler.

Note: Guides are retained when you refresh screen shots.

Adjust screen shot alignment

Because different browsers align page content differently, even when the content is “the same,” it can sometimes be
difficult to get an idea of how page elements relate to one another, particularly when using Onion Skin view. For
example, the below screen shot shows you the same area on a page in Firefox - Windows and Safari - OSX, as displayed
in Onion Skin view.
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Firefox Windows and Safari OSX screen shots as displayed in Onion Skin view.

In the above example, it’s almost impossible to compare the text areas in Onion Skin view because the default
alignments of each browser are slightly different. BrowserLab, however, gives you the ability to adjust the default
alignment of your screen shots, allowing you to do focused testing on specific areas within a web page, even when the
alignments are “oft.”
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The two screen shots in Onion Skin view after alignment adjustment.

BrowserLab gives you the option of aligning screen shots individually, or aligning all of your screen shots (“smart
aligning”) to adjust to a particular point that you specify.

Align screen shots individually
1 Display a screen shot or screen shots in 1-up view or 2-up view. (The alignment feature is deactivated in Onion Skin
view.)

2 Click the Align On/Off button. (It’s next to the View menu, to the right of the URL text box.)
Note: You can also turn Align on and off by pressing A on your computer keyboard.
The Align square appears at the upper-left corner of your screen shot.

3 Drag the Align square to an area on the page where you want to set the new alignment point. You can use the large
square at the center of the Align square to focus in on the general area.

Once you release the mouse the viewing area of the Align square magnifies the area of the screen shot underneath.
The magnification allows you to select a new alignment point with pixel-perfect precision.

Note: If you drag the Align square from the space within the square rather than from its border, the area underneath
is magnified as you drag.

4 Select a new alignment point by choosing a pixel and clicking it. You’ll see that as you drag your cursor over the
magnified area, a second pair of cross hairs and a selection point appear.

5 Click Align Current Screen Shot Here.

When you align a screen shot individually, the new alignment point you've specified moves to the upper-left corner
of the screen shot interface.

6 (Optional) If you're in 2-up view, align the second screen shot as necessary.
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Smart align all screen shots
The Smart Align feature lets you specify an alignment point on one screen shot, and then align all of your other screen
shots to that point.

1 Display a screen shot or screen shots in 1-up view or 2-up view. (The alignment feature is deactivated in Onion Skin
view.)

2 Click the Align On/Off button. (It’s next to the View menu, to the right of the URL text box.)
Note: You can also turn Align on and off by pressing A on your computer keyboard.

3 Drag the Align square to an area on the page where you want to set the new alignment point.

4 Select a new alignment point by choosing a pixel and clicking it.

Note: The alignment point you choose must be unique in order for BrowserLab to successfully match the corresponding
point on all screen shots. It is best to select distinct colors or elements (for example, the dark corner of an image) when
specifying the alignment point.

5 Click Smart Align All to this Region.

BrowserLab shows you the Smart Align progress. Click Return to Testing to close the Align square and return to
testing, or click Return to Alignment to leave the Align square open and try again.

Save screen shots to desktop

% To save a screen shot to your local desktop system, right-click (Windows) or Control-click (Mac OS) the screen
shot in the BrowserLab application window, and select Save Locally.

Use hot keys
BrowserLab comes with a number of built-in hot keys to help you work more efficiently. The following table lists the
available hot keys:
Key Action
Down arrow Changes the screen shot to the next browser in the selected Browser Set
Up arrow Changes the screen shot to the previous browser in the selected Browser Set
Plus sign Zooms in on the screen shot
Minus sign Zooms out from the screen shot
1 Displays the screen shot in 1-up View
2 Displays screen shots from two browsers in 2-up View (side-by-side)
3 Displays the screen shot in Onion Skin view
Left arrow In Onion Skin view, increases the visibility of the left-selected browser screen shot.
Right arrow In Onion Skin view, increases the visibility of the right-selected browser screen shot.
R Shows or hides rulers
Control/Command Lets you follow active links on the page
H Turns the cursor into a pan tool (hand), allowing you to drag the page
Shift Creates a "ghost cursor” (i.e. duplicate cursor) on the right or left image in 2-up view
A Turns Alignment mode on or off
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A list of hot keys is also accessible from the BrowserLab interface. Click the Hot Keys link in the upper-right corner of
the application window to access the list at any time.

If a hot key isn't working as expected, you might have one of the application controls selected. Click the main image
in the application window to reset all controls and try using the hot key again.

Change application window language
You can change the language of the BrowserLab application window. Currently BrowserLab supports English, French,

German, Japanese, Italian, and Spanish application windows.

« To change the language of the application window, select a language from the Language pop-up menu. (It’s in the
upper-right corner next to the Hot Keys link.)

Work with BrowserLab for Firebug

The Adobe BrowserLab for Firebug add-on lets you preview pages in BrowserLab after you’ve made temporary
changes to the page using Firebug. When you preview a page from Firefox, BrowserLab shows you what the altered
page looks like in Firefox as well as other browsers.

To use the BrowserLab for Firebug add-on, you’ll need the following:

+ Firefox 3.5 or later
« Firebug (available at http://addons.mozilla.org/)
+ The Adobe BrowserLab for Firebug add-on (available at http://addons.mozilla.org/)

Once you've installed the BrowserLab for Firebug add-on, a BrowserLab icon becomes visible in the lower-right corner
of your browser window. The BrowserLab add-on is also accessible from the Tools menu (Tools > Adobe BrowserLab
for Firebug).

Preview a page from Firefox
1 (Optional) In Firefox, make temporary changes to the page using Firebug.

2 Right-click (Windows) or Control-click (Mac OS) the Adobe BrowserLab for Firebug icon in the lower-right
corner of the browser and select one of the following:

Preview URL lets you preview the page as it appears on the web. The URL when previewing in BrowserLab starts
with “http”.

Preview Local Source lets you preview a local source copy of the file that includes any edits you may have made
using Firebug. Additionally, the Preview Local Source option lets you interact with a page and preview different
page states (for example, an open panel on an Accordion widget), rather than just the initial state of the page. The
URL when previewing in BrowserLab starts with “firebug”.

Note: The Preview Local Source option also lets you preview pages that would normally require logging in to a live site
(for example, a shopping cart page in an online store).

The first time you preview local source files, the BrowserLab add-on asks you if you are willing to grant BrowserLab
read access to your computer. If you do not grant BrowserLab read access, BrowserLab can’t interact with files on your
computer, and you won’t be able to preview pages. You’ll need to select Accept to give BrowserLab read access. You
can change this security setting at any time (see the next section).
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Change security settings

1 Right-click (Windows) or Control-click (Mac OS) the Adobe BrowserLab for Firebug icon in the lower-right
corner of the browser and select Options.

2 Change your Allow/Deny read access security setting as necessary.

Preserve CSS hacks

If you’re using CSS hacks, your previews for other browsers won’t recognize them by default because Firefox discards
any CSS hacks not specific to itself. The BrowserLab add-on lets you preserve CSS hacks, but if you elect to do so,
BrowserLab won’t be able to reflect any major changes you make (such as creating a new rule) in Firebug.

% To preserve CSS hacks, right-click (Windows) or Control-click (Mac OS) the Adobe BrowserLab for Firebug icon
in the lower-right corner of the browser and select Preserve CSS hacks.

Work with sites requiring authentication

You can test pages that requires HTTP authentication (usernames and passwords) by using the BrowserLab for
Firebug add-on. Using the add-on sends the local source file from Firefox to BrowserLab, and let’s you test pages that
you would otherwise not be able to view in BrowserLab.

1 Start Firefox and open the site you want to test.

2 Log in to the site as necessary.

3 Click the Firebug icon in the browser’s lower right-hand corner to turn on Firebug.
4

Right-click (Windows) or Control-click (Mac OS) the Firebug icon and select Enable All Panels. (The Firebug icon
should be orange.)

wn

Right-click (Windows) or Control-click (Mac OS) the BrowserLab for Firebug icon.

6 Select Preserve CSS Hacks, then select Preview in Local Source.

Work with BrowserLab in Dreamweaver

Adobe BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to
a publicly-accessible server first. You can preview files from your local Dreamweaver site, or from a remote or testing
server.

BrowserLab only works with Dreamweaver CS5 (version 11.0.3) and later. If you are a Dreamweaver CS5 user and have
not updated to 11.0.3, you will need to do so before using BrowserLab. You can download the 11.0.3 updater from the
Adobe website.

Set file location preference

BrowserLab lets you preview local versions of your files, files on a local network, or files on another server (for example,
a remote staging server or a remote testing server).
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When you preview a local or local network file, BrowserLab actually uploads the file to a BrowserLab server, takes the
screen shots of your page in different browsers, and then displays the screen shots in the BrowserLab application
window. When you preview a file from a server, BrowserLab performs the same operation as it does for other live files:
it takes screen shots of the server file in different browsers, and then displays the screen shots in the BrowserLab
application window.

1 Choose Window > Extensions > Adobe BrowserLab.

2 In the Adobe BrowserLab panel, choose a location from the pop-up menu.

ADOBE BROWSERLAB =

| Preview | [ Local/Network I+ ]
Local/ Network

Server

L —

Note: The file location choice you make remains the same until you change it again.

Local/Network directs BrowserLab to preview files from your local or local network site. When previewing a file
from Design or Code view, BrowserLab uses the local file as its source for screen shots. When previewing a file from
Live view, BrowserLab uses the page rendered by WebKit (the rendering engine for Live view) as its source for
screen shots.

Server directs BrowserLab to preview files from your active server.

When previewing files using the server configuration (i.e. not files in the local Dreamweaver site), the server that
BrowserLab uses is the server that is active in Dreamweaver. The active server is the server that you last selected
from the Server view menu in either the expanded or collapsed Files panel. For example, if you have been uploading
files from your local site to a defined testing server, BrowserLab will take screen shots of the specified file on the
testing server. Dreamweaver remembers this setting and will maintain it until you manually change the active
server. To see what your active server is, click the Expand button in the Files panel. The selected server (testing or
remote) is the active server.

Important: If your active server is a remote server (for example, a remote staging server) or a testing server, the Web
URL text box in the server’s Basic editing view must be completed. The Web URL should correspond to the specified
remote or testing server location (FTP address for FTP sites, remote folder for Local/Network sites, and so on).

Adjust permission settings

When you preview files from a local network (for example, a local server running a content management system like
WordPress, Drupal or Joomlal, or a local network server within a corporate firewall), you need to give BrowserLab
permission to upload these files and take screenshots of them. When you give BrowserLab permission to upload these
kinds of local network files, your computer acts as a gateway between the BrowserLab service and the files themselves.
Because BrowserLab cannot access such files directly, your computer does the accessing work, and delivers them to
BrowserLab. BrowserLab caches the files for a limited time and uses them solely for the purpose of rendering the
requested screenshots.

Note: BrowserLab does not render CSS styles for CMS sites that use the https protocol.
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When you request a preview of a file that resides on a local network, or a file that has dependencies on local network
files (for example, a CMS index page with dependent PHP files), Dreamweaver scans the page to determine whether
or not you need to give BrowserLab permission to upload the file(s). You can choose to allow permissions during such
preview requests, or you can opt to set permissions manually.

To allow permissions
< To allow permissions for the network locations associated with a particular file and its dependencies, initiate a
preview of the file in BrowserLab, and then click the Allow button in the dialog box that appears.

Note: If you click the Deny button in the dialog box, any resources in the specified locations will not be uploaded to
BrowserLab, and will therefore not appear in the preview.

To set or adjust permissions manually

To set or adjust permissions manually, follow the instructions below.

1 Choose Permission Settings from the Options Menu in the upper-right corner of the BrowserLab panel.

2 Select Allow or Deny and click OK.

Preview a page
1 In Dreamweaver, open the page you want to preview.
2 Choose File > Preview in Browser > Adobe BrowserLab.

3 When the BrowserLab login screen opens, enter your Adobe ID (email address) and password, and click Sign In.

Edit and refresh a page

You can edit a local page in Dreamweaver and then refresh the page in BrowserLab without having to save the file in
Dreamweaver, or upload it to a server. This option is particularly useful if you are making lots of edits to your CSS, and
want to preview each change as you go along without having to save the changes.

Note: If you are previewing in BrowserLab using the remote configuration, BrowserLab saves and uploads your file to the
active server automatically before previewing.

1 In Dreamweaver, open the page you want to preview.

2 Choose File > Preview in Browser > Adobe BrowserLab.

3 Make changes to the page, or to the CSS attached to the page.

4 Click the Refresh the Screenshots button in the BrowserLab application window.

BrowserLab previews your page without you having to save the local changes first.
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Adobe Story
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