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Connector for ADEP DAM Services for Adobe® Drive 3

Overview
Adobe Drive 3 enables you to connect Creative Suite 5.x to Digital Asset Management (DAM) servers. The 
connected servers appear in your computer as a mounted hard drive or mapped network drive. Once 
connected, you can access server files through Windows Explorer or Mac OS Finder, as well as the 
platform-specific file-access dialogs, and directly through the UI of integrated applications.

Adobe Drive 3 is extensible; an SDK allows partners and third parties to create connectors for particular 
asset management systems. Adobe provides some ready-made connectors. The ADEP DAM Services 
Connector enables basic access to the Adobe Digital Enterprise Platform (ADEP), the technology 
foundation powering Adobe Customer Experience Solutions. 

Supported features 

The digital asset management capability of the ADEP DAM Services Connector is made available through:

Adobe’s Web Experience Management (WEM) solution, and its predecessor, CQ5 

Adobe’s Integrated Content Review (ICR) solution

You can use the connector to access any server that runs either the WEM or ICR solution on the Adobe 
Digital Enterprise Platform (ADEP). 

The connector supports these features:

Connecting to and disconnecting from a server

Browsing documents and folders.

Creating and deleting documents and folders

Moving and copying documents and folders

Checking documents out and in

Managing document versions 

Searching documents

Thumbnails and preview icons in Adobe Bridge 

Thumbnails in the Show Versions dialog

Viewing, editing, and searching XMP metadata in Adobe Bridge

http://www.adobe.com/solutions/customer-experience/enterprise-platform.html
http://www.adobe.com/solutions/customer-experience.html
http://www.adobe.com/solutions/customer-experience/web-experience-management.html
http://www.day.com/day/en/products/digital_asset_management.html
http://www.adobe.com/solutions/customer-experience/integrated-content-review.html
http://www.adobe.com/solutions/customer-experience/enterprise-platform.html
http://www.adobe.com/solutions/customer-experience/enterprise-platform.html
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Using the ADEP DAM Services Connector
Before connecting, you must obtain the URL for the ADEP or CQ5 server from the server administrator, as 
well as a valid user ID and password. 

This document uses the localhost server in examples; this works if you have default server installation on 
your local machine. You must replace localhost with the server URL when you connect to a remote 
server. For example, to access an ADEP DAM or CQ5 DAM in a default installation on your local machine:

SERVER URL: http://localhost:4502

USERNAME: admin

PASSWORD: admin

Connecting to a server 

To connect to an ADEP or CQ5 server:

1. Start the Adobe Drive application. 

In Windows Explorer, right-click a folder, a file, or your desktop, and choose 
Adobe Drive 3 > Connect To from the context menu. 

In Mac OS, CTRL-click a folder or file in Finder or your desktop, and choose 
More > Adobe Drive 3 > Connect To from the context menu. 

2. Click Add Drive.

http://localhost:4502
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3. If you have the name of a preset server, click it to display the Server URL. Otherwise enter the Server 
URL manually.

4. Enter your connection details. For example: 

Server URL: http://localhost:4502
Name: admin
Password: admin

5. Click Connect.

6. Check that the server has been mounted in the file browser:

In Windows Explorer, it should be under My Computer.

In Mac OS Finder, it should be under Devices.

Troubleshooting

If connection fails, open a web browser and test whether the server is available using the server URL. For 
example, if you enter http://localhost:4502 and authenticate with your credentials, you should see 
the ADEP or CQ5 login screen, and be able to navigate to and open DAM access to digital assets.

If you receive no response or an empty response, your server might not be available or your 
credentials might be incorrect.

If you do not have DAM access, check that you have the Digital Asset Management capability installed; 
the connector does not work with an ADEP DAM server that does not have this capability.

Disconnecting 

In Windows Explorer: Right-click the ADEP drive and choose Disconnect from the context menu.

In Mac OS Finder: CTRL-click the ADEP drive device and choose Eject from the context menu.

In Adobe Bridge: Select Adobe Drive in the Favorites panel. Right-click (in Windows) or CTRL-click (in 
Mac OS) the ADEP drive and choose Disconnect from the context menu.

In Adobe Drive 3: Select the server to be disconnected from Recent Connections and click 
Disconnect.

Browsing and manipulating documents and folders.
Once you are connected, Adobe Drive 3 presents documents and folders from your ADEP DAM server in a 
network drive on your computer. You can view the server’s files in Windows Explorer or Mac OS Finder. You 
can also access these files in Open, Save As, and other file management dialog boxes.

http://localhost:4502
http://localhost:4502
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You can also use the UI for your ADEP DAM server to view and manipulate documents and folder. 
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Creating and deleting documents and folders 

Adobe Photoshop® CS5.x, Adobe Illustrator® CS5.x, Adobe InDesign® CS5.x, and Adobe InCopy® CS5.x 
allow you to check in documents directly to the ADEP DAM server. In other applications you must save 
your document to the ADEP drive and use Windows Explorer, Mac OS Finder or Adobe Bridge to manually 
check in the file.

You can create new folders using Windows Explorer, Mac OS Finder or Adobe Bridge CS5.x, or using the 
Open, Save As, and other file management dialog boxes in an application. 

You cannot create documents or folders at the root of the drive; you must save any new content under a 
folder in the root that already exists on the server. If you need to create new folders at the root location, 
you must use the UI provided by your ADEP DAM server.

For example, to create a new document in the ADEP DAM server from Photoshop:

1. Create a new document in Photoshop.

2. Choose File > Check In.

3. In the Save As dialog, navigate to the folder on the ADEP drive where you want to save the document.

4. Enter a check-in comment when prompted, and click OK.

Photoshop, Illustrator, InDesign, and InCopy display the file status in a status bar when you view or edit 
documents. Once the document is saved to the server, the file status changes to Up-to-Date. 
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Moving, copying documents and folders

To move or copy documents or folders on the ADEP DAM server:

In Adobe Bridge:

Invoke the context menu (right-click in Windows or CTRL-click in Mac OS) for the document or folder.

Choose Move To or Copy To from the context menu, then choose the destination folder.

Documents moved or copied in this way are automatically checked in.

In Windows Explorer or Mac OS Finder: 

Drag a document or folder to move it to a different location.

CTRL-drag (in Windows) or OPTION-drag (in Mac OS) to copy to a new location.

If you move a document from the desktop to an ADEP drive this way, or copy any document to a 
new location, you must check it in explicitly.

You cannot move or copy documents or folders to the root of an ADEP drive.

Renaming documents and folders 

In Adobe Bridge, Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or 
CTRL-click in Mac OS) for the document or folder, and choose Rename.

You cannot rename documents or folders in the root of an ADEP drive.

Deleting documents and folders

In Adobe Bridge, Mac OS Finder, or Windows Explorer, invoke the context menu (right-click in 
Windows or CTRL-click in Mac OS) for the document or folder, and choose Delete.

You cannot delete documents or folders in the root of an ADEP drive.

Deletion from an ADEP DAM server is permanent; deleted files cannot be restored. The Tools > Adobe 
Drive > Project Trash option in Adobe Bridge, Recycle Bin in Windows, and Trash in Mac OS are not 
supported.
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Working with XMP metadata

When you are connected to an ADEP DAM server, you use Adobe Bridge to view, edit, and search XMP 
metadata in managed assets. 

You can view metadata directly through the Adobe Bridge menus and panels, or you can right-click the 
asset and choose File Info.

The Adobe Bridge Label menu gives you access to the view and edit rating and label information: 

For other XMP properties, use the Adobe Bridge Metadata and Keywords panels: 
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The File Info dialog provides access to all XMP metadata properties:
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Searching documents and folders

To search for a document or a folder on an ADEP DAM server from Adobe Bridge:

1. Select Adobe Drive from the Favorites panel and open the folder in the ADEP drive you want to search.

2. Choose Edit > Find. 

3. Choose search criteria by selecting options and limiters from the Criteria menus. 

4. Enter search text in the box on the right. To add search criteria, click the plus sign (+). To remove search 
criteria, click the minus sign (-). 

5. Choose an option from the Match menu to specify whether any or all criteria must be met.

6. Click Find.

The "Search includes all versions of a file" and “Search includes deleted files” options in the Find dialog are 
ignored. 

NOTE: You can search assets based on any metadata information except "File size", "Check in comment", or 
"Lock owner" (although these are listed in the search criteria).

Check-out and version management
Adobe Photoshop, Adobe Illustrator, and Adobe InDesign or InCopy automatically check out a managed 
document when the first edit is made. 

Check the document in using the File > Check In menu. 

To cancel checkout, close the document and click Don't Save when prompted for whether changes 
should be saved.
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In other applications, you must check out manually, modify and save the document and then check in 
manually.

In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click 
in Mac OS) and choose the desired action from the Adobe Drive 3 menu (Check Out, Check In, or 
Cancel Check Out).

Managing document versions

All documents created or modified via the ADEP DAM Services Connector are versioned. Versions track 
changes to a document. Each version is a snapshot of the document at a particular point in time. When 
you check a document in, you create a new version of the document on the ADEP DAM server.

In Adobe Photoshop, Adobe Illustrator, and Adobe InDesign or InCopy, use the Show Versions popup 
menu on the status bar to display the versions of a document in the Versions dialog. 

In Mac OS Finder or Windows Explorer, invoke the context menu (right-click in Windows or CTRL-click 
in Mac OS) for the document or folder, and choose Adobe Drive 3 > Show Versions.

You can use this dialog to delete, promote and open selected versions. 
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You can also use the UI for the ADEP DAM server to display versions of a document. 

If you check out an unversioned document, checking in the edited document creates version 1of that 
document. If you cancel the checkout, the document remains unversioned.

Release notes
Some special characters, such as /:[ ]*| , are not supported in file and folder names. Avoid using 
them. [2918134].

Adobe Drive cannot show version information for files that were not originally uploaded through 
Adobe Drive. Such files have no version in the ADEP DAM server. After you edit the files and check 
them in through Adobe Drive, the correct version information is shown. [2918182].

Browsing or refreshing a folder containing many documents or sub-folders is slow. The recommended 
maximum number of documents and subfolders in a folder is 200.

If an asset is renamed by another user in Adobe Bridge on another machine, its thumbnail and preview 
cannot be displayed or opened in Adobe Bridge on a local machine. To correct this, reconnect to the 
DAM server. [2908147]

When an ADEP DAM server is configured to use only HTTP, and you attempt to connect using HTTPS, 
there is no response in the Adobe Drive Connect UI. [2925809]
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ADEP DAM servers do not support the generation of renditions for 32bits/channel and Multichannel 
PSD files. Avoid checking files of these types. [2924780] 

When a file is checked out, the Adobe Bridge content panel does not display Label and Rating for the 
thumbnail. You can see this information in the Metadata panel, and in the File Info dialog. [2918959]

When you check in an edited document from Photoshop or Illustrator, you are prompted to save it: 
“The disk copy of 'x' was changed since you last opened or saved it. Do you want to save anyway?” 
The confirmation should not appear. 

ADEP DAM servers do not support event notifications for file and folder changes. If you are browsing 
in Adobe Bridge when another user deletes or moves a folder, your window does not automatically 
refresh to show the change. Display the parent folder to refresh manually, or clear the Adobe Bridge 
cache. [2921270]

The ADEP DAM Services Connector does not support setting the last modification date of a file, which 
Adobe applications expect. You might see an alert is some cases; for example:

Open an InDesign file that links to other files, package the file to the server using File > Package, 
then open the packaged InDesign file. An alert warns “This document contains links to sources 
that have been modified. You can update the modified links now, or update them later using the 
Links Panel. “

Choose Update Links to update the modification date.

Create a new file in Photoshop and check it in to the server, leaving it open in Photoshop. If you 
double-click the newly created file In Adobe Bridge or a platform file browser, an alert warns: “The 
disk copy of “xx” was changed since you last opened or saved it. Do you wish to update it?”

Choose Update to update the modification date.

Continuous check-in of a large number (1000 or so) of files might cause an out-of-memory error. 
[2924869]. You should avoid doing this. However, you can tweak the Service Manager maximum heap 
memory value to avoid the problem. To do this:

Kill the CS5ServiceManager process.

Open the file StartupOptions.xml in the CS5ServiceManager configuration folder: 

Win32: C:\Program Files\Common Files\Adobe\CS5ServiceManager\configuration

Win64: C:\Program Files (x86)\Common Files\Adobe\CS5ServiceManager\configuration

Mac OS X: /Library/Application Support/Adobe/CS5ServiceManager/configuration

Change the value of vmMaxMemory from 128 to 256 or 512.

Launch Adobe Drive to reconnect to the DAM server.

If an asset has a large number of versions with thumbnails (1000 or so), showing the file might cause 
an out-of-memory error. We recommend that you use Adobe Bridge to view, promote, and delete 
versions. [2926502] 

Occasionally, you can get the warning “File was deleted on server” when the file is actually edited and 
checked in by another user. You can safely ignore this message. [2920822]
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In Adobe Bridge, Open in Camera Raw functionality is disabled for image types JPG, PNG, and 
camera-raw formats such as DNG. [2919948]

In Adobe Bridge, when you copy or move a file or check in a version after the first one, you cannot 
cancel the operation. If you click Cancel in the progress dialog, the operation continues. [2926863]

When working with XMP metadata in managed files:

If you drag a file from the local file system to a mounted drive using Windows Explorer or Mac OS 
Finder, then check the file in from Adobe Bridge, the file can be uploaded to the server, but its XMP 
metadata is lost. [2918897] 

XMP metadata that you edit in Adobe Bridge cannot be viewed from another integrated Adobe 
product (Photoshop, Illustrator, InDesign/InCopy). [2918897]

The last keyword for a file cannot be removed using the Metadata panel in Adobe Bridge. 
[2918839]
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