Manage form data files

You can move the answers on a PDF form to and from other file formats that preserve all the data in much less space than a full PDF.

Import form data

In some workflow scenarios, individuals submit filled-in forms as data-only files rather than as complete PDF files. These files are not PDFs, but use another file format, such as FDF or XML. You can view the data submitted by an individual recipient in the context of the PDF by opening the original file and importing the information in the data file.

  1. In Acrobat, open the PDF form into which you want to import data.
  2. Choose Tools > Forms > Clear Form.
    Note: When you import data from another file into a PDF form, the imported data replaces any information that appeared previously in the individual form fields. However, if the imported data file contains one or more blank form fields, importing will not clear the original data.
  3. Choose Tools > Forms > More Form Options > Manage Form Data > Import Data.
  4. In the Select File Containing Form Data dialog box, select a format in File Of Type corresponding to the data file you want to import. Then locate and select that file, and click Open.
    Note: Some formats are available only for specific types of PDF forms, depending on the application used to create the form, such as Acrobat or Designer ES2. Data you import from a text file (.txt) must be formatted in tab-delimited rows that form columns.

Export file data

You can save the information in a completed PDF form as a data file in another file format. Later, you can reuse the data to fill in the form again or another form with the same fields and field names.

  1. In Acrobat, open the completed form file.
  2. Choose Tools > Forms > More Form Options > Manage Form Data > Export Data.
  3. In the Export Form Data As dialog box, select the format in which you want to save the form data (FDF, XFDF, XML, or TXT). Then select a location and filename, and click Save.
    Note: Some file formats are available only for specific types of PDF forms, depending on how the form was created.

Merge exported data files to a spreadsheet

If you want to compile data from forms that are not already in a data set, use the following process.

  1. Choose Tools > Forms > More Form Options > Manage Form Data > Merge Data Files Into Spreadsheet.
  2. In the Export Data From Multiple Forms dialog box, click Add Files.
  3. In the Select file Containing Form Data dialog box, select a file format option in File Of Type option (Acrobat Form Data Files or All Files). Then locate the form files that you want to merge into the spreadsheet, select them, and click Open.
  4. Repeat the previous step to add form data files that are in other locations, as needed.
  5. Click Export. Then select a folder and filename for the spreadsheet, and click Save.
  6. In the Export Progress dialog box, click either View File Now to open the spreadsheet file or Close Dialog to return to Acrobat.
Note: When returned forms are in a response file, the most efficient way to export the information into a spreadsheet is to use the Export Data button in the left navigation panel for the PDF Portfolio response file.