Removing sensitive content

Why remove sensitive content?

Before you distribute a PDF, you may want to examine the document for sensitive content or private information that can trace the document to you. Such information can be hidden or not immediately apparent. For example, if you created the PDF, the document metadata normally lists your name as the author. You may also want to remove content that can inadvertently change and modify the document’s appearance. JavaScript, actions, and form fields are types of content that are subject to change.

Use the Remove Hidden Information feature to find and remove hidden content from a PDF. Use the Black Out & Remove Content tools to remove sensitive images and text that are visible in a PDF.

Find and remove hidden content

Use the Remove Hidden Information feature to find and remove content from a document that you don’t want, such as hidden text, metadata, comments, and attachments. When you remove items, additional items are automatically removed from the document. Items that are removed include digital signatures, document information added by third-party plug-ins and applications, and special features that enable Adobe Reader users to review, sign, and fill PDF documents.

To examine every PDF for hidden content before you close it or send it in e-mail, specify that option in the Documents preferences using the Preferences dialog box.
  1. Choose Tools > Protection > Remove Hidden Information. If you don’t see the Protection panel, see the instructions for adding panels at Task panes.

    If items are found, they are listed in the Remove Hidden Information panel with a selected check box beside each item.

  2. Make sure that the check boxes are selected only for the items that you want to remove from the document. (See Remove Hidden Information options.)
  3. Click Remove to delete selected items from the file, and click OK.
  4. Choose File > Save, and specify a filename and location. If you don’t want to overwrite the original file, save the file to a different name, location, or both.

The selected content is permanently removed when you save the file. If you close the file without saving it, repeat this process, making sure to save the file.

Remove Hidden Information options

Metadata
Metadata includes information about the document and its contents, such as the author’s name, keywords, and copyright information, used by search utilities. To view metadata, choose File > Properties.

File Attachments
Files of any format can be attached to the PDF as an attachment. To view attachments, choose View > Show/Hide > Navigation Panes > Attachments.

Bookmarks
Bookmarks are links with representational text that open specific pages in the PDF. To view bookmarks, choose View > Show/Hide > Navigation Panes > Bookmarks.

Comments And Markups
This item includes all comments that were added to the PDF using the comment and markup tools, including files attached as comments. To view comments, choose the Comments pane.

Form Fields
This item includes form fields (including signature fields), and all actions and calculations associated with form fields. If you remove this item, all form fields are flattened and can no longer be filled out, edited, or signed.

Hidden Text
This item indicates text in the PDF that is either transparent, covered up by other content, or the same color as the background.

Hidden Layers
PDFs can contain multiple layers that can be shown or hidden. Removing hidden layers removes these layers from the PDF and flattens remaining layers into a single layer. To view layers, choose View > Show/Hide > Navigation Panes > Layers.

Embedded Search Index
An embedded search index speeds up searches in the file. To determine if the PDF contains a search index, choose View > Tools > Document Processing > Manage Embedded Index. Removing indexes decreases file size but increases search time for the PDF.

Deleted Or Cropped Content
PDFs sometimes retain content that has been removed and no longer visible, such as cropped or deleted pages, or deleted images.

Links, Actions And JavaScripts
This item includes web links, actions added by the Actions wizard, and JavaScripts throughout the document.

Overlapping Objects
This item includes objects that overlap one another. The objects can be images (composed of pixels), vector graphics (composed of paths), gradients, or patterns.

Redact (black out and remove) sensitive content

Redaction is the process of permanently removing visible text and graphics from a document. You use the Black Out & Remove Content tools (also called redaction tools) to remove content. In place of the removed items, you can have redaction marks that appear as colored boxes, or you can leave the area blank. You can specify custom text or redaction codes to appear over the redaction marks.

Note: If you want to locate and remove specific words, characters, or phrases, use the Search & Remove Text tool  instead.
Text marked for redaction (left), and redacted (right)
  1. Choose Tools > Protection > Mark for Redaction . If you don’t see the Protection panel, see the instructions for adding panels at Task panes.
  2. (Optional) To set the appearance of redaction marks, click Redaction Properties. (See Change the look of redaction marks.)
  3. Mark items you want to remove by doing any of the following:
    • Double-click to select a word or image.

    • Drag to select a line, block of text, object, or area.

    • Press Ctrl as you drag to select areas of a page in a scanned document.

    To preview how your redaction marks appear, hold the pointer over the marked area.
  4. To apply multiple code entries to a single redaction, right-click a redaction mark and select an option. For more information, see Apply multiple code entries to a single redaction.
  5. (Optional) To repeat a redaction mark, right-click it and choose Repeat Mark Across Pages. This feature is convenient if a particular header, footer, or watermark appears in the same location on many pages.
  6. Click OK to remove the items. The items aren’t permanently removed from the document until you save it.
  7. If you want to search for and remove hidden information in the document by using the Remove Hidden Information feature, click Yes in the dialog box. Otherwise, click No.
  8. Choose File > Save, and specify a filename and location. The suffix “_Redacted” is appended to the filename. If you don’t want to overwrite the original file, save the file to a different name, location, or both.

Search and remove text

Use the Search & Remove Text tool to find and remove words or phrases in one or more PDFs that contain searchable text.

Note: The Search & Remove Text tool doesn’t search secured (encrypted) PDFs.
  1. Choose Tools > Protection, and select the Search & Remove Text tool . If you don’t see the Protection panel, see the instructions for adding panels at Task panes.
  2. Specify if you want to search the current PDF or all PDFs in another location.
  3. Do one of the following:
    • To search for only one word or phrase, choose Single Word Or Phrase and type the word or phrase in the text field.

    • To search for multiple words, select Multiple Words Or Phrase, and then click Select Words. Type each word in the New Word Or Phrase text field and click Add. You can also import a text file with the list of words or phrases to search for.

    • To search for a pattern (for example, phone numbers, credit card numbers, e-mail addresses, social security numbers, or dates), click Patterns. Choose one of the available patterns. You can change the language version of the patterns. (See Select a different language version for patterns.)

  4. Click Search & Remove Text.
  5. In the search results, click the plus sign (+) next to the document name to see all occurrences of the word or phrase. Then, select the occurrences you want to mark for redaction:
    • To select all occurrences in the list, click Check All.

    • To select individual occurrences, click the check box for each one you want to redact. Click the text next to a check box to view the occurrence on the page.

    • To mark none of the occurrences, close the Search window or click New Search to start over.

    • To mark whole words or partial words (characters) for redaction, select the option under Redaction Mark Options. For partial words, click Settings and specify the number and location of the characters for redaction. Character redaction is useful if you’re searching for a pattern, like credit card numbers, and want to leave part of the number visible for identification purposes.

  6. If you selected occurrences that you want to mark for redaction, click Mark Checked Results For Redaction.

    The items you selected in the list are shown marked for redaction.

    Note: If you haven’t saved the file, you can select redaction marks in the document and press Delete to remove the redaction mark. The redaction marks become permanent after you save the file.
  7. To remove the marked items, click Tools > Protection > Apply Redactions, and then click OK.

    The items aren’t permanently removed from the document until you save it.

  8. If you want to search for and remove hidden information in the document by using the Remove Hidden Information feature, click Yes. Otherwise, click No.
  9. Choose File > Save, and specify a filename and location. If you don’t want to overwrite the original file, save the file to a different name, location, or both.

Select a different language version for patterns

Localized patterns appear in the Search panel (Protection > Search & Remove Text).

  1. Choose Edit > Preferences (Windows) or Acrobat > Preferences (Mac OS).
  2. From the Categories on the left, select Documents.
  3. In the Redaction area, choose a language from the Choose Localization For Search & Remove Text Patterns menu.

Change the look of redaction marks

By default, thin red outlines appear around images and text you mark for redaction, and black boxes appear in place of redacted images and text. You can set the default appearance of redaction marks before you mark items for redaction. You can also change the look of redaction marks before you apply the redactions.

Set the default look of all marks

  1. Click Tools > Protection > Redaction Properties. If you don’t see the Protection panel, see the instructions for adding panels at Task panes.
  2. On the Appearance tab, select options you want to change, and then click OK:
    • Click the Redacted Area Fill Color icon and select a fill color from the Color palette for the boxes that replace removed items. Choose No Color to leave the redacted area blank.

    • Select Use Overlay Text if you want to select the custom text or redaction code options. Select the font, size, and text alignment.

    • Select Custom Text, and type the text you want to appear in the redacted area.

    • Select Redaction Code, and then either select a code within an existing set, or click Edit to define a new code set or a new code. (See Create redaction codes and code sets.)

    • In the Redaction Mark Appearance area, click the Outline Color icon or Fill Color icon or both. Select a color from the color palette for the images and text you mark for redaction. Move the slider to adjust the opacity of the color. Choose No Color to leave the selected area blank.

Properties for redaction text

Custom Text
Displays text you type into the Custom Text option over the redaction mark.

Font
Displays custom text in the selected font.

Font Size
Displays custom text in the selected point size.

Auto-Size Text To Fit Redaction Region
Resizes custom text to fit within the redacted area. When selected, this option overrides the Font Size setting for the overlay text.

Font Color
Displays custom text in the selected color, which you can change by clicking the color swatch.

Repeat Overlay Text
Fills the redacted area with as many instances of the custom text as needed, without changing the font size. For example, if you specify the letter x or a hyphen (-) as the custom text, these characters are repeated throughout the redacted area.

Text Alignment
Aligns text to the left, right, or center.

Redaction codes

Acrobat uses overlay text to overprint areas selected for redaction. One example of overlay text is a redaction code, which consists of one or more code entries from a collection of code entries called a code set. Acrobat includes the U.S. FOIA and U.S. Privacy Act code sets that you can use. You can use either codes or custom text to create overlay text. The difference is that redaction codes are text entries that you can save, export, and import. One code set can contain multiple codes.

Note: Codes don’t save the current attributes for overlay text as part of the code definition, such as colors, font characteristics, and repetition or size of text. Codes only make the overlay text itself reusable in future sessions and by other users with whom you share code sets. You set other attributes for the code in the Redaction Tool Properties dialog box.

Create redaction codes and code sets

  1. Click Tools > Protection > Redaction Properties . If you don’t see the Protection panel, see the instructions for adding panels at Task panes.
  2. Select Use Overlay Text.
  3. Select Redaction Code.
    • To add multiple code entries to a redaction code, select an entry from the Code Entries list and click Add Selected Entry. Repeat as desired. Select Remove Selected Entry to delete a code entry.

    • Click Edit Codes to make additional changes.

  4. In the Redaction Code Editor dialog box, click Add Set.
  5. (Optional) Type a new name for the set in the text field below the list of code sets, and then click Rename Set.
  6. Click Add Code, and type the text that you want to appear as overlay text in the text field below the list of code entries, and then click Rename Code.
  7. Repeat the previous step to add another code entry to that code set, or repeat the previous three steps to create additional code sets and codes.

Edit redaction codes and code sets

  1. Click Tools > Protection > Redaction Properties . If you don’t see the Protection panel, see the instructions for adding panels at Task panes.
  2. Select Use Overlay Text, and then select Redaction Code.
  3. Select a code set from the list on the left, and click Edit Codes.
  4. In the Redaction Code Editor dialog box, do any of the following:
    • To remove a code set and all of the code entries within it, select the code set and click Remove Set.

    • To export a code set to a separate XML file that you can reuse in other PDFs or share with others, select the code set. Then click Export Set, specify a filename and location, and click Save.

    • To import a previously saved code set, click Import Set, locate and select that file, and click Open.

    • To rename a code set, type a new name in the box below the list and click Rename Set.

  5. With the code set selected, select the code entry that you want to edit, and do one of the following:
    • To remove a code entry, click Remove Code.

    • To rename a code entry, type a new name in the box below the list and click Rename Code.

Apply multiple code entries to a single redaction

  1. Right-click the redaction marker. Choose a code set or code entry from the list at the bottom of the context menu.
  2. Select a code set from the list at the bottom of the context menu, and then select a code entry from the drop-down menu. A check mark appears next to the code entry when the code is applied.
  3. Repeat the previous step to add another code entry to the redaction.

Hold your pointer over the redaction mark to see the code entries, each one separated by a comma.

Another way to add multiple code entries to a redaction is by using the Redaction Properties dialog box. In the Protection panel, click Redaction Properties. Select Redaction Code, select a code entry, and then click Add Selected Entry.

Additional resources

For videos and articles on removing sensitive content, see these resources: