Getting Started with
ADOBE® LIVECYCLE® MOSAIC 9.5
Contents

Chapter 1: About Mosaic
Mosaic terms and concepts ................................................................. 1
Mosaic configuration, design, and deployment ......................................... 2
End-user interface ............................................................................. 2
Mosaic users and roles ........................................................................ 5
Desktop client for the designer user ...................................................... 6

Chapter 2: Installing and Configuring the Development Environment
Development system requirements ......................................................... 7
Installing the Mosaic development environment .................................... 8
Installing and configuring the Mosaic standalone server ......................... 9
Installing the desktop client .................................................................. 10
Configure Flash Builder with Mosaic SWC files .................................... 11
Removing Mosaic from a development environment ................................. 12

Chapter 3: Installing and Configuring the Production Environment
System requirements ........................................................................... 13
Installing and configuring the Mosaic server ......................................... 14
Opening a Mosaic application ................................................................ 19
Removing Mosaic from a production environment ................................ 20

Chapter 4: Sample Applications
Deploying the sample applications ....................................................... 22
Accessing Mosaic sample applications ............................................... 23

Chapter 5: Development Walkthrough
Importing sample tiles ........................................................................ 26
Building your first Flash tile ................................................................. 27
Build your first HTML tile ................................................................... 31
Chapter 1: About Mosaic

Mosaic terms and concepts

Mosaic is made up of specialized development and production components and tools located on a server and client desktop. Some terms have a specialized meaning when you discuss Mosaic.

**Catalog**  
A Mosaic catalog stores the resources you use to create an application, including views, panels, tiles, and style sheets.

**Context**  
A context is a data store that allows tiles to share data. It can include both simple and complex objects. Tiles can both get data from and store data in the context.

Mosaic provides two contexts. The view context allows tiles in the same view to share data. The application context allows tiles in all views to share data.

**Layout**  
A layout controls the arrangement of elements in a view, panel, or other application element. You can add layouts when you design a Mosaic application. Some layouts allow users to change the arrangement of elements in a panel and save the new layout as part of a view.

**Mosaic application**  
Mosaic allows you to deliver applications as components of a customized, shared workspace, or view. In the Mosaic environment, an application is the shell that contains other elements, such as views or panels.

**Mosaic browser client**  
Users can access Mosaic applications using a web browser with Adobe Flash® Player installed.

**Mosaic desktop client**  
Users can access Mosaic applications using an Adobe AIR® application installed on their computer.

**Mosaic server**  
Mosaic applications reside on the Mosaic server. The Mosaic server also contains the application component catalog and stores custom views saved by users. Apache Tomcat can provide a server platform for development environments, and LiveCycle ES2.5 provides the platform for production environments.

**Panel**  
Panels organize tiles in a view. You can group tiles in panels by task or some other category and assign a unique layout to each panel.

You can design Mosaic applications that allow users to add and remove panels from their views. If a user changes the layout of a panel and saves the view, the application preserves the layout for subsequent sessions.

**Policy**  
The Mosaic server includes a default asset policy to protect the reading and writing of Mosaic assets. Users with policy administrator privileges design and deploy custom policies referenced by applications and assets in catalogs.

**Shell**  
The Mosaic shell is an application interface that allows a user to access views and other application functionality. You select features and layout for a shell when you design an application. For example, you can create a shell that includes a view organizer or a menu that allows users to add tiles to panels.

**Tile**  
A tile is a component that contains interactive content, such as an RIA or the user interface for a remote application. Tiles are Adobe Flex® applications or modules, or HTML applications. Mosaic’s Tile SDK allows you to include Mosaic framework capabilities (like the shared context) in tiles.

You can include tiles in views (as part of a panel) or in the application shell (for example, to add a menu).

**View**  
A Mosaic view is an optional container that contains one or more panels in which you lay out tiles to suit the user’s needs. If the application shell includes a view organizer, users can save custom views that they create.

**View organizer**  
The view organizer is an application design element that allows users to manage views that they have saved.
Mosaic configuration, design, and deployment

The steps for delivering a Mosaic application include installation, development, and deployment. In most cases, the work is distributed among different roles in an organization and its partners. For example, a Mosaic environment can have the following participants:

- A server administrator who installs Mosaic and creates the required Mosaic users and roles.
- Software developers who create individual tiles for use within a Mosaic application.
- A software developer who adds tiles and other resources to a Mosaic catalog and creates an application design that provides both tile and application shell functionality.
- A server administrator who uploads catalogs to and deploys applications on the Mosaic server.

The tasks performed by each role can change depending on the organization. The Mosaic documentation does not identify specific roles for tasks.

For information and procedures for installing Mosaic, see "Installing and Configuring the Production Environment" on page 13. These procedures also include the steps to create the Mosaic users that are required to use the sample applications. You can modify the fully functional sample applications to create the Mosaic tiles and applications you need. You can also use the samples as models for new applications.

For information on upgrading from a previous version of Mosaic, see Upgrading to LiveCycle Mosaic 9.5.

Administering LiveCycle Mosaic 9.5 provides information on server customization and other more advanced tasks, including:

- Configuring Mosaic to work with an enterprise-wide authentication and authorization system (single sign-on or SSO)
- Implementing Mosaic with a file system repository
- Configuring WebDAV security for non-production environments

For information on the following tasks, see Developing Applications for LiveCycle Mosaic 9.5:

- Creating assets, including tiles.
- Creating catalogs of assets.
- Creating applications composed of catalog assets.
- Deploying catalogs and applications to the Mosaic server.

End-user interface

The default content, layout, and appearance of a Mosaic application are fully customizable. Depending on the application design, users can add, remove, or rearrange application elements as needed and save these preferences to use later. The example applications use a brokerage workspace and problem-tracking tools to illustrate some of the features of Mosaic. For examples of applications designed for other environments, see “Sample Applications” on page 22.

Accessing Mosaic

Users access Mosaic applications using either a Mosaic desktop client installed on their computers or a web browser. The desktop client requires Adobe AIR. The browser-based version requires Flash Player. For a complete list of system requirements for the Mosaic client software, see “Development system requirements” on page 7.
Initially, a user name and password control access to both the client and browser catalogs of applications (see “Opening a Mosaic application” on page 19).

**Working in Mosaic**

Mosaic application views provide a complete context for a user’s daily work, displaying content and controls from multiple sources and different perspectives. For example, a view and panels can be specific to a user’s role in the organization. The Brokerage sample application provides employees of a brokerage firm with access to client account and securities information.

Three different tiles reside in the Brokerage application. Users can work in each tile independently, but the tiles also communicate with each other. For example, when the user selects an item in the Contacts tile, stock information for the selected contact appears in the Portfolio tile. By selecting an item in the Portfolio tile, the user can display detailed information in the Stock Information tile. The Stock Information tile displays the results of a web search using the stock symbol.

The Brokerage application illustrates how Mosaic allows tiles to share information using contexts. If the user makes a selection or updates a value in a tile, Mosaic can automatically update other tiles in which that information appears. If the user logs in to a resource using a tile, they are also logged in to the resource in other tiles.

If an application allows users to create new or custom views, Mosaic can provide a different context for each view. For example, a user can save a view for each client that displays the client's information to use later.
Customizing a Mosaic application

Mosaic applications can provide menus that allow users to customize their views and panels. The sample problem-tracking application allows users to create, save, and retrieve their own views.

When the user opens the application, the view and panels appear in a default arrangement. Depending on the application design, the user can create a view with panels that contain a different tile combination or arrangement. For example, the ClientDashboard application provides controls and menus that allows users to create new views and panels. They can also add, remove, and change the position of tiles.

Adding and saving views

Depending on the application design, users can create and save custom views. When users click the upper-right corner of a view tab, a menu appears that allows them to save and close, save, or close the view. Saving the view adds it to the organizer panel using the name and description the user provides.

When the user starts a new application session, the default view appears. The user can use the organizer to display or delete the saved views.

The view menu also has an option that allows users to share the current view as a link. To access the saved view using the link, a user needs a Mosaic user account that is configured to use an appropriate role.
Adding panels and tiles
Application designs can allow users to add panels to views, and add tiles to panels, as needed.

When users add tiles to a panel, the tiles are automatically arranged using the layout provided by the application design. For example, the ClientDashBoard application panels use a layout that automatically arranges the tiles in two columns of equal width. Users can change the order of the tiles by dragging them to a new location.

Deleting tiles removes them from the panel, and closing a panel removes it from the view. Mosaic only allows users to save panels as part of a view.

Mosaic users and roles

Mosaic user accounts control access to both Mosaic application development resources and the applications themselves.

The standalone server included with Mosaic is configured such that users are associated with metadata such as first name, last name, e-mail address, and password. The assigned role determines the user’s level of access.

By default, Mosaic supports the following user accounts for the standalone server and clients:

- user
- designer
- padmin
- broker
- advisor

The password for all default users is: password.

The user account is assigned the end-user role allowing access any Mosaic application deployed on the Mosaic server to which they have logged in. It also allows end users to access an application by logging in at the application URL.

The designer account is assigned the designer role. The designer role provides the same permissions as the user role and also allows designers to upload catalogs and application resources and deploy applications.

The padmin account is assigned the role of policy administrator, which allows administrators to manage custom policies on the Mosaic server. The remaining accounts provide various levels of access for demonstration purposes.

If you use the standalone server provided with the Mosaic installation, the default users, and roles are configured for you. For more information on the standalone server, see “Installing and Configuring the Development Environment” on page 7.

If you are using Mosaic with a LiveCycle server, you create the default users and roles. (For the procedures to create users and roles, see “Create Mosaic users for LiveCycle ES2.5” on page 17.) Use LiveCycle ES2.5 to create additional users as needed and assign them the default roles.

Note: When deploying Mosaic to a production server, manually remove the preconfigured users before adding users using the LiveCycle Administration Console. For more information, see “Create Mosaic users for LiveCycle ES2.5” on page 17.

For advanced user and role configuration, see Administering LiveCycle Mosaic 9.5. The administering guide also includes information on configuring Mosaic with custom roles or to work within an enterprise single sign-on (SSO) security infrastructure.
Desktop client for the designer user

For the current release, when you log in to Mosaic as the designer user, you can access preview versions of application development tools. These tools appear in separate windows, called perspectives. They illustrate how the functionality of the desktop client can be extended to include application design and catalog management tasks. The perspectives are not fully functional. Do not use them for production purposes.

To view the design perspective, as the designer user, log in to Mosaic using the desktop client, and then click Create New. Alternatively, in the MyApps tab, scroll to an application in the list and click .

To view the catalog perspective, click Manage Catalogs.

More Help topics

“Installing and Configuring the Development Environment” on page 7
“Installing and Configuring the Production Environment” on page 13
“Sample Applications” on page 22
“Development Walkthrough” on page 26
Chapter 2: Installing and Configuring the Development Environment

Installing the Mosaic development environment includes the installation of client software, a standalone pre-configured Apache Tomcat server, and SDKs.

For information on upgrading from a previous version of Mosaic, see Upgrading to LiveCycle Mosaic 9.5.

For information about installing and configuring Mosaic server software, including requirements for production environments, see “Installing and Configuring the Production Environment” on page 13.

For advanced server customization, including configuring WebDAV security for non-production environments, see Administering LiveCycle Mosaic 9.5.

Development system requirements

To prepare to install Mosaic to a development environment, ensure that the required hardware and software are installed and configured.

Application server

Mosaic provides an Apache Tomcat server that is ready-to-use and suitable for application development. If you provide your own Apache Tomcat server, Mosaic requires the following software:

- Apache Tomcat 6.0.20 or later
- Apache log4j logging framework, version 1.2.14 or later

For software downloads and system requirements, go to the Apache Tomcat website at tomcat.apache.org.

Note: To successfully start the standalone server provided with Mosaic, ensure that your Java™ environment is configured. For example, set your JAVA_HOME and PATH environment variables. For more information, see the Java documentation for your server’s operating system.

In addition, ensure that the following software is installed on servers where you plan to develop or deploy the Mosaic applications:

- Sun Java Software Development Kit 6 (JDK 1.6)
- Apache Ant 1.7.0 or later

Tile development requirements

To create Mosaic tiles using Flex® technology, ensure that the following software is installed:

- Flash® Builder™ 4
- Flex SDK 3.3 or later (for compiling Flex 3.x applications; not used for module tiles)
- Flex SDK 4.1.0 build 16076 (for developing module tiles)

Note: Configure Flash Builder to compile with Flex SDK 3.4 or 4.1. See "Configure Flash Builder with Mosaic SWC files" on page 11.
Client software requirements

To access Mosaic applications using the desktop client, ensure that the following software is installed:

- Adobe AIR 2.0.2 or later

To access Mosaic applications using a web browser, you require one of the following browser applications and a compatible version of Adobe Flash:

- Internet Explorer 7 or later
- Firefox 3.5.4 or later (for Windows), Firefox 3.6 or later (for Mac)
- Adobe Flash Player 10.1 or later

The following table illustrates the supported (S) Mosaic client software:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Browser Client (Flash Player 10.1 or later)</th>
<th>Adobe AIR Client (AIR 2.0.2 or later)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>IE 7</td>
<td>IE 8</td>
</tr>
<tr>
<td>Windows XP SP2 and SP3</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Windows Vista SP0 to SP2</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Windows 7</td>
<td>S</td>
<td>S</td>
</tr>
<tr>
<td>Mac OS 10.5 and 10.6</td>
<td>S</td>
<td>S</td>
</tr>
</tbody>
</table>

All platforms support Flex tiles based on Flex SDK 3.3, 3.4, 3.5, 4.0 and 4.1.

All platforms support Flex module tiles based on Flex SDK 4.1 only.

Note: For HTML tiles, the behavior of the browser client is dependent on the implementation of iFrames within the specific browser.

Installing the Mosaic development environment

Install a development version of Mosaic

1. Copy the file Mosaic.zip from the Mosaic installation media to your machine and extract the contents to a directory. This location is your Mosaic install directory (for example, C:\MOSAIC_HOME).

2. Browse to the standalone/bin folder of the Mosaic install directory (for example, C:\MOSAIC_HOME\standalone\bin).

3. Execute the startup.bat batch file to launch the standalone Tomcat server that is preconfigured as a Mosaic server. For more information on installing and configuring Tomcat, see “Installing and configuring the Mosaic standalone server” on page 9.

4. Using a Command Prompt, navigate to the samples folder of the Mosaic install directory (for example, C:\MOSAIC_HOME\samples).

5. Type ant. This action deploys all Mosaic samples and demos to the standalone server. For more information on the samples, see “Sample Applications” on page 22.

6. Browse to the bin/release folder of the Mosaic installation directory (for example, C:\MOSAIC_HOME\bin\release). Double-click Mosaic.air, and follow the installations that appear to install the Mosaic desktop client. For more information on installing the desktop client, see “Installing the desktop client” on page 10.
Once you have completed the general installation, you can configure your Flash Builder instance to use the Mosaic libraries. For more information, see “Configure Flash Builder with Mosaic SWC files” on page 11.

Test your development installation
1 If it does not start automatically, start the Mosaic desktop client.
2 By default, the Mosaic standalone server is preconfigured to use port 8080. Log in to the server using the following information:
   Mosaic Server: http://localhost:8080
3 Click Connect.
4 By default, the Mosaic standalone server is preconfigured to recognize two unique users: user and designer. For testing purposes, login to the server using the following information:
   Username: designer
   Password: password
5 On the MyApps tab, select the Brokerage application, and then click to start the application.
6 In a web browser, navigate to the following URL: http://localhost:8080/mosaic/#/applications/Brokerage. Login using the following information:
   Username: designer
   Password: password

More Help topics
“Install Mosaic on a Tomcat server that you provide” on page 10
“Installing Mosaic on a LiveCycle server” on page 14
“Create Mosaic users for LiveCycle ES2.5” on page 17
“Sample Applications” on page 22

Installing and configuring the Mosaic standalone server

The Mosaic installation provides you with an Apache Tomcat server. This server is pre-configured and ready to use for deploying the sample Mosaic applications and creating, testing, and deploying new applications. Its out-of-the-box functionality makes it the best choice when you are creating a standalone Mosaic development environment.

You can also install Mosaic on a LiveCycle server to provide a full-featured environment for managing and delivering Mosaic applications. For example, use Mosaic on the standalone server to modify or create applications. To make the applications available to users, upload the catalog and applications to a Mosaic server that resides on a LiveCycle server.

Install the Mosaic standalone server

The Tomcat server that is provided with the Mosaic installation is pre-configured to work with the sample applications and includes the default Mosaic users. It is suitable for a standalone application development environment.

In Windows, run the following batch file:

• [Mosaic install directory]/standalone/bin/startup.bat
Install Mosaic on a Tomcat server that you provide

The standalone server provided with the Mosaic installation is created using Apache Tomcat. Alternatively, you can deploy a Tomcat server and configure it to work with Mosaic.

Use Apache Tomcat version 6.0.20 or later. You can download Tomcat server software from Apache's Tomcat website, [tomcat.apache.org](http://tomcat.apache.org).

The configuration also requires the Apache log4j logging framework, version 1.2.14 or later. You can download log4j from Apache's Logging Services website, [logging.apache.org](http://logging.apache.org).

1. Using a text or XML editor, open 

   
   [Tomcat root]/conf/web.xml

2. Add the following entries to the end of the file:

   ```xml
   <servlet>
     <servlet-name>webdav</servlet-name>
     <servlet-class>org.apache.catalina.servlets.WebdavServlet</servlet-class>
     <init-param>
       <param-name>debug</param-name>
       <param-value>0</param-value>
     </init-param>
     <init-param>
       <param-name>listings</param-name>
       <param-value>true</param-value>
     </init-param>
     <init-param>
       <param-name>readonly</param-name>
       <param-value>false</param-value>
     </init-param>
   </servlet>
   <servlet-mapping>
     <servlet-name>webdav</servlet-name>
     <url-pattern>/repository/*</url-pattern>
   </servlet-mapping>
   ``

3. Copy the file [Mosaic install directory]/deploy/release/mosaic.war to [Tomcat root]/webapps/.

4. Add the log4j.jar file from log4j 1.2.14 or later to [Tomcat root]/lib.

5. Create a log4j.properties or log4j.xml file and add it to [Tomcat root]/lib.

6. If you are using a 32-bit Java Virtual Machine, set the JAVA_OPTS heap memory parameter to at least 128 m. To set the parameter, create a setenv.bat or setenv.sh file in the [Tomcat root]/bin.

Installing the desktop client

The Mosaic desktop client application allows you to access Mosaic applications using Adobe AIR technology.

After you install the desktop client, you can access it using the Windows Start menu (Start > All Programs > Adobe LiveCycle Mosaic). You can also start it using the desktop icon.

1. In the [Mosaic install directory]/bin/release directory, double-click Mosaic.air, and follow the installations that appear.
2 In the Mosaic Server field, type the URL of the Mosaic server (for example, http://localhost:8080).
3 Click Connect.
4 Type a user name and password (for example, user and password) and click Login.

Configure Flash Builder with Mosaic SWC files

Mosaic includes SWC files for both Flex SDK 3.4.0 and 4.1.0. Compile your Flash Builder projects using one of these specific versions of the Flex SDK when creating content for Mosaic.

To configure your Flex SDK to use the Mosaic libraries, use one of the following methods:

- Copy the contents of a Mosaic SDK frameworks folder to the frameworks folder of your Flex SDK instance. You only perform this task once.

- Reference the Mosaic SWC files by creating a linked resource variable in Flash Builder. If you choose this option, you explicitly add the required Mosaic SWC files to each Flash Builder project you create.

Copy the Mosaic SWC files to your Flex SDK

1 Do one of the following:
   - Navigate to the [Mosaic install directory]/sdk/flex/sdk/3.4.0/frameworks/libs folder.
   - Navigate to the [Mosaic install directory]/sdk/flex/sdk/4.1.0/frameworks/libs folder.

2 Copy the required SWC files from the libs folder to the frameworks/libs folder of your corresponding Flex SDK installation. For example:
   - Flash Builder 4 (Windows Vista and Windows 7): C:\Program Files (x86)\Adobe\Adobe Flash Builder 4\sdk/4.1.0\frameworks\libs
   - Flash Builder 4 (Windows XP): C:\Program Files\Adobe\Adobe Flash Builder 4\sdk/4.1.0\frameworks\libs
   - Flex Builder 3: C:\Program Files (x86)\Adobe\Flex Builder 3\sdk\3.4.0\frameworks\libs

Create a reference to Mosaic SWC files in a Flash Builder project

1 In Flash Builder, click Window > Preferences.
2 On the General > Workspace > Linked Resources preference page, click New.
3 In the Name field, type a name for the reference. To use the sample applications provided with Mosaic, type MOSAIC_SDK.
4 Click Folder and navigate to one of the following folders:
   - [Mosaic install directory]/sdk/flex/sdk/3.4.0/frameworks/libs/
   - [Mosaic install directory]/sdk/flex/sdk/4.1.0/frameworks/libs/
5 Click OK twice to close the New Variable and Preferences dialog boxes.
6 Right-click the Flash Builder project and click Properties.
7 Click Flex Build Path.
8 On the Library Path tab, click Add SWC.
9 Browse to one of the following files:
   •  [Mosaic install directory]/sdk/flex/sdks/3.4.0/frameworks/lib/mosaic-tile.swc
   •  [Mosaic install directory]/sdk/flex/sdks/4.1.0/frameworks/lib/mosaic-tile.swc
10 Click Open to add the file to the Build Path Libraries list.
11 Click OK twice to close the Add SWC and Properties dialog boxes.
12 (Optional; for Flash Builder 4.1.0 projects only) If you want to use the Spark component library, on the Library tab, repeat the process for adding an SWC file using the following file. (Mosaic uses this library to add skins and styles to application components.):
   •  [Mosaic install directory]/sdk/flex/sdks/4.1.0/frameworks/mosaic-skin.swc
13 Repeat the process for any additional Flash Builder projects you want to use with Mosaic.

Removing Mosaic from a development environment

To remove Mosaic, remove the Mosaic desktop client and the mosaic.war file from the standalone Tomcat application server.

Remove the desktop client

Use the Windows Add or Remove Programs utility to remove the Mosaic desktop client.

1 Do one of the following:
   •  For Windows XP, click Start > Control Panel > Add or Remove Programs.
   •  For Windows Vista and Windows 7, click Start > Control Panel > Programs > Uninstall a Program.
2 Click Adobe LiveCycle Mosaic and click Remove.
3 Ensure that the following folders and their contents are removed:
   •  Windows XP
     •  C:\Documents and Settings\[username]\Application Data\Adobe\AIR\ELS\com.adobe.mosaic.
   •  Windows Vista and Windows 7
     •  C:\Users\[username]\AppData\Roaming\Adobe\AIR\ELS\ com.adobe.mosaic.

Remove Mosaic server from Tomcat

Remove the mosaic.war file from the [Tomcat root]/webapps directory.

More Help topics

“About Mosaic” on page 1
“Installing and Configuring the Production Environment” on page 13
“Sample Applications” on page 22
“Development Walkthrough” on page 26

Last updated 3/31/2011
Chapter 3: Installing and Configuring the Production Environment

The installation process for the Mosaic server includes preparing for the installation, copying the installation files, deploying Mosaic on a production server, and testing.

For information on upgrading from a previous version of Mosaic, see Upgrading to LiveCycle Mosaic 9.5.

For information on advanced server configuration tasks, see Administering LiveCycle Mosaic 9.5.

System requirements

To prepare to install Mosaic, ensure that the required hardware and software are installed and configured.

Application server

Mosaic provides an Apache Tomcat server that is ready-to-use and suitable for application development. For more information on the Tomcat server provided with Mosaic, see “Installing and configuring the Mosaic standalone server” on page 9.

For a production environment, the following application servers are recommended for Mosaic administration and application deployment.

- LiveCycle ES2.5 for JBoss* (turnkey or non-turnkey), with Service Pack 1 installed
- LiveCycle ES2.5 for IBM® WebSphere®, with Service Pack 1 installed
- LiveCycle ES2.5 for BEA WebLogic Server®, with Service Pack 1 installed

For detailed LiveCycle ES2.5 system requirements, including the recommended hardware requirements, see Preparing to Install LiveCycle ES2.5. In addition to these system requirements, ensure that the following software is installed on servers where you plan to develop or deploy the Mosaic applications:

- Sun Java Software Development Kit 6 (JDK 1.6)
- Apache Ant 1.7.0 or later

Client software requirements

To access Mosaic applications using the desktop client, ensure that all users have the following software installed:

- Adobe AIR 2.0.2 or later

To access Mosaic applications using a web browser, users need one of the following browser applications and a compatible version of Adobe Flash.

- Internet Explorer 7 or later
- Firefox 3.5.4 or later (for Windows), Firefox 3.6 (for Mac)
- Adobe Flash Player 10.1 or later

The following table illustrates the supported (S) Mosaic client software:
Getting Started with LiveCycle MOSAIC 9.5

Installing and Configuring the Production Environment

All platforms support Flex tiles based on Flex SDK 3.3, 3.4, 3.5, 4.0 and 4.1.

All platforms support Flex module tiles based on Flex SDK 4.1 only.

Note: For HTML tiles, the behavior of the browser client is dependent on the implementation of iFrames within the specific browser.

Installing and configuring the Mosaic server

You can install Mosaic on a LiveCycle server to provide a full-featured environment for managing and delivering Mosaic applications. For example, use Mosaic on the standalone server to modify or create applications. To make the applications available to users, upload the catalog and applications to a Mosaic server that resides on a LiveCycle server.

Installing Mosaic on the standalone server

The Mosaic installation provides you with an Apache Tomcat server. This server is pre-configured and ready to use for deploying the sample Mosaic applications and creating, testing, and deploying new applications. Its out-of-the-box functionality makes it the best choice when you are creating a standalone Mosaic development environment. For more information on installing the standalone server, see “Installing and configuring the Mosaic standalone server” on page 9.

Installing Mosaic on a LiveCycle server

A LiveCycle server is the preferred method for deploying production-ready Mosaic applications.

To complete the Mosaic installation on LiveCycle ES2.5, you create Mosaic users. The designer role allows you to design and manage Mosaic applications. The user role allows users to access applications.

Before installing Mosaic, ensure that your environment meets the software and hardware requirements (see “System requirements” on page 13 and LiveCycle server documentation).

Mosaic supports two logging frameworks: Sun Java JDK and Apache log4j. The following table specifies whether additional configuration is required for a logging framework to work with your server:

<table>
<thead>
<tr>
<th>Logging framework</th>
<th>WebSphere Server configuration</th>
<th>WebLogic Server configuration</th>
<th>JBoss configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sun Java JDK</td>
<td>none</td>
<td>none</td>
<td>n/a</td>
</tr>
<tr>
<td>Apache log4j</td>
<td>required</td>
<td>required</td>
<td>none</td>
</tr>
</tbody>
</table>

For configuration details, see your application server documentation.
Copy the installation files

Copy the file Mosaic.zip from the Mosaic installation media to your server and extract the contents to a directory. This location is your Mosaic install directory (for example, C:\MOSAIC_HOME).

Install Mosaic on LiveCycle ES2.5 for JBoss (turnkey and non-turnkey)

After you copy the WAR file to JBoss Application Server, it deploys Mosaic automatically. JBoss Application Server can be running or stopped when you copy the files to the directory.

1. Copy one of the following files:
   - [Mosaic install directory]/deploy/war/log4j-logging/release/mosaic.war
   - [Mosaic install directory]/deploy/war/jdk-logging/release/mosaic.war

   To one of the following directories:
   - [LiveCycleES2.5 root]/jboss/server/lc_turnkey/deploy
   - [LiveCycleES2.5 root]/jboss/server/all/deploy

2. If you want to view a sample application to verify the installation, deploy the ClientInfo.war file for a sample application to one of the following directories:
   - [LiveCycleES2.5 root]/jboss/server/lc_turnkey/deploy (turnkey)
   - [LiveCycleES2.5 root]/jboss/server/all/deploy (non-turnkey)

   ClientInfo.war files are located in the [Mosaic install directory]/samples/[application_name]/tiles/ClientInfo folder.

3. Start or restart the server to ensure that Mosaic starts correctly.

4. To test whether Mosaic is running, in a web browser, type the following URL:
   http://<server_name>:8080/mosaic/about

Install Mosaic on LiveCycle ES2.5 for WebSphere

1. In the WebSphere Administrative Console navigation tree, click Applications > New Application. In the New Application list, click New Enterprise Application.

2. Select Local File System or Remote File System, and then Browse to the location of one of the following files:
   - [Mosaic install directory]/deploy/war/log4j-logging/release/mosaic.war file
   - [Mosaic install directory]/deploy/war/jdk-logging/release/mosaic.war file

   Note: Configure WebSphere to work with log4j (see your application server documentation)

3. Select the mosaic.war file, click Open, and then click Next.

4. Ensure that Fast Path is selected and then click Next.

5. For each of the following pages, use the default values and click Next.
   - Select Installation Options
   - Map Modules to Servers
   - Map Virtual Hosts for Web Modules

6. On the Map Context Roots for Web Modules page, for Context Root, enter /mosaic, and then click Next.

7. On the Summary page, click Finish.

8. When the deployment process is complete, in the message Save Directly to the Master Configuration, click the Save link.

Last updated 3/31/2011
In the WebSphere Administrative Console navigation tree, click Applications > Application Types > WebSphere Enterprise Applications.

If you want to deploy a sample application to verify the installation, repeat the procedure to deploy a ClientInfo.war file. ClientInfo.war files for the sample applications are located in the [Mosaic install directory]/samples/[application_name]/tiles/ClientInfo folder.

Note: WebSphere 6.1.0.21 needs additional configuration to work with Mosaic (see “Configure WebSphere 6.1.0.21 for Mosaic” on page 16).

Configure WebSphere 6.1.0.21 for Mosaic

1 In the WebSphere Administrative Console navigation tree, click Servers > Server Types > WebSphere Application Servers. Under Application Servers, click the name of the server to configure.

2 Under Container Settings, click Web Container Settings > Web Container.

3 Under Additional Properties, click Custom Properties.

4 Click New and in the Name box, type com.ibm.ws.webcontainer.invokefilterscompatibility. For Value, type true. Click OK.

5 In the message Save Directly to the Master Configuration, click the Save link.

6 Restart WebSphere.

7 To test whether Mosaic is running, in a web browser, type the following URL:

   http://<server_name>:8080/mosaic/about

Install Mosaic on LiveCycle ES2.5 for WebLogic

1 To access the WebLogic Server Administration Console, type http://[host name]:[port]/console in the URL line of a web browser (for example, http://localhost:7001/console).

2 Type the WebLogic Server configuration user name and password and click Log In.

3 Under Change Center, click Lock & Edit.

4 Under Domain Structure, click Deployments.

5 In the Summary of Deployments pane, click Install.

6 Under the heading Locate Deployment to Install and Prepare for Deployment, in the Note text, click the link Upload Your Files(s).

7 Beside the Deployment Archive box, click Browse. Navigate to the location of one of the following files:

   - [Mosaic install directory]/deploy/war/log4j-logging/release/mosaic.war file
   - [Mosaic install directory]/deploy/war/jdk-logging/release/mosaic.war file

   Note: Configure WebLogic to work with log4j (see your application server documentation).

8 Select the mosaic.war file, click Open, and then click Next.

9 On the Locate Deployment to Install and Prepare for Deployment page, click Next.

10 Select Install this deployment as an application and click Next.

11 Select the server where you are deploying Mosaic and click Next.

12 For Optional Settings, use the default values, and then click Finish.
13 Under Change Center, click Activate Changes.

14 In the Summary of Deployments list, select mosaic, and then click Start > Servicing All Requests. Click Yes.

15 In the Summary of Deployments list, ensure that the Health value for mosaic is OK.

16 If you want to deploy a sample application to verify the installation, repeat the procedure to deploy a ClientInfo.war file. ClientInfo.war files for the sample applications are located in the [Mosaic install directory]/samples/[application_name]/tiles/ClientInfo folder.

17 To test whether Mosaic is running, in a web browser, type the following URL:

   http://<server_name>:8080/mosaic/about

**Configure SSL for Mosaic**

Configure Mosaic to communicate with WebDAV using SSL when:

- SSL is enabled ("Configuring SSL" in LiveCycle ES2.5 Administration Help)
- You access Mosaic using https (for example, by logging in to https://example.com:8080/mosaic/)

To configure SSL for Mosaic, import the required SSL credential into the Java Runtime Environment (JRE) default keystore.

Use the root certificate of the WebDAV server specified in the mosaic-context.xml file. The mosaic-context.xml file is located in the mosaic.war file you used to deploy Mosaic, in the directory META-INF/spring/mosaic-context.xml.

For example, the following Java keytool command imports a self-signed certificate (LC_cert.cer, alias "LC Cert") into the JBoss keystore:

```
keytool –import –alias "LC Cert" –keystore JAVA_HOME\jre\lib\security\cacerts –file LC_cert.cer
```

Application servers provide alternative methods for customizing trust stores. See your application server documentation for more information on implementing SSL.

**Create Mosaic users for LiveCycle ES2.5**

To allow users access to Mosaic applications, manually configure users and roles on the application server that hosts the Mosaic server. Once you create users and roles, you can create policies that define what assets users are entitled to access.

Before you begin, by default, Mosaic includes predefined users that are configured for the purposes of deploying and running the sample applications. These users are for development, debugging, and testing purposes only. Remove these users before creating users for use with LiveCycle ES2.5.

**Remove preconfigured users from Mosaic**

1. Locate the mosaic.war file for your environment. By default, [Mosaic installation directory]/deploy/war/jdk-logging/release or [Mosaic installation directory]/deploy/war/log4j-logging/release.

2. Open the mosaic.war file, and locate the mosaic-context.xml file included in the META-INF/spring subfolder of the WAR file.

3. Remove the following code (indicated in bold below) from the mosaic-context.xml file:
<?xml version="1.0"?>
<security:authentication-manager>
  <security:authentication-provider ref='mosaicAuthenticationProvider'/>
  <!-- IMPORTANT: REMOVE THE FOLLOWING security:authentication-provider ELEMENT BEFORE PRODUCTION SERVER DEPLOYMENT -->
  <security:authentication-provider>
    <security:user-service>
      <security:user name="user" password="password" authorities="ROLE_MOSAIC_END_USER" />
      <security:user name="designer" password="password" authorities="ROLE_MOSAIC_DESIGNER"/>
      <security:user name="padmin" password="password" authorities="ROLE_MOSAIC_POLICY_ADMINISTRATOR"/>
      <security:user name="broker" password="password" authorities="ROLE_MOSAIC_BROKER"/>
      <security:user name="advisor" password="password" authorities="ROLE_MOSAIC_ADVISOR"/>
    </security:user-service>
  </security:authentication-provider>
</security:authentication-manager>

Create Mosaic users for LiveCycle ES2.5

1. Open a web browser and enter the URL for the LiveCycle Administration Console. For example, for a JBoss server the URL is http://localhost:8080/adminui (local deployment using the default port).
2. Enter your user name and password and click Login. For example, the default user name and password are administrator and password.
3. In LiveCycle Administration Console, click Settings > User Management > Users and Groups.
4. Click New User.
5. Under General Settings, provide the user information, and then click Finish. For example:
   - First Name: Mosaic
   - Last Name: Designer
   - User Id: designer
   - Password: password
   - Confirm password: password
6. Click New User.
7. Under General Settings, provide the user information, and then click Finish. For example:
   - First Name: Mosaic
   - Last Name: User
   - User Id: user
   - Password: password
GETTING STARTED WITH LIVECYCLE MOSAIC 9.5
Installing and Configuring the Production Environment

• Confirm password: password

8 Click New User.

9 Under General Settings, provide the user information, and then click Finish. For example:
   • First Name: Mosaic
   • Last Name: Policy Admin
   • User Id: padmin
   • Password: password
   • Confirm password: password

Assign roles to the Mosaic users
If you configure Mosaic to use SAML for WebDAV authentication, Mosaic users need different permissions (see “Configuring WebDAV security” in Administering LiveCycle Mosaic 9.5).

1 Open a web browser and enter the URL for the LiveCycle Administration Console.
   For example, for a JBoss server the URL is http://localhost:8080/adminui (local deployment using the default port).

2 Enter your user name and password and click Login.
   For example, the default user name and password are administrator and password.

3 In LiveCycle Administration Console, click Settings > User Management > Role Management.

4 Click New Role.

5 Under General Settings, for Role Name, type ROLE_MOSAIC_DESIGNER and then click Next.

6 Under Find Permissions, select Repository Read, Repository Traverse, Repository Write and Service Invoke, and then click OK.

7 Click Next.

8 Under Role Users, click Find Users/Groups.

9 Under Find Users and Groups, click Find, and then select the user name of the designer user (for example, Mosaic Designer).

10 Click OK, and then click Finish.

11 Repeat the procedure to create the roles ROLE_MOSAIC_END_USER and ROLE_MOSAIC_POLICY_ADMINISTRATOR. Assign ROLE_MOSAIC_END_USER to Mosaic User and ROLE_MOSAIC_POLICY_ADMINISTRATOR to Mosaic Policy Admin. Select the same permissions as you did for ROLE_MOSAIC_DESIGNER.

Opening a Mosaic application

Open an application using the desktop client

1 Do one of the following:
   • Click All Programs > Adobe LiveCycle Mosaic.
   • Click the Mosaic desktop icon.

2 Type the URL of the Mosaic server (for example, http://localhost:8080).
3 Enter a user name and password (for example, user and password) and click Login.
4 On the MyApps tab, scroll until the application you want to open appears.
5 In the application item, click  .

Open an application using a web browser

The pattern for Mosaic application URLs is http://localhost:8080/mosaic/#/applications/[application name]. In this pattern, [application name] is the name attribute specified when the application is deployed to the Mosaic server. For example, the URL for the Basic application is http://localhost:8080/mosaic/#/applications/Basic.

If you deployed sample applications and demos, you can access them using the Mosaic client or a web browser.

For the URLs to access the sample applications, see “Accessing Mosaic sample applications” on page 23.

1 In the browser address field, type the URL of the application.
2 Enter a user name and password (for example, user and password) and click Login.

Removing Mosaic from a production environment

To remove Mosaic, remove the Mosaic desktop client and the mosaic.war file from the application server.

Remove the desktop client

Use the Windows Add or Remove Programs utility to remove the Mosaic desktop client.

1 Do one of the following:
   • For Windows XP, click Start > Control Panel > Add or Remove Programs.
   • For Windows Vista, click Start > Control Panel > Programs and Features.
   • For Windows 7, click Start > Control Panel > Uninstall a program.
2 Click Adobe LiveCycle Mosaic and click Remove.

Remove Mosaic from LiveCycle ES2.5 from Tomcat

❖ Remove the mosaic.war file from the [Tomcat root]/webapps directory.

Remove Mosaic from LiveCycle ES2.5 for JBoss (turnkey or non-turnkey)

1 Remove the mosaic.war file from one of the following directories:
   • [LiveCycleES2.5 root]/jboss/server/lc_turnkey/deploy
   • [LiveCycleES2.5 root]/jboss/server/all/deploy
2 Restart JBoss.

Remove Mosaic from LiveCycle ES2.5 for WebSphere

1 In the WebSphere Administrative Console navigation tree, click Applications > Application Types > WebSphere Enterprise Applications.
2 In the Enterprise Applications list, select mosaic_war and click Stop.
3  Select mosaic_war, click Uninstall, and then click OK.
4  In the message Save Directly to the Master Configuration, click the Save link.

**Remove Mosaic from LiveCycle ES2.5 for WebLogic**

1  To access the WebLogic Server Administration Console, type `http://[host name]:[port]/console` in the URL line of a web browser (for example, http://localhost:7001/console).
2  Type the WebLogic Server configuration user name and password and click Log In.
3  Under Change Center, click Lock & Edit.
4  Under Domain Structure, click Deployments.
5  In the Summary of Deployments list, select mosaic, and then click Stop > Force Stop Now. Click Yes.
6  In the Summary of Deployments list, select mosaic, and then click Delete. Click Yes.
7  Under Change Center, click Activate Changes.

**More Help topics**

“About Mosaic” on page 1

“Installing and Configuring the Development Environment” on page 7

“Sample Applications” on page 22

“Development Walkthrough” on page 26
Chapter 4: Sample Applications

The sample applications demonstrate Mosaic functionality using real-world content and tasks. The samples are fully functional and you can use them to create your own applications.

To access Mosaic sample applications, deploy the samples to the standalone Tomcat server included with Mosaic. Or you can deploy them to a Mosaic server deployed to LiveCycle ES2.5. Ensure that the sample roles and users are defined on the server before you attempt to access the samples.

Deploying the sample applications

Use the Ant build files provided with the Mosaic installation to deploy sample applications to the server. By default, the build files are configured to deploy the samples to a Mosaic server using the following values:

```xml
<property name="protocol" value="http" />
<property name="server" value="localhost" />
<property name="port" value="8080" />
<property name="username" value="designer" />
<property name="password" value="password" />
```

Before you begin, ensure that you have Ant 1.7.0 or later installed.

To deploy to a different server location, modify the Ant build files with the new information before running Ant. You can also modify the Ant build files to use a different user or password.

To run Ant, type `ant` from the command line. When you do not provide arguments, Ant looks for a build.xml file in the current directory.

**Note:** If you encounter a timeout error while deploying sample applications or catalogs, add a maxwait attribute with a large value to the corresponding build.xml file. For example, the following change to the build.xml file located in the `Mosaic installation directory/samples/general` folder sets the maxwait attribute value to 60000000000 seconds:

```xml
<mosaic-application action="import"
    name="Basic"
    file="applications/Basic.xml"
    property="response"
    protocol="${protocol}"
    server="${server}"
    port="${port}"
    username="${username}"
    password="${password}"
    maxwait="60000000000" />
```

<table>
<thead>
<tr>
<th>Sample application to deploy</th>
<th>Directory in which to run Ant</th>
</tr>
</thead>
<tbody>
<tr>
<td>All samples and demos</td>
<td>[Mosaic install directory]/samples/</td>
</tr>
</tbody>
</table>
Accessing Mosaic sample applications

Once you deploy Mosaic samples to a Mosaic server, you can access the sample applications using the desktop client or browser client. The desktop client displays all deployed applications on the My Apps tab. To access sample applications using the browser client, type `http://[host name]:[port]/mosaic/#/applications/[application name]` in the URL line of a web browser. The application name corresponds to the name attribute specified in the Ant task used to deploy the application to the Mosaic server. For example, if you installed Mosaic on the standalone server, you can use the following URLs to connect to the sample applications:

<table>
<thead>
<tr>
<th>Sample application to deploy</th>
<th>Directory in which to run Ant</th>
</tr>
</thead>
<tbody>
<tr>
<td>General sample applications (Basic Application, Brokerage, HTML Example, Style Example, and TileGame)</td>
<td><code>Mosaic install directory)/samples/general/</code></td>
</tr>
<tr>
<td>ClientDashboard and SlateDashboard applications</td>
<td><code>Mosaic install directory)/samples/clientDashboard/</code></td>
</tr>
<tr>
<td>mockDataService application</td>
<td><code>Mosaic install directory)/samples/stockDataService/</code></td>
</tr>
</tbody>
</table>
### Sample Applications

<table>
<thead>
<tr>
<th>Application</th>
<th>Description</th>
<th>Browser Client Default URL</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basic Application</td>
<td>The Basic application illustrates how to send messages and set context properties.</td>
<td><a href="http://localhost:8080/mosaic/#/applications/Basic">http://localhost:8080/mosaic/#/applications/Basic</a></td>
</tr>
<tr>
<td>Brokerage</td>
<td>The Brokerage application allows you to manage portfolios for a list of contacts. When you select a contact in the Contacts tile, you can use the Portfolio tile to add or remove stocks from the selected contact’s portfolio. The Google Finance information for the stock that is selected in the Portfolio tile appears in the stock information tile.</td>
<td><a href="http://localhost:8080/mosaic/#/applications/Brokerage">http://localhost:8080/mosaic/#/applications/Brokerage</a></td>
</tr>
</tbody>
</table>
| Client Dashboard | The ClientDashboard application is a customer service desk that contains the tiles with the following functions:  
- Track open cases  
- Track bugs related to specific cases  
- Display detailed information about a client associated with a particular case  
- Display overall issue statistics for a client associated to a particular case  
When you change the case in the open cases tile, the other tiles are updated to display information that is associated with the case. | http://localhost:8080/mosaic/#/applications/ClientDashboard       |
| HTML Example     | The HTML Example application provides an HTML version of the Mosaic desktop client. You can launch sample applications, download Adobe AIR, and confirm the versions of the Mosaic client and server software. | http://localhost:8080/mosaic/#/applications/Default              |
| mockStockService | An example of loading a "service" before loading any tiles within an application. The service example illustrates how to create functionality outside a tile and then use the features across multiple tiles. | http://localhost:8080/mosaic/#/applications/mockStockService     |
To access the samples, you enter a user account and password. For example, the default user accounts include user and designer, which both use password as their password. For more information, see “Mosaic users and roles” on page 5.

**More Help topics**

“About Mosaic” on page 1

“Installing and Configuring the Development Environment” on page 7

“Installing and Configuring the Production Environment” on page 13

“Development Walkthrough” on page 26
Chapter 5: Development Walkthrough

Familiarize yourself with how Mosaic works by walking through the development of example tiles, catalogs, and applications.

Before you begin the walkthrough, ensure that you have successfully completed at least the “Installing and Configuring the Development Environment” on page 7 procedures. In addition, ensure that all required software is installed correctly.

Importing sample tiles

You develop Mosaic component applications, called tiles, using third-party applications such as Flash Builder or HTML. To use the tiles in an application, you import them into a Mosaic catalog. Once they are part of a Mosaic application, Flex and HTML tiles can, for example, share context objects. The Mosaic installation provides sample Flex and HTML tiles that illustrate how tiles work.

Import Flex sample tiles

The Mosaic installation includes sample tiles that use Flex technology. They are pre-compiled and added to the general sample_catalog, dashboard_catalog, and stockDataService_catalog catalogs.

After you configure the Mosaic libraries and import the projects, the tiles appear in the Flex Navigator view. You can review these samples to see how the Mosaic Tile SDK works, including how to perform advanced calls.

1. In Flash Builder, click File > Import > Other.
2. Select General > Existing Projects Into Workspace and click Next.
3. Click Browse and navigate to the Mosaic installation directory (for example, MOSAIC_HOME). In the Mosaic installation directory, select the samples folder and click OK.
4. Click Finish.

Import HTML sample tiles

The HTML sample tiles provided with the Mosaic installation illustrate how you can modify existing internal websites for use in a Mosaic application.

To use the HTML sample tiles, you need access to a web server where you can place the HTML files and run a JavaScript file. For example, you can use a local Apache Tomcat instance running on the same computer as the Mosaic AIR client application.

When you install the Mosaic standalone server, the server installation deploys the HTML tiles. To install the HTML tiles on a different server, use the following procedures.

Install the HTML tiles on an Apache Tomcat server

❖ Copy the following WAR files to the [Tomcat root]/webapps directory:
  • [Mosaic install directory]/samples/general/tiles/BasicHTML/BasicHMLTiles.war
  • [Mosaic install directory]/samples/clientDashboard/tiles/ClientInfo/ClientInfo.war

Last updated 3/31/2011
Install the HTML tiles on LiveCycle ES2.5 for JBoss (turnkey and non-turnkey)
❖ Copy one of the following WAR files to the [LiveCycleES2.5 root]/jboss/server/lc_turnkey/deploy directory:
   • [Mosaic install directory]/samples/general/tiles/BasicHTML/BasicHTMLTiles.war
   • [Mosaic install directory]/samples/clientDashboard/tiles/ClientInfo/ClientInfo.war

Install the HTML tiles on a server (general instructions)
For more information about deploying HTML files on your web server, see your server documentation.

By default, the location of the HTML specified in the sample catalogs is http://localhost:8080 (the default Mosaic server URL). If you deploy the sample HTML files to a different location, update the HTML tile entries in the catalogs.

1 Copy the contents of the following folders to a web server other than where Mosaic is installed:
   • [Mosaic install directory]/samples/general/tiles/BasicHTML/
   • [Mosaic install directory]/samples/clientDashboard/tiles/ClientInfo/ClientInfo/

2 In an XML editor, open [Mosaic install directory]/samples/general/catalogs/descriptor.xml.

3 For the following entries, change the value of the uri attribute to the appropriate web server location, and save your changes:
   • MessagePassing
   • SimpleContext

4 Open [Mosaic install directory]/samples/clientDashboard/catalogs/descriptor.xml.

5 For the ClientInfo entry, change the value of the uri attribute to the appropriate web server location, and save your changes.

6 Redeploy the catalogs and sample applications to your server. For detailed instructions, see Developing Applications for LiveCycle Mosaic 9.5.

Building your first Flash tile

In general, you use the following basic steps to create a Flash tile:
• Create a Flex project and compile a SWF file
• Add the tile (SWF file) to a catalog
• Add the tile to an application
• Deploy the tile, catalog, and application to the Mosaic server

Create Flex Project and Compile a SWF file
1 Launch Flash Builder.
2 Click File > New > Flex Project.
3 Give your project a name.
4 Ensure that Web Application is selected from the Application type radio button group.
5 Click Finish.
6 Right-click on your new project and click Properties.
7 Click Flex Build Path.
8 Select the Library path tab.

9 Click Add SWC.

10 Type ${MOSAIC_SDK}/sdk/flex/sdks/4.1.0/mosaic-tile.swc.

11 Once the project is created and the default MXML application loads, add the namespace mc="com.adobe.mosaic.core.*" to your application tag (the namespace "mx" shown below is from Flex 3.4; in Flex 4.x the namespaces have changed):

```xml
<?xml version="1.0" encoding="utf-8"?>
               xmlns:s="library://ns.adobe.com/flex/spark"
               xmlns:mx="library://ns.adobe.com/flex/mx"
               xmlns:mc="com.adobe.mosaic.core.*"
               layout="absolute" />
</mx:Application>
```

12 Change the root tag from mx:Application to mc:Tile

```xml
<?xml version="1.0" encoding="utf-8"?>
         xmlns:s="library://ns.adobe.com/flex/spark"
         xmlns:mx="library://ns.adobe.com/flex/mx"
         xmlns:mc="com.adobe.mosaic.core.*"
         layout="absolute" />
</mc:Tile>
```

13 Add a label object to the tile definition:

```xml
<?xml version="1.0" encoding="utf-8"?>
         xmlns:s="library://ns.adobe.com/flex/spark"
         xmlns:mx="library://ns.adobe.com/flex/mx"
         xmlns:mc="com.adobe.mosaic.core.*"
         layout="absolute" >
  <s:Label text="Hello World!" />
</mc:Tile>
```

14 In the Flex Navigator view, right-click the project, and then click Properties.

15 Click Flex Compiler.

16 For Additional Compiler Arguments, enter the following argument:

```
-lang:en_US -includes=mx.managers.systemClasses.MarshallingSupport -static-link-runtime-shared-libraries=true
```

17 Click Flex Build Path. On the Library Path tab, for Framework linkage, select Merged Into Code.

Add a tile to a catalog

1 Locate the [Mosaic install directory]/samples/general/catalogs/Tiles folder.

2 Create a subfolder named [YourTileName] and copy the newly compiled SWF file tile from your bin-debug directory to this new folder. Make note of the filename which is required in a later step.

Note: [Your Tile Name] is the filename of the tile without the extension. For example, if the tile filename is MyTile.swf, then set the name of the subfolder and the tile to MyTile.
3 Open the [Mosaic install directory]/samples/general/catalogs/descriptor.xml file with a text or XML editor. The file descriptor.xml is the catalog that contains the sample applications provided with Mosaic.

4 Inside the <tile:TileClassList> element place a new <tile:TileClass> element with a name attribute equal to [YourFileName].

```xml
<tile:TileClass
    initialHeight="400"
    initialWidth="680"
    name="[YourTileName]"
    label="[YourLabelName]"
    catalog="sampleCatalog"
    fitContent="true">
    <crx:Metadata>
        <crx:Description>Your first tile.</crx:Description>
        <crx:Category>Component</crx:Category>
        <crx:Tag>component</crx:Tag>
    </crx:Metadata>
    <tile:Content loadAs="default"
        contentType="application/x-shockwave-flash"
        uri="/mosaic/catalogs/sample_catalog/tiles/[YourTileName]/content"/>
</tile:TileClass>
```

Because the tile is based on an application that is built using Flex, for the tile:Content element, the value of loadAs is "default". For tiles based on Flex modules, set loadAs to "module".

**Deploy the catalog and application to the server**

1 Add the contents of the folder [Mosaic install directory]/samples/general/catalogs to a ZIP archive. The default content of the catalogs folder is the Resources, Stylesheets, and Tiles folders, and the file descriptor.xml.

   For example, for a Windows operating system, select the contents of [Mosaic install directory]/samples/general/catalogs, and then click Send To > Compressed (Zipped) Folder. This process creates the ZIP archive descriptor.zip.

2 Use the mosaic-catalog ant task to import the ZIP archive to the server.

3 In the [Mosaic install directory]/samples/general/applications folder, create a copy of Default.xml, and rename it [YourApplicationName].xml.

4 Edit [YourApplicationName].xml to reference your tile. For example:
5 Edit the file [Mosaic install directory]/samples/general/build.xml to deploy your application using the following values:

```xml
<target name="deploy-applications">
<mosaic-application action="import"
   name="[YourTileName]"
   file="applications/[YourTileName]"
   property="response"
   protocol="${protocol}"
   server="${server}"
   port="${port}"
   username="${username}"
   password="${password}" />
<echo message="${response}" />
</target>
```

6 To deploy your application, run Ant in the directory [Mosaic install directory]/samples/general/.

7 Open the application in the Mosaic desktop client, or the Mosaic browser client using the URL http://localhost:8080/mosaic/#/applications/[YourApplicationName].

### Debugging Flash tiles in the browser client

Before you begin, ensure that:

- You are using a debug build of the browser client by deploying the debug mosaic.war file located in the [Mosaic installation directory]/deploy/war/debug/log4j-logging folder. The standalone Tomcat is delivered with the release version of mosaic.war file in the webapps folder of the Mosaic server.
- The latest debug version of your tile has been deployed to the Mosaic server.
- An application which uses the tile has also been deployed.

1 In the source view within Flash Builder, right-click and then select Debug As > Debug Configurations.

2 Select a debug configuration, or create a configuration by double-clicking Web Application.

3 In the URL Or Path To Launch section, deselect Use Default and type the URL to your Mosaic application. For example: http://localhost:8080/mosaic/#/applications/Brokerage.

4 Click debug.

Your Mosaic application launches in the browser client and you can debug your tiles.
Build your first HTML tile

You can integrate web pages that you do not own or control into a Mosaic application. To do so, you require a fixed URL pattern that you can map one or many context objects into.

1. Locate the [Mosaic install directory]/samples/general/catalogs folder.
2. Edit the file descriptor.xml.
3. Add a new <tile:TileClass> tag inside the <tile:TileClassList> node:

   ```xml
   <tile:TileClass name="GoogleFinance"
       maxHeight="1200"
       maxWidth="1200"
       minHeight="400"
       minWidth="400"
       maintainAspectRatio="true"
       initialHeight="400"
       initialWidth="400"
       label="GoogleFinance"
       catalog="sampleCatalog">

   <crx:Metadata>
       <crx:Description>Google Finance</crx:Description>
       <crx:Category>Component</crx:Category>
       <crx:Tag>component</crx:Tag>
       <crx:Tag>generic</crx:Tag>
   </crx:Metadata>

   <tile:Content contentType="text/html"
       uri="http://www.google.com/finance?client=ob&q=${application.symbol}"
   />

   </tile:TileClass>
   ```

Comparing the Mosaic ActionScript and JavaScript APIs

In general, JavaScript method signatures are the same as the equivalents in ActionScript. For example, the type restrictions cited in ActionScript are the same as for JavaScript. However, you do not have access to the same object and variable types.

For example, if you want to send a message that has an Array as the payload the following are the ActionScript and JavaScript code snippets differences:

```actionscript
/* ActionScript */
function sendMyMessage():void {
    var payload:Array = new Array();
    payload[0] = "foo";
    payload[1] = "bar";
    payload[2] = 23213;
    var m:Message = new Message("myNameSpace","messageName",payload)
    mosaicApp.sendMessage(m);
}
```

The equivalent in JavaScript looks like the following code snippet:
// JavaScript
function sendMyMessage():void {
  var payload = new Array();
  payload[0] = "foo";
  payload[1] = "bar";
  payload[2] = 23213;
  var m = new Object();
  m.nameSpace = "myNameSpace";
  m.name = "messageName";
  m.payload = payload;
  mosaicApp.sendMessage(m);
}

For more information on the Mosaic ActionScript, see ActionScript 3.0 Reference for the Adobe Flash Platform. For information on JavaScript APIs, see LiveCycle Mosaic 9.5 JavaScript Language Reference.

More Help topics

“About Mosaic” on page 1

“Installing and Configuring the Development Environment” on page 7

“Installing and Configuring the Production Environment” on page 13

“Sample Applications” on page 22