Exporting and importing projects

Flash Builder exports Flex projects and Flex library projects in the FXP format. ActionScript projects can only be exported as an archive file, typically in ZIP format.

The FXP format is an archive format that includes project folders, files, and metadata about the project. An exported project includes all dependent Flex library projects.

Note: You can also use the Eclipse Export wizard to export Flex projects and Flex library projects in ZIP format or other archive formats.

When exporting or importing a Flex project, some contents of the project require special handling.

  • Different versions of the Flex SDK

    You can import a Flex project that references a version of the Flex SDK that is not installed with your Flash Builder installation. See Installed Flex SDKs for information on downloading and installing additional versions of the Flex SDK.

    If Flash Builder cannot find a specific version of the Flex SDK, a dialog opens allowing you to browse to the SDK.

    After installing the correct version of the Flex SDK, browse to the location.

  • service files

    Flex projects that connect to data services contains a services folder that contains links to deployed service files. When exporting the project, Flash Builder exports the links but not the deployed services. Upon import, manually deploy the service files and update the links as necessary.

    For projects that connect to services using LiveCycle Data Service or BlazeDS, make sure that service destinations are available on the target server.

    For projects that reference local files, upon import deploy the local files using the same path in the original project. This applies to projects accessing static XML service files or local files for HTTP services or web services.

  • Zend Framework

    Flex projects that connect to data services using PHP and the Zend Framework contain two configuration files. Upon import, examine these files to make sure that they are configured properly for your system:

    amf-config.ini

    gateway.php

    See Installing Zend Framework for information on installing, configuring, and troubleshooting your Zend Framework installation.

  • Data model files (LiveCycle Data Services)

    A Flex project that uses LiveCycle Data Services (LCDS) links to a data model file.

    Upon export and subsequent import, Flash Builder references the actual data model file and not a link to it. If you want to use a linked file, and not the one packaged with the exported project, then change the data model file using project properties. Select Project > Properties > Data Model and make the changes.

Export a Flex project or Flex library project as an FXP file

The menus for this procedure vary slightly between the standalone and plug-in configurations of Flash Builder.

Some Flex projects require special handling upon import. See Exporting and importing projects.

  1. In Flash Builder, select File > Export Flex Project (FXP).

    If you have the plug-in version of Flash Builder, select File > Export > Flash Builder > Flash Builder Project.

    You can also use the context menu for a project in the Package Explorer. Select Export > Flash Builder > Flash Builder Project.

  2. In the Export Flex Project wizard, select the project to export.

    All available projects for export are listed in the Project pop-up menu.

  3. (Optional) Enable Validate Project compilation.

    Use this option to confirm that your project compiles without errors. If there are errors, you can still export the project.

  4. Click Finish.

    For server projects, absolute paths to server resources are saved as path variables. When you later import the project, you specify values for the path variables.

Export an ActionScript project in ZIP format (or other archive format)

  1. In Flash Builder, select File > Export > Other.

  2. In the Export wizard, select General > Archive File. Click Next.

  3. In the Export wizard select the project and files to export:

    • In the leftmost panel, expand the project to specify project folders to include

    • In the rightmost panel, for each selected folder, specify the files to include.

  4. Browse to a location to save the exported project and specify a filename.

  5. Specify archive file options and click Finish.

Importing projects

Flash Builder can import Flex projects, Flex library projects, and ActionScript projects. Projects can be imported from existing project folders or from files that were previously exported from Flash Builder. You can import multiple versions of the same Flex project or Flex library project. After importing multiple versions, you can compare the versions and copy or merge differences.

Projects requiring special handling

Some Flex projects require special handling upon import. For example:

  • The project references an earlier version of the Flex SDK

  • The project references service files for access to data

  • The Zend Framework configuration for access to PHP services needs to be updated

  • The project uses LiveCycle Data Services (LCDS) links to a data model file.

See Exporting and importing projects for information on projects that require special handling.

Support for Catalyst projects

Flash Builder provides development support to application designers using Adobe® Flash® Catalyst™. Catalyst exports a project as an FXP file. Catalyst exports components in as an FXPL file. An FXPL file is a library package. The FXP and FXPL files can then be imported into Flash Builder for development. For FXP files, the resulting project is a Flex web project that runs in Adobe Flash Player. An FXPL file contains a library file. You can import an FXPL files as a Flex library project or you can import the contents into an existing Flex project.

You can create an Adobe AIR project from a Catalyst project. Import the FXP file for the Catalyst project into Flash Builder. Convert the application type for the project from Web (runs in Adobe Flash Player) to Desktop (runs in Adobe AIR). See Changing Flex projects to Adobe AIR projects.

Importing a Flex project or Flex library project

You can import a project from an exported FXP file or by navigating to a folder containing the project.

Note: See Importing a Catalyst FXPL project for information on importing the contents of a library project into another Flex project. An FXPL project is a library project created by Adobe Catalyst.

The menus available for this procedure vary slightly for the plug-in configuration of Flash Builder.

  1. From the Flash Builder menu, select File > Import FXP.

    If you have the plug-in version of Flash Builder, select File > Import > Flash Builder > Flash Builder Project.

    You can also use the context menu for the Package Explorer to import a project.

  2. (Project folder) If you are importing from an existing project folder, select Project Folder, and navigate to the folder containing the project.

  3. (FXP file) If you are importing from an FXP file, select File and navigate to the location of the file.

    If an FXP file contains more than one project, you can select individual projects to import.

  4. (Library project or FXPL project) If you are importing a library project or a Catalyst FXPL project, you have the option to import the contents into an existing project. See Importing a Catalyst FXPL project

  5. (FXP file) If a project by the same name exists in the workspace, specify the import method:

    • Import as New Project: Flash Builder appends a numeric identifier to the project name. Previous versions of the project are preserved.

      In the Extract To field, specify a location in which to extract the file. Typically, this location is a directory in your Flash Builder workspace representing a project folder. You can specify a new project folder or overwrite an existing project folder.

    • Overwrite existing project: Select the project to overwrite. The previous version of the project is permanently removed.

  6. (Path variables) If you are importing a project that defines path variables, update path variables for the project.

    Projects compiled for ColdFusion, PHP, LiveCycle Data Services, or other server technologies use path variables to access a web server and server resources. Other projects can have user-defined path variables.

    Select each path variable and provide a valid value for the variable.

  7. (Font references) If you are importing an FXP exported by Catalyst, the project can contain font references. You have the option to resolve references to fonts.

    See Resolving font references when importing Catalyst projects.

  8. Click Finish.

  9. (PHP server projects) If you are importing a project of application server type PHP, then install or update your Zend installation.

    The Zend dialog guides you through the process.

    Note: If you cancel the process in the Zend dialog, manually install or update your Zend framework. You cannot access PHP services unless the Zend Framework is properly installed and configured. See Installing Zend Framework for information on installing, configuring, and troubleshooting your Zend Framework installation.
  10. (Server projects) Deploy services.

    1. Manually place services in the web root of the server. Use the same directory structure that was used in the original project.

    2. In the Data/Services view, from the context menu for a service, select Refresh.

Importing a Catalyst FXPL project

A Catalyst FXPL project is a library project created by Adobe Catalyst. When you import an FXPL project, you have the option to import the contents into another Flex project or Flex library project.

This feature is designed to help developers working with Catalyst application designers. However, you can use this feature to import the contents of any library project into another Flex project or Flex library project.

The menus available for this procedure vary slightly for the plug-in configuration of Flash Builder. This procedure assumes that you are importing a library project.

  1. From the Flash Builder menu, select File > Import FXP.

    If you have the plug-in version of Flash Builder, select File > Import > Flash Builder > Flash Builder Project.

    You can also use the context menu for the Package Explorer to import a project.

  2. Select File and navigate to the location of the file.

  3. Specify the import method:

    • Import a new copy of project: Flash Builder appends a numeric identifier to the project name. Previous versions of the project are preserved.

      In the Extract To field, specify a location in which to extract the file. Typically, this location is a directory in your Flash Builder workspace representing a project folder. You can specify a new project folder or overwrite an existing project folder.

    • Import contents into existing project.

      For Source Folder, browse to a src folder of an existing project. For Package, browse to an existing package or specify a new package name for the contents.

    • Overwrite existing project: If a project by the same name exists in the workspace, you can overwrite the existing project.

      Select the project to overwrite. The previous version of the project is permanently removed.

  4. Click Finish.

    When importing FXPL files, Flash Builder attempts to resolve references to fonts in the FXPL file. See Resolving font references when importing Catalyst projects.

Resolving font references when importing Catalyst projects

When importing an FXP project created with Adobe Catalyst, the imported project can contain references to fonts that are not available on your system.

The Import wizard provides the option to fix font references using CSS. If you select this option, Flash Builder imports the Catalyst style sheet Main.css. Main.css contains references to the fonts used in the project.

If you get compile errors from the fonts referenced in the style sheet, fix the references in the style sheet with fonts available on your system.

Catalyst FXPL projects do not contain style sheets. Flash Builder attempts to correct any references to fonts when importing an FXPL file. If Flash Builder cannot find a corresponding font on the target system, the original font references are left intact. For FXPL projects, font references that Flash Builder cannot resolve are discovered at runtime. There is either a font substitution or a runtime error for unresolved font references.

Note: For FXPL files, Flash Builder modifies the fontFamily attribute in MXML files when it attempts to resolve font references.

Importing a Flex 3 project

You can import a Flex 3 project into Flash Builder using Flex 3 Compatibility Mode. In this case, the namespaces and components are unchanged from Flex 3. However, you can take advantage of the compiler available with Flex 4.

New documents created in Flex 3 Compatibility Mode use MX components and the following namespace:

mx="http://www.adobe.com/2006/mxml"

  1. In Flash Builder, select File > Import Flex Project.

  2. Navigate to the previously exported Flex 3 project ZIP file, or browse to the Flex 3 Project folder.

  3. Click Finish.

  4. In the Choose Flex SDK Version dialog, make sure that Flex 4 SDK is specified. Select Use Flex 3 Compatibility Mode.

  5. Select OK.

Comparing changes in a project

If you import multiple versions of a project you can compare, copy, or merge the contents of the versions. You can only compare different versions of the same project.

  1. In the Package Explorer, select one of the projects you want to compare.

  2. Open the Package Explorer context menu and select Compare Project With Version.

    The Compare Viewer launches, allowing you to compare the project with other versions of the project.

  3. Select the version for comparison, which opens the Eclipse Compare Editor.

  4. In the compare editor, navigate to the file you want to compare and from the context menu, select Show Content Comparison.

    The Compare Editor displays both versions of the file, with differences highlighted.

    You can use Compare Editor options to copy or merge differences in the file. See the Eclipse documentation on the Compare Editor for details.

Importing an ActionScript project

ActionScript projects are exported in ZIP archive format. Use the Eclipse import wizard to import ActionScript projects.

  1. In Flash Builder, select File > Import > Other > General > Archive File.

    You can also use the context menu for the Package Explorer to import an ActionScript project.

  2. In the Import Flex Project dialog box, select the ZIP file you want to import.

  3. Click Finish.

Importing projects exported with the Eclipse Export wizard

If you have a project that was exported using Eclipse’s Export wizard, use the Eclipse Import wizard to import the project. Select File > Import > General. Then navigate to the appropriate format for your project.

For more information, see the Eclipse documentation for importing projects. This documentation is available as Help in the Eclipse Import and Export wizards.

If the project contained services created with Flash Builder tools for accessing data services, then you manually have to add the services. Copy the server files in the services folder to an appropriate server. Use the service properties for a server from the Data/Service view to determine the service location.

If you exported a PHP project that uses the Zend Framework, the Zend Framework must be installed on the target server. Modify the amf-config.ini file that configures the Zend Framework. For zend_path, specify the absolute path to the Zend installation directory. See Installing Zend Framework for information on installing, configuring, and troubleshooting your Zend Framework installation.

Importing projects into multiple workspaces

When you import a project, you import it into a Flash Builder workspace. A project can be imported into multiple workspaces. In this scenario, the project files exist on disk in one location, but are referenced by each workspace. Changes you make to a project apply to all workspaces.

Importing source files into a new project

If you have source files and assets on your file system, but are not in a project, you can create a new project for these files.

  1. From the Flash Builder menu, select File > New > Project.

    Project can be a Flex project, Flex library project, or ActionScript project.

  2. In the New Project wizard, specify the source and output folder settings to the appropriate location in your file system.

    Note: You could also accept the default wizard locations and move the source files accordingly.

Exporting Adobe AIR application installer

For AIR projects, a production build creates a digitally signed AIR file, which users can install before running the application. This process is similar to creating an installer .exe for a typical native application. You can create an unsigned intermediate package, that you can sign later before release.

For information on exporting an AIR production build and installer, see Export a release build (Desktop application, runs in Adobe AIR).