Saving encoding profiles

When you close Flash Media Live Encoder after running it from the GUI, all of the settings from that session are saved in the default encoding profile, startup.xml. The next time you start Flash Media Live Encoder—either from the GUI or from the command line without the /p parameter—Flash Media Live Encoder validates the profile and applies the settings in the startup.xml file. If the values of any settings aren’t valid, Flash Media Live Encoder uses the default values for those settings instead.

The startup.xml file is stored in Drive:\Documents and Settings\username\Application Data\Adobe\Flash Media Live Encoder 3.1 on Windows and Users/username/Library/Application Support/Adobe/Flash Media Live Encoder 3.1 on Macintosh.

Note: To get the default encoding profile set by Adobe, close Flash Media Live Encoder, delete or rename startup.xml, and restart the application. Flash Media Live Encoder launches with the default values for encoding and creates a new startup.xml file. If desired, you can save this file under another name, such as default.xml, for later use.
Once you determine encoding and streaming settings that work well in your environment, it’s a good idea to save them in a custom profile for easy retrieval. This is especially important if you will be running encoding sessions from both the GUI and the command line. You can configure encoding and streaming settings using the GUI, and then save your settings as a custom profile to use from the command line.
Note: On Macintosh, use TextEdit to edit Flash Media Live Encoder xml files (profile and configuration files). To configure TextEdit, go to 'Preferences'. Select the 'Open and Save' tab. Change the 'Plain Text File Encoding' setting for opening and saving files to 'Unicode (UTF-16)'.

For example, imagine that you’re running one encoding session in GUI mode and another in command-line mode. You make some changes in the Encoding Options and close the GUI instance. Flash Media Live Encoder updates the startup.xml profile to reflect the changed settings. If you stop the command-line encoding session and then restart it without specifying a custom profile, the new session uses the updated startup.xml profile from the GUI session. Thus, to avoid unexpected changes to your encoding profile, you may want to first configure settings in the GUI, save them as a custom profile, and then use the custom profile whenever you run Flash Media Live Encoder from the command line.

Note: When using the command line, use the /d parameter to validate and correct a profile.

Flash Media Live Encoder saves the following settings in an XML profile:

  • Video and audio encoding settings, except for hardware device properties controlled by Windows or another application

  • Flash Media Server connection settings, such as server URLs, stream name, and automatic startup and reconnection

  • File archiving settings, including filename and path and chunking settings

  • Metadata elements and values

  • Preview and zoom settings

  • Logging settings

Flash Media Live Encoder does not save the following settings in a profile:

  • Hardware device properties. Flash Media Live Encoder provides access to the properties dialog boxes of your video and audio devices, but it cannot prevent or reverse changes made by other applications. To verify that your preferred device settings are in place, click the setting icon  next to the Device box on the Encoding Options tab.

  • Deselected settings. For example, if you resize the video output but deselect the Resize option before saving a profile, the resized dimensions are not saved.

Save a profile

  1. Select File > Save Profile.

  2. In the Save As dialog box, enter a descriptive name for the file. Do not name the file startup.xml, because this name is reserved for storing settings from the last session.

  3. Click Save.

    If you use multiple Flash applications, servers, or content distribution network providers, it’s a good idea to save a separate profile for each environment.

Open a profile from the GUI

  1. Disconnect from Flash Media Server, if applicable.

  2. Select File > Open Profile.

  3. Select a profile from the Open dialog box.

If any values in the profile are invalid, Flash Media Live Encoder uses the default values instead. To see which values were changed, check the Encoding Log tab.

Open a profile from the command line

 From a command prompt in your Flash Media Live Encoder installation directory, start Flash Media Live Encoder using the FMLEcmd command and the /p option, in the following format (on Macintosh, replace back slashes with forward slashes in the file path):
FMLEcmd /p [path to profilename.xml] /d 

The path (optional) and profilename parameters are the path and filename of the XML profile that you want to open. The /d option validates that profile.

For example, on Windows:

FMLEcmd /p c:\Profiles\my_profile.xml /d

If you do not specify a profile in the command line, Flash Media Live Encoder loads the default profile, startup.xml. If any values in the profile are invalid, Flash Media Live Encoder uses the default values instead. To see which values were changed, check the Encoding Log tab.