Importing artwork

There are several ways to get your artwork into Flash Catalyst.

  • Import a layered design document created in Adobe Photoshop or Adobe Illustrator.
    Note: Flash Catalyst only imports design documents that are 40 MB or less.
  • Import a layered FXG file. You can export an FXG file from Adobe Fireworks and other Adobe Creative Suite applications.

  • Import one or more bitmap images.

  • Copy and paste graphics into the Flash Catalyst artboard.

  • Import a SWF file.

  • Import a Flash Catalyst library package.

When you import artwork from Illustrator CS5 into Flash Catalyst CS5, the layer structure remains intact and art can continue to be edited in Illustrator.

Import Adobe Illustrator files

You can start a new Flash Catalyst project by importing an Illustrator file.

  1. Start Flash Catalyst.

  2. In the Create New Project From Design File section of the Welcome screen, choose From Adobe Illustrator AI File.

    If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.
  3. Browse to the file you want to import, select it, and click Open.

    The Illustrator Import Options dialog box includes artboard settings and fidelity options. You can choose to import non-visible layers and include unused symbols.

    Note: Choosing Import Non-Visible Layers imports all layers, including layers that are hidden in the Illustrator file. Choosing Include Unused Symbols imports the graphic symbols that ship with Illustrator and the symbols you create.
  4. Specify a size and color for the artboard. Select import fidelity options and click OK.

    Illustrator Import Options dialog box

    The Illustrator file converts to the FXG format automatically, and then imports into a new Flash Catalyst project. If the Illustrator file includes a single artboard, all artwork is placed in the same Flash Catalyst page state. If the Illustrator file includes multiple artboards, the artwork in each artboard is placed in a separate Flash Catalyst page state.

You can copy and paste individual pieces of artwork from Illustrator into the Flash Catalyst artboard. The Illustrator Import Fidelity Options also appear when you copy and paste artwork.
Note: Objects outside the Illustrator artboard are discarded when you import or copy and paste artwork into Flash Catalyst.
Illustrator symbols import as Optimized Graphics. If your Illustrator file includes multiple instances of the same symbol, then your Flash Catalyst document will include multiple instances of the same optimized graphic. In Flash Catalyst, it is a best practice to use one instance of an object and then share that object to other states. You can remove all but one instance of the optimized graphic, share the same instance to other states, and then apply different properties in each state. To convert the optimized graphic into a Flash Catalyst component, you must first break it apart by choosing Modify > Break Apart Graphic.

Import Adobe Photoshop files

You can start a new Flash Catalyst project by importing a Photoshop file.

  1. Start Flash Catalyst.

  2. In the Create New Project From Design File section of the Welcome screen, choose From Adobe Photoshop PSD File.
    If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.
  3. Browse to the file you want to import, select it, and click Open.

    The Photoshop Import Options dialog box includes artboard settings and fidelity options. You can also choose to import non-visible layers.
    Note: Choosing Import Non-Visible Layers imports all layers, including layers that are hidden in the Photoshop file.
  4. Specify a size and color for the artboard. Select import fidelity options and click OK.

    Photoshop Import Options dialog box
Click Advanced in the Photoshop Import Options dialog box to specify exactly which layers to import. You can select and deselect layers to import, regardless of their visibility in Photoshop.

Import FXG files

Flash Catalyst imports artwork in the FXG file format.

  1. Start Flash Catalyst.

  2. In the Create New Project From Design File section of the Welcome screen, choose FXG File.
    If Flash Catalyst is already running, choose File > New Project From Design Comp. You can have only one project open at a time.
  3. Browse to the file you want to import, select it, and click Open.

For information on exporting an FXG file from Fireworks, see Export FXG files.

Import bitmap images

Flash Catalyst accepts bitmap images with the PNG, GIF, JPG, JPEG, and JPE filename extensions.

  1. Choose File > Import > Image.

  2. Browse to locate the file, select it, and choose Open.

    • When you import a single image file, it is placed in the project library and an instance is placed in the artboard in the current state. A new layer for the object is added in the Layers panel.

    • When you import multiple image files, they are placed in the project library. No image is added the artboard. To add an instance of the image to the artboard, drag it from the Library panel to the artboard.

Import SWF files

  1. Choose File > Import > SWF File.

  2. Browse to locate the file, select it, and choose Open.

    • When you import a single SWF file, it is placed in the project library and an instance is placed in the artboard in the current state. A new layer for the object is added in the Layers panel.

    • When you import multiple SWF files, they are placed in the project library. No SWF file is added the artboard. To add an instance of the SWF file to the artboard, drag it from the Library panel to the artboard.

    • You cannot preview a SWF file in Flash Catalyst Library panel. To preview the SWF file, run the project by choosing File > Run Project.

    • Use interactions and effects in Flash Catalyst to control the playback of SWF files. You can also play or stop a SWF file at a specific frame. For more information, see Interactions and action sequences.

    • Only SWF content written in ActionScript 3.0 and published using Adobe Flash Professional is controllable in Flash Catalyst.

    • There is no direct integration between Flash Catalyst and Flash Professional. Edit the SWF file in Flash Professional, republish, and import the new file into Flash Catalyst. Use the Source link in the Properties panel to swap the old SWF file for the new one.

Import a Flash Catalyst library package

For information on importing artwork in a library package, see Export and import a library package.

Import fidelity considerations

When you import from Illustrator and Photoshop, you specify fidelity options that control how Flash Catalyst imports your artwork. It is helpful to know which attributes are supported in Flash Catalyst, and when to flatten or rasterize artwork before importing.