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Adobe eLearning Suite extension features

Combining multiple SWF files
You can combine multiple projects published as SWF files using SCORM Packager. The combined files can be 

published as a SWF file or as an EXE file. SCORM Packager creates a table of contents (TOC) using the names of the 

separate modules (SWF files). Tables of contents (TOCs) of individual modules are displayed under their module name.

SCORM Packager currently supports SWF files published using Adobe® Captivate®, and which use the same 

ActionScript® version.

When creating a project with multiple modules that require a consistent appearance, instructional designers can create 

a design template that they can use across modules. Individual content creators can use this design template to create 

their modules.

To ensure uniformity of TOC settings across a movie, you can set a SWF file as the master movie. The TOC settings 

of the master movie are applied to all the other movies in the package. Master movies are helpful in the following cases:

• When content creators change TOC settings while creating their modules

• When instructional designers want to define the settings of a module as a standard for the rest of the modules

Combining multiple quizzes (SCOs)
You can combine multiple projects containing interactions (scorable objects, known as SCOs) using SCORM 

Packager. When you publish the file containing multiple SCOs, a ZIP file containing all the SCOs, and a manifest file 

are generated. You can directly upload the generated ZIP file to an LMS.

A SCO can be created in one of the following ways:

• Publish an Adobe Captivate project containing at least one scorable object as a SWF file.

• Publish a FLA file containing a quiz created using a quiz template as a SWF file.

• Publish a FLA file containing learning interaction objects as a SWF file.

Note: The SCO must be created using Adobe® Flash® CS4 Professional in Adobe® eLearning Suite.

You can add SCOs created using Flash into Adobe Captivate aggregator projects that are part of the eLearning suite.

SWF files created using Flash do not have an associated manifest file. Adobe Captivate prompts you to enter manifest 

details when you try to add such SWF files in SCORM Packager. A manifest file is then created using this information, 

and later bundled into the published ZIP file.

Create an aggregator file
1 Select File > New > Aggregator Project.

2 In the Aggregator dialog box, click New.

3 In the Create New Project dialog box, select Multi-SCO Project.

4 If the SCO has been created in Flash, the SCO Manifest Details dialog box appears. Enter the details. The SCO 

Identifier is a mandatory field.
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5 Click OK.

6 In the Aggregator dialog box, click Add Module.

7 In the Open dialog box, select the SWF file that you want to add to SCORM Packager.

8 Repeat steps 6 – 7 to add more SWF files to SCORM Packager.

9 Save the file as a .aggr file.

Publish the aggregator file
After you have created and saved the aggregator file, you can publish it as a SWF file, or as an EXE file.

1 Select File > New > Aggregator Project.

2 Do one of the following:

• Create an aggregator file.

• Open an existing aggregator file.

3 In the Aggregator dialog box, click Publish.

4 In the Publish SCO Package dialog box, enter a name for the project in the Project Title field.

5 Click Browse to publish your file to an alternative location.

6 Click Publish.

The aggregator file is published as a ZIP file. You can directly upload the ZIP file to a learning management system 

(LMS).

Creating quizzes (SCOs) in Adobe Flash using learning 
interaction objects
You can create quizzes (SCOs) in Adobe Flash using one of the following:

Quiz templates Quiz templates are designed for quizzes that require tracking. A quiz template contains objects that 

you can customize. It also contains the necessary code that is required to track the score, and pass such information to 

an LMS. 

When you publish a FLA file as a SWF file, the details to track scoring are embedded into the SWF file. The manifest 

file however, is not generated. When you add such a SWF file created using Flash into the aggregator, you are 

prompted to enter the manifest details. Adobe Captivate creates a manifest file using these details and incorporates it 

into the ZIP file that is produced when you publish the aggregator file. The ZIP file can be directly uploaded to an LMS.

Learning interaction objects from the Flash library Use learning interaction objects when creating interactions 

(quizzes) that must fit into a pre-designed layout in Flash. These objects are available from the common library. 

To create aggregator-compliant content using learning interaction objects, provide additional information inside the 

SWF file. For more information, see http://www.adobe.com/devnet/captivate/. Best practice is to use quiz templates 

when you want to create aggregator-compliant content.

Create a quiz using a quiz template
Each template contains the following elements:

• Welcome page

http://www.adobe.com/devnet/captivate/
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• One of each learning interaction types

• Results page

• Navigation elements

• ActionScript (version 3.0) to gather AICC and SCORM tracking information (LMS Adapter).

The quiz templates are fully functional. After creating a document from a quiz template, you can immediately test the 

document to see how the quiz functions.

1 Open Adobe Flash.

2 Select File > New.

3 In the New From Template dialog box, select Templates.

4 In the Category panel, select Quiz.

5 Click OK.

Modify learning interactions in a quiz template
Each question in the quiz is considered an interaction. When you use a quiz template, you place interactions 

sequentially between the first and last frame of the Questions layer on the root Timeline. 

Add or remove frames and keyframes as needed, as long as the interactions remain sequential. Also, the first and last 

frames are reserved for the Welcome and Results pages. The number of frames between the Welcome and Results page 

keyframes is used to calculate the score.

Modify an interaction
A. First frame of the layer  B. Questions layer  

For example, the following 12 keyframes on the Interactions layer include a 10-question quiz:

Frame 1 = Welcome page keyframe

Frames 2-11 = Interactions keyframes

Frame 12 = Results page keyframe

1 Select the first frame on the Interactions layer and modify the text of the Welcome page. Double-click the object 

that you want to modify on the slide to edit it.

2 Move to the interactions keyframes. Select each of the learning interactions and configure them.

3 Select the last frame in the Interactions layer and modify the text of the Results page. Leave the supplied dynamic 

text field names intact, or the results do not appear. Do not delete or place interactions in this frame.

A

B
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Configure a learning interaction component
A quiz template consists of each of the learning interaction types, stored in movie clips in the library. These movie clips 

are containers for the collection of elements that make up each interaction. When you add an interaction (movie clip) 

to the Stage, break it apart to edit the individual objects.

Each interaction is associated with instructions that help you configure the interaction. Do not delete these 

instructions; they contain the necessary ActionScript code. Instructions do not appear in the SWF file.

1 Select the entire learning interaction, and then select Modify > Break Apart. This action breaks the interaction into 

individual objects that you can modify.

Note: Break apart the interaction only once.

2 Deselect all the items on the Stage (Control+Shift+A). 

3 Select the learning interaction component.

4 Select Window > Component Inspector.

Component Inspector

5 If the application sends tracking information to a server-side LMS, specify a name for the interaction in the 

Interaction ID box. Each interaction in the quiz templates is uniquely named.

6 In the Question box, type the text you want the user to see. This text can be a question or instructions for the user.

7 Configure the learning interaction.

8 At the bottom of the Component inspector, click Options and enter feedback and Knowledge Track parameters for 

the learning interaction.

Note: Documents created using a quiz template have the Knowledge Track option turned on and the Navigation 

option turned off for each learning interaction. The reason for these default settings is that the quiz template has its 

own navigation controls.
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Add learning interactions to a quiz template
In a quiz template, you add learning interactions to the Interactions layer.

1 In the first layer of the Timeline, select the frame that precedes the frame number where you want to add the 

interaction. For example, to add an interaction to Frame 8, select Frame 7. 

2 Shift-click the same frame number (Frame 7) in the other layers to select those frames.

3 Right-click a selected frame and select Insert Frames to extend the Timeline evenly across all layers.

4 On the Interactions layer, select the frame you added and select Insert > Timeline > Blank Keyframe. 

5 To add an interaction, do one of the following:

• To copy and paste a pre-existing interaction in the Timeline, right-click the keyframe with the interaction and 

select Copy Frames. Paste the frame in the blank keyframe that you inserted in step 4. In this copy of the 

interaction, modify objects on the Stage or the settings in the Component inspector.

• To use an interaction from the library, drag the desired interaction movie clip type from the Learning 

Interactions library (Window > Common Libraries > Learning Interactions) to the blank keyframe. Break the 

interaction apart (select the interaction and select Modify > Break Apart), and edit the assets and parameters.

Add learning interactions to a document (no quiz template)
To add learning interactions to a Flash document that does not use a quiz template, place stand-alone learning 

interactions in the Timeline in a single frame, sequential frames (for example, ten questions in ten sequential frames), 

or labeled frames.

The learning interactions are present in the Common Libraries panel. In addition, the library contains a folder called 

Assets that contains subfolders called Controls, Graphics, and UIComponents. These folders are used for customizing 

learning interactions.

1 Select the appropriate layer and select Insert > Timeline > Blank Keyframe.

2 Select Window > Common Libraries > Learning Interactions.

Learning interaction assets
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3 Select the new keyframe and drag one of the Learning Interaction movie clips from the Library panel to the Stage.

4 Reposition the interaction by dragging it to where you want it to appear on the Stage. 

5 Configure the learning interaction.

Note: Watch the frame count across layers as you add and remove keyframes. All layers must end at the same frame 

number along the Timeline so that the frame count is the same in all layers.

APIs available in learning interactions

checkAnswer()

Syntax
public function checkAnswer (e:MouseEvent):String

Description
Checks the user response and returns any one of the following results for the question: notComplete, Correct, 

Incorrect.

resetQuestion()

Syntax
public function resetQuestion (e:MouseEvent):void

Description
Resets all the parameters of the question, and allows the user to attempt the question again.

getPointsScored ()

Syntax
public function getPointsScored ():int

Description
Returns the points scored for a question based on the points assigned for the question in the component inspector.

getInteractionDetails()

Syntax
public function getInteractionDetails ():Object

Description
This method can be used to get the interaction data after the user answers the question. The interaction data can be 

accessed using following variables.



7USING ADOBE ELEARNING SUITE EXTENSIONS

Adobe eLearning Suite extension features

getFeedbackString ()

Syntax
public function getFeedbackString ():String

Description
Returns the feedback for an interaction, which is set using component inspector of a question.

CourseBuilder extensions with Adobe Dreamweaver 
CS4
In Adobe eLearning Suite, Adobe® Dreamweaver® CS4 is powered with CourseBuilder extensions. This additional 

functionality enables you to quickly create complete web-based instructional content for multiple platforms and 

browsers.

CourseBuilder extensions include:

• A gallery of more than 25 pre-built interactions.

Note: You can also customize the pre-built interactions and save them.

• A visual action manager that lets you add complex logic and interactivity without having to know JavaScript.

• The ability to send results to a learning management system (LMS) that complies with AICC, SCORM 1.2, and 

SCORM 2004 standards.

Add CourseBuilder interactions
To add a CourseBuilder interaction, do the following:

1 Create an HTML page.

2 Click the Design tab to switch to the Design view.

3 Select Insert > CourseBuilder Interaction.

A message to save the page appears.

Variable Definition

Id Set ID from Component Inspector

objectiveId Set Interaction ID from Component Inspector

type Question type (choice, true-false, matching, likert, sequence, fill-in)

correct_response Correct answer for the interaction

student_response Answer given by the user

result_str Result for the interaction

latency_str Time taken to answer the interaction in hh:mm:ss

date_str Current date in mm:dd:yyyy format

time_str Current time when the interaction data is received in hh:mm:ss
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4 Click OK.

5 Specify a name and click Save.

CourseBuilder links support files, such as images, to the directory in which you are saving the page.

The CourseBuilder Interaction dialog box appears. 

In the Gallery tab, you can see a template slide for each question type.

6 Select a question type and a template.

In the General tab, specify the following:

• The question stem.

• When the interaction is judged (for example, when the user clicks a choice).

• Conditions for identifying correct answers.

• Whether you want to send the results to an LMS.

• Number of tries.

• The time allowed to the user to complete the interaction.

• Whether a Reset button is required.

• Whether you want to insert the interaction in an AP Div tag.

7 In the Choices tab, specify:

• Number of choices.

• Text and image to describe each choice.

• If a choice is correct or incorrect.

• Score.

8 In the Action Mgr tab, specify feedback for correct and incorrect answers and interaction behavior, such as a check 

for the number of tries.

9 Click OK.

10  Select File > Preview In Browser.

11  Select a browser from the list of installed browsers.

A message to save the current document appears.

12  Click Yes.

The browser opens, and the question appears.

Test the correct and incorrect choices.

Enable LMS tracking
You can add information to a CourseBuilder interaction for LMS tracking.

1 In the General tab, enable Knowledge Track.

2 In the Tracking tab, specify the Interaction ID, Objective ID, and the LMS standard.

3 Click OK to apply changes made to the interaction.
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Set AICC-trackable information for an interaction on one page
To add AICC- trackable information to a CourseBuilder interaction, do the following:

1 Create an HTML page with an interaction.

2 Add the following functions in the Action Mgr tab.

• Send Objective Info

• Send Score

• Send Lesson Status

• Send Lesson Time

3 Add the course structure files and create a zip file with the folder contents.

Set SCORM 1.2-trackable information for an interaction on one page
To add SCORM 1.2- trackable information to a CourseBuilder interaction, do the following:

1 Create an HTML page with an interaction.

2 Add the following functions in the Action Mgr tab:

• Send Objective Info

• Send Score

• Send Lesson Status

• Send Lesson Time

3 Add the manifest file and create a zip file with the folder contents.

Set SCORM 2.0-trackable information for an interaction on one page
To add SCORM 2.0- trackable information to a CourseBuilder interaction, do the following:

1 Create an HTML page with an interaction.

2 Add the following functions on the Action Mgr page:

• Send Core Data

• Send Lesson Status

• Send Completion Status

3 Add the manifest file and create a zip file with the folder contents.

Adobe Captivate-Adobe Device Central Workflow
In Adobe eLearning Suite, Adobe® Device Central CS4 is tightly integrated with Adobe Captivate. This integration 

helps you preview and test your eLearning content on a broad range of devices.
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Create a mobile project in Adobe Captivate
You can start creating a mobile project from within Adobe Captivate.

1 Select Create Project > Mobile Project.

Adobe Device Central CS4 is launched.

2 In the New Document tab, select the player version.

Note: Target devices must support the player version specified in the project.

3 Specify if you want to add playback controls:

4 Retain default display settings or customize the default settings.

• To use default display settings, double-click the device.

This step enables you to move back to Adobe Captivate with default display settings of the mobile.

• To customize the default display settings, select Custom Size for All Selected Devices, specify the width and 

height of the content display area, and click Create.

Create a mobile project from Adobe Device Central
You can start creating a mobile project by accessing Adobe Captivate from within Device Central.

❖ Select File > New Document In > Captivate.

Preview a mobile project
You can preview the mobile project created in Adobe Captivate in Adobe Device Central, and use the emulator to test 

the content.

❖ In Adobe Captivate, select File > Preview > In Device Central.

Emulate mobile content
Device Central provides many options for testing mobile content, enabling you to emulate a wide variety of mobile 

devices and scenarios. You can also use easy-to-record scripts to automate testing.

Adobe Captivate-Adobe Bridge workflow
In Adobe® eLearning Suite, Adobe® Bridge is integrated with Adobe Captivate. This integration lets you easily organize, 

browse, locate, and import shared creative assets while authoring in Adobe Captivate.

You can perform the following actions to implement an Adobe Captivate-Adobe Bridge workflow:

• Select any content asset from Bridge and insert it in an Adobe Captivate slide.

• Drag-and-drop audio, video, and other types of media from Bridge into the Adobe Captivate library.

• Select a PSD file in Bridge and edit it in Adobe Captivate.
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Access Bridge from Adobe Captivate
You can launch Bridge from within Adobe Captivate.

❖ Select File > Browse.

Note: Alternatively, you can click the Browse Bridge Connection tool button.

Switch to Adobe Captivate from Bridge
You can quickly return to Adobe Captivate from Bridge.

❖ Select File > Return to Adobe Captivate.

Place assets in Adobe Captivate
From Bridge, you can place selected assets in Adobe Captivate by dragging and dropping them or using the In 

Captivate option from the Place menu.

❖ Select File > Place > In Captivate.

Note: For a quick look at the new features of Bridge, see Getting Started with ADOBE eLEARNING SUITE.

Using the LMS Adapter
The LMS Adapter enables you to publish Adobe rich media content to an LMS regardless of the Shareable Content 

Object Reference Model (SCORM) or AICC file standards followed by the LMS. LMS Adapter is a compiled 

ActionScript 3.0 code clip that detects an LMS and passes data in a format that is compatible with all SCORM 

standards. Use the LMS Adapter to create custom quizzes. Standard quiz templates include built-in code for passing 

SCORM information to the LMS.

1 To include the LMS Adapter clip in a FLA file, open the file and select Window > Common Libraries > Learning 

Interactions. Drag the LMS Adapter into the FLA file.

2 Initialize the LMS Adapter by adding ActionScript code to call mandatory methods.

For information about the mandatory methods, see Code template for using LMS Adapter APIs.

Note: The LMS Adapter supports only ActionScript 3.0.

3 Publish the FLA file as a SWF file.

Note: If the FLA file is a custom quiz file, add code to mark the published SWF file as a learning interaction SWF file. 

See sample code to convert a custom quiz SWF file into a learning interaction SWF file.

4 Create a wrapper HTML file that contains launch code

Use SCORM Packager to perform this step.

Code template for using LMS Adapter APIs
You can use the following code template for using LMS Adapter APIs to create a SCORM- or AICC-compliant course.
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import flash.utils.Timer;  
import flash.events.TimerEvent;  
import flash.events.MouseEvent;  
//step 1: Drag LMS adapter compiled movieclip and name it as "tracking_mc"  
//step 2:  
tracking_mc.createLMSAdapter("SCORM");// Compulsory to use this API  
//step 3:  
var tadapter = tracking_mc.currentTrackingAdapter();// Compulsory to use this API  
//step 4:  
if(tadapter != null){  

if(tadapter.isInitialized()){// Compulsory to use this API  
trace("adapter already initialized");  

}else{  
trace("initializing the LMS adapter");  
tadapter.initialize();// Compulsory to use this API  
var timer:Timer = new Timer(5000,1);  
timer.addEventListener(TimerEvent.TIMER_COMPLETE,gettrackingdata);  
timer.start();  

}  
}  
function gettrackingdata(e:TimerEvent):void{  

trace("calling get tracking data");  
tadapter.getTrackingData();// Compulsory to use this API  

}  
-----------------------------------  
//step 5:  
//check if get tracking data is success using Timer  
var tdata:Timer = new Timer(5000,20);  
tdata.addEventListener(TimerEvent.TIMER,checkTrackingData);  
tdata.start();  
function checkTrackingData(e:TimerEvent):void{  

if(!tadapter.isTrackingDataLoaded()){// Compulsory to use this API and proceed only if this 
step is a success  

trace("tracking data not loaded");  
}else{  

trace("tracking data loaded");  
tdata.stop();  

}  
} 
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Sample code to convert a custom quiz SWF file into a learning interaction SWF 
file
Add the following to Frame 1:  
---------------------------------------------------------------------------------------------  

try{  
if(ExternalInterface.available == true)  
{  

ExternalInterface.addCallback("cpSetValue", cpSetValue);  
ExternalInterface.addCallback("cpGetValue", cpGetValue);  

}  
}catch(e)  
{  

trace("Security sandbox violation error " + e);  
}  

  
  

Add these methods:  
---------------------------------------------------------------------------------------------
------  

//For External Interface  
public function cpSetValue(variable:String, val):void  
{  

  
var arr:Array = variable.split(".");  
var ref = this;  
  
for(var i=0; i < arr.length -1; i++)  
{  

ref = ref[arr[i]];  
}  
ref[ arr[arr.length -1] ] = Number(val); //val;// This works fine for numbers, 

booleans and strings  
}  
  
public function cpGetValue(variable:String)  
{  

  
var arr:Array = variable.split(".");  
var ref = this;  
  
for(var i=0; i < arr.length -1; i++)  
{  

ref = ref[arr[i]];  
}  
ref = ref[ arr[arr.length -1] ];  
return ref;  

}
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