Using the Extensions view

Use the Extensions view to install, uninstall, import, and reload extensions.

If the Extensions view is not already displayed in the workbench, add the Extensions view by selecting Window > Show View > Other. Then, in the Show View dialog box, select ColdFusion > Extensions view.

Install and uninstall extensions

  1. In the Extensions view, click and select the Archive file to install.

    Note: If the extension that you are installing is shipped with ColdFusion Builder, the Archive file is available in the Extensions directory within the ColdFusion Builder installation.
  2. The Extension Install wizard guides you through the installation.

  3. Select the Server. If no server is configured, click Add Server to add a new server. For information about adding a server, see Adding ColdFusion servers.

    You can install the same extension on different servers. For example, CF9 local server and CF8 local server. However, at any given point, only the server that the extension uses is active.

  4. Enter the path to the ColdFusion web root (if the path is not automatically populated when selecting the server). For example, C:\ColdFusion9\wwwroot\

  5. Select a folder within the web root to install the extension. The archive file is extracted to the install location.

  6. Click Install.

To view a brief description about the installed extension, click the extension name. If you have installed the same extension on more than one server, you can make one of the servers active. To do so, select the server that you want to make active from the Active Server drop-down list.

To uninstall an extension, select the extension in the Extensions view and click . You can uninstall an extension from the IDE only, or remove the extension from your IDE and computer’s file system at the same time. When an extension is permanently removed from the file system, you cannot undo the command.

Note: If you are uninstalling an extension that is installed on multiple servers, repeat the uninstall process for every server.

Import and reload extensions

Use the Extensions view to import and reload extensions.

  • You can import extensions from an existing directory into ColdFusion Builder. Click in the Extensions view, and select the directory that contains the extension files.

    Note: It is useful to import extensions when you use existing extensions to develop new extensions.
  • You reload an extension if you change the configuration file of an installed extension. Configuration file changes are reflected only after you reload the extension. Click in the Extensions view to reload all the installed extensions.

Debug and package extensions

While loading extensions from the configuration file, any errors are logged to the Eclipse log. To debug the errors, you can view the ColdFusion Builder error log by selecting Window > Show View > Other > General > Error Log. The ColdFusion Builder error log appears in the Error Log view.

To package an extension, add the following contents to a ZIP file:
  • Configuration file (IDE_config.xml)

  • Handler directory that contains all the Handler CFM files

Note: Ensure that you add the configuration file and handler directory directly under the root of the ZIP file.