ActionScript

If you are using Adobe Captivate projects within other applications like Adobe Flash, Adobe AIR applications, and Flex, it is important that you specify the version of ActionScript for the SWF file before publishing it. You cannot set variables within an Adobe Captivate movie if you publish it using an ActionScript version that is not supported by the application. Adobe AIR and Flex support only ActionScript 3.0 whereas Adobe Flash supports both ActionScript 2.0 and ActionScript 3.0.

Users must have Flash Player 9 or later installed on their computers to view Adobe Captivate movies created using ActionScript 3.0.

  1. Select Edit > Preferences.

  2. In the Category panel, select Publish Settings from the project options.

  3. In the Publish Settings panel, select an ActionScript version from the options under ActionScript Version.