Learning management system (LMS)



You can use a learning management system (LMS) to distribute a computer-based tutorial created using Adobe Captivate over the Internet. A learning management system is used to provide, track, and manage web-based training.

The project that you upload to the LMS must be compliant with the SCORM/AICC standards. When you publish a project after setting the required SCORM/AICC options, Adobe Captivate creates the necessary files required for compliance to these standards. You can directly upload the published package to an LMS.

The following workflow is usually used for creating an LMS-ready package using Adobe Captivate and uploading it to an LMS.

  1. Create an Adobe Captivate project with at least one slide containing an interactive object, and for which reporting has been enabled.

  2. Set the SCORM/AICC options using the Preferences dialog box.

  3. Publish the project as a SWF file after enabling the Export HTML option. Best practice is also to select compression in a ZIP file. This way, you can upload the package as a single file to the LMS.

  4. Do one of the following:
    • Upload the published project files or the ZIP file directly to the LMS.

    • Publish the Adobe Captivate project and upload it to an HTTP location (your content server). Use the PENS settings in Adobe Captivate to load content from the content server to the LMS.

PENS (Package Exchange Notification Services) is a protocol that enables single-click publishing between systems that support e-learning such as authoring tools and an LMS. The published content must be compliant with AICC or ADL SCORM content package formats.

SCORM (Shareable Content Object Reference Model) is a set of specifications used to produce reusable e-learning objects. It defines communication between a client (such as Adobe Captivate) and a host (usually an LMS). SCORM is distributed by Advanced Distributed Learning, an organization under the US Department of Defense.

AICC (Aviation Industry CBT [Computer-Based Training] Committee) standards define how content for e-learning is developed, delivered, and evaluated.

Create an LMS-ready file in Adobe Captivate

To create an LMS-ready file in Adobe Captivate, do the following:
  • Enable reporting for the project in the SCORM/AICC format using the Preferences dialog box.

  • Publish the Adobe Captivate project using the Flash (SWF) option.

When you enable reporting for the project by setting the SCORM options, Adobe Captivate creates the following files when the project is published:
Manifest File
This file is used to import the Adobe Captivate project into the LMS. The manifest file, imsmanifest.xml, contains the metadata of the project and its course structure.

HTML File
Launches the Adobe Captivate project from the LMS.

JavaScript File
Acts as a link between the SWF file and the LMS. Adobe Captivate sends tracking data to the LMS using the JavaScript APIs.

SWF File
The contents of the published project are stored in the SWF file.

Other supporting Files (.xsd Files)
Contain other information required by the LMS.

SCORM_support Folder
The files in this folder ensure compliance to the SCORM standards during run time.

When you enable reporting for the project using the AICC option, the information required by AICC is stored in the SWF file itself. The JavaScript that is generated for AICC is the standard JavaScript that is published for an Adobe Captivate project.

  1. In an open project, select Quiz > Quiz Preferences.

  2. In the Project Preferences dialog box, select Reporting from the Quiz menu.

  3. Select Enable Reporting For This Project.

  4. Select Standard.

  5. Select SCORM from the menu.

  6. Click Manifest.

  7. Set the SCORM version by clicking the pop-up menu and selecting 1.2 or 2004.

  8. In the Course area, set the following manifest options:

    SCORM Version
    The runtime files (HTML, SWF files) that are generated after publishing are the same irrespective of the version that you select. However, the packaging files generated during publishing depend on the specified version number. Packaging files are the files that Adobe Captivate generates in addition to the runtime files. Packaging files help import the Adobe Captivate project into an LMS.

    Identifier
    (Required field) The identifier used by the LMS to identify different manifests. A default identifier based on the name of your Adobe Captivate project is automatically added to this field. You can change the identifier at any time by selecting the text and typing in new text.

    Title
    (Required field) The title of your project that is displayed to the user viewing the project using an LMS. A default title based on the name of your Adobe Captivate project is automatically added to this field. You can change the title at any time by selecting the text and typing in new text.

    Description
    (Required field) The text that the LMS displays to describe your project. A default description based on the name of your Adobe Captivate project is automatically added to this field. You can edit the description at any time.

    Version
    (Required field) The version specifies a number that can be used to differentiate manifests with the same identifier. For example, if you are uploading the same project after modifying it, use a different version number.

    Duration
    (Optional field) Specify the approximate time it takes to work with this particular Adobe Captivate project.

    Subject
    (Optional field) Select this option to write a short description of the Adobe Captivate project using keywords or phrases. For example, if the project is about animals, you can specify the subject as zoology.

  9. In the SCO area, you can set the following manifest options:

    Identifier
    (Required field) The LMS uses the identifier to identify different shareable content objects (SCOs). In the Adobe Captivate context, SCO refers to the Adobe Captivate project. A default identifier based on the name of your Adobe Captivate project is automatically added to this field. You can change the identifier at any time by selecting the text and typing in new text.
    Note: A course can contain more than one project. Each project is treated as a distinct SCO. However, Adobe Captivate does not support more than one project in a course.

    Title
    (Required field) A default title based on the name of your Adobe Captivate project is automatically added to this field. You can change the title at any time by selecting the text and typing in new text.

    Mastery Score
    (Optional field) The passing score for the project. The score is a number from 0 through 100. This field is enabled for projects containing score-reporting objects, such as quiz slides, text entry boxes, click boxes, or buttons.

    Time Allowed
    (Optional field) The maximum time allowed to complete the project.

    Time Limit Action
    (Optional field) The action taken when the maximum time allowed to complete the project has been exceeded. Use the options to define the action that takes place if the user exceeds the specified time:
    Exit With Message
    The project closes after displaying a message to users that they have exceeded the time limit for the project.

    Exit Without Message
    The project closes without displaying any message to the user.

    Continue With Message
    The project continues to play after displaying a message to the user.

    Continue Without Message
    The project continues to play without informing the user of the extended time.

    Launch Data
    (Optional field) The initialization data that the SCO expects from the LMS. Because a SWF file cannot be modified based on the initialization data, this option can be left blank for Adobe Captivate projects.

  10. Click OK to return to the Preferences dialog box.

  11. Select an LMS from the menu. If the LMS to which you are connecting is not listed in the menu, select Default.

  12. Select the condition for the report status. The report status is sent after every user attempt to the LMS.
    Complete/Incomplete
    The report status is sent as complete or incomplete depending on the options set in the Choose Report Data section.

    Pass/Fail
    The report status is sent as pass or fail depending on the options set in the Choose Report Data section.

  13. Select an option in Choose Report Data. The report status is set depending on the options you choose.
    Quiz Results Only
    The status is sent as Fail/Incomplete after every user interaction until the user achieves the minimum score required to pass the exam. From then on, the status is reported as Pass/Complete to the LMS.

    Adobe Acrobat Connect Pro
    The report is generated in the Adobe Acrobat Connect Pro format.

    User Access Only
    The status is sent as Pass/Complete even if a single user interaction occurs.

    Slide Views Only
    The status is sent as Pass/Complete only after the user has completed viewing the prescribed number of slides.

    Quiz Results And Slide Views
    The status is sent as Pass/Complete only after the user has achieved the minimum score and has viewed the prescribed number of slides.

  14. You can choose to send the score to the LMS in points or as a percentage. Choose the Percent option because of its better compliance with LMS.

  15. You can choose to send information on the interaction and the final score or just the final score. The entire course of user interaction until the end of the project is tracked if you choose Interaction And Score.

  16. Click LMS Customization Settings, and select options in the LMS Customization Settings dialog box:
    Never Send Resume Data
    The project notifies the LMS when users resume a session after taking a break. Users see the page at which they left off earlier. If this option is enabled, users see the first page when they resume the project.

    Escape Version And Session ID
    Converts the version and session ID to its URL encoded values.

    Don’t Escape Characters
    Supports the escape version and session ID option. Type the characters that should not be included in the escape version and session ID.

  17. Click OK.

    The manifest file is generated. To see the manifest file, publish your Adobe Captivate project and create a SWF file. If you used the default save location, you see the SWF file and imsmanifest.xml file in your My Documents\My Adobe Captivate 4 Projects folder.

    Note: If necessary, you can create a package interchange file (PIF). The PIF packages the Adobe Captivate project output files and manifest file (with additional files if you are using the SCORM 2004 option).

Publish the project for an LMS

After you set the SCORM/AICC options, you must publish the project as a SWF file.

When you choose to zip the published files, the entire set of published files is compressed into a single ZIP file. The ZIP file containing the manifest file is also called a PIF (Package Interchange File). SCORM guidelines recommend, but do not require, the use of a PIF for transporting content packages between systems. However, some LMSs require you to upload the project as a PIF. In any case, it is always simpler to upload a single file to the LMS rather than many files.
  1. Open an Adobe Captivate project.

  2. Select File > Publish.

  3. On the left of the Publish dialog box, select Flash (SWF).

  4. In Project Title, enter the name without the filename extension (.swf).

  5. In the Folder text box, enter the full path to the folder in which to save the file or click Browse to locate the folder.

  6. In Output Options, select Zip Files And Export HTML. This option packages the course into a PIF by creating a ZIP file containing the Flash (SWF) file and the HTML file.

  7. Click Publish.

Upload the project

You can upload the created project directly to an LMS or host it on your content server. Specify the required information for PENS in Adobe Captivate if you want to upload the project from the content server to an LMS.
  1. In an open project, select Edit > Preferences.

  2. In the Preferences dialog box, select PENS from the Quiz menu.

  3. In the Package section, enter the following information that the LMS requires to connect to and publish the project.
    Source URL
    The location (URL) of the project on the content server.

    User ID And Password
    Specify the login details for the LMS to connect to the specified URL on the content server.

    URL Expiry
    Specify the date and time after which the URL expires. At that point, the LMS can no longer access the URL.

  4. In the LMS section, specify the following details for the LMS.
    Target URL
    URL of the Learning Management Server where the project from the content server is published.

    User ID and Password
    Login credentials to publish the project from the content server to the target URL.

    Send Using
    Select the method (HTTP-GET or HTTP- POST) that the LMS uses to transmit the learning content package.

Set PENS options

PENS allows for coordination between Adobe Captivate and e-Learning publishing and management systems. PENS allows you to automate the notification, transfer, and delivery of content packages between Adobe Captivate and LMSs.
  1. In an open project, select Edit > Preferences.

  2. Select PENS from the Quiz menu.

  3. Enter information for the following options in the Package section of the Quiz panel:

  4. Source URL
    Enter the location where the learning content package is stored.

    User ID And Password
    Enter a required user ID and password.

    URL Expiry
    Enter the expiration date and time for the learning content package. Default date and time is 24 hours from the time that you set PENS data.

  5. Enter information for the following options in the LMS section of the Quiz panel:
    Target URL
    Enter the location of the publishing/management server.

    User ID and Password
    Enter the user ID and password required by the publishing/management server.

    Send Using
    Select the method (HTTP-GET or HTTP- POST) that the LMS uses to transmit the package.

    Command
    Select one of the following commands:
    Collect
    Uploads a new project to the LMS.

    Delete
    Deletes a project from the LMS.

    Revise
    Updates the existing project in the LMS with the new version.
    Note: The PENS protocol currently supports only the Collect command.

    Receipt E-mail
    Specify the e-mail address to which the notification should be sent after the source package is uploaded to the LMS.

    Receipt URL
    You can choose to have a standard web page displayed after the upload to the LMS is complete. For example, the web page could have a single-line message saying, “The file has been successfully uploaded to the LMS.” Enter the URL for the page that will be displayed in this field.

    Receive Alerts While LMS Is Processing The Package
    Select this option if you want to be informed of any alerts when the package is being uploaded to the LMS. The alert is sent to you using the option you have set in the Receipt URL field.

    Preview
    Click this button to see a summary of the PENS information.