Microsoft PowerPoint



You can import and edit Microsoft PowerPoint presentations in Adobe Captivate. Imported slides can be edited in a Microsoft PowerPoint environment from within Adobe Captivate. You can choose to link to the source PowerPoint presentation to keep it in sync with the Adobe Captivate project.

When a PowerPoint presentation is linked to an Adobe Captivate project, Adobe Captivate creates a reference to the source presentation. When the linked presentation is opened in Adobe Captivate for editing, the source presentation is loaded into Adobe Captivate. Because the source presentation is referenced, and not embedded into the project, linking to presentations does not affect the file size of the Adobe Captivate project.

When you import a presentation into Adobe Captivate without linking to it, the entire source presentation is embedded into the project. Editing an embedded presentation does not affect its source file. However, embedding increases the file size of the Adobe Captivate project. You can embed the presentation when the location of the Microsoft PowerPoint presentation is not fixed. Embedding is also useful when the Adobe Captivate project must be opened on a computer that doesn't have access to the Microsoft PowerPoint presentation.

Adobe Captivate supports PowerPoint presentations with the extensions .ppt, .pps, .pptx, and .ppsx. You can import PPT and PPS slides even if you do not have PowerPoint installed on your computer. However, you can’t edit them after import. To import PPTX and PPSX slides, you must have PowerPoint installed on your system. Adobe Captivate converts PPTX files to PPT files during import. The information loss that occurs during such conversion is documented on the Microsoft website http://office.microsoft.com/en-us/powerpoint/HA101023491033.aspx.

Some of the actions in Microsoft PowerPoint are not supported in Adobe Captivate. Custom animations applied to SmartArt graphics in PowerPoint 2007 are not supported in Adobe Captivate.

Note: Best practice is to install PowerPoint using the default options.

Scenario

PowerPoint version required

Import PPT file

It is not necessary to install PowerPoint if you are importing slides from a PPT file.

Import PPTX file

PowerPoint 2003 with Office Service Pack 3 (or newer) and Office Compatibility Pack

or

PowerPoint 2007

Edit PPT file

PowerPoint 2003 or PowerPoint 2007

Edit PPTX file

PowerPoint 2003 with Office Service Pack 3 (or newer) and Office Compatibility Pack (both available as freeware on the Microsoft website)

or

PowerPoint 2007

Open, edit, and save the PowerPoint file in PowerPoint before importing it into Adobe Captivate. Performing this procedure ensures that the PowerPoint version installed on your computer is stable.

PowerPoint tips

Follow these guidelines when you work with Adobe Captivate and PowerPoint:

  • Avoid parallel edits. For example, suppose you edit a linked PowerPoint file within Adobe Captivate and a copy of it outside the application simultaneously. In such cases, the results are unpredictable.

  • Avoid updates with older PPT versions. If you want to edit an embedded PPT file outside of Adobe Captivate, export the file from the resource Library and then edit the file. The edited file can then be updated in Adobe Captivate.

  • Disable installation of interactive PowerPoint plug-ins which start automatically.

  • Avoid linking to PowerPoint files over the network on a shared network drive. The results are unpredictable if you lose connectivity while working with the shared file.

Import PowerPoint presentations into Adobe Captivate

  1. In an open project, Select File > Import > PowerPoint Slides.

  2. Navigate to and select the PowerPoint presentation file format that you want to import.

  3. Click Open.

  4. Decide where to place the imported PowerPoint slides in the Adobe Captivate project. Add the slides to the end of the project, or click a slide in the list and add the PowerPoint slides after that slide.

  5. Click OK.

  6. In the Convert PowerPoint Presentations dialog box, do the following:

    1. Select the PowerPoint slides to convert to Adobe Captivate project slides.

    2. Set navigation preferences for the selected slides.

    3. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, deselect Linked.

  7. Click OK.

    The PowerPoint slides are imported into the Adobe Captivate project and appear in the designated location. If necessary, you can change the order of the slides.

Narration in a PowerPoint presentation slide is imported as a sound object and appears as a separate object on the Timeline. Even in the linked mode, changes made to the audio file in Adobe Captivate after import are not reflected in the respective Microsoft PowerPoint presentation. Similarly, changes made to the audio file in Microsoft PowerPoint are not reflected in the Adobe Captivate project. Object sounds are retained in the SWF file that is created from slides containing such objects.

Slide labels and notes are imported only during the first import. Any subsequent changes to the labels and notes in PowerPoint are not reflected in Adobe Captivate.

Create Adobe Captivate projects from PowerPoint presentations

  1. In an open project, Select File > New > Project.

  2. Select From MS PowerPoint, and click Browse.

  3. Navigate to and select the PowerPoint presentation file format that you want to import.

  4. In the Convert PowerPoint Presentations dialog box, do the following:

    1. Enter the name of the project.

    2. Select a size for the new Adobe Captivate project. The size displayed is the actual size of the slide in PowerPoint. Best practice is not to change the size.

    3. Select the PowerPoint slides to convert to Adobe Captivate project slides.

    4. Set navigation preferences for the selected slides.

    5. If you want to link to the PowerPoint presentation, select Linked. If you want to embed the PowerPoint presentation, deselect Linked.

  5. Click OK.

Insert Adobe Captivate projects into PowerPoint presentations

You can insert Adobe Captivate projects into Microsoft PowerPoint presentations in a few simple steps. Publish an Adobe Captivate project as a SWF file. Then open a PowerPoint presentation and insert the published SWF file into a slide.
Note: For information on inserting Adobe Captivate projects into Microsoft PowerPoint 2007, see the topic on PowerPoint 2007 on the Microsoft website.
  1. Create and edit the project in Adobe Captivate.

  2. Publish the project as a SWF file.

  3. Note the location of the saved SWF file.

  4. Open the PowerPoint presentation to which you want to add the Adobe Captivate project.

  5. In the Developer menu, select More Controls from the Control Toolbox.

  6. Select More Controls.

  7. From the list of objects, select Shockwave Flash Object.

  8. Drag diagonally to create a box for the project.

    You can resize the box in which the project appears. Return to the slide that contains the project in PowerPoint, and drag the resizing handles.
  9. Right-click the box and select Properties.

  10. In the Properties dialog box, click once on the top line, Custom.

  11. Click once on the Ellipsis button.

    The Property Pages dialog box appears.

  12. In Movie URL, enter the location of the SWF file to add. Type the full path, including the filename (for example, C\:My Documents\MyFile.swf) or URL to the SWF file that you want to play.

  13. Click OK.

  14. In the PowerPoint Properties dialog box (opened in step 9), set the following properties:

    • Set the Playing property to True to play the file automatically when the slide is displayed. If the SWF file has a Start/Rewind control built in to it, you can set the Playing property to False.

    • If you don't want the animation to play repeatedly, set the Loop property to False. (Click the cell to display a down arrow; then click the arrow and select False.)

    • Set Embed Movie to True to ensure that the Adobe Captivate project is always included with the PowerPoint presentation.

  15. When you finish setting options, close the Properties dialog box.

  16. Test the project. From the View menu, select Slide Show. (In Microsoft Windows 2003, click the Slide Show menu and select View Show.)

  17. To exit the slide show and return to normal view, press Esc.

Edit imported PowerPoint slides within Adobe Captivate

You can edit an individual slide or the entire set of slides imported from a PowerPoint presentation within Adobe Captivate without launching PowerPoint. If you want to edit only a few slides, edit each slide individually. It is faster than editing the entire presentation.

When you send an Adobe Captivate project with linked slides for editing, send the PowerPoint presentation along with the project. Sometimes the recipient has to relink the presentation before editing it.

  1. Import the PowerPoint presentation into your project.

  2. Open the slides in Edit mode. Navigate to a slide imported from PowerPoint.

  3. Click Edit PPT and select one of the following options.

    Edit Slide
    Edit the selected slide

    Edit Presentation
    Edit the entire presentation.

    Find Presentation In Library
    Locate the presentation in the library. When you select this option, the presentation is highlighted in the library.

    Export Animation
    Convert the selected slide to a SWF file. After conversion, Adobe Captivate prompts you to save the SWF file.

  4. When you select Edit Slide or Edit Presentation, the PowerPoint editing environment opens within the Adobe Captivate window. You can edit the slides in Microsoft PowerPoint.

  5. After you complete editing, click Save PPT.

  6. The Adobe Captivate editing environment appears.

  7. Save the project.

Update PowerPoint presentation changes made outside Adobe Captivate

Updating is necessary when the PowerPoint file is linked and the changes are made directly in Microsoft PowerPoint.

  1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.

  2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. Right-click the presentation in the Presentation folder.

  4. Select Update.

Change link type after importing the presentation

  1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.

  2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. In the Library panel, right-click the presentation in the Presentation folder.

  4. Do one of the following:

    1. Select Change To Linked if you have not linked to (embedded) the presentation during import. Specify a location for the linked file on your computer.

    2. Select Change To Embedded to embed the linked file into your project.

Change the link to the presentation after importing

When you send an Adobe Captivate project for editing, the recipient sometimes has to relink the presentation to the project.

  1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.

  2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. Right-click the presentation and select Properties.

  4. Click the hypertext link pointing to the location of the presentation.

  5. In the error message, click OK to choose another location.

  6. Navigate to the presentation and click Open.

Reduce file size of projects with embedded slides

You can import a presentation into an Adobe Captivate project without linking (embedded mode). The entire presentation is embedded into the Adobe Captivate project. Slides that are not selected during import are also imported into the Adobe Captivate project, but they are not visible in the project. When you choose to reduce the file size, Adobe Captivate deletes such slides permanently from the project. This process is irreversible.

  1. Open the Adobe Captivate project in Edit mode and navigate to a slide that was imported from the PowerPoint presentation.

  2. Click Edit PPT and select Find Presentation In Library. When you select this option, the PowerPoint presentation containing the slide is highlighted in the library.

  3. In the Library panel, right-click the presentation in the Presentation folder.

  4. Select Compact.
    Note: The Compact option is disabled for linked presentations.