Publish a project as a SWF file



Publish a SWF file

Note: To run projects that you have published using Flash, you must have the same or later version of Flash Player.

You can publish Adobe Captivate projects as SWF files in one of the following formats:

  • Flash 7, 8, 9, or 10

  • Flash Lite 3.0, or 3.1

After publishing your project as a SWF file, you can use these SWF files independently or include them in web pages.

  1. In an open project, select File > Publish.

  2. In the Publish dialog box, select Flash (SWF), and configure the following options:
    Project Title
    Enter the desired name without the filename extension (.swf).

    Folder
    Enter the full path for the folder in which to save the file or click Browse to locate the folder. A folder is created with the same name as the title, and all published files are moved inside it. If you do not want to create a separate folder and want to place the published SWF file in the same folder as the source file, clear the option Publish Files To A Folder.

    For example, if you have chosen to publish your project variables.swf to the desktop, a folder named variables is created on the desktop, and the files are published into this folder. When this option is not chosen, all the published files are published directly to the desktop.

    Zip Files
    Creates a ZIP file containing the Flash content (SWF file) and other associated files like the HTML file required to display the SWF file, and a JavaScript for loading the SWF file into the HTML file. When you have enabled AICC/SCORM, other supporting files are created. This option is especially useful when you want to create a single file for uploading to a learning management system (LMS). For more information, see Create an LMS-ready file in Adobe Captivate.

    Full Screen
    Opens the file in full screen mode. (You can’t apply this option if you select AICC or SCORM options for the project.)
    Note: If you select the full screen option, Adobe Captivate generates two HTML files to accommodate the Windows XP Service Pack 2 release. Use both HTML files with the SWF file so that when you publish your project users won’t receive a Service Pack 2 warning message. You should link to the HTML file with “fs” added, for example, “myproject_fs.htm.” The HTML file with “fs” automatically links to the second HTML file, which, in turn, plays your project.

    Generate Autorun For CD
    Runs the output file automatically when the CD is inserted into the computer.

    Export HTML
    Creates a standard JavaScript file that helps embed the SWF file into the generated HTML file.

    Send PENS Notification
    Verifies PENS compliance. For more information, see Set PENS options.
    Note: PENS is enabled only if reporting is enabled. To enable reporting, from the Edit menu, choose Preferences. In the Quiz menu, click Reporting, and select Enable Reporting.

    Export PDF
    The generated SWF file is inserted into a PDF file and published. This option is useful to share content over email or any other means where the learner doesn't have access to the content through the Flash Player in a browser.
    Note: You must have Adobe Acrobat® or Adobe Reader® version 9.0 or later installed on your computer to view the output.

    Flash Player Version
    Adobe Captivate generates the SWF file in the Flash version that you choose.

The Project Information area displays useful statistics about the project including the size (resolution), number of slides, audio information, e-learning details, accessibility compliance, and the playback control assigned to the project. To change any of the options listed in this area, click the blue text. To change preferences, click the Preferences button.

Reduce the size of a SWF file

You can reduce the size of the published Flash (SWF) file during the publishing process. However, the quality of the published file is compromised.

  1. In an open project, select File > Publish.

  2. In the left panel, select Flash (SWF).

  3. In Flash (SWF) Size And Quality under Project Information in the right panel, click Custom.

  4. In the Settings area, use the slider bar to customize the quality of the file and the file size. For more information, see Change project size and quality.

    Note: The quality of the file increases as you move to the top of the slider, with a corresponding increase in file size.
  5. To use the changed setting whenever the file is published, click Retain Slide Quality Settings.

  6. Click OK.