User interface changes from After Effects CS3 to After Effects CS4



Many instructional materials—such as tutorials—created for After Effects CS3 or earlier are still useful for After Effects CS4. In many cases, basic functionality has changed only slightly, or only the names of user interface items have changed. You can get the most use from materials created for previous versions of After Effects if you know how the names and locations of user interface items have changed. For information about current functionality, follow the respective links.

For information about major new features, see New features in After Effects CS4.

For a complete list of new and changed features in After Effects CS4, see Todd Kopriva's blog on the Adobe website.

Panels

Align panel

Brushes panel

Character panel

Composition panel

Effects & Presets panel

Effect Controls panel

Layer panel

Mask Interpolation panel

Metadata panel

Preview panel

Project panel

Render Queue panel

Smoother panel

Timeline panel

Tools panel

Tracker panel

Wiggler panel

Menus

File menu

Composition menu

Layer menu

Effect menu

Animation menu

Window menu

Help menu

Dialog boxes

New dialog boxes

Camera Settings dialog box

Composition Settings dialog box

Composition Marker and Layer Marker dialog boxes

Import File, Import Multiple FIles, and Replace Footage File dialog boxes

  • Added Adobe Premiere Pro Dynamic Link (*.prproj) and Adobe Soundbooth (*.asnd) items to Format, Files Of Type (Windows), and Enable (Mac OS) menus.

  • Changed GIF to GIF, Generic QuickTime in Format, Files Of Type (Windows), and Enable (Mac OS) menus.

  • Added *.f4v to the MPEG entry in Format, Files Of Type (Windows), and Enable (Mac OS) menus.

  • Added *.3gp, *.3g2, *.mp4, *.m4v, *.m4a, *.qt, to the QuickTime entry in Format, Files Of Type (Windows), and Enable (Mac OS) menus.

  • (Windows only) Added *.asx to the Windows Media entry in the Format and Files Of Type menus.

See Import footage items using the Import dialog box and Supported import formats.

PSD import dialog box

Mask Shape dialog box

Open dialog box

Output Module Settings dialog box

Output Module Templates dialog box

  • Changed Embedding to Include. Possible values include Project Link, Source XMP Metadata, and Project Link & Source XMP Metadata. See Output module settings.

Preferences dialog box

See Preferences.

  • Previews:

    • Added Enable Adaptive Resolution With OpenGL.

    • Replaced Accelerate Effects Using menu with Accelerate Effects Using OpenGL (When Possible).

  • Import:

    • Added Composition - Cropped Layers to Default Drag Import As menu.

    • Changed Comp to Composition in Default Drag Import As menu.

  • Output:

    • Changed Minimum Diskspace Before Overflowing to Minimum Disk Space Before Overflowing.

  • Grids & Guides:

    • Added Center-cut Action-Safe and Center-cut Title-safe controls.

  • Label Defaults:

    • Added Adjustment menu.

  • Media & Disk Cache:

    • Changed name of Memory & Cache preferences category to Media & Disk Cache.

    • Added Write XMP IDs To Files On Import and Create Layer Markers From Footage XMP Metadata options.

    • Removed Maximum Memory Usage and Maximum RAM Cache Size controls. Functionality moved to new controls in Memory & Multiprocessing preferences category.

  • Appearance:

    • Changed name of User Interface Colors preferences category to Appearance.

    • Changed User Interface Brightness to Brightness.

  • Memory & Multiprocessing:

    • Changed name of Multiprocessing preferences category to Memory & Multiprocessing.

    • Added several controls for configuring memory and multiprocessing.

    • (Windows only) Moved Prevent DLL Address Space Fragmentation to this preferences category from Media & Disk Cache preferences category.

Project Settings dialog box

Welcome And Tip Of The Day dialog box

  • Replaced Tip Of The Day dialog box with Welcome dialog box, which provides several new functions. Choose Help > Welcome And Tip Of The Day.

Keyboard shortcuts and mouse actions

New keyboard shortcuts

Changed keyboard shortcuts

  • Open Interpret Footage dialog box for selected footage item: Ctrl+Alt+G (Windows) or Command+Option+G (Mac OS). Changed from Ctrl+F (Windows) and Command+F (Mac OS). See Footage (keyboard shortcuts).

  • Most commands that affect views and previews have been modified subtly so that—if a Composition viewer is locked—the commands operate on the composition for which the Composition viewer is shown. See Edit this, look at that (ETLAT) and locked Composition viewers.

Mouse actions

  • Temporarily activate Hand tool (when any tool other than Unified Camera tool is active): Hold down spacebar or the middle mouse button. See Activate a tool.

  • Temporarily activate Orbit Camera, Track XY Camera, or Track Z Camera tool: With Unified Camera tool active, hold the left, middle, or right mouse button. See Adjust a camera view or working 3D view.

  • Activate a view in a multi-view layout in the Composition panel without affecting layer selection: Click within the view with the middle mouse button. See Choose a view layout and share view settings.