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Installing and Deploying Acrobat Connect 
Pro Lotus Notes Add-in

1  Overview
This document details the deployment and client installation of Adobe® Acrobat® Connect™ Pro Add-in for IBM® Lotus 
Notes. The Add-in integrates the Lotus Notes mail client with Adobe Acrobat Connect Pro, a real-time collaboration 
solution for online meetings and trainings. The solution provides in-context scheduling and management options for 
Adobe Acrobat Connect Pro meetings within the Lotus Notes mail client.

The product is available in two configurations:
• A standalone Sun™ Java™ feature for Lotus Notes 8 Built on Eclipse™

• A modified mail template file for Lotus Notes 7

This document is for the following audience:
• IBM Lotus Domino administrators who need to configure and deploy the Connect Pro Lotus Notes Add-in.

2  System Requirements
The add-in is available for the following operating systems:

• Microsoft® Windows® XP

• Microsoft Windows Vista®

• Apple® Mac® OS® X

The standalone Java plug-in supports the following software:

• Lotus Domino 8.x (Windows only)

• Lotus Notes 8.5 or higher (Windows and Macintosh)

The modified mail template supports the following software:

• Lotus Domino 7.0.x (Windows only)

• Lotus Notes 7.0.x, Lotus Notes 7.0.3 and greater recommended (Windows only)

3  About the add-in

3.1  Introduction
The Connect Pro Add-in enables users to manage their Connect Pro meeting rooms and invite meeting participants 
from IBM Lotus Notes. Currently, the add-in only appears in the Lotus Notes client, and does not support use with 
Lotus iNotes (Web-based email software).
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3.2  Global Properties
The administrator can use the following configuration properties to set up and control the functionality of the add-in 
for end users. The administrator can also use these properties to control access to features by dictating access control 
groups and preset settings.

Before deploying the add-in, the administrator can choose to set the Global Properties to allow users certain rights and 
to show/hide functionality according to the needs of the organization. For example, some users may be able to create 
Connect Pro Meeting Rooms and some users are restricted from doing so. Refer to the table below to see the global 
properties, their descriptions, and their default values.

3.3  Pre-requisites
Rights and permissions You must have administrator privileges on the Domino system(s) to configure the update site 
(Lotus Domino 8.x) or the mail template (Lotus Domino 7.0.x) for the add-in.

Accessibility The Connect Pro Add-In for Lotus Notes uses an XML web services API published by Adobe. The API 
resides within the Connect Pro Server that is used to access Connect Pro on the web. It is important to ensure that users 
within your organization can reach the Adobe Connect Pro URL and can call a web service from within your network.

Installation The administrator may install the software at an enterprise level, but each end user’s computer will need 
write permission to the installation directories on their local machine.   If users do not have the proper permissions, 
the add-in installation will fail.

Property Type Default Description

RESTRICT_ADDIN_USE String or boolean ‘false’ (or ‘0’) Uses ACCESS_ACL_GROUPS value to control access 
to the add-in or allows all users access to the add-in.

ACCESS_ACL_GROUPS String Comma delimited list of Lotus Domino ACL groups 
that can access the add-in; requires 
RESTRICT_ADDIN_USE set to 1.

RESTRICT_ROOM_CREATION String of boolean ‘false’ (or ‘0’) Prevents users from creating new room or allows 
users to create new rooms.

CREATE_ACL_GROUPS String Comma delimited list of Lotus Domino ACL groups 
that can access the add-in; requires 
RESTRICT_ROOM_CREATION set to 1.

RESTRICT_SERVER String or boolean ‘false’ (or ‘0’) Forces the use of one server.

Important: If set to true, requires a valid entry for 
DEFAULT_SERVER_URL.

DEFAULT_SERVER_URL String Default URL for the Acrobat Connect Pro server; 
pre-populates the server address for the user.

Important: This value will be applied upon deploy-
ment and installation of the add-in only once. 
Currently there is no option to change this value 
post-deployment.

FORCE_SSL String or boolean ‘true’ (or ‘1’) Disables the option to turn off SSL, forces all server 
calls to use SSL or allows the user to enable/disable 
SSL for server access.

Important: If used in conjunction with 
RESTRICT_SERVER = true, requires a valid secure 
URL (HTTPS://...) for DEFAULT_SERVER_URL.

HELP_URL String http://www.adobe.com/go/lea
rn_cnn_lotususing_en

The Connect Pro Add-In for Lotus Notes help docu-
mentation web address accessed by the user 
through the Help menu item in the toolbar.
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Access Control If your organization chooses to restrict access to the add-in or to restrict the right to create Connect Pro 
meeting rooms, we recommend that you create and use Lotus Domino Groups for access control.

1  In the Public Name and Address Book, create the following Domino groups:

• Connect Pro Add-in User

• Connect Pro Add-in Room Creator

2  Insert the appropriate existing Domino users or groups into the designated groups. Users who are in the Connect 
Pro Add-In User group but not in the Connect Pro Add-in Room Creator group can use the add-in but cannot create 
rooms if the globaldata.properties RESTRICT_ROOM_CREATION field is set to true. Adding users to both groups 
allows them to use the add-in and create meeting rooms.   Users who are not in the Connect Pro Add-In User group 
cannot use the add-in.

Documentation  Be sure that users in your network have the ability to reach Acrobat Connect Pro Help documen-
tation.

3.4  Supported languages
The Connect Pro Add-In for Lotus Notes includes support for the following languages: Brazilian Portuguese, Chinese 
Simplified, Dutch, English, French, German, Italian, Japanese, Korean, Spanish, Turkish and Russian.

3.5  Users with multiple accounts
Users that have multiple Connect Pro accounts within one username and password have limited capabilities. When a 
user configures this type of account in Lotus Notes, the add-in will retrieve and create meetings from the last account 
returned by the Connect Pro server. 

4  Lotus Domino Server 8 Deployment Instructions
This section details how to make the Connect Pro Add-in available to the appropriate users of your organization using 
Lotus Notes 8.x.

4.1  Set up Global Properties
The globaldata.properties file comes packaged as part of the update site used for client installation. Administrators 
should edit this file prior to deployment and prior to the loading of the files into a Notes Eclipse Update Site. The file 
is located in the update site directory …\plugins\com.adobe.connect.addin.notes_1.0.XX.jar.

To configure global properties:
1  Open the jar with a third-party tool such as WinRAR. If you are using WinRAR, make sure you have a viewer/editor 
configured.
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2  When you open the .jar archive, you will see the globaldata.properties file located at top level as shown here: 

3  Open the globaldata.properties file with a text editor and configure each global property value above according to 
the information in Global Properties.

4  Save your changes and close the globaldata.properties file.

5  Once completed, close the jar archive.

4.2  Create Lotus Domino groups
This step is optional. You can use existing Domino groups to apply permissions, but we recommend creating designated 
Lotus Domino Groups to be used for access control.

1  Create the following Domino groups:

• Connect Pro Add-in User

• Connect Pro Add-in Room Creator

2  Insert the appropriate users into the groups. Users who are in the Connect Pro Add-In User group will be able to use 
the add-in but not be able to create rooms if the globaldata.properties RESTRICT_ADDIN_USE field is set to true. 
Adding users to both groups allows them to use the add-in and create meeting rooms. 

4.3  Set up the Lotus Domino update site on your server
This section details how to make the Connect Pro Add-in available for installation to designated users in your organi-
zation.



ACROBAT CONNECT PRO LOTUS NOTES ADD-IN
Installation & Deployment Guide

5

          
          

          
           

          

4.3.1  Unzip the Connect Pro Add-In distribution file
Create a directory on an administrative server where you are access from a Lotus Notes client. Call it “Acrobat Connect 
Pro Update Site”. Unzip the add-in to this directory. You should see a directory structure as follows:

4.3.2  Create a Lotus Notes application update site
Note: If your organization has previously deployed Eclipse plug-ins or features, and you want to use your existing Lotus 
Update Site or a Widget Catalog, skip this step.

To deploy the add-in to your organization for the first time, create a Lotus update site. This site houses the files required 
by the user to install the add-in on their local Lotus Notes client.

To create an update site:
1  Open Lotus Notes.

2  In the main menu, go to File > Application > New.

3  Set the Server, Title, and File name for your Update Site. Typically, you would select a non-local server so that end 
users will be able to access it. 
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4  Check Show advanced templates to expand the list of options under the template window. Select “Eclipse Update Site 
(8.5)”.

5  Click OK to create the Eclipse update site application.

4.3.3  Import the update site source files
1  Open the update site application you just created, and open the Features tab.
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2  Click the Import Local Update Site button.

3  Click Browse button to locate your site.xml file in the directory where you have unzipped the add-in. It will be at the 
top level directory where the add-in is unzipped.

4  Click Open.

5  Click OK to start the import. 

6  Once the import process is complete, you should see the Feature, as in the following image:

7  Click the Update URL References button.
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8  Enter a recognizable Label for the add-in.

9  Click the … button to choose the New Site URL and, since this add-in is only available to Lotus Notes 8 clients, use 
the URL beginning with nrpc://.

10  Click OK to save your selection.
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11  From the main menu at the top of Lotus Notes, select Actions > Show URLs.

This button displays the URLs to distribute to your users to install the add-in. Since this add-in is only appropriate for 
Lotus Notes 8 users, the URL to distribute should be the one beginning with nrpc://.

12  To distribute this information to users, click the Copy button to copy the URL to your clipboard.

4.3.4 Sign the update site application
If the update site application is not signed, end users get a warning message during client installation that the source is 
not trusted. End users can click OK to proceed with the installation. 

For instructions on how to sign a database, see Lotus Domino Administrator 8.5 Help (Signing a database or template).

You now have successfully created and deployed the Lotus Application update site for the Connect Pro Add-In.
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5  Lotus Notes 8 Client Installation

5.1  Installing Connect Pro Add-in for Lotus Notes 8.x
The functionality to point to an Eclipse update site is disabled by default. 

To enable update site functionality:
1  Open this file: <notes install dir>\framework\rcp\plugin_customization.ini.

2  Add the following line to the end of the file, save and close the file:
com.ibm.notes.branding/enable.update.ui=true

3  Restart the Notes client.

4  From Home, in the top menu, click File > Application Install.

5  Select “Search for new features to install” and click Next.

Note: Steps 6 - 8 are for first time feature installation only.

6  Click Add Remote Location to find the Lotus Update Site.

7  Enter “Adobe Plugin Update Site” for Name.

8  Enter the Update Site URL and click OK to add the location to your list.

9  Make sure Update Site is checked, click Finish.

10  Choose the feature and click Next.

11  Accept the license agreement, and click Finish.

12  When the installation is complete you will be prompted to Restart Notes. Choose the option to Restart Immediately.

13  Notes should close and reopen in a few moments.

6  Uninstalling the Lotus 8.x Add-in 
1  Open Lotus Notes and navigate to Home.

2  Choose File > Application Management.

3  Expand the tree menu of categories and feature, and locate the Connect Pro Lotus Notes Add-in and highlight it.

4  In the left pane, click Uninstall.

5  Click OK to confirm your selection.

6  Click Restart Now to restart Lotus Notes.

You have successfully uninstalled the Connect Pro Lotus Notes Add-in.

7  Lotus Domino Server 7 Deployment Instructions
There are two options to install the Connect Pro Add-in for Lotus Notes: one for organizations using the default mail 
template (see 7.1  Organizations Using the Default Mail Template) and one for organizations using a custom or non-
English mail template (see 7.2  Organizations Using a Custom Mail Template). 
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7.1  Organizations Using the Default Mail Template
If your organization is using the version 7 English mail template and has not customized it, you must replace the 
template file. To accomplish this, use IBM Lotus Domino Administrator. Follow the steps below to replace your mail 
template.

1  Do the following to copy the new template file to your server and sign it:

a  Download the mail7acpro.ntf and copy it to your production server in the data directory. This is the Acrobat 
Connect Pro Lotus Notes Add-in mail template for version 7 [full mail template].

b  Open IBM Lotus Domino Administrator and locate the template file that you copied to the data directory. 

c  Right-click on the template file and choose Sign.

d  Choose the appropriate ID file (be sure the signer is configured to “Sign or run restricted LotusScript/Java agents” 
on the server) and click OK.

e  If you have multiple servers that store database templates, create a replica of the new template on each server and 
repeat steps b through d.

2  Modify the template properties of your original mail template and the new template your original mail file for distri-
bution to your organization. The steps below describe how to make the new template your primary inherited template 
and modify your original template properties to no longer be the default master template.

a  Locate your original mail template (e.g. mail7.ntf), right-click and choose Properties. 
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b  Click on the Design tab (4th tab) and rename the Template name to something other than StdR7Mail (for example, 
StdR7MailOriginal). 

c  Click on the add-in mail template (mail7acpro.ntf), ensure that “Database file is a master template” is checked, and 
enter the Template name: StdR7Mail.

d  If you created replicas of the template on other servers, repeat steps a through c for each server.

The new mail template is updated for users during the next design refresh. The designer task updates all databases that 
inherit their designs from the master template. You can manually update the database design if you do not want to wait 
until the next day for the changes to take effect by using the “Load design—Dmail” command in the server console. For 
more information on the design task, refer to Lotus Notes help (Synchronizing databases with master templates).

Security note The add-in code uses some features of Lotus Notes that are outside of the default settings for Lotus Notes 
Execution Control List (ECL). To avoid security warnings, each user's Lotus Notes client workstation policy must 
include the following ECL settings for the signer of the mail database.

Allow Access to the following:

• File System

• External Code

• Current Database

• Environment Variables

Allow ability to:

• Read other databases
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The image below shows the settings dialog for ECL security settings on the Lotus Notes client. You can use a domain 
policy in the Lotus Domino Server configuration using IBM Lotus Administrator to deploy the settings across the 
domain. For more information on ECL and Policy settings, refer to Lotus Domino Administrator Help (Creating a 
security policy settings document).

7.2  Organizations Using a Custom Mail Template
If you have modified the mail template from the default or are using a non-English mail template, you must merge the 
two mail template files. To accomplish this, you need to use IBM Lotus Domino Administrator and Lotus Domino 
Designer. Follow the steps below to merge the mail templates.

1  Backup your original mail template.

a  Open IBM Lotus Domino Administrator and locate your current master mail template file (e.g. mail7.ntf).

b  Click on the template file and go to File > Database > New Copy.

c  Copy the file to the same directory and give it a different name (for example, mail7Original.ntf).
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d  Open the template you created in the previous step and click File > Database > Properties. Click on the Design tab 
(4th tab), check “Database file is a master template,” and enter the Template name: StdR7MailOriginal.

2  Copy the add-in only template file to your server and open it Domino Designer along with your original template 
file.

a  Download the Acrobat Connect Pro Lotus Notes Add-in mail template for version 7 [Add-in only] 
(mail7acproAddinOnly.ntf) and copy it to your production server in the data directory.

b  Open Domino Designer. 

c  Click File > Database > Open, choose your server, and click on your master mail template file. If you cannot locate 
your master mail template file, enter the name of the file and click OK.

d  Click File > Database > Open, choose your server, and click on the Add-in template file. If you cannot locate the add-
in template file, enter the name of the file and click OK.

3  Copy the new design elements from the add-in template to your master mail template design. For each section listed 
below:

a  Go to the section in the add-in template

b  Highlight each design element (to select multiple items, hold down the Ctrl button as you select)

c  Right-click and select Copy from the pop-up menu.

d  Open the corresponding section in your master mail template

e  Right-click and select Paste from the pop-up menu.

See Appendix: Connect Pro Add-in for Lotus Notes 7.x Design Elements for a complete list of design elements required.

4  Integrate the Views and Folders for the add-in which will replace current design elements. If you have not 
customized any views or folders, you can replace all views and folders with the design elements in the add-in template. 
If you have customized views and templates, you need to copy specific code elements to your views and folders.
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Copy the toolbar menu items for the add-in into each view and folder in which users will access the add-in features. 
Adobe recommends using all folders and views so that the add-in is always accessible. To accomplish this:

a  In the Folders section of the add-in template design, open ($Inbox). 

b  In the top right section, scroll down to the bottom and select the last six actions (refer to the following image). 

c  Right-click and choose Copy.

d  Open each folder and view in your destination template to add the toolbar menu features. 

e  In the top right pane, scroll down and click the last action.

f  Right-click and choose Paste.

Note: You only need to copy the actions from one view and paste them to all necessary views and folderspos. Some views 
and folders that are not seen by the user do not need these toolbar actions (for example, (Connect JARs) view does not need 
these actions). 

5  Copy the code that will initialize the add-in each time a user enters the mail database. This code only needs to run 
on the major views that will be accessed: Inbox, Calendar, and Contacts.

a  In the Folders section of the add-in template design, open ($Inbox). 
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b  In the bottom left pane, click on PostOpen.

c  The bottom right pane will contain a block of code labeled Acrobat Connect Notes Add-In Code to initialize add-in.

d  Copy code between the BEGIN and END comments the ($Inbox) folder, and paste the code in the respective place 
(PostOpen).

e  Open the ($Calendar) View and ($Contacts) View, and paste the same code in the PostOpen section of the view.

Note: The initialization code needs to run on at least one view of the mail database (preferably the default view).   This will 
run the setup and check the user’s access against the public address book. 

6  Configure global settings using the following steps:

a  In the merged mail template in Domino Designer, open Share Code\Script Libraries.

b  Open ConnectNotesAddinSettings.
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c  Click on Initialize.

d  If desired, configure each global property value above according to the information in 3.2  Global Properties.

7  Sign your master mail template that you just modified.

a  Open IBM Lotus Domino Administrator.

b  Locate your master mail template (choose “All Database Types” to be sure you can locate the template file).

c  Right click and choose Sign.

d  Choose the appropriate ID file (be sure the signer is configured to “Sign or run restricted LotusScript/Java agents” 
on the server) and click OK.
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Security Note The add-in code uses some features of Lotus Notes that are outside of the default settings for Lotus Notes 
Execution Control List (ECL). To avoid security warnings, each user's Lotus Notes client workstation policy must 
include the following ECL settings for the signer of the mail database.

Allow Access to the following:

• File System

• External Code

• Current Database

• Environment Variables

Allow ability to:

• Read other databases

The image below shows the settings dialog for ECL security settings on the Lotus Notes client. You can use a domain 
policy in the Lotus Domino Server configuration using IBM Lotus Administrator to deploy the settings across the 
domain. For more information on ECL and Policy settings, refer to Lotus Domino Administrator Help (Creating a 
security policy settings document).

8  The Connect Pro Add-in supports multiple languages. You need to copy the translated string documents from the 
add-in template to your master mail template.

a  In IBM Lotus Domino Administrator, open the add-in template.

b  Select View, hold Shift + Ctrl, and click Go To, then choose (Connect String Lookup) and click OK.
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c  Select all documents and copy them to your clipboard. Use Ctrl+A to select all and Ctrl+C to copy.

d  Open your new master mail template select View, hold Shift+Ctrl, and click Go To, then choose (Connect String 
Lookup) and click OK.

e  Paste the documents into this view.

9  Finally, you need to copy a document from the add-in template to your master mail template. This document 
contains JAR file attachments that will deploy to the Lotus install directory of each client machines upon setup.

a  In IBM Lotus Domino Administrator, open the add-in template.

b  Select View, hold Shift+Ctrl, and click Go To. Then choose (Connect JARs) and click OK.

c  Select the document and copy it to your clipboard.
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d  Open your new master mail template select View, hold Shift+Ctrl, and click Go To, then choose (Connect JARs) and 
click OK.

e  Paste the document into this view.

f  Close both databases.

The new mail template will be updated for users during the next design refresh. The designer task updates all databases 
that inherit their designs from the master template. You can manually update the database design if you do not want to 
wait until the next day for the changes to take effect by using the “Load design—Dmail” command in the server console. 
For more information on the design task, refer to Lotus Notes Help (Synchronizing databases with master templates).

8  Lotus Notes 7 Client Installation

8.1  Installing the Connect Pro Add-in for Lotus Notes 7.x
If the Connect Pro Add-in was installed by the Administrator, the product will be available the next time the user’s mail 
database design is refreshed.

The first time a user opens the mail database, he/she will be prompted to finalize the installation. 

This will only happen if he/she is connected to the domino server. Once the installation is finalized, the user must 
restart Lotus Notes. 

When the user restarts Lotus Notes, the add-in is ready to configure.
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Note: If an error occurs and the user does not get a successful completion message, check the global properties for the correct 
values and ensure the user has rights to write to the Lotus installation directory. If problems still occur, you will need to 
copy the string documents to the user's mail database and deploy the 3 JAR files attached in the (Connect JAR) document 
to the Lotus jvm directory (<Lotus Install Dir>\jvm\lib\endorsed) of the user’s workstation.

9  Uninstalling the Lotus 7.x Add-in
Uninstalling the Connect pro Lotus Notes Add-in is primarily controlled by the Domino Administrator. In Domino 
Administrator, modify the user’s database to inherit from the mail template without the add-in.

1  Open IBM Lotus Domino Administrator. 

2  Right-click on the mail database of the user you would like to uninstall and choose Properties. 

3  Click on the 4th tab and modify the Template Name (Inherit design from master template) to the original master 
template name (StdR7MailOriginal).

The new mail template is updated for users during the next design refresh. The designer task updates all databases that 
inherit their designs from the master template. You can manually update the database design if you do not want to wait 
until the next day for the changes to take effect by using the “Load design—Dmail” command in the server console. For 
more information on the design task, refer to Lotus Notes help (Synchronizing databases with master templates).
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Appendix: Connect Pro Add-in for Lotus Notes 7.x 
Design Elements 

Pages
• Connect_About

Forms
• Connect_JARs

• Connect_License

• Connect_Start

• Connect_String_Entry

• (Connect Create Room)

• (Connect Invite DE)

• (Connect Invite EN)

• (Connect Invite ES)

• (Connect Invite FR)

• (Connect Invite IT)

• (Connect Invite JA)

• (Connect Invite KO)

• (Connect Invite NL)

• (Connect Invite PT)

• (Connect Invite RU)

• (Connect Invite TR)

• (Connect Invite ZH)

• (Connect Profile DE)

• (Connect Profile EN)

• (Connect Profile ES)

• (Connect Profile FR)

• (Connect Profile IT)

• (Connect Profile JA)

• (Connect Profile KO)

• (Connect Profile NL)

• (Connect Profile PT)

• (Connect Profile RU)

• (Connect Profile TR)

• (Connect Profile ZH)
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• (Connect Rooms DE)

• (Connect ProRooms EN)

• (Connect Rooms ES)

• (Connect Rooms FR)

• (Connect Rooms IT)

• (Connect Rooms JA)

• (Connect Rooms KO)

• (Connect Rooms NL)

• (Connect Rooms PT)

• (Connect Rooms RU)

• (Connect Rooms TR)

• (Connect Rooms ZH)

• (Connect Servers DE)

• (Connect Servers EN)

• (Connect Servers ES)

• (Connect Servers FR)

• (Connect Servers IT)

• (Connect Servers JA)

• (Connect Servers KO)

• (Connect Servers NL)

• (Connect Servers PT)

• (Connect Servers RU)

• (Connect Servers TR)

• (Connect Servers ZH)

Folders
Code elements only in all folders

Views
Code elements only in all views

• (Connect JARs) 

• (Connect String Lookup DE)

• (Connect String Lookup EN)

• (Connect String Lookup ES)

• (Connect String Lookup FR)

• (Connect String Lookup IT)

• (Connect String Lookup JA)
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• (Connect String Lookup KO)

• (Connect String Lookup NL)

• (Connect String Lookup PT)

• (Connect String Lookup RU)

• (Connect String Lookup TR)

• (Connect String Lookup ZH)

• (Connect String Lookup)

Shared Code\Agents
(Connect_Initialize)

(ConnectInsertMeetingMemo)

(ConnectInsertMeeting)

Shared Code\Actions
• Acrobat Connect

• Create a Room

• Acrobat Connect - Schedule

• Acrobat Connect - Send

• Acrobat Connect - Separator

• AdobeConnect\About

• AdobeConnect\Create Room

• AdobeConnect\Help

• AdobeConnect\More Meeting Options

• AdobeConnect\Schedule

• AdobeConnect\Send

• AdobeConnect\Seperator

• AdobeConnect\Settings…

Shared Code\Script Libraries
• Bar

• ConnectNotesAddin

• ConnectNotesAddinSettings

Shared Resources\Images
• AC_SplashScreen.jpg

• AC_SplashScreen2.jpg

• adobe_connect.gif

• connect_addin_bg.jpg
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