Adobe LiveCycle Designer ES2

Fragmente erstellen und einfügen

Fragmente können in einer separaten XDP-Datei oder im aktuellen Formularentwurf erstellt werden. Wenn Sie ein Fragment in einer separaten Datei erstellen, können Sie die ausgewählten Objekte durch einen Verweis auf die Fragmentdatei ersetzen. Wenn Sie die Auswahl nicht durch einen Fragmentverweis ersetzen, wird das Fragment zwar erstellt, die Auswahl bleibt jedoch unverändert und wird nicht mit dem neuen Fragment verbunden. Durch diese Vorgehensweise können Sie Arbeitsschritte sparen, wenn Sie mehrere Fragmente ähnlichen Typs erstellen müssen.

Es ist empfehlenswert, das Fragment in der aktuellen Datei zu erstellen, wenn Sie mehrere Fragmente in einer Datei definieren möchten. Das Erstellen mehrerer Fragmente in einer Datei erleichtert eventuell die Aktualisierung mehrerer Fragmente. Dies gilt insbesondere dann, wenn die Fragmente ähnlich sind.

Hinweis: Sie können kein Fragment in einem Formular erstellen, das durch Importieren einer PDF-Datei als Grafik erstellt wurde. Weitere Informationen finden Sie unter PDF-Dokumente als Grafik importieren.

Fragmente werden anhand des Fragmentnamens identifiziert. Wenn Sie das Fragment in einer separaten Datei erstellen, können Sie auch den Speicherort und den Dateinamen festlegen. Der Fragmentname muss nicht mit dem Dateinamen übereinstimmen. Der Fragmentname wird in der Fragmentbibliothek angezeigt, wenn Sie im Dialogfeld "Fragment erstellen" auf "OK" klicken. Wenn Sie ein Fragment im aktuellen Formularentwurf erstellen und als XDP-Datei speichern, wird der Fragmentname nach dem Speichern der Datei in der Fragmentbibliothek angezeigt.

Zum Erstellen eines Fragments können Sie entweder ein vorhandenes Teilformular oder ein bzw. mehrere Objekte auswählen. Wenn Sie Objekte auswählen, die sich nicht in einem Teilformular befinden, werden die Objekte bei der Fragmenterstellung in ein Teilformular aufgenommen.

Hinweis: Nachdem Sie ein Fragment durch Auswählen vorhandener Objekte erstellt haben, aktualisieren Sie etwaige Skriptverweise im Fragment, um wiederzugeben, dass die Objekte in ein neues Teilformular eingeschlossen wurden.

Verwenden Sie das Menü zum Erstellen von Fragmenten oder ziehen Sie die ausgewählten Objekte in die Fragmentbibliothek. Wenn Sie ein Fragment durch Ziehen der Auswahl in die Fragmentbibliothek erstellen, ist die Option zum Erstellen des Fragments in der aktuellen Datei nicht verfügbar.

Speichern Sie die Fragment-Quelldateien als XDP-Dateien. Wenn Sie eine Fragment-Quelldatei als PDF-Datei speichern, können andere Formulare nicht auf die Fragmente verweisen.

Wenn Sie ein Fragment in einer LiveCycle ES2-Anwendung erstellen und einchecken, wird das Fragment im Repository gespeichert und in der Anwendungsansicht von Workbench ES2 angezeigt.

Erstellen Sie Skriptfragmente nicht aus Teilformularen, sondern aus Skriptobjekten mit Hilfe der Palette "Hierarchie". (Siehe So erstellen Sie ein Skriptfragment.)

So erstellen Sie ein Fragment

  1. Wählen Sie die Objekte aus, die in das Fragment aufgenommen werden sollen. Sie können ein Fragment oder mehrere Objekte auswählen.
  2. Wählen Sie "Bearbeiten" > "Fragmente" > "Fragment erstellen".
  3. (Optional) Geben Sie im Feld "Beschreibung" eine Beschreibung des Fragments ein.
  4. Wählen Sie eine Methode zum Erstellen des Fragments:
    • Wenn Sie das Fragment in einer separaten XDP-Datei definieren möchten, die in der Fragmentbibliothek gespeichert wird, aktivieren Sie die Option "Neues Fragment in Fragmentbibliothek erstellen".
      • Wählen Sie in der Standalone-Version von Designer ES2 die Fragmentbibliothek aus, in der Sie die Fragmentdatei speichern möchten.
      • Wählen Sie in Designer ES2 mit Workbench ES2 in der Liste "Fragmentbibliothek" einen LiveCycle ES2-Anwendungsordner aus, in dem Sie die Fragmentdatei speichern möchten. Der Stammordner der Anwendung kann nicht ausgewählt werden.
      • (Optional) Wenn Sie einen anderen Dateinamen verwenden möchten, geben Sie im Feld "Dateiname" den gewünschten Dateinamen für das Fragment ein.
      • Um auf das neue Fragment im aktuellen Formularentwurf zu verweisen, wählen Sie "Auswahl durch Verweis auf neues Formularfragment ersetzen" und klicken Sie auf "OK".
    • Um das Fragment in der aktuellen Datei zu definieren, wählen Sie "Neues Fragment in aktuellem Dokument erstellen" und klicken Sie auf "OK".

Fragmentverweise einfügen

Fragmente bieten Ihnen die Möglichkeit, Inhalte in mehreren Formularen wiederzuverwenden. Beim Erstellen eines Formularentwurfs fügen Sie einen Verweis auf ein vorhandenes Fragment ein. Das Fragment wird dann im Formularentwurf angezeigt.

Nachdem Sie einen Fragmentverweis eingefügt haben, können Sie ihn im Formularentwurf an eine andere Stelle verschieben.

Wenn Sie Designer ES2 mit Workbench ES2 verwenden, können Sie einen Verweis auf ein Fragment einfügen, das sich außerhalb des Stammordners der Anwendung befindet oder nicht Bestandteil einer Workbench ES2-Anwendung ist. Sie müssen jedoch das Fragment und alle referenzierten Dateien in die aktuelle Anwendung kopieren. Die Dateien werden in denselben Ordner wie das aktuelle Formular kopiert. Die Verweise auf die Dateien werden aktualisiert.

Hinweis: Sie können keine Fragmente in ein Formular einfügen, das durch Importieren einer PDF-Datei als Grafik erstellt wurde. (Siehe PDF-Dokumente als Grafik importieren.)

Aktivieren Sie im Menü der Palette "Fragmentbibliothek" die Option "Vorschaufenster einblenden", um eine Vorschau der Fragmente in der Palette anzuzeigen.

So fügen Sie ein Fragment über die Palette "Fragmentbibliothek" ein

 Führen Sie einen der folgenden Schritte aus:

  • Ziehen Sie das Fragment in den Formularentwurf.

    Hinweis: Sie können keine Fragmente von der Palette "Fragmentbibliothek" in ein Teilformular ziehen, das ein untergeordnetes Element eines Teilformularsatzes ist. Der Cursor ändert sich und Designer ES2 zeigt ein Warnsymbol (einen Kreis mit einer diagonalen Linie) an, das auf einen ungültigen Vorgang hinweist.

  • Doppelklicken Sie auf das Fragment.

So fügen Sie ein Fragment über das Menü "Einfügen" ein

  1. Wählen Sie "Einfügen" > "Fragment".
  2. Navigieren Sie zu der Datei mit dem Fragment.
  3. Wählen Sie die Datei aus.
  4. Wenn die Datei mehrere Fragmente enthält, wählen Sie das gewünschte Fragment aus.
  5. Klicken Sie auf "OK". Das Fragment wird in der Mitte der sichtbaren Seite angezeigt.

Verwandte Themen

Palette "Fragmentbibliothek"

So erstellen Sie ein Skriptfragment

So wählen Sie Objekte aus

Dialogfeld "Fragment erstellen"

Dialogfeld "Fragment einfügen"

So fügen Sie ein Skriptfragment ein