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About XMLOUT

The StreamServer can produce XML output, and send this output to some kind of
destination. The contents and structure of the XML output is configured using the
XMLOUT tool.

Templates

When you create the XMLOUT configuration, you can use DTDs or XML
documents as templates. See XML document templates on page 7.

Output configuration

When you create an XMLOUT configuration, you define an XML structure to
which you map blocks and fields defined in the corresponding Event
configuration. See Configuring XML formatted output on page 13.
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XML document templates

XML document templates

When you create an XMLOUT configuration, you can use the following types of
templates:

External DTDs. Load an external DTD to the XMLOUT tool, and display
all elements and attributes in the Templates view. You create the XML
document structure by dragging element by element from the template to
the Process view.

Internal DTD subsets. You create the internal DTD subset from the
XMLOUT tool. The DTD subset is included in the XML document prolog,
and its elements and attributes are displayed in the Templates view. You
create the XML document structure by dragging element by element from
the template to the Process view.

XML documents. Load the XML document to the XMLOUT tool, and
display all elements and attributes in the Templates view. You create the
XML document structure by dragging the root element to the Document
node in the Process view. The whole structure is imported from the
template, and you must manually delete all unnecessary nodes from the
Process view. You can use an existing XML document, or use the
XMLOUT tool to generate an XML document based on an external DTD,
an internal DTD subset, or an XSD (XML schema). See Generating XML
document templates from DTDs and XSDs on page 8.

Resources

External DTSs, XSDs, and XML document templates are all resources that you
load to the XMLOUT tool. Before you load a resource, you must import the
corresponding file to a resource set connected to the corresponding Message.

To load an XML document template

1

2
3

In the Process view, right-click the Resources folder and select Import XML
File. The Select Resource dialog box opens.

Browse to the sample folder and select the resource.

The template is added to the Resources folder and the Templates view.

To load a DTD | XSD

1

In the Process view, right-click the Resources folder and select Load DTD
as resource | Load DTD as resource. The Select Resource dialog box
opens.

Browse to the sample folder and select the resource.

The template is added to the Resources folder and the Templates view.
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8 Generating XML document templates from DTDs and XSDs
XML document templates

To create an internal DTD subset

1  In the Process view, right-click the Prolog node and select Edit Internal
DTD. The Edit Internal DTD dialog box opens.

2 Edit the DTD and click Validate to check if it follows the general DTD
syntax.

3 Click OK.

4 The DTD is added to the Prolog node, and a template is added to the
Templates view.

Generating XML document templates from
DTDs and XSDs

If you have the appropriate DTD/XSD, you can use the XMLOUT tool to
generate a template based on the DTD/XSD.

Methods

You can use two methods to generate an XML document template based on a
DTD/XSD:

*  Manually - typical. With this method, you can specify the number of
instances and recursion level for the elements. What you specify here
applies to all elements. You can also specify which element is the root
element, and where to store the temporary file. See Typical configuration on
page 9.

*  Manually — custom. With this method, you can customize the number of
instances and recursion level per element. You can also specify which
element is the root element, and where to store the temporary file. See
Custom configuration on page 10.

Recursion level and Number of instances

The DTD/XSD contains information about the number of allowed instances of an
element type within another element type. This information does not explicitly
say “five type A elements, ten type B elements” etc. Instead it says “one type A
element, one or more type B elements, zero or more type C elements” etc. If no
more information were provided, the XMLOUT tool would not know when to
stop generating the XML template. To know when to stop, the XMLOUT tool
needs the following input:

*  Recursion level — specifies how many instances of itself an element type
can contain. See Recursion level.

*  Number of instances — specifies how many instances of other element
types an element type can contain. See Number of instances.
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Example 1

Example 2

Generating XML document templates from DTDs and XSDs
XML document templates

Recursion level

This DTD example illustrates how many instances of itself the <article>
element can contain when Recursion level is set to 1 and 2.
Element declaration

<ELEMENT article (descriptian)»
<ELEMENT description (article®)»

Recursion level 1 Recursion level 2
<article> <aticle>
<description> <description>
<article> <articler
<fdescription> <description>
<articlex
¢description®

Number of instances

This DTD example illustrates how many instances of the <descriptions element
the <articles element can contain when Number of instances is set to 1 and 3.
Element declaration

<ELEMENT article (descriptions)»
<IELEMENT description (article?)>

1 instance J instances
<articler <articler
<description/> <description,>
<faricler <description/>
<description>
<farticler

Typical configuration

With this method, you can specify the number of instances and recursion level for
the elements. What you specify here applies to all elements. The generated
template will include all possible combinations of the elements declared in the
DTD/XSD.

To generate and load the template

1 In the Resources folder, right-click the DTD | XSD and select
Autogenerate XML Document. The XML Builder — Settings dialog box
opens.

2 Seclect Typical, configure the settings, and click OK. The XML document
template is loaded.

Settings

Number of Defaults to 1. You can increase the number.
instances
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10 | Generating XML document templates from DTDs and XSDs
XML document templates

Settings

Recursion level Defaults to 1. You can increase the number.

Document element | Defaults to the element that is most likely to be the root
element.

XML result file Path to the result file (generated template).

Custom configuration

With this method, you can customize the number of instances and recursion level
for each element.

The generated template will, by default, include the elements that are
unambiguously declared in the DTD/XSD. You must insert all other elements
manually.

XML Builder initial settings

Document element | Defaults to the element that is most likely to be the root
element.

XML result file Path to the result file (generated template).

To generate and load the template

1 Inthe Resources folder, right-click the DTD/XSD and select Autogenerate
XML Document. The XML Builder — Settings dialog box opens.

2 Select Custom.

3 Specify the Document element (root element) and click OK. The XML
Builder — Add Element Children dialog box opens.

4  For each active element, you can add new sub-elements. See Figure 1 on
page 11. Click OK to continue with the next element in turn.

5 When you have reached the last element, and clicked OK, a preview of the
final XML document template is displayed in the XML Builder — Result
Tree dialog box. You can edit the attribute values.

6  Click OK. The XML document template is generated and loaded.
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Generating XML document templates from DTDs and XSDs | 11
XML document templates
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Figure I  Add element children
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XML document templates
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Configuring XML formatted output

Configuring XML formatted output

You use the XMLOUT tool to configure the contents and structure of XML
formatted output from the StreamServer. With the XMLOUT tool, you can
configure the following:

Indentation, empty elements, and escape sequences

The XML structure in the output will by default be automatically indented,
and empty elements will be displayed as </element>. Characters <, >, etc.
will by default be substituted with numeric sequences. To change the default
settings, you must select Tools > Options and edit the options. See Options
dialog box on page 33.

The XML structure

Create the structure of elements, attributes, text nodes, processing
nstructions, etc.

Blocks

Recurring data is defined as fields within blocks in the Event configuration.
The block and field configuration defined in the Event tool are available in a
separate Event view in the XMLOUT tool. In the XMLOUT tool, you drag
the blocks from the Event view, and drop them on the appropriate element in
the Process view. See Adding blocks on page 22.

Text nodes

A text node is either a variable, static text, or field. You can add text nodes
to elements, attributes, etc. See Adding text nodes on page 23.

Free blocks

Free blocks can be added before the first instance of a main block, after the
last instance of a main block, or be invoked using the CallBlock scripting
function. See Free blocks on page 27.

Sort criteria for blocks

For each block defined in the XMLOUT tool, you can specify one or more
sort keys. When the StreamServer processes the data, it will sort the blocks
according to the sort keys. See Sorting on page 29.

Output format for fields and variables

You can specify which format to use for the output from fields and variables.
See Output format for fields and variables on page 28.
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Example: creating an XMLOUT configuration
Configuring XML formatted output

Example: creating an XMLOUT configuration

In this example, you have the Event configuration in Example 3, and want the
StreamServer to generate output according to Example 4.

Example 3 Event configuration

Eﬁ' Ewvent
El-M8 Message
B Classic
=[] Field folder

fooom classic

classic_artist

e clazsic_artist_album
s classic_artist_price
; - [Z] Jazz and blues

- Rock and pop

[
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Example: creating an XMLOUT configuration
Configuring XML formatted output

Sample output

<!DOCTYPE
<! ELEMENT
< !ELEMENT
<! ELEMENT
< !ELEMENT
<! ELEMENT

<?xml version="1.0"?>

Document [

Document (#PCDATA|Element label |Element artist) *>
Element label (#PCDATA) >

Element artist (#PCDATA|Element album|Element price) *>

Element album (#PCDATA) >

Element price (#PCDATA)>]>

<Document >

<Element_label>CLASSIC MUSIC</Element_label>
<Element artist>Brahms
<Element albums>Symphonie A</Element_ album>
<Element prices>25</Element prices
</Element_artists
<Element label>JAZZ AND BLUES</Element labels>
<Element_artist>Gillespie
<Element albums>Jabbadabba</Element albums>
<Element price>44</Element_price>
</Element_artist>
<Element label>ROCK AND POP</Element labelx>
<Element artist>Sting
<Element albums>Save the jungle</Element albums>
<Element prices>23</Element prices

</Element_artists

</Document >

Configuring the prolog

The figure below illustrates where in the XMLOUT configuration you specify the

XML header,

5]

and the internal DTD subset used in this example.

=?xml version="1.0"7»

= Prolog - “IDOCTYPE Document [
[ XML header: <|ELEMENT Document (§PODATA|Element label|Element_artist)®s

Internal DTD Subset

=!ELEMENT Element lahel {(#PCLATA):=

=!ELEMENT Element _artist (#PCDATA|Element album|Element price)*=
<!ELEMENT Element album ($PCDATA) =

<!ELEMENT Element price ($PCDATL)=]x

Configure the XML header

1  Select the XML Header item. The corresponding settings are displayed in
the Properties view.

2 Keep the settings.

StreamServe Persuasion SP5 XMLOUT User Guide Rev A
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Configuring XML formatted output

Property

HML header:

Add the internal DTD subset

1 Right-click the Prolog item and select Edit Internal DTD. The Edit Internal
DTD dialog box opens.

2  Enter the DTD subset shown below, click Validate and OK. The internal
DTD subset is added as an item below the Prolog item, and as a template to
the Templates view.

<!ELEMENT Document (#PCDATA|Element label|Element artist)*>
<!ELEMENT Element label (#PCDATA)>

<!ELEMENT Element artist (#PCDATA|Element album|Element price) *>
<!ELEMENT Element album (#PCDATA) >

<!ELEMENT Element price (#PCDATA)>]>

Configuring the document

You first add the blocks from the Message immediately below the root element.
You then use the internal DTD subset as a template to add elements to the XML
tree. Finally, when the XML tree is complete, you add fields and static text to the

elements.

Add the blocks

1  Drag the Classic block from the Event view, and drop it on the Document
node in the Process view. The classic block is added, within a block
container, below the Document node.

2 Do the same with the Jazz and blues and Rock and pop blocks.

Event view Process view
=% Event E---<B> Document
xEq: Message EI Block container

=l Classic
- [E Jazz and blues
- Rock and pop

- [E] Classic

- Block container
e [E Jazz and blues
=[] Black cantainer

" [E] Rock and pop

Add the elements

The steps below describe how to add elements to, and above, the classic block
container. The same steps apply to the other blocks.

1  Expand all block container nodes.
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Configuring XML formatted output

2 Right-click Element_label in the Template view, drag it to the classic
block container, and release the mouse button. A shortcut menu opens.

3  Select Copy Item above Selection. Element label is added above the
Classic block container.

4 Right-click the Classic block and select Add > Element. A new element is
added to the classic block.

5 Right-click Element_artist in the Template view, drag it to the new
element, and release the mouse button. A shortcut menu opens.

6 Seclect Replace This Item. Element artist is added to the classic block.

7 Drag Element_album from the Template view and drop it on
Element artist.Element album is added as a sub node to

Element artist.

8 Drag Element_price from the Template view and drop it on
Element artist.Element album is added as a sub node to

Element artist.

- Document
‘W Element_label
(£ Block containes
| B[ Classic
El- b Element_artist
i b Element_album
'Y Element_price
-2 Block container
- [E] Black container

Add the fields and static text

The steps below describe how to add fields to elements in the classic block and
static text to Element label above the classic block container. The same steps
also apply to the two other blocks.

1 Right-click Element_label and select Add > Static Text. A Static Text
node is added to Element label.

In the Label field for the Static Text node, enter CLASSIC MUSIC.

3 In the Event view, right-click the field Classic_artist, drag it to
Element_album, and release the mouse button. A shortcut menu opens.

4 Seclect Copy Item above Selection. The field is added above

Element album.

5 Drag the ficld Classic_artist_album from the Event view and drop it on
Element_album. The field is added into Element album.

6 Drag the field Classic_artist_price from the Event view and drop it on
Element_price. The field is added into Element price.
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Configuring XML formatted output

Event view

Process view

Ex— Ewvent
-8 Message

El-E Classic
=[] Field folder
! clagsic
clazsic_artist
clazsic_artist_album
classic_artist_price
-[E] Jazz and blues
- [E] Rock and pop

=43 Document

El- b Element_label

- Static Test

(2] Black container
EI-[E Classic

El- B Element_artist
= classic_artist
¥ Element_album
: fem clazsic_artist_album

El- b Element_price
e classic_artist_price

[ Block container
[ Block container

-
£
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Configuring XML formatted output

Prolog configuration

The prolog can contain XML and <!DocTYPE. . . > declarations, comments, and
processing instructions.

XML declaration

Select the XML Header item and configure the properties. See XML header on
page 39.

DOCTYPE declaration

You can use external DTDs, internal DTD subsets, and a combination of both in
the <1poCTYPE. . . > declaration.

Declaring an external DTD
You can define an external DTD in two ways:
*  Specify the path to the DTD.
*  Specify the path to the DTD, and load the DTD as a template. The template
resource must be available in a Resource Set connected to the Message.
To specify path only

1 Right-click the Prolog item and select Define External DTD. The external
DTD is added as an item below the Prolog item.

2 In the Properties view, specify the settings. See External DTD on page 39.

To specify path and load template

1  Right-click the Prolog item and select Import External DTD. The Select
Resource dialog box opens.

2 Browse to, and select, the DTD resource. The DTD is added as an item
below the Prolog item, and as a template to the Templates view.

3 Inthe Properties view, specify the settings. See External DTD on page 39.

Declaring an internal DTD subset

1 Right-click the Prolog item and select Edit Internal DTD. The Edit Internal
DTD dialog box opens.

2  Enter the DTD subset shown below, click Validate and OK. The internal
DTD subset is added as an item below the Prolog item, and as a template to
the Templates view.
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Configuring XML formatted output

Comments in the prolog

To add a comment

Right-click the Prolog item and select Add > Comment. The new comment is
added.

To configure a comment

Configure the comment according to Comment on page 41.

Processing instructions in the prolog

To add a processing instruction

Right-click the Prolog item and select Add > Processing Instruction. The new
processing instruction is added.

To configure a processing instruction

Configure the processing instruction according to Processing instruction on page
42.
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Configuring XML formatted output

Document configuration

If you have templates, you can create the XML structure by dragging nodes from
the Templates view to the Process view. You can also add nodes manually by
right-clicking existing nodes in the Process view and selecting Add > node.

To configure the document using a DTD template

1
2

In the Templates view, expand the DTD.

Right-click the template root element, drag it to the Document node in the
Process view, and release the mouse button. A shortcut menu opens.

In the shortcut menu, select Replace this item. The Document node is
replaced by the template root element.

Continue to drag elements and attributes from the template, and drop them
on the appropriate nodes in the Process view.

Drag the blocks from the Event view, and drop them on the appropriate
elements in the Process view.

In each block, create the structure of element, attributes, etc.

Drag the fields from the Event view, and drop them on the appropriate
nodes in the Process view.

To configure the document using an XML document template

1
2

In the Templates view, expand the XML document.

Right-click the template element you want to use as root element, drag it to
the Document node in the Process view, and release the mouse button. A
shortcut menu opens.

In the shortcut menu, select Replace this item. The Document node is
replaced by the template root element and all its sub nodes.

Remove the nodes you do not need.

Drag the blocks from the Event view, and drop them on the appropriate
elements in the Process view.

In each block, create the structure of element, attributes, etc.

Drag the fields from the Event view, and drop them on the appropriate
nodes in the Process view.

Drag-and-drop options

If you drag-and-drop nodes using the left mouse button, the new node is inserted
in the node where you drop it. If you use the right mouse button, you will get more
options for inserting the new node — replace existing, copy into, copy above,
copy below, and cancel.
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Configuring XML formatted output

Adding blocks

You can add blocks to the following items:
*  Elements

. Block containers

To add a block

Drag the block from the Event view, and drop it on the appropriate element or
block container in the Process view.

To configure a block
Configure the block according to Block on page 48.

Block container

Block containers in XMLOUT are equivalent to frames in PageOUT. When you
drop a block on an element in the Process view, the block is automatically
encapsulated in a block container. You can add several blocks to a block
container, and you can add blocks to several block containers.

If you add several blocks to one block container, the order in which block data is
delivered depends on the order in which data is received — and whether or not
sorting is enabled in the Event configuration.

If you add the blocks to several block containers, block data from the first block
container will be delivered first, data from the second block container next, and
so on.

See Block container on page 48 for more information

XML structure in blocks

When you add a block to an element in the Process view, it does not contain
anything. You must manually build the structure of elements, static text, etc.
within each block. You can do this using shortcut menu commands. You can also
drag nodes from a template, or from the surrounding XML structure.

Adding elements

You can add elements to the following items:
*  Comments

*  Elements

*  Blocks

*  Before first instance blocks

*  After last instance blocks

*  Free blocks
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Configuring XML formatted output

To add an element

Right-click the item and select Add > Element. The new element is added to the
item.

To configure an element

Configure the element according to Element on page 44.

Adding attributes

You can add attributes to Element items.

To add an attribute

Right-click the element and select Add > Attribute. The new attribute is added to
the element.

To configure an attribute

Configure the attribute according to A#tribute on page 45.

Adding text nodes

A text node is either a variable, static text, or a field. You can add text nodes to
the following items:

*  Comments

*  CDATA sections

*  Elements

*  Attributes

*  Blocks

*  Before first instance blocks
*  After last instance blocks

*  Free blocks

Adding variables

To add a new variable

Right-click the item and select Add > Variable. The new variable is added to the
item.

To add a variable defined in the Event configuration

Drag the variable from the Event view, and drop it on the appropriate item in the
Process view.
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Configuring XML formatted output

To configure a variable

Configure the variable according to Variable on page 46.

Adding static text
Right-click the item and select Add > Static Text. The static text node is added
to the item.

To configure a static text node

Configure the static text node according to Static text on page 45.

Adding fields

Drag the field from the Event view, and drop it on the appropriate item in the
Process view.

To configure a field
Configure the field according to Field on page 46.

Adding comments

You can add comments to the following items:
*  Prolog

*  Elements

*  Blocks

*  Before first instance blocks

*  After last instance blocks

. Free blocks

To add a comment

Right-click the item and select Add > Comment. The new comment is added to
the item.

To configure a comment

Configure the comment according to Comment on page 41.

Adding processing instructions
You can add processing instructions to the following items:
*  Prolog
*  Comment

. Elements
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. Blocks
. Before first instance blocks
. After last instance blocks

. Free blocks

To add a processing instruction

Right-click the item and select Add > Processing Instruction. The new
processing instruction is added to the item.

To configure a processing instruction

Configure the processing instruction according to Processing instruction on page
42.

Adding CDATA sections

You can add CDATA sections to the following items:
+  Comment

*  Elements

*  Blocks

*  Before first instance blocks

*  After last instance blocks

*  Free blocks

To add a CDATA section

Right-click the item and select Add > CDATA Section. The new CDATA section
is added to the item.

To configure a CDATA section
Configure the CDATA section according to CDATA section on page 42.
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Epilog configuration

The epilog can contain any information that is covered in the prolog except for
<IDOCTYPE. . .> and XML declarations.

Comments in the epilog

To add a comment

Right-click the Epilog item and select Add > Comment. The new comment is
added.

To configure a comment

Configure the comment according to Comment on page 41.

Processing instructions in the epilog

To add a processing instruction

Right-click the Epilog item, and select Add > Processing Instruction. The new
processing instruction is added.

To configure a processing instruction

Configure the processing instruction according to Processing instruction on page
42.

Editing scripts before and after the epilog

1 Right-click the Epilog item, and select Edit > Script Before | Script After.
The script editor opens.

2 Edit the script and click OK.
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Free blocks

There are three types of free blocks:

»  Before First Instance Block. This block will be added before the first
instance of a main block, i.e. a block specified in the corresponding Event.

. After Last Instance Block. This block will be added after the last instance
of a main block.

*  Free Block. This block can be invoked using the CallBlock scripting
function. See the Scripting reference.

Free block — CallBlock invoked

To add the block

Right-click the Free blocks folder and select Add Free Block. The new free block
is added to the Free blocks folder.

To configure the block
Configure the free block according to Free block on page 51.

Before first instance block

To add the block

Right-click the main block and select Add > Before First Instance Block. The
new free block is added to the main block.

To configure the block
Configure the free block according to Before first instance block on page 50.

After last instance block

To add the block

Right-click the main block and select Add > After Last Instance Block. The new
free block is added to the main block.

To configure the block
Configure the free block according to After last instance block on page 50.
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Output format for fields and variables

In the Event tool you can configure fields and variables to handle numeric or date
formatted data. Which format to use is determined by the input data. In the
XMLOUT tool, you can specify which format to use for the output from the
corresponding field or variable. You can use the same format as specified in the

Event tool, or you can select a new format.

For example, if the input is 02/08/12, and you want to change this to 08.12.02
in the output, you must first specify the format yy/mm/dd in the Event tool. You
then specify the new output format mm.dd. yy, in the XMLOUT tool.

Format tables

Numeric and date formats are made available through format tables. Before you
specify any formats, you must add a format table to a resource set connected to

the Message. You can import Formats. txt from

<StreamServe

installation>\Applications\StreamServer\<version>\Tools\Samples

to the resource set.

The first time you specify a format, a resource selection dialog box opens. In this
dialog box, you must browse to, and select, the format table you want to use. This
table will be selected by default the next time you specify a format for any of the

fields or variables in the XMLOUT configuration.

To select a new numeric | date format for a field or variable

1  Inthe Process view, select the field or variable. The properties are displayed

in the Properties view.

2 In the Output format ficld, click the browse button. The Formats dialog

box opens.
3  Select the Numeric | Date category.

4 Double-click the new Format.

Note: Do not use the Numeric formats k and d. They should only be used in the

Event configuration.

To add a new format

In the Formats dialog box, in the Format field, enter the new format and click
Add. You can also add new formats directly to the format table resource. See

Formats dialog box on page 35.
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You can use sort keys to specify the order in which block data will be added to
the output. If no sort keys are used, data will be added in the same order as
specified in the Event configuration, i.e. in the same order as in the Message.

To specify sort keys for a block

1 In the Process view, right-click the block and select Edit > Sort Criteria.
The Edit Sort Criteria dialog box opens.

2 Edit the sort criteria and click OK.

Syntax
"<«field>":"<type><order>"
For example:
"customer_name":"SA"

<types> is either s (alpha-numeric) or N (numeric)

<orders is either A (ascending) or b (descending)

Multiple sort keys

Multiple sort keys are separated by spaces. Data will be sorted according to the
first key. Block instances that equally fulfill the first sort will be sorted according
to the next key, and so on.

Sort keys for the name and age fields

In data Out data
John Gray Sort criteria Ezra Dollar
Ezra Dallar Uname';"SA" "age" NA" John Gray
John Gray John Gray
Will Jones Will Jones
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Unlinked blocks and fields

If a field or block is removed from the Event configuration, the corresponding
fields in the XMLOUT configuration are not removed. Instead the links are
broken.

Exporting data from unlinked fields

You can configure unlinked fields to be exported as variables, static text, or not
at all. You can select Tools > Default Unlinked Export and set export options
that apply to all unlinked fields. See Set Unlinked Field Properties dialog box on
page 34.

You can also set the export settings separately for each field. See Field on page
46.
Deleting unlinked objects

You can delete the unlinked objects separately. You can also select Tools >
Delete all Unlinked Objects to delete all unlinked objects at the same time.
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Main window

The Main window contains five views:

. Event view

This is the structure created in the corresponding Event tool. You can drag
fields and blocks from this view to the Process view.

*  Process view
This is where you create the XMLOUT configuration.

+  Template view
This is where you display XML document templates, DTDs, and XSDs.

*  Preview view
This is where you preview the XML output.

*  Properties view

Select a node in the Process view, and configure the corresponding
properties in the Properties view.

Menus and menu commands

File menu

New Clear the existing XMLOUT configuration and start with a new Process view.

Open Open an existing XMLOUT configuration. The XMLOUT configuration must
have been saved as a * . dxo file.

Save Save the XMLOUT configuration as data embedded in the corresponding
Message file in the Design Center Project.

Save As Save the XMLOUT configuration as a separate * . dxo file.

Exit Exit the XMLOUT tool.

Edit menu

Standard Windows options.

StreamServe Persuasion SP5 XMLOUT User Guide Rev A



32

Main window
XMLOUT tool GUI reference

View menu
Status Bar Show/hide the status bar.
Event Show/hide the Event view.
Browser
Process Show/hide the Process view.
Browser
Toggle View The View Mode determines the display names for the fields in the Event view
Mode and Process view. You can toggle between the following modes:
* Label
*  Description
*  Sample content
Toggle Show/hide operation nodes. Operation nodes can include scripts and sort key
Operation definitions.
Nodes
Insert menu
Contains all available item types, i.e. fields, elements, etc., that you can add to the
XMLOUT configuration.
Tools menu

Import Event

Link All
Objects

Unlink object

Default
unlinked
export

Delete all
Unlinked
Objects

Import
External DTD

Applicable only when using the XMLOUT tool as a standalone application.
Imports an Event configuration.

Link all unlinked fields and blocks. Unlinked blocks and fields in the Process
view will be linked to blocks and fields with the same name in the Event view.

Manually cut the link between a field in the Process view, and the corresponding
field in the Event view.

Set export options that apply to all unlinked fields. See Set Unlinked Field
Properties dialog box on page 34.

Delete all unlinked objects at the same time.

Add an eternal DTD to the <!DocTYPE. . . > declaration and, at the same time,
load the DTD as a template.
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Define Add an eternal DTD to the <!pocTYPE. . . > declaration.
External DTD

Load DTD as Load a DTD as a template.
Resource

Edit Internal Add an internal DTD subset to the < !DocTYPE. . . > declaration and, at the same
DTD time, load the DTD as a template.

Load XSD as Load an XSD as a resource. From this XSD, you can generate an XML document
Resource  template.

Import XML Load an XML document template.

File

Auto Select a DTD or XSD in the Resource folder, and auto generate an XML
generate document template.

XML

Document

Edit Script Select an item in the Process view, and edit a before or after script.

Edit Sort Select a block item in the Process view, and edit the sort keys for the block.
Criteria

Preview Preview the export from the XMLOUT tool.

Export

Customize  Open the Customize dialog box. See Customize dialog box on page 34.

Options Edit the settings for indentation, empty elements, and escape sequences. See
Options dialog box on page 33.

Dialog boxes

Options dialog box

Settings

Output format Determines whether or not to indent the lines in the XML
output.

Auto Indent — Auto indent the lines. Decreases
performance.

Raw — Left align all lines.

Stream — The output is a stream of data on a single line.
High performance, but not suitable for the human eye.
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Settings

Empty element
style

Determines how to display empty elements:

<element></element> OI </element>

Escape sequences

Determines the format of escape sequences for the
following characters:

& <, >, ", ',and -

Use predefined entity

Use samp; etc. Some XML parsers require that the
entities are declared in the DTD. If you do not select this
option, the numeric sequences &#38; etc. will be used

instead. All XML parsers can understand numeric
sequences.

Note: Characters used in static text will not be
substituted.

Set Unlinked Field Properties dialog box

Settings

Do not export

Do not export the field.

Export as variable

Export the field as a variable. Do not use white spaces in
the variable name. Do not enter the $-prefix.

Export as static
text

Select to export the Label, Description, Sample Data, or
a custom Text.

Customize dialog box

Toolbars tab

Turn toolbars on and off, turn tooltips on and off, and modify the appearance of

the toolbars.

Commands tab

Display information about the toolbar buttons.
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Settings

Category

General — Data will be handled as a regular string of
characters.

Numeric — Data will be handled as numeric data. This
category must have been specified for the field or
variable in the Event configuration.

Date — Data will be handled as date formatted data. This
category must have been specified for the field or
variable in the Event configuration.

Format

Select an existing format or add a new format. Do not use
the numeric formats x and d. They should only be used in
the Event configuration.

Select Resource Browse to and select an alternative format resource.

Numeric format description

z

If the value of a leading or trailing digit is zero, the digit is replaced
by a space, " "

If the value of a leading or trailing digit is zero, the digit is removed.

The digit is always displayed.

A digit on either side of a decimal separator, or the last sign if no
decimal separator exists. The digit is always displayed, except if the
field value is zero (0 or 0.0 or similar).

Example

Z ZZZ ZZZ ZZ#, ##

Date format description

d Day

m Month

y Year
Example | dd/mm/yyyy
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XML Builder — Settings dialog box
Used for: Generating a template from a DTD/XSD.

Settings

Mode

Typical — Generate a typical XML document. This
document will contain all possible combinations
specified in the DTD/XSD.

Custom — Generate a custom XML document. See
Generating XML document templates from DTDs and
XSDs on page 8.

Number of
instances

The number of instances of other element types an
element type can contain. See Generating XML document
templates from DTDs and XSDs on page 8.

Recursion level

The number of instances of itself an element type can
contain. See Generating XML document templates from
DTDs and XSDs on page 8.

Document element

The root element in the generated template.

XML result file

The location of the temporary file for the template. If you
want to keep the generated template, you can import it as
aresource to the appropriate Resource Set, and later load
it to the XMLOUT tool.

XML Builder — Add Element Children dialog box

Used for specifying which elements to include in a customized sample.

XML Builder — Result Tree

Used for displaying a preview of the final XML document sample. You can edit

the attribute values.
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Event view

This is the structure created in the corresponding Event tool. You can drag fields
and blocks from this view to the Process view.
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Process view

This is where you create the XMLOUT configuration.

Prolog

The prolog can contain XML and <!DoCTYPE. . . > declarations, comments, and

processing instructions.

Shortcut menu commands

Import External
DTD

Add an eternal DTD to the <!DoCTYPE. . . > declaration
and, at the same time, load the DTD as a template.

Define External
DTD

Add an eternal DTD to the <!DoCTYPE. . . > declaration.

Edit Internal DTD

Add an internal DTD subset to the <! DOCTYPE. . . >
declaration and, at the same time, load the DTD as a
template.

Add Comment

Add a comment below. See Comment.

Add Processing
Instruction

Add a Processing Instruction. See Processing instruction,

Document

The Document item is the root element in the XML document. See Document on

page 43.

Epilog

The epilog can contain any information that is covered in the prolog except for
<IDOCTYPE. . . > and XML declarations.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Comment

Add a comment below. See Comment.

Add Processing
Instruction

Add a Processing Instruction. See Processing instruction,
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To the Free Blocks folder, you can add free blocks that must be invoked using the
CallBlock scripting function. See the Scripting reference.

Item types

XML header

This item type specifies the XML declaration, for example:

<?xml version="1.0" encoding="UTF-8" Standalone="yes”?>

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After Insert or edit an after script.

Settings

Label Label displayed in the Process view.

Description Optional information about this item. This information is

not exported from the XMLOUT tool.

XML version

The XML version. For example 1.0.

XML encoding

The XML encoding. For example UTF-8. The same code
page must be specified for the output connector.S

Standalone Standalone document declaration.
Item type Processing Instruction.
References
www.w3.0rg

External DTD

This item type declares an external DTD, for example:

<!DOCTYPE chapter SYSTEM "mybook.dtd"s>

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.
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Settings

Label

Label displayed in the Process view.

Public identifier

You can increase performance with a public identifier.
Contact those responsible for the DTD for information
about the public identifier.

System identifier

System identifier of the external DTD. The system
identifier must point to an instance of a resource via a
URL

Y ou must always specify a system identifier. The system
identifier will be used if the public is not recognized.

Item type

External DTD.

References
www.w3.org

Internal DTD subset

This item type specifies an internal DTD subset, for example:

<!ELEMENT music (#PCDATA | CL) *>

<!ELEMENT CL (#PCDATA | Composer | Artist)*>

<!ELEMENT Composer

<!ELEMENT Artist

(#PCDATA) >

(#PCDATA) >

Shortcut menu commands

Edit DTD

Open the Edit Internal dialog box, and specify the DTD
subset.

View

Open the Templates view. You can expand the DTD
subset and display the elements.

Autogenerate XML
Document

Automatically generate an XML document template
based on the DTD subset. See XML document templates
on page 7.

Settings

Label

Label displayed in the Process view.

Description

Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type

Internal DTD subset.
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This item type adds comments to the XML output. For example:

<!-- declarations for <head> & <body> -->

Comments can contain any data except the literal string - -. You can place
comments anywhere in your document.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Element

Include an element in the comment. See Element.

Add Processing

Include a processing instruction in the comment. See

Instruction Processing instruction.

Add CDATA Include a CDATA section in the comment. See CDATA

Section section.

Add Field Include a field in the comment. See Field. Y ou must first
select the field in the Event view.

Add Variable Include a variable in the comment. See Variable.

Add Static text

Include a static text in the comment. See Static text.

Add Block Include a block container, and a block, in the comment.

Container See Block container. You must first select a block in the
Event view.

Settings

Label e Label displayed in the Process view.
e Comment in the XML output. To this you can add

items using the shortcut menu.

Description Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type Comment.

References

www.w3.org
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CDATA section

This item adds CDATA sections to the XML output. For example:

<! [CDATA[ *p = &g; b = (1 <= 3); 11>

The only string that must not be used in a CDATA section is ] ] >.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After Insert or edit an after script.

Add Field Include a field in the CDATA section. See Field. You
must first select the field in the Event view.

Add Variable Include a variable in the CDATA section. See Variable.

Add Static text

Include a static text in the CDATA section. See Static
text.

Settings
Label *  Label displayed in the Process view.
*  CDATA in the XML output. To this you can add
items using the shortcut menu.
Description Optional information about this item. This information is
not exported from the XMLOUT tool.
Item type CDATA Section.
References
www.w3.org

Processing instruction

This item adds processing instructions to the XML output. For example:

<?word document='my doc.doc’ ?>

The string 2> cannot be placed within a processing instruction, which means
nested processing instructions are not allowed.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.
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Settings
Pl target Identifies the application to which the instruction is
directed. Can be any name that does not start with xm1.
Pl value Optional data passed to the application.
Description Optional information about this item. This information is
not exported from the XMLOUT tool.
Item type Processing Instruction.
References
www.w3.0rg

Document

This item type specifies the root element in your XML document.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Element

Add an element below the root element. See Element.

Add Attribute

Add an attribute to the root element. See Attribute.

Add Comment

Add a comment below the root element. See Comment.

Add Processing

Add a processing instruction below the root element. See

Instruction Processing instruction.

Add CDATA Add a CDATA section below the root element. See

Section CDATA section.

Add Field Add a field below the root element. See Field. You must
first select the field in the Event view.

Add Variable Add a variable below the root element. See Variable.

Add Static text

Add a static text below the root element. See Static text.

Add Block Add a block container below the root element. See Block
Container container.

Settings

Label *  Label displayed in the Process view.

*  Element name in the XML output.
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Element
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Settings

Description Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type Element.

Has attributes

Shows whether or not the root element has attributes.

This item type specifies elements at any level below the root element.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Element

Add an element below the element. See Element.

Add Attribute

Add an attribute to the element. See Attribute.

Add Comment

Add a comment below the element. See Comment.

Add Processing

Add a processing instruction below the element. See

Instruction Processing instruction.

Add CDATA Add a CDATA section below the element. See CDATA

Section section.

Add Field Add a field below the element. See Field. You must first
select the field in the Event view.

Add Variable Add a variable below the element. See Variable.

Add Static text

Add a static text below the element. See Static text.

Add Block Add a block container below the element. See Block

Container container.

Settings

Label *  Label displayed in the Process view.
*  Element name in the XML output.

Description Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type Element.

Has attributes

Shows whether or not the element has attributes.

Owner element

The element one level above.
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Attribute
This item type adds an attribute to an element.

Shortcut menu commands

Edit Script Before | Insert or edit a before script.

Edit Script After Insert or edit an after script.

Add Field Add a field as value to the attribute. See Field. You must
first select the field in the Event view.

Add Variable Add a variable as value to the attribute. See Variable.

Add Static text Add a static text as value to the attribute. See Static text.

Settings

Label *  Label displayed in the Process view.
e Attribute name in the XML output.

Description Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type Attribute

Owner element The element that owns this attribute.

Attribute Value Shows whether you have defined the attribute value as a

type static text, variable, or field. If the attribute value is
empty, “Unknown” is displayed.

Static text

This item type:

Adds text to an element, i.e. create a text node below an element.
Adds text to a CDATA section.

Adds text to a comment.

Sets an attribute value.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.
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Settings

Label

*  Label displayed in the Process view.

e Text in the XML output.

Description

Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type

Static Text.

Output format

Used to select numeric or date format. See Output format
for fields and variables on page 28.

Variable
This item type:

e Adds data to an element, i.e. create a text node below an element.
e Adds data to a CDATA section.

. Adds data to a comment.

. Sets an attribute value.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Settings

Label

*  Label displayed in the Process view.

*  Variable name displayed in the XML preview.

Description

Optional information about this item. This information is
not exported from the XMLOUT tool.

Sample content

Descriptive text.

Item type

Variable.

Output format

Used to select numeric or date format. See Qutput format
for fields and variables on page 28.

Field
This item type:

e Adds data to an element, i.e. create a text node below an element.
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. Adds data to a CDATA section.

. Adds data to a comment.

. Sets an attribute value.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Unlink The field is normally linked to a field in the Event view.
You can unlink the field, and use the Unlinked export
property to specify what to do with the field data.

Settings

Label *  Label displayed in the Process view.

*  Variable name displayed in the XML preview.

Description Optional information about this item. This information is

not exported from the XMLOUT tool.

Sample content

Descriptive text entered in the Event configuration.

Item state

Linked — The field is linked to a ficld defined in the
corresponding Event.

Unlinked — The field is not linked to any field in the
Event configuration. Use the Unlinked export property to
specify what to do with the field data.

Unlinked export

Determines whether or not to export an unlinked field.
Do not export — Do not export the field.

Export as static text — Use Fixed Export Type below to
specify what to export as static text.

Export as variable — Use Variable Name below to
specify what to export.

Fixed Export Type

Below “Export as static text”.

Select to export the Label, Description, Sample Data, or
a fixed string. Use Fixed Export Value below to specify
what to export as Fixed String.

Fixed Export Value

Below “Fixed Export Type > Export Fixed String”.

The text to export. Must not contain quotation marks.
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Settings

Variable Name

Below “Export as variable”.

The variable name. You cannot type the s-prefix when
you enter the variable name. The prefix is automatically
included in the export.

Item type

Field.

Output format

Used to select numeric or date format. See Qutput format
for fields and variables on page 28.

Block container

Block containers in XMLOUT are equivalent to frames in PageOUT. When you
drop a block on an element in the Process view, the block is automatically
encapsulated in a block container.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Block

Add a block to the block container. See Block. You must
first select the block in the Event view.

Settings

Label

*  Label displayed in the Process view.

*  Name displayed in the XML preview.

Description

Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type

Block container.

Block

This item type maps blocks defined in the corresponding Event to node sets in the
XML document. You first add the block, then specify the node set (elements,
fields, etc.) within the block.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.
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Shortcut menu commands

Edit Sort Criteria

Edit sort keys for the block.
Syntax
"<«field>":"<type><order>"

where:

<types is either s (alpha-numeric) or N (numeric)
<orders> is either A (ascending) or D (descending)
Multiple sort keys

Multiple sort keys are separated with space.

Example

"customer name":"SA" "customer number":"NA"

Add Element

Add an element to the block. See Element.

Add Comment

Add a comment to the block. See Comment.

Add Processing

Add a processing instruction to the block. See Processing

Instruction instruction.

Add CDATA Add a CDATA section to the block. See CDATA section

Section

Add Field Add a field to the block. See Field. You must first select
the field in the Event view.

Add Variable Add a variable to the block. See Variable.

Add Static text

Add a static text to the block. See Static text.

Add Block
Container

Add a block container to the block. See Block container.

Add Before First
Instance Block

Add a before first instance block to the block. See Before
first instance block.

Add After Last
Instance Block

Add an after last instance block to the block. See After
last instance block.

Unlink You can manually unlink a block and all its fields from
the corresponding block and fields in the Event
configuration.

Settings

Label *  Label displayed in the Process view.

*  Name displayed in the XML preview.
Description Optional information about this item. This information is

not exported from the XMLOUT tool.
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Settings

Item type Block.

Before first instance block

This item type specifies a free block that will be added before the first instance of
a main block, i.e. a block specified in the corresponding Event.

Shortcut menu commands

Edit Script Before | Insert or edit a before script.

Edit Script After Insert or edit an after script.

Add Element Add an element to the free block. See Element.

Add Comment Add a comment to the free block. See Comment.

Add Processing Add a processing instruction to the free block. See

Instruction Processing instruction.

Add CDATA Add a CDATA section to the free block. See CDATA

Section section.

Add Field Add a field to the free block. See Field. You must first
select the field in the Event view.

Add Variable Add a variable to the free block. See Variable.

Add Static text Add a static text to the free block. See Static text.

Settings

Label Label displayed in the Process view.

Description Optional information about this item. This information is

not exported from the XMLOUT tool.

Item type Block Before First Instance.

Owner block The main block that invokes this free block.

After last instance block

This item type specifies a free block that will be added after the last instance of a
main block, i.e. a block specified in the corresponding Event.

Shortcut menu commands

Edit Script Before | Insert or edit a before script.
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Shortcut menu commands

Edit Script After

Insert or edit an after script.

Add Element

Add an element to the free block. See Element.

Add Comment

Add a comment to the free block. See Comment.

Add Processing

Add a processing instruction to the free block. See

Instruction Processing instruction.

Add CDATA Add a CDATA section to the free block. See CDATA

Section section.

Add Field Add a field to the free block. See Field. You must first
select the field in the Event view.

Add Variable Add a variable to the free block. See Variable.

Add Static text

Add a static text to the free block. See Static text.

Settings

Label Label displayed in the Process view.

Description Optional information about this item. This information is
not exported from the XMLOUT tool.

Item type Block After Last Instance.

Owner block

The main block that invokes this free block.

This item type specifies a free block that can be invoked using the callBlock

scripting function.

Shortcut menu commands

Edit Script Before

Insert or edit a before script.

Edit Script After

Insert or edit an after script.

Add Element

Add an element to the free block. See Element.

Add Comment

Add a comment to the free block. See Comment.

Add Processing

Add a processing instruction to the free block. See

Instruction Processing instruction.

Add CDATA Add a CDATA section to the free block. See CDATA
Section section.

Add Variable Add a variable to the free block. See Variable.
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Shortcut menu commands
Add Static text Add a static text to the free block. See Static text.
Settings
Label Label displayed in the Process view.
Description Optional information about this item. This information is
not exported from the XMLOUT tool.
Item type Free Block.
Resources

To the Resources folder, you can add XML template resources.

Shortcut menu commands

Import External Add an eternal DTD to the <!DocTYPE. . . > declaration
DTD and, at the same time, load the DTD as a template.
Load DTD as Load a DTD as a template.

Resource

Load XSD as Load an XSD as a resource. From this XSD, you can
Resource generate an XML document template.

Import XML File Load an XML document template.
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Properties view

Select a node in the Process view, and configure the corresponding properties in
the Properties view.
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