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About Overlay Editor

You use the Overlay Editor to create overlays.

An overlay can be regarded as information in a preprinted form that has not yet 
been filled out. Logotypes, organization names, and frames common to many 
types of output pages can be defined in one single overlay. If you need to change 
this information, you edit the overlay instead of changing every type of output 
page. 

This guide contains instructions on how to create overlays. For information on 
how to add overlays to an output page, see the PageOUT documentation.
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Overlay Editor settings

Before you start working with the Overlay Editor, you can specify default settings 
for the tool. These settings will be applied on all future overlays that you create 
using the Overlay Editor.

In addition to the settings described in this section, you can also specify tool 
settings related to specific areas. For example, you can specify different tasks to 
be performed automatically when you save an overlay. Such settings are 
described in their respective context in this guide. 
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Overlay Editor settings
Specifying units
You can specify the default units that will be used in the Overlay Editor.

To specify units

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the Units tab.

3 Specify the unit settings.

4 Click OK.

Unit settings

Metric Click to measure all quantities below in metric units.

Horizontal position The unit for measuring horizontal positions.

The default unit (1/10 inch) corresponds to the default 
scale of all grids (except the Millimeter Grid). Therefore, 
you can specify horizontal measurements according to 
the number of horizontal grid lines.

Vertical position The unit for measuring vertical positions.

The default unit (1/6 inch) corresponds to the default 
scale of all grids (except the Millimeter Grid). Therefore, 
you can specify vertical measurements according to the 
number of vertical grid lines.

Horizontal distance The unit for measuring horizontal distances.

Vertical distance The unit for measuring vertical distances.

Radius The unit for measuring radius.

Font size The unit for measuring font sizes.

Line thickness The unit for measuring line thickness.

Angle The unit for measuring angles.

Show units in 
dialogs

Select to show units after all values in object information 
and object setup dialog boxes.
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Overlay Editor settings
Specifying object type settings
You can specify default settings for the different object types (boxes, ellipses, 
text, etc.) that can be added to an overlay.

When you have added an object, you can edit the settings for that specific object. 
Information on how to do this is described in the relevant sections of this guide.

To specify object type settings

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the Defaults tab.

3 Select the object type.

4 Specify the object type settings.

5 Click OK.

Object type settings

Properties Click to specify the default settings for the object type. See:

• Box properties on page 31.

• Ellipse properties on page 31.

• Check box properties on page 31.

• Grass line and marker line properties on page 31.

• Freeline properties on page 32.

• Horizontal line and vertical line properties on page 32.

• Font properties on page 25.

Info Click to receive detailed information about the object type.

Snap point Click to specify grid and snap points for the object type. See 
Grid and snap point settings on page 22.

Paragraph Click to specify paragraph properties for the object type. See 
Paragraph properties on page 26.

Grid Click to specify grid parameters for the object type. See Grid 
parameters on page 21.

You can specify a default grid, or you can create a new grid, 
see Creating custom grids on page 20.

Reset Click to return the settings above to the default settings.
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Overlay Editor settings
Specifying general Overlay Editor settings
You can specify general settings for the Overlay Editor, for example how you 
want the tool to behave on startup, and how you want the tool to display grids.

To specify general tool settings

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the General tab.

3 Specify the general tool settings.

4 Click OK.

General tool settings

Show positions relative 
to grid

Select to give the position of objects relative to the 
grid.

If cleared, the position of objects will be given 
relative to the upper-left corner of the page.

Show selection size Select to dynamically display the size of an area that 
you select using the mouse. This function works 
only in editing or zoom mode.

Ruler initially visible Select to display the ruler.

Open empty document 
at startup

Select to open an empty document each time you 
start the program.

Display page setup for 
new document

Select to display the Page format dialog box each 
time you create a new overlay.

Beep on errors Select to make the Overlay Editor signal any errors 
you make with a beep.

Use TAB key in editor Select to make it possible to use tabs in text.

If cleared, and an object is selected, the TAB key can 
be used for jumping to, and selecting other objects.

Snap to grid Select to snap objects to the grids.

Show grid full page Select to display grid lines on the whole page.

If cleared, grid lines are only visible within the 
current grid area.

Show grid numbers Select to show numbers for grid lines.

Show grid offset line Select to show the main grid axis in red color.
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Overlay Editor settings
Use font kerning 
information

Select to use font kerning in text. 

Note: You can clear this option to gain 
performance, but this may result in not 
evenly spaced text characters.

Prompt for PDF import 
options

Only applicable when the PDFIN filter is installed.

Select to display PDF Import dialog where you set 
password and path to font map file.

Grid type Select to display the grid as lines, dots, or crosses. 
You can also select to hide the grid.

General tool settings
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Overlays

An overlay is the main entity in the Overlay Editor. Each overlay consists of one 
or more pages. When you design an overlay, you can either start from an existing 
overlay, or create a new overlay.
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Overlays
Handling unavailable fonts
If you open an existing overlay, the overlay may contain fonts that are unavailable 
on your workstation. You can specify how the Overlay Editor should handle the 
substitution of such fonts.

To specify font substitution settings

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the Fonts tab.

3 Specify the font substitution settings.

4 Click OK.

Font substitution settings

Ask for font 
substitution name

Only applicable when opening FFD files (see Stand-
alone formats on page 53) in stand-alone mode.

Select to override the automatic font substitution as well 
as the settings in the font substitution table below. You 
can specify exactly how each missing font should be 
replaced.

Always substitute 
Type 1 fonts with 
TrueType

Select to substitute all PostScript Type 1 fonts with 
TrueType fonts. This is useful if you open overlays 
created by using PostScript Type 1 fonts on a workstation 
that does not have PostScript fonts or Adobe Type 
Manager installed.

Always substitute 
by table

Select to search for substitution fonts by looking in the 
font substitution table below.

Note: The fonts will be substituted according to the 
table, even if fonts that exactly match the original 
fonts are installed in your system.

Typefaces to 
substitute

A list of fonts to be substituted, if they are present in an 
overlay that you open.

Available typefaces A list of available replacement fonts.
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Overlays
Opening existing overlays
You can open and reuse an existing overlay.

If the overlay is a single-page overlay created in Design 1.31 (an earlier version 
of the Overlay Editor), you must import the overlay instead of opening it.

Prerequisites

If you want the Overlay Editor to substitute unavailable fonts, you must specify 
how the substitution is to be handled before you open the overlay.

To open an existing overlay

Select File > Open and open the overlay.

To import a single-page overlay

Select File > Import > Page and open the overlay.
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Overlays
Creating new overlays
When you create a new overlay, you specify the page format for the pages within 
the overlay.

To create a new overlay

1 Select File > New. The Page Format dialog box opens.

2 Specify the page format settings.

3 Click OK.

You can edit the page format settings at any time by selecting Page > 
Page Setup, and specifying new settings for the selected page.

Page format settings

Paper name The paper size.

Page size If you want to use a paper size that is not listed, specify 
the exact Width and Height (in millimeters).

Orientation The paper orientation – Portrait or Landscape.

Draw on screen/on 
printer

The items to be included when the overlay is shown on 
the computer screen and when it is printed. 

Printable area – Displays the printer margins.

Printer The printer options.

Note: When working with StreamServe, you should not 
select the Use Margins on printer option.

Save settings as 
default

Select to set the current settings as default settings.

Hide this dialog 
next time

Only applicable when creating a new overlay.

Select to hide the Page Format dialog box next time you 
create a new overlay.

Apply settings to 
all pages

Only applicable when editing an existing overlay.

Select to apply the page format settings to all pages 
within the overlay.
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Pages

Each overlay consists of one or more pages. On each page, you can insert 
graphics, text, lines, etc. in order to create the required layout of the overlay.

Adding pages
You can add new pages one by one, or you can insert several pages at the same 
time. You can also duplicate the current page.

To add a single page

Select Page > Add Page.

To add multiple pages

1 Select Page > Insert Pages. The Insert Pages dialog box opens.

2 Specify the number of pages, and where to insert the pages.

3 Click OK.

To duplicate a page

1 Make sure the page you want to duplicate is selected.

2 Select Page > Duplicate Pages. The Duplicate Pages dialog box opens.

3 Specify where to insert the duplicate page.

4 Click OK.

Changing page numbers
By changing the page number, you can move a page to another position in the 
overlay.

To change page numbers

1 Select Page > Change Number. The Change Page Number dialog box 
opens.

2 Enter the new page number.

3 Click OK.
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Pages
Measuring distances on a page
You can measure the distance between any two points on a page. The result is 
presented both in millimeters, and in horizontal and vertical grid steps.

To measure a distance on a page

1 Select Edit > Action > Measure.

2 Click the starting point.

3 Click the point you want to measure the distance to. The Distance Between 
Points dialog box opens and displays the result.

4 Click Close.

Entering and viewing page information
You can enter information about each page, for example a short description of the 
page, and notes describing relevant page information. You can also view 
information from the Overlay Editor, for example when the page was created.

To enter and view page information

1 Select Page > Page Info. The Page Info dialog box opens.

2 Enter the page information, and view the information from the Overlay 
Editor.

3 Click OK.

Deleting pages
You can delete one ore more pages at the same time. You can enter whole page 
intervals, or single pages separated by commas. For example, entering 1-3,5 will 
remove pages 1, 2, 3 and 5.

To delete pages

1 Select Page > Delete Pages. The Remove pages dialog box opens.

2 Specify the pages you want to remove.

3 Click OK. The Overlay Editor asks you to confirm.

4 Click Yes.
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Grids

Using the Overlay Editor grids, you can position objects very precisely. The 
appearance on screen matches the actual output for all formats (except PCL, 
which uses its own font system), and all images, lines, ellipses, and text objects 
will be positioned correctly.

Available grids

For each page, there are five different grids available. You can also create your 
own custom grids. All grids are simultaneously active, but only one of them is 
visible at a time. Different pages in an overlay can have different grids visible at 
the same time, and different objects on a page can be snapped to different grids, 
or to no grid at all.

Default grid for an object

Provided that snapping to grid is activated, each object that you add is snapped to 
a grid according to the default settings for the particular object type, see 
Specifying object type settings on page 9. If you move an object that is not 
snapped to the currently visible grid, it will remain snapped to the grid that it was 
originally snapped to.

You can edit the grid parameters for a selected page, or the grid and snap point 
settings for a specific object at any time.
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Grids
Creating custom grids
You can create a grid according to the description below. Such a grid can be used 
on the selected page, but not on any other pages in the overlay. If you want to use 
the new grid on several pages, you must create the grid when you specify the 
object type settings, see Specifying object type settings on page 9.

To create a custom grid

1 Select Form > Grid > Setup. The Select Grid dialog box opens.

2 Enter a name for the grid.

3 Click Add. The grid is added to the list.

4 Select the grid and click Edit. The setup dialog box for the grid opens.

5 Specify the grid settings.

6 Click OK twice.

Grid settings

Offset The distance from the edge of the page to the grid offset 
line.

Click × 2 or / 2 to double or halve the value.

Snap distance The distance between two grid lines.

Click × 2 or / 2 to double or halve the value.

Show main lines 
every

The number of grid steps between two main grid lines.

Show snap lines 
every

The number of grid steps between shown grid lines.

Offset from left 
side of the page

Select to offset the grid from the left side of the page.

Offset from right 
side of the page

Select to offset the grid from the right side of the page.

Set Defaults Select to revert to the default settings.
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Grids
Editing grid parameters for a selected page
You can edit the parameters for the grids on the selected page.

To edit the grid parameters

1 Select Form > Grid > Setup. The Select Grid dialog box opens.

2 From the list, select the grid you want to be displayed.

3 Edit the grid parameters.

4 Click OK.

If you just want to activate snap to grid, select Form > Snap To Grid.

If you just want to change the display mode of the grid, select Form > 
Grid > Foreground, Background or Hidden.

Grid parameters

Grid under objects Select to display the grid in the background.

Grid over objects Select to display the grid in the foreground.

Invisible Select to hide the grid.

Align all grids to 
left

Select to align all grids to the left. The offsets will be 
calculated from the left, and the grid lines will be 
numbered from left to right.

Align all grids to 
right

Select to align all grids to the right. The offsets will be 
calculated from the right, and the grid lines will be 
numbered from right to left.

Snap to grid Select to snap objects to the grids.

Show grid line 
numbers

Select to display the grid line numbering.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



22 Editing grids and snap points for a selected object
Grids
Editing grids and snap points for a selected 
object

You can edit the grid and snap point settings for a selected object.

To edit the grid and snap point

1 Right-click the object and select Snap Point. The Snap Point Setup dialog 
box opens.

2 Edit the grid and snap point settings.

3 Click OK.

If you just want to change to another grid, right-click the object, select 
Object Grid, and select the new grid.

Grid and snap point settings

Relative to The point on the object to snap to the grid.

Each radio button corresponds to a point on the object. 
For example, the top left radio button corresponds to the 
top left point on the object.

Snap object to grid The grid to snap the object to.

X An offset between 0 and 1 grid step that will fine tune the 
snap point in the X direction.

Y An offset between 0 and 1 grid step that will fine tune the 
snap point in the Y direction.

Snap to text 
baseline

Select to snap a text object to the text baseline.
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Text

You can add several types of text objects to a page in an overlay. 

Defaults font and paragraph properties

When you add a text object, the font and paragraph properties are set according 
to the default settings for the text type, see Specifying object type settings on page 
9. You can edit the properties for a selected text object at any time.

Available text objects

You find all text object tools in the Graphics toolbox. When you position the 
cursor over a tool, the name of the tool is displayed in the status bar.

• Header text – For headings.

• Field text – For field text information.

• Guide text – For guide text in data fields.

• Free Text – For informative text, such as legal text, license agreements etc.
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Text
Adding text
When adding text, you must first add a text object and then enter the text in the 
text object. You can insert special characters in the text, for example non-breaking 
spaces, and the current date and time.

To add a text object

1 In the Graphics toolbox, select the suitable text tool.

2 On the page, use the mouse to specify the size and position of the text 
object. The text object is added to the page.

To enter text in the text object

1 Select the tool Select text editing mode.

2 Click the text object.

3 Enter the text. Insert special characters by selecting Edit > Insert, and select 
the required special character.

4 When you are finished entering the text, click outside the text object.
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Text
Formatting text
You can edit the font properties for an entire text object, or for a specific word or 
character within the text object. You can also use different baseline shifts for 
specific words or characters.

To edit font properties

1 Right-click the text object, word, or character and select Font. The Font 
dialog box opens.

2 Edit the font properties.

3 Click OK.

To shift the baseline of a word or character

1 Select the word or character and press CTRL+SHIFT+S. The Baseline 
dialog box opens.

2 Specify the offset (in points). A positive value will displace the baseline 
upwards. A negative value will displace the baseline downwards.

3 Click OK.

Font properties

General Select to specify general font properties, such as font and 
font style.

Size options Select to further specify the font size. 

The radio buttons attached to the text sample represent 
different character height parameters. You should use the 
Character Height parameter to modify the font size, 
since this is the normal way to do it in most Microsoft 
Windows programs.
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Text
Formatting paragraphs
You can edit the paragraph properties for an entire text object, or for a specific 
paragraph within the text object.

To edit paragraph properties

1 Select the text object or paragraph, and select Object > Paragraph. The 
Paragraph dialog box opens.

2 Edit the paragraph properties.

3 Click OK.

Paragraph properties

Indentation Left indent – The left indent of the paragraph.

Right indent – The right indent of the paragraph.

First line indent – The left indent for the first line in the 
paragraph.

Spacing Before paragraph – The space before the paragraph.

After paragraph – The space after the paragraph.

Line spacing Auto – Select to use the default line spacing.

Fixed – Select to use a fixed line spacing (in points).

Relative – Select to use a relative line spacing (in percent 
of the row height). The row height is equal to the 
maximum font cell size for a capital letter, including line 
spacing, plus any baseline shift.

Alignment Left – Select to align the paragraph to the left.

Centered – Select to center the paragraph.

Right – Select to align the paragraph to the right.

Justified – Select to adjust the horizontal spacing so that 
the text is aligned evenly along the right and left margins. 
The last line will be aligned according to the selected 
option above.

Dotted fill – Select to fill any remaining unused space 
with a dotted line.

Tabs Click to specify the tab settings.

Note: To be able to use tabs in text, you must enable the 
use of the TAB key, see Specifying general 
Overlay Editor settings on page 10.
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Text
Rotating text
You can specify a specific rotation angle for a text object, or you can rotate the 
text object in increments of 90 degrees.

To specify the rotation angle for a text object

1 Right-click the text object and select Object Info. The Object Info dialog 
box opens.

2 In the Angle field, specify the rotation angle (in degrees).

3 Click OK.

To rotate a text object 90 degrees clockwise

Select the text object, and click the Rotate button.
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Graphics

You can add lines of different types, boxes, ellipses, check boxes etc. to a page in 
an overlay.

Defaults properties of graphics

When you add a graphic, the properties are set according to the default settings 
for the graphic object type, see Specifying object type settings on page 9. You can 
edit the properties for a selected graphic object at any time.

Available graphic objects

You find all graphic object tools in the Graphics toolbox. When you position the 
cursor over a tool, the name of the tool is displayed in the status bar.

• Box – For rectangles with sharp or rounded corners.

• Ellipse – For circular and oval objects.

• Check box – For check boxes.

• Freeline – For solid lines, dashed lines, and arrows.

• Grass line – For evenly spaced vertical grass lines, suitable for indicating 
text that should be entered in block letters.

• Marker line – For evenly spaced marker lines, suitable for dividing large 
fields into several smaller parts.

• Vertical line – For evenly spaced vertical lines.

• Horizontal line – For evenly spaced horizontal lines.

• Vertical dotline – For evenly spaced vertical dotted lines.

• Horizontal dotline – For evenly spaced horizontal dotted lines.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



30 Adding graphics
Graphics
Adding graphics
1 In the Graphics toolbox, select the appropriate tool.

2 On the page, use the mouse to specify the size and position of the text 
object. An object of the specified size is added to the page.

Editing graphics
You can edit the geometrical and object-specific properties of a graphic.

To edit a graphic

1 Double-click the graphic object. The associated dialog box opens.

2 Modify the properties of the graphic object.

3 Click OK.

Geometrical properties of graphics
You modify the geometrical properties (position, size, line thickness, etc.) of a 
graphic object in the object setup dialog box that opens when you double-click the 
object.

Units

In the dialog box, the geometrical properties are specified using default units, see 
Specifying units on page 8.

Note: You can specify measurements in other units than the default ones. In that 
case, the Overlay Editor recalculates the specified values, and presents the 
properties using the default units.

Displacement

The object is either displaced from the origin of the grid, or from the upper-left 
corner of the page, see Specifying general Overlay Editor settings on page 10. 

Figure 1 Geometrical properties of a freeline
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Graphics
Box properties
You specify the box properties in the Box Setup dialog box.

Ellipse properties
You specify the ellipse properties in the Ellipse Setup dialog box.

Check box properties
You specify the check box properties in the Check Box Setup dialog box.

Grass line and marker line properties
You specify the grass and marker line properties in the Grass Lines Setup and 
Marker Lines Setup dialog boxes.

Box properties

Equal linewidths Select to use equal line widths for horizontal and vertical 
lines.

Equal corners Select to use equal corners.

Borders Select the check boxes that correspond to the sides you 
want to be shown on the printed overlay.

Repetitions Click to add several boxes of the same type.

Specify the distance between the boxes, and the number 
of boxes you want to add.

Ellipse properties

Repetitions Click to add several ellipses of the same type.

Specify the between the ellipses, and the number of 
ellipses you want to add.

Check box properties

Repetitions Click to select several check boxes of the same type.

Specify the distance between the check boxes, and the 
number of check boxes you want to add.

Grass line and marker line properties

Repeat Count The number of grass or marker lines to display.
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Graphics
Freeline properties
You specify the freeline properties in the Freeline Setup dialog box.

Horizontal line and vertical line properties
You specify the properties of horizontal and vertical lines (including dotted lines) 
in the Horizontal Lines Setup and Vertical Lines Setup dialog boxes.

Freeline properties

Clip to bounding 
rectangle

Select to make the line ends limited by the bounding 
rectangle of the line.

Note: To see the effect, select View > Show Exact.

Arrows Click to insert arrow heads.

You can insert a left and a right arrow head. For each 
arrow head, you can specify the size and angle.

Note: To see the effect, select View > Show Exact.

Dash Click to create a dashed line. 

You can either use a solid or a dashed line. For a dashed 
line, you specify the lengths of the dashes and the gaps, 
and whether you want the line to start with a dash or a 
gap. You can also center the dashes on the line.

Horizontal and vertical line properties

Repeat Count The number of horizontal or vertical lines to display.

Dash Click to create a dashed line.

You can either use a solid or a dashed line. For a dashed 
line, you specify the lengths of the dashes and the gaps, 
and whether you want the line to start with a dash or a 
gap. You can also center the dashes on the line.
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Images

You can add images of most of the common image formats to an overlay page. 
Once the image is added, you can manipulate it in the following ways:

• Specify image properties. The properties will be applied on the added 
source image, without changing the source image.

• Specify how you want the image to be displayed on screen. The display 
properties will be applied on top of the image properties, without changing 
the source image.
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Adding images
Prerequisites

Before you can add an image, you must include it as a resource in the resource set 
you intend to use.

To add an image from a resource set

1 Select File > Import > Image. The Select Resource dialog box opens.

2 Browse to the correct folder and double-click the image.

3 Position the image using the mouse.

Adding images when running in stand-alone mode
When you run the Overlay Editor in stand-alone mode, you must embed images. 
When you import the overlay to a resource set, all embedded images are added as 
image resources to the same resource set. This means the overlay resource will 
use references to the image resources instead of using the embedded images.

To add an image

1 Select File > Import > Image. The Import image dialog box opens.

2 Select the image.

3 Select Embedded image to embed the image.

4 If you want to use the mouse to position the image, select Position image 
with mouse. Otherwise, the upper-left corner of the image will be placed 
where you last clicked the mouse.

5 Click OK.

When you save an overlay that includes embedded or linked images, 
the images are automatically included in the resource set. Therefore, if 
you add an image by copying it from the clipboard (embed the image) 
or by dragging it from the Windows Explorer (link the image), you do 
not have to include it in the resource set.
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Disabling conversion of embedded images to resources
By default, embedded images are automatically included in the resource set when 
you save an overlay.

If required, you can select not to convert embedded images into resources. For 
example, in Projects created in old versions of StreamServe you may want to keep 
the images embedded.

To disable conversion of embedded images

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the LXF tab.

3 Clear Convert embedded images to resource.

To convert an image resource to an embedded image

Right-click the image and select Revert to embedded.

Importing images from a scanner or digital camera
If you have a scanner or a digital camera with TWAIN drivers installed on your 
workstation, you can import images directly into the Overlay Editor directly from 
this source. Before you can import the images, you must identify the source.

To select the scanner source

1 Select File > Scanner > Select Source. The Select Source window opens.

2 Select the source.

3 Click Select.

To scan and import images

1 Select File > Scanner > Acquire. The Overlay Editor starts the default 
scanner or digital camera application.

2 Scan or select the image using the default scanner application as usual. 
When the image has been acquired, you will automatically be returned to 
the Overlay Editor window and the selected overlay.

3 Position the image on the page using the mouse.
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Images
Specifying how images are displayed on 
screen

The appearance of images on screen will never exactly match the appearance of 
images in a printed overlay. By specifying the imaging preferences, you can 
change the way images are displayed on screen in order to achieve a higher degree 
of similarity to printed output. The settings will affect all images in the overlay.

Note: The display settings will not affect the printed output.

To specify how images are displayed on screen

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the Imaging tab.

3 Specify the display settings.

4 Click OK.

Display settings

Intensity An intensity value between -100 and +100, where -100 
corresponds to black and +100 corresponds to white.

Contrast A contrast ratio between -100 and +100 (in percent).

The contrast ratio is the ratio between the brightest white 
and the darkest black in an image.

Gamma A gamma correction factor between 0.01 and 4.99.

Gamma is a numerical parameter that describes the non-
linear relationship between pixel value and intensity. The 
non-linearity of the screen must be compensated in order 
to achieve a correct reproduction of the intensity in an 
image. 

Dithering Dithering is a technique that is used to mix pixels of 
available colors to simulate colors that are currently not 
available.

Ordered – This option is faster than Error diffusion, but 
the result is often not as good. It may produce a 
distinctive pattern of darker or lighter areas in the image.

Error diffusion – This option produces a less structured 
dither than the Ordered option. It eliminates the 
distinctive patterning using the surrounding pixels when 
mixing the pixel color. However, diffusion dithering may 
cause visual inconsistencies when only a part of the 
screen is redrawn.
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Specifying image properties
For each image, you can configure a number of properties. These properties will 
be applied when the image is used on the overlay page. The source image will 
remain unchanged.

To configure image properties

1 Double-click the image. The Image Properties dialog box opens.

2 Configure the image properties.

3 Click OK.

If you are not satisfied with the configured properties, you can right-
click the image and select Select Resource or Reimport. The image 
will be reloaded and the properties will return to the default values.

You can always revert to the original image size by right-clicking the 
image and selecting Original Size.

Image properties

Browse Click to replace the current image with another image.

Size New values for Width and Height.

Scale – The size (in percent) relative to the original size.

Relative – The size (in percent) relative to the current 
size.

Size – The absolute size.

Keep proportion – Select to keep the ratio between the 
width and height.

Vertical mirror Select to mirror the image vertically.

Horizontal mirror Select to mirror the image horizontally.

Inverted Select to display the negative of the image.

Locked Select to lock the image so it cannot be moved or edited.

Under grid Select to display the grid in the foreground.

Brightness A value between 0 and 255 that adjusts the brightness.

Angle A rotation angle (in degrees). The image will be rotated 
and resized to fit within the original image area.

Transparence Click to change the color transparency.
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Editing source images
You can select an image in Overlay Editor, and open Windows Explorer with the 
corresponding image file high-lighted. Then you can use the appropriate image 
editing tool to edit the source image.

To edit a source image

1 Right-click the image and select Open Containing Folder. Windows 
Explorer opens with the corresponding image file high-lighted.

2 Use the appropriate image editing tool to edit and save the image.
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Exporting images
1 Right-click the image and select Export Image. The Export Image dialog 

box opens.

2 Browse to a suitable directory and enter an appropriate file name.

3 Select the format you want to export the image to.

4 Click Save.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



40 Exporting images
Images
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



41
Coloring objects

You can add colors to objects, such as lines and text. You can also fill boxes and 
ellipses with color.

To color an object

1 Right-click the object and select Stroke Color (for lines), Text Color (for 
text), or Interior color (for filling). The Color dialog box opens.

2 Specify the color settings.

3 Click OK.

Color settings

Transparent Select to make the object invisible.

Gray Select to use a gray scale.

Gray – A value between 0 and 100%, where 100 means 
black and 0 means transparent.

Print on all separations – Select to make the color 
appear on all color separations.

Overprint – Select to prevent dark colors in the 
background from blending with the object.

RGB Select to use RGB colors. The RGB system is used for 
on-screen display.

Specify the stroke color in red (R), green (G), and blue 
(B) colors. Enter a value between 0 and 255 for each 
color.

Overprint – See above.

CMYK Select to use CMYK colors. The CMYK system is used 
for printed color.

Specify the stroke color in Cyan, Magenta, Yellow, and 
Black. Enter a value between 0 and 100% for each color.

Overprint – See above.

Custom Select to specify a CMYK color with custom color name.

Specify the stroke color in Cyan, Magenta, Yellow, and 
Black. Enter a value between 0 and 100% for each color.

Name – The name of the color.

Overprint – See above.
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Object layout

You can change the layout of objects on the overlay page. For example, you can 
align, move, and distribute objects. If objects overlap or cover each other, you can 
bring them to the front or send them to the back.

Aligning objects
You can align a group of objects with the object that is furthest in the alignment 
direction. For example, if you left align objects, the left side of each object will 
be aligned with the left side of the object that is furthest to the left. You can also 
make the width of all selected objects equal to the widest object.

To align objects

1 Select the objects.

2 Select Object > Arrange > Align Objects > Right, Left, Top, Bottom, or 
Align Widths.

Distributing objects
You can distribute a group of objects horizontally or vertically. The objects will 
be evenly distributed over the distance between the two objects that are furthest 
from each other.

To distribute objects

1 Select the objects.

2 Select Object > Arrange > Space evenly > Across or Down.
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Object layout
Moving objects relative to the grid
1 Select the objects.

2 Select Object > Arrange > Move. The Move selected objects dialog box 
opens.

3 Specify the move options.

4 Click OK.

Arranging overlapping objects
If objects overlap or cover each other, you can bring them to the front or send 
them to the back.

To bring objects forward or send backward one level

1 Select the objects.

2 Select Object > Arrange > Move Up or Move Down.

To bring objects to front or send objects to back

1 Select the objects.

2 Select Object > Arrange > Bring To Front or Send To Back.

Move options

Horizontal The number of grid steps that you want to move the 
selected objects horizontally.

Vertical The number of grid steps that you want to move the 
selected objects vertically.

Leave original Select to leave the original object in its place, and only 
paste a copy of it in the new position.

Repeat – The number of evenly spaced objects you want 
to create.
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Object layout
Locking objects
You can lock objects so they cannot be moved by accident.

To lock an object

1 Select the object.

2 Select Form > Form Info. The Form Info dialog box opens.

3 Select the Objects tab. A list of the objects is displayed, with the selected 
object highlighted.

4 Click Lock.

5 Click OK.
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Object libraries

You can create object libraries containing custom objects that you use frequently, 
for example logotypes, headers, footers, etc. First you add an object library to the 
Object Library toolbox, and then you add the objects to the library.

Adding object libraries
You can add new or existing object libraries to the Object Library toolbox.

To add a new object library

1 Select View > Object Library Toolbox. The Object Library toolbox opens.

2 Click Setup. The Preferences dialog box opens.

3 Click New. The Save Object Library dialog box opens.

4 Save the library file in a suitable directory. The Object Library dialog box 
opens.

5 Enter a name for the library and any additional comments.

6 Click OK twice.

To add an existing object library

1 Select View > Object Library Toolbox. The Object Library toolbox opens.

2 Open the toolbox menu and select Settings. The Preferences dialog box 
opens.

3 Click Find. The Locate Object Library dialog box opens.

4 Open the library to be added.

5 Click OK.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



48 Adding objects to object libraries
Object libraries
Adding objects to object libraries
You must add objects to the object library in the Object Library toolbox.

Prerequisites

When reusing an object from the object library, the object will be inserted in the 
same position as it was located in when it was added to the object library. Make 
sure that the object is placed in the correct position before adding it to the library.

To add objects to an object library

1 Select the objects.

2 Select View > Object Library Toolbox. The Object Library toolbox opens.

3 From the drop-down list, select the object library.

4 In the Object Library toolbox, click Add. The Object Library Entry dialog 
box opens.

5 Enter a name for the object.

6 Click OK.

Inserting objects from object libraries
You can insert an object from an object library on the selected overlay page. The 
object will be inserted in the same position that it was located in when it was 
added to the object library.

To insert an object

1 Select View > Object Library Toolbox. The Object Library toolbox opens.

2 Select the object library.

3 From the list of available objects, select the object.

4 Click Insert.
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Entering and viewing overlay 
information

General information about an overlay, as well as detailed information about added 
objects, imported images, used fonts, etc., is automatically saved in the overlay 
file. You can enter and view overlay information at any time.

To enter and view overlay information

1 Select Form > Form Info. The Form Info dialog box opens.

2 Select the appropriate tab.

3 Enter new information, and view information from the Overlay Editor.

4 Click OK.

General overlay information
You find the general overlay information on the General tab in the Form Info 
dialog box.

General overlay information

Document • The name of the overlay.

• The directory where the overlay is stored.

• The date when the overlay was created.

• The date when the overlay was last saved.

• The Overlay Editor file version.

Creator The name of the user that created the current file. You can 
edit the name and add more information to this field. 

Save creator name as default – Select to set the current 
creator as the default creator.

Description A description of the overlay.

Notes Notes concerning the overlay.

Template The name of the creator of the overlay template that was 
used when creating the current overlay.

Paper size The paper size of the overlay.

Passwords Indicates if the overlay is protected by a password.
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Entering and viewing overlay information
Information about added objects
You find the object information on the Objects tab in the Form Info dialog box.

Document 
identifier

A unique number that identifies the overlay.

Pages Makes it possible to edit and view notes and descriptions 
for each page in the overlay. Select the page and click 
View.

General overlay information

Object information

Objects on current 
page

A list of all the objects that have been added to the current 
page.

The objects are listed in the order in which they appear on 
the page, starting with the object closest to the foreground 
at the top, and ending with the object closest to the 
background at the bottom.

Up Click to move the selected object closer to the 
foreground.

Down Click to move the selected object closer to the 
background.

Lock See Locking objects on page 45.

Unlock Click to unlock the selected object.
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Entering and viewing overlay information
Font information
You find the font information on the Fonts tab in the Form Info dialog box.

You find the information about embedded fonts on the Embedding tab in the 
Form Info dialog box.

Color information
You find the color information on the Colors tab in the Form Info dialog box.

Font information

Typefaces and 
fonts

A list of all the fonts that have been used in the overlay.

Change Click to change the properties of the selected font.

Information about embedded fonts
Only applicable when using FFD files (see Stand-alone formats on page 53) in 
stand-alone mode.

Typeface families A list of all TrueType fonts used in the overlay.

Embedded Click to embed the selected font into the overlay. When 
opening the overlay on a workstation where the font is 
unavailable, the font will be installed automatically.

Normal Click to not embed the selected font in the overlay. For 
example, if the font is protected by copyright conditions 
stated in the font file.

Embed all Select to embed all listed fonts in the overlay.

Color information

Colors used in 
current document

A list of all the colors – standard or custom RGB and 
CMYK colors – that have been used on the current page.

Change Click to change the properties of a selected color.

Turn all output into 
grayscale

Select to convert the colors to gray scale.
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Saving overlays

To enable the use of an overlay in the PageOUT tool, you must save the overlay 
in an internal StreamServe format called LXF (Layout eXchange Format). The 
LXF file is used both for previewing the overlay in the PageOUT tool, and for 
printing the overlay on the output page.

Stand-alone formats

If you run the Overlay Editor in stand-alone mode, you can save the overlay in 
formats other than the LXF format. Such overlays cannot be used directly in the 
PageOUT tool, but can be used as templates when creating similar overlays.

The following stand-alone formats are available:

• Fill-In Overlay Editor Form (*.ffd) – A standard Overlay Editor format.

• Fill-In Overlay Editor Compressed (*.fdz) – A compressed version of the 
standard Overlay Editor format.

PRN and EMF formats

In previous versions of StreamServe, you exported an overlay to one PRN file 
(PCL or PostScript print file) and one EMF file (Enhanced MetaFile). These files 
were then used in StreamServe Projects.

Nowadays, you should always create and use overlays in LXF format. However, 
you can still use your old overlays in PRN/EMF format in new Projects. For more 
information, see the PageOUT documentation.
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Saving overlays
Specifying general saving settings
Only applicable when running in stand-alone mode.

Before you save a overlay, you can specify different tasks to be performed 
automatically when you save the overlay.

To specify saving settings

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the Save tab.

3 Specify the saving settings.

4 Click OK.

Saving settings

Write page preview 
into file

Select to save a 100×100 pixel thumbnail in Windows 
Bitmap format for each page in an FFD file.

Compress page preview – Select to compress the page 
preview thumbnail files by up to 90% using RLE (run-
length encoding).

Create backup 
before saving

Select to create backup copies (*.bak) of files before 
saving the new versions.

Compact file when 
lost space exceeds 
XX%

Since FFD files are saved by using a compound file 
technique, large overlay files with many pages may 
eventually become fragmented. Activating this setting 
avoids this. Recommended: 35%

Ask user before compacting file – Select to make the 
Overlay Editor ask for permission before compacting 
files.

Save last recently 
used directories

Select to make the Overlay Editor remember the 
directory where you last opened or saved a file. This 
directory will then be opened the next time you want to 
open or save a file.
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Specifying LXF-related saving settings
Before you save an overlay as an LXF file, you can specify different tasks to be 
performed automatically when you save an overlay as an LXF file.

To specify LXF-related saving settings

1 Select View > Preferences. The Preferences dialog box opens.

2 Select the LXF tab.

3 Specify the LXF-related saving settings.

4 Click OK.

Password protecting overlays
Only applicable when creating FFD files (see Stand-alone formats on page 53) in 
stand-alone mode.

You can protect an overlay by using a password (max 10 characters), so that no 
unauthorized user can open it.

To password protect overlays

1 Select Form > Passwords. The Set Passwords dialog box opens.

2 Enter and retype the password.

3 Click OK.

LXF-related saving settings

Convert embedded 
images to files

Only applicable when running in stand-alone mode.

Select to convert all embedded images to linked images.

Copy linked files to 
destination

Only applicable when running in stand-alone mode.

Select to copy linked image files to the same folder as the 
LXF file. This is useful if the exported LXF files are 
moved to another location, as it reduces the risk of broken 
links.

Convert embedded 
images to resource

See Disabling conversion of embedded images to 
resources on page 35.
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Saving LXF overlays
Select File > Save.

Saving stand-alone overlays as LXF files
Only applicable when running in stand-alone mode.

Before you can use an overlay in FFD or FDZ format in the PageOUT tool, you 
must save the overlay as an LXF file.

To save a a single overlay in LXF format

Select File > Save As and save the file in LXF format.

To batch convert overlays into LXF format

1 Select File > Convert Forms. The Convert forms dialog box opens.

2 In the Directory box, specify the directory containing the overlays.

3 From the Format 1 list, select Layout eXchange Format.

4 Click Options. The LXF export options dialog box opens.

5 Specify the export options.

6 Click OK.

7 In the Destination directory box, specify the directory for the LXF files.

8 Click Convert.

LXF export options

Include element 
defaults

Select to include all element settings, including the ones 
that have default values, in the LXF file. This option 
increases the LXF file size.

Convert embedded 
images to files

Select to save images as separate files. The image files 
are saved in the same folder as the LXF file.

If cleared, images are embedded into the LXF file.

Note: If you embed large image files, performance will 
be affected.

Copy linked files to 
destination

Select to copy linked image files to the same folder as the 
LXF file. This is useful if the exported LXF files are 
going to be moved to another location, as it reduces the 
risk of broken links.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



Saving LXF overlays 57
Saving overlays
To compress LXF files

When you save an LXF file (Save As option when saving single overlays and 
Format option when batch converting overlays) you can select Layout 
eXchange Format Compressed if you want to compress the LXF files.
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Printing and mailing overlays

From the Overlay Editor, you can print an overlay. If you run the Overlay Editor 
in stand-alone mode, you can send the overlay in an email directly from the 
Overlay Editor.

Printing overlays
Before you can print an overlay, you must specify the print settings for the 
Overlay Editor.

To specify the print settings

1 Select File > Print Format. The Preferences window opens.

2 Select the Printing tab.

3 Specify the print settings.

4 Click OK.

To print an overlay

Select File > Print.

Print settings

Print graphics Select to make any graphics appear on the printout.

Print images Select to make images appear on the printout.

Print info page after 
form

Select to create and print a separate page with general 
information after printing the overlay.

Send printer 
commands

Select to send printer command objects (which can be 
used for PCL macro files) to the printer.

Relative to printer 
default margins

Select to fit the overlay to the printable area on the printer 
paper.

Relative to 
absolute 
coordinates

Select to print the overlay relative to the upper-left corner 
of the paper, even though the printer cannot print all the 
way to the edge of the paper.
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Mailing overlays
Only applicable when running in stand-alone mode.

Requirements

• To be able to use the email function in the Overlay Editor, you must use an 
SMAPI compatible email program.

• Before you send the overlay by email, you must log in to the mail module.

To log in to the mail module

1 Select File > Mail > Log In. The Choose Profile dialog box opens.

2 From the Profile Name drop-down list, select the mail profile.

3 Click OK.

To mail an overlay

1 Select File > Mail > Send Form. The Compose Message dialog box opens 
an email message with the overlay attached.

2 Fill in the appropriate fields. Select Require receipt to ask the recipients to 
send a receipt when they have opened the message.

Note: The recipients must also be using a SMAPI compatible email 
program in order for the Require receipt option to work.

3 Click Send.
StreamServe Persuasion SP5 Overlay Editor User Guide Rev A



61
Converting PDF to LXF

You can open a PDF file in Overlay Editor (Stand alone), and convert it to LXF. 
When you open the PDF file, Overlay Editor uses the PDFIN filter to convert the 
PDF to LXF. See the PDFIN filter documentation for more information about the 
PDFIN filter.

To convert a PDF file to LXF

1 From Windows Start menu, select All Programs > StreamServe 
Persuasion > Design > Overlay Editor to open Overlay Editor.

2 Select File > Open and browse to and select the PDF file you want to open. 
The PDF import dialog box opens.

3 Configure the import settings (see PDF import settings below) and click 
OK. The PDF document is converted to LXF and opened in Overlay Editor.

4 Select File > Save to save the LXF document.

PDF import settings

Settings

Owner password The password to enter if the PDF input document is 
protected by an owner password.

User password The password to enter if the PDF input document is 
protected by a user password.

Font map file Path to a mapping table where PDF font names are 
mapped to Windows font names. See PDFIN filter 
documentation for more information.

Binary output This PDFIN filter option converts the PDF file to binary 
format. Not applicable to Overlay Editor.
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Converting PDF to LXF
Always create 
output

When enabled, the PDFIN filter always creates LXF 
output, even if an error occurs.

Consolidate text Select to create one text fragment for each line of text. If 
you do not select this option, each line of text in the LXF 
will consist of several text fragments.

See Consolidating text on page 63 for more information.

Hide this dialog 
next time

Select to hide this dialog box the next time you import a 
PDF file. You can enable the dialog box again if you 
select View > Preferences and select Prompt for PDF 
import options.

Settings
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Consolidating text
When you convert a PDF file to LXF, each paragraph section in the PDF is by 
default converted to several text fragments in the LXF. This means it will be 
difficult to edit the text in Overlay Editor.

Figure 2 Several text fragments in Overlay Editor.

When you import the PDF file, you can enable the option Consolidate text. If 
you do so, each line of text in the PDF is included in the same text fragment in the 
LXF.

Figure 3 Each text line one text fragment in Overlay Editor.

When you have imported the PDF file, you can manually define text fragments to 
consolidate. For example, you can consolidate the text in each paragraph.

Figure 4 Consolidating text in paragraphs.

To consolidate text manually

1 Select the text fragments you want to consolidate.

2 Select Object > Arrange > Consolidate.
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