Bearbeiten von vorhandenen Webseiten und Blogeinträgen

Sie können Webseiten in Websites und Blogeinträge in Blogs bearbeiten, mit denen Sie verbunden sind und zu deren Bearbeitung Sie berechtigt sind. Weitere Informationen finden Sie unter Herstellen von Verbindungen mit Blogs. Gesperrte Webseiten und Blogeinträge können nicht bearbeitet werden; die Sperre weist darauf hin, dass die Webseite oder der Blogeintrag gerade von einem anderen Benutzer bearbeitet wird. Wenn Sie eine Webseite oder einen Blogeintrag aufrufen, wird im Meldungsbereich unter der Symbolleiste angegeben, ob Sie die Seite oder den Blogeintrag bearbeiten können.

Contribute unterstützt die Bearbeitung von Inhalt in dynamischen Websites, die die Blogprotokolle MetaWeblog und Atom verwenden.

Während Sie eine Webseite oder einen Blogeintrag bearbeiten, speichert Contribute die Seite oder den Eintrag als Entwurf. Der Entwurfstitel wird im Bedienfeld „Seiten“ in der Seitenleiste angezeigt.

Bearbeiten von vorhandenen Webseiten und Blogeinträgen
Das Bedienfeld „Seiten“

Weitere Informationen finden Sie unter Bearbeiten von Webseiten. Informationen zum Arbeiten mit Entwürfen finden Sie unter Speichern von Entwürfen.

Hinweis: Informationen zum Bearbeiten von Microsoft-Dokumenten, die mit Ihrer Website verknüpft sind, finden Sie unter Bearbeiten von Webseiten in externen Anwendungen.

Möglicherweise gelten Beschränkungen hinsichtlich der bearbeitbaren Teile eines Webseitenentwurfs. Der Vorlagenersteller kann eine Vorlage mit gesperrten Bereichen erstellen oder der Contribute-Administrator kann über Bearbeitungsbeschränkungen festlegen, dass nur Text bearbeitet werden kann.

Hinweis: Wenn Sie eine Seite oder einen Seitenbereich bearbeiten müssen und nicht dazu berechtigt sind, wenden Sie sich an Ihren Contribute-Administrator oder lesen Sie den Abschnitt Verwalten von Benutzern und Rollen.

Sie können auch Contribute-Plugins verwenden, um Webseiten und Blogeinträge in Browsern wie Internet Explorer und Mozilla Firefox zu bearbeiten. Weitere Informationen finden Sie unter Bearbeiten von Webseiten oder Blogeinträgen vom Browser aus.

Bearbeiten von Webseiten

Nachdem Sie eine Verbindung mit einer Website hergestellt haben, können Sie die Seiten dieser Website ganz einfach anzeigen und bearbeiten.

  1. Navigieren Sie zu der Seite, die Sie bearbeiten möchten (siehe Durchsuchen von Webseiten und Blogeinträgen.

  2. Führen Sie einen der folgenden Schritte aus:

    • Klicken Sie in der Symbolleiste auf die Schaltfläche „Seite bearbeiten“.

    • Wählen Sie „Datei“ > „Aktionen“ > „Seite bearbeiten“.

    Die Seite wird im Contribute-Editor als Entwurf angezeigt und der Entwurfstitel wird im Bedienfeld „Seiten“ angezeigt.

Bearbeiten von Webseiten, die mit einem Inhaltstyp erstellt wurden

  1. Stellen Sie über die Liste in der Contribute-Startseite eine Verbindung mit einer Website her.

  2. Klicken Sie auf die erforderliche Datei im übergeordneten Verzeichnis.

  3. Klicken Sie im Browser auf „Seite bearbeiten“.

  4. Bearbeiten Sie den Inhalt der Seite.

  5. Senden Sie die Seite zur Überprüfung oder veröffentlichen Sie die Seite.

    Hinweis: Wenn Sie eine Seite veröffentlichen, der ein Inhaltstyp zugeordnet ist, wird der Verlaufsdatei ein Eintrag hinzugefügt.

Bearbeiten von XML-Seiten

Sie können XML-Seiten durchsuchen, bearbeiten und wieder auf der Website veröffentlichen. Nur XML-Seiten mit gültiger Struktur können in Contribute bearbeitet werden. Contribute überprüft XML-Seiten, bevor sie zur Bearbeitung angezeigt werden und während sie veröffentlicht werden. Es ist nicht möglich, neue XML-Seiten in einer Site zu erstellen. Sie können eine geöffnete XML-Seite jedoch kopieren. Dazu verwenden Sie die Option „Kopie der aktuellen Seite“ oder „Als neue Seite veröffentlichen“.

  1. Navigieren Sie zu der XML-Seite, die Sie in Contribute bearbeiten möchten.

  2. Klicken Sie im Contribute-Browser auf „Seite bearbeiten“ oder wählen Sie „Datei“ > „Aktionen“ > „Seite bearbeiten“. Die XML-Seite wird als Entwurf in Contribute geöffnet.

  3. Ändern Sie die Werte der Attribute und Elemente.

    Im folgenden Codefragment können Sie beispielsweise den Inhalt der Name-Tags bearbeiten, wie „abcd“ oder „efgh“, nicht jedoch das Name-Tag selbst.

    • <root> 
      <name> 
      <first> abcd </first> 
      <second> efgh </second> 
      </name> 
      </root>
  4. (Optional) Klicken Sie in der Symbolleiste auf das XML-Symbol, um die Änderung zu überprüfen.

  5. Senden Sie die Seite zur Bearbeitung/Überprüfung oder veröffentlichen Sie die Seite.

Bearbeiten von Spry-Widgets

Widgets sind Objekte, mit denen die Funktionalität und Arbeitsweise in einer Webseite für den Benutzer verbessert werden kann. Widgets sind beispielsweise Akkordeons, Bedienfelder mit Registerkarten und reduzierbare Bedienfelder. Widgets in HTML-Seiten werden mithilfe von HTML, CSS, JavaScript und Bildern erstellt. In vielen Webdesign-Anwendungen stehen vordefinierte Widgets zur Verfügung. Sie können vordefinierte Widgets ganz einfach anpassen, indem Sie ihre Werte ändern. Dann können Sie die benutzerdefinierten Widgets in Ihre Webseite einbinden. Die Änderungen am Code werden automatisch durchgeführt.

Ein Spry-Widget wird gemäß Ajax-Framework aufgebaut. Das Framework wiederum ist so strukturiert, dass Widgets einfach erstellt und bearbeitet werden können. Ein Spry besteht aus HTML, CSS und benutzerdefinierten Spry-Attributen. Die Widget-Struktur wird mithilfe von HTML erstellt. Über einen JavaScript-Aufruf wird eine ID an das Spry übergeben. Wenn Sie das Erscheinungsbild eines Widgets ändern möchten, ändern Sie die Werte in der CSS-Datei. Weitere Informationen zu Spry-Widgets finden Sie unter www.adobe.com/go/learn_ct_spry_widget_model_de.

Bearbeiten von Spry-Widgets

Contribute identifiziert und beschriftet Spry-Widgets, die in Dreamweaver erstellt wurden. Stellen Sie sicher, dass Sie zur Bearbeitung von Widgets berechtigt sind. Die Option zur Widget-Bearbeitung ist deaktiviert, wenn der Administrator Ihnen die erforderlichen Berechtigungen nicht erteilt hat.

  1. Öffnen Sie den Entwurf im Bearbeitungsmodus.

  2. Wählen Sie das Widget aus, dessen Eigenschaften Sie ändern möchten.

  3. Öffnen Sie das Dialogfeld „Widget-Eigenschaften“, indem Sie einen der folgenden Schritte ausführen:

    • Klicken Sie in der Symbolleiste auf das Symbol für die Widget-Eigenschaften .

    • Wählen Sie „Format“ > „Spry-Widget-Eigenschaften“ aus.

  4. Bearbeiten Sie im Dialogfeld für die Widget-Eigenschaften die Werte nach Bedarf und klicken Sie auf „OK“.

    Hinweis: Je nach ausgewähltem Widget wird ein Listenmenü für den Vorschaustatus in der Symbolleiste angezeigt. Ein Widget für Formulare kann beispielsweise den Status „gültig“ oder „Fehler“ aufweisen. Die Statusangaben werden im Dialogfeld für die Widget-Eigenschaften angezeigt.

    Seiten mit Spry-Widgets können in Contribute bearbeitet werden, wenn sie in Dreamweaver CS3 oder Dreamweaver CS4 erstellt wurden. Die folgenden Widgets werden in Contribute unterstützt:

    • Spry-Textfeld

    • Spry-Auswahl

    • Spry-Kontrollkästchen

    • Spry-Textbereich

    • Spry-Optionsschaltergruppe

    • Spry-Menüleiste

    • Spry-Bedienfeld mit Registerkarten

    • Spry-Akkordeon

    • Reduzierbares Spry-Bedienfeld

    • Spry-QuickInfo

    • Spry-Kennwort

    • Spry-Kennwortbestätigung

Zulassen der Widget-Bearbeitung durch Benutzer

Administratoren können festlegen, ob Benutzer der Website Widgets bearbeiten dürfen oder nicht.

  1. Wählen Sie „Bearbeiten“ > „Websites verwalten“ und klicken Sie dann auf die Website, die Sie verwalten möchten.

  2. Wählen Sie im Dialogfeld „Website verwalten“ eine Rolle aus und klicken Sie auf „Rolleneinstellungen bearbeiten“.

  3. Wählen Sie im Dialogfeld „Einstellungen bearbeiten“ im linken Bereich die Option „Bearbeitung“ aus.

  4. Führen Sie im Bereich „Andere Bearbeitungsoptionen“ die folgenden Schritte aus:

    • Aktivieren Sie das Kontrollkästchen „Benutzer dürfen Widget-Eigenschaften (Spry-Widgets) bearbeiten“.

    • Aktivieren Sie das Kontrollkästchen „Benutzer dürfen Widgets (Spry-Widgets) kopieren und einfügen“.

    • Deaktivieren Sie im Bereich „Allgemeine Einschränkungen für die Bearbeitung“ das Kontrollkästchen „Skripts, Formulare und Spry-Widgets schützen“, damit Benutzer Spry-Widgets löschen können.

Bearbeiten von SSI-Informationen (Server Side Include)

Eine SSI-Datei (Server Side Include) enthält gängige Informationen, die für mehrere Webseiten gelten. Mithilfe eines Include-Tags in Webseiten verweisen Sie auf Inhalt in einer SSI-Datei. Alle Änderungen, die Sie am Inhalt der SSI-Datei vornehmen, werden in allen Webseiten übernommen.

Zum Verweisen auf den Inhalt einer SSI-Datei (xyz.ssi) in einer Webseite verwenden Sie beispielsweise folgendes Format:

<!--#include file="../xyz.ssi" --> 

Die xyz.ssi-Datei enthält Informationen im folgenden Format:

<p> [Common Content] </p>

Contribute ermöglicht Ihnen die Bearbeitung des SSI-Inhalts in einer Webseite. Wenn Sie den SSI-Inhalt bearbeiten und die Webseite veröffentlichen, werden die Änderungen in allen Webseiten übernommen, die einen Verweis auf die SSI-Datei enthalten.

Bearbeiten von SSI-Informationen

Wenn Sie SSI-Informationen bearbeiten, sucht Contribute auf dem Server nach dem HTML-Quellinhalt und zeigt ihn zur Bearbeitung im Browser an. SSI-Informationen können in den folgenden Seitentypen in einer Website bearbeitet werden:

PHP

Pre Hypertext Processor

ASP

Active Server Pages

JSP

Java Server Pages

CFML

ColdFusion Markup Language

SSI-Includes, wie CSS und Skripts, werden nicht angezeigt. Selbst wenn Sie den entsprechenden Abschnitt manuell auswählen, sind diese Bereiche gesperrt und können nicht bearbeitet werden.

Hinweis: Die Option zur SSI-Bearbeitung wird im In-Browser-Editor nicht unterstützt.
  1. Wechseln Sie zu der Seite mit dem SSI-Inhalt.

  2. Klicken Sie auf „Seite bearbeiten“ oder wählen Sie „Datei“ > „Aktionen“ > „Seite bearbeiten“.

  3. Wählen Sie den Abschnitt aus, der Informationen aus einer SSI-Include-Datei enthält.

  4. Klicken Sie in der Symbolleiste auf „Eingeschlossene Datei bearbeiten“ oder wählen Sie „Format“ > „Eingeschlossene Datei bearbeiten“.

  5. Wählen Sie den Typ der zu bearbeitenden Datei in der Liste aus.

    Hinweis: Contribute zeigt eingeschlossene Dateien in der aktuellen Auswahl an.
  6. Bearbeiten Sie den SSI-Inhalt nach Bedarf und veröffentlichen Sie die geänderte Seite.

Bearbeiten von Blogs

Blogeinträge können mit zwei verschiedenen Methoden geändert werden. Sie können Einträge direkt in Contribute bearbeiten. Wenn der Eintrag in einem Browserfenster geöffnet ist, können Sie stattdessen auch auf die Schaltfläche „In Contribute bearbeiten“ klicken, um Contribute zu starten und den Eintrag dort zu bearbeiten. Weitere Informationen finden Sie unter Bearbeiten von Webseiten oder Blogeinträgen vom Browser aus.

Hinweis: Wenn die Schaltfläche „Seite bearbeiten“ oder „Eintrag bearbeiten“ nicht in der Contribute-Symbolleiste angezeigt wird, sind Sie nicht mit dem Blogserver verbunden, auf dem das Blog gehostet wird. Klicken Sie in der Symbolleiste auf die Schaltfläche „Verbinden“, um eine Verbindung mit dem Blogserver herzustellen.
  1. Navigieren Sie zur Blog-Homepage.

  2. Wählen Sie im Popupmenü „Einträge“ den Blogeintrag aus, den Sie verwalten möchten. Oder wählen Sie „Ansicht“ > „Blogeintrag auswählen“ > „Blogtitel“ und dann den zu bearbeitenden Blogeintrag. Stattdessen können Sie auch „Ansicht“ > „Datei oder Blogeintrag auswählen“ wählen und dann im Dialogfeld „Datei oder Blogeintrag auswählen“ auf die Schaltfläche „Bearbeiten“ klicken.

    Der ausgewählte Blogeintrag wird im eingebetteten Browser angezeigt und sein Titel wird im Popupmenü „Einträge“ aufgelistet.

  3. Klicken Sie auf die Schaltfläche „Eintrag bearbeiten“ oder wählen Sie „Datei“ > „Aktionen“ > „Eintrag bearbeiten“.

    Der Blogeintrag wird als Entwurf in Contribute geöffnet. Nun können Sie den Inhalt nach Bedarf ändern und den Eintrag dann veröffentlichen.

    Hinweis: Sie können diesen Blogeintrag mit einem leeren Blogeintrag verknüpfen und die Einträge veröffentlichen. Weitere Informationen finden Sie unter Erstellen von Hyperlinks zu neuen, leeren Blogeinträgen.

Bearbeiten einer auf dem Computer gespeicherten Webseite

Sie können mit Contribute Seiten bearbeiten, die sich nicht in der Website befinden, mit der Sie verbunden sind, indem Sie eine auf dem Computer gespeicherte HTML-Seite öffnen und bearbeiten. Das Verfahren ähnelt der Verwendung von Windows-Editor oder TextEdit, Sie profitieren aber vom Komfort und von der Funktionalität von Contribute.

Ein Beispiel: Sie erhalten in einer E-Mail-Nachricht eine HTML-Seite, die Sie für einen Kollegen bearbeiten sollen. Auch wenn es sich nicht um die Seite einer Website handelt, mit der Sie verbunden sind, können Sie die Seite auf dem Computer speichern, in Contribute öffnen und bearbeiten und anschließend an den Kollegen zurückschicken.

Hinweis: Sie dürfen keine Verbindung mit dem lokalen Laufwerk herstellen. Andernfalls verwaltet Contribute die Dateien auf dem Computer wie Dateien in einer Website und die Funktion zur direkten Bearbeitung funktioniert nicht ordnungsgemäß.
  1. Wählen Sie im Contribute-Browser oder -Editor „Datei“ > „Öffnen“.

    Das Dialogfeld „Öffnen“ wird angezeigt.

    Hinweis: Sie können mit dieser Funktion keine TXT-Dateien öffnen und bearbeiten, die auf dem Computer gespeichert sind.
  2. Suchen Sie zu bearbeitende Datei, wählen Sie sie aus und klicken Sie auf „Öffnen“.

    Die Seite wird als Entwurf im Contribute-Editor geöffnet und die Symbolleiste enthält die Schaltflächen „Speichern“ und „Schließen“ anstelle der Schaltflächen „Veröffentlichen“ und „Abbrechen“.

    Hinweis: Die Administratorvoreinstellungen werden nicht verwendet, weil diese Seite nicht Bestandteil einer Website ist. Wenn Sie Voreinstellungen auf Seiten anwenden möchten, die auf diese Weise bearbeitet werden, finden Sie Einzelheiten im Contribute Support Center unter www.adobe.com/go/contribute_support.

Bearbeiten von Webseiten oder Blogeinträgen vom Browser aus

Sie können Contribute-Plugins verwenden, um Webseiten und Blogeinträge direkt vom Webbrowser aus zur Bearbeitung in Contribute zu öffnen. Sie haben aber auch die Möglichkeit, Webseiten oder Blogeinträge direkt im Webbrowser zu bearbeiten, ohne Contribute zu öffnen. Nach Abschluss der Bearbeitung folgt die Webseite dem Arbeitsablauf, der ihrer Vorlage zugewiesen ist.

Im Gegensatz zur Contribute-Anwendung wird der In-Browser-Editor nur im Bearbeitungsmodus geöffnet. Aufgaben wie die Verwaltung der Website, die Erstellung von Verbindungen sowie das Festlegen von Voreinstellungen können im In-Browser-Editor nicht ausgeführt werden. Der In-Browser-Editor übernimmt die Contribute-Einstellungen für Site-Verbindungen und Arbeitsabläufe sowie die Contribute-Berechtigungen. Die Webseiten folgen dem Arbeitsablauf, der ihren Vorlagen in Contribute zugewiesen ist.

Es ist nicht möglich, im Webbrowser eine Verbindung mit einer Website herzustellen. Stellen Sie die Verbindung mit Ihrer Website oder Ihrem Blog in Contribute her, bevor Sie eine Webseite oder einen Blogeintrag im Browser bearbeiten. Weitere Informationen finden Sie unter Erstellen von Website-Verbindungen und Erstellen von Blogserver-Verbindungen. Sie werden aufgefordert, eine Verbindung mit der Seite herzustellen, falls noch nicht geschehen.

Wenn Sie die Webseite oder den Blogeintrag im Webbrowser bearbeiten, startet Contribute den In-Browser-Editor. Beim In-Browser-Editor handelt es sich um den Contribute-Editor, der im Webbrowser ausgeführt wird. Im In-Browser-Editor können nur veröffentlichte Seiten bearbeitet werden. Es ist nicht möglich, im In-Browser-Editor neue Webseiten oder Blogs zu erstellen.

Der In-Browser-Editor besteht aus drei Bereichen: Symbolleistenbereich, Bearbeitungsbereich und Statusbereich. Der Bearbeitungsbereich und der Statusbereich sehen genauso aus wie in der Contribute-Anwendung.

Die Symbolleiste im In-Browser-Editor unterscheidet sich folgendermaßen von der Symbolleiste in Contribute.

Die Symbolleiste im In-Browser-Editor:

  • Enthält nur Schaltflächen für die Aktionen, die im In-Browser-Editor ausgeführt werden können und die dem Benutzer zur Verfügung stehen.

  • Enthält keine Menüleiste. Einige Aktionen, die in Contribute nur über die Menüleiste aufgerufen werden können, stehen in Form von neuen Symbolen in der Symbolleiste zur Verfügung.

  • Einige Contribute-Aufgaben, die nur selten verwendet werden, sind in der Symbolleiste nicht vorhanden.

Bei der Arbeit im In-Browser-Editor können Sie dieselben Tastaturbefehle verwenden wie in Contribute. Während der Bearbeitung können Sie Bilder in den In-Browser-Editor ziehen und dort ablegen, genauso wie in Contribute.

Wenn Sie eine Seite zur Bearbeitung im Browser öffnen, ändert sich die URL in die vom In-Browser-Editor festgelegte URL. Die ursprüngliche URL wird angezeigt, nachdem Sie eine Aktion auf der Seite ausgeführt haben.

Hinweis: Wenn Sie den In-Browser-Editor oder seine Registerkarte schließen, steht der Webseitenentwurf in Contribute im Bedienfeld „Seiten“ zur Verfügung.

Webseiten müssen vor der Veröffentlichung zur Überprüfung, Bearbeitung oder Genehmigung gesendet werden. Wenn Sie nach der Bearbeitung einer Seite die gewünschte Sendeaktion auswählen, müssen Sie die Überprüfer oder Genehmiger auswählen. Der an die Überprüfer gesendete Entwurf wird im Bedienfeld „Seiten“ der Überprüfer angezeigt. Von nun an folgt der Entwurf demselben Ablauf, der gelten würde, wenn der Entwurf in Contribute bearbeitet worden wäre. Eine Erstellung im Team ist nur möglich, wenn der Entwurf für die Bearbeitung in Contribute eingestellt wurde.

Im In-Browser-Editor kann jeweils nur eine Instanz einer Webseite bearbeitet werden. Wenn Sie versuchen, dieselbe Seite in einer anderen Instanz zur Bearbeitung zu öffnen, wird eine Fehlermeldung eingeblendet. Ähnlich ist eine zur Bearbeitung geöffnete Webseite gesperrt und kann nicht von anderen Benutzern bearbeitet werden.

Schließen Sie alle verknüpften Dateien, die in Contribute oder im In-Browser-Editor geöffnet sind, bevor Sie eine Webseite veröffentlichen. Sie müssen eine Webseite auch schließen, wenn sie über eine abhängige Datei verfügt, die mit der zu veröffentlichenden Datei gemeinsam verwendet wird.

Bei den folgenden Aktionen im Webbrowser wird der In-Browser-Editor geschlossen, nachdem Sie zur Bestätigung aufgefordert wurden. Contribute speichert die Webseite vor dem Schließen.

  • Schließen der Registerkarte, die den In-Browser-Editor enthält

  • Schließen des Browsers

  • Klicken auf die Zurück- und Weiter-Schaltflächen, um eine andere Webseite im Fenster des In-Browser-Editors aufzurufen

Hinweis: Das Klicken auf die Stopp- oder Aktualisieren-Schaltflächen hat keinerlei Auswirkungen auf den In-Browser-Editor.

Diese Funktion ist mit folgenden Browsern und Betriebssystemen verfügbar:

  • Internet Explorer Version 6.0 und höher unter Windows Vista (SP 1) und Windows XP (SP 2)

  • Mozilla Firefox Version 1.5 und höher unter Windows Vista (SP 1) und Windows XP (SP 2)

  • Mozilla Firefox ab Version 1.5 unter Mac OS X® (10.3.9) und Mac OS X (10.4.x).

Installieren der Browser-Plugins unter Windows

Die Browser-Plugins werden automatisch installiert, wenn bei der Contribute-Installation die Option „Alle Komponenten“ aktiviert ist.

Wenn Probleme in Bezug auf das Firefox-Plugin auftreten, installieren Sie Contribute neu und stellen Sie dabei sicher, dass die Option für das Firefox-Plugin für CS5 im Komponentenabschnitt ausgewählt ist.

Hinweis: Bei der Neuinstallation werden alle vorhandenen Dateien mit der jeweils neuen Version überschrieben, wobei jedoch die Verbindungseinstellungen und die Voreinstellungen beibehalten werden.

Nach erfolgreicher Installation von Contribute werden für die Plugins die Schaltflächen „Bearbeiten“ und „Im Blog veröffentlichen“ in einer separaten Symbolleiste im Browserfenster angezeigt. Das Menü „Bearbeiten“ enthält zwei Optionen:

Bearbeiten
Öffnet die Webseite zur Bearbeitung im Browser.

In Contribute bearbeiten
Öffnet die Webseite zur Bearbeitung in Contribute.
Hinweis: Wenn die Symbolleisten nicht angezeigt werden, wählen Sie im Webbrowser „Ansicht“ > „Symbolleisten“ > „Contribute-Symbolleisten“.
Grafik in Originalgröße anzeigen
Das Browser-Plugin zur Seitenbearbeitung

Installation der Browser-Plugins unter Mac OS

Die Browser-Plugins werden automatisch installiert, wenn bei der Contribute-Installation die Option „Alle Komponenten“ aktiviert ist.

Wenn Sie das Firefox-Plugin bei der Installation nicht installiert haben, können Sie diese Komponente vom folgenden Pfad installieren:

[Contribute-Installationsverzeichnis] /FFExtnForContributeCS5.app

Nach erfolgreicher Installation von Contribute werden für die Plugins die Schaltflächen „Bearbeiten“ und „Im Blog veröffentlichen“ in einer separaten Symbolleiste im Browserfenster angezeigt.

Hinweis:
  • Die Browser-Plugins von Contribute für Mozilla Firefox unter Mac OS können nur mit dem Firefox-Erweiterungsmanager entfernt werden.

  • Die Contribute-Anwendung kann unter Mac OS nicht repariert werden; Sie müssen die Anwendung neu installieren.

Sie müssen mit Ihrer Website oder Ihrem Blog verbunden sein, bevor Sie eine Webseite oder einen Blogeintrag im Webbrowser bearbeiten können. Weitere Informationen finden Sie unter Erstellen von Website-Verbindungen und Erstellen von Blogserver-Verbindungen.

Beim Öffnen der Seite oder des Eintrags wird möglicherweise die Schaltfläche „Verbindung herstellen“ angezeigt. Dies bedeutet, dass Sie nicht mit der Website oder dem Blog verbunden sind und deshalb die Webseite oder den Blogeintrag nicht bearbeiten können. Unter Erstellen von Website-Verbindungen wird beschrieben, wie Sie eine Verbindung mit einer Webseite herstellen.

Bearbeiten von Webseiten oder Blogeinträgen in Contribute vom Browser aus

  1. Öffnen oder suchen Sie die Webseite, das Blog oder den Blogeintrag im Browser.

  2. Wählen Sie „Bearbeiten“ > „In Contribute bearbeiten“.

  3. Wenn Sie eine Blog-Homepage angegeben haben, wählen Sie im Popupmenü „Einträge“ den Blogeintrag aus, den Sie bearbeiten möchten. Die Webseite oder der Blogeintrag wird als Entwurf im Contribute-Editor geöffnet. Sie können diese Seite oder diesen Blogeintrag nun bearbeiten.

  4. Bei Webseiten, für die ein anderer Arbeitsablauf als „Erstellen > Veröffentlichen“ gilt, werden Sie aufgefordert, die Seite zur Überprüfung oder Genehmigung zu senden. Wählen Sie die gewünschten Überprüfer im Dialogfeld aus und klicken Sie auf „OK“.

    Wenn die Überprüfer eine Verbindung mit der Site in Contribute herstellen, wird die Webseite in ihrem Contribute-Bedienfeld angezeigt.

Bearbeiten von Webseiten oder Blogeinträgen im bevorzugten Browser

  1. Öffnen oder suchen Sie die Webseite, das Blog oder den Blogeintrag im Browser.

    Hinweis: Sie müssen mit Ihrer Website oder Ihrem Blog verbunden sein, bevor Sie eine Webseite oder einen Blogeintrag im Browser bearbeiten können. Weitere Informationen finden Sie unter Erstellen von Website-Verbindungen und Erstellen von Blogserver-Verbindungen.
  2. Klicken Sie in der Symbolleiste des Browsers auf „Bearbeiten“.

  3. Wenn Sie eine Blog-Homepage angegeben haben, wählen Sie im Popupmenü „Einträge“ den Blogeintrag aus, den Sie bearbeiten möchten. Die Webseite oder der Blogeintrag wird als Entwurf im Webbrowser geöffnet. Sie können diese Seite oder diesen Eintrag nun bearbeiten.

  4. Bei Webseiten, für die ein anderer Arbeitsablauf als „Erstellen > Veröffentlichen“ gilt, werden Sie aufgefordert, die Seite zur Überprüfung oder Genehmigung zu senden. Wählen Sie die gewünschten Überprüfer im Dialogfeld aus und klicken Sie auf „OK“.

Wenn die Überprüfer eine Verbindung mit der Site in Contribute herstellen, wird die Webseite im Bedienfeld „Seiten“ angezeigt.

Nachdem die erforderliche Aktion für die Seite ausgeführt wurde, wird der In-Browser-Editor geschlossen und die Webseite wird im Browser aktualisiert.

Wenn die Webseite nicht bearbeitet werden kann, wird im In-Browser-Editor eine Fehlermeldung angezeigt und die Seite wird wieder auf die ursprüngliche URL zurückgesetzt. Wenn jedoch nach dem Laden des In-Browser-Editors eine Fehlermeldung angezeigt wird, klicken Sie auf die Schaltfläche „Schließen“, um zur ursprünglichen Seite zurückzukehren.