Erste Schritte

Adobe RoboHelp wurde zur Entwicklung von Hilfesystemen, E-Learning-Inhalten, Richtlinien und Verfahren sowie Wissensdatenbanken konzipiert. Mit den verbesserten Funktionen zum Bearbeiten und für das Layout können Sie Inhalte in einem professionellen Erscheinungsbild erstellen. Durch die neuen MultiScreen-HTML5- und eBook-Layouts (SSLs) sind Inhalte, die in RoboHelp, FrameMaker oder Microsoft® Word erstellt wurden, jetzt auch auf Mobilgeräten, eBook-Readern und Tablets verfügbar. Indem Sie benutzerdefinierte Fluid-Layouts erstellen, ermöglichen Sie den Benutzern die Anzeige der Inhalte auf verschiedenartigen Geräten.

Grafik in Originalgröße anzeigen
Ausgabe auf mehreren Geräten wurde mithilfe von RoboHelp generiert.

Im MultiScreen-HTML5-Layout können Sie sogar Desktop-Inhalte aus Legacy-Projekten generieren, für die ein anderes als das herkömmliche WebHelp-Layout verwendet wurde. So können Sie z. B. das Inhaltsverzeichnis auf der rechten Seite platzieren oder eine Seite für die Anzeige von Suchergebnissen gestalten. Im Paradigma „MultiScreen“ ist auch der Desktop als Bildschirm mit einer bestimmten Breite und Höhe definiert.

Adobe RoboHelp dank seiner vielen Innovationen eines der weltweit führenden Autorenwerkzeuge für Onlinehilfen. Neue Funktionen bieten für technische Redakteure und Leser ein produktiveres Erlebnis.

Aktuelle Informationen zu Adobe RoboHelp finden Sie unter www.adobe.com/go/learn_robohelp_product_de.

Bevor Sie die Software verwenden, nehmen Sie sich einen Moment Zeit, um sich mit dem grundlegenden Arbeitsablauf und den zahlreichen Ressourcen vertraut zu machen, die Ihnen zur Verfügung stehen. Ihnen stehen Video-Anleitungen, Zusatzmodule, Vorlagen, Benutzercommunities, Seminare, Lehrgänge, RSS-Feeds und vieles mehr zur Verfügung.

Vereinfachter Arbeitsablauf

Grafik in Originalgröße anzeigen
Hinweisende Informationsgrafik: RoboHelp 10-Ein- und Ausgabeformate

1. Projekt erstellen

Jedes Hilfesystem enthält mindestens ein Projekt. Die elementaren Bausteine von Projekten sind Themen. Siehe Projekte.

2. Inhalt verfassen

Erstellen Sie zunächst Themen. Multimediale Zusätze lassen sich entweder gleich hinzufügen oder zu einem späteren Zeitpunkt beim Anpassen der Ausgabe einbinden. Themen, die auch zur kontextsensitiven Hilfe genutzt werden sollen, sollten in Absprache mit dem Anwendungsentwickler eingeplant werden. Kontextsensitive Themen werden angezeigt, nachdem der Benutzer auf eine Hilfeschaltfläche der Benutzeroberfläche klickt oder die Taste F1 drückt. Siehe Arbeiten mit Themen

3. Dateien importieren

Zu den importierbaren Dateien gehören HTML-Dateien, Microsoft Word-Dateien (.doc, .docx, .docm und .rtf), FrameMaker-Bücher und -Dokumente (.book, .bk, .fm, .frm, .mif), XML-Dateien (.xml) und Adobe PDF-Dokumente (.pdf). Siehe Projekte.

4. Navigation entwickeln

Erstellen Sie je nach der gewünschten inhaltlichen Struktur oder Hierarchie die notwendigen Verknüpfungen zwischen Themen und zu externen Inhalten. Text oder Bilder lassen sich auch mit anderen Inhalten verknüpfen. Erstellen Sie ein Inhaltsverzeichnis, das die Hierarchie des Inhalts wiedergibt, und fügen Sie einen Index hinzu, den der Benutzer zur Navigation nutzen kann. Mit sogenannten Abfolgen können Sie für den Benutzer empfehlenswerte Navigationspfade durch die Hilfethemen festlegen. Oft ist zum vollständigen Verständnis einer Funktion das Lesen einer Reihe zusammengehöriger Themen nötig; diese können in einer Abfolge zusammengefasst werden. Weitere Informationen finden Sie unter Inhaltsverzeichnisse, Indizes, Glossare und Verknüpfungen, Navigation und Suche.

5. Ausgabe anpassen

Hierzu lassen sich Formatvorlagen und Layouts anwenden (diese bestimmen Verhalten und Aussehen). Eine weitere Möglichkeit ist bedingter Text, mit dem Inhalte anhand bestimmter Kriterien (Interesse des Benutzers, verwendete Anwendung, Wissensstand, usw) angezeigt oder zurückgehalten werden. Auch durch das Hinzufügen multimedialer Inhalte lässt sich ein Hilfesystem konsequent gestalten und bereichern. Siehe Bedingter Text und Ausgabe generieren, anzeigen und veröffentlichen.

6. Hilfepaket generieren, testen und verteilen

Generieren Sie zunächst die Ausgabe, damit das Hilfesystem zum Testen von Verknüpfungen, Formaten usw. angezeigt werden kann. Prüfen Sie jede Ausgabe, die zur Verteilung ansteht, einschließlich gedruckter Dokumentation. Weitere Informationen finden Sie unter Erzeugen der Ausgabe.

Aktivierung und Registrierung

Die vollständigen Systemanforderungen und Empfehlungen für Adobe® RoboHelp® finden Sie unter www.adobe.com/de/support/robohelp.

Wenn Ihr Computer nicht mit dem Internet verbunden ist, finden Sie die Informationen in der ReadMe-Datei auf dem Installationsdatenträger.

Installieren der Software

  1. Schließen Sie alle anderen Adobe-Anwendungen auf dem Computer.

  2. Legen Sie den Installationsdatenträger ein und befolgen Sie die angezeigten Anweisungen.

Hinweis: Wenn der Computer, auf dem Sie RoboHelp installieren, nicht über die neueste Version von PDF-Add-On verfügt, können Sie die neueste Version mit RoboHelp installieren. Sie können außerdem das ExtendScript-Toolkit installieren. RoboHelp verwendet dieses Toolkit, um Skriptfunktionen bereitzustellen. Weitere Informationen zu ExtendScript finden Sie unter Allgemeines zur ExtendScript Toolkit-Unterstützung.

Weitere Informationen finden Sie in der Readme-Datei auf dem Installationsdatenträger.

Installationshilfe

Hilfe bei Installationsproblemen finden Sie im Abschnitt „Erste Schritte und Hilfe“ unter .

Lizenzaktivierung

Während des Installationsverfahrens stellt die Adobe-Software eine Verbindung zu Adobe her, um die Lizenzaktivierung abzuschließen. Bei diesem Vorgang werden keine personenbezogenen Daten übermittelt. Weitere Informationen zur Produktaktivierung finden Sie unter www.adobe.com/go/activation_de auf der Website von Adobe.

Registrieren

Registrieren Sie das Produkt, damit Sie Installationssupport und andere Dienste nutzen können sowie über Updates benachrichtigt werden.

Hinweis: Registrieren Sie sich nur einmal für RoboHelp 10.

 Befolgen Sie zum Registrieren die Anweisungen im Fenster „Registrierung“, das nach dem Installieren der Software angezeigt wird.

Wenn Sie die Registrierung verschieben, können Sie sie später jederzeit mit „Hilfe“ > „Registrierung“ durchführen.

Adobe-Programm zur Produktverbesserung

Nachdem Sie die Adobe-Software einige Male verwendet haben, wird ein Dialogfeld angezeigt, in dem Sie gefragt werden, ob Sie am Adobe-Programm zur Produktverbesserung teilnehmen möchten.

Falls Sie sich zur Teilnahme entschließen, werden Daten zu Ihrer Verwendung der Adobe-Software an Adobe gesendet. Es werden keine persönlichen Angaben aufgezeichnet oder übertragen. Das Adobe-Programm zur Produktverbesserung erfasst ausschließlich Informationen zu den Funktionsmerkmalen und Tools, die Sie in der Software verwenden, und darüber, wie oft Sie diese verwenden.

Sie können jederzeit an dem Programm teilnehmen und die Teilnahme wieder rückgängig machen:

  • Um teilzunehmen, wählen Sie „Hilfe“ > „Adobe Product Improvement Program“ und klicken Sie dann auf die Option „Ja, teilnehmen“.

  • Wenn Sie die Teilnahme beenden möchten, wählen Sie „Hilfe“ > „Adobe Product Improvement Program“ und klicken Sie dann auf „Nein, danke“.

Weitere Informationen zum Adobe-Programm zur Produktverbesserung finden Sie in einer Liste häufig gestellter Fragen auf der Adobe-Website.

Hilfe und Support

Adobe Community-Hilfe

Adobe Community-Hilfeist eine integrierte Umgebung auf Adobe.com, über die Sie Zugriff auf Inhalte erhalten, die von der Benutzer-Community beigetragen und von Experten von Adobe und aus der Branche allgemein moderiert werden. Diese Community-Hilfe enthält keine zusammenhängenden Bücher, sondern ist eher lose in Form von Sammlungen zusammengehöriger Elemente strukturiert. Adobe überarbeitet und ergänzt diese Sammlungen ständig.

Setzen Sie für die RoboHelp-Hilferessourcenseite ein Lesezeichen, damit die besten Webinhalte zu RoboHelp jederzeit für Sie zur Verfügung stehen. Dazu zählen die folgenden Ressourcen:
  • Videos, Übungen, Tipps und Techniken, Blogs, Artikel und Beispiele für Designer und Entwickler.

  • Vollständige Onlinehilfe, die regelmäßig aktualisiert wird.

  • Weitere Inhalte auf Adobe.com umfassen Knowledgebase-Artikel, Downloads und Updates, die Adobe Developer Connection und vieles mehr.

Hilfeinhalt online anzeigen

  • Wenn Sie im Produkt die Hilfe aufrufen, wird Ihr standardmäßiger Webbrowser (Internet Explorer, Safari, Chrome, Firefox usw.) gestartet und der Inhalt der Produkthilfe wird angezeigt.

  • Anschließend können Sie die Funktionen des Browsers verwenden, um nach Inhalt zu suchen, ihn den Favoriten hinzuzufügen oder ihn zu bewerten.

Offlinehilfeinhalt herunterladen

  • Wenn Sie die Hilfe zum ersten Mal im Produkt aufrufen, wird Adobe Help Manager im Hintergrund gestartet und prüft, ob neue oder aktualisierte Inhalte verfügbar sind.

    Adobe Help Manager ist ein AIR-basiertes Programm zur Installation von Inhalten. Es lädt Offlinehilfeinhalte herunter und gibt Meldungen aus, wenn neue Updates verfügbar sind. Dadurch wird sichergestellt, dass Ihnen jederzeit aktuelle und richtige Referenzinformationen zur Verfügung stehen.

  • Wenn keine neuen Inhalte verfügbar sind, wird die Anwendung geschlossen, bis Sie die Hilfe das nächste Mal aufrufen.

  • Werden neue Inhalte gefunden, wird auf dem Desktop ein kleines Popup mit der entsprechenden Benachrichtigung angezeigt, in der Regel in der rechten unteren Ecke des Bildschirms.

  • Wenn Sie auf die Benachrichtigungsmeldung klicken, wird der Help Manager gestartet und zeigt alle für den Download verfügbaren Hilfeinhalte in den Voreinstellungen für lokale Inhalte an.

  • Sie können die einzelnen Pakete wählen, indem Sie den Titel des gewünschten Produkts oder Hilfepakets hervorheben und auf „Aktualisieren“ klicken.

  • Um den gesamten verfügbaren Inhalt zu aktualisieren, klicken Sie auf der Voreinstellungsseite „Allgemein“ auf „Download“. Hinweis: Die Größe des Downloads für den gesamten relevanten Inhalt wird angezeigt. Bei umfangreichen Aktualisierungen kann der Download mehrere Minuten oder länger dauern.

  • Sie können während des Downloads weiterhin Hilfeinhalte in Ihrem Webbrowser durchsuchen.

  • Wenn Ihre Adobe-Anwendungen standardmäßig die lokalen, installierten Hilfedateien verwenden sollen, legen Sie auf der Registerkarte „Allgemein“ in den Voreinstellungen fest, dass nur lokale Hilfeinhalte angezeigt werden sollen.

  • Sie können stattdessen auch festlegen, dass weiterhin Onlineinhalt angezeigt werden soll. In diesem Fall schaltet der Hilfemanager automatisch auf Onlinehilfe um, wenn kein Internetzugriff möglich ist.

Dienste, Downloads und Extras

Sie können Ihr Produkt durch Integration verschiedene Dienste, Zusatzmodule und Erweiterungen ausbauen. Zudem haben Sie die Möglichkeit, Muster und andere Elemente herunterzuladen sowie verschiedene Ressourcen anzuzeigen, die Ihnen die Arbeit erleichtern können.

Adobe Exchange

Besuchen Sie Adobe Exchange unter www.adobe.com/go/exchange_de, um Beispiele sowie Zusatzmodule und Erweiterungen von Adobe und Drittentwicklern herunterzuladen. Mit diesen Zusatzmodulen und Erweiterungen können Sie u. a. Aufgaben automatisieren, Workflows anpassen und professionelle Spezialeffekte erzeugen.

Adobe-Downloads

Besuchen Sie www.adobe.com/go/downloads_de, wenn Sie kostenlose Updates, Testversionen und andere nützliche Software suchen.

Adobe Labs

Auf der Seite der Adobe Labs unter www.adobe.com/go/labs_de können Sie neue und sich entwickelnde Technologien und Produkte von Adobe ausprobieren. Auf der Adobe Labs-Website stehen Ihnen u. a. folgende Ressourcen zur Verfügung:

  • Vorabversionen von Softwareanwendungen und Technologien

  • Codebeispiele und optimale Verfahren für schnelleres Lernen

  • Frühe Versionen von Produkt- und technischer Dokumentation

  • Foren, Wikis und andere Ressourcen unterstützen die Interaktion mit gleichgesinnten Benutzern

Adobe Labs unterstützt einen gemeinschaftlichen Prozess der Softwareentwicklung. In dieser Umgebung kann der Kunde schnell neue Produkte und Technologien produktiv nutzen. Die Adobe Labs bieten außerdem ein Forum für frühes Feedback. Anhand dieses Feedbacks erstellen die Entwicklungsteams von Adobe Software, die den Anforderungen und Erwartungen der Community entspricht.

Adobe-Foren

Sie können Fachleute in der Adobe RoboHelp-Community unter www.adobe.com/go/learn_robohelp_forum_de ansprechen. Wenn Sie einen Kommentar zu einer Hilfeseite eingeben, wird dieser automatisch im Forum veröffentlicht. Die Experten und andere Benutzer können auf Ihren Kommentar antworten.

Adobe TV

Auf Adobe TV unter http://tv.adobe.com/de finden Sie lehrreiche und inspirierende Videos. Der Technical Communications-Kanal hält Videos bereit, die für Experten im Bereich technische Dokumentation interessant sind. Die Videos unter RoboHelp erleichtern Ihnen den schnellen Einstieg.

RoboHelp-Beispielprojekte und -Ausgabe

Auf der Seite RoboHelp-Ressourcen können Sie mit RoboHelp erstellte Beispielprojekte und andere Ressourcen wie Arbeitsbereiche und für die Implementierung kontextsensitiver Hilfe konfigurierte Anwendungen herunterladen.

RoboHelp Developer Center

Auf der Seite RoboHelp Developer Center finden Sie Artikel von internen und externen RoboHelp-Benutzern zu verschiedenen Themen.

Vorherige RoboHelp-Hilfe

Laden Sie die Dokumentation der älteren Versionen von RoboHelp von der RoboHelp-Hilferessourcenseite herunter.

Neuerungen bei RoboHelp 10

Verbesserte Autorenfunktionen

Verbesserte Funktion „Suchen und Ersetzen“
In RoboHelp 10 steht eine erheblich verbesserte Funktion zum Suchen und Ersetzen von Text in mehreren Dateien zur Verfügung. Das Werkzeug zum Suchen und Ersetzen wird unauffällig ausgeführt und unterstützt sowohl Platzhalter als auch reguläre Ausdrücke. Weitere Informationen finden Sie unter Text in Dateien suchen und ersetzen.

Neuer externer Pod „Inhaltssuche“
Der Arbeitsablauf für die Einrichtung der Suche, um externen Inhalt einzubeziehen (eine in RoboHelp 9 eingeführte Funktion), wurde für besseren Bedienkomfort optimiert. Greifen Sie auf den Pod „Externe Inhaltssuche“ über das Menü „Ansicht“ zu und geben Sie URLs für den Inhalt an, der außerhalb des Hilfesystems (z. B. in Blogs) verfügbar ist. Dann ordnen Sie die URLs Begriffen zu, nach denen der Benutzer wahrscheinlich suchen wird. Indem Sie den Inhalt auf diese Weise pflegen, optimieren Sie die Suche für die Benutzer und erleichtern den Zugriff auf benutzergenerierte Inhalte. Siehe Externe Inhaltssuche.

Unterstützung für die Anwendung von CBTs auf Definitionen für die externe Inhaltssuche
Es ist jetzt möglich, auf jede Definition für die externe Inhaltssuche eine CBT anzuwenden. So können Sie z. B. mithilfe einer CBT festlegen, dass ein einem Schlüsselwort zugeordnetes Video in hoher Qualität nur abgespielt wird, wenn von einem Mobilgerät aus auf den Inhalt zugegriffen wird. Weitere Informationen zur Vorgehensweise finden Sie unter Externe Inhaltssuche.

Verknüpfung von Fenstererstellung und primärer Layoutauswahl wurde aufgehoben
Jedes Fenster, das Sie in RoboHelp 9 erstellen, ist vom selben Typ wie das primäre Layout im SSL-Pod. In RoboHelp 10 können Sie beim Erstellen eines Fensters einen Fenstertyp wählen. Mit dieser Funktion können Sie die Verknüpfung der Fenstererstellung mit der primären Layoutauswahl im Einzelquellenlayout-Pod aufheben. Siehe Fenster

Die Option „Aktualisieren“ im Ressourcenmanager
SharePoint-Ordner, die als freigegebene Speicherorte im Ressourcenmanager-Pod hinzugefügt wurden, werden nicht automatisch aktualisiert. Über das neue Symbol „Aktualisieren“ im Ressourcenmanger können Sie jetzt manuell den Inhalt aller freigegebenen Speicherorte aktualisieren. Siehe Ressourcen verwalten.

Projekte über das Netzwerk bearbeiten
Das Öffnen und Bearbeiten von RoboHelp-Projekten über das Netzwerk war in vorherigen Versionen von RoboHelp umständlich. In RoboHelp 10 wurden Änderungen an der Architektur vorgenommen, um Ihnen den Zugriff auf Projekte über das Netzwerk zu ermöglichen.
Hinweis: Die Verwendung hängt von der Netzwerkgeschwindigkeit und der Größe des Projekts ab.

Unterstütung für benutzerdefinierte Variable in Thementiteln
In RoboHelp 10 können Sie benutzerdefinierte Variablen nicht nur in Themeninhalten, Inhaltsverzeichnissen oder Indexbegriffen, sondern auch in Thementiteln verwenden. Durch diese Verbesserung können Sie benutzerdefinierte Variablen anstatt der tatsächlichen Produktnamen und/oder Funktionsnamen in Thementiteln verwenden und Überarbeitungen vermeiden, wenn diese Namen häufig oder kurzfristig geändert werden. Schrittweise Anweisungen finden Sie unter Benutzerdefinierte Variablen.

Unterstützung für CSS-Formatierung in Snippets
In RoboHelp 10 können Sie unterschiedliche Formate für verschiedene Snippets erstellen und die Stylesheets an diese anhängen. RoboHelp zeigt den Inhalt des Snippets mit dem im Stylesheet definierten Aussehen an. Sie können ein CSS angeben, bevor Sie den Tabellen- und Listenstil in das Snippet einfügen. RoboHelp kopiert diese Formate bei der ersten Verwendung in das CSS. Schrittweise Anweisungen finden Sie unter Erstellen und Verwalten von Snippets.
Hinweis: Das CSS des Themas hat Vorrang vor dem CSS des Snippet.

TITLE- und ALT-Attribute für Bilder
In RoboHelp 10 können Sie mithilfe der Optionen „Bildschirmtipp“ und „ALT-Text“ die TITLE- und ALT-Attribute für ein Bild festlegen. In der Standardeinstellung sind beide Attribute leer.

Wenn Sie 508-konforme Ausgabe in WebHelp generieren (oder unter „Gedruckte Dokumentation“ Barrierefreiheit aktivieren) und das ALT-Attribut leer ist, übernimmt RoboHelp den Wert des TITLE-Attributs (sofern vorhanden) oder den Namen des Bild für das ALT-Attribut. Schrittweise Anweisungen finden Sie unter Bearbeiten von Bildern in RoboHelp.

Unterstützung für die neuesten Geräte, Produkte und Browser
Die Unterstützung der neuesten Plattformen, Browser und Geräte (E-Book-Reader, Mobilgeräte, Tablet-PCs usw.) sorgt dafür, dass Sie stets auf dem aktuellen Stand sind. Endbenutzer können von RoboHelp generierte Inhalte in der neuesten Version von Internet Explorer, Mozilla Firefox und Google Chrome anzeigen.

Integration mit FrameMaker 11, Adobe Captivate 6 und Acrobat 10
RoboHelp 10 unterstützt die neuesten Versionen der Adobe-Produkte wie FrameMaker 11, Adobe Captivate 6 und Acrobat 10. Nutzen Sie die neuesten Verbesserungen in diesen Produkten, wie Unterstützung für das Hinzufügen von Hotspots in Grafiken in FrameMaker 11 oder Unterstützung für Generieren der HTML5-Ausgabe in Adobe Captivate 6.

Verbesserungen beim Importieren und Verknüpfen

Allgemeine Verbesserungen beim Importieren und Verknüpfen
In RoboHelp 10 gelten folgende Verbesserungen beim Importieren und Verknüpfen von Microsoft Word- und FrameMaker-Dokumenten:
Formate automatisch zuordnen
RoboHelp bietet eine Option zur schnellen Zuordnung von Absatz-, Zeichen und Tabellenformaten aus Microsoft Word- und FrameMaker-Dateien zu den entsprechenden Formaten in dem für die Formatzuordnung gewählten CSS. Damit die automatische Zuordnung verwendet werden kann, müssen die Namen der Formate in den FrameMaker-Dateien und dem CSS übereinstimmen. Weitere Informationen finden Sie unter Automatisch zuordnen.

Verbessertes Importieren und Verknüpfen von FrameMaker-Dokumenten
In RoboHelp 10 wurde die Import- und Verknüpfungsfunktion für FrameMaker-Dokumente in einigen Punkten verbessert:
Verbesserte Funktion zum Seitenumbruch und zur Themenbenennung für importierten oder verknüpften Inhalt
In RoboHelp 9 können Sie ein Dokument umbrechen oder, basierend auf Absatzformatvorlagen oder einem Markierungstyp, in Themen einteilen. In RoboHelp 10 können Sie eine Kombination aus Absatzformatvorlagen und Markierungstyp nutzen. Diese Verbesserung bietet mehr Möglichkeiten, Seitenumbrüche zu implementieren. Beispielsweise können Sie jetzt ein Dokument immer bei Überschrift 1 mit einigen Ausnahmen umbrechen oder Sie können ein Dokument jeweils bei Überschrift 1 und in einigen Fällen bei Überschrift 2 umbrechen. Themennamen basieren auf den im Dialogfeld für Konvertierungseinstellungen auf der Registerkarte „Andere Einstellungen“ angegebenen Themennamenmustern oder auf dem Markierungstext, der im FrameMaker-Dokument für den Markierungstyp für Seitenumbruch angegeben wurde. Weitere Informationen finden Sie unter Seitenumbruch und Themennamen festlegen.

Unterstützung für in FrameMaker generiertes Inhaltsverzeichnis und Index bei Import und Verknüpfung der FrameMaker DITA-Map
FrameMaker erstellt jetzt ein Inhaltsverzeichnis und einen Index beim Konvertieren einer DITA-Map als Buch mit FrameMaker-Komponente. Wenn Sie eine DITA-Map in ein RoboHelp-Projekt importieren oder damit verknüpfen, können Sie das von FrameMaker erstellte Inhaltsverzeichnis und den Index verwenden, um ein Inhaltsverzeichnis und einen Index zu erstellen oder sie einem bereits bestehenden Inhaltsverzeichnis bzw. Index im Projekt hinzuzufügen.

U3D-Ansichtsverknüpfungen in importiertem oder verknüpftem FrameMaker-Inhalt
Mit FrameMaker 11 können Sie Hyperlinks zu einer U3D-Ansicht erstellen. Wenn Sie FrameMaker-Inhalt importieren oder verknüpfen, funktionieren diese Hyperlinks, wenn die U3D-Ansicht und alle Objekte, die damit verknüpft sind, in einen verankerten Rahmen platziert werden. Bei der Konvertierung generiert RoboHelp eine PDF für jede U3D-Ansicht, die in einen verankerten Rahmen platziert wurde, und bettet die PDF in einen iFrame im Thema ein. Wenn bei der Konvertierung eine Verknüpfung einer U3D-Ansicht mit einem Objekt außerhalb des verankerten Rahmens erkannt wird, entfernt RoboHelp den Hyperlink.

Funktionen für Review und Zusammenarbeit

In RoboHelp 9 wurden Arbeitsabläufe eingeführt, die Autoren, SMEs und Endbenutzern die Zusammenarbeit auf unterschiedliche Weise ermöglichen. Einige dieser Arbeitsabläufe wurden in RoboHelp 10 verbessert, um bestimmten Anforderungen von RoboHelp-Benutzern gerecht zu werden.

Verbesserungen in PDF-Review
Erstellen Sie ein PDF-Dokument aus dem RoboHelp-Gesamtprojekt oder aus Projektteilen wie Themen, Masterseiten und Snippets und senden Sie es zum Review. (Die Reviewer benötigen lediglich den kostenlosen Adobe Reader, um in das PDF-Dokument Kommentare einzufügen.) Importieren Sie die Kommentare nach dem Review in das Projekt. Zeigen Sie das Feedback dann im Reviewfenster an und verwalten Sie es dort. Schritt-für-Schritt-Anweisungen finden Sie unter PDF-Review und Kommentare und Änderungen verwalten.
Auf Inhaltsverzeichnis basierender Review
Wenn Sie eine PDF für den Review erstellen, (wählen Sie „Review“ > „PDF für Review erstellen“), wird in RoboHelp die Liste von Themen im aktuellen Projekt angezeigt, sodass Sie einen Themensatz auswählen können, der in der PDF einbezogen werden soll. Standardmäßig wird die Themenliste in RoboHelp wie im Projektmanager angezeigt. Diese Standardansicht ist nicht hilfreich, wenn Sie Ausgabe basierend auf mehreren Inhaltsverzeichnissen erstellen und dafür den Themensatz aus einem Inhaltsverzeichnis auswählen müssen, den Sie in die PDF für Review einbeziehen möchten. In derartigen Situationen ist die neue Option zum Anzeigen von Dateien aus einem ausgewählten Inhaltsverzeichnis nützlich.

Mit der Option „Nicht mit den Themen verknüpfte Inhaltsverzeichniselemente ausschließen“ können Sie sicherstellen, dass die PDF, die Sie basierend auf dem ausgewählten Inhaltsverzeichnis erstellen, keine Inhaltsverzeichniselemente enthält, die mit den Optionen im Link-Menü verknüpft sind.

Themen oder Dateien nach Änderungsdatum filtern
Beim Erstellen einer PDF zum Review können Sie in RoboHelp 9 einen Themenstatus auswählen, damit RoboHelp Themen oder Dateien mit diesem Status aus dem Projekt filtern kann. In RoboHelp 10 können Sie das Datum der letzten Änderung unabhängig vom oder in Verbindung mit dem Themenstatus verwenden, um die Kriterien für die Auswahl von Themen für die PDF zum Review anzugeben.

Themen mithilfe von CBTs in der Review-PDF einbeziehen oder ausschließen
Mit RoboHelp 10 können Sie den Inhalt für die Review-PDF schnell auswählen..

Status automatisch als „Zum Review gesendet“ und „Geprüft“ einstellen
RoboHelp 10 wird mit zwei neuen Themenstatus geliefert: „Zum Review gesendet“ und „Geprüft“. Diese Status können Sie genau wie andere Status zuweisen, indem Sie die Eigenschaften des aktuellen Themas bearbeiten und den Status manuell festlegen. Sie können diese Status jedoch in den folgenden Situationen mit einem einzigen Mausklick einem Themensatz zuweisen:
  • Erstellen einer PDF zum Review

    Wenn Sie die Option „Themenstatus auf ‚Zum Review gesendet‘ einstellen“ wählen, aktualisiert RoboHelp den Status der Themen, die zum Review gesendet werden, auf „Zum Review gesendet“.

  • Importieren der Kommentare

    In RoboHelp 10 enthält der Bildschirm „Übersicht der importierten Kommentare“ eine neue Option „Status auf ‚Review erfolgt‘ aktualisieren“. Bei Auswahl dieser Option aktualisiert RoboHelp den Status aller Themen, die nach dem Review importiert werden, in „Geprüft“.

Funktionen für die Veröffentlichung

Neues MultiScreen-HTML5-SSL zum Generieren unterschiedlicher Ausgaben für unterschiedliche Geräte
RoboHelp 10 bietet ein neues MultiScreen-HTML5-SSL, mit dem Sie die Ausgabe für mehrere Geräte wie Smartphones und Tablets aus demselben Quellinhalt generieren können. Die generierte Ausgabe ist HTML5-kompatibel und kann an verschiedene Bildschirmgrößen und interaktive Funktionen auf Mobilgeräten angepasst werden. Beispielsweise können Benutzer problemlos auf allen Android-Smartphones, iPad (9.7-Zoll-Bildschirm) und Samsung Galaxy 10.1-Tablet auf Ihren Inhalt zugreifen.

Außerdem können Sie MultiScreen-HTML5 anstelle von WebHelp verwenden, um die Vorteile von HTML5 zu nutzen. Beispielsweise können Sie Desktop-Hilfe mit einem neuen rahmenlosen Aussehen generieren, Videos in hoher Qualität hinzufügen und ein browserübergreifend einheitliches Erlebnis bieten.

Videos mit den Dateiererweiterungen .mp4, .ogg, .ogv und .webm können direkt im Browser abgespielt werden und benötigen keine zusätzlichen Plugins. Wenn die native Wiedergabe von MP4-Videos in einem Browser nicht möglich ist, wird QuickTime verwendet.

Weitere Informationen finden Sie unter MultiScreen HTML5-Ausgabe generieren.

Unterstützung für Paketerstellung des Hilfeinhalts als native mobile Anwendung
Mithilfe von RoboHelp 10 können Sie ein Inhaltspaket als native mobile Anwendung erstellen. Diese Funktion ist derzeit für das mobile Android-Betriebssystem verfügbar.

RoboHelp-generierte Android-Projektdateien sind Entwicklungsversionen. Diese Dateien können Sie testen und debuggen sowie anschließend auf Benutzergeräten und/oder Google Play veröffentlichen. Weitere Informationen finden Sie unter Native mobile Anwendung erstellen.

Unterstützung für Hilfeintegration mit iOS- und Android-Anwendungen
RoboHelp bietet eine API, die Sie nutzen können, um MultiScreen-HTML5-Ausgabe in iOS- und Android-Anwendungen zu integrieren. Im Lieferumfang der API sind der Quellcode für die verfügbaren Funktionen sowie die Beispielanwendungen zur Verwendung der bereitgestellten API enthalten.
iOS-Beispielanwendung, die die Funktionen der mobilen Hilfe-API zeigt
Grafik in Originalgröße anzeigen
Android-Beispielanwendung, die die Funktionen der mobilen Hilfe-API zeigt

Diese Funktion wird für iOS Versionen 5 (und höher) und Android 2.2 (und höher) unterstützt. Sie können die folgenden Funktion über die mobile Hilfe-API nutzen:

  • Hilfe in der Anwendung einbetten

  • Hilfe in dem in der Anwendung enthaltenen Browser oder dem Standardbrowser für das mobile Betriebssystem öffnen

  • Kontextsensitive Hilfe von mobilen Anwendungsbildschirmen implementieren

  • Hilfe auf einem Server hosten und in der mobilen Anwendung verknüpfen

Weitere Informationen finden Sie unter Hilfe für iOS- und Android-Anwendungen erstellen.

Anpassbare Bildschirmprofile und Bildschirmlayouts
Die RoboHelp 10-Installation enthält Bildschirmprofile, die für Standardgeräte und einer Vielzahl von Bildschirmlayouts geeignet sind. Dadurch können Sie eine Ausgabe mit unterschiedlichem Aussehen (z. B. dem Inhaltsverzeichnis auf der rechten Seite) generieren. Sie können diese Bildschirmprofile für neue Geräte anpassen und den leistungsstarken Bildschirmlayouteditor nutzen, um die Bildschirmlayouts verschiedenartig anzupassen.

Unterstützung für Medienabfragen
Durch diese Unterstützung können Sie den Inhalt für die verschiedenen Medien oder Geräte unterschiedlich gestalten. Beispielsweise können Sie durch Medienabfragen die Bilder und Hyperlinks für gedruckten oder Onlineinhalt unterschiedlich darstellen. Weitere Informationen finden Sie unter Medienabfragen.

Neue eBook-SSL zum Generieren von ePub 3- und Kindle Book-Ausgabe
In RoboHelp 9 können Sie eine ePub 2-Ausgabe mithilfe eines Skripts generieren. In RoboHelp 10 wurde das Skript für das Generieren der ePub 2-Ausgabe verbessert, um verschiedenen Anforderungen der Benutzer gerecht zu werden. Außerdem wurde die ePub-Unterstützung erweitert und unterstützt jetzt auch die ePub 3-Ausgabe. Sie können das neue eBook-SSL konfigurieren, standardmäßige und benutzerdefinierte Metadaten bereitstellen und die Ausgabe gemäß den ePub 3-Spezifikationen generieren. Weitere Informationen finden Sie unter ePub- und Kindle Book-Ausgabe erstellen und ePub 2.0.1-Ausgabe generieren.

Generierung von nativer SharePoint(ASPX)-Ausgabe
RoboHelp 10 unterstützt die Veröffentlichung von WebHelp-, FlashHelp- und browserbasierten Hilfe-Ausgaben (Adobe AIR SSL) auf einer SharePoint-Site unter Verwendung des UNC-Pfads (Universal Naming Convention). Weitere Informationen finden Sie unter WebHelp-Ausgabe generieren, FlashHelp-Ausgabe generieren und Server zum Hosten browserbasierter Hilfe konfigurieren. Diese Ausgabe erfolgt im HTML-Format und ist nicht mit dem SharePoint-Chrom kompatibel (Navigationsverknüpfungen, Marken und Softwareoptionen, die von einer SharePoint-Masterseite kommen und auf allen SharePoint-Seiten gleich sind).

RoboHelp 10 unterstützt die Veröffentlichung der MultiScreen-HTML5-Ausgabe auf SharePoint in seinem nativen Format (ASPX), wobei die Ausgabe in SharePoint 2010 und SharePoint 2007 problemlos angezeigt wird. Bei der Anzeige der veröffentlichten Ausgabe werden die Themen im SharePoint-Chrom in Form einer einzelnen durchgehenden HTML-Seite angezeigt. Weitere Informationen finden Sie unter MultiScreen HTML5-Ausgabe generieren.

Neues Skript zum Generieren von Ausgabe mit dem neugestalteten Glossar als Popups oder Quickinfos
Wenn Sie die Ausgabe eines RoboHelp-Projekts in einem Layout, das aus einem Einzelquellenlayout-Pod ausgewählt wurde, generieren, generiert RoboHelp das Glossar als Expanding-Hotspots. RoboHelp 10 wird mit einem Skript zum Generieren von Ausgabe für ein ausgewähltes Layout geliefert, wobei das Glossar als Popups oder Quickinfos umgestaltet wurde.

Führen Sie den Glossar-Hotspot-Assistenten aus und wählen Sie „Werkzeuge“ > „Skripts“ > „Ausgabegenerator mit Glossarneugestaltung“, um dieses Skript auszuführen.

Hinweis: Führen Sie den Glossar-Hotspot-Assistenten aus und wählen Sie „Werkzeuge“ > „Skripts“ > „Ausgabegenerator mit Glossarneugestaltung“, um dieses Skript auszuführen.

Neues Skript, um die WebHelp-Ausgabe mit einer CHM-Skin zu generieren
RoboHelp 10 wird mit einem Skript zum Generieren von WebHelp-Ausgabe mit dem Erscheinungsbild von CHM-Ausgabe geliefert.

Wählen Sie „Werkzeuge“ > „Skripte“ > „Konverter für WebHelp in CHM“, um das Skript auszuführen.

Verbesserte Suche
In RoboHelp 9 wurde die Suchfunktion überarbeitet, um sie noch benutzerfreundlicher zu gestalten. Es steht eine Option zur Verfügung, mit der Sie Themen und Baggagedateien, auf die nicht verwiesen wird, aus der Ausgabe bzw. der Suche ausschließen können. Sie können die Option nutzen, um relevantere Suchergebnisse zu erhalten.

In RoboHelp 10 wurde die Suchfunktion mit weiteren Optionen verbessert:

  • Gesamtanzahl der Suchergebnisse anzeigen

  • Unterstützung für UND-Suche

  • Endbenutzer können UND-Suche konfigurieren

  • Angegebene Baggagedateitypen von Suche ausschließen

  • Unterstützung von CJK-Inhalt (Chinesisch/Japanisch/Koreanisch) in Suchabfragen

    Die WebHelp- und FlashHelp-Ausgabe in RoboHelp unterstützt eine Schlüsselwortsuche, das heißt eine Benutzerabfrage wird in einzelne Wörter aufgeteilt und anschließend werden diese Wörter im Projektinhalt gesucht. Das Aufteilen einer Suchabfrage in einzelne Wörter ist nicht einfach bei den Sprachen Chinesisch/Japanisch/Koreanisch, da bei diesen Sprachen die Wortgrenzen nicht deutlich festgelegt sind. In RoboHelp 10 wurde die Suchfunktion bei WebHelp-, FlashHelp-, AIRHelp- und browserbasierten AIRHelp-Ausgaben verbessert und erkennt CJK-Inhalt in Suchabfragen, sodass Sie optimalere Ergebnisse erhalten.

    Weitere Informationen finden Sie unter Suchen in der RoboHelp-Ausgabe.

Benutzerfreundliche und produktive Funktionen

Beispielanwendungen mit für die Veröffentlichung über mehrere Kanäle konfigurierten Layouts
Im Lieferumfang der RoboHelp 10-Installation sind die drei Beispielprojekte Global Site Consult, Salesbuilder und EmployeeCare enthalten. Anhand dieser Projekte können Sie erkennen, wie RoboHelp-Projekte für verschiedene Verwendungszwecke erstellt werden können, beispielsweise für die Verwaltung einer Wissensdatenbank. Die Layouts sind so eingerichtet, dass Sie unterschiedliche Ausgabearten generieren können. Eine Übersicht der neuen Funktionen von RoboHelp 10 finden Sie im Thema „Wissenswertes zu Adobe RoboHelp 10“.

Verknüpfte Themen über Strg+Klicken in neuen Registerkarten öffnen
Im Entwurfseditor können Sie verknüpfte Themen jetzt durch Klicken bei gedrückter Strg-Taste in neuen Registerkarten öffnen. Auf diese Weise müssen Sie nicht im Projektmanager oder in der Themenliste nach verknüpften Themen suchen und gelangen mit weniger Mausklicks zum gewünschten Thema.

Optionen zum Löschen der Formatierung und Zurücksetzen der Formatvorlagen
Durch das neue Symbol „Formatierung löschen“ in der Symbolleiste „Formatierung“ können Sie alle Inline- und CSS-Formatvorlagen aus einer Auswahl entfernen. Außerdem können Sie mit der Option „Stil zurücksetzen“ im Pod „Formatvorlagen und Formatierung“ die gesamte Formatierung, die durch eine Formatvorlage auf eine Auswahl angewendet wurde, entfernen, indem Sie einfach die Formatvorlagenkategorie auswählen. Weitere Informationen finden Sie unter Formatierung löschen und Formatvorlagen zurücksetzen.

Verbesserungen am Arbeitsbereich
In RoboHelp 10 finden Sie einige wichtige Verbesserungen im Arbeitsbereich, die eine höhere Flexibilität und Geschwindigkeit ermöglichen:
Einfacher Zugriff auf Lernressourcen über den Starter-Pod
Der Zugriff auf Lernressourcen erfolgt über den Starter-Pod. Sie können die RoboHelp-Einstellungen so konfigurieren, dass diese Informationen gegebenenfalls nicht angezeigt werden. Weitere Informationen finden Sie unter Konfigurieren allgemeiner Einstellungen.

Einfaches Hinzufügen oder Bearbeiten von Suchmetadaten
Die neue Option „Metadaten durchsuchen“ im Menü „Bearbeiten“ von RoboHelp ermöglicht den schnellen Zugriff auf Optionen zum Konfigurieren der drei Elemente für Suchmetadaten, d. h. von Synonymen, zu ignorierende Wörtern und Stoppwörtern. Mit dieser neuen Option können Sie Suchmetadaten ganzheitlich konfigurieren. Weitere Informationen finden Sie unter Suchmetadaten hinzufügen.

Einfache Bearbeitung der LNG-Datei
Über „Bearbeiten“ > „LNG-Datei“ können Sie den Inhalt der LNG-Datei anzeigen und Ihren Anforderungen entsprechend bearbeiten. Die LNG-Datei enthält Textelemente der Benutzeroberfläche für MultiScreen, WebHelp, WebHelp Pro, FlashHelp, FlashHelp Pro, AIR Help, gedruckte Dokumentation oder HTML Help-Ausgabe. Weitere Informationen finden Sie unter Projekteinstellungen ändern.

Unterstützung für Ereignisse bei Skripterstellung
In RoboHelp 9 muss ein Skript manuell aufgerufen werden; es kann nicht automatisch ausgeführt werden, wenn ein Ereignis aufgetreten ist. In RoboHelp 10 können Sie die in Skripts definierten Funktionen bei bestimmten Ereignissen ausführen. Beispielsweise können Sie die Funktion für die Erstellung der Sicherungskopie eines Projekts automatisieren, wenn ein Projekt gespeichert wird. Weitere Informationen finden Sie unter Ereignisunterstützung bei Skripterstellung.